Добро пожаловать в EMS SQL Backup!

EMS SQL Backup – это простой в использовании и одновременно мощный инструмент для создания резервных копий и восстановления БД SQL server, включающий в себя механизм быстрого развертывания и мониторинга выполнения этих действий.

Для получения дополнительной информации посетите наш сайт: http://www.sqlmanager.net/

Ключевые особенности

  • Сжатие файлов резервного копирования (на любой редакции сервера)
  • Уменьшение времени выполнения резервного копирования до 4 раз (на любой редакции сервера)
  • Шифрование файлов резервного копирования (на любой редакции сервера)
  • Поддержка облачных хранилищ (FTP (SSL), SFTP (SSH), Сетевые папки Windows (CIFS), Dropbox)
  • Простая организация процесса доставки журналов с помощью удобного мастера
  • Резервное копирование файлов и файловых групп баз данных
  • Возможность массового аварийного восстановления баз данных на сервере
  • Возможность выполнения 11 типов сервисных задач, включая резервное копирование, реиндексацию, обновление статистики и др.
  • Механизм политик для быстрого развертывания сервисных планов на множестве серверов и отслеживания состояния их выполнения
  • Централизованное наблюдение за состоянием политик на множестве серверов с помощью понятной пользователю GUI консоли
  • Многопоточное выполнение операций резервного копирования для увеличения быстродействия
  • Поддержка SQL Server Failover Cluster
  • Работа с Enterprise и BI версиями SQL Server (только PRO версия)


Новости

Версия | Дата выпуска
EMS SQL Backup 3.1 | 12.01.2022

Что нового в EMS SQL Backup 3.0?

  1. Добавлена поддержка короткоживущих токенов доступа к хранилищам Dropbox.
  2. Добавлена поддержка конвертации планов обслуживания с MSSQL Server 2019.
  3. Реализована совместимость с Windows 11.
  4. Не работало получение токена авторизации в хранилищах Google Drive. Исправлено.
  5. При создании шаблона из политики без сохранения выбора БД появлялась ошибка. Исправлена.
  6. Прекращена поддержка Windows XP и Windows 7. Минимальные требования — Windows 7 SP1 с установленным .NET Framework 4.8.


Системные требования

EMS SQL Backup Service

  • Microsoft® Windows 7 SP1, Microsoft® Windows 8, Microsoft® Windows 2012 Server, Microsoft® Windows 10, Microsoft® Windows 2016 Server;
  • SQL Server 2000, SQL Server 2005, SQL Server 2008, SQL Server 2012, SQL Server 2014, SQL Server 2016, SQL Server 2017, SQL Server 2019, Windows 11;
  • .Net Framework 4.8;
  • 1024 MB RAM или более;
  • 70MB свободного пространства на жестком диске для установки программы.

EMS SQL Backup Administration Console

  • Microsoft® Windows 7 SP1, Microsoft® Windows 8, Microsoft® Windows 2012 Server, Microsoft® Windows 10, Microsoft® Windows 2016 Server;
  • SQL Server 2000, SQL Server 2005, SQL Server 2008, SQL Server 2012, SQL Server 2014, SQL Server 2016, SQL Server 2017, SQL Server 2019, Windows 11;
  • .Net Framework 4.8;
  • 512 Mб RAM или более;
  • 120Mб свободного пространства на жестком диске для установки программы.


Сравнительная таблица характеристик

Полная сравнительная таблица характеристик различных версий программы EMS SQL Backup представлена ниже.

 | SQL Backup PRO | SQL Backup | SQL Backup Free
Сжатие файлов резервного копирования (на любой редакции сервера) | + | + | +
Поддержка шифрования файлов резервного копирования средствами сервера | + | + | +
Уменьшение времени выполнения резервного копирования до 4 раз (на любой редакции сервера) | + | + | +
Многопоточное выполнение операций резервного копирования для увеличения быстродействия | + | + | +
Резервное копирование нескольких баз данных в один файл | + | + | +
Предотвращение отказа сервисной задачи резервного копирования при отказах сети | + | + | +
Поддержка облачных хранилищ: FTP (SSL), SFTP (SSH), Сетевые папки Windows (CIFS), Dropbox | + | + | +
Возможность загрузки файлов резервных копий "на лету" в несколько облачных хранилищ одновременно | + | + | +
Восстановление соединения при обрыве в процессе загрузки в облачные хранилища | + | + | +
Возможность выполнения 11 типов сервисных задач, включая резервное копирование, реиндексацию, обновление статистики и др. | + | + | +
Возможность доставки файлов резервного копирования с серверов и облачных хранилищ | + | + | +
Утилита преобразования файлов резервного копирования из формата SQL Backup в формат SQL Server | + | + | +
Неограниченное число удаленных и локальных хранилищ для каждой резервной копии | + | + | +
Интеллектуальное восстановление. Восстановление по истории на указанную дату с автоматическим построением последовательностей файлов с учетом серверных номеров LSN | + | + | +
Подбор последовательностей файлов восстановления с возможностью поиска и скачивания файлов с облачных/сетевых хранилищ | + | + | +
Механизм политик для быстрого развертывания сервисных планов на множестве серверов и отслеживания состояния их выполнения | + | + | +
Набор стандартных шаблонов типовых политик обслуживания серверных систем | + | + | +
Централизованное наблюдение за состоянием политик на множестве серверов с помощью понятной пользователю GUI консоли | + | + | +
Возможность удаленной установки серверных компонентов | + | + | +
Собственный механизм электронных уведомлений о результатах выполнения задач | + | + | +
Создание отчетов о результатах выполнения сервисных задач | + | + | +
Экспорт истории выполнения сервисных задач во внешний файл | + | + | +
Резервное копирование файлов и файловых групп баз данных | + | + | +
Возможность массового аварийного восстановления баз данных на сервере | + | + | +
Количество обслуживаемых баз на один экземпляр SQL Server | Не ограничено | Не ограничено | 2 БД
Возможность доставки баз данных между SQL серверами по расписанию | + | + | – *
Поддержка облачных хранилищ: Google Drive | + | + | –
Несколько уровней сжатия для достижения оптимального баланса между размером резервного копирования и времени выполнения | + | – | –
Шифрование файлов резервного копирования (на любой редакции сервера) | + | – | –
Поддержка облачных хранилищ: Amazon S3, Microsoft Azure | + | – | –
Поддержка SQL Server Failover Cluster | + | – | –
Простая организация процесса доставки журналов с помощью удобного мастера | + | – | –
Работа с Enterprise и BI версиями SQL Server | + | – | –

* - экземпляр SQL Server с Free лицензией может быть выбран в качестве исходного сервера, но не может быть выбран в качестве целевого.


Установка

Установка программы EMS SQL Backup

  • загрузите полный дистрибутив программы со страницы загрузки,
  • полученный файл извлеките из архива в нужную директорию (например, c:\unzipped),
  • откройте файл SQLBackupSetup-x.x.xx.xxxx.msi и следуйте инструкциям мастера установки.

Существует два режима установки EMS SQL Backup Console: Typical и Custom. При выборе типа установки Custom Вы можете выбрать директорию установки, а также указать, следует ли копировать файл документации по EMS SQL Backup в папку программы.

После завершения процесса установки найдите ярлык программы в Пуск->Программы->EMS.

Важно: Для начала работы обязательно необходимо зарегистрировать сервер и установить серверные компоненты на сервере (серверную часть).

Обновление программы

  • загрузите полный дистрибутив со страницы загрузки сайта,
  • закройте программу EMS SQL Backup, если она запущена,
  • повторите процедуру установки,
  • запустите программу, используя кнопки в Пуск->Программы->EMS.

Важно

Существует режим установки серверных компонентов на локальные сервера без установки консоли EMS SQL Backup.

Такой тип установки следует использовать в случае, когда удаленная установка серверных компонентов из консоли SQL Backup невозможна по какой-то причине, но есть возможность скопировать и перенести дистрибутив программы на сервер и запустить его там.

Чтобы запустить установку серверных компонентов с помощью мастера установки серверных компонентов, необходимо на третьем шаге мастера установки EMS SQL Backup выбрать режим Server-side only.

Смотрите также:

Часто задаваемые вопросы


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Digital River. Процедура совершения покупки через Share-it! защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернете и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией share-it!.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery). Сделав заказ, Вы сможете немедленно скачать регистрационные ключи или пароли и ссылки на архивы полных версий программ. Также Вы получите копию регистрационных ключей или паролей по электронной почте.

Если при оформлении Вы не получили регистрационный ключ в течение двух часов, обратитесь в службу поддержки по этому адресу sales@sqlmanager.net.

Если Вы являетесь зарегистрированным пользователем, то при возникновении проблем или вопросов при использовании нашего программного обеспечения обращайтесь в службу поддержки.

Важно: Лицензия приобретается на каждый экземпляр сервера, а не на программу EMS SQL Backup Console.

Описание продукта | Share It!
EMS SQL Backup (Business Regular license) + 1 год Сопровождения | Купить!
EMS SQL Backup (Business Regular license) + 2 года Сопровождения
EMS SQL Backup (Business Regular license) + 3 года Сопровождения
EMS SQL Backup (Business Pro license) + 1 год Сопровождения
EMS SQL Backup (Business Pro license) + 2 года Сопровождения
EMS SQL Backup (Business Pro license) + 3 года Сопровождения
EMS SQL Backup (Non-commercial Regular license) + 1 год Сопровождения
EMS SQL Backup (Non-commercial Regular license) + 2 года Сопровождения
EMS SQL Backup (Non-commercial Regular license) + 3 года Сопровождения
EMS SQL Backup (Non-commercial Pro license) + 1 год Сопровождения
EMS SQL Backup (Non-commercial Pro license) + 2 года Сопровождения
EMS SQL Backup (Non-commercial Pro license) + 3 года Сопровождения
EMS SQL Backup (Trial/Free version) | Загрузить!

*Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Подробнее об услуге сопровождения читайте на странице http://sqlmanager.net/ru/support/faq/maintenance

Смотрите также:

Регистрация


Регистрация

Регистрация EMS SQL Backup не означает непосредственную регистрацию программы EMS SQL Backup Console. Регистрация складывается из покупки и дальнейшей активации полученных Лицензионных Ключей для каждого экземпляра сервера, с которым Вы хотите работать.

Установив клиентскую и серверную часть EMS SQL Backup, нужно произвести активацию серверной части EMS SQL Backup. Для получения активационного кода сделайте следующее:

  1. Запустите EMS SQL Backup.
  2. Установите соединение с SQL Server.
  3. Выберите сервер в Проводнике, кликните по нему правой кнопкой мыши и выберите пункт Activate license.
  4. Следуйте указаниям Мастера.

Чтобы удалить лицензию с экземпляра сервера, используйте Мастер деактивации лицензии. После этого Вы сможете активировать этот лицензионный ключ на другом сервере.

Активация лицензии

Деактивация лицензии

Смотрите также:

Приобретение


Активация лицензии

Для того чтобы начать работу с серверами, необходимо активировать EMS SQL Backup License для каждого экземпляра сервера.

Предполагается, что Вы уже приобрели лицензию на продукт, и что у Вас есть лицензионная информация. Если Вы не можете найти информацию о лицензии, пожалуйста, посетите Вашу учетную запись пользователя - Личный кабинет https://secure.sqlmanager.net/member/subscribe.

Для работы с Enterprise и BI версиями SQL Server вам необходимо активировать лицензию EMS SQL Backup PRO.

Чтобы активировать приобретенный лицензионный ключ, необходимо выполнить следующие действия:

  1. Выберите пункт Activate license контекстного меню сервера, чтобы запустить Мастер Активации Лицензии.
  2. Выберите предпочтительный способ активации лицензии и закончите выполнение всех шагов Мастера.
  3. Убедитесь, что активация прошла успешно - в окне Overall status в строке License должна отобразиться информация о лицензии, и на сайте в разделе Личный кабинет статус ключа должен смениться на Active.

Список шагов

Выбор типа активации

Ввод лицензионного ключа

Активация через сайт

Настройка параметров подключения

Выполнение онлайн активации

Ввод кода активации

Завершение операции

Смотрите также:

Приобретение

Деактивация лицензии


Выбор способа активации

На этом шаге необходимо выбрать способ активации лицензии EMS SQL Backup.

License activation_Select activation type

RadioButton Activate EMS SQL Backup License online

Выберите этот тип активации при наличии доступа в Интернет. Лицензия продукта будет активирована автоматически в течение нескольких секунд.

Важно: Если на выбранном SQL сервере уже есть активированная лицензия, то она будет деактивирована при активации нового ключа.

RadioButton Activate EMS SQL Backup License through our website

Выбрав этот способ, Вы можете зарегистрировать продукт непосредственно через аккуант на сайте sqlmanager.net.

Этот способ активации недоступен, если на выбранном SQL сервере уже активирована лицензия.

RadioButton Renew maintenance manually

Эта опция может быть использована для продления периода Сопровождения, если у Вас уже есть код активации.

Важно: Лицензия Free может быть активирована только online способом.

Следующий шаг если был выбран Activate License online.

Следующий шаг если был выбран Activate License through our website.

Следующий шаг если был выбран Enter existing license activation code manually.


Ввод лицензионного ключа

На этом шаге необходимо задать настройки регистрации при активации Online.

License activation_Enter the key_online_email

SQL Server Instance ID

Идентификационный номер регистрируемого экземпляра сервера генерируется автоматически в этом поле.

RadioButton Activate license key

В это поле необходимо скопировать или ввести вручную лицензионный ключ.

Ключ может быть взят из Личного кабинета или получен по электронной почте после покупки лицензии.

RadioButton Activate Free license

Выберите эту опцию, что бы активировать лицензию SQL Backup Free.

Отличия между версиями EMS SQL Backup наглядно приведены в Сравнительной таблице характеристик.

Следующий шаг


Manual

SQL Backup
  • Index
  • « Prev
  • Next »

Активация через сайт

Это шаг появляется, если на первом шаге был выбран тип активации RadioButton Activate EMS SQL Backup License through our website.

License activation_Enter the key_website

Для выполнения такого типа активации необходимо:

  1. Зарегистрироваться на сайте в разделе Личный кабинет https://secure.sqlmanager.net/login.
  2. Перейти в раздел My Registered Products.
  3. Раскрыть список ключей для необходимого продукта.
  4. Выбрать действие Activate License.
  5. На веб странице в открывшемся окне введите в соответствующее поле идентификационный номер регистрируемого экземпляра сервера, который был автоматически сгенерирован в поле SQL Server instance ID. Скопировать идентификационный номер в буфер обмена можно, нажав кнопку Copy to clipboard.
  6. Скопируйте сгенерированный код активации.
  7. На следующем шаге вставьте скопированный код в поле License Activation Code.
  8. Нажмите кнопку Finish, чтобы завершить процесс активации лицензии.

Следующий шаг


Ввод кода активации

Код активации, скопированный с сайта, необходимо ввести в поле License Activation Code.

License activation - Enter the license key

Следующий шаг


Выполнение онлайн активации

Этот шаг отображается, если на первом шаге был выбран тип активации RadioButton Activate EMS SQL Backup License online.

License activation - License activation process

Настройки подключения для выполнения онлайн активации задаются на вкладке Proxy диалога Options.

После завершения Вы автоматически перейдете на следующий шаг.

Если при деактивации предыдущего ключа возникли проблемы, то будет показан шаг Деактивации лицензии через сайт.


Завершение операции

На заключительном шаге ознакомьтесь с результатом выполнения активации.

License activation - Performing operation

Нажмите кнопку Finish для завершения выполнения операции.


License deactivation

SQL Backup
  • Index
  • « Prev
  • Next »

Деактивация лицензии

Деактивация лицензии необходима в случае, если Вы хотите перенести лицензию с одного экземпляра сервера на другой. В этом случае Вам сначала необходимо деактивировать лицензионный ключ, а затем активировать его на другом экземпляре сервера.

После выполнения шагов Мастера Ваш лицензионный ключ будет деактивирован, и служба EMS SQL Backup перестанет работать на данном экземпляре SQL Server. После завершения выполнения всех шагов Мастера EMS получит уведомление о деактивации, и Вы сможете активировать лицензионный ключ на другом сервере.

Чтобы деактивировать лицензионный ключ, необходимо выполнить следующие действия:

  1. Выберите пункт Deactivate license контекстного меню сервера, чтобы запустить Мастер Деактивации Лицензии.
  2. Выберите предпочтительный способ деактивации лицензии и закончите выполнение всех шагов Мастера.
  3. Убедитесь, что деактивация прошла успешно - в окне Overall status в строке License не должна отображаться информация о лицензии, и на сайте в разделе Личный кабинет статус ключа должен смениться на Inactive.

Список шагов:

Выбор способа деактивации

Деактивация через сайт

Выполнение онлайн деактивации

Завершение операции

Смотрите также:

Приобретение

Активация лицензии


Licence deactivation

SQL Backup
  • Index
  • « Prev
  • Next »

Выбор способа деактивации

На этом шаге необходимо выбрать способ деактивации лицензии EMS SQL Backup.

License deactivation - Select the deactivation method

RadioButton Deactivate EMS SQL Backup License online

Выберите этот тип деактивации при наличии доступа в Интернет. Лицензия продукта будет деактивирована автоматически в течение нескольких секунд.

RadioButton Deactivate EMS SQL Backup License through our website

Выбрав этот способ, Вы можете деактивировать лицензию продукта непосредственно через аккуант на сайте sqlmanager.net

Чтобы перейти на следующий шаг Мастера, поставьте флажок CheckBox I understand that License Key will be deactivated now. При переходе на следующий шаг лицензия будет деактивирована локально. Локальная деактивация означает, что лицензия будет деактивирована для экземпляра SQL Server только в программе, но Вы не сможете активировать этот лицензионный ключ для другого экземпляра.

Важно: Для полной успешной деактивации необходимо закончить выполнение всех шагов Мастера.

Следующий шаг если был выбран Deactivate License online.

Следующий шаг если был выбран Deactivate License through our website.


Деактивация через сайт

Этот шаг появляется, если на первом шаге был выбран тип активации RadioButton Deactivate EMS SQL Backup License through our website.

License deactivation - Website deactivation

Для выполнения такого типа деактивации необходимо:

  1. Зарегистрироваться на сайте в разделе Личный кабинет https://secure.sqlmanager.net/login.
  2. Перейти в раздел My Registered Products.
  3. Раскрыть список ключей для необходимого продукта.
  4. Выбрать действие Deactivate License.
  5. В открывшееся окно вставьте код деактивации. Скопировать код деактивации в буфер обмена можно нажав кнопку Copy.
  6. После вставки нажмите кнопку Deactivate.
  7. Нажмите кнопку Finish Мастера, чтобы завершить процесс деактивации лицензии.


Licence deactivation

SQL Backup
  • Index
  • « Prev
  • Next »

Выполнение онлайн деактивации

Этот шаг отображается, если на первом шаге был выбран тип активации RadioButton Deactivate EMS SQL Backup License online.

На этом шаге осуществляется процесс деактивации лицензии онлайн.

License deactivation - Deactivation process

Настройки подключения для выполнения онлайн деактивации задаются на вкладке Proxy диалога Options.

После завершения Вы автоматически перейдете на следующий шаг.


Завершение операции

На заключительном шаге ознакомьтесь с результатом выполнения онлайн деактивации.

License deactivation - Summary

Нажмите кнопку Finish для завершения выполнения операции.


Менеджер лицензий

С помощью диалога License Manager Вы можете просматривать информацию о лицензиях на всех серверах, зарегистрированных в EMS SQL Backup, на которых установлены серверных компоненты. Этот инструмент позволяет автоматически активировать лицензионные ключи, для которых был продлен период Сопровождения, на всех экземплярах серверов одновременно.

Чтобы открыть Менеджер лицензий, выберите пункт License Manager в меню шестеренок.

В списке отображаются все сервера, к которым установлено подключение. Чтобы отобразить все сервера, зарегистрированные в консоли EMS SQL Backup, нажмите кнопку Show All.

В Менеджере лицензий отображается следующая информация для каждого сервера:

  • Instance name - имя экземпляра сервера,
  • License key - лицензионный ключ,
  • License type - тип лицензионного ключа,
  • Customer name - имя покупателя,
  • Maintenance end date - дата окончания периода Сопровождения.

Перед тем как обновить информацию о лицензионном ключе на консоли, Вам необходимо Продлить подписку на него в Личном кабинете.

Чтобы автоматически обновить информацию о периоде Сопровождения для всех лицензий в списке, нажмите кнопку Reactivate All. Обновление лицензии происходит в режиме он-лайн. Настройки подключения для выполнения онлайн активации задаются на вкладке Proxy диалога Options.

Чтобы обновить лицензионный ключ на одном экземпляре сервера, нажмите кнопку Reactivate у соответствующего экземпляра сервера.

Если обновление информации прошло успешно, Вы увидите сообщение, информирующее о дате выполнения активации лицензии. В противном случае, появится информация о возникшей в ходе обновления ошибке.

Для каждого сервера Вы можете запустить визард Активации лицензии или визард Деактивации лицензии нажатием на кнопки Activate/Deactivate соответственно.


Предыдущие версии

Версия | Дата выпуска
EMS SQL Backup 3.0 | 16.05.2018
EMS SQL Backup 2.2.1 | 08.05.2017
EMS SQL Backup 2.2 | 03.04.2017
EMS SQL Backup 2.1.1 | 30.01.2017
EMS SQL Backup 2.1 | 29.08.2016
EMS SQL Backup 2.0.1 | 13.04.2016
EMS SQL Backup 2.0 | 11.02.2016
EMS SQL Backup 1.8 | 16.06.2015
EMS SQL Backup 1.7 | 27.02.2015
EMS SQL Backup 1.6 | 28.11.2014
EMS SQL Backup 1.5 | 07.07.2014
SQL Angel 1.4 | 25.02.2014
SQL Angel 1.3 | 07.11.2013
SQL Angel 1.2 | 10.06.2013
SQL Angel 1.1 | 01.04.2013
SQL Angel 1.0 | 12.12.2012

Версия 3.0

  1. Введено условное выполнение шагов в задачах обслуживания.
  2. Улучшен редактор задач обслуживания.
  3. Доступно конвертирование планов обслуживания для SSIS 2012-2017.
  4. Исправлены ошибки в редакторе выборки баз и объектов баз данных.
  5. Исправлены ошибки в установщике серверных компонентов.
  6. Улучшения в отслеживании активных задач.
  7. Множество других исправлений и улучшений.

Версия 2.2.1

  1. Статусы задач, запускающихся в одно время, могли отображаться неверно. Исправлено.
  2. Maintenance Cleanup. Не всегда корректно удалялись файлы с Google Drive, если в директории было более 100 файлов. Исправлено.
  3. Restore. При обзоре файлов в облачных хранилищах в случае Google Drive отображались не все файлы. Исправлено.
  4. Изредка при обновлении логов появлялась ошибка "The conversion could not be completed because the supplied DateTime did not have the Kind property set correctly". Исправлено.

Версия 2.2

  1. Возможность создания резервных копий файлов и файловых групп.
  2. Поддержка восстановления отдельных файлов и файловых групп из резервных копий.
  3. Bulk restore: массовое восстановление резервных копий баз данных сервера с возможностью планировать эту операцию.
  4. Поддержка резервных копий формата SQL Server, состоящих из нескольких файлов (многодорожечных).
  5. Возможность сокращения текста уведомления, присылаемого по e-mail, до статуса выполненной задачи.
  6. Очистка истории резервного копирования для базы данных при ее удалении.
  7. Возможность удаления файлов резервных копий, загруженных из удаленных хранилищ, после операции восстановления.
  8. При настройке уведомлений по e-mail тестирование соединения с сервером теперь сопровождается логом SMTP-подключения.
  9. Множество небольших изменений и исправлений, повышающих удобство использования и стабильность продукта.

Версия 2.1.1

  10. Оптимизация операции очистки директорий резервных копий и отчетов (Maintenance Cleanup).

2. Исправлена ошибка обновления до версии 2.1 через автономную программу установки.

3. Обрезались имена файлов резервных копий. Исправлено.

4. При загрузке файлов резервных копий в директории высокой вложенности FTP иногда появлялась ошибка. Исправлено.

5. Программа не могла получить состояние серверных компонентов при изменении конфигурации системы. Исправлено.

6. При выполнении разностных резервных копий с разбиением по БД иногда происходила ошибка 'There is already an open DataReader associated with this Command which must be closed first'. Исправлено.

7. При выполнении резервных копий с загрузкой в облачные хранилища иногда происходила ошибка 'Specified argument was out of the range of valid values'. Исправлено.

8. Другие улучшения и исправления.

Версия 2.1

  1. Существенно увеличена скорость создания резервных копий и загрузки их в облачные хранилища за счет загрузки "на лету" одновременно в несколько сетевых хранилищ.
  2. Поддержка SQL Server Failover Cluster.
  3. Поддержка прокси для подключения к облачному хранилищу Azure.
  4. Возможность поиска сразу нескольких файлов резервных копий в облачных хранилищах.
  5. Возможность задания параметров авторизации для сетевой директории в Log/Database Shipping.
  6. Добавлена проверка возможных разрывов цепочки восстановления в процессе создания резервной копии для обнаружения резервных копий, выполняемых сторонними программами, во избежание усложнения процесса восстановления в будущем.
  7. Множество других исправлений и улучшений.

Версия 2.0.1

  1. После обновления версии 1.7 на версию 2.0 возникала ошибка 'The time zone ID '' was not found on the local computer'. Исправлено.
  2. Исправлена ошибка применения привилегий при подключении NetBIOS/CIFS для машин, находящихся в рабочей группе.
  3. Исправлены ошибки назначения прав при локальной установке серверных компонентов на некоторые системы.
  4. Исправлена ошибка определения разрядности при локальной установке серверных компонентов на некоторые системы.
  5. При переходе на летнее/зимнее время возникала ошибка 'The supplied DateTime represents an invalid time', если сервер и консоль находились в разных часовых поясах.
  6. Множество других исправлений.

Версия 2.0

  1. Добавлена возможность восстанавливать базы данных из облачных/сетевых хранилищ.
  2. Добавлена возможность не хранить файлы бэкапов локально и использовать для их хранения только облачные/сетевые хранилища.
  3. Добавлена возможность удалять старые или неактуальные файлы бэкапов из облачных/сетевых хранилищ.
  4. Добавлена возможность делать бэкап заключительного фрагмента журнала перед восстановлением БД.
  5. Добавлены операции Cut, Copy, Paste для редактора политики.
  6. Множество других улучшений и исправлений.

Версия 1.8

  1. Добавлена возможность восстанавливать базы данных из облачных/сетевых хранилищ.
  2. Добавлена возможность не хранить файлы бэкапов локально и использовать для их хранения только облачные/сетевые хранилища.
  3. Добавлена возможность удалять старые или неактуальные файлы бэкапов из облачных/сетевых хранилищ.
  4. Добавлена возможность делать бэкап заключительного фрагмента журнала перед восстановлением БД.
  5. Добавлены операции Cut, Copy, Paste для редактора политики.
  6. Множество других улучшений и исправлений.

Версия 1.7

  1. Доступна бесплатная версия. Количество обслуживаемых баз для кажого экземпляра SQL Server ограничено двумя.
  2. Добавлена возможность копирования бэкапов с сервера на машину, на которой запущена консоль SQL Backup.
  3. Добавлена возможность загружать бэкапы вхранилище Microsoft Azure.
  4. Добавлена возможность делать перезапись файлов бэкапа при копировании в сетевые директории.
  5. Стало возможным перемещать/переименовывать папку с бэкапами. Перемещенные файлы бэкапов теперь находятся автоматически.
  6. Снято ошибочное ограничение при выборе БД шага 'Database Shipping'.
  7. Множество других улучшений и исправлений.

Версия 1.6

  1. Реализована возможность смены часового пояса в EMS SQL Backup Administration Console.
  2. Улучшен учет перехода на летнее время при планировании политик.
  3. Добавлена возможность задания HTTP прокси для загрузки файлов резервных копий по протоколу FTP.
  4. Улучшена работа мастеров активации и деактивации лицензии.
  5. Другие исправления и улучшения.

Версия 1.5

  1. Встроенный пларировщик (Built-In Scheduler) для выполнения политик на серверах без SQL Server Agent, например, SQL Server Express. Возможность использовать SQL Server Agent сохранена.
  2. Улучшена и упрощена удаленная и локальная установка серверных компонентов:
  • Сохранение используемых параметров удаленной установки.
  • Множество подсказок, поясняющих сообщений и проверок в момент задания параметров.
  • Возможность удаленной установки через произвольную сетевую папку в случае отсутствия ADMIN$.
  • Возможность задания порта для экземпляра сервера.
  3. Пересылка БД: возможность пересылки полного бэкапа БД с одного экземпляра сервера на другой по расписанию.
  4. Более подробный лог для Tasks и Steps. Теперь в логе отображаются исходные данные.
  5. Улучшена поддержка SQL Server 2014.
  6. Счетчик ознакомительного периода работал некорректно в некоторых случаях. Исправлено.
  7. Исправлены ошибки декомпрессии файлов в некоторых конфигурациях.
  8. В некоторых случаях не происходило усечение файлов логов EMS SQL Backup. Исправлено.
  9. Множество других улучшений и исправлений.

Версия 1.4

  1. Продукт переименован в EMS SQL Backup.
  2. Удобное средство управления регистрационными ключами - License Manager.
  3. Возможность множественного обновления компонентов на стороне сервера.
  4. Консоль больше не требует прав администратора для запуска.
  5. Исправлены ошибки в планировщике.
  6. Исправлены ошибки локализации дат.
  7. Исправлены утечки памяти.
  8. Множество других исправлений и улучшений.

Версия 1.3

  1. Поддержка удаленных хранилищ для пересылки и хранения резервных копий.
  • Сетевые папки (Network folder), Сетевые хранилища (NAS).
  • Загрузка по протоколам FTP(ImplicitSSL/ExplicitSSL), SFTP (SSH).
  • Поддержка облачного хранилища Amazon S3.
  2. Возможность выбора неограниченного количества удаленных и локальных хранилищ для каждой резервной копии.
  3. Поддержка опции 'Check orphaned users' для восстановления резервных копий.
  4. Новые макросы для папки с резервными копиями: {backup_root_folder}, {server}.
  5. Улучшены производительность и отображение логов.
  6. Улучшенный внешний вид.

Версия 1.2

  • Добавлена возможность проверки целостности результирующих файлов после процесса резервного копирования (RESTORE VERIFYONLY & CHECKSUM).
  • Отображение прогресса для длительных процессов.
  • Контроль увеличения размера журналов (ограничение размера журнала по дате и размеру).
  • Отображение размера БД.
  • Улучшен вид главной формы.
  • Другие исправления и улучшения.

Версия 1.1

  • Добавлена поддержка одновременных резервных копий на одном сервере.
  • Добавлена поддержка резервных копий, не влияющих на их последовательность (copy-only).
  • Оповещения об обновлениях программы.
  • Улучшена конвертация политики в шаблон.
  • Новые возможности управления шаблонами.
  • Множество улучшений интерфейса.
  • Исправлены утечки памяти для серверных компонентов.
  • Улучшена стабильность подключений для серверной части и консоли.
  • Улучшено управление логами на серверной части.
  • При обрыве соединения с сервером возникала ошибка записи конфигурации. Исправлено.
  • Другие незначительные исправления и улучшения.

Версия 1.0 (Первый официальный выпуск)

Главные характеристики:

  • Сжатие файлов резервного копирования до 5 раз (на любой редакции сервера).
  • Уменьшение времени выполнения резервного копирования до 4 раз (на любой редакции сервера).
  • Шифрование файлов резервного копирования (на любой редакции сервера).
  • Простая организация процесса доставки журналов с помощью удобного мастера.
  • Возможность выполнения 8 типов сервисных задач, включая резервное копирование, доставку журналов, реиндексацию, обновление статистики и др.
  • Механизм политик для быстрого развертывания сервисных планов на множестве серверов и отслеживания состояния их выполнения.
  • Централизованное наблюдение за состоянием политик на множестве серверов с помощью понятной пользователю GUI консоли.
  • Многопоточное выполнение операций резервного копирования для увеличения быстродействия.
  • Работа с Enterprise и BI версиями SQL сервера.

и другие...

Наверх

Смотрите также:

Новости


Часто задаваемые вопросы

Пожалуйста, прочитайте внимательно эту страницу, если у Вас есть вопросы о EMS SQL Backup.

Вопросы

  • С какими версиями SQL Server работает EMS SQL Backup?
  • EMS SQL Backup необходимо устанавливать на каждом сервере, с которым я хочу работать?
  • Сколько лицензий EMS SQL Backup мне необходимо приобрести, если у меня 5 серверов, на 2-х из которых работает по два экземпляра SQL Server?
  • Как перенести лицензию с одного экземпляра SQL Server на другой?
  • За счет чего EMS SQL Backup уменьшает размер файлов резервного копирования?
  • Зависит ли функция сжатия файлов резервного копирования от версии или редакции SQL Server?
  • На сколько уменьшается размер файла резервного копирования и от чего это зависит?
  • Можно ли восстановить файл резервного копирования EMS SQL Backup на SQL Server, где нет установленных компонентов EMS SQL Backup?
  • С чем связано уменьшение времени, требуемого для выполнения резервного копирования и восстановления?
  • EMS SQL Backup использует недокументированные возможности SQL Server?
  • EMS SQL Backup может выполнить стандартное резервное копирование, пригодное для восстановления на SQL Server без использования EMS SQL Backup?
  • EMS SQL Backup поддерживает доставку журналов?
  • У меня есть сервера в разных часовых поясах. По какому времени будут происходить запуски задач на них?
  • В чем преимущество использования механизма политик EMS SQL Backup по сравнению со стандартными планами обслуживания SQL Server?
  • Могут ли в одной политике участвовать сервисные задачи разных типов?
  • Могут ли задачи в политике иметь собственные расписания выполнения?
  • Может ли EMS SQL Backup выполнить однократную сервисную задачу без создания политики?
  • Может ли на одном сервере одновременно выполняться несколько политик?
  • У меня есть настроенные планы обслуживания SQL Server. Могу я их использовать в EMS SQL Backup?
  • Каким образом EMS SQL Backup уведомит меня в случае сбоя в выполнении политики?
  • Могу я выполнять наблюдение/управление за своей группой серверов с помощью двух (трех) разных (установленных на разных компьютерах) консолей?
  • Серверы, с которыми работает EMS SQL Backup, должны находиться в пределах одной локальной сети?
  • Необходимо ли открывать дополнительно какие-либо порты или разрешать протоколы для работы EMS SQL Backup?
  • Можно ли установить серверные компоненты EMS SQL Backup удаленно?
  • Мне не удается установить серверные компоненты удаленно через EMS SQL Backup из-за ограничения прав или ошибки установки. Могу ли я установить компоненты, запустив установку на серверной машине?
  • Под каким аккаунтом рекомендуется запускать сервис EMS SQL Backup?
  • Выполнение политики завершается неудачей с ошибкой: "Не удалось завершить задание. Владелец (NT AUTHORITY\SYSTEM) задания SqlBackup_XXXXXXXX_Task не имеет доступа к серверу". Почему это происходит?
  • Какие отличия между различными версиями EMS SQL Backup?
  • Я могу не платить за обслуживание программы?
  • При установке серверных компонентов EMS SQL Backup через сетевую директорию я получаю ошибку "Access is Denied". Как можно исправить проблему?

Ответы

В: С какими версиями SQL Server работает EMS SQL Backup?

О: EMS SQL Backup работает со всеми редакциями SQL Server (за исключением Compact Edition), начиная с SQL Server 2000 по SQL Server 2014.

В: EMS SQL Backup необходимо устанавливать на каждом сервере, с которым я хочу работать?

О: Да, серверные компоненты EMS SQL Backup необходимо устанавливать на каждом экземпляре SQL Server.

В: Сколько лицензий EMS SQL Backup мне необходимо приобрести, если у меня 5 серверов, на 2-х из которых работает по два экземпляра SQL Server?

О: У Вас всего 7 экземпляров SQL сервера, поэтому Вам необходимо приобрести 7 лицензий EMS SQL Backup.

В: Как перенести лицензию с одного экземпляра SQL Server на другой?

О: Для того, чтобы перенести лицензию с одного сервера на другой, выполните следующее.

  1. В EMS SQL Backup Administration Console выберите сервер, с которого Вы хотите перенести лицензию.
  2. В контекстном меню сервера выберите пункт "Deactivate license on ...".
  3. Следуйте указаниям мастера License Deactivation Wizard.
  4. Выберите сервер, на котором Вы хотите активировать деактивированный лицензионный ключ.
  5. В контекстном меню сервера выберите пункт "Activate license on ...".
  6. Следуйте указаниям мастера License Activation Wizard.

В: За счет чего EMS SQL Backup уменьшает размер файлов резервного копирования?

О: Это достигается за счет сжатия данных, получаемых от сервера в процессе резервного копирования.

В: Зависит ли функция сжатия файлов резервного копирования от версии или редакции SQL Server?

О: EMS SQL Backup использует собственную функцию сжатия данных, возможность использования которой не зависит от редакции и версии SQL Server.

В: На сколько уменьшается размер файла резервного копирования и от чего это зависит?

О: Это зависит от данных, хранящихся в базе и от выбранного в EMS SQL Backup уровня сжатия. В случае текстовых\числовых данных размер файла резервного копирования, при использовании сжатия, может быть меньше до 80% по сравнению со случаем, когда сжатие отключено. Если в базе хранятся в основном бинарные данные, которые плохо поддаются сжатию, например растровые изображения в формате JPEG, то использование функции сжатия не сможет существенно уменьшить размер файла резервного копирования.

В: Можно ли восстановить файл резервного копирования EMS SQL Backup на SQL Server, где нет установленных компонентов EMS SQL Backup?

О: Непосредственно это сделать нельзя. Однако Вы можете использовать утилиту командной строки ConvertUtil.exe, которая не нуждается в установке и регистрации для преобразования файлов резервного копирования в формате SQL Backup в стандартный формат SQL Server. После преобразования резервное копирование может быть восстановлено стандартными средствами SQL Server.

В: С чем связано уменьшение времени, требуемого для выполнения резервного копирования и восстановления?

О: Подбор уровня сжатия позволяет найти компромисс между скоростью резервного копирования и размером файла. При этом экономия времени выполнения резервного копирования может достигать до 80% по сравнению с нативным инструментом за счет меньшей нагрузки на дисковую подсистему.

В: EMS SQL Backup использует недокументированные возможности SQL Server?

О: EMS SQL Backup использует лишь документированные особенности SQL Server, что гарантирует его корректную работу на всех существующих версиях SQL Server, а также на новых версиях, которые могут появиться в будущем.

В: EMS SQL Backup может выполнить стандартное резервное копирование, пригодное для восстановления на SQL Server без использования EMS SQL Backup?

О: Да, EMS SQL Backup на это способен. Для этого в мастере резервного копирования нужно выбрать SQL Server в качестве типа резервного копирования.

В: EMS SQL Backup поддерживает доставку журналов?

О: EMS SQL Backup позволяет осуществлять доставку журналов, используя свои особенности сжатия и шифрования, что делает эту процедуру более быстрой и безопасной.

В: У меня есть сервера в разных часовых поясах. По какому времени будут происходить запуски задач на них?

О: При создании политики можно выбрать будет ли задача на серверах с разными часовыми поясами запускаться по поясному времени на серверах или одновременно относительно времени консоли. Это опция называется «Task Scheduling in different time zones» и находится на шаге 1 в мастере создания политик.

В: В чем преимущество использования механизма политик EMS SQL Backup по сравнению со стандартными планами обслуживания SQL Server?

О: Механизм политик EMS SQL Backup обеспечивает следующие возможности:

  • Использование функционала резервного копирования EMS SQL Backup
  • Возможность развертывания и последующего контроля политики на нескольких серверах разных версий одновременно
  • Удобный механизм контроля за работой политик
  • Возможность использования шаблонов

В: Могут ли в одной политике участвовать сервисные задачи разных типов?

О: Политика может содержать как несколько задач разных типов, так и несколько задач одного типа.

В: Могут ли задачи в политике иметь собственные расписания выполнения?

О: Да, каждая задача может иметь одно или несколько расписаний.

В: Может ли EMS SQL Backup выполнить однократную сервисную задачу без создания политики?

О: Да может. Выполнить сервисную задачу можно через пункт контекстного меню «Quick Maintenance Actions» дерева Servers.

В: Может ли на одном сервере одновременно выполняться несколько политик?

О: Несколько политик могут быть развернуты на одном сервере, время их запуска может быть одинаково и время выполнения может пересекаться, за исключением случая 2-х задач резервного копирования/восстановления/доставки журналов, которые не могут выполняться одновременно на одном экземпляре SQL Server.

В: У меня есть настроенные планы обслуживания SQL Server. Могу я их использовать в EMS SQL Backup?

О: Вы можете преобразовать планы обслуживания SQL Server в политики EMS SQL Backup, используя мастер конвертации планов обслуживания через контекстное меню «Maintenance Policies | Convert from Maintenance Plan» дерева Servers.

В: Каким образом EMS SQL Backup уведомит меня в случае сбоя в выполнении политики?

О: EMS SQL Backup имеет возможность рассылать собственные электронные уведомления о результатах выполнения политик. Также EMS SQL Backup Console покажет статусы и результаты выполнения политик при соединении с сервером.

В: Могу я выполнять наблюдение/управление за своей группой серверов с помощью двух (трех) разных (установленных на разных компьютерах) консолей?

О: Да это возможно. Однако Ваша конфигурация EMS SQL Backup Console должна быть доступна со всех этих компьютеров. Конфигурация может храниться как в файле, так и в базе данных на каком-либо SQL Server. В данном случае мы рекомендуем хранить конфигурацию на SQL Server. Чтобы изменить место хранения конфигурации вызовите диалог «Options | Save Configuration», укажите новое местоположение конфигурации и включите опцию «Switch to saved configuration», чтобы начать использовать новое местоположение. В EMS SQL Backup Console, установленных на остальных компьютерах, Вы должны будете переключиться на новое местоположение конфигурации, используя диалог «Options | Switch Configuration».

В: Серверы, с которыми работает EMS SQL Backup, должны находиться в пределах одной локальной сети?

О: Серверы могут находиться где угодно. Если Вы можете подключиться к вашим серверам через SQL Server Management Studio, то и EMS SQL Backup сможет работать с ними.

В: Необходимо ли открывать дополнительно какие-либо порты или разрешать протоколы для работы EMS SQL Backup?

О: Для работы EMS SQL Backup Вам нет необходимости открывать дополнительно какие-либо порты или подключать протоколы сверх тех, что использует Ваш SQL Server Management Studio.

В: Можно ли установить серверные компоненты EMS SQL Backup удаленно?

О: Да, Вы можете установить серверные компоненты EMS SQL Backup удаленно из EMS SQL Backup Console. Для этого в дереве Servers выберите SQL Server, на который хотите произвести установку, и выберите пункт Install server-side EMS SQL Backup Components в контекстном меню. Далее следуйте указаниям мастера.

Для удаленной установки необходимо выполнение ряда условий:

  • Установка через SQL Server:

- Необходимо иметь учетную запись с правами системного администратора SQL Server, например sa.

- Служба SQL Server должна быть запущена под учетной записью с правами локального администратора Windows, например LocalSystem

  • Установка через NETBIOS:

- Необходимо иметь права системного администратора Windows на удаленной машине.

- Необходимо иметь учетную запись с правами системного администратора SQL Server, например sa.

В: Мне не удается установить серверные компоненты удаленно через EMS SQL Backup из-за ограничения прав или ошибки установки. Могу ли я установить компоненты, запустив установку на серверной машине?

О: Да, для этого предусмотрен специальный режим работы программы установки EMS SQL Backup.

  1. Скопируйте дистрибутив программы (SQLBackupSetup-x.x.xx.xxxx.msi) на серверную машину.
  2. От имени администратора выполните следующую команду: SQLBackupSetup.exe -var:"ServerInstall=1"
  3. Следуйте инструкциям программы установки, которая сама обнаружит все установленные локально экземпляры сервера и предложит установить на них серверные компоненты.

В: Под каким аккаунтом рекомендуется запускать сервис EMS SQL Backup?

О: Для службы EMS SQL Backup может использоваться любой аккаунт, обладающий следующим привилегиями:

  • Доступ на SQL Server с правами администратора сервера.
  • Доступ на запись в директорию, которая будет использована для создания резервных копий.
  • Возможность авторизации на другой машине в сети для доступа на чтение/запись в общую директорию при организации процесса пересылки журналов.

Например, может использоваться доменный пользователь системы, обладающий перечисленными привилегиями. Если организация процесса пересылки журналов не планируется, в качестве учетной записи пользователя для службы может быть использована встроенная учетная запись Local System.

В: Выполнение политики завершается неудачей с ошибкой: "Не удалось завершить задание. Владелец (NT AUTHORITY\SYSTEM) задания SqlBackup_XXXXXXXX_Task не имеет доступа к серверу". Почему это происходит?

О: Данная ошибка происходит, когда SQL Server Agent неверно получает информацию о наборе прав пользователя NT AUTHORITY\SYSTEM - владельца выполняемой задачи. Данную проблемы можно решить одним из следующих способов.

  • Изменить учетную запись службы EMS SQL Backup на любую другую, имеющую привилегии запуска задач на сервере. Пересоздать политику.
  • Изменить владельца задач SqlBackup_XXXXXXXX_Task на другого пользователя, имеющего права на запуск задач.
  • Если на сервере была удалена учетная запись BUILTIN\Administrators, восстановить ее с правами администратора.

В: Какие отличия между различными версиями EMS SQL Backup?

О: Отличия между версиями EMS SQL Backup наглядно приведены в Сравнительной таблице характеристик.

В: Я могу не платить за обслуживание программы?

О: В базовую цену EMS SQL Backup включен 1 год Сопровождения. После окончания периода Сопровождения Вы можете продолжить работать с программой без каких-либо ограничений, однако обновления программы, вышедшие после даты окончания периода Сопровождения, будут Вам недоступны.

В: При установке серверных компонентов EMS SQL Backup через сетевую директорию я получаю ошибку "Access is Denied". Как можно исправить проблему?

О: Прежде всего, убедитесь, что у заданного пользователя есть права локального Администратора на хосте, на котором запущена служба SQL Server.

Если проблема осталась, то одно из возможных решений - отключить удаленное управление учетными записями пользователей на целевом хосте, чтобы разрешить удаленному администратору получить доступ к ресурсу ADMIN$ и запустить процесс установки. Чтобы отключить удаленное управление учетными записями пользователей, необходимо добавить запись в реестр на целевом хосте. Для этого:

  • откройте реестр Windows,
  • найдите и выделите подраздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System,
  • создайте параметр DWORD с именем LocalAccountTokenFilterPolicy,
  • присвойте этому параметру значение 1.

Наверх

Если у Вас возникли какие-либо вопросы, свяжитесь с нашим Центром поддержки.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Начало работы

EMS SQL Backup предоставляет Вам возможность эффективно управлять одним или несколькими серверами SQL Server с использованием различных доступных инструментов.

При первом запуске программы отображается окно Configuration, в котором необходимо указать настройки хранения конфигурации.

Для начала работы с программой необходимо указать параметры подключения к серверу и установить серверные компоненты для каждого зарегистрированного сервера.

Сервер можно зарегистрировать в папках Groups или Solutions в проводнике.

Для удобства пользователя в проводнике баз данных по умолчанию существуют два раздела - Groups и Solutions. Groups используются для организации серверов по некоторым определенным критериям (например, местоположение). С помощью Solutions можно объединять сервера, которые будут включены в одну политику, и отдельные базы данных, расположенные на разных серверах.

Смотрите также:

Управление серверами

Управление политиками обслуживания

Шаблоны

Активность

Операции обслуживания

Опции


Общие сведения о EMS SQL Backup

EMS SQL Backup состоит из двух основных программных частей: SQL Administration Console и Server-side components.

SQL Administration Console запускается на клиентской машине, а Server-side components устанавливаются на сервер (машину, на которой запущен экземпляр SQL Server) удаленно либо локально. Server-side components представляют собой службу, устанавливаемую на машину с запущенными экземплярами SQL Server, и набор хранимых процедур (extended stored procedures), создаваемых в базе данных 'master' каждого экземпляра SQL Server.

EMS SQL Backup Administration Console является основным инструментом управления экземплярами SQL Server и создаваемыми политиками обслуживания, выполняет функции контроля состояния экземпляров, а также консолидации журналов. Все задачи, выполняемые на SQL Server, инициируются службой, которая должна быть запущена на сервере все время работы с EMS SQL Backup и выполнения политик (в т.ч. выполнения по расписанию). Коммуникация EMS SQL Backup Administration Console и службы, запущенной на сервере, осуществляется посредством расширенных хранимых процедур EMS SQL Backup, что позволяет получать полный контроль над выполнением политик обслуживания без использования дополнительных подключений к машине сервера и избежать открытия новых сетевых портов.


Общие сведения о политиках

Политика (Policy) – это совокупность операций (операций обслуживания), которые должны быть произведены над базами и серверами, и набора расписаний, в соответствии с которым эти операции будут выполнены. Политика реализована в виде набора задач SQL сервера и для их выполнения необходим SQL Agent.

Задача = Шаг(и) + назначенное(ые) расписание(я)

Политика = Задача 1 + Задача 2 + .... + Задача N

Выполнение каждой политики отображается в Статусе выполнения, в котором сообщается об успешном выполнении или о возникших при выполнении ошибках. Политики, имеющие ошибки, можно исправить и перезапустить, или игнорировать.

Для более простого и быстрого создания стандартных политик Вы можете использовать Шаблоны.

Так как политики представляют собой набор заданий (jobs) SQL Server, то для их выполнения необходима стабильная работа агента SQL Server.

Управление политиками обслуживания

Статусы политик


Навигация

Проводник (Explorer) - основное навигационное окно для работы с серверами и базами данных. Представление объектов в нем имеет иерархическую структуру. С его помощью можно получить доступ к любому объекту для выполнения необходимых операций над ним. Для удобства пользователя в проводнике баз данных по умолчанию существуют два раздела - Groups и Solutions.

Вы можете переносить сервера между группами и решениями.

Инструменты для администрирования серверов и баз данных поделены на четыре группы. Каждая группа инструментов располагается в выделенном ей разделе. Такие разделы располагаются в верхней части окна EMS SQL Backup и называются вкладками (Tabs).

Appendix - Program interface - Tabs

Servers - для управления серверами, базами данных и отслеживания статусов выполнения политик;

Policies - для управления политиками;

Templates - для управления шаблонами политик, задач, шагов и расписаний;

Activity - для просмотра запущенных политик и задач на серверах.

Панели инструментов

Панель инструментов - строка, с вынесенными на нее кнопками, позволяющими совершать, практически, все операции с объектом.

Appendix - Program interface - Toolbar

Панели инструментов располагаются на вкладках Servers и Policies.

Смотрите также:

Управление серверами

Управление политиками обслуживания

Шаблоны

Активность


Управление серверами

При переходе на вкладку Servers открывается рабочая область для управления серверами и базами данных.

Servers

С помощью проводника можно получить доступ к серверам и базам данных. В проводнике серверы и базы данных можно объединять в группы (Groups) и решения (Solutions).

Shortcuts - вкладка быстрого доступа, на которую можно перетащить часто используемые объекты.

Troubled servers - раздел, в котором отображаются серверы, на которых возникли ошибки при выполнении политик.

Overall status - статус выбранного сервера. Для каждого статуса сервера предусмотрена кнопка, нажав на которую можно выполнить необходимое действие.

Policies are successful, There are no policies

Есть подключение к серверу, все политики выполняются без ошибок. Нажав на кнопку, можно создать новую политику в открывшемся редакторе.

Server isn't connected

Этот статус появляется, если отсутствует подключение к выбранному серверу

Backup service isn't installed

Этот статус появляется, если на сервере не установлены серверные компоненты.

Policies have problems

При выполнении политики возникла ошибка. Автоматически исправить возникшую ошибку можно, используя кнопку Resolve problem.

Some of policies have unknown status - статус некоторых политик неизвестен. Это происходит, если время запуска политики прошло, а она так и не была выполнена.

Policies have warnings - при выполнении политики возникли предупреждения. В предупреждениях сообщается о несоответствующих регистрируемых параметрах сервера и некоторых других неполадках при выполнении, которые не влияют на конечный результат.

Статус сервера

- Неподключенный сервер, на котором не установлены компоненты EMS SQL Backup.

- Подключенный сервер, на котором не установлены компоненты EMS SQL Backup.

InProcess - Обновление состояния сервера.

ServerConnectionFailed - Невозможно подключиться к серверу с данными настройками подключения. Для исправления этой ошибки нужно открыть Свойства сервера, проверить и изменить параметры подключения.

OK - Подключенный сервер, на котором установлены компоненты EMS SQL Backup.

Disconnected - Неподключенный сервер, на котором установлены компоненты EMS SQL Backup.

PoliciesHaveProblems - При выполнении политики произошла ошибка. Можно исправить ошибки, нажав Resolve.

- При выполнении политики возникли предупреждения.

- Все политики на сервере выполнились успешно.

- У некоторых политик на сервере статус 'Unknown'.

Важно: Базы данных также имеют определенные статусы, информацию о которых Вы можете найти на странице Состояния базы данных.

Policies

В этом окне приведена вся информация о существующих на выбранном сервере политиках, их задачах, времени запуска и статусе.

Двойной щелчок мышкой на политике или задаче запускает ее выполнение или, при наличии ошибок, открывает диалоговое окно Resolve the problem.

Контекстное меню политики позволяет:

  • устранить проблему выполнения (при наличии ошибок)

RunPolisy выполнить политику

PausePolicy приостановить выполнение политики

просмотреть историю политики

EditPolicy редактировать политику в Редакторе политик

Launches

Запуски политик на выбранном сервере. Каждая политика содержит набор задач. В этом разделе отображается информация о запусках задач: дата и время запуска, результат, статус. Количество дней, за которое отображаются запуски, можно задать в диалоговом окне Настройки окружения на вкладке Параметры обновления.

Можно управлять списком запусков с помощью фильтра. Кнопка Filter расположена на панели над списком.

В диалоговом окне, открывающемся при нажатии этой кнопки, можно выбрать определенные статусы запуска. В этом случае отображаться будут запуски, имеющие соответствующий статус.

Сохранять информацию о запусках во внешний файл можно с помощью Отчетов.

Start date

В том разделе можно выполнить отбор запусков по дате начала выполнения - с From date по To date.

Apply Filter - применить указанные настройки фильтра.

Discard Filter - сбросить все настройки фильтра и отобразить полный список.

При нажатии на кнопку Show details в колонке Message будет показано окно с детальной информацией о выполнении шага или об ошибке/предупреждении (в зависимости от статуса.)

При нажатии кнопки Reports Report можно сформировать отчет по политикам и запускам.

Смотрите также:

Начало работы

Управление политиками обслуживания

Шаблоны

Активность

Операции обслуживания

Опции


Контекстные меню

Контекстное меню - это список действий, который можно открыть, нажав правой кнопкой мыши на объекте в проводнике баз данных.

Для объектов вкладки Servers отображаются следующие контекстные меню.

Контекстное меню групп

Контекстное меню группы

Контекстное меню сервера

Контекстное меню базы данных

Смотрите также:

Контекстное меню вкладки Policies


Контекстное меню групп

Контекстное меню групп открывается при нажатии на узле Groups правой кнопкой мыши в проводнике.

Servers Management - Popup menu - Groups

iconNewSubFolder Create New Group - создать новую группу;

iconRefresh Refresh - обновить подобъекты;

Policy Maintenance Policies

CreatePolicy Create New Policy - создать новую политику;

CopyFromTemplate Copy from Templates - создать политику на основе шаблона;

Quick Maintenance Actions - открыть список операций обслуживания;

Show History - показать историю выполнения политик;

Collapse Collapse - свернуть все группы;

Expand Expand - развернуть все группы.

Смотрите также:

Контекстное меню группы

Контекстное меню сервера

Контекстное меню базы данных


Контекстное меню группы

Контекстное меню группы открывается при нажатии на группу объектов правой кнопкой мыши в проводнике.

Servers Management - Popup menu - Group

iconNewSubFolder Create New Group - создать новую группу;

DeleteGroup Delete Group - удалить группу;

  • Rename Group - переименовать группу;

btnRegisterHost Register Server - зарегистрировать сервер;

iconRefresh Refresh - обновить подобъекты группы;

Policy Maintenance Policies

CreatePolicy Create New Policy - создать новую политику;

CopyFromTemplate Create from Templates - создать политику на основе шаблона;

Quick Maintenance Actions - открыть список операций обслуживания;

Show History - показать историю выполнения политик;

AddToShortcuts Add to Shortcuts - добавить выбранный объект на вкладку быстрого доступа;

Collapse Collapse - свернуть все группы;

Expand Expand - развернуть все группы.

Смотрите также:

Контекстное меню групп

Контекстное меню сервера

Контекстное меню базы данных


Контекстное меню сервера

Это меню открывается при нажатии правой кнопкой мыши на сервер в проводнике баз данных.

Servers Management - Popup menu - Server

iconNewSubFolder Create New Group - создать новую группу;

btnRegisterHost Register Server - зарегистрировать сервер;

btnUnregisterHost Unregister Server - удалить регистрацию сервера;

btnDBProperties Server Properties - свойства сервера;

GetBackupToConsole получить файл резервной копии с сервера;

btnConnectToDB / btnDisconnectFromDB Connect/Disconnect - подключиться к серверу/отключиться от сервера;

iconRefresh Refresh - обновить подобъекты сервера;

Policy Maintenance Policies

CreatePolicy Create New Policy - создать новую политику;

CopyFromTemplate Copy from Templates - создать политику на основе шаблона;

ConvertfromMaintenanceplan Convert from Maintenance Plan - конвертировать из плана обслуживания;

PausePolicy Pause All Policies on Server - приостановить выполнение политик на сервере;

ResumePolicies Resume All Policies on Server - возобновить выполнение политик на сервере;

Quick Maintenance Actions - открыть список операций обслуживания;

Show History - показать историю выполнения политик;

ServerProperties Server-side Components Properties - свойства серверных компонентов;

Install/Update/Remove server-side EMS SQL Backup components - установить/удалить/переустановить серверные; компоненты EMS SQL Backup

Activate license - активировать лицензию EMS SQL Backup;

Deactivate license - деактивировать лицензию EMS SQL Backup;

Send bug report to EMS - отправить отчет об ошибке;

AddToShortcuts Add to Shortcuts - добавить выбранный объект на вкладку быстрого доступа;

Collapse Collapse - свернуть все группы;

Expand Expand - развернуть все группы;

Смотрите также:

Контекстное меню групп

Контекстное меню группы

Контекстное меню базы данных


Контекстное меню базы данных

Это меню открывается при нажатии на базу данных в проводнике баз данных.

Servers Management - Popup menu - Database

создать резервную копию выбранной базы данных;

восстановить выбранную базу данных;

GetBackupToConsole получить файл резервной копии с сервера;

iconRefresh Refresh - обновить подобъекты сервера;

Policy Maintenance Policies

CreatePolicy Create New Policy - создать новую политику;

CopyFromTemplate Copy from Templates - создать политику на основе шаблона;

ConvertfromMaintenanceplan Convert from Maintenance Plan - конвертировать из плана обслуживания;

PausePolicy Pause All Policies on Server - приостановить выполнение политик на сервере;

ResumePolicies Resume All Policies on Server - возобновить выполнение политик на сервере;

Quick Maintenance Actions - открыть список операций обслуживания;

Show History - показать историю выполнения политик;

AddToShortcuts Add to Shortcuts - добавить выбранный объект на вкладку быстрого доступа.

Смотрите также:

Контекстное меню групп

Контекстное меню группы

Контекстное меню сервера


Мастер регистрации сервера

С помощью этого мастера Вы можете зарегистрировать сервер в программе.

Чтобы запустить Register Server wizard необходимо выбрать пункт Register Server в контекстном меню сервера в проводнике или на панели инстурментов.

Список шагов:

Задание параметров подключения

Задание дополнительных параметров

Выполнение операции

Смотрите также:

Установка серверных компонентов EMS SQL Backup

Обновление серверных компонентов

Свойства серверных компонентов

Свойства сервера


Задание параметров подключения

На этом шаге необходимо задать основные параметры для регистрации сервера в системе.

Setting connection parameters

Server Name

Из этого раскрывающегося списка выберите сервер (хост), к которому хотите подключиться. В этот список программа автоматически добавляет серверы, найденные в локальной сети. Если компоненты SQL-DMO установлены на клиентском компьютере, используется их функция ListAvailableSQLServers. Если компоненты SQL-DMO не установлены, используется функция NetServerEnum из netapi32.dll. Если данная библиотека не установлена, то при первом открытии программы этот список будет пуст, и имя сервера необходимо будет задать вручную. В этом случае в списке Server name будут отображаться те серверы, базы данных которых уже зарегистрированы в программе.

Важно: Имя сервера не всегда отображается в списке. В этом случае введите его вручную.

SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2005 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в Server name Вы должны будете указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

В поле Alias можно указать псевдоним сервера, то есть, под каким названием он будет отображаться в проводнике.

В разделе Authentication задается способ идентификации пользователя на сервере.

RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

При выборе SQL Server authentication следует указать имя и пароль в полях User name и Password соответственно.

Timeout

Время ожидания в секундах при подключении к SQL Server.

Test Connection

Можно проверить имеется ли в настоящее время соединение с указанным сервером, нажав на кнопку Test Connection.

Следующий шаг >>


Задание дополнительных параметров

На этом шаге можно задать дополнительные параметры.

Setting additional options

В текстовом Description можно задать текстовое описание сервера.

CheckBox Connect automatically on Console startup

При запуске программы EMS SQL Backup связь с этим сервером будет устанавливаться автоматически.

CheckBox Connect to SQL Server after registration

Подключиться к серверу сразу после регистрации.

CheckBox Install/Update server-side EMS SQL Backup components on this SQL Server

Если включена эта опция, то мастер удаленной установки серверных компонентов будет запущен автоматически после регистрации сервера.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

Нажмите кнопку Finish для выполнения операции регистрирования сервера.

<< Предыдущий шаг


Удаленная установка серверных компонентов EMS SQL Backup

EMS SQL Backup состоит из двух основных программных частей: SQL Administration Console и Server-side components.

Подробно об этих компонентах можно прочитать в разделе Общие сведения о EMS SQL Backup.

Для правильной работы EMS SQL Backup необходимо установить серверные компоненты на каждый используемый экземпляр сервера.

Server-side components

Серверные компоненты устанавливаются локально или удаленно на все экземпляры MS SQL Server, с которыми будет работать EMS SQL Backup. Они включают в себя службы и хранимые процедуры для просмотра и обслуживания серверов.

EMS SQL Backup Administration Console

Эта часть устанавливается локально на компьютере администратора серверов. При установке устанавливается консольное приложение и происходит конфигурирование репозитория.

Для сервера и служб нужны права Local system или локального администратора.

Для запуска мастера установки серверных компонентов необходимо в проводнике, на вкладке Servers, в контекстном меню сервера выбрать пункт Install server-side EMS SQL Backup components.

Список шагов:

Выбор типа установки

Задание учетной записи

Выполнение операции

Смотрите также:

Мастер регистрации сервера

Мастер обновления/удаления серверных компонентов

Обновление серверных компонентов

Мастер локальной установки серверных компонентов

Свойства серверных компонентов

Свойства сервера


Выбор типа установки

На этом шаге необходимо выбрать тип установки служб программы EMS SQL Backup.

Installation Wizard - Selecting installation type

Для локального сервера на этом шаге будет отображаться имя сервера.

Для удаленного сервера необходимо будет выбрать тип установки серверных компонентов.

RadioButton SQL Server

Установить серверные компоненты через подключение к SQL Server.

Рекомендуется использовать эту опцию, если служба SQL Server запущена под системной учетной записью LocalSystem или под учетной записью пользователя, являющегося Администратором.

RadioButton Network Folder

Установить серверные компоненты через сетевую папку.

Remote resource

Выберите сетевую папку, которая будет использована для копирования файлов, необходимых для установки серверных компонентов EMS SQL Backup: RadioButton ADMIN$ или RadioButton Custom (другая сетевая директория). Используйте другую папку, если на удаленном хосте нет ресурса ADMIN$.

Если Вы выбрали опцию Custom, задайте следующие параметры.

Share path

Укажите имя сетевой директории без указания полного сетевого пути (например, 'Shared').

Share local path

Укажите полный локальный путь к директории на удаленном хосте (например, 'C:\Shared').

Задайте параметры авторизации для доступа к сетевому ресурсу:

RadioButton Windows authentication - использовать текущую учетную запись Windows,

RadioButton This account - укажите имя пользователя (User) и пароль (Password).

Пожалуйста, убедитесь, что у заданного пользователя есть разрешения на чтение и запись в указанную папку, а также, что этот пользователь принадлежит группе Администраторы на удаленном хосте.

После задания всех настроек, нажмите кнопку Check folder, чтобы проверить существование папки и доступ к ней.

Следующий шаг >>


Задание учетной записи

Используйте этот шаг, чтобы указать учетную запись, под которой будет запущена служба EMS SQL Backup и параметры подключения службы к SQL Server.

Installation Wizard - Specifying account information

Windows account for EMS SQL Backup Service Log On

Задайте учетную запись Windows, которая будет использована службой EMS SQL Backup Service для входа в систему.

RadioButton Local System account (NT AUTHORITY\SYSTEM)

Выберите эту опцию, чтобы в качестве учетной записи для входа в систему использовалась учетная запись LocalSystem.

RadioButton This account

Выберите эту опцию, чтобы указать пользователя Windows, от имени которого будет производиться вход службы EMS SQL Backup Service в систему.

В поле User необходимо задать полное имя пользователя в формате <имя_домена\имя_пользователя> и указать пароль в поле Password.

SQL Server login for EMS SQL Backup Service

Задайте логин SQL Server, который будет использоваться службой EMS SQL Backup Service для подключения к серверу. После установки серверных компонентов этот логин можно редактировать в диалоге Свойства серверных компонентов.

Важно: Заданный логин должен принадлежать роли 'sysadmin'.

RadioButton Windows authentication

Выберите эту опцию, чтобы использовать Windows аутентификацию пользователя, заданного в Windows account for EMS SQL Backup Service Log On для подключения к SQL Server.

Важно: Если Windows логина для заданной учетной записи Windows не существует на сервере, то он будет создан и добавлен к роли 'sysadmin'.

Важно: Если Вы выбрали учетную запись Local System для входа службы в систему, убедитесь, что логин NT AUTHORITY\система существует на SQL Server и принадлежит роли 'sysadmin'.

RadioButton SQL Server authentication

Программа распознает пользователя на сервере по заданным имени и паролю.

При выборе этой опции следует указать имя и пароль в полях User и Password соответственно.

<< Предыдущий шаг

Следующий шаг >>


Задание параметров отказоустойчивости службы

Если сервер, на который происходит установка серверных компонентов, сконфигрурирован как отказоустойчевый кластер, то в мастере установки появится шаг задания параметров кластера. На этом шаге нужно задать ресурсы, которые могут быть использованы для конфигурации отказоустойчивости службы EMS SQL Backup.

Installation Wizard - Setting cluster configuration

Для обеспечения выполнения политик на отказоустойчивом кластере SQL Server, служба EMS SQL Backup должна быть установлена и сконфигурирована как кластерная (отказоустойчивая).

Для этого необходимо, чтобы на сервере было выделено хранилище, не используемое другими кластерными службыми, и на этом хранилище выделен раздел, который может быть использован службой EMS SQL Backup.

Storage settings

В выпадающем списке Available storage выберите диск, который будет использован службой EMS SQL Backup. В списке отображаются только диски, не используемые другими кластерными службами.

В списке Partition выберите доступный раздел диска.

Network settings

В этом разделе задайте сетевые параметры кластерной службы.

В поле Network выберите имя сети кластера, в которой будет доступна служба EMS SQL Backup. В поле IP address for service задайте IP-адрес, который будет использоваться службой. Может быть задан только свободный IP-адрес, принадлежащей выбранной сети.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно увидеть значения всех заданных на предыдущих шагах опций.

Installation Wizard - Performing operation

Если все задано верно, то можно начать выполнение операции, нажав кнопку Install.

О процессе выполнения операции и возникших ошибках сообщается в этом же окне.

<< Предыдущий шаг


Мастер обновления/удаления серверных компонентов

При возникновении ошибок в работе сервисов EMS SQL Backup необходимо переустановить серверные компоненты.

При обновлении программа пытается обновить компоненты для всех экземпляров SQL Server, установленных на той же машине, что и выбранный экземпляр.

В контекстном меню сервера в проводнике баз данных необходимо выбрать пункт Update/Remove server-side SQL Backup Components.

Список шагов:

Выбор сервера

Выбор типа операции

Задание учетной записи

Выполнение операции

Смотрите также:

Мастер регистрации сервера

Установка серверных компонентов EMS SQL Backup

Обновление серверных компонентов

Мастер локальной установки серверных компонентов

Свойства серверных компонентов

Свойства сервера


Выбор типа обновления/удаления

На этом шаге необходимо тип обновления/удаления серверных компонентов.

Installation Wizard - Selecting updating type

Для локального сервера на этом шаге будет отображаться имя сервера.

Для удаленного сервера необходимо будет выбрать тип обновления или удаления серверных компонентов.

RadioButton SQL Server

Обновить/удалить серверные компоненты через подключение к SQL Server.

Рекомендуется использовать эту опцию, если служба SQL Server запущена под системной учетной записью LocalSystem или под учетной записью пользователя, являющегося Администратором.

RadioButton Network Folder

Обновить/удалить серверные компоненты через сетевую папку.

Remote resource

Выберите сетевую папку, которая будет использована для копирования файлов, необходимых для обновления/удаления серверных компонентов EMS SQL Backup: RadioButton ADMIN$ или RadioButton Custom (другая сетевая директория). Используйте другую папку, если на удаленном хосте нет ресурса ADMIN$.

Если Вы выбрали опцию Custom, задайте следующие параметры.

Share path

Укажите имя сетевой директории без указания полного сетевого пути (например, 'Shared').

Share local path

Укажите полный локальный путь к директории на удаленном хосте (например, 'C:\Shared').

Задайте параметры авторизации для доступа к сетевому ресурсу:

RadioButton Windows authentication - использовать текущую учетную запись Windows,

RadioButton This account - укажите имя пользователя (User) и пароль (Password).

Пожалуйста, убедитесь, что у заданного пользователя есть разрешения на чтение и запись в указанную папку, а также, что этот пользователь принадлежит группе Администраторы на удаленном хосте.

После задания всех настроек, нажмите кнопку Check folder, чтобы проверить существование папки и доступ к ней.

Следующий шаг >>


Выбор типа операции

На этом шаге необходимо выбрать операцию, которая будет выполнена со серверными компонентами EMS SQL Backup.

Installation Wizard - Selecting operation

RadioButton Update

Выберите этот вариант, чтобы восстановить или обновить серверные компоненты EMS SQL Backup.

RadioButton Uninstall

Выберите эту опцию, чтобы удалить серверные компоненты EMS SQL Backup. Задания, созданные посредством EMS SQL Backup, будут удалены с сервера.

<< Предыдущий шаг

Следующий шаг >>


Spwcifying service log-on settings

SQL Backup
  • Index
  • « Prev
  • Next »

Задание учетной записи

Используйте этот шаг, чтобы указать учетную запись, под которой будет запущена служба EMS SQL Backup и параметры подключения службы к SQL Server.

Update Wizard - Specifying account information

Windows account for EMS SQL Backup Service Log On

Задайте учетную запись Windows, которая будет использована службой EMS SQL Backup Service для входа в систему.

RadioButton Local System account (NT AUTHORITY\SYSTEM)

Выберите эту опцию, чтобы в качестве учетной записи для входа в систему использовалась учетная запись LocalSystem.

RadioButton This account

Выберите эту опцию, чтобы указать пользователя Windows, от имени которого будет производиться вход службы EMS SQL Backup Service в систему.

В поле User необходимо задать полное имя пользователя в формате <имя_домена\имя_пользователя> и указать пароль в поле Password.

Важно: Служба EMS SQL Backup Service устанавливается в единственном экземпляре, поэтому при изменении учетной записи Windows для одного экземпляра сервера, она автоматически изменится и для других.

SQL Server login for EMS SQL Backup Service

Задайте логин SQL Server, который будет использоваться службой EMS SQL Backup Service для подключения к серверу. После установки серверных компонентов этот логин можно редактировать в диалоге Свойства серверных компонентов.

Важно: Заданный логин должен принадлежать роли 'sysadmin'.

RadioButton Windows authentication

Выберите эту опцию, чтобы использовать Windows аутентификацию пользователя, заданного в Windows account for EMS SQL Backup Service Log On для подключения к SQL Server.

Важно: Если Windows логина для заданной учетной записи Windows не существует на сервере, то он будет создан и добавлен к роли 'sysadmin'.

Важно: Если Вы выбрали учетную запись Local System для входа службы в систему, убедитесь, что логин NT AUTHORITY\система существует на SQL Server и принадлежит роли 'sysadmin'.

RadioButton SQL Server authentication

Программа распознает пользователя на сервере по заданным имени и паролю.

При выборе этой опции следует указать имя и пароль в полях User и Password соответственно.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно увидеть значения всех заданных на предыдущих шагах опций.

Update Wizard - Performing operation

Если все задано верно, то можно начать выполнение операции, нажав кнопку Update/Uninstall.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Обновление серверных компонентов

Инструмент Update server-side components предназначен для обновления серверных компонентов на нескольких экземплярах серверов одновременно.

Чтобы открыть этот диалог, выберите пункт Update Server-side Components в меню шестеренок. В списке отображаются сервера, у которых версия серверных компонентов ниже, чем версия EMS SQL Backup Console.

Multiple server-side components updater

Отметьте в списке те сервера, на которых следует обновить серверные компоненты. Установите флажок CheckBox All, чтобы выбрать все сервера.

Под именем экземпляра отображаются параметры, которые будут использованы при обновлении:

Access method - метод доступа на сервер,

Service Windows log on - учетная запись, под которой будет запущена служба,

Service SQL Server login - параметры авторизации службы на сервере,

Network Folder authentication - параметры авторизации для доступа к сетевой папке.

После выбора необходимых серверов и задания параметров нажмите кнопку Update, чтобы начать процесс обновления серверных компонентов.

Нажмите кнопку Change settings, чтобы изменить параметры авторизации и настройки учетной записи службы EMS SQL Backup для выполнения обновления в диалоге Настройки учетной записи службы.


Настройки учетной записи службы

В диалоге Service account settings необходимо задать учетную запись для входа службы в систему и логин SQL Server для подключения службы к SQL Server.

При задании настроек для удаленного экземпляра сервера необходимо также указать метод, которым будет проводиться обновление серверных компонентов.

Multiple server-side components updater - Settings

Для обновления на удаленном сервере выберите тип обновления:

RadioButton SQL Server

Обновить серверные компоненты через подключение к SQL Server.

Рекомендуется использовать эту опцию, если служба SQL Server запущена под системной учетной записью LocalSystem или под учетной записью пользователя, являющегося Администратором.

RadioButton Network Folder

Обновить серверные компоненты через сетевую папку.

Network Folder settings

Этот раздел настроек доступен, если в качестве типа обновления выбран тип Network Folder.

Remote resource

Выберите сетевую папку, которая будет использована для копирования файлов, необходимых для обновления серверных компонентов EMS SQL Backup: RadioButton ADMIN$ или RadioButton Custom (другая сетевая директория). Используйте другую папку, если на удаленном хосте нет ресурса ADMIN$.

Если Вы выбрали опцию Custom, задайте следующие параметры.

Share path

Укажите имя сетевой директории без указания полного сетевого пути (например, 'Shared').

Share local path

Укажите полный локальный путь к директории на удаленном хосте (например, 'C:\Shared').

Задайте параметры авторизации для доступа к сетевому ресурсу:

RadioButton Windows authentication - использовать текущую учетную запись Windows,

RadioButton This account - укажите имя пользователя (User) и пароль (Password).

Пожалуйста, убедитесь, что у заданного пользователя есть разрешения на чтение и запись в указанную папку, а также, что этот пользователь принадлежит группе Администраторы на удаленном хосте.

После задания всех настроек, нажмите кнопку Check folder, чтобы проверить существование папки и доступ к ней.

Windows account for EMS SQL Backup Service Log On

Задайте учетную запись Windows, которая будет использована службой EMS SQL Backup Service для входа в систему.

RadioButton Local System account (NT AUTHORITY\SYSTEM)

Выберите эту опцию, чтобы в качестве учетной записи для входа в систему использовалась учетная запись LocalSystem.

RadioButton This account

Выберите эту опцию, чтобы указать пользователя Windows, от имени которого будет производиться вход службы EMS SQL Backup Service в систему.

В поле User необходимо задать полное имя пользователя в формате <имя_домена\имя_пользователя> и указать пароль в поле Password.

Важно: Служба EMS SQL Backup Service устанавливается в единственном экземпляре, поэтому в Мастере локальной установки серверных компонентов при изменении учетной записи Windows для одного экземпляра сервера, она автоматически изменится и для других.

SQL Server login for EMS SQL Backup Service

Задайте логин SQL Server, который будет использоваться службой EMS SQL Backup Service для подключения к серверу. После установки серверных компонентов этот логин можно редактировать в диалоге Свойства серверных компонентов.

Важно: Заданный логин должен принадлежать роли 'sysadmin'.

RadioButton Windows authentication

Выберите эту опцию, чтобы использовать Windows аутентификацию пользователя, заданного в Windows account for EMS SQL Backup Service Log On для подключения к SQL Server.

Важно: Если Windows логина для заданной учетной записи Windows не существует на сервере, то он будет создан и добавлен к роли 'sysadmin'.

Важно: Если Вы выбрали учетную запись Local System для входа службы в систему, убедитесь, что логин NT AUTHORITY\система существует на SQL Server и принадлежит роли 'sysadmin'.

RadioButton SQL Server authentication

Программа распознает пользователя на сервере по заданным имени и паролю.

При выборе этой опции следует указать имя и пароль в полях User и Password соответственно.


Мастер локальной установки серверных компонентов

Installation Wizard - самостоятельное приложение, поставляемое в комплекте с EMS SQL Backup, предназначенное для локальной установки серверных компонентов EMS SQL Backup на каждый используемый экземпляр сервера.

EMS SQL Backup состоит из двух основных программных частей: SQL Administration Console и Server-side components.

Серверные компоненты устанавливаются локально или удаленно на все экземпляры MS SQL server, с которыми будет работать EMS SQL Backup. Они включают в себя службы и хранимые процедуры для просмотра и обслуживания серверов.

Если удаленная установка с помощью Мастера удаленной установки серверных компонентов невозможна по какой-то причине, то необходимо скопировать установочный файл приложения EMS SQL Backup на компьютер, на котором установлен сервер, и запустить там; на третьем шаге мастера установки выбрать режим Server-side only. После завершения мастера EMS SQL Backup Setup откроется окно мастера установки серверных компонентов Installation Wizard.

Подробно об этих компонентах можно прочитать в разделе Общие сведения о EMS SQL Backup.

Для правильной работы EMS SQL Backup необходимо установить серверные компоненты на каждый используемый экземпляр сервера.

Список шагов:

Выбор операции

Настройка параметров установки

Настройки соединения для инсталлятора

Настройки учетной записи службы

Задание параметров отказоустойчивости службы

Выполнение операции


Выбор операции

Выберите тип операции на первом шаге мастера.

Stand-alone installer - Choosing operation type

Выберите Install для установки серверных компонентов, Update для бновления и Uninstall - для удаления серверных компонентов.

Следующий шаг >>


Настройка параметров установки

На этом шаге задайте все настройки, необходимые для установки/обновления/удаления компонентов.

Stand-alone installer - Configuring service settings

Отметьте экземпляры сервера, на которых Вы хотите установить/обновить/удалить серверные компоненты. Все доступные экземпляры сервера отображаются в списке.

Нажмите кнопку Connection, чтобы вызвать диалог Настройки параметров подключения к SQL Server для инсталлятора.

Нажмите кнопку Service account, чтобы вызвать диалог Настройки учетной записи службы EMS SQL Backup.

Значения заданных параметров отображаются под имененем экземпляра SQL Server.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения для инсталлятора

В диалоге Connection for [instance_name] задайте логин SQL Server, который будет использоваться инсталлятором.

Stand-alone installer - Configuring service settings - Connection dialog

Connection settings

Задайте тип аутентификации на SQL Server: RadioButton Windows authentication or RadioButton SQL Server authentication.

RadioButton Windows authentication

Программа распознает текущего пользователя по его доменному имени и паролю. Имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

RadioButton SQL Server authentication

Программа распознает пользователя на сервере по заданным имени и паролю.

При выборе этой опции следует указать имя и пароль в полях User и Password соответственно.

Важно: Заданный логин должен принадлежать роли 'sysadmin'.

SQL Server port

TCP/IP Порт подключения к серверу.

После задания настроек нажмите кнопку Check connection, чтобы проверить, что указанный логин может использоваться для работы инсталлятора: указанный логин существует, введен правильный пароль, и логин принадлежит роли 'sysadmin'.


Задание параметров отказоустойчивости службы

Если сервер, на который происходит установка серверных компонентов, сконфигрурирован как отказоустойчевый кластер, то в мастере установки появится шаг задания параметров кластера. На этом шаге нужно задать ресурсы, которые могут быть использованы для конфигурации отказоустойчивости службы EMS SQL Backup.

Stand-alone installer - Cluster settings

Для обеспечения выполнения политик на отказоустойчивом кластере SQL Server, служба EMS SQL Backup должна быть установлена и сконфигурирована как кластерная (отказоустойчивая).

Для этого необходимо, чтобы на сервере было выделено хранилище, не используемое другими кластерными службыми, и на этом хранилище выделен раздел, который может быть использован службой EMS SQL Backup.

Storage settings

В выпадающем списке Available storage выберите диск, который будет использован службой EMS SQL Backup. В списке отображаются только диски, не используемые другими кластерными службами.

В списке Partition выберите доступный раздел диска.

Network settings

В этом разделе задайте сетевые параметры кластерной службы.

В поле Network выберите имя сети кластера, в которой будет доступна служба EMS SQL Backup. В поле IP address for service задайте IP-адрес, который будет использоваться службой. Может быть задан только свободный IP-адрес, принадлежащей выбранной сети.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге Вы можете посмотреть лог выполняемой операции.

Stand-alone installer - Performing operation

После завершения операции Вы можете скопировать лог с помощью пунктов контекстного меню Copy или Copy All.

<< Предыдущий шаг


Свойства серверных компонентов

Информацию, которую задавали при установке серверных компонентов, можно просмотреть в окне Server-side components Properties.

Чтобы открыть это окно, необходимо в контекстном меню сервера выбрать пункт ServerProperties Server-side components Properties.

Параметры аутентификации

Настройки электронной почты

Настройки хранения лога

Настройки хранения резервных копий

Смотрите также:

Мастер регистрации сервера

Установка серверных компонентов EMS SQL Backup

Обновление серверных компонентов

Свойства сервера


Параметры аутентификации

В разделе SQL Server connection settings for server-side components задается способ идентификации пользователя на сервере.

В этом диалоге, в отличие от Свойств сервера, задаются параметры учетной записи SQL Server, которая будет использоваться для подключения службой, установленной на сервере.

RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

При выборе SQL Server authentication следует указать имя и пароль в полях User name и Password соответственно.

Connection Timeout

Время ожидания в секундах при подключении к SQL Server.

RadioButton SQL Backup built-in

При выборе этой опции все политики, развернутые на сервере, будут запускаться по встроенному планировщику EMS SQL Backup.

RadioButton SQL Server Agent

При выборе этой опции все политики будут преобразованы в задания SQL Server Agent. Текущее состояние SQL Server Agent отображается справа от опции.

CheckBox Show Debug Info - отображать отладочную информацию в логах сервера.

Настройки электронной почты


Настройки электронной почты

На этой вкладке можно задать настройки электронной почты, которая будет использоваться для отправки уведомлений политик.

CheckBox Send notifications by Email

Установите этот флажок, чтобы разрешить отправку уведомлений служб по электронной почте.

Email service settings

SMTP server

Укажите SMTP-сервер для mail agent.

Port

Укажите SMTP порт для mail agent.

CheckBox Use SSL/TLS

Установите это флажок для включения SSL/TLS шифрования соединения c почтовым сервером.

Login

Имя пользователя для доступа к mail agent.

Password

Пароль для доступа к mail agent.

Send from

Укажите адрес электронной почты, который будет отображаться в качестве адреса отправителя в сообщении электронной почты.

Test address

Нажмите кнопку, чтобы отправить тестовое сообщение получателю для проверки правильности указанных настроек.

Параметры аутентификации


Настройки хранения лога

На вкладке Log storage settings задайте параметры хранения записей лога SQL Backup для выбранного сервера. В файле лога хранятся записи о запусках пользовательских задач и политик, а также записи о резервных копиях баз данных.

Capacity of task log storage

Задайте количество записей лога выполнения задач, которое будет храниться в программе. Как только количество сохраненных записей превысит заданное количество, программа автоматически удалит старые записи.

Capacity of backups log storage

Задайте количество записей в истории резервных копий. Как только количество записей истории превысит заданное количество, программа автоматически удалит старые записи из истории резервных копий.

CheckBox Delete backup history for dropped databases

Установите этот флажок, чтобы обеспечить удаление всей информации о резервных копиях БД в хранилище SQL Backup при удалении самой БД. Очистка истории достигается за счет срабатывания DDL триггера на удаление БД, таким образом, неважно, как именно удаляется БД.

При достижении хранилищем максимально возможного размера 3,9Гб Вы получите предупреждение 'Log size is exceeded', информирующее о том, что необходимо удалить старые записи, уменьшив значения параметров. Это сообщение появляется при подключении к серверу, а также отображается в окне информации о сервере до тех пор, пока не будет выполнена операция по очистке истории или автоматическое усечение хранилища.

Усечение файла (удаление записей) может происходить спустя некоторое время после достижения граничных значений.


Настройки хранения резервных копий

На вкладке Backup settings задайте директорию на сервере, которая по умолчанию будет использоваться для хранения файлов резервных копий.

Backup folder

В этом поле укажите директорию, в которой будут храниться файлы резервных копий баз данных. Чтобы открыть диалог выбора папок на сервере, нажмите кнопку EllipsisButton .

Важно: При настройке параметров резервного копирования для этой папки будет использоваться тэг {backup_root_folder}.


Свойства сервера

В этом диалоговом окне можно просмотреть свойства зарегистрированного сервера.

Чтобы открыть это окно, необходимо в контекстном меню сервера выбрать пункт btnDBProperties Server Properties.

Параметры подключения

Дополнительные опции

Смотрите также:

Мастер регистрации сервера

Установка серверных компонентов EMS SQL Backup

Обновление серверных компонентов

Свойства серверных компонентов


Параметры подключения

На этой вкладке отображаются параметры подключения к серверу.

Server properties - Server connection info

Server Name

Имя сервера.

Alias

Псевдоним сервера, под которым он отображается в списке серверов.

В разделе Authentication задается способ идентификации пользователя на сервере.

RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

При выборе SQL Server authentication следует указать имя и пароль в полях User name и Password соответственно.

Timeout

Время ожидания в секундах при подключении к SQL Server.

Test Connection

Можно проверить имеется ли в настоящее время соединение с указанным сервером, нажав на кнопку Test Connection.

Дополнительные опции


Дополнительные опции

На этой вкладке отображаются дополнительные параметры зарегистрированного сервера.

Server properties - Server options

В поле Description указано описание сервера.

CheckBox Connect automatically on Console startup - при запуске программы EMS SQL Backup связь с этим сервером будет устанавливаться автоматически.

Параметры подключения


Получение бэкапа с сервера

Мастер Get Backup Files from Server позволяет Вам перенести файлы резервных копий с выбранного сервера на жесткий диск компьютера, на котором запущена программа EMS SQL Backup Administration Console. Для получения файлов с сервера необходимо только подключение к SQL серверу.

Чтобы запустить этот мастер необходимо выбрать пункт GetBackupToConsole Get Backup Files from Server в контекстном меню сервера в проводнике или на панели инстурментов.

Шаги:

Выбор резервной копии

Выбор файлов

Просмотр сводной информации

Смотрите также:

Резервное копирование базы данных

Восстановление баз данных из резервной копии


Выбор резервной копии

На первом шаге мастера Вам необходимо выбрать резервную копию на сервере и задать папку на локальном диске, в которой будут сохранены файлы резервных копий.

Get backup to console - Specifying source

Backup provider

Выберите механизм, с помощью которого была создана резервная копия.

RadioButton EMS SQL Backup

Резервная копия была создана средствами EMS SQL Backup.

RadioButton SQL Server

Резервная копия была создана средствами SQL сервера.

Backup source

RadioButton History - история резервного копирования. Отображаются резервные копии только выбранного типа.

RadioButton Select files - файлы резервных копий.

Server

Из этого раскрывающегося списка нужно выбрать сервер, на котором расположена база данных, резервную копию которой необходимо получить.

Database

Из этого раскрывающегося списка необходимо выбрать базу данных, резервную копию которой необходимо получить.

Если в качестве источника резервной копии была выбрана History, то в списке будут отображаться существующие копии выбранной базы данных. Необходимо выбрать одну из них для передачи. Первоначально в списке отображается только 20 последних записей истории. Чтобы отобразить более старые резервные копии, необходимо нажать кнопку Get more...

Если в качестве источника резервной копии были выбраны файлы, то необходимо добавить нужные файлы в список вручную.

Get backup to console - Specifying backup files

Для каждого выбранного файла отображается дополнительная информация.

Date - дата создания;

Database - база данных, для которой была создана резервная копия;

Type - тип резервной копии;

Encrypted - зашифрован файл или нет;

First LSN - первый регистрационный номер транзакции в файле;

Storage name - имя и адрес файла резервной копии;

Last LSN - последний регистрационный номер транзакции в файле;

Check Point LSN - регистрационный номер контрольной точки;

Differential Base LSN - регистрационный номер транзакции

Add Local File

Нажав на эту кнопку, можно выбрать файл, расположенный на выбранном сервере. Если резервная копия состоит из нескольких файлов (опция доступная для резервных копий типа EMS SQL Backup), то необходимо выбрать первый файл из списка. Для выбора остальных вариантов добавления файлов необходимо нажать смежную кнопку со стрелкой вниз.

Add Network File

По нажатию на эту кнопку будет открыт стандартный диалог ОС выбора файлов, в котором можно выбрать файл из сетевого окружения клиентской машины.

Add Cloud File

При нажатии на эту кнопку появляется диалог Select cloud. В этом диалоге необходимо добавить облачное хранилище, в котором находится необходимый файл резервной копии.

Restore Database Wizard - Files - Add cloud

Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Если Вы создаете новое подключение, то после настройки его параметров Вам будет предложено сохранить его.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

После того как добавлено облачное хранилище, нажмите кнопку Ok, чтобы запустить процесс получения файлов из хранилища. Если подключение к хранилищу установлено и у заданного пользователя достаточно прав на получения списка файлов, то появится диалог Select file. В этом диалоге будет отображаться список файлов, загруженных в хранилище.

Restore Database Wizard - Files - Files on cloud

Выберите необходимый файл резервной копии и задайте локальную директорию, в которую он будет загружен, в поле Local path for download. После нажатия OK программа предложит скачать выбранный файл на сервер. Переход на следующий шаг будет возможен только после успешного скачивания файла.

Cross1 Remove - удалить выбранный файл.

ClearList Clear - удалить все выбранные файлы.

Если в качестве источника была выбрана History, то следующим шагом будет Выбор файлов.

Если в качестве источника были выбраны Select files, то следующим шагом будет Просмотр сводной информации.


Выбор файлов

На этом шаге необходимо выбрать файла резервной копии, которые необходимо получить с сервера на локальный диск. В списке отображаются файлы, составляющие резеврную копию базы данных, выбранной на первом шаге.

Get backup to console - Selecting files

Если файл не найден на сервере, о чем свидетельствует иконка статуса NotFoundBackup, то становится доступна кнопка Find in cloud FindInCloud . Нажмите эту кнопку, чтобы выбрать облачные хранилища для поиска файла. Если файл будет найден в одном из хранилищ, его иконка статуса изменится на FoundInCloud , и при нажатии Next, программа предложит скачать файл или несколько файлов.

После того как Вы выбрали необходимые файлы, нажмите кнопку Next, чтобы перейти на шаг Просмотр сводной информации.


Просмотр сводной информации

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Get backup to console - Summary

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.


Reports

SQL Backup
  • Index
  • « Prev
  • Next »

Отчеты

Используя отчеты, Вы можете просматривать информацию о выполнении задач, отображаемую на странице Launches, и сохранять ее в одном из предложенных форматов.

Чтобы открыть отчет по выполнению задач или политик, необходимо нажать кнопку Reports Report на панели инструментов или выбрать в контекстном меню задачи пункт Reports Show Report.

Отчет отображается в специальном окне просмотра - Preview.

В этом окне предоставлены инструменты для работы с отчетом.

Существует три типа отчетов:

  • Отчет по политике, запущенной на одном сервере

Открыть отчет этого типа можно, когда в проводнике выбран один сервер. Если при этом в окне Policies выбрана политика, которая развернута на нескольких серверах, то отчет будет содержать информацию по запускам политики только на выбранном сервере. В отчете отображается краткая информация о задачах в политике: имя задачи, запланированное время запуска, время запуска, время окончания выполнения и статус выполнения задачи.

  • Отчет по политике, запущенной на нескольких серверах

Открыть отчет этого типа можно, когда в окне Policies выбрана политика, запущенная на нескольких серверах. Кроме того, в проводнике должна быть выбрана группа или решение. В этом отчете отображается краткая информация о задачах в политике: имя задачи, имя сервера, запланированное время запуска, время запуска, время окончания выполнения и статус выполнения задачи.

  • Подробный отчет по задачам в политике

Открыть отчет этого типа можно, когда в окне Policies выбрана конкретная задача политики. В этом отчете отображается подробная информация о выбранной задаче: имя задачи, имя шага, запланированное время запуска, время запуска, время окончания выполнения, статус выполнения задачи/шага и сообщение о выполнении задачи/шага (информационное сообщение, предупреждение или ошибка).

Главное меню

File

Preview - page setup Page Setup - задать настройки и формат страницы отчета.

Preview - Print settings Print... - задать настройки печати страницы.

Preview - Print Print - печать отчета.

Preview - Export Docunemt Export Document - экспортировать отчет в один из доступных форматов (PDF file, HTML file, MHT file, RTF file, Excel file, CSV file, Text file).

Preview - Send via E-mail Send via E-mail - отправить отчет по электронной почте.

View

  • Page layout: Facing or Continuous - изменить макет страницы.
  • Enable/Disable toolbar - отобразить/скрыть панели инструментов.
  • Enable/Disable status bar - отобразить/скрыть панели статусов.
  • Customize toolbar - настроить панели инструментов.

Background

Preview - Color Color - задать цвет фона отчета.

Preview - Watermark Watermark - задать водяные знаки для отчета.

Панель инструментов

  • Search - найти указанный текст в отчете.
  • Open a document - открыть файл отчета.
  • Save the document - сохранить отчет во внешний файл *.prnx.
  • Print... - задать настройки печати страницы.
  • Quick Print - печать отчета.
  • Page Setup - задать настройки и формат страницы отчета.
  • Scale - задать настройки масштабирования.
  • Enable/Disable hand tool - включить-отключить инструмент прокрутки "рука".
  • Задать размер отображения страницы.
  • Перемещаться по страницам документа отчета.
  • Color - задать цвет фона отчета.
  • Watermark - задать водяные знаки для отчета.
  • Export Document - экспортировать отчет в один из доступных форматов (PDF file, HTML file, MHT file, RTF file, Excel file, CSV file, Text file).
  • Закрыть окно просмотра отчетов.


Управление политиками обслуживания

При переходе на вкладку Policies открывается рабочая область для управления политиками обслуживания.

Политика (Policy) – это совокупность операций (операций обслуживания), которые должны быть произведены над базами и серверами и набора расписаний, в соответствии с которым эти операции будут выполнены. Политика реализована в виде набора задач SQL сервера и для их выполнения необходим SQL Agent.

Пользователь может запланировать одну или несколько задач к выполнению в соответствии с определенными расписаниями. Эти задачи могут затрагивать различное количество баз на разных серверах. Политика может быть создана как для отдельного сервера, так и для группы (Group) серверов или решения (Solution). Для этого необходимо запускать Мастер создания политик из контекстного меню соответствующих элементов (сервера, группы или решения).

Выполнение каждой политики отображается в Статусе выполнения, в котором сообщается об успешном выполнении или возникших при выполнении ошибках. Также статус выполнения политик отображается в статусе сервера.

Политики, имеющие ошибки, можно исправить и перезапустить или игнорировать.

Для просмотра статусов политик и процесса их выполнения можно перейти на вкладки Servers и Activities.

Для начала работы с политиками необходимо их создать. Для этого необходимо в контекстном меню в проводнике выбрать пункт CreatePolicy Create New Policy или CopyFromTemplate Create Policy from Template.

Также можно создать шаблон на основе существующей политики с помощью команды CreateTemplateFromPolicy Create Template from Policy.

Существует два режима просмотра политик на вкладке Policies: Policy Tasks и Policy Servers.

На вкладке Policy Tasks отображается содержимое выбранной политики, сгруппированное по шагам.

На вкладке Policy Servers отображается содержимое выбранной политики, сгруппированное по серверам.

В нижней части, в разделе Details, отображается дополнительная информация по выбранному в разделе Policy объекту.

Смотрите также:

Начало работы

Управление серверами

Шаблоны

Активность

Операции обслуживания

Опции


Контекстное меню

Контекстное меню - это список действий, который можно открыть, нажав правой кнопкой мыши на объекте в проводнике баз данных.

Для объектов вкладки Policies отображаются следующие контекстные меню:

  • Контекстное меню политики
  • Контекстное меню задачи
  • Контекстное меню шага
  • Контекстное меню расписания
  • Контекстное меню сервера


Контекстное меню политики

При нажатии правой кнопкой на политике в списке политик появляется контекстное меню политики.

С его помощью можно выполнить следующие действия.

CreatePolicy Create New Policy - создать новую политику;

CopyFromTemplate Create Policy from Template - создать политику на основе шаблона;

EditPolicy Edit policy - изменить выбранную политику;

DeletePolicy Delete policy - удалить политику;

CreateTemplateFromPolicy Create Template from Policy - создать шаблон на основе политики;

Show History - показать историю выполнения политики.


Контекстное меню задачи

При нажатии правой кнопкой на задаче в списке задач появляется контекстное меню задачи.

С его помощью можно выполнить следующие действия:

Task popup menu

Add Task - добавить задачу в политику;

Add Task from Template - создать задачу в политике на основе шаблона задачи;

Edit Task - открыть задачу в Редакторе задач;

Remove Task - удалить задачу из политики;

Expand Expand All развернуть список задач;

Collapse Collapse All - свернуть список задач;

Show History - просмотреть историю запусков задачи;

CopyMenu Copy - скопировать выбранную задачу;

CutMenu Cut - вырезать выбранную задачу;

PasteMenu Paste - вставить скопированную задачу.


Контекстное меню шага

При нажатии правой кнопкой на шаге в списке задач появляется контекстное меню шага.

С его помощью можно выполнить следующие действия:

Step popup menu2

Edit Step - открыть шаг в Редакторе операции обслуживания;

Expand Expand All развернуть список задач;

Collapse Collapse All - свернуть список задач.


Контекстное меню расписания

При нажатии правой кнопкой на расписании в списке задач появляется контекстное меню расписания.

С его помощью можно выполнить следующие действия:

Schedule context menu

Add Schedule - добавить расписания в задачу;

Add Schedule from Template - создать расписание в задаче на основе шаблона расписания;

Edit Schedule - открыть шаг в Редакторе расписаний;

Remove Schedule - удалить расписание из задачи;

Expand Expand All развернуть список задач;

Collapse Collapse All - свернуть список задач;

CopyMenu Copy - скопировать выбранное расписание;

CutMenu Cut - вырезать выбранное расписание;

PasteMenu Paste - вставить скопированное расписание.


Контекстное меню сервера

При нажатии правой кнопкой на сервере в списке задач появляется контекстное меню сервера.

С его помощью можно выполнить следующие действия:

Policy_server context menu

Exclude server from Task - удалить сервер из операции обслуживания;

Expand Expand All развернуть список задач;

Collapse Collapse All - свернуть список задач;

Show History - показать историю выполнения политик на сервере.

Важно: Если операция обслуживания развернута только на одном сервере, его нельзя удалить из списка. Вместо этого, Вы можете удалить шаг из задачи.


Мастер создания политик

С помощью мастера Policy wizard можно пошагово создать политику.

Запустить этот мастер можно одним из следующих способов:

  • на вкладке Policies выбрать пункт контекстного меню CreatePolicy Create New Policy;
  • на вкладке Servers выбрать пункт Policy Maintenance Policies | CreatePolicy Create New Policy из контекстного меню Базы данных/Сервера/Группы серверов.

Перед тем, как откроется мастер создания политик, появится диалоговое окно Select servers for policy. В этом окне надо будет выбрать сервер, группу или решение, для которых будет создана политика. При выборе группы или

решения политика будет создана для всех серверов, которые в них входят.

Creating_from_template - Select Server

Важно: Создание политики для базы данных означает создание политики для сервера, на котором хранится база данных. Эта база данных будет отмечена по умолчанию на тех шагах мастера, на которых требуются выбор базы данных.

Список шагов:

Задание имени и описания политики

Определение набора задач

Определение параметров уведомлений

Выполнение операции

Смотрите также:

Выполнение политик

Редактор политик

Конвертация планов обслуживания


Задание имени и описания политики

На первом шаге необходимо указать имя политики и ее описание в полях Name и Description соответственно.

Setting policy name and description

In different time zones schedule tasks on basis of

При нахождении обслуживаемого сервера в другом часовом поясе может возникнуть необходимость выбора времени, по которому будет происходить запуск выполнения политики. Если задача должна запускаться в строго определенное время, например, когда сервер не загружен, то выберите запуск по часовому поясу сервера.

Если серверное время запуска задачи не имеет значения, или для шага политики требуется, чтобы задача запускалась строго одновременно на всех серверах, то необходимо использовать Home time zone.

RadioButton Use local server time - использовать для планирования запусков часовой пояс, в котором расположен сервер.

RadioButton Use local Console time as absolute time - использовать для планирования запусков часовой пояс, заданный в Основных настройках. Рекомендуется использовать эту опцию, чтобы синхронизировать выполнение операций в задаче "Доставка журналов".

Следующий шаг >>


Определение набора задач и расписаний

На этом шаге необходимо создать задания, которые будут выполняться в политике.

Defining set of tasks

Управлять задачами можно с помощью кнопок, расположенных справа от списка.

AddTask Create new - создать новую задачу.

CreateTaskFromTemplate Creating new from template - создать новую задачу на основе шаблона. В этом случае будет предложено выбрать один из шаблонов в открывшемся окне.

EditTask Edit - редактировать задачу.

DeletePolicyTask Delete - удалить задачу.

CopyToTemplates Copy to templates - сохранить задачу как шаблон.

С помощью следующих кнопок Вы можете быстро копировать и перемещать задачи в рамках одной политики:

Copy - скопировать выбранный объект,

Paste - вставить скопированный объект.

При создании объекта на основе шаблона появляется диалоговое окно со списком существующих шаблонов.

Maintenance Policies - SelectingTemplate

<< Предыдущий шаг

Следующий шаг >>


Определение параметров уведомлений

Администратор EMS SQL Backup может получать сообщения на e-mail о результатах запуска политик.

На этом шаге необходимо задать параметры уведомлений, которые будут применены ко всем задачам внутри политики.

Defining notification options

В списке Servers необходимо отметить серверы, для которых должны приходить оповещения о выполнении политик.

Notify

Тип генерируемого сообщения выбирается из этого списка.

When the policy succeeds - отправлять сообщение о том, что политика была выполнена успешно.

When the policy fails - отправлять сообщение о том, что политика не была выполнена.

When the policy completes - отправлять сообщение о том, что политика запускалась, независимо от результата выполнения.

В поле Send E-mail to необходимо ввести e-mail адрес оператора, которому будет отправляться сообщения, генерируемые при выполнении политики. Вы можете ввести несколько адресов, разделяя их запятыми.

CheckBox Include detailed log

Если флажок установлен, то программа будет присылать полный лог выполнения политики, в противном случае тело присылаемого письма будет содержать только статус выполнения.

Важно: Для работы уведомлений необходимо, чтобы были заданы настройки электронной почты.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно увидеть значения всех заданных на предыдущих шагах опций.

Если все задано верно, то можно начать выполнение операции, нажав кнопку Finish.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Policy editor

SQL Backup
  • Index
  • « Prev
  • Next »

Редактор политик

В редакторе политик можно вносить изменения в уже существующую политику.

Открыть политику для просмотра и изменения можно одним из следующих способов:

  • на вкладке Policies дважды щелкнуть мышкой на нужной политике;
  • на вкладке Policies, на панели инструментов выбрать пункт EditPolicy Edit Policy;
  • на вкладке Policies, в контекстном меню политики выбрать пункт EditPolicy Edit Policy.

Вкладки редактора

Задание имени и описания политики

Определение набора задач и расписаний

Настройка уведомлений

Смотрите также

Конвертация планов обслуживания

Шаблоны политик

Выполнение политик

История политик


Задание имени и описания политики

На этой вкладке отображаются имя политики и ее описание в полях Name и Description соответственно.

Policy Editor - Name and description

In different time zones schedule tasks on basis of

При нахождении обслуживаемого сервера в другом часовом поясе может возникнуть необходимость выбора времени, по которому будет происходить запуск выполнения политики. Если задача должна запускаться в строго определенное время, например, когда сервер не загружен, то выберите запуск по часовому поясу сервера.

Если серверное время запуска задачи не имеет значения, или для шага политики требуется, чтобы задача запускалась строго одновременно на всех серверах, то необходимо использовать Home time zone.

RadioButton Use local server time - использовать для планирования запусков часовой пояс, в котором расположен сервер.

RadioButton Use local Console time as absolute time - использовать для планирования запусков часовой пояс, заданный в Основных настройках. Рекомендуется использовать эту опцию, чтобы синхронизировать выполнение операций в задаче "Доставка журналов".


General

SQL Backup
  • Index
  • « Prev
  • Next »

Определение набора задач и расписаний

На этой вкладке можно просмотреть и при необходимости изменить список задач.

В состав политики должен входить комплекс запланированных задач, каждая из которых содержит хотя бы одну операцию обслуживания.

Policy Editor - General

Управлять задачами можно с помощью кнопок, расположенных справа от списка.

AddTask Create new - создать новую задачу.

CreateTaskFromTemplate Creating new from template - создать новую задачу на основе шаблона. В этом случае будет предложено выбрать один из шаблонов в открывшемся окне.

EditTask Edit - редактировать задачу.

DeletePolicyTask Delete - удалить задачу.

CopyToTemplates Copy to templates - сохранить задачу как шаблон.

С помощью следующих кнопок Вы можете быстро копировать и перемещать задачи в рамках одной политики:

Copy - скопировать выбранный объект,

Paste - вставить скопированный объект.

При создании объекта на основе шаблона появляется диалоговое окно со списком существующих шаблонов.

Maintenance Policies - SelectingTemplate


Настройка уведомлений

На этой вкладке можно просматривать и изменять параметры уведомлений.

Policy Editor - Notification

В списке Servers необходимо отметить серверы, для которых должны приходить оповещения о выполнении политик.

Notify

Тип генерируемого сообщения выбирается из этого списка.

When the policy succeeds - отправлять сообщение о том, что политика была выполнена успешно.

When the policy fails - отправлять сообщение о том, что политика не была выполнена.

When the policy completes - отправлять сообщение о том, что политика запускалась, независимо от результата выполнения.

В поле Send E-mail to необходимо ввести e-mail адрес оператора, которому будут отправляться сообщения, генерируемые при выполнении политики.

CheckBox Include detailed log

Если флажок установлен, то программа будет присылать полный лог выполнения политики, в противном случае тело присылаемого письма будет содержать только статус выполнения.

Важно: Для работы уведомлений необходимо, чтобы были заданы настройки электронной почты.


Конвертация планов обслуживания

С помощью этого мастера Вы можете преобразовать планы обслуживания, созданные в Management Studio для SQL Server, в политики EMS SQL Backup. Преобразованы могут быть только планы обслуживания с линейной структурой.

Важно: Рекомендуется отключить Планы обслуживания после преобразования, чтобы избежать побочных эффектов.

Важно: Для выполнения конвертации необходимо иметь установленные службы SQL Server Integration Services.

Чтобы произвести преобразование плана обслуживания в политику необходимо выбрать в контекстном меню сервера, групп, группы или базы данных пункт Policy Maintenance Policies | ConvertfromMaintenanceplan Convert from Maintenance plan.

Важно: Если на сервере нет доступных планов обслуживания, этот пункт не будет отображаться в контекстном меню.

Список шагов:

Приветственный шаг

Выбор плана обслуживания для конвертации

Просмотр результатов конвертации

Выполнение операции

Смотрите также:

Выполнение политик

Редактор политик

Мастер созданий политик


Welcome

SQL Backup
  • Index
  • « Prev
  • Next »

Приветственный шаг

С помощью этого мастера можно преобразовать планы обслуживания SQL Server в политики EMS SQL Backup.

Следующий шаг >>


Выбор плана обслуживания для конвертации

На этом шаге отображается список планов обслуживания SQL Server.

Из этого списка надо выбрать один из существующих планов. Этот план будет преобразован в политику на следующем шаге.

<< Предыдущий шаг

Следующий шаг >>


Просмотр результатов конвертации

На этом шаге проводится анализ выбранного плана обслуживания и конвертация его в политику.

При конвертации могут возникнуть ошибки. Политику с ошибкой можно открыть и исправить в редакторе политик, с помощью кнопки Edit Policy.

Если установить флажок CheckBox Disable Maintenance plan, то все задачи исходного плана обслуживания будут отключены.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге отображаются параметры, заданные на предыдущих шагах.

Для завершения выполнения операции и размещения политики на сервере нажмите кнопку Finish.

<< Предыдущий шаг


Выполнение политик

Политики выполняются в соответствии с заданными расписаниями.

Запустить выполнение политики вручную можно на вкладке Servers. Для этого на вкладке Servers в разделе Policies необходимо выбрать в раскрывающемся меню нужной политики пункт RunPolisy Execute Policy.

Если политика выполняется для одного сервера, а в ней есть задачи для другого сервера, то в открывшемся диалоговом окне будет предложен выбор доступных серверов.


Статусы политик

Waiting - задача не была выполнена и находится в ожидании запуска.

Success – выполнение задачи прошло успешно.

Warning - задача была выполнена с незначительными ошибками. В предупреждениях сообщается о несоответствующих регистрируемых параметрах сервера и некоторых других неполадках при выполнении, которые не влияют на конечный результат.

Failed – не удалось выполнить задачу.

Executing – задача выполняется в настоящий момент.

Aborted – выполнение задачи было остановлено.

Missed – ожидаемое время запуска выполнения задачи прошло, но запуск не был произведен.

Unknown – информация о выполнении задачи не может быть получена до установления соединения с сервером.

Ignored (статус задачи) – при устранении проблем задача была помечена, как игнорируемая.

Общий статус сервера формируется на основе статусов всех развернутых на нем политик.

Если у всех политик на сервере статус Success, то статус сервера будет Policies are successful.

Если хотя бы у одной политики на сервере статус Warning, то статус сервера Policies have warnings.

Если хотя бы у одной политики на сервере статус Failed, то статус сервера Policies have problems.

Общий статус группы или решения формируется на основе статусов политик серверов, которые в него включены.

Если у всех политик на всех серверах в группе/решении статус Success, то статус группы/решения будет Policies are successful.

Если хотя бы у одной политики хотя бы на одном сервере в группе/решении статус Warning, то статус группы/решения Policies have warnings.

Если хотя бы у одной политики хотя бы на одном сервере в группе/решении статус Failed, то статус группы/решения Policies have problems.


Синхронизация информации о политиках

При установлении соединения с сервером происходит сравнение конфигураций политик, хранящихся на сервере и в EMS SQL Backup Console. При несоответствии информации в зависимости от вида рассинхронизации появляются информационные сообщения.

Update Policy - если политика, была изменена при отсутствии соединения с сервером.

Если измененная политика была развернута только на одном сервере, то предлагается обновить серверную рабочую копию политики на основе конфигурации EMS SQL Backup Console.

Если измененная политика была развернута на нескольких серверах, то предлагается обновить серверную рабочую копию имеющейся политики на основе конфигурации EMS SQL Backup Console или развернуть политику отдельно на этом сервере.

Update policy from service

Install Policy - если политика была создана при отсутствии соединения с сервером. Предлагается создать серверную рабочую копию.


История запусков

Все запуски задач политик отображаются в списке Launches на вкладке Servers.

Информация о запусках приведена в виде таблицы со следующими столбцами:

  • Name - имя политики/задачи/шага;
  • Planned Start - запланированное время запуска;
  • Started - время запуска;
  • Finished - время завершения;
  • Status - статус выполнения;
  • Message - сообщение о ходе выполнения.

Вы можете просмотреть подробную информацию о выполнении каждого шага, нажав на кнопку Show details в колонке Message для выбранного шага.

Launches - Show details

В появившемся диалоге отображается следующая информация о выполнении шага:

  • Started - время запуска;
  • Finished - время завершения;
  • Status - статус выполнения;
  • Message - детальная информация о ходе и результатах выполнения. Если статус выполнения шага Failed, то в этом поле будет описана причина неудачного выполнения шага.


Устранение проблем выполнения

Если при выполнении политики возникли проблемы, то можно повторно выполнить задачи политики, помечая при этом ошибочные запуски статусом Ignored.

Для этого необходимо на вкладке Servers в разделе Policies выбрать в раскрывающемся меню нужной политики пункт Resolve the problem.

Mark problem task(s) launches as ignored - игнорировать запуски задач с ошибками.

Run problem task(s) - запустить задачи, при выполнении которых возникли проблемы.


История политик

С помощью этого инструмента можно просматривать историю запуска и выполнения политик.

Для просмотра истории выполнения всех политик сервера или группы серверов необходимо в соответствующем контекстном меню выбрать пункт [image] Show History.

Для просмотра истории выполнения конкретной политики необходимо в контекстном меню этой политики выбрать пункт [image] Show History.

Для просмотра истории выполнения политик для конкретной базы в контекстном меню базы выбрать пункт [image] Show History.

Policy History Viewer

В главном окне отображается таблица с полной информацией о каждом запуске политик:

Time - время запуска;

Status - статус политики;

Policy - имя политики;

Task - название политики;

Server - сервер политики;

Message - информационное сообщение.

Для каждой политики в раскрывающемся подуровне отображается информация о выполнении каждой задачи:

Time - время запуска;

Result - результат выполнения;

Step - название шага;

Server - сервер политики;

Message - информационное сообщение;

Duration - продолжительность выполнения;

Details - дополнительная информация.

Эта таблица является настраиваемой. Можно выбрать отображаемые столбцы, сортировать, группировать и отбирать нужные данные.

Отображаемую информацию о выполнении политик можно сохранять во внешние файлы.

Export to HTML - сохранить текущее состояние истории во внешний HTML файл;

Export to text - сохранить текущее состояние истории во внешний текстовый файл.

Обновить отображаемую информацию можно с помощью кнопки Refresh Refresh, находящейся на одной из панелей инструментов.


Панели инструментов

Панели инструментов располагаются слева от редактора и над окном просмотра истории политики.

Навигационная панель

PolicyHistory - Using Navigation bar

RadioButton One day

Показать историю политики за один день.

RadioButton One week

Показать историю политики за неделю.

RadioButton Custom

Задать промежуток времени, за которое следует показывать историю политики. С помощью полей from и to задайте, с какого момента и до какого времени Вы хотите просмотреть историю.

Нажмите кнопку Apply, чтобы отобразить историю политики за указанное время.

Export

Export to HTML

Сохранить текущее состояние истории во внешний HTML файл. По умолчанию создаваемый файл будет сохранен в папке программы.

Export to text

Сохранить текущее состояние истории во внешний текстовый файл. По умолчанию создаваемый файл будет сохранен в папке программы.

Панель инструментов

Все инструменты навигационной панели доступны на панели инструментов. Панель инструментов - ToolBar - расположена в верхней части окна.


Sorting

SQL Backup
  • Index
  • « Prev
  • Next »

Сортировка

В любой таблице EMS SQL Backup можно выполнить сортировку значений в столбце.

Чтобы отсортировать данные необходимо:

  • Нажать на заголовок этого столбца мышкой. Если столбец не был отсортирован, то одно нажатие отсортирует его по возрастанию, следующее - по убыванию. Индикатором сортировки служит стрелочка в заголовке столбца.
  • В контекстном меню заголовка выбрать пункт: btnSortAscending Sort Ascending - сортировать по возрастанию или btnSortDescending Sort Descending - сортировать по убыванию.

Убрать сортировку

чтобы убрать сортировку, необходимо в контекстном меню заголовка столбца выбрать пункт Clear Sorting.


Группировка

Группировку по столбцам в EMS SQL Backup можно осуществлять в диалоговых окнах История политик и Доступные резервные копии.

Группировать

Группировка осуществляется с помощью панели группировки, расположенной над заголовками столбцов таблицы. Чтобы активизировать эту панель, необходимо в контекстном меню заголовка столбца выбрать пункт btnGroupByBox Group By Box.

Чтобы сгруппировать таблицу по одному или нескольким столбцам, необходимо перетащить заголовки столбцов на панель группировки, расположенную над таблицей, или в контекстном меню заголовка нужного столбца выбрать пункт btnGroupByThisColumn Group by this column.

Сгруппированные данные отображаются в виде таблицы со свернутыми подуровнями.

Чтобы развернуть все подуровни, используйте пункт контекстного меню области группировки FullExpand Full Expand.

Чтобы свернуть все подуровни, используйте пункт контекстного меню области группировки FullCollapse Full Collapse.

Grouping by two columns

Убрать группировку

  • Переместить заголовок столбца с панели группировки на его прежнее место.
  • Выбрать в контекстном меню области группировки пункт ClearGrouping Clear grouping.
  • В контекстном меню заголовка столбца, по которому выполнена группировка, выбрать пункт Ungroup UnGroup.

Выбор видимых столбцов

Можно указывать, какие из существующих столбцов таблицы будут отображаться.

Делается это с помощью пункта контекстного меню Column Chooser. По нажатию на эту кнопку появляется окно, в котором, устанавливая флажки, Вы отмечаете видимые столбцы.


Фильтрация

Для отбора записей таблицы в Истории политик по определенным признакам используется Фильтр.

Можно использовать Настраиваемый фильтр - Custom Filter и Конструктор фильтров - Filter Builder.

Custom Filter

В правом верхнем углу заголовка столбца нажать значок фильтра CustomFilter. Выбрать из раскрывшегося списка одно из условий фильтра - Custom, Blanks (пустые ячейки), Non blanks (непустые ячейки) или одно из значений списка. При выборе Custom задать необходимые параметры отбора в появившемся диалоговом окне.

Custom Auto Filter

В этом диалоговом окне можно задать два условия фильтрации и их отношение - должны ли выполняться оба условия сразу, или достаточно выполнения одного. Установив переключатель в положение RadioButton AND, укажите, что оба условия должны выполняться одновременно, в положение RadioButton OR укажите, что должно выполняться только одно из них.

Custom Auto Filter

Из раскрывающихся списков выбираем условие отбора:

  • равно - equals,
  • не равно - does not equal,
  • больше - is greater than,
  • больше или равно - is greater than or equal to,
  • меньше - is less than,
  • меньше или равно - is less than or equal to,
  • пустые - is blank,
  • непустые - non blank,
  • похоже (для текстовых полей) - like,
  • не похоже (для текстовых полей) - not like.

В поле указываем последовательность символов. Используйте символ "%" для указания любого набора символов и символ "_" для обозначения любого символа. При выполнении условия отбираются только те значения, которые отвечают указанному условию.

Конструктор фильтров

Чтобы запустить конструктор фильтров, необходимо в контекстном меню заголовка столбца выбрать пункт btnFilterEditor Filter Editor.

Добавить или удалить условие или группу условий можно нажатием на кнопки InsertCondition Insert Condition и RemoveCondition Remove Condition соответственно.

Отношение между группами условий определяется групповым оператором, который выбирается из списка, открывающегося по нажатию на надпись And.

And, Or Or, NotAnd Not And, NotOr Not Or, AddCondition Add Condition, AddGroup Condition Group или RemoveGroup Remove Group.

Для головного условия доступен еще пункт ClearAll Clear All, с помощью которого можно удалить все заданные условия.

Условия задаются в строках.

[Название столбца] Условие Значение.

При нажатии на элемент открывается список подстановки.

Чтобы применить фильтр, нажмите кнопку Apply.

Если для таблицы установлен фильтр, то в нижней части появляется панель, на которой отображается условие фильтра.

На этой панели располагаются элементы управления, с помощью которых можно:

  • Удалить фильтр - нажав на кнопку btnClose .
  • Включить фильтр - установить флажок перед условием фильтра.
  • Изменить условия фильтрации с помощью кнопки Edit Filter. Эта кнопка открывает конструктор фильтров.

На этой панели отображается история модификации фильтра, которая открывается при нажатии на раскрывающийся список.

Удалить фильтр

Удалить фильтр и отобразить все записи таблицы можно одним из следующих способов.

  1. В контекстном меню заголовка столбца, по которому задан отбор, выбрать пункт ClearFilter Clear Filter.
  2. Нажать кнопку btnClose на панели фильтра.


Шаблоны

На вкладке Templates расположены инструменты, необходимые для управления шаблонами. Шаблоны разделены на предустановленные (Preset) и пользовательские (Custom).

Для работы с шаблонами необходимо перейти на вкладку Templates.

На вкладке Templates можно работать с шаблонами следующих объектов:

PolicyTemplate Policy Templates - шаблоны политик

TaskTemplate Task Templates -шаблоны задач

StepTemplate Step Templates - шаблоны шагов

ScheduleTemplate Schedule Templates - шаблоны расписаний

Template - Explore

При выборе типа шаблона справа отображается список шаблонов выбранного типа. Управлять шаблонами в этом списке можно с помощью контекстного меню.

AddTemplate Add - добавить шаблон;

EditTemplate Edit - изменить шаблон;

DeleteTemplate Delete - удалить шаблон;

ExportTemplate Export - экспортировать шаблон;

ImportTemplate Import - импортировать шаблон;

CopyTemplate Clone Template - создать копию шаблона.

При установке программы предоставляется набор предустановленных шаблонов.

Все шаблоны можно импортировать и экспортировать во внешний *.xml файл. Для этого в контекстном меню шаблона необходимо выбрать пункт ImportTemplate Import для импорта и ExportTemplate Export для экспорта шаблонов.

Смотрите также:

Начало работы

Управление серверами

Управление политиками обслуживания

Активность

Операции обслуживания

Опции


Шаблоны политик

Для создания новых политик с минимальными затратами времени, необходимо предусмотреть, чтобы часть параметров политики можно было определить заранее, а другую часть можно было добавить непосредственно на этапе создания самой политики. Поэтому определим понятие "шаблон политики". Шаблон политики – это заготовка политики, в которой предопределены некоторые ее составляющие.

На странице Policy Templates можно управлять шаблонами политик программы.

Template - Explore

Управлять шаблонами политик можно с помощью кнопок, расположенных на одной из панелей инструментов, или команд контекстного меню.

Add Add New Template - создать новый шаблон. При выборе этого пункта открывается Мастер создания политик.

Edit Edit Template - редактировать шаблон;

Delete Delete Template - удалить шаблон;

ExportTemplate Export - сохранить шаблон;

ImportTemplate Import - загрузить шаблон;

CopyTemplate Clone Template - создать копию шаблона политики.

Смотрите также:

Шаблоны задач

Шаблоны шагов

Шаблоны расписаний


Создание шаблона на основе политики

Если у Вас уже имеется настроенная политика, Вы можете создать на ее основе шаблон, который впоследствии можно будет использовать для создания новой политики. Он будет содержать все задачи, шаги и расписания с заданными параметрами.

Чтобы создать шаблон на основе политики, выберите ее в списке политик на вкладке Policies, затем выберите пункт CreateTemplateFromPolicy Create Template from Policy ее контекстного меню.

В появившемся диалоге введите имя создаваемого шаблона политики (Template name), а также укажите, следует ли сохранять базы, на которых развернута политика, в шаблон ( CheckBox Save database selection). Выбор баз сохранится для каждой задачи, включенной в политику.

Creating template from policy

Этот шаблон будет автоматически добавлен в список шаблонов политик на вкладке Templates.


Шаблоны задач

Шаблонами задач можно управлять в разделе Task Templates.

Template - Task

Управлять шаблонами задач можно с помощью кнопок, расположенных на одной из панелей инструментов, или команд контекстного меню.

Add Add New Template - создать новый шаблон. При выборе этого пункта открывается Мастер создания задач.

Edit Edit Template - редактировать шаблон;

Delete Delete Template - удалить шаблон;

ExportTemplate Export - сохранить шаблон;

ImportTemplate Import - загрузить шаблон;

CopyTemplate Clone Template - создать копию шаблона задачи.

Смотрите также:

Шаблоны политик

Шаблоны шагов

Шаблоны расписаний


Мастер создания задач

С помощью этого мастера можно создавать служебные задачи, при выполнении которых в назначенное время будут запускаться шаги (операции обслуживания) в установленном порядке.

Для запуска этого мастера необходимо на вкладке Templates открыть раздел TaskTemplate Task templates и в контекстном меню списка объектов выбрать пункт Add Add New Template.

Список шагов:

Задание имени и описания задачи

Задание шагов

Задание расписаний

Выполнение операции


Задание имени и описания задачи

При создании шаблона задания необходимо на первом шаге указать имя задания.

Task templates - Service task wizard - Set service task name

Имя шаблона задается в поле Name. В поле Description можно указать краткую информацию о создаваемом шаблоне.

Следующий шаг >>


Выбор серверов

Выберите сервера для выполнения задачи.

<< Предыдущий шаг

Следующий шаг >>


Задание шагов

На этом шаге необходимо составить список заданий в необходимой последовательности. Также необходимо задать условия зависимостей выполнения шагов.

Task templates - Service task wizard - Define a set of steps for service task

AddStep Create new step - создать новый шаг. При нажатии на эту кнопку откроется окно выбора шагов. После выбора задачи необходимо указать все ее параметры в открывшемся мастере.

StepFromTemplate Create step from template - создать шаг на основе шаблона. В этом случае будет предложено выбрать из списка шаблонов шагов.

EditStep Edit step - редактировать шаг.

CheckBox Fail task on failure - прерывать выполнение всей задачи в случае неудачного выполнения данного шага.

DeleteStep Delete step - удалить шаг.

CopyToTemplates Copy step to templates - создать шаблон на основе выбранного шага.

Managing constraints for creating execution conditions

Crerate constraint Создать новое ограничение

Выберите шаг, для которого необходимо создать ограничение, нажмите на кнопку и выберите зависимый шаг. Также, вы можете строить зависимости визуально, перетаскивая объекты мышью.

Edit constraint Редактировать ограничение

Выделите связь и нажмите кнопку, чтобы задать уловие перехода к следующему шагу.

Remove constraint Удалить ограничение

Выделите связь и нажмите кнопку, чтобы удалить ее.

<< Предыдущий шаг

Следующий шаг >>


Редактор ограничений

В данном редакторе вы можете менять тип связи для организации порядка и условий выполнения шагов обслуживания.

В зависимости от выбранного значения следующий шаг выполнится, если:

Failure - выполнение шага закончится неудачно (Красная связь),

Success - шаг выполнится успешно (Зеленая связь),

Completion - шаг выполнится с любым результатом (Синяя связь).

Constraints Editor - Schema


Задание расписаний

На этом шаге можно задать одно или несколько расписаний по которым будет выполняться создаваемая задача.

Task templates - Service task wizard - Define a schedule for service task

AddSchedule Create new schedule - создать расписание. При создании и изменении расписания открывается Редактор расписаний.

CreateScheduleFromTemplate Create schedule from template - создать расписание на основе шаблона.

EditSchedule Edit schedule - изменить расписание.

DeleteSchedule Delete schedule - удалить расписание.

CopyScheduleToTemplates Copy schedule to templates - копировать расписание в шаблоны.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно увидеть значения всех заданных на предыдущих шагах опций.

Task templates - Service task wizard - Executing

Если все задано верно, то можно начать выполнение операции, нажав кнопку Finish.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Редактор задач

С помощью этого редактора можно просматривать и изменять параметры служебных задач, при выполнении которых в назначенное время будут запускаться шаги (операции обслуживания) в установленном порядке.

Для запуска этого мастера необходимо на вкладке Templates открыть раздел TaskTemplate Task templates и в контекстном меню списка объектов выбрать пункт Add Add New Template.

Вкладки редактора:

Задание имени и описания задачи

Выбор серверов

Задание шагов

Задание расписаний


Задание имени и описания задачи

На этой вкладке отображаются имя политики и ее описание в полях Name и Description соответственно.


Выбор серверов

На данной вкладке вы можете просмотреть или отредактировать список серверов для текущего задания.


Задание шагов

На этой вкладке отображается список шагов, которые будут выполняться в указанной последовательности при запуске задачи.

AddStep Create new step - создать новый шаг. При нажатии на эту кнопку откроется окно выбора шага. После выбора шага необходимо указать все его параметры в открывшемся мастере.

StepFromTemplate Create step from template - создать шаг на основе шаблона. В этом случае появится диалог выбора шаблонов шагов.

EditStep Edit step - редактировать шаг.

DeleteStep Delete step - удалить шаг

CopyToTemplates Copy step to templates - создать шаблон на основе выбранного шага.

Изменять порядок шагов можно с помощью кнопок MoveUp и MoveDown.

CheckBox Terminate task on step fail - прерывать выполнение задачи в случае неудачного выполнения одного из шагов.

Краткое описание каждого шага можно просмотреть в поле Description.


Задание расписаний

На этом шаге можно задать одно или несколько расписаний по которым будет выполняться задача.

AddSchedule Create new schedule - создать расписание;

CreateScheduleFromTemplate Create schedule from template - создать расписание на основе шаблона;

CopyScheduleToTemplates Copy schedule to templates - Копировать расписание в шаблоны

EditSchedule Edit schedule - изменить расписание;

DeleteSchedule Remove schedule - удалить расписание.


Создание шаблона на основе задачи

Если у Вас уже имеется задача с заданными настройками, Вы можете создать на ее основе шаблон, который впоследствии можно будет использовать для создания новой задачи. Он будет содержать все шаги и расписания с заданными параметрами.

Чтобы создать шаблон на основе задачи, откройте редактор политики, в которую она включена и выберите пункт CopyToTemplate Copy to Templates контекстного меню задачи, шаблон которой Вы хотите создать, или используйте соответствующую кнопку на панели.

В появившемся диалоге введите имя создаваемого шаблона задачи (Template name), а также укажите, следует ли сохранять базы, на которых развернута задача, в шаблон ( CheckBox Save database selection).

Create template from task

Этот шаблон будет автоматически добавлен в список шаблонов задач на вкладке Templates.


Шаблоны шагов

Шаблонами шагов можно управлять в разделе Step Templates.

Template - Step

Управлять шаблонами шагов можно с помощью кнопок, расположенных на одной из панелей инструментов или команд контекстного меню.

Add Add New Template - создать новый шаблон. При выборе этого пункта открывается окно выбора шагов. При выборе шага открывается соответствующий мастер.

Edit Edit Template - редактировать шаблон;

Delete Delete Template - удалить шаблон;

ExportTemplate Export - сохранить шаблон;

ImportTemplate Import - загрузить шаблон;

CopyTemplate Clone Template - создать копию шаблона шага.

Смотрите также:

Шаблоны политик

Шаблоны задач

Шаблоны расписаний


Создание шаблона на основе шага

Если у Вас уже имеется настроенная операция обслуживания, включенная в задачу в политике, Вы можете создать на ее основе шаблон, который впоследствии можно будет использовать для создания нового шага. В шаблоне будут сохранены все параметры, заданные при создании шага.

Чтобы создать шаблон на основе шага, откройте редактор политики, в которую он включен и выберите пункт CopyToTemplate Copy to Templates контекстного меню шага, шаблон которого Вы хотите создать, или используйте соответствующую кнопку на панели.

В появившемся диалоге введите имя создаваемого шаблона шага (Template name), а также укажите, следует ли сохранять базы, на которых развернута операция обслуживания, в шаблон ( CheckBox Save database selection).

Create template from step

Этот шаблон будет автоматически добавлен в список шаблонов шагов на вкладке Templates.


Шаблоны расписаний

Расписание (Schedule) - служебный объект для задания времени и периодичности выполнения задач и политик. Каждой политике соответствует хотя бы одно расписание.

При выполнении политик можно использовать время каждого сервера при запуске расписаний политики или время EMS SQL Backup.

Шаблоны расписаний можно просматривать и редактировать в этом разделе.

Template - Schedule

Управлять шаблонами расписаний можно с помощью кнопок, расположенных на одной из панелей инструментов или команд контекстного меню.

Add Add New Template - создать новый шаблон. При выборе .этого пункта открывается Редактор расписаний.

Edit Edit Template - редактировать шаблон;

Delete Delete Template - удалить шаблон;

ExportTemplate Export - сохранить шаблон;

ImportTemplate Import - загрузить шаблон;

CopyTemplate Clone Template - создать копию шаблона расписания.

Смотрите также:

Шаблоны политик

Шаблоны задач

Шаблоны шагов


Редактор расписаний

При изменении расписания открывается окно редактирования.

На вкладке Name & Description можно указать имя и описание расписания.

Schedule template - Schedule editor - NameDescription

На вкладке General указываются все параметры расписания.

CheckBox Enabled

Этот параметр указывает, является ли расписание активным. Если флажок установлен, то расписание активно.

Schedule type

В этом разделе можно выбрать тип расписания.

RadioButton Start automatically when SQL Server Agent starts

Задачи, связанные с этим расписанием, будут запущены при запуске SQL Server Agent.

RadioButton Start whenever the CPUs become idle

Запускать задачи, связанные с этим расписание, при низкой загрузке CPU.

RadioButton Start once

Запустить один раз. Необходимо указать дату и время для выполнения операции.

RadioButton Recurring from date

Выполнение задания, связанного с этим расписанием, будет происходить периодически.

Параметры периодического выполнения задайте в разделе Frequency.

Из раскрывающегося списка Occurs выберите периодичность выполнения операции.

Daily - каждые n дней.

Weekly - каждые n недель.

Monthly - каждые n месяцев.

В календаре from date укажите начало действия создаваемого расписания, to date - окончание действия расписания.

CheckBox Если не установлен флажок перед полем to date, то конечная дата становится неактивной, и операция будет выполняться с заданной периодичностью до тех пор, пока Вы не измените или не удалите это расписание.

Количество дней, недель или месяцев (n) задается в счетчике Recurs every.

При указании недель можно выбрать день недели.

Для месяцев можно задать конкретный день месяца для выполнения операции и периодичность выполнения.

Daily Frequency

RadioButton Occurs once at - выполнять операцию один раз в день. С помощью счетчика указать время выполнения.

RadioButton Recurs every - выполнять операцию каждые несколько часов или минут. Интервал задайте с помощью счетчиков. Если указать дополнительный интервал from... to... то можно указать, в какое время операции будут выполняться с заданной периодичностью. Таким образом, можно, например, выполнять операции только в течение рабочего дня.


Создание шаблона на основе расписания

Если у Вас уже имеется расписание с заданными настройками, Вы можете создать на его основе шаблон, который впоследствии можно будет использовать для создания нового расписания. В шаблоне будут сохранены все параметры, заданные при создании расписания.

Чтобы создать шаблон на основе расписания, откройте редактор политики, в которую включена задача с необходимым расписанием, и выберите пункт CopyToTemplate Copy to Templates контекстного меню расписания, шаблон которого Вы хотите создать, или используйте соответствующую кнопку на панели.

В появившемся диалоге введите имя создаваемого шаблона расписания (Template name).

Create template from schedule

Этот шаблон будет автоматически добавлен в список шаблонов расписаний на вкладке Templates.


Активность

На этой вкладке можно просмотреть список всех процессов, инициированных программой EMS SQL Backup: Политиками и [image] Операциями обслуживания.

Результаты выполнения политик сохраняются в репозитории и отображаются в консоли.

Activity - Explore

В разделе Active Tasks отображаются текущие задачи.

Policy Name - имя политики:

Task Name - имя задачи;

Server Name - сервер, на котором выполняется задача;

Started - задача была запущена;

Finished - было прекращено выполнение задачи;

Status - состояние выполняемой задачи. Также, статус выполнения можно просмотреть в Истории политик.

Более подробный журнал событий отображается в разделе Task Details. Вы можете создать детальный отчет о событиях, используя пункт Copy As Bugreport контекстного меню. После того как отчет будет создан, Вы можете вставить его в любой текстовый редактор.

iconRefresh Refresh (клавиша F5)

Обновить содержимое раздела Activity.

StopTask Stop task

Прервать выполнение задачи.

Show task history

Открыть историю политик для выбранного объекта.

Show all tasks \ Show only active tasks

Выбрать будут ли отображаться все задачи, выполненные за последние 24 часа, или только выполняющиеся в настоящий момент.

Смотрите также:

Начало работы

Управление серверами

Управление политиками обслуживания

Шаблоны

Операции обслуживания

Опции


Операции обслуживания

В EMS SQL Backup представлен набор операций, выполняющих обслуживание баз данных. Эти операции используются в политиках и задачах.

Операции обслуживания могут быть запущены отдельно для конкретной базы данных или сервера, а могут быть включены в политики для регулярного выполнения.

Чтобы выполнить одну операцию обслуживания для конкретной базы или сервера необходимо в контекстном меню базы или сервера выбрать пункт [image] Quick Maintenance Action.

Создание операций обслуживания

Редактирование операций обслуживания

Операции обслуживания

Резервное копирование базы данных

Восстановление баз данных из резервной копии

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Обновление статистики

Регистрирация параметров базы данных

Сжатие базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление

Смотрите также:

Начало работы

Управление серверами

Управление политиками обслуживания

Шаблоны

Активность

Опции


Создание операций обслуживания

Операции обслуживания можно запускать отдельно для выполнения одной конкретной операции обслуживания базы данных.

Операции обслуживания:

Резервное копирование базы данных

Восстановление баз данных из резервной копии

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирование параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Для выполнения одной из операций обслуживания необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | <Имя операции>.

Если включить задачу в состав политики или шаблона, то она будет выполняться автоматически в соответствии с заданными параметрами выполнения и в указанное время.

Чтобы включить задачу в состав политики или шаблона необходимо:

  1. На вкладке Policies в Мастере создания политик, на шаге определения набора задач, при создании задачи, выбрать в появившемся окне <Название задачи>.
  2. На вкладке Templates при создании или редактировании шаблона политики, операции обслуживания или задачи выбрать <Название задачи> в появившемся окне.

Смотрите также:

Редактирование операций обслуживания


Резервное копирование базы данных

C помощью этого мастера задаются необходимые настройки операции создания резервных копий баз данных Backup Database.

В Backup Database step можно создавать резервные копии одной или нескольких баз данных, журналов транзакций или файлов и групп файлов.

Для запуска операции резервного копирования необходимо на вкладке Servers выбрать сервер или базу данных. Затем в контекстном меню сервера или базы данных выбрать пункт [image] Quick Maintenance Actions | [image] Backup Database.

Для того чтобы резервное копирование выполнялось автоматически в заданное время, необходимо включить шаг Backup Database в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании задачи выбрать в появившемся окне Backup Database step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Backup Database step в появившемся окне.

Список шагов:

Задание имени

Выбор исполнителя операции резервного копирования

Выбор баз данных

Задание параметров EMS SQL Backup

Задание настроек резервного копирования

Задание параметров файла

Задание параметров проверки резервной копии

Настройка подключений к хранилищам

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Backup Database - Naming template

Имя шага задается в поле Name.

В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор исполнителя операции резервного копирования

Выберите исполнителя операции резервного копирования.

Service tasks - Backup Database - SQL Angel backup

Выберите RadioButton EMS SQL Backup, если хотите создать резервную копию нескольких баз данных с дополнительными настройками. При включенном сжатии такая резервная копия делается существенно быстрее, чем средствами SQL Server. Резервные копии, созданные таким способом не могут быть восстановлены средствами SQL Server. Для преобразования резервных копий существует конвертер резервных копий.

Выберите RadioButton SQL Server для создания резервной копии одной базы данных. Для выполнения операции будут использованы средства SQL Server.

<< Предыдущий шаг

Следующий шаг >>


Выбор баз данных

На этом шаге мастера необходимо выбрать базы данных для резервного копирования.

Service tasks - Backup Database - SQL Angel backup - Selecting database

Backup Type

В этом разделе можно выбрать тип резервной копии.

RadioButton Database - full - полное резервное копирование всей базы, включая и журнал транзакций.

RadioButton Database - differential - в резервную копию добавляются изменения, сделанные в базе данных с момента последнего полного резервного копирования.

RadioButton Transaction log - создается резервная копия части журнала транзакций, начинающаяся с конца последней успешно созданной копии и заканчивающаяся текущим концом журнала. До создания первой резервной копии журнала необходимо создать полную резервную копию базы данных.

Установите флажок CheckBox Remove inactive entries, чтобы очистить текущий журнал транзакций после создания резервной копии.

CheckBox Leave in restoring state - оставить базу данных в состоянии восстановления, чтобы сделать ее недоступной для пользователей до полного восстановления.

CheckBox Copy-only - создать резервную копию только для копирования. Это резервная копия, изолированная от обычной последовательности резервных копий SQL Server.

CheckBox Skip SIMPLE model DBs - пропускать БД, которые имеют модель восстановления SIMPLE. Если эта опция выключена, и БД, использующие модель SIMPLE, попадают в список/фильтр, сервер вернет ошибку, и процесс будет завершен. Включите эту опцию во избежание подобных ошибок.

Backup Component

В этом разделе можно выбрать объект резервной копии.

RadioButton Database - резервная копия базы данных.

RadioButton Files and filegroups - резервная копия отдельных файлов и файловых групп.

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Databases

Выбрать для резервного копирования одновременно несколько баз данных можно только в том случае, если резервная копия создается средствами EMS SQL Backup. Для этого на втором шаге должен быть выбран RadioButton EMS SQL Backup.

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

При создании шаблонов невозможно выбрать конкретную базу данных, расположенную на конкретном сервере, можно только указать список названий баз данных. Если таковые будут присутствовать на сервере, то к ним будут применены операции обслуживания.

Service tasks - Entering databases

Список редактируется с помощью кнопок, расположенных сбоку, или сочетаний клавиш.

- добавить объект в список (клавиша Insert).

При нажатии этой кнопки в нижней части формы появляется поле для ввода. Нажатие на кнопку Enter добавляет указанное в поле название базы в список.

EditItem - изменить пункт списка (клавиша Enter).

Cross - удалить пункт списка (клавиша Delete).

Если в качестве объекта бэкапа выбрано Files and filegroups, то помимо выбора БД становится доступен выбор файлов и файловых групп.

Service tasks - Backup Database - SQL Angel backup - Selecting filegroups

Objects

Для каждой выбранной БД дожен быть выбран набор файлов и файловых групп.

  • All - все файловые группы БД целиком.
  • By list - файлы и файловые группы, выбранные вручную.

Следующий шаг

Для EMS SQL Backup

Задание параметров EMS SQL Backup

Для SQL Server

Задание настроек резервного копирования


Задание параметров EMS SQL Backup

На этом шаге можно задать общие настройки резервного копирования. Этот шаг доступен только при создании резервной копии средствами EMS SQL Backup.

Service tasks - Backup Database - SQL Angel backup - Defining backup settings

Max Thread Count

Максимальное число потоков, которые будут использованы для операции резервного копирования.

CheckBox Compression

Использовать сжатие для резервной копии.

Compression Level

Степень сжатия можно задать в этом поле. '1' - максимальная скорость создания резервной копии, '9' - максимальная степень сжатия.

CheckBox Encryption

Включите опцию для использования шифрования.

Encryption Password

В этом поле можно указать пароль, который будет использоваться для расшифровки резервной копии. В поле Confirm Password подтвердите заданный пароль.

Encryption Type

Тип шифрования выберите из этого раскрывающегося списка.

<< Предыдущий шаг

Следующий шаг >>


Задание настроек резервного копирования SQL Server

На этом шаге можно задать параметры хранения резервной копии. Этот шаг доступен только при создании резервной копии средствами SQL Server. Так выглядит диалог для SQL Server 2008 и младше.

Service tasks - Backup Database - SQL Server backup - Setting backup options

Block size

В разделе Block size задайте размер физического блока в байтах. Поддерживаются размеры 512, 1 024, 2 048, 4 096, 8 192, 16 384, 32 768 и 65 536 байт (64 КB).

RadioButton Default - размер блока по умолчанию. Значение по умолчанию равно 65536 для ленточных устройств и 512 для других устройств.

RadioButton To restore from CD (2 KB) - если создается резервная копия, которую планируется копировать на компакт-диск и восстанавливать с него, выберите этот пункт.

RadioButton С помощью счетчика Other задайте любое другое произвольное значение.

Backup Password

В поле Password можно указать пароль, который будет использоваться для открытия резервной копии. В поле Confirm Password подтвердите заданный пароль.

В разделе Write type - укажите: перезаписать файл резервной копии или добавить в него новую информацию.

RadioButton Append - добавить на носитель,

RadioButton Overwrite - перезаписать носитель.

CheckBox Backup compression - включить сжатие резервной копии.

Для серверов, поддерживающих шифрование резервных копий, доступны опции его настройки:

Editing Service task template - Backup Database - Backup Options2014short

Backup encryption

В этом разделе можно настроить шифрование резевных копий средствами SQL Server.

CheckBox Encrypt backup - включить шифрование резервной копии.

Выберите алгоритм шифрования в поле Algorithm. В поле Certificate or assymmetric key выберите сертификат или ассиметричный ключ. Помните, что выбраны могут быть только сертификаты, защищенные мастер-ключом, и ассиметричные ключи из расширенного управления ключами (EKM).

<< Предыдущий шаг

Next step >>


Задание настроек перекачки данных SQL Server

При создании резервной копии средствами SQL Server становится доступным дополнительный шаг.

Service tasks - Backup Database - SQL Server backup - Setting other options

В поле Buffer count укажите общее число буферов ввода-вывода, которые будут использоваться для операции резервного копирования.

Наибольший объем пакета данных в байтах для обмена между SQL Server и носителем резервного набора задайте в поле Max transfer size, Kbyte. Поддерживаются значения, кратные 65 536 байтам (64 КБ), вплоть до 4 194 304 байт (4 МБ).

Важно: Если в поле указано значение "0", то автоматически будет использоваться значение по умолчанию.

<< Предыдущий шаг

Следующий шаг >>


Задание параметров файла

На этом шаге необходимо задать свойства файла резервной копии.

Service tasks - Backup Database - SQL Angel backup - Setting file options

Backup folder

В этом поле указывается директория, в которой должна быть создана резервная копия. Вы можете использовать следующие теги: {backup_root_folder} и {server}. Директория, для которой используется тег {backup_root_folder} указывается в диалоге Свойства серверных компонентов.

Чтобы проверить доступность указанной директории, нажмите на кнопку Check.

Важно: Кнопка Check доступна только при настройке резервного копирования на одном сервере.

Backup file name

В этом поле задайте имя файла резервной копии. В имени файла можно использовать теги: {server}, {database}, {backup_type}, {date} и {login}. Если Вы хотите загружать файл в хранилище, то рекомендуется использовать тег {date}, так как он гарантирует уникальность имени файла бэкапа.

Важно: Чтобы добавить тег в поле ввода необходимо кликнуть по нему один раз в списке Available tags.

RadioButton Backup to a single file

Выберите эту опцию для резервного копирования всех выбранных баз данных в один файл.

RadioButton Backup to several files

Резервная копия будет разделена на несколько файлов.

RadioButton Split by size

Файл резервной копии будет разделен на тома указанного размера.

RadioButton Split by database

Для каждой базы данных будет создана резервная копия в виде отдельного файла.

Следующий шаг >>


Настройка подключений к хранилищам

На этом шаге задайте параметры подключения к облачным хранилищам, в которые Вы хотите загружать копии файлов бэкапов. Вы можете добавить неограниченное количество удаленных и локальных хранилищ. Копии файлов бэкапов будут загружены во все заданные хранилища.

Поддерживаются подключения к следующим видам хранилищ:

  • SMB/CIFS
  • FTP
  • Secure FTP
  • Amazon S3 Cloud
  • Microsoft Azure
  • Google Drive
  • Dropbox

Service tasks - Backup Database - Specifying cloud connections

Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Если Вы создаете новое подключение, то после настройки его параметров Вам будет предложено сохранить его.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

Важно: Если файл резервной копии с таким именем уже существует в хранилище, то он не будет заменен. В этом случае операция загрузки файла бэкапа завершится неудачей.

CheckBox Don't save backup files on the server side

При выполнении резервного копирования EMS SQL Backup выполняет загрузку данных в облачные/сетевые хранилища "на лету" одновременно с получением данных от сервера. Если включена эта опция, запись на локальный диск сервера выполняться не будет. Это позволяет сохранить свободное место на диске, однако, в случае ошибок загрузки файла во все выбранные облачные хранилища, консистентный файл или набор файлов резервной доступен не будет.

Важно: Для использования некоторых типов облачных соединений есть ограничения.

  • FTP, SFTP, SMB/CIFS, Dropbox можно использовать для всех типов лицензий, включая бесплатную (Free).
  • Google Drive может использоваться для лицезий EMS SQL Backup for SQL Server и EMS SQL Backup PRO for SQL Server.
  • S3, Azure может использоться только для лицензии EMS SQL Backup PRO for SQL Server.

<< Предыдущий шаг

Следующий шаг >>


Задание параметров проверки резервной копии

На этом шаге мастера задайте настройки проверки резервной копии.

Service tasks - Backup Database - Specifying backup veryfying options

CheckBox Verify backup when finished (VERIFYONLY) - проверить копию после завершения операции. С помощью проверки резервной копии можно проконтролировать ее физическую доступность, убедиться в том, что все файлы резервной копии могут быть прочитаны и восстановлены, и в том, что резервную копию можно восстановить в любой момент.

CheckBox Perform checksum before writing to media (CHECKSUM) - создать контрольную сумму перед записью копии на резервный носитель. Независимо от того, присутствует ли контрольная сумма страницы или нет, инструкция BACKUP создаст отдельные контрольные суммы резервных копий для потока резервных файлов.

Если установлен флажок CheckBox Continue on error, то при возникновении ошибки в контрольной сумме, операция не будет остановлена.

CheckBox Detect possible backup sequence breaks - анализировать последовательность бэкапов на предмет возможных разрывов цепочки восстановления. Данная опция доступна, если выбран тип резервной копии Differential или Transaction log. Если эта опция включена, программа анализирует все записи в истории резервных копий, которые будут необходимы при восстановлении на текущую резервную копию. В случае, если в этой последовательности будет найдена хотя бы одна резервная копия, выполненная сторонним приложением, программа сгенерирует предупреждение о том, что при восстановлении потребуются файлы резерных копий, созданные разными приложениями.

Использование данной опции позволяет выявить случаи, когда резервные копии выполняются неявным образом через интерфейс VSS, работающими на сервере планами обслуживания либо другим сторонним ПО, и могут нарушить или усложнить последовательность восстановления, обеспечиваемую EMS SQL Backup.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Backup Database - SQL Angel backup - Performing operation

Если все задано верно, то можно начать выполнение операции, нажав кнопку Finish.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Restore

SQL Backup
  • Index
  • « Prev
  • Next »

Восстановление баз данных из резервной копии

Restore Database Wizard позволяет выполнять операцию восстановления базы данных на вашем SQL Server. Мастер предоставляет простой интерфейс для настройки опций восстановления базы данных. С помощью мастера Вы можете восстановить файлы резервных копий, хранящиеся локально на сервере или на удаленных облачных хранилищах.

Для запуска резервного копирования необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | [image] Restore Database или в контекстном меню базы данных выбрать пункт [image] Restore Database.

Важно: Эта задача обслуживания не может быть включена в политику.

Список шагов:

Выбор резервной копии

Выбор составных частей резервной копии

Задание параметров назначенной базы данных

Задание дополнительных параметров восстановления

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Выбор резервной копии

На первом шаге необходимо выбрать одну из существующих резервных копий, из которых будет восстановлена база данных.

Restore Database Wizard_Angel

Backup provider

Выберите механизм, с помощью которого была создана резервная копия.

RadioButton EMS SQL Backup

Резервная копия была создана средствами EMS SQL Backup.

RadioButton SQL Server

Резервная копия была создана средствами сервера.

Backup source

RadioButton History - история резервного копирования. Отображаются резервные копии только выбранного типа.

RadioButton Select files - файлы резервных копий.

Server

Из этого раскрывающегося списка нужно выбрать сервер, на котором расположена восстанавливаемая база данных.

Database

Из этого раскрывающегося списка необходимо выбрать базу данных, которая будет восстановлена.

Если в качестве источника резервной копии была выбрана History, то в списке будут отображаться существующие копии выбранной базы данных. Для выбранной базы данных отобразится список доступных для нее резервных копий. Необходимо выбрать одну из них для восстановления. Первоначально в списке отображается только 20 последних записей истории. Чтобы отобразить более старые резервные копии, необходимо нажать кнопку Get more...

В поле Storage отображаются облачные хранилища, в которые файл резервной копии был загружен в процессе резервного копирования. Если файл не найден на локальном диске, Вы сможете осуществить его поиск в облачном хранилище и затем скачать его.

При восстановлении по истории на выбранную дату происходит поиск всех необходимых для восстановления допустимых с точки зрения SQL Server последовательностей файлов бэкапов. Это гарантируется проверкой внутренних номеров последовательностей журнала LSN.

Важно: Если файл не загружался в облачное хранилище в процессе резервного копирования, и не найден программой локально, то соответствующая этому файлу точка в истории отображена не будет. Восстановить файл в этом случае можно только, выбрав его вручную.

При выборе опции Select files Вы можете добавить вручную файлы из локальной/сетевой директории или из облачного хранилища.

Важно: Если Вы выбрали файл резервной копии, которого нет на локальном диске, его поиск будет автоматически произведен при переходе на следующий шаг. Поиск производится в облачных хранилищах, которые были заданы в процессе резервного копирования и в "похожих" облачных хранилищах из списка Cloud Connections.

Если в качестве источника была выбрана History, то следующим шагом будет Выбор составных частей резервной копии.

Если в качестве источника были выбраны Select files, то следующим шагом будет Задание параметров назначенной базы данных.


Добавление файлов вручную

Если в качестве источника резервной копии выбрана опция Select files, то необходимо добавить нужные файлы вручную.

Restore Database Wizard_Files

Для каждого выбранного файла отображается дополнительная информация.

Date - дата создания;

Database - база данных, для которой была создана резервная копия;

Type - тип резервной копии;

Encrypted - зашифрован файл или нет;

First LSN - первый регистрационный номер транзакции в файле;

Storage name - имя и адрес файла резервной копии;

Last LSN - последний регистрационный номер транзакции в файле;

Check Point LSN - регистрационный номер контрольной точки;

Differential Base LSN - регистрационный номер транзакции

Cross1 Remove - удалить выбранный файл.

ClearFiles Clear - удалить все выбранные файлы.

Изменить порядок выбранных файлов можно с помощью кнопок MoveUp и MoveDown .

Set password

Если резервная копия защищена паролем, то его можно ввести в окне, которое открывается при нажатии на эту кнопку.

Чтобы выбрать тип хранилища, из которого Вы хотите добавить файл резервной копии, нажмите на стрелку вниз рядом с кнопкой Add Local File.

Add Local File/Add Network File

Нажав на эту кнопку, можно выбрать файл, расположенный либо на сервере, либо на компьютере, находящемся в локальной сети. Если резервная копия состоит из нескольких файлов (опция доступная для резервных копий типа EMS SQL Backup), то необходимо выбрать первый файл из списка.

Add Cloud File

При выборе опции Add Cloud File, появляется диалог Select cloud. В этом диалоге необходимо добавить облачное хранилище, в котором находится необходимый файл резервной копии.

Restore Database Wizard - Files - Add cloud

Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Если Вы создаете новое подключение, то после настройки его параметров Вам будет предложено сохранить его.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

После того как добавлено облачное хранилище, нажмите кнопку Ok, чтобы запустить процесс получения файлов из хранилища. Если подключение к хранилищу установлено и у заданного пользователя достаточно прав на получения списка файлов, то появится диалог Select file. В этом диалоге будет отображаться список файлов, загруженных в хранилище.

Restore Database Wizard - Files - Files on cloud

Выберите необходимый файл резервной копии и задайте локальную директорию, в которую он будет загружен, в поле Local path for download.

Важно: Файл будет доступен для восстановления только после его загрузки их облачного хранилища.

Если файл содержит резервные копии нескольких баз данных, то нужно будет выбрать для восстановления только одну базу.


Выбор составных частей резервной копии

Этот шаг активен, если на первом шаге в качестве источника данных был выбран пункт History.

На этом шаге необходимо выбрать последовательность бэкапов для восстановления нужного состояния базы данных. Каждая предложенная программой последовательность бэкапов представляет собой комбинацию файлов, допустимую для последовательного восстановления с точки зрения SQL Server. Это гарантируется проверкой внутренних номеров последовательностей журнала LSN. В случае когда допустимыми являются несколько последовательностей с разным набором файлов бэкапов, выбрать используемую для операции восстановления можно с помощью кнопок Left и Right . По умолчанию программа выбирает самую короткую последовательность, состоящую из файлов, доступных локально.

Restore Database Wizard - History - Specifying file settings

В первой колонке отображается, доступен ли файл для восстановления:

FoundLocally - файл бэкапа найден на локальном диске;

FoundInCloud - файл бэкапа найден в облачном/сетевом хранилище;

NotFoundBackup - файл бэкапа не найден.

В колонке Backup file отображается путь до файла - на локальном диске или в облачном/сетевом хранилище.

Если файл не найден на локальном диске или в облаке при автоматическом поиске, Вы можете выделить этот файл в списке и нажать кнопку Find in cloud - FindInCloud .

В открывшемся диалоге Select cloud необходимо добавить облачные хранилище, в которых следует произвести поиск файла.

По умолчанию, в этом диалоге содержится список облачных хранилищ, в которых вероятно может быть расположен файл - хранилища, которые были заданы при бэкапе и похожие хранилища из списка Облачных соединений.

Restore Database Wizard - History - Specifying file settings - Adding clouds

Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Если Вы создаете новое подключение, то после настройки его параметров Вам будет предложено сохранить его.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

После того как Вы задали хранилища, нажмите кнопку Ok для начала поиска. Поиск производится на всех облаках в заданном порядке. При нахождении файла на облаке предлагается использовать это хранилище для скачивания файла. Вы также можете продолжить поиск дальше.

После того как найдены все файлы резервных копий, нажмите кнопку Next, чтобы перейти на шаг Задание параметров назначенной базы данных.

Важно: Если часть файлов содержится в облачных хранилищах, Вам будет предложено скачать их перед переходои на следующий шаг. Это необходимо для восстановления базы данных. Файлы загружаются в папку, которая была задана в настройках операции бэкапа.

<< Предыдущий шаг

Следующий шаг >>


Выбор файлов и файловых групп

Этот шаг появляется, если на предыдущих шагах была выбрана резервная копия типа Files and filegroups. На нем необходимо выбрать файлы и файловые группы для восстановления, которое будет выполнено с ключевым словом WITH PARTIAL.

Restore Database Wizard - Files and filegroups

Выберите These files and filegroups для выбора всех элементов дерева.


Задание параметров назначенной базы данных

На этом шаге необходимо задать параметры восстанавливаемой базы данных.

В разделе Restore as выберите, каким образом будет сохранена на сервере восстановленная база данных.

RadioButton Existing Database - будет заменена уже существующая.

Из списка Database Name надо будет выбрать ту базу, которую хотите заменить восстанавливаемой.

RadioButton New Database - будет создана новая база данных,

При восстановлении базы данных из differential copy пункт New Database недоступен.

В поле New database name задайте имя создаваемой базы данных.

CheckBox Verify only (RESTORE VERIFYONLY) - проверить набор файлов резервной копии. С помощью проверки резервной копии можно проконтролировать ее физическую доступность, убедиться в том, что все файлы резервной копии могут быть прочитаны и восстановлены, и в том, что резервную копию можно восстановить в любой момент.

CheckBox Delete downloaded files after restore - удалить файлы резервных копий, полученные из удаленных (облачных) хранилищ. Эта опция доступна, если программа загрузила хотя бы один файл из удаленного хранилища на втором шаге.

Restore Database Wizard - History - Specifying restore type

В столбце File/Group Logical Name в виде дерева представлены файлы базы данных. В столбце Physical File Name Вы можете увидеть и при необходимости изменить восстанавливаемые файлы.

Выбрать файлы можно в диалоговом окне, открывающемся при нажатии на кнопку EllipsisButton

Restore Database Wizard - History - Specifying restore type - Selecting Files

<< Предыдущий шаг

Следующий шаг >>


Задание дополнительных параметров восстановления

Recovery options

Эта группа опций позволяет задать параметры восстановления.

RadioButton Recovery - восстановление (откат всех неподтвержденных транзакций). Настраивает операцию восстановления на откат любых незавершенных транзакций. После процедуры восстановления база данных готова к использованию.

RadioButton No Recovery - без восстановления (оставить базу данных в режиме восстановления). Настраивает операцию восстановления на отмену отката любых незавершенных транзакций. Если впоследствии должен применяться другой журнал транзакций, то следует указать параметр No Recovery или Standby.

RadioButton Standby - режим ожидания (оставить в режиме ожидания и только для чтения). Следует также указать резервный файл, с помощью которого можно отменить результаты восстановления. Этот параметр разрешается применять для автономного восстановления (в том числе частичного восстановления). Параметр не разрешается использовать при оперативном восстановлении. При попытке указать параметр Standby для оперативного восстановления операция восстановления заканчивается неудачей. Инструкцию Standby также не разрешается применять, если необходимо обновление базы данных.

Undo File Name - имя файла отката. Это резервный файл, местонахождение которого хранится в журнале базы данных. Если файл с таким именем существует, то он перезаписывается. В противном случае компонент Database Engine создает этот файл.

Важно: При недостатке места на диске операция останавливается.

CheckBox Replace (WITH REPLACE)

Если установлен этот флажок, то при совпадении имен существующая база данных будет перезаписана.

CheckBox Continue on error - при возникновении ошибки операция восстановления базы данных не будет прервана.

Restore Database Wizard_history_Specify other restore settings

CheckBox Backup the transaction log before proceeding with the restore is checked

Отметьте эту опцию, чтобы выполнить резервное копирование заключительного фрагмента журнала перед восстановлением. Обратите внимание, что при резервном копировании будет использована опция 'WITH NORECOVERY', поэтому база данных перейдет в состояние Recovery. Это гарантирует, что после создания резервной копии заключительного фрагмента журнала база данных не изменится.

Важно: Резервное копирование заключительного фрагмента журнала будет выполнено автоматически при переходе на следующий шаг.

CheckBox Restore tail of log automatically

Если вы отметите эту опцию, то файл резервной копии заключительного фрагмента журнала будет добавлен в список файлов для восстановления.

Transaction log restore options

Элементы управления в этом разделе становятся доступными для изменения, если на шаге Выбор резервной копии был выбрана резервная копия типа Transaction log.

RadioButton Restore all records of transaction log

Сделать полное восстановление из резервной копии журнала транзакций.

RadioButton Restore all records of transaction log before

Восстановить все записи журнала, сделанные до указанной даты.

RadioButton Restore all records of transaction log up to marked transaction

Восстановить базу данных до состояния, когда была принята отмеченная транзакция.

Mark name

Имя отметки транзакции.

Search for marks after

С какой даты и времени необходимо начать поиск отмеченной транзакции.

CheckBox Include marked transaction

Если флажок установлен, то база данных будет восстановлена до состояния отмеченной транзакции, то есть отмеченная транзакция будет включена в восстанавливаемую базу данных.

CheckBox Kill connections

Отметьте эту опцию, чтобы разорвать все подключения к базе данных перед началом восстановления. Если к базе установлены подключения, операция восстановления закончится ошибкой.

Важно: Если отмечена эта опция и Backup the transaction log before proceeding with the restore, то подключения будут разорваны перед выполнением операции резервного копирования tail-log.

CheckBox Check orphaned users

Проверять наличие изолированных пользователей в базе данных перед ее восстановлением.

CheckBox Drop orphaned users

Удалять изолированных пользователей перед восстановлением базы данных.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Restore Database Wizard SQL Angel restore - Performing operation

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Пересылка баз данных

С помощью операции обслуживания Database Shipping можно создавать полные резервные копии баз данных и отправлять их на выбранный сервер через общую папку.

Для выполнения пересылки баз данных необходимо иметь не меньше двух экземпляров сервера SQL.

Версия сервера назначения не может быть ниже, чем версия исходного.

У обоих серверов должен быть доступ к общей папке.

Для запуска операции пересылки баз данных, необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | DatabaseShipping Database shipping.

Для включения операции обслуживания в политику необходимо выполнить одно из следующих действий.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Database Shipping step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Database Shipping step в появившемся окне.

Список шагов:

Задание имени

Задание пар баз данных

Задание параметров резервного копирования

Задание директорий параметров восстановления

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Database Shipping - Naming step

Следующий шаг >>


Задание пар баз данных

На этом шаге необходимо задать пары баз данных для пересылки файлов резервного копирования.

Service tasks - Database Shipping - Specifying database pairs

Source server

Из этого раскрывающегося списка необходимо выбрать сервер, на котором расположена исходная база данных, резервную копию которой надо перенести.

Destination server

Из этого раскрывающегося списка необходимо выбрать сервер, на который будут отправлены файлы резервного копирования.

Задайте пары баз данных в таблице, указав исходные и назначенные в полях Source DB и Destination DB соответственно.

Если на назначенном сервере не существует необходимой базы данных, то в поле Destination DB можно выбрать действие Create New для создания новой базы. При создании новой базы данных в поле New database необходимо указать ее имя.

Создание базы данных осуществляется путем создания полной резервной копии исходной базы данных и ее последующего восстановления.

Data folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам MDF.

Log folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам LDF.

Важно: При создании шаблона этот шаг отсутствует.

<< Предыдущий шаг

Следующий шаг >>


Задание параметров резервного копирования

На этом шаге можно задать настройки резервного копирования для исходных баз данных.

Service tasks - Database Shipping - Specifying backup options

Backup folder

Укажите директорию для резервного копирования. Расположение необходимо указывать относительно исходного сервера. Путь можно ввести вручную или задать в окне, открывающемся при нажатии на кнопку EllipsisButton . Можно проверить доступ к директории, нажав на кнопку Check.

Max Thread Count

Максимальное число потоков, которые будут использованы для операции резервного копирования.

CheckBox Compression

Использовать сжатие для резервной копии.

Compression Level

Степень сжатия можно задать в этом поле: '1' - максимальная скорость создания резервной копии, '9' - максимальная степень сжатия.

CheckBox Encryption

Включите опцию для использования шифрования.

Encryption Password

В этом поле можно указать пароль, который будет использоваться для расшифровки резервной копии. В поле Confirm Password подтвердите заданный пароль.

Encryption Type

Тип шифрования выберите из этого раскрывающегося списка.

CheckBox Keep backups on the source server

Включение этой опции позволит сохранять все файлы резервных копий на исходном сервере в папке, заданной в поле Backup folder.

<< Предыдущий шаг

Следующий шаг >>


Задание директорий и параметров восстановления

На этом шаге задайте необходимые настройки для общей и назначенной директорий и параметры восстановления базы данных.

Service tasks - Database Shipping - Specifying folders and recovery options

Network shared folder

Укажите общую папку для копирования резервных копий исходной базы данных.

Оба сервера, между которыми происходит передача файлов резервных копий, должны иметь доступ к этой директории. Параметры авторизации доступа в общую папку задайте в разделе Authorization.

Проверить наличие этого доступа можно с помощью кнопки Check.

Destination folder

Укажите папку, в которую будут помещены файлы полных резервных копий. Назначенный сервер должен иметь к ней доступ. Проверить наличие доступа можно с помощью кнопки Check.

Recovery options

Эта группа опций позволяет задать параметры восстановления.

RadioButton No Recovery - без восстановления (оставить базу данных в режиме восстановления). Настраивает операцию восстановления на отмену отката любых незавершенных транзакций. Если впоследствии должен применяться другой журнал транзакций, то следует указать параметр No Recovery или Standby.

RadioButton Standby - режим ожидания (оставить в режиме ожидания и только для чтения). Следует также указать резервный файл, с помощью которого можно отменить результаты восстановления. Этот параметр разрешается применять для автономного восстановления (в том числе частичного восстановления). Параметр не разрешается использовать при оперативном восстановлении. При попытке указать параметр Standby для оперативного восстановления операция восстановления заканчивается неудачей. Инструкцию Standby также не разрешается применять, если необходимо обновление базы данных.

Undo File Name - имя файла отката. Это резервный файл, местонахождение которого хранится в журнале базы данных. Если файл с таким именем существует, то он перезаписывается. В противном случае компонент Database Engine создает этот файл.

RadioButton Recovery - восстановление (откат всех неподтвержденных транзакций). Настраивает операцию восстановления на откат любых незавершенных транзакций. После процедуры восстановления база данных готова к использованию.

Важно: При недостатке места на диске операция останавливается.

CheckBox Kill connections to destination database

Для принудительного отключения от всех баз данных установите этот флажок.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Database Shipping - Viewing summary information

Для начала выполнения операции, нажмите кнопку Run.

<< Предыдущий шаг


Выполнение задания агента SQL Server

Execute EMS SQL Agent job wizard запускает задания агента SQL Server. Можно создавать задания, которые выполняют инструкции Transact-SQL и сценарии ActiveX, задачи служб Analysis Services и задачи обслуживания репликаций, либо производят запуск пакетов. Можно также настроить задание, чтобы контролировать Microsoft SQL Server и вызывать предупреждения. Задания агента SQL Server обычно используются, чтобы автоматически выполнять повторяющиеся задачи.

Важно: Статус этого шага не зависит от успешности выполнения задания, а отражает успешность его запуска на выполнение.

Для запуска операции выполнения задания агента SQL Server необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | ExecuteJob Execute EMS SQL Agent job.

Для того чтобы задания агента SQL Server выполнялись автоматически в заданное время, необходимо включить шаг Execute EMS SQL Agent job в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Execute EMS SQL Agent job step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Execute EMS SQL Agent job step в появившемся окне.

Список шагов:

Задание имени

Выбор задания

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


New topic_2

SQL Backup
  • Index
  • « Prev
  • Next »

Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Execute SQL Server Job - Naming template

Имя операции обслуживания задается в поле Name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор задания

На этом шаге устанавливается соответствие между экземпляром сервера и заданием, которое должно быть выполнено.

Service tasks - Execute EMS SQL Agent server job - Selecting job

В разделе Servers необходимо выбрать серверы, на которых должно быть выполнено выбранное задание. Само задание необходимо выбрать из списка Available SQL Server Agent's Job и используя кнопку AddItem или двойной щелчок мышки. Удалить выбранное задание из списка можно с помощью кнопки Cross .

В списке Selected SQL Server Agent's Job in execution order отображаются выбранные задания в порядке выполнения. Порядок заданий можно менять с помощью кнопок MoveDown и MoveUp.

Важно: Если сервер недоступен, то службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером.

Важно: Выбор серверов недоступен при создании шаблона.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно увидеть значения всех заданных на предыдущих шагах опций.

Service tasks - Execute EMS SQL Agent server job - Executing job

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Выполнение инструкции T-SQL

С помощью Execute T-SQL statement step wizard можно запустить инструкции Transact-SQL.

Для запуска инструкции Transact-SQL необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | btnShowSQLScript Execute T-SQL statement.

Для того чтобы инструкции Transact-SQL запускались автоматически в заданное время, необходимо включить шаг Execute T-SQL statement в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Execute T-SQL statement step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Execute T-SQL statement step в появившемся окне.

Список шагов:

Задание имени

Выбор сервера

Задание оператора T-SQL

Выполнение оператора T-SQL

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Execute T-SQL Statement - Naming template

Имя операции обслуживания задается в поле Name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор серверов

На этом шаге выберите сервер на котором должна быть выполнена инструкция T-SQL.

Execute T-SQL statement - Database selection

Servers

В разделе Servers необходимо выбрать серверы на которых должен быть выполнен создаваемый оператор T-SQL.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Для выбранного сервера справа отображается описание и версия.

<< Предыдущий шаг

Следующий шаг >>


Задание инструкции T-SQL

На этом шаге необходимо задать оператор T-SQL, который должен быть выполнен на выбранном сервере.

Service tasks - Execute T-SQL statement - Defining T-SQL statement

Введите инструкцию T-SQL в поле редактора T-SQL statement.

В поле Execute timeout можно задать ограничения по времени для ожидания завершения выполнения инструкции.

Загрузить\Сохранить текст оператора можно с помощью кнопок Load\Save.

С помощью кнопки Check statement можно проверить синтаксис инструкции T-SQL. Для проверки синтаксиса оператор выполняется на сервере в режиме PARSEONLY.

Важно: Кнопка Check statement недоступна при создании шаблона.

На вкладке Errors отображается информация об ошибках, найденных в инструкции.

Service tasks - Execute T-SQL statement - Defining T-SQL statement - Error

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Execute T-SQL statement - Executing T-SQL statement

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Очистка истории

С помощью History cleanup wizard можно удалить данные журнала, связанные с деятельностью по созданию истории резервных копий, с заданиями агента SQL Server и планами обслуживания баз данных.

Для запуска операции очистки истории необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | ServerHistoryCleanup History cleanup.

Для того чтобы очистка истории выполнялась автоматически в заданное время, необходимо включить шаг History cleanup в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне History cleanup step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать History cleanup step в появившемся окне.

Список шагов:

Задание имени

Выбор серверов

Выбор дат

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - History Cleanup - Naming template

Имя операции обслуживания задается в поле Name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор серверов

На этом шаге мастера необходимо выбрать серверы, на которых будет выполнена очистка истории.

History cleanup - Choose server

В разделе Servers необходимо выбрать серверы. Для выбранного сервера справа отображается описание и версия.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

<< Предыдущий шаг

Следующий шаг >>


Выбор типа удаляемой истории

На этом шаге необходимо выбрать историю какого типа следует удалить.

Service tasks - History Cleanup - Selecting history

MS SQL Server

В этом разделе задайте временные параметры для удаляемой истории резервного копирования MS SQL и некоторой информации журналов выполнения заданий.

EMS SQL Backup

Следующие опции предназначены для удаления информации некоторых журналов операций, выполняемых EMS SQL Backup.

CheckBox Backup and restore history data older than

Установите этот флажок, чтобы удалить все записи истории резервного копирования и восстановления, давность которых больше заданного периода.

CheckBox SQL Server Agent job history data older than

Установите этот флажок, чтобы удалить все записи истории заданий агента SQL Server, давность которых больше заданного периода.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - History Cleanup - Cleaning history

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Проверка целостности баз данных

Проверка целостности базы данных заключается в проверке распределения и структурной целостности всех объектов в заданной базе данных. Можно проверить одну или несколько баз данных. Кроме того, можно задать проверку индексов базы данных.

Для запуска операции проверки целостности необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | DatabaseIntegrityCheck Database Integrity Check.

Для того чтобы проверка целостности выполнялась автоматически в заданное время, необходимо включить шаг Database Integrity Check в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Database Integrity Check step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Database Integrity Check step в появившемся окне.

Список шагов:

Задание имени

Выбор баз данных

Задание параметров проверки

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Database Integrity Check - Naming template

Имя шаблона задается в поле Task name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор баз данных

На этом шаге необходимо выбрать базы данных, проверку целостности которых следует выполнить.

Service tasks - Datbase Integrity Check - Selecting database

В разделе Servers необходимо выбрать серверы.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

При создании шаблонов невозможно выбрать конкретную базу данных, расположенную на конкретном сервере, можно только указать список названий баз данных. Если таковые будут присутствовать на сервере, то к ним будут применены операции обслуживания.

Service tasks - Entering databases

Список редактируется с помощью кнопок, расположенных сбоку, или сочетаний клавиш.

- добавить объект в список (клавиша Insert).

При нажатии этой кнопки в нижней части формы появляется поле для ввода. Нажатие на кнопку Enter добавляет указанное в поле название базы в список.

EditItem - изменить пункт списка (клавиша Enter).

Cross - удалить пункт списка (клавиша Delete).

<< Предыдущий шаг

Следующий шаг >>


Задание параметров проверки

На этом шаге мастера можно настроить проверку целостности базы данных.

Service tasks - Datbase Integrity Check - Setting options

CheckBox Exclude indexes checks (NOINDEX)

При включенной опции проверка некластеризованных индексов для пользовательских таблиц выполняться не будет. Это уменьшает общее время выполнения.

CheckBox Perform logical checks on indexes (EXTENDED_LOGICAL_CHECKS)

При уровне совместимости 100 (SQL Server 2008) и выше выполняются логические проверки согласованности индексированных представлений, XML-индексов и пространственных индексов.

CheckBox Limit the checking to

Установите этот флажок, если необходимо выполнить проверку с условиями:

RadioButton Physical Only (PHYSICAL_ONLY). Осуществляется проверка целостности физической структуры страниц и заголовков записей, физической структуры сбалансированных деревьев и целостности выделения пространства в базе данных.

RadioButton Data Purity (DATA_PURITY). Осуществляется проверка таблицы на недействительность или выход из допустимого диапазона значений столбцов.

CheckBox Apply lock during check (TABLOCK)

Указание значения аргумента приводит к получению инструкцией DBCC CHECKDB блокировок вместо использования внутреннего моментального снимка базы данных. Это включает краткосрочное использование монопольной блокировки на базу данных.

CheckBox Write detailed error messages (ALL_ERRORMSGS)

Отображает все сформированные для объекта ошибки. Если флажок не установлен, то будут отображаться лишь первые 200 сообщений об ошибках для каждого объекта.

CheckBox Suppress info messages (NO_INFOMSGS)

Если установлен этот флажок, то информационные сообщения не будут отображаться.

Operation timeout

Эта опция позволяет задать время ожидания, в течение которого может выполняться данная операция. По истечении этого времени программа вернет ошибку.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Datbase Integrity Check - Checking Integrity

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Реорганизация индексов

С помощью Reorganize indices wizard можно перестраивать индексы в таблицах и представлениях базы данных.

Для запуска операции реорганизации индексов необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | ReorganizeIndices Reorganize indices.

Для того чтобы реорганизация индексов выполнялась автоматически в заданное время, необходимо включить шаг Reorganize indices в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Reorganize indices step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Reorganize indices step в появившемся окне.

Список шагов:

Задание имени

Выбор объектов

Задание параметров реорганизации

Выбор дополнительных опций

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Reorganize Indices - Naming template

Имя шаблона задается в поле Task name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор объектов

На этом шаге необходимо выбрать объекты для реорганизации индексов.

Service tasks - Reorganizing indices - Selecting database

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Objects

  • All - все объекты (таблицы и представления)
  • All user - таблицы и представления пользовательских баз данных
  • By mask -выбрать объекты по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени объекта.
  • By list - объекты, выбранные вручную из списка.

Тип объектов можно выбрать из раскрывающегося списка, расположенного ниже.

  • Tables - таблицы.
  • Views - представления.
  • Tables and Views - таблицы и представления.

Нужные объекты отмечаются флажками в соответствующих списках.

Если Вы создаете шаг в шаблоне политики, тогда Вы можете ввести имена баз данных/таблиц/представлений вручную.

Service tasks - Entering databases and tables

Список редактируется с помощью кнопок, расположенных сбоку, или сочетаний клавиш.

- добавить объект в список (клавиша Insert).

При нажатии этой кнопки в нижней части формы появляется поле для ввода. Нажатие на кнопку Enter добавляет указанное в поле название базы в список.

EditItem - изменить пункт списка (клавиша Enter).

Cross - удалить пункт списка (клавиша Delete).

<< Предыдущий шаг

Следующий шаг >>


Задание параметров реорганизации

На этом шаге необходимо задать настройки операции реорганизации индексов.

Service tasks - Reorganizing indices - Defining rules

Reorganize/Rebuild indices if fragmentation level is above

Необходимо указать пределы фрагментации в процентах. При превышении этого ограничения индексы будут реорганизованы Reorganize или перестроены Rebuild.

CheckBox Compact large objects

При установке этого флажка будут сжиматься данные, имеющие типы image, text, ntext, varchar(max), nvarchar(max), varbinary(max) и xml data.

<< Предыдущий шаг

Следующий шаг >>


Выбор дополнительных опций

На этом шаге задайте параметры выполнения реорганизации индексов.

Service tasks - Reorganizing indices - Advanced options

Free space

RadioButton Reorganize pages with the default amount of free space - реорганизовать страницы, используя стандартный объем свободного пространства.

RadioButton Change free space per page percentage to - реорганизовать страницы, используя заданный объем свободного пространства. Задайте значение в процентах, показывающее, насколько полным компонент Database Engine должен сделать конечный уровень каждой индексной страницы во время создания или изменения индекса.

CheckBox Pad index (PAD_INDEX)

установите этот флажок, чтобы оставить свободное пространство на каждой странице промежуточных уровней индекса.

CheckBox Sort results in tempdb

Если установлен этот флажок, то промежуточные результаты сортировки, которые используются для создания индекса, хранятся в базе данных tempdb.

CheckBox Ignore duplicate keys

Если этот флажок установлен, то дублирующиеся ключи будут игнорироваться при реорганизации.

CheckBox Keep index online while reindexing

Будут ли базовые таблицы и связанные индексы доступны для запросов и изменения данных во время операций с индексами.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Reorganizing indices - Performing operation

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Обновление статистики

С помощью Update statistics wizard можно обновить данные о распределении ключевых значений одной или более статистических групп (коллекций) в определенной таблице или индексированном представлении.

Для запуска операции обновления статистики необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | UpdateStatistics Update statistics.

Для того чтобы статистика обновлялась автоматически в заданное время, необходимо включить шаг Update statistics в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Update statistics step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Update statistics step в появившемся окне.

Список шагов:

Задание имени

Выбор баз данных

Задание настроек

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Update Statistics - Naming template

Имя задается в поле Task name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор объектов

На этом шаге необходимо выбрать объекты для обновления статистики.

Service tasks - Update Statistics - Selecting database

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Objects

  • All - все объекты (таблицы и представления)
  • All user - таблицы и представления пользовательских баз данных
  • By mask -выбрать объекты по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени объекта.
  • By list - объекты, выбранные вручную из списка.

Тип объектов можно выбрать из раскрывающегося списка, расположенного ниже.

  • Tables - таблицы.
  • Views - представления.
  • Tables and Views - таблицы и представления.

Если Вы создаете шаг в шаблоне политики, тогда Вы можете ввести имена баз данных/таблиц/представлений вручную.

Service tasks - Entering databases and tables

Список редактируется с помощью кнопок, расположенных сбоку, или сочетаний клавиш.

- добавить объект в список (клавиша Insert).

При нажатии этой кнопки в нижней части формы появляется поле для ввода. Нажатие на кнопку Enter добавляет указанное в поле название базы в список.

EditItem - изменить пункт списка (клавиша Enter).

Cross - удалить пункт списка (клавиша Delete).

<< Предыдущий шаг

Следующий шаг >>


Задание настроек

На этом шаге необходимо задать настройки операции обновления статистики.

Service tasks - Update Statistics - Setting options

В разделе Update необходимо выбрать тип объектов, для которых будет обновлена статистика.

RadioButton All existing statistics - для всех объектов.

RadioButton Column statistics only - для столбцов таблицы.

RadioButton Index statistics only - для индексов таблицы.

Options

RadioButton Full scan - считывать все строки в таблицах и представлениях, чтобы собрать статистические данные.

Если выбрана опция RadioButton Sample, то Вы можете указать долю записей таблицы или индексированного представления, подлежащих выборке при сборе статистических данных для крупных таблиц или представлений. С помощью счетчика укажите число строк или процентов, которые будут участвовать в выборке для обновления статистики. Из раскрывающегося списка выберите единицы выборки:

  • PERCENT - проценты, (если указать 100%, то это будет равносильно выбору Fullscan);
  • ROW - строки.

Поскольку выборка осуществляется путем просмотра всех страниц данных, реальный объем выборки может не вполне точно соответствовать указанному объему. Если для PERCENT или ROWS указано значение 0, результатом является пустой набор статистики.

RadioButton Resample - статистические данные будут собраны с использованием наследуемого коэффициента выборки для всех существующих статистик, включая индексы. Если с указанным коэффициентом выборки производится выборка недостаточного количества строк, компонент Database Engine автоматически корректирует выборку, основываясь на количестве существующих строк в таблице или представлении.

Если установлен флажок CheckBox No recompute, то устаревшая статистика не подлежит автоматическому пересчету. Статистические данные устаревают в зависимости от количества операций INSERT, UPDATE и DELETE, выполненных в индексированных столбцах.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Update Statistics - Updating Statistics

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Регистрирация параметров базы данных

С помощью Database Parameters Logger wizard можно проверить параметры базы данных (например, информацию о резервных копиях, фрагментации индексов, журналов транзакций, файлы данных, операции проверки целостности и более) и просмотреть предупреждения, если параметры не удовлетворяют данным условиям для эффективного обслуживания базы данных.

Для запуска операции регистрации параметров базы данных, необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | ServerParametersLogger Database Parameters Logger.

Для того чтобы регистрация параметров базы данных выполнялась автоматически в заданное время, необходимо включить шаг Database Parameters Logger в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Database Parameters Logger step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Database Parameters Logger step в появившемся окне.

Просмотреть результаты выполнения этой операции можно на вкладке Активность.

Список шагов:

Задание имени

Выбор баз данных

Задание параметров проверки

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Server Params Logger - Naming template

Имя шаблона задается в поле Task name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор баз данных

На этом шаге необходимо выбрать базы данных для которых будет выполнена операция регистрации параметров.

Service tasks - Server Params Logger - Selecting database

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

При создании шаблонов невозможно выбрать конкретную базу данных, расположенную на конкретном сервере, можно только указать список названий баз данных. Если таковые будут присутствовать на сервере, то к ним будут применены операции обслуживания.

Service tasks - Entering databases

Список редактируется с помощью кнопок, расположенных сбоку, или сочетаний клавиш.

- добавить объект в список (клавиша Insert).

При нажатии этой кнопки в нижней части формы появляется поле для ввода. Нажатие на кнопку Enter добавляет указанное в поле название базы в список.

EditItem - изменить пункт списка (клавиша Enter).

Cross - удалить пункт списка (клавиша Delete).

<< Предыдущий шаг

Следующий шаг >>


Задание параметров проверки

На этом шаге необходимо выбрать события, которые будут внесены в журнал.

Service tasks - Server Params Logger - Setting options

Для каждой выбранной опции можно задать ряд дополнительных настроек. Элементы управления для задания этих опций отображаются в разделе Logging conditions и меняются в зависимости от выбранной опции.

CheckBox No backup

Включите эту опцию для регистрации баз данных, не имеющих резервных копий.

CheckBox Last full backup

Включите эту опцию для регистрации тех баз данных, для которых давно создавались полные резервные копии.

Давность можно указать с помощью счетчиков Last full backup older than.

CheckBox Last log backup

Включите эту опцию для регистрации тех баз данных, для которых давно создавались резервные копии журналов.

Давность можно указать с помощью счетчиков Last log backup older than.

CheckBox Index fragmentation

Установите этот флажок для регистрации индексов с высокой степенью фрагментации.

Степень фрагментации можно задать с помощью счетчиков Index fragmentation more than.

Only check indices with more than

Необходимо указать пределы фрагментации в процентах.

CheckBox Integrity check (SQL Server 2005 or higher)

Включите эту опцию для регистрации списка баз данных с устаревшей датой проверки целостности.

Давность можно указать с помощью счетчиков Last integrity check older than.

CheckBox Transaction log

Установите этот флажок, чтобы получить список баз данных, у которых объем свободного места в журнале транзакций меньше указанного значения.

Free space is less than

С помощью этого счетчика задайте предел свободного пространства для журналов транзакций.

Log file is larger than

В этом поле задайте максимально допустимый размер файла журнала базы данных. В отчет попадут файлы, превышающие указанный размер.

CheckBox Data file

В отчет должны попасть базы данных, у которых объем свободного места в файлах данных меньше, чем указано в поле Free space is less than.

Free space is less than

С помощью этого счетчика задайте предел свободного пространства файла данных.

Data file is larger than

В этом поле задайте максимально допустимый размер файла данных базы данных. В отчет попадут файлы, превышающие указанный размер.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Server Params Logger - Performing Operations

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Сжатие базы данных

С помощью Shrink database wizard можно уменьшить размер данных базы данных SQL Server и файлов журналов.

Для запуска операции сжатия базы данных необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | [image] Shrink database.

Для того чтобы сжатие базы данных выполнялось автоматически в заданное время, необходимо включить шаг Shrink database в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Shrink database step.
  2. На вкладке Templates при создании или редактировании шаблона политики шага или задачи выбрать Shrink database step в появившемся окне.

Список шагов:

Задание имени

Выбор баз данных

Задание настроек

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Shrink Database - Naming template

Имя шаблона задается в поле Task name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор баз данных

На этом шаге необходимо выбрать базы данных, которые необходимо сжать.

Service tasks - Shrink database - Selecting database

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных. Если сервер недоступен, то на этом сервере не установлены компоненты EMS SQL Backup или к этому серверу нет подключения.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

При создании шаблонов невозможно выбрать конкретную базу данных, расположенную на конкретном сервере, можно только указать список названий баз данных. Если таковые будут присутствовать на сервере, то к ним будут применены операции обслуживания.

Service tasks - Entering databases

Список редактируется с помощью кнопок, расположенных сбоку, или сочетаний клавиш.

- добавить объект в список (клавиша Insert).

При нажатии этой кнопки в нижней части формы появляется поле для ввода. Нажатие на кнопку Enter добавляет указанное в поле название базы в список.

EditItem - изменить пункт списка (клавиша Enter).

Cross - удалить пункт списка (клавиша Delete).

<< Предыдущий шаг

Следующий шаг >>


Задание настроек

На этом шаге необходимо задать параметры сжатия базы данных.

Service tasks - Shrink database - Setting options

Shrink database when it exceeds

Задайте размер в мегабайтах, при превышении которого выполняется сжатие базы данных.

Freed space

Amount of free space to remain after shrink

Прекратить сжатие, когда размер свободного пространства в базе данных достигнет этого значения.

Необходимо выбрать, будет ли освободившееся пространство сохранено в файлах базы данных - RadioButton Retain freed space in database files или возвращено операционной системе - RadioButton Returned freed space to operating system.

CheckBox Suppress informational messages

Если этот флажок установлен, то информационные сообщения не отображаются.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Shrink database - Shrinking database

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Очистка после обслуживания

С помощью Maintenance Cleanup wizard можно удалять файлы, относящиеся к планам обслуживания, включая файлы резервных копий баз данных и отчеты, созданные планами обслуживания. С помощью этой операции можно удалять как файлы, хранящиеся на сервере локально, так и файлы с удаленных облачных хранилищ. Удаление файлов MS SQL Server не поддерживается на SQL Server 2000.

Для запуска операции очистки после обслуживания необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | MaintenanceCleanup Maintenance Cleanup.

Для того чтобы очистка после обслуживания выполнялась автоматически в заданное время, необходимо включить шаг Maintenance Cleanup в политику.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Maintenance Cleanup step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Maintenance Cleanup step в появившемся окне.

Список шагов:

Задание имени

Выбор серверов

Задание параметров выполнения операции

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Maintenance Cleanup - Naming template

Имя задается в поле Name. В поле Description можно задать краткое описание операции.

Этот шаг отображается только при добавлении шага в политику или шаблон, но не отображается при создании Quick Maintenance Action.

Следующий шаг >>


Выбор серверов и директорий

На этом шаге необходимо выбрать серверы, для которых будет выполнена данная операция обслуживания и указать необходимые файлы или директории.

Service tasks - Maintenance cleanup - Selecting server

Servers

Отметьте серверы, для которых должна выполняться операция. Необходимо убедиться, что к серверу есть подключение.

Важно: Выбор серверов невозможен при создании шаблона.

Списком назначенных директорий можно управлять с помощью кнопок.

CreatePolicyTask Add file or folder specification - добавить файл или директорию.

EditStepM Edit specification - изменить добавленный объект.

DeletePolicyTask Remove selected - удалить добавленный объект из списка.

Cleanup specification

В этом диалоге необходимо задать расположение, в котором следует удалить файлы - сервер или облачное хранилище.

Service tasks - Maintenance cleanup - Define items to clear

Location

Выберете Server, если хотите очистить папки/файлы, хранящиеся локально на сервере.

Выберете Cloud storage для очистки файлов в облачном хранилище.

Provider

Выберите с помощью чего создавались резервные копии EMS SQL Backup или SQL Server.

Folder

Путь к необходимой директории задайте в этом поле. Путь должен быть задан относительно сервера, на котором производится выполнение операции.

Если выбран пункт MS SQL Server, то Вы можете указать конкретный файл резервной копии, который необходимо удалять.

Extension

В этом поле можно указать расширение для файлов, если они отличаются от принятых по умолчанию.

CheckBox Include subfolders/ CheckBox Include first-level subfolders

Установите этот флажок, чтобы включить в выполнение все вложенные директории в выбранной.

В выпадающем списке File type выберите, файлы какого типа следует удалять:

  • Backups - файлы резервной копии;
  • Reports - текстовые отчеты предыдущих запусков планов обслуживания.

Важно: Этот выпадающий список доступен только в случае, если в поле Provider выбран пункт MS SQL Server.

Cloud storage

Service tasks - Maintenance cleanup - Define items to clear - Cloud

Задайте хранилище, в котором Вы хотите удалить файлы резервных копий. Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Если Вы создаете новое подключение, то после настройки его параметров Вам будет предложено сохранить его.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

All files by mask

В этом поле задайте маску, по которой будут отфильтрованы файлы для удаления.

CheckBox Include backup parts

Установите этот флажок, чтобы программа производила поиск связанных частей одной резервной копии для каждого найденного файла с заданных расширением или маской. Найденные связанные файлы будут также удалены.

Важно: Эта опция доступна только для файлов поставщика типа EMS SQL Backup. Эта опция не применяется, если в качестве места поиска задано облачное хранилище, а в качестве маски - "*.*".

<< Предыдущий шаг

Следующий шаг >>


Задание параметров выполнения операции

На этом шаге можно задать параметры очистки после обслуживания.

Service tasks - Maintenance cleanup - Defining cleanup criteria

SQL Backup and Clouds criteria

RadioButton All files older than - удалить все файлы, хранящиеся дольше указанного срока.

RadioButton All files except for the latest - удалить все файлы кроме заданного числа последних.

SQL Server criteria

CheckBox Apply file age criteria when cleaning maintenance

Используйте эту опцию, чтобы удалить файлы старше указанной даты.

Delete files older than - удалить все файлы, хранящиеся дольше указанного срока.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Maintenance cleanup - Performing operation

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Доставка журналов

С помощью Transaction Log Shipping можно создавать резервные копии журналов транзакций и отправлять их на выбранный сервер через общую папку.

Для выполнения доставки журналов необходимо иметь не меньше двух экземпляров сервера SQL.

Версия сервера назначения не может быть ниже, чем исходного.

Для исходной базы данных должна использоваться полная или bulk-logged модель восстановления.

У обоих серверов должен быть доступ к общей папке. Базы данных, восстанавливаемые на сервере назначения, остаются в режиме restoring или standby.

Важно: Эта операция обслуживания не включена в список [image] Quick Maintenance Actions. Она может выполняться только будучи включенной в политику.

Для включения операции обслуживания в политику необходимо выполнить одно из следующих действий.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Log Shipping step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Log Shipping step в появившемся окне.

Список шагов:

Задание имени

Задание пар баз данных

Задание параметров резервного копирования

Задание директорий параметров восстановления

Выполнение операции

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Имя задается в поле Name. В поле Description можно задать краткое описание операции.

Следующий шаг >>


Задание пар баз данных

На этом шаге необходимо задать пары баз данных для передачи журналов транзакций.

Transaction Log_Specify database pairs

Source server

Из этого раскрывающегося списка можно выбрать сервер, на котором расположена исходная база данных, резервную копию которой надо перенести.

Destination server

Из этого раскрывающегося списка необходимо выбрать сервер, на который будут отправлены журналы транзакций.

Задайте пары баз данных в таблице, указав исходные и назначенные в полях Source DB и Destination DB соответственно. Выбираемая в качестве назначенной база данных должна находиться в состоянии Restoring и являться восстановленной копией исходной базы, в противном случае нужно использовать опции Overwrite или Create new.

Если на назначенном сервере не существует такой базы данных, то в поле Destination DB можно выбрать действие Create New для создания новой базы. При создании новой базы данных в поле New database необходимо указать ее имя.

Создание и перезапись базы данных осуществляется путем создания полной резервной копии исходной базы данных и ее последующего восстановления. Даже в случае запланированного исполнения, создание базы данных осуществляется непосредственно при завершении работы мастера.

Чтобы перезаписать существующую базу данных, установите флажок CheckBox Overwrite.

Файлы резервных копий журналов транзакций, хранящиеся на исходном сервере, переносятся и восстанавливаются на назначенном сервере.

При создании и перезаписи базы выполнение операции будет проходить в 2 этапа:

  • Перенос полной резервной копии базы данных.
  • Перенос журнала транзакций базы данных.

Важно: Первый этап будет выполнен только при создании политики. Второй этап будет выполняться по расписанию.

Data folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам MDF.

Log folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам LDF.

Важно: При создании шаблона этот шаг отсутствует.

<< Предыдущий шаг

Следующий шаг >>


Задание параметров резервного копирования

На этом шаге можно задать настройки резервного копирования для исходных баз данных.

Transaction Log_Specify backup options

Backup folder

Укажите каталог для резервного копирования. Расположение необходимо указывать относительно исходного сервера. Путь можно ввести вручную или задать в окне, открывающемся при нажатии на кнопку EllipsisButton . Можно проверить наличие директории, нажав на кнопку Check.

Max Thread Count

Максимальное число потоков, которые будут использованы для операции резервного копирования.

CheckBox Compression

Использовать сжатие для резервной копии.

Compression Level

Степень сжатия можно задать в этом поле: '1' - максимальная скорость создания резервной копии, '9' - максимальная степень сжатия.

CheckBox Encryption

Включите опцию для использования шифрования.

Encryption Password

В этом поле можно указать пароль, который будет использоваться для расшифровки резервной копии. В поле Confirm Password подтвердите заданный пароль.

Encryption Type

Тип шифрования выберите из этого раскрывающегося списка.

CheckBox Keep backups on the source server

Включение этой опции позволит сохранять все файлы резервных копий журналов транзакций на исходном сервере в папке, заданной в поле Backup folder.

<< Предыдущий шаг

Следующий шаг >>


Задание директорий и параметров восстановления

На этом шаге задайте необходимые настройки для общей и назначенной директорий и параметры восстановления журнала транзакций.

Transaction Log_Specify folders and recovery options

Network shared folder

Укажите общую папку для копирования резервных копий журналов транзакций исходной базы данных.

Оба сервера, между которыми происходит передача файлов журналов, должны иметь доступ к этой директории. Параметры авторизации доступа в общую папку задайте в разделе Authorization.

Проверить наличие этого доступа можно с помощью кнопки Check.

Destination folder

Укажите папку, в которую будут помещены файлы журналов транзакций. Назначенный сервер должен иметь к ней доступ. Проверить наличие доступа можно с помощью кнопки Check.

Recovery options

Эта группа опций позволяет задать параметры восстановления.

RadioButton No recovery (leaves the database in the restoring state)

Без восстановления (оставить базу данных в режиме восстановления). Настраивает операцию восстановления на отмену отката любых незавершенных транзакций.

Важно: При выборе этого типа восстановления база данных не может быть использована в промежуточном состоянии до полного восстановления.

Важно: База данных принудительно оставляется в состоянии восстановления после выполнения операции, если для восстановления использовались файл или файловая группа. Это полезно в одном из следующих случаев:

  • скрипт восстановления был запущен, и журнал был применен;
  • используется последовательность файлов восстановления, и база данных не предназначена для выполнения двух операций восстановления.

RadioButton Standby (leaves database in read-only and standby mode)

Режим ожидания (оставить в режиме ожидания и только для чтения). Следует также указать резервный файл, с помощью которого можно отменить результаты восстановления. Этот параметр разрешается применять для автономного восстановления (в том числе частичного восстановления). Параметр не разрешается использовать при оперативном восстановлении. При попытке указать параметр Standby для оперативного восстановления операция восстановления заканчивается неудачей. Инструкцию Standby также не разрешается применять, если необходимо обновление базы данных.

Undo File Name - имя файла отката. Это резервный файл, местонахождение которого хранится в журнале базы данных. Если файл с таким именем существует, то он перезаписывается. В противном случае компонент Database Engine создает этот файл.

Важно: При недостатке места на диске, операция останавливается.

CheckBox Kill connections to destination database

Для принудительного отключения от всех баз данных установите этот флажок. Рекомендуется устанавливать этот флажок, если на втором шаге была выбрана опция Overwrite.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Transaction Log_Performing operation

Для начала выполнения операции, нажмите кнопку Run.

Если на втором шаге было указано, что будет создана новая база, то она будет создана до выполнения резервного копирования и восстановления.

При создании и перезаписи базы выполнение операции будет проходить в два этапа:

  1. Перенос полной резервной копии базы данных.
  2. Перенос журнала транзакций базы данных.

<< Предыдущий шаг


Массовое восстановление

С помощью операции обслуживания Bulk Restore можно выполнять восстановление сразу множества БД, указав лишь директорию для поиска файлов резервных копий и опции восстановления.

Для запуска операции массового восстановления необходимо на вкладке Servers в контекстном меню сервера выбрать пункт [image] Quick Maintenance Actions | BulkRestore Bulk Restore.

Для включения операции обслуживания в политику необходимо выполнить одно из следующих действий.

  1. На вкладке Policies в Мастере создания политик на шаге определения набора задач при создании шага выбрать в появившемся окне Bulk Restore step.
  2. На вкладке Templates при создании или редактировании шаблона политики, шага или задачи выбрать Bulk Restore step в появившемся окне.

Список шагов:

Задание имени

Выбор серверов

Задание опций восстановления

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

На первом шаге мастера укажите имя и описание создаваемого шага.

Service tasks - Bulk Restore - Naming template

Следующий шаг >>


Выбор серверов

На этом шаге необходимо выбрать серверы, для которых будет выполнена данная операция обслуживания и указать необходимые директории.

Service tasks - Bulk Restore - Selection

Restore Source Folder

В этом поле необходимо задать директорию, в которой будет производится поиск файлов резервных копий. Резервные копии для восстановления подбираются следующим образом. Программа сканирует все файлы резервных копий и выбирает из них все БД. Для каждой БД выбирается резервная копия на самую последнюю дату. Если эта резервная копия - бэкап лога транзакций или разностный бэкап, программа подбирает все необходимые предшествующие бэкапы для восстановления БД.

Target Data Folder

В этом поле необходимо задать директорию, в которую будут перемещены файлы данных БД при восстановлении.

Target Log Folder

В этом поле необходимо задать директорию, в которую будут перемещены файлы журнала транзакций БД при восстановлении.

Если операция вызывается вне политики (Quick Maintenance Action), то диалог настроек выглядит следующим образом.

Service tasks - Bulk Restore - Database Selection

Для заполнения списка БД нажмите кнопку Fill databases. После сканирования директории и поиска БД их имена будут отображаться в столбце Database name, а время последней найденной резервной копии в столбце Point. Используйте флажки для выбора необходимых для восстановления БД.

<< Предыдущий шаг

Следующий шаг >>


Задание параметров восстановления

На этом шаге можно задать настройки восстановления БД, резервные копии которых были найдены на предыдущем шаге.

Service tasks - Bulk Restore - Restore Options

CheckBox Verify only (RESTORE VERIFYONLY) - проверить набор файлов резервной копии. С помощью проверки резервной копии можно проконтролировать ее физическую доступность, убедиться в том, что все файлы резервной копии могут быть прочитаны и восстановлены, и в том, что резервную копию можно восстановить в любой момент.

CheckBox WITH REPLACE (will be applied for all databases in the list)

Если установлен этот флажок, то при совпадении имен существующие базы данных будут перезаписаны.

<< Предыдущий шаг

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций.

Service tasks - Bulk Restore - Viewing summary information

Если все задано верно, то можно начать выполнение операции, нажав кнопку Run.

О процессе выполнения операции и возникших ошибках сообщается в появляющемся окне.

<< Предыдущий шаг


Редактирование операций обслуживания

Уже созданную операцию обслуживания можно просмотреть и изменить в соответствующем редакторе.

Открыть операцию обслуживания в редакторе можно одним из следующих способов.

  • На вкладке Policies выбрать в редактируемой политике нужное задание. Открыть шаг двойным щелчком мыши или выбрать в контекстном меню шага пункт Edit step.
  • На вкладке Templates в разделе Шаблоны политик выбрать в редактируемой политике нужное задание. Открыть шаг двойным щелчком мыши или выбрать в контекстном меню шага пункт Edit step.
  • На вкладке Templates в разделе Шаблоны задач выбрать задачу для редактирования, затем в открывшемся редакторе задач на вкладке Step открыть шаг двойным щелчком мыши или выбрать в контекстном меню шага пункт Edit step.

Резервное копирование базы данных

Пересылка баз данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Сжатие базы данных

Реорганизация индексов

Обновление статистики

Регистрирование параметров базы данных

Очистка после обслуживания

Доставка журналов

Массовое восстановление

Смотрите также:

Шаблоны задач

Шаблоны шагов

Шаблоны политик

Создание операций обслуживания


Резервное копирование базы данных

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Backup Database.

Вкладки редактора:

Задание имени

Исполнитель операции резервного копирования

Выбор баз данных

Параметры для EMS SQL Backup

Параметры файла резервной копии

Параметры для SQL Server

Параметры проверки резервной копии

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Backup Database - Name_Description

В поле Description можно задать краткое описание операции.


Исполнитель операции резервного копирования

На этой вкладке отображается исполнитель операции резервного копирования.

Editing Service task template - Backup Database - General

RadioButton EMS SQL Backup

Резервные копии создаются сразу для нескольких баз данных с дополнительными настройками. Резервные копии, созданные таким способом не могут быть восстановлены средствами SQL Server. Для преобразования резервных копий существует конвертер резервных копий.

RadioButton SQL Server

Резервные копии создаются для одной базы данных. Для выполнения операции используются средства SQL сервера.


Выбор баз данных

На этой вкладке можно изменить тип резервной копии и выбрать серверы и базы данных.

Editing Service task template - Backup Database - Databases

Backup Type

В этом разделе можно выбрать тип резервной копии.

RadioButton Database - full - полное резервное копирование всей базы, включая журнал транзакций.

RadioButton Database - differential - в резервную копию добавляются изменения, сделанные в базе данных с момента последнего полного резервного копирования.

RadioButton Transaction log - создается резервная копия части журнала транзакций, начинающаяся с конца последней успешно созданной копии и заканчивающаяся текущим концом журнала. До создания первой резервной копии журнала необходимо создать полную резервную копию базы данных.

Установите флажок CheckBox Remove inactive entries чтобы очистить текущий журнал транзакций после создания резервной копии.

CheckBox Leave in restoring state - оставить базу данных в состоянии восстановления, чтобы сделать ее недоступной для пользователей до полного восстановления.

CheckBox Copy-only - создать резервную копию только для копирования. Это резервная копия, изолированная от обычной последовательности резервных копий SQL Server.

CheckBox Skip SIMPLE model DBs - пропускать БД, которые имеют модель восстановления SIMPLE. Если эта опция выключена, и БД, использующие модель SIMPLE, попадают в список/фильтр, сервер вернет ошибку, и процесс будет завершен. Включите эту опцию во избежание подобных ошибок.

Backup Component

В этом разделе можно выбрать тип объект для резервной копии.

RadioButton Database - резервная копия БД.

RadioButton Files and filegroups - резервная копия отдельных файлов и файловых групп.

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Databases

Выбрать для резервного копирования одновременно несколько баз данных можно только в том случае, если резервная копия создается средствами EMS SQL Backup. Для этого на втором шаге мастера должен быть выбран RadioButton EMS SQL Backup.

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Если Вы редактируете шаг при создании политики на основе шаблона, то в случае, когда базы данных, заданные на шаге выбора баз данных отсутствуют на выбранном сервере, список баз будет выглядеть следующим образом.

Editing Service task - Clean mismatches

Нажмите кнопку Clean Mismatches, чтобы удалить отсутствующие базы из списка.

Если в качестве объекта бэкапа выбрано Files and filegroups, то помимо выбора БД становится доступен выбор файлов и файловых групп.

Service tasks - Backup Database - SQL Angel backup - Selecting filegroups

Objects

Для каждой выбранной БД дожен быть выбран набор файлов и файловых групп.

  • All - все файловые группы БД целиком.
  • By list - файлы и файловые группы, выбранные вручную.


Параметры для EMS SQL Backup

На этой вкладке можно задать параметры резервного копирования. Эта вкладка отображается, только если резервная копия базы данных создается средствами EMS SQL Backup.

Editing Service task template - Backup Database - Angel Options

Max Thread Count

Максимальное число потоков, которые будут использованы для операции резервного копирования.

CheckBox Compression

Использовать сжатие для резервной копии.

Compression Level

Степень сжатия можно задать в этом поле. '1' - максимальная скорость создания резервной копии, '9' - максимальная степень сжатия.

CheckBox Encryption

Включите опцию для использования шифрования.

Encryption Password

В этом поле можно указать пароль, который будет использоваться для расшифровки резервной копии. В поле Confirm Password подтвердите заданный пароль.

Encryption Type

Тип шифрования выберите из этого раскрывающегося списка.


Параметры файла резервной копии

На этой вкладке можно задать параметры файла резервной копии. Эта вкладка отображается, только если резервная копия базы данных создается средствами EMS SQL Backup.

Editing Service task template - Backup Database - Angel Files

Backup folder

В этом поле указывается директория, в которой должна быть создана резервная копия. Вы можете использовать следующие теги: {backup_root_folder} и {server}. Директория, для которой используется тег {backup_root_folder} указывается в диалоге Свойства службы.

Чтобы проверить доступность указанной директории, нажмите на кнопку Check.

Важно: Кнопка Check доступна только при настройке резервного копирования на одном сервере.

Backup file name

В этом поле задайте имя файла резервной копии. В имени файла можно использовать теги: {server}, {database}, {backup_type}, {date} и {login}.

Важно: Чтобы добавить тег в поле ввода необходимо кликнуть по нему один раз в списке Available tags.

RadioButton Backup to a single file

Выберите эту опцию для резервного копирования всех выбранных баз данных в один файл.

RadioButton Backup to several files

Резервная копия должна быть разделена на несколько файлов.

RadioButton Split by size

Файл резервной копии будет разделен на тома указанного размера.

RadioButton Split by database

Для каждой базы данных будет создана резервная копия в виде отдельного файла.


Options

SQL Backup
  • Index
  • « Prev
  • Next »

Параметры SQL Server

На этой вкладке можно задать параметры резервного копирования. Эта вкладка отображается только в случае, если резервная копия базы данных создается средствами SQL сервера. Так выглядит диалог для SQL Server 2008 и младше.

Editing Service task template - Backup Database - Backup Options

Block size

В разделе Block size задайте размер физического блока в байтах. Поддерживаются размеры 512, 1 024, 2 048, 4 096, 8 192, 16 384, 32 768 и 65 536 байт (64 КB).

RadioButton Default - размер блока по умолчанию. Значение по умолчанию равно 65536 для ленточных устройств и 512 для других устройств.

RadioButton To restore from CD (2 KB) - если создается резервная копия, которую планируется копировать на компакт-диск и восстанавливать с него, выберите этот пункт.

RadioButton С помощью счетчика Other задайте любое другое произвольное значение.

Backup Password

В поле Password можно указать пароль, который будет использоваться для открытия резервной копии. В поле Confirm Password подтвердите заданный пароль.

В разделе Write type - укажите: перезаписать файл резервной копии или добавить в него новую информацию.

RadioButton Append - добавить на носитель,

RadioButton Overwrite - перезаписать носитель.

CheckBox Backup compression - включить сжатие резервной копии.

Диалог для серверов, поддерживающих шифрование резервных копий, выглядит так.

Editing Service task template - Backup Database - Backup Options2014

Backup encryption

В этом разделе можно настроить шифрование резевных копий средствами SQL Server.

CheckBox Encrypt backup - включить шифрование резервной копии.

Выберите алгоритм шифрования в поле Algorithm. В поле Certificate or assymmetric key выберите сертификат или ассиметричный ключ. Помните, что выбраны могут быть только сертификаты, защищенные мастер-ключом, и ассиметричные ключи из расширенного управления ключами (EKM).


Дополнительные параметры

Эта вкладка отображается, только если резервная копия базы данных создается средствами SQL сервера.

Editing Service task template - Backup Database - Additional_options

В поле Buffer count укажите общее число буферов ввода-вывода, которые будут использоваться для операции резервного копирования.

Наибольший объем пакета данных в байтах для обмена между SQL Server и носителем резервного набора задайте в поле Max transfer size, Kb. Поддерживаются значения, кратные 65 536 байтам (64 КБ), вплоть до 4 194 304 байт (4 МБ).

Важно: Если в поле указано значение "0", то автоматически будет использоваться значение по умолчанию.


Параметры проверки резервной копии

На этой вкладке можно задать параметры проверки резервной копии.

Editing Service task template - Backup Database - Verify Options

CheckBox Verify backup when finished (VERIFYONLY) - проверить копию после завершения операции. С помощью проверки резервной копии можно проконтролировать ее физическую доступность, убедиться в том, что все файлы резервной копии могут быть прочитаны и восстановлены, и в том, что резервную копию можно восстановить в любой момент

CheckBox Perform checksum before writing to media (CHECKSUM) - создать контрольную сумму перед записью копии на резервный носитель. Независимо от того, присутствует ли контрольная сумма страницы или нет, инструкция BACKUP создаст отдельные контрольные суммы резервных копий для потока резервных файлов.

Если установлен флажок CheckBox Continue on error, то при возникновении ошибки в контрольной сумме, операция не будет остановлена.

CheckBox Detect possible backup sequence breaks - анализировать последовательность бэкапов на предмет возможных разрывов цепочки восстановления. Данная опция доступна, если выбран тип резервной копии Differential или Transaction log. Если эта опция включена, программа анализирует все записи в истории резервных копий, которые будут необходимы при восстановлении на текущую резервную копию. В случае, если в этой последовательности будет найдена хотя бы одна резервная копия, выполненная сторонним приложением, программа сгенерирует предупреждение о том, что при восстановлении потребуются файлы резерных копий, созданные разными приложениями.

Использование данной опции позволяет выявить случаи, когда резервные копии выполняются неявным образом через интерфейс VSS, работающими на сервере планами обслуживания либо другим сторонним ПО, и могут нарушить или усложнить последовательность восстановления, обеспечиваемую EMS SQL Backup.


Облачные хранилища

На этой вкладке задайте параметры подключения к облачным хранилищам, в которые Вы хотите загружать копии файлов бэкапов.

Поддерживаются подключения к следующим видам хранилищ:

  • SMB/CIFS
  • FTP
  • Secure FTP
  • Amazon S3 Cloud
  • Microsoft Azure
  • Google Drive
  • Dropbox

Editing Service task template - Backup Database - Clouds

Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

CheckBox Don't save backup files on the server side

При выполнении резервного копирования EMS SQL Backup выполняет загрузку данных в облачные/сетевые хранилища "на лету" одновременно с получением данных от сервера. Если включена эта опция, запись на локальный диск сервера выполняться не будет. Это позволяет сохранить свободное место на диске, однако, в случае ошибок загрузки файла во все выбранные облачные хранилища, консистентный файл или набор файлов резервной доступен не будет.


Пересылка баз данных

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Database shipping.

Вкладки редактора:

Задание имени и описания

Задание параметров пересылки баз данных

Задание пар баз данных

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени и описания

Имя операции обслуживания задается в поле Name.

Editing Service task template - Database Shipping - Name

В поле Description можно задать краткое описание операции.


Параметры резервной копии

На этой вкладке задайте парамерты резервной копии при перемещении БД.

Editing Service task template - Database Shipping - Backup

Backup folder

Укажите директорию для резервного копирования. Расположение необходимо указывать относительно исходного сервера. Путь можно ввести вручную или задать в окне, открывающемся при нажатии на кнопку EllipsisButton . Можно проверить доступность директории, нажав на кнопку Check.

Max Thread Count

Максимальное число потоков, которые будут использованы для операции резервного копирования.

CheckBox Compression

Использовать сжатие для резервной копии.

Compression Level

Степень сжатия можно задать в этом поле. '1' - максимальная скорость создания резервной копии, '9' - максимальная степень сжатия.

CheckBox Encryption

Включите опцию для использования шифрования.

Encryption Password

В этом поле можно указать пароль, который будет использоваться для расшифровки резервной копии. В поле Confirm Password подтвердите заданный пароль.

Encryption Type

Тип шифрования выберите из этого раскрывающегося списка.

CheckBox Keep backups on the source server

Включение этой опции позволит сохранять все файлы резервных копий на исходном сервере в папке, заданной в поле Backup folder.


Параметры восстановления

На этой вкладке задайте парамерты восстановления при перемещении БД.

Editing Service task template - Database Shipping - Restore

Network shared folder

Укажите общую папку для копирования файлов резервных копий исходных баз данных.

Оба сервера, между которыми происходит передача файлов журналов, должны иметь доступ к этой директории. Параметры авторизации доступа в общую папку задайте в разделе Authorization.

Проверить наличие этого доступа можно с помощью кнопки Check.

В разделе Authorization задайте параметры авторизации доступа в сетевую папку. Windows Authentication - авторизация Windows.

Важно: Помните, что авторизация будет происходить от имени пользователей, под которыми запущены службы EMS SQL Backup Serviсе на исходном и целевом серверах.

Destination folder

Укажите папку, в которую будут помещены файлы резервных копий. Назначенный сервер должен иметь к ней доступ. Проверить наличие доступа можно с помощью кнопки Check.

Recovery options

Эта группа опций позволяет задать параметры восстановления.

RadioButton No Recovery - без восстановления (оставить базу данных в режиме восстановления). Настраивает операцию восстановления на отмену отката любых незавершенных транзакций. Если впоследствии должен применяться другой журнал транзакций, то следует указать параметр No Recovery или Standby.

RadioButton Standby - режим ожидания (оставить в режиме ожидания и только для чтения). Следует также указать резервный файл, с помощью которого можно отменить результаты восстановления. Этот параметр разрешается применять для автономного восстановления (в том числе частичного восстановления). Параметр не разрешается использовать при оперативном восстановлении. При попытке указать параметр Standby для оперативного восстановления операция восстановления заканчивается неудачей. Инструкцию Standby также не разрешается применять, если необходимо обновление базы данных.

Undo File Name - имя файла отката. Это резервный файл, местонахождение которого хранится в журнале базы данных. Если файл с таким именем существует, то он перезаписывается. В противном случае компонент Database Engine создает этот файл.

RadioButton Recovery - восстановление (откат всех неподтвержденных транзакций). Настраивает операцию восстановления на откат любых незавершенных транзакций. После процедуры восстановления база данных готова к использованию.

Важно: При недостатке места на диске операция останавливается.

CheckBox Kill connections to destination database

Для принудительного отключения от всех баз данных установите этот флажок.


Задание пар баз данных

На этой вкладке можно задать пары баз данных для пересылки баз данных.

Editing Service task template - Database Shipping - Selection

Source server

Из этого раскрывающегося списка необходимо выбрать сервер, на котором расположена исходная база данных, резервную копию которой надо перенести.

Destination server

Из этого раскрывающегося списка необходимо выбрать сервер, на который будут отправлены файлы резервного копирования.

Задайте пары баз данных в таблице, указав исходные и назначенные в полях Source DB и Destination DB соответственно.

Если на назначенном сервере не существует необходимой базы данных, то в поле Destination DB можно выбрать действие Create New для создания новой базы. При создании новой базы данных в поле New database необходимо указать ее имя.

Создание базы данных осуществляется путем создания полной резервной копии исходной базы данных и ее последующего восстановления.

Data folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам MDF.

Log folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам LDF.

Важно: При редактировании шаблона отсутствует возможность выбора баз данных.


Выполнение задания агента SQL Server

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Execute SQL Server Agent Job.

Вкладки редактора:

Задание имени

Основные параметры

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Execute EMS SQL Agent server job - Name

В поле Description можно указать краткую информацию об объекте.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно просмотреть и изменить соответствие между экземпляром сервера и заданием, которое должно быть выполнено.

Editing Service task template - Execute EMS SQL Agent server job - General

В разделе Servers можно выбрать серверы, на которых должен быть выполнено выбранное задание. Само задание необходимо выбрать из списка Available SQL Server Agent's Job.

Важно: Если сервер недоступен, то службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером.


Выполнение инструкции T-SQL

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Execute T-SQL Statement.

Вкладки редактора:

Задание имени

Основные параметры

Выбор серверов

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Execute T-SQL statement - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно просматривать и редактировать инструкцию T-SQL.

Editing Service task template - Execute T-SQL statement - General

Введите необходимую инструкцию T-SQL в поле редактора T-SQL statement.

В поле Execute timeout можно задать ограничения по времени для выполнения процедуры проверки оператора.

Загрузить\Сохранить текст оператора можно с помощью кнопок Load\Save.

С помощью кнопки Check statement можно проверить синтаксис оператора T-SQL. Для проверки синтаксиса оператор выполняется на сервере в режиме PARSEONLY.

На вкладке Errors отображаются информация об ошибках, найденных в операторе.

Editing Service task template - Execute T-SQL statement - General_error


Выбор серверов

На этой вкладке можно выбрать серверы, на которых будет выполняться заданная инструкция T-SQL.

Editing Service task template - Execute T-SQL statement - Selection

Servers

В разделе Servers необходимо выбрать серверы на которых должна быть выполнена создаваемая инструкция T-SQL.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Для выбранного сервера справа отображается описание и версия.


Очистка истории

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания History Cleanup.

Вкладки редактора:

Задание имени

Основные параметры

Выбор серверов

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - History Cleanup - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке необходимо выбрать историю какого типа следует удалить.

Editing Service task template - History Cleanup - General

MS SQL Server

В этом разделе задайте временные параметры для удаляемой истории резервного копирования MS SQL и некоторой информации журналов выполнения заданий.

EMS SQL Backup

Следующие опции предназначены для удаления информации некоторых журналов операций, выполняемых EMS SQL Backup.

CheckBox Backup and restore history data older than

Установите этот флажок, чтобы удалить все записи истории резервного копирования и восстановления, давность которых больше заданного периода.

CheckBox SQL Server Agent job history data older than

Установите этот флажок, чтобы удалить все записи истории заданий агента SQL Server, давность которых больше заданного периода.


Выбор серверов

На этой вкладке можно выбрать серверы, на которых будет выполняться данная операция.

Editing Service task template - History Cleanup - Selection

В разделе Servers необходимо выбрать серверы. Для выбранного сервера справа отображается описание и версия.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.


Проверка целостности баз данных

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Database Integrity Check.

Вкладки редактора:

Задание имени

Основные параметры

Выбор серверов и баз данных

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Database Integrity Check - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно задать параметры, необходимые для выполнения операции.

Editing Service task template - Database Integrity Check - General

CheckBox Exclude indexes checks (NOINDEX)

При включенной опции проверка некластеризованных индексов для пользовательских таблиц выполняться не будет. Это уменьшает общее время выполнения.

CheckBox Perform logical checks on indexes (EXTENDED_LOGICAL_CHECKS)

При уровне совместимости 100 (SQL Server 2008) и выше выполняются логические проверки согласованности индексированных представлений, XML-индексов и пространственных индексов.

CheckBox Limit the checking to

Установите этот флажок, если необходимо выполнить проверку с условиями:

RadioButton Physical Only (PHYSICAL_ONLY). Осуществляется проверка целостности физической структуры страниц и заголовков записей, физической структуры сбалансированных деревьев и целостности выделения пространства в базе данных.

RadioButton Data Purity (DATA_PURITY). Осуществляется проверка таблицы на недействительность или выход из допустимого диапазона значений столбцов.

CheckBox Apply lock during check (TABLOCK)

Указание значения аргумента приводит к получению инструкцией DBCC CHECKDB блокировок вместо использования внутреннего моментального снимка базы данных. Это включает краткосрочное использование монопольной блокировки на базу данных.

CheckBox Write detailed error messages (ALL_ERRORMSGS)

Отображает все сформированные для объекта ошибки. Если флажок не установлен, то будут отображаться лишь первые 200 сообщений об ошибках для каждого объекта.

CheckBox Suppress info messages (NO_INFOMSGS)

Если установлен этот флажок, то информационные сообщения не будут отображаться.

Operation timeout

Эта опция позволяет задать время ожидания, в течение которого может выполняться данная операция. По истечении этого времени программа вернет ошибку.


Выбор серверов и баз данных

На этой вкладке можно выбрать серверы, на которых будет выполняться данная операция.

Editing Service task template - Database Integrity Check - Databases

В разделе Servers необхоимо выбрать те серверы, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Если Вы редактируете шаг при создании политики на основе шаблона, то в случае, когда базы данных, заданные на шаге выбора баз данных отсутствуют на выбранном сервере, то список баз будет выглядеть следующим образом.

Editing Service task - Clean mismatches

Нажмите кнопку Clean Mismatches, чтобы удалить отсутствующие базы из списка.


Сжатие базы данных

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Shrink Database.

Вкладки редактора:

Задание имени

Основные параметры

Выбор баз данных

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Shrink Database - Name

В поле Description можно задать краткое описание операции.


Основные параметры

На этой вкладке можно просмотреть и изменить параметры сжатия баз данных.

Editing Service task template - Shrink Database - General

Shrink database when it exceeds

Задайте размер в мегабайтах, при превышении которого выполняется сжатие базы данных.

Freed space

Amount of free space to remain after shrink

Прекратить сжатие, когда размер свободного пространства в базе данных достигнет этого значения.

Необходимо выбрать, будет ли освободившееся пространство сохранено в файлах базы данных - RadioButton Retain freed space in database files или возвращено операционной системе - RadioButton Returned freed space to operating system.

CheckBox Suppress informational messages

Если этот флажок установлен, то информационные сообщения не отображаются.


Выбор баз данных

На этой вкладке можно просматривать и выбирать базы данных, которые необходимо сжать.

Editing Service task template - Shrink Database - Databases

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Если Вы редактируете шаг при создании политики на основе шаблона, то в случае, когда базы данных, заданные на шаге выбора баз данных отсутствуют на выбранном сервере, то список баз будет выглядеть следующим образом.

Editing Service task - Clean mismatches

Нажмите кнопку Clean Mismatches, чтобы удалить отсутствующие базы из списка.


Реорганизация индексов

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Reorganize Indices.

Вкладки редактора:

Задание имени

Основные параметры

Выбор объектов

Параметры перестройки индексов

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Reorganizing indices - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно изменить основные параметры операции обслуживания.

Editing Service task template - Reorganizing indices - General

Reorganize/Rebuild indices if fragmentation level is above

Необходимо указать пределы фрагментации в процентах. При превышении этого ограничения индексы будут реорганизованы Reorganize или перестроены Rebuild.

CheckBox Compact large objects

При установке этого флажка будут сжиматься данные, имеющие типы image, text, ntext, varchar(max), nvarchar(max), varbinary(max) and xml data.


Выбор объектов

На этой вкладке можно выбрать объекты, содержащие индексы, которые необходимо реорганизовать.

Editing Service task template - Reorganizing indices - Databases

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Objects

  • All - все объекты (таблицы и представления)
  • All user - таблицы и представления пользовательских баз данных
  • By mask -выбрать объекты по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени объекта.
  • By list - объекты, выбранные вручную из списка.

Тип объектов можно выбрать из раскрывающегося списка, расположенного ниже.

  • Tables - таблицы.
  • Views - представления.
  • Tables and Views - таблицы и представления.

Нужные объекты отмечаются флажками в соответствующих списках.

Если Вы редактируете шаг при создании политики на основе шаблона, то в случае, когда базы данных/таблицы/представления, заданные на шаге выбора объектов отсутствуют на выбранном сервере, то их список будет выглядеть следующим образом.

Editing Service task - Clean mismatches (tables and views)

Нажмите кнопку Clean Mismatches, чтобы удалить отсутствующие базы данных/таблицы/представления из списка.


Параметры перестройки индексов

На этой вкладке можно просмотреть и изменить параметры перестройки индексов.

Editing Service task template - Reorganizing indices - Rebuild options

Free space

RadioButton Reorganize pages with the default amount of free space - реорганизовать страницы, используя стандартный объем свободного пространства.

RadioButton Change free space per page percentage to - реорганизовать страницы, используя заданный объем свободного пространства. Задайте значение в процентах, показывающее, насколько полным компонент Database Engine должен сделать конечный уровень каждой индексной страницы во время создания или изменения индекса.

CheckBox Pad index (PAD_INDEX)

Установите этот флажок, чтобы оставить свободное пространство на каждой странице промежуточных уровней индекса.

CheckBox Sort results in tempdb

Если установлен этот флажок, то промежуточные результаты сортировки, которые используются для создания индекса, хранятся в базе данных tempdb.

CheckBox Ignore duplicate keys

Если этот флажок установлен, то дублирующиеся ключи будут игнорироваться при реорганизации.

CheckBox Keep index online while reindexing

Будут ли базовые таблицы и связанные индексы доступны для запросов и изменения данных во время операций с индексами.


Обновление статистики

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Update Statistics.

Вкладки редактора:

Задание имени

Основные параметры

Выбор объектов

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Update Statistics - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно просмотреть и при необходимости изменить настройки обновления статистики.

Editing Service task template - Update Statistics - General

В разделе Update необходимо выбрать тип объектов, для которых будет обновлена статистика.

RadioButton All existing statistics - для всех объектов.

RadioButton Column statistics only - для столбцов таблиц.

RadioButton Index statistics only - для индексов таблиц.

Options

RadioButton Full scan - считывать все строки в таблицах и представлениях, чтобы собрать статистические данные.

Если выбрана опция RadioButton Sample, то Вы можете указать долю записей таблицы или индексированного представления, подлежащих выборке при сборе статистических данных для крупных таблиц или представлений. С помощью счетчика укажите число строк или процентов, которые будут участвовать в выборке для обновления статистики. Из раскрывающегося списка выберите единицы выборки:

  • PERCENT - проценты, (если указать 100%, то это будет равносильно выбору Fullscan);
  • ROW - строки.

Поскольку выборка осуществляется путем просмотра всех страниц данных, реальный объем выборки может не вполне точно соответствовать указанному объему. Если для PERCENT или ROWS указано значение 0, результатом является пустой набор статистики.

RadioButton Resample - статистические данные будут собраны с использованием наследуемого коэффициента выборки для всех существующих статистик, включая индексы. Если с указанным коэффициентом выборки производится выборка недостаточного количества строк, компонент Database Engine автоматически корректирует выборку, основываясь на количестве существующих строк в таблице или представлении.

Если установлен флажок CheckBox No recompute, то устаревшая статистика не подлежит автоматическому пересчету. Статистические данные устаревают в зависимости от количества операций INSERT, UPDATE и DELETE, выполненных в индексированных столбцах.


Выбор объектов

На этой вкладке можно выбирать серверы, базы данных и объекты, для которых необходимо выполнить обновление статистики.

Editing Service task template - Update Statistics - Databases

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • By list - базы данных, выбранные вручную.

Objects

  • All - все объекты (таблицы и представления)
  • All user - таблицы и представления пользовательских баз данных
  • By mask -выбрать объекты по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени объекта.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Тип объектов можно выбрать из раскрывающегося списка, расположенного ниже.

  • Tables - таблицы.
  • Views - представления.
  • Tables and Views - таблицы и представления.

Если Вы редактируете шаг при создании политики на основе шаблона, то в случае, когда базы данных/таблицы/представления, заданные на шаге выбора объектов отсутствуют на выбранном сервере, то их список будет выглядеть следующим образом.

Editing Service task - Clean mismatches (tables and views)

Нажмите кнопку Clean Mismatches, чтобы удалить отсутствующие базы данных/таблицы/представления из списка.


Регистрирование параметров базы данных

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Database Parameters Logger.

Вкладки редактора:

Задание имени и описания

Основные параметры

Выбор объектов

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени и описания

Имя операции обслуживания задается в поле Name.

Editing Service task template - Server Params Logger - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно просмотреть и при необходимости изменить настройки регистрирования параметров базы данных.

Editing Service task template - Server Params Logger - General

Для каждой выбранной опции можно задать ряд дополнительных настроек. Элементы управления для задания этих опций отображаются в разделе Logging conditions и меняются в зависимости от выбранной опции.

CheckBox No backup

Включите эту опцию для регистрации баз данных, не имеющих резервных копий.

CheckBox Last full backup

Включите эту опцию для регистрации тех баз данных, для которых давно создавались полные резервные копии.

Давность можно указать с помощью счетчиков Last full backup older than.

CheckBox Last log backup

Включите эту опцию для регистрации тех баз данных, для которых давно создавались резервные копии журналов.

Давность можно указать с помощью счетчиков Last log backup older than.

CheckBox Index fragmentation

Установите этот флажок для регистрации индексов с высокой степенью фрагментации.

Степень фрагментации можно задать с помощью счетчиков Index fragmentation more than.

Only check indices with more than

Необходимо указать пределы фрагментации в процентах.

CheckBox Integrity check (SQL Server 2005 or higher)

Включите эту опцию для регистрации списка баз данных с устаревшей датой проверки целостности.

Давность можно указать с помощью счетчиков Last integrity check older than.

CheckBox Transaction log

Установите этот флажок, чтобы получить список баз данных, у которых объем свободного места в журнале транзакций меньше указанного значения.

Free space is less than

С помощью этого счетчика задайте предел свободного пространства для журналов транзакций.

Log file is larger than

В этом поле задайте максимально допустимый размер файла журнала базы данных. В отчет попадут файлы, превышающие указанный размер.

CheckBox Data file

В отчет должны попасть базы данных, у которых объем свободного места в файлах данных меньше, чем указано в поле Free space is less than.

Free space is less than

С помощью этого счетчика задайте предел свободного пространства файла данных.

Data file is larger than

В этом поле задайте максимально допустимый размер файла данных базы данных. В отчет попадут файлы, превышающие указанный размер.


Выбор баз данных

На этой вкладке можно просматривать и выбирать базы данных, параметры которых необходимо регистрировать.

Editing Service task template - Server Params Logger - Databases

Servers

Необходимо отметить те сервера, на которых находятся нужные базы данных.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов недоступен при создании шаблона.

Databases

  • All - системные и пользовательские базы данных.
  • All system - все системные базы данных.
  • All user - все пользовательские базы данных.
  • By mask - выбрать базы данных по маске. Используйте символ "*" для обозначения любого символа и символ "?" для одного любого символа в имени базы данных.
  • Including - все выбранные базы данных.
  • Excluding - все базы данных за исключением выбранных.
  • Online only - все базы данных в режиме online.

Если Вы редактируете шаг при создании политики на основе шаблона, то в случае, когда базы данных, заданные на шаге выбора баз данных отсутствуют на выбранном сервере, то список баз будет выглядеть следующим образом.

Editing Service task - Clean mismatches

Нажмите кнопку Clean Mismatches, чтобы удалить отсутствующие базы из списка.


Очистка после обслуживания

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Maintenance Cleanup.

Вкладки редактора:

Задание имени

Основные параметры

Выбор серверов и фалов планов обслуживания

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Maintenance Cleanup - Name

В поле Description можно задать краткое описание операции.


General

SQL Backup
  • Index
  • « Prev
  • Next »

Основные параметры

На этой вкладке можно просмотреть и при необходимости изменить настройки операции очистки после обслуживания.

Editing Service task template - Maintenance Cleanup - General

SQL Backup and Clouds criteria

RadioButton All files older than - удалить все файлы, хранящиеся дольше указанного срока.

RadioButton All files except for the latest - удалить все файлы кроме заданного числа последних.

SQL Server criteria

CheckBox Apply file age criteria on maintenance cleanup

Используйте эту опцию, чтобы удалить файлы старше указанной даты.

Delete files older than - удалить все файлы, хранящиеся дольше указанного срока.


Выбор серверов и директорий

На этой вкладке можно выбрать серверы, для которых будет выполнена данная операция обслуживания и указать необходимые файлы или директории.

Editing Service task template - Maintenance Cleanup - Selection

Servers

Отметьте серверы, для которых должна выполняться операция.

Важно: Если службы EMS SQL Backup не запущены или не установлены, или нет соединения с сервером, то сервер недоступен для выбора.

Важно: Выбор серверов невозможен при создании шаблона.

Списком назначенных директорий можно управлять с помощью кнопок.

CreatePolicyTask Add file or folder specification - добавить файл или директорию.

EditStepM Edit specification - изменить добавленный объект.

DeletePolicyTask Remove selected - удалить добавленный объект из списка.

Cleanup specification

В этом диалоге необходимо задать расположение, в котором следует удалить файлы - сервер или облачное хранилище.

Service tasks - Maintenance cleanup - Define items to clear

Location

Выберете Server, если хотите очистить папки/файлы, хранящиеся локально на сервере.

Выберете Cloud storage для очистки файлов в облачном хранилище.

Provider

Выберите с помощью чего создавались резервные копии EMS SQL Backup или SQL Server.

Folder

Путь к необходимой директории задайте в этом поле. Путь должен быть задан относительно сервера, на котором производится выполнение операции.

Если выбран пункт MS SQL Server, то Вы можете указать конкретный файл резервной копии, который необходимо удалять.

Extension

В этом поле можно указать расширение для файлов, если они отличаются от принятых по умолчанию.

CheckBox Include subfolders/ CheckBox Include first-level subfolders

Установите этот флажок, чтобы включить в выполнение все вложенные директории в выбранной.

В выпадающем списке File type выберите, файлы какого типа следует удалять:

  • Backups - файлы резервной копии;
  • Reports - текстовые отчеты предыдущих запусков планов обслуживания.

Важно: Этот выпадающий список доступен только в случае, если в поле Provider выбран пункт MS SQL Server.

Cloud storage

Service tasks - Maintenance cleanup - Define items to clear - Cloud

Задайте хранилище, в котором Вы хотите удалить файлы резервных копий. Вы можете создать новое подключение, нажав на кнопку Create new connection, или добавить уже существующее, нажав на кнопку Add existing connection. В последнем случае появится список подключений, заданных на вкладке Cloud Connections диалога Options.

Если Вы создаете новое подключение, то после настройки его параметров Вам будет предложено сохранить его.

Чтобы поменять параметры добавленного подключения, нажмите на его имя. В зависимости от типа подключения откроется соответствующий диалог для его настройки.

All files by mask

В этом поле задайте маску, по которой будут отфильтрованы файлы для удаления.

CheckBox Include backup parts

Установите этот флажок, чтобы программа производила поиск связанных частей одной резервной копии для каждого найденного файла с заданным расширением или маской. Найденные связанные файлы будут также удалены.

Важно: Эта опция доступна только для файлов поставщика типа EMS SQL Backup. Эта опция не применяется, если в качестве места поиска задано облачное хранилище, а в качестве маски - "*.*".


Доставка журналов

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Log Shipping.

Вкладки редактора:

Задание имени и описания

Задание параметров резервного копирования

Задание пар баз данных

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени и описания

Имя операции обслуживания задается в поле Name.

Editing Service task template-Transaction Log Shipping-Name

В поле Description можно задать краткое описание операции.


Параметры резервной копии

На этой вкладке задайте параметры резервной копии доставки журналов.

Backup folder

Укажите каталог для резервного копирования. Расположение необходимо указывать относительно исходного сервера. Путь можно ввести вручную или задать в окне, открывающемся при нажатии на кнопку EllipsisButton . Можно проверить наличие директории, нажав на кнопку Check.

Max Thread Count

Максимальное число потоков, которые будут использованы для операции резервного копирования.

CheckBox Compression

Использовать сжатие для резервной копии.

Compression Level

Степень сжатия можно задать в этом поле. '1' - максимальная скорость создания резервной копии, '9' - максимальная степень сжатия.

CheckBox Encryption

Включите опцию для использования шифрования.

Encryption Password

В этом поле можно указать пароль, который будет использоваться для расшифровки резервной копии. В поле Confirm Password подтвердите заданный пароль.

Encryption Type

Тип шифрования выберите из этого раскрывающегося списка.

Editing Service task template-Transaction Log Shipping-Backup

CheckBox Keep backups on the source server

Включение этой опции позволит сохранять все файлы резервных копий журналов транзакций на исходном сервере в папке, заданной в поле Backup folder.


Параметры восстановления

На этой вкладке задайте параметры восстановления журналов.

Editing Service task template-Transaction Log Shipping-Restore

Network shared folder

Укажите общую папку для копирования резервных копий журналов транзакций исходной базы данных.

Оба сервера, между которыми происходит передача файлов журналов, должны иметь доступ к этой директории. Параметры авторизации доступа в общую папку задайте в разделе Authorization.

Проверить наличие этого доступа можно с помощью кнопки Check.

В разделе Authorization задайте параметры авторизации доступа в сетевую папку. Windows Authentication - авторизация Windows.

Важно: Помните, что авторизация будет происходить от имени пользователей, под которыми запущены службы EMS SQL Backup Serviсе на исходном и целевом серверах.

Destination folder

Укажите папку, в которую будут помещены файлы журналов транзакций. Назначенный сервер должен иметь к ней доступ. Проверить наличие доступа можно с помощью кнопки Check.

Recovery options

Эта группа опций позволяет задать параметры восстановления.

RadioButton No recovery (leaves database in the restoring state)

Без восстановления (оставить базу данных в режиме восстановления). Настраивает операцию восстановления на отмену отката любых незавершенных транзакций.

Важно: При выборе этого типа восстановления база данных не может быть использована в промежуточном состоянии до полного восстановления.

Важно: База данных принудительно оставляется в состоянии восстановления после выполнения операции, если для восстановления использовались файл или файловая группа. Это полезно в одном из следующих случаев:

  • скрипт восстановления был запущен и журнал был применен;
  • используется последовательность файлов восстановления, и база данных не предназначена для выполнения двух операций восстановления.

RadioButton Standby (leaves database in read-only and standby mode)

Режим ожидания (оставить в режиме ожидания и только для чтения). Следует также указать резервный файл, с помощью которого можно отменить результаты восстановления. Этот параметр разрешается применять для автономного восстановления (в том числе частичного восстановления). Параметр не разрешается использовать при оперативном восстановлении. При попытке указать параметр Standby для оперативного восстановления операция восстановления заканчивается неудачей. Инструкцию Standby также не разрешается применять, если необходимо обновление базы данных.

Undo File Name - имя файла отката. Это резервный файл, местонахождение которого хранится в журнале базы данных. Если файл с таким именем существует, то он перезаписывается. В противном случае компонент Database Engine создает этот файл.

Важно: При недостатке места на диске, операция останавливается.

CheckBox Kill connections to destination database

Для принудительного отключения от всех баз данных установите этот флажок.


Задание пар баз данных

На этой вкладке можно задать пары баз данных для передачи журналов транзакций.

Editing Service task template-Transaction Log Shipping-Selectioon

Source server

Из этого раскрывающегося списка можно выбрать сервер, на котором расположена исходная база данных, резервную копию которой надо перенести.

Destination server

Из этого раскрывающегося списка необходимо выбрать сервер, на который будут отправлены журналы транзакций.

Задайте пары базы данных в таблице, выбрав для исходной базы данных назначенную в поле Destination DB. Файлы резервных копий журналов транзакций, хранящиеся на исходном сервере, переносятся и выполняются на назначенном сервере.

Чтобы перезаписать существующую базу данных, установите флажок CheckBox Overwrite.

Если при редактировании будет задана опция Overwrite или задано создание новой БД, то первый этап операции выполнится сразу при применении настроек (нажатии OK), при этом при следующем открытии на редактировании опция Overwrite будет сброшена, а вместо <Create new> будет подставлено имя БД, созданной при применении предыдущей измененной конфигурации.

Если на назначенном сервере не существует такой базы данных, то в поле Destination DB можно выбрать действие Create New для создания новой базы. При создании новой базы данных в поле New Database необходимо указать ее имя.

Создание и перезапись базы данных осуществляется путем создания полной резервной копии исходной базы данных и ее последующего восстановления. Даже в случае запланированного исполнения, создание базы данных осуществляется непосредственно при завершении работы мастера.

Data folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам MDF.

Log folder

Для создаваемой базы данных в этом поле нужно указать путь к файлам LDF.

Важно: При редактировании шаблона отсутствует возможность выбора баз данных.


Массовое восстановление

В этом редакторе можно просмотреть и изменить параметры ранее созданной операции обслуживания Bulk Restore.

Вкладки редактора:

Задание имени

Выбор серверов

Задание опций восстановления

Смотрите также:

Резервное копирование базы данных

Выполнение задания агента SQL Server

Выполнение оператора T-SQL

Очистка истории

Проверка целостности баз данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Регистрирация параметров базы данных

Очистка после обслуживания

Доставка журналов

Пересылка баз данных

Массовое восстановление


Задание имени

Имя операции обслуживания задается в поле Name.

Editing Service task template - Bulk Restore - Name

В поле Description можно задать краткое описание операции.


Выбор серверов

На этой вкладке необходимо выбрать серверы, для которых будет выполнена данная операция обслуживания и указать или изменить необходимые директории.

Editing Service task template - Bulk Restore - Selection

Restore Source Folder

В этом поле необходимо задать директорию, в которой будет производится поиск файлов резервных копий. Резервные копии для восстановления подбираются следующим образом. Программа сканирует все файлы резервных копий и выбирает из них все БД. Для каждой БД выбирается резервная копия на самую последнюю дату. Если эта резервная копия - бэкап лога транзакций или разностный бэкап, программа подбирает все необходимые предшествующие бэкапы для восстановления БД.

Target Data Folder

В этом поле необходимо задать директорию, в которую будут перемещены файлы данных БД при восстановлении.

Target Log Folder

В этом поле необходимо задать директорию, в которую будут перемещены файлы журнала транзакций БД при восстановлении.


Задание опций восстановления

На этой вкладке можно изменить настройки восстановления БД.

Editing Service task template - Bulk Restore - Options

CheckBox Verify only - проверить набор файлов резервной копии. С помощью проверки резервной копии можно проконтролировать ее физическую доступность, убедиться в том, что все файлы резервной копии могут быть прочитаны и восстановлены, и в том, что резервную копию можно восстановить в любой момент.

CheckBox WITH REPLACE (will be applied for all databases in the list)

Если установлен этот флажок, то при совпадении имен существующие базы данных будут перезаписаны.


Меню "шестеренка"

EMS SQL Backup располагает набором инструментов, позволяющих изменять настройки приложения.

Доступ к настройкам можно получить в меню, которое открывается при нажатии кнопку шестеренок Options в верхнем левом углу окна EMS SQL Backup Console.

Сохранение/Загрузка конфигурации

Настройки системы можно сохранять для последующего использования и восстановления настроек.

Настройки окружения

С помощью этого инструменты Вы можете изменять основные настройки программы EMS SQL Backup.

Смотрите также:

Начало работы

Управление серверами

Управление политиками обслуживания

Шаблоны

Активность

Операции обслуживания


Сохранение/Загрузка конфигурации

Настройки системы можно сохранять для последующего использования и восстановления настроек. Можно сохранять регистрационную информацию серверов, политики, расписания, задания и т.д. Эти настройки можно сохранять в XML файле или в специальной таблице базы данных, где они будут храниться также в формате XML.

Switch Configuration

Можно изменить текущую конфигурацию программы, выбрав в меню программы пункт Switch configuration.

Если предыдущая конфигурация не была сохранена, то она будет утеряна.

Save Configuration

Сохранить конфигурацию, выбрав в меню программы пункт Save configuration.

Configuration - Load

RadioButton Store in a configuration file on your local computer - хранить файл конфигурации на локальном компьютере.

В поле File Name укажите путь к xml файлу конфигурации и имя этого файла.

RadioButton Store in an SQL Server database - хранить параметры конфигурации в базе данных.

Server Name

Из этого раскрывающегося списка выберите сервер (хост), к которому хотите подключиться. В этот список программа автоматически добавляет серверы, найденные в локальной сети. Если SQL-DMO components установлены на клиентском компьютере, используется их функция ListAvailableSQLServers. Если SQL-DMO components не установлены, используется функция NetServerEnum из netapi32.dll. Если данная библиотека не установлена, то при первом открытии программы этот список будет пуст, и имя сервера необходимо будет задать вручную. В этом случае в списке Server name будут отображаться те серверы, базы данных которых уже зарегистрированы в программе.

Важно: Имя сервера не всегда может отображаться в списке, тогда вводите его вручную.

SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2005 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в Server name Вы должны будете указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

В разделе Authentication задается способ идентификации пользователя на сервере.

RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

RadioButton SQL Server Authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

При выборе SQL Server Authentication следует указать имя и пароль в полях User name и Password соответственно.

Connection timeout

Время ожидания в секундах при подключении к SQL Server.

Database Name

Из этого раскрывающегося списка выберите базу данных, в которой будет храниться конфигурация.

Test Connection

Проверку подключения можно выполнить, нажав на кнопку Test Connection.

Schema - схема базы данных, в которой находится таблица конфигурации.

Options Table Name - таблица параметров конфигурации.

CheckBox Switch to saved configuration - перейти к сохраненной конфигурации. Если этот флажок не установлен, то будет выполнен экспорт настроек.


Опции

С помощью этого инструменты Вы можете изменять основные настройки программы EMS SQL Backup.

Чтобы открыть настройки окружения необходимо в меню программы выбрать пункт Environment Options.

Безопасность

Параметры обновления


Основные

На вкладке General можно задать настройки безопасности для конфигурационной информации и установить часовой пояс для консоли EMS SQL Backup.

Environment Options - Connection Settings

Значение параметра Home time zone использутеся при планировании заданий в политиках.

При первом запуске программы EMS SQL Backup Administration Console часовой пояс Home time zone устанавливается равным часовому поясу, который установлен на компьютере. При изменении часового пояса на компьютере часовой пояс программы не изменяется автоматически. Его необходимо переключить, выбрав необходимый часовой пояс из выпадающего списка Home time zone.

Под выпадающим списком Home time zone указан Local time zone - часовой пояс, который установлен на компьютере, на котором запущена программа EMS SQL Backup Administration Console.

Важно: После изменения значения Home time zone все политики, которые были запланированы с учетом часового пояса консоли, будут заново созданы в соответствие с примененными изменениями.

Encrypt configuration data

Если этот флажок установлен, то конфигурационная информация хранится в зашифрованном виде.

Пароль запрашивается при запуске программы, когда загружаются данные конфигурации.

В полях Password и Confirm password задайте пароль и подтверждение пароля для доступа к этой конфигурационной информации.

Параметры обновления


Параметры обновления данных

На этой вкладке задайте настройки частоты выполнения обновлений вкладок программы.

Environment options - Refresh Options

Server refresh interval (sec)

В этом поле укажите в секундах интервал, с которым на вкладке Servers будет обновляться отображаемая информация о серверах.

Log view depth (days)

В этом поле укажите число дней, за которое должна отображаться история запуска и выполнения политик на странице История политик и в списке запусков Launches.

Launches records per page

В этом поле укажите, сколько записей о запусках задач/политик, следует отображать в списке Launches.


Параметры облачных соединений

На вкладке Cloud Connections Вы можете задать параметры для подключения к облачным хранилищам, в которых Вы можете хранить копии файлов резервных копий баз данных. При настройке операции резервного копирования баз данных на шаге Настройка облачных хранилищ Вы сможете выбрать необходимое хранилища из этого списка.

Environment options - Cloud connections

Чтобы добавить подключение к хранилищу в список, нажмите кнопку Create new connection. Задайте параметры нового подключения с помощью открывшегося мастера создания облачных хранилищ.

Для изменения параметров добавленного подключения нажмите на его имя в списке. В этом случае откроется редактор облачных соединений.

Удалить добавленное подключение можно, нажав кнопку Delete.


Мастер создания облачных соединений

С помощью мастера Cloud Connection Settings Wizard можно пошагово задать параметры создаваемого облачного подключения.

Открыть этот мастер можно несколькими способами.

  • Нажать кнопку Create new connection на вкладке Cloud connections диалога Options.
  • Нажать кнопку Create new connection на шаге настройки подключений к хранилищам мастера операции резервного копирования базы данных.

Список шагов:

Выбор типа соединения

Настройки соединения SMB/CIFS

Настройки соединения FTP

Настройки соединения SFTP

Настройки соединения с Amazon S3

Настройки соединения с Microsoft Azure

Настройки соединения с Dropbox

Настройки соединения с Google Drive

Настройка авторизации

Выполнение операции


Выбор типа соединения

На этом шаге выберите тип создаваемого облачного подключения.

Options - Cloud connections - Wizard - Type

Следующий шаг зависит от выбранного на этом шаге типа облачного соединения.

Важно: Для использования некоторых типов облачных соединений есть ограничения.

  • FTP, SFTP, SMB/CIFS, Dropbox можно использовать для всех типов лицензий, включая бесплатную (Free).
  • Google Drive может использоваться для лицезий EMS SQL Backup for SQL Server и EMS SQL Backup PRO for SQL Server.
  • S3, Azure может использоться только для лицензии EMS SQL Backup PRO for SQL Server.


Настройки соединения SMB/CIFS

На этом шаге задайте настройки подключения SMB/CIFS.

Options - Cloud connections - Wizard - Cifs

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Folder

Задайте путь к директории на локальном или удаленном компьютере, в которой будут храниться копии файлов бэкапа. Нажмите кнопку EllipsisButton , чтобы открыть диалог обзора папок. При нажатии на кнопку OpenFolder откроется указанная директория. Путь к сетевой папке должен быть задан в формате UNC.

Задайте параметры аутентификации для загрузки файлов бэкапа в указанную папку. Убедитесь, что у указанного пользователя есть права записи в указанную папку. Если отмечена опция CheckBox Windows Authentication, то имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

В поле User name укажите имя пользователя, в поле Password - пароль.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения FTP

На этом шаге задайте настройки подключения к FTP.

Options - Cloud connections - Wizard - FTP

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Host address

Задайте имя сервера FTP или его IP-адрес (без указания протокола).

Remote folder

Задайте имя папки на FTP сервере, в которую будут загружаться копии файлов бэкапов. Если указанная директория не существует на сервере, то она будет создана перед загрузкой файла.

Задайте параметры аутентификации для загрузки файлов бэкапа в указанную папку. Убедитесь, что у указанного пользователя есть права записи в указанную папку. Включите опцию CheckBox Anonymous logon для анонимного входа или же укажите имя пользователя в User name, в поле Password — пароль.

Protocol

С помощью этого выпадающего списка Вы можете задать способ шифрования соединения с удаленным сервером:

  • FTP (Standard)
  • FTPS (Implicit SSL/TLS)
  • FTPS (Explicit SSL/TLS)

Port

В этом поле Вы можете изменить порт, по которому осуществляется соединение.

Mode

С помощью этого выпадающего списка Вы можете изменить режим подключения к FTP серверу:

  • Passive (PASV)
  • Active (PORT)

Если для подключения к FTP Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout

Задайте время ожидания (в секундах) при подключении к FTP серверу.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения SFTP

На этом шаге задайте настройки подключения SFTP.

Options - Cloud connections - Wizard - SFTP

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Host address

Задайте имя сервера SSH или его IP адрес (без указания протокола).

Port

В этом поле Вы можете изменить порт, по которому осуществляется соединение.

Remote folder

Задайте имя папки на SFTP сервере, в которую будут загружаться копии файлов бэкапов. Если указанная директория не существует на сервере, то она будет создана перед загрузкой файла.

Задайте параметры аутентификации для загрузки файлов бэкапа в указанную папку. Убедитесь, что у указанного пользователя есть права записи в указанную папку. Если отмечена опция CheckBox Windows Authentication, то имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

В поле User name укажите имя пользователя, в поле Password - пароль.

Proxy

Выберите тип прокси-сервера, через которое должно осуществляться соединение с SFTP сервером:

  • Socks 4
  • Socks 5
  • HTTP

Если для подключения к SFTP серверу Вы выбрали прокси, то задайте параметры подключения:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout

Задайте время ожидания (в секундах) при подключении к SFTP серверу.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения с Amazon S3

На этом шаге задайте настройки подключения к Amazon S3.

Options - Cloud connections - Wizard - S3

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Bucket

Задайте имя хранилища, которое будет использоваться для хранения файлов бэкапов. Создать хранилище (bucket) можно на сайте Amazon. Если указанное хранилище не существует, то оно будет автоматически создано в регионе US Standard. Имя хранилища должно быть уникальным среди всех хранилищ на Amazon.

Path

Если Вы хотите хранить файлы бэкапов в папке, то в этом поле задайте путь к этой папке в указанном хранилище. Если указанной папки не существует в хранилище, то она будет создана автоматически при загрузке файла. Используйте '/' в качестве разделителя пути (например: 'backups/Adventure Works').

В полях Access key и Secret key задайте ключ доступа и секретный ключ для доступа к хранилищу. Эти ключи Вы можете найти на странице Security Credentials Вашего аккаунта Amazon Web Services.

Storage class

Из выпадающего списка выберите класс хранения загружаемых файлов бэкапов:

  • Standard
  • Reduced Redundancy

Protocol

С помощью этого выпадающего списка Вы можете задать протокол передачи файлов - с шифрованием (HTTPS) или без (HTTP).

Если для подключения к сервису Amazon Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout

Задайте время ожидания (в секундах) при подключении к сервису Amazon.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения с Microsoft Azure

На этом шаге задайте настройки подключения к Microsoft Azure.

Options - Cloud connections - Wizard - Azure

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Account name

Введите имя учетной записи хранилища Microsoft Azure. Имя учетной записи образует поддомен URL адреса BLOB-объекта.

Account key

Введите ключ доступа к учетной записи. Может быть использован как первичный, так и вторичный ключ.

Container

Каждый BLOB-объект в хранилище Azure располагается в контейнере. Из выпадающего списка можно выбрать один из существующих контейнеров. Также, Вы можете ввести имя нового контейнера, удовлетворяющего требованиям именования. Чтобы просмотреть правила именования контейнеров, наведите курсор мыши на иконку Question .

Если для подключения к сервису Microsoft Azure Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout, sec

Задайте время ожидания (в секундах) для выполнения операций на сервисе Microsoft Azure.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения с Dropbox

На этом шаге задайте настройки подключения к Dropbox.

Options - Cloud connections - Wizard - Dropbox

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Folder

EMS SQL Backup по умолчанию загружает файлы в папку 'Apps/EMS SQL Backup' на Dropbox. Если Вы хотите хранить файлы бэкапов в подпапке этой папки, то в этом поле задайте путь к этой подпапке. Если указанной папки не существует в хранилище, то она будет создана автоматически при загрузке файла. Используйте '/' в качестве разделителя пути (например: 'backups/Adventure Works', в этом случае файлы будут загружены в 'Apps/EMS SQL Backup/backups/Adventure Works').

Если для подключения к сервису Dropbox Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

<< Предыдущий шаг

Следующий шаг >>


Настройки соединения с Google Drive

На этом шаге задайте настройки подключения к Google Drive.

Options - Cloud connections - Wizard - GoogleDrive

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Folder

EMS SQL Backup по умолчанию загружает файлы в корень хранилища Google Drive. Если Вы хотите хранить файлы бэкапов в папкe, то в этом поле задайте путь к этой папке. Если указанной папки не существует в хранилище, то она будет создана автоматически при загрузке файла. Используйте '/' в качестве разделителя пути (например: 'backups/Adventure Works').

Если для подключения к сервису Google Drive Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

<< Предыдущий шаг

Следующий шаг >>


Настройки авторизации

Для некоторых облачных сервисов, таких как Google Drive и Dropbox, необходимо получение параметров авторизации через Web. На этом шаге необходимо задать или получить параметры авторизации.

Options - Cloud connections - Wizard - Auth

Authorization type

В этом разделе нужно задать источник параметров авторизации для доступа в хранилище.

RadioButton Online authorization - получение информации об авторизации через Web. Для получения информации необходимо нажать кнопку Get authorization info, выполнить вход в аккаунт хранилища в открывшемся окне браузера и подтвердить доступ приложению EMS SQL Backup. После успешного входа и подтверждения доступа в окне браузера будет выведено сообщение, подтверждающее подключение и получение кодов. Код доступа будет сохранен программой, и предупреждение рядом с кнопкой Next исчезнет. Используйте этот метод, если Вы еще не настраивали подключение к выбранному сервису через EMS SQL Backup.

RadioButton Authorization from file - использование информации об авторизации из файла. Если Вы предварительно сохраняли информацию об авторизации в файл, то Вы можете указать путь к этому файлу в поле ввода (либо выбрать его, нажав кнопку EllipsisButton ).

RadioButton Manual authorization - явное задание предварительно полученной информации об авторизации. Скопируйте имеющийся код доступа в поле ввода.

После первоначального получения авторизации методом Online authorization, она сохраняется программой и может быть выгружена для дальнейшего использования с помощью нажатия кнопки Copy authorization info. Выберите To clipboard в выпадающем меню для копировании информации в буфер обмена. Для сохранения информации об авторизации в файл выберите To file в выпадающем меню и задайте путь в стандартном диалоге сохранения файла Windows.

Следующий шаг >>


Выполнение операции

На этом шаге мастера можно просмотреть значения всех заданных на предыдущих шагах опций и проверить соединение с облачным хранилищем .

Options - Cloud connections - Wizard - Finish

Чтобы проверить доступ к указанному на предыдущих шагах хранилищу, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Редактор облачных соединений

С помощью редактора Cloud Connection Settings Editor можно изменить параметры ранее созданного облачного подключения.

Открыть этот редактор можно несколькими способами.

  • Кликнуть имя существующего подключения на вкладке Cloud connections диалога Options.
  • Кликнуть на добавленное подключение на шаге настройки подключений к хранилищам мастера операции резервного копирования базы данных.

Список вкладок редактора:

Настройки соединения SMB/CIFS

Настройки соединения FTP

Настройки соединения SFTP

Настройки соединения с Amazon S3

Настройки соединения с Microsoft Azure

Настройки соединения с Dropbox

Настройки соединения с Google Drive

Настройка авторизации


Настройки соединения SMB/CIFS

На этой вкладке Вы можете изменить настройки подключения SMB/CIFS.

Options - Cloud connections - Editor - Cifs

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Folder

Задайте путь к директории на локальном или удаленном компьютере, в которой будут храниться копии файлов бэкапа. Нажмите кнопку EllipsisButton , чтобы открыть диалог обзора папок. При нажатии на кнопку OpenFolder откроется указанная директория. Путь к сетевой папке должен быть задан в формате UNC.

Задайте параметры аутентификации для загрузки файлов бэкапа в указанную папку. Убедитесь, что у указанного пользователя есть права записи в указанную папку. Если отмечена опция CheckBox Windows Authentication, то имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

В поле User name укажите имя пользователя, в поле Password - пароль.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки соединения FTP

На этой вкладке Вы можете изменить настройки подключения FTP.

Options - Cloud connections - Editor - FTP

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Host address

Задайте имя сервера FTP или его IP адрес (без указания протокола).

Remote folder

Задайте имя папки на FTP сервере, в которую будут загружаться копии файлов бэкапов. Если указанная директория не существует на сервере, то она будет создана перед загрузкой файла.

Задайте параметры аутентификации для загрузки файлов бэкапа в указанную папку. Убедитесь, что у указанного пользователя есть права записи в указанную папку. Если отмечена опция CheckBox Windows Authentication, то имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

В поле User name укажите имя пользователя, в поле Password - пароль.

Protocol

С помощью этого выпадающего списка Вы можете задать способ шифрования соединения с удаленным сервером:

  • FTP (Standard)
  • FTPS (Implicit SSL/TLS)
  • FTPS (Explicit SSL/TLS)

Port

В этом поле Вы можете изменить порт, по которому осуществляется соединение.

Mode

С помощью этого выпадающего списка Вы можете изменить режим подключения к FTP серверу:

  • Passive (PASV)
  • Active (PORT)

Если для подключения к FTP Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout

Задайте время ожидания (в секундах) при подключении к FTP серверу.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки соединения SFTP

На этой вкладке Вы можете изменить настройки подключения FTP.

Options - Cloud connections - Editor - SFTP

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Host address

Задайте имя сервера SSH или его IP адрес (без указания протокола).

Port

В этом поле Вы можете изменить порт, по которому осуществляется соединение.

Remote folder

Задайте имя папки на SFTP сервере, в которую будут загружаться копии файлов бэкапов. Если указанная директория не существует на сервере, то она будет создана перед загрузкой файла.

Задайте параметры аутентификации для загрузки файлов бэкапа в указанную папку. Убедитесь, что у указанного пользователя есть права записи в указанную папку. Если отмечена опция CheckBox Windows Authentication, то имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows.

В поле User name укажите имя пользователя, в поле Password - пароль.

Proxy

Выберите тип прокси-сервера, через которое должно осуществляться соединение с SFTP сервером:

  • Socks 4
  • Socks 5
  • HTTP

Если для подключения к SFTP серверу Вы выбрали прокси, то задайте параметры подключения:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout

Задайте время ожидания (в секундах) при подключении к SFTP серверу.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки соединения с Amazon S3

На этой вкладке Вы можете изменить настройки подключения к Amazon S3.

Options - Cloud connections - Editor - S3

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Bucket

Задайте имя хранилища, которое будет использоваться для хранения файлов бэкапов. Создать хранилище (bucket) можно на сайте Amazon. Если указанное хранилище не существует, то оно будет автоматически создано в регионе US Standard. Имя хранилища должно быть уникальным среди всех хранилищ на Amazon..

Path

Если Вы хотите хранить файлы бэкапов в папке, то в этом поле задайте путь к этой папке в указанном хранилище. Если указанной папки не существует в хранилище, то она будет создана автоматически при загрузке файла. Используйте '/' в качестве разделителя пути (например: 'backups/Adventure Works').

В полях Access key и Secret key задайте ключ доступа и секретный ключ для доступа к хранилищу. Эти ключи Вы можете найти на странице Security Credentials Вашего аккаунта Amazon Web Services.

Storage class

Из выпадающего списка выберите класс хранения загружаемых файлов бэкапов:

  • Standard
  • Reduced Redundancy

Protocol

С помощью этого выпадающего списка Вы можете задать протокол передачи файлов - с шифрованием (HTTPS) или без (HTTP).

Если для подключения к сервису Amazon Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout

Задайте время ожидания (в секундах) при подключении к сервису Amazon.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки соединения с Microsoft Azure

На этой вкладке Вы можете изменить настройки подключения к Microsoft Azure.

Options - Cloud connections - Editor - Azure

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Account Name

Введите имя учетной записи хранилища Microsoft Azure. Имя учетной записи образует поддомен URL адреса BLOB-объекта.

Account key

Введите ключ доступа к учетной записи. Может быть использован как первичный, так и вторичный ключ.

Container

Каждый BLOB-объект в хранилище Azure располагается в контейнере. Из выпадающего списка можно выбрать один из существующих контейнеров. Также, Вы можете ввести имя нового контейнера, удоавлетворяющего требованиям именования. Чтобы просмотреть правила именования контейнеров, наведите курсор мыши на иконку Question .

Если для подключения к сервису Microsoft Azure Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Timeout, sec

Задайте время ожидания (в секундах) для выполнения операций на сервисе Microsoft Azure.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки соединения с Dropbox

На этой вкладке Вы можете изменить настройки подключения к Dropbox.

Options - Cloud connections - Editor - Dropbox

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Folder

EMS SQL Backup по умолчанию загружает файлы в папку 'Apps/EMS SQL Backup' на Dropbox. Если Вы хотите хранить файлы бэкапов в подпапке этой папки, то в этом поле задайте путь к этой подпапке. Если указанной папки не существует в хранилище, то она будет создана автоматически при загрузке файла. Используйте '/' в качестве разделителя пути (например: 'backups/Adventure Works', в этом случае файлы будут загружены в 'Apps/EMS SQL Backup/backups/Adventure Works').

Если для подключения к сервису Dropbox Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки соединения с Google Drive

На этой вкладке Вы можете изменить настройки подключения к Google Drive.

Options - Cloud connections - Editor - GoogleDrive

Name

Введите имя для подключения. Имя подключения должно быть уникальным среди всех уже созданных подключений.

Folder

EMS SQL Backup по умолчанию загружает файлы в корень хранилища Google Drive. Если Вы хотите хранить файлы бэкапов в папкt, то в этом поле задайте путь к этой папке. Если указанной папки не существует в хранилище, то она будет создана автоматически при загрузке файла. Используйте '/' в качестве разделителя пути (например: 'backups/Adventure Works').

Если для подключения к сервису Dropbox Вы хотите использовать прокси, то отметьте опцию CheckBox Use proxy и задайте параметры подключения к прокси-серверу:

  • Server - имя прокси-сервера,
  • Port - порт,
  • User name - имя пользователя,
  • Password - пароль.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Настройки авторизации

На этой вкладке редактор можно задать, изменить или получить новые параметры авторизации.

Options - Cloud connections - Editor - Auth

Authorization type

В этом разделе нужно задать источник параметров авторизации для доступа в хранилище.

RadioButton Online authorization - получение информации об авторизации через Web. Для получения информации необходимо нажать кнопку Get authorization info, выполнить вход в аккаунт хранилища в открывшемся окне браузера и подтвердить доступ приложению EMS SQL Backup. После успешного входа и подтверждения доступа в окне браузера будет выведено сообщение, подтверждающее подключение и получение кодов. Код доступа будет сохранен программой, и предупреждение рядом с кнопкой Next исчезнет. Используйте этот метод, если Вы еще не настраивали подключение к выбранному сервису через EMS SQL Backup.

RadioButton Authorization from file - использование информации об авторизации из файла. Если Вы предварительно сохраняли информацию об авторизации в файл, то Вы можете указать путь к этому файлу в поле ввода (либо выбрать его, нажав кнопку EllipsisButton ).

RadioButton Manual authorization - явное задание предварительно полученной информации об авторизации. Скопируйте имеющийся код доступа в поле ввода.

После первоначального получения авторизации методом Online authorization, она сохраняется программой и может быть выгружена для дальнейшего использования с помощью нажатия кнопки Copy authorization info. Выберите To clipboard в выпадающем меню для копировании информации в буфер обмена. Для сохранения информации об авторизации в файл выберите To file в выпадающем меню и задайте путь в стандартном диалоге сохранения файла Windows.

Чтобы проверить заданные параметры, нажмите кнопку Test connection. В открывшемся диалоге выберите сервера, через которые Вы хотите проверить подключение.


Параметры прокси-сервера

На вкладке Proxy задайте настройки параметров подключения к сети Интернет. Эти параметры подключения будут использоваться при выполнении онлайн активации и деактивации лицензии.

Options - Proxy

RadioButton Automatically detect proxy settings

Автоматически определять настройки прокси-сервера.

RadioButton I have direct connection to the Internet

Выберите эту опцию, если у Вас прямое подключение к Интернету.

RadioButton Manual proxy configuration

При выборе этой опции задайте параметры прокси-сервера вручную.

Proxy Server

В этой группе опций введите следующие параметры: имя прокси-сервера, порт, имя пользователя и пароль (если установлен флажок CheckBox Use authentication).

Test Connection - проверяет возможность установления подключения с заданными параметрами.


Как...

В этом разделе содержится краткая информация по основным операциям, которые можно выполнить в программе EMS SQL Backup.

Установить EMS SQL Backup

Установить серверные компоненты EMS SQL Backup, не имея прав на удаленную установку

Активировать экземпляр SQL Server

Запланировать выполнение задачи создания резервной копии базы данных каждые сутки

Настроить процесс переноса журнала транзакций

Отслеживать показатели производительности сервера с помощью инструмента политик

Подготовить политику на основе стандартных схем обслуживания SQL Server

Добавить базу данных/сервер в существующую политику

Быстро создать политику одновременно на нескольких серверах/базах данных

Перенести набор задач политики на другую группу баз данных/серверов

Определить причину неудачи выполнения политики

Восстановить успешный статус политики после выявленеия причины неудачи выполнения

Преобразовать план обслуживания SQL Server в политику EMS SQL Backup

Эффективно использовать шаблоны

Настроить уведомления политик

Сгенерировать отчет о выполнении политики

Обеспечить одновременное выполнение задач на разных серверах, находящихся в разных часовых поясах

Обновить EMS SQL Backup

Удалить EMS SQL Backup

Смотрите также:

Начало работы

Управление серверами

Управление политиками обслуживания

Шаблоны

Активность

Операции обслуживания

Опции


Установить EMS SQL Backup

EMS SQL Backup состоит из двух основных программных частей: SQL Administration Console и Server-side components. Для того чтобы полностью установить EMS SQL Backup и начать работу с сервером в EMS SQL Backup Console, необходимо:

  1. Установить EMS SQL Backup Administration Console.
  2. Зарегистрировать сервер, выбрав пункт btnRegisterHost Register Server контекстного меню проводника серверов. Откроется мастер регистрации сервера.
  3. Подключиться к серверу, выбрав пункт btnConnectToDB Connect его контекстного меню.
  4. После регистрации сервера необходимо установить на него серверные компоненты. Для этого выберите пункт Install server-side EMS SQL Backup components контекстного меню сервера. Если у Вас недостаточно прав для удаленной установки серверных компонентов, перенесите установочный файл EMS SQL Backup на сервер и запустите Мастер локальной установки серверных компонентов.


Установить серверные компоненты EMS SQL Backup, не имея прав на удаленную установку

Если у Вас недостаточно прав для удаленной установки серверных компонентов с помощью мастера удаленной установки серверных компонентов, то Вы можете установить их локально на сервере с помощью мастера локальной установки серверных компонентов.

Для того чтобы выполнить установку серверных компонентов локально на экземпляре SQL Server:

  1. скопируйте установочный файл программы EMS SQL Backup на компьютер, на котором установлен SQL Server;
  2. запустите мастер установки EMS SQL Backup и на третьем шаге выберите режим Server-side only;
  3. после завершения мастера EMS SQL Backup Setup автоматически откроется окно мастера локальной установки серверных компонентов Installation Wizard;
  4. следуйте инструкциям мастера в соответствии с разделом мастер локальной установки серверных компонентов.

Важно: Мастер установки EMS SQL Backup установит на Ваш компьютер приложение EMS SQL Backup Service Installer (InstallWizard.exe), который позволяет устанавливать, обновлять и удалять серверные компоненты локально на сервере.


Активировать экземпляр SQL Server

Активация лицензии для экземпляра SQL Server осуществляется с помощью мастера активации лицензии. Для его запуска

выберите пункт Activate SQL license контекстного меню сервера.

Существует четыре способа активации лицензии на экземпляре SQL Server:

  • онлайн активация;
  • активация через сайт;
  • активация вручную.

Онлайн активация

  1. На первом шаге мастера выберите пункт RadioButton Activate EMS SQL Backup License online.
  2. На втором шаге мастера в поле License Key введите лицензионный ключ, который может быть взят из Личного кабинета.
  3. На последнем шаге нажмите кнопку Finish, чтобы завершить процесс активации лицензии.

Активация через сайт

  1. На первом шаге мастера выберите пункт RadioButton Activate EMS SQL Backup License through our website.
  2. Зайдите в Личный кабинет https://secure.sqlmanager.net/login и перейдите в раздел My Registered Products.
  3. Раскройте список ключей для необходимого продукта и выберите действие Activate License.
  4. На веб странице в открывшемся окне введите в соответствующее поле идентификационный номер регистрируемого экземпляра сервера, который был автоматически сгенерирован в поле SQL Server instance ID на втором шаге мастера.
  5. Скопируйте сгенерированный в поле License Activation Code на третьем шаге мастера.
  6. На последнем шаге нажмите кнопку Finish, чтобы завершить процесс активации лицензии.

Активация вручную

  1. На первом шаге мастера выберите пункт RadioButton Enter existing license activation code manually.
  2. На втором шаге введите код активации.
  3. На последнем шаге нажмите кнопку Finish, чтобы завершить процесс активации лицензии.


Запланировать выполнение задачи создания резервной копии базы данных каждые сутки

Для того чтобы задача создания резервной копии базы данных выполнялась по расписанию каждые сутки, необходимо создать политику, содержащую шаг Backup Database и расписание с соответствующими параметрами.

Для этого выполните следующую последовательность действий:

  1. выберите пункт Policy Maintenance Policies | CreatePolicy Create New Policy контекстного меню базы данных в проводнике серверов;
  2. на втором шаге открывшегося мастера создания политики выберите раздел Steps и нажмите кнопку Add Add;
  3. в диалоге Select Step выберите пункт RadioButton Backup Database;
  4. в открывшемся мастере создания шага резервного копирования базы данных задайте параметры резервного копирования; после завершения всех шагов мастера шаг Backup Database появится в списке Steps;
  5. выберите раздел Schedules и нажмите кнопку Add Add;
  6. в открывшемся редакторе расписаний задайте следующие параметры:
  • Schedule type - RadioButton Recurring from date (повторяющееся задание),
  • Occurs - Daily (повторять каждые n дней),
  • Recurs every - 1 day (повторять каждый день),
  • Daily frequency - RadioButton Occurs once at (повторять раз в день),
  • Occurs once at - время запуска выполнения задачи резервного копирования

и нажмите кнопку OK; расписание появится в списке Schedules;

  7. завершите все шаги мастера создания политики.


Настроить загрузку файлов бэкапов в хранилища (Сетевые папки/FTP/SFTP/Clouds)

С помощью EMS SQL Backup Вы можете сохранять файлы резервных копий не только в директорию на сервере, но и загружать их копии в другие хранилища.

Если Вы хотите настроить загрузку копий файлов бэкапов в другие хранилища, выполните следующие действия.

  1. Откройте диалог Options и перейдите на вкладку Cloud Connections.
  2. Нажмите кнопку Create new connection и в открывшемся диалоге выберите тип подключения: SMB/CIFS, FTP, Amazon S3 Cloud, Secure FTP, Microsoft Azure, Dropbox, Goggle Drive.
  3. В зависимости от выбранного типа подключения появится соответствующий диалог для настройки подключения.
  4. После того как все настройки будут заданы, нажмите кнопку OK. Созданное подключение появится в списке Cloud connections.
  5. При настройке операции резервного копирования перейдите на шаг мастера Specifying cloud connections и нажмите кнопку Add existing connection.
  6. Выберите подключение из открывшегося списка. Вы можете добавлять неограниченное количество хранилищ.


Подготовить политику на основе стандартных схем обслуживания SQL Server

В EMS SQL Backup существует набор предустановленных политик, задач, шагов и расписаний, с помощью которых Вы можете быстро создать политику.

Список всех предустановленных шаблонов с описаниями можно найти на вкладке Templates.

Чтобы добавить предустановленную задачу в политику, необходимо на втором шаге мастера создания политик выбрать пункт Tasks, нажать кнопку CreatePolicyTaskFromTemplate Create New from Template и выбрать нужный шаблон задачи.

Чтобы добавить предустановленный шаг в задачу, необходимо на втором шаге мастера создания политик выбрать пункт Steps, нажать кнопку CreatePolicyTaskFromTemplate Create New from Template и выбрать нужный шаблон шага.

Чтобы добавить предустановленное расписание в задачу, необходимо на втором шаге мастера создания политик выбрать пункт Schedules, нажать кнопку CreatePolicyTaskFromTemplate Create New from Template и выбрать нужный шаблон расписания.


Настроить процесс переноса журнала транзакций

Чтобы настроить процесс переноса журнала транзакций с одного сервера на другой, необходимо создать политику, в которой будет содержаться шаг Transaction Log Shipping. Создание шага происходит с помощью мастера создания шага доставки журналов.

На втором шаге мастера необходимо задать пары баз данных, между которыми будет осуществляться передача журналов транзакций. Выбираемая в качестве целевой база данных должна находиться в состоянии Restoring и являться восстановленной копией исходной базы, в противном случае нужно использовать опции Overwrite (для перезаписи базы) или Create new (для создания новой).

На третьем шаге необходимо указать директорию, в которую будут сохраняться резервные копии журнала транзакций исходной базы данных на исходном сервере, а также задать параметры резервного копирования.

На четвертом шаге мастера необходимо указать общую папку (Network shared folder), в которую будут копироваться создаваемые резервные копии журналов транзакций исходной базы данных. Оба сервера, между которыми происходит передача файлов журналов, должны иметь доступ к этой папке. Из этой папки файлы резервных копий будут перемещаться в папку, указанную в поле Destination folder. Целевой сервер должен иметь доступ к ней.

Если Вы создаете или перезаписываете базу данных, то после завершения всех шагов мастера доставки журналов на целевом сервере будет создана полная резервная копия исходной базы данных. Целевая база данных будет находиться в режиме восстановления. Перенос журнала транзакций будет производиться по расписанию, заданному в политике для этого задания.

Важно: На первом шаге мастера создания политики необходимо выбрать опцию RadioButton Use local Console time as absolute time.


Отслеживать показатели производительности сервера с помощью инструмента политик

С помощью операции обслуживания Регистрация параметров базы данных Вы можете отслеживать параметры базы данных и получать предупреждения, когда их значения не удовлетворяют некоторым заданным условиям.

Чтобы получать уведомления о возможных проблемах, необходимо включить шаг Database Parameters Logger в политику. Также, можно выполнить эту операцию обслуживания, выбрав пункт [image] Quick Maintenance Actions | ServerParametersLogger Database Parameters Logger контекстного меню сервера или базы данных.

Если после выполнения шага политики, выполняющего операцию обслуживания Database Parameters Logger, ее статус изменился на Warning, это означает, что значения некоторых параметров базы данных не удовлетворяют условиям, заданным на третьем шаге мастера регистрирации параметров базы данных. Чтобы просмотреть эти параметры и их значения, выберите этот шаг в списке Launches и нажмите кнопку Show details. В появившемся окне будет подробный отчет о результатах выполнения этой операции.


Добавить базу данных/сервер в существующую политику

В зависимости от количества задач и шагов в политике и от того, создавалась ли политика на решении или нет, можно выделить несколько способов добавления баз данных или серверов в политику.

Политика создавалась на решении, в котором содержатся базы данных/сервера

  1. Если в политике содержится большое количество задач (шагов), то выполните следующую последовательность действий:
  • создайте шаблон на основе этой политики (без сохранения списка баз данных), выбрав пункт CreateTemplateFromPolicy Create Template from Policy ее контекстного меню;
  • добавьте необходимые базы данных/сервера в существующее решение;
  • создайте политику на обновленном решении на основе созданного шаблона с помощью пункта Policy Maintenance Policies | CopyFromTemplate Create from Templates контекстного меню решения.
  2. Если в политике содержится несколько задач (шагов), то рекомендуется открыть редактор каждого шага и на вкладке Selection отметить необходимые базы данных/сервера.

Политика создавалась на отдельных базах данных/серверах

  1. Если в политике содержится большое количество задач (шагов), то рекомендуется:
  • объединить базы данных/сервера, на которых развернута политика, в решение, а затем добавить в него необходимые базы данных/сервера;
  • создать шаблон на основе этой политики (без сохранения списка баз данных), выбрав пункт CreateTemplateFromPolicy Create Template from Policy ее контекстного меню;
  • развернуть политику на созданном решении на основе созданного шаблона с помощью пункта Policy Maintenance Policies | CopyFromTemplate Create from Templates контекстного меню решения.
  2. Если в политике содержится несколько задач (шагов), то рекомендуется открыть редактор каждого шага и на вкладке Selection отметить необходимые базы данных/сервера.


Быстро создать политику одновременно на нескольких серверах/базах данных

Самым эффективным способом быстрого создания политики на нескольких серверах/базах данных является создание политики на решении (solution), в котором объединены эти сервера/базы данных.

Для того чтобы быстро создать политику на нескольких серверах или базах данных, выполните следующую последовательность действий:

  1. Создайте решение, выбрав пункт iconNewSubFolder Create Solution контекстного меню решений.
  2. Перенесите в созданное решение необходимые базы данных/сервера.

Важно: В одно решение нельзя объединить и базы данных, и сервера.

  3. Выберите пункт Policy Maintenance Policies | CopyFromTemplate Create New Policy контекстного меню решения для создания новой политики. При создании шагов в этой политике все базы данных/сервера решения будут выбраны автоматически.


Перенести набор задач политики на другую группу баз данных/серверов

В зависимости от количества задач и шагов в политике и от того, создавалась ли политика на решении или нет, можно выделить несколько способов переноса задач политики с одной группы баз данных или серверов на другую.

Политика создавалась на решении, в котором содержатся базы данных/сервера

  1. Если в политике содержится большое количество задач (шагов), то выполните следующую последовательность действий:
  • создайте шаблон на основе этой политики (без сохранения списка баз данных), выбрав пункт CreateTemplateFromPolicy Create Template from Policy ее контекстного меню;
  • создайте новое решение (solution) и добавьте в него необходимые базы данных/сервера;
  • создайте политику на новом решении на основе созданного шаблона с помощью пункта Policy Maintenance Policies | CopyFromTemplate Create from Templates контекстного меню решения.
  2. Если в политике содержится несколько задач (шагов), то рекомендуется открыть редактор каждого шага и на вкладке Selection отметить необходимые базы данных/сервера.

Политика создавалась на отдельных базах данных/серверах

  1. Если в политике содержится большое количество задач (шагов), то рекомендуется:
  • объединить базы данных/сервера, на которые Вы хотите перенести политику, в решение;
  • создать шаблон на основе этой политики (без сохранения списка баз данных), выбрав пункт CreateTemplateFromPolicy Create Template from Policy ее контекстного меню;
  • развернуть политику на созданном решении на основе созданного шаблона с помощью пункта Policy Maintenance Policies | CopyFromTemplate Create from Templates контекстного меню решения.
  2. Если в политике содержится несколько задач (шагов), то рекомендуется открыть редактор каждого шага и на вкладке Selection отметить необходимые базы данных/сервера.


Определить причину неудачи выполнения политики

Если на сервере есть хотя бы одна политика, при выполнении которой возникли ошибки, то в статусе сервера будет сообщение Policies have problems.

Чтобы выявить политику, при выполнении которой произошла ошибка, необходимо в списке политик в разделе Policies найти ту, статус которой Failed. Такой статус означает, что выполнение хотя бы одной из задач политики закончилось неудачей.

При выборе задачи этой политики в разделе Launches отобразится информация о запусках задачи политики. Выберите задание со статусом Failed и нажмите кнопку Show details в столбце Message. В появившемся окне в поле Message будет отображаться сообщение, в котором будет описана причина неудачного выполнения шага.

Если возникшая при выполнении политики проблема была решена, то можно восстановить успешный статус политики.


Восстановить успешный статус политики после выявленеия причины неудачи выполнения

Если Вы выявили причину, по которой политика не была запущена или была выполнена с ошибкой, то можно исправить суммарный статус политики, то есть изменить ошибочные статусы (Failed, Missed, Warning и Aborted) задач политики на статус Ignored и при необходимости повторно выполнить ошибочные задачи. Это можно сделать несколькими способами.

  • Нажмите кнопку Resolve, расположенную под статусом выбранного сервера. В появившемся диалоге будут перечислены задачи политик с ошибочным статусом выполнения. Вы можете изменить ошибочный статус на Ignored и/или выполнить все ошибочные задачи всех политик. В этом случае общий статус каждой политики переформируется с учетом статуса последних запусков ошибочных задач.
  • Выберите ошибочную политику в списке Policies, а затем выберите пункт Resolve the Problem ее контекстного меню. Откроется диалог, в котором будет предложено изменить статус всех ошибочных задач политики на Ignored и/или выполнить их повторно. В этом случае статус выбранной политики переформируется с учетом статуса последних запусков ошибочных задач.
  • Выберите ошибочную задачу политики в списке Policies, а затем выберите пункт Resolve the Problem ее контекстного меню. Откроется диалог, в котором будет предложено изменить статус этой ошибочной задачи политики на Ignored и/или выполнить ее повторно. В этом случае статус выбранной политики переформируется с учетом статуса последнего запуска этой ошибочной задачи.

С помощью контекстного меню ошибочных задач в списке Launches можно изменить ошибочный статус выполнения выбранной задачи (Ignore Errors for Selected Launches) или всех задач (Ignore Errors for All Problem Launches).


Преобразовать план обслуживания SQL Server в политику EMS SQL Backup

Если у Вас есть настроенные планы обслуживания SQL Server, Вы можете использовать их в EMS SQL Backup, преобразовав их в политики EMS SQL Backup.

Чтобы преобразовать план обслуживания SQL Server в политику EMS SQL Backup выполните следующую последовательность действий:

  1. Выберите пункт Policy Maintenance Policies | ConvertfromMaintenanceplan Convert from Maintenance Plan в контекстном меню сервера, чтобы запустить мастер конвертации планов обслуживания.
  2. На втором шаге мастера выберите план обслуживания, который необходимо преобразовать в политику.
  3. На третьем шаге можно просмотреть результаты конвертации. Подпланы плана обслуживания преобразуются в задачи политики. Если при преобразовании плана обслуживания в политику произошли ошибки, то их можно исправить в редакторе политик, который вызывается при нажатии на кнопку Edit Policy.
  4. Рекомендуется установить флажок CheckBox Disable Maintenance plan, чтобы отключить выполнение задач в конвертируемом плане обслуживания.
  5. На последнем шаге просмотрите настройки конвертации и нажмите кнопку Finish. Созданная политика появится в списке на вкладке Policies.


Эффективно использовать шаблоны

В EMS SQL Backup существует инструмент шаблонов, с помощью которых Вы можете создавать сохраненные в конфигурации EMS SQL Backup параметры политик, задач, шагов и расписаний.

Чтобы создать шаблон, перейдите на вкладку Templates и выберите объект (политику, задачу, шаг или расписание), шаблон которого хотите создать. Затем нажмите кнопку Add, расположенную на панели инструментов или в контекстном меню шаблона.

Если у Вас имеется настроенная политика, развернутая на некоторой группе баз или серверов, Вы можете создать ее шаблон. Для этого необходимо перейти на вкладку Policies и выбрать пункт CreateTemplateFromPolicy Create Template from Policy ее контекстного меню.

Также Вы можете создавать шаблоны существующих задач, шагов и расписаний. Для этого необходимо:

  • открыть редактор политики, в которой они созданы;
  • выбрать пункт CopyToTemplate Copy to Templates контекстного меню объекта, шаблон которого Вы хотите создать.

Все сохраненные шаблоны затем могут быть использованы при создании политик.

Чтобы создать политику на основе шаблона, необходимо выбрать пункт CopyFromTemplate Create Policy from Template контекстного меню списка политик на вкладке Policies. В диалоге Item Selection выберите необходимый шаблон (или несколько шаблонов). Откроется редактор политики, в которой уже будут содержаться задачи, созданные в шаблоне.

Чтобы создать в политике задачу/шаг/расписание на основе шаблона, используйте пункт AddNewFromTemplate Add New from Template контекстного меню или соответствующую кнопку на втором шаге мастера создания политик. Добавленный объект затем можно будет открыть в редакторе и при необходимости изменить параметры, заданные в шаблоне.

На вкладке Templates отображается список всех шаблонов, как предустановленных, так и созданных пользователем. Вы можете сохранить шаблон в *.xml файл, выбрав пункт ExportTemplate Export контекстного меню шаблона. Также можно загружать сохраненные шаблоны с помощью кнопки ImportTemplate Import. Эта возможность позволяет копировать шаблоны из одной конфигурации EMS SQL Backup в другую.

Смотрите также:

Подготовить политику на основе стандартных схем обслуживания SQL Server


Настроить уведомления политик

Вы можете настроить оповещения, которые будут уведомлять Вас о результате выполнения политики по электронной почте.

Параметры уведомления задаются на третьем шаге мастера создания политики.

Необходимо задать условие, при котором будут отправляться уведомления:

  • When the policy succeeds - отправлять сообщение об успешном выполнении политики;
  • When the policy fails - отправлять сообщение об ошибочном выполнении политики;
  • When the policy completes - отправлять сообщение о запуске политики, независимо от результата ее выполнения.

В поле Send E-mail To необходимо ввести e-mail адрес администратора, которому будут отправляться сообщения, генерируемые при выполнении политики.

SQL Server Agent должен быть настроен на использование компонента Database Mail для отправки почты.

Важно: Для работы уведомлений необходимо, чтобы были заданы настройки электронной почты на выбранном сервере, который будет использоваться для отправки уведомлений политик.


Сгенерировать отчет о выполнении политики

C помощью инструмента отчетов Вы можете просматривать информацию о выполнении задач политики, которая отображается в разделе Launches, а также сохранять отчеты в файлы различных форматов и отправлять по электронной почте.

Чтобы сгенерировать отчет по выполнению задач или политик, необходимо нажать кнопку Reports Report на панели инструментов раздела Launches или выбрать в контекстном меню задачи пункт Reports Show Report.

Существует три типа отчетов:

  • отчет по политике, запущенной на одном сервере;
  • отчет по политике, запущенной на нескольких серверах;
  • подробный отчет по задачам в политике.

Отчет по политике, запущенной на одном сервере

Открыть отчет этого типа можно, когда в проводнике выбран один сервер. Если при этом в окне Policies выбрана политика, которая развернута на нескольких серверах, то отчет будет содержать информацию по запускам политики только на выбранном сервере. В отчете отображается краткая информация о задачах в политике: имя задачи, запланированное время запуска, время запуска, время окончания выполнения и статус выполнения задачи.

Отчет по политике, запущенной на нескольких серверах

Открыть отчет этого типа можно, когда в окне Policies выбрана политика, запущенная на нескольких серверах. Кроме того, в проводнике должна быть выбрана группа или решение. В этом отчете отображается краткая информация о задачах в политике: имя задачи, имя сервера, запланированное время запуска, время запуска, время окончания выполнения и статус выполнения задачи.

Подробный отчет по задачам в политике

Открыть отчет этого типа можно, когда в окне Policies выбрана конкретная задача политики. В этом отчете отображается подробная информация о выбранной задаче: имя задачи, имя шага, запланированное время запуска, время запуска, время окончания выполнения, статус выполнения задачи/шага и сообщение о выполнении задачи/шага (информационное сообщение, предупреждение или ошибка).


Обеспечить одновременное выполнение задач на разных серверах, находящихся в разных часовых поясах

Для того чтобы запуск задач политики выполнялся одновременно на серверах, расположенных в разных часовых поясах, необходимо на первом шаге мастера создания политики в разделе Task Scheduling in different time zones выбрать пункт RadioButton Use local Console time as absolute time.

В этом случае политика будет выполняться на всех серверах в то время, которое стоит на компьютере с установленной EMS SQL Backup Console, без учета часовых поясов, в которых расположены сервера.


Сообщить об ошибках и предложениях

С помощью EMS SQL Backup Вы можете автоматически сгенерировать отчет об ошибке, возникшей в ходе работы с программой, а затем отправить этот отчет с описанием Вашей проблемы. Перед тем как отсылать предложения и отчеты об ошибках, убедитесь, что Вы используете последнюю версию EMS SQL Backup.

Чтобы создать письмо с прикрепленным к нему файлом отчета об ошибке, выполните следующую последовательность действий:

  1. В дереве серверов выберите сервер, на котором возникла ошибка;
  2. В контекстном меню этого сервера выберите пункт Send bug report to EMS;
  3. После того как будут сгенерированы файлы для отчета, откроется почтовый клиент, установленный по умолчанию на Вашем компьютере, в котором будет автоматически создано новое письмо с прикрепленным к нему файлом;
  4. В сообщении пошагово опишите действия, предшествующие появлению ошибки, и отправьте письмо.

Если по какой-либо причине при автоматической генерации письма произошла ошибка, или отправка была отменена, появится следующий диалог.

Следуйте приведенным инструкциям, чтобы создать отчет об ошибке вручную:

  1. Нажмите на "mailto:" сслыку sqlangelreports@sqlmanager.net, чтобы открыть почтовый клиент по умолчанию; если почтовый клиент не открылся, скопируйте почтовый адрес нажатием на кнопку Copy to clipboard и создайте письмо вручную;
  2. Нажмите кнопку Save and open folder и выберите директорию, в которую следует сохранить файл с отчетом об ошибке; после того как файл будет сохранен, папка с ним откроется автоматически;
  3. Прикрепите сохраненный файл к созданному письму;
  4. Прикрепите сохраненный файл к письму;
  5. в сообщении пошагово опишите действия, предшествующие появлению ошибки, и отправьте письмо.


Обновить EMS SQL Backup

Обновление программы EMS SQL Backup включает в себя обновление EMS SQL Backup Administration Console и обновление Server-side components.

Для обновления EMS SQL Backup Administration Console выполните следующую последовательность действий:

  • загрузите полный дистрибутив со страницы загрузки сайта,
  • закройте программу EMS SQL Backup, если она запущена,
  • повторите процедуру установки,
  • запустите программу, используя кнопки в Пуск->Программы->EMS.

После запуска программы EMS SQL Backup Administration Console при попытке подключения к серверам появится предупреждение о том, что версия серверных компонентов устарела. Вам будет предложено обновить серверные компоненты. Обновление производится с помощью мастера обновления/удаления серверных компонентов.

Если по какой-то причине Вам не удалось обновить серверные компоненты через EMS SQL Backup Administration Console, то перенесите установочный файл программы EMS SQL Backup на компьютер, на котором установлен SQL Server и запустите установку там. Обновление серверных компонентов локально на сервере происходит по аналогии с процессом их установки с помощью мастера локальной установки серверных компонентов. Чтобы обновить серверные компоненты, необходимо выбрать опцию CheckBox Update и экземпляры SQL Server.


Удалить EMS SQL Backup

Для того чтобы удалить EMS SQL Backup выполните следующую последовательность действий:

  1. Удалите серверные компоненты со всех серверов, на которых они были установлены. Это делается с помощью мастера обновления/удаления серверных компонентов, который вызывается при выборе пункта Update/Remove server-side SQL Backup Components контекстного меню сервера.
  2. Удалите программу EMS SQL Backup Console с Вашего компьютера через Панель управления -> Установка и удаление программ.

Важно: Если по какой-то причине Вам не удалось удалить серверные компоненты через EMS SQL Backup Administration Console, то перенесите установочный файл программы EMS SQL Backup на компьютер, на котором установлен SQL Server и запустите установку там. Удаление серверных компонентов локально на сервере происходит по аналогии с процессом их установки с помощью мастера локальной установки серверных компонентов. Чтобы удалить серверные компоненты, необходимо выбрать опцию RadioButton Uninstall All на втором шаге мастера.


Использовать бесплатную версию EMS SQL Backup

Чтобы использовать бесплатную версию EMS SQL Backup, необходимо активировать лицензионный ключ типа Free. Обратите внимание на то, что для активации бесплатной лицензии необходимо подключение к сети Интернет.

  1. Откройте мастера активации лицензии из контекстного меню экземпляра SQL Server.
  2. На первом шаге мастера выберите пункт RadioButton Activate EMS SQL Backup License online.
  3. На втором шаге мастера выберите опцию RadioButton Free в качестве License type.
  4. Завершите выполнение шагов мастера.

Отличия между версиями EMS SQL Backup наглядно приведены в Сравнительной таблице характеристик.


Состояния базы данных

Общий статус базы данных формируется на основе состояния базы данных на сервере (цвет значка базы или иконка в правом нижнем углу) и статуса политик (цвет иконки щита в левом верхнем углу).

- база данных в состоянии emergency и не имеет политик

- база данных в состоянии emergency, и выполнение всех политик прошло успешно

- база данных в состоянии emergency, и есть политики, которые не удалось выполнить

- база данных в состоянии emergency, и есть политики, выполненные с незначительными ошибками

- база данных в состоянии offline (недоступна) и не имеет политик

- база данных в состоянии offline (недоступна), и выполнение всех политик прошло успешно

- база данных в состоянии offline (недоступна), и есть политики, которые не удалось выполнить

- база данных в состоянии offline (недоступна), и есть политики, выполненные с незначительными ошибками

- база данных в состоянии online (доступна) и не имеет политик

- база данных в состоянии online (доступна), и выполнение всех политик прошло успешно

- база данных в состоянии online (доступна), и есть политики, которые не удалось выполнить

- база данных в состоянии online (доступна), и есть политики, выполненные с незначительными ошибками

- база данных в однопользовательском режиме и не имеет политик

- база данных в однопользовательском режиме, и выполнение всех политик прошло успешно

- база данных в однопользовательском режиме, и есть политики, которые не удалось выполнить

- база данных в однопользовательском режиме, и есть политики, выполненные с незначительными ошибками

- база данных в процессе восстановления работоспособности и не имеет политик

- база данных в процессе восстановления работоспособности, и выполнение всех политик прошло успешно

- база данных в процессе восстановления работоспособности, и есть политики, которые не удалось выполнить

- база данных в процессе восстановления работоспособности, и есть политики, выполненные с незначительными ошибками

- база данных в процессе восстановления из резервной копии и не имеет политик

- база данных в процессе восстановления из резервной копии, и выполнение всех политик прошло успешно

- база данных в процессе восстановления из резервной копии, и есть политики, которые не удалось выполнить

- база данных в процессе восстановления из резервной копии, и есть политики, выполненные с незначительными ошибками

- база данных помечена как подозрительная и не имеет политик

- база данных помечена как подозрительная, и выполнение всех политик прошло успешно

- база данных помечена как подозрительная, и есть политики, которые не удалось выполнить

- база данных помечена как подозрительная, и есть политики, выполненные с незначительными ошибками

InactiveDatabase - база данных отключена


Конвертер резервных копий

Утилита ConvertUtil.exe предназначена для преобразования файлов резервных копий из формата EMS SQL Backup в стандартный формат файлов резервных копий MS SQL Server. Утилита работает только в консольном режиме.

Использование:

<путь к ConvertUtil.exe>\ConvertUtil.exe -I[nputFile]:file_name -O[utputFile]:

file_name -D[atabases]:name[,...n] [-H[elp]|Help|-?] [-P[assword]:password]

На машине, на которой локально установлена программа EMS SQL Backup Console, утилита лежит в папке "C:\Program Files\EMS\SQL Backup\Distrib\Service\". На серверной машине, на которой установлены серверные компоненты, утилита находится в папке "C:\Program Files\EMS\SQL Backup\Service\".

Основные параметры:

-I[nputFile] | файл резервной копии EMS SQL Backup, который подлежит конвертации.
-O[utputFile] | имя выходного файла, который будет создан в результате конвертации.
-D[atabases] | Имена баз данных, данные которых будут извлечены.

Дополнительные параметры:

-H[elp]|Help|-? | дополнительная справочная информация
-P[assword] | пароль для зашифрованной резервной копии

Пример:

"C:\Program Files\EMS\SQL Backup\Service\ConvertUtil.exe" -I:”C:\Data\TEST.bkp” –O:”TESTms.bak”

–D:Employee,Departments –P:8p5Zh79

Важно: Если резервная копия EMS SQL Backup состоит из нескольких файлов, то необходимо указать только первый файл последовательности. Все последующие файлы будут обработаны автоматически.

Важно: Если при создании резервной копии EMS SQL Backup, на шаге Задание параметров EMS SQL Backup, было задано больше одного потока в поле Max Thread Count, то после конвертации будет создано столько выходных файлов, сколько потоков было задано.


Директории SQL Server

Диалог SQL Server Folders позволяет просматривать и выбирать директории на сервере.

Server folder dialog

Этот диалог появляется при выборе директорий хранения резервных копий:

  • на вкладке Настройки хранения резервных копий диалога Свойства службы;
  • на шаге задания параметров файла мастера резервного копирования базы данных и вкладке параметры файла резервной копии редактора шага резервного копирования базы данных;
  • на шаге выбора резервной копии мастера восстановления баз данных;
  • на шаге выбора серверов и директорий мастера очистки после обслуживания и на вкладке выбор серверов и директорий редактора шага очистки после обслуживания;
  • на шаге задания параметров резервного копирования и задания директорий и параметров восстановления мастера доставки журналов,а также на вкладке задание параметров доставки журналов редактора шага доставки журналов.