Введение

SQL Administrator - это высокопроизводительная программа для работы с серверами Microsoft SQL. Являясь простой в установке и использовании, программа содержит почти полный набор инструментов для наиболее эффективного управления и администрирования серверов Microsoft SQL. Этот программный продукт разработан специально для администраторов баз данных. Он предназначен для выполнения задач по администрированию максимально просто, быстро и эффективно. Эта программа избавляет от необходимости устанавливать множество отдельных утилит.

Основные возможности программы:

  • Мониторинг производительности в режиме реального времени
  • Сборщик статистики производительности системы и SQL Server
  • Графическое сравнение статистики за разные периоды времени для поиска “узких мест” в производительности
  • Анализ тенденций развития метрик производительности через определенный промежуток времени
  • Проверка работоспособности сервера с помощью сводного инструмента сигнализаторов
  • Грамотная система мастеров настроек для резервного копирования/восстановления, присоединения/отсоединения, проверки, сжатия баз данных, восстановления/реорганизации индексов
  • Получение полного объема информации обо всех задачах по обслуживанию базы данных, включая их расписание и статус выполнения
  • Хранение, сравнение и применение конфигураций сервера, включая свойства сервера, опции конфигурации, логины, опции БД, разрешения на объекты
  • Прогнозирование необходимости расширения дискового пространства
  • Анализ использования пространства накопителем, базой данных или объектами базы данных
  • Создание/изменение/удаление объектов SQL Server
  • Просмотр информации о текущих серверных процессах, а также блокировках, относящихся к определенным процессам и объектам
  • Удобный инструмент управления запросами для SQL запросов и выполнения скриптов
  • Возможность печати почти всех данных программы
  • Поддержка SQL Server версий с 2000 по 2014 включительно

Более подробно о возможностях программы.


Новости

Версия | Дата выпуска
SQL Administrator 2.0 | 01.04.15

Что нового в SQL Administrator 2.0?

  1. Добавлен Database Explorer: Новый инструмент для просмотра информации о базе данных и объектам баз данных, а также для управления ими.
  2. Database Explorer | Database tab. Здесь отображается основная информация о состоянии базы данных: значения ее свойств и опций, даты и результаты выполнения задач по обслуживанию, расположение последних резервных копий, размер и рост базы данных, информация о файлах и периоде ожидания при доступе к ним, и многое другое. Требующие внимания значения подсвечиваются. Здесь же можно выполнить различные действия с базой данных: сделать резервную копию, проверить целостность, обновить индексы, создать объекты и т.д.
  3. Server Explorer | Server tab. Значительно расширен набор предоставляемой информации о сервере. Объекты теперь можно создавать/редактировать/удалять прямо здесь, без необходимости открывать соответствующие вкладки Server Explorer'а. Для удобства сигнализаторы теперь можно просматривать в виде вертикальной сетки.
  4. Server Explorer | Performance. Теперь здесь собрана наиболее важная информация о текущей нагрузке сервера в виде графиков и таблиц.
  5. Появилась бесплатная версия с ограниченным функционалом.
  6. Server Explorer | Maintenance. Теперь здесь для всех баз данных сервера показываются дата и статус последнего выполнения каждой из задач по обслуживанию сервера.
  7. Добавлены новые сигнализаторы:
    • High Disk Transfer Latency
    • Low Page Life Expectancy
    • Databases in Restricted User Mode
    • Databases in Non-Online State
    • Errors in Server Error Log
  8. Для WMI соединения с сервером, используемого для получения системной информации и значений счетчиков, теперь можно задавать логин/пароль Windows, отличный от текущего.
  9. Statistics Collector. Теперь также появилась возможность собирать информацию о следующих счетчиках:
    • Paging File. % Usage
    • Physical Disk. Avg. Disk sec/Read
    • Physical Disk. Avg. Disk sec/Write
    • Physical Disk. Disk Reads/sec
    • Physical Disk. Disk Writes/sec
    • SQL Server: Buffer Manager. Page life expectancy
    • SQL Server: Memory Manager. Memory Grants Pending
    • SQL Server: SQL Statistics. Batch Requests/sec
  10. Server Explorer | Server group. Для более удобного просмотра данные представлены в виде вертикальной сетки. Также выводится дополнительная информация о серверах.
  11. User, Role, Application Role Editors. В дополнение к возможности просматривать и редактировать право доступа данного участника появилась возможность задавать право доступа на данного участника.
  12. Увеличен размер редакторов объектов по умолчанию.
  13. Server Explorer | Alarm Summary. Сделано ограничение ширины представления, а также другие визуальные изменения.
  14. Maintenance Plan Editor. Стало удобнее создавать задачи для одной и той же базы данных – нет необходимости каждый раз открывать диалог выбора баз данных, – базы из предыдущих задач добавляются в выпадающем списке.
  15. Увеличена высота выпадающего списка – раньше было неудобно находить нужный элемент в большом списке.
  16. Большое количество прочих улучшений и исправлений.


Сравнительная таблица характеристик

Бесплатная Free версия SQL Administrator не включает все особенности Full версии и имеет некоторые функциональные ограничения.

Полная сравнительная таблица характеристик представлена ниже.

 | Полная версия | Бесплатная версия
Постоянный контроль сервера SQL
Контроль самых важных показателей эффективности | + | -
Просмотр счетчиков производительности системы и SQL Server в режиме реального времени | + | -
Исчерпывающая сводная информация по серверу и базе данных с выделением важных сведений | + | +
Просмотр информации о текущих серверных процессах, а также блокировках, относящихся к определенным процессам и объектам | + | -
Просмотр журналов SQL Server и системы | + | +
Великолепная настройка производительности
Сборщик статистики производительности системы и SQL Server | + | -
Графическое сравнение статистики за разные периоды времени для поиска “узких мест” в производительности | + | -
Анализ тенденций развития метрик производительности через определенный промежуток времени | + | -
Поиск отсутствующих индексов | + | -
Проверка работоспособности SQL сервера
Проверка работоспособности сервера с помощью сводного инструмента сигнализаторов | + | +
Предупреждение об остановке сервера, отсутствии достаточного пространства, невозможности выполнить задание или план обслуживания и т.д. | + | +
Возможность исправления неисправностей одним щелчком мыши | + | +
Простое управление сервисными задачами SQL Server
Грамотная система мастеров настроек для резервного копирования/восстановления, присоединения/отсоединения, проверки, сжатия баз данных, восстановления/реорганизации индексов | + | +
Создание/изменение/удаление планов обслуживания | + | +
Получение полного объема информации обо всех задачах по обслуживанию базы данных, включая их расписание и статус выполнения | + | +
Управление конфигурациями сервера SQL
Сохранение конфигурации сервера, включая свойства сервера, опции конфигурации, логины, опции базы данных, права доступа объектов | + | -
Сравнение конфигураций с демонстрацией их различий | + | -
Обновление сервера на основе сохраненной конфигурации или конфигурации другого сервера | + | -
Эффективное управление хранилищем данных SQL Server
Управление базами данных и их файлами | + | +
Анализ использования пространства накопителем, базой данных или объектами базы данных | + | + / –
Прогнозирование необходимости расширения дискового пространства | + | -
Простое управление объектами SQL Server
Управление объектами сервера: планами обслуживания, заданиями, предупреждениями, операторами, учетными записями-посредниками и др. | + | +
Управление объектами базы данных: таблицами, представлениями, процедурами, функциями и схемами секционирования, последовательностями и пр. | + | +
Выведение на экран свойств объекта в виде таблицы с возможностью выбора колонки, данных фильтрации и сортировки | + | +
Возможность распечатать свойства объекта | + | -
Создание нового объекта на основе существующего объекта с того же или другого сервера в качестве шаблона | + | -
Эффективное управление параметрами безопасности
Управление логинами и серверными ролями | + | +
Управление пользователями баз данных и пользовательскими ролями | + | +
Выявление логинов, имеющих высокие привилегии на сервере (системные администраторы и администраторы службы безопасности) | + | +
Просмотр информации обо всех параметрах безопасности сервера и баз данных одновременно | + | +
Просмотр и предоставление прав на выбранный защищаемый объект в таблице участников | + | -
Просмотр и предоставление прав выбранному участнику в таблице защищаемых объектов | + | -
Простой в использовании пользовательский интерфейс
Грамотная система мастеров настроек для выполнения задач по обслуживанию SQL Server | + | +
Отсутствие лишней информации позволяет сосредоточиться на выполняемой задач | + | +
Набор обложек делает возможным настроить внешний вид программы, удовлетворяющий личным предпочтениям | + | +
Полностью настраиваемый интерфейс программы | + | +
Другие функциональные особенности
Удобный инструмент управления запросами для SQL запросов и выполнения скриптов | + | +
Возможность печати почти всех данных программы | + | -


Системные требования

  • Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows 2008 Server, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8, Microsoft Windows 2012 Server;
  • .Net Framework 2.0;
  • .Net Framework 4.0 (для работы с планами обслуживания SQL Server 2012);
  • 512 MB или больше оперативной памяти;
  • 70MB свободного пространства на диске для установки программы;
  • Видеокарта Super VGA и монитор с минимальным разрешением 800x600 (рекомендуется Super VGA с разрешением 1024x768 или выше);
  • Совместимая c Windows мышь;
  • Microsoft Data Access Components (MDAC) или SQL Server Native Client;
  • Возможность соединения с локальным или удаленным сервером Microsoft SQL Server 2000, SQL Server 2005, SQL Server 2008, SQL Server 2012 or SQL Server 2014 (Сервер SQL Server Compact Edition не поддерживается);


Установка

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Установка EMS SQL Administrator for SQL Server

Установка программы SQL Administrator

  • загрузите установочный файл программы со страницы загрузки,
  • полученный файл извлеките из архива в нужную директорию (например, c:\unzipped),
  • откройте файл SQLAdminSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлык программы SQL Administrator в меню Пуск.

Обновление программы

  • загрузите полный дистрибутив со страницы загрузки сайта,
  • закройте программу SQL Administrator, если она запущена,
  • повторите процедуру установки,
  • запустите программу, используя кнопки в Пуск->Программы->EMS.

Смотрите также:

Часто задаваемые вопросы


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Share-it!. Процедура совершения покупки через Share-it! защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернете и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией share-it!.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery). Сделав заказ, Вы сможете немедленно скачать регистрационные ключи или пароли и ссылки на архивы полных версий программ. Также Вы получите копию регистрационных ключей или паролей по электронной почте.

Если при оформлении Вы не получили регистрационный ключ в течение двух часов, обратитесь в службу поддержки по этому адресу sales@sqlmanager.net.

Если Вы являетесь зарегистрированным пользователем, то при возникновении проблем или вопросов при использовании нашего программного обеспечения обращайтесь в службу поддержки.

Описание продукта | Share It!
SQL Administrator (Business) + 3 года Сопровождения | Купить!
SQL Administrator (Business) + 2 года Сопровождения
SQL Administrator (Business) + 1 год Сопровождения
SQL Administrator (Non-commercial) + 3 года Сопровождения
SQL Administrator (Non-commercial) + 2 года Сопровождения
SQL Administrator (Non-commercial) + 1 год Сопровождения
SQL Administrator (Trial version) | Загрузить!
SQL Administrator (Free version)

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Подробнее об услуге сопровождения читайте на странице http://sqlmanager.net/ru/support/faq/maintenance

Смотрите также:

Регистрация


Регистрация

Если Вы не зарегистрировали свою копию программы SQL Administrator, то Вы можете сделать это, нажав кнопку Register Now в окне, открывающемся при выборе пункта главного меню программы Help | About.

В появившемся окне укажите регистрационное имя - в поле Registration name, и ключ - в поле Registration Key.

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией из share-it!.
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно. Для этого необходимо открыть окно About SQL Administrator, выбрав пункт главного меню Help | About. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Смотрите также:

Приобретение


Предыдущие версии

Версия | Дата выпуска
SQL Administrator 1.4 | 29.09.14
SQL Administrator 1.3 | 04.02.14
SQL Administrator 1.2 | 28.08.13
SQL Administrator 1.1 | 24.05.13
SQL Administrator 1.0 | 04.03.13

Версия 1.4

  1. Добавлена поддержка новых возможностей SQL Server 2014:
    • поддержка шифрования резервных копий;
    • поддержка загрузки резервных копий в Windows Azure;
    • поддержка файлов данных и файловых групп, оптимизированных для памяти.
    • поддержка новых разрешений серверного уровня: CONNECT ANY DATABASE, IMPERSONATE ANY LOGIN, SELECT ALL USER SECURABLES;
    • поддержка планов обслуживания на серверах SQL Server 2014.
  2. Добавлена возможность клонирования объектов сервера, включая задания и планы обслуживания, на том же самом сервере либо на другой сервер.
  3. Проводник. В разделе Security добавлено представление Credentials, которое позволяет просматривать и управлять учетными данными.
  4. Проводник | вкладка Security. В списке System and Security Administrators теперь также показываются логины, обладающие правами серверной роли securityadmin (имеющие права назначения всех серверных привилегий).
  5. Редактор баз данных.
    • Добавлена поддержка нескольких ранее неподдерживаемых опций баз данных SQL Server 2012 и SQL Server 2014.
    • При создании файла базы данных на SQL Server 2012 и выше по умолчанию подставлялся размер файла 3 Мб, что меньше минимально допустимого размера для данной версии сервера, поэтому возникала ошибка при сохранении. Исправлено.
    • После удаления файла базы данных, при повторном открытии редактора он вновь появлялся в списке, хотя был удален на сервере. Исправлено.
  6. Редактор запросов. Теперь при изменении размера области результатов запроса высота таблицы просмотра автоматически подстраивается под новую высоту.
  7. Мастер резервного копирования. Для опции сжатия резервных копий теперь можно задать значение Server default.
  8. Проводник | вкладки Database Users, Roles, Application Roles. Добавлено поле Description.
  9. Проводник | вкладка Databases. Добавлено поле ID (скрыто по умолчанию, может быть показано с помощью диалога Column Chooser).
  10. Alarm Summary | сигнализатор Databases without Backup. Теперь для новых регистраций серверов интервал проверки наличия резервных копий составляет по умолчанию 8 дней.
  11. Проводник | вкладка Database Users. На SQL Server 2012 и выше для некоторых пользователей неправильно отображалось значение свойства Orphaned, хотя соответствующий сигнализатор определял таких пользователей корректно. Исправлено.
  12. Alarm Summary. Если имя базы данных содержало символ, недопустимый без кавычек, в некоторых сигнализаторах возникала ошибка 'Incorrect syntax'. Исправлено.
  13. Если при создании планов обслуживания на SQL Server 2012 и выше возникала ошибка, то после закрытия программы процесс Ssis11Adpt.exe не завершался. Исправлено.
  14. Множество других улучшений и исправлений.

Версия 1.3

  1. Внедрен мастер сравнения серверных конфигураций (Compare Server Configurations wizard), позволяющий загружать в хранилище, сравнивать и восстанавливать конфигурации SQL Server. Доступно сравнение как сохраненных конфигураций сервера, так и конфигураций двух серверов. Конфигурация включает в себя: сведения о сервере, свойства сервера, параметры конфигураций сервера, параметры баз данных, файлы баз данных и группы файлов, участники сервера и баз данных, разрешения для объектов сервера и базы данных.
  2. Добавлена форма регистрации серверов (Register Servers form), которая позволяет быстро зарегистрировать в программе SQL сервера локальной сети.
  3. В диалоге подключения к серверу в окне запроса добавлена возможность сразу выбрать текущую базу данных для выполняемых запросов. Имеется список недавно выбранных баз данных.
  4. Инструмент выполнения запросов (Query execution tool).
  • Добавлены сочетания клавиш Alt+клавиша для некоторых команд из панели инструментов.
  • Пополнен список незарезервированных сервером слов для выделения и "Автозавершения кода".
  • При редактировании файла без подключения к серверу, при открытии "Автозавершения кода" возникала ошибка Object reference not set to an instance of an object. Исправлено.
  5. Wizards.
  • При каждом новом запуске мастера лог результатов выполнения операции прокручивается так, чтобы информация о новом выполнении начиналась с верхней строки окна.
  • После загрузки шаблона его файл оставался заблокированным для редактирования. Исправлено.
  6. При открытии редактора планов обслуживания из сигнализаторов (Alarm Summary), при сохранении возникала ошибка Maintenance plan with 'XXX' name already exists. Исправлено.
  7. При открытии редактора данных типа Blob для поля запроса "только для чтения", кнопка загрузки данных из файла оставалась доступной. Исправлено.
  8. Разрешения. Нельзя было аннулировать разрешения, назначенные не текущим пользователем. Исправлено.
  9. Диалоги Server Registration (Регистрация сервера), Server Group (Группа серверов), Windows и другие. Добавлены сочетания клавиш Alt+клавиша для фокусирования некоторых параметров управления диалогов. (Показываются после нажатия Alt).
  10. Диалог Windows. Кнопка"Закрыть" перекрывала кнопку "Справка". Исправлено.
  11. Мастер резервного копирования. При использовании символа апострофа (‘) в полях имя бэкапа, описание бэкапа, имя набора носителей, описание набора носителей при выполнении возникала ошибка. Исправлено.
  12. SQL Редактор.
  • При удалении текста в конце строки до пробела, пробел также удалялся. Исправлено.
  • Не работал клик по полосе прокрутки для перемещения page up (страница вверх). Исправлено.
  13. Диалог Опции. В поле, где задается имя файла лога программы, добавлена кнопка открытия файла.
  14. Множество улучшений и исправлений.

Версия 1.2

  1. Выполнение запроса (Query execution tool).
  • Результаты выполнения запроса теперь можно редактировать. (Таблица должна иметь первичный ключ.)
  • Редактор объектов BLOB (BLOB Editor) предназначен для просмотра или редактирования значений BLOB полей.
  • Добавлен навигатор (grid navigator) для перемещения по записям и редактирования результатов запроса.
  2. Проводник (Server Explorer). Добавлена возможность запуска или остановки сервера.
  3. Wizards. В контекстное меню лога выполнения добавлены пункты "Выбрать все" (Select All) и "Копировать" (Copy).
  4. Диалоговое окно состояния сборщика статистики (Statistics Collector State). Теперь показывается прогресс при запуске или остановке сервиса.
  5. В диалоге выбора нескольких элементов (например, выбора элементов серверной роли) добавлено контекстное меню с командами выбора всех или снятия выбора со всех элементов.
  6. Планы обслуживания (Maintenance Plans). Кнопка истории планов обслуживания (Maintenance Plan History) не отключалась, если список планов был пуст. Исправлено.
  7. Статистическая динамика (Collected Statistics Trend). Кнопка "Показать подробности" (Show Details) не отключалась, если список был пуст. Исправлено.
  8. Множество улучшений и исправлений.

Версия 1.1

  1. Сетки данных и диаграммы представлений обозревателя серверов, данные запросов, список неисправностей теперь могут быть распечатаны либо экспортированы в несколько популярных форматов данных.
  2. В сетках данных обозревателя серверов появилась возможность пошагового поиска.
  3. Обозреватель серверов | Текущая и собранная статистики | Настройка диаграмм представлений. В диалоге добавления счетчика производительности теперь отображается его описание.
  4. Обозреватель серверов | Обслуживание | Проверка базы данных. Добавлена колонка даты последней успешной проверки базы данных.
  5. Обозреватель серверов | Хранение | Базы данных. Для баз данных в состоянии восстановления в контекстном меню теперь доступна команда "Восстановление базы данных без восстановления данных".
  6. Мастер резервного копирования баз данных. Иконки баз данных теперь отображаются с учетом их (баз данных) состояния.
  7. Обозреватель серверов | Обслуживание | Резервное копирование | Невыполненные задания резервного копирования. Теперь при вызове мастера резервного копирования баз данных подставляется имя базы данных из текущей строки представления.
  8. Обозреватель серверов. В некоторых случаях при открытии обслуживания представлений возникала ошибка "Элемент с таким ключом уже существует". Исправлено.
  9. При регистрации сервера из главного меню программы не подставлялась текущая группа серверов. Исправлено.
  10. Если в Обозревателе серверов выбрана группа серверов, при вызове нового запроса эта группа серверов подставляется в диалоге подключения к серверу.
  11. Прочие улучшения и исправления.

Версия 1.0

  • Управление задачами обслуживания, проверка наличия запланированных задач, периодичности и успешности их выполнения.
  • Выполнение поиска возможных неисправностей и информирование пользователя при их обнаружении.
  • Наличие средств для управления параметрами хранения SQL Server. Возможность получить информацию о пространстве, занятом базами, данными и отдельными объектами, и прогнозировать необходимость расширения дискового пространства.
  • Нахождение уязвимых мест в производительности, а также прогнозирование их появление с помощью инструментов сбора и анализ статистики производительности системы и SQL сервера.
  • Управление безопасностью сервера SQL Server максимально просто и наглядно.
  • Проведение мониторинга активности на сервере, анализ журналов сервера.
  • Управление серверными объектами.
  • Выполнение SQL запросов и скриптов.

Наверх

Смотрите также:

Новости


Часто задаваемые вопросы

Пожалуйста, прочитайте внимательно эту страницу, если у вас есть вопросы о EMS SQL Administrator.

Вопросы

  • Что такое EMS SQL Administrator?
  • Что мне необходимо для начала работы с EMS SQL Administrator?
  • Почему я не могу подключиться к SQL Server?
  • Для чего SQL Administrator использует подключение WMI к серверу?
  • Я постоянно получаю сообщение об ошибке “Время ожидания истекло” ('Timeout expired') при попытке выполнения запроса в Query tool.
  • Можно ли как-то восстановить мои настройки и регистрации сервера со старого или неисправного HDD, на котором был установлен SQL Administrator?
  • В чем разница между детальной и усреднённой статистиками в представлении Производительность/Накопленная статистика?
  • Я не могу редактировать план обслуживания. Редактор находится в режиме «только чтение».
  • Я пытаюсь выполнить план обслуживания, но ничего не происходит, а история о планах обслуживания не содержит никакой информации.
  • Открытие Alarm Summary | Alarm Log занимает слишком много времени. Что делать?
  • Я выполняю проверку базы данных с помощью мастера проверки баз данных, но в обозревателе серверов последняя дата выполнения обслуживания не обновляется. Почему?

Ответы

В: Что такое EMS SQL Administrator?

О: SQL Administrator – это мощный инструмент для администрирования сервера Microsoft SQL Server. Являясь простым в установке и использовании, продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы именно администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.

В: Что мне необходимо для начала работы с EMS SQL Administrator?

О: Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному серверу SQL Server. Во-вторых, Ваш компьютер должен соответствовать системным требованиям EMS SQL Administrator.

В: Почему я не могу подключиться к SQL Server?

О:

  1. Если Ваш сервер установлен в качестве именованного экземпляра, то необходимо вводить имя сервера в виде имя_компьютера\имя_экземпляра. По умолчанию именованный экземпляр сервера SQL Server Express Edition имеет имя SQLEXPRESS.
  2. При подключении к удаленному серверу убедитесь, что соединение не блокируется файерволом. Чтобы открыть необходимые порты, обратитесь к Вашему системному администратору.
  3. Убедитесь, что SQL Server запущен, и Вы используете корректный логин/пароль для доступа к нему.
  4. Убедитесь, что у вас правильно настроены клиентские протоколы. Используйте SQL Server Configuration Manager для подключения к SQL Server 2005 или выше (он устанавливается с помощью Native Client) или SQL Server Client Network Utility (system32\cliconfg.exe) для подключения к более ранним версиям сервера.
  5. Убедитесь, что опция удаленного подключения включена, и протоколы сервера настроены корректно. Используйте SQL Server Surface Area Configuration для подключения к SQL Server 2005 или выше и SQL Server Network Utility (Program Files\Microsoft SQL Server\80\Tools\Binn\svrnetcn.exe) для подключения к более ранним версиям сервера.
  6. Если вы используете именованный экземпляр сервера с динамически назначаемым портом TCP/IP, убедитесь, что служба SQL Browser запущена.
  7. При удаленном подключении используйте IP адрес сервера вместо имени для обеспечения корректной работы DNS.

В: Для чего SQL Administrator использует подключение WMI к серверу?

О: Подключение WMI используется для:

  • получения системной информации о сервере, например, об установленной операционной системе или типа процессора;
  • запуска и остановки служб SQL Server;
  • просмотра журналов событий Windows;
  • получения значений счетчиков производительности для их отображения в продукте, некоторых оповещениях и для сбора статистики.

В: Я постоянно получаю сообщение об ошибке "Время ожидания истекло" ('Timeout expired') при попытке выполнения запроса в Query tool.

О: Вам нужно увеличить время ожидания запроса в закладке Query tool диалога Параметры, или установить неограниченное время (значение равно 0).

В: Можно ли как-то восстановить мои настройки и регистрации сервера со старого или неисправного HDD, на котором был установлен SQL Administrator?

О: SQL Administrator хранит все свои настройки в реестре Windows. Это означает, что единственный способ перенести их – получить доступ к реестру Windows. Сделать это можно, загрузив ОС со старого HDD (если это возможно) либо открыв файл реестра специальной программой-редактором. Если это удалось, то можно выгрузить ветки 'HKEY_CURRENT_USER\Software\EMS\SQL Administrator' и 'HKEY_LOCAL_MACHINE\Software\EMS\SQL Administrator' в *.REG файлы, перенести эти файлы на новую систему и добавить информацию в реестр с помощью двойного щелчка мыши по файлам. Также Вы должны предоставить права на запись группе 'Пользователи' в ветке 'HKEY_LOCAL_MACHINE\Software\EMS\SQL Administrator' с помощью редактора реестров (Registry Editor tool).

В: В чем разница между детальной и усреднённой статистиками в представлении Производительность | Накопленная статистика?

О: Сборщик статистики собирает детальную статистику производительности системы с интервалом 5 минут по умолчанию. Данная информация хранится по умолчанию 31 день и затем усредняется. Усреднение производится по дням недели с интервалом 30 минут. Это необходимо для уменьшения общего количества хранимой информации. Параметры сбора статистики можно настроить для каждого сервера на вкладке Сбор статистики диалога Свойства регистрации сервера.

В: Я не могу редактировать план обслуживания. Редактор находится в режиме «только чтение».

О: Для создания и редактирования планов обслуживания Вам необходимо установить службы интеграции SQL Server на компьютере. В противном случае, Вы сможете только просматривать существующие планы обслуживания.

Если службы интеграции SQL Server установлены на другом компьютере в Вашей локальной сети, то используя файл 'Ssis11Adpt.exe' и примеры конфигурационных файлов 'Ssis11Adpt.exe.config.example' и 'SsisClient.config.example' из папки установки программы, Вы можете сделать следующее:

  • скопировать файл 'Ssis11Adpt.exe' на компьютер, где установлены службы интеграции SQL Server;
  • в папке с 'Ssis11Adpt.exe' создать файл 'Ssis11Adpt.exe.config' и настроить его параметры;
  • запустить 'Ssis11Adpt.exe';
  • в папке с программой создать файл 'SsisClient.config' и настроить его параметры.

Если конфигурационные файлы настроены правильно, планы обслуживания можно будет редактировать. Не забудьте открыть порт в брандмауэре компьютера.

В: Я пытаюсь выполнить план обслуживания, но ничего не происходит, а история о планах обслуживания не содержит никакой информации.

О: Возможно, задание для плана обслуживания не может запуститься. Пожалуйста, проверьте историю выполнения задания с именем <maintenance_plan_name> или <maintenance_plan_name>.<subplan_name>.

В: Открытие Alarm Summary | Alarm Log занимает слишком много времени. Что делать?

О: Пожалуйста, проверьте, что задание по очистке журнала cleanup_alarm_log_<repository_database_name> запущено на сервере, на котором находится база данных репозитария SQL Administrator. Это очистит старые записи журнала.

В: Я выполняю проверку базы данных с помощью мастера проверки баз данных, но в обозревателе серверов последняя дата выполнения обслуживания не обновляется. Почему?

О: Информация о выполнении задач по проверке базы данных и перестройки/реорганизации индексов берется из истории выполнения планов обслуживания и заданий. Таким образом, запуск таких задач в мастере, а также выполнение соответствующий SQL команд не отражаются в колонке «Дата последнего выполнения».

Наверх

Если у вас возникли какие-либо вопросы, свяжитесь с нашим Центром поддержки.


Сопутствующие продукты

MySQL

Microsoft SQL

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

DB2

 | EMS SQL Management Studio for DB2 - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for DB2 объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
 | DB Comparer for DB2 - это мощное приложение, предназначенное для сравнения баз данных DB2, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Data Comparer for DB2 - мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for DB2 Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET 2003, 2005, 2008 и 2010 , позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
sourcerescuer | Source Rescuer EMS Source Rescuer™ - это простая в использовании утилита для Borland Delphi® и C++Builder®, позволяющая восстановить утерянный исходный код. Если Вы утратили исходные тексты приложения, написанные на Delphi® или C++Builder®, но обладаете исполняемым файлом, Source Rescuer поможет восстановить часть необходимого исходного кода. Source Rescuer восстанавливает все формы и модули данных проекта со всеми заданными свойствами и событиями. Восстановленные процедуры событий не имеют тела (Source Rescuer – не декомпилятор), но указывают на адрес кода исполняемого файла. В большинстве случаев Source Rescuer экономит от 50 до 90 процентов времени, затрачиваемого на восстановление проекта.
 | Наверх


Начало работы

SQL Administrator предоставляет полный набор инструментов для администрирования SQL Server.

При первом запуске программы отображается стартовая страница.

С помощью ссылок, расположенных на этой странице, можно выполнить действия для начала работы с программой и сервером.

Getting Started

Getting Started_Register a server Зарегистрировать сервер, который будет использоваться в качестве репозитория, и создать базу данных репозитория на нем.

Getting Started_Setserver as repository Установить сервер в качестве репозитория программы.

Getting Started_Register servers Зарегистрировать серверы, которые вы будете администрировать с помощью программы, и задать для них параметры сигнализаторов и сборщика статистики.

Getting Started_Statistics collector Установить и запустить сборщик статистики.

Getting Started_program options Задать настройки программы.

Для получения информации о производительности системы и значения счетчиков производительности, необходимо разрешить WMI подключение к серверной машине.

Смотрите также:

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Безопасность

Агент SQL сервера

Производительность

Журнал сервера

Запросы

Опции


Рабочая область и вкладки

В рабочей области создаются вкладки. С их помощью можно переключаться между рабочими областями. Тип отображения вкладок можно задать в Environment Options.

Изменять расположение и количество отображаемых столбцов можно с помощью кнопки ColumnChooser Column Chooser, отображающейся на панели инструментов.

Настройка рабочих областей

Для некоторых разделов проводника можно задать дополнительные настройки отображения.

  • Хранение
  • Безопасность
  • Агент SQL сервера
  • Производительность

Нажмите кнопку CustomizeLayout Customize Layout на панели управления. Появится диалог Customization для настройки рабочей области.

Customization - Hidden_Items

Сплиттеры

Сплиттеры - разделительные полосы между окнами, позволяющие быстро изменять размер окна.

Customization - Splitter

Разделители

Для отделения одной части формы от другой используются разделители.

Customization - Separator

Для каждой настраиваемой секции можно вызвать контекстное меню.

Customization - Item_Context_Menu

CustomizeLayout Hide Customization Form - сохранить изменения и закрыть окно настройки.

HideItem Hide Item - убрать выбранный объект из рабочей области.

Group Group - создать группу элементов.

CreateEmptySpaceItem Create EmptySpace Item - создать пустую рабочую область.

SizeConstraints Size Constraints - ограничения размеров выбранного объекта.

ResetToDefault Reset to default - сбросить все настройки.

FreeSizing Free sizing - включить/отключить свободное изменение размеров.

LockSize Lock size - зафиксировать текущие размеры объекта.

LockWidth Lock Width - зафиксировать текущую ширину объекта.

LockHeight Lock Height - зафиксировать текущую высоту объекта.

В контекстном меню объекта Label расположен пункт Rename Rename с помощью которого можно изменить надпись.

При выборе пункта Group Group контекстного меню новая группа объектов появляется в списке Layout Group на вкладке Layout Tree View. Чтобы удалить группу выберите пункт Ungroup Ungroup ее контекстного меню.

Контекстное меню группы

CustomizeLayout закрыть окно настройки;

Rename переименовать группу;

HideText скрыть название группы в рабочей области;

TextPosition положение имени группы в заголовке;

CreateEmptySpaceItem создать пустую область;

CreateTabbedGroup создать вложенную группу;

Для вложенных групп можно:

UngroupTabbedGroup удалить вложенную группу;

AddTab добавить новую вкладку.

Layout Group - список объектов, находящихся на рабочей области.

Customization - Layout_Tree_View

При нажатии на имя объекта в списке границы выделяются соответствующей области. После этого можно перетаскивать ее в любую часть рабочей области и изменять ее размер.

Customization - Dragging_Item

Смотрите также:

Проводник

Работа с серверами

Главное меню и панели инструментов

Работа с окнами

Работа с таблицами


Проводник SQL Server

Проводник (Server Explorer) - это основное навигационное окно для работы с серверами, задачами обслуживания, статистикой и пр. Объекты в нем представлены в виде дерева. С его помощью можно быстро выполнять практически все операции с сервером.

Все объекты доступны в соответствующих подузлах дерева. Сервер начинает отображаться в дереве проводника после регистрации. Чтобы свернуть/развернуть узел, используйте кнопки "-"/"+" перед именем узла, или просто дважды щелкните по узлу.

Чтобы отобразить проводник, необходимо в главном меню выбрать пункт Tools | Server Explorer.

С помощью контекстного меню сервера Вы можете:

  • connect to the selected server - подключиться к выбранному серверу;
  • disconnect from the selected server - отключиться от выбранного сервера;
  • register a new server - зарегистрировать новый сервер;
  • unregister the selected server - удалить регистрацию выбранного сервера;
  • add new server group - добавить новую группу серверов;
  • start server - запустить службу сервера;
  • stop server - остановить службу сервера;
  • restart server - перезапустить службу сервера;
  • pause server - приостановить службу сервера;
  • resume server - возобновить службу сервера;
  • run SQL Server Configuration Manager - запустить SQL Server Configuration Manager;
  • open a new Server Explorer - открыть новое окно проводника;
  • view server properties - посмотреть свойства сервера;
  • view server registration properties - посмотреть регистрационную информацию сервера.

Для каждой группы объектов и для каждого объекта можно создать отдельное окно проводника, выбрав в контекстном меню пункт New Server Explorer at This.

Все серверы могут быть объединены в группы. Для добавления группы серверов щелкните правой кнопкой мыши в проводнике и выберите пункт контекстного меню сервера Add Server Group.

Server explorer - Add server group

Имя и описание группы укажите в полях Group name и Group description в открывшемся диалоговом окне.

Для перемещения сервера из одной группы в другую, достаточно перетащить его. Также, можно выбрать для сервера другую группу, открыв диалоговое окно Server Registration и выбрав новую группу из списка Server Group. Это диалоговое окно открывается при выборе в контекстном меню сервера пункта Register server.

Чтобы переупорядочить сервера в группе или группы серверов, перетаскивайте объект мышью, удерживая клавишу 'Shift'.

Смотрите также:

Рабочая область и Вкладки

Работа с серверами

Проводник баз данных

Главное меню и панели инструментов

Работа с окнами

Работа с таблицами


Проводник баз данных

Проводник баз данных - это основное навигационное окно для работы с базами данных, объектами баз данных и задачами обслуживания. Все объекты доступны в подузлах базы данных.

Сервер отображается в дереве проводника после регистрации. Чтобы открыть список баз данных на сервере или список объектов базы данных, используйте кнопки "-"/"+" перед именем сервера/базы данных соответственно.

Чтобы открыть вкладку с проводником баз данных, необходимо в главном меню выбрать пункт Tools | Database Explorer.

С помощью контекстного меню базы данных Вы можете:

  • Disconnect from the selected server - отключиться от выбранного сервера;

Create Create Database - создать базу данных;

Edit Edit Database - редактировать базу данных;

Drop Drop Database - удалить базу данных;

  • Rename Database - переименовать базу данных;
  • Server Registration Properties - открыть диалог просмотра регистрационных свойств сервера;
  • New Database Explorer at This - открыть новое окно проводника баз данных;
  • Tasks - выполнить задачи обслуживания:

Резервное копирование базы данных

Восстановление базы данных

AttachDatabase Присоединение базы данных

DetachDatabase Отсоединение базы данных

CheckDatabase Проверка базы данных

RebuildIndexes Перестроение и реорганизация индексов

Сжатие базы данных

Смотрите также:

Рабочая область и Вкладки

Работа с серверами

Проводник SQL Server

Управление объектами базы данных

Главное меню и панели инструментов

Работа с окнами

Работа с таблицами


Работа с серверами

RegisterServer Регистрация сервера

Для начала работы с сервером его необходимо зарегистрировать. Это делается с помощью Редактора регистрации сервера. Открыть этот мастер можно одним из следующих способов:

  • В главном меню программы выбрать пункт Server | RegisterServer Register Server.
  • В контекстном меню сервера выбрать пункт RegisterServer Register Server.
  • Нажать кнопку RegisterServer Register Server на панели инструментов.

ConnectToServer Подключение к серверу

Чтобы подключиться к серверу, необходимо выполнить одно из следующих действий:

  • В контекстном меню сервера выбрать пункт ConnectToServer Connect to <server_name>.
  • Дважды щелкнуть по названию сервера в проводнике.

DisconnectFromServer Отключение от сервера

Чтобы отключиться от сервера, необходимо в контекстном меню сервера выбрать пункт DisconnectFromServer Disconnect from <server_name>.

RegistrationProperties Просмотр регистрационной информации сервера

Для просмотра и изменения регистрационной информации необходимо в проводнике, в контекстном меню сервера, выбрать пункт - <server_name> Registration Properties

Управление группами серверов

В проводнике сервера можно объединять в группы, перетаскивая мышкой названия серверов в созданные группы.

Для создания группы необходимо в контекстном меню сервера или группы выбрать пункт Add Server Group.

UnregisterServer Удалить регистрацию сервера

Чтобы удалить регистрационную информацию сервера из программы необходимо выполнить одно из приведенных действий:

  • В главном меню выбрать пункт Server | UnregisterServer Unregister server <server_name>.
  • В проводнике, в контекстном меню сервера, выбрать пункт UnregisterServer Unregister server <server_name>.

Смотрите также:

Рабочая область и Вкладки

Проводник

Главное меню и панели инструментов

Работа с окнами

Работа с таблицами


Главное меню и панели инструментов

Главное меню

Из главного меню можно получить доступ к основным инструментам и настройкам программы. Оно расположено в верхней части окна программы.

Main menu and toolbars - Main menu

Панели инструментов

Панель инструментов - ToolBar - строка или столбец, с вынесенными на него кнопками, позволяющими совершать, практически, все операции с открытым объектом.

Панели инструментов могут меняться в зависимости от активного окна.

Main menu and toolbars - Toolbars

Панель инструментов можно перемещать, перетаскивая мышкой.

Настройка панелей инструментов.

Настроить отображение и содержимое всех панелей инструментов можно в специальном диалоговом окне - Customize.

Открыть его можно, нажав на любую панель управления правой кнопкой мыши и выбрав пункт Customize, или выбрав в главном меню пункт Tools | Customize, или используя функцию Add or Remove Buttons, открывающуюся при нажатии на кнопку More Buttons в правом углу панели.

Вкладка Toolbars

Main menu and toolbars - Customize

На этой вкладке можно создавать, редактировать и удалять панели инструментов.

New - добавить панель инструментов,

Rename - переименовать,

Delete - удалить,

Reset - сбросить все текущие настройки.

Вкладка Commands

На этой вкладке выберите кнопки, которые будут отображаться на панели инструментов.

Main menu and toolbars - Customize - Commands

В списке Categories выберите категорию, а в списке Commands - команду, относящуюся к выбранной категории.

Чтобы поместить нужную кнопку на панель её нужно перетащить из списка Commands на панель инструментов.

Вкладка Options

Main menu and toolbars - Customize - Options

!CheckBox Always show full menus - всегда показывать полные меню.

!CheckBox Show full menus after a short delay - показывать полные меню после небольшой задержки.

Reset my usage data - сброс.

!CheckBox Large icons - крупные значки.

!CheckBox Show ScreenTips on Toolbars - отображать подсказки для кнопок.

!CheckBox Show shortcut keys in ScreenTips - включить в подсказки сочетания клавиш.

Menu animations - анимация при выборе меню.

Смотрите также:

Рабочая область и Вкладки

Проводник

Работа с серверами

Работа с окнами

Работа с таблицами


Работа с окнами

Управление открытыми окнами SQL Administrator осуществляется с помощью подпунктов пункта главного меню Windows.

С помощью этого меню можно:

  • Cascade - расположить открытые окна каскадом,

Working with windows - Cascade

  • Minimize All - свернуть все окна,
  • Restore All - вернуть всем окнам первоначальный размер.
  • Tile Horizontal - расположить все окна одно над другим,

Working with windows - Horizontal

  • Tile Vertical - расположить все окна в один ряд,

Working with windows - Vertical

  • Close All - закрыть все окна.
  • Previous Window - перейти к следующему окну.
  • Next Window - перейти к предыдущему окну.
  • Windows List - просмотреть список открытых окон.

Working with windows - List of windows

С помощью инструментов, расположенных в этом диалоговом окне, можно Activate - разворачивать или Close -закрывать активные окна. Также можно Save - сохранять запросы в файлы *.sql.

В диалоговом окне Options | Environment Options, в поле Maximum number of windows in Window menu можно задать максимальное число открытых окон. Если количество открытых окон превысит заданное число, то программа автоматически будет закрывать ранее открытые.

Смотрите также:

Рабочая область и Вкладки

Проводник

Работа с серверами

Главное меню и панели инструментов

Работа с таблицами


Работа с таблицами

Контекстное меню заголовков столбцов

Working with grid - Column header popup menu

Сортировка

Выбрать столбец, по которому хотите отсортировать данные -> нажать на заголовок этого столбца мышкой.

Если столбец не был отсортирован, то одно нажатие отсортирует его по возрастанию, следующее - по убыванию.

В контекстном меню заголовка столбца выбрать пункт SortAsc Sort Ascending или SortDesc Sort Descending.

Убрать сортировку

Вызвать контекстное меню правой кнопкой мыши на нужном столбце -> выбрать пункт Clear Sorting.

Выбор видимых столбцов

Можно указывать, какие из столбцов таблицы будут видимыми.

Делается это с помощью пункта контекстного меню ColumnChooser Column Chooser или с помощью кнопки ColumnChooser на панели инструментов. По нажатию на эту кнопку появляется окно, в котором, отображается список отсутствующих столбцов. Из этого списка можно перетащить название столбца в строку заголовков, и обратно.

Working with grid - Column chooser

Изменение порядка столбцов.

Для изменения порядка столбцов достаточно перетащить заголовок столбца в требуемое место.

Working with grid - Change column order

Группировка

Данные в таблице можно группировать по одному или нескольким столбцам.

Working with grid - Grouping data

Группировка по одному столбцу

Если на панель группировки Вы поместите заголовок поля, то все записи таблицы будут сгруппированы по этому полю. Для того, чтобы сгруппировать таблицу по столбцу необходимо перетащить заголовок столбца на специальную панель над таблицей, так называемую "панель группировки".

Working with grid - Grouping data by two columns

Группировка по нескольким столбцам.

Если на панель группировки Вы поместите заголовки нескольких полей, то все записи таблицы будут сгруппированы по этим полям в указанном порядке.

Таблица будет выглядеть следующим образом.

Working with grid - Grouping data by two columns

В заголовках групп могут отображаться сведения о сгруппированных данных, если была задана сводка по столбцу.

На панели группировки тот заголовок, который находится ниже, является подчиненным. Группировка по нему будет проходить во вторую очередь. Объекты на панели группировки доступны для фильтрации данных.

Для отмены группировки необходимо перетащить заголовок столбца обратно в таблицу. При этом можно изменить порядок столбцов.

Фильтрация

Фильтр — это быстрый способ поиска подмножества данных и работы с ними в таблице. В отфильтрованной таблице отображаются только строки, отвечающие условиям, заданным для столбца.

Фильтр не меняет порядок записей. При фильтрации временно скрываются строки, которые не отвечают заданным условиям.

Для отбора записей используются Настраиваемый фильтр - Custom Filter и Конструктор фильтров - Filter Builder.

Custom Filter

Нажать значок фильтра CustomFilter в правом верхнем углу заголовка столбца, появляющийся при наведении курсора на заголовок. Выбрать из раскрывшегося списка одно из условий фильтра - Custom, Blanks (пустые ячейки), Non blanks (непустые ячейки) или одно из значений списка. При выборе Custom задать необходимые параметры отбора в появившемся диалоговом окне Custom Auto Filter.

Working with grid - Custom filter

В этом диалоговом окне можно задать два условия фильтрации и их отношение - должны ли выполняться оба условия сразу, или достаточно выполнения одного. Установив переключатель в положение !RadioButton AND укажите, что оба условия должны выполняться одновременно, в положение !RadioButton OR укажите, что должно выполняться только одно из них.

Из раскрывающихся списков выбираем условия отбора:

  • равно - equals,
  • не равно - does not equal,
  • больше - is greater than,
  • больше или равно - is greater than or equal to,
  • меньше - is less than,
  • меньше или равно - is less than or equal to,
  • пустые - blanks,
  • не пустые - non blanks,

В поле указываем последовательность символов. Используйте символ "%" для указания любого набора символов и символ "_" для обозначения любого символа. При выполнении условия отбираются только те значения, которые отвечают указанному условию.

Второе условие не является обязательным.

Конструктор фильтров

Чтобы запустить конструктор фильтров, необходимо в контекстном меню заголовка столбца выбрать пункт FilterEditor Filter Editor.

Если для таблицы установлен фильтр, то в нижней части появляется панель, на которой отображается условие фильтра.

На этой панели располагаются элементы управления, с помощью которых можно:

  • Удалить фильтр - нажав на кнопку CloseFilter .
  • Включить фильтр - установить флажок перед условием фильтра.
  • Изменить условия фильтрации с помощью кнопки Edit Filter. Эта кнопка открывает конструктор фильтров.

На этой панели отображается история модификации фильтра, которая открывается при нажатии на раскрывающийся список.

Удалить фильтр

Удалить фильтр и отобразить все записи таблицы можно одним из следующих способов.

  1. В контекстном меню заголовка столбца, по которому задан отбор, выбрать пункт ClearFilter Clear Filter.
  2. Нажать кнопку CloseFilter на панели фильтра.

Смотрите также:

Рабочая область и Вкладки

Проводник

Работа с серверами

Главное меню и панели инструментов

Работа с окнами


Конструктор фильтров

Конструктор фильтров

Чтобы запустить конструктор фильтров, необходимо в контекстном меню заголовка столбца выбрать пункт FilterEditor Filter Editor.

Добавить или удалить условие или группу условий можно нажатием на кнопки InsertCondition Insert Condition и RemoveCondition Remove Condition соответственно.

Отношение между группами условий определяется групповым оператором, который выбирается из списка, открывающегося по нажатию на надпись And.

And, Or Or, NotAnd Not And, NotOr Not Or, AddCondition Add Condition, AddGroup Condition Group или RemoveGroup Remove Group.

Для головного условия доступен ещё пункт ClearAll Clear All, с помощью которого можно удалить все заданные условия.

Условия задаются в строках.

[Название столбца] Условие Значение.

При нажатии на элемент открывается список подстановки.

Чтобы применить фильтр, нажмите кнопку Apply.


Servers

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Работа с серверами

Все зарегистрированные сервера можно объединить в группы. При выборе группы серверов в Проводнике SQL Server рабочая область выглядит следующим образом:

Здесь отображаются все зарегистрированные сервера в группе. Вы можете просмотреть Регистрационные свойства сервера, информацию по сигнализаторам, настройки службы сбора статистики и некоторую информацию о сервере.

С помощью контекстного меню сервера Вы можете запустить мастера для выполнения основных операций обслуживания баз данных, сравнить конфигурации сервера, обновить информацию о сервере, распечатать документ со сводной таблицей по серверам, просмотреть свойства сервера и открыть диалог Server Registration Properties.

Дважды кликните по ячейке с количеством сработавших сигнализаторов, чтобы открыть окно Alarm Summary для выбранного сервера.

По двойному клику мыши в любой другой области открывается диалог регистрационных свойств сервера.

При выборе сервера в Проводнике SQL Server рабочая область выглядит следующим образом:

С помощью кнопок на ленте Вы можете выполнить различные операции с сервером и объектами.

Connection

  • подключиться к серверу/отключиться от сервера;
  • открыть диалог регистрационных свойств сервера;
  • открыть SQL Server Configuration Manager для локальных серверов.

Tools

  • открыть диалог Server Properties;
  • открыть мастера выполнения операций обслуживания баз данных:
  • Резервное копирование базы данных
  • Перестроение и реорганизация индексов
  • Проверка базы данных
  • Присоединение базы данных
  • Отсоединение базы данных
  • Восстановление базы данных
  • Сжатие базы данных
  • запустить Мастер сравнения серверных конфигураций.

Create

С помощью кнопок на этой ленте Вы можете создать новые объекты сервера в соответствующих редакторах:

  • Редактор планов обслуживания
  • Редактор заданий
  • Редактор логинов
  • Редактор баз данных
  • Редактор предупреждений
  • Редактор операторов
  • Редактор учетных записей-посредников
  • Редактор устройств резервного копирования
  • Редактор серверных ролей
  • Редактор снимков базы данных

Edit & Drop

На этой ленте расположены кнопки Edit Object(s) и Drop Object(s), с помощью которых можно выбрать объекты, которые Вы хотите отредактировать или удалить.

На рабочей области вкладки сервера расположено четыре секции: Server Information (информация о сервере), System Information (информация о системе), Server Status (состояние сервера) и Alarms (сигнализаторы).

В разделе System Information отображается информация об операционной системе, на которой установлен выбранный сервер.

Раздел Server Status содержит значение текущих параметров SQL Server:

User Connections - количество активных подключений к серверу;

Server Response (msec) - ответ сервера (в миллисекундах);

SQL Server Authentication (enabled/disabled) - разрешен ли вход для серверных логинов;

Number of Databases - количество баз данных;

Size of Data Files - размер файлов данных;

Size of Log Files - размер файлов журналов.

В разделе Alarms отображается информация о проблемах, возникших на сервере. В заголовке показано, сколько сигнализаторов какого типа сработали на сервере: Информация, [image] Предупреждения, [image] Ошибка.

Смотрите также:

Начало работы

Обслуживание серверов и баз данных

Хранение

Безопасность

Агент SQL сервера

Производительность

Журнал сервера

Запросы

Опции


Регистрация и просмотр свойств сервера

Для начала работы с сервером в SQL Administrator необходимо его зарегистрировать. Для этого существует специальный инструмент RegisterServer Register Server.

Вызывается этот мастер командой Register Server, которая присутствует в:

  • главном меню программы Server | RegisterServer Register Server,
  • на панели инструментов SQL Administrator,
  • в контекстном меню группы серверов.

Вкладки:

Параметры подключения

WMI Connection

Значения сигнализаторов

Сборщик статистики

Смотрите также:

Сигнализаторы

Репозитарий сервера

WMI подключение

Служба сбора статистики

Свойства сервера


General

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Параметры подключения

На вкладке General диалогового окна просмотра свойств сервера можно просматривать и при необходимости изменять параметры подключения к серверу баз данных.

Register server - Configuring general connection settings

Из раскрывающегося списка SQL server name выберите сервер (хост), к которому хотите подключиться.

При нажатии на кнопку [image] открывается список серверов, найденных в локальной сети.

Важно: имя сервера не всегда может отображаться в списке, в этом случае его можно ввести вручную.

Настройка подключения.

SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2008 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в SQL server name необходимо указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

В разделе Authentication задается способ идентификации пользователя на сервере.

!RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows.

!RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

Управление именами и паролями пользователей на сервере осуществляется с помощью Login Manager.

Если выбираете SQL Server authentication, то следует указать имя и пароль в полях Login и Password соответственно.

По имени и паролю система определяет ваши права доступа к информации и, в соответствии с этим, разрешает доступ к объектам.

Server display name

Имя, под которым сервер отображается в проводнике.

Server group

Группа в проводнике, к которой принадлежит выбранный сервер.

Server description

Текстовые комментарии к серверу.

Проверить соединение можно с помощью нажатия на кнопку Test connection.


WMI подключение

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

WMI connection

Попытка установить WMI-подключения к серверной машине происходит в момент подключения к удаленному серверу.

Register server - WMI Connection

!RadioButton Use current Windows user credentials

Эта опция означает, что для установления WMI-подключения к серверной машине будет использоваться текущий пользователь Windows.

!RadioButton Use these credentials

Введите имя входа (Login) и пароль (Password) для WMI-подключения.

Подробнее о WMI-подключении смотрите в разделе WMI подключение.


Значения сигнализаторов

На вкладке Alarm Summary можно просматривать и задавать значения сигнализаторов. Сигнализатор - это сообщение , которое информирует о возможных сбоях и вероятных проблемах на сервере. Все эти сообщения отображаются на вкладке Alarm summary.

Register server - Managing alarms

Alarm Summary Enabled

Установите этот флажок для получения информации сигнализаторов от всех отмеченных событий.

Важно: Сигнализаторы No server connection и No WMI Connection включаются / выключаются всегда с помощью этого флажка.

Для каждого предупреждения (кроме No server connection и No WMI Connection) можно задать:

Enabled

Установите этот флажок, чтобы активировать сигнализатор соответствующего события.

Check Interval

В этом поле можно задать, с какой частотой сервер будет проверяться на возникновение ошибок данным сигнализатором. Формат времени - 'd.hh:mm:ss'

Severity

Из этого раскрывающегося списка можно выбрать и установить для каждого сигнализатора степень важности.

Information - уведомление.

Warning - предупреждение.

Error - ошибка.

No server connection

Этот сигнализатор информирует об отсутствии подключения к серверу.

Max Response Time

Задать время в формате 'd.hh:mm:ss' в течение которого осуществляется попытка подключения к серверу. Если попытка установить соединение с сервером не удалась, то по истечении заданного интервала времени срабатывает сигнализатор "No Server Connection".

No WMI Connection

Этот сигнализатор извещает об отсутствии WMI подключения. При отсутствии этого подключения не работают некоторые функции программы.

SQL Server Agent Stopped

Этот сигнализатор извещает о том, что отключен SQL Server Agent и в связи с этим не выполняются задания.

Databases without Backup

В этом сигнализаторе отображается список баз данных, для которых не создавались резервные копии в течение указанного периода времени.

Check Period, Days

Число дней, за которое необходимо проверять наличие резервных копий баз данных, задайте в этом поле. Наличие резервных копий проверяется по серверной истории резервных копий.

Excluded Databases

Базы данных, для которых не нужно выполнять эту проверку, укажите в этом списке.

Failed Backups

В этом разделе отображаются планы обслуживания и задания, выполняющие операции резервного копирования, при последнем выполнении которых возникли ошибки.

Excluded Maintenance Subplans

В этом списке можно указать подпланы обслуживания (по одному в строку) для которых не должен срабатывать сигнализатор.

Excluded Jobs

В этом списке можно указать задания обслуживания (по одному в строку) для которых не должен срабатывать сигнализатор.

Failed Maintenance Plans

В этом разделе отображаются планы обслуживания, при выполнении которых в течение указанного периода времени возникли ошибки.

Check Period, Days

Число дней, за которые необходимо проверять наличие возникновения ошибок в планах обслуживания задайте в этом поле.

Excluded Maintenance Plans

В этом списке можно указать планы обслуживания (по одному в строку) для которых не должен срабатывать этот сигнализатор.

Failed Jobs

В этом разделе отображаются задания, при выполнении которых возникли ошибки.

Check Period, Days

Число дней, за которые необходимо проверять наличие возникновения ошибок в заданиях, задайте в этом поле.

Excluded Jobs

В этом списке можно указать задания (по одному в строку), для которых не должен срабатывать этот сигнализатор.

Filling up of Database Space

В этом разделе отображаются базы данных, у которых заполнены файловые группы.

Excluded Filegroups (database, filegroups)

Файловые группы, которые не нужно проверять, можно внести в этот список. Формат <database_name, filegroup_name>. По одной в строку.

Max Fullness Percent

Максимальный процент заполнения файловой группы, по достижению которого срабатывает сигнализатор.

Guest Enabled Databases

В этом разделе отображаются базы данных, имеющие активную учетную запись пользователя guest.

Excluded Databases

В этом списке можно указать базы данных (по одной в строку), для которых не должен срабатывать этот сигнализатор.

Orphaned Logins

Изолированные логины. Логин может стать изолированным, если перестает существовать пользователь Windows или группа, которой он соответствует. Также логин может стать изолированным при переносе базы данных 'master'.

Excluded Logins

Укажите в этом списке логины, для которых не должен срабатывать этот сигнализатор.

Orphaned Users

Изолированные пользователи. Пользователь базы данных может стать изолированным, если перестает существовать соответствующий логин SQL сервера. Также пользователь может стать изолированным при восстановлении базы данных или присоединении её к другому серверу.

Excluded Users (database, user)

Укажите в этом списке пользователей базы данных, в формате <database_name, database_user>, для которых не должен срабатывать этот сигнализатор.

Mixed Mode Authentication

Использование смешанной аутентификации - Windows и SQL Server.

Ole Automation Procedure enabled

Процедуры OLE-автоматизации включены на сервере. Если они включены, то существует возможность создания экземпляров объектов OLE-автоматизации в пакетах Transact-SQL, что может отрицательно сказаться на безопасности сервера.

xp_cmdshell Enabled

На сервере включена процедура xp_cmdshell. Эта процедура позволяет выполнять на сервере команды среды Windows, что может отрицательно сказаться на безопасности сервера.

CPU Overload

Этот сигнализатор срабатывает при загрузке CPU на величину большую, чем указано в поле Max CPU Usage Percent.

Max CPU Usage Percent

Максимальный процент использования процессора.

Lack of Memory

Уведомление о возможной нехватке оперативной памяти на сервере и отображение текущего значения страниц в секунду и объема доступной памяти.

Max Pages per Second

Максимальное число страниц в секунду.

Min Available Memory Percent

Минимальный объем свободной памяти.

Busy Disks

Отображаются диски, имеющие низкий уровень простоя в работе.

Min Disk Idle Time Percent

Минимальный процент времени простоя.

Large Disk Queue

Отображаются диски, имеющие длину очереди больше, чем указано в поле Max Disk Queue Length.

Max Disk Queue Length

Максимальная длина дисковой очереди.

High Disk Transfer Latency

Этот сигнализатор оповещает о том, что задержка при чтении и записи на диск превышает заданные значения Max Read Time and Max Write Time. Показывает текущие значения скорости чтения/записи.

Max Read Time

Введите значение максимальной задержки при чтении с диска (в секундах).

Max Write Time

Введите значение максимальной задержки при записи на диск (в секундах).

Low Page Life Expectancy

Этот сигнализатор срабатывает, когда страницы находятся в буфере меньше, чем задано параметром Min Page Life Expectancy.

Min Page Life Expectancy

Введите минимальное значение (в секундах), при достижении которого сработает сигнализатор.

Databases in Restricted User Mode

Этот сигнализатор показывает базы данных, для которых пользовательский доступ установлен в режиме RESTRICTED_USER.

Excluded Databases

В этом списке можно указать базы данных (по одной в строку), для которых не должен срабатывать этот сигнализатор.

Databases in Non-online State

Этот сигнализатор показывает базы данных, которые находятся не в состоянии Online, то есть в состоянии Offline или Emergency.

Excluded Databases

В этом списке можно указать базы данных (по одной в строку), для которых не должен срабатывать этот сигнализатор.

Errors in Server Error Log

Этот сигнализатор срабатывает, если строка, заданная в поле Search for появляется в логе SQL Server.

Search for

Введите подстроку ошибки SQL Server, о которой необходимо просигнализировать (например, 'login failed').

Low Buffer Cache Hit Ratio

Низкий процент заполнения буферного кэша. Процент заполнения - соотношение между числом попаданий в кэш и числом обращений к нему.

Min Buffer Hit Ratio

Минимальный процент заполнения буферного кэша.


Сборщик статистики

На этой вкладке можно задать параметры сбора статистики для каждого сервера. Просмотреть результаты сбора статистики можно на вкладке накопленная статистика в проводнике.

Важно: Сбор статистики базы данных осуществляется только в том случае, если служба Сбора статистики установлена и запущена в течение текущей сессии.

Register server - Setting statistics collection parameters

!CheckBox Enable Statistics collection

Если установлен этот флажок, то в программе будет осуществляться сбор статистики для выбранного сервера

Collect every n minutes

Получать и записывать статистическую информацию каждые n минут.

Remove detailed statistics older than n days

Удалять подробную статистику старше указанного количества дней.

Remove average statistics older than n days

Удалять усредненную статистику старше указанного количества дней.

Excluded from collection databases

В этом поле можно указать список баз данных, для которых не будет выполняться сбор статистики.


Регистрация нескольких серверов

С помощью диалога Register servers Вы можете зарегистрировать несколько серверов одновременно.

Чтобы открыть этот диалог:

  • выберите пункт Server | Register Servers... главного меню программы

или

  • выберите пункт Register Servers... контекстного меню проводника.

В таблице содержится список SQL серверов в локальной сети, которые были найдены средствами клиента SQL Server.

У зарегистрированных серверов установлен флажок Registered. Чтобы зарегистрировать новый сервер, установите в соответствующей строке флажок Registered. Чтобы удалить регистрацию сервера - снимите этот флажок.

Также, задайте следующие опции для регистрируемого сервера:

Display name - алиас сервера,

Server group - группа серверов, к которой будет принадлежать сервер,

Description - описание,

Alarm Summary enabled - получать ли информацию от сигнализаторов,

Statistics Collection enabled - собирать ли статистику сервера.

Задайте способ идентификации пользователя на сервере: Windows authentication или введите в соответствующих колонках имя (Login) и пароль (Password).

Для получения более детальной информации смотрите главу Регистрация и просмотр свойств сервера.


Сигнализаторы

На этой странице отображаются все сработавшие сигнализаторы.

Список сработавших сигнализаторов можно посмотреть в разделе проводника Alarm Summary.

С помощью пункта Tools | Alarm Summary главного меню программы можно открыть отдельную вкладку Alarm Summary, на которой отображается таблица, содержащая все сработавшие сигнализаторы на всех серверах.

Alarm summary - All

Чтобы посмотреть подробное описание сработавших сигнализаторов, выберите пункт Alarm Summary в проводнике.

Управлять списком сигнализаторов можно с помощью элементов управления, расположенных на панели инструментов, находящейся в верхней части окна.

Refresh Refresh - обновить значения сигнализатора. Из раскрывающегося списка можно выбрать конкретный сигнализатор, который нужно обновить.

EnableAlarmSummary Enable - отображать значения сигнализаторов.

DisableAlarmSummary Disable - не отображать значения сигнализаторов.

AlarmOptions Alarm Options - задать настройки сигнализаторов.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

AlarmLog Alarm Log - показать журнал сигнализаторов.

Рядом с каждым сигнализатором отображаются следующие кнопки:

Refresh - обновить информацию о сигнализаторе;

Tune -задать параметры срабатывания сигнализатора;

Help - открыть справку.

Для некоторых сигнализаторов отображается список объектов, которые содержат обнаруженные ошибки. Для каждого объекта предоставлен список действий для устранения возникшей ошибки.

alarmDatabasesWithoutBackups Databases without Backup

Этот сигнализатор показывает список баз данных, у которых отсутствуют резервные копии за определенный промежуток времени. Чтобы устранить проблему, создайте резервную копию в Мастере резервного копирования, который открывается при нажатии на кнопку Backup.

alarmFailedJobs Failed jobs

Этот сигнализатор показывает список заданий, при последнем выполнении которых (в заданный промежуток времени), возникли ошибки. Нажмите кнопку Run, чтобы запустить повторное выполнение задания.

Важно: Для работы с заданиями необходимо запустить службу SQL Server Agent.

alarmFailedBackups Failed backups

Этот сигнализатор показывает список планов обслуживания и заданий, выполняющих операции резервного копирования, при выполнении которых (в заданный промежуток времени), возникли ошибки. Чтобы вызвать редактор планов обслуживания или редактор заданий, нажмите на имя плана обслуживания / задания в колонке Maintenance Plan/Job. Чтобы открыть редактор шагов или редактор задач, нажмите на имя шага / задачи в колонке Task/Job Step. Также можно запустить выполнение задания нажатием кнопки Run в столбце Run.

Важно: Для работы с заданиями необходимо запустить службу SQL Server Agent.

alarmFailedMaintPlans Failed Maintenance Plans

Этот сигнализатор показывает список подпланов, при последнем выполнении которых (в заданный промежуток времени), возникли ошибки. Чтобы вызвать редактор планов обслуживания, нажмите на имя плана обслуживания. При нажатии на имя подплана откроется раздел Задачи редактора планов обслуживания. Чтобы запустить выполнение плана обслуживания, нажмите кнопку Run.

alarmFilledDBSpace Filling up of Database Space

Этот сигнализатор показывает список баз данных, у которых заполнены файловые группы. Он появляется, когда процент заполнения файловой группы превышает указанное значение. Чтобы изменить размер файловой группы, нажмите кнопку Edit.

alarmGuestEnabled Guest Enabled Databases

Этот сигнализатор показывает список баз данных, имеющих активную учетную запись пользователя 'guest'. Чтобы отключить эту учетную запись, нажмите на кнопку Disable guest.

alarmOrphanedLogins Orphaned Logins

В этом сигнализаторе отображается список изолированных логинов. Чтобы открыть логин в редакторе логинов, нажмите на его имя. Чтобы удалить логин, нажмите на кнопку Drop.

alarmOrphanedUsers Orphaned Users

Этот сигнализатор появляется, когда пользователь базы данных становится изолированным. Чтобы открыть пользователя в редакторе пользователей баз данных, нажмите на его имя. После выбора логина, для которого был создан пользователь, он перестанет быть изолированным. Чтобы удалить пользователя, нажмите кнопку Drop.

alarmMixedMode Mixed Mode Authentication

Этот сигнализатор информирует о том, что на сервере активирован смешанный режим аутентификации - Windows и SQL Server. Чтобы изменить режим аутентификации, нажмите кнопку Modify. Откроется диалоговое окно Server properties.

alarmOLEProcEnabled Ole Automation Procedures Enabled

Этот сигнализатор информирует о том, что на сервере разрешены процедуры OLE-автоматизации. Нажмите кнопку Disable, чтобы открыть диалоговое окно Server properties и отключить эту опцию.

xp_cmdshell Enabled

Этот сигнализатор появляется, если на сервере включена процедура xp_cmdshell. Нажмите кнопку Disable, чтобы открыть диалоговое окно Server properties и отключить эту опцию.

alarmLowBufferCacheHitRatio Low Buffer Cache Hit Ratio

Этот сигнализатор информирует о том, что процент заполнения буферного кэша стал ниже минимального значения (Min Buffer Hit Ratio). Чтобы устранить проблему, отредактируйте необходимые параметры в диалоге Server Properties.

alarmServerErrorLog Errors in Server Error Log

Этот сигнализатор срабатывает, когда ошибка, заданная в поле Search for появляется в логе SQL Server. Полный текст ошибки приведен в столбце Message.

alarmRestrictedUserMode Databases in Restricted User Mode

Этот сигнализатор показывает базы данных, для которых пользовательский доступ установлен в режиме RESTRICTED_USER. При нажатии на имя базы данных она открывается в Редакторе баз данных, в котором можно изменить режим пользовательского доступа.

alarmNonOnlineDatabase Databases in Non-online State

Этот сигнализатор показывает базы данных, которые находятся не в состоянии Online, то есть в состоянии Offline или Emergency. При нажатии на имя базы данных она открывается в Редакторе баз данных, в котором можно изменить состояние базы данных (если возможно).

Чтобы сигнализатор не срабатывал для определенного объекта, нажмите кнопку Exclude рядом с именем объекта.

Note: Для срабатывания следующих сигнализаторов необходимо WMI подключение: SQL Server Agent Stopped, CPU Overload, Lack of Memory, Busy Disks, Large Disk Queue.

Полный список сигнализаторов приведен на вкладке Alarm Summary диалога Server Registration Properties.

Смотрите также:

Регистрация и просмотр свойств сервера

Репозитарий сервера

WMI подключение

Служба сбора статистики

Свойства сервера


Журнал сигнализаторов

В журнале отображаются сработавшие сигнализаторы в хронологическом порядке.

Сигнализаторы отображаются в виде таблицы со следующими столбцами:

Alarm Name - название сигнализатора;

Check Date - дата проверки сервера на наличие потенциальной проблемы;

Alarmed - включен ли сигнализатор;

Description - текстовое сообщение, описывающее потенциальную проблему, о которой сообщает сигнализатор.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Значения сигнализаторов


Репозитарий SQL Administrator

Для хранения служебной информации в SQL Administrator используется база данных на сервере.

В репозитории хранятся:

  1. Последние значения сигнализаторов.
  2. Журнал сигнализаторов (для сигнализаторов, поддерживающих журналирование).
  3. Параметры сборщика статистики для каждого из зарегистрированных серверов.
  4. Текущая (подробная) статистика производительности серверов.
  5. Усредненная статистика производительности серверов.

Задать параметры репозитория программы SQL Administrator можно в диалоговом окне, открывающемся при выборе пункта главного меню Server | SQL Administrator Repository.

SQL Administrator repository

Для репозитория можно указать следующие настройки.

SQL server name - имя сервера на котором расположена база репозитория. Необходимо указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

В разделе Authentication задается способ идентификации пользователя на сервере.

!RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows.

!RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

Управление именами и паролями пользователей на сервере осуществляется с помощью Login Manager.

Если выбираете SQL Server authentication, то следует указать имя и пароль в полях Login и Password соответственно.

По имени и паролю система определяет ваши права доступа к информации и, в соответствии с этим, разрешает доступ к объектам.

Database name (new or existent)

Из этого раскрывающегося списка нужно выбрать базу данных. Если необходимо создать новую базу, то её имя можно ввести в поле вручную. Если выбрана новая база для репозитария, то появляется следующий диалог.

С его помощью можно выбрать сервера, системная информация о которых, будет храниться в репозитарии, и статистика которых будет собираться с помощью службы сбора статистики. С помощью контекстного меню, появляющегося при нажатии правой кнопкой на форме, Вы можете:

Select All - выбрать все сервера,

Deselect All - отменить выбор всех серверов.

Чтобы новые параметры применились к statistics collector service, нужно переустановить сервис.

Репозитарий рекомендуется размещать на сервере, отличном от основного во избежание проблем с производительностью.

При создании базы данных репозитория, на сервере также создаются Задачи обслуживания:

  • avg_stats – усредняет текущую статистику, для сокращения места, занимаемой статистикой производительности серверов.
  • cleanup_stats – удаляет старую статистику в соответствии с параметрами времени хранения текущей и усредненной статистики.
  • cleanup_alarm_log – удаляет старые элементы лога сигнализаторов в соответствии с значениями параметра времени хранения лога сигнализаторов.

Для этих заданий имеются расписания для автоматического выполнения. Нужно проверять состояние выполнения этих заданий, иначе, если задания по какой-то причине не выполняются, база репозитория может сильно увеличиваться в размерах, а в самой программе могут возникать проблемы с производительностью при доступе к данным репозитория.

Смотрите также:

Регистрация и просмотр свойств сервера

Сигнализаторы

WMI подключение

Служба сбора статистики

Свойства сервера


WMI подключение

Кроме SQL соединения с SQL серверами, программа использует также WMI соединение.

WMI соединение используется:

  • Для получения системной информации о SQL сервере, например, версии установленной операционной системы, типе процессора.
  • Для запуска/остановки сервисов SQL сервера.
  • Для чтения журналов Windows.
  • Для получения значения счетчиков производительности системы для отображения в программе, в некоторых сигнализаторах, для сбора статистики в Службе сбора статистики.

При соединении используется аутентификация Windows - программа распознает пользователя по его доменному имени и паролю. Имя и пароль берутся автоматически в соответствии с используемой учетной записью домена Windows. Для подключения к службе сбора статистики используются права аккаунта log on. При отсутствии возможности установить удаленное WMI соединение с SQL сервером указанные выше функции программы недоступны.

Удаленное соединение в WMI зависит от брандмауэра Windows и настройки DCOM. В Windows Vista и более поздних операционных системах, User Account Control (UAC) может также потребовать изменения некоторых параметров. Также следует обеспечить доступ пользователя к пространству имен WMI ‘root\CIMV2’ (в SQL Administrator используется только это пространство имен).

По умолчанию права есть только у администраторов, но возможно обеспечить удаленный доступ к определенным пространствам имен WMI и для пользователей, не являющихся администраторами.

Подробнее об этом смотрите в MSDN library в разделе Connecting to WMI on a Remote Computer (http://msdn.microsoft.com/en-us/library/aa389290(v=vs.85).aspx).

Для установления удаленного WMI соединения нужно создать исключение для Windows firewall, чтобы разрешить пересылку информации по WMI. Для этого необходимо:

  • Для Windows XP and Windows Server 2003. В редакторе Group Policy (чтобы открыть введите Gpedit.msc в командной строке) в Local Computer Policy\Computer Configuration\Administrative Templates\Network(Сеть)\Network Connections (Сетевые подключения)\Windows Firewall(Брандмауэр Windows)\Domain Profile (Профиль домена) или Standard Profile key (Стандартный профиль) активировать параметр ‘Windows Firewall: Allow remote administration exception’ ('Брандмауэр Windows: Разрешать исключения для удаленного управления').
  • Для Windows Vista and later. На Control Panel (Панели управления) | Security (Система и безопасность) | Windows Firewall (Брандмауэр Windows) нажмите Разрешить запуск программы или компонента через Брандмауэр Windows. На странице разрешенных программ установить флажок для "Инструментарий управления Windows (WMI)".

Если удаленный пользователь не обладает правами администратора, то также необходимо:

  • Задать удаленный доступ и права на запуск DCOM пользователям или группам. Для этого нужно в DCOMCnfg.exe выбрать Component Services\Computers\My Computer. В контекстном меню My Computer выбрать пункт Properties. На вкладке COM Security в разделе Launch and Activation Permissions нажать Edit Limits. В список добавить нужного пользователя и установить для него права на Remote Launch и Remote Activation.
  • Задать права на удаленный доступ DCOM. В этом же диалоговом окне, на этой же вкладке, в разделе Access Permissions нажать кнопку Edit Limits. Из списка выбрать ANONYMOUS LOGON и для него установить флажок Remote Access.
  • Разрешить доступ пользователей к пространству имен WMI ‘root\CIMV2'. Открыть Control Panel (Панель управления) | Administrative Tools (Администрирование) | Computer Management (Управление Компьютером) | Services and Applications (Службы и приложения). В контекстном меню раздела WMI Control (Управляющий элемент WMI) выбрать пункт Properties (Свойства). На вкладке Security (Безопасность) выбрать Root\CIMV2 и нажать кнопку Security (Безопасность). В появившемся списке задать разрешение Remote Enable (Включить удаленно) для пользователя или группы.

Смотрите также:

Регистрация и просмотр свойств сервера

Сигнализаторы

Репозитарий сервера

Служба сбора статистики

Свойства сервера


Служба сбора статистики

Служба Statistics collector предназначена для сбора информации о производительности сервера SQL Server.

Чтобы разрешить сбор статистики для конкретных серверов, необходимо в диалоговом окне Register Server на вкладке Statistics Collection установить флажок !CheckBox Enabled.

Чтобы открыть Службу сбора статистики, выберите в главном меню программы пункт Tools | Statistics Collector State, или в левом нижнем углу программы щелкните на надписи "Statistics Collector State".

Statistics collector - Statistics Collector State

Statistics Collector service state

В этом поле отображается текущий статус службы. Обновить этот статус можно с помощью кнопки.

Install Service

Для начала работы со службой, ей необходимо установить.

Для этого нажмите кнопку Install Service.

Uninstall Service - удалить установку.

Start Service - запустить службу.

Stop Service - остановить службу.

Во время установки, в появившемся диалоговом окне можно задать настройки репозитория сервера и параметры доступа к службе.

Statistics collector - Statistics collector service options

SQL Administrator repository connection properties

В этом разделе задайте настройки репозитория сервера.

Service login

Определите, каким образом будет проводиться идентификация в службе.

!RadioButton Local system

Учетная запись LocalSystem - предопределенная локальная учетная запись, используемая диспетчером управления службами.

Этот тип идентификации может быть выбран только в случае, если в качестве способа идентификации пользователя на сервере используется SQL Server authentication.

!RadioButton This account

Если выбрана эта опция, то служба будет запускаться под указанным именем пользователя.

User name

Укажите учетную запись, под которой будет запущена служба в форме имя_домена\имя_пользователя.

Password

Введите пароль пользователя.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Регистрация и просмотр свойств сервера

Сигнализаторы

Репозитарий сервера

WMI подключение

Свойства сервера


Свойства сервера

В диалоговом окне Server Properties можно просматривать и изменять свойства сервера, позволяющие оптимизировать его работу.

Чтобы открыть диалоговое окно Server Properties необходимо в разделе рабочей области Actions выбрать пункт ServerProperties Server Properties. Также этот пункт доступен в контекстном меню раздела Server Security Options на вкладке Безопасность.

Все свойства сервера отображаются на следующих вкладках.

  • Память
  • Процессор
  • Параллелизм
  • Безопасность
  • Настройка контактной зоны
  • Подключения
  • Параметры базы данных
  • Полнотекстовый поиск
  • Дополнительные свойства сервера
  • Сеть

Навигационная панель редактора:

На навигационной панели отображается список складок редактора.

В разделе Shown values можно выбрать, какие значения будут отображаться на активной вкладке.

Configured Values

На активной вкладке отображаются измененные настроенные значения.

Running Values

При выборе этого пункта, на активной вкладке отображаются текущие работающие значения параметров. Если параметры были изменены, но ещё не вступили в силу, то просмотреть исходные значения параметров можно, нажав на панели инструментов Running Values.

Смотрите также:

Регистрация и просмотр свойств сервера

Сигнализаторы

Репозитарий сервера

WMI подключение

Служба сбора статистики


Память

Используйте вкладку Memory для просмотра или изменения параметров работы сервера с памятью.

Server properties - Memory

!CheckBox Use Address Windowing Extensions (AWE) memory

Указывает, что SQL Server использует расширения AWE в Microsoft Windows 2000 и Windows Server 2003 для поддержки 64 гигабайт (ГБ) физической памяти. Поддержка AWE работает только в 32-разрядных версиях операционных систем. Для использования памяти AWE необходимо задать настройки Windows дополнительно к указанной настройке SQL Server.

Параметры Minimum amount of server memory и Maximum amount of server memory для перенастройки объема памяти (в мегабайтах) в буферном пуле, используемого экземпляром SQL Server.

По умолчанию требования памяти сервера могут меняться в зависимости от системных ресурсов.

Значения по умолчанию

Minimum server memory = 0

Maximum server memory = 2147483647. Минимальное значение этого параметра - 16 MB.

Minimum server memory (MB)

Минимальный размер памяти сервера (в МБ)

Указывает, что при запуске SQL Server выделяется, по крайней мере, минимальный объем выделенной памяти, и этот объем не уменьшается. Задайте значение в зависимости от объема и активности экземпляра SQL Server. Задавайте для этого параметра оправданное значение, чтобы операционная система не забирала значительный объем памяти у SQL Server, и это не сказывалось на производительности Windows.

Maximum server memory (MB)

Максимальный размер памяти сервера (в МБ)

Максимальный объем памяти, который может использовать SQL Server во время работы. Этому параметру настройки может быть присвоено конкретное значение, если известно, что одновременно с SQL Server будет запущено несколько других приложений; также необходимо гарантировать достаточное количество памяти для этих приложений. Если другие приложения, например веб-серверы или серверы электронной почты, запрашивают память только при необходимости, то не задавайте этот параметр, так как SQL Server освобождает для них память по мере необходимости. Однако приложения часто используют столько памяти, сколько доступно в момент запуска и не запрашивают ее дополнительно. Если приложение запущено на том же компьютере, на котором запущен SQL Server, задайте такое значение, которое обеспечивает необходимый для приложения объем памяти, не занимаемый SQL Server.

Если параметр Минимальный размер памяти сервера равен 0, а параметр Максимальный размер памяти сервера равен 2147483647, SQL Server может использовать в любое время оптимальный объем памяти в зависимости от того, сколько памяти в текущий момент использует операционная система и другие приложения. При изменении загрузки компьютера и SQL Server меняется объем выделенной памяти. Ограничить объем динамически выделяемой памяти можно с помощью задания минимального и максимального значений.

В SQL Server Index creation memory - параметр, определяющий максимальный первоначальный объем памяти, выделенной для создания индекса. Если доступен дополнительный объем памяти, то сервер будет его использовать, даже если он превышает значение этого параметра.

Параметр Minimum amount of memory for query execution используется, чтобы указать минимальное количество памяти (в килобайтах), которое будет выделено для выполнения запроса.

Чтобы иметь возможность редактировать это поле снимите флажок !CheckBox Self-configuring.


Процессор

На вкладке Processor можно задать параметры экземпляра Microsoft® SQL Server, относящиеся к использованию процессора.

Server properties - Processor

Для реализации многозадачности операционные системы Microsoft Windows 2000 и Windows Server 2003 иногда перемещают потоки между разными процессорами. Назначение процессорам определенных потоков может повысить производительность, устраняя повторную загрузку процессоров и уменьшая количество переносов потоков между процессорами (а значит, уменьшая число контекстных переключений). Такая связь между потоком и процессором называется соответствием процессоров.

Соответствие процессоров поддерживается с помощью двух параметров affinity mask - !CheckBox Automatically configure CPU affinity mask и !CheckBox Automatically configure IO affinity mask.

В поле Maximum number of working threads можно указать количество рабочих потоков, доступных процессам Microsoft ® SQL Server

Чтобы иметь возможность изменять значение в этом поле, уберите флажок !CheckBox Self-configuring.

!CheckBox Run SQL Server at a higher scheduling priority

Установите этот флажок, если необходимо, чтобы процесс Microsoft SQL Server имел более высокий приоритет, чем все остальные процессы, запущенные на том же компьютере.

Чтобы обеспечить уменьшение системных издержек, связанных с излишним переключением контекста, что иногда случается при симметричной многопроцессорной обработке, установите флажок !CheckBox Windows fiber mode (lightweight pooling). В случае, когда наблюдается излишнее переключение контекста, использование упрощенных пулов, может обеспечить лучшую производительность за счет встроенного переключения контекстов, помогая таким образом уменьшить количество переходов пользователь/ядро.


Параллелизм

На вкладке Parallelism можно задать настройки для параллельного использования процессора экземпляром сервера.

Server properties - Parallelism

Используйте параметр Query plan cost threshold for parallelism, чтобы указать порог, при котором Microsoft SQL Server создает и выполняет параллельные планы для запросов. SQL Server создает и выполняет параллельный план для запроса, только если ожидаемая стоимость выполнения последовательного плана для того же запроса выше значения, установленного в параметре Query plan cost threshold for parallelism. Стоимость связана с ожидаемым количеством затраченного времени в секундах, необходимого для выполнения последовательного плана на определенной аппаратной конфигурации. Параметр Query plan threshold for parallelism следует устанавливать только в симметричных многопроцессорных системах.

Если SQL Server 2005 работает на многопроцессорном компьютере, он определяет оптимальную степень параллелизма, то есть количество процессоров, задействованных для выполнения одной инструкции для каждого из планов параллельного выполнения. Для ограничения количества процессоров в плане параллельного выполнения может быть использован параметр Maximum degree of parallelism in query executions. Установленное по умолчанию значение 0 использует все доступные процессоры. Чтобы отключить формирование параллельных планов, присвойте параметру Maximum degree of parallelism in query executions значение 1. Значение выше 1 (до 64) позволяет ограничить максимальное количество процессоров, используемых при выполнении одного запроса. Если указано значение, превышающее число доступных процессоров, используется фактическое число доступных процессоров. Если у компьютера только один процессор, то значение параметра Maximum degree of parallelism in query executions учитываться не будет.

Используйте параметр Maximum number of available locks, чтобы установить максимальное количество доступных блокировок, таким образом ограничивая объем памяти, используемой компонентом Database Engine для них. Значение 0 (по умолчанию) позволяет компоненту Database Engine динамически выделять и освобождать структуры блокировок в зависимости от изменяющихся системных требований.

Когда сервер запускается с параметром Maximum number of available locks, установленным в 0, диспетчер блокировок запрашивает у компонента Database Engine объем памяти, достаточный для начального пула в 2 500 структур блокировки. Если пул блокировки будет исчерпан, для пула будет запрошена дополнительная память.

Установите флажок !CheckBox Unlimited, чтобы разрешить серверу использовать блокировки динамически.

Используйте параметр Query wait for resources before timing out для указания времени в секундах (от 0 до 2147483647), в течение которого запрос будет ожидать ресурсы. Если используется значение по умолчанию (-1) или указано значение -1, то интервал ожидания равен предполагаемой цене запроса, увеличенной в 25 раз.

!CheckBox Use time-out calculated as 25 times of the estimated query cost

В Microsoft SQL Server требующие много памяти запросы (например, включающие сортировку и хеширование) помещаются в очередь, если для выполнения запроса не хватает памяти. Время истечения запроса истекает после установленного времени, рассчитанного SQL Server (25-кратная рассчитанная стоимость запроса), или времени, указанного неотрицательной величиной времени ожидания запроса.


Безопасность

На вкладке Security можно настроить экземпляр Microsoft ® SQL Server, задав параметры, относящиеся к безопасности сервера в группах: Server Authentication, Login audit level, Other security options, xp_cmdshell Proxy Account.

Server properties - Security

Server authentication

!RadioButton Windows Authentication mode

Когда пользователь подключается к серверу с помощью учетной записи Microsoft ® Windows, SQL Server проверяет имя учетной записи и пароль, используя информацию операционной системы Windows. Это режим идентификации является используемым по умолчанию. Он гораздо более безопасный, чем смешанный. Проверка подлинности Windows использует протокол безопасности Kerberos, обеспечивает политику паролей с точки зрения сложности проверки надежных паролей, поддерживает блокировку учетных записей, а также поддерживает истечение срока действия пароля.

!RadioButton SQL Server and Windows Authentication mode

Выбрав этот пункт, вы активируете смешанный режим аутентификации. В этом режиме пользователи могут подключаться, используя как Windows Authentication, так и SQL Server Authentication.

Пользователи, которые подключаются с помощью учетной записи пользователя Windows, могут использовать проверенные соединения, которые проверяются Windows.

Login audit level

!RadioButton None - не заносить в журнал попытки аутентификации.

!RadioButton Failed logins only - заносить в журнал неудачные попытки аутентификации.

!RadioButton Successful logins only - заносить в журнал случаи правильной аутентификации.

!RadioButton Both failed and successful logins - заносить в журнал все попытки аутентификации.

Other security options

!CheckBox Cross database ownership chaining

Установите этот флажок, чтобы включить межбазовые цепочки владения для экземпляра Microsoft SQL Server для всех баз данных.

!CheckBox C2 audit mode

Включение этого параметра заставляет сервер регистрировать как успешные, так и неуспешные попытки получения доступа к инструкциям и объектам. Эти сведения позволяют профилировать работу системы и отслеживать возможные нарушения политики безопасности.

!CheckBox Common Criteria compliance

Установка этого флажка включает следующие элементы, необходимые для поддержки стандарта Common Criteria.

  • Residual Information Protection (RIP) - Защита остаточных данных

Критерий RIP требует, чтобы выделяемая память была перезаписана известным битовым шаблоном, прежде чем она будет перераспределена для другого ресурса. Соответствие стандарту RIP может повысить безопасность, однако может привести к снижению производительности. После включения параметра common criteria compliance enabled производится перезапись памяти.

  • The ability to view login statistics - Возможность просматривать статистику имени входа

После включения параметра common criteria compliance enabled включается аудит входа. Каждый раз, когда пользователь успешно входит в SQL Server, становятся доступными сведения о времени последнего успешного входа, времени последней неудачной попытки входа и о количестве попыток между последним успешным уходом и текущим входом. Чтобы увидеть статистику входа, запросите динамическое административное представление sys.dm_exec_sessions.

  • Column GRANT should not override table DENY - Разрешение GRANT на столбец не переопределяет запрета DENY на таблицу

После включения параметра common criteria compliance enabled запрет DENY на уровне таблицы имеет больший приоритет, чем разрешение GRANT на уровне столбца. Если этот параметр выключен, разрешение GRANT на столбец имеет больший приоритет, чем запрет DENY на уровне таблицы.

xp_cmdshell Proxy Account

Эта опция позволяет пользователям SQL сервера, которые не принадлежат к фиксированной роли сервера sysadmin, выполнять команды xp_cmdshell и владеть объектами SQL Server - jobs. Чтобы получить доступ к этой функции, необходимо ввести имя учетной записи и пароль учетной записи в поля Account name и Account Password соответственно.

Эта опция доступна только при использовании SQL Server 2005 (и выше). Имя пользователя, используемое для прокси-сервера должно иметь минимум привилегий, необходимых для выполнения предусмотренной работы. Чрезмерные льготы для учетной записи могут быть использованы злоумышленниками для взлома вашей системы безопасности.


Настройка контактной зоны

На вкладке Surface area configuration можно настраивать экземпляр сервера Microsoft® SQL Server, включая и отключая некоторые редко используемые компоненты.

Server properties - Surface area configuration

!CheckBox Enable ad hoc distributed queries using OPENROWSET and OPENDATASOURCE

Установив этот флажок, Вы разрешаете выполнение нерегламентированных распределенных запросов, использующих операторы OPENROWSET и OPENDATASOURCE, на поставщиках, отличных от поставщика OLE DB для собственного клиента SQL.

В нерегламентированных распределенных запросах с помощью функций OPENROWSET и OPENDATASOURCE осуществляется подключение к удаленным источникам данных, использующим OLE DB. Функции OPENROWSET и OPENDATASOURCE должны использоваться с теми источниками данных OLE DB, обращения к которым происходят нечасто. Для источников данных, к которым обращение производится более чем несколько раз, определите связанный сервер.

!CheckBox Enable CLR integration

Установив этот флажок, вы указываете, могут ли пользовательские сборки выполняться на SQL Server.

!CheckBox Enable remote dedicated administrator connection (DAC)

Выделенное административное соединение (DAC) позволяет администратору подключиться к серверу для выполнения диагностических операций или инструкций языка Transact-SQL. DAC может использоваться в тех случаях, когда компонент Database Engine не отвечает на обычные соединения. По умолчанию эта функция включена только для локального соединения. Включение данного параметра позволяет использовать соединение DAC с удаленного компьютера. В конфигурации с кластеризацией необходимо установить этот параметр, чтобы разрешить соединение DAC.

!CheckBox Enable Database Mail

Компонент Database Mail — это решение уровня предприятия для отправки сообщений электронной почты от компонента Microsoft SQL Server 2005 Database Engine. Используя компонент Database Mail, приложения базы данных могут отправлять почтовые сообщения пользователям. Сообщения могут содержать результаты запроса, а также могут включать файлы из любого сетевого ресурса.

!CheckBox Enable using OLE Automation objects in Transact-SQL

В Transact-SQL включен ряд системных хранимых процедур, позволяющих ссылаться на объекты OLE-автоматизации из пакетов Transact-SQL, хранимых процедур и триггеров. Они выполняются как расширенные хранимые процедуры, при этом объекты OLE-автоматизации, запускаемые посредством хранимых процедур, работают в адресном пространстве экземпляра SQL Server Database Engine аналогично расширенным хранимым процедурам.

!CheckBox Enable xp_cmdshell

Опция xp_cmdshell увеличивает число процессов командного ядра Windows в строке для выполнения. Любые выходные данные возвращаются в виде текстовых строк.

!CheckBox Enable SQL Mail

Служба SQL Mail обеспечивает механизм отправки, получения и обработки сообщений электронной почты. Сообщения могут быть инициализированы, чтобы предоставить получателю конкретный результирующий набор запроса SQL Server. Служба SQL Mail также обеспечивает механизмы чтения и удаления сообщений электронной почты. Установка клиентского соединения с почтовым сервером, на котором реализован интерфейс Extended MAPI, позволяет выполнить все эти операции.


Подключения

На этой вкладке можно задать параметры, относящиеся к настройкам подключения к серверу.

Server properties - Connections

Maximum number of user connections

Максимальное число одновременных соединений (0 = не ограничено)

При установке значения, отличающегося от нуля, ограничивает количество соединений, допускаемое Microsoft SQL Server.

Важно: установка этого параметра на малое значение, например 1 или 2, может не дать возможности администраторам соединиться с целью администрирования сервера, однако выделенное соединение с сервером может быть осуществлено всегда.

Estimated query cost limit in seconds

Время выполнения запроса

С помощью этого счетчика задайте верхнюю границу времени выполнения запроса. Стоимость связана с оценочным значением затраченного времени в секундах, необходимого для завершения запроса на определенной конфигурации оборудования.

Если задать ненулевое неотрицательное значение, регулятор запросов запрещает выполнение всех запросов, расчетная стоимость которого превышает это значение. Если указать значение 0 (значение по умолчанию), регулятор запросов разрешает выполнение всех запросов без ограничения времени.

Outgoing remote query timeout in seconds

Время ожидания удаленного запроса (в секундах, 0 = не ограничено)

Задает время (в секундах), в течение которого может выполняться удаленная операция перед истечением времени ожидания SQL Server. Значение по умолчанию составляет 600 секунд, то есть 10 минут ожидания.

!CheckBox Allow remote SQL Servers to connect to this server

Разрешить удаленные соединения с этим сервером

Управляет выполнением хранимых процедур с удаленных серверов, на которых запущены экземпляры SQL Server. Установка этого флажка равнозначна установке параметра sp_configureremote access равным 1. Снятие флажка исключает выполнение хранимых процедур с удаленного сервера.

!CheckBox Distributed transactions for server-to-server communication

Требовать применения распределенных транзакций для соединения «сервер-сервер»

Защищает действия процедуры между серверами посредством транзакции координатора распределенных транзакций (MS DTC) (Microsoft).

Default connection options

Задает параметры соединения по умолчанию

Configuration option | Параметр конфигурации | Описание
ANSI NULL default off | ANSI NULL по умолчанию выключен | Изменяет работу сеанса для отказа совместимости с ANSI при поддержке значений NULL. Новые столбцы, которые определялись без явной поддержки значений NULL, определяются с недопущением этих значений.
ANSI NULL default on | ANSI NULL по умолчанию включен | Изменяет работу сеанса для использования совместимости с ANSI для поддержки значений NULL. Новые столбцы, которые определялись без явной поддержки значений NULL, определяются с допущением этих значений.
ANSI NULLs | Значения NULL по стандарту ANSI | Управляет обработкой значений NULL при использовании операторов равенства.
ANSI padding | Заполнение символами ANSI | Управляет дополнением переменных фиксированной длины.
ANSI warnings | Предупреждения в формате ANSI | Управляет усечением и значением NULL в предупреждениях статистического выражения.
Arithmetic abort | Прерывание арифметических действий | Прерывает запрос, если во время его выполнения возникла ошибка переполнения или деления на ноль.
Arithmetic ignore | Пропуск арифметических действий | Возвращает значение NULL, если во время выполнения запроса возникла ошибка переполнения или деления на ноль.
Close cursor on COMMIT | Закрытие курсора при фиксации | Управляет поведением курсоров после выполнения операции фиксации.
Concat NULL yields NULL | Сцепление значений NULL дает значение NULL | Возвращает NULL при конкатенации значения NULL со строкой.
Disable deferred constraint checking | Отключить отложенную проверку ограничений | Управляет промежуточной или отложенной проверкой ограничений.
Implicit transactions | Неявные транзакции | Управляет неявным началом транзакции при выполнении инструкции.
No count | Отсутствует счетчик | Выключает сообщение, которое возвращается в конце каждой инструкции и указывает количество затронутых строк.
Numeric round abort | Прерывание округления | Создает ошибку, если в выражении происходит потеря точности.
Quoted identifier | Заключенный в кавычки идентификатор | При вычислении выражения различает двойные и одинарные кавычки.
Xact abort | Прерывание транзакции | Выполняет откат транзакции, если инструкция языка Transact-SQL вызывает ошибку исполнения.


Параметры базы данных

На этой вкладке можно задать настройки баз данных выбранного экземпляра сервера.

Server properties - Database options

Default index fill factor in % - Коэффициент заполнения индекса, используемый по умолчанию

Указывает, как полный Microsoft SQL Server должен создавать каждую страницу при создании нового индекса на основании существующих данных. Коэффициент заполнения влияет на производительность, так как в процессе заполнения SQL Server тратит значительное время на разбиение страниц по мере их заполнения.

Значение по умолчанию равно 0; диапазон допустимых значений от 0 до 100. Коэффициент заполнения, равный 0 или 100, создает кластеризованные индексы с полными страницами данных и некластеризованные индексы с полными конечными страницами, но оставляет некоторое пространство в верхнем уровне дерева индексов. Значения коэффициента заполнения 0 и 100 одинаковы во всех отношениях.

При малых значениях коэффициента заполнения SQL Server создает индексы с незаполненными страницами. Каждый индекс требует больше места для хранения, но при этом остается больше места для последующих вставок без необходимости разбиения страниц.

Recovery interval in minutes - Интервал восстановления (в минутах)

Задает максимальное число минут на базу данных для восстановления баз данных. Если значение по умолчанию равно 0, оно означает автоматическую настройку, которую выполняет SQL Server. На практике это означает, что на восстановление требуется менее минуты и для активных баз данных контрольная точка повторяется каждую минуту.

Default data files location

Указывает расположение файлов данных по умолчанию. Нажмите кнопку OpenFile , чтобы перейти к новому размещению по умолчанию.

Default log files location

Указывает расположение файлов журналов по умолчанию. Нажмите кнопку OpenFile , чтобы перейти к новому размещению по умолчанию.

Backup and restore options

Waiting for a new tape

!RadioButton Wait indefinitely

Указывает, что SQL Server будет ждать новую ленту для резервного копирования неограниченно.

!RadioButton Try once

Указывает, что SQL Server выдаст ошибку времени ожидания, если лента для резервного копирования не будет доступна в тот момент, когда она потребуется.

!RadioButton Try for ... minute(s)

Указывает, что SQL Server выдаст ошибку времени ожидания, если лента для резервного копирования не будет доступна в течение заданного периода.

Default backup media retension in days - Срок по умолчанию для хранения носителей резервных копий (в днях)

Задает значение по умолчанию для всей системы для периода времени хранения каждого носителя данных резервных копий после того, как он был использован для резервного копирования базы данных или журнала транзакций. Этот параметр обеспечивает защиту резервных копий от перезаписи до истечения установленного числа суток.

!CheckBox Compressed backups by default

Указывает, установлено ли сжатие резервной копии по умолчанию.


Полнотекстовый поиск

На вкладке Full-text search можно задать настройки, отвечающие за полнотекстовые запросы, выполняющие лингвистический поиск.

Server properties - Full-text search

Default full-text language

Полнотекстовые запросы выполняют лингвистический поиск текстовых данных в полнотекстовых индексах, оперируя словами и фразами на основе правил конкретного языка. Из этого раскрывающегося списка выберите язык для полнотекстового поиска.

Full-text catalog upgrade option

В этом разделе выберите действие, которое нужно выполнить с полнотекстовым каталогом при обновлении сервера.

!RadioButton Rebuild

Полнотекстовые каталоги перестраиваются с помощью новых и улучшенных средств разбиения по словам. Перестроение индексов может занять длительное время, а после обновления может потребоваться значительный объем ресурсов ЦП и памяти.

!RadioButton Reset

Полнотекстовые индексы сброшены. Файлы полнотекстовых каталогов SQL Server 2005 удалены, но метаданные полнотекстовых каталогов и полнотекстовых индексов сохранились. После обновления для всех полнотекстовых индексов отключается отслеживание изменений и сканирование не запускается автоматически. После завершения обновления каталог останется пустым, пока не будет вручную запущено полное заполнение.

!RadioButton Import

Полнотекстовые каталоги импортируются. Обычно импорт производится значительно быстрее перестроения. Например, если используется только один процессор, то импорт выполняется в 10 раз быстрее, чем перестроение. Однако в импортированных полнотекстовых каталогах не используются новые улучшенные средства разбиения по словам, добавленные в SQL Server 2008, поэтому со временем рекомендуется произвести перестроение полнотекстовых каталогов.


Дополнительные свойства сервера

На этой вкладке можно изменять различные настройки сервера.

Server properties - Miscellaneous

!CheckBox Allow triggers to fire another (nested triggers) - Разрешить триггерам вызывать срабатывание других триггеров

Управляет возможностью триггера выполнить действие, вызывающее срабатывание других триггеров. Если этот флажок не установлен, триггеры не могут срабатывать от других триггеров. Если этот флажок установлен, срабатывание триггеров может вызываться другими триггерами более чем на 32 уровнях.

!CheckBox Allow a server trigger to fire itself (recursive server triggers)

Установите этот флажок, чтобы разрешить триггеру рекурсивно самому себя вызывать.

!CheckBox Optimize plan cache for ad hoc workloads

Параметр optimize for ad hoc workloads используется для повышения эффективности кэширования планов рабочих нагрузок, содержащих много отдельных нерегламентированных пакетов. Если этот параметр имеет значение 1, компонент Компонент Database Engine при первой компиляции пакета сохраняет в кэше планов небольшую скомпилированную заглушку плана, а не полный откомпилированный план. Это несколько снижает требования к памяти, так как кэш планов не заполняется скомпилированными, не используемыми повторно планами.

!CheckBox Scan for automatically run stored procedures at server startup

Используйте эту опцию для сканирования автоматического выполнения хранимых процедур во время запуска сервера Microsoft SQL. Если эта опция включена, то все автоматически запускаемые хранимые процедуры, определенные на сервере, SQL Server сканирует и выполняет.

Blocked process threshold in seconds to generate report

Параметр blocked process threshold определяет пороговое значение (в секундах), в течение которого блокированный процесс порождает сообщения. Пороговое значение может быть задано в диапазоне от 0 до 86 400. По умолчанию отчеты о заблокированных процессах не создаются.

Cursor number of rows threshold to run asynchronously

Параметр cursor threshold используется для указания количества строк в наборе курсора, при котором наборы ключей курсора создаются асинхронно. Когда курсоры формируют набор ключей для результирующего набора, оптимизатор запросов прогнозирует количество строк, которые будут возвращены для этого результирующего набора. Если оптимизатор запросов определяет, что число возвращенных строк превышает указанное пороговое значение, курсор формируется асинхронно, позволяя пользователю извлекать из него строки при продолжающемся процессе его заполнения. В противном случае курсор формируется синхронно, и запрос ожидает возвращения всех строк.

Если значение параметра cursor threshold установить равным -1, все наборы ключей будут создаваться синхронно, что предпочтительно для небольших наборов курсоров. Если значение параметра cursor threshold установить равным 0, все наборы ключей будут создаваться асинхронно.

Maximum size of text data to replicate in bytes

В этом поле укажите максимальный размер (в байтах) для данных типов text, ntext, varchar(max), nvarchar(max), varbinary(max), xml, и image, которые могут добавляться к реплицируемому столбцу в инструкциях INSERT, UPDATE, WRITETEXT и UPDATETEXT. Значение по умолчанию равно 65536. Значение -1 означает отсутствие ограничений, кроме тех, которые налагаются типом данных. Этот параметр применим только к репликации транзакций и системе отслеживания измененных данных. Если сервер настроен как для репликации транзакций, так и для системы отслеживания измененных данных, заданное значение применяется к обеим функциям. При репликации моментальных снимков и репликации слиянием этот параметр не учитывается.

Cutoff year for interpreting two-digit years as four-digit years

Используйте этот параметр, чтобы указать целое число от 1753 до 9999, которое представляет пороговый год для интерпретации обозначенного двумя цифрами года как года из четырех цифр.

Если двузначное число, обозначающее год, меньше или равно двузначному числу из последних двух цифр порогового года, год относится к тому же столетию, что и пороговый год. Если двузначное число, обозначающее год, больше двузначного числа из последних двух цифр порогового года, год относится к столетию, которое предшествует столетию порогового года. Например, если two digit year cutoff равно 2049 (по умолчанию), год, обозначенный двумя цифрами 49, интерпретируется как 2049, а год, обозначенный двумя цифрами 50, интерпретируется как 1950.

Default language for created logins

Из этого раскрывающегося списка выберите язык, который будет устанавливаться по умолчанию для создаваемого пользователя.

Filestream access level

FILESTREAM дает возможность приложениям на основе SQL Server хранить в файловой системе неструктурированные данные, такие как документы и изображения. Приложения могут эффективно использовать многопоточные API-интерфейсы и производительность файловой системы, одновременно обеспечивая согласованность между неструктурированными и соответствующими им структурированными данными.

!RadioButton Disable FILESTREAM support for this instance

Выберите этот пункт, чтобы отключить функцию FILESTREAM для работы с неструктурированными данными.

!RadioButton Enable FILESTREAM for Transact-SQL access

Если выбрана эта опция, то неструктурированные данные будут управляться средствами Transact-SQL (insert, update, query, search, and back up).

!RadioButton Enable FILESTREAM for Transact-SQL and Win32 streaming access

Если выбрана эта опция, то используется потоковый доступ Win32 для FILESTREAM. можно использовать Win32 для чтения и записи данных в FILESTREAM BLOB.


Network

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Сеть

На этой вкладке можно задать настройки, регулирующие работу по сети.

Server properties - Network

Network packet size

С помощью этого счетчика можно задать размер пакета (в байтах), используемого во всей сети.

Remote login timeout

С помощью этого счетчика задайте для указания интервал времени ожидания (в секундах) попытки войти в систему на удаленном сервере.


Мастер сравнения серверных конфигураций

Мастер сравнения серверных конфигураций (Compare Server Configurations Wizard) позволяет сохранять текущую конфигурацию сервера, которая включает в себя сведения о сервере, свойства сервера, глобальные параметры конфигурации сервера, участников сервера, базы данных, участников баз данных и разрешения. С помощью данного мастера Вы также можете:

  • сравнивать сохраненную и текущую конфигурации одного сервера и обновлять конфигурацию сервера на основе сохраненной конфигурации,
  • сравнивать текущие конфигурации двух серверов и обновлять конфигурацию одного сервера на основе конфигурации другого,
  • сравнивать сохраненные конфигурации двух серверов,
  • сравнивать две сохраненные конфигурации одного сервера.

Конфигурации, которые больше не актуальны, могут быть удалены.

Все сохраненные конфигурации хранятся в базе данных, которая используется в качестве репозитария SQL Administrator.

Чтобы запустить этот мастер, необходимо выбрать Tools | CompareConfigurations Compare Configurations... в главном меню программы или нажать кнопку CompareConfigurations Compare Configurations... на Панели инструментов.

Шаги мастера:

Выбор операции

Сохранение конфигурации

Задание настроек сохранения конфигурации

Просмотр информации о сохранении

Выполнение операции

Сравнение конфигураций

Выбор конфигураций для сравнения

Задание настроек сравнения

Просмотр информации о сравнении

Выполнение операции

Просмотр результатов сравнения

Выбор целевого сервера

Задание файла назначения

Просмотр информации об обновлении

Выполнение операции

Удаление конфигурации

Выбор сервера

Выбор конфигураций для удаления

Просмотр информации об удалении

Выполнение операции

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.


Выбор операции

На первом шаге мастера Вам необходимо выбрать операцию, которую Вы хотите произвести.

Compare server configurations - Selecting operation

!RadioButton Save configuration

Сохранить текущую конфигурацию сервера в Репозитарий SQL Administrator. Сохраненная конфигурация включает в себя: сведения о сервере, свойства сервера, параметры конфигураций сервера, параметры баз данных, файлы баз данных и группы файлов, участники сервера и баз данных, разрешения для объектов сервера и базы данных.

!RadioButton Compare configurations

Сравнить серверные конфигурации. Вы можете сравнивать сохраненные или текущие конфигурации одного сервера или двух серверов. После сравнения Вы можете обновить текущую конфиурацию сервера на основе другой конфигурации. Обновление возможно только в случае, если в качестве одной из конфигураций для сравнения выбрана текущая конфигурация сервера.

!RadioButton Delete saved configurations

Удалить сохраненные конфигурации.


Задание настроек сохранения конфигурации

На этом шаге задайте настройки сохранения конфигурации сервера.

Compare server configurations - Setting saving configuration options

Server group

Из этого раскрывающегося списка выберите группу серверов, к которой принадлежит необходимый сервер.

Server name

Выберите сервер, конфигурацию которого Вы хотите сохранить.

Configuration name

Задайте имя сохраняемой конфигурации. Имя конфигурации не должно превышать 128 символов.


Просмотр информации о сохранении

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции сохранения конфигурации сервера нажмите кнопку Execute.

Compare server configurations - Viewing saving configuration information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

После нажатия кнопки Execute Вы автоматически перейдете на шаг Выполнения операции.


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Compare server configurations - Executing saving configuration operation

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.


Выбор конфигураций для сравнения

На этом шаге Вам необходимо задать конфигурации, сравнение которых Вы хотите провести.

Compare server configurations - Specifying configurations for comparing

Server group

Из этого раскрывающегося списка выберите группу серверов, к которой принадлежит необходимый сервер.

Server name

Выберите сервер, конфигурацию которого Вы хотите сравнить.

!CheckBox Same server

Установите флажок, если Вы хотите сравнить две конфигурации одного сервера.

Configuration

Из выпадающего списка выберите конфигурацию для сравнения. В списке содержатся имена всех сохраненных конфигураций, а также указано время их создания. Есои Вы хотите сравнить и обновить текущую серверную конфигурацию, выберите пункт <Current>.


Задание настроек сравнения

На данном шаге задайте опции для сравнения конфигураций.

Compare server configurations - Setting comparing configurations options

Выберите разделы конфигурации, которые Вы хотите сравнить:

  • server information - сведения о сервере,
  • server properties - свойства сервера,
  • global configuration settings - глобальные параметры конфигурации сервера,
  • server principals - участники сервера,
  • databases - базы данных,
  • databases principals - участники баз данных,
  • permissions - разрешения.

В списке Comparing databases выберите базы данных, которые необходимо сравнить. Сравниваются следующие параметры (и участники):

  • database properties - свойства базы данных,
  • filegroups - файловые группы,
  • files - файлы базы данных,
  • application roles - роли приложений,
  • roles - роли базы данных,
  • users - пользователи.

Базы данных, информация о которых содержится в первой заданной конфигурации, но не содержится во второй, выделены голубым цветом.

Базы данных, информация о которых содержится во второй заданной конфигурации, но не содержится в первой, выделены зеленым цветом.

С помощью контекстного меню, появляющегося при нажатии правой кнопкой на форме, Вы можете:

Select All - выбрать все базы,

Deselect All - отменить выбор всех баз.

Если установлен флажок !CheckBox All, то будет произведено сравнение всех баз на сервере.


Просмотр информации о сравнении

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции сравнения серверных конфигураций нажмите кнопку Execute.

Compare server configurations - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

После нажатия кнопки Execute Вы автоматически перейдете на шаг Выполнения операции.


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Compare server configurations - Executing comparing operation

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.


Просмотр результатов сравнения

После выполнения сравнения появляется таблица, в которой отражены различия между сравниваемыми конфигурациями. Если сравнивается текущая конфигурация сервера, то Вы можете восстановить значения параметров, которые были изменены.

Compare server configurations - Viewing comparison results

!CheckBox Show only changed values

Отметьте эту опцию, чтобы в таблице отображались только параметры с измененными значениями.

Параметры, имеющие разные значения, выделены желтым цветом.

Объекты, которые существуют только в первой конфигурации, выделены голубым.

Объекты, которые существуют только во второй конфигурации, выделены зеленым.

Чтобы перейти на следующий шаг, выберите параметры, которые Вы хотите изменить, или объекты, которые хотите создать в текущей конфигурации сервера. Для этого установите флажок "Selected for next operation" в соответствующей строке.

Важно: Обновление конфигурации сервера возможно только в случае, если сравнивалась текущая конфигурация. Если Вы сравниваете две сохраненных конфигурации, то колонка "Selected for next operation" будет скрыта.


Выбор целевого сервера

На этом шаге выберите сервер, конфигурацию которого Вы хотите обновить. Если Вы сравниваете сохраненную и текущую конфигурации одного сервера, то текущая конфигурация будет обнволена на основе сохраненной.

Compare server configurations - Selecting server to update

Значения выбранных параметров выбранного сервера будут обновлены на основе конфигурации другого сервера; объекты будут созданы или удалены в зависимости от конфигурации.

!CheckBox Reconfigure server

Эта опция доступна, если обновляемые параметры относятся к группе Configuration (глобальные параметры конфигурации сервера). Если флажок установлен, то команда 'RECONFIGURE WITH OVERRIDE' будет включена в скрипт обновления сервера (параметры сервера будут изменены сразу после выполнения скрипта).

Если флажок не установлен, то изменения будут применены при перезагрузке сервера или при следующей переконфигурации сервера.

Note: Для применения изменений некоторых параметров может понадобиться перезагрузка сервера.


Задание файла назначения

Скрипт обновления сервера может быть выполнен после завершения шагов мастера, открыт в окне редактора запросов или сохранен в файл.

Compare server configurations - Specifying destination file name

!RadioButton Update server now

Выберите эту опцию, чтобы обновить серверную конфигурацию сразу после завершения шагов мастера.

!RadioButton Generate update script

Эту опцию выберите, если хотите просмотреть скрипт обновления перед его выполнением.

!RadioButton Load script to Query window - открыть скрипт в редакторе запросов.

!RadioButton Save script to file - сохранить скрипт в *.sql файл.

В последнем случае в поле File name необходимо указать имя файла и путь к нему, или выбрать файл, воспользовавшись стандартным диалоговым окном, открывающимся при нажатии на кнопку SaveFile . Для создаваемого файла можно указать кодировку, выбрав его из раскрывающегося списка Encoding.

!CheckBox Open script in Query window

Если установлен этот флажок, то скрипт будет автоматически открыт в редакторе запросов сразу после его сохранения в файл.


Задание паролей

На этом шаге Вам необходимо задать пароли для создаваемых логинов и ролей приложения. Этот шаг появляется только в случае, если Вы выбрали логины или роли приложения на шаге Просмотр результатов сравнения, чтобы создать их на целевом сервере.

Compare server configurations - Setting passwords

В верхней таблице Вам необходимо задать пароль (Password) для каждого логина, а затем подтвердить его в поле Confirm Password. Установите флажок Must Change on Next Logon, чтобы при следующем подключении к серверу пароль был изменен.

В нижней таблице задайте пароль (Password) для каждой создаваемой роли приложения, а затем подтвердите его в поле Confirm Password.


Просмотр информации об обновлении

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции обновления конфигурации сервера нажмите кнопку Execute.

Compare server configurations - Viewing update information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

После нажатия кнопки Execute Вы автоматически перейдете на шаг Выполнения операции.


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Compare server configurations - Executing updating operation

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.


Выбор сервера

На этом шаге выберите сервер, конфигурации которого Вы хотите удалить.

Compare server configurations - Selecting server for deleting configuration

Server group

Из этого раскрывающегося списка выберите группу серверов, к которой принадлежит необходимый сервер.

Server name

Выберите сервер, конфигурации которого Вы хотите удалить.


Выбор конфигураций для удаления

На этом шаге выберите конфигурации, которые Вы хотите удалить.

Compare server configurations - Selecting configurations to delete

В таблице перечислены все сохраненные конфигурации выбранного сервера.

Configuration name - имя конфигурации.

Date - дата сохранения конфигурации.

Version - версия SQL Administrator, в которой сохранялась данная конфигурация.

Чтобы выбрать конфигурацию для удаления, установите в соответствующей строке флажок Delete.


Просмотр информации об удалении

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции удаления конфигураций сервера нажмите кнопку Execute.

Compare server configurations - Viewing delele configuration information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

После нажатия кнопки Execute Вы автоматически перейдете на шаг Выполнения операции.


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Compare server configurations - Executing delete configuration operation

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.


Обслуживание серверов и баз данных

Для обслуживания серверов существует набор задач обслуживания и дополнительных вспомогательных инструментов.

Планы обслуживания

Редактор планов обслуживания

История планов обслуживания

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Устройства резервного копирования

Выполненные с ошибками резервные копии

История резервного копирования

Присоединение базы данных

Отсоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов

Сжатие базы данных

Свойства сервера

В разделе Проводника Maintenance можно просмотреть весь список действий, выполняемых с каждой базой данных на сервере. База данных выбирается из раскрывающегося списка Database на панели инструментов.

Важно: Вкладка Maintenance (за исключением раздела Backup) не доступна для SQL Server Express Edition, так как для управления планами обслуживания требуется агент SQL Server.

Для каждой базы данных, расположенной на выбранном сервере, отображается информация по всем операциям, которые с ней должны выполняться и о времени и результатах их выполнения.

Task Name

Имя выполняемой операции:

Full Backup - полное резервное копирование.

Differential Backup - резервное копирование внесенных изменений.

Transaction Log Backup - резервное копирование журнала транзакций.

CheckDatabase Checking Database - проверка базы данных.

CheckDatabase Checking Database Objects - проверка объектов базы данных.

RebuildIndexes Rebuilding/Reorganizing Indexes of Database - перестройка, реорганизация индексов базы данных.

RebuildIndexes Rebuilding/Reorganizing Indexes of Database Objects - перестройка, реорганизация индексов объектов базы данных.

Shrink Database - сжатие базы данных.

Shrink Database Files - сжатие файлов базы данных.

Maintenance Task Execution

По каждой выполняемой операции отображается информация о выполнении.

Last Execution Date - дата и время последнего выполнения.

Last Execution Outcome - результат последнего выполнения.

Schedule Period during a Month - расписание на месяц. Представляет собой серую ось с точками, которые соответствуют шестичасовым интервалам, дням и неделям. Зеленые линии показывают запланированное время резервного копирования.

В нижней части окна отображается более подробная информация по выбранной операции.

Maintenance Plan/Job

План обслуживания или задание.

Name - имя плана обслуживания.

Enabled - включен ли этот план обслуживания.

Last Run Outcome - результат последнего запуска.

Last Run Date - дата последнего запуска.

Schedule

Расписание выбранного плана обслуживания.

Schedule Name - имя расписания.

Enabled - включено ли это расписание.

Task/Job Step

Шаги плана обслуживания или задания.

Name - имя шага.

Last Run Outcome - результат последнего запуска.

Last Run Duration - продолжительность последнего выполнения.

Last Run Message - сообщение, полученное при последнем выполнении.

Schedule

Расписание выбранного шага.

Контекстное меню и панель управления раздела Task:

Refresh Refresh - обновить.

ColumnChooser Column chooser - выбрать отображаемые столбцы.

Database - выбрать базу данных.

CreateMaintenancePlan Create maintenance plan - создать план обслуживания.

Backup database - выполнить резервное копирование базы данных.

CheckDatabase Check database - выполнить проверку базы данных.

RebuildIndexes Rebuild/reorganize indexes - выполнить перестройку, реорганизацию индексов.

Shrink database - выполнить сжатие базы данных.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Контекстное меню и панель управления раздела Maintenance plan/job:

Edit Edit plan/job - изменить план обслуживания. Для редактирования можно открыть несколько планов одновременно. Для этого нужно выбрать в таблице желаемые объекты, удерживая клавишу Ctrl.

Drop Drop plan/job - удалить выбранный план обслуживания.

MaintenancePlanHistory Plan/job history - просмотреть историю выполнения выбранного плана обслуживания.

Enable/Disable plan/job - включить/отключить план обслуживания или задание.

StartJob Execute maintenance plan/job - выполнить выбранный план обслуживания.

Stop job - остановить выполнение задания.

Edit schedules - редактировать расписание выбранного задания.

Enable/Disable schedules - включить/отключить расписание.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Списки баз данных отображаются в следующих разделах:

Резервное копирование баз данных

Проверка баз данных

Восстановление/Реорганизация индексов

Storage->Databases

Безопасность

Смотрите также:

Начало работы

Работа с серверами

Хранение

Безопасность

Агент SQL сервера

Производительность

Журнал сервера

Запросы

Опции


Планы обслуживания

План обслуживания (Maintenance Plan) - фиксированная последовательность действий по оптимизации базы данных, которые будут выполняться в установленное время. Каждому плану также можно назначить запуск на разные моменты времени.

Важно: Необходимо запустить службы SQL Server Agent на сервере.

Важно: Если пользователь при входе использует тип аутентификации SQL Server, то планы обслуживания не будут показаны. Для их отображения необходимо использовать аутентификацию Windows.

Важно: Объект Агент SQL Server виден только членам ролей sysadmin, SQLAgentUserRole или MaintenanceUserRole. Для создания планов обслуживания и управления ими необходимо членство в роли sysadmin.

Database Maintenance - Maintenance plans

С помощью планов обслуживания можно выполнить следующие действия:

  • Создание последовательности выполняемых действий с использованием набора типовых задач обслуживания. Создание собственный скриптов Transact-SQL.
  • Удобная иерархия. Задачи в каждом плане обслуживания могут быть сгруппированы в подпланы, для каждого из которых можно назначить собственное расписание выполнения.
  • Возможность создания мультисерверных планов обслуживания.
  • Возможность фиксирования истории выполнения планов для удаленных серверов.
  • Поддержка Windows Authentication и SQL Server Authentication.

В этом разделе отображается список существующих планов обслуживания.

Планы обслуживания представлены в виде таблицы. Для каждого из них отображается следующая информация.

Name - имя объекта.

Folder - директория объекта.

Creation Date - дата создания.

Owner - владелец.

Reader Role - роль, имеющая право на чтение.

Writer Role - роль, имеющая право на запись.

Encrypted - зашифрован или нет.

Description - текстовое описание объекта.

Для управления объектами списка планов обслуживания используйте элементы управления, расположенные на панели управления или в контекстном меню.

Create Create maintenance plan - создать план обслуживания.

Edit Edit selected maintenance plan - изменить план обслуживания. Для редактирования можно открыть несколько планов одновременно. Для этого нужно выбрать в таблице желаемые объекты, удерживая клавишу Ctrl.

Drop Drop selected maintenance plan - удалить выбранный план обслуживания.

  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Execute Execute selected maintenance plan - выполнить выбранный план обслуживания.

MaintenancePlanHistory View maintenance plan history - просмотреть историю выполнения выбранного плана обслуживания.

Refresh Refresh the content of the job list - обновить

ColumnChooser Choose columns to display - выбрать отображаемые столбцы.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Смотрите также:

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Присоединение базы данных

Отсоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов

Сжатие базы данных


Редактор планов обслуживания

В редакторе Maintenance Plan Editor можно задать необходимые настройки плана обслуживания и его подпланов.

Чтобы открыть редактор планов обслуживания, необходимо в списке планов обслуживания или истории плана обслуживания дважды щелкнуть мышкой на нужном объекте или в контекстном меню выбрать пункт Create maintenance plan или Edit Maintenance Plan.

Важно: Чтобы работать с планами обслуживания, необходимо установить на сервере службу SQL Server Agent. Также необходимо установить SQL Server Integration Services на рабочем компьютере. Если не установлен SQL Server Integration Services, то планы открываются в режиме "только для чтения".

Список вкладок редактора и наиболее часто используемые инструменты располагаются на панели инструментов.

Вкладки редактора

Имя и описание

Задачи

Резервное копирование базы данных

Дополнительно

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка ограничений для заданий

Подключения

Расписания

Отчет

История выполнения


Панели инструментов

На панели инструментов редактора планов обслуживания отображаются инструменты, наиболее часто используемые для работы с объектом.

Maintenance plans - Maintenance Plan Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Execute Execute plan - выполнить план обслуживания.

History

Из раскрывающегося списка выберите период за который будет отображаться история выполнения плана обслуживания

ClearJobHistory Clear history - очистит историю выполнения плана обслуживания.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


General

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Имя и описание

На этой вкладке задайте основные параметры создаваемого плана обслуживания.

Maintenance plans - Maintenance Plan Editor - Setting general options

Name - имя плана обслуживания.

Description - текстовое описание плана обслуживания.

Смотрите также:

Задачи

Подключения

Расписания

Отчет

История выполнения


Задания

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Задачи

На этой вкладке можно создавать задачи, сгруппированные в подпланы. План обслуживания может содержать несколько вложенных подпланов, в которых содержится некоторый набор задач. Каждому подплану можно назначить своё расписание. В каждом плане обслуживания должен быть хоть один подплан. Все задачи реализуются средствами сервера.

Maintenance plans - Maintenance Plan Editor - Managing tasks

Подпланы отображаются в виде таблицы. Для каждого подплана отображается следующая информация:

Task Name - имя задачи.

Enabled - активен ли подплан.

Type - тип задания.

Databases/Objects - задействованные объекты и базы данных.

Контекстное меню

  • Add task - добавить задачу к существующему подплану.
  • Insert task - вставить новую задачу перед существующей.
  • Edit selected task - изменить существующую задачу.
  • Delete selected task - удалить существующую задачу.
  • Add a new subplan - создать новый подплан.
  • Edit selected subplan - изменить выбранный подплан.
  • Delete selected subplan - удалить выбранный подплан.
  • Enable Task - включить задачу.
  • Disable Task - отключить задачу.
  • Move the task up - переместить на одну строку вверх.
  • Move the task down - переместить на одну строку вниз.

В окне редактирования подплана задайте его имя (Name) и описание (Description).

Maintenance plans - Maintenance Plan Editor - Managing tasks - Edit subplan

Следующие задачи могут быть добавлены в подплан:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Смотрите также:

Имя и описание

Подключения

Расписания

Отчет

История выполнения


Резервное копирование базы данных

В этом диалоговом окне необходимо задать параметры задачи резервного копирования.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Backup

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Database(s)

Из этого раскрывающегося списка выберите, для каких баз данных будет выполнена текущая задача.

  • All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

  • System databases

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

  • All user databases

Создаваемый план обслуживания запускается для всех пользовательских баз данных.

С помощью кнопки Ellipsisbtn можно открыть диалоговое окно выбора баз данных.

Если для резервного копирования была выбрана только одна база данных, то необходимо выбрать, будет ли для неё создана полная резервная копия - !RadioButton Back up entire database, или резервная копия будет создана только для файлов и файловых групп - !RadioButton Back up files or filegroups. При выборе файлов и файловых групп их необходимо выбрать из соответствующего раскрывающегося списка.

!RadioButton Back up to the same backup device

Если выбрана эта опция, то резервные копии баз данных будут сохранены на одном носителе после выполнения операции.

Важно: Все выбранные носители должны быть одного типа.

Append to media / Overwrite media

Выберите, должны ли носители информации быть дополнены или переписаны во время операции резервного копирования.

!RadioButton Back up each database to a separate backup device

При выборе этой опции резервные копии баз данных будут сохранены на разные носители после выполнения операции.

!RadioButton To file

В поле Backup folder можно ввести или выбрать в диалоговом окне, открывающемся при нажатии на кнопку Ellipsisbtn,директорию, в которую будут сохранены резервные копии.

!CheckBox Create subfolder for each database

Установите этот флажок, чтобы для каждой резервной копии базы данных была создана отдельная папка.

!RadioButton To Windows Azure blob

Резервная копия каждой базы данных будет загружена в отдельный файл в хранилище Windows Azure.

Credential for Azure

Из выпадающего списка выберите учетную запись, которая будет использоваться для доступа к хранилищу Windows Azure. Чтобы создать новую учетную запись, нажмите кнопку AddJobCategory Add.

Storage container

Введите имя контейнера для хранения файла резервной копии.

URL prefix

После задания параметров в этом поле будет сформирован URL для доступа к контейнеру. Имя и дата создания файла резервной копии будет добавлено автоматически при загрузке резервной копии.

Backup file extension

В этом поле укажите расширение для файла резервной копии. По умолчанию - *.bak.

Дополнительно

Установка ограничений для задач

Смотрите также:

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Дополнительно

На этой вкладке можно задать дополнительные параметры операции резервного копирования.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Backup - Advanced

!CheckBox Backup set will expire

Если установлен этот флажок, то для резервной копии устанавливается срок годности.

!RadioButton After - резервная копия остается действительной в течение указанного числа дней после создания.

!RadioButton On - резервная копия остается действительной до указанной даты.

!CheckBox Verify backup integrity

Если установлен этот флажок, то созданная резервная копия будет выполнена проверка целостности созданного бэкапа. Эта проверка позволит выяснить, не повреждена ли резервная копия физически и может быть восстановлена.

!CheckBox Copy-only

Резервная копия типа copy-only не влияет на общую процедуру копирования-восстановления базы данных. Можно создать резервную копию copy-only для любого типа резервного копирования.

Backup compression (для SQL Server 2008 Enterprise и более поздних)

Server default

Использовать значение, заданное по умолчанию в свойствах сервера опцией Compressed backups by default.

On

Выберите эту опцию для сжатия резервной копии, независимо от степени сжатия, определенной сервером по умолчанию.

Off

Выберите эту опцию для создания резервной копии без использования сжатия, независимо от степени сжатия, определенной сервером по умолчанию.

!CheckBox Encrypt backup

Отметьте эту опцию, чтобы включить шифрование данных при создании резервной копии. Опция доступна только для SQL Server 2014.

Для шифрования резервной копии необходимо указать алгоритм шифрования и шифратор для защиты ключа шифрования.

Algorithm

Выберите один из доступных алгоритмов шифрования:

!RadioButton AES-128

!RadioButton AES-192

!RadioButton AES-256

!RadioButton Triple DES

Encryptor

Из выпадающего списка выберите шифратор. Шифратором может служить сертификат или асимметричный ключ для базы данных master.

Резервное копирование базы данных


Проверка базы данных

В этом диалоговом окне необходимо задать параметры задачи проверки целостности.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Check database

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Database(s)

Из этого раскрывающегося списка выберите, для каких баз данных будет выполнена текущая задача.

  • All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

  • System databases

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

  • All user databases

Создаваемый план обслуживания запускается для всех пользовательских баз данных.

С помощью кнопки Ellipsisbtn можно открыть диалоговое окно выбора баз данных.

!CheckBox Include checking index integrity

Проверка целостности всех страниц индекса, а также страниц таблиц данных.

Смотрите также:

Резервное копирование базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Перестроение индексов

В этом диалоговом окне необходимо задать параметры задачи перестроения индексов.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Rebuild index

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Database(s)

Из этого раскрывающегося списка выберите, для каких баз данных будет выполнена текущая задача.

  • All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

  • System databases

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

  • All user databases

Создаваемый план обслуживания запускается для всех пользовательских баз данных.

С помощью кнопки Ellipsisbtn можно открыть диалоговое окно выбора баз данных.

Object(s)

Если в поле Database(s) была выбрана одна база данных, то можно в этой базе данных выбрать отдельные объекты (таблицы или представления), в которых будут перестроены индексы.

All tables and views - все таблицы и представления.

All tables - все таблицы

All views - все представления.

Select - Выбрать отдельные объекты.

Для выбора отдельных объектов откройте с помощью кнопки Ellipsisbtn диалоговое окно.

!RadioButton Use fill factor value that is specified for rebuilt index

Удалить индексы таблиц в базе данных и заново создать их с коэффициентом заполнения, который был указан при создании индексов.

!RadioButton Use this fill factor value

Удалить индексы таблиц в базе данных и создать их заново с автоматически рассчитываемым коэффициентом заполнения. Чем выше процент, тем больше свободного места резервируется на страницах индекса. Допустимые значения от 0 до 100.

!CheckBox Sort in tempdb

С помощью этой опции указывается, где будут храниться промежуточные результаты сортировки, сгенерированные при создании индексов.

!CheckBox Keep indexes online during rebuilding

Эта опция позволяет пользователям получать доступ к базовой таблице, данным кластеризованного индекса и к любым связанным некластеризованным индексам во время выполнения операций с индексами.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Реорганизация индексов

В этом диалоговом окне необходимо задать параметры задачи реорганизации индексов.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Reorganize indexes

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Database(s)

Из этого раскрывающегося списка выберите, для каких баз данных будет выполнена текущая задача.

  • All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

  • System databases

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

  • All user databases

Создаваемый план обслуживания запускается для всех пользовательских баз данных.

С помощью кнопки Ellipsisbtn можно открыть диалоговое окно выбора баз данных.

Object(s)

Если в поле Database(s) была выбрана одна база данных, то можно в этой базе данных выбрать отдельные объекты (таблицы или представления), в которых будут реорганизованы индексы.

All tables and views - все таблицы и представления.

All tables - все таблицы

All views - все представления.

Select - Выбрать отдельные объекты.

Для выбора отдельных объектов откройте с помощью кнопки Ellipsisbtn диалоговое окно.

!CheckBox Compact large object pages

Установите этот флажок, чтобы освободить пространство для таблиц и представлений, когда это будет возможно.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Сжатие базы данных

В этом диалоговом окне необходимо задать параметры задачи сжатия базы данных.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Shrink database

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Database(s)

Из этого раскрывающегося списка выберите, для каких баз данных будет выполнена текущая задача.

  • All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

  • System databases

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

  • All user databases

Создаваемый план обслуживания запускается для всех пользовательских баз данных.

С помощью кнопки Ellipsisbtn можно открыть диалоговое окно выбора баз данных.

Shrink database when its size becomes more than (MB)

В этом поле можно задать размер базы данных в мегабайтах, при превышении которого будет запущена операция по сжатию базы.

Free space after shrink (%)

Прекратить сжатие, когда свободное место в файлах базы данных достигнет указанного значения.

Выберите нужно ли после завершения задачи !RadioButton Return free space to the operating system - вернуть свободное пространство операционной системе или !RadioButton Retain freed space in the database files - сохранить освободившееся пространство в файлах базы данных.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Обновление статистики

В этом диалоговом окне необходимо задать параметры задачи обновления статистики.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Update statistics

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Database(s)

Из этого раскрывающегося списка выберите, для каких баз данных будет выполнена текущая задача.

  • All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

  • System databases

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

  • All user databases

Создаваемый план обслуживания запускается для всех пользовательских баз данных.

С помощью кнопки Ellipsisbtn можно открыть диалоговое окно выбора баз данных.

Object(s)

Если в поле Database(s) была выбрана одна база данных, то можно в этой базе данных выбрать отдельные объекты (таблицы или представления), для которых будет обновлена статистика.

All tables and views - все таблицы и представления.

All tables - все таблицы

All views - все представления.

Select - Выбрать отдельные объекты.

Для выбора отдельных объектов откройте с помощью кнопки Ellipsisbtn диалоговое окно.

!RadioButton Update column and index statistics - для всех объектов.

!RadioButton Update column statistics only - для столбцов таблицы.

!RadioButton Update index statistics only - для индексов таблицы

Выберите тип просмотра, который используется для сбора обновленной статистики.

!RadioButton Perform full scan

Все строки в таблицах и представления должны быть считаны, чтобы собрать статистические данные.

Sample by n percent of rows

Доля таблицы или индексированного представления в процентах, подлежащая выборке при сборе статистических данных для крупных таблиц или представлений. Если указать 100%, то это будет равносильно выбору Fullscan.

Sample by n rows

Число строк, которые будут участвовать в выборке для обновления статистики.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Выполнение задания

В этом диалоговом окне необходимо задать параметры задачи выполнения задания. Эта опция недоступна, если в выбранном подключении нет SQL Server Agent.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Execute job

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Job to execute

Из этого раскрывающегося списка необходимо выбрать одно из существующих заданий SQL. Для создания и изменения существующего задания в Job Editor используются кнопки AddJobCategory и OpenInEditor соответственно.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Выполнение оператора T-SQL

В этом диалоговом окне необходимо задать параметры задачи выполнения оператора Transact-SQL.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Execute TSQL statement

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Execution timeout, seconds

Определить время ожидания завершения задачи (в секундах).

SQL

В этом текстовом редакторе необходимо задать оператор Transact-SQL, который будет выполняться в задаче.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Добавление уведомления о выполнении оператора

В план обслуживания можно добавить автоматически отправляемое уведомление.

Для использования этого задачи необходимо включить Database Mail и настроить msdb в качестве Mail Host Database. Также необходимо наличие операторов Microsoft SQL Server Agent с действительными e-mail адресами.

В диалоговом окне Notify Operators Task необходимо задать параметры уведомления о выполнении оператора.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Notify operator

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

Operators to notify

В этом поле необходимо отметить операторов, которым будут отправляться уведомления.

Message text

В этом поле необходимо задать текст отправляемого уведомления.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Очистка истории

Очистка журнала обслуживания

Установка очередности задач


Очистка истории

В этом диалоговом окне необходимо задать параметры задачи очистки истории.

С помощью задачи Clean Up History Task можно удалить устаревшую статистическую информацию из базы данных msdb. С помощью этой задачи будет удалена история резервного копирования и восстановления, история выполнения заданий SQL Server Agent и история планов обслуживания.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Clean up history

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

!CheckBox Remove backup/restore history

Установите этот флажок, чтобы удалить историю резервного копирования и восстановления выбранной базы данных из базы msdb.

!CheckBox Remove SQL Server Agent job history

Установите этот флажок, чтобы из журнала удалялись записи о работе SQL Server Agent, старше указанного времени.

!CheckBox Remove maintenance plan history

Если установлен этот флажок, то из базы данных msdb будет удалена история плана обслуживания.

Remove history that is older than

История старше указанного срока будет удаляться.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка журнала обслуживания

Установка очередности задач


Очистка журнала обслуживания

В этом диалоговом окне необходимо задать параметры задачи очистки журнала обслуживания.

На вкладке General задайте основные настройки задачи.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Clean up maintenance log

Name

В этом поле необходимо указать имя задачи.

!CheckBox Enabled

Включить выполнение задачи можно, установив этот флажок.

Connection

В этом поле можно указать новый тип подключения или выбрать один из существующих.

File types to remove

В этом разделе выберите тип файла для удаления.

!RadioButton Backup files

Файлы резервных копий.

!RadioButton Maintenance plan reports

Текстовые отчеты о ранее запущенных планах обслуживания.

File location

!RadioButton Delete specific file

Удалить файл, определенный в поле File name.

File name

В этом поле, используя кнопку OpenFile, укажите файл, который должен быть удален.

!RadioButton Delete files in specific folder by extension

Удалить все файлы, имеющие определенное расширение, из указанной директории. Используется для одновременного удаления нескольких файлов.

Folder name

В этом поле, используя кнопку OpenFile, укажите директорию, из которой должны быть удалены файлы.

File extension

в этом поле необходимо задать расширение удаляемых файлов.

*.bak - файлы резервных копий.

*.txt - отчеты о планах обслуживания.

!CheckBox Include first level subfolders

Удалить файлы с указанным расширением из вложенных директорий первого уровня вложенности.

File age

!CheckBox Delete only files that are older than

Файлы, существующие дольше указанного срока, будут удалены.

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Установка очередности задач


Установка ограничений для задач

На вкладке Precedence constraints можно задать ограничения для задач.

В разделе Preceding executables необходимо указать задачи, которые должны быть выполнены перед редактируемой.

В разделе Subsequent executables укажите задачи, которые должны выполняться после редактируемой задачи обслуживания.

!RadioButton To execute the task all constraints must be True (Logical AND) - все задачи, выполняемые перед редактируемой, должны быть TRUE.

!RadioButton To execute the task one constraint must be True (Logical OR) - для выполнения редактируемой задачи хотя бы одно из выполняемых ранее задач должно быть TRUE.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Precedence constraints

Контекстное меню:

Create Add constraint - добавить ограничение.

Edit Edit constraint - изменить ограничение.

Drop Delete constraint - удалить ограничение.

При добавлении или редактировании ограничения появляется окно Precedence Constraint.

Maintenance plans - Maintenance Plan Editor - Managing tasks - Precedence constraints - Edit constraint

Вторая задача (constrained executable) будет выполнена только в случае, если результат выполнения первой задачи (preceding executable) будет удовлетворять заданному критерию.

Есть два типа критериев:

!CheckBox Preceding execution result is - результат выполнения предыдущей задачи.

Критерию можно присвоить значение Success, Failure или Completion. Значение !RadioButton Success требует успешного завершения предыдущей задачи, значение !RadioButton Failure — завершения предыдущей задачи с ошибкой, а значение !RadioButton Completion обозначает, что задача будет выполнена независимо от результата выполнения предыдущей задачи.

!CheckBox Expression evaluates to True - заданное выражение возвращает True.

Вычисляется значение выражения, заданного в текстовом поле. Выражение может использовать литералы, системные и пользовательские переменные, функции и операторы, определяемые грамматикой выражений служб SSIS. Если выражение возвращает значение True, то задача будет выполнена.

Эти критерии можно использовать совместно (установив значение !RadioButton And), или выбрать только один критерий (установив значение !RadioButton Or).

Смотрите также:

Резервное копирование базы данных

Проверка базы данных

Перестройка индексов

Реорганизация индексов

Сжатие базы данных

Обновление статистики

Выполнение задания

Выполнение оператора T-SQL

Добавление уведомления о выполнении оператора

Очистка истории

Очистка журнала обслуживания


Подключения

На этой вкладке можно просматривать и изменять список возможных подключений для выполнения планов обслуживания.

Maintenance plans - Maintenance Plan Editor - Adding connections

Подключения отображаются в виде таблицы со следующими столбцами: Name, Server, Authentication, Connection String.

Local Server connection не может быть удален.

Контекстное меню:

Create New connection - добавить новое подключение.

Edit Edit connection - изменить существующее подключение.

Drop Drop connection - удалить существующее

Для задания параметров подключения, при его создании или редактировании, открывается специальное диалоговое окно - Connection Properties.

Maintenance plans - Maintenance Plan Editor - Adding connections - Connection properties

Connection name

Имя подключения.

Из раскрывающегося списка SQL server name выберите сервер (хост), к которому хотите подключиться.

При нажатии на кнопку [image] открывается список серверов, найденных в локальной сети.

Важно: имя сервера не всегда может отображаться в списке, в этом случае его можно ввести вручную.

SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2008 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в SQL server name необходимо указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

В разделе Authentication задается способ идентификации пользователя на сервере.

!RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows.

!RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

Управление именами и паролями пользователей на сервере осуществляется с помощью Login Manager.

Если выбираете SQL Server authentication, то следует указать имя и пароль в полях Login и Password соответственно.

По имени и паролю система определяет ваши права доступа к информации и, в соответствии с этим, разрешает доступ к объектам.

Смотрите также:

Имя и описание

Задачи

Расписания

Отчет

История выполнения


Расписания

На этой вкладке можно создавать расписания для подпланов, созданных на вкладке Задачи.

Maintenance plans - Maintenance Plan Editor - Managing schedules

Список расписаний для подпланов представлен в виде таблицы со следующими столбцами.

Name - имя расписания;

ID - идентификационный номер расписания;

Enabled - активно или нет;

Next Run Time - время следующего запуска;

Description - текстовое описание.

Управлять списком объектов можно с помощью контекстного меню.

  • New Schedule - Создать расписание, также можно использовать кнопку 'Insert';
  • Edit schedule - Редактировать расписание, также можно использовать кнопку 'Enter';
  • Delete schedule - удалить расписание, также можно использовать кнопку 'Delete';
  • Attach schedule - вставить уже существующее расписание;
  • Detach Schedule - удалить уже существующее расписание. Оно будет удалено только из этого подплана.
  • List Auto Width - автоматически установить ширину столбцов.

Смотрите также:

Имя и описание

Задачи

Подключения

Расписания

Отчет

История выполнения


Отчет

Параметры отчетов, создающихся при выполнении планов обслуживания, задаются на вкладке Reports.

Maintenance plans - Maintenance Plan Editor - Setting reporting options

!CheckBox Write report to a text file

Записывать отчет в текстовый файл.

!RadioButton Create new file

Создавать новый файл при каждом выполнении плана обслуживания.

По умолчанию, файлы отчетов записываются на том компьютере, на котором установлен экземпляр SQL Server, содержащий этот план обслуживания. Эта директория указывается при установке сервера.

Чтобы указать другую папку, введите полный путь к папке, в поле Folder name, или нажмите кнопку OpenFile и укажите нужную папку.

!RadioButton Append to file

Отчет о каждом выполнении плана добавляется в файл, указанный в поле File name. Также, можно указать файл, нажав кнопку OpenFile и выбрав файл из диалогового окна.

!CheckBox Send report by e-mail

Выберите эту опцию, чтобы передать результаты выполнения плана обслуживания по электронной почте. Эта опция доступна, только если Database Mail включен и правильно настроен.

To operator

Выберите оператора из списка доступных операторов, которые будут получать электронную почту. Эта опция доступна, только если Database Mail включен и правильно настроен.

!CheckBox Log to remote server

Установите этот флажок, чтобы вести журнал истории плана обслуживания на удаленном сервере.

Connection

Укажите информацию, используемую для подключения к удаленному серверу.

!CheckBox Extended logging

Выберите эту опцию, чтобы включить больше информации в журнал. Включение этой опции позволит увеличить объем хранимой истории выполнения плана обслуживания.

Смотрите также:

Имя и описание

Задачи

Подключения

Расписания

Отчет

История выполнения


History

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

История выполнения

На этой вкладке отображается история выполнения плана обслуживания.

Maintenance plans - Maintenance Plan Editor - Viewing maintenance plan history

История выполнения плана обслуживания отображается в виде таблицы со следующими столбцами: Maintenance Plan Name, Start Time, End Time, Subplan Name, Run Status, Logged Remotely, Plan ID, Duration, Source Server.

Можно изменять порядок столбцов, перетаскивая их заголовки по горизонтали. См. Работа с таблицами.

В разделе Task Details отображается список подпланов плана, выбранного в разделе Maintenance Plan History.

По задачам подплана отображается следующая информация: Task name, Start Time, Run Status, Duration, Server, Error Number, Error Message, Command, Task Details.

В нижней части отображается текстовое сообщение, если выбранная задача была выполнена с ошибкой.

Временной интервал отображения истории можно задать на Панели инструментов, в разделе History.

Смотрите также:

Имя и описание

Задачи

Подключения

Расписания

Отчет

История выполнения


История планов обслуживания

В разделе проводника Maintenance Plan History отображается история выполнения планов обслуживания.

Database Maintenance - Maintenance plan history

В разделе Maintenance Plan History история выполнения отображается в виде таблицы со следующими столбцами: Maintenance Plan Name, Start Time, End Time, Subplan Name, Run Status, Logged Remotely, Plan ID, Duration, Source Server. Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Из раскрывающегося списка Date Interval на панели инструментов можно выбрать интервал за который будет отображаться история.

Maintenance Plan - из этого раскрывающегося на панели инструментов списка можно выбрать конкретный план обслуживания по которому будет отображена история.

Контекстное меню раздела Maintenance Plan History

Edit Edit maintenance plan - редактировать план обслуживания.

ClearJobHistory Clear History - очистить историю выполнения планов обслуживания.

Execute Execute - выполнить план обслуживания.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

В разделе Task Details отображается дополнительная информация по выбранному выше плану обслуживания.

Task name, Start Time, Run Status, Duration, Server, Error Number, Error Message, Command, Task Details.

Если статус плана "Failed", то в нижней части формы отображается текстовое сообщение о возникшей ошибке.


Резервное копирование баз данных

Для работы с резервными копиями баз данных обслуживаемого сервера в проводнике существует специальный раздел - Maintenance | [image] Backup.

Database Maintenance - Backup database

Мастер резервного копирования

История резервного копирования

Выполненные с ошибками резервные копии

Устройства резервного копирования

В основной рабочей области отображается список всех баз данных выбранного сервера.

Для каждой базы показаны следующие параметры:

Database Name - имя базы данных;

Recovery Model - модель восстановления;

Has Backups - есть ли резервные копии;

Has Backup Schedules - есть ли расписание создания резервных копий;

Last Backup Date - дата последнего резервного копирования;

Last Execution Outcome - результат последнего выполнения;

Schedule Period during a Month - расписание на месяц. Представляет собой серую ось с точками, которые соответствуют шестичасовым интервалам, дням и неделям. Зеленые линии показывают запланированное время резервного копирования.

Контекстное меню

CreateMaintenancePlan Create maintenance plan - создать план обслуживания.

Create a database backup - создать резервную копию базы данных.

Edit Edit Database - редактировать базу данных

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Панель инструментов

Refresh Обновить содержимое страницы.

ColumnChooser Выбрать столбцы, которые должны отображаться.

При выборе конкретной базы данных в разделе Database, в нижней части окна, в разделе Backup Maintenance Plan/Job, отображается информация по планам обслуживания для этой базы:

Backup Maintenance Plan/Job

План обслуживания или задание.

Name - имя плана обслуживания.

Enabled - включен ли этот план обслуживания.

Last Run Outcome - результат последнего запуска.

Last Run Date - дата последнего запуска.

Schedule

Расписание выбранного плана обслуживания.

Schedule Name - имя расписания.

Enabled - включено ли это расписание.

Task/Job Step

Шаги плана обслуживания или задания.

Name - имя шага.

Last Run Outcome - результат последнего запуска.

Last Run Duration - продолжительность последнего выполнения.

Last Run Message - сообщение, полученное при последнем выполнении.

Schedule

Расписание выбранного шага.

Чтобы открыть план в Редакторе планов обслуживания необходимо дважды щелкнуть по нему мышкой, или выбрать пункт Edit Plans/Jobs в контекстном меню.

Смотрите также:

Планы обслуживания

Восстановление баз данных из резервной копии

Присоединение базы данных

Отсоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов

Сжатие базы данных


Мастер резервного копирования

С помощью Backup Database Wizard можно выполнить операцию резервного копирования базы данных SQL Server (для этой операции используется оператор Transact-SQL BACKUP DATABASE).

Эта операция используется для создания резервной копии всей базы данных, журнала транзакций или файлов и файловых групп.

Чтобы запустить [image] Backup Database Wizard, выберите в главном меню программы Tools | [image] Backup Database, или на панели инструментов нажмите кнопку [image] Backup Database, или в контекстном меню базы данных выберите пункт [image] Backup Database.

Список шагов:

Выбор сервера

Выбор типа резервного копирования

Выбор базы данных

Выбор нескольких баз данных

Выбор файлов и файловых групп

Выбор устройств резервного копирования

Задание наборов устройств резервного копирования

Задание параметров устройств резервного копирования

Задание параметров резервной копии

Создание задания

Выполнение операции


Выбор сервера

С помощью мастера резервного копирования Вы можете создавать резервные копии баз данных.

Server group

Из этого раскрывающегося списка необходимо выбрать группу, которой принадлежит сервер, на котором находится нужная база или базы.

Server name

Сам сервер можно выбрать из этого раскрывающегося списка.

Backup Database Wizard - Selecting server

!RadioButton Backup up a single database - создать резервную копию для одной базы данных.

!RadioButton Back up several database - создать резервную копию одновременно для нескольких баз данных.

Следующий шаг>>


Выбор типа резервного копирования

На этом шаге необходимо задать тип резервного копирования.

Backup Database Wizard - Setting backup type

В разделе Backup Type выберите тип резервного копирования.

!RadioButton Full - копировать базу данных полностью.

!RadioButton Differential - база данных будет скопирована частично (на следующем шаге можно будет выбрать нужные для копирования файлы).

!RadioButton Transaction log - в резервной копии будет сохранен журнал транзакции.

!CheckBox Copy-only (backup not affect the normal sequence of backups)

Резервная копия типа copy-only не влияет на общую процедуру копирования-восстановления базы данных. Можно создать резервную копию copy-only для любого типа резервного копирования.

Следующий шаг, если на первом шаге было выбрано создание резервной копии для одной базы данных - !RadioButton Backup up a single database

Следующий шаг, если на первом шаге было выбрано создание резервной копии для нескольких баз данных - !RadioButton Back up several database


Выбор базы данных

На этом шаге необходимо выбрать базу данных, для которой необходимо создать резервную копию.

Этот шаг принимает такой вид, если на первом шаге был выбран пункт !RadioButton Backup up a single database.

Backup Database Wizard - Selecting a single database to backup

В разделе Recovery Model отображается модель восстановления базы данных.

В поле Backup Name укажите имя резервной копии базы данных.

Краткое текстовое описание резервной копии можно задать в поле Backup Description.

<<Предыдущий шаг

Следующий шаг>>


Выбор нескольких баз данных

Этот шаг принимает такой вид, если на первом шаге был выбран пункт !RadioButton Back up several database.

Backup Database Wizard - Selecting several databases to backup

В этом случае необходимо отметить флажками нужные базы данных.

Для каждой базы можно задать настройки создаваемой резервной копии.

В разделе Recovery Model отображается модель восстановления базы данных.

В поле Backup Name укажите имя резервной копии базы данных.

Краткое текстовое описание резервной копии можно задать в поле Backup Description.

<<Предыдущий шаг

Следующий шаг>>


Выбор файлов и файловых групп

Этот шаг отображается, если резервное копирование выполняется для одной базы данных. На первом шаге было выбрано !RadioButton Backup up a single database, а на втором шаге было выбран тип резервного копирования !RadioButton Full или !RadioButton Differential.

На этом шаге выберите те файлы базы данных, резервную копию которых необходимо создать.

!CheckBox Если установить флажок Back up entire database, то будут выделены все файлы базы данных.

Backup Database Wizard - Selecting database files to backup

В столбце File or Filegroup в виде дерева представлены файлы базы данных. В столбце Backup установите флажки напротив тех файлов, которые надо добавить в резервную копию.

<<Предыдущий шаг

Следующий шаг>>


Выбор устройств резервного копирования

На этом шаге необходимо выбрать носители информации или устройства, на которые будет сохранена резервная копия базы данных. Для восстановления базы из резервной копии понадобятся все указанные в списке устройства и файлы.

Backup Database Wizard - Selecting backup devices

Из списка Backup Device выберите устройство для резервного копирования.

Также можно добавлять устройства разного типа с помощью кнопки Add Device.

При нажатии на раскрывающийся список кнопки Add Device можно выбрать одно из действий, которые необходимо произвести с устройствами резервного копирования.

  • Add Logical Device - добавить в список устройство (в появившемся списке отображаются все существующие устройства).
  • Create Logical Device - создать логическое устройство создать новое устройство.
  • Add File - добавить файл.
  • Add Tape - добавить ленту.
  • Add Windows Azure URL (доступно только для серверов версии SQL Server 2014).

При нажатии кнопки Change открывается диалоговое окно выбора устройства указанного типа.

Удалить выбранное устройство можно, нажав на кнопку Remove.

Для просмотра содержимого устройства резервного копирования, нажмите кнопку Device Contents.

Add Mirror Set - добавить набор зеркал.

При добавлении Windows Azure URL появляется диалог, предназначенный для формирования URL-адреса, на который будет загружена резервная копия базы данных.

Backup Database Wizard - Selecting backup devices - Azure URL Properties

Credential for Azure

Из выпадающего списка выберите учетную запись, которая будет использоваться для доступа к хранилищу Windows Azure. Чтобы создать новую учетную запись, нажмите кнопку AddJobCategory Add.

Storage container

Введите имя контейнера для хранения файла резервной копии.

Blob name

Введите имя файла резервной копии базы данных.

Result URL

В этом поле будет отображаться сформированный URL для доступа к файлу резервной копии.

Следующий шаг>>


Задание наборов носителей

На этом шаге определите, будут ли резервные копии всех баз данных записаны на один набор носителей, или каждая резервная копия будет записана на отдельный носитель.

Backup Database Wizard - Specifying backup sets

!RadioButton Back up all databases to the same media set

Все резервные копии баз данных будут записаны на один набор носителей после выполнения операции.

!RadioButton Back up each database to a separate media set

Резервная копия каждой базы данных будет записана на отдельный носитель.

!RadioButton To file

Резервная копия каждой базы данных будет записана в отдельный локальный файл.

Backup folder

С помощью кнопки Ellipsisbtn выберите папку, в которой хотите создать резервную копию.

!CheckBox Create subfolder for each database - создать подкаталог для каждой базы.

Backup file name

Введите имя файла резервной копии. По умолчанию будет создан файл с именем <database_name>.bak, где <database_name> - имя той базы данных, резервная копия которой создается.

!RadioButton To Windows Azure blob

Резервная копия каждой базы данных будет загружена в отдельный файл в хранилище Windows Azure.

URL template

С помощью кнопки Ellipsisbtn вызовите диалог для задания Windows Azure URL. Итоговый URL-адрес должен содержать тэг <database _name>. Он будет заменен на имя базы данных при загрузке файла резервной копии в хранилище.

Backup Database Wizard - Selecting backup devices - Azure URL Properties

Credential for Azure

Из выпадающего списка выберите учетную запись, которая будет использоваться для доступа к хранилищу Windows Azure. Чтобы создать новую учетную запись, нажмите кнопку AddJobCategory Add.

Storage container

Введите имя контейнера для хранения файла резервной копии.

Blob name

Введите имя файла резервной копии базы данных.

Result URL

В этом поле будет отображаться сформированный URL для доступа к файлу резервной копии.

Следующий шаг


Задание параметров устройств резервного копирования

На этом шаге укажите, записывается ли резервная копия на новый или на уже существующий носитель.

Backup Database Wizard - Setting backup media options

!RadioButton Back up to an existing backup media - записать резервную копию на уже существующий носитель.

Если носитель не существует, то он будет создан с заданным именем.

!RadioButton Append to Media - добавить информацию на существующий носитель.

!RadioButton Overwrite Media - перезаписать носитель.

Если выбран пункт !RadioButton Append to Media, то в поле Media set name необходимо задать имя носителя.

Если установлен флажок !CheckBox Check media name and abort if it doesn't match, то будет выполнена проверка наличия устройства с таким именем. Операция будет прервана при обнаружении несоответствия.

Если выбран пункт !RadioButton Overwrite Media, то в поле Media set name необходимо задать имя носителя.

Если установлен флажок !CheckBox Check media name and backup expiration date, abort if no success, то будет выполнена проверка наличия устройства с таким именем и даты истечения срока действия резервной копии. Дата истечения срока действия резервной копии задается на шаге Задание параметров резервной копии. Операция будет прервана при обнаружении несоответствия.

!RadioButton Back up to a new backup media

Создать новое устройство резервного копирования.

Media set name - имя устройства резервного копирования.

Media set description - описание устройства.

<<Предыдущий шаг

Следующий шаг>>


Задание параметров резервной копии

На этом шаге необходимо задать дополнительные параметры создаваемой резервной копии.

Backup Database Wizard - Setting backup options

В разделе Set backup expiration date необходимо задать настройки сроков действия создаваемой резервной копии.

!RadioButton Backup will expired after - резервная копия будет действительна в течение указанного количества дней.

!RadioButton Backup will expired on - резервная копия будет действительна до указанной даты.

Backup verification options

!CheckBox Verify backup after creation

Установите этот флажок для проверки резервной копии, выполняемой после создания.

!CheckBox Perform checksum verification before writing to media

Если флажок установлен, то будет выполняться проверка контрольной суммы перед записью резервной копии на носитель.

!CheckBox Continue on checksum error

Если флажок установлен, то операция резервного копирования будет продолжена при возникновении ошибки во время проверки контрольной суммы.

Backup compression

Выберите одну из опций сжатия резервной копии.

!RadioButton Server default

Использовать значение, заданное по умолчанию в свойствах сервера опцией Compressed backups by default.

!RadioButton On

Выполнять сжатие резервной копии.

!RadioButton Off

Не выполнять сжатие резервной копии.

<<Предыдущий шаг

Следующий шаг>>


Задание параметров резервного копирования лога транзакции

На этом шаге задайте параметры резервного копирования лога транзакции. Этот шаг появляется только в случае, если на втором шаге была выбран тип резервного копирования !RadioButton Transaction log.

Backup Database Wizard - Specifying  transaction backup options

!RadioButton Truncate inactive log items

Журнал очищается после того, как все записи в одном или нескольких виртуальных журналах становятся неактивными.

!RadioButton Don't truncate transaction log

Указывает, что усечение журнала не происходит, а компонент Database Engine пытается осуществить резервное копирование независимо от состояния базы данных. Следовательно, резервная копия, созданная с параметром NO_TRUNCATE, может иметь неполные метаданные. Данный параметр позволяет производить создание резервной копии журнала в тех ситуациях, когда база данных повреждена.

!RadioButton Back up the tail of the log and leave the database in the restoring state

Создает резервную копию остатка журнала и оставляет базу данных в состоянии RESTORING. Параметр NORECOVERY полезен при переключении на вспомогательную базу данных в случае возникновения ошибки, а также при сохранении остатка журнала после операции RESTORE.

!RadioButton Back up the tail of the log and leave the database in a read-only and standby state

Создает резервную копию остатка журнала и оставляет базу данных в режиме только для чтения и состоянии STANDBY. Предложение STANDBY записывает резервные данные (выполняя откат, но с возможностью дальнейшего восстановления).


Задание параметров шифрования

На этом шаге задайте параметры шифрования данных резервной копии.

Этот шаг появляется только при выполнении резервного копирования на серверах версии SQL Server 2014. Редактирование параметров возможно только в случае, если на шаге Задание параметров устройств резервного копирования была выбрана опция !RadioButton Back up to a new backup media.

Backup Database Wizard - Setting backup encryption

!CheckBox Encryption

Отметьте эту опцию, чтобы включить шифрование данных при создании резервной копии.

Для шифрования резервной копии необходимо указать алгоритм шифрования и шифратор для защиты ключа шифрования.

Algorithm

Выберите один из доступных алгоритмов шифрования:

!RadioButton AES-128

!RadioButton AES-192

!RadioButton AES-256

!RadioButton Triple DES

Encryptor

Из выпадающего списка выберите шифратор. Шифратором может служить сертификат или асимметричный ключ для базы данных master.

<<Предыдущий шаг

Следующий шаг>>


Создание задания

На этом шаге необходимо указать параметры задания для создания резервной копии.

Backup Database Wizard - Setting schedule options

!CheckBox Back up now

Установите этот флажок, чтобы начать создание резервной копии сразу после задания всех необходимых настроек.

!CheckBox Create a job

Установите этот флажок, чтобы создать задание со всеми задаваемыми параметрами операции резервного копирования. Для создания задания необходимо запустить службу SQL Server Agent.

В разделе Job properties необходимо указать параметры создаваемого задания.

Job name

Имя задания

Schedules

Список расписаний для создаваемого задания.

Управлять объектами этого списка можно с помощью кнопок, расположенных под ним.

Create - создать расписание.

Add Existing - добавить уже существующее.

Edit - изменить существующее расписание.

Remove - удалить расписание из списка.

Создавать и изменять расписания можно в Редакторе расписаний.

<<Предыдущий шаг

Следующий шаг>>


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Backup Database Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Backup Database Wizard - Exectuing backup database task

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


История резервного копирования

В этом разделе отображается вся история по выполнению резервных копий баз данных на зарегистрированных серверах.

С помощью инструментов, расположенных на панели инструментов и в контекстном меню, можно:

Backup - создать резервную копию.

Restore - восстановить базу данных из резервной копии.

DatabaseProperties Database Properties - просмотреть или изменить свойства базы данных.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Backup - Backup history

История резервного копирования баз данных представлена в виде таблицы со следующими столбцами.

Backup Start Date - дата и время начала создания резервной копии.

Backup Finish Date - дата и время окончания создания резервной копии.

DB Name - имя базы данных.

Backup Type - тип резервной копии.

Backup Set Name - имя набора устройств резервного копирования.

Backup Set Description - описание набора устройств резервного копирования.

Position - положение резервной копии на носителе.

Backup Size (MB) - размер резервной копии.

Compressed Size (MB) - размер сжатой резервной копии.

Media Set Name - название набора внешних устройств резервного копирования.

Media Set Description - описание набора внешних устройств резервного копирования.

User Name - имя пользователя, создавшего резервную копию.

Server Name - имя сервера.

Можно изменять порядок столбцов, перетаскивая их заголовки по горизонтали. См. Работа с таблицами.


Выполненные с ошибками резервные копии

В этом разделе отображается список операций резервного копирования, которые были выполнены с ошибками.

В разделе Maintenance Plan/Job History отображается список планов обслуживания и заданий, в которых возникли ошибки.

Контекстное меню:

Edit Edit Maintenance plan/job - изменить план обслуживания или задание.

StartJob Execute Subplan/Job - выполнить выбранный план обслуживания или задание.

  • Stop Job - остановить выполнение задания.

CreateMaintenancePlan Create Maintenance Plan - создать план обслуживания.

Backup Database - создать резервную копию.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

В разделе Task/Step History отображаются шаги выбранного задания или плана обслуживания. Сообщение об ошибке для выбранного шага выводится в нижней части окна.

Изменить выбранный шаг в редакторе можно с помощью пункта контекстного меню Edit Task/Step.

Backup - Failed backups

История планов обслуживания, выполненных с ошибками, представлена в виде таблицы со следующими столбцами: Run Date, Database, Run Status, Logged Remotely, Server, Plan/Job Name, Subplan Name, Backup Task/Step, Duration.

Шаги выбранного задания или плана обслуживания отображаются в виде таблицы со следующими столбцами: Run Date, Task/Step Name, Duration, Server, Command, Message.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Устройства резервного копирования

В разделе Backup devices содержится информация по всем устройствам резервного копирования, существующим в системе.

Backup - Backup devices

Управлять этим списком можно с помощью элементов управления, расположенных на панели инструментов или в контекстном меню.

Refresh Refresh - обновить список.

ColumnChooser Column Chooser - выбрать столбцы для отображения.

Create Create Backup device - создать устройство резервного копирования.

Edit Edit Backup device - изменить устройство резервного копирования.

Drop Drop Backup device - удалить устройство резервного копирования.

  • Rename Backup device - переименовать устройство резервного копирования.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

При создании и изменении объекта открывается Редактор устройств резервного копирования.


Редактор устройств резервного копирования

Этот редактор открывается при создании или редактировании устройства резервного копирования.

Вкладки редактора:

Свойства

Содержимое устройства

SQL описание


Свойства

На этой вкладке необходимо задать основные параметры устройства резервного копирования. Часть элементов управления доступна для редактирования только при создании объекта.

Backup database - Backup devices - Backup device Editor - Setting general properties

Name

Имя устройства.

Device type and physical name

Тип устройства и физическое имя.

!RadioButton File - файл.

!RadioButton Tape - ленточное устройство.

Чтобы завершить создание объекта необходимо нажать Apply на панели инструментов.


Содержимое устройства

При редактировании устройства на этой вкладке можно просматривать содержимое этого устройства.

Backup database - Backup devices - Backup device Editor - Viewing device contents

В разделе Media Properties устройства резервного копирования отображаются в виде таблицы со следующими столбцами:

Media name - имя устройства;

Number of families in the media set - количество семейств на носителе;

Sequence number of the family - порядковый номер семейства;

Sequence number of the media - порядковый номер носителя;

Media label created on - дата создания метки;

Media description - описание носителя.

В нижней части окна, в просмотрщике данных, показано содержимое устройства, то есть все резервные копии баз данных, располагающиеся на этом устройстве. А также, некоторая информация по этим копиям.

Backup Start Date - дата и время начала создания резервной копии;

Backup Finish Date - дата и время завершения создания резервной копии;

DB Name - имя базы данных, для которой делалась резервная копия;

Backup Type - тип резервной копии;

Backup Set Name - имя носителя резервной копии;

Backup Set Description - текстовое описание носителя резервной копии;

Position - положение резервной копии на носителе;

Backup Size (MB) - размер полученной резервной копии;

User Name - кем создана резервная копия;

Server Name - сервер, на котором расположена созданная резервная копия.

С помощью контекстного меню Вы можете запустить Мастер восстановления баз данных из резервной копии


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Backup database - Backup devices - Backup device Editor - Viewing SQL definition


Восстановление баз данных из резервной копии

Восстановление — это процесс копирования данных из резервной копии и применения журналов транзакций для наката до целевой точки восстановления.

С помощью этого мастера Вы можете восстановить и подготовить к работе базу данных из резервной копии.

Чтобы запустить этот инструмент, необходимо выбрать Tools | [image] Restore Database в главном меню программы или нажать кнопку Restore Database на Панели инструментов.

Список шагов:

Выбор сервера и типа восстановления

Выбор базы данных и способа восстановления

Указание момента времени для восстановления

Наборы резервных копий для восстановления

Файлы и файловые группы

Задание параметров восстановления

Параметры выполнения восстановления

Выполнение операции

Смотрите также:

Планы обслуживания

Резервное копирование баз данных

Присоединение базы данных

Отсоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов

Сжатие базы данных


Выбор сервера и типа восстановления

На первом шаге Вы можете выбрать тип восстановления базы данных.

Restore Database Wizard - Selecting server and setting restore type

Server group

Из этого раскрывающегося списка выберите группу серверов, к которой принадлежит нужный сервер.

Server name

Сервер, на который будет помещена восстанавливаемая база, необходимо выбрать из этого списка.

Select restore type

Выбрать тип восстановления базы данных можно с помощью опций в этом разделе.

!RadioButton Restore entire database

Полное восстановление базы данных.

!RadioButton Restore files or filegroups

Восстановление отдельных файлов и файловых групп. Файлы и файловые группы могут быть восстановлены с помощью операции восстановления файлов и файловых групп или с помощью восстановления из полной резервной копии.

!RadioButton Restore transaction log

Для восстановления базы данных будет использован журнал транзакций. SQL Server проверяет резервные копии журнала транзакций, чтобы гарантировать, что транзакции загружаются в нужную базу данных и в соответствующей последовательности.

!RadioButton Recovery only (without restoring)

Выберите эту опцию, если необходимо выполнить только восстановление базы данных.

!RadioButton Recovery from database snapshot

Восстановить базу данных из моментального снимка. В поле From snapshot укажите необходимый моментальный снимок.

<<Предыдущий шаг

Следующий шаг>>


Выбор базы данных

На этом шаге необходимо выбрать базу данных или указать имя новой.

Restore Database Wizard - Setting database

New or existing database name

В этом поле укажите имя базы, в которую будет восстановлена резервная копия. Вы можете выбрать из списка существующую базу или ввести имя новой.

!CheckBox Overwrite any existing database - перезаписать существующую базу данных.

Если на первом шаге была выбрана опция !RadioButton Restore transaction log, то на этом шаге Вам необходимо выбрать существующую базу данных, журнал транзакций которой Вы хотите восстановить.

Если на первом шаге была выбрана опция !RadioButton Recovery only (without restoring), то на этом шаге Вам необходимо выбрать одну из баз, которые находятся в состоянии Restoring, чтобы сделать ее данные доступными.

Если на первом шаге была выбрана опция !RadioButton Restore from database snapshot, то на этом шаге Вы можете просмотреть имя базы данных, которая будет восстановлена на основе выбранного снимка.


Указание момента времени для восстановления

На этом шаге необходимо указать момент времени, к которому будет восстановлена база данных.

Restore Database Wizard - Specifying point in time

!RadioButton Restore to the latest possible time - восстановить на самую позднюю дату.

!RadioButton Restore at time - восстановить к указанной дате. На следующем шаге можно будет выбрать только те резервные копии, дата создания которых не превосходит указанную дату.

При выполнении восстановления из журналов транзакций этот шаг примет следующий вид.

Restore Database Wizard - Specifying point in time -TransactionLogs

Для восстановления из журналов транзакций можно дополнительно указывать следующие параметры.

!RadioButton Restore at transaction mark

Восстановить к указанной метке транзакции.

!CheckBox Include marked transaction - включить транзакции с отметками.

Следующий шаг


Наборы резервных копий для восстановления

На этом шаге необходимо выбрать источник резервной копии. Этот шаг не активен при восстановлении из журналов транзакций.

Restore Database Wizard - Selecting backup set to restore

!RadioButton From database - восстановление будет производиться из выбранной базы данных.

!RadioButton From device (specify all devices of a media set) - в качестве источника выбирается устройство резервного копирования или набор устройств.

С помощью контекстного меню можно:

  • Add Device - добавить устройство резервного копирования;
  • Add Logical Device - добавить логическое устройство;
  • Add File - добавить файл;
  • Add Tape - добавить ленту;
  • Add Windows Azure URL (доступно только для серверов версии SQL Server 2014).
  • Remove Device - удалить устройство из списка;
  • Clear List - очистить список;
  • Device Contents - просмотреть содержимое устройства.

При добавлении Windows Azure URL появляется диалог, предназначенный для формирования URL-адреса, с которого будет восстанавливаться резервная копия базы данных.

Backup Database Wizard - Selecting backup devices - Azure URL Properties

Credential for Azure

Из выпадающего списка выберите учетную запись, которая будет использоваться для доступа к хранилищу Windows Azure. Чтобы создать новую учетную запись, нажмите кнопку AddJobCategory Add.

Storage container

Введите имя контейнера, в котором хранится резервная копия.

Blob name

Введите имя файла резервной копии базы данных.

Result URL

В этом поле будет отображаться сформированный URL для доступа к файлу резервной копии.

В нижней части окна отображается список копий, доступных в выбранном источнике и подробная информация по каждой копии.

Следующий шаг


Файлы и файловые группы

На этом шаге нужно выбрать файлы и группы файлов для восстановления базы данных. Этот шаг не отображается при восстановлении из журналов транзакций.

Restore Database Wizard - Selecting files and filegroups to restore

В списке отображаются все доступные файлы и файловые группы. В поле New File Name and Path можно задать новое имя файла, если Вы не хотите заменять существующий файл.

Если на первом шаге при выборе способа восстановления были выбраны !RadioButton Restore files or filegroups, то в списке для каждого файла появится флажок !CheckBox Restore.

Установите флажок !CheckBox Restore, чтобы добавить файл в список восстанавливаемых.

Следующий шаг


Задание параметров восстановления

На этом шаге задайте дополнительные параметры восстановления базы данных из резервной копии.

Restore Database Wizard - Setting restore options

Restore options

!CheckBox Confirmation before restoring each backup

Если этот флажок установлен, то программа требует подтверждения при каждом запуске процесса восстановления базы данных.

!CheckBox Restrict access for the database to db_owner, dbcreator or sysadmin

Установленный флажок Restrict Access for Database to dbo Only ограничивает доступ к вновь созданной базе данных для членов ролей db_owner, dbcreator и sysadmin.

!CheckBox Keep replication settings of the restored database

Этот параметр указывает, что настройки репликации сохраняются при восстановлении опубликованной базы данных на сервере, отличном от того, на котором она была создана. Это предотвращает удаление настроек репликации при восстановлении базы данных или журнала резервного копирования на резервном сервере.

Media checking options

!CheckBox Perform checksum verification before writing to media

Проверка контрольной суммы перед восстановлением с устройства резервного копирования

!CheckBox Continue on checksum errors

Если установлен этот флажок, то при возникновении ошибки в контрольной сумме, операция восстановления будет продолжена.

Следующий шаг


Параметры выполнения восстановления

На этом шаге задайте параметры восстановления базы данных.

Restore Database Wizard - Setting recovery options

!RadioButton Recovery

Восстановление (откат всех неподтвержденных транзакций). Настраивает операцию восстановления на откат любых незавершенных транзакций. После процедуры восстановления база данных готова к использованию.

!RadioButton No recovery

Без восстановления (оставить базу данных в режиме восстановления). Настраивает операцию восстановления на отмену отката любых незавершенных транзакций. Если впоследствии должен применяться другой журнал транзакций, то следует указать параметр No Recovery или Standby.

Важно: Если выбрана эта опция, база данных не может использоваться в этом промежуточном, не восстановленном состоянии.

При восстановлении из файла или файловой группы использование этой опции оставляет базу в состоянии восстановления после операции восстановления. Это полезно в одном из следующих случаев:

  • скрипт восстановления выполняется, и журнал применяется всегда;
  • последовательность файлов восстанавливается, и база данных не предназначена для использования между двумя операциями восстановления.

!RadioButton Standby

Режим ожидания (оставить в режиме ожидания и только для чтения). Следует также указать резервный файл, с помощью которого можно отменить результаты восстановления. Этот параметр разрешается применять для автономного восстановления (в том числе частичного восстановления). Параметр не разрешается использовать при оперативном восстановлении. При попытке указать параметр Standby для оперативного восстановления операция восстановления заканчивается неудачей. Инструкцию Standby также не разрешается применять, если необходимо обновление базы данных.

Standby file name

В этом поле указывается файл отката - резервный файл, местонахождение которого хранится в журнале базы данных. Если файл с таким именем существует, то он перезаписывается. В противном случае компонент Database Engine создает этот файл.

Следующий шаг


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Restore Database Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Restore Database Wizard - Executing restore database operation

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


Присоединение базы данных

С помощью Attach Database Wizard можно присоединить скопированную или отсоединенную базу данных SQL Server, состоящую из одного или нескольких фалов. В SQL Server полнотекстовые файлы, являющиеся частью базы данных, присоединяются вместе с базой данных.

Чтобы запустить этот инструмент, необходимо выбрать пункт Tools | AttachDatabase Attach Database... главного меню или нажать кнопку AttachDatabase Attach Database... на Панели инструментов.

Важно: Базу данных сначала необходимо отсоединить. Попытка присоединить базу данных, которая не была отсоединена, приведет к возникновению ошибки.

Список шагов:

Выбор сервера

Выбор базы данных для присоединения

Выполнение операции

Смотрите также:

Планы обслуживания

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Отсоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов

Сжатие базы данных


Выбор сервера

На этом шаге необходимо выбрать сервер, к которому будет присоединена база данных.

Attach Database Wizard - Selecting server

Server group

Из этого раскрывающегося списка выберите группу серверов, которой принадлежит нужный сервер.

Server name

Из этого раскрывающегося списка выберите нужный сервер.

Следующий шаг>>


Выбор базы данных для присоединения

На втором шаге укажите, какие файлы базы данных необходимо присоединить.

Attach Database Wizard - Defining database files

В список Databases с помощью пункта контекстного меню Add MDF file необходимо добавить основные файлы прикрепляемых баз данных.

Пункт Remove MDF File/Database в этом меню удаляет файл из списка.

В поле DB Name in File необходимо указать имя базы данных, которую подключаете. Из списка Database Owner выберите владельца этой базы данных.

Файл, выбранный в верхней таблице указывает на другие файлы базы данных (*.ndf и *.ldf), которые появляются в списке Selected database files.

Когда Вы выбираете файл с расширением *.mdf, SQL Administrator ищет остальные необходимые файлы в каталогах, указанных в этом файле, а затем автоматически добавляет их в список.

При выполнении операции присоединения все файлы данных (*.mdf и *.ndf) должны быть доступны. Если у какого-либо файла данных путь отличается от того, каким он был при первом создании или последнем присоединении, необходимо указать текущий путь к файлу с помощью кнопки OpenFile или пункта Add File... контекстного меню.

Пункт Remove File... удаляет файл из списка.

Важно: Каталоги с файлами могут быть отредактированы вручную. С помощью контекстного меню Вы можете выполнить стандартные операции редактирования.

<<Предыдущий шаг

Следующий шаг>>


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Attach Database Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Attach Database Wizard - Executing attach database task

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


Отсоединение базы данных

Отсоединение базы данных означает удаление ее с экземпляра SQL Server, но сама база данных остается неповрежденной со всеми своими файлами данных и журналов транзакций. Эти файлы затем можно использовать для присоединения базы данных к любому экземпляру SQL Server, включая сервер, от которого она была отсоединена.

Отсоединить базу Вы можете только, если нет действующих подключений к этой базе данных, и когда она не участвует в репликации.

Detach Database Wizard предназначен для отсоединения баз данных от сервера Microsoft® SQL Server™.

Чтобы запустить мастер, необходимо выбрать пункт Tools | DetachDatabase Detach Database в главном меню программы или нажать кнопку DetachDatabase Detach Database на панели инструментов программы.

Список шагов:

Выбор сервера

Выбор баз данных

Выполнение операции

Смотрите также:

Планы обслуживания

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Присоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов

Сжатие базы данных


Выбор сервера

На этом шаге необходимо указать сервер которому принадлежит отсоединяемая база данных.

Detach Database Wizard - Selecting server

Server group

Из этого раскрывающегося списка выберите группу серверов, которой принадлежит нужный сервер.

Server name

Из этого раскрывающегося списка выберите нужный сервер.

Следующий шаг>>


Выбор баз данных

В списке отображаются все базы данных, расположенные на выбранном сервере, и их состояние.

!CheckBox Detach - отсоединить базу данных.

Важно: Отсоединять можно только базу данных, к которой нет активных подключений.

!CheckBox Disconnect All connections - отключить все соединения. Выбор этой опции повлечет за собой откат всех активных транзакций.

!CheckBox Update Statistics - обновить статистику базы данных.

Detach Database Wizard - Selecting databases

<<Предыдущий шаг

Следующий шаг>>


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Detach Database Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Detach Database Wizard - Executing detach database task

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


Проверка баз данных

На вкладке проводника CheckDatabase Check Database расположены инструменты управления, предназначенные для работы с проверками баз данных.

Чтобы открыть эту вкладку, необходимо в проводнике выбрать Maintenance | CheckDatabase Check Database.

Database Maintenance - Check database

В верхней части для каждой базы данных отображается следующая информация:

Database Name - имя базы данных;

Has Check Entire DB Schedule - есть ли расписание полной проверки;

Last Success Date - дата последнего успешного выполнения проверки;

Check Entire DB Last Execution - дата последней полной проверки;

Check Entire DB Last Outcome - сообщение о результатах последней проверки;

Schedule Period during a Month - расписание на месяц. Представляет собой серую ось с точками, которые соответствуют шестичасовым интервалам, дням и неделям. Зеленые линии показывают запланированное время проверки.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Контекстное меню:

CreateMaintenancePlan Create Maintenance Plan - создать план обслуживания.

CheckDatabase Check database - проверить базу данных.

Edit Edit database - редактировать базу данных.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

При выборе базы данных из списка Database, в списке Check Database Maintenance Plan/Job отображаются планы обслуживания, содержащие операцию Check Database для этой базы.

По планам обслуживания отображается следующая информация:

Check Database Maintenance Plan/Job

План обслуживания или задание.

Name - имя плана обслуживания.

Enabled - включен ли этот план обслуживания.

Last Run Outcome - результат последнего запуска.

Last Run Date - дата последнего запуска.

Schedule

Расписание выбранного плана обслуживания.

Schedule Name - имя расписания.

Enabled - включено ли это расписание.

Task/Job Step

Шаги плана обслуживания или задания.

Name - имя шага.

Last Run Outcome - результат последнего запуска.

Last Run Duration - продолжительность последнего выполнения.

Last Run Message - сообщение, полученное при последнем выполнении.

Schedule

Расписание выбранного шага.

Чтобы открыть план обслуживания в соответствующем редакторе, необходимо выбрать пункт Edit Plans/Jobs в контекстном меню плана, или дважды щелкнуть на нем мышкой.

Смотрите также:

Планы обслуживания

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Присоединение базы данных

Отсоединение базы данных

Перестроение и реорганизация индексов

Сжатие базы данных


Мастер проверки баз данных

С помощью мастера проверки базы данных Check Database Wizard Вы можете проверять целостность выделения пространства, структурную и логическую целостность всех объектов в указанной базе данных. (Используется оператор Transact-SQL DBCC CHECKDB).

Чтобы запустить мастер, необходимо выбрать пункт Tools | CheckDatabase Check Database в главном меню программы или нажать кнопку CheckDatabase Check Database на панели инструментов программы.

Список шагов:

Выбор сервера и баз данных

Задание расписания

Выбор объектов проверки

Задание параметров восстановления

Задание параметров проверки

Выполнение операции


Выбор сервера и баз данных

На этом шаге необходимо выбрать сервер, содержащий базу данных для проверки, и саму базу данных.

Check Database Wizard - Selecting server and databases to check

Server group

Из этого раскрывающегося списка выберите группу серверов, которой принадлежит нужный сервер.

Server name

Из этого раскрывающегося списка выберите нужный сервер.

Databases

Базы данных, которые необходимо проверить, отметьте флажками.

Следующий шаг>>


Задание расписания

На этом шаге задайте параметры запуска проверки базы данных.

Check Database Wizard - Setting schedule options

!RadioButton Check database(s) now

Выполнить проверку сразу после задания всех необходимых параметров.

!RadioButton Create a job

Создать задание для регулярного выполнения операции.

В разделе Job properties необходимо указать параметры создаваемого задания.

Job name

Имя задания

Schedules

Список расписаний для создаваемого задания.

Управлять объектами этого списка можно с помощью кнопок, расположенных под ним.

Create - создать расписание.

Add Existing - добавить уже существующее.

Edit - изменить существующее расписание.

Remove - удалить расписание из списка.

Создавать и изменять расписания можно в Редакторе расписаний.

<<Предыдущий шаг

Следующий шаг>>


Выбор объектов проверки

На этом шаге выберите тип проверки, которая будет выполнена для каждой базы данных.

Check Database Wizard - Specifying checks to perform

!CheckBox Check the entire database

Установите этот флажок, чтобы выполнить проверку всей базы данных, включая проверку структуры индекса и целостности данных.

!CheckBox Check the allocation and structural integrity of a specified filegroup

Проверка распределения и структурной целостности отдельной файловой группы.

Filegroup. Из этого раскрывающегося списка выберите проверяемую файловую группу.

!CheckBox Check the consistency of disk space allocation structures

Выполнять проверку размещения и использования страниц.

!CheckBox Check the integrity of table/view pages and structures

Проверить одну таблицу, индексированное представление или отдельный индекс.

!CheckBox Check for the system catalog consistency

Выберите эту опцию, чтобы проверить согласованность между системными таблицами указанной базы данных и внутри самих таблиц.

!CheckBox Check the integrity of constraints

Выполнять проверку целостности указанных ограничений.

Если был выбран тип проверки !CheckBox Check the integrity of table/view pages and structures или !CheckBox Check the integrity of constraints то доступен шаг выбора таблиц.

<<Предыдущий шаг

Следующий шаг>>


Выбор таблиц для проверки

Этот шаг отображается, если в качестве объектов проверки был выбрана проверка !CheckBox Check the integrity of table/view pages and structures.

Check Database Wizard - Tables to check

Если установлен флажок !CheckBox Check all tables, то будут проверяться все таблицы.

С помощью кнопок перенесите проверяемые таблицы из списка доступных - Available Tables, в список выбранных - Selected Tables.

<<Предыдущий шаг

Следующий шаг>>


Задание параметров разрешения ошибок

На этом шаге необходимо задать настройки разрешения ошибок.

Check Database Wizard - Setting repair options

!RadioButton No repair data

Выбор этой опции равносилен указанию аргумента REPAIR_FAST. Этот аргумент используется только для обеспечения обратной совместимости. Действия по восстановлению не выполняются.

!RadioButton Repair without data loss

Выбор этой опции равносилен указанию аргумента REPAIR_REBUILD.

Выполняет действия по восстановлению данных, которые можно выполнить без риска их потери. Это может быть быстрое восстановление (например, восстановление отсутствующих строк в некластеризованных индексах) или более ресурсоемкие операции (например, перестроение индекса).

REPAIR_REBUILD не исправляет ошибки, связанные с данными FILESTREAM.

!RadioButton Repair with allowing of data loss

Выбор этой опции равносилен указанию аргумента REPAIR_ALLOW_DATA_LOSS.

Пытается устранить все обнаруженные ошибки. Эти исправления могут привести к частичной потере данных.

Note: Не рекомендуется для восстановления данных. Для этого лучше воспользоваться восстановлением базы данных из резервной копии.

<<Предыдущий шаг

Следующий шаг>>


Задание параметров проверки

На этом шаге можно задать дополнительные параметры выполнения проверки базы данных.

Check Database Wizard - Setting check options

Check parameters

!CheckBox No intensive checks of nonclustered indexes

Указывает, что не следует выполнять тщательную проверку некластеризованных индексов пользовательских таблиц. Это уменьшает общее время выполнения.

Важно: Эта опция отображается только в том случае, если на шаге Задание параметров разрешения ошибок была выбрана опция !RadioButton No repair data.

!CheckBox Extended index logical checks (intensive operation) (EXTENDED_LOGICAL_CHECKS)

Выполняются логические проверки в индексированных представлениях, XML-индексах и пространственных индексах (при их наличии). По умолчанию проверки физической целостности выполняются раньше, чем проверки логической целостности.

!CheckBox Allow take exclusive table locks to execute faster (TABLOCK)

Установка этого флажка приводит к получению инструкцией DBCC CHECKDB блокировок вместо использования внутреннего моментального снимка базы данных. Это включает краткосрочное использование монопольной блокировки (X) на базу данных. Аргумент TABLOCK позволит инструкции DBCC CHECKDB быстрее выполняться на базе данных, находящейся под интенсивной нагрузкой, однако уменьшит возможности одновременной работы пользователей с базой данных во время выполнения инструкции DBCC CHECKDB.

!CheckBox Check the integrity of physical structures only (PHYSICAL_ONLY)

Проводится проверка целостности физической структуры страниц и заголовков записей, а также целостности выделения пространства в базе данных. Эта проверка служит для выполнения проверки физической согласованности базы данных с низкими накладными расходами на выполнение. Она может обнаруживать обрывы страниц, ошибки контрольной суммы и типичные сбои оборудования, которые могут привести к повреждению пользовательских данных.

Важно: Эта опция отображается только в том случае, если на шаге Задание параметров разрешения ошибок была выбрана опция !RadioButton No repair data.

!CheckBox Check for valid or out-of-range column values (DATA_PURITY)

Указание значения аргумента приводит к выполнению инструкцией DBCC CHECKDB проверки базы данных на недействительность или выход из допустимого диапазона значений столбцов. Например, инструкция DBCC CHECKDB будет обнаруживать столбцы со значениями даты и времени, выходящими за допустимый диапазон значений типа данных datetime; или столбцы типа данных decimal или приблизительных числовых типов данных с недопустимыми значениями масштаба или точности.

Важно: Если указан аргумент PHYSICAL_ONLY, проверка целостности значений в столбцах не выполняется.

Check output options

!CheckBox Show all information messages

Отображается неограниченное количество текстовых сообщений.

!CheckBox Show only the first 200 errors

Если этот флажок установлен, то будут отображаться только первые 200 ошибок. По умолчанию выводятся все сообщения об ошибках.

<<Предыдущий шаг

Следующий шаг>>


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Check Database Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Check Database Wizard - Executing check database task

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


Перестроение и реорганизация индексов

На вкладке проводника RebuildIndexes Rebuild\Reorganise Indexes расположены инструменты управления, предназначенные для работы с перестройкой и реорганизацией индексов.

Чтобы открыть эту вкладку, необходимо в проводнике выбрать Maintenance | RebuildIndexes Rebuild\Reorganize Indexes.

Database Maintenance - Rebuild_Reorganize Indexes

В верхней части окна отображается список баз данных со следующими столбцами:

Database Name - имя базы данных;

Has Reindex Schedule - есть ли расписание операции реорганизации индексов;

Reindex Last Execution - дата последней реорганизации индексов;

Reindex Last Outcome - сообщение о результатах последней реорганизации;

Schedule Period during a Month - расписание на месяц. Представляет собой серую ось с точками, которые соответствуют шестичасовым интервалам, дням и неделям. Зеленые линии показывают запланированное время реорганизации.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Контекстное меню:

CreateMaintenancePlan Create Maintenance Plan - создать план обслуживания.

RebuildIndexes Rebuild\Reorganize Indexes - выполнить перестройку и реорганизацию индексов

Edit Edit database - редактировать базу данных.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

При выборе базы данных из списка Database в списке Reindex/Reorganize Indexes Maintenance Plan/Job отображаются планы обслуживания, содержащие операцию Reindex/Reorganize Indexes для этой базы.

По планам обслуживания отображается следующая информация:

Reindex/Reorganize Indexes Maintenance Plan/Job

План обслуживания или задание.

Name - имя плана обслуживания.

Enabled - включен ли этот план обслуживания.

Last Run Outcome - результат последнего запуска.

Last Run Date - дата последнего запуска.

Schedule

Расписание выбранного плана обслуживания.

Schedule Name - имя расписания.

Enabled - включено ли это расписание.

Task/Job Step

Шаги плана обслуживания или задания.

Name - имя шага.

Last Run Outcome - результат последнего запуска.

Last Run Duration - продолжительность последнего выполнения.

Last Run Message - сообщение, полученное при последнем выполнении.

Schedule

Расписание выбранного шага.

Чтобы открыть план обслуживания в соответствующем редакторе, необходимо выбрать пункт Edit Plans/Jobs в контекстном меню плана, или дважды щелкнуть на нем мышкой.

Смотрите также:

Планы обслуживания

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Присоединение базы данных

Отсоединение базы данных

Проверка баз данных

Сжатие базы данных


Мастер перестройки и реорганизации индексов

С помощью мастера Rebuild/Reorganize Indexes Wizard можно выполнять операции по управлению индексами: реорганизация, перестроение, отключение. (Используется оператор Transact-SQL ALTER INDEX REORGANIZE ... REBUILD ... DISABLE).

Если логическое упорядочивание страниц индексов выполняется на основе значения ключа, а не на физическом расположении внутри файла данных, то такие индексы называются фрагментированными. Фрагментированные индексы могут значительно снизить производительность запросов. Фрагментация индексов устраняется путем реорганизации или перестроения индекса.

Чтобы запустить мастер, необходимо выбрать пункт Tools | RebuildIndexes Rebuild/Reorganize Indexes в главном меню программы или нажать кнопку RebuildIndexes Rebuild/Reorganize Indexes на панели инструментов программы.

Список шагов:

Выбор серверов и баз данных

Задание расписания

Задание условий перестроения и реорганизации индексов

Задание параметров выполнения операции

Выполнение операции


Выбор серверов и баз данных

На этом шаге необходимо выбрать сервер, содержащий базу данных для выполнения операции, и саму базу данных.

Rebuild_Reorganize Indexes Wizard - Selecting server and databases

Server group

Из этого раскрывающегося списка выберите группу серверов, которой принадлежит нужный сервер.

Server name

Из этого раскрывающегося списка выберите нужный сервер.

Databases

Базы данных, в которых необходимо провести перестройку индексов, отметьте флажками.

Следующий шаг>>


Задание расписания

На этом шаге задайте параметры запуска перестроения и реорганизации индексов.

Rebuild_Reorganize Indexes Wizard - Setting schedule options

!RadioButton Reindex now

Выполнить реиндексацию сразу после задания всех необходимых параметров.

!RadioButton Create a job

Создать задание для регулярного выполнения операции.

В разделе Job properties необходимо указать параметры создаваемого задания.

Job name

Имя задания

Schedules

Список расписаний для создаваемого задания.

Управлять объектами этого списка можно с помощью кнопок, расположенных под ним.

Create - создать расписание.

Add Existing - добавить уже существующее.

Edit - изменить существующее расписание.

Remove - удалить расписание из списка.

Создавать и изменять расписания можно в Редакторе расписаний.

<<Предыдущий шаг

Следующий шаг>>


Задание условий перестроения и реорганизации индексов

На этом шаге необходимо указать настройки фрагментации для реорганизации и перестройки индексов.

Если на шаге Задание расписания была выбрана опция !RadioButton Reindex now, то этот шаг примет следующий вид.

Rebuild_Reorganize Indexes Wizard - Setting reindex action condition

В поле Fragmentation указан существующий коэффициент заполнения.

!CheckBox Rebuild index if fragmentation more or equal to

Значение фрагментации для запуска перестроения индекса.

!CheckBox Reorganise index if fragmentation more or equal to

Значение фрагментации для запуска реорганизации индекса.

Если на шаге Задание расписания была выбрана опция !RadioButton Create a job, то этот шаг примет следующий вид.

Rebuild_Reorganize Indexes Wizard - Setting reindex action condition job

В соответствующих полях определите значения фрагментации, при достижении которых необходимо произвести операции перестроения и реорганизации индексов.

!CheckBox Sort in tempdb

Определяет место хранения промежуточных результатов сортировки, формируемых во время создания индекса. Если флажок установлен, то результаты сортировки хранятся в базе данных tempdb. В противном случае, результаты сортировки хранятся в схеме секционирования или файловой группе, в которой хранится результирующий индекс.

Max degree of parallelism

Установите максимальное число процессоров, которые могут быть использованы обработчиком запросов для выполнения одной инструкции индекса.

!CheckBox LOB compaction

Отметьте эту опцию, чтобы сжимать все страницы, содержащие данные большого объекта (LOB).Типы данных LOB: image, text, ntext, varchar(max), nvarchar(max), varbinary(max) и xml. Сжатие этих данных может освободить место на диске.

<<Предыдущий шаг

Следующий шаг>>


Задание параметров выполнения операции

На этом шаге задаются настройки выполнения реорганизации и перестроения индексов.

Rebuild_Reorganize Indexes Wizard - Setting index actions and options

В нижней части приведен список параметров, которые могут быть определены для выбранного действия.

!RadioButton Rebuild - индекс будет перестроен с использованием тех же столбцов, типов индекса, атрибута уникальности и порядка сортировки.

!CheckBox Pad index - устанавливает процентную долю свободного пространства в страницах промежуточного уровня во время создания индекса.

!CheckBox Statistics norecompute - указывает, пересчитана ли статистика распределения.

!CheckBox Allow row locks - указывает, разрешена ли блокировка строк.

!CheckBox Allow page locks - указывает, разрешена ли блокировка страниц.

!CheckBox Ignore duplicate keys - определяет ответ на ошибку, случающуюся, когда операция вставки пытается вставить в уникальный индекс повторяющиеся значения ключа.

!CheckBox Sort in tempdb - указывает, следует ли сохранять результаты сортировки в базе данных tempdb.

!CheckBox As online operation - определяет, будут ли базовые таблицы и связанные индексы доступны для запросов и изменения данных во время операций с индексами.

Fillfactor - указывает значение в процентах, показывающее, насколько полным компонент Database Engine должен сделать конечный уровень каждой индексной страницы во время создания или изменения индекса.

Max DOP - устанавливает максимальное число процессоров, которые могут быть использованы обработчиком запросов для выполнения одной инструкции индекса.

!RadioButton Reorganise - конечный уровень индекса будет реорганизован.

!CheckBox LOB compaction - указывает, что конечный уровень индекса будет реорганизован.

<<Предыдущий шаг

Следующий шаг>>


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Rebuild_Reorganize Indexes Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Rebuild_Reorganize Indexes Wizard - Executing task

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


Сжатие базы данных

Сжатие базы данных позволяет сократить размер файлов данных и файлов журнала в заданной базе данных.

Сжать базу Вы можете только, если нет действующих подключений к этой базе данных, и она не участвует в репликации.

Shrink Database Wizard предназначен для сжатия базы данных.

Чтобы запустить мастер, необходимо выбрать пункт Tools | [image] Shrink Database в главном меню программы или нажать кнопку [image] Shrink Database на панели инструментов программы.

Список шагов:

Выбор сервера и баз данных

Выбор типа сжатия

Задание параметров сжатия базы данных

Задание параметров сжатия файлов

Задание расписания

Выполнение операции

Смотрите также:

Планы обслуживания

Резервное копирование баз данных

Восстановление баз данных из резервной копии

Присоединение базы данных

Отсоединение базы данных

Проверка баз данных

Перестроение и реорганизация индексов


Выбор сервера и баз данных

На этом шаге необходимо выбрать сервер, содержащий базу данных для выполнения операции, и саму базу данных.

Shrink Database Wizard - Selecting server and databases

Server group

Из этого раскрывающегося списка выберите группу серверов, которой принадлежит нужный сервер.

Server name

Из этого раскрывающегося списка выберите нужный сервер.

Databases

Базы данных, которые необходимо сжать, отметьте флажками.

Следующий шаг при выборе одной базы данных.

Следующий шаг при выборе нескольких баз данных.


Выбор типа сжатия

На этом шаге необходимо выбрать объекты, подлежащие сжатию. Этот шаг доступен только в случае, если на первом шаге Вы выбрали одну базу данных.

Shrink Database Wizard - Setting shrink type

С помощью переключателя Select shrink type укажите, что именно должно быть сжато.

!RadioButton Shrink the entire database - сжать всю базу данных.

!RadioButton Shrink database files - сжать только некоторые отдельные файлы.

Следующий шаг при сжатии всей базы

Следующий шаг при сжатии отдельных файлов.


Задание параметров сжатия базы данных

На этом шаге Мастера Вы можете просмотреть объем распределенного и свободного места.

Этот шаг появляется, если на втором шаге была выбрана опция !RadioButton Shrink entire database.

Если Вы производите сжатие одной базы, то этот шаг выглядит следующим образом.

Shrink Database Wizard - Specifying shrink database options

Здесь представлена информация о текущем объеме распределенного места и (currently allocated space) и доступного места (available free space) в сжимаемой базе данных.

!CheckBox Reorganize data files by moving free space to the end of files - сжатие файлов данных освобождает место за счет перемещения страниц данных из конца файла на пустое место ближе к началу файла.

Важно: Данные, перемещаемые в результате сжатия файла, могут быть разбросаны по любым его фрагментам. Это приводит к фрагментации индекса и может снизить производительность обработки запросов, которые производят поиск в диапазоне индекса. Для предотвращения фрагментации после сжатия необходимо перестроить индексы в файле.

Percentage of free space after shrinking

Введите максимальный процент свободного пространства, которое должно остаться в базе данных после ее сжатия.

Если на первом шаге вы выбрали несколько баз данных, тогда этот шаг выглядит следующим образом.

Shrink Database Wizard - Specifying shrink options for several databases

В таблице приведена информация о распределенном (allocated) и свободном (free) месте для каждой выбранной базы данных.

!CheckBox Move Free Space to End of File - перемещать свободное место в конец файла.

Free Space after Shrinking - максимальный процент свободного пространства, которое должно остаться в базе данных после ее сжатия.

Следующий шаг>>


Задание параметров сжатия файлов

На этом шаге мастера показывается информация о распределенном и занимаемом месте файлами базы данных. Здесь же вы можете задать, каким образом следует осуществить сжатие каждого файла.

Этот шаг появляется только в случае, если на втором шаге выбрана опция !RadioButton Shrink database files.

Shrink Database Wizard - Specifying shrink file options

В таблице приведена следующая информация о файлах базы данных:

File Name - имя файла;

Allocated Space, MB - распределенное место;

Used Space, MB - занимаемое место;

Size after shrinking - размер файла после сжатия.

В столбце Operation укажите, как произвести сжатие:

  • Move free space to the end of the file and truncate

Перемещает распределенные страницы из конца файла на место нераспределенных страниц в начале файла.

  • Truncate free space at the end of the file only

Освобождает все свободное пространство в конце файла операционной системы, но не перемещает страницы внутри файла.

  • Empty the file by moving data to the other file

Выполняет миграцию всех данных из указанного файла в другие файлы в той же файловой группе.

<<Предыдущий шаг

Следующий шаг>>


Задание расписания

На этом шаге задайте параметры запуска сжатия базы данных.

Shrink Database Wizard - Setting schedule options

!CheckBox Shrink database(s) now

Выполнить сжатие базы данных сразу после задания всех необходимых параметров.

!CheckBox Create a job

Создать задание для регулярного выполнения операции.

В разделе Job properties необходимо указать параметры создаваемого задания.

Job name

Имя задания

Schedules

Список расписаний для создаваемого задания.

Управлять объектами этого списка можно с помощью кнопок, расположенных под ним.

Create - создать расписание.

Add Existing - добавить уже существующее.

Edit - изменить существующее расписание.

Remove - удалить расписание из списка.

Создавать и изменять расписания можно в Редакторе расписаний.

<<Предыдущий шаг

Следующий шаг>>


Просмотр сводной информации

На этом шаге отображаются значения параметров, заданные на предыдущих шагах.

Для начала выполнения операции нажмите кнопку Execute.

Shrink Database Wizard - Viewing summary information

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

<<Предыдущий шаг

Следующий шаг>>


Выполнение операции

На последнем шаге сообщается о ходе выполнения операции.

Ошибки, возникшие в процессе выполнения задачи, выводятся в окно лога.

Shrink Database Wizard - Executing shrink database task

С помощью контекстного меню окна лога Вы можете очистить окно лога, выделить весь текст и скопировать выделенный текст.

<<Предыдущий шаг


Управление объектами базы данных

SQL Administrator предоставляет пользователю набор всех необходимых инструментов для работы с объектами базы данных.

Важно: Перед тем как начать работу с базой данных и объектами в SQL Administrator необходимо зарегистрировать его в Проводнике баз данных.

После подключения к серверу в Проводнике баз данных разворачивается список баз данных.

При выборе базы данных в проводнике информация о ней отображается на рабочей области.

С помощью кнопок на ленте Вы можете:

  • открыть редактор базы данных
  • выполнить основные задачи обслуживания базы данных
  • управлять объектами базы данных (создавать, редактировать и удалять)

На рабочей области раздела базы данных располагается следующая информация:

General

В этом разделе отображается основная информация о базе данных:

Owner - владелец базы данных

Recovery Model - модель восстановления

Collation - параметры сортировки

Compatibility Level - уровень совместимости

State - состояние

Read-only - является ли база данных доступной только для чтения

User Access - пользовательский доступ

Guest Account - активна ли учетная запись пользователя 'guest'

Creation Date - дата создания базы данных.

Options

В этом разделе показываются значения некоторых параметров базы данных.

Maintenance

Здесь отображается информация о задачах обслуживания базы данных. Для задачи резервного копирования (полного, инкрементного и журнального) доступна следующая информация:

  • Date - дата выполнения резервного копирования
  • Backup name - имя резервной копии
  • Time taken - время, затраченное на выполнение операции
  • Devices - устройства резервной копии.

Также в данном разделе отображается дата последней успешной проверки базы данных и наиболее фрагментированные индексы, для которых необходимо выполнить операцию перестроения индексов.

Size

В этом разделе показаны диаграммы использования файлами базы данных дискового пространства. На этой диаграмме отображается, сколько места занимают данные (Row data) и индексы (Indexes); нераспределенное (Unallocated) и неиспользуемое (Unused) пространство данных; занятое и свободное пространство журналов.

Files

В этом списке отображаются файлы базы данных и информация о них:

  • Name - имя файла;
  • Type - тип файла;
  • State - состояние файла;
  • OS File Name - путь к файлу на сервере;
  • Filegroup - файловая группа;
  • Size, MB - размер файла;
  • Max. Size, MB - максимальный размер файла,
  • Growth - параметры прироста файла,
  • Read Latency, ms - задержка при чтении файла,
  • Write Latency, ms - задержка при записи в файл.

Чтобы развернуть список объектов базы данных, кликните два раза по базе данных в дереве, а затем выберите требуемую группу объектов.


Таблицы

На вкладке Tables проводника баз данных можно просматривать, создавать, редактировать и удалять таблицы.

Контекстное меню

Create Create Table ('Insert') - создать таблицу.

Edit Edit Table ('Enter') - редактировать таблицу.

Drop Drop Table ('Delete') - удалить таблицу.

  • Rename - переименовать таблицу.
  • Select Top 1000 Rows From - выполнить запрос для выборки первых 1000 записей в таблице.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список таблиц отображается в виде таблицы со следующими столбцами:

Schema - имя схемы, которой принадлежит таблица;

Name - имя таблицы;

Data Space - пространство данных;

Partition Column - столбец, по которому секционирована таблица;

Number of Partitions - количество секций;

LOB Data Space - пространство данных для объектов LOB;

Replicated - реплицирована ли таблица в другую базу данных;

Filetable - является ли таблица Filetable;

Memory-optimized - является ли таблица оптимизированной для памяти;

Durability - указано значение свойства Durability для таблиц оптимизированных для памяти;

Change Tracking - разрешено ли отслеживание изменений;

Description - описание таблицы.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор таблиц

Редактор таблиц - основной инструмент SQL Administrator для работы с таблицами баз данных. Он позволяет выполнять все операции с таблицей, а также с ее подобъектами.

Чтобы открыть объект в редакторе необходимо на вкладке Tables дважды щелкнуть на нужной таблице мышкой. Также для создания и редактирования таблиц можно использовать пункты контекстного меню Create Table и Edit Table соответственно.

С помощью редактора таблиц Вы можете создавать, редактировать и удалять поля, индексы, внешние ключи и другие подобъекты таблицы, а также просматривать и редактировать параметры таблицы.

Вкладки редактора:

  • Панели инструментов
  • Поля
  • Свойства таблицы
  • Опции таблицы FileTable
  • Ограничения CHECK
  • Индексы и первичные/уникальные ключи
  • Статистики
  • Внешние ключи
  • Триггеры
  • Сведения о таблице
  • Описание
  • Разрешения
  • SQL описание


Панели инструментов

На панели инструментов редактора таблиц отображаются инструменты, наиболее часто используемые для работы с объектом.

Table Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Поля

На вкладке Fields можно задать поля и основные параметры таблицы.

Name

Введите имя таблицы. Имя таблицы должно соответствовать правилам для идентификаторов, быть уникальным в рамках схемы и может состоять не более чем из 128 символов.

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать таблица. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

Table Editor - Fields

Table type

Выберите тип таблицы.

!RadioButton Table

Выберите эту опцию, чтобы создать обычную таблицу SQL Server.

!RadioButton Filetable

Установите эту опцию, чтобы разрешить хранение файлов и каталогов в базе данных. Таблицы FileTable являются специализированными пользовательскими таблицами с предварительно определенной схемой для хранения данных FILESTREAM, а также сведений об иерархии файлов и каталогов и атрибутах файлов.

При выборе этой опции необходимо задать параметры таблицы FileTable на вкладке Filetable options.

!RadioButton Memory-optimized table

Установите этот флажок, чтобы создать таблицу, оптимизированную для памяти.

Оптимизированная для памяти таблица - это существующая в памяти пользовательская таблица, схема которой, подобно другим таблицам, хранится на диске.

При создании таблицы, оптимизированной для памяти, необходимо создать индексы.

!RadioButton Schema and data are persisted

Выберите эту опцию, чтобы создать надежную таблицу, оптимизированную для памяти. Этот параметр обеспечивает устойчивость как схем, так и данных.

!RadioButton Only schema is persisted

Эта опция обеспечивает надежность схемы таблицы, в том числе индексов. Транзакции на этих таблицах не требуют каких-либо дисковых операций ввода-вывода, но их данные не будут восстановлены при сбое или отработке отказа сервера.

Fields

В списке Fields отображаются следующие свойства полей:

Name - имя поля;

Data Type - тип данных;

Not Null - допускается ли пустое значение;

Identity - является ли поле идентификатором;

Default Value - значение поля по умолчанию;

Description - описание поля.

Двойной щелчок откроет выбранное поле в редакторе полей - Field Editor.

Правой кнопкой можно вызвать контекстное меню списка Fields, с помощью которого можно добавить, редактировать, удалить или изменить порядок полей.


Свойства таблицы

На вкладке Properties задаются свойства создаваемой таблицы.

Table Editor - Properties

Storage

Data space

Из выпадающего списка выберите пространство данных - схему секционирования или файловую группу, в которой хранится таблица.

Partition column

Это поле доступно, если в качестве пространства данных была выбрана схема секционирования. Выберите поле, по которому будет секционирована таблица;

Text/image file group

Из выпадающего списка выберите группу файлов для данных типа TEXT и IMAGE.

Filestream data space

Из выпадающего списка выберите пространство данных файлового потока. Эта опция доступна для SQL Server 2008 и выше.

!CheckBox Store varchar(max), nvarchar(max), varbinary(max) and xml fields in data rows

Значения varchar(max), nvarchar(max), varbinary(max), xml, а также большие значения определяемых пользователем типов хранятся непосредственно в строке данных с ограничением в 8 000 байт до тех пор, пока значение помещается в записи. Если значение не умещается в записи, то указатель хранится в строке, а все остальное хранится вне строки в области хранения объектов LOB.

!CheckBox Store text, ntext, image values in data rows

Если отмечена эта опция, то новые строки типа text, ntext или image сохраняются непосредственно в строке данных. Все существующие BLOB (большие двоичные объекты: типы данных text, ntext или image) при обновлении значения BLOB будут преобразованы в формат text in row.

Значение value length limit (ограничение длины) по умолчанию равно 256 байт. Вы можете задать это значение вручную в пределах от 24 до 7000 байт.

В разделе Compression by partitions задайте параметры сжатия таблицы.

В столбце Filegroup отображается файловая группа таблицы.

В поле Compression выберите тип сжатия:

  • None - без сжатия,
  • Rows - построчное,
  • Page - постраничное.

Options

!CheckBox Lock table on bulk load

Если отключено (по умолчанию), то процесс массовой загрузки в пользовательских таблицах получает блокировку строк. Если включено, то процесс массовой загрузки в пользовательских таблицах получает блокировку массовых обновлений.


Опции таблицы FileTable

На вкладке FileTable задайте настройки для создаваемой таблицы FileTable.

Table Editor - Filetable options

Directory name

Укажите имя каталога таблицы FileTable, совместимое с Windows. Это имя должно быть уникальным среди всех имен каталогов FileTable в базе данных. Если это значение не задано, то используется имя таблицы FileTable.

File name column collation

Выберите имя параметров сортировки, применяемых к столбцу Name в таблице FileTable. Если это значение не задано, то используются параметры сортировки по умолчанию базы данных.

!CheckBox FileTable namespace is enabled

При отключении этой опции отключаются все системные ограничения и триггеры, которые были созданы с таблицей FileTable.


Ограничения CHECK

На вкладке Checks Вы можете создавать, просматривать и редактировать ограничения CHECK, то есть устанавливать ограничения на значения в поле.

С помощью контекстного меню можно создать новое, редактировать или удалить существующее ограничение, а также включить/отключить все ограничения.

Table Editor - Check constraints

В списке Check constraints отображаются следующие свойства ограничений:

Name - имя ограничения;

Condition - условие;

Enabled - включено ли ограничение;

Description - описание.

По двойному щелчку мыши ограничение открывается в редакторе ограничений CHECK.


Индексы и первичные/уникальные ключи

На вкладке Indexes and primary/unique keys Вы можете создавать, просматривать и редактировать индексы таблицы.

С помощью контекстного меню можно создать новый, редактировать или удалить существующий индекс, а также включить/отключить все индексы.

Table Editor - Indexes

В списке Indexes and primary/unique keys отображаются следующие свойства индексов:

Name - имя индекса;

Index Type - тип индекса;

Columns - поля, на которых основан индекс;

Included Columns - неключевые столбцы, добавляемые на конечный уровень некластеризованного индекса;

Clustered - является ли индекс кластеризованным;

Enabled - активен ли индекс;

Description - описание индекса.

По двойному щелчку мыши индекс открывается в редакторе индексов.


Статистики

На вкладке Statistics Вы можете создавать, просматривать и редактировать статистики таблицы.

С помощью контекстного меню можно создать новую, редактировать или удалить существующую статистику, а также выполнить операцию Update Statistics.

Table Editor - Statistics

В списке Statistics отображаются следующие свойства статистики:

Name - имя статистики;

System - является ли статистика системной;

Columns - поля, на основе которых создана статистика;

No Auto Recompute - отключен ли параметр автоматического обновления статистики;

Filter - предикат фильтра статистики.

По двойному щелчку мыши статистика открывается в редакторе статистик.


Внешние ключи

На этой вкладке Вы можете создавать и редактировать внешние ключи таблицы.

С помощью контекстного меню можно создать новый, редактировать или удалить существующий внешний ключ, а также включить/отключить все внешние ключи.

Table Editor - Foreign keys

В списке Foreign keys отображаются следующие свойства внешних ключей:

Name - имя внешнего ключа;

Columns - столбцы, на основе которых создан внешний ключ;

PK Table - таблица, на которую ссылается внешний ключ;

PK Table Columns - поля внешней таблицы;

Enabled - активен ли внешний ключ;

Description - описание внешнего ключа.

По двойному щелчку мыши внешний ключ открывается в редакторе внешних ключей.


Триггеры

На этой вкладке Вы можете создавать и редактировать триггеры.

С помощью контекстного меню можно создать новый, редактировать или удалить существующий триггер, а также включить/отключить все триггеры.

Table Editor - Triggers

В списке Triggers отображаются следующие свойства триггеров:

Name - имя триггера;

Type - тип триггера;

Insert - срабатывает ли триггер на вставку;

Update - срабатывает ли триггер на обновление;

Delete - срабатывает ли триггер на удаление;

Enabled - активен ли триггер;

Description - описание триггера.

По двойному щелчку мыши триггер открывается в редакторе триггеров.


Сведения о таблице

На вкладке Information отображается информация о редактируемой таблице:

General

Creation Date - дата создания,

Modification Date - дата последнего редактирования,

ANSI Nulls on Creation (On/Off) - будут использоваться значения NULL по стандарту ANSI,

Quoted Identifier on Creation (On/Off) - заключались ли в кавычки идентификаторы при создании,

Owner - владелец таблицы,

System (Yes/No) - является ли таблица системной,

Change Tracking (Yes/No) - разрешено ли отслеживание изменений,

Change Data Capture (Yes/No) - включена ли система отслеживания измененных данных,

Replicated (Yes/No) - реплицирована ли таблица в другую базу данных,

ID - идентификатор таблицы.

Data

Number of Rows - количество строк в таблице,

Total Reserved Space, MB - общий размер зарезервированного места (МБ),

Used by Rows, MB - объем места, занимаемого строками данных (МБ),

Used by Indexes, MB - объем места, занимаемого индексами (МБ).

Table Editor - Information


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к таблице, то Вы можете его создать (изменить) на вкладке Description.

Table Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующей таблицы.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Table Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для управления разрешениями на уровне столбца и для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL таблицы.

Table Editor - SQL Definition


Редактор полей

Редактор Field Editor позволяет изменять свойства полей таблицы базы данных при создании или редактировании поля.

Чтобы открыть поле в редакторе, дважды щелкните по нему в списке полей или выберите пункт Edit Field... в контекстном меню на вкладке Fields в Редакторе таблиц.

Вкладки:

  • Свойства
  • Значение по умолчанию
  • Параметры XML полей
  • Описание
  • SQL описание


Свойства

На вкладке Properties задайте основные параметры поля.

Field Editor - Properties

Name

Задайте имя поля.

Table

В этом поле отображается имя таблицы, которой принадлежит редактируемое поле.

!CheckBox Computed

Отметьте эту опцию, чтобы создать вычисляемое поле и задать выражение, которое будет вычислять его значение.

!CheckBox Store computed value in table

Если установлен этот флажок, то вычисляемое значение будет храниться в таблице.

Expression

В этом поле задайте формулу, по которой будет вычисляться значение в создаваемом поле.

Выражение может содержать невычисляемые поля, константы, функции и переменные, связанные одним и более операторами. Выражение не может быть подзапросом или включать в себя пользовательские типы данных.

Data type

Выберите тип данных, на основе которого необходимо создать поле - системный тип SQL Server или пользовательский тип.

Type

Выберите тип поля из выпадающего списка, содержащего стандартные типы данных SQL Server или пользовательские типы данных.

Length/precision

Задайте размер поля. Если установлен флажок !CheckBox Maximum size, то значение размера поля будет максимально возможным для SQL Server.

Scale

Для типов decimal или numeric это число указывает максимальное общее число подлежащих сохранению десятичных знаков справа от разделителя, отделяющего десятичную дробь от целого числа. Его значение должно быть меньшим или равным заданного значения Length/precision.

Collation

Из выпадающего списка выберите правило сравнения символьных данных. Эти правила задают кодовую страницу и порядок сопоставления символьных данных для работы с данными в Юникоде и других форматах.

Identity

!CheckBox Is identity

Эта опция определяет, является ли поле идентификатором. Столбцы идентификаторов обычно используются с ограничением PRIMARY KEY для поддержания уникальности идентификаторов строк в таблице.

Seed

Задайте начальное значение счетчика, которое будет первым вставлено в таблицу.

Increment

Задайте значение приращения, добавляемое к значению идентификатора предыдущей загруженной строки.

!CheckBox Not for replication

Если отмечена эта опция, то значения в столбцах идентификаторов не приращиваются, если вставку выполняют агенты репликации.

Options

!CheckBox Not NULL

Эта опция определяет, допустимы ли для столбца значения NULL. Если этот флажок установлен, то значения поля не могут пустыми.

!CheckBox Primary key

Отметьте эту опцию, чтобы сделать редактируемое поле первичным ключом.

!CheckBox Row GUID

Эта опция указывает, будет ли SQL Server использовать столбец в качестве глобального уникального идентификатора (ROWGUID). Это свойство может быть установлено только для столбцов с типом данных uniqueidentifier.

!CheckBox Filestream

Установите этот флажок, если хотите хранить данные этого поля в файловой группе файлового потока.

Этот флажок доступен, если для таблицы указана какая-либо файловая группа файлового потока.

!CheckBox Sparse

Установите этот флажок, если хотите сделать это поле разреженным. Разреженным является столбец, в котором большая часть значений нулевые.


Значение по умолчанию

На вкладке Default value можно задать значение по умолчанию, которое будет введено в столбец, если пользователь оставит его пустым. Значение по умолчанию может быть любым выражением, результат которого — константа, например, константой, встроенной функцией или математическим выражением. Каждый столбец может содержать только одно значение по умолчанию.

Field Editor - Default value

Если в базе данных созданы объекты с именем по умолчанию, то их можно использовать как значение по умолчанию для поля. Для того чтобы их использовать, необходимо установить переключатель в положение Default Object и из раскрывающегося списка выбрать объект.


Параметры XML полей

Параметры на вкладке XML активны только тогда, когда тип поля установлен как xml, или определенный пользователем тип базируется на типе XML.

Field Editor - XML options

XML schema collection

Из раскрывающегося списка выберите коллекцию XML схем.

!RadioButton Allows multiple top-level elements (CONTENT)

Указывает, что каждый экземпляр типа данных xml в столбце может содержать несколько элементов верхнего уровня.

!RadioButton Allows only one top-level element (DOCUMENT)

Указывает, что каждый экземпляр типа данных xml в столбце может содержать только один элемент верхнего уровня.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к полю, то Вы можете его создать (изменить) на вкладке Description.

Field Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL поля.

Field Editor - SQL Definition


Редактор ограничений CHECK

Ограничения CHECK устанавливают, какие значения данных допустимы в столбце. Одно ограничение CHECK может затрагивать несколько столбцов, а к отдельному столбцу может применяться несколько проверочных ограничений. При удалении таблицы также удаляются проверочные ограничения. Проверочные ограничения обеспечивают доменную целостность, ограничивая значения, которые может принимать столбец.

Ограничения CHECK можно создавать как часть определения таблицы при ее создании. Если таблица уже существует, можно добавить ограничение CHECK. Таблицы и столбцы могут содержать несколько ограничений CHECK.

Редактор Check Constraint Editor позволяет изменять свойства ограничений таблицы базы данных при создании или редактировании ограничения.

Чтобы открыть ограничение в редакторе, дважды щелкните по нему в списке ограничений CHECK или выберите пункт Edit Check Constraint... в контекстном меню на вкладке Check constraints в Редакторе таблиц.

Вкладки:

  • Свойства
  • Описание
  • SQL описание


Свойства

На вкладке Properties задайте основные параметры ограничения CHECK.

Check Editor - Properties

Name

Задайте имя для нового ограничения или отредактируйте имя существующего.

Table

В этом поле отображается имя таблицы, которой принадлежит редактируемое ограничение.

!CheckBox Enabled

Если этот флажок установлен, то ограничение включено.

!CheckBox Check existing data

Проверка уже внесенных в таблицу данных на соответствие новому ограничению осуществляется в том случае, если этот флажок установлен.

Condition

Задайте логическое выражение, возвращающее значения TRUE или FALSE, которое будет служить ограничением на поле.

Например, salary >= 15000 AND salary <= 100000.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к ограничению, то Вы можете его создать (изменить) на вкладке Description.

Check Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL ограничения.

Check Editor - SQL Definition


Редактор индексов

Индекс - это объект реляционной базы данных, обеспечивающий быстрый доступ к данным в строках таблицы на основе значений ключа. Индексы также обеспечивают уникальность строк таблицы. SQL Server поддерживает кластеризованные и некластеризованные индексы. Первичный ключ таблицы автоматически индексируется.

Редактор Index Editor позволяет изменять свойства индексов таблицы базы данных при создании или редактировании индекса.

Чтобы открыть индекс в редакторе, дважды щелкните по нему в списке индексов или выберите пункт Edit Index... в контекстном меню на вкладке Indexes and primary/unique keys в Редакторе таблиц.

Вкладки:

  • Свойства
  • Хранение
  • Фильтр
  • Параметры XML индекса
  • Параметры пространственного индекса
  • Описание
  • SQL описание


Свойства

На вкладке Properties задайте основные параметры индекса.

Name

Задайте имя для нового индекса или отредактируйте имя существующего.

Index Editor - Properties

Table

В этом поле отображается имя таблицы, которой принадлежит редактируемый индекс.

!CheckBox Enabled

Если этот флажок установлен, то индекс активен.

!CheckBox Clustered

Установив этот флажок, укажите, что индекс кластеризованный. То есть, индекс, в котором физический порядок строк в соответствующей таблице определяется логическим порядком ключевых значений. За некоторыми исключениями, каждая таблица должна иметь кластеризованный индекс. Кроме того, что кластеризованный индекс повышает производительность запросов, его можно перестраивать или переорганизовывать по запросу, управляя фрагментацией таблицы. Кластеризованный индекс может быть также создан для представления.

Index type

!RadioButton Primary Key

Выберите это значение если создаете первичный ключ.

!RadioButton Unique key

Если существует уникальный индекс, каждый раз при добавлении данных операциями вставки компонент Database Engine производит проверку на наличие повторяющихся значений. Для операций вставки, которые могли бы сформировать повторяющиеся значения ключей, производится откат, и выводится сообщение об ошибке. Это происходит, даже если операция вставки изменяет несколько строк, а в результате образуется всего одно повторяющееся значение.

!RadioButton Unique index

Создает уникальный индекс для таблицы или представления. Уникальным является индекс, в котором не допускается наличие двух строк с одинаковыми значениями ключа индекса. Кластеризованный индекс представления должен быть уникальным.

!RadioButton XML index - создает первичный XML-индекс — это разобранное и сохраненное представление XML-объектов BLOB, содержащихся в столбце типа данных xml. Для каждого большого двоичного объекта (BLOB) столбца типа данных xml в индексе создается несколько строк данных, и их количество приблизительно равно числу узлов в большом двоичном объекте XML.

!RadioButton Spatial index

Создает пространственный индекс. Этот индекс используется в пространственных базах данных.

!RadioButton Columnstore index

Создает индекс columnstore. Такие индексы группируют и сохраняют данные для каждого столбца, затем объединяют все столбцы, чтобы завершить создание всего индекса.

!RadioButton Index - создает индекс, не задающий ограничения на данные.

Index creation options

Max degree of parallelism

Переопределяет параметр конфигурации сервера max degree of parallelism только на время выполнения операции с индексами. Эту опцию можно использовать для ограничения числа процессоров, используемых в одновременном выполнении планов. Максимальное число процессоров — 64.

Если задано значение 0 или отмечена опция !CheckBox Default, то в зависимости от текущей рабочей нагрузки системы используется реальное или меньшее число процессоров.

!CheckBox Sort in tempdb

Если установлен этот флажок, то промежуточные результаты сортировки, которые используются для создания индекса, хранятся в базе данных tempdb.

!CheckBox Keep table online

Если установлен этот флажок, то при выполнении операций с индексом в оперативном режиме выполняются следующие правила:

  • при выполнении фоновых операций с индексами базовая таблица не может изменяться, усекаться или удаляться;
  • для выполнения операций с индексами необходимо дополнительное временное место на диске;
  • оперативная обработка индексов может выполняться для секционированных индексов, содержащих материализованные вычисляемые или включенные столбцы.

Options

!CheckBox Do not recompute statistics

Если установлен этот флажок, это значит, что устаревшая статистика не подлежит автоматическому пересчету. Статистические данные устаревают в зависимости от количества операций INSERT, UPDATE и DELETE, выполненных в индексированных столбцах.

!CheckBox Pad index

Этот флажок устанавливает процентную долю свободного пространства в страницах промежуточного уровня во время создания индекса. Эта опция активна только тогда, когда задан коэффициент заполнения - Fill factor.

!CheckBox Ignore duplicate keys

Установленный флажок позволяет игнорировать дублирующиеся ключи. Указывает реакцию на ошибку, вызванную дублированием значений ключа в многострочной транзакции INSERT в уникальном кластеризованном или уникальном некластеризованном индексе.

!CheckBox Allow row locks определяет, используются ли блокировки строки при доступе к данным индекса.

!CheckBox Allow page lock определяет, используются ли блокировки страницы при доступе к данным индекса.

Hash index options (для таблиц, оптимизированнх для памяти)

!CheckBox Hash index

Отметьте эту опцию, чтобы создать хэшированный индекс. Хэшированный индекс состоит из набора контейнеров, организованных в массив.

Number of buckets

Задайте число контейнеров, которое следует создать в хэшированном индексе.

Fields for index

В нижней части формы Вы можете выбрать поле из списка имеющихся полей (Available Fields) и поместить его в список выбранных полей-индексов (Selected fields). Делается это с помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перетаскивания поля из одного списка в другой или с помощью двойного щелчка мыши.

Если Вы хотите указать неключевые столбцы, добавляемые на конечный уровень некластеризованного индекса, отметьте опцию !CheckBox Included Only для этого столбца.


Storagw

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Хранение

На этой вкладке задайте параметры хранения для индекса.

Index Editor - Storage

Data space

Из этого раскрывающегося списка выберите хранилище данных индекса. Это может быть файловая группа или схема секционирования.

Важно: При создании индекса необходимо задать пространство данных. По умолчанию используется пространство данных таблицы.

Partitioning column

Из этого раскрывающегося списка выберите поле, которое будет использоваться в качестве поля секционирования.

Этот раскрывающийся список доступен только в том случае, если в Data space Вы выбрали схему секционирования.

В разделе Compression by partitions задайте параметры сжатия индекса.

В поле Filegroup отображается файловая группа индекса.

В поле Compression (by partition) выберите тип сжатия:

  • None - без сжатия,
  • Row - построчное,
  • Page - постраничное.

В поле Rows отображается количество строк данных.

Filestream dataspace

Если необходимо, выберите Файловую группу файлового потока из этого раскрывающегося списка.


Фильтр

На этой вкладке можно задать предикат фильтра для индекса.

Index Editor - Filter

Filter

Задайте фильтр для отфильтрованного индекса путем указания строк для включения в индекс.

Отфильтрованный индекс должен быть некластеризованным индексом для таблицы.

Предикат фильтра использует простую логику сравнения и не может ссылаться на вычисляемый столбец, столбец определяемого пользователем типа, столбец типа пространственных данных или столбец типа hierarchyID. Сравнения с помощью литералов NULL с операторами сравнения недопустимы. Вместо этого используются операторы IS NULL и IS NOT NULL.


Параметры XML индекса

На этой вкладке задайте параметры XML индекса. Настройки на этой вкладке активны, если на вкладке Properties выбран тип индекса !RadioButton XML index.

Index Editor - XML options

!RadioButton Primary XML index

Отметьте эту опцию для создания XML-индекса по заданному столбцу типа xml. В этом случаей создается кластеризованный индекс с ключом, образованным из ключа кластеризации таблицы пользователя и идентификатора XML-узла.

!RadioButton Secondary XML index

Отметьте эту опцию для создания вторичного XML-индекса. Эта опция доступна только в случае, если в таблице уже создан первичный XML-индекс.

Вторичный XML-индекс может быть одного из следующих типов:

!RadioButton For value

Создает вторичный XML-индекс для столбцов, где ключевые столбцы (значение узла и путь) входят в первичный XML-индекс.

!RadioButton For path

Создает вторичный XML-индекс для столбцов, построенных на основе значений путей и узлов в первичном XML-индексе. Во вторичном индексе типа PATH значениями путей и узлов являются ключевые столбцы, обеспечивающие эффективный поиск путей.

!RadioButton For property

Создает вторичный XML-индекс по столбцам первичного XML-индекса (PK, путь и узел), где PK — первичный ключ базовой таблицы.


Параметры пространственного индекса

На этой вкладке задайте параметры пространственного индекса. Настройки на этой вкладке активны, если на вкладке Properties выбран тип индекса !RadioButton Spatial index.

Index Editor - Spatial index options

Bounding box (for geometry data only)

Используйте эту группу опций, чтобы задать числовой четырехэлементный кортеж, который определяет четыре координаты ограничивающего прямоугольника: координаты x-min и y-min нижнего левого угла и координаты x-max и y-max верхнего правого угла.

Grid tessellation

Определите плотность сетки на каждом уровне схемы тесселяции.

!CheckBox Auto

Если отмечена эта опция, то будут использованы значения по умолчанию для данного типа данных.

Grid size of level n

!RadioButton Default

Использовать значение по умолчанию.

Если уровень совместимости базы данных имеет значение 100 или ниже, по умолчанию используется значение MEDIUM на всех уровнях. Если уровень совместимости базы данных имеет значение 110 или выше, то по умолчанию используется автоматическая схема сетки.

!RadioButton Low (4x4)

Наименьшая возможная плотность сетки на данном уровне; соответствует 16 ячейкам (сетка 4x4).

!RadioButton Medium (8x8)

Cредняя плотность сетки на данном уровне; соответствует 64 ячейкам (сетка 8x8).

!RadioButton High (16x16)

Наибольшая возможная плотность сетки на данном уровне; соответствует 256 ячейкам (сетка 16x16).

Spatial options

Max cells per object (except level 1)

Укажите число ячеек тесселяции на объект, которое может быть использовано процессом тесселяции для отдельного пространственного объекта в индексе. Если отмечена опция !CheckBox Default, то число ячеек для указанной тесселяции будет установлено по умолчанию.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к индексу, то Вы можете его создать (изменить) на вкладке Description.

Index Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL индекса.

Index Editor - SQL Definition


Редактор статистик

Статистики для оптимизации запросов — это объекты, содержащие статистические сведения о распределении значений в одном или нескольких столбцах таблицы или индексированного представления. Оптимизатор запросов использует эти статистические сведения для оценки количества элементов, то есть числа строк, в результатах запроса. Такая оценка количества элементов позволяет оптимизатору запросов создать высококачественный план запроса. Например, оптимизатор запросов может использовать оценочное количество элементов, чтобы выбрать оператор index seek вместо оператора index scan, который потребляет больше ресурсов, и благодаря этому повысить производительность запроса.

Редактор Statistics Editor позволяет изменять свойства статистик таблицы базы данных при создании или редактировании статистики.

Чтобы открыть статистику в редакторе, дважды щелкните по ней в списке статистик или выберите пункт Edit Statistics... в контекстном меню на вкладке Statistics в Редакторе таблиц.

Вкладки:

  • Свойства
  • Данные статистики

Вектор плотности

Гистограмма

  • SQL описание


Свойства

На этой вкладке задайте основные свойства статистики.

Name

Задайте имя для новой статистики или отредактируйте имя существующей.

Statistics Editor - Properties

Table

В этом поле отображается имя таблицы, которой принадлежит редактируемая статистика.

Fields

В нижней части формы Вы можете выбрать поле из списка имеющихся полей (Available Fields) и поместить его в список выбранных полей-статистик (Selected fields). Делается это с помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перетаскивания поля из одного списка в другой или с помощью двойного щелчка мыши.

Filter

Введите выражение для выбора подмножества включаемых строк при создании объекта статистики. Статистика, создаваемая с предикатом фильтра, называется отфильтрованной. Предикат фильтра использует простую логику сравнения и не может ссылаться на вычисляемый столбец, столбец определяемого пользователем типа, столбец типа пространственных данных или столбец типа hierarchyID. Сравнения с помощью литералов NULL с операторами сравнения недопустимы. Вместо этого используются операторы IS NULL и IS NOT NULL.

!CheckBox Update statistics automatically

Если эта опция включена, то оптимизатор запросов определяет, когда статистика становится устаревшей, а затем обновляет ее во время ее использования в запросе.

Statistics creation options

!RadioButton Perform full scan

Вычисляет статистику путем просмотра всех строк в таблице или индексированном представлении.

!RadioButton Sample by ... percent of rows

Укажите число строк в таблице или индексированном представлении для оптимизатора запросов, которые используются при создании статистики.

!RadioButton Sample by ... rows

Укажите приблизительное процентное соотношение в таблице или индексированном представлении для оптимизатора запросов, которые используются при создании статистики.


Данные статистики

На вкладке Statistics data представлены результаты выполнения команды DBCC SHOW_STATISTICS - текущая статистика оптимизатора запросов для таблица или индексированного представления.

В результате выполнения команды DBCC SHOW_STATISTICS на вкладках отображаются заголовок, гистограмма и вектор плотности на основе данных, хранящихся в объекте статистики.

Statistics Editor - Statistics data


Вектор плотности

Оптимизатор запросов использует плотности для улучшения оценок количества элементов для запросов, которые возвращают данные нескольких столбцов из одной таблицы или индексированного представления. Вектор плотностей содержит по одной плотности для каждого префикса столбцов объекта статистики.

Statistics Editor - Statistics data - Density vector


Гистограмма

Гистограмма измеряет частоту появления каждого различающегося значения в наборе данных. Оптимизатор запросов вычисляет гистограмму для значений столбца в первом ключевом столбце объекта статистики, выбирая значения столбцов путем статистической выборки строк или при помощи полного просмотра всех строк в таблице или представлении. Если гистограмма создается на основе выбранного набора строк, то сохраняемые итоговые значения количества строк и количества различающихся значений являются приблизительными и не всегда выражаются целыми числами.

Statistics Editor - Statistics data - Histogram


SQL описание

На этой вкладке можно просмотреть DDL статистики.

Statistics Editor - SQL Definition


Редактор внешних ключей

Внешний ключ - Foreign Key - столбец или сочетание столбцов, значения которого соответствуют первичному или уникальному ключу из той же или другой таблицы. Внешний ключ также называют ссылочным ключом.

Внешний ключ применяется для установления связи между данными в двух таблицах.

Редактор Foreign Key Editor позволяет изменять свойства статистик таблицы базы данных при создании или редактировании внешнего ключа.

Чтобы открыть внешний ключ в редакторе, дважды щелкните по нему в списке внешних ключей или выберите пункт Edit Foreign Key... в контекстном меню на вкладке Foreign keys в Редакторе таблиц.

Вкладки:

  • Свойства
  • Описание
  • SQL описание


Свойства

На этой вкладке задайте основные параметры внешнего ключа.

Name

Задайте имя для нового внешнего ключа или отредактируйте имя существующего.

Foreign key Editor - Properties

Table

В этом поле отображается имя таблицы, которой принадлежит редактируемый внешний ключ.

!CheckBox Enabled

Если этот флажок установлен, то индекс активен.

!CheckBox Check existing data

Проверка существующих данных осуществляется в том случае если этот флажок установлен.

С помощью переключателя Update/Delete action выберите действие, которое будет выполняться при обновлении данных в таблице:

  • No Action - Без действия.
  • Cascade - Каскадное обновление. Операция обновления значения первичного ключа, на которое указывают внешние ключи в существующих строках других таблиц. При каскадном обновлении все значения внешних ключей обновляются так, чтобы они соответствовали новому значению первичного ключа.
  • Set Null - Указывает, что при попытке обновить ключевое значение, на которое ссылаются внешние ключи в строках других таблиц, все значения, составляющие эти внешние ключи, должны быть изменены на NULL. Чтобы выполнялось это ограничение, все столбцы внешних ключей целевой таблицы должны допускать значение NULL.
  • Set Default - Указывает, что при попытке обновить ключевое значение, на которое ссылаются внешние ключи в строках других таблиц, все значения, составляющие эти внешние ключи, должны быть изменены на значение по умолчанию. Чтобы выполнялось это ограничение, для всех столбцов внешних ключей целевой таблицы должно быть определено значение по умолчанию. Если столбец допускает значение NULL и множество значений по умолчанию не задано явно, NULL становится неявным значением по умолчанию для данного столбца.

!CheckBox Not for replication

При выполнении агентом репликации операций вставки обновления или удаления ограничение внешнего ключа не устанавливается, если установлен этот флажок.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к внешнему ключу, то Вы можете его создать (изменить) на вкладке Description.

Foreign key Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL внешнего ключа.

Foreign key Editor - SQL Definition


Редактор триггеров

Триггер — это особая разновидность хранимой процедуры, выполняемая автоматически при возникновении события на сервере базы данных. Триггеры языка обработки данных выполняются по событиям, вызванным попыткой пользователя изменить данные с помощью языка обработки данных. Событиями DML являются процедуры INSERT, UPDATE или DELETE, применяемые к таблице или представлению. В компоненте SQL Server 2005 Database Engine триггеры языка обработки данных могут быть созданы непосредственно из инструкций Transact-SQL или из методов сборок, созданных в среде CLR платформы Microsoft .NET Framework, и загружены на экземпляр SQL Server. SQL Server допускает создание нескольких триггеров для любой указанной инструкции.

Редактор Trigger Editor позволяет изменять свойства триггеров таблицы базы данных при создании или редактировании триггера.

Чтобы открыть триггер в редакторе, дважды щелкните по нему в списке триггеров или выберите пункт Edit Trigger... в контекстном меню на вкладке Triggers в Редакторе таблиц.

Вкладки:

  • Свойства
  • Опции
  • Описание
  • SQL описание


Свойства

На этой вкладке задайте основные параметры триггера.

Name

Задайте имя для нового триггера или отредактируйте имя существующего.

Trigger Editor - Properties

Table

В этом поле отображается имя таблицы, которой принадлежит редактируемый триггер.

!CheckBox Enabled

Установите этот флажок, если хотите чтобы триггер был включен.

Trigger type

Выберите, в каком виде будет представлен исходный код.

Можете выбрать один из двух видов:

  • SQL trigger - действия триггера, указаны в инструкциях языка Transact-SQL,
  • CLR trigger - метод сборки. В тексте нужно вызывать метод класса из зарегистрированной на сервере сборки и указать имя сборки, имя класса и метод. Образец "assembly_name.class_name.method_name".

!CheckBox Instead of triggering statement

Если отмечена эта опция, то триггер DML срабатывает вместо инструкции SQL, используемой триггером, переопределяя, таким образом, действия инструкций триггера. В противном случае триггер DML срабатывает только после успешного выполнения всех операций в инструкции SQL, запускаемой триггером. Все каскадные действия и проверки ограничений, на которые имеется ссылка, должны быть успешно завершены, прежде чем триггер сработает.

Events

В этом разделе выбирается событие, которое после выполнения вызывает срабатывание триггера.

Можете выбрать одно или несколько событий из предложенных: Insert, Update or Delete.

Для триггеров типа SQL trigger введите условия и действия триггера. Условия триггера указывают дополнительные критерии, определяющие, какие события — DML, DDL или событие входа — вызывают срабатывание триггера.

Для триггеров типа CLR trigger укажите метод сборки для связывания с CLR-триггером. Этот метод не должен принимать аргументы и возвращать значения void. class_name должно быть допустимым идентификатором SQL Server и существовать как класс в сборке с видимостью сборки. Если класс имеет имя, содержащее точки (.) для разделения частей пространства имен, имя класса должно быть заключено в квадратные скобки ([ ]) или двойные кавычки (" "). Класс не может быть вложенным.


Options

На этой вкладке задайте дополнительные опции триггера.

Trigger Editor - Options

Options

!CheckBox ANSI Nulls

Эта опция задает совместимое со стандартом ISO поведение операторов сравнения «равно» (=) и «не равно» (<>) при их использовании со значениями NULL в SQL Server. Если параметру SET ANSI_NULLS установлено значение ON, любая инструкция SELECT, использующая предложение WHERE column_name = NULL, не вернет ни одной строки, даже если в столбце column_name есть значения NULL. Любая инструкция SELECT, использующая предложение WHERE column_name <> NULL, не вернет ни одной записи, даже если в столбце column_name есть значения, не равные NULL.

!CheckBox Quoted identifier

Эта опция заставляет SQL Server следовать правилам ISO относительно разделения кавычками идентификаторов и строк-литералов. Идентификаторы, заключенные в двойные кавычки, могут быть либо зарезервированными ключевыми словами Transact-SQL, либо могут содержать символы, которые обычно запрещены правилами синтаксиса для идентификаторов Transact-SQL.

!CheckBox Not for replication

Включенная опция указывает, что триггер не может быть выполнен, если агент репликации изменяет таблицу, используемую триггером.

!CheckBox Encrypted

Включите эту опцию, чтобы зашифровать тело команды CREATE TRIGGER.

Execute as

Переключатель Execute as указывает контекст безопасности, в котором выполняется триггер. Позволяет управлять учетной записью пользователя, используемой экземпляром SQL Server для проверки разрешений на любые объекты базы данных, на которые ссылается триггер. С помощью этого переключателя Вы можете выбрать тип учетной записи.

Типы:

  • Caller - вызывающий,
  • Owner - владелец,
  • Current user - текущий пользователь,
  • User - пользователь.

В группах опций Fired first on и Fired last on укажите, на какое событие триггер должен срабатывать в первую и последнюю очередь.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к триггеру, то Вы можете его создать (изменить) на вкладке Description.

Trigger Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL триггера.

Trigger Editor - SQL Definition


Представления

На вкладке Views проводника баз данных можно просматривать, создавать, редактировать и удалять представления.

Контекстное меню

Create Create View ('Insert') - создать представление.

Edit Edit View ('Enter') - редактировать представление.

Drop Drop View ('Delete') - удалить представление.

  • Rename - переименовать представление.
  • Select Top 1000 Rows From - выполнить запрос для выборки первых 1000 записей в представлении.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список представлений отображается в виде таблицы со следующими столбцами:

Schema - имя схемы;

Name - имя представления;

Indexed - индексировано ли представление;

Schema Bound - привязано ли представление к схеме базовой таблицы;

System - является ли представление системным;

Description - описание представления.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор представлений

Представление (View) - это виртуальная таблица, представляющая данные одной или более таблиц или представлений альтернативным образом. Представление может быть создано только в текущей базе данных. Представление может включать не более 1024 столбцов.

В редакторе представлений Вы можете создавать новые представления и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Views дважды щелкнуть на нужном представлении мышкой. Также для создания и редактирования представлений можно использовать пункты контекстного меню Create View и Edit View соответственно.

Вкладки:

  • Свойства
  • Поля
  • Индексы
  • Статистики
  • Триггеры
  • Описание
  • Разрешения
  • SQL описание


Свойства

На этой вкладке задайте основные параметры представления.

View Editor - Properties

Name

Введите имя представления. Имя представления должно соответствовать правилам для идентификаторов, быть уникальным в рамках схемы и может состоять не более чем из 128 символов.

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать представление. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

!CheckBox ANSI Nulls

Эта опция задает совместимое со стандартом ISO поведение операторов сравнения «равно» (=) и «не равно» (<>) при их использовании со значениями NULL в SQL Server. Если параметру SET ANSI_NULLS установлено значение ON, любая инструкция SELECT, использующая предложение WHERE column_name = NULL, не вернет ни одной строки, даже если в столбце column_name есть значения NULL. Любая инструкция SELECT, использующая предложение WHERE column_name <> NULL, не вернет ни одной записи, даже если в столбце column_name есть значения, не равные NULL.

!CheckBox Quoted identifier

Эта опция заставляет SQL Server следовать правилам ISO относительно разделения кавычками идентификаторов и строк-литералов. Идентификаторы, заключенные в двойные кавычки, могут быть либо зарезервированными ключевыми словами Transact-SQL, либо могут содержать символы, которые обычно запрещены правилами синтаксиса для идентификаторов Transact-SQL.

SQL

В этом окне задайте SQL скрипт создания представления.

При нажатии на кнопку Display object template текст в поле заменится на шаблон скрипта создания представления.


Поля

На вкладке Fields Вы можете просмотреть все поля, отображаемые в представлении.

View Editor - Fields

Список полей представления отображается в виде таблицы со следующими столбцами:

Name - имя поля;

Data Type - тип данных;

Not Null - допускается ли пустое значение;

Identity - является ли поле идентификатором;

Default Value - значение поля по умолчанию;

Description - описание поля.

В поле Description можно ввести описание для каждого поля представления.


Indexes

На вкладке Indexes Вы можете создавать, просматривать и редактировать индексы представления. Чтобы открыть индекс в редакторе, дважды щелкните по нему или выберите пункт Edit Index... в контекстном меню.

View Editor - Indexes

В списке Indexes and primary/unique keys отображаются следующие свойства индексов:

Name - имя индекса;

Index Type - тип индекса;

Columns - поля, на которых основан индекс;

Included Columns - неключевые столбцы, добавляемые на конечный уровень некластеризованного индекса;

Clustered - является ли индекс кластеризованным;

Enabled - активен ли индекс;

Description - описание индекса.

В поле Description можно ввести описание для каждого индекса представления.


Статистики

На вкладке Statistics Вы можете создавать, просматривать и редактировать статистики представления. Чтобы открыть статистику в редакторе, дважды щелкните по ней или выберите пункт Edit Statistics... в контекстном меню.

View Editor - Statistics

В списке Statistics отображаются следующие свойства статистики:

Name - имя статистики;

System - является ли статистика системной;

Columns - поля, на основе которых создана статистика;

No Auto Recompute - отключен ли параметр автоматического обновления статистики;

Filter - предикат фильтра статистики.


Триггеры

На вкладке Triggers Вы можете создавать, просматривать и редактировать триггеры представления. Чтобы открыть триггер в редакторе, дважды щелкните по ней или выберите пункт Edit Trigger... в контекстном меню.

View Editor - Triggers

В списке Triggers отображаются следующие свойства триггеров:

Name - имя триггера;

Type - тип триггера;

Insert - срабатывает ли триггер на вставку;

Update - срабатывает ли триггер на обновление;

Delete - срабатывает ли триггер на удаление;

Enabled - активен ли триггер;

Description - описание триггера.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к представлению, то Вы можете его создать (изменить) на вкладке Description.

View Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующего представления.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

View Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для управления разрешениями на уровне столбца и для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL представления.

View Editor - SQL Definition


Процедуры

На вкладке Procedures проводника баз данных можно просматривать, создавать, редактировать и удалять процедуры.

Контекстное меню

Create Create Procedure ('Insert') - создать процедуру.

Edit Edit Procedure ('Enter') - редактировать процедуру.

Drop Drop Procedure ('Delete') - удалить процедуру.

  • Rename - переименовать процедуру.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список процедур отображается в виде таблицы со следующими столбцами:

Schema - имя схемы;

Name - имя процедуры;

Type - тип процедуры;

System - является ли процедура системной;

Assembly Method - метод сборки;

Assembly Class - класс сборки;

Assembly - сборка;

Description - описание процедуры.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор процедур

Хранимая процедура (Procedure)— это сохраненная совокупность инструкций языка Transact-SQL или ссылка на метод среды Microsoft .NET Framework CLR, которая может принимать и возвращать предоставленные пользователем параметры. Процедуры можно создавать для постоянного использования, для временного использования в одном сеансе (локальная временная процедура) или для временного использования во всех сеансах (глобальная временная процедура).

Хранимые процедуры могут выполняться автоматически при запуске экземпляра SQL Server.

В редакторе процедур Вы можете создавать новые процедуры и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Procedures дважды щелкнуть на нужной процедуре мышкой. Также для создания и редактирования процедур можно использовать пункты контекстного меню Create Procedure и Edit Procedure соответственно.

Вкладки:

  • Свойства
  • Параметры
  • Описание
  • Разрешения
  • SQL описание


Свойства

На этой вкладке задайте основные параметры процедуры.

Name

Введите имя процедуры. Имена процедур должны соответствовать требованиям, предъявляемым к идентификаторам, и должны быть уникальными в схеме. Локальную или глобальную временную процедуру можно создать, указав один символ номера (#) перед именем procedure_name (#procedure_name) для локальных временных процедур и два символа номера для глобальных временных процедур (##procedure_name).

Procedure Editor - Properties

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать процедура. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

!CheckBox ANSI Nulls

Эта опция задает совместимое со стандартом ISO поведение операторов сравнения «равно» (=) и «не равно» (<>) при их использовании со значениями NULL в SQL Server. Если параметру SET ANSI_NULLS установлено значение ON, любая инструкция SELECT, использующая предложение WHERE column_name = NULL, не вернет ни одной строки, даже если в столбце column_name есть значения NULL. Любая инструкция SELECT, использующая предложение WHERE column_name <> NULL, не вернет ни одной записи, даже если в столбце column_name есть значения, не равные NULL.

!CheckBox Quoted identifier

Эта опция заставляет SQL Server следовать правилам ISO относительно разделения кавычками идентификаторов и строк-литералов. Идентификаторы, заключенные в двойные кавычки, могут быть либо зарезервированными ключевыми словами Transact-SQL, либо могут содержать символы, которые обычно запрещены правилами синтаксиса для идентификаторов Transact-SQL.

SQL

В этом окне задайте SQL скрипт создания процедуры.

При нажатии на кнопку Display object template текст в поле заменится на шаблон скрипта создания процедуры.


Параметры

На вкладке Parameters Вы можете просматривать список параметров, объявленных в существующей процедуре.

На данной вкладке параметры нельзя ни добавлять, ни редактировать.

Procedure Editor - Parameters

Список параметров процедуры отображается в виде таблицы со следующими столбцами:

Name - имя параметра;

Data Type - тип данных параметра;

Output - является ли параметр выходным;

Read Only - является ли параметр доступным только для чтения;

Default Value - значение по умолчанию для параметра;

Description - описание параметра.

В поле Description можно ввести описание для каждого параметра.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к процедуре, то Вы можете его создать (изменить) на вкладке Description.

Procedure Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующей процедуры.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Procedure Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL процедуры.

Procedure Editor - SQL Definition


Функции

На вкладке Functions проводника баз данных можно просматривать, создавать, редактировать и удалять функции.

Контекстное меню

Create Create Function ('Insert') - создать функцию.

Edit Edit Function ('Enter') - редактировать функцию.

Drop Drop Function ('Delete') - удалить функцию.

  • Rename - переименовать функцию.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список процедур отображается в виде таблицы со следующими столбцами:

Schema - имя схемы;

Name - имя функции;

Type - тип функции;

System - является ли функция системной;

Assembly Method - метод сборки;

Assembly Class - класс сборки;

Assembly - сборка;

Returns Null on Null input - может ли функция возвращать NULL при входных NULL параметрах;

Description - описание функции.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор функций

Определенная пользователем функция (Function) представляет собой подпрограмму Transact-SQL или среды CLR, которая возвращает значение. Пользовательская функция не может выполнять действия, изменяющие состояние базы данных. Она, как и системная функция, может быть вызвана из запроса.

Типы пользовательских функций:

Rowset functions

Функция является возвращающей табличное значение, если в предложении RETURNS содержится переменная TABLE. В зависимости от того, каким образом определено тело функции, функции, возвращающие табличное значение, подразделяются на встроенные функции и функции из нескольких инструкций.

Aggregate functions

Функция является агрегатной, если она оперирует некоторым количеством значений, а возвращает единственное итоговое значение.

Ranking functions

Эта функция формирует рейтинг (или ранжирующее значение), который указывает на релевантность возвращенных данных.

Scalar functions

Функция является скалярной, если в ней указано предложение RETURNS, соответствующее одному из скалярных типов данных. Скалярные функции могут состоять из нескольких инструкций.

В редакторе функций Вы можете создавать новые функции и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Functions дважды щелкнуть на нужной функции мышкой. Также для создания и редактирования функций можно использовать пункты контекстного меню Create Function и Edit Function соответственно.

Вкладки:

  • Свойства
  • Параметры
  • Описание
  • Разрешения
  • SQL описание


Свойства

На этой вкладке задайте основные параметры функции.

Name

Введите имя функции. Имена функций должны соответствовать требованиям, предъявляемым к идентификаторам, и должны быть уникальными в схеме.

Function Editor - Properties

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать функция. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

!CheckBox ANSI Nulls

Эта опция задает совместимое со стандартом ISO поведение операторов сравнения «равно» (=) и «не равно» (<>) при их использовании со значениями NULL в SQL Server. Если параметру SET ANSI_NULLS установлено значение ON, любая инструкция SELECT, использующая предложение WHERE column_name = NULL, не вернет ни одной строки, даже если в столбце column_name есть значения NULL. Любая инструкция SELECT, использующая предложение WHERE column_name <> NULL, не вернет ни одной записи, даже если в столбце column_name есть значения, не равные NULL.

!CheckBox Quoted identifier

Эта опция заставляет SQL Server следовать правилам ISO относительно разделения кавычками идентификаторов и строк-литералов. Идентификаторы, заключенные в двойные кавычки, могут быть либо зарезервированными ключевыми словами Transact-SQL, либо могут содержать символы, которые обычно запрещены правилами синтаксиса для идентификаторов Transact-SQL.

SQL

В этом окне задайте SQL скрипт создания функции.

При нажатии на кнопку Display object template текст в поле заменится на шаблон скрипта создания функции.


Параметры

На вкладке Parameters Вы можете просматривать список параметров, объявленных в существующей функции.

На данной вкладке параметры нельзя ни добавлять, ни редактировать.

Function Editor - Parameters

Список параметров функции отображается в виде таблицы со следующими столбцами:

Name - имя параметра;

Data Type - тип данных параметра;

Output - является ли параметр выходным;

Read Only - является ли параметр доступным только для чтения;

Default Value - значение по умолчанию для параметра;

Description - описание параметра.

В поле Description можно ввести описание для каждого параметра.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к функции, то Вы можете его создать (изменить) на вкладке Description.

Function Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующей функции.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Function Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL функции.

Function Editor - SQL Definition


Типы данных

На вкладке Data Types проводника баз данных можно просматривать, создавать, редактировать и удалять пользовательские типы данных.

Контекстное меню

Create Create ('Insert') - создать тип данных.

Edit Edit ('Enter') - редактировать тип данных.

Drop Drop ('Delete') - удалить тип данных.

  • Rename - переименовать тип данных.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список типов данных отображается в виде таблицы со следующими столбцами:

Schema - имя схемы;

Name - имя типа данных;

Type - тип пользовательского типа;

System - является ли тип системным;

Base Type Not NULL - является ли тип данных, на основе которого создан пользовательский тип, не пустым;

Assembly Class - класс сборки;

Assembly - сборка;

Description - описание типа.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор типов данных

Пользовательский тип данных (Data Type) - это определяемый пользователем тип данных, основанный на одном из системных типов данных SQL Server или реализуемый с помощью класса сборки в общеязыковой среде исполнения (CRL) Microsoft .NET Framework.

CLR - это определяемый пользователем тип данных, который создается при обращении к сборке SQL Server. Реализация определяемого пользователем типа CLR определяется в сборке, создаваемой в среде CLR платформы .NET Framework.

В редакторе типов данных Вы можете создавать новые типы данных и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Data Types дважды щелкнуть на нужном типе данных мышкой. Также для создания и редактирования типов данных можно использовать пункты контекстного меню Create и Edit соответственно.

Вкладки:

Свойства

Ограничения типа CHECK

Первичные и уникальные ключи

Описание

Разрешения

SQL описание


Свойства

На этой вкладке задайте основные параметры типа данных.

Name

Введите имя типа данных. Имена типов данных должны соответствовать требованиям, предъявляемым к идентификаторам, и должны быть уникальными в схеме.

Data Type Editor - Properties

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать тип данных. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

Type

При создании нового пользовательского типа данных необходимо выбрать, на основе какого объекта он будет создан.

!RadioButton Alias data type - создать псевдоним системного типа данных SQL Server.

!RadioButton CLR data type - создать определяемый пользователем тип данных на основе сборки.

!RadioButton Table data type - создать табличный тип данных.

Alias data type properties

Задайте настройки псевдонима типа данных.

Type

Из выпадающего списка выберите предоставляемый SQL Server тип данных, на основе которого формируется псевдоним. Редактирование этого параметра возможно только при создании нового псевдонима.

Length/precision

Задайте размер поля. Если установлен флажок !CheckBox Maximum size, то значение размера поля будет максимально возможным для SQL Server.

Scale

Для типов decimal или numeric это число указывает максимальное общее число подлежащих сохранению десятичных знаков справа от разделителя, отделяющего десятичную дробь от целого числа. Его значение должно быть меньшим или равным заданного значения Length/precision.

!CheckBox Not Null

Эта опция определяет, допустимы ли для столбца значения NULL. Если этот флажок установлен, то значения поля не могут пустыми.

Rule

Из выпадающего списка выберите правило, которое хотите привязать к псевдониму. Если установлен флажок !CheckBox Ignore for existing columns, то предотвращается наследование нового правила существующим столбцом типа данных псевдонима.

Default

Из выпадающего списка выберите значение по умолчанию, которое хотите привязать к псевдониму. Если установлен флажок !CheckBox Ignore for existing columns, то предотвращается наследование нового умолчания существующим столбцом типа данных псевдонима.

CLR Data Type

Задайте настройки определяемого пользователем тип данных на основе сборки.

Data Type Editor - Properties - CLR Data Type

Assembly

Из выпадающего списка выберите сборку SQL Server, которая ссылается на реализацию пользовательского типа в среде CLR.

Class name

Укажите класс внутри сборки, реализующий определяемый пользователем тип.

Table Data Type

Задайте настройки для создания табличного типа данных.

Data Type Editor - Properties - Table Data Type

Fields

В этой таблице отображаются столбцы табличного типа данных.

С помощью контекстного меню Вы можете создать новое поле, открыть существующее поле в Редакторе полей, удалить выбранное поле или переместить поле вверх/вниз по списку.

В списке Fields отображаются следующие свойства полей:

Name - имя поля;

Data Type - тип данных;

Not Null - допускается ли пустое значение;

Identity - является ли поле идентификатором;

Default Value - значение поля по умолчанию;

Description - описание поля.


Ограничения типа CHECK

На вкладке Checks Вы можете создавать, просматривать и редактировать ограничения CHECK, то есть устанавливать ограничения на значения в поле. Эта вкладка доступна только при создании/редактировании табличных типов.

Data Type Editor - Check constraint

С помощью контекстного меню можно создать новое, редактировать или удалить существующее ограничение.

Дважды щелкните по ограничению мышкой, чтобы открыть редактор тела ограничения Check Constraint.

Data Type Editor - Check constraint - Check constraint editor


Первичные и уникальные ключи

На вкладке Primary/unique keys Вы можете создавать, просматривать и редактировать ключи табличного типа.

Data Type Editor - Primary and unique keys

С помощью контекстного меню можно создать новый, редактировать или удалить существующий ключ.

Дважды кликните по ключу, чтобы открыть его в Редакторе индексов.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к типу данных, то Вы можете его создать (изменить) на вкладке Description.

Data Type Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующего типа данных.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Procedure Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для управления для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL типа данных.

Data Type Editor - SQL Definition


Пользователи базы данных

Пользователь базы данных (Database User) - это главный элемент, обеспечивающий контроль доступа к элементам базы данных. Пользователь определяется единственным логином, видимым в пределах той базы данных, в которой он был объявлен.

Пользователи создаются для логинов, не являющихся участниками административных ролей. Позволяют регулировать права доступа к объектам базы данных. Права доступа к базе данных определяются для логина в редакторе логинов. Права доступа к объектам базы данных указываются для пользователя в редакторе пользователей. Для каждого логина можно создавать только одного пользователя.

Контекстное меню:

Create Create User - создать пользователя.

Edit Edit User - изменить пользователя.

Drop Drop User - удалить пользователя.

  • Rename - переименовать пользователя.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Пользователи базы данных отображаются в виде таблицы со следующими столбцами:

Name - имя пользователя;

User type - тип;

Orphaned - является ли пользователь изолированным;

Can Connect - может ли подключаться к базе данных;

DB Owner - является ли владельцем базы данных;

Sysadmin - является ли членом предопределенной роли сервера sysadmin;

Login - логин, для которого создан пользователь;

Certificate - сертификат, для которого создан пользователь;

Asymmetric Key - асимметричный ключ, для которого создан пользователь;

Default Schema - схема по умолчанию.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Роли базы данных

Роль базы данных (Database Role) - это совокупность пользователей и групп, обладающих идентичными правами доступа. Это сущности, защищаемые на уровне базы данных. После создания роли необходимо настроить для нее разрешения уровня базы данных. Пользователь может принадлежать к нескольким группам и иметь несколько ролей. Свойства каждой роли определяют возможности пользователя по работе с объектами баз данных.

Контекстное меню

Create Create Role ('Insert') - создать роль.

Edit Edit Role ('Enter') - редактировать роль.

Drop Drop Role ('Delete') - удалить роль.

  • Rename - переименовать роль.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Роли базы данных отображаются в виде таблицы со следующими столбцами:

Name - имя роли;

Owner - владелец роли;

DB Owner - владелец базы данных

Fixed Role - является ли роль предопределенной (фиксированной);

Created - дата создания роли;

Modified - дата последнего изменения роли;

Number of Assigned Roles - количество назначенных ролей;

Number of Members - количество участников.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Смотрите также:

Логины

Пользователи баз данных

Роли приложения

Роли сервера

Разрешения сервера

Разрешения базы данных


Роли приложения

Роль приложения (Application role) — это участник базы данных, позволяющий приложению выполняться со своими, подобными пользовательским, правами доступа. Роли приложений можно использовать для разрешения доступа к определенным данным только тем пользователям, которые подключены посредством конкретного приложения. В отличие от ролей баз данных, роли приложений не содержат элементов и по умолчанию находятся в неактивном состоянии.

Контекстное меню

Create Create Application Role - создать роль приложения.

Edit Edit Application Role(s) - изменить роль приложения.

Drop Drop Application Role(s) - удалить роль приложения.

  • Rename - переименовать роль приложения.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Роли приложения отображаются в виде таблицы со следующими столбцами:

Name - имя роли;

DB Owner - владелец базы данных;

Default Schema - схема по умолчанию;

Created - дата создания роли;

Modified - дата последнего изменения роли;

Number of Assigned Roles - количество назначенных ролей.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Смотрите также:

Логины

Пользователи баз данных

Роли баз данных

Роли сервера

Разрешения сервера

Разрешения базы данных


Функции секционирования

На вкладке Partition Functions проводника баз данных можно просматривать, создавать, редактировать и удалять функции секционирования.

Контекстное меню

Create Create Partition Function ('Insert') - создать функцию секционирования.

Edit Edit Partition Function(s) ('Enter') - редактировать функцию секционирования.

Drop Drop Partition Function(s) ('Delete') - удалить функцию секционирования.

  • Rename - переименовать функцию секционирования.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список функций секционирования отображается в виде таблицы со следующими столбцами:

Name - имя функции секционирования;

Parameter Data Type - тип данных параметра;

Parameter Collation - параметры сортировки параметра функции;

Boundary Value - граничное значение;

Creation Date - дата создания;

Modification Date - дата последнего редактирования;

Description - описание функции секционирования.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор функций секционирования

Секционирование - это процесс замены таблицы несколькими меньшими таблицами. Каждая меньшая таблица имеет тот же формат, что и исходная, но содержит лишь некоторое подмножество данных. Строки помещаются в новые таблицы в зависимости от некоторых свойств, например в соответствии с некоторым диапазоном ключей. Правила, которые определяют, в какую таблицу перемещать строки, должны быть однозначными.

Функция секционирования (Partition Function) - функция, определяющая порядок распределения строк секционированной таблицы или индекса по набору секций на основе значений определенных столбцов, называемых столбцами секционирования.

В редакторе функций секционирования Вы можете создавать новые функции секционирования и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Partition Functions дважды щелкнуть на нужной функции секционирования мышкой. Также для создания и редактирования функций секционирования можно использовать пункты контекстного меню Create Partition Function и Edit Partition Function соответственно.

Вкладки:

Свойства

Описание

SQL описание


Свойства

На этой вкладке задайте основные параметры функции секционирования.

Name

Введите имя функции секционирования. Имена функций секционирования должны соответствовать требованиям, предъявляемым к идентификаторам.

Parameter

Data type

Задайте тип данных для параметра функции секционирования.

Length/precision

Задайте размер поля.

Scale

Для типов decimal или numeric это число указывает максимальное общее число подлежащих сохранению десятичных знаков справа от разделителя, отделяющего десятичную дробь от целого числа. Его значение должно быть меньшим или равным заданного значения Length/precision.

Collation

Из выпадающего списка выберите правило сравнения символьных данных. Эти правила задают кодовую страницу и порядок сопоставления символьных данных для работы с данными в Юникоде и других форматах.

Partition Function Editor - Properties

!CheckBox Boundary values belong to left intervals

Если флажок установлен, то аргумент boundary value принадлежит к левой области интервала для случая, когда значения интервалов были отсортированы компонентом Database Engine по возрастанию слева направо. Если флажок не установлен, то к правой.

Boundary values

В этом списке указываются все значения интервалов.

Интервал задает граничные значения для каждой секции секционированной таблицы или индекса.

В списке Вы можете увидеть следующие характеристики интервала:

  • значение - Boundary Value,
  • интервал - Interval,
  • схемы секционирования - Partition Schemes. в столбцах указываются все схемы, использующие эту функцию секционирования.

С помощью пункта контекстного меню Create Add Boundary Value Вы можете добавить новый интервал.

С помощью пункта контекстного меню Drop Delete Value можно удалить интервал.

С помощью кнопок MoveUp MoveDown Вы можете менять интервалы местами.

This area lists the boundary values specified by the partition function.

Чтобы добавить схему секционирования, которая будет использовать редактируемую функцию секционирования, выберите пункт контекстного меню Create Create Partition Scheme.

Для удаления схемы секционирования используйте пункт контекстного меню Drop Delete Partition Scheme.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к функции секционирования, то Вы можете его создать (изменить) на вкладке Description.

Partition Function Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL функции секционирования.

Partition Function Editor - SQL Definition


Схемы секционирования

На вкладке Partition Schemes проводника баз данных можно просматривать, создавать, редактировать и удалять схемы секционирования.

Контекстное меню

Create Create Partition Scheme ('Insert') - создать схему секционирования.

Edit Edit Partition Scheme(s) ('Enter') - редактировать схему секционирования.

Drop Drop Partition Scheme(s) ('Delete') - удалить схему секционирования.

  • Rename - переименовать схему секционирования.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список схем секционирования отображается в виде таблицы со следующими столбцами:

Name - имя схемы секционирования;

Partition Function - функция секционирования, которая использует схему секционирования;

Description - описание схемы секционирования.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор схем секционирования

Схема секционирования (Partition Scheme) - это объект базы данных, который сопоставляет секции функции секционирования набору файловых групп.

В редакторе схем секционирования Вы можете создавать новые схемы секционирования и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Partition Schemes дважды щелкнуть на нужной схеме секционирования мышкой. Также для создания и редактирования схем секционирования можно использовать пункты контекстного меню Create Partition Scheme и Edit Partition Scheme соответственно.

Вкладки:

Свойства

Описание

SQL описание


Свойства

На этой вкладке задайте основные параметры схемы секционирования.

Name

Введите имя схемы секционирования. Имена схем секционирования должны соответствовать требованиям, предъявляемым к идентификаторам.

Partition function

Из раскрывающегося списка выберите функцию секционирования, использующую схему секционирования.

Partition Scheme Editor - Properties

В списке Filegroups указываются имена файловых групп, содержащих секции, указываемые в функции секционирования.

В этом списке содержатся следующие сведения:

  • интервал - Interval,
  • файловая группа - Filegroup.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к схеме секционирования, то Вы можете его создать (изменить) на вкладке Description.

Partition Scheme Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


SQL описание

На этой вкладке можно просмотреть DDL схемы секционирования.

Partition Scheme Editor - SQL Definition


Последовательности

На вкладке Sequences проводника баз данных можно просматривать, создавать, редактировать и удалять последовательности.

Контекстное меню

Create Create ('Insert') - создать последовательность.

Edit Edit ('Enter') - редактировать последовательность.

Drop Drop ('Delete') - удалить последовательность.

  • Rename - переименовать последовательность.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список последовательностей отображается в виде таблицы со следующими столбцами:

Schema - имя схемы;

Name - имя последовательности;

Base Type - тип чисел последовательности;

Current Value - текущее значение;

Start Value - начальное значение;

Increment - значение шага последовательности;

Min Value - минимально допустимое значение;

Max Value - максимально допустимое значение;

Cyclic- является ли последовательность цикличной;

Cache - хранятся ли значения в памяти;

Exhausted - является ли последовательность исчерпанной;

Description - описание последовательности.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор последовательностей

Последовательности (Sequence) - удобный метод построения последовательности пронумерованных списков. Каждый раз, когда пользователь обращается к последовательности, значение ее порядкового номера увеличивается. Это обеспечивает одноразовое использование определенного номера. Таким образом, последовательности могут использоваться для создания уникальных номеров.

В редакторе последовательностей Вы можете создавать новые последовательности и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Sequences дважды щелкнуть на нужной последовательности мышкой. Также для создания и редактирования последовательностей можно использовать пункты контекстного меню Create и Edit соответственно.

Вкладки:

Свойства

Описание

Разрешения

SQL описание


Свойства

На этой вкладке задайте основные параметры последовательности.

Name

Введите имя последовательности. Имена последовательностей должны соответствовать требованиям, предъявляемым к идентификаторам, и должны быть уникальными в схеме.

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать последовательность. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

Sequence Editor - Properties

For data type

Выберите, данные какого типа должны быть в последовательности: !RadioButton System type (системного) или !RadioButton User-defined type пользовательского.

Type

Тип данных в последовательности.

Precision

Задайте размер поля.

Next value

Первое значение, возвращаемое объектом последовательности. Значение должно быть не больше максимального и не меньше минимального значения объекта последовательности. По умолчанию начальным значением для нового объекта последовательности служит минимальное значение для объекта возрастающей последовательности и максимальное — для объекта убывающей.

Increment

Значение, на которое увеличивается (или уменьшается, если оно отрицательное) значение объекта последовательности при каждом вызове функции NEXT VALUE FOR. Если значение приращения отрицательно, то объект последовательности убывает, в противном случае — возрастает. Приращение не может быть равно 0. По умолчанию для нового объекта последовательности используется приращение 1.

Minimum value

Укажите минимально допустимое значения для объекта последовательности. По умолчанию минимальным значением для нового объекта последовательности служит минимальное значение для типа данных объекта последовательности. Для типа данных tinyint это ноль, для всех остальных типов данных — отрицательное число.

Maximum value

Укажите максимально допустимое значения для объекта последовательности. По умолчанию максимальным значением для нового объекта последовательности служит максимальное значение для типа данных объекта последовательности.

Cache

Задайте количество номеров последовательностей, хранимых в памяти для быстрого доступа (опция !RadioButton This).

!CheckBox Cyclic

Свойство указывает, перезапускается объект последовательности с минимального значения (или максимального для объектов убывающих последовательностей) или вызывает исключение, когда достигнуто максимальное (или максимальное) значение.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к последовательности, то Вы можете его создать (изменить) на вкладке Description.

Sequence Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующей последовательности.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Sequence Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL последовательности.

Sequence Editor - SQL Definition


Синонимы

На вкладке Synonyms проводника баз данных можно просматривать, создавать, редактировать и удалять синонимы.

Контекстное меню

Create Create ('Insert') - создать синоним.

Edit Edit ('Enter') - редактировать синоним.

Drop Drop ('Delete') - удалить синоним.

  • Rename - переименовать синоним.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список синонимов отображается в виде таблицы со следующими столбцами:

Schema - имя схемы;

Name - имя синонима;

Object Name - имя исходного объекта;

Object Type - тип исходного объекта;

Description - описание синонима.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор синонимов

Синоним (Synonym) — это альтернативное имя, которое дается объекту схемы. Клиентские приложения могут использовать для ссылки на базовый объект синонимы из одного слова вместо имен, состоящих из двух, трех или четырех частей.

Синоним является объектом базы данных, который выполняет следующие функции:

  • предоставляет альтернативное имя для другого объекта базы данных, существующего на локальном или удаленном сервере, на которое затем другие объекты ссылаются как на базовый объект;
  • обеспечивает уровень абстракции, защищающий клиентские приложения от изменений, производимых в имени или местоположении базовых объектов.

В редакторе синонимов Вы можете создавать новые синонимы и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Synonyms дважды щелкнуть на нужном синониме мышкой. Также для создания и редактирования синонимов можно использовать пункты контекстного меню Create и Edit соответственно.

Вкладки:

Свойства

Описание

Разрешения

SQL описание


Свойства

На этой вкладке задайте основные параметры синонима.

Name

Введите имя синонима. Имена синонимов должны соответствовать требованиям, предъявляемым к идентификаторам, и должны быть уникальными в схеме.

Schema

Из раскрывающегося списка выберите схему, которой будет принадлежать синоним. По умолчанию задана схема, которая является схемой по умолчанию для текущего пользователя.

Synonym Editor - Properties

Object name

В этом поле отображается объект, для которого создается синоним.

Чтобы выбрать другой объект, нажмите кнопку с троеточием.

Имя объекта можно изменить вручную

В диалоге Select Database Object выберите объект базы данных, на который будет ссылаться синоним.

dialog allows you to specify a database object to use as the referenced object.

Synonym Editor - Properties - Select Object

После выбора необходимого объекта, его тип будет отображаться в поле Object type.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к синониму, то Вы можете его создать (изменить) на вкладке Description.

Synonym Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующего синонима.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Synonym Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL синонима.

Synonym Editor - SQL Definition


Schemas

На вкладке Schemas проводника баз данных можно просматривать, создавать, редактировать и удалять схемы.

Контекстное меню

Create Create Schema ('Insert') - создать схему.

Edit Edit Schema(s) ('Enter') - редактировать схему.

Drop Drop Schema(s) ('Delete') - удалить схему.

  • Rename - переименовать схему.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Список схем отображается в виде таблицы со следующими столбцами:

Name - имя схемы;

System - является ли схема системной;

Owner - владелец схемы;

Description - описание схемы.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор схем

Схема (Schema) является коллекцией объектов базы данных, принадлежащих одному пользователю и образующих одно пространство имен. Пространством имен является набор объектов, в котором не может быть повторяющихся имен. Например, две таблицы могут иметь одинаковое имя, если только они находятся в разных схемах. Объект базы данных, например, таблица, принадлежит схеме, а схема принадлежит пользователю или роли базы данных. Если владелец схемы покидает организацию, перед удалением выбывшего пользователя схема передается во владение новому пользователю или роли.

В редакторе схем Вы можете создавать новые схемы и редактировать существующие.

Чтобы открыть объект в редакторе необходимо на вкладке Schemas дважды щелкнуть на нужной схеме мышкой. Также для создания и редактирования схем можно использовать пункты контекстного меню Create Schema и Edit Schema соответственно.

Вкладки:

Свойства

Описание

Разрешения

SQL описание


Свойства

На этой вкладке задайте основные параметры схемы.

Schema Editor - Properties

Name

Введите имя схемы. Имена схем должны соответствовать требованиям, предъявляемым к идентификаторам.

Owner

Выберите владельца схемы - пользователя или роль.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к схеме, то Вы можете его создать (изменить) на вкладке Description.

Schema Editor - Description

Внесенные изменения вступят в силу при нажатии кнопки Apply на панели инструментов.


Разрешения

На вкладке Permissions Вы можете указать разрешения для пользователей, ролей баз данных и ролей приложения.

Эта вкладка доступна только при редактировании существующего синонима.

Из списка Principal type на панели управления выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Schema Editor - Permissions

Principal Name

В этом столбце перечислены имена участников базы данных (пользователи, роли баз данных или роли приложения)

Note: При двойном клике на имени объекта открывается соответствующий редактор.

С помощью контекстного меню можно:

  • Grant - предоставить выбранному участнику права на выполнение операции,
  • Grant with Grant Option - предоставить выбранному участнику права на выполнение операции с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям),
  • Revoke - аннулировать права для выбранного участника,
  • Deny - запретить выбранному участнику выполнение операции,
  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

С помощью контекстного меню можно вызвать диалог для просмотра действующих разрешений.

Смотрите также:

Разрешения базы данных


SQL описание

На этой вкладке можно просмотреть DDL схемы.

Schema Editor - SQL Definition


Storage

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Хранение

На вкладке Storage в Server Explorer отображаются диаграммы, построенные на основе информации об использовании дискового пространства и размерах баз данных.

Подразделы:

Базы данных

Моментальные снимки баз данных

Использование дискового пространства

Использование пространства объектами

На этой вкладке отображается следующая информация.

Disk Space, GB

В этом разделе отображается информация об использовании дискового пространства на сервере.

Количество столбцов гистограммы зависит от количества дисков на сервере. Каждый столбец разделен на три секции:

Red Free Space - свободное дисковое пространство.

Green Used by Other - дисковое пространство, используемое данными, не относящимися к базам данных.

Yellow Used by Databases - дисковое пространство, используемое базами данных.

Data Size, MB

Этот раздел содержит информацию о размерах файлов данных тех баз, которые занимают большой объем дискового пространства на сервере.

Для каждой базы отображается три столбца:

Yellow Size on - размер файла данных на указанную дату (месяц назад от текущей даты). Если в репозитарии для сервера нет статистики размеров баз на эту дату, то берется ближайшая дата, на которую статистика есть.

Green Current Data File Size - текущий размер файла данных.

Red Max Data File Size - максимальный размер фала данных (если задан).

Log Size, MB

Этот раздел содержит информацию о размерах файлов журналов крупнейших баз данных на сервере. Для каждой базы отображается три столбца:

Yellow Size on - размер файла журнала за месяц от текущей даты. Если в репозитарии для сервера нет статистики размеров баз на эту дату, то берется ближайшая дата, на которую статистика есть.

Green Current Log File Size - текущий размер файла журнала.

Red Max Log File Size - максимальный размер фала журнала (если задан).

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Безопасность

Агент SQL сервера

Производительность

Журнал сервера

Запросы

Опции


Редактор баз данных

Открыть базу данных в редакторе можно из любого списка баз данных. Для этого необходимо в списке баз данных щелкнуть на нужной базе два раза мышкой или в контекстном меню базы выбрать пункт Edit Edit Database.

Списки баз данных отображаются в следующих разделах:

Backup

Check Databases

Rebuild/Reorganize indexes

Storage->Databases

Security

Список вкладок отображается на навигационной панели.

Основные параметры базы данных

Файловые группы

Опции

Отслеживание изменений

Свойства базы данных

Назначение прав

SQL описание

Смотрите также:

Базы данных

Моментальные снимки баз данных

Использование дискового пространства

Использование пространства объектами


Панели инструментов

На панели инструментов редактора баз данных отображаются инструменты, наиболее часто используемые для работы с объектом.

Database Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.

Permissions

Инструменты для задания разрешений и прав. Этот раздел активен только при переходе на вкладку Permissions.

Principal type

Список участников базы данных (пользователей и ролей) для которых можно задать права на эту базу данных.

Permission

Из этого списка выберите права, которые необходимо задать выбранному участнику базы данных.

!CheckBox Granted or denied only

Если этот флажок установлен, то на вкладке будут отображаться только сущности, для которых были определены права или установлен запрет.


General

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Основные параметры базы данных

На вкладке General можно просматривать и изменять основные параметры базы данных.

Database Editor - Setting general options

Name - имя базы данных.

Owner - владелец базы данных - пользователь или роль.

Database files

Базы данных SQL Server содержат файлы трех типов.

  • Первичные файлы данных. Первичный файл данных является отправной точкой базы данных. Он указывает на остальные файлы базы данных. В каждой базе данных имеется один первичный файл данных. Для имени первичного файла данных рекомендуется использовать расширение MDF.
  • Вторичные файлы данных. Ко вторичным файлам данных относятся все файлы данных, за исключением первичного файла данных. Некоторые базы данных могут вообще не содержать вторичных файлов данных, тогда как другие содержат несколько вторичных файлов данных. Для имени вторичного файла данных рекомендуется использовать расширение NDF.
  • Файлы журналов.

В SQL Server расположение всех файлов базы данных записывается в первичный файл базы данных.

В списке файлов Database files отображаются файлы базы данных и информация о них:

  • Name - имя файла;
  • File Type - тип файла;
  • OS File Name - путь к файлу на сервере;
  • Filegroup - файловая группа;
  • Size (MB) - размер файла;
  • Growth - параметры прироста файла.

Эти файлы можно изменять, удалять и добавлять с помощью пунктов контекстного меню.

Свойства фалов меняются в специальном диалоговом окне, которое открывается при двойном щелчке мышкой на строку списка файлов или при выборе пункта контекстного меню Edit File.

Database Editor - Setting general options - File Properties

В поле File Name указывается логическое имя файла - имя, используемое для ссылки на физический файл во всех инструкциях Transact-SQL. Логическое имя файла должно соответствовать правилам для идентификаторов SQL Server и быть уникальным среди логических имен файлов в соответствующей базе данных.

File Type - тип файла:

!RadioButton Data - файл базы данных;

!RadioButton Filestream - файл файлового потока;

!RadioButton Memory-optimized data - файл данных, оптимизированных для памяти.

!RadioButton Log - файл журналов.

В поле OS File Name указывается физическое имя файла - это имя физического файла, включая путь к каталогу. Оно должно соответствовать правилам для имен файлов операционной системы.

В поле File Group указывается группа, к которой будет принадлежать данный файл.

Группа по умолчанию - PRIMARY. Пользователь может сам создавать группы и задавать их свойства на вкладке Файловые группы.

В поле File Size, MB указывается текущий размер каждого файла. Также текущий размер файла можно задать с помощью счетчика File size. MB, находящегося под списком файлов.

!CheckBox Allow file growth - разрешить автоматический прирост файла.

Ниже идет элемент управления, отвечающий за прирост файла. С помощью счетчика File growth указывается требуемый шаг роста. Каждый раз при заполнении файла его размер увеличивается на указанный шаг роста. Если в файловой группе имеется несколько файлов, их автоматический рост начинается лишь по заполнении всех файлов. Затем файлы увеличиваются в размерах по кольцевому списку.

!RadioButton Megabytes - шаг можно указывать в мегабайтах.

!RadioButton Percent - шаг можно указывать в процентах.

В разделе Max size можно указать максимальный размер файла, или то, что он может продолжать увеличиваться в размерах, пока не займет все доступное место на диске.

!CheckBox Unlimited

Если этот флажок установлен, то файл имеет неограниченный размер.


Файловые группы

Из объектов баз данных и файлов можно формировать файловые группы, используемые для решения задач распределения и административного управления.

Database Editor - Managing filegroups

Файловыми группами можно управлять с помощью контекстного меню.

Add Filegroup - добавить группу.

Delete Filegroup - удалить группу.

Row data filegroups

Первичные файловые группы

В первичную файловую группу входит первичный файл данных и все прочие файлы, не назначенные специально в другие файловые группы. Все страницы для системных таблиц размещаются в первичной файловой группе.

Пользовательские файловые группы

К пользовательским файловым группам относятся все файловые группы, которые создаются с помощью этого инструмента.

Файлы журналов не могут входить в состав файловых групп. Управление пространством журнала отделено от управления пространством данных.

Файл не может входить в состав нескольких файловых групп.

Filegroup Name - имя объекта.

Number of files - число файлов в группе.

Read-only - объект доступен только для чтения.

Default - файловая группа является используемой по умолчанию.

Filestream filegroups

Этот раздел доступен для серверов версии SQL Server 2008 и выше.

В этом разделе задайте файловые группы файлового потока.

Filegroup Name - имя файловой группы файлового потока.

Number of files - число файлов в группе.

Read-only - объект доступен только для чтения.

Default - файловая группа является используемой по умолчанию.

Memory-optimized data filegroups

Этот раздел доступен для серверов версии SQL Server 2014.

Задайте имя оптимизированной для памяти группы файлов в столбце Filegroup Name.

Число файлов в группе увеличивается автоматически при добавлении нового файла данных, оптимизированного для памяти на вкладке General.


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Опции

Опции базы данных можно задать на этой вкладке.

Database Editor - Editing database options

Recovery Model

Full - при ошибке носителя обеспечивается полное восстановление с помощью резервных копий журналов транзакций. Если файл данных поврежден, восстановление носителя может восстановить все зафиксированные транзакции.

Bulk-logged - после сбоя носителя обеспечивается восстановление, совмещающее наивысшую производительность и минимальное использование пространства журнала для определенных массовых (крупномасштабных) операций.

Simple - используется простая стратегия создания резервных копий, использующая минимум пространства журнала.

Collation

Из этого раскрывающегося списка необходимо выбрать правило сравнения символьных данных. Эти правила задают кодовую страницу и порядок сопоставления символьных данных для работы с данными в Юникоде и других форматах.

Compatibility level

Устанавливает поведение экземпляра сервера, соответствующее указанной версии SQL Server.

Automatic options

Auto Close

Если флажок установлен, то после отключения последнего пользователя база данных корректно закрывается, а используемые ею ресурсы освобождаются. База данных автоматически открывается снова, когда пользователь опять пытается подключиться к ней.

Если флажок не установлен, то база данных остается открытой и после отключения последнего пользователя.

Auto Create Statistics

При установке этого параметра для использованных в предикате столбцов автоматически создается статистика.

Если параметр не установлен, то статистика не создается автоматически, но ее можно создать вручную.

Create Incremental Statistics

Укажите, следует ли использовать инкремент при создании статистики для каждой секции.

Auto Shrink

Если флажок установлен, то файлы базы данных подлежат периодическому сжатию. Как файлы данных, так и файлы журналов могут быть автоматически сжаты сервером SQL Server. AUTO_SHRINK уменьшает размер журнала транзакций только в том случае, если выбрана простая модель восстановления базы данных или была создана резервная копия журнала.

Если не установлен, файлы баз данных во время периодических проверок на неиспользуемое пространство не будут сжиматься автоматически.

Auto Update Statistics

При установке параметра в ON любая отсутствующая статистика, требуемая при запросе для его оптимизации, будет автоматически создана во время оптимизации запроса.

При установке параметра в OFF статистика должна создаваться вручную.

Auto Update Statistics Asynchronously

Обеспечивает асинхронное обновление статистики. Если этот параметр установлен, то перед компиляцией запроса не происходит ожидание обновления статистики. Вместо этого устаревшая статистика ставится в очередь на обновление фоновым рабочим потоком.

Containment

Status

Если значение этого параметра Partial, то база данных является автономной. В автономных базах данных некоторые параметры, которые обычно задаются на уровне сервера, могут быть заданы на уровне базы данных.

Default Full-Text Language

Полнотекстовые запросы выполняют лингвистический поиск текстовых данных в полнотекстовых индексах, оперируя словами и фразами на основе правил конкретного языка. Из этого раскрывающегося списка выберите язык для полнотекстового поиска.

Default Language

Язык по умолчанию, который будет задан для всех новых пользователей автономной базы данных.

Nested Triggers

Разрешить триггерам вызывать срабатывание других триггеров. Управляет возможностью триггера выполнить действие, вызывающее срабатывание других триггеров. Если этот флажок не установлен, триггеры не могут срабатывать от других триггеров. Если этот флажок установлен, срабатывание триггеров может вызываться другими триггерами более чем на 32 уровнях.

Transform Noise Words

Параметр конфигурации transform noise words подавляет сообщения об ошибках, если из-за фильтрации пропускаемых слов, то есть стоп-слов, логическая операция для полнотекстового запроса не возвращает ни одной строки.

Two Digit Year Cut-off

Этот параметр cutoff предназначен для указания целого числа в диапазоне от 1753 до 9999, которое представляет граничное значение при интерпретации года, указанного двумя цифрами

Cursor options

Close Cursor on Commit

Если параметр установлен, курсоры, открываемые при фиксации или откате транзакции, закрываются.

Если не установлен, курсоры остаются открытыми, когда транзакция фиксируется; откат транзакции закрывает все курсоры, кроме курсоров, определенных как INSENSITIVE или STATIC.

Default Cursor Scope

!RadioButton LOCAL - область курсора локальна по отношению к пакету, хранимой процедуре или триггеру, в которых он был создан. Имя курсора действительно только внутри этой области.

!RadioButton GLOBAL - область курсора глобальна относительно соединения. Имя курсора может использоваться в любой хранимой процедуре или пакете, выполняемом соединением.

Database State

Database State

!RadioButton Если указано ONLINE, база данных открыта и доступна для использования.

!RadioButton Если указано OFFLINE, база данных закрывается, корректно отключается и отмечается как перешедшая в автономный режим.

!RadioButton Если указано EMERGENCY, база данных отмечается как находящаяся в режиме READ_ONLY, запись в журнал отключается, а доступ разрешен лишь для членов фиксированной серверной роли sysadmin.

Read-Only

Флажок, установив который, Вы запрещаете любое изменение данных в базе. Разрешаете только чтение и просмотр информации.

User Access

!RadioButton При указании MULTI_USER разрешается подключение всех пользователей, имеющих соответствующие разрешения.

!RadioButton При указании RESTRICTED_USER к базе данных могут подключаться лишь члены фиксированной роли базы данных db_owner и члены фиксированных серверных ролей dbcreator и sysadmin, но их количество не ограничивается.

!RadioButton Если указано SINGLE_USER, то к базе данных одновременно может быть подключен лишь один пользователь. Соединения всех остальных пользователей прекращаются.

External Access Options

Cross-Database Ownership Chaining

Если флажок установлен, то база данных может быть источником или целевой базой данных в межбазовой цепочке владения.

Если не установлен, то база данных не может участвовать в межбазовых цепочках владения.

Trustworthy

Если указано значение ON, модули базы данных (например, пользовательские функции или хранимые процедуры), использующие контекст олицетворения, могут получать доступ к ресурсам, расположенным вне базы данных.

Если указано значение OFF, контекст олицетворения не имеет доступа к ресурсам вне базы данных.

Параметр TRUSTWORTHY устанавливается в OFF при каждом присоединении базы данных.

FILESTREAM

Directory name

Имя директории, в которой будут хранится данные FILESTREAM.

Non-transactional Access Level

Укажите один из следующих параметров для нетранзакционного доступа через файловую систему к данным FILESTREAM, хранящимся в FileTables: OFF, READ_ONLY или FULL.

Service broker Options

Enable Service Broker

Включает компонент Service Broker в заданной базе данных.

Honor Broker Priority

Учитывать уровни приоритета при выполнении операций отправки сообщений.

Snapshot Isolation Level Options

Enable Snapshot Isolation

Если флажок установлен, то транзакции могут указать уровень изоляции транзакции SNAPSHOT. Если транзакция выполняется на уровне изоляции SNAPSHOT, всем инструкциям видны данные из моментального снимка в состоянии, которое существовало в момент начала транзакции.

Если не установлен, то транзакции не могут указать уровень изоляции транзакции SNAPSHOT.

Elevate Isolation to Snapshot on Memory-Optimized Tables

Если флажок установлен, то минимальный уровень изоляции для доступа к оптимизированным для памяти таблицам - SNAPSHOT. В противном случае, уровень изоляции не повышается.

Read-Commited Snapshot

Если флажок установлен, то транзакции, указывающие уровень изоляции READ_COMMITTED, используют управление версиями строк вместо блокировки. Если транзакция выполняется на уровне изоляции READ_COMMITTED, всем инструкциям видны данные из моментального снимка в том состоянии, которое существовало на момент начала выполнения инструкции.

Если не установлен, то транзакции с уровнем изоляции READ_COMMITTED используют блокировку.

SQL Options

ANSI NULL Default

Определяет значение по умолчанию, NULL или NOT NULL, для столбцов, типа данных alias или пользовательского типа CLR, для которых в инструкциях CREATE TABLE или ALTER TABLE не было явно указано, могут ли они содержать NULL.

Если флажок установлен, то значением по умолчанию является NULL.

Если нет, то значением по умолчанию является NOT NULL.

ANSI Nulls

Если флажок установлен, то все сравнения со значением NULL выдают результат UNKNOWN.

Если нет, то при сравнении значений не в Юникоде со значением NULL выдается результат TRUE, если оба значения равны NULL.

ANSI Padding

Если флажок установлен, то конечные пробелы в символьных значениях, вставляемых в столбцы varchar или nvarchar, и конечные нули в двоичных значениях, вставляемых в столбцы varbinary, не отбрасываются. Значения не подгоняются под длину столбца. Столбцы типа char и binary, допускающие значения NULL, подгоняются по длине столбца.

Если не установлен, то конечные пробелы (в столбцах varchar или nvarchar) и нули (в столбцах varbinary) отбрасываются. Эти параметры влияют только на определение вновь создаваемых столбцов. В столбцах типа char и binary конечные пробелы и нули отбрасываются.

Столбцы типа char и binary, допускающие значения NULL, всегда подгоняются по длине столбца.

ANSI Warnings

Если флажок установлен, то при возникновении таких состояний, как деление на ноль или появление значений NULL в статистических функциях, создается предупреждение или сообщение об ошибке.

Если не установлен, то предупреждения не создаются, а при возникновении таких состояний, как деление на ноль, возвращаются значения NULL.

Arithmetic Abort

Если флажок установлен, то при возникновении переполнения или деления на ноль во время выполнения запроса запрос завершается.

Если не установлен, то выводится предупреждающее сообщение о возникшей ошибке, но запрос, пакет или транзакция продолжают выполняться, как будто ошибка не происходила.

Concatenate Null Yields Null

Если флажок установлен, то операция сцепления выдает результат NULL, если любой из операндов имеет значение NULL.

Если не установлен, то значение NULL обрабатывается как пустая символьная строка.

Numeric Round-Abort

Когда флажок установлен, то если при расчете выражения происходит потеря точности, возникает ошибка.

Если не установлен, потеря точности не приводит к возникновению сообщения об ошибке, а результат округляется с точностью столбца или переменной, в которых сохраняется результат.

Quoted Identifiers

Если флажок установлен, то можно использовать двойные кавычки при выделении идентификаторов с разделителями.

Если нет, то идентификаторы нельзя заключать в кавычки, и они должны соответствовать всем правилам Transact-SQL для идентификаторов.

Recursive Triggers

Если флажок установлен, то допустимо рекурсивное срабатывание триггеров AFTER.

Если не установлен, то только прямое рекурсивное срабатывание триггеров AFTER запрещено.

Miscellaneous Options

Date Correlation Optimization

Если флажок установлен, то SQL Server поддерживает статистику корреляции между любыми двумя таблицами в базе данных, связанными ограничением FOREIGN KEY и содержащими столбцы типа datetime.

Если не установлен, то статистика корреляции не поддерживается.

Database Encryption

Включите опцию для использования шифрования. Шифрование базы данных происходит при ее сохранении на диск. Перед работой с базой производится ее дешифровка.

Важно: Эта опция доступна только для баз данных сервера SQL Server 2008.

Delayed durability

Этот параметр контролирует, должны ли транзации быть полностью устойчивыми или отложенными устойчивыми. Когда значение параметра DISABLED, все транзакции будут полностью устойчивыми. Если значение параметра ALLOWED, то транзакции могут быть как полностью устойчивыми, так и отложенными устойчивыми, в зависимости от значения опции durability, заданной в атомарном блоке или операторе commit. Если значение параметра FORCED, то все транзакции являются отложенными устойчивыми.

Enable Change Data Capture

Включить отслеживание измененных данных. Система отслеживания измененных данных регистрирует действия по вставке, обновлению и удалению, применяемые к таблицам, сохраняя подробности операций изменения в легко обрабатываемом реляционном формате.

Page Verify

!RadioButton CHECKSUM - компонент Database Engine рассчитывает контрольную сумму для содержимого страницы в целом и сохраняет значение в заголовке страницы при записи страницы на диск. При чтении страницы с диска контрольная сумма вычисляется повторно и сравнивается с сохраненным в заголовке страницы значением.

!RadioButton TORN_PAGE_DETECTION - для каждого 512-байтового сектора из 8-килобайтовой (КБ) страницы базы данных в заголовке страницы устанавливается один бит, который будет сохранен при записи страницы на диск. При чтении страницы с диска биты разрыва, хранимые в заголовке страницы, сравниваются с действительными сведениями о секторах страницы.

!RadioButton NONE - для страницы базы данных не будет создаваться ни значение CHECKSUM, ни TORN_PAGE_DETECTION. SQL Server не будет проверять страницу на разрыв или совпадение контрольной суммы, даже если соответствующие данные CHECKSUM или TORN_PAGE_DETECTION присутствуют в заголовке страницы.

Parameterization

!RadioButton Simple parameterization (SIMPLE) - параметризация запросов основывается на поведении базы данных по умолчанию.

!RadioButton Forced parameterization (FORCED) - SQL Server выполняет параметризацию всех запросов в базе данных.

Target Recovery Time, sec

Укажите максимальное время (в секундах), для восстановления определенной базы данных в случае сбоя.


Отслеживание изменений

На этой вкладке можно задать необходимые настройки отслеживания изменения сервера - Change tracking.

Database Editor - Configuring change tracking

!CheckBox Change tracking enabled

Установите этот флажок, чтобы включить возможность отслеживания изменений.

Retention period

С помощью этих элементов управления задайте минимальный период хранения данных об изменениях, внесенных в базу данных.

Период, установленный по умолчанию, составляет 2 дня. Минимальный допустимый период - 1 минута.

Данные об изменениях по истечению минимального периода их хранения удаляются только в том случае, если установлен флажок !CheckBox Automatically cleanup change tracking information after retention period.


Свойства базы данных

На этой вкладке отображается дополнительная информация о базе данных.

Database Editor - Viewing database properties

Database size

В этом разделе отображается информация о пространстве на жестком диске, занимаемом различными частями выбранной базы данных.

Total Size - общий размер.

Total Data Space - общий размер данных.

Total Transaction Log Space - общий размер журнала транзакций.

Backups

В этом разделе отображается информация о резервных копиях базы данных.

Last Full Backup Date - дата последнего создания полной резервной копии.

Last Differential Backup Date - дата последнего создания резервной копии внесенных изменений.

Last Transaction Log Backup Date - дата последнего создания резервной копии журнала транзакций.

Miscellaneous

Дополнительная информация по базе данных.

Date Created - дата создания.

Number of Users - число пользователей.

Service Broker GUID - уникальный идентификатор брокера ресурсов.

С помощью пункта Copy Focused Row Value to Clipboard контекстного меню можно скопировать значение выбранной ячейки в буфер обмена.


Назначение прав

На этой вкладке можно задать права пользователей на изменение базы данных.

Database Editor - Setting permissions

Двойным щелчком мыши в поле ALTER можно разрешить пользователю вносить изменения в выбранную базу.

Principal name

Список участников базы данных (пользователей и ролей). Двойным щелчком на имени участника базы данных открывается соответствующий редактор - Редактор ролей или редактор пользователей.

Задать разрешение на внесение изменений в таблицу можно с помощью контекстного меню поля действия, элементов управления на навигационной панели, или двойным щелчком в поле действия.

Действие для задания прав можно выбрать из раскрывающегося списка Permission на навигационной панели.

Grant Grant - предоставить права на выполнение данного действия.

GrantWithGrantOPtions Grant with GRANT OPTION - предоставить с правами 'GRANT'.

Revoke Revoke - аннулировать все ранее заданные права.

Deny Deny - запретить выполнение данного действия.

  • Grant to all principal - предоставить права на выполнение данного действия всем участникам.
  • Grant with Grant Option to all principal - предоставить с правами 'GRANT' всем участникам.
  • Revoke from All Principals - аннулировать все ранее заданные права для всех участников.
  • Deny to All Principals - запретить выполнение данного действия всем участникам.
  • Effective Permissions - просмотреть действующие разрешения выбранного участника базы данных.

Database Editor - Setting effective permissions

В открывшемся окне отображаются все эффективные разрешения.

Эффективные разрешения - это сумма всех этих явно и неявно заданных разрешений участника базы данных на выбранную привилегию базы.

Permission - разрешение;

Grantee Securable - объект, на который выданы права;

Grantee Principal - участник, которому выдали права.

Пользователь может входить в группы, которые имеют разрешения на привилегию или могут иметь разрешение на какую-то другую привилегию, которая перекрывает выбранную.


SQL описание

На этой вкладке можно просматривать DDL выбранной базы данных.

Database Editor - Viewing SQL Definition


Базы данных

На вкладке Databases отображается список баз данных, с которыми можно производить различные действия по управлению и обслуживанию.

Действия, выполняемые с базами данных:

Create Create database (клавиша 'Insert') - создать базу данных;

Edit Edit selected database(s) (клавиша 'Enter') - изменить выбранную базу или базы;

Drop Drop selected database(s) (клавиша 'Delete') - удалить выбранную базу или базы;

  • Rename selected database - Переименовать выбранную базу или базы;
  • Сlone - создать копию объекта на сервере;
  • Clone To - создать копию объекта на другом сервере;
  • Tasks - Выполнить одно из действий по обслуживанию базы данных:

backup database - создать резервную копию базы данных;

restore database - восстановить базу данных из резервной копии;

recover without restoring - выполнить только восстановление;

AttachDatabase attach database - присоединить базу данных;

DetachDatabase detach database - отсоединить базу данных;

CheckDatabase check database - проверить базу данных;

RebuildIndexes rebuild/reorganize indexes - перестроить и реорганизовать индексы;

shrink database - сжать базу данных.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Storage - Databases

Базы данных отображаются в виде таблицы со следующими столбцами:

Name - имя базы данных;

State - состояние;

Owner - владелец;

Recovery Model - модель восстановления;

Collation - правило сравнения символьных данных;

Compatibility Level - уровень совместимости;

Creation Date - дата создания.

При необходимости могут быть добавлены дополнительные столбцы, которые соответствуют следующим свойствам баз данных: ANSI Null Default, ANSI Nulls, ANSI Padding, ANSI Warnings, Arithmetic Abort, Auto Close, Auto Create Statistics, Auto Shrink, Auto Update Statistics, Auto Update Statistics Asynchronously, Change Data Capture Enabled, Close Cursor on Commit, Concatenate Null Yields Null, Cross-Database Ownership Changing, Date Correlation Optimization, Default Local Cursor, Distributor, Encrypted, Encrypted Master Key, Forced Parameterization, Fulltext Enabled, In Standby Mode, Is Cleanly Shut Down, Merge Published, Numeric Round-Abort, Page Verify, Published, Quoted Identifiers, Read Committed Snapshot, Read-Only, Recursive Triggers, Reuse Log Space Waiting For, Service Broker Enabled, Service Broker GUID, Service Broker Priority Honored, Snapshot Isolation State, Subscribed, Synchronization with Backup, Trustworthy, User Access.

Порядок столбцов можно менять, перетаскивая их с места на место.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Чтобы открыть базу данных в редакторе, можно дважды щелкнуть мышкой на названии базы данных в таблице.

Смотрите также:

Редактор баз данных

Моментальные снимки баз данных

Использование дискового пространства

Использование пространства объектами


Моментальные снимки баз данных

Database snapshot - статическое, доступное только для чтения представление базы данных на момент создания снимка. Моментальные снимки доступны в редакциях Enterprise Edition версий Microsoft SQL Server 2005 и выше.

Моментальный снимок базы данных соответствует базе данных-источнику на уровне транзакций в том виде, в котором она существовала в момент создания моментального снимка. База данных-источник может иметь несколько моментальных снимков. Моментальные снимки используются для восстановления базы данных.

Операция возврата базы данных (задаваемая при помощи моментальных снимков) переносит всю исходную базу данных назад во времени, возвращая ее к моментальному снимку базы данных, т.е. заменяя исходную базу данных указанным моментальным снимком. В данный момент может существовать только снимок, к которому производится возврат. Затем операция возврата вновь создает журнал (поэтому впоследствии нельзя будет выполнить накат возвращенной базы данных к точке пользовательской ошибки).

Важно: База данных-источник должна находиться в состоянии 'online'.

Для управления списком серверов используется контекстное меню.

Create Create Database Snapshot - создать моментальный снимок базы данных;

Edit Edit Database Snapshot - изменить моментальный снимок базы данных;

Drop Drop Database Snapshot - удалить моментальный снимок базы данных;

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью;

  • Source Database properties - просмотреть и изменить свойства исходной базы данных;
  • Revert Database to Snapshot - вернуть базу данных к состоянию снимка с помощью Мастера восстановления баз данных.

Storage - Database snapshots

Список моментальных снимков базы данных отображается в виде таблицы со следующими столбцами:

Name - имя снимка;

Source Database - база данных, с которой сделан снимок;

Snapshot Owner - владелец снимка;

Snapshot Size (MB) - размер снимка;

Database Size (MB) - размер базы данных;

Size (%) - процентное соотношение размера снимка к размеру базы данных.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Чтобы открыть моментальный снимок в соответствующем редакторе, необходимо дважды щелкнуть по нему мышкой или в контекстном меню выбрать пункт Edit Database Snapshot.

Также, для управления объектами можно использовать сочетания клавиш. Создать - 'Insert', редактировать - 'Enter' удалить - 'Delete'.

Смотрите также:

Редактор баз данных

Базы данных

Использование дискового пространства

Использование пространства объектами


Панели инструментов

На панели инструментов редактора моментальных снимков отображаются инструменты, наиболее часто используемые для работы с объектом.

Database snapshots editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Редактор моментального снимка

Диалоговое окно New Database Snapshot открывается автоматически при создании моментального снимка базы данных.

Database snapshots editor - Creating database snapshot

Source database

Из этого раскрывающегося списка выберите базу данных, для которой необходимо сделать моментальный снимок.

Snapshot name

По умолчанию имя моментального снимка базы данных генерируется автоматически с учетом имени базы и даты создания снимка. Важно: Имя каждого моментального снимка должно быть уникальным.

В списке Files отображается список файлов нового моментального снимка базы данных. В поле Operating-System File Name отображается имя файла исходной базы данных и дата создания моментального снимка. С помощью кнопки Apply можно изменить расположение этого файла.

Для редактирования моментальный снимок не доступен. У существующего снимка можно только просматривать свойства и SQL описание.

Database snapshots editor - Editing database snapshot

Параметры, отображаемые для существующего моментального снимка.

In-Snapshot Size (MB) - размер моментального снимка базы данных.

In-DB Size(MB) - размер базы данных.

SQL definition


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Database snapshots editor - Viewing SQL Definition


Использование дискового пространства

В разделе проводника Disk Space Usage отображается объем дискового пространства, занятый базами данных, данными и журналами.

Контекстное меню

Backup Database - создать резервную копию базы данных.

Shrink database - сжать базу данных.

Edit Database Properties - просмотреть свойства базы данных.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Нажмите кнопку Bottom Panel на панели навигации (или используйте кнопки LargestDatabases / Files), чтобы определить, какую информацию следует отображать в нижней части окна: LargestDatabases Largest Databases (самые большие базы данных) или Files Files (файлы базы данных).

Storage - Disk space usage

В верхней части отображаются базы данных. Для каждой базы данных предоставляется следующая информация о файлах:

Database:

Database Name - имя базы данных;

Database ID - идентификатор базы данных;;

Data/Log - информация о файлах данных/журналов:

Disk Free Space (MB) - свободное место на диске;

Size (MB) - размер файла;

Unallocated Space (MB) - нераспределенное место;

Auto Growth - разрешен ли автоматический прирост файла;

Growth (MB/Month) - параметры прироста файла;

Max Size (MB) - максимальный размер файла;

No Space Warned On - предполагаемая дата, когда закончится пространство для данных в файле базы/журнале.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

В нижней части отображается информация либо о файлах выбранной базы данных, либо о месте занимаемом на диске большими базами данных. Диаграммы строятся на основе информации о размере журналов и самих данных.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Редактор баз данных

Базы данных

Моментальные снимки баз данных

Использование пространства объектами


Использование пространства объектами

В разделе проводника Space Usage by Objects отображается список объектов выбранной базы данных, а также информация о том, сколько места они занимают на диске.

Для просмотра ролей приложения необходимо выбрать базу из раскрывающегося списка Database на панели инструментов

Storage - Space usage by objects

Объекты базы данных отображаются в виде таблицы со следующими столбцами:

Object Name - имя объекта;

Schema - схема, которой принадлежит объект;

Object Type - тип объекта;

System - является ли объект системным;

Number of Records - количество записей;

Reserved (KB) - зарезервированное пространство;

Data (KB) - пространство, занимаемое данными;

Indexes (KB) - пространство, занимаемое индексами;

Unused (KB) - неиспользуемое место.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Используйте пункт ShowNonSystemObjectsOnly Non-system only контекстного меню или соответствующую кнопку на панели инструментов, чтобы отображать только несистемные объекты.

С помощью пункта контекстного меню Print Print Вы можете создать отчет и открыть окно предварительного просмотра перед печатью.

При нажатии на кнопку '+' в начале записи раскроется список индексов в виде таблицы со следующими столбцами:

Index Name - имя индекса;

Partition - идентификатор секции;

Number of Records - количество записей в таблице;

Total Reserved (KB) - общий объем страниц, зарезервированных в секции;

Total Used (KB) - общий объем страниц, используемых в секции;

In-Row Data Reserved (KB) - общий объем страниц, зарезервированных для хранения и управления данными в данной секции;

In-Row Data Used (KB) - объем страниц, используемых для хранения и управления данными, содержащимися в строках данной секции;

Leaf Level of In-Row Data - конечный уровень данных в строке;

LOB Data Reserved (KB) - общий объем страниц, зарезервированных для хранения и управления данными типа text, ntext, image, varchar(max), nvarchar(max), varbinary(max) и xml, хранящимися вне строк секции;

LOB Data Used (KB) - объем страниц, используемых для хранения и управления данными типа text, ntext, image, varchar(max), nvarchar(max), varbinary(max) и xml, хранящимися вне строк секции;

Row Overflow Data Reserved (KB) - общий объем страниц, зарезервированных для хранения и управления данными типа varchar, nvarchar, varbinary и sql_variant, хранящимися вне строк секции;

Row Overflow Data Used (KB) - объем страниц, используемых для хранения и управления данными типа varchar, nvarchar, varbinary и sql_variant, хранящимися вне строк секции;

Internal Table - внутренняя таблица.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Редактор баз данных

Базы данных

Моментальные снимки баз данных

Использование дискового пространства


Безопасность

В разделе проводника Security можно управлять правами и участниками (principals) уровня сервера и базы данных.

Участники (Principals) — сущности, которые могут запрашивать ресурсы SQL Server. Как и другие компоненты модели авторизации SQL Server, участников можно иерархически упорядочить. Область влияния участника зависит от области его определения: Windows, сервер, база данных, — а также от того, коллективный это участник или индивидуальный. Имя входа Windows является примером индивидуального (неделимого) участника, а группа Windows — коллективного. Каждый из участников имеет идентификатор безопасности (SID).

  • Логины
  • Пользователи баз данных
  • Роли баз данных
  • Роли приложения
  • Роли сервера
  • Разрешения сервера
  • Разрешения базы данных

Server Security Options

В этой области отображаются значения некоторых параметров, определяющих безопасность сервера.

Server authentication - режим аутентификации на сервере;

Cross-database ownership changing - межбазовые цепочки владения для экземпляра Microsoft SQL Server;

Ad hoc distributed queries - выполнение нерегламентированных распределенных запросов;

CLR integration - выполнение пользовательских сборок на SQL Server;

Remote dedicated administrator connection (DAC) - удаленное выделенное административное соединение;

Database Mail - компонент Database Mail, с помощью которого приложения базы данных могут отправлять почтовые сообщения пользователям;

OLE Automation objects - объекты OLE-автоматизации;

xp_cmdshell - расширенная хранимая процедура xp_cmdshell, которая увеличивает число процессов командного ядра Windows в строке для выполнения;

SQL Mail - служба SQL Mail, которая обеспечивает механизм отправки, получения и обработки сообщений электронной почты.

Контекстное меню области позволяет открыть диалоговое окно Server Properties, где вы можете просмотреть и настроить параметры сервера.

Database Security Options

В этой области отображается список баз данных с некоторыми параметрами безопасности.

Database - имя базы данных;

DB Changing - включена ли возможность отслеживания изменений;

Trust Worthy - доверяет ли экземпляр SQL Server базе данных и ее содержимому;

Guest Enabled - активна ли учетная запись пользователя 'guest'.

С помощью контекстного меню можно открыть диалоговое окно для просмотра и редактирования свойств базы - Edit Database.

System Administrators

В этой области отображается список существующих логинов, принадлежащих серверной роли System Administrator.

Login Name - имя логина;

Login Type - тип логина (способ подключения к серверу SQL);

Disabled - показывает, разрешен ли логин;

Denied - показывает, запрещены ли любые подключения к серверу для входа в систему;

Locked -показывает, заблокирован ли логин;

Credential - имя учетных данных для сопоставления с именем входа SQL Server.

Контекстное меню

Create Create Login - создать логин;

Edit Edit Login - изменить логин;

Drop Drop Login - удалить логин;

  • Rename Login - переименовать логин;
  • Enable/Disable login - включить/отключить;
  • Grant/Deny login(s) - задать права или запретить выполнение;
  • Unlock login(s) - разблокировать логины.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Агент SQL сервера

Производительность

Журнал сервера

Запросы

Опции


Логины

Логин - объект, который представляет собой идентификатор пользователя или процесса, выполняющего соединение с экземпляром SQL Server.

Пользователю в базе данных может соответствовать только один логин.

Для сервера Microsoft® SQL Server™ используется два способа проверки для подключения к базам данных.

Windows Authentication для аутентификации на сервере используется доменное имя и пароль. SQL Server authentication - персональные имя и пароль логина на сервере.

Security - Logins

Логины отображаются в виде таблицы со следующими столбцами:

Name - имя логина;

Login type - тип логина (способ подключения к серверу SQL);

Enabled - показывает, разрешен ли логин;

Denied - показывает, запрещены ли любые подключения к серверу для входа в систему;

Locked - показывает, заблокирован ли логин;

Sysadmin - принадлежит ли логин к фиксированной роли 'sysadmin';

Password Policy - применяется ли политика паролей Windows к данному имени входа;

Password Expiration - применяется ли к данному имени входа политика истечения срока действия паролей;

Credential - имя учетных данных для сопоставления с именем входа SQL Server;

Certificate - имя сертификата, связываемого с данным именем входа;

Asymmetric Key - имя асимметричного ключа, связываемого с данным именем входа.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Контекстное меню

Create Create Login - создать логин.

Edit Edit Login - изменить логин.

Drop Drop Login - удалить логин.

  • Rename Login - переименовать логин.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.
  • Enable/Disable login - включить/отключить
  • Grant/Deny login(s) - задать права или запретить выполнение.
  • Unlock login(s) - разблокировать логины.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Смотрите также:

Пользователи баз данных

Роли баз данных

Роли приложения

Роли сервера

Разрешения сервера

Разрешения базы данных


Редактор логинов

Редактор логинов предназначен для задания необходимых для работы параметров логина. Этот редактор открывается автоматически при создании или изменении объекта.

Чтобы открыть объект в редакторе необходимо на вкладке Logins дважды щелкнуть на нужном логине мышкой. Также для создания и редактирования логинов можно использовать пункты контекстного меню Create Login и Edit Login соответственно.

Панели инструментов

Вкладки редактора:

Свойства логина

Серверные роли

Сопоставление пользователей и логинов

Разрешения

SQL описание


Панели инструментов

На панели инструментов редактора логинов отображаются инструменты, наиболее часто используемые для работы с объектом.

Login Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.

Permissions

Securable Type

Из этого раскрывающегося списка необходимо выбрать отображаемый защищаемый тип: Server, Login or Endpoint.

!CheckBox Granted or denied only

Если этот флажок установлен, то на вкладке будут отображаться только сущности, для которых были определены права или установлен запрет.


Свойства

На вкладке Properties можно задать основные параметры логина.

Login Editor - Setting login properties

Name

В этом поле необходимо ввести имя нового логина.

!CheckBox Если установлен флажок Enable, то логин включен.

!CheckBox Denied connection to database engine

Выберите эту опцию, чтобы запретить любые подключения к серверу для входа в систему.

Для редактируемого логина необходимо выбрать способ подключения к серверу SQL.

!RadioButton Windows login

!RadioButton SQL Server login

!RadioButton Login mapped to certificate

!RadioButton Login mapped to asymmetric key

!RadioButton Windows login

При аутентификации Windows клиент идентифицируется по его учетной записи в ОС Windows.

!RadioButton SQL Server login

Программа распознает пользователя по его персональным имени и паролю на сервере.

По имени и паролю система определяет ваши права доступа к информации и, в соответствии с этим, разрешает доступ к объектам.

  • пароль - в поле Password,
  • подтверждение пароля - Confirm password.

Credential name

Из этого раскрывающегося списка необходимо выбрать имя учетных данных для сопоставления с новым именем входа SQL Server. Учетные данные уже должны существовать на сервере.

!CheckBox Enforce Windows password policies to login

Если установлен этот флажок, то политика паролей Windows на компьютере, где выполняется SQL Server, должна быть принудительно применена к данному имени входа.

!CheckBox Enforce password expiration policy to login

Если установлен этот флажок, то надо принудительно применять к данному имени входа политику истечения срока действия паролей.

!CheckBox User must change password next logon

Выберите эту опцию, чтобы заставить пользователя сменить пароль при следующем входе в систему.

!RadioButton Login mapped to certificate - установить соответствие с сертификатом.

Certificate name - имя сертификата, связываемого с данным именем входа.

!RadioButton Login mapped to asymmetric key - установить соответствие с асимметричным ключом.

Asymmetric key name - имя асимметричного ключа, связываемого с данным именем входа.

В разделе Default parameters Вы можете указать параметры, которые будут использоваться по умолчанию для имени входа Microsoft SQL Server.

  • Default Database - база данных по умолчанию,
  • Default Language - локализация по умолчанию.


Серверные роли

На вкладке Server Roles укажите принадлежность логина к серверным ролям. Выбранные серверные роли определяют, какие операции могут выполняться под данным именем входа.

Login Editor - Assigning server roles

Чтобы указать серверную роль, выберите ее в списке и поставьте галку в соответствующей строке в колонке Selected.


Сопоставление пользователей и логинов

На вкладке User Mapping Вы можете указать соответствие редактируемого логина пользователям баз данных, располагающихся на выбранном сервере.

Login Editor - User mapping

Установите флажок в колонке Map User рядом с именем базы данных, затем введите имя пользователя в колонке User Name и выберите схему базы данных по умолчанию (Default Schema) с помощью выпадающего списка.

Guest account enabled - показывает, разрешен ли доступ к базе данных пользователю Guest.

При необходимости, для каждого пользователя можно выбрать роли базы данных в таблице Role membership, установив флажок в столбце Selected.


Разрешения

В разделе Permissions можно задать права на выполнение операций сервера (Server), разрешения на имена входа (Login), серверные роли (Server Roles) и на конечные точки (Endpoint).

Эта вкладка доступна только при редактировании существующего логина.

Login Editor - Setting server permissions

Более подробную информацию о том, как задавать права для имен входа, Вы найдете в разделе Разрешения сервера.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Login Editor - Viewing SQL definition


Пользователи баз данных

Пользователь базы данных (User) - это главный элемент, обеспечивающий контроль доступа к элементам базы данных. Пользователь определяется единственным логином, видимым в пределах той базы данных, в которой он был объявлен.

Пользователи создаются для логинов, не являющихся участниками административных ролей. Позволяют регулировать права доступа к объектам базы данных. Права доступа к базе данных определяются для логина в редакторе логинов. Права доступа к объектам базы данных указываются для пользователя в редакторе пользователей. Для каждого логина можно создавать только одного пользователя.

Чтобы посмотреть пользователей базы данных, выберите базу из списка Database на панели управления.

Security - Database users

Пользователи базы данных отображаются в виде таблицы со следующими столбцами:

Name - имя пользователя;

User type - тип;

Orphaned - является ли пользователь изолированным;

Can Connect - может ли подключаться к базе данных;

DB Owner - является ли владельцем базы данных;

Sysadmin - является ли членом предопределенной роли сервера sysadmin;

Login - логин, для которого создан пользователь;

Certificate - сертификат, для которого создан пользователь;

Asymmetric Key - асимметричный ключ, для которого создан пользователь;

Default Schema - схема по умолчанию.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Контекстное меню:

Create Create User - создать пользователя.

Edit Edit User - изменить пользователя.

Drop Drop User - удалить пользователя.

  • Rename - переименовать пользователя.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Смотрите также:

Логины

Роли баз данных

Роли приложения

Роли сервера

Разрешения сервера

Разрешения базы данных


Редактор пользователей баз данных

В редакторе пользователей можно создавать и редактировать пользователей и задавать для них разрешения .

Чтобы открыть объект в редакторе пользователей достаточно щелкнуть по нему два раза мышкой в разделе Пользователи баз данных или выбрать там же пункт контекстного меню Edit User.

Инструменты редактора располагаются на вкладках и панелях инструментов.

Вкладки редактора:

Свойства

Описание

Разрешения на пользователя

Разрешения пользователя

SQL описание


Панели инструментов

На панели инструментов редактора пользователей отображаются инструменты, наиболее часто используемые для работы с объектом.

User Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.

Permissions

Securable Type

Из этого раскрывающегося списка необходимо выбрать тип защищаемого объекта.

!CheckBox Granted or denied only

Если этот флажок установлен, то на вкладке будут отображаться только сущности, для которых были определены права или установлен запрет.

!CheckBox Non-system objects only

Выберите эту опцию для отображения только несистемных объектов в списке защищаемых объектов.


Свойства

На этой вкладке необходимо задать основные параметры пользователя и его принадлежность серверным ролям.

User Editor - Setting database user properties

В поле Name укажите имя пользователя.

!RadioButton Login

Выберите из раскрывающегося списка логин, для которого создаете пользователя.

!RadioButton Certificate

Сертификат, для которого создается пользователь базы данных.

!RadioButton Asymmetric key

Асимметричный ключ, для которого создается пользователь базы данных.

!RadioButton Without login

Указывает, что пользователь не должен сопоставляться с существующим именем входа.

Default schema

Указывает первую схему, которую найдет сервер, после того, как он получит имена объектов для пользователя данной базы данных.

В разделе Member Of укажите принадлежность редактируемого пользователя к серверным ролям. С помощью кнопок переносите их из списка доступных ролей - Available Roles, в список выбранных ролей - Selected Roles. Роли, доступные для выбора - это серверные роли, а также роли, созданные пользователем.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к объекту, то Вы можете его создать (изменить) на вкладке Description.

User Editor - Setting description

Внесенные изменения вступят в силу только при переходе на другую вкладку, при выборе другого объекта или при нажатии кнопки Apply на панели инструментов.


Разрешения на пользователя

На этой вкладке Вы можете предоставить разрешения другим пользователям и ролям на редактируемого пользователя.

Эта вкладка доступна только при редактировании существующего пользователя.

На панели инструментов выберите тип участника базы данных в списке Principal type.

User Editor - Setting permissions on user

В столбце Principal Name отображается список пользователей, ролей баз данных и ролей приложения.

Остальные столбцы соответствуют разрешениям, которые могут быть предоставлены на редактируемого пользователя:

  • Alter
  • Control
  • Impersonate
  • View definition

Подробнее о том, как предоставлять разрешения, смотрите на вкладке Разрешения базы данных.


Разрешения пользователя

На вкладке Permissions Вы можете указать разрешения для пользователя.

Эта вкладка доступна только при редактировании существующего пользователя.

На панели навигации выберите тип защищаемого объекта (Securable type). Список объектов выбранного типа будет отображаться в главном окне.

User Editor - Setting permissions

В столбце Securable Name (Permission для разрешений баз данных) перечислен список объектов (действий). В остальных столбцах - разрешения, которые могут быть выданы на выбранный объект:

State (для разрешений баз данных);

Select, Insert, Update, Delete, References, Alter, Control, Take ownership, View definition, View change tracking (для таблиц);

Select, Insert, Update, Delete, References, Alter, Control, Take ownership, View definition (для представлений, возвращающих табличное значение встроенных функций);

Execute, Alter, Control, Take ownership, View definition (для процедур, расширенных процедур);

Select, References, Alter, Control, Take ownership, View definition (для функций, возвращающих табличное значение);

Execute, References, Alter, Control, Take ownership, View definition (для скалярных функций, агрегатных функций, коллекций XML-схем);

Select, Insert, Update, Delete, Execute, Control, Take ownership, View definition (для синонимов);

Execute, References, Control, Take ownership, View definition (для типов данных);

Select, Insert, Update, Delete, Execute, References, Alter, Control, Take ownership, View definition (для схем);

Alter, Control, Take ownership, View definition (для ролей, маршрутов, привязок удаленных служб);

Alter, Control, Impersonate, View definition (для пользователей);

Alter, Control, View definition (для ролей приложения);

References, Alter, Control, Take ownership, View definition (для сборок, полнотекстовых каталогов, сертификатов, асимметричных ключей, симметричных ключей, типов сообщений, контрактов);

Select, Receive, References, Alter, Control, Take ownership, View definition (для очередей);

Send, Alter, Control, Take ownership, View definition (для служб).

Подробнее о том, как предоставлять разрешения, смотрите на вкладке Разрешения базы данных.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

User Editor - Viewing SQL definition


Роли баз данных

Роль базы данных (Database Role) - это совокупность пользователей и групп, обладающих идентичными правами доступа. Это сущности, защищаемые на уровне базы данных. После создания роли необходимо настроить для нее разрешения уровня базы данных. Пользователь может принадлежать к нескольким группам и иметь несколько ролей. Свойства каждой роли определяют возможности пользователя по работе с объектами баз данных.

Чтобы посмотреть роли базы данных, выберите базу из списка Database на панели управления.

Контекстное меню

Create Create Role ('Insert') - создать роль.

Edit Edit Role ('Enter') - редактировать роль.

Drop Drop Role ('Delete') - удалить роль.

  • Rename - переименовать роль.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Security - Database roles

Роли базы данных отображаются в виде таблицы со следующими столбцами:

Name - имя роли;

Owner - владелец роли;

DB Owner - владелец базы данных

Fixed Role - является ли роль предопределенной (фиксированной);

Created - дата создания роли;

Modified - дата последнего изменения роли;

Number of Assigned Roles - количество назначенных ролей;

Number of Members - количество участников.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Смотрите также:

Логины

Пользователи баз данных

Роли приложения

Роли сервера

Разрешения сервера

Разрешения базы данных


Редактор ролей баз данных

В редакторе ролей можно создавать и редактировать роли и задавать для них разрешения.

Чтобы открыть объект в редакторе ролей достаточно щелкнуть по нему два раза мышкой в разделе Роли баз данных или выбрать там же пункт контекстного меню Edit Role.

Инструменты редактора располагаются на вкладках и панелях инструментов.

Вкладки редактора:

Свойства

Задание принадлежности роли

Описание

Разрешения на роль

Разрешения роли

SQL описание


Панели инструментов

На панели инструментов редактора пользователей отображаются инструменты, наиболее часто используемые для работы с объектом.

Database role Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.

Permissions

Securable Type

Из этого раскрывающегося списка необходимо выбрать тип защищаемого объекта.

!CheckBox Granted or denied only

Если этот флажок установлен, то на вкладке будут отображаться только сущности, для которых были определены права или установлен запрет.

!CheckBox Non-system objects only

Выберите эту опцию для отображения только несистемных объектов в списке защищаемых объектов.


Свойства

На вкладке Properties необходимо задать основные параметры роли и выбрать пользователей, которые станут ее владельцами.

Database role Editor - Setting database role properties

В поле Name укажите имя создаваемой (редактируемой) роли.

Из списка Owner выберите владельца роли (пользователя, роль базы данных или роль приложения).

Members of the role

Выберите участников (пользователя или роль приложения), которые станут владельцами новой роли (они будут наследовать все разрешения роли). Из списка всех доступных участников - Available Principals - выберите участника и с помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перенесите его в список выбранных - Selected Principals.


Задание принадлежности роли

На вкладке Member of roles укажите принадлежность редактируемой роли к другим ролям базы данных. Выбранные роли определяют набор задач, которые смогут выполнять члены редактируемой роли.

Database role Editor - Defining role membership

С помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перенесите роль из списка доступных ролей - Available Roles, в список выбранных ролей - Selected Roles.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к объекту, то Вы можете его создать (изменить) на вкладке Description.

Database role Editor - Editing description

Внесенные изменения вступят в силу только при переходе на другую вкладку, при выборе другого объекта или при нажатии кнопки Apply на панели инструментов.


Разрешения на роль

На этой вкладке Вы можете предоставить разрешения другим пользователям и ролям на редактируемую роль.

Эта вкладка доступна только при редактировании существующей роли.

На панели инструментов выберите тип участника базы данных в списке Principal type.

Application role Editor - Setting permissions on role

В столбце Principal Name отображается список пользователей, ролей баз данных и ролей приложения.

Остальные столбцы соответствуют разрешениям, которые могут быть предоставлены на редактируемую роль:

  • Alter
  • Control
  • View definition

Подробнее о том, как предоставлять разрешения, смотрите на вкладке Разрешения базы данных.


Разрешения роли

На вкладке Permissions Вы можете указать разрешения для роли.

Эта вкладка доступна только при редактировании существующей роли.

На панели навигации выберите тип защищаемого объекта (Securable type). Список объектов выбранного типа будет отображаться в главном окне.

Database role Editor - Setting permissions

В столбце Securable Name перечислен список объектов. В остальных столбцах - разрешения, которые могут быть выданы на выбранный объект:

State (для разрешений баз данных);

Select, Insert, Update, Delete, References, Alter, Control, Take ownership, View definition, View change tracking (для таблиц);

Select, Insert, Update, Delete, References, Alter, Control, Take ownership, View definition (для представлений, возвращающих табличное значение встроенных функций);

Execute, Alter, Control, Take ownership, View definition (для процедур, расширенных процедур);

Select, References, Alter, Control, Take ownership, View definition (для функций, возвращающих табличное значение);

Execute, References, Alter, Control, Take ownership, View definition (для скалярных функций, агрегатных функций, коллекций XML-схем);

Select, Insert, Update, Delete, Execute, Control, Take ownership, View definition (для синонимов);

Execute, References, Control, Take ownership, View definition (для типов данных);

Select, Insert, Update, Delete, Execute, References, Alter, Control, Take ownership, View definition (для схем);

Alter, Control, Take ownership, View definition (для ролей, маршрутов, привязок удаленных служб);

Alter, Control, Impersonate, View definition (для пользователей);

Alter, Control, View definition (для ролей приложения);

References, Alter, Control, Take ownership, View definition (для сборок, полнотекстовых каталогов, сертификатов, асимметричных ключей, симметричных ключей, типов сообщений, контрактов);

Select, Receive, References, Alter, Control, Take ownership, View definition (для очередей);

Send, Alter, Control, Take ownership, View definition (для служб).

Подробнее о том, как предоставлять разрешения, смотрите на вкладке Разрешения базы данных.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Database role Editor - Viewing SQL definition


Роли приложения

Роль приложения (Application role) — это участник базы данных, позволяющий приложению выполняться со своими, подобными пользовательским, правами доступа. Роли приложений можно использовать для разрешения доступа к определенным данным только тем пользователям, которые подключены посредством конкретного приложения. В отличие от ролей баз данных, роли приложений не содержат элементов и по умолчанию находятся в неактивном состоянии.

Для просмотра ролей приложения необходимо выбрать базу из раскрывающегося списка Database на панели инструментов.

Контекстное меню

Create Create application role - создать роль приложения.

Edit Edit application role(s) - изменить роль приложения.

Drop Drop application role(s) - удалить роль приложения.

  • Rename - переименовать роль приложения.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Security - Application roles

Роли приложения отображаются в виде таблицы со следующими столбцами:

Name - имя роли;

DB Owner - владелец базы данных;

Default Schema - схема по умолчанию;

Created - дата создания роли;

Modified - дата последнего изменения роли;

Number of Assigned Roles - количество назначенных ролей.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Смотрите также:

Логины

Пользователи баз данных

Роли баз данных

Роли сервера

Разрешения сервера

Разрешения базы данных


Редактор ролей приложения

В редакторе ролей приложения можно создавать и редактировать роли и задавать для них разрешения.

Чтобы открыть объект в редакторе ролей достаточно щелкнуть по нему два раза мышкой в разделе Роли приложения или выбрать там же пункт контекстного меню Edit Application Role.

Инструменты редактора располагаются на вкладках и панелях инструментов.

Вкладки редактора:

  • Свойства роли приложения
  • Описание
  • Разрешения на роль
  • Разрешения роли
  • SQL описание


Панели инструментов

На панели инструментов редактора пользователей отображаются инструменты, наиболее часто используемые для работы с объектом.

Application role Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.

Permissions

Securable Type

Из этого раскрывающегося списка необходимо выбрать тип защищаемого объекта.

!CheckBox Granted or denied only

Если этот флажок установлен, то на вкладке будут отображаться только сущности, для которых были определены права или установлен запрет.

!CheckBox Non-system objects only

Выберите эту опцию для отображения только несистемных объектов в списке защищаемых объектов.


Свойства

На вкладке Properties необходимо задать основные параметры роли приложения и определить ее принадлежность ролям базы данных.

Application role Editor - Setting application role properties

В поле Name укажите имя создаваемой (редактируемой) роли.

Password

Введите пароль для роли приложения, затем подтвердите его в поле Confirm Password.

Default Schema

Укажите первую схему, в которой сервер будет производить поиск при распознавании имен объектов для этой роли.

Важно: Если оставить поле пустым, то роль приложения будет использовать в качестве схемы по умолчанию схему dbo.

The application role is member of

Укажите принадлежность редактируемой роли приложения к другим ролям базы данных. С помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перенесите их из списка доступных ролей - Available Roles, в список выбранных ролей - Selected Roles.


Описание

Если Вы хотите добавить (изменить) текстовый комментарий к объекту, то Вы можете его создать (изменить) на вкладке Description.

Application role Editor - Editing description

Внесенные изменения вступят в силу только при переходе на другую вкладку, при выборе другого объекта или при нажатии кнопки Apply на панели инструментов.


Разрешения роли

На вкладке Permissions Вы можете указать разрешения для роли приложения.

Эта вкладка доступна только при редактировании существующей роли.

На панели навигации выберите тип защищаемого объекта (Securable type). Список объектов выбранного типа будет отображаться в главном окне.

Application role Editor - Setting permissions

В столбце Securable Name перечислен список объектов. В остальных столбцах - разрешения, которые могут быть выданы на выбранный объект:

State (для разрешений баз данных);

Select, Insert, Update, Delete, References, Alter, Control, Take ownership, View definition, View change tracking (для таблиц);

Select, Insert, Update, Delete, References, Alter, Control, Take ownership, View definition (для представлений, возвращающих табличное значение встроенных функций);

Execute, Alter, Control, Take ownership, View definition (для процедур, расширенных процедур);

Select, References, Alter, Control, Take ownership, View definition (для функций, возвращающих табличное значение);

Execute, References, Alter, Control, Take ownership, View definition (для скалярных функций, агрегатных функций, коллекций XML-схем);

Select, Insert, Update, Delete, Execute, Control, Take ownership, View definition (для синонимов);

Execute, References, Control, Take ownership, View definition (для типов данных);

Select, Insert, Update, Delete, Execute, References, Alter, Control, Take ownership, View definition (для схем);

Alter, Control, Take ownership, View definition (для ролей, маршрутов, привязок удаленных служб);

Alter, Control, Impersonate, View definition (для пользователей);

Alter, Control, View definition (для ролей приложения);

References, Alter, Control, Take ownership, View definition (для сборок, полнотекстовых каталогов, сертификатов, асимметричных ключей, симметричных ключей, типов сообщений, контрактов);

Select, Receive, References, Alter, Control, Take ownership, View definition (для очередей);

Send, Alter, Control, Take ownership, View definition (для служб).

Подробнее о том, как предоставлять разрешения, смотрите на вкладке Разрешения базы данных.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Application role Editor - Viewing SQL definition


Серверные роли

SQL Server предоставляет роли уровня сервера, помогающие в управлении разрешениями на сервере. Эти роли являются субъектами безопасности, группирующими других участников. Разрешения ролей уровня сервера распространяются на весь сервер.

В разделе Server Roles можно просматривать и редактировать (для версии SQL Server 2012) серверные роли, а также задавать логины для каждой роли.

Контекстное меню

Create Create application role - создать серверную роль;

Edit Edit application role(s) - изменить серверную роль;

Drop Drop application role(s) - удалить серверную роль;

  • Rename - переименовать серверную роль;
  • Сlone - создать копию объекта на сервере;
  • Clone To - создать копию объекта на другом сервере;

SetMembers Set members - задать участников серверной роли;

  • Remove all members - удалить всех участников выбранной роли.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Security - Server roles

В верхней части отображаются серверные роли отображаются в виде таблицы со следующими столбцами:

Server Role Name - имя серверной роли;

Owner - владелец;

Number of Members - количество участников;

Server Role Description - описание серверной роли.

В нижней части отображается список имен входа для выбранной серверной роли. С помощью контекстного меню Вы можете удалить выбранный логин из списка членов серверной роли, а также редактировать логин.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

При выборе пункта контекстного меню SetMembers Set Members... появляется диалог выбора логинов.

Server Roles - Set Server Role Members

Чтобы выбрать участника серверной роли, выберите его в списке и поставьте флажок в поле Selected. С помощью контекстного меню, появляющегося при нажатии правой кнопкой на форме, Вы можете:

Select All - выбрать все логины,

Deselect All - отменить выбор всех логинов.

Смотрите также:

Логины

Пользователи баз данных

Роли баз данных

Роли приложения

Разрешения сервера

Разрешения базы данных


Редактор серверных ролей

Редактор серверных ролей доступен только для версии SQL Server 2012.

В редакторе можно создавать и редактировать серверные роли и задавать для них разрешения.

Чтобы открыть объект в редакторе серверных ролей достаточно щелкнуть по нему два раза мышкой в разделе Серверные роли или выбрать там же пункт контекстного меню Edit Server Role.

Инструменты редактора располагаются на вкладках и панелях инструментов.

Вкладки редактора:

  • Свойства
  • Разрешения
  • SQL описание


Панели инструментов

На панели инструментов редактора пользователей отображаются инструменты, наиболее часто используемые для работы с объектом.

Server Roles Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.

Permissions

Securable Type

Из этого раскрывающегося списка необходимо выбрать отображаемый защищаемый тип: Server, Server Roles, Login или Endpoint.

!CheckBox Granted or denied only

Если этот флажок установлен, то на вкладке будут отображаться только сущности, для которых были определены права или установлен запрет.


Свойства

На вкладке Properties необходимо задать основные параметры серверной роли и выбрать логины, которые станут ее членами.

Server Roles Editor - Properties

В поле Name укажите имя создаваемой (редактируемой) серверной роли.

Из списка Owner выберите владельца роли.

Members of server role

Выберите участников (логины), которые станут членами серверной роли (они будут наследовать все разрешения роли). Из списка всех доступных участников - Available Principals - выберите участника и с помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перенесите его в список выбранных - Selected Principals.


Задание принадлежности роли

На вкладке Member of server roles укажите принадлежность редактируемой серверной роли к другим серверным ролям. Выбранные роли определяют набор задач, которые смогут выполнять члены редактируемой роли.

Эта вкладка доступна только при создании новой серверной роли.

Server Roles Editor - Defining server role membership

С помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected перенесите роль из списка доступных серверных ролей - Available Server Roles, в список выбранных серверных ролей - Selected Server Roles.


Разрешения

В разделе Permissions можно задать права на выполнение операций сервера (Server), разрешения на серверные роли (Server Roles), имена входа (Login) и на конечные точки (Endpoint).

Эта вкладка доступна только при редактировании существующей серверной роли.

На панели навигации выберите тип защищаемого объекта (Securable type).

Server Roles Editor - Permissons

Более подробную информацию о том, как задавать права для серверных ролей, Вы найдете в разделе Разрешения сервера.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Viewing SQL definition - Viewing SQL definition


Разрешения сервера

На вкладке Server Permissions в Server Explorer Вы можете управлять разрешениями сервера.

Security - Server permissions

Панель управления

Из списка Principal выберите участника (логин или серверную роль (для SQL Server 2012)), для которого хотите задать разрешения.

Из списка Securables Type выберите тип защищаемого объекта - Server Permission, Login, Endpoint, Server Role (для SQL Server 2012).

С помощью кнопок выберите:

  • Select Principal - выбирать участника, которому Вы хотите предоставить права.

В этом случае в таблице будет отображаться список всех защищаемых объектов выбранного типа.

  • Select Securable - выбирать защищаемый объект, на который Вы хотите предоставить права.

В этом случае в таблице будет отображаться список всех участников (логинов или серверных ролей (для SQL Server 2012)).

- отображать только сущности, для которых были определены права или установлен запрет.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

Существует 4 вида прав:

Grant Grant - предоставить,

Revoke Revoke - аннулировать,

Deny Deny - запретить,

GrantWithGrantOPtions Grant with Grant Option - предоставить с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям).

Права на выполнение какой-либо операции меняются в соответствующей колонке.

При выборе участника / защищаемого объекта (активна кнопка Select Principal / Select Securable) с помощью контекстного меню можно:

  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения для всех участников на выполнение выбранного действия;
  • Deny on All Objects / to All Principals - запретить всем участникам выполнение выбранного действия.

С помощью пункта контекстного меню Print Print Вы можете создать отчет и открыть окно предварительного просмотра перед печатью.

При предоставлении прав участникам с помощью контекстного меню также можно:

Create Create Login - создать логин;

Edit Edit Login - изменить логин;

Drop Drop Login - удалить логин;

Create Create server role - создать серверную роль;

Edit Edit server role(s) - изменить серверную роль;

Drop Drop server role(s) - удалить серверную роль.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Логины

Пользователи баз данных

Роли баз данных

Роли приложения

Роли сервера

Разрешения базы данных


Разрешения базы данных

На странице Database Permissions Вы можете управлять правами пользователей и ролей на выполнение операций с базами данных.

Security - Database permissions

Панель управления

Чтобы просмотреть список разрешений базы данных, выберите базу из списка Database на панели управления.

Из списка Principal выберите участника (роль базы данных, пользователя или роль приложения), для которого хотите задать разрешения.

Из списка Securable Type выберите тип защищаемого объекта - Server Permission, Login, Endpoint, Server Role (для SQL Server 2012).

С помощью кнопок выберите:

  • Select Principal - выбирать участника, которому Вы хотите предоставить права. В этом случае в таблице будут отображаться защищаемые объекты, на которые можно выдать разрешения выбранному участнику.
  • Select Securable - выбирать защищаемый объект, на который Вы хотите предоставить права. В этом случае в таблице будет отображаться список всех участников (роль базы данных, пользователя или роль приложения).

- отображать только сущности, для которых были определены права или установлен запрет.

ShowNonSystemObjectsOnly - отображать только несистемные объекты в списке защищаемых объектов.

Права меняются двумя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку;
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Grant with GRANT OPTION->Deny->Revoke).

Существует 4 вида прав:

Grant Grant - предоставить,

Revoke Revoke - аннулировать,

Deny Deny - запретить,

GrantWithGrantOPtions Grant with Grant Option - предоставить с правами 'GRANT' (то есть с возможностью предоставлять права на это действие другим пользователям).

Права на выполнение какой-либо операции меняются в соответствующей колонке.

При выборе участника / защищаемого объекта (активна кнопка Select Principal / Select Securable соответственно) с помощью контекстного меню можно:

  • Grant All - предоставить выбранному участнику разрешения на выполнение всех операций;
  • Grant All with Grant Option - предоставить выбранному участнику разрешения на выполнение всех операций с правами 'GRANT';
  • Revoke All - аннулировать все разрешения для выбранного участника;
  • Deny All - запретить выбранному участнику выполнение всех операций;
  • Grant on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия;
  • Grant with Grant Option on All Objects / to All Principals - предоставить всем участникам права на выполнение выбранного действия с правами 'GRANT';
  • Revoke on All Objects / from All Principals - аннулировать разрешения на все объекты / всем участникам;
  • Deny on All Objects / to All Principals - запретить выбранному участнику выполнение действий со всеми объектами / всем участникам выполнение выбранного действия.

С помощью пункта контекстного меню Print Print Вы можете создать отчет и открыть окно предварительного просмотра перед печатью.

С помощью контекстного меню можно вызвать диалог для управления разрешениями на уровне столбца и для просмотра действующих разрешений.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Логины

Пользователи баз данных

Роли баз данных

Роли приложения

Роли сервера

Разрешения сервера


Разрешения на уровне столбца

Для некоторых объектов можно задать разрешения на конкретные поля. Для этого выберите пункт Column permission... контекстного меню в списке разрешений базы данных.

Object name - имя выбранного объекта, на столбцы которого предоставляются права.

Principal name - имя участника, которому предоставляются права.

В диалоге Column permissions представлен список столбцов выбранного объекта, для которых можно задавать права на выполнение действий (select, update, references).

С помощью пунктов контекстного меню Вы можете предоставить/аннулировать права или запретить выполнение операции со столбцами.


Действующие разрешения

Действующие разрешения (Effective permissions) для участника на доступ к защищаемому объекту — это результат явных разрешений, определенных для этого участника для данного объекта, разрешений для предков этого объекта и разрешений, унаследованных участником через роль или членство в группах. Диалог Effective permissions позволяет просматривать разрешения, получающиеся в результате комбинации всех разрешений участника на доступ к защищаемому объекту. Этот диалог открывается в режиме 'только для чтения'.

В диалоговом окне Effective permissions в виде дерева отображается полный список назначенных пользователю прав.

Permission - имя разрешения;

Column - столбец, на который выдаются права;

Grantee Securable - защищаемый объект, которому назначено разрешение;

Grantee Principal - участник, которому назначено разрешение.

В последнем столбце указан тип разрешения (granted, granted with grant option, denied).

Для вашего удобства кнопки Expand/Collapse доступны в контекстном меню.


Учетные данные

Учетные данные (Credential) являются записью, которая содержит сведения для проверки подлинности, которые необходимы для подключения к ресурсу извне SQL Server. Большинство учетных данных включают имя пользователя и пароль Windows.

Учетные данные используются для доступа к хранилищу Windows Azure , используемого для загрузки файлов резервных копий.

Контекстное меню

Create Create ('Insert') - создать учетные данные.

Edit Edit ('Enter') - редактировать учетные данные.

Drop Drop ('Delete') - удалить учетные данные.

  • Rename - переименовать роль.
  • Сlone - создать копию объекта на сервере.
  • Clone To - создать копию объекта на другом сервере.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Security - Credentials

Пользователи базы данных отображаются в виде таблицы со следующими столбцами:

Name - имя учетных данных,

Identity - имя учетной записи для использования при подключении за пределами сервера,

Creation Date - дата создания,

Modification Date - дата изменения.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.


Редактор учетных данных

Редактор учетных данных предназначен для задания необходимых для работы параметров учетных данных. Этот редактор открывается автоматически при создании или изменении объекта.

Чтобы открыть объект в редакторе необходимо на вкладке Credentials дважды щелкнуть на нужном объекте мышкой. Также для создания и редактирования учетных данных можно использовать пункты контекстного меню Create и Edit соответственно.

Панели инструментов

Вкладки редактора:

Свойства учетных данных

SQL описание


Панели инструментов

На панели инструментов редактора баз данных отображаются инструменты, используемые для работы с объектом.

Credential Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Свойства

На вкладке Properties можно задать основные параметры учетных данных.

Credential Editor - Properties

В поле Name укажите имя создаваемых учетных данных. Имя не может начинаться с символа решетки (#).

Identity

Укажите имя учетной записи для использования при подключении за пределами сервера.

Password

Задайте пароль, необходимый для исходящей проверки подлинности. Это свойство является необязательным.

Подтверждение пароля задайте в поле Confirm password.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Credential Editor - Viewing SQL definition


Агент SQL сервера

Агент SQL Server — это служба, которая позволяет автоматизировать некоторые административные задачи. Чтобы локальные или многосерверные административные задачи могли выполняться автоматически, необходимо запустить службу агента SQL Server. Агент SQL Server запускается как служба с названием SQL Server Agent (MSSQLSERVER), если это экземпляр по умолчанию, или SQLAgent$<имя экземпляра>, если это именованный экземпляр.

Если служба SQL Server и служба агента SQL Server не настроены для автоматического запуска, необходимо запустить эти службы вручную.

Note: Объекты Агента SQL Server доступны только участникам роли System Administrator.

  • Задания
  • Расписания
  • Предупреждения
  • Операторы
  • Учетные записи-посредники

SQL Server Agent

В главном разделе отображается общая информация по последним запущенным заданиям - Last Run Jobs, заданиям, ожидающим запуска - Next Running Jobs и заданиям, которые не были выполнены - Failed Jobs.

Last Run Jobs

Job - имя задания;

Last Run Date - дата последнего запуска;

Server - сервер, на котором было запущено задание;

Duration - продолжительность выполнения задания;

Retries - число попыток повторного выполнения задания.

Next Running Jobs

Job - имя задания;

Next Running Date - дата следующего запуска задания;

Schedule - расписание.

Failed Jobs

Job - имя задания;

Run Date - дата запуска;

Run Status - сообщение о результате последнего выполнения;

Duration - продолжительность выполнения задания;

Server - сервер, на котором было запущено задание;

Retries - число попыток повторного выполнения задания.

Из раскрывающегося списка Date Interval на панели инструментов можно выбрать интервал за который будет отображаться история.

Задание можно открыть в соответствующем редакторе, дважды щелкнув на нем мышкой.

Контекстное меню

Create Create job - создать новое задание;

Edit Edit job(s) - изменить выбранное задание;

Drop Drop job(s) - удалить выбранные задания;

Rename job - переименовать задание;

Enable job(s) - активировать задание;

Disable job(s) - деактивировать задание;

StartJob Start job(s) - начать выполнение задания;

Stop job(s) - остановить выполнение задания;

MaintenancePlanHistory View job history - показать историю выполнения заданий.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Безопасность

Производительность

Журнал сервера

Запросы

Опции


Задания

Задание - это определенный набор операций, выполняемых последовательно с помощью SQL Server Agent. С помощью заданий можно выполнять значительный набор операций, таких как запуск скриптов Transact-SQL, приложений командной строки, скриптов Microsoft ActiveX, служб SSIS, команд и запросов Analysis Services, или задач репликации.

С помощью задания можно выполнять повторяющиеся и запланированные задачи и отправлять уведомления об их выполнении операторам.

Важно: Для работы с заданиями необходимо запустить службу SQL Server Agent.

SQL Server Agent - Jobs

Задания отображается в виде таблицы со столбцами:

Name - имя задания;

Category - категория;

Enabled - включено ли это задание;

Execution Status - состояние выполнения;

Last Run Outcome - сообщение о результатах последнего выполнения;

Last Run Date - дата последнего запуска;

Next Run Date - дата следующего запуска;

Schedules - количество расписаний;

Creation Date - дата создания задания;

Owner - владелец;

Description - описание.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Управлять объектами можно с помощью элементов управления, расположенных на панели инструментов и в контекстном меню.

Create Create job - создать новое задание;

Edit Edit job(s) - изменить выбранное задание;

Drop Drop job(s) - удалить выбранные задания;

  • Rename job - переименовать задание;
  • Enable job(s) - активировать задание;
  • Disable job(s) - деактивировать задание;

StartJob Start job(s) - начать выполнение задания;

  • Stop job(s) - остановить выполнение задания;

MaintenancePlanHistory View job history - показать историю выполнения заданий.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Смотрите также:

История заданий

Предупреждения

Операторы

Учетные записи-посредники


Редактор заданий

В Job Editor можно создавать и изменять задания.

Чтобы открыть задание в редакторе необходимо в списке заданий дважды щелкнуть мышкой по нужному заданию или в контекстном меню задания выбрать пункт Edit Edit job(s).

Jobs - Job Editor

Вкладки:

Задание

Шаги

Расписания

Уведомления

Целевые серверы

Предупреждения

История задания

SQL описание


Панели инструментов

На панели инструментов редактора предупреждений отображаются инструменты, наиболее часто используемые для работы с объектом.

Job Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

StartJob Start job - начать выполнение задания.

  • Stop job - остановить выполнение задания.

Job History

History date interval

Из этого раскрывающегося списка можно выбрать период, за который будет отображаться история выполнения задания.

ClearJobHistory Clear history - очистить историю задания.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Задание

На вкладке Job задайте основные параметры задания.

Jobs - Job Editor

Job name - имя задания. Имя должно быть уникальным и не может содержать символ процента (%).

!CheckBox Enabled - показывает текущее состояние задания. Если флажок не установлен, задание не включено и не срабатывает.

Owner - имя учетной записи владельца задания.

Важно: Чтобы создать задание, пользователь должен быть членом одной из фиксированных ролей базы данных SQL Server Agent или членом роли sysadmin. Задание может быть изменено только его владельцем или членами роли sysadmin.

Category - из этого раскрывающегося списка можно выбрать ранее заданную категорию задания.

С помощью категорий задания можно структурировать список заданий для упрощения выполнения фильтрации и группировки. Создать новую категорию можно, нажав на кнопку "+".

Description - описание задания.

Далее следует следующая справочная информация по редактируемому заданию.

Source server - сервер задания.

Created at - дата создания.

Last modified at - дата последнего изменения.

Last run at - дата последнего запуска.

Last run outcome - состояние после последнего запуска (успешно было выполнено или с ошибками).

Next run at - дата следующего запуска (для тех объектов, для которых задано расписание).


Шаги

На этой вкладке показан список действий (шагов), выполняемых этим заданием.

Job Editor - Managing job steps

Действия можно добавлять удалять и редактировать с помощью контекстного меню, открывающегося при нажатии правой кнопкой мыши.

Для создания и редактирования шага существует специальный редактор шага.

Идентификационные номера шагов начинаются с 1 и присваиваются сервером.

Редактор шага

Job Editor - Job Step Editor - General

Вкладка General

На этой вкладке задайте основные свойства и параметры шага.

Name - имя шага.

Step type - тип команды на выполнение.

Database - имя базы данных, в которой необходимо выполнить этап.

Run as user - имя учетной записи пользователя, используемое при выполнении шага.

В поле Command пропишите сам текст шага, то есть те действия, которые должны быть произведены с данными или метаданными.

Вкладка Advanced

Job Editor - Job Step Editor - Advanced

На этой вкладке задайте параметры выполнения шага.

В разделе Action when step succeeds выберите одно из действий, которое будет выполнено при успешном выполнении шага задания.

В разделе Action when step fails - при невыполнении или выполнении с ошибками.

Действия.

!RadioButton Go to next step - перейти к следующему шагу.

!RadioButton Quit job with success - завершить выполнение задания с пометкой "удачно".

!RadioButton Quit job with failure - завершить выполнение задания с пометкой "неудачно".

!RadioButton Go to step - перейти к шагу n, в раскрывающемся списке выберите имя шага к которому необходимо перейти.

В разделе Retries if step fails задайте количество попыток выполнения шага в случае неудачного выполнения:

  • Number of retry attempts - число попыток выполнения шага.
  • Retry Interval, minutes - интервал между попытками в минутах.

Log of step command/query output.

Для SQL Server Agent существует возможность записи выходной информации. Она может быть записана в таблицу sysjobsteplogs базы данных msdb или во внешний файл.

To file

История выполнения будет вноситься во внешний файл, указанный в соответствующем поле.

!CheckBox To step log table (msdb.dbo.sysjobsteplogs)

При установке этого флажка история будет записана в таблицу sysjobsteplogs базы данных msdb.

!CheckBox To job history

Установите этот флажок, чтобы внести данные из этого файла в общую историю выполнения заданий.

Если установлен флажок !CheckBox Overwrite, то история в указанном хранилище будет перезаписана.


Расписания

На этой вкладке отображается список расписаний, по которым выполняется данное задание.

Job Editor - Managing job schedules

Управление расписаниями осуществляется с помощью контекстного меню, открывающегося при нажатии правой кнопкой мыши.

Для указания параметров расписания существует специальный редактор расписаний.

С помощью контекстного меню Вы можете:

  • New Schedule - создать расписание и добавить его в список.
  • Edit Schedule - редактировать расписание.
  • Delete Schedule - удалить расписание из списка.
  • Attach Schedule - добавить в список одно из существующих расписаний.
  • Detach Schedule - удалить из списка существующее расписание.
  • List Auto Width - подогнать ширину списка под ширину окна.


Редактор расписаний

Редактировать и создавать расписания Вы можете в специальном Редакторе расписаний.

На вкладке Schedules редактора расписаний задайте основные параметры расписания.

Schedule Editor - Editing schedule definition

В поле Name укажите название расписания. Установив флажок !CheckBox Enabled, Вы указываете, что расписание вступает в силу сразу после создания.

Панель Execution Type позволяет Вам выбрать режим выполнения задания.

!RadioButton Start when SQL Server Agent starts - запускается выполнение задания тогда, когда запускается SQL Server Agent.

!RadioButton Start when CPU usage is low - запускать при низкой загрузке CPU.

!RadioButton Start at time - запустить один раз и далее указать дату и время для выполнения операции.

!RadioButton Run recurrently - запускать периодически. Параметры периодического расписания задаются ниже.

Параметры периодического выполнения задания можно задать на панели с тремя вкладками, расположенной ниже.

На первой вкладке - Recurring Interval задаете периодичность запуска задания.

!RadioButton Daily - каждые n дней.

!RadioButton Weekly - каждые n недель.

!RadioButton Monthly - каждые n месяцев.

Количество дней недель или месяцев задается в счетчике Recurs Every.

При указании недель можно выбрать день недели.

Для месяцев можно задать конкретный день месяца для выполнения операции и периодичность выполнения.

На вкладке Daily Frequency можно задать параметры периодичности выполнения в пределах одного дня:

!RadioButton Occurs once at - выполнять задание один раз в день. С помощью счетчика указать время выполнения.

!RadioButton Occurs every - выполнять задание каждые несколько часов или минут. Интервал задайте с помощью счетчиков. Если указать дополнительный интервал Start at - End at то можно указать, в какое время резервные копии будут создаваться с заданной периодичностью. Таким образом, можно, например, создавать копии только в течение рабочего дня.

На вкладке Duration можно задать следующие параметры:

В календаре Start date укажите начало действия создаваемого расписания,

End date - окончание действия расписания. Если установлен флажок !CheckBox No end date, то конечная дата становится неактивной, и задание будет выполняться до тех пор, пока Вы не измените или не удалите это расписание.


Уведомления

На вкладке Notifications укажите параметры уведомлений.

Job Editor - Managing notifications

С помощью следующих инструментов укажите адресата, которому необходимо отправить сообщение о выполнении задания, а также событие уведомления. Ниже перечислены действия, для которых нужно выбрать события и адресатов (если требуется).

Notify by e-mail - на адрес электронной почты;

Notify by pager - на пейджер;

Notify by net send - по сети с использованием оператора Net Send;

Write to Windows Application Log - записать в журнал операций Windows;

Delete job - удалить задание.

В качестве адресатов выбираются операторы сервера.

С помощью флажков, стоящих напротив каждого адресата укажите в каком случае необходимо посылать сообщение.

!CheckBox When job succeeds - в случае удачного выполнения задания.

!CheckBox When job fails - в случае невыполнения или выполнения с ошибками.


Целевые серверы

Если задание должно выполняться на одном или нескольких целевых серверах в многосерверной среде, то задавать целевые серверы следует на этой вкладке.

Целевой сервер - это сервер, получающий задания от главного сервера.

На текущем сервере и главном сервере должна работать одна и та же версия SQL Server.

Job Editor - Managing target servers

!CheckBox Appoint the job to the current server only - выполнять задание только на главном (master) сервере.

Список задействованных серверов отображается в списке Selected Target servers.

Добавить сервер в список выбранных можно с помощью кнопок MoveAllToAvailable MoveToAvailable MoveToSelected MoveAllToSelected.


Предупреждения

На вкладке Alerts можно просматривать и изменять список предупреждений.

Job Editor - Managing alerts

Предупреждения отображаются в виде списка. Управлять этим списком можно с помощью контекстного меню, вызываемого нажатием правой клавишей мышки.

  • New Alert - создать новое предупреждение и указать его свойства в редакторе предупреждений.
  • Edit Alert - редактировать предупреждение.
  • List Auto Width - подогнать ширину столбцов по ширине окна.

В списке отображаются предупреждения в виде таблицы со следующими столбцами:

Name - имя предупреждения;

Enabled - включено ли это предупреждение;

Type - тип;

Run job on Alert - запускать ли выполнение задания при предупреждении.

Щелкните заголовок столбца для сортировки элементов этого столбца по возрастанию или по убыванию.


История задания

На этой вкладке можно просмотреть историю выполнения задания в указанную дату и выполнение каждого отдельного шага этого задания.

Job Editor - Viewing job history

В разделе Job History отображается следующая информация по текущему заданию.

  • Run date - дата последнего запуска;
  • Run status - состояние после последнего запуска (успешно было выполнено или с ошибками);
  • Duration - длительность выполнения;
  • Retries - количество повторных попыток запуска;
  • Server - на каком сервере выполнялось задание;
  • Notified by Email - уведомление, отправленное на e-mail;
  • Notified by Pager - уведомление, отправленное на пейджер;
  • Notified by Net Send - уведомление, отправленное по Net Send.

В разделе Step History отображается история выполнения каждого шага задания, выбранного в разделе Job History.

  • Run date - дата последнего запуска;
  • Step ID - номер шага;
  • Step Name - имя шага;
  • Run Status - статус шага;
  • Duration - длительность выполнения;
  • Retries - количество повторных запусков;
  • Error ID - идентификационный номер ошибки, если была;
  • Severity - уровень важности;
  • Message - сообщение об итоге выполнения шага.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Job Editor - Viewing SQL Definition


История заданий

На этой вкладке можно просмотреть всю историю выполнения заданий и выполнение каждого отдельного шага каждого задания.

Управлять списком записей можно с помощью кнопок, расположенных на панели инструментов и в контекстном меню.

Refresh Refresh - обновить список заданий.

ColumnChooser Column chooser - выбрать отображаемые столбцы.

  • Date Interval - задать интервал просмотра выполнения заданий.
  • Job - просмотреть историю выполнения одного задания.

Edit Edit job - изменить задание в редакторе.

ClearJobHistory Clear job history - удалить историю выполнения задания.

  • Enable job(s) - активировать задание.
  • Disable job(s) - деактивировать задание.

StartJob Start job(s) - начать выполнение задания

  • Stop job(s) - остановить выполнение задания.

EditJobStep Edit job step - изменить шаг задания в редакторе.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

SQL Server Agent - Job history

В разделе Job History отображается следующая информация по текущему заданию.

  • Run date - дата последнего запуска;
  • Run status - состояние после последнего запуска (успешно было выполнено или с ошибками);
  • Duration - длительность последнего выполнения;
  • Retries - количество повторных попыток запуска;
  • Server - на каком сервере выполнялось задание;
  • Notified by Email - уведомление, отправленное на e-mail;
  • Notified by Pager - уведомление, отправленное на пейджер;
  • Notified by Net Send - уведомление, отправленное по Net Send.

В разделе Step History отображается история выполнения каждого шага задания, выбранного в разделе Job History.

  • Run date - дата последнего запуска.
  • Step ID - номер шага.
  • Step Name - имя шага.
  • Run Status - статус шага.
  • Duration - длительность выполнения.
  • Retries - количество повторных запусков.
  • Error ID - идентификационный номер ошибки, если была.
  • Severity - уровень важности.
  • Message - сообщение о результате выполнения шага.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Смотрите также:

Задания

Предупреждения

Операторы

Учетные записи-посредники


Предупреждения

Предупреждение (Alert) - это определенная пользователем реакция на событие SQL Server. Предупреждение выполняет определенную пользователем задачу, например, отправляет электронную почту или сообщение на пейджер указанному оператору. По умолчанию только члены предопределенной роли сервера sysadmin могут создавать предупреждения.

Важно: Для работы предупреждений необходимо запустить службу SQL Server Agent.

SQL Server Agent - Alerts

Все предупреждения отображаются в виде таблицы со столбцами:

Name - имя предупреждения;

Enabled - включено ли это предупреждение;

Type - тип пред;

Error Number - номер ошибки;

Severity - уровень критичности ошибки;

Database - база данных, в которой может произойти ошибка;

Performance Object - объект производительности;

Performance Counter - счетчик в объекте производительности;

Performance Instance - экземпляр счетчика;

Performance Condition - поведение счетчика, на которое должно реагировать предупреждение;

WMI Namespace - пространство имен WMI;

WMI Query - инструкция WMI Query Language;

Run Job - задание, которое запускается в ответ на предупреждение;

Has E-mail Notification - отправлять уведомительное сообщение по электронной почте;

Has Net Send Notification - отправлять уведомительное сообщение по Net Send;

Last Occurrence Date - дата последнего срабатывания;

Last Response Date - дата последнего уведомления.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Управлять объектами можно с помощью элементов управления, расположенных на панели инструментов и в контекстном меню.

Create Create alert - создать предупреждение;

Edit Edit alert(s) - изменить предупреждение;

Drop Drop alert(s) - удалить предупреждение;

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью;

  • Rename alert - переименовать предупреждение;
  • Enable alert(s) - активировать предупреждение;
  • Disable alert(s) - выключить предупреждение.

Смотрите также:

Задания

История заданий

Операторы

Учетные записи-посредники


Редактор предупреждений

В Alert Editor можно задавать необходимые свойства предупреждения.

Чтобы открыть предупреждение в редакторе необходимо в списке предупреждений дважды щелкнуть мышкой по нужному объекту или в контекстном меню предупреждения выбрать пункт Edit Edit alert(s).

Alerts - Alert Editor

Все свойства объекта задаются на следующих вкладках редактора:

Свойства предупреждения

Задание ответов на предупреждение

Задание дополнительных параметров

SQL описание


Панель инструментов

На панели инструментов редактора предупреждений отображаются инструменты, наиболее часто используемые для работы с объектом.

Alert Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Свойства предупреждения

На вкладке Properties можно задать основные параметры предупреждения.

Name - имя предупреждения. Имя появляется в сообщении электронной почты или пейджера, отправленном в ответ на предупреждение. Оно должно быть уникальным и не должно содержать символ процента (%).

!CheckBox Enabled - показывает текущее состояние предупреждения. Если флажок не установлен, предупреждение не включено и не срабатывает.

Alerts - Alert Editor

В разделе Alert type можно выбрать тип предупреждения.

!RadioButton SQL Server event alert - предупрежедение о событии SQL Server;

!RadioButton SQL Server performance condition alert - сообщение о производительности;

!RadioButton WMI event alert - предупреждение о событии WMI.

В разделе Properties задайте параметры выбранного типа предупреждения.

Для SQL Server event alert

Вы можете выбрать ошибку по номеру или по описанию с помощью счетчика и раскрывающегося поля строки !RadioButton Error number.

Из раскрывающегося списка !RadioButton Error Severity выберите уровень критичности ошибки. Ошибки разделены на несколько групп в зависимости от их серьезности. Первые - это сообщения и некритичные ошибки, а последние в этом списке - это Fatal Error.

Database name - из этого списка выберите базу данных, в которой может произойти ошибка, для которой срабатывает предупреждение. По умолчанию, оно будет действовать для всех баз данных.

Alert if message text contains - последовательность символов, на которую должно быть похоже описание ошибки SQL Server.

!RadioButton SQL Server performance condition alert

Предупреждения о производительности SQL Server.

Alert Editor - Setting server performance properties

Object

Объект производительности для контроля.

Counter

Счетчик в объекте производительности для контроля.

Instance

Экземпляр счетчика для контроля.

Alert if value is

Укажите пороговое значение и действие, по которому срабатывает предупреждение. С помощью выпадающего списка выберите действие: less than (значение счетчика меньше указанного числа), equal to (значение счетчика равняется указанному числу), more than (значение счетчика больше указанного числа).

!RadioButton WMI event alert

Параметры предупреждения о событии WMI.

Alert Editor - Setting WMI alert properties

WMI (Windows Management Instrumentation) это реализация Web-Based Enterprise Management (WBEM).

Новая технология, предоставляющая программное обеспечение для мониторинга и контроля управляемыми ресурсами по сети. Такими управляемыми ресурсами являются жесткие диски, файловые системы, настройки операционной системы, процессы, службы, настройки регистрации, сетевые компоненты, журналы событий, пользователи, группы и т.д.

WMI позволяет отслеживать значения счетчиков производительности. В Microsoft® SQL Server™ есть встроенный WMI Event Provider.

Один из распространенных способов использования WMI Event Provider - это создание предупреждения SQL Server Agent, которое будет реагировать на определенные события. SQL Server Agent отправляет запрос WQL, получает событие WMI и запускает задание в ответ на событие.

WMI namespace

Укажите пространство имен для использования в инструкции языка запросов инструментария WMI (WQL). Поддерживаются только пространства имен на компьютере, на котором запущен агент SQL Server.

WMI Query

Укажите инструкцию WQL (WMI Query Language), определяющую событие, на которое реагирует предупреждение.

Примеры:

SELECT * FROM Win32_OperatingSystem WHERE Caption="Microsoft Windows XP Professional" AND CSDVersion="Service Pack 2"

Если необходимо контролировать количество процессов, которые используют более 10 потоков, то можно использовать следующий запрос:

SELECT ThreadCount FROM Win32_Process WHERE ThreadCount>10

Этот запрос WQL извлекает специфические свойства событий для любого события, которое происходит в базе данных AdventureWorks и существует в группе событий DDL_DATABASE_LEVEL_EVENTS:

SELECT SPID, SQLInstance, DatabaseName FROM DDL_DATABASE_LEVEL_EVENTS WHERE DatabaseName = 'AdventureWorks'


Задание ответов на предупреждение

На вкладке Response задайте действия, выполняемые службой SQL Server Agent в ответ на срабатывание предупреждения.

Alert Editor - Setting response

Job name

Из этого списка выберите имя задания, которое запускается в ответ на это предупреждение. Можно создать новое, нажав кнопку AddJobCategory Add.

Notify operators when alert is raised

В этой таблице отображается, какие операторы будут оповещены о предупреждении.

С помощью флажков установите один или несколько типов уведомительных сообщений.

E-mail - на адрес электронной почты;

Page - на пейджер;

Net send - по Net Send.

Новый оператор можно создать, выбрав из контекстного меню оператора пункт New operator.


Задание дополнительных параметров

На вкладке Advanced можно задать дополнительные параметры предупреждения.

Alert Editor - Setting advanced properties

Options

Include alert error text to notification message sent by

Определите, какие типы оповещения будут использоваться при срабатывании предупреждения:

!CheckBox E-mail, !CheckBox Pager, !CheckBox Net send.

E-mail - на адрес электронной почты;

Page - на пейджер;

Net send - по Net Send.

Additional message text

В это поле введите сам текст предупреждения, отправляемый оператору.

Delay between responses, seconds

Период ожидания (в секундах) между откликами на предупреждение.

Установкой этого значения можно предотвратить, например, отправку нежелательных почтовых сообщений, если предупреждение возникает многократно за короткий промежуток времени.

History

Ниже отображается следующая справочная информация по этому предупреждению:

Last alert date - последняя дата возникновения предупреждения;

Last response date - дата последнего ответа на предупреждение от службы SQLServerAgent;

Number of occurrences - число возникновений предупреждения;

Occurrences last reset date - дата последнего сброса.

С помощью кнопки Reset можно сбросить справочную информацию


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Alert Editor - Viewing SQL definition


Операторы

Оператор - объект, представляющий собой одного оператора сервера SQL. Операторы получают уведомления о выполнении Заданий и Предупреждений. Для каждого оператора можно задать уведомления о задании и о предупреждении.

Важно: Для работы операторов необходимо запустить службу SQL Server Agent.

SQL Server Agent - Operators

Все операторы отображаются в виде таблицы со столбцами:

Name - имя оператора;

Enabled - активен ли оператор;

E-mail Address - адрес электронной почты;

Pager Address - номер пейджера оператора;

Net Send Address - имя компьютера или IP адрес для Net Send;

Last Notification by E-mail - дата последнего уведомления по почте;

Last Notification by Pager - дата последнего уведомления по пейджеру;

Last Notification by Net Send - дата последнего уведомления по Net Send.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Управлять объектами можно с помощью элементов управления, расположенных на панели инструментов и в контекстном меню.

Create Create operator - создать оператора.

Edit Edit operator(s) - изменить оператора.

Drop Drop operator(s) - удалить оператора.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

  • Rename operator - переименовать оператора.
  • Enable operator(s) - включить оператора.
  • Disable operator(s) - выключить оператора.

Смотрите также:

Задания

История заданий

Предупреждения

Учетные записи-посредники


Редактор операторов

В Operator Editor можно задавать необходимые свойства оператора.

Чтобы открыть оператора в редакторе необходимо в списке операторов дважды щелкнуть мышкой по нужному объекту, или в контекстном меню предупреждения выбрать пункт Edit Edit Operator(s).

Operators - Operator Editor

Список вкладок отображается на панели инструментов:

  • Задание свойств оператора
  • Выбор предупреждений
  • Выбор заданий
  • История предупреждений
  • SQL описание


Панель инструментов

На панели инструментов редактора операторов отображаются инструменты, наиболее часто используемые для работы с объектом.

Operator Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Задание свойств оператора

Name - имя оператора. Имя должно быть уникальным и не может содержать символ процента (%).

Enabled - показывает текущее состояние оператора. Если флажок не установлен, он не активен и не срабатывает.

Operators - Operator Editor

E-mail address - адрес электронной почты оператора. Можно указать физический адрес электронной почты или псевдоним.

Pager e-mail address - адрес пейджера оператора. Эта строка передается напрямую в систему электронной почты.

Net send network address - имя компьютера или IP адрес.

Pager available time

Отметьте флажками дни недели, когда служба агента SQL сервера может отправлять уведомления оператору.

!CheckBox Monday, !CheckBox Tuesday, !CheckBox Wednesday, !CheckBox Thursday, !CheckBox Friday, !CheckBox Saturday, !CheckBox Sunday.

С помощью счетчиков From ... To ... задается временной интервал отправки сообщений.


Выбор предупреждений

На этой вкладке указано, в каких предупреждениях используется данный оператор.

Operator Editor - Managing alert notifications

Флажками необходимо отметить, какие типы оповещения будут использоваться при срабатывании каждого существующего предупреждения:

!CheckBox By e-mail - на адрес электронной почты;

!CheckBox By pager - на пейджер;

!CheckBox By Net Send - по сети с использованием оператора Net Send.

Можно создать новое предупреждение, выбрав в контекстном меню пункт New alert.


Выбор заданий

На этой вкладке отображается список заданий, где используется редактируемый оператор.

Operator Editor - Managing job notifications

В списке приведены доступные задания. Для каждого задания определите, какие типы оповещения будут использоваться при его выполнении: By E-mail, By Pager, By Net Send.

Для каждого задания отображается, при каком результате выполнения будет отправляться оповещение того или иного типа. Это указывается для каждого задания на вкладке Notifications.

Чтобы задать ситуацию, при которой будет срабатывать оповещение, дважды кликните по заданию, в открывшемся редакторе заданий перейдите на вкладку Notifications и определите тип уведомления.

Важно: Можно создать новое задание или изменить существующее, выбрав в контекстном меню пункт Create New job или Edit Edit Job соответственно.


История предупреждений

На этой вкладке можно просматривать, когда было отправлено уведомление этому оператору в последний раз.

Operator Editor - Viewing notification history

Last notification by e-mail - последнее уведомление по электронной почте

Last notification by pager - последнее уведомление на пейджер.

Last notification by net send - последнее уведомление по Net Send.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Operator Editor - Viewing SQL definition


Proxies

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Учетные записи-посредники

Учетные записи-посредники (Proxy) агента Microsoft SQL Server определяют контекст безопасности, в котором может выполняться шаг задания. Чтобы установить разрешения для определенного шага задания, создайте учетную запись-посредник, которая имеет необходимые разрешения для подсистемы агента SQL Server, и затем назначьте эту учетную запись-посредник шагу задания. Только члены фиксированной серверной роли sysadmin имеют разрешение на создание, изменение или удаление учетных записей-посредников. Пользователи, не являющиеся членами фиксированной серверной роли sysadmin, должны быть добавлены к одной из следующих фиксированных ролей базы данных агента SQL Server в базе данных msdb, чтобы использовать записи-посредники: SQLAgentUserRole, SQLAgentReaderRole или SQLAgentOperatorRole.

Важно: Для работы с этим типом объектов необходимо запустить SQL Server Agent.

Чтобы открыть объект в соответствующем редакторе, необходимо дважды щелкнуть на нем мышкой или выбрать соответствующий пункт контекстного меню.

SQL Server Agent - Proxies

Все учетные записи-посредники отображаются в виде таблицы со столбцами:

Name - имя учетной записи-посредника;

Credential - имя учетных данных учетной записи-посредника;

Enabled - активна ли учетная запись-посредник;

Description - описание.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Из раскрывающегося списка на панели инструментов можно выбрать подсистему для отображения в списке только тех учетных записей-посредников, которые относятся к выбранной подсистеме.

Контекстное меню

Create Create Proxy - создать новую учетную запись-посредника.

Edit Edit proxy(s) - редактировать учетную запись-посредника.

Drop Drop proxy(s) - удалить учетную запись-посредника.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

  • Rename proxy - переименовать учетную запись-посредника.
  • Enable proxy(s) - включить учетную запись-посредника.
  • Disable proxy(s) - отключить учетную запись-посредника.

Смотрите также:

Задания

История заданий

Предупреждения

Операторы


Редактор учетных записей-посредников

В редакторе Proxy Editor можно задавать все необходимые настройки учетной записи-посредника.

Чтобы открыть объект в редакторе, необходимо дважды щелкнуть на нем мышкой в разделе Учетные записи-посредники, или выбрать пункт контекстного меню Create Create Proxy - создать новую учетную запись-посредника или

Edit Edit proxy(s) - редактировать учетную запись-посредника.

Proxies - Proxy Editor

Список вкладок и часто используемые инструменты отображаются на панели инструментов.

Вкладки редактора:

Задание параметров учетной записи посредника

Управление участниками учетной записи-посредника

Шаги задания

SQL описание


Панель инструментов

На панели инструментов редактора учетных записей-посредников отображаются инструменты, наиболее часто используемые для работы с объектом.

Proxy Editor - Using Navigation bar

Pages

В этом разделе отображается список вкладок редактора.

Object Actions

Apply Apply - сохранить внесенные изменения.

Refresh Refresh - обновить содержимое активной вкладки.

Object

Server

Сервер, которому принадлежит редактируемый объект.

Object

В этом поле отображается редактируемый объект. Можно открыть для изменения другой объект этого же типа, выбрав его из раскрывающегося списка.


Задание параметров учетной записи посредника

На вкладке Proxy задайте основные свойства учетной записи-посредника.

Name - имя создаваемой учетной записи-посредника.

Если установлен флажок !CheckBox Enabled, то учетная запись-посредник включена.

Proxies - Proxy Editor

Из раскрывающегося списка Credential выберите имя учетных данных учетной записи-посредника.

Чтобы создать учетные данные, нажмите кнопку AddJobCategory Add. Чтобы редактировать выбранные учетные данные в Редакторе учетных данных, дважды кликните по ней.

Description - текстовое описание учетной записи-посредника. Описание позволяет документировать учетную запись-посредника, но оно не используется агентом SQL Server для других целей.

В разделе Granted to subsystems укажите одну или несколько подсистем, которым будет предоставлен доступ:

!CheckBox ActiveX script - сценарий Microsoft ActiveX,

!CheckBox Analysis Services Command - команда служб Analysis Services,

!CheckBox Analysis Services Query - запрос служб Analysis Services,

!CheckBox Integration Services Packages - выполнение пакетов служб SSIS.

!CheckBox Operating system command or executable program - команда операционной системы,

!CheckBox PowerShell Script - скрипт PowerShell

!CheckBox Replication Distributor Agent job - агент распространителя репликации,

!CheckBox Replication Log Reader Agent job - агент чтения журнала репликации,

!CheckBox Replication Merge Agent job - агент слияния репликации,

!CheckBox Replication Queue Reader Agent job - агент чтения очереди репликации,

!CheckBox Replication Snapshot Agent job - агент моментальных снимков репликации.


Управление участниками записи-посредника

На вкладке Principals необходимо задать участников (логины, серверные роли и права) учетной записи-посредника. Это не изменяет разрешений, предоставленных участнику, указанному в учетной записи-посреднике.

Proxy Editor - Managing principals

В основном окне отображается список участников (Principal Name) с указанием типа (Principal Type) каждого.

Добавлять участников можно с помощью контекстного меню.

Add Logins - логины, имеющие доступ к данной учетной записи-посреднику.

Add msdb Database Roles - роли базы данных, которые будут иметь доступ к данной учетной записи-посреднику.

Add Server Roles - серверные роли, которые будут иметь доступ к данной учетной записи-посреднику.

Чтобы удалить участника роли, выберите пункт контекстного меню Remove Selected.

Просмотреть свойства объекта можно, выбрав в контекстном меню объекта пункт Properties.


Шаги задания

Все задания, в которых была использована редактируемая учетная запись, будут отображаться на вкладке Job Steps.

Важно: Учетная запись-посредник может быть использована только для шагов задания, которые используют подсистемы, связанные с прокси-сервером. Чтобы создать шаг задания, в котором будет использоваться учетная запись-посредник, владелец задания должен принадлежать логину, связанному с этой учетной записью, или быть членом роли с неограниченным доступом к учетным записям-посредникам.

Proxy Editor - Managing job steps

Задания, в которых используется данная учетная запись-посредник, отображаются в виде таблицы со следующими столбцами:

Job Name - имя задания;

Step Name - имя шага;

Subsystem - тип команды на выполнение.


SQL описание

На этой вкладке можно просмотреть DDL объекта.

Proxy Editor - Viewing SQL definition


Производительность

В разделе проводника Performance предоставлены инструменты для управления следующими группами:

  • Процессы ОС
  • Процессы сервера
  • Блокировки
  • Счетчики производительности
  • Накопленная статистика
  • Статистическая динамика
  • Статистика по индексам
  • Пропущенные индексы

С помощью кнопок на панели управления Вы можете управлять сбором статистики:

StatisticsAutocollection осуществлять сбор статистики автоматически;

DontCollectWhenViewIsNotActive отключить сбор статистики, когда страница Performance неактивна;

  • Collection Interval, sec - частота сбора в секундах (при автоматическом сборе);
  • Chart Range, min - деление осей в минутах.

На рабочей области вкладки Performance расположено несколько секций с графиками и диаграммами, которые визуально показывают значения счетчиков CPU, памяти, физического диска и SQL Server.

CPU

% Time

Этот график показывает время, которое ЦП тратит на выполнение потока во время работы. Отображается частота бездействия системы.

Queue Length

Соответствует количеству потоков, ожидающих обработки процессором. Если потокам некоторого процесса требуется больше циклов процессора, чем это возможно, значит, узким местом системы является процессор. Если количество процессов, требующих обработки процессором, велико, необходимо установить более быстрый процессор. Или, в многопроцессорной системе, необходимо добавить еще один процессор.

Memory

Working set, MB

Этот график отображает, какая часть (в мегабайтах) всей памяти занята процессами с наибольшим потреблением памяти. Список процессов расположен над графиком.

Pages/sec

Показывает число страниц, которые SQL Server считал с диска или записал на диск для того, чтобы разрешить обращения к страницам памяти, которые не были загружены в оперативную память в момент обращения.

Physical Disk

В этом разделе расположено несколько диаграмм производительности выбранного диска.

% Time

Показывает процент времени, в течение которого выбранный диск был занят обработкой запросов на чтение и запись.

Avg. Queue Length

Отображает среднее количество запросов на чтение и запись, которые были поставлены в очередь выбранного диска.

Sec/Read

Показывает среднее время (в секундах) чтения данных с диска.

Sec/Write

Показывает среднее время (в секундах) записи данных на диск.

Reads/sec

Показывает частоту операций чтения.

Reads/sec

Показывает частоту операций записи.

SQL Server

Две круговые диаграммы показывают текущее (Current) и общее (Total) количество ожиданий. Список ожиданий приведен над диаграммой.

Response Time, sec

Этот счетчик отображает время ответа сервера (в секундах) при выполнении SQL запроса (левая вертикальная ось).

User Connections

Показывает количество текущих подключений к серверу (правая вертикальная ось).

Batches/sec

Отображает количество пакетов команд Transact-SQL, получаемых в секунду.

Compilations/sec

Количество SQL компиляций.

Re-compilations/sec

Количество рекомпиляций.

Buffer cache hit ratio

Доля страниц, обнаруженных в буферном кэше без чтения с диска.

Object plan cache hit ratio

Отношение между числом попаданий в кэш и числом обращений к нему.

SQL plan cache hit ratio

Отношение между числом попаданий в кэш SQL запросов или планов пакетов и поиском.

Running Jobs

Здесь отображаются текущие задания на сервере.

Blocked Sessions

Здесь отображается список заблокированных процессов. Блокированный (blocked) процесс ожидает, пока блокирующий процесс закончит свое выполнение. Это может привести к длительной работе процесса. Другими словами, SQL Server преднамеренно предотвращает возможность доступа одного процесса к объекту, если другой процесс установил на нем блокировку. Это означает, что второй процесс не может продолжать работу, пока первый не освободит объект, к которому необходим доступ первому процессу.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Безопасность

Агент SQL сервера

Журнал сервера

Запросы

Опции


Процессы ОС

На странице OS Processes отображаются все процессы операционной системы, на которой установлен SQL Server.

С помощью кнопок на панели управления Вы можете управлять отображением списка процессов:

StatisticsAutocollection обновлять список процессов автоматически;

DontCollectWhenViewIsNotActive отключить получение информации о процессах, когда страница OS Processes неактивна;

  • Refresh Interval, sec - частота обновления информации о процессах в секундах.

Performance - OS Processes

Процессы отображаются в виде таблицы со столбцами:

Name - имя процесса;

CPU Usage (%) - процент использования процессора;

Memory Working Set (KB) - какой объем памяти занимает процесс;

Page Faults/sec - количество отказов страницы памяти в секунду;

I/O Read (bytes/sec) - скорость чтения;

I/O Write (bytes/sec) - скорость записи;

I/O Other (bytes/sec) - скорость выполнения других операций;

Process Description - описание процесса.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы сервера

Блокировки

Текущая статистика

Накопленная статистика

Статистика по индексам

Пропущенные индексы


Процессы сервера

На странице Server Processes отображаются все системные и несистемные процессы, запущенные на сервере. Здесь вы можете просмотреть свойства текущего процесса.

Используя контекстное меню можно:

KillProcess Kill process - завершить процесс;

ShowSQL Show SQL - показать текст команды, выполняемой процессом.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Performance - Processes

Информация о процессах отображается в виде таблицы со столбцами:

Process Info - информация о процессе:

Process ID - идентификатор сеанса процесса;

Status - состояние идентификатора процесса;

Is System - является ли процесс системным;

Database - база данных, используемая процессом в данный момент;

Command - выполняемая команда;

Client Info - информация о клиенте:

Login Name - имя входа;

Original Login Name - имя входа, которое используется для подключения к экземпляру SQL Server;

Host Name - имя рабочей станции;

Program Name - имя приложения;

Locks - блокировки:

Blocked By - блокирующий процесс;

Number of Blocking Processes - число блокирующих процессов;

Wait Time - время ожидания;

Last Wait Type - имя последнего или текущего типа ожидания;

Wait Resource - ресурс блокировки;

Process Statistics - статистика процесса.

В этом разделе представлены различные счетчики продуктивности процесса:

CPU Time - процессорное время;

Physical IO - совокупное число считанных и записанных на диск страниц;

Reads - число страниц, считанных с диска;

Writes - число страниц, записанных на диск;

Logical Reads - число страниц, считанных из кэша;

Memory Usage (KB) - объем памяти, используемой процессом;

Open Transactions - число открытых транзакций;

Transaction Isolation Level - уровень изоляции транзакции;

Row Count - число строк.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы ОС

Блокировки

Текущая статистика

Накопленная статистика

Статистика по индексам

Пропущенные индексы


Блокировки

На странице Locks отображаются сведения о блокировках SQL Server, полученных для отдельных типов ресурсов. Блокировки выдаются на такие ресурсы SQL Server, как прочитанные или измененные транзакцией строки, для предотвращения одновременного использования ресурсов несколькими транзакциями.

Контекстное меню

KillProcess Kill process - завершить процесс;

ShowSQL Show SQL - показать текст команды процесса;

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Performance - Locks

Информация о процессах отображается в виде таблицы со столбцами:

Process ID - идентификатор сеанса процесса;

Request Mode - идентификатор запроса;

Resource Type - тип ресурса;

Resource Subtype - подтип ресурса;

Database - база данных, на которой запущен процесс;

Schema - схема;

Object - объект базы данных;

Resource Description - описание ресурса;

Request Mode - режим запроса;

Request Type - тип запроса;

Request Owner GUID - идентификатор GUID определенного владельца запроса;

Request Owner ID - идентификатор определенного владельца запроса;

Request Status - текущее состояние запроса;

Request Reference Count - приблизительное количество случаев, когда этот ресурс был запрошен одним и тем же объектом;

Request Owner Type - тип сущности, которой принадлежит запрос;

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы

Текущая статистика

Накопленная статистика

Статистика по индексам

Пропущенные индексы


Счетчики производительности

На странице Current Statistics отображаются диаграммы статистических данных, собранных программой SQL Administrator. Эти диаграммы строятся на основе показателей счетчиков продуктивности SQL Server.

Статистика помогает отслеживать текущую продуктивность SQL Server.

Performance - Current statistics

Изначально рабочая область разделена на 6 секций:

  • Processor. % Processor Time. Показывает диаграмму изменения процессорного времени, то есть показывает процентное отношение времени, которое процессор был занят выполнением операций для непростаивающих потоков (non-Idle thread). Эту величину можно рассматривать как долю времени, приходящегося на выполнение полезной работы.
  • Memory. Available (MB). Эта диаграмма отображает объем доступной памяти на сервере.
  • Memory. Pages/sec. Показывает число страниц, которые SQL Server считал с диска или записал на диск для того, чтобы разрешить обращения к страницам памяти, которые не были загружены в оперативную память в момент обращения.
  • Physical Disk. % Disk Time. Показывает процент занятости диска. Эта диаграмма - основной показатель занятости диска. Счетчик может быть использован для обнаружения проблем. Чтобы получить более достоверную информацию о состоянии диска, используйте также счетчик Disk Queue Length.
  • Physical Disk. Avg. Disk Queue Length. Этот счетчик показывает эффективность дисковой подсистемы. Длина очереди диска - это среднее общее количество запросов на чтение и на запись, которые были поставлены в очередь для соответствующего диска в течение интервала измерения.
  • SQL Server: Plan Cache. Object Plans Cache Hit Ratio. Соотношение между числом попаданий в кэш и числом обращений к нему.

Чтобы увеличить диаграмму, дважды кликните по ней.

С помощью кнопок на панели управления Вы можете управлять сбором статистики:

  • Diagram Set - выберите необходимый набор диаграмм;

StatisticsAutocollection осуществлять сбор статистики автоматически;

CollectStatisticsNow получить значения счетчиков на текущий момент времени;

DontCollectWhenViewIsNotActive отключить сбор статистики, когда страница Current Statistics неактивна;

  • Collection Interval, sec - частота сбора в секундах (при автоматическом сборе);
  • Chart Range, min - деление осей в минутах.

Filter задать фильтр для счетчиков - выбрать диски, для которых следует собирать статистику.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

При нажатии на кнопку Ellipsisbtn в поле Diagram Set появляется диалог настройки таблицы диаграмм, в котором Вы можете указать, какие диаграммы показывать и какие счетчики использовать.

Performance - Current statistics - Chart view customization

Chart view

В этом разделе можно задать названия групп диаграмм.

Контекстное меню

Create создать новую группу диаграмм;

Edit переименовать группу диаграмм;

Drop удалить группу диаграмм;

MoveUp переместить вверх;

MoveDown переместить вниз.

Charts

В этом разделе Вы можете указать, какие диаграммы должны быть представлены в выбранной группе:

Create создать диаграмму;

Edit переименовать диаграмму;

Drop удалить диаграмму;

MoveUp переместить вверх;

MoveDown переместить вниз.

При создании новой диаграммы появляется окно Performance Counter, в котором Вы можете выбрать счетчик производительности для построения диаграммы.

Performance - Current statistics - Chart view customization - Performance counter

В списке показаны счетчики производительности, которые помогают определить производительность процессора, логических и физических дисков, памяти, сервера и т.д. Чтобы создать новую диаграмму выберите нужный счетчик из списка и нажмите кнопку OK.

Counters

В этом разделе Вы можете задавать счетчики для диаграмм.

Create добавить счетчик;

Drop удалить счетчик;

MoveUp переместить вверх;

MoveDown переместить вниз.

При добавлении нового счетчика появляется диалог Performance Counter.

Важно: Некоторые статистики не собираются, если не установлено WMI подключение к серверу.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы

Блокировки

Накопленная статистика

Статистика по индексам

Пропущенные индексы


Накопленная статистика

На странице Collected Statistics показаны диаграммы накопленной статистики. Но, в отличие от текущей статистики, сбор этой статистики осуществляется с помощью службы сбора статистики - Statistics Collector service. Она записывает данные (значения счетчиков производительности) о производительности сервера в заданную базу данных - репозитарий сервера. Диаграммы строятся на основе данных, записанных в этой базе.

Эта статистика помогает отслеживать текущую производительность сервера так же как и текущая статистика, но также позволяет сравнивать показатели производительности сервера в разные промежутки времени.

Важно: Разрывы на графиках означают промежутки времени, когда служба сбора статистики была остановлена.

Performance - Collected statistics

Изначально рабочая область разделена на 6 секций:

  • Processor. % Processor Time. Показывает диаграмму изменения процессорного времени, то есть показывает процентное отношение времени, которое процессор был занят выполнением операций для непростаивающих потоков (non-Idle thread). Эту величину можно рассматривать как долю времени, приходящегося на выполнение полезной работы.
  • Memory. Available (MB). Эта диаграмма отображает объем доступной памяти на сервере.
  • Memory. Pages/sec. Показывает число страниц, которые SQL Server считал с диска или записал на диск для того, чтобы разрешить обращения к страницам памяти, которые не были загружены в оперативную память в момент обращения.
  • Physical Disk. % Disk Time. Показывает процент занятости диска. Эта диаграмма - основной показатель занятости диска. Счетчик может быть использован для обнаружения проблем. Чтобы получить более достоверную информацию о состоянии диска, используйте также счетчик Disk Queue Length.
  • Physical Disk. Avg. Disk Queue Length. Этот счетчик показывает эффективность дисковой подсистемы. Длина очереди диска - это среднее общее количество запросов на чтение и на запись, которые были поставлены в очередь для соответствующего диска в течение интервала измерения.
  • SQL Server: Plan Cache. Object Plans Cache Hit Ratio. Соотношение между числом попаданий в кэш и числом обращений к нему.

Чтобы увеличить диаграмму, дважды кликните по ней.

С помощью кнопок на панели управления Вы можете управлять представлением статистики на диаграммах:

  • Chart View - выберите необходимый набор диаграмм;
  • Date Interval - выберите промежуток времени, за который следует показывать статистику;

Filter задать фильтр для счетчиков - выбрать диски, для которых следует показывать статистику.

  • Smoothing - с помощью кнопок '+' / '-' или бегунка установите предпочитаемый уровень сглаживания графиков.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Настройка отображения диаграмм производится так же, как и на странице текущей статистики.

Настройка интервалов

Вы можете добавить временной интервал в группу интервалов нажав кнопку AddJobCategory в поле Date Intervals. Чтобы отредактировать выбранный временной интервал, нажмите кнопку OpenInEditor . При нажатии на одну из этих кнопок, появляется диалог Date Intervals.

Collected statistics - Date intervals

В окне приведен список интервалов в группе. Здесь Вы можете определить, за какие периоды времени следует показывать накопленную статистику.

Контекстное меню

Create добавить временной интервал;

Edit редактировать временной интервал;

Drop удалить временной интервал;

MoveUp переместить вверх;

MoveDown переместить вниз.

При добавлении нового или редактировании выбранного интервала появляется следующий диалог.

Collected statistics - Date interval of Statistics

Сначала выберите тип шкалы: !RadioButton Source - detailed statistics (детальная статистика) или !RadioButton Source - average statistics (средняя статистика). Усредненная статистика - статистика, которая вычисляется на основе показателей детальной

статистики посредством задания, которое создается автоматически при установке службы Statistics Collector service.

При выборе первой опции задайте начало интервала (Start time) и конец интервала (End time). Вы можете ввести их вручную или выбрать дату из раскрывающегося календаря.

При выборе второй опции задайте год (Year) и месяц (Month), чтобы показывать усредненную статистику, накопленную за месяц.

Важно: Если Вы задали несколько временных интервалов в группе интервалов, тогда на горизонтальной оси будет отображаться первый. Если есть более продолжительный интервал, тогда разница между его длиной и длиной первого интервала будет добавлена к оси. Таким образом, продолжительность итогового интервала равна продолжительности самого длинного интервала в группе, а его начало совпадает с началом первого интервала.

Если в группе среди интервалов детальной статистики задан интервал усредненной статистики, то для итогового интервала берется указанный в поле Month месяц, а дни берутся из самого длинного интервала в группе.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы

Блокировки

Текущая статистика

Статистика по индексам

Пропущенные индексы


Статистическая динамика

На вкладке Collected Statistics Trend показаны графики, которые отражают динамику изменения значений счетчиков производительности, собранных службой сбора статистики. Этот инструмент помогает выявить счетчики, значения которых сильно изменились в заданный промежуток времени.

Рабочая область разделена на две части. В верхней области приведен список доступных счетчиков и следующая информация о них:

Performance Group - группа счетчиков производительности;

Performance Counter - имя счетчика производительности;

Instance - экземпляр сервера;

Statistics Trend - схематичный график динамики изменения показателей счетчика.

По умолчанию, записи в таблице отсортированы по значению изменения счетчиков (столбец Statistics Trend).

Выберите нужный счетчик и дважды кликните по нему или используйте пункт Show Details контекстного меню, чтобы просмотреть подробную диаграмму динамики его изменения. Она отобразится в нижней области страницы.

Performance - Collected statistics - Collected statistics trend

С помощью кнопок на панели управления Вы можете управлять представлением статистики на диаграммах:

  • Date Interval - выберите промежуток времени, за который следует показывать статистику: день, неделю, месяц, четверть или год;
  • Smoothing - с помощью кнопок '+' / '-' или бегунка установите предпочитаемый уровень сглаживания графиков;
  • Ranges - задайте диапазоны значений счетчиков, которые следует считать равными;
  • Week Time - выберите дни недели и время, за которые следует показывать динамику статистики;
  • Expand/Collapse all rows - используйте эти кнопки, чтобы свернуть/развернуть записи, когда они сгруппированы.

С помощью пункта контекстного меню Print Print Вы можете создать отчет и открыть окно предварительного просмотра перед печатью.

Выбор дней недели

Collected statistics trend - Week time

В списке Week days отметьте дни, за которые следует показывать статистику. Затем установите промежуток времени суток (Day time). Чтобы показывать статистику за весь день, установите флажок !CheckBox All day time.

Настройка диапазонов

Collected statistics trend - Ranges

Графики статистической динамики строятся на основе значений счетчиков, у которых разные единицы измерения. Например, счетчик Avg Disk Queue Length обычно принимает малые значения, в то время как счетчик Disk Transfers/sec достигает значения 100 и выше.

По этой причине некорректно сравнивать значения разных счетчиков (и их изменения) в том виде, в котором они собираются службой сбора статистики.

Поэтому необходимо задать диапазоны значений для различных счетчиков, которые следует считать равными. Эта настройка производится в диалоге Equal Counter Value Ranges. Например, на скриншоте показано, что изменение значения счетчика % Disk Time от 0 до 100 сопоставимо с изменением значений счетчика Avg Disk Queue Length от 0 до 4 и т.д. Это означает, что значения всех счетчиков масштабируются с учетом заданных в диалоге интервалов по следующему принципу.

  1. Полученное значение счетчика делится на соответствующую ему длину диапазона, заданную в колонке Range.
  2. Ищется счетчик с максимальным значением изменения и помещается на первую строчку в таблице Collected Statistics Trend.
  3. Значения других счетчиков делятся на величину изменения этого максимального счетчика.
  4. Все диаграммы в таблице перестраиваются согласно масштабированным значениям, затем сглаживаются.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.


Статистика по индексам

Страница Index Physical Stats содержит информацию о размере и фрагментации данных и индексов всех таблиц и представлений выбранной базы данных.

Чтобы посмотреть статистику, выберите базу из списка Database на панели управления.

С помощью контекстного меню или кнопок на панели управления Вы можете:

RebuildIndexes Rebuild/Reorganise Indexes - вызвать мастер перестройки и реорганизации индексов;

  • Rebuild indexes - перестроить индексы;
  • Reorganise indexes - реорганизовать индексы;
  • Disable indexes - отключить индекс;
  • Enable indexes - активировать индекс.

Print Print - создать отчет и открыть окно предварительного просмотра перед печатью.

Rebuld_Reorganize Indexes - Index Physical Stats

Информация об индексах отображается в виде таблицы со столбцами:

Schema - имя схемы;

Table - имя таблицы;

Index - имя индекса;

Partition Number - номер секции в объекте;

Index Type - тип индекса;

Allocation Unit - тип единицы распределения;

Fragmentation (%) - логическая фрагментация индекса;

Index Depth - количество уровней индекса;

Number of Fragments - количество фрагментов;

Avg Fragment Size (Pages) - среднее количество страниц в одном фрагменте;

Number of Pages - общее количество страниц индекса или данных;

Avg. Used Page Space (%) - средний процент доступного места для хранения данных, используемого всеми страницами;

Number of Records - общее количество записей;

Min. Record Size (Bytes) - минимальный размер записи;

Max. Record Size (Bytes) - максимальный размер записи;

Avg. Record Size (Bytes) - средний размер записи;

Number of Compressed Pages - количество сжатых страниц.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы

Блокировки

Текущая статистика

Накопленная статистика

Пропущенные индексы


Отсутствующие индексы

При формировании плана запроса оптимизатор запросов анализирует, какие индексы наилучшим образом подойдут для конкретного условия фильтра. Если наиболее подходящие индексы не существуют, оптимизатор запросов формирует близкий к оптимальному план запроса, однако по-прежнему сохраняет сведения об этих индексах.

На странице Missing Indexes Вы можете получить сведения об отсутствующих индексах и решить, стоит ли их реализовывать или нет.

Performance - Missing indexes

Информация об отсутствующих индексах отображается в виде таблицы со столбцами:

Database Name - имя базы данных;

Schema Name - имя схемы;

Object Name - имя объекта;

Index Columns - столбцы таблицы базе данных, которых не хватает в индексе;

Creation Index Benefit - на сколько уменьшатся затраты при выполнении запроса при создании индекса.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Чтобы создать отсутствующий индекс используйте пункт CreateIndex Create Index... контекстного меню или нажмите соответствующую кнопку на панели управления. В появившемся окне при необходимости отредактируйте скрипт создания индекса и нажмите кнопку OK.

С помощью пункта контекстного меню Print Print Вы можете создать отчет и открыть окно предварительного просмотра перед печатью.

При выборе отсутствующего индекса в верхней таблице, в нижней (Missing Index Estimated Usage) показывается подробная информация о его предполагаемом использовании: Index Columns: Compared with Equality, Included, Compared with Inequality; User Queries That May Use Index: Index Seeks, Index Scans, Last Seek, Last Scan, Avg Total Query Cost, Query Cost Benefit (%); System Queries That May Use Indexes: Index Seeks, Index Scans, Last Seek, Last Scan, Avg Total Query Cost, Query Cost Benefit (%); Total Benefit.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.

Смотрите также:

Процессы

Блокировки

Текущая статистика

Накопленная статистика

Статистика по индексам


Журнал сервера

Информация, приведенная на странице SQL Server Log позволяет анализировать журналы событий сервера. С их помощью пользователь может просмотреть все действия, выполнявшиеся на сервере в течение сеанса.

SQL Server Log

У всех журналов есть поля Date (дата) и Message (сообщение). В зависимости от выбранных журналов таблица будет содержать различные столбцы.

SQL Server Log: Event Source, Log Type, Log Name.

SQL Server Agent Log: Message, Error Level, Log Type, Log Name.

Database Mail Log: Message, Event Type, Process, Mail Item ID, Account ID.

Windows Log: Event Source, Category, Event Code, User, Event Type, Log Type, Log Name.

При выборе записи журнала в таблице поля под таблицей заполняются следующей информацией (в зависимости от типа журнала):

  • Message (for all logs) - сообщение, связанное с событием;
  • Date (for all logs) - дата события;
  • Category (for Windows logs only) - категория события, которая иногда используется для дальнейшего описания связанных событий;
  • Event code (for Windows logs only) - идентификатор события;
  • Event type (for Database Mail and Windows logs) - тип уведомления, помещаемого в журнал. Допустимые значения: errors(ошибки), warnings(предупреждения), informational messages (информационные сообщения), success messages (сообщения об успешном завершении) и additional internal messages (дополнительные внутренние сообщения);
  • Process (for Database Mail logs only) - идентификатор процесса внешней программы Database Mail. Обычно он изменяется при каждом запуске внешней программы Database Mail;
  • Event Source (for SQL Server and Windows logs) - исходная функция, создавшая событие, например, имя службы (MSSQLSERVER);
  • User (for Windows logs only) - имя пользователя, под которым был выполнен вход, когда произошло событие;
  • Error level (for SQL Server Agent log only) - указывает тип проблемы, с которой столкнулся сервер SQL Server;
  • Mail item ID (for Database Mail only) - идентификатор почтового отправления в очереди почты. Содержит NULL, если сообщение не относится к определенному элементу электронной почты;
  • Account ID (for Database Mail only) - идентификатор учетной записи, относящейся к событию. Содержит NULL, если сообщение не относится к определенной учетной записи.

С помощью пункта контекстного меню Print Print Вы можете создать отчет и открыть окно предварительного просмотра перед печатью.

Чтобы вызвать диалог выбора журналов, используйте пункт SelectLogs Select Logs контекстного меню или соответствующую кнопку на панели управления.

SQL Server Log - Select server logs

Из приведенного списка журналов выберите те, которые следует показывать в таблице на странице SQL Server Logs.

Доступны следующие типы журналов:

  • SQL Server Log

Журнал ошибок SQL Server позволяет убедиться, что процессы были завершены успешно (например, операции резервного копирования и восстановления, пакеты команд или другие сценарии и процессы). Это полезно при определении любых текущих или потенциальных проблем, включая сообщения автоматического восстановления, сообщения ядра и другие сообщения об ошибках на уровне сервера. Обычно SQL Server хранит резервные копии шести предыдущих журналов и присваивает наиболее свежей копии расширение «.1», следующей - расширение «.2» и т. д. Файл текущего журнала ошибок расширения не имеет.

  • SQL Server Agent Log

Агент SQL Server создает журнал ошибок, в который по умолчанию записываются предупреждения и ошибки. В журнале отображаются следующие предупреждения и ошибки:

  • Предупреждающие сообщения, содержащие сведения о потенциальных проблемах, например «Задание <job_name> удалено в процессе выполнения».
  • Сообщения об ошибках, обычно требующих вмешательства системного администратора, например «Невозможно начать почтовый сеанс».

SQL Server поддерживает до девяти журналов ошибок агента SQL Server. Каждый архивируемый журнал снабжается расширением, указывающим относительный срок давности журнала. Например, расширение .1 указывает на новейший архивированный журнал ошибок, а расширение .9 — на наиболее старый.

  • Database Mail Log

Компонент Database Mail хранит сведения о регистрации в базе данных msdb. Сведения о содержимом сообщений электронной почты Database Mail, их состояниях, а также о любых полученных сообщениях, например, сообщениях об ошибках регистрируются в Database Mail и могут использоваться для аудита или обеспечения безопасности.

  • Windows Log

Журнал событий Windows является важным источником информации при устранении ошибок сервера SQL. Он включает в себя 4 полезных журнала:

  • Application log - журнал приложений;
  • Security log - журнал безопасности;
  • System log - системный журнал;
  • PowerShell Scipt log - журнал PowerShell Script.

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Безопасность

Агент SQL сервера

Производительность

Запросы

Опции


Запросы

Query Editor - инструмент, используемый для создания и выполнения запросов. В редакторе можно создавать и изменять текст запросов, выполнять запросы, просматривать и экспортировать результаты их выполнения.

Чтобы создать или открыть редактор запросов, необходимо выбрать пункт Query | New / Open в главном меню программы или использовать сочетания клавиш Ctrl+N / Ctrl+O.

Панели инструментов

Редактор запросов

Контекстное меню редактора

Выполнение запросов

Просмотр сообщений

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Безопасность

Агент SQL сервера

Производительность

Журнал сервера

Опции


Панели инструментов

Панель инструментов располагается над редактором. На неё вынесены инструменты для работы с запросами.

Query Editor - Using toolbar

ConnectToServer Connect - подключиться к серверу.

DisconnectFromServer Disconnect - отключиться от сервера.

SelectDatabase Database - выбрать базу данных, на которой будет выполнен запрос.

NewQuery Create - создать новый запрос.

OpenQuery Load - загрузить запрос из файла *.sql.

Apply Save - сохранить запрос в файл *.sql.

Execute Execute - выполнить запрос.

Cancel Cancel - остановить выполнение.

Search Find text - найти текст.

Чтобы выполнить запрос, необходимо выбрать, в какой из подключенных баз данных он будет выполнен.

При нажатии кнопки ConnectToServer Connect открывается диалоговое окно Server Connection с параметрами подключения к серверу.

Важно: Это диалоговое окно появляется при создании нового запроса или открытии уже существующего.

Query Editor - Server connection

Server Group

Группа в проводнике, к которой принадлежит выбранный сервер.

Server Name

Из раскрывающегося списка зарегистрированных серверов выберите сервер для подключения.

В разделе Authentication задается способ идентификации пользователя на сервере.

!RadioButton Windows Authentication

Программа распознает пользователя по его доменному имени и паролю. Имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows.

!RadioButton SQL Server authentication

Программа распознает пользователя по его персональным имени и паролю на сервере.

Если выбираете SQL Server authentication, то следует указать имя и пароль в полях Login и Password соответственно.

По имени и паролю система определяет ваши права доступа к информации и, в соответствии с этим, разрешает доступ к объектам.

Database

Выберите базу данных, в контексте которой будет выполнен запрос.

Recent

В этом списке перечислены последние базы данных, которые были использованы для выполнения запроса.

All

В этом списке перечислены все базы данных на выбранном сервере. Если подключение к серверу не установлено, то необходимо нажать кнопку Load, чтобы получить список баз этого сервера.


Редактор запросов

Query Editor предназначен для работы с текстом запроса и предоставляет для этого все необходимые инструменты:

  • подсветка синтаксиса;
  • отображение номеров строк;
  • настраиваемая ширина границ и полей;

и многое другое.

При необходимости можно включить/отключить или настроить некоторые функции редактора запросов в диалоговом окне Query Tool Options.

Существует возможность автоматической подстановки текста. Настроить задержку отображения списка подстановки можно на вкладке Quick code диалогового окна SQL Editor Options.

Вручную вызвать список автоподстановки можно с помощью сочетания клавиш Ctrl+Space.

Если использовать это сочетание клавиш после после имени схемы, то в выпадающем списке будет приведен перечень всех таблиц в этой схеме. Если после имени таблицы - перечень всех полей в этой таблице.

Query Editor - Working with the Query Editor area

Доступ к инструментам работы с текстом запроса обеспечивается с помощью контекстного меню.

Смотрите также:

Панели инструментов

Контекстное меню редактора

Выполнение запросов

Просмотр сообщений


Контекстное меню редактора

Для редактора текста запроса существует контекстное меню, которое отрывается по нажатию правой клавиши мыши в любой точке области редактирования. Это меню позволяет быстро выполнять самые используемые команды.

Query Editor - Context menu

Execute from cursor - выполнить выбранный оператор;

Cut - вырезать текст;

Copy - копировать текст;

Paste - вставить текст;

Select All - выбрать все;

Undo - отменить действие;

Redo - вернуть отмененное действие;

Toggle Bookmark - установить закладку;

Toggle Numbered Bookmark - установить нумерованную закладку;

Go to Next Bookmark - перейти к следующей закладке;

Go to Previous Bookmark - перейти к предыдущей закладке;

Go to Numbered Bookmark - перейти к нумерованной закладке;

Editor Options - изменить настройки редактора в Editor Options;

Query Tool Options - изменить настройки редактора в Query Tool Options.

Подменю пункта Advanced:

Find - найти текст;

Replace - заменить текст;

Find Next - продолжить поиск;

Comment - закомментировать выбранный фрагмент;

Uncomment - убрать символы, обращающие данный фрагмент текста в комментарий;

Indent Selection - увеличить отступ выделенного текста;

Unindent Selection - уменьшить отступ выделенного текста;

Make Uppercase - привести выделенный текст к верхнему регистру;

Make Lowercase - привести выделенный текст к нижнему регистру;

Toggle Case - изменить регистр выделенного текста;

View Special Characters - показать знаки форматирования;

Show Code Completion - отобразить список автоподстановки;

Go to line - перейти к строке с номером. Номер строки задается в появляющемся диалоге.

Смотрите также:

Панели инструментов

Редактор запросов

Выполнение запросов

Просмотр сообщений


Выполнение запросов

Чтобы выполнить запрос необходимо нажать Execute Execute на панели инструментов или в контекстном меню.

Если синтаксис SQL правильный, запрос выполняется. Возвращаемый набор данных отображается на вкладке Results.

Если текст запроса содержит ошибки, выполнение запроса прекращается, и на вкладке Messages появляется соответствующее сообщение об ошибке.

Query Editor - Results tab

Контекстное меню вкладки Results.

Result on Separate Tab - результат выполнения запроса на отдельной вкладке/на той же вкладке, что и текст.

Fit Height of All Grids - выровнять высоту всех таблиц.

Save Data - сохранить отредактированные данные.

Discard Changes - отменить изменения.

Edit in BLOB Editor - редактировать поле в редакторе данных типа BLOB.

Set to NULL - присвоить пустое значение (если у поля нет ограничения Not Null).

Set to Empty String - изменить значение на пустую строку.

Print - распечатать таблицу.

Export Data - экспортировать данные во внешний файл.

Query Tool Options - открыть диалоговое окно Query Tool Options.

Если у таблицы есть первичный ключ, то результаты выполнения запроса можно редактировать. Возможность редактирования обозначается иконкой editingEnabled на нижней панели.

С помощью панели управления записями, расположенной в левом нижнем углу, можно:

  • перейти к первой записи,
  • перейти к предыдущей странице,
  • перейти к предыдущей записи,
  • перейти к следующей записи,
  • перейти к следующей странице,
  • перейти к последней записи,
  • добавить запись,
  • удалить запись,
  • редактировать запись,
  • сохранить изменения,
  • отклонить изменения.

Для удобства просмотра можно использовать инструменты работы с таблицей, такие как сортировка, фильтрация и изменение порядка столбцов.

Смотрите также:

Панели инструментов

Редактор запросов

Контекстное меню редактора

Просмотр сообщений


Редактор данных типа BLOB

Для просмотра и редактирования полей, имеющих тип данных, относящийся к BLOB, используется специальный редактор BLOB Editor.

Чтобы открыть значение поля в редакторе, щелкните по нему два раза или используйте пункт контекстного меню Edit in BLOB Editor.

Поля следующих типов данных могут быть отредактированы в редакторе BLOB Editor:

  • binary;
  • char;
  • image;
  • nchar;
  • ntext;
  • nvarchar;
  • sysname;
  • text;
  • varbinary;
  • varchar;
  • xml.

Редактор содержит четыре вкладки для редактирования соответствующих представлений BLOB полей:

  • Hexadecimal
  • Text
  • Rich Text
  • Image

Важно: Для строковых типов данных доступны только вкладки Text и Rich Text.


Редактирование Hexadecimal

На вкладке Hexadecimal Вы можете просмотреть и отредактировать информацию, содержащуюся в одной ячейке поля типа BLOB.

В левой части формы содержимое ячейки представлено в шестнадцатеричном виде, а в правой - в виде обычного текста.

Query Editor - BLOB Editor - Hexadecimal

С помощью кнопок Load... и Save... Вы можете загружать данные из файла и сохранять отредактированные данные в файл.


Редактирование Text

На вкладке Text содержимое ячейки представлено в виде обычного текста, доступного для редактирования.

Для редактирования текста может быть использовано контекстное меню, которое отрывается по нажатию правой клавиши мыши в любой точке области редактирования. Это меню позволяет быстро выполнять самые используемые команды:

  • Cut - вырезать;
  • Copy - копировать;
  • Paste - вставить;
  • Select All - выбрать все;
  • Undo - отменить;
  • Delete - удалить.

Query Editor - BLOB Editor - Text

С помощью выпадающего списка Text encoding выберите необходимую кодировку текста: ANSI, Unicode, Unicode Big Endian или UTF-8.

С помощью кнопок Load... и Save... Вы можете загружать данные из *.txt файла и сохранять отредактированные данные в *.txt файл.


Редактирование Rich Text

На вкладке Rich Text текст представлен в виде RTF (Rich Text Format). Текст отображается в отформатированном виде.

Query Editor - BLOB Editor - Rich Text

С помощью кнопок Load... и Save... Вы можете загружать данные из *.rtf файла и сохранять отредактированные данные в *.rtf файл.


Редактирование Image

Если поле в базе данных имеет тип image, то добавить в это поле изображение, а также просмотреть его можно на вкладке Image.

Query Editor - BLOB Editor - Image

С помощью кнопок Load... и Save... Вы можете загружать изображение из файла и сохранять в файл. Поддерживаются следующие форматы файлов изображений: *.bmp, *.wmf, *.ico, *.png, *.gif, *.ico, *.exif. *.tiff, *.emf и *.jpg.


Просмотр сообщений

На вкладке Messages отображаются системные сообщения, появившиеся в процессе выполнения запроса.

Информация показывается в виде таблицы со следующими столбцами:

  • Batch # - номер сообщения;
  • Message - текст сообщения;
  • Time - время выполнения запроса.

Query Editor - Messages tab

С помощью контекстного меню можно:

  • Go to Statement - перейти на вкладку SQL к оператору, содержащему ошибку.
  • Select Statement - перейти на вкладку SQL к оператору, содержащему ошибку, и выделить этот оператор.
  • Result on Separate Tab - результат выполнения запроса на отдельной вкладке/на той же вкладке, что и текст.
  • Show SQL... - открыть оператор SQL, содержащий ошибку, в отдельном окне редактора.
  • Make a Script of Statements with Error in New Window - копировать текст скрипта с этой ошибкой в новый редактор запросов и перейти к нему.
  • Copy Message to Clipboard - копировать сообщение в буфер обмена.
  • Query Tool Options - открыть диалоговое окно Query Tool Options.

Смотрите также:

Панели инструментов

Редактор запросов

Контекстное меню редактора

Выполнение запросов


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Опции

В диалоговом окне Options можно настроить основные параметры программы SQL Administrator.

Чтобы открыть это окно, необходимо в главном меню выбрать пункт Tools | Options.

Настройки окружения

Проводник

Сборщик статистики

Настройки выполнения запросов

Редактор запросов

Подсветка

Быстрый код

Внешний вид

Смотрите также:

Начало работы

Работа с серверами

Обслуживание серверов и баз данных

Хранение

Безопасность

Агент SQL сервера

Производительность

Журнал сервера

Запросы


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Настройки окружения

В разделе Windows layout можно выбрать, в каком виде будут отображаться окна программы.

!RadioButton Tabbed document - все рабочие области будут отображаться в виде вкладок в пределах одного окна.

!RadioButton Multiple document - все рабочие области будут отображаться в отдельных окнах.

Options - Environment

!CheckBox Run Server Explorer at startup

Если этот флажок установлен, то Проводник будет отображаться при каждом запуске программы.

!CheckBox Run Start Page at startup

Если этот флажок установлен, то стартовая страница будет отображаться при запуске программы.

Maximum number of recent files in Query menu

В этом поле можно задать максимальное число последних открытых файлов запросов, отображаемых в пункте главного меню Query.

Maximum number of windows in Window menu

В этом поле можно задать максимальное число открытых окон, отображаемых в пункте главного меню Windows.

!CheckBox Check statistics averaging jobs outcome at startup

Если этот флажок установлен, то при запуске программы будет отображаться диалоговое окно с информацией о невыполненных заданиях.

!CheckBox Log program errors to the log file

Все ошибки будут записываться в файл журнала 'SQLAdmin.log', который создается в директории установки программы.


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Проводник

!CheckBox Save/restore grouping, sorting, filtering and summaries of views

Если установлен этот флажок, то при последующем открытии таблицы будут сохранены все сделанные настройки, такие как группировки, сортировки и фильтры.

Options - Server explorer

!CheckBox Confirm revoke a grant with grant option

Если установлен этот флажок, то SQL Administrator будет запрашивать подтверждение на аннулирование сохраненных прав с правами 'GRANT'.


Сборщик статистики

На этой вкладке задайте настройки сборщика статистики.

Options - Statistics collector

Имена серверов для которых не будет осуществляться сборка статистики можно добавить в список вручную, или с помощью кнопки Add Servers.


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Настройки выполнения запросов

На этой вкладке задайте настройки выполнения запросов.

Options - Query tool

!CheckBox Results on separate tab

Если флажок установлен, то результаты запроса будут отображаться на отдельной вкладке редактора запросов.

!CheckBox Switch to results tab after execution

Если установлен этот флажок, то после выполнения запроса автоматически откроется вкладка с результатами выполнения.

!RadioButton Messages as table

Сообщения на вкладке Messages отображаются в виде таблицы. Такое представление удобно для просмотра сообщений.

!RadioButton Messages as text

Сообщения на вкладке Messages отображаются в виде текста. Такое представление удобно для копирования текста сообщений.

!CheckBox Add SQL text to messages

Если этот флажок установлен, то к сообщению будут приложены выполненные SQL операторы.

!CheckBox Execute in transaction and rollback on error

Если этот флажок установлен, то транзакция будет откатываться автоматически при возникновении ошибки.

!CheckBox Stop execution on error

Если этот флажок установлен, то выполнение запроса будет остановлено при возникновении ошибки.

Timeout, seconds

Задает время (в секундах), в течение которого может выполняться запрос перед истечением времени ожидания SQL Server. (0 - нет ограничения по времени)

Maximum number of returned rows

В этом поле укажите максимальное число строк, возвращаемое при выполнении запроса.

Maximum size of returned text data, bytes

В этом поле укажите максимальный размер (в байтах) возвращаемых при выполнении запроса текстовых данных.


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Редактор запросов

На этой вкладке задайте настройки Редактора запросов.

Options - SQL editor

General

!CheckBox Insert mode

Включен режим автоматической вставки символов.

!CheckBox Auto indent

Каждый новый отступ такой же, как в предыдущей строке.

!CheckBox Drag and drop text ending

Разрешить перетаскивание текста.

!CheckBox Cursor beyond end of line

Если щелкнуть мышью по пустому пространству после текста в строке, то курсор автоматически переместится в конец текста. Также применяется и при перемещении курсора кнопками Up/Down.

!CheckBox Home key behaviour similar to Visual Studio

При нажатии клавиши Home курсор перемещается в начало строки.

Tabs

Tab size

Длина отступа при табуляции.

!RadioButton Tab to spaces - при нажатии клавиши TAB вставлять пробелы.

!RadioButton Keep tabs - при нажатии клавиши TAB вставлять символы табуляции.

Display

Editor font

Из этого раскрывающегося списка необходимо выбрать шрифт текста запроса.

Font size

Из этого раскрывающегося списка необходимо выбрать размер шрифта текста запроса.

Right margin

Размер правого поля редактора запросов в мм.

!CheckBox Show line number

Если установлен этот флажок, то в левом поле будут показаны номера строк,

!CheckBox View white space

Если этот флажок установлен, то будут отображаться пробелы в тексте запроса.


Подсветка

На вкладке Highlight можно задать цвет и шрифт различных элементов текста, таких как функции, переменные, ключевые слова и т.д.

Options - SQL Editor - Highlight

В списке Element представлены все элементы.

Из списка Foreground color выберите цвет текста.

Из списка Background color выберите цвет, которым этот текст будет выделен.

!CheckBox Если установлен флажок Default for current skin, то будет использоваться цвет, используемый по умолчанию.

Отдельно можно задать начертание в разделе Font style:

!CheckBox Bold - жирный,

!CheckBox Italic - курсив,

!CheckBox Underline - подчеркнутый,

В нижней части формы на образце текста отображаются все внесенные изменения.


Быстрый код

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

На этой вкладке задайте параметры быстрого ввода текста при написании запроса.

Options - SQL Editor - Quick code

!CheckBox Auto show Code Completion

Если эта опция включена, то при вводе первых символов слова в текстовом редакторе SQL будет предложено несколько вариантов завершения слова во всплывающем списке. Всплывающий список будет появляться после времени, определенного в поле Delay (msec.).


Options

SQL Administrator
  • В начало
  • « Назад
  • Вперед »

Внешний вид

На вкладке Appearance можно выбрать цветовую схему интерфейса программы.

Из раскрывающегося списка Style можно выбрать одну из существующих схем интерфейса.

Цветовое оформление для выбранной схемы Skin можно выбрать из раскрывающегося списка Skin name.

Options - Appearance

В нижней части вкладки, на образце, отображаются все внесенные во внешний вид изменения.


Сочетания клавиш

Список объектов

Insert | Создать новый объект
Enter | Редактировать выбрать объект
Delete | Удалить выбранный объект

Редактор запросов

Ctrl+N | Создать новый запрос
Ctrl+O | Загрузить запрос из файла
Ctrl+S | Сохранить запрос
Ctrl+Shift+S | Сохранить все запросы
Ctrl+X; Shift+Del | Вырезать
Ctrl+C; Ctrl+Insert | Копировать
Ctrl+V; Shift+Insert | Вставить
Ctrl+A | Выделить все
Ctrl+Z; Alt+Back | Отменить действие
Ctrl+Y | Вернуть отмененное действие
Ctrl+K+K; Ctrl+B+T | Установить закладку
Ctrl+Shift+Num | Установить нумерованную закладку (num - номер закладки)
Ctrl+K+N; Ctrl+B+N | Перейти к следующей закладке
Ctrl+K+P; Ctrl+B+P | Перейти к предыдущей закладке
Ctrl+Num | Перейти к нумерованной закладке (num - номер закладки)
Ctrl+B+C | Удалить все закладки
Ctrl+K+L | Удалить нумерованные закладки
Ctrl+F | Найти текст
Ctrl+H | Заменить текст
F3 | Найти следующий фрагмент текста
Ctrl+K+C | Закомментировать выбранный фрагмент
Ctrl+K+U | Убрать символы, обращающие данный фрагмент текста в комментарий
Tab | Увеличить отступ выделенного текста
Shift+Tab | Уменьшить отступ выделенного текста
Ctrl+Shift+U | Привести выделенный текст к верхнему регистру
Ctrl+U | Привести выделенный текст к нижнему регистру
Ctrl+Alt+U | Изменить регистр выделенного текста
Ctrl+R+W | Показать знаки форматирования
Ctrl+Space | Отобразить список автоподстановки
Ctrl+G | Перейти к строке
Shift+Alt+Up | Выделить колонку текста вверх
Shift+Alt+Down | Выделить колонку текста вниз
Shift+Alt+Left | Переход на символ влево с одновременным выделением столбцов
Shift+Alt+Right | Переход на символ вправо с одновременным выделением столбцов
Ctrl+Shift+Alt+Left | Переход на слово влево с одновременным выделением столбцов
Ctrl+Shift+Alt+Right | Переход на слово вправо с одновременным выделением столбцов
Ctrl+Left | Переход на слово назад
Ctrl+Right | Переход на слово вперед
Ctrl+Shift+Left | Выделить символы до предыдущего слова
Ctrl+Shift+Right | Выделить символы до следующего слова
Ctrl+PageDown | Перейти на последнюю строку страницы
Ctrl+PageUp | Перейти на первую строку страницы
Ctrl+Shift+PageDown | Выделить текст до последней строки на странице
Ctrl+Shift+PageUp | Выделить текст до первой строки на странице
Ctrl+Shift+Alt+PageDown | Выделить колонку до первой строки на странице
Ctrl+Shift+Alt+PageUp | Выделить колонку до последней строки на странице
Shift+Home | Выделить текст до начала строки
Shift+End | Выделить текст до конца строки
Ctrl+Shift+Alt+Home | Выделить колонку от текущей позиции курсора до начала первой строки
Ctrl+Shift+Alt+End | Выделить колонку от текущей позиции курсора до начала последней строки
Insert | Переключение режима вставки/удаления
Ctrl+Back | Удалить символы от текущей позиции курсора до начала слова

Управление окнами

Ctrl+Tab | Перейти к следующей вкладке
F6 | Перейти к следующему окну
Ctrl+F6 | Перейти к предыдущему окну


Окно поиска и замены

Диалоговое окно Find Text предназначено для поиска и замены текста в рабочей области редактора запросов.

Text to find

В это поле вводится искомое сочетание символов.

Из раскрывающегося списка Вы можете выбрать сочетание символов, которое искали до этого.

Replace with

В это поле необходимо ввести строку, которой будет заменена строка поиска. Из раскрывающегося списка можно выбрать любую из ранее введенных строк. Чтобы заменить строку поиска пустой строкой, оставьте это поле пустым.

Options

!CheckBox Case sensitive

Учитывать разряд символов при поиске.

!CheckBox Whole words only

Искать слово целиком.

!CheckBox Regular expressions - распознавать регулярные выражения в поле Text to find.

!CheckBox Prompt on replace - подтверждать каждую замену.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в полях Text to find и Replace with аналогичен синтаксису регулярных выражений, используемых в Perl. Дополнительную информацию по ним можно найти на http://perldoc.perl.org/perlre.html#Regular-Expressions.

В разделе Direction укажите направление поиска:

!RadioButton Forward - вниз.

!RadioButton Backward - вверх.

Scope

!RadioButton Global

Поиск и замена проводятся в пределах всей рабочей области, в направления, указанного в разделе Direction.

!RadioButton Selected text

Поиск и замена проводятся только в пределах выделенного текста.

Origin

!RadioButton From cursor

Процесс поиска и замены начинается с текущей позиции курсора, а затем переходит вперед или назад к началу текста, в зависимости от направлении, указанного в разделе Direction.

!RadioButton Entire scope

Процесс поиска и замены охватывает весь блок выделенного текста или весь скрипт (неважно, где находится курсор в области редактирования) в зависимости от настроек, указанных в разделе Scope.


Предварительный просмотр отчета

Перед печатью отчета Вы открывается окно Preview предварительного просмотра отчета. Набор инструментов окна Preview позволяет сохранить отчет в файл одного из предложенных форматов, а также изменить внешний вид отчета (изменить цвет фона и добавить водяные знаки).

Вы можете сгенерировать отчет на основе данных, представленных на различных вкладках Проводника, включая информацию, представленную на вкладке Alarm summary. Также, создание отчета возможно на основе результата SQL запроса, созданного в редакторе запросов.

Чтобы открыть окно предварительного просмотра отчета, выберите пункт Print Print контекстного меню или нажмите соответствующую кнопку на панели инструментов.

Отчет содержит следующую информацию:

  • дата и время создания отчета;
  • имя сервера;
  • имя базы данных (для отчетов, относящихся к базам данных);
  • имя отчета;
  • таблицу с теми колонками, которые отображаются на форме.

Главное меню

File

Page Setup - задать настройки и формат страницы отчета;

Print... - задать настройки печати страницы;

Print - печать отчета;

Export Document - экспортировать отчет в один из доступных форматов (PDF file, HTML file, MHT file, RTF file, Excel file, CSV file, Text file);

Send via E-mail - отправить отчет по электронной почте.

View

  • Page layout: Facing or Continuous - изменить макет страницы;
  • Enable/Disable toolbar - отобразить/скрыть панели инструментов;
  • Enable/Disable status bar - отобразить/скрыть панели статусов;
  • Customize toolbar - настроить панели инструментов.

Background

Color - задать цвет фона отчета;

Watermark - задать водяные знаки для отчета.

Панель инструментов.

  • Search - найти указанный текст в отчете;
  • Customize - настроить вид отчета для печати;
  • Open a document - открыть файл отчета;
  • Save the document - сохранить отчет во внешний файл *.prnx;
  • Print... - задать настройки печати страницы;
  • Quick Print - печать отчета;
  • Page Setup - задать настройки и формат страницы отчета;
  • Header and Footer - настроить колонтитулы;
  • Scale - задать настройки масштабирования;
  • Enable/Disable hand tool - включить-отключить инструмент прокрутки "рука";
  • Задать размер отображения страницы;
  • Перемещаться по страницам документа отчета;
  • Задать количество страниц отчета, отображаемых в окне;
  • Color - задать цвет фона отчета;
  • Watermark - задать водяные знаки для отчета;
  • Export Document - экспортировать отчет в один из доступных форматов (PDF file, HTML file, MHT file, RTF file, Excel file, CSV file, Text file);
  • Закрыть окно просмотра отчетов.

Доступность:
Full version | Да
Free version | Нет
Важно: Посмотреть наличие функций в версиях SQL Administrator Full и Free вы можете в сравнительной таблице характеристик.


Состояния базы данных

- база данных в состоянии online (доступна);

- база данных отключена;

- база данных доступна только для чтения журнала восстановления (standby);

- база данных в процессе восстановления из резервной копии (restoring);

- база данных в состоянии emergency;

- база данных в состоянии emergency и доступна только для чтения (read-only);

- база данных в однопользовательском режиме (single-user);

- база данных в состоянии emergency и в однопользовательском режиме (single-user);

- база данных в однопользовательском режиме (single-user) и доступна только для чтения журнала восстановления (standby);

- база данных в однопользовательском режиме (single-user), доступна только для чтения (read-only) и для чтения журнала восстановления (standby);

- база данных доступна только для чтения (read-only) и для чтения журнала восстановления (standby);

- база данных доступна только для чтения (read-only);

- база данных в процессе восстановления (recovering) и помечена как подозрительная (suspect). В приложении SQL Server во время восстановления произошла ошибка, связанная с ресурсами (recovery pending).


Выбор баз данных

Диалог выбора баз данных Select Databases появляется каждый раз, когда Вы выбираете пункт Select... из выпадающего списка Databases при создании или редактировании некоторых планов обслуживания.

Maintenance plans - Maintenance Plan Editor - Select databases

В списке отображаются базы данных, существующие на сервере.

!RadioButton All databases

Создаваемый план обслуживания запускается на всех базах данных указанного сервера, кроме tempdb.

!RadioButton System database

Создаваемый план обслуживания запускается для всех системных баз данных сервера, кроме tempdb.

!RadioButton All user databases

Создаваемый план обслуживания запускается для всех баз данных, кроме системных.

Если выбран пункт !RadioButton Specific databases, то флажками можно отметить те базы, для которых будет выполняться редактируемое задание.

!CheckBox Ignore non-online databases

Если установлен этот флажок, то будут отображаться только online базы данных.


Выбор таблиц и представлений

Диалог выбора баз таблиц и представлений Select Tables/Views появляется каждый раз, когда Вы выбираете пункт Select... из выпадающего списка Object(s) при создании или редактировании некоторых планов обслуживания.

Maintenance plans - Maintenance Plan Editor - Select objects

Чтобы запустить выполнение плана либо для всех таблиц и представлений, либо только для таблиц, либо только для представлений базы данных выберите соответственно опции !RadioButton All tables and views / !RadioButton All tables / !RadioButton All views.

При выборе пунктов !RadioButton Specific tables или !RadioButton Specific views становится доступен список соответствующих объектов, в котором флажками нужно отметить те, где будут реорганизованы индексы.


Редактор учетных данных

Учетные данные обеспечивают возможность проходить проверку подлинности SQL Server пользователям, имеющим удостоверение вне SQL Server. Учетные данные также применяются в случае, когда пользователям, использующим проверку подлинности SQL Server, требуется доступ к ресурсам домена, например, к хранилищу файлов для создания резервной копии.

После создания учетных данных их можно сопоставить с именем входа. Набор учетных данных может быть одновременно сопоставлен с несколькими именами входа SQL Server. С одним именем входа SQL Server может одновременно быть сопоставлен только один набор учетных данных.

Name

Укажите имя создаваемых учетных данных. Системные учетные данные начинаются с символов '##'.

Identity

Задайте имя учетной записи для использования при подключении за пределами сервера.

Password

Укажите пароль, необходимый для исходящей проверки подлинности, и подтвердите его в поле Confirm password.


Использование шаблонов

В SQL Administrator для некоторых операций предусмотрена возможность сохранения последовательности действий и параметров в специальных файлах, которые называются шаблоны. Используются шаблоны в мастерах. Например, в мастере экспорта данных или импорта данных.

Если в мастере в левом нижнем углу расположена кнопка Templates, то все параметры, указанные с помощью мастера, можно сохранить в файл формата *.tpl. Для каждого мастера предусмотрен специальный формат шаблона. Это позволяет избежать ошибок при открытии шаблона в другом мастере.

При нажатии на кнопку Templates открывается список действий.

  • загрузить шаблон - Load Template.
  • сохранить шаблон - Save Template.

Сохранять и загружать шаблон можно на любом шаге мастера.