Добро пожаловать в SQL Manager for PostgreSQL!

SQL Manager for PostgreSQL – это мощный инструмент для разработки и администрирования серверов баз данных PostgreSQL. SQL Manager for PostgreSQL гарантировано работает со всеми версиями PostgreSQL, включая версию 17, и поддерживает все самые новые функции PostgreSQL, включая параметр FILLFACTOR для таблиц и индексов, создание индексов без блокировки таблицы, создание доменов на основе других доменов и другие. Такие инструменты как Конструктор баз данных, Дизайнер запросов и мощный BLOB-редактор удовлетворят все нужды опытных пользователей. SQL Manager for PostgreSQL имеет современный дружественный графический интерфейс и эффективную систему мастеров настроек, понятную даже новичку.

Посетите наш веб-сайт для получения более подробной информации: https://www.sqlmanager.ru

Ключевые особенности

  • Полная совместимость со всеми версиями PostgreSQL, вплоть до версии 17
  • Поддержка данных UTF8
  • Поддержка расширений
  • Поддержка триггеров в представлениях
  • Быстрая навигация и управление базами данных
  • Эффективные инструменты управления данными
  • Великолепные графические и текстовые инструменты для построения запросов
  • Современный графический интерфейс пользователя
  • Улучшенный проводник баз данных для более простого управления объектами PostgreSQL
  • Эффективное управление параметрами безопасности
  • Впечатляющие возможности импорта и экспорта данных
  • Мощный конструктор баз данных
  • Простые и удобные мастера для выполнения задач PostgreSQL
  • Соединение при помощи переадресации локальных портов через SSH-туннель
  • Доступ к серверу PostgreSQL посредством протокола HTTP
  • Инструменты, позволяющие осуществлять контроль версий
  • Конструктор отчетов с понятным мастером создания отчетов

Домашняя страница: | https://www.sqlmanager.ru/products/postgresql/manager
Служба поддержки: | https://www.sqlmanager.ru/support
Регистрация: | https://www.sqlmanager.ru/products/postgresql/manager/buy


Новости

Версия | Дата выпуска
SQL Manager for PostgreSQL 6.6 | 14.10.2024

Что нового в SQL Manager for PostgreSQL?

1. Добавлена поддержка PostgreSQL 17.

2. Оптимизирована работа редактора SQL с большим числом вкладок.

3. Исправления и улучшения в работе системы контроля версий.

4. В Мастеры создания и восстановления резервной копии добавлена опция no-table-access-method.

5. В редактор политик добавлена поддержка опции RESTRICTIVE.

6. Теперь при возникновении ошибки в импорте данных показывается не только номер строки в исходном файле, но и ошибочное значение.

7. В Мастер сравнения БД добавлены объекты статистики.

8. Исправлена выгрузка данных в мастере выгрузки БД при использовании HTTP прокси.

9. Исправлена ошибка удаления секции таблицы, если она находилась в другой схеме.

10. Улучшения в работе с псевдонимами в редакторе SQL.

11. Исправлена работа с БД в имени которых содержался пробел.

12. Другие улучшения и исправления.

Смотрите также:

Предыдущие версии


Системные требования

  • Microsoft Windows XP, Microsoft Windows Server 2003, Microsoft Windows Server 2008, Microsoft Windows Server 2008 R2, Microsoft Windows Server 2012, Microsoft Windows Server 2012 R2, Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8/8.1, Microsoft Windows 10, Microsoft Windows 11, Microsoft Windows 11 ARM
  • 512 Мб RAM (рекомендуется 1 Гб и более)
  • 200 Мб свободного пространства на жестком диске для установки программы
  • Возможность соединения с локальным или удаленным сервером PostgreSQL
  • Поддерживаемые версии сервера PostgreSQL: с 7.3 по 17


Сравнительная таблица характеристик

Бесплатная Lite версия SQL Manager for PostgreSQL не включает все особенности Full версии и имеет ограничение числа баз данных, которые могут быть зарегистрированы. Некоторые функции и инструменты в Lite версии недоступны.

Полная сравнительная таблица характеристик представлена ниже.

Важно: Если у вас установлена Lite версия программы, то Вы можете активировать все возможности Full версии. Эти возможности будут доступны для работы в течение тридцати дней.

Для получения более подробной информации об активации смотрите на странице Активация режима полной версии.

 | Full version | Lite version
Полная совместимость со всеми версиями PostgreSQL
Поддержка ограничений исключений | + | +
Поддержка условия “when“ триггеров | + | +
Поддержка значений по умолчанию для аргументов функций | + | +
Поддержка функций, возвращающих таблицу | + | +
Поддержка объектов "Сортировки" | + | +
Поддержка расширений | + | +
Поддержка триггеров представления | + | +
Поддержка unlogged таблиц | + | +
Поддержка материализованных представлений | + | +
Поддержка рекурсивных представлений | + | +
Поддержка триггеров на события | + | +
Поддержка данных UTF8 | + | +
Современный графический интерфейс пользователя
Поддержка темной цветовой схемы | + | +
Эффективная система мастеров | + | +
Улучшенный проводник баз данных для более простого управления объектами PostgreSQL | + | +
Новая панель инструментов для легкого переключения между окнами по принципу панели задач Windows | + | +
Навигационная панель c "горячими клавишами" для большинства окон программы | + | +
Возможность сохранения всех настроек программы | + | +
Настраиваемые панели инструментов для всех окон приложения | + | +
Полностью настраиваемый интерфейс программы | + | +
Мощный модуль настройки внешнего вида системы | + | +
Локализуемый пользовательский интерфейс | + | +
Быстрая навигация и управление базами данных
Соединение с несколькими серверами/базами данных одновременно | + | +
Поддержка соединений SSL | + | +
Возможность регистрации баз данных для работы только с требуемыми базами | + | +
Создание "проектов" для работы только с выбранными объектами базы данных | + | +
Доступ к серверу PostgreSQL посредством протокола HTTP | + | +
Соединение при помощи переадресации локальных портов через SSH туннель | + | -
Создание пользовательских закладок быстрого доступа для любого узла дерева базы данных | + | +
Одновременная работа с несколькими выбранными объектами | + | +
Возможность группировки зарегистрированных баз данных по принадлежности к серверу | + | +
Простое и понятное управление всеми объектами PostgreSQL
Создание/удаление баз данных и схем | + | +
Управление таблицами и их подобъектами: полями, индексами, триггерами, правилами, ограничениями и внешними ключами | + | +
Управление представлениями, функциями, процедурами, сортировками и последовательностями | + | +
Управление типами, агрегатами, операторами и языками | + | +
Установка и настройка правил для таблиц и представлений | + | +
Копирование любых объектов баз данных | + | +
Переименование любых объектов баз данных | + | +
Мощный отладчик функций PL/pgSQL | + | -
Возможность просмотра зависимостей между объектами базы данных | + | +
Эффективные инструменты управления данными
Мощный редактор BLOB-полей с различными режимами просмотра данных | + | -
Целый набор эффективных инструментов, например, для группировки, быстрого поиска и фильтрации данных | + | +
Отображение данных и работа с двумя связанными таблицами одновременно | + | -
Отображение данных в табличном и карточном виде | + | -
Возможность копировать и вставлять выбранные записи | + | -
Возможность создавать диаграммы на основе запросов | + | -
Экспорт данных в сценарии SQL в виде выражения INSERT | + | -
Эффективное управление параметрами безопасности
Функциональный менеджер для управления пользователями, их группами и их привилегиями | + | +
Менеджер настроек прав пользователей, отображающий все права для объектов базы данных в форме таблицы | + | +
Возможность управления правами на объект непосредственно в редакторе объекта | + | +
Великолепные графические и текстовые инструменты для построения запросов
Визуальный конструктор для построения сложных SQL запросов даже без знаний синтаксиса | + | -
Многооконный редактор запросов с функцией автозавершения кода, подсветкой синтаксиса и функцией Code Folding | + | +
Исполнение больших сценариев SQL с помощью редактора скриптов | + | +
Возможность представления плана запроса в виде диаграммы | + | -
SQL Formatter (Вызывается из контекстного меню редактора запросов) | + | -
Избранные запросы | + | +
Конструктор отчетов с понятным мастером создания отчетов
Новый мастер создания отчетов позволяет создавать отчеты всего за пару шагов | + | -
Управление отчетами аналогично управлению объектами базы данных: доступ к отчетам осуществляется напрямую из дерева Проводника БД | + | -
Впечатляющие возможности импорта и экспорта данных
Экспорт данных в наиболее популярные форматы: MS Excel, MS Word, MS Access, HTML, PDF, TXT, CSV, DBF, XML, ODF и т.д. | + | -
Импорт данных из файлов MS Excel, MS Access, DBF, XML, ODF, TXT и CSV | + | -
Мастера для копирования данных в файл/из файла на сервере | + | -
Частичное или полное копирование метаданных и данных из одной базы данных в другую | + | -
Мощный визуальный конструктор баз данных
Два типа аннотаций для диаграмм (IDEF1x и IE) | + | -
Функциональный инструмент навигации | + | -
Инструмент обратного проектирования | + | -
Создание нескольких страниц для разделения одной диаграммы на различные предметные области | + | -
Возможности создания, редактирования и удаления таблиц и их полей, визуального установления отношений между таблицами | + | -
Возможность добавления комментариев к диаграмме | + | -
Вывод диаграммы на печать или сохранение ее в виде изображения | + | -
Широкие возможности настройки внешнего вида конструктора | + | -
Инструменты, позволяющие осуществлять контроль версий
Возможность использования систем контроля версий: Concurrent Versions System (CVS), Subversion (SVN), Visual SourceSafe (VSS), Team Foundation Server (TFS) | + | -
Возможность управлять процессами разработки, связанные с базой данных | + | -
Возможность отката структуры базы данных в любую предыдущую версию | + | -
Возможность создавать ветви для базы данных | + | -
Возможность создавать теги/метки для сохранения определённого состояния базы данных | + | -
Возможность получения скрипта изменений между двумя состояними базы данных и проверки его на созданной тестовой базе данных | + | -
Возможность вместе с описанием базы данных хранить в репозитории системы контроля версий произвольные SQL скрипты | + | -
Возможность просмотра истории изменений базы данных и/или объектов | + | -
Простые и удобные мастера для выполнения задач PostgreSQL
Анализ таблиц | + | -
Сжатие таблиц | + | -
Кластеризация таблиц | + | -
Переиндексация таблиц | + | -
Просмотр журнала событий сервера | + | -
Создание резервной копии базы данных | + | +
Восстановление базы данных из резервной копии | + | +
Другие необходимые инструменты для того, чтобы сделать Вашу работу с сервером PostgreSQL простой и удобной
Модуль Статистики базы данных для просмотра различной статистической информации об объектах базы данных | + | -
Извлечение метаданных в текстовые файлы или в редактор выполнения скрипта | + | +
Мощный модуль печати метаданных для создания настраиваемых отчетов о метаданных | + | -
Мастер отчетов HTML для быстрого создания подробного HTML отчета о вашей базе данных | + | -
Конструктор отчетов для визуального создания подробных отчетов | + | -
Мастер скачивания файлов для загрузки файлов с/на сервер PostgreSQL | + | -
Мастер сравнения баз данных | + | -
Расширения базы данных | + | +
SQL Monitor | + | +
Инструмент поиска по метаданным | + | -
Другие функциональные особенности
Клавиатурные шаблоны | + | +
Список запланированных действий "To-do" | + | +
Менеджер внешних инструментов | + | +


Установка

Установка программы SQL Manager for PostgreSQL

  • загрузите установочный файл программы со страницы загрузки,
  • полученный файл извлеките из архива в нужную директорию (например, c:\unzipped),
  • откройте файл PgManagerFullSetup.exe / PgManagerLiteSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Часто задаваемые вопросы по установке ПО

Обновление программы

  • загрузите установочный файл программы со страницы загрузки сайта,
  • полученный файл извлеките из архива в нужную директорию (например, c:\unzipped),
  • закройте программу SQL Manager for PostgreSQL, если она запущена,
  • откройте файл PgManagerFullSetup.exe / PgManagerLiteSetup.exe и следуйте инструкциям мастера обновления.

Вы можете обновить версию программы, используя SQL Direct. При обновлении программы с помощью SQL Direct обновляется не только файл программы, но и сопутствующие файлы. Предпочтительнее использовать этот способ.

Смотрите также:

Часто задаваемые вопросы


Приобретение

Для приобретения наших продуктов на территории Российской Федерации вы можете использовать форму он-лайн оплаты платежной картой либо запросить счёт для безналичной оплаты путем банковского перевода.

Выбор типа лицензии, количества лет Сопровождения и способа оплаты происходит на странице покупки продукта.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery).

После приобретения мы отправим вам регистрационный ключ электронной почтой. Регистрационная информация будет так же доступна зарегистрированным пользователям на нашем сайте.

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО.

Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

Подробнее об услуге сопровождения читайте на странице https://www.sqlmanager.ru/support/faq#maintenance.

Если у вас остались вопросы - вы можете найти ответы на них в разделе FAQ или обратиться в службу поддержки по адресу sales@sqlmanager.ru.

Смотрите также:

Регистрация


Регистрация

Если Вы не зарегистрировали свою копию программы SQL Manager for PostgreSQL, то Вы можете сделать это, нажав кнопку Register Now в окне, открывающемся при выборе пункта главного меню программы Help | About.

Welcome to SQL Manager - About

В появившемся окне укажите регистрационное имя - в поле Registration name, и ключ - в поле Registration Key.

Welcome to SQL Manager - Register product

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией из Digital River.
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно. Для этого необходимо открыть окно About SQL Manager for PostgreSQL, выбрав пункт главного меню Help | About. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Смотрите также:

Приобретение


Предыдyщие версии

16.02.2024 выпущен SQL Manager for PostgreSQL 6.5.1

21.12.2023 выпущен SQL Manager for PostgreSQL 6.5

10.10.2023 выпущен SQL Manager for PostgreSQL 6.4.3

27.03.2023 выпущен SQL Manager for PostgreSQL 6.4.2

11.11.2022 выпущен SQL Manager for PostgreSQL 6.4.1

18.10.2022 выпущен SQL Manager for PostgreSQL 6.4

03.04.2022 выпущен SQL Manager for PostgreSQL 6.3.2

23.07.2021 выпущен SQL Manager for PostgreSQL 6.3.1

07.04.2021 выпущен SQL Manager for PostgreSQL 6.3

21.12.2020 выпущен SQL Manager for PostgreSQL 6.2

15.03.2020 выпущен SQL Manager for PostgreSQL 6.1.1

28.01.2020 выпущен SQL Manager for PostgreSQL 6.1

06.12.2019 выпущен SQL Manager for PostgreSQL 6.0.1

01.11.2019 выпущен SQL Manager for PostgreSQL 6.0

18.03.2019 выпущен SQL Manager for PostgreSQL 5.9.5

27.07.2018 выпущен SQL Manager for PostgreSQL 5.9.4

29.05.2018 выпущен SQL Manager for PostgreSQL 5.9.3

08.12.2017 выпущен SQL Manager for PostgreSQL 5.9.2

26.04.2017 выпущен SQL Manager for PostgreSQL 5.9.1

09.03.2017 выпущен SQL Manager for PostgreSQL 5.9

16.12.2016 выпущен SQL Manager for PostgreSQL 5.8.1

19.10.2016 выпущен SQL Manager for PostgreSQL 5.7.1

25.03.2016 выпущен SQL Manager for PostgreSQL 5.7.0

18.12.2015 выпущен SQL Manager for PostgreSQL 5.6.2

18.11.2015 выпущен SQL Manager for PostgreSQL 5.6.1

14.09.2015 выпущен SQL Manager for PostgreSQL 5.6.0

06.10.2014 выпущен SQL Manager for PostgreSQL 5.5.0

14.10.2014 выпущен SQL Manager for PostgreSQL 5.4.0.1

08.04.2013 выпущен SQL Manager for PostgreSQL 5.3.0.1

15.11.2012 выпущен SQL Manager for PostgreSQL 5.2.0.1

05.12.2011 выпущен SQL Manager for PostgreSQL 5.1.0.1.

17.05.2011 выпущен SQL Manager 2011 for PostgreSQL 5.0.0.1.

15.11.2010 выпущен SQL Manager 2010 for PostgreSQL 4.8

15.02.2010 выпущен SQL Manager 2010 for PostgreSQL 4.7

09.09.2009 выпущен SQL Manager 2007 for PostgreSQL 4.6

10.12.2008 выпущен SQL Manager 2007 for PostgreSQL 4.5

18.07.2008 выпущен SQL Manager for PostgreSQL вер. 4.4

01.02.2008 выпущен SQL Manager for PostgreSQL вер. 4.3

03.12.2007 выпущен SQL Manager for PostgreSQL вер. 4.2

20.06.2007 выпущен SQL Manager for PostgreSQL вер. 4.1

17.05.2007 Выпущен SQL Manager 2007 for PostgreSQL вер 3.9

14.12.2006 Выпущен SQL Manager for PostgreSQL вер. 3.8

09.10.2006 Выпущен SQL Manager 2005 for PostgreSQL вер. 3.7

31.05.2006 Выпущен SQL Manager 2005 for PostgreSQL вер. 3.6

03.04.2006 Выпущен SQL Manager 2005 for PostgreSQL вер.3.5

07.02.2006 Выпущен SQL Manager 2005 for PostgreSQL вер.3.4

16.02.2024 выпущен SQL Manager for PostgreSQL 6.5.1

1. Улучшена обработка локальных переменных в списках автозавершения в редакторе процедур и запросов.

2. Исправлено отображение списка аргументов при выполнении функции, где все аргументы имеют значения по умолчанию.

3. Теперь таблица данных не переключается в режим отображение только видимых строк, если уже загружены все данные.

4. Геометрические типы теперь отображаются в таблице данных как BLOB.

5. Исправлено масштабирование всплывающих подсказок при использовании системного масштабирования отличного от 100%.

6. Увеличен таймаут подключения при использовании SSH-туннелирования.

7. Исправлена обработка GENERATED полей при изменении порядка колонок в таблице.

8. Исправления в работе системы контроля версий для процедур и статистик.

9. Исправления в темной теме оформления.

10. Множество других улучшений и исправлений.

21.12.2023 выпущен SQL Manager for PostgreSQL 6.5

1. Выпущена 64-битная версия SQL Manager for PostgreSQL.

2. Шаблоны сервисов теперь сохраняются в кодировке UTF8.

3. Добавлена поддержка новых методов аутентификации.

4. Добавлена поддержка объектов STATISTICS.

5. Добавлена поддержка опции NULLS NOT DISTINCT в редакторе индексов.

6. Добавлена поддержка SET COMPRESSION для колонок таблиц.

7. Улучшено отображение wait_event в окне просмотра статуса сервера.

8. Добавлена настройка отображения для типов данных TIMESTAMP и TIMESTAMPTZ.

9. Добавлена поддержка нескольких рядов вкладок в редакторе Query Data.

10. Улучшено отображение данных для функций, которые возвращают несколько курсоров.

11. Данные формата PDF в BLOB теперь можно просматривать напрямую в программе.

12. Множество других улучшений и исправлений.

27.03.2023 выпущен SQL Manager for PostgreSQL 6.4.3

1. Исправлена ошибка при открытии Мастера экспорта данных.

2. Для агрегатных функций не отображался владелец. Исправлено.

3. Для агрегатных функций невозможно было выбрать значения из системного каталога. Исправлено.

4. Исправлена ошибка редактирования значений в редакторе Перечислений.

5. Исправлена ошибка Control 'Preview' has no parent window в редакторе печати данных таблицы.

6. Не отображалось описание операций плана запроса при переходе между элементами. Исправлено.

7. В некоторых случаях появлялась ошибка при выполнении запроса с параметром, если в комментарии присутствовали апострофы. Исправлено.

8. Другие небольшие исправления и улучшения.

27.03.2023 выпущен SQL Manager for PostgreSQL 6.4.2

1. Улучшена поддержка PostgreSQL 15.

2. Улучшена поддержка темной темы оформления.

3. Добавлена поддержка тел LANGUAGE SQL для функций.

4. В дизайнер запросов SQL добавлена возможность опционально скрывать связи таблиц по внешним ключам.

5. Шаблоны для создания и восстановления резервных копий теперь сохраняются в юникодном формате.

6. Улучшена работа редактора для просмотра логов сервера.

7. Исправления в экспорте изображений в виде скрипта SQL.

8. Размер окна редактора фильтрации данных теперь можно изменять.

9. Окно Дизайнера БД теперь масштабируется корректно.

10. При переключении редактора просмотра данных в карточный вид сбрасывался список отображаемых полей. Исправлено.

11. Другие исправления и улучшения.

11.11.2022 выпущен SQL Manager for PostgreSQL 6.4.1

1. Добавлена поддержа подключения к серверу версии 15.

2. Исправлена клиентская сортировка данных типа NUMERIC на вкладке данных.

3. Теперь при добавлении записи вручную на вкладке данных для полей типа GENERATED BY DEFAULT автоматически подставляется значение последовательности.

4. Исправлено открытие последнего файла диаграммы в Конструкторе БД.

5. Исправлены недочеты в подсветке кода SQL в редакторах.

6. Исправлены ошибки в работе с кодировками в редакторе BLOB.

7. Другие исправления и улучшения.

18.10.2022 выпущен SQL Manager for PostgreSQL 6.4

1. Добавлена возможность отображения типов полей в редакторе данных.

2. Добавлена поддержка опций хранения индексов.

3. Улучшено отображение данных в окне просмотра логов сервера.

4. Добавлена возможность сворачивать дерево объектов.

5. В контроль версий добавлены индексы представлений.

6. Добавлена поддержка запуска на Windows 11 ARM.

7. Добавлена поддержка приватных ключей типа Ed25519 формата Putty.

8. Добавлена поддержка фильтров для полей типа ENUM.

9. Улучшена работа с большими значениями типов NUMERIC в редакторе данных.

10. Исправлен поиск предыдущего\следующего совпадения в дереве объектов.

11. Улучшена работа через HTTP-туннель.

12. Улучшения в форматировании данных типа JSON.

13. Добавлены горячие клавиши для маркеров в редакторе скрипта.

14. Исправлено отображение привилегий для процедур.

15. Улучшена работа с микросекундами для полей типа TIMESTAMP.

16. Поля таблицы теперь автозаполнняются для оператора INSERT INTO.

17. Исправлена ошибка при добавлении данных, содержащих автогенерируемые значения.

18. Исправлено редактирование комментариев для материализованных представлений.

19. Оптимизирована подсветка кода в редакторе скрипта.

20. В отладчике процедур исправлена работа с search_path, имя которых содержит точки.

21. В некоторых редакторах не работал сброс панелей инструментов. Исправлено.

22. При сохранении настроек теперь выгружаются Избранные запросы.

23. При сравнении БД последовательности теперь выгружаются без указания владельца, он задается отдельно.

24. Множество других исправлений и улучшений.

03.04.2022 выпущен SQL Manager for PostgreSQL 6.3.2

1. Добавлена опция, отвечающая за отображение владельца объекта на вкладке DDL.

2. Для BLOB-полей текстового типа добавлена поддержка сортировки в редакторе данных.

3. Хосты и базы данных теперь сортируются по имени в выпадающих списках редакторов объектов.

4. В списке автозаполнения редактора SQL для полей теперь дополнительно указывается тип данных.

5. При экспорте в формат XLSX теперь доступна настройка формата отображения.

6. В некоторых случаях при экспорте данных дублировался апостроф. Исправлено.

7. В редакторе SQL теперь корректно выполняются команды, если они записаны в одну строку.

8. Окно результатов выполнения открывается автоматически только в случае возникновения ошибки.

9. Исправлено отображение данных типа Bit varying.

10. При запуске процедуры из редактора в некоторых случаях к значениям сохраненных параметров добавлялись лишние апострофы. Исправлено.

11. Исправлена проблема сохранения настроек SSL для баз данных.

12. Исправлено подключение к БД при наличии пробелов в начале имени или пароля.

13. Множество других улучшений и исправлений.

23.07.2021 выпущен SQL Manager for PostgreSQL 6.3.1

1. Добавлена поддержка опции GENERATED при создании поля.

2. Поля теперь форматируются корректно в операторах вставки данных.

3. Исправлены ошибки в истории параметров вызова функций.

4. В некоторых случаях появлялась ошибка Out of range при переключении на вкладку зависимостей. Исправлена.

5. Улучшена поддержка темной темы оформления.

6. Другие улучшения и исправления.

07.04.2021 выпущен SQL Manager for PostgreSQL 6.3

1. Исправления в истории хранения параметров при изменении текста SQL.

2. Теперь при запуске программы курсор фокусируется на списке БД.

3. Обновлен список событий для объектов EVENT TRIGGER.

4. Исправлена проблема, возникающая при отладке процедуры с большим количеством параметров.

5. В некоторых случаях некорректно импортировались данные полей типа TIMESTAMPTZ. Исправлено.

6. Исправлено округление чисел с плавающей точкой с большим количеством знаков дробной части.

7. Теперь сохраняются настройки фильтрации данных при переключении по вкладкам таблицы.

8. На панель инструментов возвращена кнопка открытия пустого редактора запросов.

9. Исправлены ошибки использования псевдонимов в Дизайнере запросов.

10. Другие улучшения и исправления.

21.12.2020 выпущен SQL Manager for PostgreSQL 6.2

1. Обновлены библиотеки для работы с SSH.

2. Исправлена загрузка списка расширений при работе с PostgreSQL 13.

3. Исправлена проблема с зависанием в редакторе пользователей при добавлении нового пользователя.

4. Исправлено отображение свойства INCLUDE в DDL индекса.

5. Исправлена ошибка с колонкой OID при открытии некоторых запросов SQL c агрегатной функцией.

6. В Мастере сохранения настроек базы теперь сортируются по алфавиту.

7. Теперь по F12 либо открывается окно редактора SQL, либо происходит переключение на него, если оно уже открыто.

8. При открытии данных таблицы сразу создавался предпросмотр печатной формы. Исправлено

9. Теперь при перемещении файла в редактор SQL происходит загрузка из файла, а не просто копирование текста.

10. Другие улучшения и исправления.

13.05.2020 выпущен SQL Manager for PostgreSQL 6.1.1

1. Улучшена работа с Amazon RedShift.

2. В редакторе выполнения скрипта добавлена поддержка команды COPY.

3. В контекстное меню дерева объектов добавлен пункт поиска метаданных.

4. В отладчике в некоторых случаях некорректно обрабатывалось присваивание NULL переменным. Исправлено.

5. Команда смены пути поиска в редакторе запроса данных теперь применяется и в плане запроса.

6. В редакторе скриптов теперь запоминается последний выбранный путь к файлу.

7. Улучшена работа с типом данных TIMESTAMPTZ.

8. При внешнем изменении файла, открытом в редакторе скрипта, будет появляться предупреждение.

9. Исправлена ошибка, которая возникала при перемещении расширения в другую схему.

10. Теперь корректно отображается псевдоним сервера в редакторах объектов.

11. При двойном изменении порядка полей обнулялись текущие значения последовательностей, если они использовались в таблице. Исправлено.

12. Другие исправления и улучшения.

28.01.2020 выпущен SQL Manager for PostgreSQL 6.1

1. Добавлена возможность открытия нескольких редакторов выполнения запросов.

2. Добавлена возможность открытия нескольких окон поиска по метаданным.

3. Улучшена работа формы поиска и замены текста.

4. Ускорена операция сброса состояния для отладчика с использованием расширения.

5. Функции и процедуры расширений теперь не отображаются в дереве объектов, если выбрано скрытие системных объектов.

6. Исправлено задание параметра типа BOOLEAN в отладчике.

7. Для типа данных timestamptz теперь отображаются данные микросекунд.

8. Множество других изменений и улучшений.

06.12.2019 выпущен SQL Manager for PostgreSQL 6.0.1

1. Шрифт выпадающего списка автодополнения теперь изменяется вместе со шрифтом редактора.

2. Исправлено обновление данных в материализованных представлениях в режиме использования транзакций.

3. Исправлены ошибки поиска текста и метаданных.

4. Исправлено пропадание главного меню программы в случае использования файла локализации.

5. При нажатии кнопки "Закрыть все окна" теперь выдается запрос на подтверждение.

6. Панели главной формы теперь можно перетаскивать без ограничений.

7. Исправлено сохранение запросов редактора при изменении алиаса сервера.

8. Некоторые другие исправления и улучшения.

01.11.2019 выпущен SQL Manager for PostgreSQL 6.0

1. Добавлена поддержка темной визуальной темы.

2. Обновлены иконки интерфейса.

3. Добавлена поддержка PostgreSQL версии 12.0.

4. Реализована поддержка юникода в именах объектов.

5. Улучшена поддержка мониторов с высоким разрешением и систем с увеличенным размером шрифта.

6. Добавлена возможность выделения цветом редакторов, относящихся к определенной БД.

7. Добавлена возможность указания алиаса сервера.

8. В редакторе данных добавлена вкладка JSON для просмотра и редактирования отформатированного текста.

9. Добавлена поддержка комментариев для табличных пространств.

10. Для материализованных представлений добавлена команда "Refresh concurrently".

11. При отображении данных типа CHAR теперь показываются конечные пробелы.

12. Различные исправления и улучшения в автодополнении кода.

13. Для типа данных timestamptz теперь применяется форматирование из настроек отображения.

14. Множество других исправлений.

15. Улучшения в интерфейсе и удобстве работы с программой.

18.03.2019 выпущен SQL Manager for PostgreSQL 5.9.5

1. Добавлена поддержка процедур.

2. Добавлена поддержка резервных копий БД для сервера версии 11.1.

3. В редактор функций добавлена опции PARALLEL.

4. В редактор поля добавлена возможность просмотра и изменения метода хранения данных.

5. Улучшена работа проверки синтаксиса в редакторе функций.

6. Для некоторых пользовательских типов данных в редакторе функции не отображалось название типа. Исправлено.

7. Небольшие исправления в Мастере сохранения настроек

8. Вложенные многострочные комментарии теперь распознаются корректно.

9. План запроса мог не возвращать данные, если после EXPLAIN не было пробела. Исправлено.

10. При импорте данных при несовпадении кодировок могла прерваться транзакция. Исправлено.

11. Исправлена ошибка генерации скрипта на смену владельца для материализованных представлений.

12. Тип данных BIT VARYING без уточнения размера теперь корректно отображается в фрейме данных.

13. Множество других улучшений и исправлений.

27.07.2018 выпущен SQL Manager for PostgreSQL 5.9.4

1. Добавлена поддержка свойства GENERATED AS IDENTITY для столбцов таблиц.

2. Исправлен импорт данных в режиме "Update or Insert", если в качестве ключевых выбраны все колонки таблицы.

4. Улучшения и исправления в отладчике процедур.

5. Теперь список пользователей выгружается в корректную папку, заданную в настройках.

6. Исправлено восстановление прав на столбцы таблицы после её пересоздания.

7. Добавлена выгрузка параметров секционирования таблиц.

8. Теперь оператор приведения к типу (::) можно использовать совместно с символом параметра (:).

9. Исправлен импорт строк с кавычками и обратным слешем.

10. В окне поиска метаданных для таблицы, содержащей параметр-домен, не отображался DDL. Исправлено.

11. Добавлена возможность экспорта списка задач.

12. При копировании записей из таблицы обрезались конечные пробелы. Исправлено.

13. Множество других улучшений и исправлений.

29.05.2018 выпущен SQL Manager for PostgreSQL 5.9.3

1. Добавлена поддержка свойства GENERATED AS IDENTITY для столбцов таблиц.

2. Исправлен импорт данных в режиме "Update or Insert", если в качестве ключевых выбраны все колонки таблицы.

4. Улучшения и исправления в отладчике процедур.

5. Теперь список пользователей выгружается в корректную папку, заданную в настройках.

6. Исправлено восстановление прав на столбцы таблицы после её пересоздания.

7. Добавлена выгрузка параметров секционирования таблиц.

8. Теперь оператор приведения к типу (::) можно использовать совместно с символом параметра (:).

9. Исправлен импорт строк с кавычками и обратным слешем.

10. В окне поиска метаданных для таблицы, содержащей параметр-домен, не отображался DDL. Исправлено.

11. Добавлена возможность экспорта списка задач.

12. При копировании записей из таблицы обрезались конечные пробелы. Исправлено.

13. Множество других улучшений и исправлений.

08.12.2017 выпущен SQL Manager for PostgreSQL 5.9.2

1. Добавлена поддержка PostgreSQL 10.

2. Добавлена поддержка секционирования в таблицах.

3. Улучшения в отладчике.

4. Реализована возможность отладки с использованием расширения pldbgapi.

5. Исправлены ошибки в работе мастере Сравнения баз данных.

6. Окна редактора функций с длинными именами теперь восстанавливаются корректно.

7. В некоторых случаях пароли из pgpass.conf не использовались. Исправлено

8. Кнопки Commit и Rollback теперь не отображаются, если не было изменения данных.

9. В Query data при включенной опции "Show result for each query" и возникновении ошибки выполнение не начнется с первого запроса, а продолжится.

10. В редакторе данных в виде формы был недоступен атрибут NOT NULL для полей типа BOOLEAN. Исправлено.

11. Редактор функций. Изменена комбинация клавиш для вызова отладчика на Ctrl+D.

12. Множество других исправлений и улучшений.

26.04.2017 выпущен SQL Manager for PostgreSQL 5.9.1

1. Добавлены новые опции в редакторе политик.

2. Добавлена поддержка синтаксиса WITH RECURSIVE в отладчике функций.

3. Исправлена ошибка при отладке оператора INSERT, если имя поля таблицы совпадает с именем входного параметра.

4. Юникодные символы некорректно импортировались в режиме Batch Insert. Исправлено.

5. Кнопка фиксации транзакции не всегда отображалась. Исправлено.

6. Комментарии теперь корректно сохраняются в Визуальном Конструкторе БД.

7. При дублировании комментария индекса в другую схему неверно подставлялось имя схемы. Исправлено.

8. Множество других исправлений и улучшений.

09.03.2017 выпущен SQL Manager for PostgreSQL 5.9

1. Добавлена поддержка сертификатов SSL.

2. Добавлена поддержка триггеров ограничений.

3. Реализована работа с данными в таблицах через точки записи (savepoint).

4. Добавлена возможность задавать путь поиска в отладчике функций.

5. Устранены зависания программы при редактировании скрипта.

6. По умолчанию для текстовых полей типа BLOB открывается вкладка Text вместо HEX.

7. Теперь сообщения (raise notice) отображаются в редакторе SQL в момент их выполнения, а не в момент завершения работы запроса.

8. При изменении тела материализованного представления не генерировался скрипт на изменение индексов. Исправлено.

9. Добавлены горячие клавиши для поиска следующего\предыдущего совпадения в дереве объектов.

10. Множество других улучшений и исправлений.

16.12.2016 выпущен SQL Manager for PostgreSQL 5.8.1

  1. Исправлена ошибка выполнения резервного копирования на PostgreSQL 9.6.
  2. Исправлены ошибки при экспорте результатов некоторых запросов.
  3. Результат выполнения запроса был нередактируемым, когда запросу предшествовали комментарии. Исправлено.
  4. Значения NUMERIC некорректно экспортировались в виде скрипта SQL. Исправлено.
  5. SSH-подключение не устанавливалось в некоторых случаях использования ключа в формате OpenSSH. Исправлено.
  6. Множество других улучшений и исправлений.

19.10.2016 выпущен SQL Manager for PostgreSQL 5.7.1

  1. Поддержка PostgreSQL 9.6.
  2. Добавлена поддержка свойств DEFERRABLE/NOT DEFERRABLE и INITIALLY DEFERRED/INITIALLY IMMEDIATE для первичных и уникальных ключей.
  3. Поддержка PHP 7.x в модуле обслуживания HTTP-туннелирования.
  4. Отладчик функций. Добавлена расширенная поддержка синтаксиса RAISE и EXCEPTION; добавлена обработка директив подстановки.
  5. Исправлены ошибки при форматировании SQL.
  6. Некоторые настройки панелей инструментов не сохранялись при перезапуске программы. Исправлено.
  7. Исправлено отображение размерности для типа данных INTERVAL.
  8. Исправлены проблемы с памятью в менеджере привилегий.
  9. Исправлен экспорт данных в юникоде из полей BLOB.
  10. Множество других исправлений и улучшений.

30.06.2016 выпущен SQL Manager for PostgreSQL 5.7.1

  11. Поддержка последних версий OpenSSH.
  12. Исправление ошибки, возникавшей при авторизации по SSH с приватным ключом.
  13. При создании индекса c включенной локализацией появлялась ошибка Access Violation. Исправлено.
  14. Неверно заполнялись директории по умолчанию при регистрации нового хоста. Исправлено.
  15. Другие улучшения и исправления.

25.03.2016 выпущен SQL Manager for PostgreSQL 5.7.0

  1. Поддержка PostgreSQL Server версии 9.5.
  2. Поддержка опции REPLICATION у ролей.
  3. Поддержка метода BRIN в индексах таблиц.
  4. Возможность изменения опции LOGGED у таблиц.
  5. Поддержка наследования внешних таблиц.
  6. Добавлена поддержка подобъекта таблицы - политики (Policy).
  7. Добавлена возможность создания индексов для материализованных представлений.
  8. Исправления в работе с объектами базы, у которых в имени есть кавычки.
  9. Исправления работы с памятью.
  10. Прочие исправления и улучшения.

18.12.2015 выпущен SQL Manager for PostgreSQL 5.6.2

1. Многочисленные исправления и оптимизации использования оперативной памяти.

2. Исправлена ошибка, возникавшая при закрытии редактора BLOB.

3. При открытии скрипта из командной строки, он открывается в уже запущенном экземпляре программы, а не запускает новый.

4. Улучшена работа автозавершения кода для больших функций и SQL запросов.

5. Исправлена ошибка в редакторе триггеров, возникавшая при использовании более 64 полей таблицы.

6. Исправлена ошибка работы с Group Manager при отсутствии привилегии "Can create roles", но имеющихся правах Superuser.

7. Export Data. Теперь сохраняется последний выбранный формат экспорта; при новом открытии Мастера он будет использован по умолчанию.

8. Исправлено отображение сообщений об ошибках подключения (в некоторых случаях весь текст заменялся знаками вопроса).

9. В функциях исправлены проблемы работы с объектами, имена которых требуется заключать в кавычки.

10. Изменены названия форматов в Export Data в соответствии со стандартами MS Office.

11. Export Data. Изменено название по умолчанию вкладки в MS Excel с Sheet1 на Export.

12. Множество других исправлений.

18.11.2015 выпущен SQL Manager for PostgreSQL 5.6.1

  1. Улучшена работа с типом REFCURSOR в редакторе данных.
  2. Добавлена возможность управления группами обычному пользователю, если у него есть на это права.
  3. Улучшена работа с функциями, имена которых начинаются с "_".
  4. Улучшения в порядке выгрузки объектов в Extract Database.
  5. Исправление проблем с запуском на некоторых национальных версиях Windows.
  6. Исправлены ошибки работы с памятью.
  7. Исправлены проблемы с неверным количеством импортируемых данных из Excel и CSV.
  8. Исправлены ошибки при открытии Server Status.
  9. При изменениии порядка полей терялись их комментарии. Исправлено.
  10. Неверное генерировался SQL при дублировании UNLOGGED TABLE. Исправлено.
  11. Множество других исправлений.

14.09.2015 выпущен SQL Manager for PostgreSQL 5.6.0

  1. Добавлена поддержка оберток внешних данных (foreign data wrappers), внешних серверов (foreign servers) и внешних таблиц (foreign tables).
  2. Дерево зависимостей.
  • Добавлена возможность перемещать дерево в области отображения с помощью удерживания левой кнопки мыши.
  • Изменено оформление выбранного и рекурсивного объектов, что позволяет лучше их различать.
  • Добавлены различные режимы отображения дерева зависимостей: показать все объекты, показать объекты, зависящие от выбранного объекта, или только объекты, от которых зависит выбранный объект.
  • Выбранный объект автоматически помещается в область отображения, в случае если дерево зависимостей слишком велико.
  3. Редактор таблиц. Вкладка данных (Data tab). Появилась возможность автоматического создания подчиненных уровней данных для таблиц, связанных с данной посредством внешних ключей.
  4. Панель окон (Windows panel).
  • Добавлена возможность передвигать с помощью мышки вкладки открытых окон.
  • Теперь можно закрывать окна нажатием средней клавиши мыши.
  5. Проводник БД. Избранные запросы и скрипты можно добавить в папки Избранных объектов.
  6. Настройки окружения (Environment Options).
  • Возможность задания символа, обозначающего параметр для запросов (вкладка Tools).
  • Шрифт для сетки данных теперь можно задать отдельно.
  • Проводник БД. Добавлена опция 'Поиск начинающихся на' ('Start-with search') для поиска объектов.
  • Проводник БД. Добавлена опция 'Авторазворот панели навигации' ('Auto expand navigation pane').
  • Добавлена возможность выключения опции 'Restore desktop on connection' для БД с выключенной опцией 'Refresh objects on connection'.
  • Добавлена возможность устанавливать, какую базу данных необходимо выбрать во вновь открытом редакторе или инструменте: базу данных, выбранную в данный момент в Проводнике баз данных, или базу данных, выбранную в текущем открытом редакторе/инструменте.
  • Конструктор запросов | Настройки цветовой панели (Design Query | Color Palette options). Добавлена возможность задавать цвет для активного и неактивного заголовка таблиц (Опция 'Windows style of tables' должна быть выключена).
  • Общие сочетания клавиш (Global Shortcuts). Добавлены сочетания клавиш для отладчика.
  7. Редактор запросов (Query data). Теперь при выполнении блока, содержащего оператор 'BEGIN', кнопки 'Commit' и 'Rollback' становятся доступными в панели инструментов и навигационной панели, даже если использование транзакций не включено. Также будет появляться диалог подтверждения завершения транзакции при закрытии редактора (если подтверждения не отключены на вкладке 'Confirmations' настроек окружения (Environment Options)).
  8. Сетка данных (Data Grid). Теперь возможно выделять группы ячеек и копировать их в буфер обмена. Для этого нужно в Настройках окружения (Environment Options) на вкладке Grid включить опции 'Cell selection' и 'Row/cell multi-selection'.
  9. Мастер копирования объектов (Duplicate Object wizard). Сейчас при дублировании таблицы в другую БД операторы копирования данных не добавляются к скрипту создания таблицы, а выполняются отдельно, что существенно уменьшает использование памяти.
  10. Редактор запросов (Query data).
  • Быстрый код (Quick Code). Теперь можно выбирать элемент из списка автодополнения кода с помощью пробела ('Space') или табуляции ('TAB') (опционально).
  • Теперь можно выделить запрос SQL и вызвать диалог экспорта данных с помощью соответствующей команды контекстного меню.
  11. Экспорт данных в виде SQL скрипта (Export Data as SQL Script), Извлечение БД (Extract Database). Теперь в поле 'Script destination' | 'File charset' по умолчанию подставляется кодировка, которая использовалась при последней операции.
  12. Редактор запросов (Query data). План запроса.
  • Теперь план запроса можно просматривать в графической форме при включенной опции 'Verbose'.
  • Панель информации об операции ('Operation info') теперь реализована как отдельное текстовое поле.
  13. Настройки внешнего вида (Visual Options). Добавлена возможность установить значение свойства тип наклона ('Slants Kind') для страницы управления.
  14. Некоторые формы масштабировались некорректно, когда в настройках системы размер элементов (Control Panel\Display | Size of All Items) был задан как 'Medium'. Исправлено.
  15. Монитор SQL (SQL Monitor). Теперь лог представлен в виде готового к выполнению SQL: вся служебная информация выводится в виде SQL-комментариев.
  16. Множество других улучшений и исправлений.

06.10.2014 выпущен SQL Manager for PostgreSQL 5.5.0

  1. Добавлена поддержка новых возможностей PostgreSQL 9.4:
    • Добавлена поддержка типа данных JSONB.
    • Добавлена поддержка изменения Deferrable параметров внешних ключей без пересоздания ключа.
    • Добавлена поддержка возможности переноса всех объектов из одного табличного пространства в другое.
  2. Мастер извлечения баз данных. Теперь результирующий скрипт корректно упорядочен с учетом зависимостей между объектами.
  3. Мастер резервного копирования баз данных. Теперь возможно добавить текущие дату и время в имя файла резервной копии.
  4. Управление изменениями. Добавлена поддержка клиента Slik Subversion 1.8.x (SQL Manager работает только с 32-разрядными клиентами SVN).
  5. Редактор запросов. Автодополнение кода. Обновлен список ключевых слов PostgreSQL с учетом последних версий сервера.
  6. Редактор таблиц. Перестановка полей. Теперь создание триггеров в скрипте изменений следует после вставки данных.
  7. Редактор запросов. Если включена опция «Don’t save queries automatically for the next session», то в случае наличия изменений в запросе при закрытии вкладки выдается предупреждение, что они не будут автоматически сохранены.
  8. Управление изменениями. SVN.
    • При подключении через HTTPS, если сертификат невалиден, при выполнении операции теперь выдается запрос: игнорировать ошибку или прервать выполнение.
    • Если в качестве комментария при записи изменений в систему контроля версий вводились нелатинские символы, возникала ошибка «Cannot write database history record». Исправлено.
  9. Редактор запросов. План запроса. Теперь числовые значения выравниваются по правому краю и отформатированы с разбиением на группы разрядов.
  10. Проводник баз данных. Теперь поле поиска «Search» не очищается после окончания поиска.
  11. Мастер резервного копирования баз данных. Большой лог выполнения операции иногда обрезался в конце. Исправлено.
  12. DDL функций. Символы в именах параметров, недопустимые без кавычек, брались в кавычки неверно. Исправлено.
  13. Мастер экспорта данных. При экспорте полей типа integer в файл формата DBF значения записывались в файл вместе с разделителем тысяч. Исправлено.
  14. При переименовании поля представления из схемы, не являющейся схемой по умолчанию для текущего пользователя, генерировался неверный скрипт. Исправлено.
  15. При изменении типа поля на smallserial иногда возникала ошибка. Исправлено.
  16. Отладчик. Невозможно было изменить значение переменной типа time. Исправлено.
  17. Множество других исправлений и улучшений.

14.10.2013 выпущен SQL Manager for PostgreSQL 5.4.0.1

  1. Добавлена поддержка новых возможностей PostgreSQL 9.3:
    • Поддержка материализованных представлений.
    • Поддержка рекурсивных представлений.
    • Поддержка триггеров на события.
  2. SQL Редактор. Улучшение функции «Автозавершение кода»:
  • Теперь возможен показ списка колонок для псевдонимов функций и подзапросов.
  • Список таблицы или колонок подзапроса текущего SELECT запроса теперь показывается в «Автозавершении кода» даже без указания псевдонима.
  • Контекстно-зависимые элементы: псевдонимы текущего SQL запроса, локальные переменные, таблица или колонки подзапроса – теперь располагаются в «Автозавершении кода» в верху списка.
  3. Отладчик функций. При первом запуске отладчика в качестве значений параметров используются значения, введенные при выполнении функции.
  4. Типы event_trigger и json добавлены в список стандартных типов.
  5. Редакторы таблицы и представления. Для подобъектов теперь доступна команда «Переименовать» (Rename).
  6. Редактор оператора. Поле Name теперь позволяет вводить только допустимые для имени оператора символы.
  7. Исправлено несколько ошибок в отладчике функций:
  • Если в теле функции последняя строка - комментарий, возникала ошибка «syntax error». Исправлено.
  • При наличии в отлаживаемой функции операций со значениями типа oid иногда возникала ошибка «can't read the blob». Исправлено.
  • Если для параметра типа bigint задавалось очень большое число, его точность терялась. Исправлено.
  8. Команда главного меню Справка | Руководство PostgreSQL работала некорректно. Исправлено.
  9. Редактор функций.
  • В некоторых случаях переставали работать сочетания клавиш для копирования/вставки информации из буфера обмена Ctrl+Ins и Shift+Ins. Исправлено.
  • При экспорте результатов функции, возвращающей rowset, иногда возникала ошибка «access violation». Исправлено.
  10. Найти/Заменить диалоговые окна. Дублировались горячие клавиши некоторых полей ввода. Исправлено.
  11. Мастер экспорта данных. При использовании опции «Пропустить записи» (Skip records) сигнализировалось, что экспорт прошел с ошибками, хотя на самом деле операция завершилась успешно. Исправлено.
  12. Множество улучшений и исправлений.

08.04.2013 выпущен SQL Manager for PostgreSQL 5.3.0.1

  1. Теперь при изменении объекта, к заголовку окна добавляется звездочка (*). То же самое для файлов, открытых в форме SQL Скрипта, диаграмме Визуального конструктора базы данных и т. д.
  2. Регистрационная информация баз данных. Добавлена возможность задавать значения параметров PostgreSQL для сессии.
  3. Управление правами. Добавлена возможность извлечения привилегий в виде SQL скрипта.
  4. Редактор функций.
  • Если функция изменена, то при вызове отладчика возникает запрос на ее компиляцию, отладку без компиляции или отладку старой версии функции.
  • В некоторых случаях проверка синтаксиса работала некорректно. Исправлено.
  • После компиляции курсор в теле функции не сохранял свою позицию. Исправлено.
  5. SQL Редактор.
  • Для результатов типа refcursor теперь можно открыть данные курсора (если выполнение в транзакции).
  • 'Union' подсвечивалось как алиас, если находилось сразу после секции FROM. Исправлено.
  • Если в запросе есть вложенные комментарии, при выполнении возникала ошибка. Исправлено.
  6. Мастер восстановления баз данных. Теперь корректно работает с очень большими SQL файлами.
  7. Проводник баз данных.
  • При открытии типа enum, даже если уже имелся открытый редактор этого типа, все равно открывалась новая форма. Исправлено.
  • Если включен режим "Сортировать по алиасам", а для отображения функций задано "Показывать аргументы как дочерние узлы", то аргументы функции сортировались по алфавиту, что вводило в заблуждение. Исправлено.
  8. Мастер извлечения баз данных.
  • При использовании PostgreSQL 9.1 и выше при выполнении производился запрос к системной таблице pg_authid, что вызывало ошибку при отсутствии прав. Исправлено.
  • При извлечении составных типов для полей–массивов не учитывалось количество размерностей массива. Исправлено.
  9. Настройки редактора. Настройки цвета фона применялись к полям описаний объектов, а цвет переднего плана – нет. Исправлено.
  10. Визуальный конструктор базы данных. Если в системе отсутствуют принтеры, при открытии формы возникала ошибка "В данный момент принтер не выбран". Исправлено.
  11. Редактор представлений. Информация на вкладке Triggers не обновлялась после изменения триггера. Исправлено.
  12. Поиск по метаданным. Теперь поиск не производится во временных объектах.
  13. В режиме плавающих окон отключение Windows Bar не сохранялось между сеансами работы. Исправлено.
  14. Мастер создания отчетов. Выбор стиля отчета не применялся к отчету. Исправлено.
  15. Дерево зависимостей. Зависимость между родительской и унаследованной от нее таблицами не показывалась в режиме показа подобъектов.
  16. Форма новой таблицы. При нажатии Ctrl+Insert всплывал диалог добавления поля, даже если была активна другая вкладка формы. Исправлено.
  17. Множество других исправлений и улучшений.

15.11.2012 выпущен SQL Manager for PostgreSQL 5.2.0.1

  1. Добавлена поддержка новых возможностей PostgreSQL 9.2:
  • Поддержка типов, описывающие диапазоны
  • Поддержка типа данных SMALLSERIAL
  • Поддержка привилегий на типы данных
  • Поддержка непроверяемых и ненаследуемых проверочных ограничений
  • Поддержка переименования ограничений
  • Поддержка метода доступа к индексам SP-GiST
  • Поддержка опции security_barrier в представлениях
  2. Конструктор баз данных.
  • Теперь в диаграмму можно добавлять представления и функции
  • Добавлена возможность показа свойств атрибутов (опциональность, вхождение в ключи и т.п.) в скобках после имени и типа атрибута.
  • Опции печати страницы диаграммы теперь сохраняются в файле диаграммы.
  • Добавлена возможность отображения границ листов печати на диаграмме.
  • Добавлена возможность перемещения мышью схем на диаграмму.
  • При загрузке диаграммы из файла не восстанавливалось положение линий связи. Исправлено.
  • После загрузки диаграммы, а также после переключения между страницами диаграммы значение в поле масштаба не обновлялось. Исправлено.
  3. Редактор функций.
  • Добавлена возможность проверки SQL синтаксиса тела функции. Также добавлена опция для автоматической проверки синтаксиса после компиляции.
  • Добавлена поддержка параметров конфигурации функции.
  • При форматировании тела функции с помощью команды Quick Code | Format в декларациях переменных %rowtype и %type добавлялся лишний пробел, что приводило к ошибке при компиляции. Исправлено.
  4. Мастер резервного копирования баз данных.
  • Добавлена поддержка подключения к серверу с использованием SSH-туннеля.
  • В базах данных с большими таблицами иногда выдавалась ошибка, что процесс pg_dump не отвечает, хотя само выполнение продолжалось нормально. Исправлено.
  5. Мастер восстановления баз данных.
  • Добавлена поддержка подключения к серверу с использованием SSH-туннеля.
  • Добавлен индикатор выполнения при восстановлении данных из SQL файла.
  • При восстановлении команд COPY с большим объемом данных из SQL файлов, возникала ошибка «Нехватка памяти» (Out of memory). Исправлено.
  6. Экспорт/Импорт данных.
  • Теперь в большинстве случаев не производится повторное открытие запроса, куда экспортируются данные.
  • Исправлено несколько ошибок, возникающих при экспорте/импорте.
  7. SQL Редакторы.
  • Опция завершения кода (Code Completion) теперь позволяет выбирать поля переменных композитного и %rowtype типов в теле PL/pgSQL функций.
  • Диалог сохранения файла. Последнее выбранное значение опции «Не добавлять ‘Byte-order-mark’ в файлы Unicode» теперь сохраняется между сеансами работы подобно опции набора символов (Charset).
  8. Отладчик функций.
  • Добавлена поддержка выражений типа RAISE EXCEPTION 'message' USING ERRCODE = 'XXXXX'.
  • Добавлена поддержка конструкции USING expression в команде открытия курсора.
  • Добавлена поддержка юникодных строк.
  9. Управление изменениями. Добавлена поддержка клиента VisualSVN Server.
  10. SQL Редактор. Теперь время выполнения запроса показывается более корректно, без учета дополнительных затрат в самой программе.
  11. Редактор внешних ключей. Добавлена поддержка внешних ключей без проверки (PostgreSQL 9.1 и выше).
  12. Состояние сервера. В список подключений добавлена колонка «Имя приложения».
  13. Просмотрщик данных.
  • При вставке записей из буфера обмена не вставлялись данные полей типа geometry, имеющих в имени поля символы в верхнем регистре. Исправлено.
  • При выполнении команды «Установить значение |Установить в пустую строку» вставлялся пробел вместо пустой строки для полей типа varchar большого размера. Исправлено.
  • При фильтрации значений GUID возникала ошибка. Исправлено.
  • При работе с сервером 9.0 и выше при редактировании полей xml в некоторых случаях возникала ошибка. Исправлено.
  • Вкладка Blob View была недоступна для полей xml, если данные не содержали Blob полей других типов. Исправлено.
  14. Проводник баз данных.
  • Дерево базы данных. Теперь в ветке базовых типов отображаются псевдо-типы и неопределенные типы.
  • Не отображались подсказки имен объектов, не входящие по ширине. Исправлено.
  15. Редактор объектов. Вкладка "Привилегии". Операция «Предоставить все права» теперь не назначает прав владельцу.
  16. Извлечение метаданных. Выражения DROP не создавались для типов Enum. Исправлено.
  17. Расширения. Программа зависала после установки расширения PostGIS. Исправлено.
  18. SQL Скрипт. При выполнении команды COPY с большим объемом данных из SQL файла, возникала ошибка «нехватка памяти».
  19. Отчет HTML. В некоторых случаях в создаваемом отчете национальные символы в именах объектов отображались некорректно. Исправлено.
  20. SQL Монитор. Время событий было показано не совсем корректно. Исправлено.
  21. Мастер сохранения настроек. Не сохранялись настройки: Форматтер SQL, Глобальные горячие клавиши и Шаблоны объектов. Исправлено.
  22. Прочие исправления и улучшения.

05.12.2011 выпущен SQL Manager for PostgreSQL 5.1.0.1

  1. Добавлена поддержка новых возможностей PostgreSQL 9.1:
    • Поддержка объектов "Сортировки".
    • Поддержка расширений (инструмент Расширения базы данных в меню Сервис).
    • Поддержка триггеров в представлениях.
    • Поддержка команды ALTER TYPE для составных и перечислимых типов данных.
    • Поддержка unlogged таблиц.
  2. Мастер резервного копирования баз данных. Добавлена поддержка создания резервных копий для PostgreSQL 9.1.
  3. Добавлена поддержка списка столбцов для триггеров типа UPDATE (PostgreSQL 9.0 и выше).
  4. Добавлена возможность отладки триггерных функций.
  5. Редактор функций.
    • Добавлено сочетание клавиш Ctrl+H для скрытия/показа элементов управления заголовка функции.
    • Добавлена возможность быстрого задания возвращаемого типа void и типа trigger.
    • В заголовке формы для функций с большим количеством параметров, список параметров усекается, чтобы помещалась также информация о базе и сервере.
    • Теперь в разделе Инструменты | Редакторы объектов в диалоговом окне Настройки окружения для создаваемых функций можно задать значение по умолчанию для свойства “Execute with definer's privileges”.
    • В списке выбора возвращаемого значения тип REF CURSOR переведен в раздел стандартных типов.
    • Пункты контекстного меню списка полей return table всегда были отключены. Исправлено.
    • При выполнении функции в редакторе, при задании некоторых очень больших по модулю отрицательных значений для параметра BIGINT, значение в функцию передавалось не правильно. Исправлено.
    • При закрытии редактора функций с большим количеством параметров возникала ошибка «Не удалось создать ключ XXX». Исправлено.
    • Переменные с типом “<имя поля таблицы>%тип” не попадали в список автозавершения кода. Исправлено.
  6. Редактор триггеров. Добавлено сочетание клавиш Ctrl+H для скрытия/показа элементов управления заголовка триггера.
  7. Управление изменениями. Добавлена поддержка Slik Subversion client. Также поддержка CollabNet Subversion client для Subversion.
  8. Во многих инструментах добавлена возможность экспорта табличных данных в файл.
  9. Редактор ограничений. Добавлена возможность задавать комментарий к ограничению.
  10. Редактор внешних ключей. Теперь можно менять размер формы.
  11. Редактор списка заданий. Теперь при открытии формы фокус находится на поле ввода текста. Добавлены горячие клавиши для перехода ко всем полям ввода.
  12. Сетка данных.
    • При закрытии формы с сеткой данных, если запись была изменена, но не сохранена, теперь выдается запрос на сохранение/отмену изменений в записи.
    • Неправильно определялся размер полей с числовыми типами данных, имеющих точность 15 и более – не позволялось вводить большие значения. Исправлено.
  13. SQL Редактор.
    • Если при отключенной опции “Показывать результаты для каждого запроса”, после текста запроса SELECT стоял разделитель операторов (;), а затем комментарий, при выполнении результат был пустым. Исправлено.
    • Не работал набор клавиш Ctrl+N для добавления новой закладки запросов. Исправлено.
    • При использовании локализации Azeri (Latin) некоторые символы вводились с клавиатуры некорректно. Исправлено.
    • При включенной опции “Разрешить использование параметров в тексте запросов” строки с двоеточием в комментариях также считались параметрами запроса, а при выполнении этого запроса выдавалось окно ввода значений. Исправлено.
  14. Конструктор баз данных.
    • После удаления таблицы с диаграммы, сохранения, и повторной загрузки диаграммы, удаленная таблица появлялась снова. Исправлено.
    • В режиме “Плавающие окна” в некоторых случаях рабочее поле диаграммы становилось неактивным, не реагировало на клики мыши и не позволяло добавлять таблицы. Исправлено.
  15. Конструктор запросов.
    • Запросы, имеющие выражение в условии присоединения, при разборе выдавали ошибку. Исправлено.
    • В режиме “Плавающие окна” после перемещения курсора над некоторыми вкладками, те прорисовывались некорректно. Исправлено.
  16. Отладчик функций.
    • При отладке функций, содержащих отдельные операторы CASE, возникала ошибка. Исправлено.
    • Если внешний и вложенный блоки кода имели переменные с одинаковым именем, то при переходе во вложенный блок отображаемое значение переменной не менялось. Исправлено.
    • В некоторых случаях при отладке функций, использующих BIGINT переменные, возникала ошибка "Переполнение при конвертации варианта типа (int64) в тип (целое число)". Исправлено.
  17. Статус сервера.
    • При разрыве соединения с сервером обновление информации по таймеру не прекращалось, и при этом каждый раз выдавалась ошибка. Исправлено.
    • При разрыве соединения с сервером, после того, как сервер становился доступным, соединение не восстанавливалось даже после нажатия “Обновить” - нужно было заново открывать форму. Исправлено.
  18. Редактор представлений. Вкладка Зависимости. В некоторых случаях показывались не все зависимости. Исправлено.
  19. Извлечение базы данных. Для версий сервера 8.2 и выше оператор создания последовательности (CREATE SEQUENCE) иногда шел после оператора создания таблицы (CREATE TABLE), использующей ее. Исправлено.
  20. Экспорт в SQL скрипт. При создании не PostgreSQL скрипта операторы INSERT генерировались с ошибкой. Исправлено.
  21. Создание таблицы. Если для поля указана опция Unique, то при сохранении таблицы эта опция не попадала в скрипт и не сохранялась. Исправлено.
  22. Управление пользователями. Если для первой базы данных хоста включено “Управление изменениями” и нет подключенных баз этого хоста, то при создании новой роли при сохранении возникала ошибка Access violation. Исправлено.
  23. Мастер восстановления баз данных. При восстановлении SQL файла, содержащего оператор подключения возникала ошибка. Исправлено.
  24. Редактор индексов. При добавлении нового индексного ключа с помощью контекстного меню, возникала ошибка “Невозможно конвертировать тип варианта (Null) в тип (OleStr)”. Исправлено.
  25. Управление правами.
    • Двойное нажатие по пустому полю или по заголовку сетки интерпретировалось как двойные нажатия по активной ячейке. Исправлено.
    • Для роли, имя которой было подстрокой имени другой роли, показывались суммарные права этих двух ролей. Исправлено.
  26. Мастер сохранения настроек. При сохранении клавиатурных шаблонов в файл и восстановлении их на другом компьютере, шаблоны, имеющие переводы строк, не восстанавливались. Исправлено.
  27. Проводник баз данных. При регистрации базы данных в одной копии программы, в другой открытой копии база данных также появляется в дереве, но ее настройки управления изменениями (change management) были пусты. Исправлено.
  28. Печать метаданных. Шаблон для таблиц формата A4 имел некорректный размер страницы. Исправлено.
  29. Редактор SQL скриптов. Неправильно определялся тип и имена объектов некоторых SQL операторов для показа в проводнике операторов.
  30. Мастер очистки таблиц и Мастер анализа таблиц. Даже при выборе отдельных таблиц действие выполнялось для всех таблиц базы данных. Исправлено.
  31. Прочие улучшения и исправления.

17.05.2011 выпущен SQL Manager 2011 for PostgreSQL 5.0.0.1.

  1. Управление изменениями. Помогает организовать контроль над процессом разработки базы данных. Позволяет откатить БД к определенному моменту времени; работать с разными ветками БД; просматривать историю изменений; получить скрипт перехода от одного состояния БД к другому; и другие возможности. Интегрируется со следующими version control systems: CVS, Subversion, Visual SourceSafe, TFS.
  2. Мастер сравнения баз данных. Позволяет получить скрипт для синхронизации структуры базы данных.
  3. Добавлен инструмент Search in Metadata. С его помощью можно выполнить быстрый поиск в рамках метаданных базы. Инструмент позволяет задавать различные условия поиска и просмотра результатов.
  4. Конструктор баз данных.
    • Добавлены операции 'Undo' и 'Redo'.
    • Добавлена возможность выбора схем для выполнения обратного проектирования.
    • Добавлены инструменты для форматирования объектов диаграммы: изменения шрифта, цвета и т.д.
  5. Мастер создания HTML отчетов. Теперь возможно задать стиль отчета визуально.
  6. Администратор регистрации баз данных. Позволяет быстро зарегистрировать новые базы данных и удалить регистрации несуществующих.
  7. Управление экземплярами сервера. Позволяет проверять статус сервиса PostgreSQL сервера и запускать/останавливать сервис.
  8. Добавлена возможность задавать сочетания клавиш не только для команд редактора SQL, но и для некоторых других команд. (Environment Options | Global Shortcuts)
  9. Имена объектов в DDL теперь не заключаются в кавычки без необходимости.
  10. Форматтер SQL позволяет теперь форматировать DDL операторы.
  11. Более удобное переключение между окнами по Ctrl+Tab.
  12. Появилась возможность копировать объекты в другую базу с помощью перетаскивания в проводнике баз данных.
  13. Другие улучшения и исправления.

15.11.2010 выпущен SQL Manager 2010 for PostgreSQL 4.8.

  1. Добавлена поддержка новых возможностей PostgreSQL 8.4:
  • Поддержка ограничений исключений.
  • Поддержка условия “when“ триггеров.
  • Поддержка новых версий pg_dump/pg_restore в Мастерах создания резервных копий и восстановления баз данных.
  • Добавлена опция “Explain buffers usage” при получении плана выполнения запроса, которая показывает дополнительную информацию о буферах.
  • Исправлена ошибка, возникающая после создания триггера, имеющего аргументы функции.
  2. Редактор функций. Теперь при нажатии клавиши Tab в таблице параметров фокус переходит на следующую ячейку таблицы.
  3. Редактор функций. При запуске функции в диалоге ввода значений параметров для типа timestamp нельзя было ввести время вручную. Исправлено.
  4. Проводник БД. Если включен показ системных объектов, теперь показываются табличные типы в ветке составных типов.
  5. Редактор таблиц. В Проводнике БД на навигационной панели не работали команды создания/редактирования/удаления правил. Исправлено.
  6. При работе с туннелем SSH при потере SSH соединения восстановить соединение можно было только после перезапуска программы. Исправлено.
  7. Отладчик функций. Для параметра типа numeric нельзя было указать значение с более чем 10 разрядами. Исправлено.
  8. В редакторах SQL и в просмотрщике данных не вводились с клавиатуры некоторые национальные символы. Исправлено.
  9. Статистика баз данных. После обновления игнорировалось значение поля All objects/User objects/System objects – показывались все объекты. Исправлено.
  10. Конструктор запросов. Неправильно парсились запросы, имеющие сравнение с true/false. Исправлено.
  11. Прочие изменения и исправления.

15.02.2010 выпущен SQL Manager 2010 for PostgreSQL 4.7.

  1. Добавлена поддержка разрешений на уровне полей таблицы (для PostgreSQL 8.4).
  2. Менеджер прав и вкладка Permissions в редакторах объектов. Добавлена поддержка привилегии Truncate (для PostgreSQL 8.4).
  3. Редакторы SQL.
  • Появилась возможность сворачивать код для регионов – разделов, ограниченных строками --region и --endregion.
  • Кодировка файла, выбранная в диалоге открытия/сохранения, теперь сохраняется и используется при открытии/сохранении файлов в дальнейшем.
  • Команда Undo не работала для отмены комментирования текущей строки (Ctrl+/).
  4. Статус сервера. Частота обновления теперь сохраняется между сеансами работы.
  5. Редактор таблиц, вкладка “Данные”.
  • Для таблиц, имеющих потомков, в панель инструментов добавлена опция “Include Data of Descendant Tables”.
  • Если таблица содержит поле с именем в верхнем регистре, то при сортировке по этому полю возникала ошибка. Исправлено.
  • Имена полей, содержащие не латинские символы, отображались некорректно. Исправлено.
  • При соединении по HTTP при вставке записей в таблицу с полем serial возникала ошибка, если search_path для данного пользователя имел отсутствующие в базе схемы (для режима с выключенными транзакциями). Исправлено.
  • Пункт контекстного меню Set Empty String всегда был недоступен для полей типа VARCHAR с неограниченным размером. Исправлено.
  6. Редактор агрегатных функций. Теперь при создании агрегатов в качестве типа входных данных можно указывать domain (для PostgreSQL 8.2 и выше).
  7. Извлечение базы данных.
  • Если путь к файлу сценария содержит несуществующие папки, эти папки теперь создаются автоматически.
  • При извлечении функции с параметром из другой схемы, чем сама функция, в некоторых случаях создавался неверный сценарий.
  8. Редактор SQL.
  • Для команды “Show Results on Edit Tab” добавлено сочетание клавиш Ctrl+D.
  • При определенной комбинации настроек для всех запросов показывалось "0 records fetched". Исправлено.
  9. Входные типы (input types) в DDL агрегатов теперь располагаются "в столбец".
  10. Сочетания клавиш. Добавлен запрос подтверждения удаления схемы и сочетаний клавиш.
  11. Форма создания таблиц. Значение по умолчанию для опции “With oids” теперь установлено на “off” в связи с тем, что такое значение по умолчанию установлено для данной опции на сервере, начиная с версии 8.1.
  12. Если после регистрации первой базы данных в программе сразу отменить регистрацию хоста или базы данных, возникала Access Violation. Исправлено.
  13. Конструктор баз данных. Если список объектов был представлен в виде дерева, то двойной щелчок по схеме приводил к ошибке Access Violation.
  14. Редакторы объектов, вкладка Dependencies. Если в программе была установлена неанглийская локализация, то при переходе на вкладку иногда возникала ошибка “Floating point division by zero”.
  15. Исправлено несколько ошибок, возникающих при работе с типами row и record в отладчике функций.
  16. Если для таблицы был установлен какой-либо параметр хранения данных, кроме fillfactor, при соединении с базой возникала ошибка. Исправлено.
  17. Конструктор запросов.
  • Неанглийские имена полей показывались некорректно. Исправлено.
  • Если имя поля или таблицы на сервере записано в нижнем регистре, а в запросе - в верхнем регистре и без кавычек, то парсер выдавал ошибку. Исправлено.
  18. Редактор функций. После выполнения процедуры, возвращающей набор данных, переставали работать сочетания клавиш Ctrl+Ins и Shift+Ins на закладке редактора текста процедуры. Исправлено.
  19. Другие улучшения и исправления.

10.12.2008 выпущен SQL Manager 2010 for PostgreSQL 4.6.

  1. Поддержка новых возможностей PostgreSQL 8.4:
  • Поддержка variadic функций; функций, возвращающих таблицу; значений по умолчанию для аргументов функций.
  • Поддержка ON TRUNCATE триггеров.
  • Поддержка SELECT запросов с WITH clause.
  • Поддержка новых опций pg_dump/pg_restore в мастерах создания резервных копий и восстановления БД.
  • Поддержка возможности устанавливать start value для последовательностей.
  2. Редактор SQL.
  • Появилась возможность использования macro.
  • Добавлена подсветка соответствующих открывающихся/закрывающихся скобок.
  • Исправлены ошибки, связанные с неверным анализом алиасов таблиц в запросах.
  • При возникновении ошибки место ошибки не всегда корректно подсвечивалось, даже если в сообщении имелась информации о нем. Исправлено.
  • Прерывание запроса производится теперь с помощью средств libpq.dll, а не посредством pg_cancel_backend функции – теперь для прерывания собственного запроса не нужно быть суперпользователем.
  • При отображении имени файла и пути в заголовке окна теперь при необходимости обрезается не имя файла, а его путь.
  • Если запрос возвращал значение Infinity в поле timestamp, значение отображалось как Null. Исправлено.
  3. Просмотр данных.
  • При открытии таблиц BLOB данные теперь автоматически не загружаются с сервера – только при обращении к ним.
  • Добавлена поддержка значений Infinity, -Infinity и NaN для полей типа real и double precision.
  • Исключены опции Perform data sorting on client, Perform data filtration on client – программа сама определяет оптимальный режим.
  • При вставке данных большого размера в поле bytea иногда возникала синтаксическая ошибка. Исправлено.
  4. Отладчик функций.
  • Добавлена поддержка конструкций RETURN QUERY и RETURNING … INTO … .
  • Возникала ошибка при получении данных из “for execute” курсора. Исправлено.
  • Возникала синтаксическая ошибка при наличии в функции конструкции FOR … IN EXECUTE … LOOP. Исправлено.
  5. Извлечение базы данных.
  • При извлечении всей базы данных раньше выгружались объекты различных расширений сервера. Исправлено.
  • Добавлена опция, позволяющая добавлять OID в комментарии объектов.
  • Извлечение данных теперь выполняется быстрее.
  • Описание ограничений выводилось как COMMENT ON INDEX, что приводило к ошибке при выполнении. Исправлено.
  6. Редактор функций.
  • Для функций, возвращающих курсор, теперь поддерживается экспорт данных.
  • Для некоторых функций при редактировании тела возникала ошибка List index our of bounds. Исправлено.
  • При компиляции функции, возвращающей данные составного типа, создавался неверный сценарий. Исправлено.
  7. DDL функций.
  • Аргументы теперь выводятся «в столбик».
  • Имя параметра не заключалось в кавычки, даже будучи ключевым словом.
  • Если функция имела параметр типа "char" (pg_catalog.char), в DDL этот параметр отображался как CHAR. Исправлено.
  8. Изменение метаданных.
  • Если сценарий завершается по таймауту, появляются кнопки Recompile with Double Timeout (Повторить с двойным таймаутом) и Recompile with Unlimited Timeout (Повторить с неограниченным таймаутом).
  • Если сообщение об ошибке содержит часть кода и указатель на позицию ошибки, для его отображения используется моноширинный шрифт.
  9. Менеджер прав. При назначении прав на таблицу с полем SERIAL, теперь предлагается назначить права и на соответствующую последовательность.
  10. Сценарий SQL. При отображении имени файла и пути в заголовке окна теперь при необходимости обрезается не имя файла, а его путь.
  11. Экспорт в виде сценария SQL. При экспорте в PostgreSQL при формировании определения таблицы теперь более корректно задаются типы полей.
  12. Проводник БД. Для последовательностей в меню Tasks появилась команда Restart Sequence (Перезапустить последовательность).
  13. Экспорт данных. При экспорте данных типа decimal с точностью более 14 цифр числа округлялись до 4 цифр. Исправлено.
  14. Редактор таблиц. На закладке описания не работала команда обновления. Исправлено.
  15. При добавлении поля NOT NULL в таблицу, имеющую данные со значениями по умолчанию, создавался неверный сценарий.
  16. Редактор представлений. Иногда текст запроса неправильно форматировался.
  17. Печать метаданных. Если у функции был большой заголовок, то в отчете он закрывал часть текста функции. Исправлено.
  18. Конструктор баз данных. Если удалить поле связи таблиц, а затем открыть существующую диаграмму, содержащую эти таблицы, возникала ошибка List index out of bounds. Исправлено.
  19. Монитор SQL, мастера создания резервных копий и восстановления баз данных. Неанглийские сообщения об ошибке не перекодировались из UTF-8 в Unicode.
  20. Исправлено несколько ошибок при работе в режиме плавающих окон.
  21. Прочие улучшения и исправления.

10.12.2008 выпущен SQL Manager 2007 for PostgreSQL 4.5.

  1. Регистрационная информация базы данных.
  • Большинство параметров раздела Параметры сетки данных | Настройки данных в диалоге Настройки окружения теперь можно настраивать для каждой базы данных индивидуально в окне регистрационной информации баз данных. Значения параметров, заданных в диалоге Настройки окружения теперь используются только как значения по умолчанию для вновь регистрируемых баз данных.
  • Добавлена опция “Schema-organized database tree”, при отключении которой для данной базы в Проводнике БД строится дерево без разбивки объектов по схемам.
  • Для журналов метаданных и Редактора SQL теперь есть возможность задать и сохранять данные в кодировке Unicode или ANSI.
  2. Дизайнер запросов.
  • Если таблица имеет связи посредством внешних ключей с другими таблицами из запроса, то при добавлении таблицы в запрос добавляются соответствующие выражения JOIN.
  • В некоторых случаях при переименовании таблиц и переходе на вкладку SQL возникала ошибка “Cannot bind JOIN expression”. Исправлено.
  3. Редактор функций.
  • Теперь можно посмотреть результат выполнения функций, возвращающих курсор.
  • Если для аргумента функции DOUBLE PRECISION задать значение 0, при выполнении функции это значение заменялось на NULL.
  4. Теперь поддерживается Unicode в теле функций, представлениях, правилах, проверочных ограничениях, описаниях объектов, значениях по умолчанию для полей, доменов и в других свойствах объектов.
  5. Проводник БД.
  • Теперь многие объекты из различных расширений сервера PostgreSQL считаются системными и не показываются, если для базы данных отключена опция “Показывать системные объекты”.
  • Улучшенный диалог поиска объектов.
  • На панели инструментов поиска добавлена кнопка переключения режима поиска.
  • Добавлена возможность менять порядок хостов путем перетаскивания их мышкой.
  • При закрытии программы сохраняется информация о последней рабочей базе, и при повторном запуске эта база автоматически выбирается в дереве.
  • При двойном щелчке по папке объектов, она раскрывается или сворачивается.
  6. Конструктор баз данных.
  • Теперь таблицы располагаются более плотно при обратном проектировании (reverse engineering).
  • Настройки выравнивания объектов на диаграмме не работали после открытия диаграммы из файла.
  • На некоторых принтерах не печатались иконки полей и таблиц. Исправлено.
  7. Вкладка "Данные | Вид BLOB". Добавлена вкладка XML для просмотра содержимого BLOB поля в виде XML.
  8. Сетка данных. Изменение принципа работы в асинхронном режиме – использование отдельного подключения для каждой сетки данных позволяет производить выборку данных без потери возможности одновременного использования остальных функций программы.
  9. Извлечение базы данных, Мастер экспорта в виде SQL скрипта. Сейчас сценарий создается сразу в выбранной кодировке символов, что значительно уменьшает время его создания.
  10. Опции SQL Manager. Во всех формах настроек добавлена возможность возврата к установкам по умолчанию как для всех параметров, так и для конкретной категории.
  11. Редактор представлений и Редактор правил. Теперь при открытии Редактора SQL запрос форматируется с помощью SQL Formatter. Также DDL представлений теперь не содержит лишних скобок в выражениях.
  12. Теперь в качестве владельца объекта можно задать и роль (для PostgreSQL версии 8.1 и выше).
  13. Список окон. Добавлена команда закрытия всех окон баз данных (“Close All Database Windows”).
  14. Редактор внешних ключей. Теперь в редакторе можно посмотреть и отредактировать описание внешнего ключа.
  15. Значение опции “Serial fields as integer” теперь распространяется не только на DDL таблицы, но и на все места, где отображается тип поля.
  16. На вкладке Редакторы объектов в диалоге "Настройки окружения" добавлена опция, позволяющая выбрать, разбивать ли функции опции в DDL на несколько строк, или показывать все опции в одну строку.
  17. Редактор таблиц. Мастера экспорта/импорта данных и экспорта в виде SQL скрипта теперь доступны, даже если данные таблицы не открыты.
  18. Мастер сохранения настроек. Теперь если файл для экспорта настроек уже существует, то выдается запрос на его перезапись или генерацию уникального имени.
  19. Редактор ограничений. Теперь можно менять размер окна, размер сохраняется между сеансами работы.
  20. Сетка данных. Теперь цвет курсора меняется, если сетка данных неактивна.
  21. Редактор SQL. В качестве имени запроса можно было задать имя уже существующего запроса. Исправлено.
  22. Быстрый код.
  • Параметры кода не всегда отображались для второго и последующих аргументов функции.
  • При наличии нескольких функций с одинаковым именем и разными аргументами показывались аргументы только одной из них. Исправлено.
  • Если автоматическое отображение параметров кода было отключено, то параметры не показывались даже при нажатии Ctrl+Shift+Space. Исправлено.
  23. Исправлены ошибки, связанные с неверным отображением в DDL типов полей для массивов на основе пользовательских типов данных.
  24. Редактор SQL.
  • Исправлено несколько ошибок, связанных с некорректной подсветкой SQL кода.
  • Если при сохранении содержимого в файл указать кодировку, отличную от Unicode, при последующем сохранении кодировка сбрасывалась в Unicode.
  25. При соединении через HTTP туннель если при сохранении объекта возникала ошибка, то она не отображалась в окне изменения метаданных, и всегда позволялось зафиксировать изменения, хотя реально на сервере изменения не произвелись.
  26. В дереве зависимостей и на вкладке Зависимости не отображались зависимости составных и табличных типов с другими объектами.
  27. При редактировании или удалении записей таблиц, содержащих polygon и/или point поля, иногда возникала ошибка. Исправлено.
  28. Отладчик функций. Возникала ошибка синтаксиса (“Syntax error”) при открытии функций с конструкцией FOR ... IN. Исправлено.
  29. Числовые поля большой точности не совсем корректно редактировались и отображались в гриде. Исправлено.
  30. После изменения порядка столбцов значения последовательностей SERIAL полей не восстанавливались.
  31. При некоторых настройках PostgreSQL сервера при редактировании поля money возникала ошибка. Исправлено.
  32. Свойства базы данных. Если описание базы данных содержало символ "\", при сохранении возникала ошибка. Исправлено.
  33. Другие исправления и улучшения.

18.07.2008 выпущен SQL Manager for PostgreSQL вер. 4.4

  1. Добавлены Backup Database Wizard и Restore Database Wizard, которые позволяют создавать резервные копии баз данных и восстанавливать базы данных из резервных копий с помощью pg_dump и pg_restore утилит PostgreSQL сервера.
  2. Редактор агрегатных функций. Добавлена поддержка агрегатных функций с несколькими аргументами. Добавлена поддержка оператора сортировки для MIN- or MAX-like aggregates.
  3. Редактор функций
  • Добавлена поддержка planner options при работе с сервером 8.3.
  • Добавлены сочетания клавиш Ctrl+Up/Ctrl+Down для изменения порядка аргументов.
  • При пересоздании функции не восстанавливались разрешения на нее. Исправлено.
  4. Просмотрщик данных
  • Поддержка типа данных PostGIS geometry. В Редакторе таблиц можно просматривать и редактировать geometry столбцы. В Редакторе запросов столбцы на основе вызовов asEWKT, asText функций - редактируемые.
  • Для поиска записи при обновлении или удалении добавлена опция Use key and changed fields (Environment Options | Grid | Data Options), которая теперь используется по умолчанию.
  • Числовые значения большой точности значение теперь корректно отображаются и редактируются.
  5. Отладчик функций
  • Добавлена команда Run to cursor.
  • В случае синтаксической ошибки теперь выдается номер строки с ошибкой.
  • Исправлено несколько ошибок выполнения функции и добавлена поддержка некоторых новых конструкций PL/pgSQL.
  6. Редактор SQL скриптов
  • Добавлена поддержка команды \connect <имя базы данных> для задания текущей базы во время выполнения скрипта.
  • Опция Default directory for scripts из Регистрационной информации базы данных не работала. Исправлено
  • Добавлена поддержка операторов CREATE RULE с ALSO clause. Раньше неправильно определялся конец оператора.
  7. После импорта данных в таблицу с помощью Мастера импорта данных или после вставки записей в таблицу в режиме редактирования данных, для SERIAL и BIGSERIAL полей производится обновление текущего значения последовательности.
  8. Редактор табличных пространств.Теперь отображается размер табличного пространства.
  9. Мастер создания HTML отчетов. Добавлена возможность поменять размер шрифта DDL секции.
  10. Редактор индексов. Добавлена опция Mark as index to cluster table on.
  11. К главной панели инструментов добавлена панель с опциями из меню Services: Анализ таблиц, Очистка таблиц, Статус сервера, Конфигурация сервера.
  12. Добавлена поддержка кодировки LATIN9 при открытии/сохранении SQL скриптов.
  13. Изменение метаданных. Теперь сохраняются положение и размер окна.
  14. В поле Description редакторов объектов теперь можно вставить символ табуляции.
  15. Конструктор баз данных. Для полей, основанных на NOT NULL доменах, не отображался признак NOT NULL. Исправлено.
  16. Мастер извлечения баз данных
  • В некоторых случаях функции выводились в скрипт дважды. Исправлено.
  • Таблицы созданные с опцией WITH OIDS выгружались в скрипт без этой опции.
  17. Не сохранялось положение и содержимое панелей инструментов главной формы. Исправлено.
  18. Code Parameters не работал для имен объектов, заключенных в кавычки.
  19. Редактор запросов. Не работала SQL сортировка для запросов с группировкой, имеющих ORDER BY clause.
  20. Прочие улучшения и доработки.

01.02.2008 выпущен SQL Manager for PostgreSQL вер. 4.3

  1. Поддержка новых возможностей PostgreSQL сервера 8.3:
  • Поддержка enum data types.
  • Поддержка типов TSVECTOR, TSQUERY, XML и UUID.
  • Поддержка массивов составных типов данных.
  • Поддержка порядка сортировки индексных ключей (ASC, DESC; NULLS FIRST, NULLS LAST)
  • Поддержка новых статистических данных сервера 8.3 в Статистике базы данных.
  2. Поддержка operator classes в ключах индексов.
  3. Проводник баз данных. Составные типы данных вынесены в отдельную ветвь дерева объектов базы данных.
  4. Инструменты редактора SQL:
  • При вводе параметров параметризованных запросов не поддерживался Unicode текст. Исправлено.
  • Не всегда корректно сохранялись Избранные запросы при работе с несколькими копиями Query data.
  5. Редактор SQL.
  • Многие функции стали работать быстрее.
  • Для некоторых операторов неправильно строился code folding. Также в DDL функций code folding теперь используется только для сворачивания всего тела.
  • Code Completion для алиасов таблиц не открывался при использовании в самом конце запроса.
  • В свернутых code foldings теперь показывается первое слово оператора.
  • Шаблоны клавиатуры теперь отключены для комментариев.
  • При заполнении Code Completion и подсветке ссылок теперь учитываются схемы по умолчанию из search_path configuration parameter.
  6. Импорт данных.
  • При импорте не учитывался параметр client encoding базы данных, и поэтому в некоторых случаях возникала ошибка Invalid byte sequence for encoding… .
  • Не работала опция Commit changes manually на предпоследнем шаге.
  7. Просмотрщик данных.
  • Подуровни, основанные на SQL запросе, теперь могут редактироваться и в режиме Load All Rows, но только, если запрос построен по одной таблице и содержит ключевые поля.
  • При вставке текста в ячейку таблицы по нажатию Shift-Ins появлялся диалог дублирования поля. Исправлено.
  • В зависимости от настроек программы, если имя столбца содержало точку, нельзя было редактировать данные таблицы.
  8. При удалении индекса, в генерируемом SQL операторе имя индекса было без схемы.
  9. Экспорт данных. При экспорте результатов запросов определенного вида возникала ошибка Parser: parse error at end of input. Исправлено.
  10. В мастерах в списках выбора базы данных не отображались базы данных с соединением через SSH или HTTP.
  11. При работе с PostgreSQL 8.3 все триггеры отображались как отключенные.
  12. Настройки внешнего вида. Опция Menu shows recent items first не сохранялась после закрытия программы.
  13. Редактор функций. Для добавления и удаления параметров добавлены сочетания клавиш Ctrl+Ins и Ctrl+Del соответственно.
  14. Мастер создания баз данных. На шаге установки параметров создаваемой БД теперь показываются только параметры, актуальные для данной версии сервера.
  15. Шаблоны клавиатуры. При использовании команды Paste в теле шаблона при применении шаблона вместо вставки всего текста из буфера обмена вставлялось только первое слово.
  16. Дерево зависимостей. Если прервать построение дерева, при последующем выборе объекта не запрашивалось повторное его построение.
  17. Прочие улучшения и доработки.

03.12.2007 выпущен SQL Manager for PostgreSQL вер. 4.2

  1. Query data
  • Редактор стал работать быстрее. На больших скриптах такие возможности как подсветка элементов и ссылки теперь не отключаются.
  • Добавлена возможность автоматического обновления проводника баз данных после выполнения DDL операторов. Включается на закладке Tools | Query data в Environment options,
  • Для результатов запросов теперь автоматически вызывается Fit Columns Widths.
  • При экспорте результатов запросов с параметрами не учитывались их значения, результаты были пусты. Исправлено.
  • При экспорте результатов запроса, содержащего оператор приведения типов "::", возникала ошибка. Исправлено.
  • При использовании в запросе некоторых восточно-европейских языков, не вводились некоторые символы. Исправлено.
  • Запросы INSERT, UPDATE, DELETED с RETURNING clause (на сервере 8.2) не возвращали результат. Исправлено.
  • В гиперссылках имен объектов иногда не учитывалась схема объекта. Исправлено.
  2. DB Explorer.
  • Добавлена панель для быстрого поиска объектов в DB Explorer.
  • Добавлена новая вкладка - Window List.
  • Базы данных с соединением по SSH и HTTP теперь помещаются в разные группы объектов серверов с соответствующими иконками.
  • В режиме ‘Group functions by names" при создании или удалении функции в дереве изменения отображались некорректно. Исправлено.
  3. Поддержка Enterprise DB 8.2.
  4. Добавлен инструмент для поиска опций SQL Manager (Options | Find Option).
  5. Visual Database Designer.
  • Поля NOT NULL выделяются жирным шрифтом.
  • Поля типа SERIAL и BIGSERIAL теперь выделяются подчеркиванием.
  6. View Editor. Добавлена команда для редактирования запроса в Design Query.
  7. Function Editor.
  • При работе с сервером 8.2 при добавлении OUT параметра генерировался неверный скрипт изменения метаданных. Исправлено.
  • При работе с сервером 8.2, при выполнении функции, возвращающей RECORD, возникала ошибка. Исправлено.
  • При компиляции функции, содержащей в качестве OUT параметра OIDVECTOR[] возникала ошибка. Исправлено.
  • Появилась возможность увеличить окно параметров.
  8. Data Grid.
  • Если запись содержали поля типа CIRCLE с определенными значениями, при сохранении изменений в данных, возникала ошибка "Error while posting updates". Исправлено.
  • Если на сервере установлена опция standard_conforming_strings, то при редактировании данных, требующих string escaping, возникала ошибка. Исправлено.
  9. Table Editor, вкладка Fields. Для полей типа домена теперь в скобках выводится базовый тип.
  10. Исправлена ошибка при соединении с сервером PostgreSQL 8.3 beta.
  11. Download File wizard. При работе с сервером 8.2 выдавалась ошибка. Исправлено.
  12. Design Query. Исправлено несколько ошибок связанных с синтаксическим анализом запроса.
  13. При работе с окнами команды Cascade и Tile работают теперь только для не свернутых окон.
  14. Grant Manager. Фильтр по имени объекта работал только в том случае, если имя полностью совпадало. Исправлено.
  15. EMS Direct. Не сохранялась дата последнего обновления, и поэтому при каждом запуске форма показывалась.
  16. Прочие улучшения и доработки.

20 июня 2007 выпущен SQL Manager for PostgreSQL вер. 4.1

  1. Импорт Данных. Теперь для увеличения скорости возможно импортировать данные посредством команды COPY. Для этого на шаге ‘Установки импорта и типы записи данных теперь можно указать «Пакетная вставка» в качестве типа импорта.
  2. При открытии/сохранении файла в редакторах SQL теперь можно указать кодировку файла.
  3. В SQL редакторах добавлена возможность обнаружения и автоматического исправления опечаток в SQL коде. Параметры проверки и исправлений можно настроить на закладке Правописание диалога Настройки Редактора.
  4. Во многих списках объектов появилась возможность использовать инкрементный поиск.
  5. Редактор Blob не был доступен для текстовых полей. Исправлено.
  6. Добавлена русская локализация.
  7. Просмотр данных: Форма. Для строковых полей с длиной 80 и более символов создается редактор как для полей TEXT. Добавлена опция Перенос слов в строках.
  8. Сетка данных. При вставке данных в поле типа TEXT данные обрезались до 8 килобайт. Исправлено.
  9. Завершение Кода.
  • Имена объектов с буквами в верхнем регистре теперь вставляются заключенными в кавычки.
  • Окно "Завершение кода" не открывалось для первого слова первой строки редактора. Исправлено.
  10. Редактор SQL.
  • Для таблиц с именем в нижнем регистре, если в SELECT запросе в имени таблицы присутствовали большие буквы, результаты запроса становились доступными только для чтения. Исправлено.
  • При сохранении содержимого закладки редактора в файл, после перемещения закладок файл становился привязанным к другой закладке. Исправлено.
  • В некоторых случаях прерывание запроса не работало. Также имелась вероятность установить такие настройки программы, что при прерывании запроса появлялось сообщение об ошибке и соединение с сервером прерывалось. Исправлено.
  • При использовании нескольких копий редактора SQL при сохранении содержимого учитывается, было ли изменено содержимое в другой копии.
  11. В DDL таблиц теперь более корректно определяется, является ли поле полем типа SERIAL. Теперь полями SERIAL считаются только те поля, в которых имя последовательности соответствует именам таблицы и поля.
  12. Экспорт данных в SQL скрипт. Теперь при экспорте в файл, если файл существует, выдается предупреждение.
  13. Проводник БД.
  • В контекстное меню добавлены команды Создать БД, Удалить БД.
  • Для баз с большим количеством объектов стал работать быстрее.
  • Если была создана закладка для папки Избранные Запросы, после обновления закладка исчезала. Исправлено.
  14. Конфигурация сервера, Настройки роли. Исправлено возникновение ошибки Access Violation при добавлении параметра.
  15. В некоторых случаях при отключении от базы данных возникала ошибка Access Violation. Исправлено.
  16. HTML отчет. На шаге выбора типов объектов для отчета добавлены кнопки для выбора/исключения всех объектов.
  17. Мастер закачки файлов. При возврате на предыдущий шаг введенные параметры не сохранялись. Исправлено.
  18. Для таблиц с именем в нижнем регистре, если в редакторе SQL имя написано большими буквами, оно не подсвечивалось как ссылка. Исправлено.
  19. Редактор Таблиц. При создании внешнего ключа на вкладке Поля признак внешнего ключа не обновлялся. Исправлено.
  20. В Lite версии при создании базы данных, если было превышено ограничение числа зарегистрированных баз, при повторном присоединении в дерево добавлялась база с пустым именем. Исправлено.
  21. После выравнивания окон (например, по вертикали) при выборе в редакторе другого объекта (панель Объекты) положение и размер формы изменялись. Исправлено.
  22. Прочие улучшения и доработки.

17.05.2007 Выпущен SQL Manager 2007 for PostgreSQL вер. 3.9

  1. Поддержка UTF8 в редакторе SQL, конструкторе запросов, в табличном виде, в мастерах экспорта/импорта данных.
  2. Теперь Вы можете продолжать работу с SQL Manager в то время, как в редакторе SQL или в конструкторе запросов производится выполнение запроса, либо запрашиваются данные таблицы или представления в редакторе. Выполнение затянувшегося процесса выполнения по желанию можно прервать.
  3. Новая форма Статистика базы данных позволяет просматривать разнообразную статистическую информацию об объектах базы данных, помогает найти узкие места в производительности БД, сделать выводы о необходимости создать новые индексы и т.п. Для сбора статистики должны быть установлены соответствующие опции в файле настроек сервера postgresql.conf.
  4. Все Мастера, включая Мастер экспорта/импорта данных, извлечения, копирования базы данных, теперь работают в фоновом режиме, а Вы в это время можете продолжать работать с программой.
  5. Новый улучшенный редактор SQL наподобие Visual Studio 2005 с функцией Code Folding и поддержкой UNICODE.
  6. Улучшенный Мастер импорта данных позволяет импортировать данные до 10 раз быстрее. Добавилась возможность импорта данных из файлов форматов HTML, XML Document, Open Document Format (OpenOffice), Open XML Format (MS Word 2007, MS Excel 2007).
  7. Добавлена поддержка большинства новых возможностей PostgreSQL сервера 8.2, таких, как:
  • поддержка параметра FILLFACTOR для таблиц и индексов
  • поддержка разрешения CONNECT для баз данных
  • поддержка разрешения USAGE для последовательностей
  • поддержка CREATE INDEX CONCURRENTLY
  • поддержка ALTER TABLE [ NO ] INHERIT
  • домены теперь могут создаваться на основе других доменов
  • поддержка выражения IF EXISTS в DROP операторах в мастере извлечения БД
  • поддержка возможности для всех объектов, которыми владеет роль, задать в качестве владельца другую роль
  8. В редакторах объектов добавлена закладка Разрешения (Permissions), на которой можно предоставить права на объект пользователям и группам.
  9. В Проводнике БД появилось меню генерации типовых SQL команд для объектов базы данных (Script to Query data, Script to Clipboard). Теперь Вы можете легко получить такие SQL команды как CREATE, ALTER, DROP, SELECT и др. для каждого объекта базы данных.
  10. Теперь Вы можете сохранять свои запросы в папках Избранные запросы в Проводнике БД; в этом случае запросы могут храниться либо локально в реестре (и быть доступными только для вас), либо в специальной таблице базы данных (и быть доступными некоторым либо всем пользователям вашей базы).
  11. Добавлен мастер скачивания файлов (Download File Wizard), который позволяет загружать файлы с/на сервер PostgreSQL с использованием стандартных функций PostgreSQL, протоколов FTP и SFTP.
  12. Улучшен Визуальный конструктор базы данных, добавлен новый вид объектов: комментарии. Выбор уровня детализации отображения объектов (отображать только имена объектов, либо поля). При выполнении Reverse Engineering можно выбрать схемы, таблицы которых добавлять на диаграмму.
  13. Улучшенный Мастер экспорта данных теперь работает быстрее. Добавилась возможность выгрузки данных в форматы XML Document, Open Document Format (OpenOffice), Open XML Format (MS Word 2007, MS Excel 2007).
  14. Добавлено окно Свойств базы данных (Database Properties) с показом и возможностью изменения некоторых опций базы данных.
  15. Улучшенный Редактор таблиц. Добавлена возможность просмотра и изменения свойств таблицы на отдельной закладке.
  16. В контекстном меню объектов в Проводнике БД появилось меню Операции (Tasks), в котором собраны основные операции, которые можно выполнить над выбранным объектом. Также хосты теперь именуются с учетом выбранного типа соединения: SSH или HTTP туннелирования.
  17. Улучшенная система построения отчетов.
  18. В отладчике функций (Function Debugger) изменившиеся переменные теперь выделяются жирным шрифтом. Добавлен показ переменных SQLSTATE и SQLERRM.
  19. Множество других улучшений и исправлений

14.12.2006 Выпущен SQL Manager for PostgreSQL вер. 3.8

Что нового в SQL Manager 2005 for PostgreSQL версии 3.8?

  1. SQL Скрипт.
  • Добавлена возможность выполнения выбранных операторов и операторов под курсором.
  • Добавлена поддержка выполнения оператора COPY FROM STDIN.
  • В списке сообщений теперь показываются замечания, возвращаемые сервером при выполнении SQL операторов.
  • При формировании имени объекта для его последующего отображения в Проводнике теперь учитывается схема, заданная в операторе SET search_path.
  • Не очищался список ошибок при загрузке файла. Исправлено.
  2. Управление Правами. Добавлена поддержка назначения прав с правами Grant.
  3. Мастер извлечения баз данных.
  • Добавлена возможность экстракта данных в виде SQL оператора COPY.
  • Увеличена скорость обработки по сравнению с предыдущей версией.
  • Опция Dollar-quoted function body теперь применяется и к определению функций, создаваемых в Мастере извлечения баз данных.
  4. SSH туннелинг.
  • Поддержка аутентификации по приват-ключу.
  • Возможность установки соединения для нескольких хостов/баз данных одновременно.
  5. Отладчик функций.
  • Добавлена поддержка dollar-quoted строк.
  • Добавлена поддержка SQL операторов SELECT INTO
  • В список переменных добавлены affected rows и result oid.
  • Исправлена некорректная обработка функций, содержащих переменные типа table_name.column_name%TYPE.
  • При выполнении Continue оператора возникала ошибка типа syntax error. Исправлено.
  • Команда RAISE NOTICE прерывала выполнение функции. Исправлено.
  6. Сетка Данных.
  • Фильтр по полям типа DATE работал некорректно, если в системных настройках компьютера формат даты отличен от MDY. Исправлено.
  • Установка фильтра с использованием опции «SQL фильтрация» вместе с ограничением по числу возвращаемых записей «Выбирать только *», приводила к тому, что данные либо отображались не полностью, либо не показывались вообще. Исправлено.
  • При выбранном виде «Форма» теперь работает прокрутка колесом мыши.
  7. Дерево Зависимостей.
  • При включенной опции «Показывать подобъекты» зависимости показывались не совсем корректно. Исправлено
  • Иконки объектов не выводились на печать. Исправлено.
  8. Конфигурация Сервера, вкладка Список Параметров. Добавлена колонка "Группа Параметров", для группирования параметров.
  9. Опции Отображения. Добавлена опция "Показывать часто выполняемые команды".
  10. Настройки Редактора. Добавлена возможность сброса цветов в значения по умолчанию.
  11. Опции Окружения, вкладка Проводник БД. Добавлена опция "Обновлять объекты при отображении в Ассистенте SQL".
  12. Проводник БД. Вновь созданный объект не попадал в список "Недавние Объекты".
  13. Data Import. При импорте из формата DBF требуемыми значениями для полей типа boolean по умолчанию были False, True, вместо F и T, что приводило к необходимости менять эти значения для импорта DBF файлов с boolean полями. Исправлено.
  14. Environment Options, Windows tab. Не работала опция "Ограничение одновременно открытых окон".
  15. Опции Окружения, Предпочтения. Опция "Сохранять состояние рабочей области при отсоединении" не применялась к правилам, индексам, триггерам и отчетам.
  16. Просмотр Логов. При попытке открыть текущий лог локального PostgreSQL сервера возникала ошибка IO error 32 и лог не открывался.
  17. Прочие улучшения и доработки.

09.10.2006 Выпущен SQL Manager 2005 for PostgreSQL вер. 3.7

Что нового в SQL Manager 2005 for PostgreSQL версии 3.7?

  1. Регистрация баз данных. Добавлена опция ‘Обновлять объекты при подключении, позволяющая отключить обновление списка объектов при подключении к базе данных. Рекомендуется отключать эту опцию, если база данных содержит большое количество объектов, или если соединение с базой медленное.
  2. Добавлена французская локализация.
  3. Редактор представлений. При любых изменениях представления генерировался скрипт вида DROP VIEW... CREATE VIEW, что приводило к ошибкам, если имелись зависимые от этого представления объекты. Исправлено.
  4. Настройки редактора | Быстрый код. Добавлена опция, предоставляющая возможность сортировать имена полей таблицы при показе в окне Автоподстановки кода.
  5. Отладчик функций. Некорректно работал с функциями, содержащие переменные вида table.column%TYPE. Исправлено.
  6. Сетка данных.
  • Добавлена опция Вид формы | Перенос слов в редакторе Memo (диалог Настройки окружения> Сетка > Расширенные).
  • Форматы (Сетка | Цвета и Форматы) не применялись к подчиненным уровням. Исправлено.
  7. Редактор таблиц | закладка Данные. Нельзя было отредактировать или удалить записи таблиц, содержащих TSearch2 поля. Исправлено.
  8. SQL скрипт. Теперь не закрывается при отключении от базы данных.
  9. При открытии данных таблицы, первичный ключ которой содержал выражения, возникала ошибка и данные не открывались. Исправлено.
  10. Редакторы индексов и представлений. При создании индексов и представлений их описание не сохранялось (сбрасывалось). Исправлено.
  11. Проводник БД.
  • Если для проекта создана вкладка, то после добавления в проект объекта, на вкладке объект не появлялся. Исправлено.
  • После обновления списка объектов не показывались функции, владелец которых отсутствует (удален). Исправлено.
  • Индексы и отчеты не открывались через меню Недавние объекты. Исправлено.
  12. Опции ‘Развернуть после соединения" применялись только для объектов Языки и Пространства. Исправлено.
  13. Редактор полей. При изменении типа объекта с SERIAL на BIGSERIAL генерировался неверный скрипт - не учитывалось, что последовательность уже есть в базе. Исправлено.
  14. Не всегда корректно отрабатывала команда ‘Сброс панелей инструментов и меню". Исправлено.
  15. Некоторые опции диалога "Заменить текст" в Редакторе SQL работали некорректно. Исправлено.
  16. Исправлено несколько ошибок, связанных с некорректной работой программы на многомониторной конфигурации.
  17. Дерево зависимостей. Элемент "Сохранить как изображение" отсутствовал на Навигационной панели.
  18. Теперь возможно изменять размер формы Списка Задач.
  19. Включение/отключение опции Dollar-quoted function body применялось только после перезапуска программы. Исправлено.
  20. Большое количество других улучшений и исправлений.

31.05.2006 Выпущен SQL Manager 2005 for PostgreSQL вер. 3.6

Что нового в SQL Manager 2005 for PostgreSQL версии 3.6?

  1. Добавлена поддержка работы с EnterpriseDB сервером.
  2. Export as SQL Script. Теперь можно выбирать, для какого DBMS сервера генерировать сценарий.
  3. Query data.
  • Возможность переименовывать и перемещать закладки.
  • Время выполнения запроса теперь показывается в формате часы:минуты:секунды.
  • Иногда при выполнении запросов в Query data возникала ошибка Range Check Error.
  • Добавлена возможность импортировать данные в запрос, если он поддерживает вставку данных.
  4. DB Explorer.
  • Добавлена команда Add to Projects. Теперь объекты в проекты можно добавлять не только перетаскиванием, но и посредством выбора в открывающейся по этой команде форме.
  • После дублирования таблицы в дереве не показывались индексы и триггеры новой таблицы. Исправлено.
  5. Grid.
  • Добавлены пункты контекстного меню Expand All и Collapse All.
  • Добавлена опция Save column sorting для режима Save and restore layout.
  • Не работала команда контекстного меню Paste Cell в Lite версии.
  • Не работала SQL sorting, если имена полей таблицы - ключевые слова SQL. Исправлено.
  • При прокрутке колесом мыши в Print Data view также прокручивался и DB Explorer. Исправлено.
  6. Уменьшена загрузка CPU при работе с программой.
  7. Extract Database.
  • Некорректно работал для функций, имеющих OUT параметры.
  • Некорректно работал, если имя таблицы "char". Исправлено.
  8. Query datas.
  • Открытие редактора объекта по Ctrl+Enter не учитывало схему объекта.
  • Поиск объекта в DB Explorer по Ctrl+Shift+Enter не работал. Исправлено.
  • SQL Formatter некорректно работал с "\" последовательностью символов в строках.
  • Команда "Select All" некорректно работала с очень длинными строками (более чем 4096 символов). Исправлено.
  9. Туннель HTTP не работал по протоколу HTTPS. Исправлено.
  10. В DDL функций на языке C теперь показывается object file.
  11. Положение элементов управления на панелях инструментов теперь не сбрасывается после установки новой версии программы. Сбросить панели инструментов и меню можно, использую соответствующую команду в Windows menu или button на форме Environment Options dialog.
  12. Environment Options. Изменение опции "Table details in SQL Assistant" не применялось к DB Explorer.
  13. Data Import wizard. При настройке соответствия столбцов для импорта из Excel, при выборе нового столбца курсор в гриде перемещался на первый столбец.
  14. Database Registration Info. При сохранении не проверялась уникальность алиасов БД.
  15. Visual Database Designer. Стиль контекстного меню не менялся в соответствии с текущей визуальной схемой.
  16. Множество других улучшений и исправлений.

03.04.2006 Выпущен SQL Manager 2005 for PostgreSQL вер.3.5.

Что нового в SQL Manager 2005 for PostgreSQL версии 3.5?

  1. Просмотр и редактирование Конфигурации Сервера.
  2. Query data. Реализовано переназначение клавиш для различных команд и операций в соответствии с вашими предпочтениями.
  3. Design Query. Просмотр плана выполнения запроса в виде графической диаграммы.
  4. Dependency Tree. Теперь диаграмма может быть распечатана.
  5. Function, Domain, Sequence, Aggregate editors, Table Properties. Теперь возможно поменять схему объекта (начиная с версии PostgreSQL Server 8.1).
  6. Function Editor. Реализована возможность редактирования параметров функций при отсутствии зависимых объектов у этой функции.
  7. Aggregate Editor.
  • Реализована возможность редактирования агрегатов.
  • Тип параметров агрегата, не опрашивающего входные значения, отображался некорректно. Исправлено.
  8. Было невозможно изменить имя объекта в формах редактирование пользователей и групп. Исправлено.
  9. Query data.
  • Добавлены пункты контекстного меню Next Bookmark и Previous Bookmark.
  • В некоторых редких случаях пропадал текст с начала строки при использовании инструмента автозавершения кода при включенной опции "Trim trailing spaces". Исправлено.
  • Теперь SQL Formatter корректно обрабатывает выражения TYPE CAST.
  • Перетаскивание имен полей из инструмента SQL Assistant теперь работает.
  10. Query data. Добавлена возможность выполнения выражения SQL под курсором.
  11. Visual Database Designer.
  • Не отображались изменения в открытой диаграмме при изменении имен полей или имени таблицы. Исправлено.
  • Если таблица не выделена, но выделено поле, то пункт контекстного меню Drop Table работал некорректно. Ошибка исправлена.
  • При удалении поля и последующем откате транзакции, возникало пустое сообщение об ошибке. Исправлено.
  12. Import Data Wizard.
  • Теперь при отключенных транзакциях в режиме "Commit changes manually" по завершении импорта запрашивается действие над транзакцией (Commit или Rollback).
  • Возможность менять размер диалогового окна.
  • Возникала ошибка "Division by zero" после импорта данных при включенной опции "Commit changes manually". Исправлено.
  • Игнорировалась установка Generator Value и Constant Value при задании формата импортируемых полей. Ошибка исправлена.
  • При задании части полей для импорта, в оставшиеся поля производилась вставка пустых строк, что приводило к тому, что значения по умолчанию, определенные в таблице для полей, не применялись. Ошибка исправлена.
  13. Сетка таблицы. В Лайт-версии невозможно было сменить режим таблицы. Исправлено.
  14. Extract Database.
  • Версия сервера вставляется в комментарий к сценарию.
  • В выражении CREATE TABLE, отсутствовали кавычки до и после имени таблицы. Исправлено.
  • При извлечении выбранных функций при включенной опции "Character and character varying as char and varchar", функции с параметрами типа CHAR и VARCHAR пропускались. Исправлено.
  15. HTML Report. Добавлена возможность смены верхнего и нижнего колонтитула отчета.
  16. SQL Script. Добавлено подтверждение на прерывание выполнения скрипта.
  17. DB Explorer.
  • Было невозможно открыть индекс или триггер из списка недавно открытых объектов. Исправлено.
  • Контекстное меню не скрывалось при переключении на другое приложение. Ошибка исправлена.
  • После переименования схемы, было невозможно получить доступ к ее объектам без обновления дерева объектов базы данных. Исправлено.
  • При попытке удаления объекта и последующем откате транзакции, он исчезал из дерева объектов. Исправлено.
  18. Operator Editor. При создании оператора, имело место неверное заключение в кавычки параметров типа массив. Исправлено.
  19. Table Editor. В некоторых случаях ограничения CHECK не отображались в дереве проводника. Исправлено.
  20. При создании новых последовательностей и последующей их компиляции без изменения каких-либо параметров, имя последовательности оставалось пустым при генерации сценария. Исправлено.
  21. Table Editor, View Editor. При экспорте списков подобъектов, строки длиной более 32 символа обрезались. Ошибка исправлена.
  22. Прочие незначительные улучшения и исправления ошибок.

07.02.2006 Выпущен SQL Manager 2005 for PostgreSQL вер.3.4

Что нового в SQL Manager 2005 for PostgreSQL версии 3.4?

  1. Query data. Добавлен показ плана выполнения запроса в виде графической диаграммы.
  2. Полная поддержка ролей на сервере PostgreSQL 8.1.
  3. Добавлен сервис "Server Status".
  4. SQL Formatter. Formats SELECT, INSERT, UPDATE, DELETE queries. (Available from Query data context menu).
  5. Добавлена итальянская локализация (Luigi Covato).
  6. SQL Script.
  • Теперь показывается прогресс выполнения скрипта и есть возможность остановить выполнение.
  • Появилась возможность открывать несколько окон одновременно.
  • Устранено зависание при редактировании скрипта большого размера (>10Mb), если была включена опция "Enable Parsing".
  7. Сетка таблицы.
  • При вставке записей из буфера обмена теперь можно задать соответствия столбцов данных из буфера обмена со столбцами данных запроса.
  • Form View. Увеличен редактор мемо-полей (настраивается в окне Environment Options на закладке Grid / Advanced)
  • Blob View. Добавлена опция "Word Wrap" для режима просмотра в виде текста.
  • Теперь "Set to Empty String" и другие подобные команды при выполнении не выполняют немедленного сохранения записи в таблицу
  • Реализована корректная работа с OID полями, для значений которых отсутствует BLOB объект.
  • Добавлена опция "OID columns as BLOB".
  8. Добавлена возможность переименования последовательностей
  9. Grant Manager.
  • Не показывались права для групп на сервере PostgreSQL 8.1.
  • При переключении БД иногда возникала ошибка "Record index is out of bounds".
  10. Report Designer и Report Editor теперь поддерживают соединение с базой данных через HTTP-туннель.
  11. Design Query теперь сохраняет запрос между сессиями.
  12. Query data: Теперь нет ограничения на размер редактируемого текста.
  13. Database Registration Info. Не сохранялось свойство "Font Charset".
  14. Очень долго происходило переключение языка программы, если имелись открытые соединения с базами данных. Исправлено.
  15. По нажатию F1 для некоторых форм не открывалась нужная страница документации. Исправлено.
  16. Исправлены ошибки при соединении с базой данных пользователя, не имеющего прав на все схемы.
  17. DB Explorer.
  • После удаления индекса или триггера, он не удалялся из дерева. Исправлено.
  • Пункт контекстного меню "Data Manipulation" работал некорректно для представлений.
  18. Устранено зависание Design Query при парсинге запросов, содержащих оператор приведения типа "::".
  19. При удалении таблицы, открытой на закладке "Data", программа зависала, либо операция прерывалась по таймауту. Исправлено.
  20. Function Debugger. Операция получения элемента массива по его индексу вызывала ошибку при работе с сервером PostgreSQL 7.2. Исправлено.
  21. Table Editor. Двойной клик по индексу в Table Explorer не открывал его редактор. Исправлено.
  22. После переименования объекта его имя в контекстном меню DB Explorer не обновлялось. Исправлено.
  23. Другие улучшения и багфиксы.

Смотрите также:

What's new


Часто задаваемые вопросы

  1. Что такое EMS SQL Manager for PostgreSQL?
  2. Чем отличаются Полная и Lite версии SQL Manager for PostgreSQL?
  3. Что мне потребуется для начала работы с SQL Manager for PostgreSQL?
  4. Чем отличаются функции Импорт/Экспорт в SQL Manager for PostgreSQL от утилит Export/Import for PostgreSQL?
  5. Чем отличается функция Дизайнер запросов из инструментария SQL Manager for PostgreSQL от приложения SQL Query for PostgreSQL?
  6. Чем отличается встроенная в SQL Manager for PostgreSQL функция "Извлечь Метаданные" от утилиты DB Extract for PostgreSQL?
  7. Не могу модифицировать DDL. Почему?
  8. Что такое SSH-туннель?
  9. Я не могу установить соединение с сервером PostgreSQL через SSH. Какие значения необходимо ввести в поля закладки SSH диалога "Database Registration".
  10. Что такое HTTP-туннель?
  11. При создании объектов базы данных, символы в их именах автоматически заменяются на символы нижнего регистра. Как мне это исправить?
  12. Я пытаюсь создать отчет в Конструкторе Отчетов, но не могу получить доступ к данным таблицы: список 'Band data source' пуст.
  13. Как повысить скорость работы с большими таблицами?
  14. Моя таблица содержит около 1000 записей и большое количество полей. Ее открытие в закладке "Данные" занимает слишком много времени.
  15. Мне нужно внести некоторые изменения в объекты моей тестовой базы данных, а затем те же изменения проделать и в основной. Может быть в SQL Manager for PostgreSQL для этого есть специальные инструменты?
  16. Я пытаюсь экспортировать таблицу, но поля TEXT не экспортируются.
  17. Чем отличаются функции "Извлечение базы данных" и "Экспорт в SQL-скрипт"?
  18. Как мне изменить директорию, в которую будут сохраняться экспортированные данные?
  19. Как только я пытаюсь выполнить запрос в Редакторе SQL или во время выполнения некоторых операций с объектами базы данных, я получаю сообщение об ошибке "ERROR: Query was cancelled".
  20. Я зарегистрировал базу данных, но при попытке ее открыть появляется сообщение "dynamic library libpq.dll not found".
  21. Как мне настроить форматы данных в сетке данных?
  22. Я работаю под MS Windows, но мой удаленный PostgreSQL сервер работает на LINUX. Могу ли я работать с этим сервером, используя SQL Manager?
  23. Я нахожусь за файерволом (роутером). Я могу использовать SQL Manager для управления удаленным PostgreSQL сервером?
  24. Почему я не могу соединиться с PostgreSQL сервером?

В:

Что такое EMS SQL Manager for PostgreSQL?

О:

EMS SQL Manager for PostgreSQL - это мощнейший графический инструмент для разработки и администрирования баз данных PostgreSQL. Он позволит легко и быстро создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, управлять пользователями и их привилегиями, визуально строить SQL-запросы, просматривать статистику базы данных, извлекать и распечатывать метаданные, экспортировать/импортировать данные, просматривать и редактировать BLOB-поля, и многое другое.

Наверх

В:

Чем отличаются Полная и Lite версии SQL Manager for PostgreSQL?

О:

Эти версии SQL Manager for PostgreSQL отличаются ценой и функциональностью. Чтобы зарегистрировать Ваш SQL Manager for PostgreSQL, обратитесь на страницу Покупки; узнать о функциональных особенностях той или иной версии продукта Вы можете на странице Таблица характеристик.

Наверх

В:

Что мне потребуется для начала работы с SQL Manager for PostgreSQL ?

О:

Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному серверу PostgreSQL, который можно скачать здесь: http://www.postgresql.org/downloads/. Загрузка бесплатна. Во-вторых, Вам нужен компьютер, удовлетворяющий системным требованиям.

Наверх

В:

Чем отличаются функции Импорт/Экспорт в SQL Manager for PostgreSQL от утилит Export/Import for PostgreSQL?

О:

Утилиты Export/Import for PostgreSQL включают в себя ряд дополнительных функций, не поддерживаемых SQL Manager for PostgreSQL, например:
- экспорт/импорт данных из/в нескольких таблиц сразу;
- экспорт/импорт данных из/в таблиц, выбранных из различных баз данных на одном хосте;
- консольная утилита для экспорта/импорта с использованием файла конфигурации, содержащего все настройки.

Наверх

В:

Чем отличается функция "Design Query" из инструментария SQL Manager for PostgreSQL от приложения SQL Query for PostgreSQL?

О:

В первую очередь, SQL Query for PostgreSQL работает быстрее, так как это более легкий продукт. Также SQL Query for PostgreSQL обладает рядом дополнительных функций для построения запросов, например:
- "избранные/favorite" запросы для поиска и быстрого запуска наиболее часто исполняемых запросов;
- хранение истории запросов, позволяющей совершить "откат" к любому отредактированному запросу;
- различные улучшения интерфейса программы для более продуктивной и удобной работы.

Наверх

В:

Чем отличается встроенная в SQL Manager for PostgreSQL функция "Извлечь Метаданные" от утилиты DB Extract for PostgreSQL?

О:

DB Extract for PostgreSQL включает в себя некоторые дополнительные функции, которые недоступны в SQL Manager for PostgreSQL, например:
- извлечение метаданных из различных баз данных, расположенных на одном сервере;
- консольное приложение для упрощения процесса извлечения;
- большая скорость работы.

Наверх

В:

Не могу модифицировать DDL. Почему?

О:

Закладки DDL в Редакторе Таблиц и Редактор UDF имеют параметры "только чтение/read only". Они отображают SQL-текст операций, которые Вы переносите из таблиц в закладки "Поля", "Индексы" или через UDF. Чтобы модифицировать этот текст необходимо скопировать его в буфер обмена, а затем изменять его, используя редактор выполнения скрипта.

Наверх

В:

Что такое SSH-туннель?

О:

SSH (Secure Shell Host) протокол используется для повышения компьютерной безопасности при работе с Unix-системами в Internet. SSH использует несколько алгоритмов шифрования разной степени надежности. Распространенность SSH связана еще и с тем, что многие Linux-подобные ОС (например, FreeBSD) включают в стандартную комплектацию SSH сервер. Для получения дополнительной информации Вы можете посетить http://openssh.org. Опция SHH туннель в SQL Manager представляет собой средство организации безопасного доступа к PostgreSQL серверам при работе по небезопасным каналам связи. Также Вы можете использовать SSH туннель для доступа к удаленным PostgreSQL серверам, если по каким-либо причинам порт 5432 закрыт для внешних подключений. Соединение через SSH туннель выглядит следующим образом. Сначала устанавливается соединение и производится процедура аутентификации между встроенным в SQL Manager SSH клиентом и удаленным SSH сервером, затем вся исходящая и входящая информация между программой и PostgreSQL сервером передается через SSH сервер с использованием коммуникационного порта (обычно 22), а SSH сервер транслирует информацию уже непосредственно PostgreSQL серверу. Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием SSH туннеля, Вы должны задать следующие параметры при регистрации базы данных в SQL Manager for PostgreSQL.
На первом шаге:
- Хост - имя хоста, где расположен сервер PostgreSQL с точки зрения сервера SSH. Если SSH и PostgreSQL сервера установлены на одной машине, то он совпадает с хостом SSH, или он может быть 'localhost'.

- Порт - порт сервера PostgreSQL, его значение по умолчанию 5432.

- Пользователь - имя пользователя сервера PostgreSQL.

- Пароль - пароль пользователя PostgreSQL.

Имейте в виду, что имя хоста PostgreSQL должно быть задано относительно сервера SSH. Например, если PostgreSQL и SSH сервера установлены на одном компьютере, Вы должны указать localhost в качестве имени хоста вместо имени внешнего хоста или IP адреса. Далее выберите опцию Использовать туннелирование и SSH туннель.

На втором шаге:

- SSH хост - хост, где активирован сервер SSH.

- SSH порт - порт, где активирован сервер SSH.

- SSH пользователь - пользователь Linux машины. (Это пользователь Linux. Это не пользователь сервера PostgreSQL.)

- SSH пароль - пароль пользователя Linux.

Наверх

В:

Я не могу установить соединение с сервером PostgreSQL через SSH. Какие значения необходимо ввести в поля закладки SSH диалога "Database Registration".

О:

Нужно ввести следующее:
На закладке "Туннелирование SSH":
- SSH хост - это хост, на котором активирован сервер SSH.
- SSH порт - порт, на котором запущен сервер SSH.
- SSH пользователь - это имя пользователя на сервере. (Пользователь сервера Linux. Это не имя пользователя сервера PostgreSQL).
- SSH пароль - пароль пользователя сервера Linux.
На закладке "Соединение":
- Хост - это хост, на котором расположен сервер PostgreSQL с точки зрения сервера SSH. Если сервер SSH расположен на том же компьютере, что и сервер PostgreSQL, то он приравнивается к Хосту SSH, или же к 'localhost'.
- Порт - это порт сервера PostgreSQL на Удаленном Хосте, по умолчанию его значение 5432.
- Пользователь - имя пользователя на сервере PostgreSQL.
- Пароль - это пароль пользователя на сервере PostgreSQL.

Наверх

В:

Что такое HTTP-туннель?

О:

HTTP туннелирование - это способ, при котором соединение и передача данных между программой и PostgreSQL сервером происходит через протоколы HTTP/HTTPS, используя порт 80, через который работает обычный веб-браузер. Этот способ подходит для соединения с PostgreSQL, расположенном на удаленном сервере хостинг провайдера, когда прямое соединение невозможно из соображений безопасности. Соединение через HTTP туннель выглядит следующим образом: все исходящие запросы и команды с клиентских программ кодируются и передаются по протоколу HTTP/HTTPS, используя порт 80, специальному скрипту, который декодирует их, передает PostgreSQL серверу на обработку и возвращает обратно результат. Для использования этого способа на удаленном сервере должен быть установлен HTTP сервер (например, Apache) и PHP с подключенным расширением PostgreSQL. Как правило, это программное обеспечение предлагают все хостинг-провайдеры, предоставляющие услуги хостинга на Linux платформах. Кроме того, Вы должны разместить наш emsproxy.php скрипт на вашем веб-сервере так, чтобы иметь к нему доступ извне (например, поместить его в каталог, где находятся ваши остальные PHP скрипты). Если ваш веб-сервер удовлетворяет данным требованиям и скрипт установлен правильно, то при открытии http:///emsproxy.php page. в веб-браузере Вы увидите “EmsProxy v1.31” (версия может меняться). Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием HTTP туннеля, Вы должны задать следующие параметры в Мастере Регистрации Баз Данных в SQL Manager for PostgreSQL.
На первом шаге:
- Хост - это хост, где расположен PostgreSQL сервер с точки зрения HTTP сервера. Обычно HTTP и PostgreSQL сервер расположены на одной машине и являются 'localhost'.
- Порт - это порт PostgreSQL сервера на удаленном узле, по умолчанию он 5432.
- Пользователь - это имя пользователя на PostgreSQL сервере.
- Пароль - это пароль пользователя на PostgreSQL сервере.
Далее выберите опцию "Использовать туннелирование" и "SSH туннель".
На втором шаге:
- URL - это адрес, где находится скрипт emsproxy.php (например, http://mywebserver /emsproxy.php).

Наверх

В:

При создании объектов базы данных, символы в их именах автоматически заменяются на символы нижнего регистра. Как мне это исправить?

О:

Вам нужно отключить параметр "Конвертировать имена создаваемых объектов к нижнему регистру" в диалоге "Параметры среды" на закладке Инструменты/Редакторы объектов.

Наверх

В:

Я пытаюсь создать отчет в Конструкторе Отчетов, но не могу получить доступ к данным таблицы: список 'Band data source' пуст.

О:

Чтобы получить источник данных в отчете, Вам нужно добавить диалоговую форму в отчет (меню 'Редактировать/Edit' 'Добавить форму диалога/Add dialog form' Конструктора Отчетов), затем поместить в нее базу данных и компоненты запроса из левой панели конструктора и установить связь и параметры запроса. После этого, запрос должен появиться в списках источников данных.

Наверх

В:

Как повысить скорость работы с большими таблицами?

О:

В целях повышения скорости работы и удобства Сетка Данных позволяет производить гибкую настройку многих параметров отображения данных. Ниже приведены наиболее важные из них (пункт меню "Настройки/Настройки окружения"). На закладке Сетка:
- Ограничения в редакторах. При включении опции "Выбирать все записи из таблицы" Вы будете иметь возможность видеть все записи таблицы без дополнительных запросов к серверу, однако для больших таблиц или при низкоскоростном канале связи возможны значительные задержки при получении данных, также входящий трафик может быть большим. Режим рекомендуется при работе с базами данных, расположенными локально либо в частной сети. Режим "Выбирать только" ограничивает максимальное число записей, возвращаемых в результате запроса. Режим обусловлен тем, что человек не способен осмысленно просмотреть огромный объем информации за один раз. Для запроса и отображения следующей порции данных служит кнопка "Далее" в панели инструментов "Сетка Данных". Данный режим значительно ускоряет просмотр данных таблицы, предотвращает зависание и разрыв соединения при таймауте. Рекомендуется для работы с большими таблицами, при низкоскоростных каналах связи и когда объем трафика имеет значение. Данный режим включен по умолчанию.

На странице "Сетка/Настройки данных":

- Режим сетки по умолчанию. Данная опция определяет, будут ли все строки запроса загружаться в Сетку сразу ("Загружать все строки"), либо по мере необходимости ("Загружать видимые строки"), т.е. когда пользователь пролистывает данные в таблице. Первый режим увеличивает время открытия результата запроса, но уменьшает задержки при пролистывании. При втором режиме время открытия результата запроса минимально, но возникают задержки при навигации по сетке.

- Также очень полезная опция при включенном режиме - "Выбирать только", но она увеличивает трафик. При отключенной опции фильтрация выполняется на клиенте без участия сервера, но только в уже загруженных данных. Т.е. если указано "Выбирать только 1000 записей", то фильтр будет выбирать только из этих записей.

Для максимальной производительности при работе с большими таблицами мы рекомендуем установить следующие значения для опций:

- Выбирать только - Включено

- Загружать все строки - Включено

Наверх

В:

Моя таблица содержит около 1000 записей и большое количество полей. Ее открытие в закладке "Данные" занимает слишком много времени.

О:

Вам необходимо включить опцию "Загрузить все записи". Щелкните правой кнопкой мыши на таблице и выберите опцию "Режим сетки/Загрузить все записи".

Наверх

В:

Мне нужно внести некоторые изменения в объекты моей тестовой базы данных, а затем те же изменения проделать и в основной. Может быть в SQL Manager for PostgreSQL для этого есть специальные инструменты?

О:

Диалог "Регистрационная информация базы данных" содержит закладку "Журналы", в которой Вы можете разрешить протоколирование всех изменений метаданных в базе данных, а также протоколирование выражений SQL, выполняемых в Редакторе SQL.

Наверх

В:

Я пытаюсь экспортировать таблицу, но поля TEXT не экспортируются.

О:

Поля типов TEXT, BYTEA, OID, а также VARCHAR больших размеров или без определенного размера по умолчанию не экспортируются. Необходимо вручную выбрать поля для экспорта в закладке "Поля".

Наверх

В:

Чем отличаются функции "Извлечение базы данных" и "Экспорт в SQL-скрипт"?

О:

Функция "Экспорт в SQL-скрипт" предназначена для экспорта табличных данных, которые будут вставлены в другую базу данных, отличную от сервера PostgreSQL. Функция "Извлечение базы данных" используется для копирования данных в таблицы сервера PostgreSQL.

Наверх

В:

Как мне изменить директорию, в которую будут сохраняться экспортированные данные?

О:

Для смены директории выполните следующие действия:

- Щелкните правой клавишей мыши на необходимой базе данных в Проводнике БД и левой клавишей на "Регистрационная информация базы данных" во всплывающем меню (этот пункт Вы можете найти также в основном меню "База данных"). Откроется форма с параметрами базы данных.

- Щелкните левой клавишей на закладке "Каталоги".

- В секции "Каталог для экспорта данных" Вы можете выбрать директорию для экспорта файла.

Наверх

В:

Как только я пытаюсь выполнить запрос в Редакторе SQL или во время выполнения некоторых операций с объектами базы данных, я получаю сообщение об ошибке "ERROR: Query was cancelled".

О:

Вам нужно увеличить значения задержек в закладке "Таймауты" диалога "Настройки окружения", или установить их равными нулю, то есть неограниченными.

Наверх

В:

Я зарегистрировал базу данных, но при попытке ее открыть появляется сообщение "dynamic library libpq.dll not found".

О:

Пожалуйста, убедитесь, что файл libpq.dll находится в директории SQL Manager for PostgreSQL. Переустановка приложения может решить эту проблему.

Наверх

В:

Как мне настроить форматы данных в сетке данных?

О:

Настроить все отображаемые форматы (integer, float, date, time и date/time) можно в окне "Параметры окружения/Сетка/Форматы".

Наверх

В:

Я работаю под MS Windows, но мой удаленный PostgreSQL сервер работает на LINUX. Могу ли я работать с этим сервером, используя SQL Manager?

О:

Да, это возможно. Главное - это то, что сам SQL Manager работает исключительно под управлением MS WINDOWS. Однако, под какой ОС работает PostgreSQL сервер, не имеет никакого значения.

Наверх

В:

Я нахожусь за файерволом (роутером). Я могу использовать SQL Manager для управления удаленным PostgreSQL сервером?

О:

Если из-за политики безопасности, принятой у вас в корпоративной сети или хостинг провайдером, вы не можете соединиться с вашим PostgreSQL сервером напрямую через TCP/IP (например, этому мешает файервол), то для этой цели вы можете использовать опцию SSH или HTTP туннель в SQL Manager.

Наверх

В:

Почему я не могу соединиться с PostgreSQL сервером?

О:

1. Убедитесь, что в файле pg_hba.conf PostgreSQL сервера (находится в папке данных кластера базы данных) имеется запись для вашего клиентского компьютера.

2. Если вы соединяетесь с удаленным сервером, то на удаленном сервере должны быть разрешены TCP/IP соединения. Для этого необходимо отредактировать файл postgresql.conf на сервере: в список listen_addresses надо добавить имя или TCP/IP адрес клиентского компьютера. Либо можно указать в этом параметре звездочку - тогда будет разрешено подключение с любого хоста. То же самое можно сделать, запустив сервер с опцией -i, что эквивалентно listen_addresses = '*'.

3. Убедитесь, что Вы вводите корректный логин/пароль.

Наверх

Если у вас возникли другие вопросы, то обратитесь в Службу поддержки.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for PostgreSQL EMS SQL Backup for PostgreSQL — это простой в использовании визуальный инструмент для создания резервных копий для нескольких серверов PostgreSQL из единой консоли. Вы можете создавать автоматизированные задачи резервного копирования на основе расписаний и хранить их в локальных или удаленных папках или облачных хранилищах.
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Начало работы

Первое что нужно сделать для того, чтобы начать работать с PostgreSQL в программе SQL Manager for PostgreSQL, это зарегистрировать одну или несколько баз данных. Для этого существует специальный инструмент Register Database Wizard. Если баз данных для регистрации нет, то их можно создать с помощью Create Database Wizard. Только после этого можно работать с базой данных – редактировать данные, администрировать и т.д.

Краткая информация по основным операциям, которые можно выполнить в программе приведена в разделе Как....

Перед началом выполнения этих операций прочитайте инструкцию.

Выбор стиля окружения и языка программы

Как выглядит программа при первом запуске

Работа с базами данных

Работа с объектами базы данных

Использование контекстных меню

Переключение между окнами

Получайте удовольствие от работы с SQL Manager for PostgreSQL!

Смотрите также:

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Выбор стиля окружения и языка программы

При первом запуске SQL Manager for PostgreSQL Вы должны выбрать стиль окружения и язык программы. Эти настройки позже можно поменять с помощью пункта главного меню программы Environment Options для смены стиля и Select Program Language для смены языка.

Getting started - Selecting style and language

Appearance theme

Выберите цветовую схему для программы:

Light - светлая,

Blue - голубая,

Dark - темная.

Bar style for editors

Выбор стиля отображения панелей.

RadioButton Navigation bar - навигационная панель (слева от основного окна редактора),

RadioButton Toolbar - панель инструментов (сверху от основного окна редактора),

RadioButton Both - навигационная панель и панель инструментов.

Program language

Позволяет выбрать язык интерфейса из списка доступных. Язык по умолчанию – английский.

(список доступных языков формируется на основе языковых файлов (*.lng), которые находятся в каталоге, в который установлена программа в директории "Languages").

Смотрите также:

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Первый запуск программы

Так выглядит SQL Manager for PostgreSQL при первом запуске.

Getting started - First time started

В контекстном меню проводника баз данных или на панели рабочего стола выберите Create new database для создания новой базы данных. Инструмент для создания - Create Database Wizard.

Для того, чтобы начать работать с уже существующей базой, необходимо её зарегистрировать. Новая, создаваемая с помощью Create Database Wizard, база регистрируется автоматически.

Нажмите Manage existing database(s), чтобы зарегистрировать базу данных с помощью Register Database Wizard.

Смотрите также:

Выбор стиля окружения и языка программы

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Использование панели рабочего стола

Desktop Panel видна тогда, когда не открыто ни одного дочернего окна. На неё вынесены элементы управления, необходимые для начала работы.

Getting started - Using Desktop Panel

Начало работы

Create new database - создает и регистрирует новую базу данных с помощью Create Database Wizard.

Manage existing database(s) – регистрирует существующую базу данных.

Create new table. Эта команда доступна, когда есть соединение хотя бы с одной базой данных. Создает таблицу в активной базе используя инструмент New table.

Create new database object – создает новый объект базы данных в активной базе. Соответственно, если нет активных соединений, то команда недоступна.

Инструменты базы данных

Execute SQL Script – открывает редактор выполнения скрипта.

Execute query – выполнить запрос, открывается редактор получения данных.

Manage permissions – управление правами пользователей. Предоставление пользователям права выполнения какого-либо действия с объектом базы данных.

Справочные материалы

PostgreSQL Manager help system - открывает этот файл справки.

PostgreSQL reference - открывает справку по PostgreSQL.

Ресурсы в сети Интернет

PostgreSQL Manager home page - ссылка на главную страницу продукта, где можно получить общую информацию о его приобретении, использовании и т.д.

PostgreSQL Manager on-line documentation - документация по SQL Manager for PostgreSQL на сайте компании. Дублирует справку, прилагающуюся к программе.

Support Center – позволяет пользователю получить on-line консультацию по любому интересующему вопросу с помощью системы Technical Support Center. Для получения такой поддержки необходимо зарегистрироваться на сайте.

PostgreSQL Manager FAQ – в этом разделе сайта пользователю предоставляется список из наиболее часто задаваемых вопросов и ответов на них.

Смотрите также:

Выбор стиля окружения и языка программы

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Работа с базами данных

После того, как база зарегистрирована, она появляется в Проводнике баз данных, который располагается в левой части окна.

Getting started - Database navigation

В нем отображаются все зарегистрированные базы данных. Те базы, с которыми в данный момент нет соединения, выделены серым цветом.

Getting started - Database navigation - Disconnected DB

В нижнем окне проводника, которое называется SQL Assistant, отображается содержимое активного элемента.

Getting started - Database navigation - SQL Assistant

Если в проводнике Вы выделили таблицу, то в нижнем окне появятся все столбцы этой таблицы, если сервер - то все базы, относящиеся к этому серверу и т. д.

Если активна опция Show Hosts, то представление баз данных имеет иерархическую структуру серверов и баз данных. Если эту опцию отключить, то в окне будет отображаться только список баз данных.

Включить опцию Show Hosts можно двумя способами. В Options | Environment Options | DB Explorer | нажать Show Hosts in DB Explorer, или в контекстном меню, открывающемся по нажатию правой кнопки мыши в Проводнике баз данных, выбрать пункт Show Hosts.

Смотрите также:

Выбор стиля окружения и языка программы

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Работа с объектами баз данных

Проводник баз данных позволяет получить доступ к любому объекту зарегистрированной базы данных, с которой в данный момент есть соединение.

Двойной щелчок на объекте открывает его в соответствующем редакторе.

Щелчком правой кнопки на объекте вызывается контекстное меню объекта со списком доступных для этого объекта операций. Обновить содержимое соответствующего поддерева можно нажатием клавиши F5 на клавиатуре, или выбрав соответствующий пункт контекстного меню. Таким образом, можно обновлять как всю базу целиком, так и некоторые объекты.

Getting started - Working with database objects

Если Вы хотите использовать проводник для работы с подобъектами (полями, индексами и т.д.) то выберите Show Table Subobjects в Environment Options | DB Explorer. Вы также можете включить эту функцию с помощью пункта меню Проводника баз данных View Mode.

Getting started - Working with database objects - View Mode

Смотрите также:

Выбор стиля окружения и языка программы

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Использование контекстных меню

Контекстное меню - это меню, отрывающееся при нажатии правой кнопкой мыши на объекте. Эти меню позволяют упростить работу с базами данных и с их объектами, обеспечивая быстрый доступ к наиболее часто используемым операциям.

Контекстные меню, открывающиеся в проводнике баз данных:

Контекстное меню сервера

Контекстное меню базы данных

Контекстное меню объекта

Смотрите также:

Выбор стиля окружения и языка программы

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Контекстное меню сервера

Контекстное меню сервера - это список действий, который можно открыть, нажав правой кнопкой мыши на сервере в проводнике баз данных.

Using context menus - Host context menu

iconChangeManagement Change Management - контроль изменений

  • Server Configuration - открыть окно задания параметров подключения сервера

btnCreateDB Create Database - создать базу данных

btnRegisterDB Register Database - зарегистрировать новую базу с помощью Register Database Wizard

btnUnregisterHost Unregister Host - удалить регистрацию хоста

iconViewMode View Mode - открыть подменю настройки отображения

  • Tabs - открыть подменю для работы с вкладками

iconFindObject Find Object - найти объект базы данных

iconSearchAgain Find Next Object - продолжить поиск

Tasks

iconServerStatus Server Status - статус сервера

iconUserManager Manage Users - управлять правами пользователей

btnGroupManager Manage Groups - управлять группами пользователей

Backup - создать резервную копию базы данных

Restore - восстановить базу данных из резервной копии

Change Management

iconChange Management - Create branch-Label-Tag Create Branch/Label/Tag - создать ветвь/Метку/Тег

  • Check Repository - проверить репозиторий

iconChange Management - Get Change script Get Change Script - получить скрипт изменений

  • Release New Version of Database - отправить новую версию базы данных

iconChange Management - History History - история изменений

View Mode

Show Table Subobjects - отображать подобъекты таблиц

btnHost Show Hosts - отображать серверы

  • Sort by Aliases - отсортировать базы данных по именам. По умолчанию, они расположены в порядке регистрации.
  • Hide Disconnected Databases - скрыть неподключенные базы данных
  • Tables' Details - подобъекты таблиц, которые будут отображаться в SQL ассистенте
  • Objects' Details - подобъекты остальных объектов, которые будут отображаться в SQL ассистенте

Tabs

btnNewTabFromHere New Tab from Here - создать новую вкладку

  • Rename Current Tab - переименовать активную вкладку
  • Delete Current Tab - удалить активную вкладку

Смотрите также:

Контекстное меню базы данных

Контекстное меню объекта


Контекстное меню базы данных

Контекстное меню баз данных открывается при нажатии в проводнике на базе данных правой кнопкой мыши.

btnConnectToDB Connect to Database - подключиться к выбранной базе данных (для неподключенной базы)

btnDisconnectFromDB Disconnect from Database - отключиться от выбранной базы данных (для подключенной базы)

  • открыть подменю Tasks

iconChangeManagement Change Management - работать с контролем изменений

btnDBProperties Database Properties - открыть Свойства базы данных

  • Server Configuration - открыть окно конфигурации сервера

btnCreateDB Create Database - создать базу данных

iconDropDatabase Drop Database - удалить базу данных

  • Database Registration Manager - администратор регистрации баз данных

btnRegisterDB Register Database - зарегистрировать новую базу с помощью Register Database Wizard

btnUnregisterDB Unregister Database - удалить регистрацию базы данных

btnUnregisterHost Unregister Host - удалить регистрацию хоста и всех зарегистрированных на нем баз данных

btnDBRegistrationInfo Database Registration Info - редактировать регистрационную информацию

  • Script to Execute Script - открыть скрипт базы данных в редакторе выполнения скрипта
  • Script to Clipboard - копировать скрипт базы данных в буфер обмена

iconViewMode View Mode - открыть подменю настройки отображения

iconRefresh Refresh Database - обновить базу данных

  • Test Connection (Reconnect) - проверить соединение (переподключиться)
  • Tabs - открыть подменю для работы с вкладками

iconFindObject Find Object - найти объект базы данных

iconSearchAgain Find Next Object - продолжить поиск

Using context menus - Database context menu

Подменю Tasks

Backup Database - создать резервную копию базы данных

Restore database - восстановить базу данных из резервной копии

btnGrantManager Manage Privileges - управление правами

btnExtractDB Extract Database - извлечь базу данных Extract Database Wizard

iconDatabases Copy Database - копировать базу данных

btnPrintMetadata Print metadata - печать метаданных

HTML Report - создать HTML отчет

iconToDoList To-Do List - открыть список задач

Analyze Tables - анализировать таблицу

Vacuum Tables - очистить таблицу

Reindex - переиндексировать таблицу

Database Extensions - расширения

Database Statistics - открыть статистику базы данных

Подменю Change Management

iconChange Management - Create branch-Label-Tag Create Branch/Label/Tag - создать ветвь/Метку/Тег

  • Check Repository - проверить репозиторий

iconChange Management - Get Change script Get Change Script - получить скрипт изменений

  • Release New Version of Database - отправить новую версию базы данных

iconChange Management - History History - история изменений

Подменю View Mode

Show Table Subobjects - отображать подобъекты таблиц

btnHost Show Hosts - отображать серверы

  • Sort by Aliases - отсортировать базы данных по именам (По умолчанию, они расположены в порядке регистрации)
  • Hide Disconnected Databases - скрыть неподключенные базы данных
  • Tables' Details - подобъекты таблиц, которые будут отображаться в SQL ассистенте
  • Objects' Details - подобъекты остальных объектов, которые будут отображаться в SQL ассистенте

Подменю Tabs

btnNewTabFromHere New Tab from Here - создать новую вкладку

  • Rename Current Tab - переименовать активную вкладку
  • Delete Current Tab - удалить активную вкладку

Смотрите также:

Контекстное меню сервера

Контекстное меню объекта


Контекстное меню объекта

Using context menus - Object context menu

Это меню открывается при нажатии на любом объекте базы данных правой кнопкой мыши.

  • New <объект> - создать новый объект базы данных
  • Edit <имя объекта> - открыть выбранный объект в редакторе
  • Rename <имя объекта> - переименовать выбранный объект
  • Drop <имя объекта> - удалить выбранный объект

iconDuplicateObject Duplicate <"имя объекта"> - копировать объект с помощью Мастера копирования объектов

  • Tasks - выполнить одно из заданий для таблицы (Для всех остальных объектов открывается дерево зависимостей)
  • Data Manipulation - выбрать одну из операций импорта/экспорта

iconChangeManagement Change Management | iconChange Management - History History - просмотреть историю изменений объекта (эта опция доступна только если включена система контроля версий)

btnDBProperties <"имя объекта"> Properties - просмотреть свойства объекта (для таблиц)

btnGrantManager Grants for <имя объекта> - управлять правами пользователей

  • Script to Execute Script - копировать скрипт объекта в редактор выполнения скрипта
  • Script to Clipboard - копировать скрипт объекта в буфер обмена

iconRefresh Refresh <имя объекта> - обновить информацию об объекте

btnDBRegistrationInfo Database Registration Info - редактировать регистрационную информацию базы данных

  • Tabs - открыть подменю работы с вкладками

iconFindObject Find Object - найти объект базы данных

iconSearchAgain Find Next Object - продолжить поиск

Подменю Tabs

btnNewTabFromHere New Tab from Here - создать новую вкладку

  • Rename Current Tab - переименовать активную вкладку
  • Delete Current Tab - удалить активную вкладку

Смотрите также:

Контекстное меню сервера

Контекстное меню базы данных


Работа с окнами

Переключение между открытыми окнами в SQL Manager for PostgreSQL организовано так же, как и в ОС Windows. По нажатию правой кнопки мыши на значке окна на панели задач программы появляется контекстное меню.

Getting started - Switching windows

Для перехода от одного окна к другому достаточно щелкнуть мышкой на нужном окне.

С помощью Environment Options | Appearance | Number of open editors is restricted можно задать максимальное число открытых редакторов объектов баз данных. Если количество открытых редакторов превысит заданное число, то программа автоматически будет закрывать ранее открытые редакторы.

Для упрощения работы с окнами, в SQL Manager for PostgreSQL существует специальный пункт в главном меню программы - Windows.

С помощью этого меню Вы можете:

  • Windows List - показать список открытых окон на вкладке Windows List,

Appendix - Window List

  • Cascade - расположить открытые окна каскадом,

Getting started - Windows - Cascade

  • Minimize All - свернуть все окна,
  • Tile Horizontal - расположить все окна одно над другим,

Getting started - Windows - Tile Horizontal

  • Tile Vertical - расположить все окна в один ряд,

Getting started - Windows - Tile Vertical

  • Set Defaults to All Windows - вернуть всем окнам первоначальный размер,
  • Reset All Toolbars and Menus - вернуть настройки всех панелей инструментов и меню к настройкам по умолчанию,
  • Close All - закрыть все окна,
  • из подменю пункта Close выберите тип объектов, которые в данный момент хотите закрыть, (например, если выберите таблицы, то закроются все открытые редакторы таблиц),
  • Previous Window - перейти к следующему окну,
  • Next Window - перейти к предыдущему окну.

Смотрите также:

Выбор стиля окружения и языка программы

Первый запуск программы

Использование панели рабочего стола

Работа с базами данных

Работа с объектами баз данных

Использование контекстных меню

Работа с окнами


Проводник баз данных

Проводник баз данных (Database Explorer или DB Explorer) основное навигационное окно для работы с базами данных и объектами баз данных. Дерево объектов в проводнике имеет иерархическую структуру. Окно проводника состоит из нескольких областей. С его помощью Вы можете быстро выполнять, практически, все операции с базами данных.

Панель инструментов проводника баз данных

Подключение к базе данных

Редактирование регистрационной информации баз данных

Основные операции над объектами

Использование вкладок

Выбор нескольких объектов

Недавно использовавшиеся объекты

Поиск

Просмотр информации об объектах в SQL ассистенте

Настройка проводника баз данных

Все объекты баз данных разделены по типам и доступны из соответствующих узлов. Для каждого типа отображается количество объектов.

Чтобы показать/скрыть окно проводника используйте команду View | DB Explorer в главном меню или нажмите клавишу F11.

DB Explorer - View

Для того чтобы быстро свернуть текущую ветку в проводнике (любую) и выделить родительский узел этой ветки Ctrl+Shift+С.

Смотрите также:

Начало работы

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты

Службы

Настройки

Дополнительно

Как...


Регистрационная информация баз данных

Если при создании и регистрировании базы данных Вы допустили ошибку, или указали неполную информацию, то Вы можете это исправить при помощи команды Database Registration Info.

Проводник баз данных позволяет редактировать регистрационную информацию баз данных в процессе работы.

Для этого используется пункт контекстного меню базы данных btnDBRegistrationInfo Database Registration Info (для подключенных баз данных) по нажатию на него открывается окно редактирования регистрационной информации базы данных.

Смотрите также:

Мастер регистрации баз данных

Регистрационная информация баз данных

Администратор регистрации баз данных


Подключение к базе данных

Команда Connect to database неактивна, если выполнено подключение к выбранной базе.

Подключить базу данных можно следующим образом:

  • в контекстном меню неподключенной базы данных выбрать пункт Connect to database

DB Explorer - Connecting to databases

  • на панели инструментов проводника выбрать пункт Connect to database

DB Explorer - Connecting to databases - Toolbar

  • выбрать Database | Connect to database в главном меню программы

  • в проводнике баз данных два раза щелкнуть мышкой по псевдониму базы данных
  • использовать сочетание клавиш Ctrl+Shift+С

Смотрите также:

Мастер регистрации баз данных

Регистрационная информация баз данных


Основные операции над объектами

Проводник баз данных позволяет получить доступ к основным действиям над объектом базы данных с помощью контекстного меню.

Важно: Для каждого типа объектов свое меню.

Основные операции, присутствующие в каждом контекстном меню, это:

  • New <объект> - создание
  • Edit <"имя объекта"> - редактирование
  • Drop <"имя объекта"> - удаление
  • Rename <"имя объекта"> - переименование
  • Duplicate <"имя объекта"> - копирование объекта

DB Explorer - Operations with database objects

Чтобы открыть объект в соответствующем редакторе достаточно двойного щелчка мыши на нем в проводнике баз данных.

С помощью операции drag-and-drop Вы можете добавить объекты в Редактор запросов, Дизайнер запросов или в Редактор SQL скриптов.

DB Explorer - Insert to Editor

Смотрите также:

Управление объектами базы данных

Редактор запросов

Выбор нескольких объектов


Выбор нескольких объектов

Иногда необходимо удалить, копировать или перенести большое количество объектов. Для каждого применять соответствующую операцию неудобно. Для таких случаев предусмотрена возможность выделения нескольких объектов одновременно.

Для того, чтобы выделить несколько объектов одновременно, надо выделять их левой кнопкой мыши, при этом удерживая клавишу Ctrl или Shift.

DB Explorer - Selecting multiple objects

Выделенные таким образом объекты можно:

  • Edit <n> Selected Objects - редактировать (n - количество выделенных объектов)
  • Drop Database Objects - удалять
  • помещать в Projects. Для этого действия пункта меню нет, поэтому объекты в проект перетаскиваются мышью

Важно: Если в Projects нет вложенных папок, то поместить туда объекты невозможно.

Смотрите также:

Основные операции над объектами

Управление объектами базы данных

Работа с проектами


Использование вкладок

Чтобы сделать Вашу работу как можно более удобной, в SQL Manager for PostgreSQL существует специальный сервис вкладок (Tab). Используйте вкладки, если хотите обеспечить быстрый доступ к определенной группе объектов проводника. Это может быть определенный сервер или база данных или группа объектов базы данных. Например, Вы можете вынести папку с представлениями на отдельную вкладку, или создать несколько вкладок на каждой из которых будет только одна база данных.

Поместить объект на отдельную вкладку можно с помощью пункта контекстного меню New Tab from Here, который присутствует в контекстном меню каждого объекта.

DB Explorer - Using tabs - New tab

Важно: Если отключить опцию отображения подобъектов таблицы на панели инструментов проводника, то New Tab from Here будет неактивен, так как таблица не является узлом дерева.

Если же эта опция включена, (кнопка View Mode | Show Table Subobjects), то пункт меню New Tab from Here становится активным.

В окне проводника баз данных можно отображать вкладки в двух видах:

  • в виде иконок на нижней панели проводника

DB Explorer - Using tabs - View as icons

  • в виде закладок

DB Explorer - Using tabs - View as tabs

Для перехода от одного вида к другому достаточно потянуть разделитель вверх или вниз.

DB Explorer - Splitter for tabs

Для этой же цели используются пункты Show more Buttons и Show Fewer Buttons всплывающего меню, открывающегося при нажатии на стрелку Configure buttons.

DB Explorer - Using tabs - Add or remove buttons

Для переключения между вкладками достаточно щелкнуть мышью или на иконке или на закладке.

Для этой же цели используются сочетания клавиш.

  • Ctrl+Shift+N - переход на следующую вкладку
  • Ctrl+Shift+P - переход на предыдущую вкладку

Переименование вкладок

Если хотите переименовать вкладку, то нужно перейти на нее и из контекстного меню баз данных выбрать пункт Rename Current Tab.

Удаление вкладок

Для удаления вкладки необходимо перейти на нее и из контекстного меню баз данных выбрать пункт Delete Current Tab.

Смотрите также:

Работа с проектами

Работа с окнами

Управление объектами базы данных


Недавно использовавшиеся объекты

Простой доступ к недавно использовавшимся объектам обеспечивает кнопка Recent Objects btnRecentObjects на панели инструментов проводника. Нажатие на неё открывает список последних, открывавшихся в пределах одной сессии, объектов. То есть, при закрытии SQL Manager for PostgreSQL этот список очищается.

DB Explorer - Recently opened objects

Количество элементов в этом списке можно менять с помощью Options | Environment Options | Tools | DB Explorer | Recent objects count.

Смотрите также:

Управление объектами базы данных

Настройки окружения


Поиск объектов

SQL Manager for PostgreSQL позволяет найти в проводнике баз данных объект по его названию. Эта опция используется, если в проводнике отображено большое количество объектов, и найти определенный объект достаточно сложно.

Пунктом Find Item контекстного меню или сочетанием клавиш Ctrl + F вызывается стандартное окно поиска, в котором указывается искомое слово.

DB Explorer - Find Object

Использование панели поиска

Первые символы искомого слова введите в поле Search. Все объекты, содержащие искомые символы, будут выделены цветом в проводнике баз данных.

Найденных объектов может быть несколько. С помощью кнопок [image] [image] Вы сможете перемещаться между найденными объектами.

DB Explorer - Search Panel

По умолчанию, Search Panel находится в верхней части проводника баз данных. Чтобы отобразить панель, выберите в контекстном меню панели проводника баз данных пункт Search Panel.

DB Explorer - Search Panel - Activate

С помощью кнопки [image] Вы можете переключать режимы поиска - Искать внутри одной категории/Искать везде.

Важно: Search Panel можно перетаскивать в любую часть окна программы.

Смотрите также:

Окно поиска


SQL ассистент

В нижней части проводника баз данных по умолчанию располагается вспомогательное окно, которое называется SQL Assistant.

В этом окне отображена более подробная информация о выделенном в проводнике баз данных объекте.

DB Explorer - SQL Assistant

Из SQL ассистента можно открывать для редактирования объекты, так же как и из проводника - двойным щелчком мыши на нужном объекте.

Для таблиц и представлений SQL ассистент можно настроить. Вы можете выбрать, что будет отображаться в SQL ассистенте, когда в проводнике будет выбрана таблица.

Show Columns - поля таблицы

Show foreign Keys - внешние ключи

Checks - Ограничения

Show Indices - индексы

Show Triggers - триггеры

Show Table Status - информация о таблице

Show DDL - DDL

Show Description - описание

Для остальных объектов можно указать

Show DDL - DDL

Show Description - описание

Вид настраивается с помощью кнопки View Mode на панели инструментов проводника.

Выберите пункт Tables' Details и в открывшемся меню укажите, что именно будет отображаться в SQL ассистенте.

DB Explorer - SQL Assistant - Object details

Или в контекстном меню SQL ассистента выберите пункт Tables' Details.

Смотрите также:

Управление объектами базы данных


Настройка проводника баз данных

Панель инструментов проводника баз данных

Панель инструментов - это набор инструментов над окном проводника баз данных. На эту панель вынесены кнопки управления базами данных и настройки проводника.

DB Explorer - Configuring DB Explorer - Toolbar

Панель инструментов можно настраивать, используя функцию Add or Remove Buttons, открывающуюся при нажатии на кнопку More Buttons btnMoreButtons в правом углу панели.

По умолчанию на панели инструментов располагаются такие кнопки:

  • Create - создать объект
  • Refresh Database - обновить базу данных
  • Connect to Database - подключиться к базе данных
  • Disconnect from Database - отсоединить базу данных
  • Properties - открыть свойства выделенного объекта
  • View Mode - настройка проводника
  • Recent - список недавно использовавшихся объектов
  • Quick Jump To Database - быстрый переход к базе данных

Все команды, кроме View Mode, предназначены для работы с базами данных. View Mode отвечает за настройку самого проводника и SQL ассистента.

View Mode

  • Show Table Subobjects - показать подобъекты таблиц в проводнике баз данных
  • Show Hosts - показать хосты
  • Sort by Aliases - сортировать базы данных по именам (по умолчанию базы отсортированы внутри сервера по времени регистрации)
  • Hide Disconnected Databases - скрывать неподключенные базы данных
  • настраивать Tables' Details в SQL ассистенте

DB Explorer - Configuring DB Explorer - View Mode

Используйте Options | Environment Options | DB Explorer для доступа к дополнительным настройкам проводника баз данных.

Панель поиска

Кроме панели инструментов имеется панель поиска - Search Panel.

DB Explorer - Search Panel - Customize

Важно: Search Panel можно перетаскивать в любую часть окна программы.

Смотрите также:

Настройка панелей инструментов

Настройки окружения


Избранные запросы

SQL Manager for PostgreSQL позволяет обеспечить быстрый доступ к запросам или некоторым частям запросов с помощью инструмента Favorite Queries

DB Explorer - Managing Favorite queries

Создать избранный запрос

Чтобы создать избранный запрос необходимо:

  • в проводнике баз данных из контекстного меню группы объектов Favorite Query выбрать пункт New Favorite Query,
  • перетащить выделенный текст запроса в папку iconFavoriteQueries Favorite Query, при этом откроется редактор избранных запросов.

Редактор избранных запросов

Этот редактор открывается только в том случае, если в контекстном меню избранного запроса Вы выбираете пункт Edit Favorite Query. Если откроете запрос двойным щелчком мыши, то он будет открыт в редакторе выполнения запросов.

SQL Editor - Favorites editor

С помощью редактора Вы можете создавать и редактировать избранные запросы.

В поле Name укажите имя запроса.

Из раскрывающегося списка Storage выберите место хранения.

В SQL редакторе Вы можете работать с текстом запроса так же как в редакторе запросов.

Смотрите также:

Использование вкладок

Редактор избранных запросов


Управление базами данных

SQL Manager for PostgreSQL предоставляет пользователю все необходимые инструменты для создания и управления базами данных.

Вы не сможете работать с базой данных в SQL Manager for PostgreSQL, если не зарегистрируете её.

Удаление регистрации сервера

Если Вы не используете сервер, то Вы можете его удалить, воспользовавшись функцией Unregister Host. Незарегистрированный сервер не отображается в проводнике баз данных.

Для удаления регистрации вам необходимо проделать следующие операции:

  • в проводнике баз данных выбрать сервер, регистрацию которого хотите удалить,
  • выбрать пункт Database | Unregister Host в главного меню программы или в контекстном меню сервера,
  • подтвердить удаление регистрации в появившемся окне.

Создание базы данных

Для упрощения процедуры создания базы данных в SQL Manager for PostgreSQL существует специальный инструмент - Мастер создания баз данных Create Database Wizard. С его помощью пользователь пошагово создает базу данных

Для создания базы данных необходимо выполнить следующие операции:

  • выбрать пункт Database | Create Database главного меню программы,
  • задать имя базы, имя сервера, тип авторизации,
  • включить опцию "регистрация после создания" Register After Creating,
  • просмотреть и исправить полученный в результате SQL скрипт.

Регистрация базы данных

Для начала работы в SQL Manager for PostgreSQL с уже существующей базой данных Вам необходимо её зарегистрировать. Для этого существует специальный инструмент Register Database Wizard. Для запуска мастера выберите пункт Database | Register Database главного меню программы.

С помощью этого инструмента Вы можете выбрать сервер, выбрать базу на этом сервере и для неё задать параметры подключения, параметры авторизации и другие опции регистрации.

Для регистрации нескольких баз, находящихся на одном сервере, нужно на шаге задания параметров сервера отключить функцию Register a single database, тогда на следующем шаге сможете выбрать несколько баз для регистрации и зарегистрировать их все одновременно.

Удаление регистрации базы данных

Если Вы не используете базу данных, то Вы можете воспользоваться функцией Unregister Database - Удалить регистрацию базы данных. Незарегистрированная база не отображается в SQL Manager for PostgreSQL.

Для удаления регистрации вам необходимо проделать следующие операции:

  • выбрать базу, регистрацию которой хотите удалить, (щелкнуть на ней мышкой в проводнике баз данных),
  • выбрать пункт Database | Unregister Database главного меню программы,
  • подтвердить удаление регистрации в появившемся окне.

Удаление базы данных

При удалении базы данных она удаляется с сервера полностью.

Для удаления базы данных нужно:

  • выбрать базу, которую хотите удалить, (щелкнуть на ней мышкой в проводнике баз данных),
  • выбрать пункт Database | Drop Database главного меню программы (в контекстном меню базы данных этого пункта нет),
  • подтвердить удаление базы данных в появившемся окне.

Удалять можно как подключенные, так и неподключенные базы данных. Если соединение с сервером отсутствует, то удалить базу не удастся.

Подключение к базе данных

Команду Connect to Database можно найти в:

  • главном меню программы - Database | Connect to Database,
  • контекстном меню базы данных.

Для подключения базы данных также можно использовать сочетание клавиш Ctrl+Shift+C или двойной щелчок мыши на имени нужной базы в проводнике.

Отключение от базы данных

Если сеанс работы с базой данных завершен, то Вы можете отключиться от неё.

Команда Disconnect from Database присутствует везде, где есть Connect to Database. Отключиться от базы данных можно также с помощью сочетания клавиш Ctrl+Shift+D.

Смотрите также:

Начало работы

Проводник баз данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты

Службы

Настройки

Дополнительно

Как...


Мастер создания баз данных

Мастер создания баз данных Create Database Wizard автоматически генерирует SQL-скрипт для создания новой базы данных и выполняет его на PostgreSQL.

Вызывается мастер командой Create Database, которая присутствует в:

  • главном меню программы - Database | Create Database
  • на панели инструментов SQL Manager for PostgreSQL
  • на панели инструментов проводника
  • на панели рабочего стола

Если же Вы не хотите использовать мастер, или у Вас есть готовый SQL-скрипт, то можете воспользоваться редактором выполнения скриптов.

Мастер состоит из следующих шагов.

Setting database name - Присвоение имени новой базе данных

Setting connection properties - Установка параметров подключения к новой базе данных

Tunneling options - Параметры туннелирования

Setting advanced database properties - Задание основных свойств базы данных

Result SQL statement - Просмотр получившегося в результате SQL-скрипта

Смотрите также:

Мастер регистрации баз данных

Регистрационная информация баз данных

Параметры базы данных


Присвоение имени

В поле Database name укажите имя базы данных. Если на сервере уже существует база с таким же именем, программа Вас об этом предупредит.

Если хотите автоматически зарегистрировать базу сразу после создания, то установите флажок Register after creating. В этом случае после завершения создания базы откроется окно Database Registration Info.

Create Database Wizard - Setting database name

Следующий шаг


Установка параметров соединения

На втором шаге необходимо задать параметры соединения с сервером.

Create Database Wizard - Setting connection properties

Из раскрывающегося списка Host name выбираете сервер (хост), к которому хотите подключиться. В этот список попадают имена или IP адреса уже зарегистрированных серверов.

В поле Port задайте порт для подключения. Укажите имя пользователя и пароль в полях User name и Password.

CheckBox Если установлен флажок Use tunneling, то можно использовать один из предложенных видов туннелирования:

RadioButton SSH tunneling - SSH туннелирование

RadioButton HTTP tunneling - HTTP туннелирование

Смотрите дополнительно в разделе Часто задаваемые вопросы.

Я не могу установить соединение с сервером PostgreSQL через SSH. Какие значения необходимо ввести в поля закладки SSH диалога "Database Registration".

Следующий шаг


Параметры тyннелирования

Если на втором шаге Вы указали, что будете использовать туннелирование, то на третьем шаге необходимо задать параметры туннелирования.

Используйте SSH туннелирование для осуществления обмена данными с сервером по шифрованному каналу.

Если Вы выбрали SSH tunneling , то необходимо будет указать следующие параметры:

Create Database Wizard - Setting connection properties - SSH

  • SSH host name - имя сервера SSH. В случае задания параметров SSH, имя или ip адрес на предыдущем шаге должно указываться относительно машины, на которой установлен SSH сервер. Использование localhost подразумевает что SSH сервер и PostgreSQL сервер запущены на одной машине. Имя SSH сервера задается относительно клиентской машины, на которой запущен SQL Manager for PostgreSQL.
  • SSH port - порт.
  • SSH user name - имя пользователя.
  • SSH password - пароль.

В случае использования SSH туннелирования, имя хоста PostgreSQL должно быть задано относительно сервера SSH. Например, если PostgreSQL и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.

CheckBox Use private Key for authentication

Если установлен флажок Use private Key for authentication, то дополнительно будет использоваться ключевой файл, который можно будет указать в поле SSH key file. Если для использования этого файла нужно ввести пароль, то это можно сделать в появившемся поле.

Если выбрали HTTP туннелирование, то задать надо будет адрес сервера и путь до скрипта в поле URL.

Create Database Wizard - Setting connection properties - HTTP

Следующий шаг


Задание основных свойств базы данных

На этой вкладке необходимо задать основные параметры базы данных.

Create Database Wizard - Setting advanced database properties

Location - расположение создаваемой базы данных указывается в виде текстовой строки, в формате путей для ОС, на которой запущен PostgreSQL сервер. (Для PostgreSQL вер. 7.4 или ниже).

Template - выберите один из существующих шаблонов баз данных, (шаблон - это база с которой будет копироваться новая база данных, если не задано, то в качестве шаблона будет использована системная база данных template1).

Encoding - из этого раскрывающегося списка выберите кодировку, которая будет использоваться в новой базе данных.

Owner (для версий сервера 7.3 и выше) - в этом поле нужно указать пользователя, который обладает правами владельца базы данных.

Default Tablespace (для версий сервера 8.0 и выше) - из этого списка выберите табличное пространство, используемое по умолчанию.

Connection Limit (для версий сервера 8.1 и выше) - в этом поле задайте максимальное число одновременных подключений к базе данных. (-1 - неограниченное число подключений).

Следующий шаг


Просмотр скрипта

На последнем шаге мастер предоставляет возможность просмотреть автоматически сгенерированный SQL скрипт. При необходимости, Вы можете его отредактировать.

Create Database Wizard - Viewing result SQL statement

При нажатии кнопки Run будет создана база данных со всеми заданными параметрами.

Если Вы на первом шаге установили флажок Register after creating, то, после того как Вы нажмете Run, откроется окно Database Registration Info, в котором можно будет указать регистрационную информацию базы данных.


Мастер регистрации баз данных

Мастер регистрации баз данных позволяет Вам зарегистрировать уже существующую базу данных в SQL Manager for PostgreSQL.

Вызывается мастер командой btnRegisterDB Register Database..., которая присутствует в:

  • главном меню программы Database | Register Database...
  • на панели инструментов SQL Manager for PostgreSQL
  • в контекстном меню баз данных
  • вызывается сочетанием клавиш Shift+Alt+R

Мастер состоит из следующих шагов:

Установка параметров соединения

Параметры туннелирования

Выбор базы данных

Установка параметров регистрации

Смотрите также:

Мастер создания баз данных

Регистрационная информация баз данных

Параметры базы данных


Установка параметров соединения

На этом шаге необходимо задать параметры соединения с сервером.

Register Database wizard - Setting connection parameters

Из раскрывающегося списка Host name выбираете сервер (хост), к которому хотите подключиться. В этот список попадают имена уже зарегистрированных серверов.

В поле Port задайте порт для подключения. Укажите имя пользователя и пароль в полях User name и Password.

CheckBox Register a single database

Если убрать флажок Register a single database, то система позволит выбрать и зарегистрировать сразу несколько баз данных, имеющихся на сервере.

CheckBox Use tunneling

Если установлен флажок Use tunneling, то можно использовать один из предложенных видов туннелирования:

RadioButton SSH tunneling - SSH туннелирование

RadioButton HTTP tunneling - HTTP туннелирование

Используйте SSH туннелирование для осуществления обмена данными с сервером по шифрованному каналу.

Для доступа к PostgreSQL серверу через HTTP протокол выберите HTTP туннелирование.

Параметры туннелирования

Следующий шаг


Параметры туннелирования

Если на первом шаге Вы указали, что будете использовать туннелирование, то на этом шаге необходимо задать параметры туннелирования.

Используйте SSH туннелирование для осуществления обмена данными с сервером по шифрованному каналу.

Если Вы выбрали SSH tunneling, то необходимо будет указать следующие параметры:

Register Database wizard - Setting connection parameters - SSH

Используйте SSH туннелирование для осуществления обмена данными с сервером по шифрованному каналу.

SSH host name - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH port - порт SSH сервера на удаленном хосте (по умолчанию равен 22).

SSH user name - имя пользователя на сервере (пользователь SSH сервера, а не сервера PostgreSQL).

SSH password - пароль пользователя SSH сервера.

Имейте в виду, что в случае использования SSH туннелирования имя хоста PostgreSQL должно быть задано относительно сервера SSH. Например, если PostgreSQL и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.

CheckBox Use Private Key for authentication

Если установлен флажок Use Private Key for authentication, то в поле SSH key file можно указать ключевой файл для аутентификации.

Если выбрали HTTP туннелирование, то задать надо будет адрес сервера в поле URL.

Register Database wizard - Setting connection parameters - HTTP

Следующий шаг


Выбор базы данных

Если на первом шаге убрать флажок Register a single database, то система позволит выбрать и зарегистрировать сразу несколько баз данных, имеющихся на сервере.

Из списка Available database выберите нужные базы данных и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available перенесите их в список выбранных баз - Selected databases, или перетащите из одного списка в другой с помощью мышки.

Register Host Wizard - Selecting databases

Если база данных была создана путем выполнения скрипта в редакторе SQL скриптов, то после создания появится диалоговое окно Register Database.

Необходимо переместить созданную базу данных из списка доступных баз - Available databases в список регистрируемых - Selected databases.

Register Database dialog

Важно: Это диалоговое окно появляется только в том случае, если установлен флажок CheckBox Register newly created databases на вкладке SQL Script в Environment Options.

В Lite версии нельзя зарегистрировать больше пяти баз.

Следующий шаг


Установка параметров регистрации

На этой вкладке задайте общие параметры базы данных.

Register Database wizard - Setting specific options - General

Из раскрывающегося списка Database name выберите нужную базу данных. Псевдоним, под которым база данных будет отображаться в проводнике, можно указать в поле Database alias.

Database

Client encoding - кодировка, которая будет использоваться SQL Manager for PostgreSQL для работы с данными.

Auth. method - выбор метода аутентификации при подключении к базе данных.

CheckBox Login prompt before connection

Если Вы не хотите хранить пароль, то устанавливайте этот флажок, и каждый раз при подключении SQL Manager будет предлагать ввести имя пользователя и пароль заново.

CheckBox Refresh objects on connection

Обновлять объекты при подключении к базе данных. Рекомендуется отключать эту функцию для баз данных, которые содержат большое количество пользовательских объектов, и для баз, соединение с которыми производится по slow lines.

CheckBox Ping server every N seconds

Опрашивать сервер через каждые N секунд. С помощью счетчика, задайте через сколько секунд следует опрашивать сервер.

CheckBox Show system objects

Отображать системные объекты.

CheckBox Autoconnect on startup

При запуске программы SQL Manager for PostgreSQL связь с этой базой данных будет устанавливаться автоматически.

SSL

Register Database wizard - Setting specific options - SSL

SSL mode

Выберите режим работы протокола SSL из списка: Disabled, Allow, Prefer, Require, Verify CA, Verify Full.

Root certificate

Укажите полный путь к корневому сертификату.

Client certificate

Укажите полный путь к клиентскому сертификату.

Client key

Укажите полный путь к файлу приватного ключа клиента.

Revocation list

Укажите файл со списком аннулированных сертификатов (Certificate Revocation List).

Logs

На данной вкладке задайте настройки файлов журналов. Также эти опции можно найти на вкладке Logs в Регистрационной информации баз данных.

Register Database wizard - Setting specific options - Logs

CheckBox Enable log of metadata changes

Если Вы хотите вести журнал изменений, происходивших с метаданными, то установите флажок Enable log of metadata changes, и укажите, в какой файл следует записывать изменения в поле Log file.

CheckBox Enable log of Query data queries

Если же Вы хотите вести статистику по исполнению SQL скриптов, то активируйте функцию Enable log of Query data queries.

В поле Log file укажите, в какой файл сохранять эту статистику.

CheckBox Is Unicode

Если этот флажок установлен, то журналы будут сохраняться в кодировке Unicode. Если не установлен, то будет использоваться кодировка ANSI.

Нажмите кнопку Finish для завершения выполнения операции.


Регистрационная информация баз данных

Если при создании и регистрировании базы данных Вы допустили ошибку, или указали неполную информацию, то Вы можете это исправить при помощи команды Database Registration Info.

Проводник баз данных позволяет редактировать регистрационную информацию баз данных в процессе работы.

Для этого используется пункт контекстного меню Database Registration Info (для подключенных баз данных).

Вкладки

Настройки подключения

Опции общего назначения

Настройки отображения

Используемые директории

Журналы регистрации

Настройка SSL подключения

Параметры SSH туннелирования

Параметры HTTP туннелирования

Параметры отображения данных

Параметры контроля внесения изменений

Поиск опций

С помощью кнопки Test Connect Вы можете проверить, возможно ли установить подключение к базе данных с заданными настройками.

Кнопка Copy Alias From позволяет скопировать все настройки из другой регистрации базы данных, которую можно выбрать из раскрывающегося списка, открывающегося по нажатию на кнопку btnMoreButtons.

Смотрите также:

Мастер создания баз данных

Мастер регистрации баз данных

Параметры базы данных

Администратор регистрации баз данных


Настройки подключения

На этой вкладке можно изменить настройки базы данных для подключения к серверу.

Database Registration Info - Editing connection properties

Host name

Из раскрывающегося списка выберите сервер (хост). В этот список попадают имена уже зарегистрированных серверов. Имя сервера или его IP адрес можно ввести вручную.

Port

Укажите порт для подключения.

User name

Укажите имя пользователя.

Password

Введите пароль для подключения к БД.

Database name

Выберите нужную базу данных.

Database alias

Укажите псевдоним, под которым база данных будет отображаться в проводнике.

Client encoding

Из списка выберите кодировку, которая будет использоваться SQL Manager for PostgreSQL для работы с данными.

Host alias

Укажите псевдоним для хоста, который будет отображаться в проводнике.

Auth. method

Выбор метода аутентификации при подключении к базе данных.


Опции общего назначения

На этой вкладке настраиваются общие опции.

Database Registration Info - Setting common database options

CheckBox Login prompt before connection

Если Вы не хотите хранить пароль, то устанавливайте этот флажок и каждый раз при подключении SQL Manager будет предлагать ввести имя пользователя и пароль заново.

CheckBox Show system objects

Отображать системные объекты.

CheckBox Autoconnect on startup

При запуске программы SQL Manager for PostgreSQL связь с этой базой данных будет устанавливаться автоматически.

CheckBox Refresh objects on connection

обновлять объекты при подключении к базе данных.

CheckBox Ping server every N seconds

Опрашивать сервер через каждые N секунд. С помощью счетчика, задайте через сколько секунд следует опрашивать сервер.

Из списка SSL mode - выберите каким образом будет использоваться шифрованный канал для обмена данными:

Disabled - запрещен

Allow - разрешен

Prefer - предпочтителен

Require - требуется использовать шифрованный канал


Параметры сессии

На этой вкладке Вы можете задать необходимые параметры конфигурации сервера PostgreSQL, которые будут инициализированы при подключении к базе данных.

Database Registration Info - Session Settings

Для параметров указаны следующие характеристики:

  • Parameter Name - имя параметра,
  • Parameter Value - значение параметра.

Для работы с параметрами предназначается контекстное меню, которое открывается при нажатии правой кнопкой мыши на рабочей области.

С помощью контекстного меню Вы можете:

  • Add Parameter - добавить параметр,
  • Edit Parameter - редактировать параметр,
  • Delete Parameter - удалить параметр,
  • Export Data - экспортировать значения параметров в файл с помощью Мастер экспорта данных.

При добавлении/редактировании параметров появляется диалог Add/Edit Parameter.

Database Registration Info - Session Settings - Add parameter

Из раскрывающегося списка Parameter name выберите один из параметров.

В поле Value задайте значение параметра. В разделе Parameter Info отображается информация о выбранном параметре.

В поле Description можно отредактировать описание параметра, если требуется.

Чтобы получить подробную информацию о параметрах сервера, обратитесь к документации PostgreSQL.


Настройки отображения

Настройки отображения объектов базы данных.

CheckBox Use custom color for DB editors

Включите опцию и выберите цвет шрифта, которым будут отображаться вкладки объектов и редакторов выбранной БД.

Database Registration Info - Setting display options

Если установить флажок, то объекты выбранного типа будут отображаться в проводнике баз данных.

По умолчанию, отображаются все объекты.

CheckBox Tables - таблицы

CheckBox Views - представления

CheckBox Functions - функции

CheckBox Domains - домены

CheckBox Rules - правила

CheckBox Triggers - триггеры

CheckBox Indices - индексы

CheckBox Sequences - последовательности

CheckBox Composite Types - составные типы данных

CheckBox Enum Types - перечислимые типы

CheckBox Range Types - диапазонные типы

CheckBox Base Types - базовые типы данных

CheckBox Aggregates - агрегатные функции

CheckBox Operators - операторы

CheckBox Tablespaces - табличные пространства

CheckBox Languages - языки описания процедур

CheckBox Reports - отчеты

CheckBox Favorite queries - избранные запросы

CheckBox Local Scripts - локальные скрипты

CheckBox Shared Scripts - общие скрипты

CheckBox Favorite objects - избранные объекты

С помощью контекстного меню формы, открывающегося при нажатии на форме правой кнопкой мыши, Вы можете:

Select All - установить все флажки.

Deselect All - убрать все флажки.

Смотрите также:

Управление объектами базы данных

Проводник баз данных


Используемые директории

На этой вкладке указываются директории для хранения внешних данных.

Database Registration Info - Setting default directories

Default directory for Extract Metadata в эту папку, по умолчанию, будут сохраняться выгруженные с помощью Extract Database Wizard файлы.

Default directory for Export Data - папка, в которую будет производить экспорт данных с помощью Export Data Wizard

Default directory for Import Data - из этой директории будет импортировать данные с помощью Import Data Wizard

Default directory for HTML Report - директория, которая будет подставляться в Data Export (Import\HTML Report) Wizard по умолчанию.

Default directory for Reports в эту папку сохраняются файлы отчетов, созданные пользователем. При условии, что при создании отчета пользователь указывает в мастере создания отчетов (Create Report Wizard), что этот отчет необходимо сохранить в файл базы данных. По умолчанию SQL Manager for PostgreSQL автоматически создает эту папку в "Мои документы" текущей учетной записи Windows, при первом сохранении отчета.

Default directory for Local Scripts - в эту папку, по умолчанию, будут сохраняться локальные скрипты.


Журналы регистрации

На этой вкладке задайте параметры журналов регистрации.

Database Registration Info - Setting log options

CheckBox Enable log of metadata changes

Если Вы хотите вести журнал изменений, происходивших с метаданными, то установите флажок Enable log of metadata changes, и укажите, в какой файл следует записывать изменения в поле Metadata log file.

CheckBox Enable log of Query data queries

Если же Вы хотите вести статистику по исполнению SQL скриптов, то активируйте функцию Enable log of Query data queries.

В поле Query data log file укажите, в какой файл сохранять эту статистику. О каждом выполненном запросе в этот файл попадает следующая информация:

  • дата и время выполнения запроса;
  • текст запроса;
  • результат или ошибки (если таковые возникли при выполнении).

CheckBox In Unicode

Установите этот флажок, если хотите сохранять журналы в кодировке Unicode. Если флажок не установлен, то будет использоваться ANSI.


Настройка SSL

На данной вкладке вы можете задать параметры SSL для безопасного подключения к базе данных.

SSL mode

Выберите режим работы протокола SSL из списка: Disabled, Allow, Prefer, Require, Verify CA, Verify Full.

Database Registration Info - SSL

Root certificate

Укажите полный путь к корневому сертификату.

Client certificate

Укажите полный путь к клиентскому сертификату.

Client key

Укажите полный путь к файлу приватного ключа клиента.

Revocation list

Укажите файл со списком аннулированных сертификатов (Certificate Revocation List).


Параметры SSH туннелирования

На этой вкладке задайте параметры SSH туннелирования.

Важно: Невозможно одновременно использовать SSH и HTTP туннелирование. Если Вы выберете SSH, то HTTP туннелирование будет отключено.

Database Registration Info - Setting SSH tunnel options

CheckBox Connecting through the security Shell (SSH) tunnel

Если установлен флажок Connecting through the security Shell (SSH) tunnel, то соединение с сервером будет осуществляться через шифрованный канал.

SSH host name - имя сервера SSH. В случае задания параметров SSH, имя или ip адрес на предыдущем шаге должно указываться относительно машины, на которой установлен SSH сервер. Использование localhost подразумевает что SSH сервер и PostgreSQL сервер запущены на одной машине. Имя SSH сервера задается относительно клиентской машины, на которой запущен SQL Manager for PostgreSQL.

SSH port - порт.

SSH user name - имя пользователя.

SSH password - пароль.

В случае использования SSH туннелирования имя хоста PostgreSQL должно быть задано относительно сервера SSH. Например, если PostgreSQL и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.

CheckBox Use Private Key for authentication

Если установлен флажок Use Private Key for authentication, то в поле SSH key file можно указать ключевой файл для аутентификации.

Смотрите также:

Настройка SSH туннелирования


Параметры HTTP туннелирования

На этой вкладке задайте параметры HTTP туннелирования.

Важно: Невозможно одновременно использовать SSH и HTTP туннелирование. Если Вы выберите HTTP, то SSH туннелирование будет отключено.

Database Registration Info - Setting HTTP tunnel options

CheckBox Connecting through the HTTP tunnel

Если установлен флажок Connecting through the HTTP tunnel, то соединение с сервером будет осуществляться через промежуточный HTTP сервер.

Для того, чтобы можно было установить такое соединение, на HTTP сервер должен быть загружен скрипт EMSProxy.php, который входит в дистрибутив программы.

Адрес сервера задайте в поле URL.

Смотрите также:

Настройка HTTP туннелирования


Задание параметров

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Параметры отображения данных

Параметры отображения данных просмотрщика данных задайте на вкладке Data options.

Эти параметры Вы можете задать на вкладке Data options инструмента Environment Options.

Database Registration Info - Setting data options

RadioButton Select all records from a table - загрузить все записи в инструмент просмотра. В этом случае в таблицу загружаются все данные из возвращаемого сервером набора данных.

RadioButton Select only N rows - загрузить только указанное число записей в таблицу из возвращаемого сервером набора данных.

В разделе Advanced - задайте расширенные свойства таблицы.

CheckBox Use transactions in Data tab of object editors, Query data and Design Query - использовать транзакции на вкладке данных редактора объектов, в этом случае при открытии SQL Manager будет запущена транзакция, которую можно зафиксировать или откатить вручную, либо автоматически при закрытии SQL Manager.

Если этот флажок установлен, то транзакция активна до тех пор, пока не закрыта вкладка Data или пока не нажата кнопка Commit. Все редактируемые записи заблокированы до фиксации транзакции. Если флажок не установлен, то транзакция автоматически фиксируется (autocommit) при сохранении каждой записи, которая блокируется только на короткий период времени.

CheckBox Asynchronous query execution - асинхронное выполнение запроса. Запрос будет выполнен в отдельном потоке, все элементы управления останутся активными при выполнении и его можно прервать.

CheckBox Use separate connection for each data view within a database - использовать общее подключение для каждого просмотра данных внутри базы данных. Если флажок не установлен, то при открытии просмотрщика данных создастся новое подключение к БД. Не рекомендуется использовать, если установлено ограничение на число подключений к серверу. Эта опция зависит от опции Asynchronous query execution.

CheckBox OID columns as BLOB - данные типа OID представлены в виде BLOB с возможностью изменения в редакторе BLOB.

Default Grid Mode

RadioButton Load all rows - загрузить все записи в инструмент просмотра. В этом случае в таблицу загружаются все данные из возвращаемого сервером набора данных.

RadioButton Load visible rows - загрузить видимые записи. в таблицу из возвращаемого сервером набора данных загружается только строго определенное количество записей.

Смотрите также:

Просмотрщик данных


Управление изменениями

На вкладке Change Management задаются настройки, необходимые для работы с системами контроля внесения изменений. См. также Управление изменениями.

Система управления изменениями (Система контроля версий) позволяет организовать совместную работу группы людей (часто — программистов) над одним проектом.

Эта система может быть полезна для одиночных разработчиков, в базах которых сложная бизнес-логика (в процедурах, триггерах и т.п.), и им нужен контроль изменений этих объектов, подобный тому, который используется при разработке программ.

В системе контроля версий хранится служебная информация о самой базе, добавленной в систему, о базах, привязанных к конкретной ветке и т.п. Если резервная копия создается на клиентском компьютере, резервная копия для метки хранится в системе контроля версий, если же резервная копия создается на сервере – в системе контроля версий хранится только информация о том, где расположена эта копия на сервере.

Для разработчиков баз данных:

  • Систематизация процесса выпуска новых версий базы данных.
  • Хранение версий базы данных.
  • Учет изменений.
  • Получение (хранение, тестирование) скриптов переходов от версии к версии и т.п.
  • Возможность откатить БД к заданному состоянию (версии)
  • Контроль изменений

Для администраторов БД:

  • Контроль изменений

CheckBox Enabled

Чтобы включить возможность задавать настройки системы управления изменениями для базы данных необходимо установить флажок Enabled.

Важно: iconDatabase with Change Management База данных, подключенная к системе контроля версий, в проводнике баз данных отображается с другой иконкой.

При нажатии на кнопку Repository Management Wizard открывается Мастер управления репозиторием.

Database Registration Info - Change Management

Source provider

Из этого раскрывающегося списка выберите систему управления версиями.

В настоящее время поддерживаются следующие системы:

  • CVS (вер. 1.9 и выше)
  • Subversion (вер. 1.5 и выше)
  • Microsoft Visual SourceSafe (вер. 8.0)
  • Team Foundation Server (2005, 2008, 2010)

Для каждой системы контроля версий необходимо установить программу-клиент.

Важно: Для работы с Team Foundation Server 2005/2008 должен быть установлен .NET Framework.

При необходимости укажите имя пользователя и пароль в поле User Name и Password соответственно. Эти имя и пароль нужны для идентификации пользователя в одной из систем контроля версий.

При нажатии на кнопку Properties открывается окно Provider Settings, в котором можно задать настройки подключения к репозиторию выбранной системы управления версиями:

CVS

SVN

VSS

TFS

Version control project

В этом поле укажите расположение проекта системы контроля версий. Формат задания пути на сервере зависит от используемой системы контроля версий и принятых в ней соглашений.

Working folder

В этом поле укажите директорию локального репозитория.

Branch name

Информационное поле, в котором отображается имя сопоставленной базе данных ветви. Ветвь, содержащая информацию, о текущей базе данных выбирается автоматически. Если же в системе контроля версий нет ветви, содержащей информацию о текущей базе данных, то при нажатии ОК, выводится диалоговое окно, в котором можно выбрать ветвь.

Из раскрывающегося списка, находящегося рядом с кнопкой Copy From, можно выбрать базу данных из тех, которые уже подключены к системе контроля версий.

Смотрите также:

Включить управление изменениями

Создание ветви/метки/тега

Извлечение данных из репозитория

Получение скрипта изменений

Релиз новой версии базы данных

История изменений


Мастер управления репозиторием

С помощью этого мастера можно задать или создать репозиторий в выбранной системе контроля версий для конкретной базы данных.

Repository management wizard - Selecting operation

Мастер состоит из следующих шагов:

Выбор операции

Выбор провайдера

Задание настроек провайдера

CVS

SVN/VSS

TFS

Задание настроек репозитория

Создание метки

Выполнение операции


Выбор операции

На этом шаге нужно выбрать одно из действий которое должно быть произведено с репозиторием.

Repository management wizard - Selecting operation

RadioButton Create new repository - создать новый репозиторий. Если для текущей базы данных репозиторий еще не создавался, то его необходимо создать.

RadioButton Checkout an existing one - извлечение из созданного для БД репозитория и создание локальной копии.

Следующий шаг


Выбор провайдера

На этом шаге необходимо выбрать одну из систем контроля версий.

RadioButton Concurrent Version System

RadioButton Subversion

RadioButton Visual SourceSafe

RadioButton Team Foundation System

Repository management wizard - Selecting provider

Следующий шаг


Задание настроек провайдера

На этом шаге необходимо задать параметры подключения к системе контроля версий, выбранной на предыдущем шаге.

Для каждой системы контроля версий необходимо задать собственные настройки:

CVS

SVN/VSS

TFS


CVS

На этом шаге необходимо задать параметры подключения к системе контроля версий, выбранной на предыдущем шаге.

Repository management wizard - Configuring provider settings - CSV

Имя и пароль для доступа к репозиторию укажите в полях Username и Password соответственно.

CVS executable

В этом поле задайте расположение файла "cvs.exe". Путь можно указать вручную, или выбрать в стандартном диалоговом окне, открывающемся при нажатии на кнопку ExplorerButton.

CVSROOT

В этом разделе задайте корневую директорию хранилища CVS.

RadioButton Use environment variable - использовать значение из переменной окружения (рекомендуется).

RadioButton Use custom value - задать произвольное значение корневой директории CVS.

Для проверки настроек используется кнопка Test.

Следующий шаг


SVN/VSS

На этом шаге необходимо задать параметры подключения к системе контроля версий, выбранной на предыдущем шаге.

Repository management wizard - Configuring provider settings - VSS

Имя и пароль для доступа к репозиторию укажите в полях Username и Password соответственно.

Путь к файлу конфигурации базы данных SourceSafe укажите в поле SourceSafe database file для VSS / Subversion client libraries path - путь до клиентских библиотек для SVN. Путь можно указать вручную, или выбрать в стандартном диалоговом окне, открывающемся при нажатии на кнопку ExplorerButton.

Для проверки настроек используется кнопка Test.

Следующий шаг


TFS

На этом шаге необходимо задать параметры подключения к системе контроля версий, выбранной на предыдущем шаге.

Repository management wizard - Configuring provider settings - TFS

Имя и пароль для доступа к репозиторию укажите в полях Username и Password соответственно.

Server - HTTP-путь к TFS-серверу с заданием порта подключения, например 'http://server:8080' или 'http://localhost:8080'

Workspace - Имя рабочего пространства на TFS-сервере

Для проверки настроек используются кнопки Test Client и Test Connection.

Test Client - проверяет наличие и работоспособность TFS-клиента.

Test Connection - проверяет возможность установления подключения с заданными параметрами.

Следующий шаг


Задание настроек репозитория

На этом шаге задаются настройки расположения репозитория.

Repository management wizard - Specify repository settings

Server path - путь к репозиторию на сервере, включая имя самого репозитория. Формат задания зависит от используемой системы контроля изменений и принятых для нее соглашений. В этом поле имя репозитория указывается только при извлечении информации из хранилища и создании локальной копии (операции check_out).

Local path - путь к локальному репозиторию, без указания директории самого репозитория. Директория с именем репозитория по заданному пути не должна существовать или должна быть пустой.

Repository name - имя создаваемого репозитория. При создании репозитория это поле доступно для редактирования.

Следующий шаг


Создание метки

Этот шаг доступен только если создается новый репозиторий. Use this step to define database label options.

Repository management wizard - Defining label options

В разделе Backup storage location задайте параметры сохранения резервной копии базы данных.

RadioButton Version Control Repository - резервная копия будет сохранена в репозитории системы управления изменениями.

RadioButton Separately - резервная копия будет сохранена в отдельную директорию, заданную в поле ниже.

Для создаваемой метки можно задать дополнительный параметр.

CheckBox Backup metadata only - если установлен этот флажок, то резервная копия будет создана только для метаданных базы.

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Finish, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Repository management wizard - Performing operation

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


CVS

CVS executable

В этом поле задайте расположение файла "cvs.exe". Путь можно указать вручную, или выбрать в стандартном диалоговом окне, открывающемся при нажатии на кнопку ExplorerButton.

Provider settings - CVS

CVSROOT

В этом разделе задайте корневую директорию CVS.

RadioButton Use environment variable - использовать значение из переменной окружения (рекомендуется).

RadioButton Use custom value - задать произвольное значение корневой директории CVS.

Для проверки настроек используется кнопка Test.


SVN

Путь к файлу конфигурации базы данных укажите в поле Subversion client libraries path. Путь можно указать вручную, или выбрать в стандартном диалоговом окне, открывающемся при нажатии на кнопку ExplorerButton.

Обратите внимание, что SQL Manager for PostgreSQL поддерживает только 32-разрядные клиенты SVN.

Provider settings - Subversion

Для проверки настроек используется кнопка Test.


VSS

Путь к файлу конфигурации базы данных SourceSafe укажите в поле SourceSafe database file. Путь можно указать вручную, или выбрать в стандартном диалоговом окне, открывающемся при нажатии на кнопку ExplorerButton.

Provider settings - SourceSafe

Для проверки настроек используется кнопка Test.


TFS

Server - HTTP-путь к TFS-серверу с заданием порта подключения, например 'http://server:8080' или 'http://localhost:8080'

Workspace - Имя рабочего пространства на TFS-сервере

Provider settings - Team Foundation Server

Для проверки настроек используются кнопки Test Client и Test Connection.

Test Client - проверяет наличие и работоспособность TFS-клиента.

Test Connection - проверяет возможность установления подключения с заданными параметрами.


Ветви репозитория

Использование функционала управления изменениями в SQL Manager предусматривает, что базе данных строго ставится в соответствие ветвь репозитория системы контроля версий. Таким образом, создание ветви в репозитории средствами SQL Manager сопровождается созданием копии базы данных.

При создании нового репозитория для базы данных, имя этой базы сохраняется в головной ветви репозитория (Trunk). При последующем использовании существующего репозитория рабочая ветвь определяется автоматически по имени базы данных. Если же информация об имени текущей базы данных не найдена ни в одной из ветвей заданного репозитория, то при первом подключении к базе данных будет выведено информационное сообщение о задании соответствия вручную

Database Registration Info - Change Management - Question

После нажатия Yes будет выведено диалоговое окно выбора ветви.

Database Registration Info - Change Management - Select_branch

При выборе ветви необходимо подтвердить это в появившемся окне.

Имя базы данных заменятся в выбранной ветви на имя текущей базы данных.

Database Registration Info - Change Management - Replace database of the branch


Свойства базы данных

Используйте этот инструмент для просмотра и редактирования информации об активной базе данных и её объектах. Чтобы открыть окно свойств базы данных выберите в контекстном меню базы данных пункт Database Properties или нажмите кнопку Object properties на панели инструментов проводника баз данных.

Основные свойства

Описание

Права

Поиск опций

Смотрите также:

Мастер создания баз данных

Мастер регистрации баз данных

Регистрационная информация баз данных

Администратор регистрации баз данных


Основные свойства

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Общие параметры

На этой вкладке отображается следующая информация по базе данных:

Database Properties - General

Database name - в этом поле указано имя базы данных.

Database owner (для версий сервера 7.3 и выше) - в этом поле нужно указать пользователя, который обладает правами владельца базы данных.

OID - количество идентификаторов объектов (недоступно для редактирования).

Encoding - из этого раскрывающегося списка выберите кодировку, которая будет использоваться в базе данных (недоступно для редактирования).

Default Tablespace (для версий сервера 8.0 и выше) - из этого списка выберите табличное пространство, используемое по умолчанию (недоступно для редактирования).

Database size (MB) - размер файлов базы данных (недоступно для редактирования).

Connection Limit (для версий сервера 8.1 и выше) - в этом поле задайте максимальное число одновременных подключений к базе данных. (-1 - неограниченное число подключений).


Описание

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Количество объектов

На этой вкладке Вы можете задать текстовое описание выбранной базы данных.

Database Properties - Description


Права

На этой вкладке Вы можете задать некоторые права на использование выбранной базы данных.

Вкладка доступна для версий сервера 8.1 и выше.

Database Properties - Permissions

В главном окне расположена таблица, в которой строки - это группы и пользователи базы данных, а столбцы - действия, выполняемые над объектами.

OWN (OWNER)

Позволяет устанавливать нового владельца базы данных (чтобы изменять владельцев, Вы должны обладать соответствующими правами.)

CONN (CONNECT)

Позволить пользователю подключаться к текущей базе данных. (Этот столбец доступен, только если Вы работаете с сервером версии 8.2 или выше.)

CRT (CREATE)

Разрешить создание новых схем в базе данных.

TMP (TEMPORARY)

Позволить создание временных таблиц.

Права на выполнение того или иного действия можно менять тремя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку.
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Revoke).
  • с помощью одинарного нажатия на активную (выделенную ячейку). При этом появляется раскрывающийся список, из которого можно выбрать один из типов прав.

Grant - Предоставить права на выполнение данного действия ,

Revoke - Аннулировать права,

Grant with GRANT OPTION - Предоставить с правами 'GRANT' .

Контекстное меню

Контекстное меню открывается при нажатии на ячейку области таблицы и позволяет присваивать права на объект.

Grant - предоставить права

Grant with GRANT OPTION - предоставить с правами 'GRANT'

Revoke - запретить

Grant All - предоставить права на все действия для выделенного объекта

Grant with GRANT OPTION All - предоставить с правами 'GRANT' на все действия для выделенного объекта

Revoke All - запретить все действия для выделенного объекта

Grant on All - предоставить права на это действие для всех объектов

Grant with GRANT OPTION on All - предоставить с правами 'GRANT' на это действие для всех объектов

Revoke on All - запретить это действие для всех объектов


Администратор регистрации баз данных

Позволяет быстро зарегистрировать новые базы данных и удалить регистрации несуществующих.

Чтобы открыть Администратор регистрации баз данных, выберите в контекстном меню базы данных пункт Database Registration Manager.

Database Registration Info - Database Registration Manager

В списке отображаются все базы данных, находящиеся на выбранном сервере. Сервер можно выбрать из раскрывающегося списка Host на панели инструментов.

Необходимо отметить флажками базы данных, которые нужно зарегистрировать.

Они будут зарегистрированы автоматически при нажатии iconCommit Apply changes на одной из панелей инструментов.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Регистрационная информация баз данных


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Database Registration Manager - Using Navigation bar

Host

iconHost Выбрать сервер

General

iconRefresh Refresh - обновить список баз данных

iconCommit Apply changes - применить изменения

Check new DB - выбрать базу данных, существующую на сервере, но не зарегистрированную в программе

Uncheck deleted DB - удалить регистрацию удаленной с сервера базы данных

Legend

iconDB Exist on host - база данных существующая на сервере

Removed from Host - база данных, удаленная с сервера

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Управление объектами базы данных

SQL Manager for PostgreSQL предоставляет пользователю набор всех необходимых инструментов для работы с объектами базы данных.

Важно: Чтобы начать работать с объектами, необходимо подключиться к базе данных. Созданный объект автоматически открывается в соответствующем редакторе.

Создание нового объекта

Для создания любого объекта используйте:

  • пункт Database | New Object главного меню программы,
  • или контекстное меню объекта базы данных <Тип объекта> | пункт New <Тип объекта>. Этот пункт присутствует и в контекстном меню группы объектов и в контекстном меню объекта. Например: в контекстном меню группы объектов Tables выберите пункт New Table.
  • сочетание клавиш <Ctrl + N>.

Копирование объекта

Для копирования объектов существует специальный мастер, потому что объект можно копировать в другую базу данных, а так же с данными или без них.

Для копирования объекта необходимо выбрать пункт Duplicate<тип объекта><имя объекта> в контекстном меню объекта. Если Вы копируете объект таким образом, то Мастер копирования объектов открывается сразу на третьем шаге, так как на первых двух шагах выбирается база данных и объект, а в данном случае это не нужно.

Редактирование объекта

Для открытия объекта базы данных в соответствующем редакторе достаточно двойного щелчка мыши по нему в проводнике баз данных. Или выбора пункт Edit<тип объекта><имя объекта> в контекстном меню объекта. Ещё можно использовать сочетание клавиш <Ctrl + О>.

Переименование объекта

Если хотите сменить имя объекта, то Вам нужно:

  • выбрать пункт контекстного меню объекта Rename<тип объекта><имя объекта>,
  • или использовать сочетание клавиш <Ctrl + R>.

Важно: невозможно переименовать следующие объекты: схемы, домены, правила, базовые типы данных, составные типы данных, перечислимые типы, операторы, табличные пространства.

Удаление объекта

Чтобы удалить объект необходимо для выбранного объекта выбрать пункт контекстного меню объекта Drop<тип объекта><имя объекта> или использовать сочетание клавиш <Shift + Del>.

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Новый объект

С помощью этого инструмента Вы можете выбрать тип создаваемого объекта и запустить соответствующий инструмент для создания объекта.

Database Objects management - Create New Object

Для создания нового объекта выберите Database | New Object... в главном меню программы.

В появившемся окне выберите базу данных, в которой будет создан объект, из раскрывающегося списка Database (в списке отображаются только подключенные базы данных), и тип создаваемого объекта из списка Select the type of object to create.

Выбрав тип объекта, щелкните на нем два раза мышкой или нажмите кнопку OK. После этого открывается редактор для выбранного типа объекта.

Смотрите также:

Основные операции над объектами

Мастер копирования объекта

Схемы

Объекты схем

Прочие объекты


Мастер копирования объекта

Для копирования объекта надо выбрать пункт Duplicate<тип объекта><имя объекта> в контекстном меню объекта или Database | Duplicate Object... в главном меню программы.

Одним из этих действий Вы запускаете Мастер копирования объектов.

Этот мастер используется для создания нового объекта базы данных с такими же свойствами, как у копируемого объекта.

Необходимо помнить, что объекты копируются вместе с подобъектами. Например, если Вы копируете таблицу, то вместе с ней скопируются все её столбцы, внешние ключи, индексы, триггеры и т.д.

Мастер состоит из следующих шагов:

Выбор исходной базы данных

Выбор объекта

Выбор базы данных

Изменение описания

Смотрите также:

Основные операции над объектами

Новый объект

Схемы

Объекты схем

Прочие объекты


Выбор исходной базы данных

Из раскрывающегося списка Source database выберите базу данных, в которой содержится исходный объект.

Duplicate Object Wizard - Selecting the source database

Следующий шаг


Выбор объекта

Выберите объект, который хотите скопировать

Из раскрывающегося списка Object выберите тип объекта, из списка объектов, расположенного ниже, выберите объект.

Duplicate Object Wizard - Selecting object to duplicate

Следующий шаг


Выбор базы данных

На этом шаге необходимо выбрать базу данных, в которую Вы хотите поместить новый объект и задать имя этого объекта.

Duplicate Object Wizard - Selecting destination database

Из раскрывающегося списка Target database выбираете базу данных

Из раскрывающегося списка New object namespace можно выбрать пространство имен для создаваемого объекта.

В поле New object name указываете имя создаваемого объекта.

Table options

Задайте параметры копирования таблиц.

CheckBox Copy data

Если флажок Copy data установлен, то в новый объект будут скопированы все данные, содержащиеся в копируемом.

Если не установлен, то будет скопирована только структура таблицы.

Следующий шаг


Изменение описания

Измените, если нужно, скрипт создания нового объекта в окне New object definition.

Duplicate Object Wizard - Modifying the new object's definition

CheckBox Close the wizard after duplicating

Закрыть мастер после завершения операции

CheckBox Open object when finished

Открыть объект после копирования.

Для создания объекта нажмите Run.


Схемы

Схема является коллекцией объектов базы данных, принадлежащих одному пользователю и образующих одно пространство имен.

База данных содержит одну или более именованных схем, которые содержат объекты базы данных. То же самое имя объекта может без какого-либо конфликта использоваться в других схемах. В отличие от баз данных, схемы жестко не разделяются: пользователь может получить доступ к объектам в любой схеме в пределах базы данных, к которой он подключу, если у него есть соответствующие привилегии.

Схемы являются аналогами каталогов в операционной системе, за исключением того, что схемы не могут быть вложенными.

В редакторе Вы можете создавать и редактировать схемы.

В этом редакторе Вы можете изменять свойства схемы.

Открыть схему в редакторе можно:

  • двойным щелчком мыши по нужной схеме в окне проводника баз данных,
  • выбрав пункт Edit Schema <имя объекта> в контекстном меню схемы.

Вкладки редактора:

Редактирование свойств схемы

Просмотр зависимостей объекта

Редактирование описания схемы

Просмотр DDL

Назначение прав

Смотрите также:

Основные операции над объектами

Новый объект

Мастер копирования объекта

Объекты схем

Прочие объекты


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Навигационная панель

Schema Editor - Using Navigation bar

Object

iconDB выбрать базу данных,

выбрать схему для редактирования,

General

iconCompile Compile - компилировать объект при создании или редактировании,

iconRefresh Refresh - обновить содержимое активной вкладки,

iconPrint Print - печатать метаданные объекта,

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна.

Description (для вкладки Description)

iconSaveToFile Save Description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование описания схемы

Основные параметры схемы располагаются на вкладке Schema

Schema Editor - Editing schema definition

Name

Укажите название схемы.

Owner

Выберите имя владельца этого объекта из раскрывающегося списка. Подробнее смотрите в User Editor.


Объекты схем

Схема - это совокупность объектов базы данных. Схема принадлежит пользователю базы данных. Каждому пользователю может принадлежать единственная схема.

Объекты схемы

Таблицы

Представления

Функции

Домены

Правила

Триггеры

Последовательности

Базовые типы данных

Составные типы данных

Перечислимые типы

Диапазонные типы

Агрегатные функции

Операторы

Сортировки

Статистики

Все объекты отображаются в проводнике баз данных.

Смотрите также:

Основные операции над объектами

Новый объект

Мастер копирования объекта

Схемы

Прочие объекты


Таблицы

Таблицы являются объектами, которые содержат все данные в реляционных базах данных. Таблица - это коллекция столбцов. В таблицах данные организованы в виде строк и столбцов, аналогичном электронной таблице. Каждая строка представляет уникальную запись, а каждый столбец представляет поле записи. Например, таблица, содержащая данные о сотрудниках компании, может иметь строку для каждого сотрудника и столбцы, представляющие сведения о сотрудниках (например, его идентификационный номер, имя, адрес, должность и номер домашнего телефона). Имена таблиц и столбцов должны соответствовать правилам для идентификаторов; они должны быть уникальными в пределах таблицы, другими словами, можно использовать одинаковые имена столбцов в разных таблицах одной базы данных.

Таблицы имеют следующие основные составляющие:

  • Столбцы

Каждый столбец представляет какой-либо атрибут объекта, моделируемого таблицей, к примеру, таблица сведений о деталях содержит столбцы для их идентификатора, цвета и веса.

  • Строки

Каждая строка представляет отдельное вхождение объекта, моделируемого таблицей. Например, в таблице сведений о деталях обязательно имеется одна строка для каждой детали, продаваемой компанией.

Создание таблицы

Для создания таблицы используйте:

  • пункт Database | New Object главного меню программы в окне выбора типа объекта надо выбрать таблицу,
  • контекстное меню объекта базы данных Tables,
  • пункт Create | Table панели инструментов проводника баз данных,
  • сочетание клавиш <Ctrl + N>.

Переименование таблицы

Если хотите сменить имя таблицы то Вам нужно:

  • выбрать пункт контекстного меню таблицы Rename Table<имя объекта>,
  • или использовать сочетание клавиш <Ctrl + R>.

Редактирование таблицы

Чтобы открыть таблицу в редакторе таблиц достаточно двойного щелчка мыши на таблице в проводнике баз данных. Также можно это сделать, выбрав пункт контекстного меню таблицы Edit Table <имя объекта>.

Удаление таблицы

Для того чтобы удалить таблицу, необходимо для нужной таблицы выбрать пункт контекстного меню Drop Table<имя объекта> или использовать сочетание клавиш <Ctrl + Del>

Копирование таблицы

Для копирования объектов существует специальный мастер, потому что объект можно копировать в другую базу данных, а так же с данными или без них.

Для копирования таблицы необходимо выбрать пункт Duplicate Table<имя объекта> в контекстном меню таблицы. Если Вы копируете таблицу таким образом, то Мастер копирования объектов открывается сразу на третьем шаге, так как на первых двух шагах выбирается база данных и объект, а в данном случае это не нужно.


Новая таблица

Инструмент New Table позволяет Вам создавать новую таблицу, задавать для неё столбцы и редактировать её описание.

Это окно открывается автоматически при создании таблицы.

Панели инструментов

Свойства таблицы

Задание столбцов таблицы

Смотрите также:

Редактор таблиц

Свойства таблицы

Редактор столбцов


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

New table - Using Navigation bar

Object

iconDB выбрать базу данных, в которой надо создавать таблицу

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

При переходе на другие вкладки появляются панели, со специальными функциями для каждой вкладки.

Columns (для вкладки Columns)

Add column - добавить столбец

Edit column - редактировать столбец

Drop column - удалить столбец

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Свойства таблицы

На вкладке Table задаются основные свойства создаваемой таблицы:

Table name - из раскрывающегося списка выберите название схемы, а в столбец укажите имя таблицы.

Table type

RadioButton Ordinary table

Выберите эту опцию, чтобы создать обычную таблицу PostgreSQL.

RadioButton Foreign table

Выберите эту опцию, чтобы создать внешнюю таблицу. Такие таблицы позволяют использовать данные, хранящиеся вне базы, как нативные данные PostgreSQL.

Из выпадающего списка выберите внешний сервер для внешней таблицы.

Если у выбранного внешнего сервера обработчиком внешних данных служит 'postgres_fdw', то будет доступна кнопка Select Table.

RadioButton Temporary table

Выберите эту опцию, чтобы создать временную таблицу. Временная таблица будет автоматически удалена при завершении подключения. Имя таблицы сохраняется только в рамках одного подключения.

В разделе Behavior on end of transaction выберите тип поведения временной таблицы после завершения транзакции:

RadioButton Preserve rows - хранить строки,

RadioButton Delete rows - удалить строки,

RadioButton Drop table - удалить таблицу.

New table - Setting table properties

Table owner - в этом поле нужно указать пользователя, который обладает правами владельца таблицы.

Tablespace (для версий сервера 8.0 и выше) - из этого списка выберите табличное пространство - физический файл в котором хранится таблица.

CheckBox Если установлен флажок With OIDs - то для новой таблицы будут созданы идентификаторы.

CheckBox Unlogged Для сервера версии 9.1 и выше. Если таблица создается как незарегистрированная, то данные, хранящиеся в ней, не заносятся в журнал транзакций.

Note: Такие таблицы автоматически очищаются в случае неполадок.

CheckBox Установите флажок Temporary, если хотите создать временную таблицу.

В разделе Temporary tables behavior on end of transaction выберите тип поведения временной таблицы после завершения транзакции:

RadioButton Preserve rows - хранить строки,

RadioButton Delete rows - удалить строки,

RadioButton Drop table - удалить таблицу.

Fillfactor

В этом разделе можно указать коэффициент заполнения таблиц. При малых значениях FILLFACTOR, при выполнении оператора INSERT страница таблицы заполняется только на указанный процент. Оставшееся свободное место резервируется для обновления строк на странице. Для таблицы, элементы которых никогда не обновляются, допустимым является значение 100. Для часто обновляемых таблиц более приемлемым является меньшее значение.

CheckBox Use default fillfactor - использовать значение параметра Fillfactor = 100 (complete packing), используемое по умолчанию.

В поле Fillfactor можно указать значение коэффициента заполнения отличное от значения по умолчанию. Значение может быть от 10 до 100.

Partition

Выберите столбец в поле Partition by, чтобы использовать его в качестве ключа раздела.

Если вы создаёте секцию секционированной таблицы, укажите в поле For values диапазон значений, которые будут в ней содержаться.

Для новой таблицы можно указать ту таблицу, от которой она будет унаследована в разделе Inherits From.

Из списка Available Tables выберите нужную таблицу и перетащите её, или с помощью кнопок переместите в список Selected Tables.


Задание столбцов

Вкладка Columns предназначена для задания столбцов создаваемой таблицы.

New table - Specifying fields

Primary Key - является ли оно ключевым.

Column Name - имя столбца.

Data Type - тип данных.

Not Null - допускается нулевое значение или нет.

Unique - должно ли значение в этом столбце быть уникальным или допускаются повторения.

Comment - комментарий.

Двойной щелчок откроет выбранный столбец в соответствующем редакторе - Column Editor.


Опции внешней таблицы

На вкладке Foreign Table Options задайте опции для создаваемой внешней таблицы или ее столбцов.

Table Editor - Foreign table options

Чтобы добавить или удалить опцию, используйте пункты контекстного меню New Option и Delete Option(s) соответственно.

Допустимые имена опций и значения зависят от обработчика внешних данных.


Редактор таблиц

Редактор таблиц - основной инструмент SQL Manager for PostgreSQL для работы с таблицами баз данных. Он позволяет выполнять все операции с таблицей, а также с ее подобъектами.

Чтобы открыть таблицу в редакторе таблиц достаточно двойного щелчка мыши на таблице в проводнике баз данных.

Инструменты редактора таблиц

Панели инструментов

Перестановка колонок

Вкладки редактора таблиц

Для удобства Редактор таблиц разделен на несколько вкладок, каждая из которых позволяет выполнять некоторое количество операций, и отвечает за определенный набор свойств таблицы и элементов таблицы.

Вкладки

Columns - Работа со столбцами

Foreign Keys - Управление внешними ключами

Checks - Установка ограничений CHECK

Indices - Работа с индексами таблиц

Triggers - Управление триггерами

Rules - Задание правил

Policies - Работа с политиками

Properties - Свойства таблицы

Dependencies - Зависимости объектов

Data - Работа с данными

Description - Описание таблицы

DDL - Просмотр DDL описания

Permissions - Назначение прав

Table Editor - Managing fields

Смотрите также:

Новая таблица

Редактор колонок

Редактор индексов

Редактор внешних ключей


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Table Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать таблицу для редактирования

General

iconSaveDescription Save Description - сохранить описание таблицы (появляется при изменении описания таблицы)

iconRefresh Refresh - обновить содержимое редактируемой таблицы

iconPrint Print - печатать метаданные объекта

iconOptions Table Editor Option - настроить редактор таблиц

Tools

Analyze & vacuum - проанализировать и очистить таблицу

Cluster table - кластеризовать таблицу

Truncate Table - удалить данные из таблицы

Reindex table - переиндексировать таблицу

Create view on table - создать представление для таблицы

Dependency tree - просматривать Дерево зависимостей таблицы

Columns

New Column - создать в таблице новыый столбец

Edit Column<имя столбца> - редактировать выделенный столбец

Drop Column<имя столбца> - удалить выделенный столбец

Explorer

Отображаются все подобъекты открытой в редакторе таблицы.

Как и в проводнике баз данных, правой кнопкой мыши Вы можете вызвать контекстное меню объекта.

При переходе на другие вкладки редактора, появляются панели, со специальными функциями для каждой вкладки.

Foreign Keys (для вкладки Foreign Keys)

New Foreign Key - создать новый ключ

Edit Foreign Key <имя объекта> - редактировать существующий ключ

Drop Foreign Key <имя объекта> - удалить существующий ключ

Checks (для вкладки Checks)

New check constraint - создать новое ограничение

Edit check <имя объекта> - редактировать существующее ограничение

Drop check <имя объекта> - удалить существующее ограничение

Indices (для вкладки Indices)

New index - создать новый индекс

Edit index <имя объекта> - редактировать существующий индекс

Drop index <имя объекта> - удалить существующий индекс

Triggers (для вкладки Triggers)

New trigger - создать новый триггер

Edit trigger <имя объекта> - редактировать существующий триггер

Drop trigger <имя объекта> - удалить существующий триггер

Rules (для вкладки Rules)

New rule - создать новое правило

Edit rule <имя объекта> - редактировать существующее правило

Drop rule <имя объекта> - удалить существующее правило

Policies (для вкладки Policies)

Table Editor - Policies New New policy - создать новую политику

Table Editor - Policies Edit Edit policy - редактировать выбранную политику

Table Editor - Policies Drop Drop policy - удалить существующую политику

Data management (для вкладки Data)

iconCommit Commit Transaction - применить транзакцию для данных (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query)

iconRollback Rollback Transaction - откатить транзакцию для данных таблицы (активна, если включены транзакции для данных)

Export Data - экспортировать данные

Export as SQL Script - экспортировать данные в виде SQL скрипта

Import Data - импортировать данные

Save data - сохранить данные (только в редакторе таблиц)

Load data - загрузить данные (только в редакторе таблиц)

Description (для вкладки Description)

iconSaveToFile Save Description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Работа со столбцами

Вкладка Columns предназначена для работы со столбцами таблицы.

Двойной щелчок открывает столбец в редакторе столбцов. Правой кнопкой вызывается контекстное меню столбца.

Table Editor - Managing fields

Для каждого столбца на этой вкладке можно указывать следующие свойства.

Column Name - имя

Column Type - тип значения

Key - является ли столбец ключевым

Not Null - допускается нулевое значение или нет

Default - значение по умолчанию

Description - краткое текстовое описание столбца. Изменения вступят в силу при переходе на другую вкладку, или при нажатии кнопки Save Description на любой из панелей инструментов.

Подробнее про работу со столбцами.

Контекстное меню столбца

New Column - Создать новый столбец

Edit Column <имя объекта> - Редактировать выделенный столбец

Rename Column <имя объекта> - Переименовать столбец

Drop Column <имя объекта> - Удалить столбец

Duplicate Column - Копировать столбец

Reorder Columns - Изменить порядок столбцов

Copy list of column Names to clipboard - Скопировать список имен столбцов в буфер обмена

Export List - Экспортировать список объектов


Перестановка столбцов

Вы можете изменить порядок столбцов при помощи специального инструмента - диалогового окна Reorder Columns. Открыть этот инструмент можно с помощью пункта контекстного меню столбца Reorder Columns.

Важно: PostgreSQL Server не имеет оператора для изменения порядка столбцов, следовательно, SQL Manager for PostgreSQL генерирует сложный скрипт, который пересоздает таблицу, учитывая новый порядок столбцов. Поэтому, если таблица имеет зависимости (например: существует представление, ссылающееся на эту таблицу, или таблица имеет внешний ключ) скрипт может не работать. В этом случае автоматически изменить порядок столбцов не удастся.

Прежде чем откроется основное окно, появится дополнительное предупреждающее сообщение.

Table Editor - Changing fields order - Warning

Из раскрывающегося списка Operations by recreating. выберите доступна ли будет операция пересоздания таблицы.

Enabled - доступна.

Enabled, show warning - доступна, но будет появляться предупреждение.

Disabled - недоступна.

Если Вы отключили функцию пересоздания, то включить ей можно будет только на вкладке Environment Options | Confirmations, установив флажок Table altering operations performed via recreation.

Table Editor - Changing fields order

В списке Column name представлен список столбцов таблицы в том порядке, в котором они находятся в таблице.

Изменить этот порядок можно двумя способами:

С помощью кнопок [image] [image]. Они перемещают вверх или вниз выбранное столбец.

С помощью операции Drag And Drop - перетаскивания столбцы на нужное место.


Управление внешними ключами

На этой вкладке Вы можете создавать и редактировать внешние ключи таблицы.

Двойной щелчок мыши открывает ключ в редакторе внешних ключей.

Table Editor - Managing foreign keys

На вкладке Foreign Keys содержится следующая информация о внешних ключах:

Foreign Key Name - Имя внешнего ключа

On Column - Столбец

FK Table - Внешняя таблица

FK Column - Внешний столбец

On Update - действия, выполняемые при обновлении

On Delete - действия, выполняемые при удалении

Deferrable - допускается ли задержка

Check Time - время допускаемой задержки

Description - текстовое описание объекта

В нижнюю часть окна - Foreign Key Description - вынесено текстовое описание выделенного внешнего ключа.

Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.

Контекстное меню внешнего ключа

Правой кнопкой вызывается контекстное меню для выделенного ключа.

New Foreign Key - Создать новый внешний ключ

Edit Foreign Key<имя объекта> - Редактировать существующий

Drop Foreign Key<имя объекта> - Удалить ключ

Export List - экспортировать список объектов


Установка ограничений

На вкладке Checks Вы можете создавать, просматривать и редактировать ограничения, то есть устанавливать ограничения на значения в столбце.

Двойной щелчок мыши открывает Ограничение в редакторе ограничений CHECK.

Ограничение имеет:

  • Имя - Name,
  • Тело Ограничения - Definition,
  • Описание - Description. Текстовый комментарий к объекту. Это описание вынесено ещё и в нижнюю часть окна, которая называется Check Description.

Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.

Table Editor - Managing checks

Контекстное меню ограничений

По нажатию правой кнопкой на ограничении открывается контекстное меню ограничения.

New Check... - создать новое ограничение

Edit Check <имя ограничения> - редактировать выделенное ограничение

Rename Check <имя ограничения> - переименовать ограничение

Drop Check <имя ограничения> - удалить ограничение

Export List - экспортировать список объектов


Работа с индексами

На вкладке Indices Вы можете создавать, просматривать и редактировать индексы таблицы.

Двойной щелчок мыши открывает индекс в редакторе индексов.

Table Editor - Managing indexes

На этой вкладке содержится информация об индексах таблицы.

Name - Имя индекса

Function - функция

On Column(s) - Столбцы для которых создан индекс

Type - тип индекса

Unique - Является ли ключ уникальным

Primary Key - Первичный ключ

Where - Место

Description - текстовое описание объекта

Описание индекса вынесено в отдельное окно Index Description, находящееся под основным.

Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.

Контекстное меню индекса

Правой кнопкой вызывается контекстное меню индекса.

New Index - Создать новый индекс

Edit Index<имя индекса> - Редактировать существующий индекс

Drop Index<имя индекса> - Удалить индекс

Reindex table - переиндексировать таблицу

Reindex All Indicies - перестроить все индексы

Export List - экспортировать список объектов


Управление триггерами

На вкладке Triggers Вы можете создавать, просматривать и редактировать триггеры таблицы.

Table Editor - Managing triggers

Двойной щелчок мыши открывает триггер в редакторе триггеров.

Информация об объектах, содержащаяся на этой вкладке.

Trigger Name - имя триггера

Moment - момент выполнения

Event - событие при котором триггер срабатывает

Function - функция

Disabled - Включен или выключен триггер (если флажок установлен, то триггер выключен)

Arguments - аргументы

Description - текстовое описание

Описание триггера вынесено в отдельное окно Trigger Description, располагающееся под главным.

Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.

Контекстное меню триггера

По нажатию правой кнопкой на триггер открывается контекстное меню.

New Trigger... - создать новый триггер

Edit Trigger <имя объекта> - редактировать выделенный триггер

Drop Trigger <имя объекта> - удалить триггер

Enable Trigger <имя объекта> - включить триггер

Disable Trigger <имя объекта> - Выключить триггер

Enable All - Включить все триггеры

Disable All - Выключить все триггеры

Export List - экспортировать список объектов


Задание правил

На вкладке Rules Вы можете создавать, просматривать и редактировать правила таблицы.

Table Editor - Managing rules

Двойной щелчок мыши открывает правило в редакторе правил.

Информация об объектах, содержащаяся на этой вкладке.

Rule Name - Имя правила

Event - Событие

Instead - если установлен этот флажок, то правило будет срабатывать вместо указанного события

Where Condition - условие

Description - текстовое описание объекта

Описание правила вынесено в отдельное окно Rule Description, располагающееся под главным.

Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.

Контекстное меню правила

По нажатию правой кнопкой на правило открывается контекстное меню.

New Rule... - создать новое правило

Edit Rule <имя объекта> - редактировать выделенное правило

Drop Rule <имя объекта> - удалить правило

Export List - экспортировать список объектов


Управление политиками

На вкладке Policies вы можете управлять политиками выбранной таблицы.

Опция CheckBox Enable row level security позволяет включить политику защиты строк таблицы.

Опцией CheckBox Force row level security активируется политика защиты строк для владельца таблицы.

С помощью контекстного меню вы можете:

create - создать новую политику

edit - редактировать выбранную политику

rename - переименовать выбранную политику

drop - удалить выбранную политику.

Export List - экспортировать список объектов

Используйте двойное нажатие кнопкой мыши для открытия Редактора политики.

Table Editor - Policy tab1

В окне Policy Description вы можете задать описание для политики.


Свойства таблицы

Окно свойств таблицы открывается при выборе пункта Table Properties в контекстном меню таблицы.

Table Editor - Table properties

Table name

Из раскрывающегося списка выберите название схемы, а в поле укажите имя таблицы.

Table owner

В этом поле нужно указать пользователя, который обладает правами владельца таблицы.

Tablespace

Выберите табличное пространство - физический файл в котором хранится таблица (для версий сервера 8.0 и выше).

CheckBox Move indices

При включенной опции при смене табличного пространства индексы будут перемещены вместе с таблицей.

Options

Элементы управления в этом разделе доступны для редактирования только при создании новой таблицы.

CheckBox With OIDs - то для новой таблицы будут созданы идентификаторы.

CheckBox Unlogged Для сервера версии 9.1 и выше. Если таблица создается как незарегистрированная, то данные, хранящиеся в ней, не заносятся в журнал транзакций.

Note: Такие таблицы автоматически очищаются в случае неполадок.

Fillfactor

В этом разделе можно указать коэффициент заполнения таблиц. При малых значениях FILLFACTOR, при выполнении оператора INSERT страница таблицы заполняется только на указанный процент. Оставшееся свободное место резервируется для обновления строк на странице. Для таблицы, элементы которых никогда не обновляются, допустимым является значение 100. Для часто обновляемых таблиц более приемлемым является меньшее значение.

CheckBox Use default fillfactor - использовать значение параметра Fillfactor = 100 (complete packing), используемое по умолчанию.

В поле Fillfactor можно указать значение коэффициента заполнения отличное от значения по умолчанию. Значение может быть от 10 до 100.

Inherits From

Для новой таблицы можно указать ту таблицу или таблицы, от которых она будет унаследована. Из списка Available Tables выберите нужную таблицу и с помощью кнопок переместите ее в список Selected Tables.


Работа с данными

На этой вкладке Вы можете внести данные в таблицу. Также можете просматривать данные и менять их.

Управление данными осуществляется с помощью панели инструментов и раскрывающегося меню.

Table Editor - Working with table data

Смотрите также:

Просмотрщик данных


Службы таблиц

SQL Manager for PostgreSQL располагает набором инструментов, которые позволяют работать с таблицами.

Анализ таблиц

Собирает информацию о содержимом таблиц базы данных.

Кластеризация таблиц

Позводяет кластеризовать таблицу, используя средства PostgreSQL сервера, и просмотреть текущий статус таблицы.

Удаление данных из таблицы

Позволяет очистить таблицу, т.е. удалить из нее все данные.

Переиндексация таблиц

Позволяет восстанавливать поврежденные индексы таблицы.


Проанализировать и очистить таблицу

С помощью мастера анализа и очистки таблиц можно проанализировать столбцы таблицы, используя возможности PostgreSQL.

Запустить операцию анализа и очистки можно, нажав на кнопку Analyze & vacuum на любой из панелей инструментов таблицы.

Analyze & Vacuum Table - Setting analyze parameters

На первом шаге необходимо задать параметры анализа таблицы:

CheckBox Reclaim storage occupied by deleted tuples (VACUUM) - удалить устаревшие строки из файла. Также Вы можете произвести очистку таблиц, используя Мастер очистки таблиц.

CheckBox Compact unused space (FULL) - exclusively locks the table - этот флажок предназначен для того, чтобы сжимать не используемое на диске место.

CheckBox Freeze tuples (FREEZE) - recommended only for read-only databases - если установлен этот флажок, то записи будут заморожены во время выполнения операции. Рекомендовано использовать для баз данных, доступных только для чтения.

CheckBox Show detailed operation report (VERBOSE) - о произведенной операции будет выведен детальный отчет.

На следующем шаге выберите столбцы таблицы для проведения операции. С помощью кнопок перенесите столбцы из списка доступных - Available - в список выбранных - Selected.

Analyze & Vacuum Table - Selecting columns to analyze

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Analyze & Vacuum Table - Running service

В текстовом поле отображается информация о проведении и результатах выполняемой операции.

Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Кластеризовать таблицу

С помощью этого мастера Вы можете кластеризовать таблицу, используя средства PostgreSQL сервера, и просмотреть текущий статус таблицы.

Запустить операцию кластеризации можно, нажав на кнопку Clustering Table на любой из панелей инструментов таблицы.

Из списка выберите ключевое столбец для кластеризации, выделив его нажатием мыши.

Cluster Table - Selecting index for clustering

В списке отображается следующая информация о каждом ключе.

Index Name - имя индекса.

Function - функция.

Columns - столбцы, входящие в состав индекса.

Key - если среди столбцов индекса есть ключевой столбец, то это отображается в этой колонке.

CheckBox Если установлен флажок Analyze Table, то дополнительно будет выполнен анализ таблицы.

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Cluster Table - Run

В текстовом поле отображается информация о проведении и результатах выполняемой операции.

Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Удалить данные из таблицы

Если на одной из панелей инструментов нажать кнопку Truncate Table, то из таблицы будут удалены все данные.

Перед удалением данных появится окно, в котором надо будет подтвердить действие, нажав на кнопку Yes.

Truncate Table - Question

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Переиндексировать таблицу

Нажатие на кнопку Reindex table на любой из панелей инструментов запускает механизм переиндексации таблицы.

Reindex Table - Running service

Commit - применить транзакцию можно, нажав на кнопку (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query).

Rollback - откатить транзакцию (активна, если включены транзакции для данных).

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Управление подобъектами таблиц

К подобъектам таблицы относятся:

Поля

Внешние ключи

Ограничения

Индексы

Триггеры

Правила

Создать подобъект

Чтобы добавить подобъект в таблицу необходимо выполнить следующие действия:

  • открыть таблицу в редакторе таблиц. Для этого достаточно двойного щелчка мышью по нужной таблице в проводнике баз данных,
  • открыть соответствующую вкладку,
  • в контекстном меню подобъекта выбрать пункт New <тип подобъекта>,
  • в появившемся редакторе укажите требуемые свойства подобъекта.

Копировать подобъект

Для копирования подобъекта необходимо выбрать пункт Duplicate <тип подобъекта><имя подобъекта> в контекстном меню подобъекта. В первом появившемся окне введите имя нового объекта, а во втором укажите копировать ли объект с данными или без них.

Редактировать подобъект

Для того чтобы изменить подобъект необходимо:

  • открыть таблицу в редакторе таблиц для этого достаточно двойного щелчка мышью по нужной таблице в проводнике баз данных,
  • открыть соответствующую вкладку,
  • в контекстном меню подобъекта выбрать пункт Edit <тип подобъекта><имя объекта>,
  • в появившемся редакторе подобъектов укажите требуемые свойства.

Не все подобъекты можно редактировать.

Если в Environment Options на вкладке DB Explorer установлен флажок Show table subobjects, то подобъекты таблицы будут отображаться в проводнике баз данных. В этом случае для того, чтобы изменить подобъект нужно щелкнуть на нем два раза мышкой в проводнике баз данных. Он автоматически откроется в соответствующем редакторе.

Удалить подобъект

для того чтобы удалить подобъект необходимо:

  • открыть таблицу в редакторе таблиц для этого достаточно двойного щелчка мышью по нужной таблице в проводнике баз данных,
  • открыть нужную вкладку,
  • в контекстном меню подобъекта выбрать пункт Drop <тип подобъекта><имя объекта>,
  • в появившемся окне подтвердить удаление.


Столбцы

В редакторе таблиц на вкладке Columns Вы можете создавать редактировать и удалять столбцы таблицы.

Открыть столбец в редакторе можно следующим образом:

  • через редактор таблиц;
  • в SQL ассистенте.

Field Editor - Editing field definition

Column name

Задайте имя столбца, оно должно соответствовать правилам именования столбцов PGSQL.

Data type

Type

Выберите тип данных, которые будут храниться в этом поле.

Change by expression

Введите выражение для рассчета значения вычислимого столбца.

Size

Задайте размер столбца. Если установлен флажок CheckBox Unlimited, то размер столбца не будет ограничен.

Precision

Для чисел с плавающей точкой в столбце укажите отображаемое количество знаков после запятой.

Number of array dimensions

Для массивов укажите размерность массива.

Collation

Выберите кодировку символов.

Generated

Выберите свойства генерации для столбцов типа Identity: ALWAYS — пользовательское значение используется, только если в операторе INSERT указано OVERRIDING SYSTEM VALUE; BY DEFAULT — пользовательскому значению отдаётся предпочтение.

Storage

Выберите тип хранения данных: PLAIN, EXTENDED, EXTERNAL или MAIN.

Column flags

CheckBox Not null

При включенной опции столбец не может иметь значение NULL.

CheckBox Primary key

Столбец будет являться первичным ключом.

CheckBox Unique

Поле является частью уникального ключа.

Statistics

Number of statistic details

Укажите число детальности статистики.

Field Editor - Setting field statistics

В текстовом поле, расположенном на вкладке Default Value, задайте значение по умолчанию - значение, которое будет автоматически записываться в это поле, если пользователь, при занесении данных, оставит его пустым.

В нижней части формы редактора столбцов, на вкладке Default можно задать значение по умолчанию для столбца.

Field Editor - Setting default value and description

На вкладке Description можно добавить текстовый комментарий для столбца.

Field Editor - Description


Внешние ключи

Внешний ключ - Foreign Key - столбец или сочетание столбцов, значения которого соответствуют первичному или уникальному ключу из той же или другой таблицы. Внешний ключ также называют ссылочным ключом.

Создание и редактирование внешних ключей осуществляется с помощью специального инструмента - Foreign Key Editor.

Внешний ключ применяется для принудительного установления связи между данными в двух таблицах.

Этот редактор используется для изменения свойств внешнего ключа. Редактор открывается при создании или редактировании внешнего ключа.

Foreign Key Editor - Editing foreign key definition

Имя ключа задается в поле Foreign Key Name. Автоматически система создает имя, которое состоит из имени выбранной таблицы и суффикса _fk. Из раскрывающегося списка Table Вы выбираете таблицу, в которой будет создан внешний ключ.

Важно: Это поле доступно для редактирования только при создании ключа.

CheckBox Not validated

Если выбрана эта опция, то внешний ключ будет создан, но существующие данные таблицы не будут проверяться на соответствие этому внешнему ключу.

Чтобы добавить столбцы таблицы в ключ переместите их из списка доступных столбцов - Available Columns в список выбранных столбцов - Included Columns.

Далее из раскрывающегося списка Foreign table выберите внешнюю таблицу. Переместите столбцы из списка доступных столбцов - Available Columns в список выбранных столбцов - Included Columns.

Из раскрывающегося списка On delete action Вы выбираете действие, которое будет выполняться при удалении данных.

Из раскрывающегося списка On update action Вы выбираете действие, которое будет выполняться при обновлении данных в таблице.

No Action - нет действия

Restrict - ограничивать действия обновления и удаления

Cascade - каскадное обновление или удаление

Set Null - обнулить значения

Set Default - установить значения, принятые по умолчанию

В разделе Match type укажите тип соответствия:

RadioButton Simple - некоторые столбцы внешнего ключа могут иметь значение NULL, если остальные части этого ключа не NULL. (MATCH SIMPLE).

RadioButton Full - полный. Не допускаются нулевые значения ни в одном из столбцов внешнего ключа, если только все столбцы не имеют значение NULL. (MATCH FULL)

В разделе Deferrable задайте параметры задержки

CheckBox Задержка допустима, если установлен флажок Deferrable.

Из раскрывающегося списка Check Time выберите время проверки.

На вкладке Description Вы можете ввести текстовое описание редактируемого объекта.


Ограничения

Ограничения устанавливают, какие значения данных допустимы в столбце. Одно ограничение CHECK может затрагивать несколько столбцов, а к отдельному столбцу может применяться несколько проверочных ограничений. При удалении таблицы также удаляются проверочные ограничения. Проверочные ограничения обеспечивают доменную целостность, ограничивая значения, которые может принимать столбец.

Ограничения CHECK можно создавать как часть определения таблицы при ее создании. Если таблица уже существует, можно добавить ограничение CHECK. Таблицы и столбцы могут содержать несколько ограничений CHECK.

Ограничение CHECK перед выполнением команды INSERT проверяет выполнение списка условий.

Редактор ограничений позволяет Вам задавать условия для ограничения. Редактор открывается при создании или редактировании ограничения.

Check Editor - Editing check definition

В поле Check name укажите название ограничения.

CheckBox Not validated

Если выбрана эта опция, то ограничение на таблицу будет создано, но не будет применено к данным, которые уже содержатся в таблице. Новые записи будут проверяться на соответсвие этому ограничению.

Если установлен флажок CheckBox Non-inheritable, то ограничение не будет распространяться на дочерние таблицы.

В редакторе Condition задайте текст условия проверки. В поле Description можно добавить комментарий.

Ограничение целостности check является наиболее часто используемым видом ограничения. Оно позволяет задать для определённой столбца, выражение, которое будет осуществлять проверку, помещаемого в этот столбец значения. Если значение удовлетворяет, заданному ограничению, то выражение должно возвращать Логическое значение (истина).


Индексы

Индекс - это объект реляционной базы данных, обеспечивающий быстрый доступ к данным в строках таблицы на основе значений ключа. Индексы также обеспечивают уникальность строк таблицы. PostgreSQL Server поддерживает кластеризованные и некластеризованные индексы. Первичный ключ таблицы автоматически индексируется.

С помощью редактора индексов Вы можете создавать и редактировать индексы. Этот редактор автоматически открывается при создании или редактирования индекса.

Панели инструментов

Редактирование индексов

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Index Editor - Editing index definition


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Index Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать индекс для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить

iconPrint Print - печатать метаданные индекса

Dependency tree - просматривать дерево зависимостей индекса

Reindex - реиндексировать

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save Description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование индексов

На вкладке Index редактора индексов Вы можете задать основные свойства редактируемого объекта.

В поле Name указываете имя индекса.

Из раскрывающегося списка For table or materialized view выберите таблицу или материализованное представление, в котором необходимо создать индекс (зто поле доступно для изменений только при создании индекса).

CheckBox Mark for table cluster

Включите флажок, если создается индекс для операций кластеризации.

Index Editor - Editing index definition

Index type

Укажите тип создаваемого индекса.

RadioButton Primary Key - установите этот переключатель, если создаете первичный ключ.

RadioButton Unique key - если существует уникальный индекс, каждый раз при добавлении данных операциями вставки производится проверка на наличие повторяющихся значений.

RadioButton Unique index - уникальный индекс.

RadioButton Index - индекс.

RadioButton Exclusion - исключение.

Deferrable

Задайте параметры задержки.

CheckBox Deferrable

Включите флажок для установки задержки. Из раскрывающегося списка Check Time выберите время проверки.

Immediate - проверяется после каждого оператора.

Deferred - проверяется только в конце транзакции.

CheckBox Use default fillfactor.

Установите флажок, чтобы использовать фактор заполнения таблицы по умолчанию -100 (плотное заполнение).

Fillfactor

Задайте значение фактора заполнения (при отключенном флажке CheckBox Use default fillfactor).

B-tree index method

CheckBox Use default deduplicate items

Применима только к методу B-tree. Этот параметр использует значение по умолчанию для управения механизмом исключения дубликатов.

CheckBox Deduplicate_items

Этот параметр управляет механизмом исключения дубликатов.

GIN index method

CheckBox Use default fast update

Применима только к методу Gin. Установите флажок, чтобы использовать значение опции fast_update по умолчанию.

CheckBox Fastupdate

Этот параметр управляет механизмом быстрого обновления: ON включает быстрое обновление, OFF отключает его.

CheckBox Use default gin_pending_list_limit

Применима только к методу Gin method. Установите флажок, чтобы использовать значение опции gin_pending_list_limit по умолчанию (4MB).

CheckBox Gin_pending_list_limit

Укажите размер gin_pending_list_limit в килобайтах. Задаёт максимальный размер очереди записей GIN, которая используется, когда включён режим fastupdate. Если размер очереди превышает заданный предел, записи из неё массово переносятся в основную структуру данных индекса GIN, и очередь очищается.

GIST index method

CheckBox Use default buffering

Применима только к методу Gist. Использует значение по умолчанию для управлением буферизацей (AUTO).

CheckBox Buffering

Контролирует использование буферизации: OFF она отключена, с ON — включена, а с AUTO — отключена вначале, но может затем включиться на ходу, как только размер индекса достигнет значения effective_cache_size.

BRIN index method

CheckBox Use default pages_per_range

Применима только к методу Brin. Использует значение по умолчанию для определения количества блоков таблицы, которые образуют зону блоков для каждой записи в индексе BRIN (128).

CheckBox Pages_per_range

Укажите размер зоны блоков. Число записей в индексе будет равняться размеру отношения в страницах, делённому на установленное значение. Чем меньше это число, тем больше становится индекс, но в то же время сводные данные могут быть более точными и большее число блоков данных может быть пропущено при сканировании индекса.

CheckBox Use default autosummarize

Применима только к методу Brin. Использует значение по умолчанию для управлением сводным значением.

CheckBox Autosummarize

Определяет, будет ли поставлен в очередь расчёт сводного значения для предыдущей зоны страниц, когда происходит добавление в следующую.

CheckBox Don't lock table on creation

Данная опция позволяет построит индекс, не устанавливая никаких блокировок, которые бы предотвращали добавление, изменение или удаление записей в таблице; тогда как по умолчанию операция построения индекса блокирует запись (но не чтение) в таблице до своего завершения.

Из раскрывающегося списка Tablespace выберите табличное пространство индекса.

Из раскрывающегося списка Index method выберите метод индексирования:

  • b-tree
  • r-tree
  • hash
  • gist (Generalized Index Search Trees)
  • sp-gist (Space-Partitioned GiST для Postgres 9.2 и выше)
  • brin (Block Range INdex для версии Postgres 9.5 и выше).

В поле Condition for partial index задайте условие для разделения индекса.

В нижней части формы Вы можете выбрать столбец из списка имеющихся столбцов (Available Columns) и поместить его в список выбранных столбцов-индексов (Index Keys). Делается это с помощью кнопок или с помощью двойного щелчка мыши.

Operator Class

В этом поле для каждого столбца индекса укажите класс оператора. Выберите нужное значение из раскрывающегося списка.

Selected index key

в этом поле задайте имя ключа индекса, или выражение, основывающееся на одном или нескольких столбцах индекса. С помощью этого выражения Вы сможете получить быстрый доступ к таблицам, основывающимся на результатах вычислений.


Политики

Политика - это объект для обеспечения безопасного доступа к данным за счёт безопасности на уровне строк (Row Level Security), фильтрующий доступ для определенных пользователей к определённым строкам — как на обновление, так и на чтение.

Редактирование политики

Управление политиками


Редактирование политики

Редактор политик используется для создания и редактирования политик.

Policy name

Данное поле используется для задания или редактирования имени политики. Одинаковое имя может использоваться для разных таблиц, т.к. объект идентифицируется в паре с таблицей.

For table

Из списка выберите таблицу или представление, для которой будет применятся политика.

Command

Выберите команду (ALL, SELECT, INSERT, UPDATE или DELETE), к которой будет применятся данная политика.

CheckBox Restrictive

Создаваемая политика будет ограничительной. это политика, которая указывает, что создаваемая политика должна быть ограничительной.

Таким образом можно сократить множество записей, к которым можно обращаться.

Roles

Из списка Available Roles выберите роли, для которых будет применятся данная политика.

Table Editor - Policy editor

Using expression

Введите SQL условие, в соответствии с которым определяется список столбцов доступных пользователю.

Check expression

Данное поле используется для задания SQL условия для команд INSERT и UPDATE.

Используйте поле Description для описания объекта.

После того как политики настроены, вы можете активировать их на вкладке Policies:

CheckBox Enable row level security

Данная опция включает защиту строк.

CheckBox Force row level security

Опция управляет применением относящихся к таблице политик защиты строк, когда пользователь является её владельцем. Если это поведение включается, политики защиты на уровне строк будут действовать и на владельца таблицы. Если оно отключено, защита на уровне строк не будет действовать на пользователя, являющегося владельцем таблицы.

Table Editor - Policies Common Options


Представления

Представление - это виртуальная таблица, представляющая данные одной или более таблиц альтернативным образом. Представление может быть создано только в текущей базе данных. Представление может включать не более 1024 столбцов.

Для работы с представлениями в SQL Manager for PostgreSQL существует специальный инструмент - View Editor (Редактор представлений)

В редакторе Вы можете создавать и редактировать представления, в том числе материализованные.

При создании нового представления редактор открывается автоматически.

Панели инструментов

Редактирование SQL описания

Просмотр столбцов

Правила

Индексы

Триггеры

Просмотр зависимостей

Просмотр данных

Текстовое описание представлений

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

View Editor - Using Navigation barNEW

Object

iconDB Выбрать базу данных

Выбрать представление для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

Edit query with Design Query - редактировать представление в визуальном конструкторе запросов

iconRefresh Refresh - обновить содержимое редактируемого представления

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей представления

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

При переходе на другие вкладки редактора, на панели инструментов появляются дополнительные панели с инструментами для работы на этих вкладках.

Rules (для вкладки Rules)

New rule - создать новое правило

Edit rule <имя объекта> - редактировать существующее правило

Drop rule <имя объекта> - удалить существующее правило

Triggers (для вкладки Triggers)

New trigger - создать новый триггер

Edit trigger <имя объекта> - редактировать существующий триггер

Drop trigger <имя объекта> - удалить существующий триггер

Data management (для вкладки Data)

iconCommit Commit Transaction - применить транзакцию для данных (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query)

iconRollback Rollback Transaction - откатить транзакцию для данных таблицы (активна, если включены транзакции для данных)

Export Data - экспортировать данные

Export as SQL Script - экспортировать данные в виде SQL скрипта

Import Data - импортировать данные

Materialized View

View Editor - Mat view refresh обновить данные материализованного представления

View Editor - Mat view clear очистить данные материализованного представления

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


SQL описание

На вкладке View Вы можете создать просмотреть и отредактировать SQL скрипт создания представления.

Представление может быть создано визуально с помощью визуального конструктора запросов.

View Editor - Editing view definition

Если Вы создали или изменили текст, то для того, чтобы изменения вступили в силу, необходимо нажать Compile на панели навигации.


Столбцы

На вкладке Columns Вы можете просмотреть все столбцы, отображаемые в представлении.

View Editor - Viewing fields

В основной таблице отображается информация о столбцах, содержащихся в представлении.

Column Name - имя столбца.

Column Type - тип столбца.

Description - текстовое описание столбца.

По нажатию правой кнопки мыши на столбец появляется контекстное меню.

View Editor - Viewing fields - PopupMenu

Rename Column - переименовать столбец.

Copy list of Columns to clipboard - копировать список столбцов в буфер обмена.

Export metadata - экспортировать метаданные.

В нижнюю часть формы вынесено окно Column Description <имя объекта>, в котором содержится описание выделенного столбца. Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.


Индексы

На вкладке Indices вы можете управлять индексами материализованных представлений. Для открытия редактора индексов используйте контекстное меню или элементы управления на Навигационной панели или Панели управления.

Используете правую кнопку мыши чтобы:

Create new - создать новый индекс

Edit - редактировать существующий индекс,

Rename - переименовать существующий индекс

Drop - удалить существующий индекс

Reindex - выполнить переиндексацию выделенного индекса

Reindex all - переиндексировать все индексы

Export list - экспортировать список индексов

Описание индекса вынесено в отдельное окно Index Description, располагающееся под главным окном.

View Editor - Managing indices

ВАЖНО: Данная вкладка доступна только для материализованных представлений.


Правила

Правила — это особая разновидность хранимой процедуры, выполняемая автоматически при возникновении события на сервере базы данных, которая позволяет определять действия для PostgreSQL.

Для каждого представления можно задавать некоторое количество правил, корректирующих его работу.

На вкладке Rules отображается информация о правилах, присутствующих в представлении.

Rule Name - имя правила.

Event - выполняемое событие.

Instead - выполняется ли действие, указанное в правиле вместо события, заданного в поле Event.

Where Condition - условие WHERE.

Description - текстовое описание правила.

View Editor - Managing view rules

Контекстное меню

New rule - создать новое правило

Edit rule <имя объекта> - редактировать существующее правило

Drop rule <имя объекта> - удалить существующее правило

  • Export List - экспортировать список правил в файл

Смотрите также:

Редактор правил


Триггеры

На вкладке Triggers Вы можете создавать, просматривать и редактировать триггеры представления.

View Editor - Managing triggers

Двойной щелчок мыши открывает триггер в редакторе триггеров.

Информация об объектах, содержащаяся на этой вкладке.

Trigger Name - имя триггера

Moment - момент выполнения

Event - событие при котором триггер срабатывает

Function - функция

Disabled - Включен или выключен триггер (если флажок установлен, то триггер выключен)

Arguments - аргументы

Description - текстовое описание

Описание триггера вынесено в отдельное окно Trigger Description, располагающееся под главным.

Внесенные изменения вступят в силу только при переходе на другую вкладку или при выборе другого объекта.

Контекстное меню триггера

По нажатию правой кнопкой на триггер открывается контекстное меню.

New Trigger... - создать новый триггер

Edit Trigger <имя объекта> - редактировать выделенный триггер

Drop Trigger <имя объекта> - удалить триггер

Enable Trigger <имя объекта> - включить триггер

Disable Trigger <имя объекта> - Выключить триггер

Enable All - Включить все триггеры

Disable All - Выключить все триггеры

Export List - экспортировать список объектов

Смотрите также:

Редактор триггеров


Просмотр данных

На этой вкладке можно просматривать данные.

Данные представления доступны только для чтения. Вы не можете их изменить или удалить.

View Editor - Working with data

На вкладке Data отображаются данные. По умолчанию отображаются в виде сетки (см. Data View). С помощью контекстного меню этой вкладки можно Экспортировать данные, Импортировать данные, Извлечь данные в виде SQL скрипта.

Для удобства просмотра данных можно использовать фильтрование и группировку данных.

Инструменты управления данными, также доступны на Навигационной панели и Панели инструментов редактора представлений.

Смотрите также:

Просмотрщик данных


Функции

Функции представляют собой набор команд. В PostgreSQL функции хранятся непосредственно в базе данных. Каждой функции присваивается идентификатор объекта.

В PostgreSQL существует четыре типа функций:

  • функции, написанные на SQL,
  • функции на языке описания процедур (PL/Tcl or PL/pgSQL),
  • внутренние функции,
  • функции на языке С.

Редактор функций позволяет Вам создавать, редактировать и выполнять функции. Он запускается, когда Вы создаете новую функцию или открываете для редактирования уже существующую.

Чтобы открыть функцию в редакторе достаточно щелкнуть по ней два раза мышкой в проводнике баз данных.

Инструменты редактора располагаются на вкладках и панелях инструментов.

Вкладки редактора:

Определение функции

Выполнение функции

Параметры функции

Просмотр зависимостей

Текстовое описание

Просмотр DDL

Назначение прав

btnExecuteQuery Выполнение функции

Чтобы выполнить функцию нужно:

  • Открыть объект в редакторе двойным щелчком мыши на нужной функции в проводнике баз данных в группе объектов Functions.
  • Нажать Execute function на одной из панелей инструментов или нажать клавишу F9.

iconDebug Отладка

Чтобы отладить функцию на языке plpgsql необходимо:

  • Открыть объект в редакторе двойным щелчком мыши на нужной функции в проводнике баз данных в группе объектов Functions.
  • Нажать кнопку Debug на одной из панелей инструментов или воспользоваться сочетанием клавиш Shift+Ctrl+D.
  • Отладить функцию в открывшемся отладчике функций.


Панели инструментов

Панель навигации

Procedure Editor - Navigation bar

Object

iconDB Выбрать базу данных

Выбрать функцию для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconDebug Debug - отладить функцию с помощью отладчика

debugwithextension Debug with extension — отладить функцию с помощью расщирения pldbgapi

iconCheckSyntax Check syntax - проверить SQL синтаксис тела функции

iconExecute Execute - выполнить функцию

iconRefresh Refresh - обновить содержимое активной вкладки

iconPrint Print - печатать метаданные функции

Dependency tree - просмотреть дерево зависимостей функции

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Если функция была выполнена и вернула результат, то появляется панель Data Management.

iconCommit Commit Transaction - применить транзакцию для данных (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query)

iconRollback Rollback Transaction - откатить транзакцию для данных таблицы (активна, если включены транзакции для данных)

При переходе на другие вкладки появляются панели, со специальными функциями для каждой вкладки.

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение функции

Основные параметры функции задайте на вкладке Function редактора функций.

Name

Укажите название функции. Из раскрывающегося списка выберите название схемы, которой эта функция будет принадлежать.

Function Editor - Editing function definition

Тип возвращаемого значения выберите в разделе Returns.

RadioButton Single value - функция возвращает одно значение.

RadioButton Set of values - функция возвращает набор значений.

RadioButton Table - таблицу. Столбцы возвращаемой таблицы необходимо указать в поле Return table.

RadioButton Nothing - функция возвращает void.

RadioButton Trigger - триггер.

Из раскрывающегося списка Return Type необходимо выбрать тип возвращаемого значения.

В списке Arguments указываются аргументы функции.

Работать с ними позволяет контекстное меню, которое появляется при нажатии правой кнопкой мыши на список аргументов.

iconPlus Add Argument - добавить аргумент в список.

iconMinus Delete Argument - удалить аргумент.

btnArrowUp Move Up - переместить на одну позицию вверх.

btnArrowDown Move Down - переместить вниз на одну позицию.

Для аргумента в списке можно задать:

Name - имя.

Type - тип данных, выбрать из списка.

Mode - тип параметра (in - входной, out - выходной, in/out - входной и выходной).

Language

Выберите язык программирования, применяемый для выполнения функции.

CheckBox Returns null on null input

Функция будет возвращать значение NULL, если хотя бы один входной параметр будет иметь значение NULL.

CheckBox Execute with definer's privileges

Функция при выполнении будет обладать правами того пользователя, который ее создал. Если флаг не установлен — то правами пользователя, который ее вызывает.

CheckBox Is window function

При включенной опции создается оконная функция. Она выполняет вычисления над списком строк в таблице, которые как-то относятся к текущей строке. В отличие от обычных агрегатных функций, использование оконной функции не заставляет строки группироваться в одну; строки сохраняют свои отдельные значения.

CheckBox Is leakproof function

Установите флаг для создания "герметичной" функции.

Optimization

Выберите поведение функции:

IMMUTABLE (постоянная) показывает, что функция если заданы одни и те же аргументы, то функция будет возвращать одни и те же результаты.

STABLE (стабильная) показывает, что внутри транзакции функция будет возвращать одни и те же результаты при одних

VOLATILE (изменчивая) показывает, что значение функции может меняться при задании одних и тех же аргументов.

Parallel

Укажите, может ли функция выполнятся в параллельном режиме.

UNSAFE — функцию нельзя выполнять параллельном режиме.

RESTRICTED — функцию можно выполнять в параллельном режиме, но только в ведущем процессе группы.

SAFE — функция безопасна для выполнения в параллельном режиме без ограничений.

Planner options

Эти опции доступны только на сервере 8.3 и выше. Укажите необходимые числовые значения стоимости выполнения функции Estimated execution cost и примерное количество строк Estimated number of rows.

В редакторе Definition задается тело функции.

Все инструменты для работы с текстом, доступные в редакторе запросов, доступны и в редакторе функции.

Для удобства работы с текстом функции осуществляется syntax highlight - подсветка синтаксиса и code folding - возможность задать иерархическую структуру текста с возможностью скрывать подобъекты. С помощью макросов можно записать и воспроизвести некоторые действия.

Для выполнения функции необходимо нажать кнопку btnExecuteQuery Execute на одной из панелей инструментов.


Параметры конфигурации

На вкладке Configuration Parameters задайте параметры конфигурации функции.

Function Editor - Setting configuration parameters

Параметру конфигурации присваивается указанное значение в начале выполнения функции; после завершения выполнения восстанавливается исходное значение параметра.

В полях столбца Parameter Name выберите необходимые параметры конфигурации из выпадающего списка.

В полях столбца Parameter Value задайте значение для соответствующего параметра. Значения могут быть определены как строковые константы, идентификаторы или числа. Также можно задать разделенный запятыми список значений этих типов, при необходимости для конкретных параметров.

Если для конкретного параметра выбрана опция Take Current Value, то в функцию передается текущее значение параметра.


Выполнение функции

Редактор функций позволяет выполнять созданные функции.

Чтобы выполнить функцию нажмите кнопку btnExecuteQuery Execute function, которая располагается на одной из панелей инструментов.

Если в функции есть параметры, то при выполнении, для задания значений, откроется окно для ввода параметров.

Результаты успешно выполненных функций и ошибки, возникшие при выполнении, отображаются на вкладке Function редактора функций, в окне, которое появляется в нижней части формы.


Ввод параметров функции

Если в функции есть параметры, то перед ее выполнением открывается окно Enter parameters values. В этом окне Вы можете задать значения всех параметров исполняемой процедуры. После ввода параметров нажмите кнопку Ok, для того чтобы продолжить выполнение процедуры, или Cancel для отмены выполнения.

Function Editor - Specifying input parameters


Отладчик

Для исправления ошибок и оптимизации функции в SQL Manager for PostgreSQL существует специальный инструмент - отладчик. Чтобы открыть функцию или процедуру в отладчике откройте ее и нажмите кнопку Debug на любой из панелей инструментов.

Панели инструментов

Отладка

Просмотр информации

NB Вы можете отлаживать процедуры и функции с помощью кнопки debugwithextension Debug with extension, если у вас установлено расширение pldbgapi. В этом случае вы сможете использовать возможность вызова вложенных объектов. Установить расширение можно в Services --> Database extensions.

Смотрите также:

Редактор функций

Редактор процедур


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Function debugger - Using Navigation bar

General

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Debug

iconCommit Commit retaining - фиксировать сохраненное

iconDebug Step over -перейти к следующему оператору

stepinto Step into — выполнить вложенный оператор. Доступно только в режиме Debug with extension.

iconExecute Run - выполнить функцию

Run to cursor - выполнять до позиции курсора

Toggle breakpoint - переключить точку остановки

Reset - сброс

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Отладка

В отладчике вы можете отлаживать функцию или процедуру, редактирование самого текста запрещено.

Голубым цветом выделен текущий оператор.

Красным выделена строка, на которой стоит Breakpoint - контрольная точка.

Сочетания клавиш, используемые при отладке:

  • F8 - начать пошаговое выполнение.
  • Ctrl+F2 - прервать выполнение.
  • Ctrl+F8 - добавить контрольную точку к текущему оператору.
  • F9 - выполнить функцию или процедуру (до конца или до следующей контрольной точки).

Function debugger - Debugging function


Просмотр информации

На вкладках, расположенных в нижней части окна отладчика, отображается разнообразная информация о текущем объекте и процессе отладки.

На вкладке Parameters and Variables отображаются все переменные и параметры , а также их типы (поле Kind) и значения (поле Value).

Function debugger - Debug info - Parameters and variables

Значение функции в столбце Value можно менять с помощью двойного щелчка мыши. В этом случае появляется диалоговое окно в котором необходимо указать новое значение.

Function debugger - Debug info - Parameters and variables - Modify variable

Для каждого типа данных предусмотрено соответствующее поле ввода.

На вкладке Results отображаются результаты выполнения функции.

Function debugger - Debug info - Results

На этой вкладке отображаются номер функции (поле #) и значение, которое она вернула (поле Return value).

Последний выполненный оператор, а также время и план его выполнения, отображается на вкладке Last Statement.

Function debugger - Debug info - Last statement

Полный список точек останова показан на вкладке Breakpoints.

Function debugger - Debug info - Breakpoints

О точке останова отображается следующая информация:

  • Line - номер строки на которой стоит контрольная точка
  • Statement - возвращаемое значение
  • Passes - число проходов точки через которое произойдет ее срабатывание.

Сообщения отладчика функций можно посмотреть на вкладке Messages.

Function debugger - Debug info - Messages

Type - тип сообщения.

Text - текст сообщения.


Процедуры

Процедура — это объект базы данных, представляющий собой набор инструкций SQL, который компилируется один раз и хранится на сервере. Важной характеристикой продедур является поддержка транзакций.

Процедуры поддерживаются на серверах PostgreSQL с версии 11.0.

Вкладки редактора

Панели инструментов

Редактор процедур

Параметры конфигурации

Просмотр зависимостей

Текстовое описание

Просмотр DDL

Назначение прав


Панели инструментов

Все основные действия с процедурами можно выполнять с панели инструментов (вверху) или панели навигации (слева).

Панель навигации

Procedure Editor - Navigation bar

Object

iconDB Выбрать базу данных

Выбрать процедуру для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconDebug Debug - отладить процедуру с помощью отладчика

debugwithextension Debug with extension — отладить процедуру с помощью расщирения pldbgapi

iconCheckSyntax Check syntax - проверить SQL-синтаксис тела процедуры на наличие ошибок

iconExecute Execute - выполнить процедуру

iconRefresh Refresh - обновить содержимое активной вкладки

iconPrint Print - печатать метаданные процедуры

Dependency tree - просмотреть дерево зависимостей процедуры

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна.

При переходе на другие вкладки появляются панели, со специальными функциями для каждой вкладки.

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактор процедур

На вкладке Procedure необходимо задать основные параметры процедуры.

Name

Укажите название процедуры. Из раскрывающегося списка выберите название схемы, в которой она будет создана.

Procedure Editor - Editor

Language

Выберите язык программирования, применяемый для выполнения процедуры.

Arguments

В списке укажите аргументы функции. Работать с ними позволяет контекстное меню, которое появляется при нажатии правой кнопкой мыши на список аргументов.

iconPlus Add Argument - добавить аргумент в список.

iconMinus Delete Argument - удалить аргумент.

btnArrowUp Move Up - переместить на одну позицию вверх.

btnArrowDown Move Down - переместить вниз на одну позицию.

Для аргумента в списке можно задать:

Name — имя.

Type — тип данных, выбрать из списка.

Mode — тип параметра (in - входной, out - выходной, in/out - входной и выходной).

Default value — значение по умолчанию.

Definition

В редакторе Definition задается тело процедуры.

Все инструменты для работы с текстом, доступные в редакторе запросов, доступны и в редакторе процедуры.

Для удобства работы с текстом функции осуществляется syntax highlight - подсветка синтаксиса и code folding - возможность задать иерархическую структуру текста с возможностью скрывать подобъекты. С помощью макросов можно записать и воспроизвести некоторые действия.

Для выполнения процедуры необходимо нажать кнопку btnExecuteQuery Execute на одной из панелей инструментов.


Домены

Домен - пользовательский тип данных, который сформирован на основании стандартного типа. Домен основывается на отдельном базовом типе и для многих целей является с этим базовым типом взаимозаменяемым. Однако, домен может иметь ограничения, которые ограничивают его допустимые значения неким списком, выходящие за рамки которого значения разрешены в базовом типе.

В редакторе Вы можете создавать и редактировать домены.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства домена

Ограничения домена

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Domain Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать домен для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей доменов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение домена

Управлять свойствами домена можно с помощью инструментов, расположенных на вкладке Domain, редактора доменов.

Domain Editor - Editing domain definition

Имя объекта задайте в поле Name. Из раскрывающегося списка выберите имя схемы.

Тип данных выберите из раскрывающегося списка Type.

Размер задаете в поле Size.

CheckBox Если установлен флажок Unlimited, то размер неограничен.

Точность представления данных укажите в поле Precision.

В поле Number of array dimensions задайте размерность массива.

CheckBox Если значения этого домена не должны принимать значение NULL, то установите флажок Not Null.

Значение по умолчанию для домена задайте в поле Default Value.


Управление ограничениями домена

Ограничения CHECK устанавливают, какие значения данных допустимы в столбце. Одно ограничение CHECK может затрагивать несколько столбцов, а к отдельному столбцу может применяться несколько проверочных ограничений. При удалении таблицы также удаляются проверочные ограничения. Проверочные ограничения обеспечивают доменную целостность, ограничивая значения, которые может принимать столбец.

Ограничения CHECK можно создавать как часть определения таблицы при ее создании. Если таблица уже существует, можно добавить ограничение CHECK. Таблицы и столбцы могут содержать несколько ограничений CHECK.

Ограничение CHECK перед выполнением команды INSERT проверяет выполнение списка условий.

Domain Editor - Managing domain checks

Для каждого домена можно задать некоторое количество ограничений, корректирующих его работу.

Управление ограничениями осуществляется с помощью контекстного меню, открывающегося при нажатии правой кнопкой мыши на общем списке, и редактора ограничений.


Правила

Правила — это особая разновидность хранимой процедуры, выполняемая автоматически при возникновении события на сервере баз данных, которая позволяет определять поведение PostgreSQL сервера.

Этот редактор предназначен для создании или редактирования правил.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства правила

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Смотрите также:

Редактор таблиц


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Rule Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать правило для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные правила

Dependency tree - просматривать дерево зависимостей правил

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Свойства правила

На вкладке Rule задайте основные свойства правила.

Rule Editor - Editing rule definition

Название правила укажите в поле Name. Если оно должно выполняться вместо определенного события, то установите флажок Instead.

Таблицу или представление, для которой создаете правило, выберите из раскрывающегося списка For table or view.

Условия задайте в поле Condition.

Действия, которые должны выполняться задайте в поле Action.

Все инструменты для работы с текстом, доступные в редакторе запросов, доступны и в редакторе правил.

Для удобства работы с текстом правила осуществляется syntax highlight - подсветка синтаксиса и code folding - возможность задать иерархическую структуру текста с возможностью скрывать подобъекты. С помощью макросов можно записать и воспроизвести некоторые действия.

Существует возможность записи и использования макросов.

Кнопки для работы с макросами доступны на панели состояния в левой нижней части окна редактирования.

Чтобы начать запись макроса, нажмите кнопку btnRecordMacro Record, или используйте сочетание клавиш Shift + Ctrl + R.

Чтобы остановить запись, нажмите кнопку btnStopRecordMacro Stop, или используйте сочетание клавиш Shift + Ctrl + R.

Для вызова записанный макрос, используйте кнопку воспроизведения btnPlayMacro Play, или используйте сочетание клавиш Shift + Ctrl + P.


Триггеры

Триггер — это особая разновидность хранимой процедуры, выполняемая автоматически при возникновении события на сервере базы данных.

Этот редактор предназначен для создании или редактирования триггеров.

Наиболее используемые операции вынесены на панели инструментов.

Все свойства триггера, размещаются в редакторе на нескольких вкладках.

Свойства триггера

Просмотр зависимостей объектов,

Текстовое описание объекта

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Trigger Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать триггер для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить

iconPrint Print - печатать метаданные триггера

Dependency tree - просматривать дерево зависимостей триггера

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Свойства триггера

Главные параметры триггера задаются на вкладке Trigger редактора триггеров.

Trigger Editor - Editing trigger definition

В поле Name указываете имя триггера.

CheckBox Enabled - установите этот флажок, если хотите, чтобы триггер был включен.

Из раскрывающегося списка For table or view выбираете таблицу или представление, для которого создаете триггер. Поле доступно для редактирования только при создании триггера.

Constraint

При указании данной опции создается триггер ограничения с настраиваемым временем срабатывания.

CheckBox Referenced table

Укажите таблицу для создания триггера.

CheckBox Deferrable

Данная опция создает отложенный триггер, который срабатывает в конце содержащей его транзакции, а не в конце оператора, вызвавшего целевое событие.

Check time

Выберите режим срабатывания ожидающего отложенного триггера: Immediate - немедленно, или Deferred -отложить.

Далее, с помощью переключателя Type, указываете тип поведения триггера.

RadioButton Если выбран тип Before, то триггер срабатывает до указанного события.

RadioButton Если указан тип After, то триггер срабатывает только после успешного выполнения всех операций в инструкции SQL, запускаемой триггером. Все каскадные действия и проверки ограничений, на которые имеется ссылка, должны быть успешно завершены, прежде чем триггер сработает.

В разделе For each укажите для каких объектов выполняется триггер.

RadioButton Row - для каждой строки,

RadioButton Statement - для каждого оператора.

On Event

В этом разделе выбирается событие, которое после выполнения вызывает срабатывание триггера.

Можете выбрать одно или несколько событий из предложенных: Insert, Update, Delete или Truncate.

Из раскрывающегося списка Updated columns можно выбрать столбцы, которые будут обновляться.

Condition

В этом поле можно задать условие оператора WHEN для триггера.

Важно: Это поле доступно для сервера PostgreSQL версии 9.0 и выше.

На вкладке Function задайте основные свойства триггера.

RadioButton Для создания триггера Вы можете использовать имеющуюся на сервере функцию. Для этого необходимо установить Use existing function и выбрать одну из уже созданных функций из раскрывающегося списка Function name.

RadioButton Укажите Create new function, если хотите создать новую функцию. Язык создаваемой функции выберите из раскрывающегося списка Language.

Существует возможность записи и использования макросов.

Кнопки для работы с макросами доступны на панели состояния в левой нижней части окна редактирования.

Чтобы начать запись макроса, нажмите кнопку btnRecordMacro Record, или используйте сочетание клавиш Shift + Ctrl + R.

Чтобы остановить запись, нажмите кнопку btnStopRecordMacro Stop, или используйте сочетание клавиш Shift + Ctrl + R.

Для вызова записанный макрос, используйте кнопку воспроизведения btnPlayMacro Play, или используйте сочетание клавиш Shift + Ctrl + P.

На вкладке Arguments задайте аргументы функции.

Trigger Editor - Editing trigger definition - Arguments

Создать аргумент можно с помощью кнопки iconPlus или пункта контекстного меню Add Argument.

Чтобы удалить аргумент нужно нажать на кнопку iconMinus или выбрать пункт Delete Argument в контекстном меню, которое открывается при нажатии правой кнопкой мыши на нужном аргументе.

Порядок аргументов в списке можно изменить с помощью кнопок btnMoveUp btnMoveDown или пунктов Move Up и Move Down в контекстном меню.


Последовательности

Последовательности - метод построения последовательности пронумерованных списков. Последовательности может использоваться во всей базе данных, (если пользователи имеют доступ к последовательности). Каждый раз, когда пользователь обращаться к последовательности, значение ее порядкового номера увеличивается. Это обеспечивает одноразовое использование определенного номера. Таким образом, последовательности могут использоваться для создания уникальных номеров. При работе с последовательностями пользователю не нужно беспокоиться о транзакциях, поскольку база данных обеспечивает, чтобы внутри нее каждый номер использовался только один раз.

В редакторе Вы можете создавать и редактировать последовательности.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства последовательности

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Sequence Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать последовательность для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей последовательностей

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение последовательностей

Основные свойства последовательности задайте на вкладке Sequence.

Sequence Editor - Editing sequence definition

Имя последовательности указывается в поле Name. Из раскрывающегося списка выбирается имя схемы, которой будет принадлежать этот объект.

Следующее или начальное значение последовательно укажите в поле Next/Start value. Start value появляется при создании новой последовательности.

Значение шага последовательности можно задать в поле Increment.

В полях Min value и Max value укажите минимальное и максимальное значения последовательности.

В поле Cache задайте количество номеров последовательностей хранимых в памяти для быстрого доступа.

CheckBox Если установлен флажок Temporary, то последовательность будет являться временной. Флажок активен только при создании объекта.

CheckBox Чтобы последовательность была цикличной, установите флажок Cycle.


Типы данных

Пользователь может создавать тип данных, который сформирован на основании стандартного типа.

Базовые типы — это такие типы как int4, которые реализуются на более низком уровне, чем язык SQL (обычно на языке низкого уровня, таком как C).

Составные типы данных строятся на основании других типов, поэтому необходимы дополнительные функции, указывающие как должен использоваться конкретный тип.

Создание типа

Для создания типа данных используйте:

  • пункт Database | New Object главного меню программы в окне выбора типа объекта надо выбрать Type,
  • или выбрать контекстное меню объекта базы данныхTypes | пункт New Type,
  • если нужно создать составной тип данных, то в контекстном меню выберите пункт New Composite Type,
  • или сочетание клавиш <Ctrl + N>.

Изменение типа

Изменять свойства типа данных в редакторе типов можно для составных и перечислимых типов.

Чтобы открыть тип данных в редакторе типов достаточно двойного щелчка мыши на объекте в проводнике баз данных. Также можно это сделать, выбрав пункт контекстного меню типа Edit type <имя объекта>.

Копирование типа

Для копирования объектов существует специальный мастер, потому что объект можно копировать в другую базу данных, а так же с данными или без них.

Для копирования типа необходимо выбрать пункт Duplicate Type<имя объекта> в контекстном меню типа. Если Вы копируете объект таким образом, то Мастер копирования объектов открывается сразу на третьем шаге, так как на первых двух шагах выбирается база данных и объект, а в данном случае это не нужно.

Удаление типа

Для того чтобы удалить последовательность, необходимо в проводнике баз данных выбрать для нужного пункт контекстного меню Drop Type<имя объекта> или использовать сочетание клавиш <Ctrl + Del>


Базовые типы данных

Пользователь может создавать тип данных, который сформирован на основании стандартного типа.

Базовые типы — это такие типы как int4, которые реализуются на более низком уровне, чем язык SQL (обычно на языке низкого уровня, таком как C).

Этот редактор предназначен для создания базовых типов данных.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Редактирование описания базовых типов

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Base Type Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать тип для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей типов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование описания базовых типов

На вкладке Type указываете параметры определенного пользователем типа данных.

Base Type Editor - Editing base type definition

В поле Name задайте имя создаваемого типа. Из раскрывающегося списка выберите имя схемы, которой будет принадлежать этот тип данных.

Синоним типа укажите в поле Synonym.

При редактировании базового типа данных Вы сможете изменить только схему данных, которой принадлежит редактируемый объект.

Input function

Из этого раскрывающегося списка выберите функцию, конвертирующую данные из внешней текстовой формы во внутреннюю.

Output function

Из этого раскрывающегося списка выберите функцию, конвертирующую данные из внутренней текстовой формы во внешнюю.

Internal length

С помощью этого счетчика укажите длину (в байтах) внутреннего представления создаваемого типа данных.

CheckBox Variable

Если установлен флажок Variable, то длина внутреннего представления будет переменной.

Analyze function

Из этого раскрывающегося списка выберите функцию, которая будет выполнять статистический анализ типа данных.

Receive function

Из этого раскрывающегося списка выберите функцию, которая будет конвертировать данные из внешней бинарной формы типа во внутреннюю.

Send function

Из этого раскрывающегося списка выберите функцию, которая будет конвертировать данные из внутренней бинарной формы типа во внешнюю.

Element

Если тип был создан как массив, выберите из этого раскрывающегося списка тип элементов массива.

Default

Если необходимо, укажите значение по умолчанию для этого типа данных. По умолчанию таким значением является NULL.

Alignment

Из этого раскрывающегося списка выберите вид упорядочивания данных в памяти типа: char, int2, int4, или double.

Delimiter

При необходимости укажите разделительный символ, который будет использоваться для разделения значений в массиве.

Storage

Из этого раскрывающегося списка выберите метод хранения для типа данных: PLAIN, MAIN, EXTERNAL, EXTENDED.

CheckBox Passed by value

Если флажок установлен, то в этом типе данных передача параметров по значению осуществляется скорее, чем по ссылке.


Составные типы данных

Пользователь может создавать тип данных, который сформирован на основе стандартного типа.

Составные типы данных строятся на основании других типов, поэтому необходимы дополнительные функции, указывающие как должен использоваться конкретный тип.

Этот редактор предназначен для создания и редактирования типов данных.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Редактирование описания составных типов

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Composite Type Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать тип для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей типов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование описания составных типов

Если при создании типа Вы выбрали составной тип данных, то вкладка Type редактора типов будет иметь такой вид.

Composite Type Editor - Editing composite type definition

Имя и схему создаваемого типа задайте в поле Name.

В таблице Column содержатся простые типы данных, содержащихся в этом составном.

Управление типами в таблице Column осуществляется с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши в любой части таблицы.

С помощью этого меню можно:

  • добавить тип - Add Column,
  • удалить тип - Delete Column,
  • переместить вверх - Move Up,
  • Переместить вниз - Move Down.

Для типа данных можно указать следующие параметры:

  • имя - Attribute Name,
  • тип данных - Attribute Data Type,
  • размер - Size,
  • точность представления данных - Precision,
  • размерность массива - Number of array dims.


Перечислимые типы

Тип данных, заданный исчерпывающим списком всех возможных значений для переменных этого типа.

В редакторе Вы можете создавать и редактировать перечислимые типы данных.

Наиболее часто используемые операции вынесены на панели инструментов.

Вкладки

Панели инструментов

Редактирование описания перечислимых типов

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

ENUM Type Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать тип для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей типов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование описания перечислимых типов

В Редакторе перечислимых типов, на вкладке ENUM Type Вы можете задать основные настройки редактируемого или создаваемого объекта.

ENUM Type Editor - Editing ENUM type definition

Name

Из раскрывающегося списка выберите Схему, а в поле введите имя объекта.

Values

В этой таблице содержится список значений перечислимого типа.

Управлять списком значений Вы можете с помощью контекстного меню, открывающегося при нажатии на таблицу правой кнопкой мыши.

С помощью этого меню Вы можете:

  • Добавить значение в список - Add Value,
  • Удалить значение из списка - Delete Value,
  • Переместить значение выше - Move Up,
  • Переместить значение ниже - Move Down.

Name

В этом столбце укажите значение перечислимого типа.


Диапазонные типы

Диапазонный тип - это тип данных, представляющий собой диапазон значений встроенного типа данных (называемого подтипом диапазона). У подтипа должно быть задано отношение полного порядка, так, чтобы можно было определить, входит ли заданное значение в диапазон или нет.

В редакторе Вы можете создавать и редактировать перечислимые типы данных.

Наиболее часто используемые операции вынесены на панели инструментов.

Вкладки

Панели инструментов

Редактирование описания диапазонных типов

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Range Type Editor - Using Navigation bar and Toolbar

Object

iconDB Выбрать базу данных

Выбрать тип для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей типов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование описания диапазонных типов

В Редакторе диапазонных типов, на вкладке Range Type Вы можете задать основные настройки редактируемого или создаваемого объекта.

Range Type Editor - Editing range type

Name

Из раскрывающегося списка выберите Схему, а в поле введите имя объекта.

Subtype

Из раскрывающегося списка выберите подтип диапазонного типа. Подтип может быть любого типа со связанным классом оператора B-tree (чтобы значения диапазонного типа были упорядочены).

Если значения выбранного типа могут быть отсортированы, но Вы не хотите использовать сортировку по умолчанию, выберете желаемый тип сортировки в поле Collaltion.

Subtype operator class

Введите класс оператора для подтипа. Если оставить поле пустым, то будет использован класс оператора, заданный по умолчанию для данного подтипа.

Canonical function

В этом поле введите имя канонической функции. Входным параметром функции является значение диапазона; возвращаемое значение - равнозначный диапазон, у которого могут быть другие границы и форматирование.

Subtype difference function

Из раскрывающегося списка выберите разностную функцию. Входные параметры функции - два значения заданного подтипа; возвращаемое значение - их разность.

Чтобы создать новую функцию, нажмите на кнопку btnAddFunction . Чтобы открыть выбранную функцию в редакторе функций, нажмите на кнопку btnEditFunction .


Агрегатные функции

Агрегатные функции используются для выполнения таких вычислений с данными как определение максимального, минимального или среднего значения

В редакторе Вы можете создавать и редактировать агрегатные функции.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства агрегатной функции

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Aggregate Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать функцию для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей функций

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение агрегатных функций

На вкладке Aggregate задайте основные параметры агрегатной функции.

Aggregate Editor - Editing aggregate definition

В поле Name задайте название агрегатной функции.

Тип данных, для которых применяется агрегатная функция, выберите из раскрывающегося списка Input data type.

State Type - тип данных для состояния агрегатной функции.

Из списка State Function выберите функцию изменения состояния.

Final Type - тип данных для результата функции,

Final Function - итоговая функция, которая вызывается для подведения итогов выполнения агрегатной функции.

В поле Initial State укажите начальное состояние.

Из раскрывающегося списка Sort operator выберите оператор сортировки для MIN- or MAX-like aggregates.


Операторы

Объект, который определяет правила использования наборов символов в качестве операций над данными определенных типов.

Этот редактор предназначен для создания операторов.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства оператора

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Operator Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать оператор для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей операторов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение операторов

На вкладке Operator задайте основные свойства оператора.

Operator Editor - Editing operator definition

В поле Name задайте имя оператора. Из раскрывающегося списка выберите имя схемы, которой будет принадлежать этот объект.

Функцию для определения оператора выбираете из Function.

Left operand type - тип левого операнда, если установлен флажок CheckBox Support hash joins, то будет поддерживаться соединение hash.

Right Operand Type - тип правого операнда, если установлен флажок CheckBox Support merge join, то будет поддерживаться соединение merge.

Commutator - коммутатор.

Negator - элемент отрицания.

Restrict Function - ограничивающая функция.

Join Function - соединяющая функция.

Left Sort Operator - оператор левой сортировки.

Right Sort Operator - оператор правой сортировки.

Less Than Operator - оператор "меньше".

Greater Than Operator - оператор "больше".


Сортировки

В объекте "сортировка" задается функция сравнения, которая определяет порядок сортировки и способ классификации символов данных. Благодаря этому можно изменить значения параметров LC_COLLATE и LC_CTYPE, заданных при создании базы данных.

Этот редактор предназначен для создания сортировок.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства сортировки

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Collations- Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать сравнение для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей сравнений

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Свойства сортировки

На вкладке Collation можно задать все необходимые параметры объекта.

Name

В этом поле необходимо указать имя объекта. Из раскрывающегося списка можно выбрать схему, которой данный объект будет принадлежать.

Locale

Это синоним для параметров LC_COLLATE и LC_CTYPE сразу. Если задано значение в этом поле, то поля Collation order и Character classification становятся неактивными.

Collation order (lc_collate)

В этом поле необходимо указать текущую локализацию операционной системы. Настройки должны быть применимы к текущей кодировке базы данных.

Character classification (lc_ctype)

В этом поле необходимо указать текущую локализацию операционной системы. Настройки должны быть применимы к текущей кодировке базы данных.

Existing collation to copy from (existing_collation)

В это поле можно ввести название существующей сортировки, из которой будут скопированы настройки. Новая сортировка будет иметь те же параметры, что и указанная, но это будет независимый объект.


Статистики

В объекте "статистика" собирается расширенная статистика по выбранной таблице.

Этот редактор предназначен для создания новой или изменений параметров уже существующей статистики..

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Редактор статистик

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL


Статистики

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Statistics- Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать статистику для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей сравнений

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактор статистик

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Редактор статистики

На этой вкладке вы можете задать свойства новой или редактировать уже существующую статистику.

Statistics Editor - Editing range type

Name

Укажите имя статистики.

Table

Выберите таблицу, для которой необходимо собирать статистические данные.

Owner

Укажите владельца текущего объекта.

Columns

Выберите колонки (минимум две), для которых необходимо вести расчет статистики.

Kind

Выберите тип статистики. Если ни одна из опций не будет выбрана, то будет производиться расчет по всем типам статистики.

CheckBox N-distinct

CheckBox Functional dependency

CheckBox Most-common values

Expression

Укажите выражение для вычисления статистических данных.


Прочие объекты

В этом разделе представлены типы объекты, которые можно создавать и редактировать с помощью SQL, но которые не принадлежат схеме.

Табличные пространства

Языки описания процедур

Используйте проводник баз данных, чтобы управлять этими объектами.

Смотрите также:

Основные операции над объектами

Новый объект

Мастер копирования объекта

Схемы

Объекты схем


Триггеры на события

Триггер на событие срабатывает, когда наступает связанное с ним событие в базе данных. В отличие от триггеров, которые связаны с отдельной таблицей и захватывают только DML события, триггеры на события являются глобальными в рамках одной базы данных и обработывают DDL события.

В редакторе Вы можете создавать и редактировать триггеры на события.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства триггера на событие

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Event Trrigger Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать триггер на событие

General

iconCompile Compile - компилировать объект при создании или редактировании

iconSaveDescription Save description - сохранить описание текущего объекта

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей объекта

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение триггеров на события

На вкладке Trigger укажите основные параметры триггера на событие.

Event Trrigger Editor - Editing event trigger

В поле Name укажите имя триггера.

CheckBox Enabled - установите этот флажок, если хотите, чтобы триггер был включен.

Event

Выберите тип события, при котором триггер должен срабатывать.

RadioButton Before DDL command

Эта опция соответствует событию ddl_command_start сервера PosgreSQL. Это событие происходит непосредственно перед выполнением команд CREATE, ALTER, DROP. Перед запуском триггера не производится проверка на существование модифицируемого объекта.

RadioButton After SQL drop

Эта опция соответствует событию sql_drop сервера PosgreSQL. Это событие происходит непосредственно перед триггером на событие ddl_command_end любой операции по удалению объектов базы данных.

RadioButton After DDL command

Эта опция соответствует событию ddl_command_end сервера PosgreSQL. Это событие происходит непосредственно после выполнения команд CREATE, ALTER, DROP.

Command filter

Вы можете выбрать команды, при выполнении которых должен срабатывать редактируемый триггер на событие. Из списка Available Commands выберите доступные команды и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available перенесите их в список выбранных команд - Selected Commands, или перетащите мышкой из одного списка в другой.

Если Вы хотите, чтобы триггер срабатывал при выполнении всех команд выбранного события, установите флажок CheckBox Fire on all commands.

В нижней области редактора задайте свойства триггера на событие.

RadioButton Для создания триггера на событие Вы можете использовать имеющуюся на сервере функцию. Для этого необходимо установить Use existing function и выбрать одну из уже созданных функций из раскрывающегося списка Function name.

RadioButton Укажите Create new function, если хотите создать новую функцию. Язык создаваемой функции выберите из раскрывающегося списка Language.


Табличные пространства

Табличные пространства позволяют привилегированному пользователю определять альтернативное место расположения файлов в которых хранятся данные базы данных.

В редакторе Вы можете создавать и редактировать табличные пространства.

Наиболее используемые операции вынесены на панели инструментов.

Вкладки

Свойства табличного пространства

Просмотр зависимостей объектов

Просмотр DDL


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Tablespace Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать оператор для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconSaveDescription Save description - сохранить описание текущего объекта

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей табличных пространств

iconMoveToTablespace Move all objects to - перенести все объекты редактируемого табличного пространства в другое табличное пространство

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Определение табличных пространств

На вкладке Tablespace укажите основные параметры табличного пространства.

Tablespace Editor - Editing tablespace definition

В поле Name укажите имя объекта, из раскрывающегося списка Owner выберите владельца. Владельцем может быть группа или отдельный пользователь.

В поле Location укажите расположение редактируемого табличного пространства.

В нижней части формы, в разделе Size отображается текущий размер редактируемого табличного пространства.


Языки описания процедур

PostgreSQL позволяет создавать функции на различных языках программирования, базирующихся на таких языках как SQL и C. такие языки программирования называются процедурными (PLs). В PostgreSQL используются следующие языки описания процедур: PL/pgSQL, PL/Tcl, PL/Perl, PL/Python.

В редакторе Вы можете создавать и редактировать языки описания процедур.

Наиболее используемые операции вынесены на панели инструментов.

Все свойства объекта, размещаются в редакторе на нескольких вкладках. Это:

Свойства языка

Просмотр зависимостей объектов

Текстовое описание объекта

Просмотр DDL

Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Language Editor - Using Navigation bar

Object

iconDB Выбрать базу данных

Выбрать язык для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей объектов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование языка описания процедур

На вкладке Language редактора процедурных языков задайте основные свойства процедурного языка.

Language Editor - Editing language definition

В поле Name укажите имя создаваемого языка.

CheckBox Установленный флажок Trusted указывает на то, что язык является доверенным языком сервера. Это означает что пользователи, не обладающие дополнительными правами, могут использовать этот язык для создания функций и процедур.

Функцию обработки выберите из раскрывающегося списка Handler function. Из списка Validator function выберите функцию проверки.


Внешние сервера

Для доступа к внешним данным необходимо создать объект внешний сервер, который определяет как подключаться к конкретному источнику данных, в соответствии со списком опций, используемых конкретным обработчиком внешних данных.

В редакторе Foreign Server Editor Вы можете создавать и редактировать внешние сервера.

  • Панели инструментов
  • Редактирование внешнего сервера
  • Настройка опций подключения для пользователей
  • Просмотр зависимостей объектов
  • Текстовое описание объекта
  • Просмотр DDL
  • Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Foreign Server Editor - Using Navigation bar

Object

iconDB выбрать базу данных

выбрать внешний сервер для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconSaveDescription Save description - сохранить описание текущего объекта

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей табличных пространств

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование внешнего сервера

Name

Введите имя нового или отредактируйте имя существующего внешнего сервера.

Foreign Server Editor - Editing foreign server

Foreign data wrapper

Из выпадающего списка выберите обработчик внешних данных для внешнего сервера.

Server type

Введите тип внешнего сервера.

Version

Введите версию внешнего сервера.

Options

В таблице с полями Name и Value задайте опции сервера. Данные опции используются для задания настроек подключения к серверу, но конкретные имена и значения опций зависят от выбранного обработчика внешних данных.


Настройка опций подключения для пользователей

На вкладке User Mapping задайте дополнительные настройки подключения для пользователей.

Foreign Server Editor - User mapping

Чтобы добавить настройки для роли, используйте пункт контекстного меню New User Mapping.

Чтобы отредактировать настройки для роли, используйте пункт контекстного меню Edit User Mapping.

Foreign Server Editor - User mapping - User Mapping

В диалоге User Mapping задайте имя пользователя и пароль для выбранной в поле Role роли. Чтобы добавлять / удалять опции используйте пункты контекстного меню New Option и Delete Option(s).


Обработчики внешних данных

Доступ к внешним данным осуществляется при помощи обработчика внешних данных (Foreign Data Wrapper). Обработчик внешних данных — это некая библиотека, которая может устанавливать соединение с внешними источниками данных, скрывая подробности подключения к источнику данных и извлечения данных из него.

В редакторе Foreign Data Wrapper Editor Вы можете создавать и редактировать обработчики внешних данных.

  • Панели инструментов
  • Редактирование обработчиков внешних данных
  • Просмотр зависимостей объектов
  • Текстовое описание объекта
  • Просмотр DDL
  • Назначение прав


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Foreign Data Wrapper Editor - Using Navigation bar

Object

iconDB выбрать базу данных

выбрать обработчик внешних данных для редактирования

General

iconCompile Compile - компилировать объект при создании или редактировании

iconSaveDescription Save description - сохранить описание текущего объекта

iconRefresh Refresh - обновить редактируемый объект

iconPrint Print - печатать метаданные объекта

Dependency tree - просматривать дерево зависимостей табличных пространств

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Description (для вкладки Description)

iconSaveToFile Save description to file - сохранить описание в файл

iconCopyToClipboard Copy description to clipboard - копировать описание в буфер обмена

DDL (для вкладки DDL)

iconSaveToFile Save DDL to file - сохранить DDL описание в файл

Open DDL in Execute Script - открыть DDL в редакторе выполнения скриптов

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Редактирование обработчиков внешних данных

Name

Введите имя нового или отредактируйте имя существующего обработчика внешних данных.

Foreign Data Wrapper Editor - Editing foreign data wrapper

Handler function

Из выпадающего списка выберите ранее созданную функцию, которая будет вызываться для получения функций, исполняемых для внешних таблиц. У функции-обработчика не должно быть аргументов, а тип возвращаемого значения - fdw_handler.

Чтобы создать обработчик внешних данных без функции-обработчика, отметьте опцию No handler.

Validator function

Из выпадающего списка выберите ранее созданную функцию, которая будет использоваться для проверки настраиваемых опций, передаваемых обработчику внешних данных, а также опций внешних серверов, пользователей и внешних таблиц.

Если отмечена опция No validator, то опции не проверяются во время создания.

Options

В таблице с полями Name и Value задайте опции обработчика внешних данных. Допустимые имена опций и значения настраиваются отдельно для каждого обработчика внешних данных и проверяются заданной функцией Validator function.


Локальные скрипты

Раздел Local Scripts в проводнике базы данных, позволяет получить доступ к сохраненным скриптам из проводника баз данных и работать со скриптами, как с объектами базы данных.

Для создания нового локального скрипта выберите пункт iconNewScript New Script в контекстном меню соответствующей ветви в дереве проводника баз данных . Имя скрипта необходимо задать в появившемся диалоговом окне New Script.

Local Script - Setting script name

В разделе Local Scripts можно создавать дополнительные подразделы. Для этого необходимо в контекстном меню скрипта или группы скриптов выбрать пункт iconNewSubFolder New Script Folder. Такие директории могут быть директориями, используемыми по умолчанию для скриптов, которые задаются в DB Registration info | Directories. Если на момент задания директории, в ней уже присутствовали скрипты, то они будут добавлены в дерево автоматически.

Для изменения скрипт открывается в SQL Script. В этом же редакторе можно создать скрипт и сохранить его как локальный.

Локальный скрипт можно сохранить как общий.

Смотрите также:

Редактор SQL скриптов

Проводник баз данных

Общие скрипты

Регистрационная информация баз данных


Общие скрипты

При подключении базы данных к системе контроля версий в дереве базы данных в проводнике баз данных появляется дополнительный раздел iconSharedscripts Shared scripts.

Общие скрипты - это скрипты, хранящиеся в директории репозитория. Это позволяет сделать скрипты доступными для всех пользователей, работающих с этой базой данных и подключенных к системе контроля версий.

Любой скрипт, открытый в Редакторе SQL скриптов может быть сохранен как общий.

Скрипт, сохраненный не в директорию, указанную в поле Working folder на вкладке Database registration info | Change management, не будет доступен как общий скрипт.

Скрипты, создающиеся при выполнении Публикации базы данных добавляются в директорию Shared scripts.

В разделе Shared Scripts можно создавать дополнительные подразделы. Для этого необходимо в контекстном меню скрипта или группы скриптов выбрать пункт iconNewSubFolder New Script Folder. Созданные директории автоматически появляются в рабочей директории Системы контроля версий.

Для изменения и редактирования общие скрипты открываются в Редакторе SQL скриптов.

Смотрите также:

Редактор SQL скриптов

Проводник баз данных

Локальные скрипты

Регистрационная информация баз данных


Управление изменениями

Набор инструментов Change Management позволяет управлять инструментами, необходимыми для работы с системами контроля внесения изменений. Чтобы иметь возможность использовать эти инструменты необходимо подключиться к системе контроля версий.

Система контроля версий может быть полезна для одиночных разработчиков, в базах которых сложная бизнес-логика (в процедурах, триггерах и т.п.), и им нужен контроль изменений этих объектов, подобный тому, который используется разработке программ.

В системе контроля версий хранится служебная информация о самой базе, добавленной в систему, о базах, привязанных к конкретной ветке и т.п. Если резервная копия создается на клиентском компьютере, резервная копия для метки хранится в системе контроля версий, если же резервная копия создается на сервере – в системе контроля версий хранится только информация о том, где расположена эта копия на сервере.

Инструменты контроля изменений:

Создание ветви/метки/тега

Извлечение данных из репозитория

Получение скрипта изменений

Публикация новой версии базы данных

История изменений

Доступ к этим инструментам можно получить следующим образом:

Выбрать в главном меню программы пункт Tools | Change Management.

В контекстном меню сервера и контекстном меню базы данных выбрать пункт Change Management.

Для конкретного объекта базы данных можно посмотреть только историю изменений.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Создание ветви/метки/тега

Тег, метку и ветвь можно создать с помощью одного мастера - Create Tag wizard.

Тег (Tag) - специальная метка, обозначающая определенное состояние базы данных. (Это тег для всех файлов репозитория БД указанной ветки в системе контроля версий.)

Ветвь (Branch) - направление разработки, независимое от других. Ветвь представляет собой копию БД, в которую можно вносить свои изменения, не влияющие на оригинальную БД (БД главной ветки). Объекты в разных ветвях имеют одинаковую историю до точки ветвления и разные - после неё. При создании ветки всегда создается и метка. (Это ветка для всех файлов репозитория БД в системе контроля версий плюс копия оригинальной БД.)

Метка (Label) - специальная метка, обозначающая определённое состояние базы данных. Содержит резервную копию БД. При наличии метки можно в любой момент создать новую ветку на состояние, которое было в момент создания метки, либо получить копию БД на тот момент. (Это тег плюс резервная копия БД)

Для запуска этого мастера необходимо в контекстном меню сервера или контекстном меню базы данных выбрать пункт Change Management | Create Branch/Label/Tag.

Также можно выбрать в главном меню программы пункт Tools | Change Management | Create Branch/Label/Tag.

Мастер состоит из следующих шагов:

Выбор исходной базы данных

Выбор действия

Задание параметров создаваемого объекта

Задание настроек подключения

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Извлечение данных из репозитория

Получение скрипта изменений

Релиз новой версии базы данных

История изменений


Выбор исходной базы данных

На этом шаге необходимо выбрать базу данных. Если база данных не подключена к системе контроля изменений, то перейти на следующий шаг будет невозможно.

Create Branch-Label-Tag - Select source database

В поле Source database выберите базу данных.

Следующий шаг


Выбор действия

На этом шаге необходимо выбрать тип операции, которая должна быть выполнена.

Create Branch-Label-Tag - Select operation

RadioButton Create branch - создать ветвь базы данных.

CheckBox From existing label - создать ветвь из существующей метки. Из раскрывающегося списка необходимо выбрать одну из существующих меток.

RadioButton Create label - создать метку.

RadioButton Create tag - создать тег.

RadioButton Create database from label - создать базу данных из существующей метки. Метка выбирается из соответствующего раскрывающегося списка.

В поле Tag name указывается название создаваемого объекта.

CheckBox Move tag/label if it already exists

При установке этого флажка одноименный существующий тег или метка будут заменены создаваемым.

Следующий шаг

При создании тега переход осуществляется сразу на последний шаг.


Задание параметров создаваемого объекта

Этот шаг доступен, только если создается метка.

На этом шаге необходимо задать параметры создаваемой метки.

Create Branch-Label-Tag - Create branch

В разделе Backup storage location задайте параметры сохранения резервной копии базы данных.

RadioButton Version Control Repository - резервная копия будет сохранена в репозитории системы управления изменениями.

RadioButton Separately - резервная копия будет сохранена в отдельную директорию, заданную в поле ниже.

Для создаваемой метки можно задать дополнительный параметр.

CheckBox Backup metadata only - если установлен этот флажок, то резервная копия будет создана только для метаданных базы.

Следующий шаг


Задание настроек подключения

Этот шаг доступен, только когда выбран Create database from label или Create branch на втором шаге.

На этом шаге задайте параметры новой базы данных.

Create Branch-Label-Tag - Specify database destination

Из раскрывающегося списка Host name выбрать сервер (хост), к которому надо подключиться. В этот список попадают имена уже зарегистрированных серверов.

В поле Port задайте порт для подключения.

Укажите имя пользователя и пароль в полях User name и Password.

В поле Database name отображается имя базы данных.

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Create Branch-Label-Tag - Run

В текстовом поле показаны все производимые действия и результат их выполнения.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Мастер проверки состояния репозитория СКВ

Мастер Check version control Repository позволяет выявить несоответствия текущего состояния базы данных и его описания в репозитории, а также внести соответствующие исправления в репозиторий. Использование этого мастера необходимо, если хотя бы один пользователь базы данных производил изменения структуры этой базы без их синхронизации с репозиторием, сопоставленным этой базе данных.

Для запуска этого мастера необходимо в контекстном меню сервера или контекстном меню базы данных выбрать пункт Change Management | Check Repository.

Также можно выбрать в главном меню программы пункт Tools | Change Management | Check Repository.

Мастер состоит из следующих шагов:

Выбор базы данных

Выбор типов объектов

Проверка состояния репозитория

Задание действий для каждого изменения

Выбор и удаление из репозитория пропущенных объектов

Проверка и корректировка скрипта изменений

Добавление комментариев

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Создание ветви/метки/тега

Получение скрипта изменений

Релиз новой версии базы данных

История изменений


Выбор базы данных

На этом шаге необходимо выбрать базу данных. Если база данных не подключена к системе контроля изменений, то перейти на следующий шаг будет невозможно.

Check Repository - Select Database

В поле Database to check выберите базу данных для проверки репозитория.

Следующий шаг


Выбор типов объектов

На этом шаге выберите тип объектов, описание которых нужно проверить на соответствие с текущим состоянием в базе данных.

Check Repository - Select objects types

RadioButton Check the whole database - выбрать все объекты базы данных.

RadioButton Check selected object types only - выбрать объекты определенных типов. Проверка только некоторых типов объектов выполняется быстрее. При этом необходимо знать, с какими типами объектов производились изменения.

Флажками необходимо отметить типы объектов, информация по которым будет обновлена.

Следующий шаг


Проверка состояния репозитория

После того, как на предыдущих шагах Вы задали необходимые опции, нажмите кнопку Run, для проверки состояния репозитория.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Check Repository - Check Repository

В текстовом поле показаны все производимые действия и результат их выполнения.

Ошибками считаются различия описаний объектов в репозитории и текущего их состояния в базе данных.

Если они найдены, то необходимо внести изменения только в репозиторий так, чтобы он соответствовал текущему состоянию базы данных.

В случае обнаружения ошибок будет доступна кнопка Next для перехода на шаги исправления репозитория.

Выполнить проверку репозитория ещё раз можно с помощью кнопки Check Again.

Следующий шаг


Задание действий для каждого изменения

На этом шаге отображаются в виде дерева все объекты и подобъекты, которые были изменены и чьи изменения не попали в репозиторий.

Check Repository - Specify action

Для каждого найденного несоответствия необходимо выбрать в столбце Action действие, а в столбце Replacement - необходимое изменение. Список Replacement заполняется теми объектами, которые есть в репозитории системы контроля версий, но которых нет в базе данных. database.

Create New - добавить описание объекта в репозиторий.

Replace Existing - заменить описание в репозитории существующего объекта (существующий объект при этом выбирается в выпадающем списке справа) описанием нового объекта. Можно использовать Replace existing, если объект в базы данных был переименован.

Следующий шаг


Выбор и удаление из репозитория пропущенных объектов

На этом шаге отображаются объекты, которые есть в репозитории, но нет в базе данных. Удалить объект из репозитория можно установив флажок напротив его названия.

Check Repository - Select missed objects

Следующий шаг


Проверка и корректировка скрипта изменений

На этом шаге отображается скрипт изменений, соответствующих действиям, выбранным на предыдущих шагах. Этот скрипт не является выполняемым. Он будет сохранен в репозитории.

Check Repository - Check and correct script

Следующий шаг


Добавление комментариев

На этом шаге можно задать комментарии, описывающие изменения, которые будут записаны в репозиторий.

Check Repository - Specify comments

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Check Repository - Run

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Получение скрипта изменений

Мастер получения скрипта изменений - Get Change Script Wizard - используется для генерации скриптов, позволяющих изменить состояние базы данных. В качестве исходного и целевого состояния может быть выбрано любое состояние базы данных в истории системы контроля версий.

Для запуска этого мастера необходимо в контекстном меню сервера или контекстном меню базы данных выбрать пункт Change Management | Get change script.

Также можно выбрать в главном меню программы пункт Tools | Change Management | Get change script.

Мастер состоит из следующих шагов:

Выбор исходной базы данных

Выбор метода генерации

Задание начальных и конечных точек

Задание комментариев

Задание параметров сохранения

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Создание ветви/метки/тега

Извлечение данных из репозитория

Релиз новой версии базы данных

История изменений


Выбор исходной базы данных

На этом шаге необходимо выбрать базу данных. Если база данных не подключена к системе контроля изменений, то перейти на следующий шаг будет невозможно.

Get Change Script - Select Database

В поле Source Database выберите базу данных для которой нужно получить скрипт изменений.

Следующий шаг


Выбор метода генерации

На этом шаге выберите способ генерации скрипта.

Get Change Script - Select script generation method

RadioButton Generate step-by-step script (all changes from the change history) - создать скрипт, в котором изменения будут отображены пошагово в порядке их применения.

Скрипт будет содержать все операторы из истории изменений системы контроля версий в промежутке между исходным и целевым состояниями базы данных.

Такой тип генерации скрипта не может быть использован для получения скрипта "отката", т.е. в случае, когда исходное состояние базы данных является более поздним (в истории СКВ) по отношению к целевому состоянию.

RadioButton Generate differential script (by comparing states) - получить скрипт, в котором отражены изменения, полученные с помощью сравнения состояний баз данных.

Скрипт не будет содержать промежуточных изменений, например, нескольких изменений одной процедуры и т.п.

Следующий шаг


Задание начальных и конечных точек

На этом шаге укажите границы временного периода, за который будет сгенерирован скрипт изменений.

Get Change Script - Specify start and end points

Script start point

В этом разделе задайте начало периода, за который будет сформирован скрипт изменений.

RadioButton Tag - из этого раскрывающегося списка выберите тег, с которого надо начать формирование скрипта изменений.

Если тип генерации скрипта 'Step-by-Step', то список заполняется по следующему принципу. В список попадают все теги/метки текущей ветви, а также теги/метки родительских ветвей, но только такие, которые находятся "раньше" начала текущей ветви в истории СКВ, т.е. такие до которых можно построить путь в древовидной структуре СКВ по направлению от тегов текущей ветви к корню.

RadioButton Date - в этом поле выберите дату, с которой надо начать формирование скрипта изменений.

Script end point

В этом разделе указывается конец периода, за который будет сформирован скрипт изменений.

RadioButton Last revision of branch - последняя версия базы.

RadioButton Tag - один из существующих тегов.

RadioButton Date - дата, которой надо закончить формирование скрипта изменений.

Важно: при создании пошагового скрипта дата/тег целевого состояния должны быть более поздними по отношению к дате/тегу исходного состояния базы данных, в противном случае скрипт сгенерирован не будет.

Следующий шаг


Задание комментариев

На этом шаге выберите, какая дополнительная информация должна присутствовать в создаваемом скрипте в виде комментариев.

Get Change Script - Specify comments

CheckBox Add description - добавить комментарии.

CheckBox Script identification number - идентификационный номер скрипта.

CheckBox Date and time - дата и время генерации.

CheckBox User who had made a change - пользователь, внесший изменения.

CheckBox Comment that user had provided - комментарий, оставленный пользователем.

Следующий шаг


Задание параметров сохранения

На этом шаге задайте, куда будет сохранен скрипт.

Get Change Script - Specify script destination

RadioButton Automatically load to Script Editor - автоматически загрузить в редактор скриптов.

RadioButton Save to file - сохранить в файл.

File name - в этом поле укажите файл, в который будет сохранен создаваемый скрипт.

File charset - из этого раскрывающегося списка выберите кодировку создаваемого файла.

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Get Change Script - Run

В текстовом поле показаны все производимые действия и результат их выполнения.

CheckBox Load script to Script Editor - если установлен этот флажок, то сгенерированный скрипт будет автоматически загружен в редактор скриптов.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Публикация новой версии базы данных

Мастер публикации новой версии базы данных автоматизирует процессы, которые выполняются при выпуске новой версии БД. Позволяет получить скрипт изменений от предыдущей версии БД до текущей версии и протестировать его на предыдущей версии БД. Состоит из таких операций:

  1. Выполняется проверка репозитория в СКВ на точное соответствие состоянию БД (аналогично мастеру проверки состояния репозитория СКВ).
  2. Тегом или меткой помечается текущее место в репозитории БД в СКВ. Это нужно для того, чтобы в случае возникновения новых изменений была возможность получить скрипт дополнительных изменений с этой точки.
  3. Генерируется скрипт изменений от предыдущей версии до текущего состояния БД.
  4. Создается тестовая БД, например, из метки предыдущей версии, и скрипт проверяется на этой тестовой БД. После выполнения скрипта производится сравнение тестовой БД и текущей версии БД на наличие между ними различий.

Для запуска этого мастера необходимо в контекстном меню сервера или контекстном меню базы данных выбрать пункт Change Management | Release New Version of Database.

Также можно выбрать в главном меню программы пункт Tools | Change Management | Release New Version of Database.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Создание ветви/метки/тега

Извлечение данных из репозитория

Получение скрипта изменений

История изменений


Выбор баз данных

На первом шаге необходимо выбрать новую версию базы данных и предыдущую версию этой базы.

Release New Version - Select new and previous versions source

Из раскрывающегося списка New version database необходимо выбрать новую версию базы данных.

В разделе Previous version укажите параметры предыдущей версии базы данных

RadioButton In label взять предыдущую версию из одной из существующих меток.

RadioButton In database взять в качестве предыдущей версии одну из существующих баз данных. Выбрать ее нужно из раскрывающегося списка.

CheckBox Only test existing script

Если установлен этот флажок, то новый скрипт сравнения не будет генерироваться. Мастер сразу перейдет на шаг, где можно выбрать готовый файл скрипта сравнения и проверить его.

Следующий шаг

Если был установлен флажок CheckBox Only test existing script, то следующим шагом будет шаг выбора скрипта для проверки.


Выполнение проверки состояния репозитория

После выбора базы, нажмите кнопку Run, для проверки состояния репозитория.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Release New Version - Check the repository

В текстовом поле показаны все производимые действия и результат их выполнения.

Ошибками считаются различия описаний объектов в репозитории и текущего их состояния в базе данных.

Если они найдены, то необходимо внести изменения только в репозиторий так, чтобы он соответствовал текущему состоянию базы данных.

В случае обнаружения ошибок будет доступна кнопка Next для перехода на шаги исправления репозитория.

Выполнить проверку репозитория ещё раз можно с помощью кнопки Check Again.

CheckBox Skip error correction

Можно пропустить процедуру исправления репозитория, установив флажок Skip error correction, но это не рекомендуется делать.

Если не было найдено ошибок, то будет совершен переход на шаг Создание метки или ветви.


Задание действий для каждого изменения

На этом шаге отображаются в виде дерева все объекты и подобъекты, которые были изменены и чьи изменения не попали в репозиторий.

Release New Version - Specify appropriate action

Для каждого найденного несоответствия необходимо выбрать в столбце Action действие, а в столбце Replacement - необходимое изменение. Список Replacement заполняется теми объектами, которые есть в репозитории системы контроля версий, но которых нет в базе данных.

Create New - добавить описание объекта в репозиторий.

Replace Existing - заменить описание в репозитории существующего объекта (существующий объект при этом выбирается в выпадающем списке справа) описанием нового объекта.

Следующий шаг


Выбор и удаление из репозитория пропущенных объектов

На этом шаге отображаются объекты, которые есть в репозитории, но нет в базе данных.

Release New Version - Select missed objects

Удалить объект из репозитория можно установив флажок напротив его названия.

Следующий шаг


Проверка и корректировка скрипта изменений

На этом шаге отображается скрипт изменений, соответствующих действиям, выбранным на предыдущих шагах. Этот скрипт не является выполняемым. Он будет сохранен в репозитории.

Release New Version - Check and correct script

Следующий шаг


Добавление комментариев

На этом шаге можно задать комментарии, описывающие изменения, которые будут записаны в репозиторий.

Release New Version - Specify comment

Следующий шаг


Выполнение корректировки репозитория

На этом шаге производится приведение репозитория в соответствие с базой данных.

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Release New Version - Perform correction

При нажатии кнопки Next мастер возвращается на шаг проверки репозитория. Её необходимо провести заново, чтобы исключить возможность появления ошибок.


Создание метки или тега

Создать метку или тег необходимо, чтобы отметить текущее состояние базы данных.

Создайте метку, если не планируете вносить изменения в публикуемую версию базы данных.

Создайте тег, если ещё не все изменения внесены и позже предполагается получить скрипт дополнительных изменений.

Release New Version - Create a label or a tag

RadioButton Create label - создать метку.

RadioButton Create tag - создать тег.

RadioButton Don't create - не создавать ничего.

В поле Label/Tag name указывается название создаваемого объекта.

CheckBox Move label/tag if it already exists

При установке этого флажка одноименный существующий тег или метка будут заменены создаваемым.

Если создается метка, то следующий шаг это Задание параметров создаваемой метки

Если создается тег, то следующий шаг это Выполнение создания метки или тега

Если ничего не создается, то следующий шаг это Генерация скрипта изменений


Задание параметров создаваемой метки

Этот шагдоступен, только если создается метка.

На этом шаге необходимо задать параметры создаваемой метки.

Release New Version - Specify created label options

В разделе Backup storage location задайте параметры сохранения резервной копии базы данных.

RadioButton Version Control Repository - резервная копия будет сохранена в репозитории системы управления изменениями.

RadioButton Separately - резервная копия будет сохранена в отдельную директорию, заданную в поле ниже.

CheckBox Backup metadata only - если установлен этот флажок, то резервная копия будет создана только для метаданных базы.

Следующий шаг


Выполнение создания метки или тега

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Release New Version - Perform label creation

Следующий шаг


Генерация скрипта изменений

На этом шаге необходимо задать параметры создания скрипта изменений.

Release New Version - Generate change script

RadioButton Generate new script file - создать новый файл скрипта

Script file name - в этом поле, с помощью кнопки btnSaveAs в стандартном диалоговом окне задайте имя файла скрипта и путь к нему.

File charset - из этого раскрывающегося списка выбирается кодировка создаваемого скрипта.

CheckBox Add script to version control repository - если установлен этот флажок, то создаваемый скрипт будет добавлен в существующий репозиторий базы данных в системе контроля версий. Этот пункт доступен для изменения только если заданный путь совпадает с директорией хранения общих скриптов в локальной копии репозитория БД.

RadioButton Append latest changes to existing script file - данный пункт используется в случае, если скрипт изменений был уже получен при использовании мастера публикации баз данных, но позже потребовалось внести дополнительные изменения в разрабатываемую и опубликованную уже базу данных. Предполагается, что после предыдущей генерации была создана метка/тег.

Script file name - в этом поле, с помощью кнопки btnSaveAs в стандартном диалоговом окне выберите существующий файл скрипта.

Get latest changes from - Выбрав в этом поле эту метку/тег и в поле Script file name предыдущий сгенерированный скрипт можно добавить в этот скрипт только последние внесенные изменения. При этом предыдущая версия базы данных, выбранная на первом шаге, не используется для генерации скрипта, а используется лишь для получения информации о тестовой базе данных.

RadioButton Only test existing script - проверить уже существующий скрипт.

Script file name - в этом поле, с помощью кнопки btnSaveAs в стандартном диалоговом окне выберите существующий файл скрипта.

Если генерируем новый скрипт или добавляем изменения в текущий, то следующий шаг это Выбор метода генерации скрипта.

Если проверяем существующий скрипт, то следующий шаг это Задание тестовой базы данных.


Выбор метода генерации скрипта

На этом шаге выберите вид генерируемого скрипта.

Release New Version - Set script generation method

RadioButton Generate differential script (by comparing states) - получить скрипт, в котором отражены изменения, полученные с помощью сравнения состояний баз данных.

Скрипт не будет содержать промежуточных изменений, например, нескольких изменений одной процедуры и т.п.

RadioButton Generate step-by-step script (all changes from the change history) - создать скрипт, в котором изменения будут отображены пошагово в порядке их применения.

Скрипт будет содержать все операторы из истории изменений системы контроля версий в промежутке между исходным и целевым состояниями базы данных.

Если выбрано создание скрипта изменения, то следующий шаг - это Выполнение генерации скрипта изменений.

Если выбрано создание пошагового скрипта, то следующий шаг - это Задание комментариев.


Задание комментариев

На этом шаге выберите, какая дополнительная информация должна присутствовать в создаваемом скрипте в виде комментариев.

Release New Version - Perform script generation

CheckBox Add description - добавить комментарии.

CheckBox Script identification number - идентификационный номер скрипта.

CheckBox Date and time - дата и время генерации.

CheckBox User who had made a change - пользователь, внесший изменения.

CheckBox Comment that user had provided - комментарий, оставленный пользователем.

Следующий шаг


Выполнение генерации скрипта изменений

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Release New Version - Generating and Testing Script

В текстовом поле показаны все производимые действия и результат их выполнения.

Следующий шаг


Выбор файла скрипта для тестирования

Если на первом шаге был установлен флажок CheckBox Only test existing script, то будет отображен этот шаг.

На этом шаге необходимо указать имя файла скрипта, который нужно проверить.

Release New Version - Specify script file to test

В поле Script file name задайте имя файла скрипта и путь к нему.

Если программа не может определить кодировку файла, то при нажатии кнопки Next появляется диалоговое окно Script Conversion в котором ее можно задать.

Release New Version - Specify script file to test - Script Conversion

Следующий шаг


Задание тестовой базы данных

На этом шаге необходимо указать способ получения тестовой базы данных

Release New Version - Specify test database location

RadioButton Restore from the previous version label - восстановить из метки предыдущей версии.

Этот пункт меняется в зависимости от того, что выбрано на первом шаге в качестве Previous version database, если выбрана существующая БД, то этот пункт изменится на Backup/restore the previous version database - сохранить/восстановить из резервной копии предыдущую версию базы данных.

RadioButton Restore an existing backup copy - восстановить существующую копию базы данных из резервной копии.

Backup copy location - в этом поле необходимо указать расположение файла резервной копии базы данных.

RadioButton Use existing database - использовать существующую базу данных.

Следующий шаг


Параметры подключения/создания тестовой базы данных

На этом шаге задайте параметры подключения новой базы данных.

Release New Version - Perform test database creation

Из раскрывающегося списка Host выбрать сервер (хост), к которому надо подключиться. В этот список попадают имена уже зарегистрированных серверов.

Укажите имя пользователя и пароль в полях User name и Password.

В поле Database name отображается имя базы данных.

CheckBox Если установлен флажок Register database if not registered, то база будет зарегистрирована, если у неё пока нет регистрации.

Если на предыдущем шаге были выбраны параметры RadioButton Restore from the previous version label или RadioButton Restore an existing backup copy, то следующий шаг будет Выполнение проверки существования тестовой базы данных.

Если на предыдущем шаге был выбран параметр Use existing database, то следующий шаг будет Подтверждение сравнения баз данных.


Выполнение создания тестовой базы данных

На этом шаге появляется уведомление, что все параметры создания базы данных были указаны верно и тестовая база данных может быть создана.

Нажмите кнопку Run для начала выполнения операции. Когда операция выполнена кнопка Run изменяется на кнопку Next >.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Release New Version - Check the created test database

После создания автоматически открывается окно Database Registration Info.

Следующий шаг


Подтверждение сравнения баз данных

На этом шаге необходимо указать следует ли сравнивать созданную тестовую базу данных и базу данных предыдущей версии. Рекомендуется сравнить эти базы. Сравниваться будут все метаданные БД.

Release New Version - Perform comparing

CheckBox Если установлен флажок Compare the test database with the original previous version database, то базы данных будут сравниваться.

Если установлен флажок, то следующий шаг будет Выполнение сравнения баз данных

Если флажок не установлен, то следующий шаг будет Выполнение скрипта изменений в базе данных


Выполнение сравнения баз данных

На этом шаге производится сравнение тестовой базы данных и предыдущей версии базы данных.

Release New Version - Bring the test database to the previous state

Чтобы запустить процесс сравнения, нажмите кнопку Run.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Следующий шаг


Приведение тестовой базы данных к состоянию предыдущей версии

Этот шаг отображается, если в процессе сравнения тестовой базы данных и предыдущей версии базы данных были найдены различия.

Release New Version - Execute the change script on the test database

CheckBox Ignore the difference - игнорировать различия (не рекомендуется).

При нажатии Open Script откроется SQL Script с загруженным скриптом изменений, которые можно выполнить на тестовой БД для приведения ее к состоянию предыдущей версии базы данных.

В редакторе скриптов скрипт надо выполнить на тестовой базе данных, внеся изменения, если это необходимо, и вернуться обратно в мастер, нажав кнопку Save&Return to Wizard.

Release New Version - Execute the change script on the test database_2

Если установлен флажок Ignore the difference то перейдем на Следующий шаг, а если не выбрано то вернемся к шагу сравнения.


Выполнение скрипта изменений на тестовой базе данных

На этом шаге можно внести изменения в сгенерированный скрипт и выполнить его на тестовой базе данных.

Release New Version - Execute the change script on the test database_1

Open Script

При нажатии на эту кнопку открывается редактор скриптов, в котором уже загружен сгенерированный скрипт.

В редакторе скриптов его надо выполнить на тестовой базе данных, внеся изменения, если это необходимо, и вернуться обратно в мастер, нажав кнопку Save&Return to Wizard.

Release New Version - Execute the change script on the test database_2

Если скрипт не будет выполнен, то мастер вернется на шаг Выполнение сравнения баз данных.

Следующий шаг


Сравнение тестовой базы данных и новой версии базы данных

На этом шаге производится сравнение тестовой базы данных и новой версии базы данных.

Release New Version - test the generated change script

Чтобы запустить процесс сравнения, нажмите кнопку Run.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Если при выполнении возникли ошибки, то мастер перейдет на шаг Выбор способа тестирования сгенерированного дополнительного скрипта изменений.

Следующий шаг


Specify action that will be performed with the test

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Выбор способа тестирования сгенерированного дополнительного скрипта изменений

Дополнительный скрипт был создан из-за наличия отличий между тестовой и целевой (новой версии) базами данных.

Release New Version - action that will be performed with the test

RadioButton Append the additional script to the original and test the entire script

Добавление дополнительного скрипта к сгенерированному ранее и проверка всего полученного скрипта. В этом случае будет создана новая тестовая база данных. Additional script - скрипт, который после выполнения устраняет разницу между тестовой БД и новой версией базы данных.

CheckBox Drop the current test database - удалить текущую тестовую базу данных.

CheckBox Unregister the current test database - удалить регистрацию текущей тестовой базы данных.

RadioButton Test only the additional script on the current test database - тестирование только дополнительного скрипта на текущей тестовой базе данных.

Чтобы открыть дополнительный скрипт в редакторе скрипта, необходимо нажать кнопку Open Script.

Если было выбрано действие RadioButton Append the additional script to the original and test the entire script, то мастер перейдет на шаг Задание тестовой базы данных.

В другом случае мастер перейдет на шаг Сравнение тестовой базы данных и новой версии базы данных.


Завершение операции

Это последний шаг мастера. Он появляется после того, как скрипт был создан и успешно протестирован.

Этот шаг доступен, когда тестовая база после выполнения сохраненного скрипта изменений полностью соответствует Новой версии базы данных.

Release New Version - Finishing the operation

CheckBox Drop the test database - удалить тестовую базу данных.

CheckBox Unregister the test database - удалить регистрацию тестовой базы данных.

Нажатие на кнопку Run запускает выполнение выбранных действий.

Нажмите кнопку Close , чтобы закрыть мастер.


History

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

История изменений

С помощью этого инструмента можно просматривать историю изменений объекта или базы данных.

История изменений базы данных

Для просмотра изменений, сделанных в базе данных необходимо:

  • Выбрать в главном меню программы пункт Tools | Change Management | iconChange Management - History History.
  • В контекстном меню сервера и контекстном меню базы данных выбрать пункт Change Management | iconChange Management - History History.

История изменений объекта

Для просмотра истории изменения объекта необходимо в контекстном меню объекта выбрать пункт Change Management | iconChange Management - History History.

Сравнение разных версий одного объекта

Для сравнения разных версий объекта необходимо в истории изменения объекта выбрать две сравниваемые версии и в контекстном меню выбрать пункт Compare properties или Compare DDL.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Создание ветви/метки/тега

Извлечение данных из репозитория

Получение скрипта изменений

Релиз новой версии базы данных


История изменений базы данных

С помощью этого инструмента можно просмотреть историю изменений базы данных.

Для просмотра изменений, сделанных в базе данных необходимо:

  • Выбрать в главном меню программы пункт Tools | Change Management | iconChange Management - History History.
  • В контекстном меню сервера и контекстном меню базы данных выбрать пункт Change Management | iconChange Management - History History.

Change Management - Version Control History

На одной из панелей инструментов выберите базу данных из раскрывающегося списка Database и задайте период просмотра, указав начальную и конечную дату в разделе Period.

Изменения, совершенные в указанный период, отображаются в основном окне.

Для каждого изменения отображается:

  • идентификатор транзакции,
  • дата совершения изменения,
  • имя пользователя, который внес изменения,
  • комментарий к операции.

В нижней части окна отображается SQL скрипт изменений, соответствующий выбранной в верхней части строке изменений.

Смотрите также:

История изменений объекта

Сравнение версий объекта


История изменений объекта

С помощью этого инструмента можно просмотреть историю изменений конкретного объекта.

Для этого нужно в контекстном меню объекта выбрать пункт Change Management | iconChange Management - History History.

Change Management - Object History

Для объекта отображается следующая информация о проделанных изменениях:

Revision - версия, в которой были внесены изменения.

Date - дата внесения изменений.

Author - пользователь, внесший изменения.

Labels - отметки.

Панели инструментов

Database - выбрать базу данных

iconRefresh Refresh - обновить историю

Select object - выбрать другой объект

Контекстное меню

iconCompare Compare properties - сравнить свойства двух выбранных версий объекта (пункт активен, если выбраны две версии для сравнения)

iconCompareDDL Compare DDL - сравнить DDL двух выбранных версий объекта (пункт активен, если выбраны две версии для сравнения)

btnDBProperties Show properties - показать свойства выбранной версии объекта

btnShowSQLScript Show DDL - показать DDL выбранной версии объекта

iconSaveToFile Save DDL As - сохранить DDL выбранной версии объекта во внешний файл

Смотрите также:

История изменений базы данных

Сравнение версий объекта


Сравнение версий объекта

В окне просмотра истории изменения объекта можно сравнивать две различные версии объекта.

Change Management - Object History - Revisions

Для сравнения необходимо выбрать две версии объекта. Чтобы выбрать две строки необходимо щелкнуть на них мышкой, удерживая при этом клавишу Ctrl.

Для выбранных объектов нажатием правой кнопки мыши вызывается контекстное меню.

Из контекстного меню необходимо выбрать один из видов сравнения - iconCompare Compare Properties или iconCompareDDL Compare Scripts.

iconCompare Compare Properties позволяет сравнить свойства объекта в двух версиях.

iconCompareDDL Compare Scripts позволяет сравнить DDL объекта в разных версиях.

После выбора одного из видов сравнения появляется диалоговое окно, в котором отображается процесс сравнения.

Change Management - Object History - Comparing progress

Можно установить флажок CheckBox Close after finish, чтобы это окно автоматически закрылось после выполнения операции.

iconCompare Просмотр результатов сравнения свойств

Change Management - Object History - Comapring Properties

После проведения операции сравнения свойств появляется диалоговое окно, в котором отображены все свойства объекта и их значения для разных версий.

Цветом выделены свойства, имеющие разные значения для разных версий.

iconCompareDDL Просмотр результата сравнения скриптов

Change Management - Object History - Comapring Scripts

В появившемся окне отображаются скрипты объекта для разных версий.

отсутствующие в более поздней версии строки.

строки, добавленные в более поздней версии.

отличающиеся строки, присутствующие в обеих версиях.

строки, отсутствующие в одной из версий, но присутствующие в другой.

С помощью кнопок, расположенных на панели инструментов, можно перемещаться по скрипту к btnMoveItemDown следующим и btnMoveItemUp предыдущим отличиям, а также btnFindText найти некоторое сочетание символов и btnSearchAgain продолжить поиск.

Смотрите также:

История изменений базы данных

История изменений объекта


Запросы

SQL Manager for PostgreSQL предлагает два инструмента для работы с SQL запросами:

  • Query data для редактирования текста запросов,
  • Design Query для построения запросов визуально.

Создание запросов

в Редакторе запросов

Для создания этого объекта используйте:

  • пункт Tools | Query data главного меню программы,
  • или нажмите кнопку btnShowSQLEditor Query data на стандартной панели инструментов программы,
  • или используйте сочетание клавиш <Shift+F12>.

После выполнения одной из этих операций автоматически открывается редактор запросов.

в Визуальном конструкторе запросов

Для создания этого объекта используйте:

  • пункт Tools | Design Query главного меню программы,
  • или нажмите кнопку btnShowQueryBuilder Design Query на стандартной панели инструментов программы,

После выполнения одной из этих операций автоматически открывается Дизайнер запросов.

Редактирование запросов

в Редакторе запросов

для того, чтобы открыть созданный запрос для редактирования Вам необходимо

  • выбрать пункт Tools | Query data главного меню программы,
  • или нажать кнопку btnShowSQLEditor Query data на стандартной панели инструментов программы,
  • или использовать сочетание клавиш <F12>.

После выполнения одной из этих операций запрос автоматически открывается в редакторе запросов.

в Дизайнере запросов

для того, чтобы открыть созданный запрос для редактирования Вам необходимо

  • выбрать пункт Tools | Design Query главного меню программы,
  • или нажать кнопку btnShowQueryBuilder Design Query на стандартной панели инструментов программы.

После выполнения одной из этих операций запрос автоматически открывается в Дизайнере запросов.

Выполнение запроса

Чтобы выполнить запрос в любом из редакторов необходимо:

  • Создать новый или отрыть уже существующий запрос.
  • нажать кнопку btnExecuteQuery Execute query на навигационной панели или на панели инструментов редактора, или клавишу F9,
  • просмотреть, редактировать полученные данные на вкладке Results.

Сохранение запроса

Чтобы сохранить запрос в файл необходимо:

  • создать новый или отрыть уже существующий запрос,
  • выбрать пункт Save to file на навигационной панели Редактора получения данных, или пункт Save diagram на навигационной панели Визуального конструктора запросов.
  • в появившемся окне выберите куда сохранить файл и тип сохраняемого файла.

Если хотите сохранить несколько запросов в один файл, то нажмите Save All на навигационной панели Редактора получения данных. Для Визуального конструктора такой функции нет.

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Управление данными

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Редактор запросов

Редактор получения данных - основной инструмент программы SQL Manager for PostgreSQL для работы с запросами. Он позволяет создавать, редактировать и выполнять запросы, а также просматривать результаты, полученные в ходе выполнения запроса.

Для создания запроса в редакторе запросов необходимо выполнить одну из следующих операций:

  • выбрать пункт Tools | Query data главного меню программы,
  • или нажать кнопку btnNewSQLEditor Query data на стандартной панели инструментов программы,
  • или использовать сочетание клавиш <Shift+F12>.

После выполнения одной из этих операций редактор запросов открывается автоматически.

Сохраненные в файл запросы открываются в редакторе с помощью команды Load from file, находящейся на навигационной панели редактора и на панели инструментов.

Панели инструментов

Работа с окном редактирования SQL

Контекстное меню

Создание запроса с помощью перетаскивания

Просмотр плана запроса

Выполнение запроса

Использование ссылок на объекты

Журнал

Редактор избранных запросов

Смотрите также:

Дизайнер запросов

Параметры запросов

Редактор выполнения скриптов

Настройки редакторов


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации позволяет:

SQL Editor - Using Navigation bar

Database

iconDB выбрать базу данных, для которой будет создаваться запрос

General

iconExecute Execute - выполнить текущий запрос

Explain query - открыть запрос в виде плана на специальной вкладке

Run Design Query - открыть запрос в дизайнере запросов

Results on Edit tab/Results on separate tabпоказывать результаты запроса на той же/отдельной вкладке -

iconOptions изменить настройки редактора - Query data Options. При нажатии на этот пункт откроется страница Query data в Environment Options

iconRestoreDefaultSize восстановить исходный размер окна - Restore default size

Queries

Add new query - добавить новый запрос

Rename current query - переименовать текущий запрос

Remove current query - удалить текущий запрос

Remove all queries - удалить все запросы

Add to Favorite Queries - добавить запрос в Избранные запросы

Save changes to Favorite Queries - сохранить изменения в избранном запросе (активно только тогда, когда открыт один из избранных запросов)

Edit

iconFindText Find text - найти текст

iconLoadFromFile Load from file - загрузить запрос из файла

iconSaveToFile Save to file - сохранить текущий запрос в файл

iconSaveToFileAs Save to file as - сохранить в файл как

iconSaveAll Save all - сохранить все открытые запросы одновременно

При переходе на другие вкладки редактора, появляются панели, со специальными функциями для каждой вкладки.

Data management (для вкладки Results)

iconCommit Commit Transaction - применить транзакцию для данных (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query),

iconRollback Rollback Transaction - откатить транзакцию для данных таблицы (активна, если включены транзакции для данных),

Export Data - экспортировать данные

Export as SQL Script - экспортировать данные в виде SQL-скрипта

Import Data - импортировать данные

Logs (для вкладки Logs)

iconFindText Find text - найти текст в журнале

iconSaveToFile Save logs to file - сохранить журнал в файл

Clear logs - очистить журнал

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.

Смотрите также:

Работа с окном редактирования SQL

Просмотр плана запроса

Выполнение запроса

Журнал

Редактор избранных запросов


Работа с окном редактирования SQL

В главном окне Вы можете создавать и редактировать запросы.

SQL Editor - Working with SQL Editor area

Основные особенности:

  • отображение имен объектов в виде ссылок на эти объекты
  • вызов и настройка списка автоматической подстановки
  • возможность нумерации строк
  • возможность сворачивать запросы и подзапросы
  • возможность задавать свойства выделенных объектов
  • настройка полей и номеров строк
  • изменение параметров различных объектов текста запроса
  • настройка автоматического форматирования текста запроса
  • задание сочетаний клавиш для быстрого ввода текста и выполнения команд

Существует возможность записи и использования макросов.

Кнопки для работы с макросами доступны на панели состояния в левой нижней части окна редактирования.

Чтобы начать запись макроса, нажмите кнопку btnRecordMacro Record, или используйте сочетание клавиш Shift + Ctrl + R.

Чтобы остановить запись, нажмите кнопку btnStopRecordMacro Stop, или используйте сочетание клавиш Shift + Ctrl + R.

Для вызова записанный макрос, используйте кнопку воспроизведения btnPlayMacro Play, или используйте сочетание клавиш Shift + Ctrl + P.

Смотрите также:

Панели инструментов

Контекстное меню

Настройки редакторов

Шаблоны клавиатуры

Редактор избранных запросов

Окно поиска


Контекстное меню

Для редактора текста запроса существует специальное контекстное меню, которое отрывается по нажатию правой клавиши мыши в любой точке области редактирования. Это меню позволяет быстро выполнять самые используемые команды.

SQL Editor - Using the context menu

Add to Dictionary - добавить в словарь

Correct With - редактировать

Execute - Выполнить запрос

Execute Selected Only - Выполнить только выделенное

Execute under Cursor - Выполнить под курсором

Switch to Result Tab - Перейти после выполнения на вкладку результатов

Explain Query on Execution - Отображать план запроса в редакторе запросов

Reset Execution Point - Убрать контрольные точки

Markers - Открыть подменю, позволяющее работать с маркерами

Toggle Bookmarks - Установить закладку

Goto Bookmarks - Перейти к закладке (этот пункт активен только тогда, когда установлены закладки)

Undo - Отменить действие

Redo - Вернуть отмененное действие

Cut - Вырезать выделенное

Copy - Копировать выделенное

Paste - Вставить

Select All - Выделить все

Find - Найти

Replace - Найти и заменить

Search Next - Возобновить поиск

Incremental Search - инкрементный поиск

Preview - Предварительный просмотр

Print - Печатать

Quick Code

Properties - Просмотреть и изменить свойства в Editor Options

Подменю пункта Quick Code

Format SQL - Форматировать запрос SQL (при этом применяются изменения, внесенные в Форматтер SQL)

Select Character - Выбрать символ

Toggle Comment - Преобразовать выделенный текст в комментарии

Selection Lower Case - Привести выделенный текст к нижнему регистру

Selection Upper Case - Привести выделенный текст к верхнему регистру

Selection Toggle Case - Изменить регистр выделенного текста

Indent - Увеличить отступ текста

Unindent - Уменьшить отступ текста

Смотрите также:

Работа с окном редактирования SQL

Выполнение запроса


Просмотр плана запроса

Чтобы просмотреть план запроса нажмите кнопку btnExplainQuery Explain query на одной из панелей инструментов.

План запроса можно выводить в текстовом виде на вкладке Edit или в текстовом виде на текущей вкладке. Для этого нужно открыть раскрывающийся список кнопки Explain query и выбрать пункт Verbose. Если выберете пункт Analyze, а затем нажмете кнопку Explain query то план запроса будет показан на вкладке Plan более подробно, с указанием времени, потраченного на выполнение запроса.

SQL Editor - Viewing query plan

На вкладке Plan отображается последовательность действий, которые происходят в системе при выполнении запроса.

Полезная информация о каждом этапе выполнения предоставлена в окнах свойств, расположенных справа и внизу от основного окна.

В правой и нижней частях окна располагается дерево плана запроса. В столбцах отображены следующие характеристики каждого элемента плана.

  • Операции - Operation
  • Логические операции - Logical operation
  • Вес поддерева - Subtree Cost
  • Затраты ввода/вывода - IO Cost
  • Затраты CPU - CPU Cost
  • Выполнения - Executions
  • Строки - Rows
  • Размер строки - Row Size
  • Параллельно - Parallel
  • Оператор - Statement
  • Аргумент - Argument
  • Определенные значения - Defined Values
  • Вывод - Output
  • Предупреждения - Warnings

Смотрите также:

Настройки редактора выполнения скрипта

Выполнение запроса


Добавление объекта в запрос

Поместить объект в запрос можно прямо из проводника баз данных, перетащив его мышкой из окна проводника или SQL ассистента в редактор. В этом случае появляется диалоговое окно, в котором нужно указать оператор для этого объекта. C помощью перетаскивания можно вставить SQL запрос не только в Редактор запросов, но и в Дизайнер запросов.

DB Explorer - Insert to Editor

Из списка Statement выберите оператор, который нужно применить в запросе к выбранному объекту.

Name - в запрос будет помещено только имя объекта.

SELECT - оператор выбора.

INSERT - оператор вставки. Вместо значений используются параметры.

UPDATE - оператор обновления.

DELETE - оператор удаления записи.

CREATE - оператор создания.

DROP - оператор удаления таблицы.

Columns list - список столбцов.

Name and Type - список столбцов с указанием типов.

В поле Alias можно задать псевдоним для объекта.

Префикс для параметра укажите в поле Prefix for variable.

Смотрите также:

Параметры запросов

Дизайнер запросов


Использование ссылок на объекты

Если объект, упомянутый в запросе, присутствует в базе данных, то в тексте запроса его имя будет выделено другим цветом.

Чтобы открыть объект в соответствующем редакторе, нажмите на нем левой кнопкой мыши, удерживая при этом клавишу Ctrl.

SQL Editor - Using object links

Изменить цвет ссылок Вы можете на вкладке Color диалогового окна Editor Options.

Смотрите также:

Работа с окном редактирования SQL

Настройки редакторов


Выполнение запроса

Чтобы выполнить запрос, необходимо нажать Execute на одной из панелей инструментов или в контекстном меню. Если текст запроса содержит ошибки, то программа укажет на это и результат не будет доступен до того, как все ошибки будут исправлены.

Если запрос должен возвращать данные (в тексте содержатся SELECT), то в редакторе появится новая вкладка Results, на которую и будут вынесены полученные результаты.

На этой вкладке возвращенные запросом данные отображаются в Просмотрщике данных. Просмотрщик позволяет экспортировать данные и экспортировать данные как SQL скрипт.

SQL Editor - Executing queries

Если при выполнении запроса возникли ошибки, то их описание будет вынесено в информационное окно, расположенное в нижней части редактора. Двойной щелчок на ошибке делает активной строку, в которой эта ошибка была найдена.

SQL Editor - Viewing results

Execute Selected Only - Выполнить только выделенное

Execute under Cursor - Выполнить под курсором

Switch to Result Tab - Перейти после выполнения на вкладку результатов

Explain Query on Execution - Отображать план запроса в редакторе запросов

Сочетания клавиш

F9 | Выполнить запрос/скрипт
Alt+F9 | Выполнить только выделенную часть кода
Ctrl+Alt+F9 | Выполнить ту часть кода, на которой стоит курсор
Ctrl+Alt+F2 | Удалить контрольную точку (Только для Редактора получения данных)

Смотрите также:

Просмотрщик данных

Мастер экспорта данных

Мастер экспорта в виде SQL скрипта


Журнал

Все операции, производимые с запросом, программа заносит в специальные файлы журналов - Logs, которые отображаются на вкладке Logs Редактора получения данных.

В журнал заносится следующая информация:

  • дата модификации запроса,
  • сам текст запроса,
  • ошибки, возникшие при исполнении (если они были),
  • если ошибок не было, то информация о результате, полученном в ходе выполнения запроса.

Дополнительная информация о выполнении отображается в виде комментариев. Это позволяет копировать текст запроса и выполнять его. При этом все дополнительные сведения не будут вызывать ошибок.

SQL Editor - Viewing query logs

Смотрите также:

Выполнение запроса

Контекстное меню


Редактор избранных запросов

Для быстрого доступа к часто используемым запросам, в проводнике баз данных существует специальный раздел Favorite Queries iconFavoriteQueries .

Редактор избранных запросов

Этот редактор открывается только в том случае, если в контекстном меню Редактора получения данных Вы выбираете пункт [image] Add to Favorite Queries или в контекстном меню избранного запроса пункт Edit Favorite Query.

SQL Editor - Favorites editor

С помощью редактора Вы можете создавать и редактировать избранные запросы.

В поле Name укажите имя запроса.

Из раскрывающегося списка Storage выберите место хранения. Местом хранения может быть база данных (создается таблица pgmfavorites в схеме public) - пункт Database или в системном реестре - Registry.

В SQL редакторе Вы можете работать с текстом запроса так же как в редакторе запросов.

Важно: Если Вы храните избранные запросы в реестре, то после переустановки операционной системы они могут быть потеряны. Чтобы этого избежать, сохраните соответствующую ветку реестра или используйте базу данных для хранения запросов.

Смотрите также:

Избранные запросы

Работа с окном редактирования SQL


Дизайнер запросов

Этот инструмент позволяет создавать и редактировать запросы графически без текстового их описания на языке SQL. Вы можете создавать, выполнять просматривать результаты, используя визуальные методы, предоставленные этим инструментом.

Также с помощью Дизайнера запросов Вы можете получать графическое представление запроса, написанного в текстовой форме. Для этого в окно редактирования необходимо поместить текст запроса.

Для создания запроса в конструкторе выполните одну из этих операций:

  • выберите пункт Tools | Design Query главного меню программы,
  • или нажмите кнопку btnNewQueryBuilder Design Query на стандартной панели инструментов программы,

После выполнения одной из этих операций запрос автоматически открывается в визуальном конструкторе запросов.

Основные инструменты конструктора:

Панели инструментов

Окно диаграммы

Установка связей

Задание критериев

Выводимые столбцы

Критерии группировки

Условия сортировки

Окно редактирования

Выполнение запроса

Смотрите также:

Редактор запросов

Параметры запросов

Настройки конструктора запросов


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Панель навигации

Query Builder - Using Navigation bar

Database

iconDB выбрать базу данных для которой будет создаваться запрос

General

iconExecute Execute query - выполнить текущий запрос

Explain query - открыть запрос в виде плана на специальной вкладке

Clear query - удалить текущий запрос

Create View - создать представление

iconOptions Design Query Options - настроить Дизайнер запросов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Visual Builder

iconLoadFromFile Load Diagram - загрузить диаграмму

iconSaveToFile Save Diagram - сохранить диаграмму

Data Management

iconCommit Commit Transaction - применить транзакцию для данных (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query)

iconRollback Rollback Transaction - откатить транзакцию для данных таблицы (активна, если включены транзакции для данных)

Export Data - экспортировать данные

Export as SQL Script - экспортировать данные в виде SQL скрипта

На панели Object представлен список всех объектов, содержащихся в базе данных, которые можно использовать в диаграмме.

Поместить объекты из этого окна в окно диаграммы можно с помощью перетаскивания.

При переходе на другие вкладки редактора, появляются панели, со специальными функциями для каждой вкладки.

Edit (для вкладки Edit)

iconFindText Find text - найти текст

iconLoadFromFile Load from file - загрузить запрос из файла

iconSaveToFile Save to file - сохранить текущий запрос в файл

iconSaveToFileAs Save to file as - сохранить в файл как

iconSaveAll Save all - сохранить все открытые запросы одновременно

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.

Смотрите также:

Работа с окном диаграммы

Выполнение запроса


Работа с окном диаграммы

Основные действия выполняются на вкладке Builder визуального конструктора запросов.

Query Builder - Working with diagram area

Основным инструментов является Рабочая область.

Добавление объекта в рабочую область

Таблицы помещаются в рабочую область. Чтобы добавить таблицу в рабочую область достаточно перетащить её или из проводника баз данных или из списка на панели Object, располагающейся на навигационной панели. Объект, отображаемый на панели Object, добавить в рабочую область можно ещё и двойным щелчком мыши.

Выбор столбцов

Чтобы добавить столбцы таблицы или представления в создаваемый запрос необходимо установить флажок около столбца или выделить столбец двойным щелчком мыши. Все столбцы, у которых установлены флажки, попадают в запрос.

Чтобы добавить в запрос сразу все столбцы объекта необходимо установить флажок, находящийся перед названием объекта в строке заголовка.

Удаление объекта из рабочей области

Чтобы удалить объект из рабочей области необходимо выполнить одну из следующих операций:

  • нажать на кнопку "закрыть" Query Builder - Working with diagram area - Close в заголовке объекта,
  • или выбрать пункт Delete контекстного меню, открывающегося при нажатии правой кнопкой мыши на заголовок объекта.

Объект удалится только из рабочей области. В базе данных он останется.

Создание псевдонима объекта

Изменить псевдоним объекта, под которым он отображается на диаграмме, можно с помощью пункта Rename контекстного меню, открывающегося при нажатии правой кнопкой мыши на заголовок объекта. Также, Вы можете это сделать, нажав два раза мышью на названии объекта.

Установка связей

Под рабочей областью располагается окно работы с столбцами

С его помощью можно:

  • задавать критерии отбора данных в запросе,
  • выбирать какие столбцы будут выводиться в результате запроса,
  • устанавливать параметры группировки,
  • задавать условия сортировки.

Слева от рабочей области находится дерево подзапросов.

Visual Query Builder - Union

В нем отображаются вложенные запросы и составные части запроса. UNION и UNION ALL.

Visual Query Builder - Selecting query type

В нижней части окна располагается панель информации. Если запрос был выполнен успешно, то туда выносится краткий отчет о результатах выполнения. Если же нет, то отчет об ошибках.

Из раскрывающегося списка, расположенного над деревом подзапросов, списка выберите тип запроса - Select, Insert, Update или Delete.

Visual Query Builder - Selecting query type

Смотрите также:

Установка связей

Работа с окном редактирования

Выполнение запроса


Установка связей

В реляционных базах данных требуется создание связей между таблицами.

Визуальный конструктор позволяет быстро устанавливать связи между объектами, помещенными в рабочую область.

Чтобы установить связь между таблицами по двум столбцам необходимо столбец из одной таблицы перетащить в другую (поля представлены в виде списка, в котором каждая строчка - столбец).

После перетаскивания связь будет отображена в виде черной линии, соединяющей желаемые столбцы.

Query Builder - Joining two objects

Свойства связи

Свойства связи можно редактировать. Для этого необходимо открыть редактор связи, два раза щелкнув на ней мышкой или выбрать пункт контекстного меню связи Properties.

Query Builder - Link properties

В появившемся окне указываете желаемые свойства редактируемой связи.

  • условие связи выбирается из раскрывающегося списка, находящегося между именами столбцов. (=, >, <, >=, <=, <>).
  • с помощью установки флажков Вы указываете тип связи. Если установлен один флажок, то связь "один ко многим".

- если опция выбрана для левой таблицы, для связи используется оператор LEFT JOIN

- если опция выбрана для правой таблицы, для связи используется оператор RIGHT JOIN

- если опция не выбрана ни для одной из таблиц, для связи используется оператор INNER JOIN

- если опция выбрана для обеих таблиц, для связи используется оператор FULL OUTER JOIN

Контекстное меню связи:

Visual Query Builder - Link menu

  • Insert point - создавать точку на линии связи, с помощью которой эту линию можно двигать, для удобства визуального представления,
  • Delete link - удалять связь,
  • Property - редактировать свойства связи.

Смотрите также:

Работа с окном диаграммы

Задание критериев


Задание критериев

На вкладке Criteria Вы можете установить критерии отбора данных в запросе.

Query Builder - Setting criteria

Чтобы добавить условие ограничения нужно нажать кнопку EllipsisButton на форме и из появившегося контекстного меню выбрать пункт Add condition. Добавится строчка, которой будет присвоен порядковый номер. В этой строчке Вам необходимо указать условие отбора.

Чтобы задать тип составного условия нажмите на надпись All, располагающуюся рядом с EllipsisButton и выберите один из предложенных типов.

По нажатию на раскрывающиеся списки Visual Query Builder - Line1 открываются списки, состоящие из всех столбцов объектов, участвующих в запросе. В этих полях Вы можете задать операторы условия. Это могут быть как имена столбцов, так и константы или выражения. Также можно перетащить нужный столбец из рабочей области.

Нажав на символ "=", Вы получаете возможность установить отношение между операторами.

Управлять условием можно с помощью контекстного меню, которое открывается при нажатии левой кнопкой мыши на порядковый номер.

Visual Query Builder - Condition menu

С помощью этого меню можно:

  • добавить новое условие - Add condition,
  • добавить составное условие - Make composite condition,
  • удалить условие - Delete condition,
  • развернуть условие - Expand condition. (этот пункт активен только тогда, когда в добавлены составные условия. Если условие развернуто, то этот пункт заменяется на "свернуть условие" - Collapse condition).

Если на номере условия нажать правой кнопкой мыши, то появится меню с одним пунктом - Insert query. Если нажмете на этот пункт, то будет создан вложенный запрос, с которым можно работать также как и с основным. Иерархия запросов отображается в дереве подзапросов, расположенном слева от рабочей области. Если создан подзапрос то условие примет вид Editor Options - Condition первый оператор условия после символа отношения задает квалификатор запроса, а во втором отображается начало вложенного запроса.

Квалификатор запроса можно выбрать из списка, открывающегося по нажатию на нем левой кнопкой мыши.

Visual Query Builder - Criteria menu

Удалить подзапрос можно с помощью пункта контекстного меню Delete query. Это контекстное меню открывается по нажатию на условии, содержащем подзапрос правой кнопкой мыши. С помощью этого меню можно:

  • удалить подзапрос - Delete query,
  • открыть подзапрос - Show query.

Смотрите также:

Выводимые столбцы

Критерии группировки

Параметры сортировки


Выводимые столбцы

На этой вкладке Вы формируете выходную форму запроса.

Вы указываете, какие столбцы будут отображаться в результате запроса и как они будут отсортированы и сгруппированы. Можно перетащить нужный столбец из рабочей области или выбрать его из раскрывающегося списка Source column name. Также, Вы можете создавать вычисляемые столбцы.

С помощью кнопок [image] [image] Вы можете изменить порядок столбцов.

Query Builder - Setting output fields

  • В столбце Name of output указан псевдоним столбца, под которым оно будет выведено в результате запроса.
  • Столбец Aggregate содержит аггрегирующую функцию.
  • Source column name содержит настоящие имена столбцов, выводимых в результат запроса.
  • Grouping указывает сгруппирован столбец или нет.

Если флажок Select only unique records установлен, то в результате запроса отображаются только неповторяющиеся записи.

Основные действия с записями выполняются при помощи контекстного меню, которое открывается по нажатию на записи правой кнопкой мыши.

Visual Query Builder - Selection field menu

С помощью этого меню выполняются следующие операции:

  • удаление выделенного столбца - Delete current row,
  • вставка вложенного запроса - Insert Query,
  • вставка вычисляемого столбца - Insert CASE.

Query Builder - Setting output fields - CASE

Также столбцы можно отсортировать, щелкнув левой кнопкой мышки на заголовок колонки в котором содержатся столбцы.

Порядок столбцов в результате запроса будет соответствовать их последовательности в этой таблице.

Встроенный запрос открывается на отдельной вкладке рабочей области для редактирования и отображается в дереве подзапросов в левой части Визуального конструктора.

Смотрите также:

Задание критериев

Критерии группировки

Параметры сортировки


Критерии группировки

На этой вкладке задаются критерии, по которым будут сгруппированы данные, полученные в результате выполнения запроса.

Query Builder - Setting grouping criteria

Чтобы добавить критерий группировки нужно нажать кнопку EllipsisButton на форме и из появившегося контекстного меню выбрать пункт Add condition. Добавится строчка, которой будет присвоен порядковый номер. В этой строчке Вам необходимо указать условие группировки.

Чтобы задать тип условия нажмите на надпись All, располагающуюся рядом с EllipsisButton и выберите один из предложенных типов.

По нажатию на раскрывающиеся списки Visual Query Builder - Line1 открываются списки, состоящие из всех столбцов объектов, участвующих в запросе. В этих полях Вы можете задать операторы условия. Это могут быть как имена столбцов, так и константы или выражения. Также можно перетащить нужное поле из рабочей области.

Аггрегирующую функцию Вы выбираете из списка Visual Query Builder - Line2.

Нажав на знак "=", Вы получаете возможность установить отношение между операторами.

Управлять условием группировки можно с помощью контекстного меню, которое открывается при нажатии левой кнопкой мыши на порядковый номер.

Visual Query Builder - Condition menu

С помощью этого меню можно:

  • добавить новое условие - Add condition,
  • добавить составное условие - Make composite condition,
  • удалить условие - Delete condition,
  • развернуть условие - Expand condition. (этот пункт активен только тогда, когда в добавлены составные условия. Если условие развернуто, то этот пункт заменяется на "свернуть условие" - Collapse condition).

Смотрите также:

Задание критериев

Выводимые столбцы

Параметры сортировки


Параметры сортировки

В окне работы со столбцами, которое располагается под рабочей областью, существует специальная вкладка, на которой можно указывать параметры сортировки столбцов в запросе.

В списке Output columns содержатся все столбцы объектов, участвующих в запросе. Чтобы указать, по какому столбцу будет отсортирована, полученная в результате выполнения запроса, таблица, необходимо переместить столбцы из списка Output columns в список Sorted columns. Делается это с помощью кнопок или перетаскивания выбранного элемента.

В списке Sorted columns для выбранных столбцов Вы указываете параметры сортировки:

  • порядок сортировки "по возрастанию" или "по убыванию" указывается в столбце Sort order с помощью кнопки A...Z,
  • очередность сортировки (по какому столбцу сортировать в первую очередь, а по какому во вторую) задается расположением столбцов в списке Sorted columns. По первому в списке столбцу сортировка проходит в первую очередь и.т.д. Перемещать столбцы в списке можно с помощью кнопок Up и Down.

Query Builder - Setting sorting parameters

Смотрите также:

Задание критериев

Выводимые столбцы

Критерии группировки


Работа с окном редактирования

В окне редактирования автоматически генерируется текст запроса. В этом окне Вы можете просмотреть и исправить запрос. Все изменения будут отображены в окне диаграммы.

Query Builder - Working with editor area

Все, что в тексте запроса выделено зеленым, является ссылками на объекты. Зеленым ссылки выделяются по умолчанию. Вы можете задать любой цвет в настройках редактора (Options | Editor Options | Color).

Открыть для просмотра объект, на который есть ссылка в тексте, Вы можете, нажав на нем левой кнопкой мыши, удерживая при этом клавишу Ctrl. Если в этом редакторе Вы создадите текст запроса, то в рабочей области этот запрос будет представлен в графическом виде.

Более подробно про окно редактирования текста SQL.

Смотрите также:

Работа с окном диаграммы

Выполнение запроса

Редактор запросов


Выполнение запроса

Чтобы выполнить запрос необходимо нажать Execute на одной из панелей инструментов.

При выполнении запроса появится новая вкладка Results, на которую и будут вынесены полученные результаты.

На этой вкладке возвращенные запросом данные отображаются в Просмотрщике данных. Просмотрщик позволяет Экспортировать данные и Экспортировать данные как SQL скрипт.

Query Builder - Viewing results

Смотрите также:

Работа с окном диаграммы

Работа с окном редактирования

Просмотрщик данных


Параметры запросов

Редактор запросов и Визуальный конструктор запросов позволяют использовать параметры в тексте запроса.

Параметр - это переменная, значение которой может быть определено непосредственно перед выполнением запроса. В тексте запроса параметры выделены символом ":", который ставится в начале параметра.

:param1

Важно: Чтобы можно было использовать параметры необходимо установить флажок Allow using of parameters in query text в Options | Environment options | Tools.

Смотрите также:

Редактор запросов

Дизайнер запросов


Окно ввода параметров

Так как параметр - это переменная, значение которой может быть определено непосредственно перед выполнением запроса, в программе SQL Manager for PostgreSQL существует специальный инструмент, позволяющий вводить значения параметров при выполнении запроса.

Окно Input Parameters формируется на основании тех параметров, которые заданы в тексте запроса. Для каждого параметра создается поле ввода, которое называется так же как и параметр.

Для разных типов столбцов предусмотрены специальные поля ввода параметров.

Например, для столбца типа datetime появляется календарь, позволяющий избежать ошибок при вводе даты.

Query parameters - Input parameters dialog

В поле Вы можете ввести значение параметра, а можете оставить его пустым.

Нажав кнопку Ok, Вы продолжите выполнение запроса с учетом введенных параметров. Если нажмете Cancel, то остановите выполнение запроса.


Управление данными

Данные, хранящиеся в таблицах и результаты запросов, отображаются на специальных вкладках редакторов, предназначенных для просмотра данных. Так данные таблицы можно просматривать и редактировать на вкладке Data, результаты запроса - на вкладке Results. Везде, где есть возможность просмотра и редактирования данных, используется специальный инструмент - просмотрщик данных.

Используется в:

Редакторе таблиц,

Редакторе представлений,

Редакторе выполнения запросов,

Дизайнере запросов и т.д.

Данные в просмотрщике могут отображаться несколькими способами:

  • в виде таблицы - на вкладке Grid View,
  • в виде формы - на вкладке Form View,
  • в виде печатной формы - на Print Data,
  • в виде редактора данных типа BLOB - на Blob View

Основные операции, которые Вы можете производить с данными, используя контекстное меню и панели инструментов просмотрщика данных:

  • Экспорт данных,
  • Экспорт данных в виде SQL-скрипта,
  • Импорт данных
  • Редактировать BLOB.

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Просмотрщик данных

В SQL Manager for PostgreSQL существует мощный инструмент для просмотра, редактирования и печати данных из таблиц, запросов и представлений.

Наиболее часто используемые инструменты просмотрщика данных вызываются из контекстного меню.

Вкладки просмотрщика данных располагаются в нижней его части.

С их помощью можно просмотреть данные:

  • на вкладке Grid View в виде таблицы,
  • на Form View в виде форм, где каждая строка вынесена на отдельную форму,
  • на вкладке Print Data данные представлены в виде страницы предварительного просмотра.

Просмотрщик данных используется в таких инструментах:

Редактор таблиц - вкладка Data,

Редактор представлений, - вкладка Data,

Редактор запросов - вкладка Results,

Дизайнер запросов - вкладка Results.

Настроить просмотрщик данных можно с помощью вкладки Grid в Options | Environment Options

Смотрите также:

Конструктор фильтров

Таблицы

Представления


Панели инструментов

Панели редакторов

Навигационная панель

В редакторе, в котором используется просмотрщик данных, при переходе на вкладку Data или Results на навигационной панели, появляется панель Data management.

С помощью этой панели Вы можете:

Data View - Using Navigation bar

iconCommit применить транзакцию для данных - Commit Transaction (активна, если включены транзакции для данных Options | Environment Options | Tools | Use transactions in Data tab of object editors, Query data and Design Query),

iconRollback откатить транзакцию для данных таблицы - Rollback Transaction (активна, если включены транзакции для данных),

экспортировать данные - Export Data,

экспортировать данные в виде SQL скрипта - Export as SQL Script,

импортировать данные - Import Data,

сохранить данные - Save data (только в редакторе таблиц),

загрузить данные - Load data (только в редакторе таблиц).

Панели инструментов просмотрщика данных

Панель работы с записями

Data View - Navigation pane

  • First record - перейти к первой записи
  • Prior page - перейти к предыдущей странице
  • Prior record - перейти к предыдущей записи
  • Next record - перейти к следующей записи
  • Next page - перейти к следующей странице
  • Last record - перейти к последней записи
  • Insert record - добавить запись
  • Delete record - удалить запись
  • Edit record - редактировать запись
  • Post edit - сохранить изменения
  • Cancel edit - отклонить изменения
  • Refresh data - обновить данные
  • Set Bookmark - создать закладку
  • Go to Saved Bookmark - перейти к закладке
  • Filter data - фильтровать данные (открывается конструктор фильтров)
  • в поле Find Вы указываете набор символов, который хотите найти в выделенном столбце
  • включить/выключить отображение данных дочерних таблиц (Include data of descendant tables)
  • с помощью счетчика Record Limit Вы указываете максимальное число отображаемых записей

Панель инструментов вкладки Print Data:

Data View - Print Data - Toolbar

  • Design Report - настроить вид отчета с помощью инструмента Format report
  • Load Report - загрузить отчет из файла
  • Save Report - сохранить отчет в файл
  • Print - печатать
  • Print Dialog - открыть диалог печати (открывается стандартное диалоговое окно, в котором указываете параметры печати)
  • Page Setup - настроить параметры страницы
  • Show Thumbnails - показать макеты страниц
  • Title... - настройка примечаний:

Date and Time... - вставка даты и времени

Page Numbering... - вставка номеров страниц

  • Shrink To Page - разместить все на одной странице
  • Background - задать цвета фона страницы
  • Zoom - задать масштаб
  • Zoom Page - масштаб по ширине страницы
  • Whole Page - целая страница
  • Multiple Page - несколько страниц
  • Zoom - произвольный масштаб выбирается с помощью раскрывающегося списка
  • First Page - перейти к первой странице
  • Previous Page - перейти к предыдущей странице
  • счетчик Active Page - указать номер страницы, к которой хотите перейти (кроме того, в нем отображается номер страницы, на которой Вы сейчас находитесь)
  • Next Page - перейти к следующей странице
  • Last Page - перейти к последней странице

Панель инструментов вкладки Blob View

Data View - BLOB View - Toolbar

  • из раскрывающегося списка выбрать поле типа BLOB
  • кодировку выберите из раскрывающегося списка
  • Load from File - загрузить из файла (Вы можете выбрать любой тип файлов. Это может быть текст, рисунок и т.д.)
  • Save to File - сохранить в файл
  • Cut To Clipboard - вырезать (активна только на вкладках Text и Rich Text)
  • Copy To Clipboard - копировать (активна только на вкладках Text и Rich Text)
  • Paste From Clipboard - вставить (активна только на вкладках Text и Rich Text)
  • Undo - отменить действие
  • Print - печатать (активна только на вкладках Text, HTML и Rich Text)

(следующие кнопки активны только для вкладки Rich text)

  • выбрать шрифт - раскрывающийся список Font, (активна только на вкладке Rich Text)
  • выбрать размер шрифта - счетчик Font Size, (активна только на вкладке Rich Text)
  • выбрать жирное начертание - Bold, (активна только на вкладке Rich Text)
  • выбрать начертание курсивом - Italic, (активна только на вкладке Rich Text)
  • выбрать начертание с подчеркиванием - Underline, (активна только на вкладке Rich Text)
  • выбрать выравнивание по левому краю - Align Left, (активна только на вкладке Rich Text)
  • выбрать выравнивание по центру - Align Center, (активна только на вкладке Rich Text)
  • выбрать выравнивание по правому краю - Align Right, (активна только на вкладке Rich Text)
  • создать маркированный список - Bullets. (активна только на вкладке Rich Text)

Смотрите также:

Просмотр в виде таблицы

Просмотр в виде формы

Просмотр в виде печатной формы

Редактор данных типа BLOB

Применение изменений

Настройка панелей инструментов


Просмотр в виде таблицы

На основании столбцов таблицы или запроса создается форма табличного просмотра данных. Столбцы формируются из полей.

Если в просмотрщике открыты данные одной таблицы, то их можно добавлять, удалять, редактировать по усмотрению пользователя. Если в просмотрщик выведен результат запроса, то возможность редактирования данных зависит от запроса.

Все остальные операции с данными одинаковы для данных таблиц и для результатов запросов.

С помощью панели инструментов можно выполнять переход по записям, добавление и удаление строк и т.д.

Контекстное меню позволяет копировать ячейки, создавать уровни, устанавливать сводку по столбцам и т.д.

Data View - Grid View

Основные операции с данными:

  • управление столбцами
  • группировка данных
  • фильтрация данных
  • создание и работа с несколькими уровнями
  • просмотр в виде карточек
  • сводка по столбцам
  • изменение порядка столбцов

Смотрите также:

Панели инструментов

Просмотр в виде формы

Просмотр в виде печатной формы

Редактор данных типа BLOB

Применение изменений


Управление столбцами

Выбор видимых столбцов

Можно указывать, какие из столбцов таблицы будут видимыми.

Делается это с помощью пункта контекстного меню Visible Columns или с помощью кнопки btnSelectVisibleColumns в левом верхнем углу таблицы, рядом с заголовками столбцов. По нажатию на эту кнопку появляется окно, в котором, устанавливая флажки, Вы отмечаете видимые столбцы.

Data View - Grid View - Selecting visible columns

Изменение порядка столбцов.

Если Вы хотите изменить порядок столбцов, то достаточно перетащить заголовок столбца в требуемое место. Если в это место можно переместить столбец, то оно будет отмечено зелеными стрелочками, которые появятся при непосредственном приближении к месту вставки.

Data View - Grid View - Changing columns order

Смотрите также:

Группировка данных

Фильтрование данных

Работа с несколькими уровнями

Просмотр в виде карточек

Сводка по столбцу


Группировка и сортировка данных

Чтобы отсортировать данные необходимо:

открыть данные на вкладке Data или Results -> выбрать столбец, по которому хотите отсортировать данные -> нажать на заголовок этого столбца мышкой.

Если столбец не был отсортирован, то одно нажатие отсортирует его по возрастанию, следующее - по убыванию.

Чтобы отменить сортировку, вызовите контекстное меню правой кнопкой мыши на нужном столбце и выберите пункт Clear Sorting, или нажмите клавишу Ctrl и щелкните по столбцу, по которому была отсортирована таблица.

Вы можете группировать данные в таблице по одному или нескольким столбцам.

Для того, чтобы сгруппировать таблицу по столбцу необходимо перетащить заголовок столбца на специальную панель над таблицей, так называемую "панель группировки".

Data View - Grid View - Grouping data

Группировка по одному столбцу

Если на панель группировки Вы поместите заголовок столбца, то все записи таблицы будут сгруппированы по этому столбцу.

Группировка по нескольким столбцам.

Если на панель группировки Вы поместите заголовки нескольких столбцов, то все записи таблицы будут сгруппированы по этим столбцам в указанном порядке.

Таблица будет выглядеть следующим образом.

Data View - Grid View - Grouping data by two columns

В заголовках групп могут отображаться сведения о сгруппированных данных, если была задана сводка по столбцу.

На панели группировки тот заголовок, который находится ниже, является подчиненным. Группировка по нему будет проходить во вторую очередь. Объекты на панели группировки доступны для фильтрации данных.

Отменить группировку можно перетащив заголовок столбца обратно в таблицу. При этом можно изменить порядок столбцов.

Смотрите также:

Управление столбцами

Фильтрование данных

Работа с несколькими уровнями

Просмотр в виде карточек

Сводка по столбцу


Фильтрование данных

Фильтр — это быстрый способ поиска подмножества данных и работы с ними в таблице. В отфильтрованной таблице отображаются только строки, отвечающие условиям, заданным для столбца.

Фильтр не меняет порядок записей. При фильтрации временно скрываются строки, которые не отвечают заданным условиям.

Фильтровать данные в таблице можно тремя способами:

1. С помощью пункта контекстного меню Quick Filter.

Data View - Grid View - Quick Filter

Порядок действий:

  • вызвать контекстное меню для ячейки с данными,
  • выбрать пункт контекстного меню Quick Filter,
  • выбрать из открывшегося дочернего меню условие фильтрации.
  • = Value в таблице будут отображаться только те строки, которые в этом столбце имеют такое же значение, как и активное (активное значение это то для которого было вызвано контекстное меню),
  • <> Value - в таблице будут отображаться только те записи, значение которых в этом столбце не равно активному значению,
  • < Value - будут выбраны значения строго меньше активного,
  • > Value - будут выбраны значения строго больше активного,
  • <= Value - будут выбраны значения меньше активного и равные активному,
  • >= Value - будут выбраны значения больше активного и равные активному.

С помощью Quick Filter нельзя фильтровать данные BLOB-типов и sysname.

2. С помощью заголовков столбцов.

Data View - Grid View - Filtering records

В заголовке каждого столбца имеется кнопка со стрелочкой. Если нажать на эту стрелочку, то появится список значений, содержащихся в этом столбце. Если выбрать одно из этих значений, то это и будет условие фильтрации. В таблице останутся видимыми только те строки, которые соответствуют этому условию.

Кроме того, задавать более сложные условия с помощью пункта списка значений (Custom...).

При выборе этого пункта открывается специальное окно для задания условий фильтрации.

Data View - Grid View - CustomFilter

В этом диалоге можно задать 2 условия фильтрации и их отношение - должны ли выполняться оба условия сразу, или достаточно выполнения одного.

С помощью этого окна очень удобно задавать интервалы.

Из раскрывающихся списков выбираем условие отбора:

  • равно - equals,
  • не равно - does not equal,
  • меньше - is less than,
  • меньше или равно - is less than or equal to,
  • больше - is greater than,
  • больше или равно - is greater than or equal to,
  • содержит - like,
  • не содержит - not like,
  • пустые - is blank,
  • не пустые - is not blank.

В поле указываем последовательность символов. Используйте символ "%" для указания любого набора символов и символ "_" для обозначения любого символа. При выполнении условия отбираются только те значения, которые отвечают указанному условию. Например, из списка Вы выбрали пункт больше, а в поле указали 100. Следовательно, в таблице будут отображаться только те строки, в которых это значение больше 100.

Второе условие не является обязательным.

Установив переключатель в положение AND Вы указываете, что оба условия должны выполняться одновременно, в положение OR указываете, что должно выполняться только одно из них.

3. С помощью кнопки на панели инструментов.

Кнопка btnSetFilter открывает конструктор фильтров, с помощью которого Вы задаете и применяете условия фильтрации.

Если для таблицы установлен фильтр, то в нижней части появляется специальная панель, на которой отображается условие фильтра.

С помощью этой панели можно:

  • удалить фильтр - нажав на кнопку btnClose,
  • включить фильтр - установить флажок,
  • изменить условия фильтрации с помощью кнопки Customize.... Эта кнопка открывает конструктор фильтров.

Data View - Grid View - Filtering records - Filtering panel

Кроме того, на этой панели в кратком виде отображаются условия фильтра, а также история модификации фильтра, которая открывается при нажатии на кнопку раскрывающегося списка.

Смотрите также:

Управление столбцами

Группировка данных

Конструктор фильтров


Контекстное меню

С помощью контекстного меню Вы можете выполнять следующие действия:

Data View - Grid View - Using the context menu

  • Copy Cell - копировать ячейки,
  • Paste Cell - вставить ячейки,
  • Copy All Records - копировать все записи,
  • Copy Selected Records - копировать выделенные записи,
  • Paste Records - вставить записи,
  • Data Manipulation - управлять данными (в управление данными входит: экспортировать данные - Export Data, экспортировать данные в виде SQL скрипта - Export as SQL Script, импортировать данные - Import Data),
  • Quick Filter - установить фильтр данных,
  • Disable Filter - удалить фильтр,
  • Clear Sorting - отменить сортировку,
  • Set Value - установить значение в ячейке,
  • Edit BLOB - редактировать данные типа BLOB (этот пункт меню активен, если меню было вызвано для столбца, содержащего объекты типа BLOB),
  • Save BLOB to File - сохранить данные из ячейки типа BLOB в файл (этот пункт меню активен, если меню было вызвано для столбца, содержащего объекты типа BLOB),
  • Expand All - развернуть все (команда активна только тогда, когда существует группировка по одному или нескольким столбцам или существуют подуровни таблицы),
  • Collapse All - свернуть все (команда активна только тогда, когда существует группировка по одному или нескольким столбцам или существуют подуровни таблицы),
  • Next Tab - перейти на следующую вкладку (этот и следующий пункты меню активны для результатов тех запросов, которые возвращают более одного DataSet. В этом случае для результата каждого запроса создается отдельная вкладка, а также для таблиц, имеющих более одного подуровня),
  • Previous Tab - перейти на предыдущую вкладку,
  • Grid Levels - работать с уровнями таблицы,

Add Grid Level... - добавить уровень (при выборе этого пункта открывается мастер создания уровней),

Delete Grid Level - удалить уровень,

Table View - просмотр в виде таблицы,

Card View - просмотр в виде карточек,

  • Column Summary... - установить сводку по столбцу,
  • Visible Columns - выбрать столбцы, которые будут отображаться (также выбрать видимые столбцы можно с помощью кнопки btnSelectVisibleColumns в левом верхнем углу таблицы, рядом с заголовками столбцов),
  • Fit Columns Widths - выровнять ширину столбцов,
  • Grid Mode - выбрать режим сетки (отображать все строки, отображать только видимые строк или режим по умолчанию),
  • Properties... - просмотреть и изменить свойства просмотрщика данных (откроется Options | Environment Options | Grid).

Важно: Если включены опции CheckBox Show editor immediately и CheckBox Always show editor на вкладке Environment options | Grid, то для вызова контекстного меню ячейки необходимо выделить нужную ячейку и щелкнуть правой кнопкой мышки по заголовку таблицы. При щелчке правой кнопкой мыши по ячейки вызовется контекстное меню для редактирования ячейки.


Работа с несколькими уровнями

Одной из уникальных особенностей SQL Manager for PostgreSQL является возможность работать с данными в режиме нескольких уровней. Это позволяет изменять и просматривать данные в нескольких связанных таблицах одновременно.

Data View - Grid View - Working in multi-level mode

Управлять уровнями можно с помощью пункта контекстного меню Grid Levels,

  • добавить уровень - Add Grid Level... (при выборе этого пункта открывается мастер создания уровней),
  • удалить уровень - Delete Grid Level,
  • просмотр в виде таблицы - Table View,
  • просмотр в виде карточек - Card View,

Когда добавлен уровень, то для каждой записи таблицы можно просмотреть соответствующие ей записи в другой таблице. Такая подчиненная таблица называется Подуровень.

Чтобы открыть (развернуть) подуровень таблицы нужно нажать на "+", который находится в начале строки. "-" сворачивает подуровень.

Подуровней может быть несколько. В этом случае каждый располагается на отдельной вкладке в окне подуровней. Между вкладками можно переключаться, просто щелкая на них мышью, или с помощью пунктов контекстного меню:

  • перейти на следующую вкладку - Next Tab,
  • перейти на предыдущую вкладку - Previous Tab.

Для того чтобы открыть подуровни для всех записей используется пункт контекстного меню Expand All.

Пункт Collapse All сворачивает все подуровни.

Смотрите также:

Контекстное меню

Мастер создания уровней


Мастер создания уровней

Мастер создания уровней позволяет создать для таблицы новые подуровни для более удобного представления данных.

Мастер создания уровней состоит из четырех шагов.

  • Выбор главной таблицы.
  • Выбор зависимой таблицы или запроса.
  • Установка связи между главной и зависимой таблицами.
  • Задание параметров.

Чтобы запустить Мастер, необходимо выбрать пункт дочернего меню Add Grid Level..., пункта контекстного меню Grid Levels.

Create Grid Level - Add Grid Level


Выбор главной таблицы

На первом шаге Вы выбираете таблицу или запрос, который будет являться главным уровнем, к которому потом нужно будет назначить подуровень.

Из раскрывающегося списка выберите главный уровень.

Далее, с помощью переключателя Source of New level data, выбираете источник для подуровня.

RadioButton Если устанавливаете переключатель в положение Table, то на втором шаге вам будет предложено выбрать таблицу или представление.

RadioButton Если в положение Query, то на следующем шаге необходимо будет вручную написать запрос, определяющий подуровень.

Create Grid Level - Specifying master level

Следующий шаг


Выбор зависимой таблицы или запроса

Вид мастера на втором шаге зависит от того, какой источник для подуровня Вы выбрали на первом шаге.

Если в качестве источника Вы выбрали Table, то на втором шаге Вам будет предложено выбрать конкретную таблицу из раскрывающегося списка Table Name. В списке содержатся все имеющиеся в базе данных таблицы и представления.

CheckBox Вы можете уменьшить их число, установив флажок Show tables related by foreign keys only. В этом случае в списке останутся только те таблицы, которые связаны с главной с помощью внешнего ключа.

Create Grid Level - Defining source for detail level - Table

Если на первом шаге в качестве источника Вы выбрали запрос, то на втором шаге Вы должны будете создать запрос в редакторе запроса

Create Grid Level - Defining source for detail level - Query

В этом окне находится редактор SQL запросов.

Вы можете написать SQL запрос вручную в редакторе,

Можете его скопировать и вставить в редактор,

С помощью кнопки Design Query... Вы можете запустить Дизайнер запросов, который откроется в модальном окне, и создать запрос там.

После того, как выбрана таблица или создан запрос, можно переходить к следующему шагу.

Следующий шаг


Установка связи между главной и зависимой таблицей

На третьем шаге Вы выбираете столбцы, по которым необходимо связать главную и подчиненную таблицы.

Create Grid Level - Binding master and detail levels

Из списков Master Level Key Columns и Detail Level Key Columns выберите столбцы главной и подчиненной таблиц, по которым эти таблицы будут связаны.

С помощью кнопки Add добавьте в список Links Between Master and Detail Levels новую связь, которая образуется из выбранных столбцов.

Связей может быть несколько.

В этом случае, каждая подчиненная таблица будет отображаться на отдельной вкладке подуровня. Между вкладками можно переключаться, просто щелкая на них мышью, или с помощью пунктов контекстного меню:

  • перейти на следующую вкладку - Next Tab,
  • перейти на предыдущую вкладку - Previous Tab.

Удалить связь из списка можно с помощью кнопки Remove.

Следующий шаг


Параметризация запросов

Если на шаге Выбор главной таблицы был выбран запрос, то на этом шаге Вам необходимо задать параметры. Форма для задания параметров будет использоваться в сетке данных в режиме 'Load visible rows'. Смотрите дополнительно Environment Options | Grid | Data Options.

Create Grid Level - Query parameterization

Следующий шаг


Задание параметров

На последнем шаге необходимо выбрать вид отображения подуровня и указать его заголовок.

Заголовок отображается в верхней части подуровня. Указать его можно в поле Level caption.

с помощью переключателя Level type выберите, в каком виде будут отображаться данные подуровня:

RadioButton Table view - в виде таблицы,

RadioButton Card View - в виде карточек.

Create Grid Level - Setting additional parameters

Нажав кнопку Run, Вы закончите формирование уровня.


Просмотр в виде карточек

В окне табличного просмотра существует дополнительный режим просмотра - режим карточек. Card View.

Если в таблице есть подуровни, то в виде карточек можно представить только самый нижний уровень иерархии подчинения.

Чтобы включить просмотр в виде карточек, необходимо использовать пункт дочернего меню Card View пункта контекстного меню Grid Levels.

Data View - Grid View - Working in card view mode

Чтобы вернуть вид таблицы, воспользуйтесь пунктом дочернего меню Table View пункта контекстного меню Grid Levels.

Смотрите также:

Контекстное меню


Сводка по столбцу

В SQL Manager for PostgreSQL существует специальный инструмент, позволяющий выводить итоговую информацию о столбце. С помощью этого инструмента можно вывести в нижнюю или в верхнюю часть таблицы некую сводку по столбцу.

Data View - Grid View - Column Summary

инструмент создания сводок по столбцам вызывается с помощью пункта контекстного меню Column Summary....

В окне Column Summary из списка Column выбираете столбец таблицы, для которого хотите отображать дополнительную информацию.

Footer summary отображает итоговую информацию в нижнем колонтитуле таблицы.

Group header - отображает информацию в заголовке сгруппированных данных.

Group footer - отображает данные в нижнем колонтитуле сгруппированных данных.

Информация, которую можно вывести для столбцов:

  • None - ничего
  • Sum - сумму значений в столбце
  • Minimum - минимальное значение в столбце
  • Maximum - максимальное значение в столбце
  • Count - количество значений в столбце
  • Average - среднее значение в столбце

Для всех остальных типов столбцов доступно только количество значений в столбце - Count.

В поле Number format задаете формат числа.

Смотрите также:

Контекстное меню


Копирование строк

При копировании нескольких строк Вы можете задать соответствие столбцов таблицы и вставляемых строк.

Data View - Grid View - Associate columns

В списке Clipboard Columns отображаются столбцы копируемых строк.

В списке Grid Columns - столбцы таблицы, в которую копируются строки.

С помощью кнопок устанавливаются соответствия между столбцами. Они отображаются в списке соответствий, располагающемся в нижней части формы.

Кнопка Add добавляет в список соответствий новое соответствие между выделенными столбцами.

Кнопка Add All позволяет автоматически подобрать столбам таблицы, в которую копируются данные соответствующие столбцы источника данных.

Нажав на кнопку Remove, Вы удалите выделенное соответствие. Нажатие на кнопку Remove All полностью очищает список соответствий.

CheckBox First row is a header

Если установлен этот флажок, то первая строка будет воспринята, как заголовок таблицы


Просмотр в виде формы

На вкладке Form View каждая запись представлена в Виде формы. Редактировать данные удобнее, когда они представлены в таком виде.

Data View - Form View

Если на вкладке Grid View Вы выделили строчку или ячейку, а затем перешли на вкладку Form View, то на этой вкладке отобразится выделенная запись.

Для каждой записи отображается:

  • название столбцов,
  • тип столбцов,
  • поля для редактирования данных.

CheckBox Рядом с каждым полем расположен флажок Null. С его помощью можно это поле очистить. Вернуть удаленные данные, убрав флажок, не получится. Чтобы вернуть данные необходимо нажать на кнопку

Переключаться между записями можно с помощью кнопок, расположенных на панели инструментов. Эти кнопки позволяют вам создавать, редактировать, удалять записи и перемещаться по записям таблицы базы данных.

Для каждого типа данных генерируется поле ввода соответствующее типу данных.

Например, для поля типа datetime появляется календарь, позволяющий избежать ошибок при вводе даты.

Для типов полей большого размера создаются большие текстовые поля.

Если Вы на этой вкладке зададите условия для фильтрования данных, то отобразится первая запись таблицы, отвечающая заданным условиям.

Смотрите также:

Панели инструментов

Просмотр в виде таблицы

Просмотр в виде печатной формы

Редактор данных типа BLOB

Применение изменений


Просмотр в виде печатной формы

На вкладке Print Data данные представлены в режиме полного графического соответствия печатного варианта и изображения редактируемого документа на экране.

Вы можете изменять вид печатной формы, задавать формат страницы, параметры печати, сохранять отчеты в файл и загружать из файла. Все это делается с помощью панелей инструментов.

Data View - Print Data

На верхней панели отображаются характеристики полей и колонтитулов печатного документа:

  • Left - левое поле,
  • Top - верхнее поле,
  • Right - правое поле,
  • Bottom - нижнее поле,
  • Header - верхний колонтитул,
  • Footer - нижний колонтитул.

На нижней панели отображается статистика:

  • Page - страницы,
  • количество страниц - Pages,
  • Paper size - размер бумаги,
  • Status - статус.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет

Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite Вы можете в сравнительной таблице характеристик.

Смотрите также:

Панели инструментов

Просмотр в виде таблицы

Просмотр в виде формы

Редактор данных типа BLOB

Применение изменений


Параметры страницы

Чтобы открыть диалоговое окно настройки страницы для печати необходимо на панели инструментов нажать кнопку [image] Page Setup.

С помощью этого инструмента Вы можете настроить вид страницы при печати.

Настройки печати Вы можете задать на следующих вкладках:

Страница

Поля

Колонтитулы

Масштаб

Чтобы распечатать страницу, нажмите кнопку Print. Настройки печати укажите в открывшемся диалоговом окне Print.

Смотрите также:

Настройщик отчетов

Задание опций отчета

Печать


Страница

На вкладке Page Вы указываете размер и ориентацию страницы.

Data View - Print Data - Page Setup - Page

Из списка Type выбираете один из типовых размеров.

Если стандартные типы не подходят, то указываете высоту и ширину листа в разделе Dimension. В поле Width - ширину, в поле Height - высоту.

Из раскрывающегося списка Paper source выбираете тип подачи бумаги.

С помощью переключателя в разделе Orientation Вы выбираете ориентацию страницы.

  • Portrait - книжная,
  • Landscape - альбомная.

Так данные представлены в табличной форме, то при печати необходимо указать последовательность вывода страниц в разделе Print Order:

  • Down, then over - вниз, затем вправо,
  • Over, then down - вправо, затем вниз.

Если установить флажок Print using gray shading, то при печати будут использоваться оттенки серого цвета, а не только черный и белый.


Поля

На вкладке Margins Вы можете указать размер полей документа и размер колонтитулов.

Data View - Print Data - Page Setup - Margins

  • Top - размер верхнего поля
  • Bottom - размер нижнего поля
  • Left - размер левого поля
  • Right - размер правого поля
  • Header - размер верхнего колонтитула
  • Footer - размер нижнего колонтитула

Если вы задали неподходящее значение, то нажмите на кнопку Fix, чтобы его исправить.

Нажатие на кнопку Restore Original возвращает настройки к настройкам по умолчанию.

С помощью флажков в разделе Center on page Вы указываете, следует ли центрировать текст на странице.

Если установлен флажок Horizontally, то текст центрируется по горизонтали,

Если Vertically, то по вертикали.

Все указанные отображаются в разделе Preview.


Колонтитулы

На вкладке Header\Footer Вы можете задать свойства верхнего и нижнего колонтитулов.

Data View - Print Data - Page Setup - Header and Footer

Каждый колонтитул поделен на 3 раздела. В каждом разделе можно указывать разную информацию. Текст можно писать самостоятельно, а можно выбрать стандартный с помощью кнопок Predefined Function:

  • Machine name - имя компьютера,
  • User Name - имя пользователя,
  • Time Printed - время печати,
  • Date Printed - дата печати,
  • Date & Time Printed - дата и время печати документа,
  • Page # of Pages # - страница № из общего числа страниц
  • Total Pages - общее число страниц
  • Page # - номер страницы

Для колонтитула можно задавать шрифт - с помощью кнопки Font... и фон с помощью кнопки Background.

Выравнивание текста по вертикали осуществляется при помощи кнопок Vertical Alignment.

CheckBox Reverse on even pages

Если установлен этот флажок, то указанные колонтитулы будут отображаться на каждой странице.


Масштаб

На вкладке Scaling указывается масштаб страницы.

Data View - Print Data - Page Setup - Scaling

Adjust To - установить n процентов от натуральной величины. Проценты указываются в специальном поле.

Fit To - разместить не более чем на n страниц в ширину и n страниц в высоту. Количество страниц задается в специальных полях.


Настройщик отчетов

Настроить вид печатной формы можно с помощью инструмента Format report, который открывается при нажатии кнопки [image] Design Report на панели инструментов вкладки Print data просмотрщика данных.

Вкладки

Настройка отображаемых областей

Характеристики (поведение)

Форматирование

Стили

Предварительный просмотр

Карточки

Диаграммы

Нажав на кнопку Title Properties, Вы сможете задать параметры титульного листа отчета.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Параметры страницы

Задание опций отчета

Печать


Настройка отображаемых областей

На вкладке View, с помощью флажков, Вы можете выбрать те области, которые будут отображаться в отчете:

Data View - Print Data - Report Formatter - View

В разделе Show выберите те элементы, которые будут отображаться для всей таблицы.

CheckBox Caption - строка заголовка страницы,

CheckBox Bands - видимые диапазоны, (опция недоступна)

CheckBox Headers - заголовки столбцов,

CheckBox Footers - строки итогов,

CheckBox Group Footers - область группировки данных

CheckBox Expand Buttons -

CheckBox Filter Bar - панель фильтра. Если данные были отфильтрованы, то в этой строке будет показано условие фильтрации.

Далее, в разделе On Every Page, Вы можете указать те разделы, которые будут на каждой странице

CheckBox Caption - строка заголовка страницы,

CheckBox Bands - видимые диапазоны,

CheckBox Headers - заголовки столбцов,

CheckBox Footers - строки итогов,

CheckBox Filter Bar - панель фильтра.

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Характеристики (поведение)

На этой вкладке задайте следующие характеристики:

Data View - Print Data - Report Formatter - Behaviors

В разделе Selection настройте параметры выделения:

CheckBox Process Selection - обрабатывать выделенный текст,

CheckBox Process Exact Selection - процесс точного выделения.

Элементы, которые будут развернуты на печатной форме выберите в разделе Expanding.

CheckBox Groups - группы,

CheckBox Details - детали,

CheckBox Cards - карточки.

Если установлен флажок Auto Width, то ширина таблицы будет равна ширине страницы.

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Форматирование

Параметры форматирования задайте на вкладке Formatting.

Из раскрывающегося списка Look and Feel выберите оформление границ ячеек заголовка.

В разделе Refinements можно задать параметры сжатия отчета.

CheckBox Transparent Graphics - прозрачные графические изображения,

CheckBox Display Graphic As Text - отображать вместо графики текст,

CheckBox Flat CheckMarks - использовать плоские флажки.

CheckBox Suppress Background Textures - сглаживать текстуры фона.

CheckBox Consume Selection Style - не применять стили выделения.

Параметры разбиение на страницы задайте в разделе Pagination.

CheckBox By TopLevel Groups - разбиение на страницы в соответствии с группировкой,

CheckBox One Group Per Page - одна группа на странице.

Data View - Print Data - Report Formatter - Formatting

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Стили

На этой вкладке Вы можете менять внешний вид отчета.

Data View - Print Data - Report Formatter - Styles

CheckBox Если установлен флажок Use Native Styles, то будет использоваться только стиль по умолчанию, изменения нельзя будет внести.

В списке находятся все элементы отчета, кроме того, для каждого элемента указан фон, вид и размер шрифта.

Для каждого элемента можно задать следующие свойства:

  • Font - шрифт,
  • Color - цвет,
  • Texture - текстура,
  • Clear - вернуть настройки по умолчанию

Нажав на кнопку Restore Defaults, Вы отмените все внесенные изменения для выделенного объекта и установите настройки по умолчанию.

С помощью кнопки Save As... Вы можете сохранить принятые изменения в файл схемы.

Все файлы схемы отображаются в списке Style Sheets. Нажав на кнопку New, Вы создадите новый файл схемы. Копировать нужную схему можно, нажав на кнопку Copy. Кнопка Delete удаляет выбранную схему. Чтобы переименовать активную схему нажмите на кнопку Rename.

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Предварительный просмотр

Параметры предпросмотра задайте на этой вкладке

Data View - Print Data - Report Formatter - Preview

CheckBox Если установлен флажок Visible, то будут отображаться строки группировки.

CheckBox Если установлен флажок Auto Height, то высота строк будет задана автоматически.

Задайте максимальное количество строк на странице в счетчике Max Line Count.

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Карточки

На этой вкладке Вы можете задать внешний вид карточек.

В разделе Sizes можно настроить размеры карточек:

CheckBox установленный флажок Auto Width автоматически подгоняет ширину карточек

CheckBox Keep Same Width - фиксирует исходную ширину.

CheckBox Keep Same Height - фиксирует исходную высоту карточки.

В разделе Spacing задайте расстояние между карточками:

Horizontal - расстояние по горизонтали,

Vertical - расстояние по вертикали.

В разделе Framing можно задать параметры рамок карточек

CheckBox Border - если установлен этот флажок, то у карточек будет внешняя граница,

CheckBox Horizontal Lines - устанавливает внутри карточки горизонтальные разграничители для каждой строки

CheckBox Vertical Lines - добавляет разграничители для столбцов.

С помощью инструментов в разделе Shadow задайте параметры тени карточек.

Color - цвет тени,

Depth - размер тени.

Data View - Print Data - Report Formatter - Cards

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Диаграммы

На этой вкладке Вы можете задать такое свойство диаграммы как прозрачность, установив флажок Transparent.

Data View - Print Data - Report Formatter - Charts

Все внесенные изменения отображаются на образце, расположенном в правой части формы.


Задание опций отчета

Опции

Чтобы открыть это диалоговое окно, откройте раскрывающийся список Design Report [image] на панели инструментов и выберите пункт Preferences item.

Data View - Print Data - Report options

В разделе Show выберите элементы, которые будут отображаться на предварительном просмотре.

Margins - поля.

Margins hints - сведения о размере поля.

Margins hints while dragging - сведения о размере поля, отображающиеся при его изменении с помощью перетаскивания.

Из раскрывающегося списка Measurement Units выберите единицы измерения, в которых будет измеряться размер поля. Это могут быть дюймы (inches), миллиметры (millimeters) или единицы, принятые по умолчанию на этом компьютере. (default).

Параметры масштаба укажите в разделе Zoom Parameters.

CheckBox Zoom on roll with IntelliMouse

Если установлен этот флажок, то Вы можете менять масштаб страницы, вращая колесико мышки и удерживая клавишу Ctrl.

Zoom Step

В этом счетчике задайте процент изменения масштаб страницы, при Zoom on roll with IntelliMouse.

Из раскрывающегося списка Margins Color выберите цвет полей страницы.

Заголовок отчета

В этом диалоговом окне Вы можете задать настройки заголовка печатаемого документа.

Чтобы открыть это окно, нажмите кнопку Title... на панели инструментов.

Data View - Print Data - Report options - Title

Mode

Из этого раскрывающегося списка выберите, как должен отображаться заголовок.

On the first page - на первой странице.

On every top page - на каждой странице.

Not displayed at all - не отображать

На вкладке Text укажите Текст заголовка.

Properties

CheckBox Transparent

Если установлен этот флажок, то заголовок будет прозрачным.

Цвет заголовка выберите из раскрывающегося списка Color. Вы можете изменить цвет, только если не установлен флажок CheckBox Transparent.

Нажмите кнопку Font, чтобы задать шрифт заголовка в стандартном диалоговом окне.

CheckBox Adjust on scale

Если установлен этот

If this option is selected, the title can be adjusted on scale.

Alignment

В разделе Alignment укажите выравнивание заголовка по горизонтали (Horizontally) и вертикали (Vertically).

Для восстановления значений по умолчанию, нажмите кнопку Restore Defaults.

Дата и время

Чтобы открыть это диалоговое окно, откройте раскрывающийся список Title [image] на панели инструментов и выберите пункт Date and Time.

В открывшемся диалоговом окне задайте настройки даты и времени для документа.

Data View - Print Data - Report options - Date and Time

Из списков Available Date Formats и Available Time Formats выберите формат даты и времени.

При необходимости, Вы можете указать, что дата и время будут обновляться автоматически, установив флажок Update automatically.

Чтобы применить форматы даты и времени, принятые в системе по умолчанию, нажмите кнопку Default.

Нумерация страниц

Вы можете задать нумерацию страниц печатного документа.

Чтобы открыть это диалоговое окно, откройте раскрывающийся список Title [image] на панели инструментов и выберите пункт Page Numbering.

Data View - Print Data - Report options - Page Number Format

Формат номера страницы выберите из раскрывающегося списка

RadioButton Continue from the previous section - продолжить нумерацию

RadioButton Start At - начать нумерацию. С какого значения необходимо начать нумерацию страниц, укажите в соответствующем поле.

Для восстановления значений по умолчанию, нажмите кнопку Defaults.

Масштаб

Параметры масштаб страницы укажите в этом окне.

Чтобы открыть это диалоговое окно, откройте раскрывающийся список Title [image] на панели инструментов и выберите пункт Setup zoom.

Data View - Print Data - Report options - Zoom

Выберите одно из часто используемых значений масштаба (500%, 200%, 150%, 100%, 75%, 50%, 25%, 10%) или укажите процент вручную в счетчике Percent.

RadioButton Page Width - по ширине страницы.

RadioButton Whole Page - целая страница.

RadioButton Two Pages - две страницы.

RadioButton Four Pages - четыре страницы.

RadioButton Many Pages = несколько страниц.

В разделе Preview отображаются принятые изменения.

Смотрите также:

Параметры страницы

Настройщик отчетов

Печать


Печать

Стандартное диалоговое окно Print позволит Вам настроить параметры печати.

Это окно открывается при нажатии кнопки btnPrintSetup на панели инструментов, или клавиш Ctrl+P.

Data View - Print Data - Print dialog

Чтобы начать печать, нажмите кнопку Print.

Если Вы хотите изменить параметры страницы, то нажмите кнопку Page Setup. В появившемся диалоговом окне Page Setup задайте необходимые настройки.

Смотрите также:

Параметры страницы

Настройщик отчетов

Задание опций отчета


Редактор данных типа BLOB

Если в таблице содержатся поля BLOB (к этому типу относятся такие типы как: bytea, xml, text), то в просмотрщике данных появляется дополнительная вкладка Blob View. На этой вкладке можно редактировать любой тип данных, относящихся к BLOB. Для каждого типа создана своя вкладка:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как RTF

Редактировать как изображение

Редактировать как HTML

Редактировать как XML

Data View - BLOB View

Работа с записями на вкладке Blob View.

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа BLOB вынесены на панель инструментов вкладки Blob View.

Чтобы сохранить внесенные изменения, нажмите кнопку Post Edit на панели инструментов вкладки Blob View.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Панели инструментов

Просмотр в виде таблицы

Просмотр в виде формы

Просмотр в виде печатной формы

Применение изменений


Редактировать в шестнадцатеричном представлении

На вкладке Hexadecimal Вы можете просмотреть и отредактировать информацию, содержащуюся в одной ячейке поля типа BLOB. В левой части формы содержимое ячейки представлено в шестнадцатеричном виде (шестнадцатеричные значения байтов), а в правой - в виде обычного текста.

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа BLOB вынесены на панель инструментов вкладки Blob View.

Data View - BLOB View - Hexadecimal

Смотрите также:

Редактировать как текст

Редактировать как RTF

Редактировать как изображение

Редактировать как HTML

Редактировать как XML

Редактировать как PDF

Редактировать как JSON


Редактировать как текст

На вкладке Text содержимое ячейки представлено в виде обычного текста, доступного для редактирования.

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа BLOB вынесены на панель инструментов вкладки Blob View.

Data View - BLOB View - Text

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как RTF

Редактировать как изображение

Редактировать как HTML

Редактировать как XML

Редактировать как PDF

Редактировать как JSON


Редактировать как RTF

На вкладке Rich Text текст представлен в виде RTF (Rich Text Format). Его можно форматировать: изменять шрифт, менять начертание и размер шрифта, добавлять списки, устанавливать междустрочные интервалы и т.п.

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа BLOB вынесены на панель инструментов вкладки Blob View.

Data View - BLOB View - Rich Text

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как изображение

Редактировать как HTML

Редактировать как XML

Редактировать как PDF

Редактировать как JSON


Редактировать как изображение

Если столбец в базе данных имеет тип image, то добавить в этот столбец изображение и просматривать его можно на вкладке Image инструмента Blob View.

Data View - BLOB View

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа BLOB вынесены на панель инструментов вкладки Blob View.

На панели в нижней части формы отображается информация о размере и формате изображения.

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как RTF

Редактировать как HTML

Редактировать как XML

Редактировать как PDF

Редактировать как JSON


Редактировать как HTML

Если тип данных в ячейке HTML, то просматривать его можно на вкладке HTML.

Data View - BLOB View - HTML

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа BLOB вынесены на панель инструментов вкладки Blob View.

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как RTF

Редактировать как изображение

Редактировать как XML

Редактировать как PDF

Редактировать как JSON


Редактировать как XML

Если тип данных в ячейке XML (eXtensible Markup Language), то просматривать и редактировать данные можно на вкладке XML.

Data View - BLOB View - XML

На вкладке XML данные представлены в виде таблицы со столбцами Name, Unique, Attributes и Value.

Вы можете изменять структуру XML документа с помощью контекстного меню или перетаскивания объектов.

Контекстное меню

Это меню открывается при нажатии на рабочую область правой кнопкой мыши.

С помощью контекстного меню Вы можете:

  • Добавить узел (подузел выбранного) - Add a node.
  • Удалить выбранный узел - Remove node.
  • Копировать содержимое узла в буфер обмена - Copy node source to clipboard.
  • Вырезать выбранный узел - Cut node.
  • Копировать узел - Copy node.
  • Вставить узел - Paste node.

Нажмите кнопку [image], чтобы добавить или редактировать атрибут пункта.

Data View - BLOB View - XML - Item attributes

Используйте кнопки btnAddItem btnRemoveItem, чтобы добавить и удалить атрибуты.

Важно: При перетаскивании мышкой узла, удерживайте клавишу Shift, если хотите сделать его подузлом другого.

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как RTF

Редактировать как изображение

Редактировать как HTML

Редактировать как PDF

Редактировать как JSON


Редактировать как PDF

Вкладка PDF позволяет просматривать данные BLOB в формате PDF.

Data View - BLOB View - PDF

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с документами PDF вынесены на панель инструментов вкладки Blob View.

На панели в нижней части формы отображается информация о размере и формате изображения.

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как RTF

Редактировать как изображение

Редактировать как HTML

Редактировать как XML

Редактировать как JSON


Редактировать как JSON

Вкладка JSON позволяет просматривать данные BLOB в формате PDF.

Data View - BLOB View - JSON

Для перемещения по записям используйте стандартную панель инструментов просмотрщика данных. На этой же панели располагаются кнопки сохранения изменений, отмены сохранения изменений, добавления и удаления записей.

Кнопки для работы с данными типа JSON вынесены на панель инструментов вкладки Blob View.

На панели в нижней части формы отображается информация о размере и формате изображения.

Смотрите также:

Редактировать в шестнадцатеричном представлении

Редактировать как текст

Редактировать как RTF

Редактировать как изображение

Редактировать как HTML

Редактировать как XML

Редактировать как PDF


Применение изменений

После того, как Вы внесли изменения, нажмите кнопку Post Edit btnPostEdit на навигационной панели, чтобы сохранить внесенные изменения. Если Вы хотите отменить внесенные изменения, то нажмите кнопку Cancel Edit btnCancelEdit на навигационной панели.

Data View - Applying changes

Смотрите также:

Панели инструментов

Просмотрщик данных

Просмотр в виде формы

Просмотр в виде печатной формы

Редактор данных типа BLOB


Конструктор фильтров

В SQL Manager for PostgreSQL имеется специальный инструмент для задания условий отбора данных в таблице просмотрщика данных. С помощью конструктора фильтров Вы можете не только создать условие отбора любого уровня сложности, но и сохранить его в файл и загрузить из файла (см. Кнопки конструктора фильтров), что позволяет многократно использовать один фильтр.

Запуск конструктора фильтров

Работа с условиями

Работа с группами

Применение фильтра

Filter Builder dialog - Setting filter criteria

Смотрите также:

Просмотрщик данных


Запуск конструктора фильтров

Конструктор фильтров можно открыть двумя способами:

  • с помощью кнопки Filter data btnSetFilter на Панели работы с записями:
  • с помощью кнопки Customize.... на панели в нижней части таблицы.

Если для таблицы установлен фильтр, то в нижней части появляется специальная панель, на которой отображается условие фильтра.

С помощью этой панели можно:

  • удалить фильтр - нажав на кнопку btnClose,
  • включить фильтр - установить флажок,
  • изменить условия фильтрации с помощью кнопки Customize.... Эта кнопка и открывает конструктор фильтров.

Data View - Grid View - Filtering records - Filtering panel

Кроме того, на этой панели в кратком виде отображаются условия фильтра, а также история модификации, которая открывается при нажатии на кнопку раскрывающегося списка.


Работа с условиями

Добавить новое условие можно двумя способами:

  • нажать кнопку press the button to add condition,
  • выбрать из меню, открывшегося при нажатии кнопки Filter пункт Add Condition.

Условия можно объединять в группы.

Отношение между группами определяется групповым оператором, который выбирается из списка, открывающегося по нажатию на пункт меню выбора оператора (надпись AND на рисунке).

Надпись после меню выбора оператора указывает на группу, в которой находятся условия. Идентификатор главной группы - <root>.

Filter Builder dialog - Setting group operator

Далее необходимо указать одно или несколько условий отбора данных. Каждая строчка - это одно условие.

Добавить или удалить условие можно с помощью меню,

которое открывается при нажатии на кнопку EllipsisButton.

  • добавить условие - Add Condition,
  • добавить группу - Add Group,
  • удалить группу или условие - Remove Row.

По нажатию на надпись, выделенную зеленым цветом, открывается список столбцов таблицы, запроса или представления. Из списка выбираем тот столбец, для которого хотим указать условие отбора.

Filter Builder dialog - Setting filter criteria

Нажав на следующую надпись, выбираем оператор из раскрывающегося списка.

Filter Builder dialog - Setting filter operator

В списке содержатся следующие операторы:

  • равно - equals,
  • не равно - does not equal,
  • больше - is greater than,
  • больше или равно - is greater than or equal to,
  • меньше - is less than,
  • меньше или равно - is less than or equal to,
  • похоже (для текстовых столбцов) - like,
  • не похоже (для текстовых столбцов) - not like,
  • пустые - is blank,
  • не пустые - is not blank,
  • между <значение> и <значение> - between,
  • не между - not between,
  • в - in,
  • не в - not in.

(по умолчанию для числовых столбцов и столбцов типа datetime стоит оператор equals, для текстовых - like)

Для столбцов типа Дата в этом списке появляется ещё несколько операторов:

  • вчера - is yesterday,
  • сегодня - is today,
  • завтра - is tomorrow,
  • на прошлой неделе - is last week,
  • в прошлом месяце - is last month,
  • в прошлом году - is last year,
  • на этой неделе - is this week,
  • в этом месяце - is this month,
  • в этом году - is this year,
  • не следующей неделе - is next week,
  • в следующем месяце - is next month,
  • в следующем году - is next year.

Выбрав оператор, необходимо указать критерий отбора. При нажатии на надпись <empty> вместо этой надписи появляется поле для ввода значения. Тип столбца соответствует типу данных. Для текста это текстовое поле, для числовых - счетчик, для даты и времени - календарь. Используйте символ "%" для указания любого набора символов и символ "_" для обозначения любого символа.

Filter Builder dialog - Setting filter criteria values

Для операторов between и not between появляется два поля ввода, так как нужно указать интервал.

В поле указываем последовательность символов. При выполнении условия отбираются только те значения, которые отвечают указанному условию.

Например, оператор Вы выбрали is greater than (больше), а в поле указали 100. Следовательно, в таблице будут отображаться только те строки, в которых это значение больше 100.


Работа с группами

Условий для фильтра можно задавать несколько, а также объединять эти условия в группы и задавать отношения между группами условий.

Группы имеют иерархическую структуру. Групповой оператор распространяется на те группы, которые находятся внутри той группы, для которой он установлен.

В каждой группе задаются условия для одного столбца.

Filter Builder dialog - Adding a new group

Добавить группу можно с помощью пункта Add Group контекстного меню, открывающегося при нажатии кнопки EllipsisButton

Отношение между группами определяется групповым оператором, который выбирается из списка, открывающегося по нажатию пункт меню выбора оператора (надпись AND на рисунке)..

Filter Builder dialog - Setting group operator

Групповых операторов четыре:

  • AND - одновременно должны выполняться все группы условий,
  • OR - выполняться должна хотя бы одна группа условий,
  • NOT AND - не должно выполняться хотя бы одно из перечисленных условий,
  • NOT OR - не должно выполняться ни одно из перечисленных условий.


Кнопки конструктора фильтров

Файл фильтра имеет расширение .flt. Открыть такой файл можно с помощью кнопки Open, расположенной внизу формы. Кнопка Save As позволяет сохранять созданный фильтр в файл.

Filter Builder dialog - Applying filter conditions

Чтобы применить созданный фильтр, используйте кнопки OK или Apply. При нажатии на Ok конструктор закроется, при нажатии на Apply останется открытым, и Вы сможете, исходя из результатов, исправить созданный фильтр.

Кнопка Cancel закрывает конструктор без сохранения изменений.


Средства импорта и экспорта данных

SQL Manager for PostgreSQL предоставляет пользователю набор инструментов для быстрого и удобного импорта и экспорта данных.

Экспорт данных

Экспорт данных осуществляется в файлы различных форматов. В том числе: MS Excel, MS Access, RTF, HTML, PDF. и т.д.

Импорт данных

Импортирует данные из файлов разных форматов: MS Excel, MS Access, DBF, TXT, and CSV.

Экспорт в виде SQL скрипта

Экспорт данных в SQL скрипт как набор операторов INSERT.

Загрузка данных

Загружает данные в таблицу или представление.

Сохранение данных

Позволяет сохранить данные

Использование шаблонов

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Мастер экспорта данных

Мастер экспорта данных - Export Data Wizard - позволяет экспортировать данные из таблиц, представлений, результатов запроса в файлы самых распространенных форматов.

Экспорт данных можно осуществлять только из тех редакторов, где есть вкладка Data или Results. Это Редактор таблиц, Редактор представлений, Редактор запросов и Дизайнер запросов.

Этот инструмент открывается с помощью кнопки Export Data, располагающейся на навигационной панели Data Management и на панели инструментов.

Кнопка доступна, когда в редакторе открыт просмотрщик данных, то есть на вкладке Data или Results.

Также эта команда присутствует в контекстном меню объектов таблицы и представления, в проводнике баз данных и в подменю пункта Data Manipulation.

Задание имени и формата выходного файла

Выбор экспортируемых столбцов

Настройка форматов данных

Установка колонтитулов

Задание особенностей форматов

Задание общих опций экспорта

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер импорта данных

Мастер экспорта в виде SQL скрипта

Мастер сохранения данных

Мастер загрузки данных

Использование шаблонов


Задание имени и формата выходного файла

На этом шаге мастера экспорта данных Вам необходимо:

  • выбрать формат выходного файла - в разделе Destination format - установив переключатель напротив нужного формата,
  • в поле Destination file name указываете имя выходного файла и путь к нему с помощью кнопки btnSaveAs.

Export Data - Setting destination file name and format

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор экспортируемых столбов

На этом шаге Вам необходимо из списка всех колонок таблицы или представления выбрать те, которые Вы хотите экспортировать.

Из списка Available columns выберите доступные столбцы и с помощью кнопок переместите их в список экспортируемых колонок - Selected columns. Если не выбрать ни одного столбца, то по умолчанию будут экспортированы все столбцы, кроме столбов, содержащих данные BLOB.

Установленный флажок Allow captions указывает на то, что заголовки столбцов будут вынесены в первую строку.

Export Data - Selecting fields for export

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Настройка форматов данных

На третьем шаге Вы задаете, в каком формате будут отображаться данные.

Форматы отображения Вы можете задать для следующих форматов данных.

  • Integer format - Целое число
  • Float format - Число с плавающей точкой
  • Date format - Дата
  • Time format - Время
  • DateTime format - Дата и время
  • Currency format - Денежный
  • Boolean True - Истина
  • Boolean False - Ложь
  • Null string - Строка NULL

Для некоторых типов данных дополнительно можно указать разделители разрядов:

Decimal Separator - разделитель для десятичных чисел,

Date Separator - разделитель для даты,

Thousand Separator - разделитель разрядов числа,

Time Separator - разделитель для времени.

Export Data - Adjusting data formats

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Установка колонтитулов

На этом шаге можно задать текст, который будет отображаться в верхнем и нижнем колонтитулах выходного файла.

Если Вы выбрали формат файла, не поддерживающий колонтитулы, то этого шага не будет.

В поле Header text указываете текст верхнего колонтитула.

В поле Footer text - нижнего.

Этот текст будет повторяться на каждой странице выходного файла.

Export Data - Setting header and footer

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание особенностей форматов

Набор опций на этом шаге определяется выбранным форматом выходного файла.

Для следующих форматов можно указывать различные свойства на этом шаге:

Excel 97-2003

Access

Word 97-2003/RTF

HTML

PDF

TXT

CSV

XML

Excel/ODS

Word/ODT

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Особенности экспорта в Excel

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Особенности экспорта в Excel 97-2003

Если данные будут экспортированы в файл формата Excel, то на этом шаге Вы можете указать следующие свойства:

  • формат данных - на вкладке Data format,
  • расширения - на вкладке Extensions,
  • оформление - на вкладке Advanced.

Export Data - Format-specific options - Excel

Следующий шаг

Для того чтобы каждый раз при экспортировании не задавать эти параметры воспользуйтесь инструментом создания шаблонов.


Оформление таблицы и данных

Вкладка Data format содержит инструменты, необходимые для форматирования ячеек выходного файла.

Вы можете задавать такие параметры как шрифт, выравнивание, границы и т.д. для всех типов ячеек (ячеек с данными, заголовков, ссылок и т.д.). Можно также создавать стили, которые могут быть применены ко всем типам ячеек.

Оформление столбцов

Опции

Стили

Export Data - Format-specific options - Excel

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Оформление столбцов

На вкладке Columns для каждого столбцов Вы можете указать совокупность параметров, определяющих его внешний вид.

Export Data - Format-specific options - Excel - Data Format - Fields

Все инструменты, отвечающие за настройки шрифта, находятся на вкладке Font:

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

На вкладке Borders Вы можете задать толщину и вид границ ячеек.

Export Data - Format-specific options - Excel - Data Format - Fields - Borders

Если нажата одна из кнопок [image] [image] [image] [image], значит соответствующая граница будет отображаться. Для верхней, нижней, правой и левой границы отдельная кнопка.

Из раскрывающихся списков выберите тип границы (одинарная, двойная, пунктирная и т.д.). Нажав на кнопку [image], Вы можете задать для границы цвет.

На вкладке Fill Вы можете задать фоновый узор ячейки.

Export Data - Format-specific options - Excel - Data Format - Fields - Fill

Кнопка [image] отвечает за цвет фона.

Из раскрывающегося списка Вы выберите узор.

Кнопка [image] позволяет выбрать цвет узора

На вкладке Aggregate Вы можете задать для столбца одну итоговую функцию. Это значит что для данных в столбце будет найдено:

Export Data - Format-specific options - Excel - Data Format - Fields - Aggregate

RadioButton сумма - SUM,

RadioButton или среднее арифметическое - AVG,

RadioButton или минимальное значение - MIN,

RadioButton или максимальное значение - MAX.

В окне, расположенном ниже, Вы можете видеть все изменения, производимые со столбцом. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного столбца и для всех столбцов соответственно.


Опции

На вкладке Options есть возможность задать свойства вспомогательного текста:

  • верхний колонтитул - HEADER,
  • заголовок - CAPTION,
  • итоговые функции - AGGREGATE,
  • нижний колонтитул - FOOTER,
  • ссылка - HYPERLINK.

Export Data - Format-specific options - Excel - Data Format - Options

Все инструменты, отвечающие за шрифт, находятся на вкладке Font:

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

На вкладке Borders Вы можете задать толщину и вид границ ячеек.

Export Data - Format-specific options - Excel - Data Format - Fields - Borders

Если нажата одна из кнопок [image] [image] [image] [image], значит соответствующая граница будет отображаться. Для верхней, нижней, правой и левой границы отдельная кнопка.

Из раскрывающихся списков выберите тип границы (одинарная, двойная, пунктирная и т.д.). Нажав на кнопку [image], Вы можете задать для границы цвет.

На вкладке Fill Вы можете задать фоновый узор ячейки.

Export Data - Format-specific options - Excel - Data Format - Fields - Fill

Кнопка [image] отвечает за цвет фона.

Из раскрывающегося списка Вы можете выбрать узор.

Кнопка [image] позволяет выбрать цвет узора

В окне, расположенном ниже, Вы можете видеть все изменения производимые со столбцом. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного столбца и для всех столбцов соответственно.


Стили оформления

Вы можете создать собственный набор стилей, которые будут использоваться для оформления столбцов и строк.

Стили создаются на вкладке Styles.

С их помощью Вы можете оформить таблицу, задав различный цвет для столбцов или строк.

Чтобы создать стиль необходимо нажать на кнопку iconPlus, чтобы удалить - на iconMinus.

Менять порядок стилей можно с помощью кнопок btnMoveItemUp btnMoveItemDown.

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip style определяет, как будут применены созданные стили:

  • None - не применен,
  • Col - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Col или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Col, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Export Data - Format-specific options - Excel - Data Format - Styles

Все инструменты, отвечающие за шрифт, находятся на вкладке Font:

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выбираете один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

На вкладке Borders Вы можете задать толщину и вид границ ячеек.

Export Data - Format-specific options - Excel - Data Format - Fields - Borders

Если нажата одна из кнопок [image] [image] [image] [image], значит соответствующая граница будет отображаться. Для верхней, нижней, правой и левой границы отдельная кнопка.

Из раскрывающихся списков выберите тип границы (одинарная, двойная, пунктирная и т.д.). Нажав на кнопку [image], Вы можете задать для границы цвет.

На вкладке Fill Вы можете задать фоновый узор ячейки.

Export Data - Format-specific options - Excel - Data Format - Fields - Fill

Кнопка [image] отвечает за цвет фона.

Из раскрывающегося списка Вы выберите узор.

Кнопка [image] позволяет выбрать цвет узора

В окне, расположенном ниже, Вы можете видеть все изменения производимые с столбцом. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного столбца и для всех столбцов соответственно.


Расширения

Вкладка Extensions позволяет:

создавать ссылки в ячейках - объекты Hyperlinks,

создавать примечания для любой ячейки выходного файла - Notes,

задавать свойства диаграммы - Charts,

определять значение и тип ячейки - Cells,

указывать какие ячейки следует объединить - Merged Cells

Все эти объекты представлены в виде иерархического списка.

Чтобы создать объект необходимо нажать на кнопку iconPlus, чтобы удалить - на iconMinus.

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Ссылки

На этой вкладке Вы можете изменять параметры созданной гиперссылки.

Export Data - Format-specific options - Excel - Extensions - Hyperlinks

Важно: Если Вы создали гиперссылку, то её название, указанное в поле Title, заменит содержимое ячейки, для которой Вы её создали.

Свойства гиперссылки:

С помощью счетчиков Col и Row Вы задаете ту ячейку, в которой будет находиться гиперссылка.

Col - номер столбца, Row - номер строки.

В разделе Style выберите тип ссылки:

RadioButton URL - адрес в интернете,

RadioButton Local file - файл на компьютере, на котором запущен SQL Manager for PostgreSQL, или в локальной сети.

В поле Title укажите имя гиперссылки.

В поле Target задайте путь к файлу или web странице.

Кнопка [image] позволяет выбрать файл из имеющихся на компьютере или в локальной сети.


Примечания

Примечание представляет собой какие-либо замечания, относящиеся к ячейке и хранящиеся независимо от содержимого этой ячейки. Ячейки с примечаниями помечаются треугольником в правом верхнем углу. При наведении указателя на ячейку, помеченную таким образом, отображается примечание.

Для создания примечаний к ячейкам выходного файла на вкладке Extensions существует вкладка Notes.

Параметры каждого примечания Вы можете задать на вкладках Base, Font и Fill.

Export Data - Format-specific options - Excel - Extensions - Notes - Base

Вкладка Base

С помощью счетчиков Col и Row Вы можете задать ту ячейку, в которой будет находиться примечание. Col - номер столбца, Row - номер строки.

В поле Text пишете текст примечания.

Все инструменты, отвечающие за шрифт примечания, находятся на вкладке Font:

Export Data - Format-specific options - Excel - Extensions - Notes - Font

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

В разделе Orientation выбирается ориентация текста в окне примечания.

На вкладке Fill Вы можете задать вид фона окна примечания.

Export Data - Format-specific options - Excel - Extensions - Notes - Fill

RadioButton Solid - фон однородный,

RadioButton Gradient - будет использован градиент фонового цвета,

  • Horizontal - горизонтальный,
  • Vertical - вертикальный,
  • Diagonal Up - диагональная_1,
  • Diagonal Down - диагональная_2,
  • From Corner - из угла,
  • From Center - от центра.

Кнопка [image] отвечает за цвет фона.

Кнопка [image] позволяет выбрать цвет узора.

Передвигая ползунок Transparency от отметки 0% до 100%, Вы можете задать степень прозрачности окна примечания. 100% - наибольшая степень прозрачности.


Диаграммы

Вы можете создать диаграмму в выходном файле Microsoft Excel.

Для этого на вкладке Extensions нужно создать объект Chart.

Export Data - Format-specific options - Excel - Extensions - Charts - Base

Основные свойства диаграммы можно задать на вкладке Base.

В поле Title указываете имя диаграммы.

Из раскрывающегося списка Style выберите тип диаграммы. Список состоит из стандартных типов диаграмм, таких как гистограмма, круговая, точечная и т.д.

В разделе Legend position укажите положение легенды:

RadioButton Bottom - под диаграммой,

RadioButton Corner - в углу,

RadioButton Top - над диаграммой,

RadioButton Right - справа от диаграммы,

RadioButton Left - слева от диаграммы.

CheckBox Если установлен флажок Show legend, то легенда будет отображаться.

CheckBox Если установлен Флажок Auto color, то на диаграмме каждая серия будет выделена своим цветом. Если не установлен, то все серии будут одного цвета.

На вкладке Position задается расположение диаграммы на листе.

Export Data - Format-specific options - Excel - Extensions - Charts - Position

RadioButton Автоматическое - Auto:

В разделе Placement указывается положение диаграммы относительно данных.

RadioButton Bottom - под данными,

RadioButton Right - справа от данных.

Ниже, с помощью счетчиков, указываются размер диаграммы и отступы сверху и слева в сантиметрах.

Left - расстояние до данных слева,

Top - расстояние до данных сверху,

Height - высота диаграммы,

Width - ширина диаграммы.

RadioButton В разделе Custom можно указать абсолютное положение диаграммы.

На вкладке Category Labels Вы можете указывать, в каких строках и столбцах строить диаграмму.

Из раскрывающегося списка Column выберите столбец таблицы, который будет являться осью X в диаграмме.

Или с помощью счетчиков раздела Custom укажите диапазон ячеек.

Export Data - Format-specific options - Excel - Extensions - Charts - Category Labels

Для того, чтобы построить диаграмму, необходимо создать объект Series. Без него невозможно построить диаграмму.

Этот объект указывает на те значения, которые будут располагаться в диаграмме по оси Y.

Для одной диаграммы может быть создано несколько серий.

Свойства серий задаются на специальной вкладке:

Export Data - Format-specific options - Excel - Extensions - Series

Title - название серии,

Column - столбец таблицы, значения которого будут образовывать серию.

Или с помощью счетчиков раздела Custom указываете диапазон ячеек.

Нажав на кнопку [image], Вы можете задать для серии цвет.


Ячейки

На этой вкладке Вы можете задать формат ячейки и значение, которое в ней будет находиться.

В счетчике Col укажите номер столбца, в Row - строки. На их пересечении будет находиться редактируемая ячейка.

Тип ячейки выберите из раскрывающегося списка Cell type. В поле Value задаете значение, которое будет находиться в этой ячейке.

В разделе Formats укажите, в каком виде будут отображаться данные, если они являются числовыми или датой.

В поле Data укажите вид, в котором должны отображаться данные типа дата и время, а в поле Numeric - укажите формат числовых значений.

Export Data - Format-specific options - Excel - Extensions - Cells

Инструменты, располагающиеся на вкладках Font, Borders и Fill соответствуют инструментам на вкладке Columns.


Объединенные ячейки

С помощью набора инструментов раздела Merged Cells Вы можете объединить ячейки в выходном документе.

Export Data - Format-specific options - Excel - Extensions - Merged Cells

При необходимости можно создать несколько объединенных ячеек. Для этого на вкладке Extensions необходимо создать несколько объектов Merged Cells.

С помощью счетчиков задаете ячейки, которые необходимо объединить:

  • First col - первый столбец,
  • First row - первая строка,
  • Last col - последний столбец,
  • Last row - последняя строка.


Оформление страницы

На вкладке Advanced Вы можете задать общие свойства страницы:

Export Data - Format-specific options - Excel - Advanced

  • верхний колонтитул страницы - в поле Page header,
  • нижний колонтитул страницы - в поле Page footer,
  • название листа - в поле Sheet title,
  • фон страницы - с помощью раскрывающегося списка Page background.

CheckBox Если установлен флажок Calculate column width automatically, то ширина колонок задается автоматически исходя, из размеров поля.

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Access

Если данные экспортируются в Access, то на этом шаге необходимо будет указать опции таблицы. В поле Table name указать имя таблицы.

CheckBox Если не существует таблицы с таким именем, то ее можно создать, установив флажок Create new table if it does not exist.

Export Data - Format-specific options - Access

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Word 97-2003 / RTF

При экспорте данных в документ Microsoft Word (*.doc) или Rich Text Format (*.rtf) можно указать следующие свойства выходного файла:

  • Базовые стили
  • Стили оформления строк

Export Data - Format-specific options - Word

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Базовые стили

На вкладке Base Styles Вы можете указать основные свойства выходного документа.

Из списка выберите объект, для которого необходимо задать свойства:

верхний колонтитул - HEADER,

заголовок - CAPTION,

нижний колонтитул - FOOTER,

ссылка - HYPERLINK.

В разделе Page orientation установите ориентацию страницы:

RadioButton Portrait - книжная,

RadioButton Landscape - альбомная.

Export Data - Format-specific options - Word - Base Styles

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Кнопка [image] отвечает за цвет фона.

CheckBox Если установлен флажок Background, то цвет фона будет отображаться в выходном файле.

Кнопка [image] позволяет выбрать цвет, которым будет выделен текст.

CheckBox Если установлен флажок Highlight, то в выходном файле текст будет выделен указанным цветом.

В окне, расположенном ниже, Вы можете видеть все изменения производимые со столбцом. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного объекта и для всех объектов соответственно.


Стили оформления строк

На вкладке Styles Вы можете создать собственный набор стилей, которые будут использоваться для оформления столбцов и строк.

С их помощью Вы можете оформить таблицу, задав различный цвет для столбцов или строк.

Export Data - Format-specific options - Word - Strip Styles

Чтобы создать стиль необходимо нажать на кнопку iconPlus, чтобы удалить - на iconMinus.

Менять порядок стилей можно с помощью кнопок btnMoveItemUp btnMoveItemDown.

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip style определяет, как будут применены созданные стили:

  • None - не применен,
  • Col - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Col или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Col, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Кнопка [image] отвечает за цвет фона.

CheckBox Если установлен флажок Background, то цвет фона будет отображаться в выходном файле.

Кнопка [image] позволяет выбрать цвет, которым будет выделен текст.

CheckBox Если установлен флажок Highlight, то в выходном файле текст будет выделен указанным цветом.

В окне, расположенном ниже, Вы можете видеть все изменения, производимые со столбцом. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного стиля и для всех стилей соответственно.


HTML

Если Вы экспортируете данные в HTML, то для выходного файла Вы можете задать следующие характеристики:

  • оформление таблицы в выходном файле можно выбрать из предлагаемых форматов на вкладке Preview,
  • основные свойства выходного файла можно указать на вкладке Basic,
  • свойства многостраничного документа можно задать на вкладке Multi-file,
  • шрифт и формат ячеек таблицы укажите на вкладке Advanced.

Export Data - Format-specific options - HTML

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Автоформат

На вкладке Preview Вы можете задать внешний вид таблицы данных.

Из раскрывающегося списка Template можно выбрать уже готовый шаблон оформления документа. В окне предпросмотра показано, как будет выглядеть итоговая таблица, если к ней применить выбранный шаблон оформления.

Export Data - Format-specific options - HTML - Preview

Для того, чтобы изменить шаблон, достаточно нажать на любой элемент в окне предпросмотра. При нажатии на элемент появится стандартная палитра, из которой можно выбрать нужный цвет для этого элемента.

Можно изменять цвет текста, цвет фона и различных видов гиперссылок и т.д..

Внесенные изменения можно сохранить в виде шаблона с помощью кнопки Save template. В этом случае при следующем экспортировании Вы уже сможете воспользоваться готовым шаблоном, загрузив его с помощью кнопки Load template.


Базовые опции

Свойства выходного файла Вы можете задать на вкладке Basic.

Export Data - Format-specific options - HTML - Basic

Название выходного HTML файла указывается в поле Title. По умолчанию оно соответствует имени экспортируемого объекта.

В разделе Cascade style sheet options можно выбрать место хранения таблицы стилей:

RadioButton Internal - означает, что стили будут храниться в самом выходном HTML файле,

RadioButton External - для таблицы стилей будет создан отдельный файл формата *.css.

В поле CSS file name укажите имя CSS файла, а также выберите, куда его сохранить, с помощью кнопки EllipsisButton.

Если установлен флажок Overwrite CSS file if it exist, то при создании нового CSS файла существующий будет заменен новым.

CheckBox Установив флажок Export boolean columns as HTML check boxes, Вы указываете, что все столбцы таблицы, которые имеют формат boolean, в выходном файле будут отображаться в виде флажков.


Многостраничный документ

SQL Manager for PostgreSQL позволяет экспортировать таблицы, содержащие любое количество записей. Для того чтобы в выходном HTML файле было удобно просматривать таблицы с большим количеством записей при экспорте Вы можете указать, что выходной файл будет многостраничным, а также указать количество строк на каждой странице.

В разделе Multi-file export Вы можете задать параметры выходного многостраничного документа:

CheckBox Use Multi-file export. Установив этот флажок, Вы указываете, что создаваемый HTML документ будет многостраничным, в счетчике Record(s) in a single file Вы устанавливаете, сколько записей будет содержаться на каждой странице.

CheckBox Если флажок Generate index установлен, то будет создана страница содержания, в которой будут ссылки на все страницы с данными. В поле пишете название страницы, которое будет отображаться в содержании рядом с номером страницы.

Export Data - Format-specific options - HTML - Multi-file

В многостраничном HTML документе должна существовать система перехода от одной страницы к другой, а также к содержанию.

Раздел Navigation становится активным только если выбрана опция Use multi-file export.

В разделе Navigation задайте свойства навигационных элементов управления, то есть тех, которые обеспечивают переход между страницами документа. Навигация по многостраничному документу обеспечивается с помощью ссылок, которые выстроены в одну строку. Эту строку можно поместить:

CheckBox вверху страницы - установив флажок On top,

CheckBox внизу страницы - установив флажок On bottom.

Далее в текстовых полях указывается текст ссылок:

  • Index link - текст ссылки на страницу содержания,
  • First link - текст ссылки на первую страницу с данными,
  • Prior link - текст ссылки на предыдущую страницу с данными,
  • Next link - текст ссылки на следующую страницу с данными,
  • Last link - текст ссылки на последнюю страницу с данными.


Оформление выходного файла

Как будет выглядеть выходной файл, можно задать с помощью инструментов на вкладке Advanced.

Export Data - Format-specific options - HTML - Advanced

В разделе Body options задаются свойства для всей страницы:

  • шрифт всех страниц выходного файла - Default font,
  • фон документа (с помощью кнопки EllipsisButton в качестве фона можно установить любое изображение) - Background,
  • Advanced attributes - внешние атрибуты страницы

В разделе Table Options Вы можете указать некоторые свойства таблицы данных, такие как:

  • отступ ячейки - счетчик Cell padding,
  • расстояние между ячейками - Cell spacing,
  • внешняя границы таблицы - Border
  • фон таблицы (с помощью кнопки EllipsisButton в качестве фона можно установить любое изображение) - Background,
  • Advanced attributes - внешние атрибуты таблицы.


PDF

Если данные будут экспортированы в файл формата PDF, то на этом шаге Вы можете указать следующие свойства:

Export Data - Format-specific options - PDF

Из списка выберите объект, для которого необходимо задать вид шрифта:

Верхний колонтитул - Header font,

Заголовок - Caption font,

Ссылка - Hyperlink.

Нижний колонтитул - Footer font.

Из раскрывающегося списка Base font name выберите нужный шрифт. Кодировку выберите из списка Font encoding.

В счетчике Font size укажите размер шрифта.

Кнопка Font color отвечает за цвет шрифта.

В поле, расположенном ниже, Вы можете видеть все изменения производимые с объектом. Они отображаются на образце текста "SAMPLE".

В разделе Page options можно задать свойства страницы:

  • из раскрывающегося списка Page size выберите размер страницы. По умолчанию стоит размер А4,
  • ширина страницы указывается в счетчике Width,
  • высота - в счетчике Height,
  • в раскрывающемся списке Units содержатся единицы измерения, в которых указан размер страницы,
  • из раскрывающегося списка Orientation выберите ориентацию страницы: (Portrait - книжная, Landscape - альбомная).

В разделе Margins можно задать размер полей страницы:

Left - левого,

Right - правого,

Top - верхнего,

Bottom - нижнего.

Grid options. В этом разделе можно задать некоторые свойства таблицы:

Col spacing - количество пробелов для выравнивания столбца,

Row spacing - количество пробелов для выравнивания строки,

Line width - толщина линий таблицы.

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


TXT

Если данные будут экспортированы в файл формата TXT, то на этом шаге Вы можете указать следующие свойства:

CheckBox В выходном файле автоматически будет вычисляться ширина столбцов, если установить флажок Calculate column width,

расстояние между ячейками можно задать, используя счетчик Spacing.

Export Data - Format-specific options - TXT

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


CSV

Если данные будут экспортированы в файл формата CSV, то на этом шаге Вы можете указать следующие свойства:

CheckBox Если установлен флажок Quote strings, то каждое значение, содержащееся в ячейке, будет заключено в кавычки; из раскрывающегося списка Quote Вы можете выбрать вид кавычек - одинарные или двойные;

Из раскрывающегося списка Comma можно выбрать разделитель столбцов.

Export Data - Format-specific options - CSV

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


XML

Если данные будут экспортированы в файл формата XML, то на этом шаге Вы можете указать следующие свойства:

кодировку - выбирается из раскрывающегося списка Encoding,

CheckBox флажок Standalone устанавливается в том случае, если необходимо создать автономный XML документ. (standalone="yes")

Из раскрывающегося списка XML type выберите используемый тип XML.

CheckBox Если выбран тип Access, то можно установить флажок Export XSD Schema, который позволит экспортировать и XSD схему.

Export Data - Format-specific options - XML

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Excel/ODS

Если данные будут экспортированы в файл формата Excel 2007 или ODS, то на этом шаге Вы можете параметры отображения текста.

Export Data - Format-specific options - Excel 2007 - Base Styles

Задавать параметры оформления стандартных разделов файла Вы можете на вкладке Base Style.

Изменять Вы можете следующие разделы:

  • HEADER - верхний колонтитул,
  • CAPTION - заголовок,
  • DATA - данные,
  • FOOTER - нижний колонтитул.

На вкладке Strip Styles Вы задаете различный цвет для столбцов или строк.

Export Data - Format-specific options - Excel 2007 - Strip Styles

Чтобы создать стиль необходимо нажать на кнопку "+", чтобы удалить - на "-".

Менять порядок стилей можно с помощью кнопок btnMoveItemUp btnMoveItemDown.

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip type определяет, как будут применены созданные стили:

  • None - не применен,
  • Col - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Col или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Col, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Для каждого стиля, как стандартного, так и созданного, можно задавать следующие характеристики:

  • На вкладке Font задайте свойства шрифта редактируемого стиля.

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выбираете один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое) и выравнивание текста по горизонтали и выравнивание текста по вертикали.

CheckBox Если установлен флажок Background, то появляется специальная кнопка [image], открывающая стандартное окно для выбора цвета. Нажав на кнопку Wrap text, Вы указываете, что текст в ячейках будет переноситься по словам.

  • На вкладке Border задайте параметры границы:

Export Data - Format-specific options - Excel 2007 - Border

CheckBox Если хотите задать специальные параметры для границ ячеек, то установите флажок Use Border.

Нажав на кнопку [image] - Border Color, Вы можете задать для границы цвет. Из раскрывающегося списка Border Style выберите тип границы (одинарная, двойная, пунктирная и т.д.).


Word/ODT

Если данные будут экспортированы в файл формата Word 2007 или ODT, то на этом шаге Вы можете параметры отображения текста.

Export Data - Format-specific options - Word 2007 - Base Styles

Задавать параметры оформления стандартных разделов файла Вы можете на вкладке Base Style.

Изменять Вы можете следующие разделы:

  • HEADER - верхний колонтитул,
  • CAPTION - заголовок,
  • DATA - данные,
  • FOOTER - нижний колонтитул.

На вкладке Font задайте свойства шрифта редактируемого стиля.

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выбираете один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое) и выравнивание текста по горизонтали и выравнивание текста по вертикали.

CheckBox Если установлен флажок Background, то появляется специальная кнопка [image], открывающая стандартное окно для выбора цвета.

CheckBox Если установлен флажок Highlight, то из раскрывающегося списка можно выбрать цвет, которым будет выделен текст.

На вкладке Strip Styles Вы задаете различный цвет для столбцов или строк.

Export Data - Format-specific options - Word 2007 - Strip Styles

Чтобы создать стиль необходимо нажать на кнопку "+", чтобы удалить - на "-".

Менять порядок стилей можно с помощью кнопок btnMoveItemUp btnMoveItemDown.

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip type определяет, как будут применены созданные стили:

RadioButton None - не применен,

RadioButton Col - к столбцам,

RadioButton Row - к строкам.

Если создать один стиль и выбрать Col или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Col, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Для каждого стиля, как стандартного, так и созданного, можно задавать следующие характеристики:

На вкладке Border задайте параметры границы:

Export Data - Format-specific options - Word 2007 - Border

CheckBox Если хотите задать специальные параметры для границ ячеек, то установите флажок Use Border.

Нажав на кнопку [image] - Border Color, Вы можете задать для границы цвет. Из раскрывающегося списка Border Style выберите тип границы (одинарная, двойная, пунктирная и т.д.).


Задание общих опций экспорта

На последнем шаге у Вас есть возможность задать общие свойства экспорта данных.

CheckBox Export empty tables - установка этого флажка позволяет экспортировать пустую таблицу в файл.

Skip n records - Пропустить n записей. Если в счетчике стоит 0, то экспортированы будут все записи. Если же больше нуля, то первые n записей будут пропущены.

RadioButton Чтобы экспортировать все записи, установите Export all records.

RadioButton Export only n records - этот счетчик позволяет экспортировать только указанное количество записей.

CheckBox Чтобы открыть файл после экспорта, установите флажок Open file after export.

CheckBox Print file after export - установив этот флажок, Вы можете распечатать файл после экспорта.

Export Data - Setting common export options

Следующий шаг

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Finish, для начала выполнения операции.

Export Data - Exporting data

В этом окне отображается следующая информация об операции:

  • Exported - количество экспортированных записей,
  • Time - время, затраченное на экспортирование записей,
  • Speed - скорость экспорта данных.

В процессе выполнения экспорта ведется журнал операций, который позволяет пользователю просматривать операции и ошибки (если возникают).

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз при экспортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Мастер импорта данных

Мастер импорта данных - Import Data Wizard - позволяет импортировать данные в таблицу, представление или результат запроса из файлов самых распространенных форматов.

Импорт данных можно осуществлять только с помощью тех редакторов, в которых есть вкладка Data. Это Редактор таблиц.

Этот инструмент открывается с помощью кнопки Import Data, располагающейся на навигационной панели Data Management и на панели инструментов.

Кнопка доступна, когда в редакторе открыт просмотрщик данных, то есть на вкладке Data или Results. Также эта команда присутствует в контекстном меню объектов таблицы и представления, в проводнике баз данных и содержится в подменю пункта Data Manipulation.

Указание файла источника данных

Выбор источника данных

Указание соответствия столбцов

Настройка форматов данных

Определение форматов столбцов

Выбор метода импорта

Настройка общих опций

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер экспорта данных

Мастер экспорта в виде SQL скрипта

Мастер сохранения данных

Мастер загрузки данных

Использование шаблонов


Указание файла источника данных

На первом шаге мастера импорта данных Вы должны указать тип файла, из которого будут импортироваться данные, и путь к этому файлу.

Import Data - Selecting source file name and format

Import type

С помощью переключателя выберите тип файла из доступных.

RadioButton MS Excel

RadioButton MS Access

RadioButton DBF

RadioButton XML

RadioButton TXT

RadioButton CSV

RadioButton HTML

RadioButton XML Document

RadioButton MS Excel 97-2003

RadioButton MS Word 97-2003

RadioButton ODF Spreadsheets

RadioButton ODF Text

В строке Source file name укажите путь к файлу источнику. При нажатии на кнопку ExplorerButton открывается стандартное диалоговое окно позволяющее выбрать файл.

CSV format parameters

Для файла имеющего формат CSV можно указать дополнительные свойства.

  • Из раскрывающегося списка Quote Вы можете выбрать вид кавычек - одинарные или двойные,
  • из раскрывающегося списка Delimiter можно выбрать разделитель столбцов.

Следующий шаг (для импорта из Access)

Следующий шаг (для импорта из всех остальных форматов)

Для того, чтобы каждый раз при импортировании не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор источника данных

Этот шаг доступен только тогда, когда Вы импортируете данные из базы данных MS Access.

На этом шаге нужно выбрать таблицу или запрос базы данных Access, или в редакторе запросов создать новый запрос к базе данных. Текст запроса можно загрузить из файла, используя кнопку Load from file, и сохранить в файл при помощи кнопки Save to File.

RadioButton Установив переключатель в пункт I would like to import data from a table, Вы получаете возможность выбрать для импорта таблицу или запрос из базы данных.

RadioButton Если переключатель установлен в пункт I would like to import data from a SQL query, то в редакторе запросов можно создать текст запроса к базе данных.

Import Data - Selecting data source

Следующий шаг


Указание соответствия столбцов

При импорте данных в таблицу необходимо установить соответствие столбцов между таблицей, в которую данные будут импортироваться, и таблицей, из которой они импортируются.

Все операции по установлению этого соответствия проводятся на этом шаге (если импортируете данные из MS Access, то на дополнительном шаге).

Для каждого формата файлов существуют свои особенности установки соответствия столбцов:

Exceд 97-2003

Access, DBF, XML

TXT

CSV

HTML

XML Document

MS Excel/Word/ODF

Следующий шаг


Excel 97-2003

На этом шаге необходимо установить соответствие между колонками с данными в книге MS Excel и столбцами в таблице.

Import Data - Setting fields correspondence - Excel

В левой части, в списке Columns, отображается список колонок таблицы, в которую импортируют данные. В правой части - фрагмент импортируемого документа MS Excel.

В списке Ranges показано соответствие, установленное между столбцами таблицы базы данных и колонками таблицы Excel.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка iconAutoFillColumns Auto Fill Cols - автоматически устанавливает соответствие между столбцами и колонками,

Кнопка iconAutoFillRows Auto Fill Rows - автоматически устанавливает соответствие между столбцом и строкой,

Кнопка iconCross Clear Ranges - удаляет одно соответствие,

Кнопка iconClearAllRanges Clear All - удаляет все соответствия.

В разделе Skip можно указать строки и/или столбцы, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В счетчике Col(s) укажите, сколько столбцов, начиная с первого, следует исключить. В счетчике Row(s) - сколько строк.

Объект в списке Ranges можно открыть для редактирования двойным щелчком мыши.

Import Data - Setting fields correspondence - Excel - Range

В разделе Range Type задайте тип диапазона.

Из раскрывающегося списка выберите, будет ли это диапазон строк (Row) или столбцов (Col). Затем из списка, расположенного рядом, выберите начало диапазона.

В разделах Start и Finish задайте параметры начала и конца редактируемого диапазона.

Это можно сделать автоматически, установив флажок Where data started для начала и Where data Finished для конца диапазона. Или вручную указать номер строки или столбца в счетчиках Start Row и Finish Row.

Выберите направление считывания данных с помощью переключателя Direction.

  • Down - вниз,
  • Up - вверх.

Также можно указать лист в книге Microsoft Excel, на котором располагаются нужные данные. Если в разделе Sheet выбрать Default Sheet, то будут использованы данные первого листа. Если установить переключатель в положение Custom Sheet, то можно указать нужный лист по номеру (Sheet number) или по имени (Sheet name).

Следующий шаг


Access, DBF, XML Datapacket

Для форматов Access, DBF и XML этот шаг одинаков.

В списке Destination Columns отображаются столбцы таблицы, в которую импортируются данные.

В списке Source Columns - столбцы таблицы, из которой импортируют данные.

С помощью кнопок между списками устанавливаются соответствия между столбцами. Они отображаются в списке соответствий, располагающемся в нижней части формы.

Кнопка iconPlus Add добавляет в список соответствий новое соответствие между выделенными столбцами.

Кнопка iconAutoFillColumns Auto Fill позволяет автоматически подобрать столбцам таблицы, в которую импортируются данные соответствующие колонкам из таблицы источника данных.

Нажав на кнопку Remove, Вы удалите выделенное соответствие. Нажатие на кнопку Clear полностью очищает список соответствий.

При импорте данных из файла формата DBF появляется дополнительный флажок Skip deleted records. Установка этого флажка позволяет пропустить при импорте записи, помеченные на удаление.

Import Data - Setting fields correspondence - Access

Следующий шаг


TXT

На этом шаге необходимо установить соответствие между колонками с данными в текстовом документе и столбцами в таблице.

В левой части окна располагается список столбцов таблицы, в которую будут импортироваться данные. В этом же списке отображается соответствие столбцов таблицы и колонок текстового документа.

В правой части - фрагмент текстового документа - источника данных.

В текстовом документе не существует такого понятия как колонки или столбцы, поэтому в SQL Manager for PostgreSQL при экспорте нужно вручную устанавливать разграничители колонок для текстовых файлов. Разграничители представляют собой вертикальные черные линии, отделяющие один столбец от другого. Изначально в документе разгарничителей нет. Устанавливаются они с помощью двойного щелчка мыши на макете документа. Разграничители должны быть между столбцами, а также перед первым столбцом и после последнего. Размер столбца определяется количеством символов в нем. Для этого сверху и снизу макета документа предусмотрены линейки, на которых каждое деление соответствует символу.

Соответствие между столбцами устанавливается следующим образом:

В списке столбцов таблицы выбирается столбец. В макете документа выбирается столбец. Если соответствие установлено, то рядом с названием столбца появляются две цифры. Первая - это номер символа, с которого начинается столбец, вторая - количество символов в столбце.

Import Data - Setting fields correspondence - TXT

Если хотите удалить все установленные соответствия, то нажмите кнопку Clear.

С помощью счетчика Skip Lines можно указать, сколько первых строк не учитывать при импорте. Таким образом, исключаются заголовки столбцов из импортируемых данных.

Из раскрывающегося списка Charset выберите кодировку.

Следующий шаг


CSV

Чтобы при импорте данных из файла формата CSV все столбцы данных корректно отображались на втором шаге необходимо на первом шаге правильно указать разделитель колонок исходного файла.

В левой части окна располагается список столбцов таблицы, в которую будут импортироваться данные. В этом же списке отображается соответствие столбцов таблицы и колонок текстового документа.

В правой части - фрагмент документа CSV. Все столбцы в нем пронумерованы. Соответствие столбцов устанавливается по номеру столбца документа CSV.

Чтобы установить соответствие столбца таблицы, куда импортируют данные, и колонки в документе-источнике данных необходимо выделить столбец в списке полей и выделить колонку в макете документа CSV или выбрать нужный номер колонци из списка Column. Если связь установлена, то напротив названия поля появится номер столбца, который поставлен в соответствие с этим полем.

Import Data - Setting fields correspondence - CSV

Кнопка iconAutoFillColumns Auto Fill - автоматически устанавливает соответствие между столбцами и колонками.

Кнопка iconCross Clear All - удаляет все соответствия.

Чтобы в импортируемые данные не попали заголовки столбцов можно указать число первых строк, которые при импорте будут пропущены. Сделайте это с помощью счетчика Skip.

Следующий шаг


HTML

На этом шаге необходимо установить соответствие между колонками с данными в таблице HTML файла и столбцами в таблице базы данных.

Import Data - Setting fields correspondence - HTML

В левой части, в списке Columns, отображается список столбцов таблицы, в которую импортируют данные. В правой части - фрагмент импортируемого документа.

В списке Ranges показано соответствие, установленное между столбцами таблицы базы данных и колонками таблицы Excel.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка iconAutoFillColumns Auto Fill - автоматически устанавливает соответствие между столбцами и колонками,

Кнопка iconCross Clear - удаляет одно соответствие,

Кнопка iconClearAllRanges Clear All - удаляет все соответствия.

Из раскрывающегося списка Table выберите номер таблицы, из которой хотите импортировать данные. Это сделано на тот случай, если в HTML документе не одна таблица, а несколько.

В счетчике Col укажите номер колонки, который соответствует выбранному столбцу таблицы базы данных.

В разделе Skip можно указать строки и/или столбцы, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные.

Следующий шаг


XML Generic

На этом шаге необходимо установить соответствие между колонками с данными в документе XML и столбцами в таблице.

Import Data - Setting fields correspondence - XML Document

В левой части, в списке Columns, отображается список столбцов таблицы, в которую импортируют данные. В правой части - фрагмент импортируемого документа XML Document.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка iconAutoFillColumns Auto Fill - автоматически устанавливает соответствие между столбцами и колонками,

Кнопка iconCross Clear - удаляет одно соответствие,

Кнопка iconClearAllRanges Clear All - удаляет все соответствия.

В разделе Skip можно указать строки и/или столбцы, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В счетчике Col(s) укажите, сколько столбцов, начиная с первого, следует исключить. В счетчике Row(s) - сколько строк.

Чтобы заполнить таблицу на форме текстом соответствующих подузлов необходимо в поле XPath указать путь в формате XML и нажать на кнопку iconAutoFillColumns Fill Grid

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные.

Следующий шаг


MS Excel/Word/ODF

На этом шаге необходимо установить соответствие между колонками с данными документа и столбцами в таблице базы данных.

Import Data - Setting fields correspondence - MS Excel and Word 2007, ODF

В левой части, в списке Columns, отображается список столбцов таблицы, в которую импортируют данные. В правой части - фрагмент импортируемого документа.

В списке Ranges показано соответствие, установленное между столбцами таблицы базы данных и колонками таблицы Excel.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка iconAutoFillColumns Auto Fill - автоматически устанавливает соответствие между столбцами и колонками,

Кнопка iconCross Clear - удаляет одно соответствие,

Кнопка iconClearAllRanges Clear All - удаляет все соответствия.

В поле Column выберите колонку, которая соответствует выбранному столбцу таблицы базы данных.

В разделе Skip можно указать строки, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные.

Следующий шаг


Настройка форматов данных

На этом шаге необходимо указать вид представления данных для импортируемого файла. Этот вид должен соответствовать представлению данных в том файле, откуда эти данные импортируются.

Import Data - Adjusting data formats

Date & Time formats в этом разделе задаются форматы для отображения даты и времени.

  • Short date - Дата (краткий формат)
  • Long date - Дата (расширенный формат)
  • Short time - Время (краткий формат)
  • Long time - Время (расширенный формат)

В разделе Separators указываются символы, которые будут являться разделителями разрядов.

  • Decimal - Десятки
  • Thousand - Тысячи
  • Date - Дата
  • Time - Время

Boolean True - в этом поле водится текст, который отображается, если значение в ячейке "истина" (значение будет "истина" при совпадении данных в документе и в этом поле),

Boolean False в этом поле водится текст, который отображается, если значение в ячейке "ложь",

Null Values в этом поле водится текст, который отображается, если значение в ячейке NULL

Дополнительно смотрите Форматы данных

Следующий шаг


Определение форматов столбцов

На этом шаге Вы можете выбрать из списка Column name столбец и указать в разделе Formats набор свойств, определяющих формат этого столбца.

Import Data - Setting advanced field formats

Задайте генератор значений - Generator value и шаг генератора значений - Generator step для инкрементного генератора значений в соответствующем столбце.

Constant value - в это поле вводится значение, которое заменяет все значения в столбце.

Null value - значение, которое устанавливается в ячейке, если значение после импорта в ней остается Null,

В поле Default Value указываете значение по умолчанию.

В поле Left quotation задаете левую кавычку, в поле Right quotation - правую.

Из раскрывающегося списка Quotation action выберите должны ли символы кавычек быть добавлены, удалены, или оставлены как есть.

Из раскрывающегося списка Character case - регистр текстовых данных.

Из раскрывающегося списка Charset - выберите кодировку.

На этом шаге мастера есть возможность в процессе импорта данных заменить некоторые значения в столбце другими значениями. Замен текста для столбца можно создать несколько. С помощью кнопки iconPlus Add Replacement Вы можете добавить новый параметр замены.

Import Data - Setting advanced field formats - Add Replacement

Все параметры отображаются в списке, где в столбце Text to find находятся те значения текста, которые необходимо заменить, в столбце Replace - текст которым надо заменить указанные фрагменты. Если установлен флажок Ignore case, то замена будет произведена без учета регистра. С помощью кнопки [image] Edit Replacement можно редактировать условие замены. Кнопка iconMinus Delete Replacement удаляет условие замены.

Следующий шаг


Выбор метода импорта

На этом шаге укажите режим импорта.

Import Data - Setting import mode

Переключатель Insert mode позволяет задать те записи, которые будут импортироваться в таблицу.

RadioButton Insert all - вставить все записи,

RadioButton Insert new - вставить только новые записи,

RadioButton Update - обновить записи,

RadioButton Update or insert - обновить существующие и вставить новые записи,

RadioButton Delete - удалить те записи, где совпадает первичный ключ таблицы и значение столбца, выбранного в качестве ключевого, импортируемого файла,

Delete or insert - удалить совпадающие записи и вставить новые.

С помощью переключателя Import type укажите тип импорта:

RadioButton Single commands - построчная вставка, (работает значительно быстрее, чем Universal, который в данный момент используется для обратной совместимости)

RadioButton Universal mode - универсальный режим,

RadioButton Batch insert - пакетный режим вставки.

В разделе Key columns выберите ключевой столбец, по которому сравниваются столбцы таблицы и файла источника данных.

Из списка Available columns выберите доступные столбцы и с помощью кнопок переместите их в список ключевых столбцов - Selected columns.

Пример:

Таблица в базе данных | Данные из внешнего файла
Import Data - Setting import mode - Destination Table | Import Data - Setting import mode - Source Table

В качестве ключевого столбца выбран столбец ID. Для режима Insert All выбирать ключевой столбец не требуется.

Insert mode | Insert all | Insert new | Update | Update or insert | Delete | Delete or insert
Результат | Import Data - Setting import mode - Result - Insert All | Import Data - Setting import mode - Result - Insert new | Import Data - Setting import mode - Result - Update | Import Data - Setting import mode - Result - Update or insert | Import Data - Setting import mode - Result - Delete | Import Data - Setting import mode - Result - Delete or insert

Следующий шаг


Настройка общих опций

В разделе Commit задайте параметры фиксации транзакции:

RadioButton Commit when done - фиксировать транзакцию после выполнения импорта,

RadioButton Commit after each block - фиксировать транзакцию после каждого блока. Применяется для больших таблиц. Размер блока указывается в счетчике Block size.

RadioButton Commit changes manually - автоматическая фиксация транзакции не производится (должна быть выполнена вручную).

В разделе Record count Вы можете задать количество импортируемых записей.

RadioButton Выберите пункт Import all records, чтобы импортировать сразу все записи.

RadioButton В счетчике Import only n records задайте их количество..

Import Data - Customizing common options

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Import Data - Importing data

В этом окне отображается следующая информация об операции:

  • Inserted - количество импортированных записей
  • Updated - количество обновленных записей
  • Deleted - число удаленных записей
  • Errors - отображает число возникших при импорте ошибок
  • Commited - число зафиксированных записей
  • Time - время, затраченное на импортирование записей

В процессе выполнения импорта ведется журнал операций, который позволяет пользователю просматривать операции и ошибки (если возникают).

Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Мастер экспорта в виде SQL скрипта

Экспорт в виде SQL скрипта можно осуществлять только из тех инструментов, где есть вкладка Data или Results. Это Редактор таблиц, Редактор представлений, Редактор запросов и Дизайнер запросов.

Этот инструмент открывается с помощью кнопки Export as SQL script, располагающейся на навигационной панели Data Management и на панели инструментов.

Кнопка доступна, когда в редакторе открыт просмотрщик данных, то есть на вкладке Data или Results. Также эта команда присутствует в контекстном меню объектов таблицы и представления, в проводнике баз данных и содержится в подменю пункта Data Manipulation.

Задание типа назначенного сервера

Указание имени файла назначения

Выбор метода экспорта полей типа BLOB

Выбор столбцов для экспорта

Настройка опций экспорта

Редактирование итогового SQL скрипта

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер экспорта данных

Мастер импорта данных

Мастер сохранения данных

Мастер загрузки данных

Использование шаблонов


Задание типа назначенного сервера

На первом шаге необходимо выбрать сервер назначения. Скрипт будет генерироваться в формате, совместимом с выбранным типом сервера.

Допустимые типы серверов.

RadioButton DB2

RadioButton InterBase/Firebird

RadioButton MS SQL

RadioButton MySQL

RadioButton Oracle

RadioButton PostgreSQL

CheckBox Add CREATE TABLE statement

В скрипт будет добавлена инструкция CREATE TABLE, которая генерируется в соответствии с синтаксисом выбранного типа сервера.

Export as SQL Script - Defining type of destination server

Следующий шаг


Указание имени файла назначения

На втором шаге необходимо задать имя генерируемого скрипта и место его хранения.

Export as SQL Script - Setting destination file name

Script destination

RadioButton Automatically load to Script Editor

Созданный скрипт открывается в редакторе SQL запросов.

RadioButton Save to file,

Созданный скрипт сохранится в файл. Имя и адрес файла укажите в поле File name. Можно выбрать файл с помощью стандартного диалогового окна, открывающегося по нажатию кнопки btnSaveAs.

В поле Table name (as it will be represented in the script file) укажите имя таблицы, которая будет создаваться с помощью этого скрипта. Имя схемы, в которой будет создаваться таблица, укажите в поле Schema name (as it will be represented in the script file, if need). Поле Schema name доступно только для СУБД, в которых имеется этот тип объектов.

Следующий шаг


Выбор метода экспорта полей типа BLOB

На этом шаге Вы можете задать способ экспорта полей типа BLOB.

Export as SQL Script - Setting BLOB options

BLOB and arrays options

RadioButton Если выберите пункт Don't extract BLOB fields, то поля типа BLOB не будут экспортированы.

RadioButton Extract BLOB fields as strings - при выборе этого пункта поля типа BLOB будут экспортированы в виде строк.

Следующий шаг


Выбор столбцов для экспорта

На этом шаге Вам необходимо из списка всех столбцов таблицы или представления выбрать те, которые Вы хотите экспортировать.

Из списка Available columns выберите доступные столбцы и с помощью кнопок переместите их в список экспортируемых столбцов - Selected columns, или перетащите мышкой из одного списка в другой. Если не выбрать ни одного столбца, то по умолчанию будут экспортированы все столбцы.

Export as SQL Script - Selecting fields to export

Следующий шаг


Настройка опций экспорта

На этом шаге настраиваются общие свойства экспорта.

Export as SQL Script - Setting export options

CheckBox Replace non-print characters in strings with spaces

Чтобы в тексте скрипта заменить непечатаемые символы пробелами установите флажок Replace non-print characters in strings with spaces.

CheckBox Quote identifiers

В скрипт будут добавлены символы кавычек.

CheckBox Use multi insert statements

При включенной опции операторы INSERT будут группироваться.

В разделе Data options укажите параметры фиксации транзакции.

CheckBox Если установлен флажок Insert COMMIT after each block, то после указанного в счетчике Records in a block числа записей транзакция будет фиксироваться.

Следующий шаг


Редактирование SQL скрипта

На этом шаге Вы можете просмотреть и отредактировать создаваемый SQL-скрипт в редакторе запросов.

Этот шаг становится доступным только если на первом шаге установить флажок Add CREATE TABLE statement.

Export as SQL Script - Editing table definition

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Export as SQL Script - Exporting as SQL Script

В текстовом поле отображаются все производимые действия и результат их выполнения.

CheckBox Если хотите сразу открыть полученный скрипт в редакторе SQL скриптов, то установите флажок Load generated script into Script Editor.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Мастер загрузки данных

Мастер загрузки данных - Load Data Wizard - позволяет загрузить данные из файла и вставить их в таблицу, используя команду COPY FROM.

Загрузку данных можно осуществлять только для тех редакторов, где есть вкладка Data или Results. Это Редактор таблиц, Редактор представлений, Редактор запросов и Дизайнер запросов.

Этот инструмент открывается с помощью кнопки Load Data, располагающейся на навигационной панели Data Management и на панели инструментов.

Кнопка доступна, когда в редакторе открыт просмотрщик данных, то есть на вкладке Data или Results.

Также эта команда присутствует в контекстном меню объектов таблицы и представления, в проводнике баз данных и в подменю пункта Data Manipulation.

Шаги мастера:

Выбор входного файла

Выбор колонок

Выбор типа файла-источника данных

Задание опций файла-источника данных

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер экспорта данных

Мастер импорта данных

Мастер экспорта в виде SQL скрипта

Мастер сохранения данных

Использование шаблонов


Выбор входного файла

На первом шаге мастера загрузки данных Вы должны указать тип файла, из которого будут загружаться данные, и путь к этому файлу.

Load Data Wizard - Setting input file name

В строке Absolute path and name of the input file on the server укажите путь к файлу источнику, относительно сервера. Файл может находиться в локальной сети. В этом случае путь к нему задается в формате UNC (Universal Naming Convention).

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор колонок

На этом шаге Вам необходимо из списка всех колонок таблицы или представления выбрать те, в которые Вы хотите загрузить данные.

Из списка Available columns выберите колонки таблицы и с помощью кнопок переместите их в список столбцов, в которые будут загружаться данные - Selected columns, или перетащите их из одного списка в другой с помощью мыши.

CheckBox Если установлен флажок All columns, то по умолчанию буду загружены данные во все столбцы.

Load Data Wizard - Defining columns

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор типа входного файла

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Задание основных параметров

На этом шаге Вам необходимо будет указать тип входного файла.

Load Data Wizard - Specifying type of input file

CheckBox Если установлен флажок With OID, то уникальные идентификаторы объектов тоже будут загружены из выбранного файла.

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание опций входного файла

На этом шаге задайте параметры текстового файла, из которого будет производиться загрузка данных.

Если на первом шаге Вы выбрали тип файла источника данных CSV, то на этом шаге задайте следующие параметры:

Load Data Wizard - Setting CSV parameters

Кавычки, в которые заключены колонкм, укажите в поле Quote.

Разделитель колонок - Delimiters.

Если в исходном файле имеются непечатные символы, то в поле Escape можно задать набор символов, который будет обозначать непечатные символы.

В поле NULL value задайте набор символов, который обозначает значение NULL.

CheckBox Если установлен флажок Force not Null, то каждая из выбранных ниже колонок будет обрабатываться как заключенная в кавычки и, соответственно, не имеющая значений NULL

Из списка Available columns выберите нужные колонки, данные из которых будут сохранены, и с помощью кнопок, перенесите их в список выбранных колонок - Selected columns.

Для текстового файла задайте следующие параметры:

Разделитель колонок - Delimiters.

В поле NULL value задайте набор символов, который обозначает значение NULL.

Load Data Wizard - Setting TXT parameters

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Load Data Wizard - Loading data

В индикаторе выполнения, расположенном в верхней части, в процентах отображается ход выполнения операции.

В текстовом поле отображаются все производимые действия и результат их выполнения.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Мастер сохранения данных

С помощью Мастера сохранения данных Вы можете сохранить данные таблицы в файл, расположенный на сервере или на компьютере клиента.

Данная операция осуществляется с использованием команды сервера COPY.

Сохранение данных можно осуществлять только из тех редакторов, где есть вкладка Data или Results. Это Редактор таблиц, Редактор представлений, Редактор запросов и Дизайнер запросов.

Важно: Сохранение данных (COPY) из запросов доступно только в версии PostgreSQL 8.2 и выше.

Этот инструмент открывается с помощью кнопки Save Data, располагающейся на навигационной панели Data Management и на панели инструментов.

Кнопка доступна, когда в редакторе открыт просмотрщик данных, то есть на вкладке Data или Results.

Также эта команда присутствует в контекстном меню объектов таблицы и представления, в проводнике баз данных и в подменю пункта Data Manipulation.

Мастер состоит из следующих шагов:

  • Выбор файла
  • Выбор столбцов
  • Настройка назначенного файла
  • Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер экспорта данных

Мастер импорта данных

Мастер экспорта в виде SQL скрипта

Мастер загрузки данных

Использование шаблонов


Выбор файла

На первом шаге мастера сохранения данных Вы должны указать тип файла, в который будет выгружаться данные, и путь к этому файлу.

Save Data Wizard - Setting output file name

В строке Data file name укажите путь к файлу источнику.

Если необходимо сохранить файл на сервере, то указываете локальный адрес. Например: C:/Program Files/EMS...

Если файл находится на клиентском компьютере, то используйте сетевой адрес - имя компьютера/имя директории...

Следующий шаг


Выбор столбцов

На этом шаге Вам необходимо из списка всех столбцов таблицы или представления выбрать те, данные из которых Вы хотите загрузить в файл.

Из списка Available columns выберите доступные столбцы и с помощью кнопок переместите их в список сохраняемых столбцов - Selected columns, или перетащите мышкой из одного списка в другой.

CheckBox Если установлен флажок All columns, то автоматически будут выбраны все столбцы.

Save Data Wizard - Defining columns

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор типа выходного файла

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Задание основных параметров

На этом шаге Вам необходимо будет указать тип выходного файла.

Save Data Wizard - Specifying type of output file

CheckBox Если установлен флажок With OID, то уникальные идентификаторы объектов тоже будут загружены из выбранного файла.

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Настройка выходного файла

SQL Manager for PostgreSQL
  • В начало
  • « Назад
  • Вперед »

Настройка назначенного файла

На этом шаге задайте параметры файла, в который будет производиться загрузка данных.

Для файла CSV необходимо указать следующие параметры:

Save Data Wizard - Setting CSV parameters

Кавычки, в которые будут заключены колонки, укажите в поле Quote.

Разделитель колонок - Delimiters.

В поле Escape указываются ASCII символы, которые должны отображаться перед данными, заключенными в кавычки.

По умолчанию это двойные кавычки.

В поле NULL value задайте набор символов, который обозначает значение NULL.

CheckBox Если установлен флажок Force quote columns, то отличные от NULL значения в указанных ниже столбцах будут автоматически заключены в кавычки. Значения NULL не заключаются в кавычки.

Из списка Available columns выберите столбцы, данные из которых будут сохранены, и с помощью кнопок, перенесите их в список выбранных столбцов - Selected columns.

Для текстового файла задайте следующие параметры:

Разделитель колонок - Delimiters.

В поле NULL value задайте набор символов, который обозначает значение NULL.

Save Data Wizard - Setting TXT parameters

Следующий шаг

Для того, чтобы каждый раз при загрузке не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Save Data Wizard - Saving data

В индикаторе выполнения, расположенном в верхней части, в процентах отображается ход выполнения операции.

В текстовом поле отображаются все производимые действия и результат их выполнения.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Инструменты для работы с базой данных

SQL Manager for PostgreSQL располагает набором инструментов, которые позволяют работать с базами данных.

Дерево зависимостей

Позволяет представить зависимости объектов в виде диаграммы.

Конструктор баз данных

Позволяет создавать графическое представление базы данных.

Редактор выполнения скриптов

Позволяет создавать и выполнять SQL-скрипты.

Мастер извлечения баз данных

Извлекает метаданные таблиц в SQL скрипт, который потом может быть выполнен на другой машине, чтобы восстановить структуру базы данных.

Печать метаданных

Создает отчет по метаданным базы данных.

Мастер создания HTML-отчетов

Создает отчет по метаданным базы данных в формате HTML.

Работа с отчетами

Набор инструментов, позволяющий создавать и печатать отчеты.

Монитор SQL

Отображает все SQL операции, выполненные в течение одной сессии работы SQL Manager for PostgreSQL.

Поиск по метаданным

Ищет вхождения заданного текста во всех метаданных БД.

Внешние инструменты

Вы можете выбрать любые exe файлы и запускать их напрямую из SQL Manager.

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Службы

Настройки

Дополнительно

Как...


Дерево зависимостей

Чтобы открыть Дерево зависимостей, выберите пункт главного меню Tools | btnDependencyTree Dependency Tree или на основной панели инструментов нажмите кнопку btnDependencyTree Dependency Tree , или в контекстном меню базы данных выберите пункт Tasks | btnDependencyTree Dependency Tree.

В появившемся окне выберите тип объекта и сам объект.

Dependency Tree - Select object

Этот инструмент позволяет просматривать зависимости всех объектов в виде диаграммы. Зависимости конкретного объекта можно просматривать ещё и на вкладке Dependencies редакторов объектов.

В главном окне этого инструмента отображается зависимость объектов, представленная в виде дерева.

Во время построения дерева прогресс операции отображается индикатором прогресса.

Все основные инструменты для работы с объектами и диаграммой зависимости располагаются на панелях инструментов и в контекстном меню.

Чтобы просмотреть зависимость объекта его необходимо выбрать. Сделать это можно одним из этих способов:

  • нажать на кнопку Select object на навигационной панели,
  • перетащить объект из окна проводника баз данных в главное окно дерева зависимостей.

Выбранный объект, являющийся главным, отличается от остальных цветом рамки. У него она синего цвета, у всех остальных - черного. Зависимости между объектами показаны стрелками. Если на объекте, представленном в диаграмме зависимостей, щелкнуть мышкой, то он становится главным и все зависимости отображаются для него. Чтобы просмотреть информацию по предыдущему объекту нужно на навигационной панели, на панели инструментов или в контекстном меню выбрать пункт Previous object.

Слева от объекта - те объекты, на которые ссылается редактируемый объект. Справа - те объекты, которые ссылаются на объект.

Если существует циклическая ссылка, то на том месте где она должна быть отображается крестик.

В диаграмме зависимостей существует возможность отображать и скрывать подобъекты.

Делается это с помощью кнопки Hide subobjects на панелях инструментов.

Контекстное меню объекта

Set as Root - посмотреть зависимости этого объекта.

Edit Object - открыть объект в соответствующем редакторе.

Контекстное меню

Открывается при нажатии правой кнопкой мыши в любой точке диаграммы зависимостей.

Dependency Tree - Using Navigation bar - popup menu

iconRefresh обновить - Refresh,

просмотреть зависимости предыдущего объекта - Previous object,

просмотреть зависимости следующего объекта - Next object,

выбрать объект - Select object,

показать подобъекты - Show subobjects. (индексы, триггеры и внешние ключи).

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Управление объектами базы данных


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Навигационная панель

Dependency Tree - Using Navigation bar

Database

iconDB выбрать базу данных.

General

iconRefresh обновить редактируемый объект - Refresh,

iconPrint печатать метаданные объекта - Print,

iconPrintSetup настройки печати - Print setup,

iconSaveAsPicture сохранить диаграмму как изображение - Save as image,

iconRestoreDefaultSize восстановить исходный размер окна - Restore default size.

Object

просмотреть зависимости предыдущего объекта - Previous object,

просмотреть зависимости следующего объекта - Next object,

показать подобъекты - Show subobjects. (индексы, триггеры и внешние ключи).

выбрать объект - Select object.

Diagram layout

iconShowAllObjects показать все объекты - show all objects

iconShowDependingOnRoot показать объекты, зависящие от корневого - show objects depending on Root

iconShowRootDependsOn показать объекты, от которых зависит корневой - show Root depends on objects

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Конструктор баз данных

Конструктор баз данных предназначен для визуального представления баз данных, объектов баз данных и связей между ними. Также он позволяет создавать, редактировать и удалять таблицы и столбцы таблицы и устанавливать отношения между таблицами.

Чтобы открыть конструктор выберите пункт Tools | Visual Database Designer главного меню программы, или на основной панели инструментов нажмите кнопку btnVDBD Visual Database Designer, или в контекстном меню базы данных выберите пункт Tasks | btnVDBD Visual Database Designer.

Панели инструментов

Перемещение по диаграмме

Работа с объектами

Создание связей

Работа с несколькими страницами

Обратное проектирование

Печать диаграммы

Сохранить/загрузить диаграмму

Настройка диаграммы

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Управление объектами базы данных


Панели инструментов

Навигационная панель

VDBD - Using Navigation bar

Database

iconDB выбрать базу данных.

File

iconNew New diagram - создать новую диаграмму,

iconLoadFromFile Open diagram - открыть существующую диаграмму,

iconSaveToFile Save diagram - сохранить диаграмму,

iconSaveToFileAs Save diagram as - сохранить диаграмму как.

Navigator

В окне навигатора уменьшенный макет диаграммы для удобного перемещения по ней.

General

Undo - отменить действие,

Redo - повторить действие,

iconRefresh Refresh - обновить диаграмму.

iconProperties Print setup - настройки печати,

iconPrint Print - печатать диаграмму,

iconPreview Print Preview - предварительный просмотр,

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна.

iconOptions Diagram options - задать свойства диаграммы.

Pages

New Page - создать новую страницу в диаграмме,

Delete Page - удалить активную страницу диаграммы,

Delete all - удалить все страницы диаграммы.

Database Objects

VDBD - Database Objects pane

список элементов, которые могут быть помещены в диаграмму.

Нажатие правой кнопкой на списке вызывает контекстное меню.

iconFindText Find object in diagram - найти выбранный объект на диаграмме

iconPlus Add New object - добавить новый объект на диаграмму с помощью обратного проектирования

Tick As tree / As list - вид отображения объектов: В виде дерева / В виде списка

Tick Sort by schema, name - сортировать объекты в списке по названию схемы, затем по имени объекта

Tick Sort by name, schema - сортировать объекты в списке по имени объекта, затем по названию схемы

iconRefresh Refresh - обновить список объектов

Панель инструментов

Все инструменты навигационной панели доступны на панели инструментов. Панель инструментов - ToolBar - расположена в верхней части окна. Чтобы её активировать, необходимо на вкладке Windows в Environment Options выбрать RadioButton Toolbar или RadioButton Both.

RadioButton Toolbar выберите, если хотите, чтобы отображалась только панель инструментов, а RadioButton Both - если хотите, чтобы отображались обе панели.

С помощью инструментов, расположенных на этой панели можно выполнить следующие действия:

iconDB выбрать базу данных;

iconNew New diagram - создать новую диаграмму;

iconLoadFromFile Open diagram - открыть существующую диаграмму;

iconSaveToFile Save diagram - сохранить диаграмму;

iconSaveAsPicture Save as picture - сохранить диаграмму как изображение;

Incremental search - отобразить панель инкрементного поиска;

iconZoomIn Zoom in - увеличить масштаб;

iconZoomOut Zoom out - уменьшить масштаб;

iconZoomSelectRectangleToFit Select rectangle to fit - выделить участок для увеличения;

iconZoomFitModel Fit model - вписать всю диаграмму в видимую область;

iconPrintSetup Print Setup - настроить параметры печати;

iconPrint Print - печатать диаграмму;

iconPreview Print Preview - предварительный просмотр;

iconAlwaysOnTop Arrange objects - автоматически упорядочить объекты на диаграмме;

btnExtractDB Extract metadata - извлечь метаданные объектов диаграммы и загрузить их в редактор SQL скриптов;

btnReverseEngineer Reverse Engineering - выполнить обратное проектирование;

iconRefresh Refresh - обновить диаграмму;

iconOptions Diagram options - задать свойства диаграммы;

  • Задать масштаб диаграммы в процентах;

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна.

Панель Object Customization

VDBD - Toolbars - Main

  • Font - шрифт выделенного объекта диаграммы
  • Size - размер шрифта
  • Bold - жирный шрифт
  • Italic - курсив
  • Underline - подчеркнутый
  • Font color - цвет шрифта
  • Pen color - рамка объекта
  • Brush color - фон объекта

Панель инструментов диаграммы:

Align left edges - выровнять по левой границе выделенные объекты

Align right edges - выровнять объекты по правой границе

Align tops - выровнять по верхней границе

Align bottom - выровнять по нижней границе

Align horizontal centers - выровнять по центру по горизонтали

Align vertical centers - выровнять по центру по вертикали

Space equally, horizontal - равное пространство по горизонтали

Space equally, vertical - равное пространство по вертикали

Select - установить режим выделения объектов

Create table - если нажата эта кнопка (выбран этот режим), то при нажатии левой кнопкой мыши на свободную область диаграммы будет создана новая таблица

Create relation - если нажата эта кнопка, то между таблицами можно создавать связи

Create comment - если нажата эта кнопка, то можно создать комментарий

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.

Смотрите также:

Контекстные меню

Перемещение по диаграмме

Работа с объектами диаграммы

Инкрементный поиск

Создание связей

Работа с вкладками

Обратное проектирование

Печать диаграммы

Сохранить/загрузить диаграмму

Настройка диаграммы


Перемещение по диаграмме

Для быстрого и удобного перемещения по диаграмме существует специальный инструмент - Навигатор, который располагается на навигационной панели.

VDBD - Diagram navigator

Навигатор представляет собой макет окна диаграммы, в котором красным прямоугольником выделена видимая область диаграммы. Он позволяет увидеть всю диаграмму в уменьшенном виде. Работать с объектами - выделять, перемещать, создавать и редактировать - в навигаторе можно так же, как и в самом окне диаграммы.

При нажатии левой кнопкой мыши в окне навигатора, центр видимой области диаграммы перемещается в эту точку. Таким образом, можно перемещаться по диаграмме, не используя полосы прокрутки.

Смотрите также:

Панели инструментов

Работа с объектами диаграммы

Работа с вкладками


Контекстные меню

Контекстное меню области диаграммы

VDBD - Using context menu

  • Select All - выделить все объекты диаграммы,
  • Select All Headers - выделить все заголовки,
  • Select All Columns - выделить все столбцы,
  • Zoom - из подменю выбрать масштаб диаграммы,
  • Create - выбрать тип создаваемого объекта,
  • Grid - настроить вид сетки,
  • Style - настроить диаграмму,
  • Reverse Engineer - обратный инжиниринг схемы данных (генерация модели данных на основе анализа существующей БД),
  • Extract Metadata - генерировать скрипт метаданных объектов диаграммы и загрузить этот скрипт в SQL Script Editor,
  • Diagram Options - задать настройки диаграммы.

Контекстное меню заголовка таблицы позволяет работать с таблицей:

VDBD - Using entity context menu

  • открыть таблицу в редакторе - Edit Table "имя схемы.Имя_объекта",
  • создать таблицу - New Table...,
  • удалить таблицу из базы данных - Drop Table "имя схемы.Имя_объекта",
  • выделить столбцы - Select Columns,
  • скрыть подобъекты - Hide Subitems.
  • удалить таблицу из диаграммы - Remove Table "имя схемы.Имя_объекта".

Контекстное меню столбца позволяет редактировать, добавлять и удалять столбцы таблицы.

Смотрите также:

Панели инструментов

Работа с объектами диаграммы

Создание связей

Инкрементный поиск


Работа с объектами диаграммы

Объектами диаграммы являются таблицы и столбцы таблиц.

Жирным шрифтом в таблицах выделены обязательные для заполнения поля (NOT NULL). По умолчанию столбцы первичного ключа отделены от остальных столбцов таблицы и обозначены специальной иконкой. Вид представления таблиц и связей можно настроить.

Добавление объектов на диаграмму

Добавить таблицу в область диаграммы можно двумя способами:

  • перетащить таблицу из окна проводника баз данных,
  • перетащить из списка доступных объектов, который расположен на навигационной панели.

Удаление объектов из диаграммы

Чтобы удалить таблицу из базы данных воспользуйтесь пунктом контекстного меню заголовка таблицы Drop Table "Имя_объекта".

VDBD - Removing objects from diagram

Создание нового объекта

В окне диаграммы можно создавать новые таблицы, используя пункт контекстного меню заголовка таблицы New Table... или Далее в открывшемся редакторе таблиц нужно задать столбцы и свойства новой таблицы и нажать Compile. Созданная таблица появится на диаграмме.

VDBD - Creating new table

Важно: До нажатия кнопки Compile объект создается только на поле диаграммы, но не в базе данных.

Редактирование объекта

В окне диаграммы можно редактировать как таблицы, так и столбцы таблиц.

Чтобы открыть таблицу в редакторе таблиц нужно в контекстном меню заголовка таблицы выбрать пункт Edit Table "Имя_объекта".

Работа с столбцами осуществляется с помощью контекстного меню столбца.

Смотрите также:

Панели инструментов

Перемещение по диаграмме

Контекстные меню

Создание связей

Инкрементный поиск

Обратное проектирование

Управление объектами базы данных


Инкрементный поиск

Чтобы по названию найти объект на диаграмме необходимо:

  • Нажмите кнопку [image] Incremental Search на одной из панелей инструментов,
  • или используйте сочетание клавиш Ctrl+F.

VDBD - Incremental Search

Искомое сочетание символов укажите в появившемся поле Incremental Search, появившемся в нижней части области диаграммы.

Смотрите также:

Перемещение по диаграмме


Создание связей

SQL Manager for PostgreSQL позволяет создавать связи между таблицами - внешние ключи - в окне диаграммы. Для этого на панели инструментов окна диаграммы надо нажать кнопку Create relation.

VDBD - Creating relations

Теперь, чтобы установить связь между двумя таблицами нужно нажать мышкой на каждой из них. После этого откроется редактор внешних ключей, в котором Вы сможете задать все свойства создаваемой связи.

VDBD - Creating relations - Context menu

Связь между таблицами отображается в виде соединительной линии.

Управление связью осуществляется с помощью контекстного меню, которое открывается при нажатии правой кнопкой мыши на связь.

С помощью этого меню Вы можете:

  • открыть связь в редакторе внешних ключей - Edit Foreign Key "имя_объекта",
  • удалить связь Drop Foreign Key "имя_объекта".

При создании связи с помощью кнопки Create relation на панели инструментов диаграммы выбранные столбцы автоматически заносятся в редактор внешних ключей.

Смотрите также:

Перемещение по диаграмме

Работа с объектами диаграммы

Инкрементный поиск


Работа с вкладками

В одной диаграмме баз данных Вы можете создать несколько вкладок для разделения объектов на группы для удобства просмотра.

VDBD - Working with diagram pages

Работа с вкладками:

  • создать новую вкладку - New Page,
  • удалить вкладку - Delete Page,
  • удалить все вкладки - Delete All Pages,
  • переименовать вкладку - Rename Page.

Все эти команды находятся в контекстном меню страницы и на панели инструментов.

Смотрите также:

Перемещение по диаграмме

Работа с объектами диаграммы


Обратное проектирование

Для того чтобы быстро перенести на диаграмму все таблицы базы данных с отношениями между ними нужно воспользоваться кнопкой Reverse Engineer btnReverseEngineer на панели инструментов.

VDBD - Reverse engineering

Это позволит совершить обратное проектирование базы данных.

Все таблицы базы будут выстроены на диаграмме, со всеми существующими между ними связями.

VDBD - Reverse engineering - Select schema

В появившемся окне выберите схему, объекты которой хотите поместить на диаграмму.

Смотрите также:

Панели инструментов

Перемещение по диаграмме

Работа с объектами диаграммы


Печать диаграммы

Конструктор баз данных позволяет открыть диаграмму в окне предпросмотра и распечатать её.

Чтобы распечатать диаграмму, нажмите кнопку Print btnPrintMetadata на панели инструментов.

Инструмент для предпросмотра диаграммы - Print Preview - открывается при нажатии кнопки Print Preview btnPrintPreview , на панели инструментов.

Для настроек печатного документа используйте Print Setup Dialog, который открывается при нажатии на кнопку Print setup btnPrintSetup , на панели инструментов. С помощью этого же инструмента можно распечатать документ.


Предварительный просмотр

Предварительный просмотр - это режим просмотра документа в том виде, в котором он будет напечатан.

VDBD - Printing diagram - Print Preview

С помощью инструмента Print Preview Вы можете просмотреть диаграмму перед печатью.

Действия, которые можно выполнить, используя панель инструментов:

  • указать номер просматриваемой страницы. С помощью кнопок можно открыть следующую или предыдущую страницу, в счетчике укажите номер желаемой страницы,
  • кнопка Print all позволяет напечатать все страницы или только текущую (раскрывающийся список кнопки),
  • настроить параметры печати - кнопка Print options,
  • установить масштаб просмотра - Preview zoom.

Смотрите также:

Настройки печати


Настройки печати

Это диалоговое окно позволяет настроить опции печати:

  • параметры принтера - на вкладке Printer,
  • параметры страницы на вкладке Page options.

Инструменты, располагающиеся на вкладке Printer.

Database tools - VDBD - Print Setup - Printer

Имя принтера - отображается в поле Name.

Выбор активного принтера - кнопка Choose printer.

Сведения о драйвере принтера - поле Driver.

Порт подключения принтера - поле Port.

RadioButton Процент от натуральной величины - Use scale factor.

RadioButton Разместить не более чем на n страницах в ширину и n страницах в высоту - Arrange diagram at n pages horizontally and n pages vertically.

CheckBox Если установлен флажок Skip empty pages, то при печати будут пропущены пустые страницы.

CheckBox Установите флажок Print only selected objects, если хотите? чтобы напечатаны были только выделенные объекты.

CheckBox Установленный флажок Print page borders позволяет печатать границы страниц.

RadioButton All pages указывает на то что печататься будут все страницы.

RadioButton Pages from... to... позволяет задать диапазон печатаемых страниц.

Инструменты, располагающиеся на вкладке Page options.

Database tools - VDBD - Print Setup - Page options

Top margin (mm) - размер верхнего поля в мм.,

Bottom margin (mm) - размер нижнего поля в мм.,

Left margin (mm) - размер левого поля в мм.,

Right margin (mm) - размер правого поля в мм.,

В поле Page Header задайте текст верхнего колонтитула.

RadioButton Left align - выравнивание текста колонтитула по левому краю.

RadioButton Center align - выравнивание текста колонтитула по центру.

RadioButton Right align - выравнивание текста колонтитула по правому краю.

Page Footer - параметры нижнего колонтитула.

RadioButton Left align - выравнивание текста колонтитула по левому краю.

RadioButton Center align - выравнивание текста колонтитула по центру.

RadioButton Right align - выравнивание текста колонтитула по правому краю.

Смотрите также:

Предварительный просмотр


Сохранить/загрузить диаграмму

SQL Manager for PostgreSQL позволяет сохранять и загружать сохраненную диаграмму.

Файлы диаграммы сохраняются в формате .pgd.

Кнопки сохранить загрузить диаграмму расположены на панели инструментов:

  • открыть диаграмму - Open Diagram,
  • сохранить диаграмму - Save Diagram,
  • сохранить диаграмму как изображение - Save as Picture.

VDBD - Saving and Loading diagram

Чтобы открыть сохраненную ранее диаграмму нажмите на кнопку Open Diagram на панели инструментов.

Если попытаться открыть диаграмму для другой базы, то программа, не найдя соответствующих таблиц, выдаст ошибку.

Смотрите также:

Панели инструментов

Перемещение по диаграмме

Контекстные меню

Работа с объектами диаграммы


Настройка диаграммы

Настроить вид диаграммы можно с помощью инструментов, расположенных на вкладке Options | Environment Options | Tools | Visual Database Designer.

Окно настроек можно открыть также с помощью кнопки btnEnvironmentOptions Diagram options, расположенной на одной из панелей инструментов или соответствующего пункта контекстного меню.

Смотрите также:

Настройки визуального конструктора баз данных


Редактор выполнения скриптов

В редакторе Execute Script Editor Вы можете создавать, просматривать, редактировать и выполнять SQL-скрипты. Чтобы открыть редактор выберите Tools | btnNewSQLScript Execute Script в главном меню программы, или на основной панели инструментов нажмите кнопку btnNewSQLScript SQL Script, или в контекстном меню базы данных выберите пункт Tasks | btnNewSQLScript SQL Script.

Объекты базы данных, используемые в скрипте, представлены в проводнике редактора скриптов.

Область редактирования

Работать с SQL-скриптами позволяют инструменты редактора, располагающиеся на панелях инструментов.

Важно: В редакторе скриптов не выводятся результаты запросов. Для этого используйте редактор получения данных.

Если при выполнении скрипта возникнут ошибки, то все они будут показаны в специальном окне, расположенном под областью редактирования. Настройка отображения ошибок происходит с помощью Options | Environment Options | Tools | Execute Script, с помощью кнопкиExecute Script Options на панели инструментов и на навигационной панели.

Смотрите также:

Редактор получения данных

Настройки SQL-скрипта

Настройки редакторов


Панели инструментов

Навигационная панель

SQL Script Editor - Using Navigation bar

Destination

iconHost выбрать хост,

iconDB выбрать базу данных.

General

iconExecute выполнить скрипт - Execute script,

iconCompile выполнить скрипт из файла - Execute script from file,

iconNew создать новый скрипт - New script,

iconLoadFromFile открыть скрипт (скрипты сохраняются в виде файлов с расширением ".sql") - Open script,

iconSaveToFile сохранить скрипт - Save script,

iconSaveToFileAs сохранить скрипт как - Save as,

iconSaveToFileAs сохранить в Общие скрипты как - Save as,

iconDBExplorer включить/отключить синтаксический анализ - Enable/Disable Parsing,

включить журнал результатов - Enable result log,

iconOptions настройка свойств SQL скрипта - SQL Script options,

iconRestoreDefaultSize восстановить исходный размер окна - Restore default size,

iconDisableAllCodeFeatures включить/отключить всё форматирование текста - Enable/Disable All code features.

Панель Version Control появляется только если база данных подключена к системе контроля версий.

На этой панели можно указать как именно будут заноситься в систему контроля версий выполненный скрипты:

Always - всегда

If script changes objects - если скрипт изменил объекты.

RadioButton Ask comment before run - добавить комментарий перед скриптом.

RadioButton Ask comment after run - добавить комментарий после скрипта.

На панели Explorer расположен проводник редактора SQL скриптов.

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.

Смотрите также:

Работа с областью редактирования Execute Script

Проводник редактора скриптов

Выполнение скрипта


Работа с областью редактирования скрипта

Область редактирования позволяет эффективно работать с текстами SQL-скриптов.

SQL Script Editor - Working with SQL Script editor area

Функциональные возможности:

  • Подсветка синтаксиса - используются разные цвета и шрифты для различных элементов текста, таких как ключевые слова, знаки препинания, комментарии, ссылки и т.д. Просмотреть и изменить настройки цвета Вы можете на вкладке Color. (Editor Options)
  • отображение имен объектов в виде ссылок на эти объекты,
  • вызов и настройка списка автоматической подстановки,
  • возможность нумерации строк,
  • возможность сворачивать запросы и подзапросы,
  • возможность задавать свойства выделенных объектов,
  • настройка полей и номеров строк,
  • изменение параметров различных объектов текста запроса,
  • настройка автоматического форматирования текста запроса,
  • задание сочетаний клавиш для быстрого ввода текста и выполнения команд.

Важно: Если была выбрана база данных, а в скрипте присутствует оператор подключения к другой базе \connect "имя базы";, то появляется кнопка Reset, нажав на которую можно заблокировать выполнение этого оператора. Тогда скрипт будет выполнен для базы, выбранной на одной из панелей инструментов.

SQL Script Editor - Reset Script

Контекстное меню

С помощью контекстного меню Вы можете:

  • добавить в словарь - Add to Dictionary,
  • редактировать - Correct With,
  • Выполнить запрос - Execute,
  • Выполнить только выделенное - Execute Selected Only,
  • Выполнить под курсором - Execute under Cursor,
  • Убрать контрольные точки - Reset Execution Point,
  • Открыть подменю, позволяющее работать с маркерами - Markers,
  • Установить закладку - Toggle Bookmarks,
  • Перейти к закладке (этот пункт активен только тогда, когда установлены закладки) - Goto Bookmarks,
  • Отменить действие- Undo,
  • Вернуть отмененное действие- Redo,
  • Вырезать выделенное- Cut,
  • Копировать выделенное- Copy,
  • Вставить - Paste,
  • Выделить все - Select All,
  • Найти - Find,
  • Найти и заменить - Replace,
  • Возобновить поиск - Search Next,
  • инкрементный поиск - Incremental Search,
  • Перейти к строке под номером... - Go To Line By Number...,
  • Изменить регистр - Change Case,
  • Загрузить из файла - Load,
  • Сохранить в файл - Save,
  • Предварительный просмотр - Preview,
  • Печатать - Print,
  • Форматировать запрос SQL (при этом применяются изменения, внесенные в Форматтер SQL) - Format SQL,
  • Преобразовать выделенный текст в комментарии - Toggle Comment,
  • Сохранить как избранный запрос - Save as Favorite Query,
  • Просмотреть и изменить свойства в Editor Options- Properties.

Подменю пункта Quick Code:

  • Форматировать запрос SQL (при этом применяются изменения, внесенные в Форматтер SQL) - Format SQL,
  • Выбрать символ - Select Character,
  • Преобразовать выделенный текст в комментарии - Toggle Comment,
  • Привести выделенный текст к нижнему регистру - Selection Lower Case,
  • Привести выделенный текст к верхнему регистру - Selection Upper Case,
  • Изменить регистр выделенного текста - Selection Toggle Case,
  • Увеличить отступ текста - Indent,
  • Уменьшить отступ текста - Unindent.

Смотрите также:

Панели инструментов

Проводник редактора скриптов

Выполнение скрипта

Избранные запросы

Настройки SQL скрипт


Проводник редактора скриптов

На навигационной панели расположен инструмент Проводник (Explorer), который позволяет отобразить в виде дерева все объекты, содержащиеся в SQL скрипте. С помощью проводника можно быстро перейти к нужному объекту в тексте скрипта. Достаточно щелкнуть на нужном объекте мышкой.

Включить/отключить отображение проводника можно нажав на кнопку iconDBExplorer Enable/Disable Parsing.

SQL Script Editor - Using Script Explorer

Важно: При выборе объекта в проводнике баз данных выделяется соответствующие ему участок текста скрипта.

При двойном нажатии на объект в проводнике соответствующий участок скрипта выделяется, и фокус перемещается к выделенному участку.

Смотрите также:

Панели инструментов

Работа с областью редактирования скриптов

Управление объектами базы данных


Выполнение скрипта

Когда все параметры скрипта заданы, Вы можете приступать к его выполнению.

Чтобы выполнить скрипт, выберите пункт btnExecuteQuery Execute script на одной из панелей инструментов или в контекстном меню. Также, Вы можете использовать клавишу F9.

SQL Script Editor - Script execution

Важно: Если установлен флажок CheckBox Execute selected text separately (Environment Options | Tools | Execute Script), и выделен фрагмент текста скрипта, то будет выполнен только выделенный фрагмент.

Если в тексте скрипта нет ошибок, то скрипт выполняется, а об успешном выполнении информирует появляющееся информационное окно.

SQL Script Editor - Script execution - Done

Если в тексте скрипта обнаружены ошибки, то список их будет выведен в нижней части формы редактора.

Важно: Когда Вы выбираете ошибку из появившегося списка ошибок, то соответствующий ей участок кода выделяется цветом. Если вы дважды щелкаете мышкой на ошибке, то в редакторе осуществляется переход к нужному участку кода.

Важно: Execute Script не отображает результатов выполнения запросов.

Для выполнения запросов существует специальный инструмент - Query data.

Смотрите также:

Панели инструментов

Работа с областью редактирования скриптов

Проводник редактора скриптов


Мастер извлечения баз данных

Используя Мастер извлечения баз данных, Вы можете извлечь структуру объектов базы данных и сами данные в SQL скрипт. Полученный скрипт можно использовать для копирования и восстановления базы данных. Чтобы открыть мастер выберите пункт главного меню программы Tools | btnExtractDB Extract Database, или на основной панели инструментов нажмите кнопку btnExtractDB Extract Database, или в контекстном меню базы данных выберите пункт Tasks | btnExtractDB Extract Database.

Мастер извлечения баз данных

Выбор исходной базы данных

Выбор файла назначения

Выбор вида экспорта

Выбор объектов для извлечения

Выбор таблиц, из которых будут извлечены данные

Задание свойств скрипта

Выполнение операции

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов, который открывается при нажатии на кнопку Templates.

Важно: Не все функции этого мастера доступны в Lite версии.

Смотрите также:

Редактор SQL скриптов

Управление объектами базы данных

Использование шаблонов


Выбор исходной базы данных

На первом шаге выберите базу данных, которую необходимо извлечь.

Из раскрывающегося списка Source database выберите нужную базу данных.

Extract Database - Selecting source database

CheckBox Установите флажок Extract all metadata and data if database, если хотите извлечь все объекты базы данных и данные, хранящиеся в ней.

Следующий шаг


Выбор файла назначения

На этом шаге Вы можете определить сохранить ли создаваемый скрипт в файл или сразу открыть в редакторе SQL скриптов.

Extract Database - Specifying destination file name

Script destination

RadioButton Чтобы автоматически открыть скрипт в редакторе SQL скриптов, нужно выбрать пункт переключателя Automatically load to Query data.

RadioButton Если хотите сохранить скрипт в файл, то выберите пункт Save to file. В этом случае в поле File name необходимо указать имя файла и путь к нему, или выбрать файл, воспользовавшись стандартным диалоговым окном, открывающимся при нажатии на кнопку btnSaveAs. Для создаваемого файла можно указать кодировку, выбрав его из раскрывающегося списка File charset.

Следующий шаг


Выбор режима экспорта

Этот шаг неактивен, если на первом шаге Вы указали, что извлекать нужно всю структуру и данные базы данных, установив флажок Extract all metadata and data of the database.

Extract Database - Setting extraction mode

Вы можете выбрать один из трех вариантов экспорта:

RadioButton извлечь структуру и данные базы - Extract both of structure and data,

RadioButton извлечь только структуру - Extract structure only,

RadioButton извлечь только данные - Extract data only.

Следующий шаг


Выбор объектов для извлечения

Этот шаг будет активен только в том случае, если Вы извлекаете структуру базы данных.

Вы можете выбрать объекты, структуру которых следует извлечь.

Extract Database - Selecting objects for structure extraction

RadioButton Установленный Extract all objects указывает на то, что будет извлечена структура всех без исключения объектов.

RadioButton Если переключатель установлен в Extract all objects of schema, то копироваться будут объекты схемы, указанной в списке Schema name.

RadioButton Если выбрать Extract selected objects, то можно будет выбрать извлекаемые объекты.

Из раскрывающегося списка Objects to extract выбираете тип объекта (таблица, представление и т.д.). После выбора типа в списке Available появляются все объекты базы данных, соответствующие выбранному типу. С помощью кнопок переместите объекты из списка доступных - Available в список выбранных - Selected, или перетащите из одного списка в другой.

Следующий шаг


Выбор таблиц, из которых будут извлечены данные

На этом шаге Вы можете выбрать те таблицы, из которых необходимо извлечь данные.

Extract Database - Selecting objects for data extraction

RadioButton Если выберите Extract all tables, то данные будут извлечены из всех таблиц базы.

RadioButton Пункт переключателя Extract data of tables selected on previous step указывает на то, что данные будут извлекаться только из тех таблиц, которые были выбраны на предыдущем шаге.

RadioButton Если выбран пункт Extract selected Tables, то Вы сможете выбрать таблицы из списка доступных - Available, и с помощью кнопок переместить их в список выбранных - Selected.

Следующий шаг


Задание свойств скрипта

На последнем шаге можно задать некоторые общие опции генерируемого SQL скрипта.

Extract Database - Customizing script options

CheckBox Generate DROP statements

Если выбрана эта опция, то в скрипт будут добавлены операторы DROP для извлекаемых объектов базы данных

CheckBox Если установлен флажок With IF statement (for 8.2 or higher), то в операторах DROP будут заданы условия IF.

CheckBox Если установлен флажок CHARACTER and CHARACTER VARYING as CHAR and VARCHAR типы CHARACTER и CHARACTER VARYING будут представлены как CHAR и VARCHAR.

Количество записей данных в одном блоке задается в счетчике Records in a block.

CheckBox Если установлен флажок Insert "COMMIT" statement after each block, то после каждого блока добавляется оператор COMMIT.

В разделе Extract data as укажите, в каком виде извлекать данные:

RadioButton Insert statements - в виде операторов Insert,

RadioButton Copy statements - в виде операторов Copy.

CheckBox Операция извлечения будет прервана при возникновении ошибки, если установлен флажок Abort extraction on error. В противном случае скрипт будет выполняться без прерываний, а все возникшие ошибки отобразятся в специальном окне.

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Extract Database - Start of extraction process

В текстовом поле отображаются все производимые действия и результат их выполнения.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Печать метаданных

Инструмент Print Metadata позволяет печатать метаданные любого объекта базы данных. Чтобы открыть этот инструмент нужно выбрать Tools | btnPrintMetadata Print Metadata, или на основной панели инструментов нажмите кнопку btnPrintMetadata Print Metadata, или в контекстном меню базы данных выберите пункт Tasks | btnPrintMetadata Print Metadata.

Настройки печати можно произвести с помощью инструментов, находящихся на панелях инструментов.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Управление объектами базы данных

Настройки печати метаданных


Панели инструментов

Навигационная панель

Print Metadata - Using Navigation bar

Database

iconDB выбрать базу данных

General

iconPrint печатать - Print

iconPreview предварительный просмотр - Preview

iconRestoreDefaultSize восстановить исходный размер окна - Restore default size

На панели Show находится список типов объектов:

  • показать все объекты - Show All
  • таблицы - Tables
  • представления - Views
  • функции - Functions
  • домены - Domains
  • правила - Rules
  • триггеры - Triggers
  • индексы - Indices
  • последовательности - Sequences
  • типы - Types
  • агрегатные функции - Aggregates
  • операторы - Operators
  • табличные пространства - Tablespaces
  • языки описания процедур - Languages
  • схемы - Schemas

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Выбор объектов

В процессе настройки печати необходимо выбрать те объекты базы данных, метаданные которых необходимо напечатать.

Print Metadata - Printing options

На одной из панелей управления выберите тип объекта. После этого в списке Available <тип_объекта> появятся все объекты этого типа, содержащиеся в базе данных. С помощью кнопок или двойного щелчка мыши переместите эти объекты в список выбранных - <тип_объекта> for Printing. Несколько объектов можно выделить с помощью клавиш Ctrl and Shift.

В нижней части списка выбранных объектов Вы можете указать, какую именно информацию об этом объекте следует печатать:

CheckBox Columns/Params - поля/параметры

CheckBox Indices - индексы

CheckBox Foreign Keys - внешние ключи

CheckBox Checks - ограничения

CheckBox DDL - DDL

CheckBox Description - описание

CheckBox Triggers - триггеры

CheckBox Rules - правила

Убрать объект из списка выбранных можно с помощью кнопок или двойного щелчка мыши.


Предварительный просмотр

При нажатии кнопки btnPrintPreview Preview, на одной из панелей инструментов, формируется представление печатного документа.

Print Metadata - Preview

Панель инструментов

  • Начать печать отчета.
  • Открыть предыдущий сохраненный отчет.
  • Сохранить текущий отчет в файл, с расширением *.fr3.
  • btnPreviewExport Сохранить файл предварительный отчет в один из доступных форматов (HTML file, Excel file, Text file, RTF file, CSV file, HTML file, BMP image, Excel table (OLE), JPEG image, TIFF).
  • Искать текст.
  • Масштаб
  • Отобразить/скрыть содержание отчета.
  • Отобразить/скрыть иконки отчета.
  • Задать параметры страницы.
  • Редактировать страницу в Конструкторе отчетов.
  • Переход по страницам отчета.
  • Закрыть предпросмотр.

Смотрите также:

Панели инструментов

Настройки печати


Мастер создания HTML отчетов

Мастер создания HTML отчетов позволит Вам создать подробный развернутый отчет о метаданных выбранной базы данных. Открывается с помощью пункта меню Tools | [image] HTML Report, или на основной панели инструментов нажмите кнопку [image] HTML Report, или в контекстном меню базы данных выберите пункт Tasks | [image] HTML Report.

Выбор базы данных и выходной директории

Выбор типа объекта базы данных

Задание стиля отчета

Задание дополнительных параметров

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Управление объектами базы данных

Использование шаблонов


Выбор базы данных и выходной директории

На первом шаге необходимо выбрать базу данных, по метаданным которой необходимо сгенерировать отчет.

Исходная база выбирается из раскрывающегося списка Source database, в котором содержатся все зарегистрированные и подключенные базы данных.

В поле Output directory, с помощью кнопки ExplorerButton указываете путь к папке, в которой будет создан HTML отчет.

HTML Report - Selecting database and directory

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор типа объекта базы данных

На втором шаге Вы можете выбрать тип объектов, информация о которых попадет в отчет. По умолчанию, выбраны все типы объектов.

HTML Report - Selecting object types

CheckBox таблицы - Tables

CheckBox представления - Views

CheckBox функции - Functions

CheckBox домены - Domains

CheckBox правила - Rules

CheckBox триггеры - Triggers

CheckBox индексы - Indices

CheckBox последовательности - Sequences

CheckBox составные типы данных - Composite Types

CheckBox перечислимые типы - Enum Types

CheckBox базовые типы данных - Base types

CheckBox агрегатные функции - Aggregates

CheckBox операторы - Operators

CheckBox сортировки - Collations

CheckBox схемы - Schemas

CheckBox табличные пространства - Tablespaces

CheckBox языки описания процедур - Languages

CheckBox ограничения - Checks

CheckBox внешние ключи - Foreign Keys

Select all - выделить все,

Unselect all - убрать все выделение.

Следующий шаг


Задание стиля отчета

На третьем шаге Вы задайте стиль выходного HTML файла.

На вкладке CSS Preview выберите готовый шаблон оформления.

Текст описания стиля Вы можете редактировать вручную на вкладке CSS Text.

HTML Report - Specifying CSS

Следующий шаг


Задание дополнительных параметров

На последнем шаге задаются параметры, общие для всего отчета.

  • верхний колонтитул - Report header
  • нижний колонтитул - Report footer

HTML Report - Setting additional report options

С помощью ползунка DDL font size задайте размер шрифта DDL секции.

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

HTML Report - Creating HTML report

В текстовом поле показаны все производимые действия и результат их выполнения.

CheckBox Если хотите сразу открыть полученный отчет, то установите флажок Show report after generating.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Работа с отчетами

Работать с отчетами в SQL Manager for PostgreSQL можно с помощью следующих инструментов.

Мастер создания отчетов и Настройщик отчетов - упрощенные способы создания отчетов.

Конструктор отчетов - основной инструмент для создания отчетов.

Просмотрщик отчетов - инструмент для просмотра результатов.

Хранить отчеты можно в директориях, определенных в базе данных при редактировании регистрационной информации базы данных на вкладке Directories или в специально создаваемой в базе данных таблице pgmreports.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Мастер создания отчетов

Мастер создания отчетов предназначен для быстрого пошагового создания бланка отчета. Для него определен источник данных, отображаемые области и параметры страницы. Для запуска мастера необходимо выполнить одно из действий:

  • создать объект Report в проводнике баз данных,
  • выбрать пункт главного меню программы Database | New Object,
  • выбрать пункт Report из списка, открывающегося при нажатии на кнопку Create на панели инструментов проводника баз данных.

Задание основных свойств отчета

Выбор областей, отображаемых в отчете

Определение стиля отчета

Задание параметров страницы

Create Report - Specifying database name and report options

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Конструктор отчетов

Просмотрщик отчетов


Задание основных свойств отчета

На первом шаге создания отчета Вам необходимо выбрать базу данных, для которой будет сформирован отчет, из списка Database. Список состоит из зарегистрированных и подключенных баз данных.

В разделе Report creation method выберите способ создания отчета:

RadioButton New report - будет создан новый отчет,

RadioButton Import from file - отчет будет импортирован из файла.

В разделе Save options можно задать параметры сохранения файла отчета:

имя файла укажите в поле Report name,

RadioButton Если переключатель установить в Save to database, то отчет будет сохранен в специальную таблицу базы данных , которая называется pgmreports.

RadioButton Если выбран Save to file, то отчет будет сохранен в файл отчета с расширением *.fr3.

Create Report - Specifying database name and report options

Следующий шаг


Выбор областей отображаемых в отчете

На этом шаге необходимо выбрать области, которые будут включены в отчет: данные, колонтитулы, суммы, группировки полей и т.д.

Необходимые области выберите из списка доступных областей - Available Bands и с помощью кнопок Move to Selected Move all to Selected Move to Available Move all to Available перенесите в список отображаемых областей - Report Bands.

Для областей Master data, Detail data и Subdetail data необходимо задать набор значений, используя кнопку [image]. При нажатии на эту кнопку открывается конструктор запросов, с помощью которого Вы можете задать данные, которые будут отображаться в отчете.

Области, для которых указаны данные, отмечены галочкой.

Важно: Задавать данные для Detail data можно только после того как они заданы для Master data, а для Subdetail data только после Master data.

Create Report - Selecting report bands

Report title - заголовок отчета

Report summary - сводка отчета

Page header - верхний колонтитул страницы

Page footer - нижний колонтитул страницы

Master header - заголовок (верхний колонтитул) данных

Master data - данные

Master footer - нижний колонтитул области данных

Detail data - данные-детали

Subdetail data - дополнительные данные-детали

Group header - заголовок групп при группировке данных

Group footer - нижний колонтитул группы при группировке данных

Следующий шаг


Определение стиля отчета

На третьем шаге Вы можете выбрать стиль отчета. На форме расположены макеты оформления страниц. Для выбора макета достаточно щелкнуть на нужном левой кнопкой мыши.

Create Report - Selecting report style

Следующий шаг


Задание параметров страницы

На этом шаге Вам предстоит задать параметры страницы печатного документа отчета. Эти свойства задаются на трех вкладках:

Вкладка Paper

Create Report - Specifying paper settings

В разделе Size указываете размер страницы.

Из раскрывающегося списка выберите один из стандартных размеров. Если стандартные размеры не подходят, то выберите пункт Особая бумага. В этом случае станут доступными для редактирования поля, в которых указывается ширина и высота бумаги в миллиметрах - Width, mm (ширина) и Height, mm (высота).

С помощью переключателя в разделе Orientation Вы выберите ориентацию страницы.

RadioButton Portrait - книжная,

RadioButton Landscape - альбомная.

Вкладка Margins

Create Report - Specifying margins

На вкладке Margins можно указать размеры полей страницы.

CheckBox Если установлен флажок Stretch to print area, то автоматически устанавливается соответствие размеров полей размеру печатной области.

Установить размеры полей страницы вручную можно с помощью следующих полей:

  • Left, mm - левое поле,
  • Top, mm - верхнее поле,
  • Right, mm - правое поле,
  • Bottom, mm - нижнее поле.

Вкладка Other

Create Report - Specifying other page settings

На вкладке Other можно задать некоторые дополнительные характеристики макета отчета.

CheckBox Print to previous page. Эта опция позволит при печати отчета использовать пустое пространство предыдущей страницы. Функция используется, если отчет состоит из нескольких страниц.

CheckBox Если установлен флажок Two-pass report, то формирование отчета будет осуществляться в два этапа. На первом проходе отчет формируется, осуществляется его разбивка на страницы, но результат нигде не сохраняется. На втором проходе происходит обычное формирование отчета с сохранением результата в потоке.

CheckBox Установка флажка Page numbering указывает на то, что страницы отчета будут пронумерованы.

Columns

В счетчике Number задайте количество столбцов в отчете.

В поле Gap, mm указываете расстояние между столбцами.

CheckBox Если установлен флажок Open the report after the wizard has finished, то созданный мастером отчет после создания автоматически откроется в конструкторе отчетов.

Чтобы начать создание отчета нажмите кнопку Run.


Конструктор отчетов

Конструктор отчетов позволяет Вам создавать и редактировать отчеты. Этот инструмент открывается при выборе пункта Tools | Report Designer или после создания отчета с помощью Мастера создания отчетов.

Модуль Report Designer является компонентом программы FastReport (http://www.fast-report.com). Поэтому для него существует отдельный файл справки, который открывается при нажатии клавиши F1 в окне дизайнера.

Основные элементы

Панели инструментов

Добавление объектов базы данных

Добавление компонентов отчета

Просмотр отчета

Создание диалоговой формы

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер создания отчетов

Просмотрщик отчетов


Основные элементы

Рабочая область Конструктора отчетов состоит из следующих элементов:

Строка главного меню

Report Tree

Вспомогательное окно по умолчанию расположено в левой верхней части окна программы. В нем, в виде дерева, отображается структура отчета.

Report Designer_Report Tree

Вкладки позволяют переключаться между разными частями отчета, такими как Код, Данные, Страницы и Диалоговые формы.

Code

На этой вкладке отображается можно работать со скриптом отчета.

Data

Отображается структура данных отчета.

Page

Печатная форма отчета.

Form

Диалоговая форма отчета.

Data Tree

Вспомогательное окно, по умолчанию расположенное в левой нижней части окна программы. В нем, в виде дерева, отображается структура данных, указанных в [image] ADOTable и [image] ADOQuery - столбцы таблиц и запросов.

Report Designer_Data Tree

Workspace - рабочая область.

Расположена в центральной части окна.

Object Inspector

Отображает свойства активного объекта. Свойства объекта в этом окне можно менять.

Расположен по умолчанию в правой части рабочего окна программы.

Report Designer_Object Inspector

Важно: Object Inspector можно открыть нажав клавишу F11.


Добавление объектов базы данных

Для начала работы с отчетом необходимо подключить источник данных - одну или несколько баз данных.

Report Designer - Adding database component

Подключиться к базе данных

  1. В Report tree перейти на вкладку Data.
  2. Выбрать объект [image] ADODatabase на боковой панели инструментов, расположенной слева от основного окна, и поместить его в рабочую область.
  3. В контекстном меню объекта ADODatabase выбрать пункт Edit.
  4. В открывшемся окне либо указать строку подключения, либо с помощью кнопки EllipsisButton вызвать стандартное окно Windows "Свойства связи с данными" и в нем задать необходимые параметры подключения. В качестве поставщика данных должен выступать SQL Native Client.
  5. В Object Inspector установить свойство Connection True.

Добавить таблицу в отчет

  1. В Report tree перейти на вкладку Data.
  2. Выбрать объект [image] ADOTable на боковой панели инструментов, расположенной слева от основного окна, и поместить его в рабочую область.
  3. В Object Inspector установить следующие свойства:
  • Database - выбрать один из определенных пользователем [image] ADODatabase.
  • TableName - выбрать одну из таблиц подключенной базы данных. Как только Вы выбрали таблицу, все столбцы её отображаются в Data Tree.

Добавить запрос в отчет

  1. В Report tree перейти на вкладку Data.
  2. Выбрать объект [image] ADOQuery на боковой панели инструментов, расположенной слева от основного окна, и поместить его в рабочую область.
  3. В Object Inspector установить следующие свойства:
  • Database - выбрать один из определенных пользователем [image] ADODatabase.
  • SQL - с помощью кнопки EllipsisButton вызвать окно редактора SQL, в котором задать текст запроса.


Добавление компонентов отчета

Для работы с макетом печатной формы отчета необходимо в Report Tree перейти на вкладку Page.

Report Designer - Adding bands

Для корректного отображения различных частей отчета, таких как данные, заголовки, колонтитулы в Report Designer используются Bands. Каждый тип Band может отображать определенные данные.

Вы можете автоматически создать отчет, в котором будут основные элементы.

Выберите в главном меню пункт File | New Report. или на панели инструментов нажмите кнопку [image] New Report. На печатную форму отчета будут помещены автоматически ReportTitle, MasterData и PageFooter.

Чтобы добавить Band на страницу необходимо:

  1. В Report tree перейти на вкладку Page1.
  2. На боковой панели инструментов нажать кнопку [image] Insert Band.
  3. Из появившегося раскрывающегося списка выбрать нужный Band.

Каждый добавленный Band появляется в Report Tree в виде узла.

Поля таблиц и отчетов необходимо добавлять в Band MasterData.

Заголовки столбцов - GroupHeader.

Заголовок отчета - ReportTitle.

Для правильного отображения данных используются различные типы Band-ов.

Данные таблиц и запросов отображаются в MasterData.

Чтобы добавить столбцы таблицы или запроса в отчет необходимо из DataTree перетащить нужные столбцы в Band MasterData.

Свойства каждого столбца можно задать в Object Inspector.


Просмотр отчета

Чтобы просмотреть и распечатать полученный отчет, нажмите кнопку Preview на панели инструментов.

Report Designer - Preview

Сохранить отчет в файл другого формата.

На панели инструментов просмотрщика выбрать пункт btnPreviewExport Export -> из раскрывшегося списка выбрать формат файла, в который будет произведен экспорт -> в появившемся окне выбрать директорию и указать имя файла.


Создание диалоговой формы

Чтобы добавить диалоговую форму, необходимо на панели инструментов нажать кнопку Add dialog form.

Report Designer - Adding dialog form

На форме можно размещать текстовые поля, кнопки, изображения, флажки, переключатели и т.д. Этим элементам можно назначать некоторые события.


Просмотрщик отчетов

С помощью этого инструмента Вы можете просматривать, редактировать, сохранять и распечатывать отчеты. Чтобы открыть отчет в просмотрщике достаточно два раза щелкнуть мышкой по отчету, содержащемуся в группе объектов Reports в проводнике баз данных.

Основные инструменты располагаются на панелях инструментов.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Мастер создания отчетов

Конструктор отчетов


Панели инструментов

Навигационная панель

Report Viewer - Using Navigation bar

Object

iconDB выбрать базу данных

выбрать отчет

General

iconRefresh обновить - Refresh

редактировать отчет в конструкторе отчетов - Edit report

iconSaveToFile сохранить отчет - Save report

iconSaveToFileAs сохранить отчет в файл - Save report as

iconPrint распечатать отчет - Print

iconRestoreDefaultSize восстановить исходный размер окна - Restore default size

Панель инструментов

Все инструменты навигационной панели доступны на панели инструментов. Панель инструментов - ToolBar - расположена в верхней части окна. Чтобы её активировать, необходимо на вкладке Windows в Environment Options выбрать RadioButton Toolbar или RadioButton Both.

RadioButton Toolbar выберите, если хотите, чтобы отображалась только панель инструментов, а RadioButton Both - если хотите, чтобы отображались обе панели.


Монитор SQL

SQL-монитор позволяет увидеть все запросы, отправленные SQL Manager for PostgreSQL на сервер, а также результаты их выполнения. Содержимое окна нельзя редактировать, но можно копировать в буфер обмена, сохранять в файл и распечатывать.

Чтобы открыть SQL монитор выберите в главном меню программы Tools | [image] SQL Monitor, или на основной панели инструментов нажмите кнопку [image] SQL Monitor, или в контекстном меню базы данных выберите пункт Tasks | [image] SQL Monitor.

Все инструменты для работы с SQL монитором располагаются на панелях инструментов и в контекстном меню.

Смотрите также:

Настройки SQL Монитор


Панели инструментов

На навигационной панели находятся следующие инструменты:

SQL Monitor - Using Navigation bar

General

Clear contents - очистить содержимое окна

Save to file - сохранить текст в файл

iconFindText Find - найти в тексте

iconOptions SQL Monitor option - настройка SQL монитора (эти же настройки есть и в Options | Environment Options | Tools | SQL Monitor)

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Работа с монитором SQL

SQL монитор позволяет увидеть все запросы, отправленные SQL Manager for PostgreSQL на сервер, а также результаты их выполнения. Содержимое окна нельзя редактировать, но можно копировать в буфер обмена, сохранять в файл и распечатывать.

Для каждой операции отображается следующая информация:

Executed - дата и время выполнения операции,

Operation - SQL оператор,

Result - результат выполнения.

SQL Monitor - Working with SQL Monitor

Контекстное меню

  • открыть подменю для работы с маркерами - Markers
  • установить закладку - Toggle Bookmarks
  • перейти к закладке (активна, если созданы закладки) - Goto Bookmarks
  • отменить действие- Undo
  • вернуть отмененное действие- Redo
  • копировать выделенное- Copy
  • выделить все - Select All
  • найти - Find
  • возобновить поиск - Search Again
  • поиск по названию ключевого поля - Incremental Search
  • перейти к строке под номером... - Go To Line By Number...
  • изменить регистр - Change Case
  • сохранить текст в файл - Save
  • предварительный просмотр - Preview
  • печатать - Print
  • сохранить как избранный запрос - Save as Favorite Query
  • просмотреть свойства - Properties


Поиск по метаданным

Инструмент Search in Metadata предназначен для поиска некоторого сочетания символов в метаданных объектов. Результаты поиска можно просматривать.

Чтобы открыть iconSearch in Metadata Search in Metadata выберите пункт Tools | Search in Metadata в главном меню программы или используйте сочетание клавиш Ctrl+Alt+F.

В открывшемся окне, в поле Text to search задайте искомое слово. Из раскрывающегося списка Database выберите базу данных, в которой будет производиться поиск.

Search in Metadata - Setting search conditions

Options

CheckBox Search in DDL

Включать в диапазон поиска описание объектов.

CheckBox Case sensitive

При поиске учитывать регистр.

CheckBox Whole words only

Учитывать слово целиком.

CheckBox Regular expressions

Если отмечена эта опция, то введенный текст будет распознаваться как регулярное выражение.

Например, если Вы введете "empl*", то будет произведен поиск по метаданным всех строк, содержащих подстроку "empl". При вводе "^emp" результатом поиска будут объекты, в метаданных которых есть строки, начинающиеся на "emp", а при поиске

"^emp|emp$" - строки, содержащие "emp" в начале или конце строки.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в поле Text to find, соответствует синтаксису регулярных выражений языка Perl. Более подробная информация может быть найдена по ссылке: http://perldoc.perl.org/perlre.html#Regular-Expressions.

Direction

Укажите направление поиска:

RadioButton Forward - вниз

RadioButton Backward - вверх.

CheckBox Display results in separate window

При включенной опции результаты для отображения результатов открывается новое окно.

Search in Metadata - Viewing search results

На навигационной панели, в разделе Explorer отображаются все объекты, в метаданных которых встречается искомое слово и словосочетание.

Метаданные объекта отображаются в SQL редакторе при нажатии на название объекта в разделе Explorer.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Управление объектами базы данных


Внешние инструменты

Вы можете добавить к SQL Manager for PostgreSQL неограниченное количество внешних программ, способствующих повышению эффективности Вашей работы с базами данных PostgreSQL.

Добавление внешнего инструмента

Чтобы добавить другую программу необходимо:

  • выбрать пункт Options | External Tools в главном меню программы,
  • в появившемся окне внешних инструментов нажать кнопку Add,
  • в диалоговом окне указать параметры подключения,
  • нажать OK, чтобы сохранить внесенные изменения.

Эта последовательность действий добавит указанную программу в список внешних инструментов

Теперь программу, добавленную в список, Вы можете запускать с помощью SQL Manager for PostgreSQL, выбирая её из меню Tools | External Tools..

Удаление внешнего инструмента

Чтобы удалить программу из списка внешних инструментов необходимо:

  • выбрать пункт Options | External Tools в главном меню программы,
  • в появившемся окне внешних инструментов выбрать нужную программу
  • нажать кнопку Delete.


Окно внешних инструментов

Это окно открывается при выборе пункта Options | External Tools в главном меню программы.

External tools - External Tools dialog

В окне Tools отображается список уже добавленных внешних инструментов.

С помощью кнопки Add можно добавить программу в список.

При нажатии кнопки Edit открывается окно редактирования внешних инструментов, с помощью которого можно изменить свойства подключенной программы.

Нажав на кнопку Delete, Вы удалите программу из списка.

Чтобы изменить порядок программ в списке воспользуйтесь кнопками [image] [image] или сочетанием клавиш Shift+Ctrl+Up / Shift+Ctrl+Down. Также можно менять объекты местами, перетаскивая их мышкой.


Редактирование внешних инструментов

С помощью окна Edit External Tool Info можно добавлять и редактировать внешние инструменты программы SQL Manager for PostgreSQL.

Это окно открывается при нажатии кнопок Add и Edit в окне внешних инструментов.

External tools - External Tool Info editor

В поле Title укажите имя, которое для этой программы будет отображаться в списке внешних инструментов.

В поле Hot Key можно задать сочетание клавиш, при нажатии которых будет открываться программа.

В поле Program введите путь к исполняемому (*.exe) файлу программы или воспользуйтесь стандартным диалоговым окном, открывающимся при нажатии на кнопку ExplorerButton.

Working Dir - в этом поле укажите рабочую директорию для этой программы.

Параметры выполнения программы указываются в поле Parameters.


Управление правами

Для обеспечения безопасности в SQL Manager for PostgreSQL предусмотрены инструменты, с помощью которых можно задать права доступа пользователей к данным и метаданным баз данных.

iconUserManager Управление пользователями (User manager) - инструмент для добавления, удаления регистрационных имен пользователей сервера, а также для установления и редактирования пользовательских привилегий.

iconGroupManager Управление группами (Group manager) - инструмент для создания и редактирования групп пользователей.

iconGrantManager Управление правами (Grant manager) - инструмент для управления правами пользователей на работу с объектами базы данных.

Глобальные привилегии пользователей определяют права пользователей на доступ ко всем объектам базы данных. Права назначаются на доступ пользователя к базе данных, таблицам базы данных. Привилегии на доступ к объектам базы данных дают пользователю возможность выполнять различные операции (создание, изменение, удаление) с базой данных, таблицами или столбцами.


Управление ролями/пользователями

Пользователь/роль базы данных (User/Role) - это главный элемент, обеспечивающий контроль доступа к элементам базы данных. В PostgreSQL роль и пользователь являются одним типом объекта. Отличия задаются при создании. Если в Редакторе ролей/пользователей на вкладке Свойства выбрана опция CheckBox Can login, то создаваемый объект является пользователем (user), в противном случае - ролью (role).

Важно: В версиях PostgreSQL до 8.1. пользователи и группы были отдельными записями, но теперь есть только роли. Любая роль может действовать как пользователь, как группа или как и то, и другое.

Чтобы открыть редактор пользователей / ролей в главном меню программы выберите пункт Tools | User Manager.

Создание пользователя

Чтобы добавить нового пользователя, необходимо выполнить следующую последовательность действий:

  1. выбрать пункт главного меню программы Tools | User Manager,
  2. нажать Add User на одной из панелей инструментов.

Созданный объект автоматически откроется в соответствующем редакторе.

Редактирование пользователя

Все изменения свойств этого объекта осуществляются в редакторе.

Чтобы открыть объект в редакторе нужно:

  1. нажать Edit User на одной из панелей инструментов User Manager (в редакторе откроется выделенный пользователь),
  2. в общем списке на нужном объекте два раза щелкнуть мышкой.

Переименование пользователя

Чтобы переименовать объект нужно выбрать пункт Rename user в контекстном меню нужного объекта.

Удаление пользователя

Чтобы удалить пользователя нужно:

  • выбрать команду Delete User на одной из панелей инструментов User Manager,
  • или выбрать пункт Delete User в контекстном меню выбранного объекта.

Панели инструментов

Администратор пользователей

Редактор ролей

Смотрите также:

Управление группами

Управление правами


Панели инструментов

Основные инструменты, позволяющие работать с пользователями, располагаются на панелях инструментов.

Навигационная панель

User Manager - Using Navigation bar

General

iconHost из раскрывающегося списка можно выбрать сервер. Если нет подключения к серверу, то нужно выбрать его из этого раскрывающегося списка и ввести имя и пароль в появившемся окне.

Actions

iconRefresh Refresh - обновить содержимое списка

iconAddUser Add user - создать нового пользователя

iconEditUser Edit user - редактировать выделенный объект в редакторе пользователей

iconDeleteUser Delete user - удалить пользователя

iconChangeOwner Change owner of objects - выбрать роль или пользователя, которой теперь буду принадлежать права на объекты, принадлежащие выбранной роли или пользователю

iconAddGroup Show/Hide groups - показать/скрыть группы пользователей

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.

Контекстное меню

Контекстное меню вызывается щелчком правой кнопкой мыши в списке пользователей.

iconRefresh Refresh - обновить содержимое списка

iconAddUser Add user - создать нового пользователя

iconEditUser Edit user - редактировать выделенный объект в редакторе пользователей

  • Rename User - переименовать пользователя

iconDeleteUser Delete user - удалить пользователя

iconChangeOwner Change owner of objects - выбрать роль или пользователя, которой теперь буду принадлежать права на объекты, принадлежащие выбранной роли или пользователю

iconAddGroup Show/Hide groups - показать/скрыть группы пользователей

  • Columns - выбрать отображаемые столбцы


Администратор пользователей

В этом списке отображаются все зарегистрированные в системе пользователи.

Для каждого пользователя отображается следующая информация: User Name, System ID, Can Login, Superuser, Can Create DB, Can Create Role, Inherit, Connection Limit, Valid Until, Modify Catalog, User Count, Group Count.

Управлять списком пользователей Вы можете с помощью инструментов, располагающихся на панелях инструментов.


Редактор ролей/пользователей

Редактор ролей позволяет задать свойства пользователя, группы, а также их принадлежность ролям.

Он открывается автоматически при создании или редактировании пользователя и группы

Если не установлен флажок Can Login на вкладке Properties, то роль автоматически становится пользователем.

Вкладки редактора:

  • Свойства
  • Участники роли
  • Определение принадлежности
  • Просмотр DDL


Свойства

На вкладке Properties задайте основные свойства пользователя/группы.

Role Editor - Editing properties

В поле Name указываете имя пользователя.

В поле Object ID отображается уникальный идентификатор объекта. Значение в этом поле нельзя изменить.

CheckBox Если выбрана опция Can login, то редактируемый/создаваемый объект является пользователем (user), в противном случае - ролью (role).

Далее, в полях Password и Confirm password задайте пароль и подтверждение пароля соответственно.

Также, Вы можете задать срок окончания действия прав пользователя, указав значение в поле и счетчике Valid until. Из раскрывающегося списка выберите дату, в счетчике укажите время окончания действия прав.

CheckBox Если установлен флажок Always, то время действия прав не ограничено

В поле Connection limit задайте максимальное число соединений. Значение -1 означает, что число соединений не ограничено.

CheckBox Inherits right from parent roles - наследовать права от родительской роли.

CheckBox Superuser - если флажок установлен, то новая роль является суперпользователем - пользователем не имеющим ограничений внутри базы.

CheckBox Can create database objects - обладает правами создавать объекты базы данных.

CheckBox Can create roles - может создавать роли.

CheckBox Is a replication role - обладает правами инициировать потоковую репликацию или запускать\выводить базу из режима создания резервной копии.

CheckBox Can modify catalog directly - если установлен этот флажок, то пользователь может изменять системные таблицы.

Важно: Эта опция доступна только если для роли указан привилегированный пользователь.


Участники роли

На вкладке Members указываются участники редактируемого пользователя/группы.

Role Editor - Selecting members

Из списка Available roles выберите доступные роли и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available перенесите их в список выбранных ролей - Selected roles, или перетащите мышкой из одного списка в другой.

CheckBox Если установлен флажок With admin option, то ролям назначаются права администратора.


Определение принадлежности

На вкладке Members of задайте роли, в которых участвует редактируемый объект.

Role Editor - Defining membership

Из списка Available roles выберите доступные роли и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available перенесите их в список выбранных ролей - Selected roles.

На вкладке DDL отображается SQL скрипт редактируемого объекта, который Вы можете сохранить в виде избранного запроса, сохранить в файл или копировать в буфер обмена, воспользовавшись контекстным меню.

Права пользователя на выполнение действий с отдельными объектами базы данных Вы можете задавать в редакторе прав.


Управление группами

С помощью Group Manager можно создавать и изменять группы, а также управлять членством пользователей в этих группах.

Чтобы открыть редактор групп в главном меню программы выберите пункт Tools | Group Manager.

Создание группы

Чтобы добавить новую группу, необходимо выполнить следующую последовательность действий:

  • выбрать пункт главного меню программы Tools | Group Manager,
  • нажать Add Group на одной из панелей инструментов.

Созданный объект автоматически откроется в соответствующем редакторе.

Редактирование группы

Все изменения свойств этого объекта осуществляются в редакторе групп.

Чтобы открыть объект в редакторе нужно:

  • нажать Edit Group на одной из панелей инструментов Group Manager (в редакторе откроется выделенная группа),
  • в общем списке на нужном объекте два раза щелкнуть мышкой.

Удаление группы

Чтобы удалить группу нужно:

  • выбрать команду Delete Group на одной из панелей инструментов Group Manager,
  • или выбрать пункт Delete Group в контекстном меню выбранного объекта.

Смотрите также:

Управление ролями/пользователями

Управление правами


Панели инструментов

Панели инструментов располагаются слева от редактора и над редактором.

Group Manager - Using Navigation bar

General

из раскрывающегося списка Вы можете выбрать сервер. Если Вы не подключены к серверу, то выберите его из этого раскрывающегося списка и введите имя и пароль в появившемся окне.

Actions

iconRefresh Refresh - обновить содержимое списка

iconAddGroup Add group - создать группу

iconEditGroup Edit group - редактировать выделенный объект в редакторе групп пользователей

iconDeleteGroup Delete group - удалить группу

iconChangeOwner Change owner of objects - изменить владельца объекта (для PostgreSQL 8.2 и выше)

iconAddGroup Show users - показать пользователей

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.

Контекстное меню

Контекстное меню вызывается щелчком правой кнопкой мыши в списке групп.

iconAddGroup Add group - создать группу

iconEditGroup Edit group - редактировать выделенный объект в редакторе ролей (для ролей и групп используется один редактор)

  • Rename Group - переименовать группу

iconDeleteGroup Delete group - удалить группу

iconAddGroup Show users - показать пользователей

  • Columns - выбрать отображаемые столбцы в общем списке


Администратор групп

В этом списке отображаются все зарегистрированные в системе группы пользователей.

Для каждой группы отображается следующая информация: Group, Object ID, Can Login, Superuser, Can Create DB, Can Create Role, Inherit, Connection Limit, Valid Until, Modify Catalog, User Count, Group Count.

Управлять списком групп Вы можете с помощью инструментов, располагающихся на панелях инструментов.

Свойства группы задаются в редакторе ролей. Чтобы создать группу в открывшемся редакторе ролей необходимо убрать флажок Can Login.


Управление правами

С помощью инструмента Grant Manager Вы можете предоставлять пользователям права доступа к защищенным объектам.

В PostgreSQL права задаются только на существующие объекты следующих типов: table (таблица), view (представление), sequence (последовательность), database (база данных), function (функция), procedural language (процедурный язык), schema (схема) и tablespace (табличное пространство). За исключение таблиц перед именами объектов обязательно указывается их тип. Ниже приведен список привилегий:

ALL PRIVILEGES - все привилегии на указанный объект;

CREATE - право на создание. Для базы данных это создание схем внутри ее. Для схем это создание новых объектов внутри ее. Для табличного пространства это создание таблиц, индексов и временных файлов внутри него;

REFERENCES - право на создание внешний ключей;

TRIGGER - право создания триггера на указанную таблицу;

CONNECT - право на соединение с указанной базой данных;

TEMPORARY, TEMP - право на создание временных таблиц;

EXECUTE - право на выполнение функций;

USAGE - право на использование указанного языка для написания функций. Для схемы это доступ к объектам внутри ее. Для последовательности это право использовать функции currval и nextval;

SELECT - право на выбор;

DELETE - право на удаление;

INSERT - право на вставку;

UPDATE - право на обновление.

Чтобы открыть Grant Manager выберите Tools | Grant Manager в главном меню программы.

Использование панелей инструментов и контекстного меню

Управление правами на объекты базы данных

Отбор объектов

Смотрите также:

Управление ролями/пользователями

Управление группами


Панели инструментов

Основные инструменты для работы с правами располагаются на панелях инструментов и в контекстном меню.

Навигационная панель

Grant Manager - Using Navigation bar

Host or Database

iconDB из раскрывающегося списка Вы можете выбрать сервер. Если Вы не подключены к серверу, то выберите его из этого раскрывающегося списка и введите имя и пароль в появившемся окне.

General

iconRefresh Refresh - обновить содержимое списка

iconAddUser Add user - создать нового пользователя

iconEditUser Edit user - редактировать выделенный объект в редакторе ролей (Role Editor)

iconDeleteUser Delete user - удалить пользователя

iconAddGroup Add group - создать группу

iconEditGroup Edit group - редактировать группу

iconDeleteGroup Delete group - удалить группу

iconExtractRolesGrant Extract role's grants - извлечь структуру выбранной роли в SQL скрипт

iconExtractAllRolesGrants Extract all roles' grants - извлечь структуру всех ролей в SQL скрипт

iconShowGroups / iconHideGroups Show/hide groups in the list - показать/скрыть группы в списке объектов

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

Privileges for

btnGroupManager Из списка User/Group можно выбрать пользователя или группу, для которых необходимо задать права.

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Управление правами на объекты базы данных

В главном окне расположена таблица, в которой строки - это объекты базы данных, а столбцы - действия, выполняемые над объектами.

Для задания прав на объекты базы данных необходимо выбрать сервер и базу данных с помощью инструментов, располагающихся на панелях инструментов.

Права на выполнение того или иного действия можно менять тремя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку.
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant -> Grant with Grant Option -> Revoke).
  • с помощью одинарного нажатия на активную (выделенную ячейку). При этом появляется раскрывающийся список, из которого можно выбрать один из типов прав.

Grant Manager - Managing database-specific privileges

Важно: При назначении прав с помощью Grant on all / Grant on All with Grant Option / Revoke on All права на базы данных не назначаются - их необходимо назначать отдельно.

Контекстное меню

Контекстное меню открывается при нажатии на ячейку области Grant Manager и позволяет присваивать права на действия над объектами.

Grant - предоставить права,

Revoke - отменить привилегии,

Grant with GRANT OPTION - предоставить с правами 'GRANT',

Grant All - предоставить права на все действия для выделенного объекта,

Revoke All - отменить привилегии для всех действий данного объекта,

Grant with GRANT OPTION All - предоставить с правами 'GRANT' на все действия для выделенного объекта,

Grant on All - предоставить права на это действие для всех объектов,

Revoke on All - отменить привилегии на это действие для всех объектов,

Grant with GRANT OPTION on All - предоставить с правами 'GRANT' на это действие для всех объектов,

  • Sort by Type, Name, Schema - сортировать объекты по типу, имени, названию схему,
  • Sort by Name, Schema - сортировать объекты по имени объекта, названию схемы,
  • Sort by Type, Schema, Name - сортировать объекты по типу, названию схемы, имени объекта,
  • Sort by Schema, Name - сортировать объекты по названию схемы, имени объекта.

Область Column permissions of role <role_name> on table/view <table_name> отображает столбцы таблицы или представления. С помощью контекстного меню можно для каждого столбца настроить привилегии выбранной роли.

Grant Manager - Managing column permissions


Отбор объектов

В больших базах данных со множеством объектов бывает трудно найти нужный объект.

Grant Manager - Filtering objects in list

Для этого в Grant Manager предусмотрены несколько инструментов, которые располагаются на панели над основной таблицей.

  • Из раскрывающегося списка All Objects можно выбрать один из типов объектов базы данных. С помощью этого списка Вы можете оставить в таблице только таблицы, или только представления и.т.д.
  • Специальный фильтр, который позволяет скрыть объекты, для которых не заданы права.

CheckBox Если установлен флажок Granted only, то видимыми останутся только те объекты базы данных, для которых заданы права.

  • Фильтр, который позволяет находить объект по первым буквам названия - это поле Filter.

Важно: Фильтр чувствителен к регистру текста.


Службы

SQL Manager for PostgreSQL предлагает удобные службы для работы с сервером баз данных.

Резервное копирование базы данных

Позволяет создавать резервные копии баз данных.

Восстановление базы данных

Позволяет восстанавливать и подготавливать к работе базу данных из резервной копии.

Анализ таблиц

Собирает информацию о содержимом таблиц базы данных.

Очистка таблиц

Удаляет устаревшие строки из файлов, в которых хранится таблица базы данных.

Переиндексация

Позволяет восстанавливать поврежденные индексы таблицы.

Мастер загрузки файлов

Позволяет загрузить файлы с сервера на клиентский компьютер и наоборот.

Управление экземплярами сервера

Позволяет проверять статус сервиса PostgreSQL сервера и запускать/останавливать сервис.

Статистика базы данных

С помощью этого инструмента Вы можете просмотреть статистику по работе с выбранной базой данных и деятельности сервера.

Мастер копирования баз данных

Позволяет скопировать любую информацию из одной базы данных в другую.

Мастер сравнения баз данных

С помощью мастера сравнения баз данных можно создать SQL скрипт для синхронизации структуры баз данных.

Статус сервера

Показывает текущую информацию о состоянии сервера

Просмотр журналов сервера

С помощью этого инструмента Вы можете просмотреть журналы PostgreSQL сервера

Конфигурация сервера

Позволяет посмотреть и изменить конфигурацию сервера

Расширения

С помощью этого инструмента можно управлять расширениями, которые представляют собой набор различных объектов.

Шаблоны

Упрощает работу с мастерами SQL Manager

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Инструменты для работы с базой данных

Службы

Настройки

Дополнительно

Как...


Резервное копирование базы данных

С помощью мастера резервного копирования Вы можете создавать резервные копии баз данных.

Чтобы запустить этот инструмент необходимо выбрать Services | [image] Backup Database в главном меню программы, или пункт Tasks | [image] Backup Database в контекстном меню базы данных.

Все инструменты мастера располагаются на следующих шагах:

Выбор сервера

Выбор серверных объектов

Задание параметров выходного файла

Выбор объектов

Выбор включаемых объектов

Выбор исключаемых объектов

Задание опций резервной копии

Задание дополнительных опций

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Восстановление базы данных

Мастер копирования баз данных

Использование шаблонов


Выбор сервера

На первом шаге необходимо выбрать сервер, на котором расположена база, резервную копию которой необходимо сделать.

Из раскрывающегося списка Host выберите сервер.

Имя пользователя и пароль укажите в поле User name и Password соответственно.

Backup Database - Selecting host

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор серверных объектов

Выберите версию сервера, для которого будет сгенерирован скрипт базы данных.

Backup Database - Specifying objects to backup

Server version отображает версию сервера, на котором расположена база данных для резервного копирования.

Из раскрывающегося списка Output script for server version выберите версию сервера, для которой будет сгенерирован скрипт резервной копии. Доступные версии: 9.3, 9.2, 9.1, 9.0, 8.4, 8.3, 8.2, 8.1, 8.0 or 7.4.

Backup target

Выберите базу данных для резервного копирования.

RadioButton Single database

Резервная копия будет создаваться для единственной базы данных. Выберите эту базу из раскрывающегося списка Source database.

RadioButton Entire database cluster

Резервная копия будет создана для всего кластера.

RadioButton Roles only

В резервную копию будут включены только роли.

RadioButton Tablespaces only

В резервную копию будут добавлены только табличные пространства базы данных.

RadioButton Both of roles and tablespaces

В резервную копию будут сохранены и роли и табличные пространства базы данных.

База выбирается из раскрывающегося списка Database, в котором содержатся все зарегистрированные и подключенные базы данных на выбранном сервере.

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание параметров выходного файла

На этом шаге задайте параметры выходного файла

Backup Database - Setting output format and file name

Output format

Выберите формат выходного файла.

RadioButton Plain-text SQL script - охранить резервную копию в текстовый файл скрипта с расширением *.sql.

RadioButton Custom pg_dump archive - создать резервную копию в виде pg_dump архива.

RadioButton Tar archive - сохранить резервную копию в Tar архив.

В поле Output file name, с помощью кнопки btnSaveAs, укажите путь к выходному файлу и его имя.

CheckBox Add date and time into file name

Отметьте данную опцию, чтобы добавить дату и время создания файла резервной копии к имени файла.

Из раскрывающегося списка File encoding выберите кодировку файла.

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор объектов

На этом шаге Вы можете указать, какие объекты базы данных будут сохранены в резервной копии.

Backup Database - Setting backup options for database objects

Objects to backup

Выберите объекты базы данных, резервную копию которых нужно сделать.

RadioButton All objects of the database - все объекты базы данных будут сохранены в резервной копии.

RadioButton Schema - из раскрывающегося списка можно будет выбрать схему, для которой будет создана резервная копия.

RadioButton Table - Вы можете создать резервную копию одной таблицы, выбрав этот пункт. Таблицу можно выбрать из раскрывающегося списка.

В резервной копии Вы можете сохранять базу данных полностью, а можете создать резервную копию отдельно для структуры базы или для данных.

RadioButton Backup both of structure and data - сохранять структуру и данные.

RadioButton Backup structure only - сохранять только структуру.

RadioButton Backup data only - сохранять только данные.

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор включаемых объектов

На этом шаге выберите объекты, которые будут сохранены в резервной копии.

Backup Database - Selecting objects to be included

Объекты, которые необходимо включить в резервную копию, выберите из списка Available Objects и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available переместите их в список выбранных - Selected Objects, или перетащите мышкой из одного списка в другой.

При необходимости, Вы можете указать маску включаемых объектов. Это значит, что все объекты, в названии которых содержится некоторое сочетание символов, будут включены в резервную копию.

Сочетание символов введите в окне, появляющемся при нажатии на кнопку Add Name Mask.

Backup Database - Selecting objects to be included - Mask

Следующий шаг


Выбор исключаемых объектов

На этом шаге выберите объекты, которые не будут сохранены в резервной копии.

Backup Database - Selecting objects to be excluded

Объекты, которые необходимо исключить из резервной копии, выберите из списка Available Objects и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available переместите их в список выбранных - Selected Objects, или перетащите мышкой из одного списка в другой.

При необходимости, Вы можете указать маску исключаемых объектов. Это значит, что все объекты, в названии которых содержится некоторое сочетание символов, не будут включены в резервную копию.

Сочетание символов введите в окне, появляющемся при нажатии на кнопку Add Name Mask.

Backup Database - Selecting objects to be excluded - Mask

Следующий шаг


Задание опций резервной копии

На этом шаге задайте дополнительные параметры резервной копии базы данных.

Backup Database - Setting additional backup options

Structure options

CheckBox Add create database command

Добавить в скрипт оператор CREATE DATABASE.

CheckBox Add drop object command

Добавить в создаваемый скрипт оператор для удаления объектов.

CheckBox Don't use $ quoting

Запретить использование символа $.

CheckBox No privileges

Не сохранять привилегии.

CheckBox Don't set object ownership

Не устанавливать права владельца на объекты.

CheckBox Use set session authorization

Использовать авторизацию текущей сессии.

Data options

RadioButton Data as COPY command

Использовать команду COPY для вставки данных.

RadioButton Data as INSERT command

Данные вставляются с помощью команды INSERT.

CheckBox Disable triggers

Отключать активные триггеры.

CheckBox Dump table OIDs

Сохранять в резервной копии уникальные идентификаторы объектов.

CheckBox INSERT with column names

Использовать команду INSERT для вставки данных.

CheckBox Don't add table access commands

Не выводить команды для выбора табличных методов доступа.

Advanced options

CheckBox Compress file

Сжимать выходной файл. С помощью ползунка Compress level задайте степень сжатия. 9 - максимальная степень сжатия.

CheckBox Dump BLOBs

Сохранять данные полей, имеющих BLOB-содержимое.

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание дополнительных опций

Этот шаг доступен только при создании резервной копии для сервера версии 8.4 и выше. Это задается на шаге Выбор серверных объектов в поле Output script for server version.

Backup Database - Setting backup creation options

Role to be used to create the dump

Из этого раскрывающегося списка выберите роль, которая будет использоваться для дампа базы данных.

Table lock timeout, milliseconds (0- unlimited wait)

В этом поле можно указать время для блокировки таблицы в миллисекундах. Значение по умолчанию "0", это означает, что время ожидания не ограничено.

Следующий шаг


Выполнение операции

О процессе выполнения операции сообщается на последнем шаге.

Чтобы начать выполнение операции, нажмите кнопку Run.

Backup Database - Running database backup

CheckBox Если установлен флажок Verbose mode, то будет показан подробный отчет об операции.

CheckBox Если установить флажок Close the Wizard after successful completion, то мастер закроется при нажатии кнопки Run в этом окне. Если же флажок не установлен, то можно изменить свойства мастера, не открывая его заново.

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Восстановление базы данных

Восстановление — это процесс восстановления базы данных из резервной копии.

С помощью этого мастера Вы можете восстановить и подготовить к работе базу данных из резервной копии.

Чтобы запустить этот инструмент, необходимо выбрать Services | Restore Database в главном меню программы, или пункт Tasks | Restore Database в контекстном меню базы данных.

Все инструменты мастера располагаются на следующих шагах:

Выбор сервера

Выбор файла резервной копии

Выбор типа восстановления

Задание параметров восстановления для объектов

Выбор восстанавливаемых объектов

Задание дополнительных параметров восстановления

Задание параметров процесса восстановления

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Резервное копирование базы данных

Использование шаблонов


Выбор сервера

На первом шаге выберите сервер, на котором Вы хотите восстановить базу данных.

Для передачи данных Вы не можете использовать SSH и HTTP соединения.

Restore Database - Selecting host

Из раскрывающегося списка Host выберите один из зарегистрированных серверов, на котором надо восстановить базу данных из резервной копии.

Имя пользователя и пароль укажите в поле User name и Password соответственно.

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор файла резервной копии

На этом шаге необходимо указать файл резервной копии из которого будет восстанавливаться база данных.

В поле Source dump file, с помощью кнопки ExplorerButton, задайте имя файла резервной копии и путь к нему.

Restore Database - Selecting source file for restoring

Следующий шаг

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Конвертация скрипта

В окне, которое появляется после выбора файла на втором шаге, Вы можете задать кодировку восстанавливаемой базы данных. Это окно появляется, если в качестве резервной копии для восстановления выбран текстовый файл скрипта (plain-text SQL script).

Restore Database - Selecting source file for restoring - Script conversion

RadioButton Windows default - кодировка Windows.

RadioButton Database default - кодировка восстанавливаемой базы данных. (В данном случае неактивна)

RadioButton Other encoding - другая кодировка.

При выборе пункта Other encoding Вы можете выбрать нужную кодировку из списка.

В области Preview отображается скрипт с указанной кодировкой. Если необходимо, Вы также можете использовать эту область для редактирования текста скрипта.


Выбор типа восстановления

На этом шаге задайте опции восстановления базы данных.

Restore Database - Selecting restore type - From SQL script

RadioButton Restore into existing database - восстановить базу из резервной копии поверх существующей базы данных. В этом случае, необходимо из раскрывающегося списка Database name выбрать одну из зарегистрированных баз данных.

RadioButton Вы можете восстановить базу данных из резервной копии в новую базу данных, выбрав Create a new database and restore into it.

Для новой базы данных укажите:

Database name - имя создаваемой базы данных.

Database template - из этого раскрывающегося списка Вы можете выбрать одну из баз сервера, которая будет использована в качестве шаблона при создании новой базы данных.

Database encoding - кодировка базы данных.

RadioButton Create the database that is specified in the dump and restore into it

Приложением будет создана база данных, указанная в скрипте дампа и резервная копия будет восстановлена в эту базу данных.

CheckBox Drop the database if it exists

Если этот флажок установлен, то существующая база, с таким же именем, будет удалена.

Connect to database

Из этого раскрывающегося списка выберите базу данных, которая будет использована в операторе \connect.

CheckBox Ignore any CREATE DATABASE and \connect statements - игнорировать все операторы CREATE DATABASE и \connect, прописанные в резервной копии.

CheckBox Stop if connecting to multiple databases - прервать операцию при подключении к нескольким базам данных.

Следующий шаг

Чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание параметров восстановления для объектов

На этом шаге задайте объекты для восстановления данных или структуры.

Важно: Этот шаг доступен только в том случае, если Вы восстанавливаете базу данных из архива pg_dump или tar archive.

Restore Database - Setting restore options for database objects

В разделе Objects to restore выберите объекты для восстановления.

RadioButton Restore all objects - восстанавливать все объекты.

RadioButton Restore specified objects - восстанавливать выбранные объекты

RadioButton Restore objects from list file - восстановить объекты, указанные в файле. Файл, в котором прописан список восстанавливаемых объектов, укажите в поле List file.

List file

В этом поле укажите имя и путь к файлу, содержащему список объектов для восстановления. Вы можете прописать путь вручную или указать его в стандартном диалоговом окне, открывающемся при нажатии кнопки ExplorerButton. Файл может находиться на вашем компьютере или в локальной сети.

С помощью кнопки Generate File Вы можете сгенерировать файл списка объектов, а с помощью кнопки Edit File отредактировать его.

В разделе Structure/data options выберите, необходимо ли восстанавливать структуру базы и/или данные.

RadioButton Restore both structure and data - восстанавливать и структуру и данные.

RadioButton Restore structure only - восстанавливать только структуру.

RadioButton Restore data only - восстанавливать только данные.

Следующий шаг


Выбор восстанавливаемых объектов

На этом шаге выберите объекты базы данных, которые хотите восстановить.

Важно: Этот шаг отображается, только если Вы восстанавливаете базу данных из архивов pg_dump или tar archive, и на предыдущем шаге, в разделе Objects to restore, выбрали Restore specified objects.

Restore Database - Selecting objects to restore

RadioButton Restore entire schemas - восстановить все объекты указанной схемы.

При выборе этой опции будут восстановлены все объекты схем, выбранных из списка Available Objects.

RadioButton Restore specified objects

Восстанавливать только выбранные объекты.

Если Вы выбрали эту опцию, то из раскрывающегося списка Object type выберите тип объектов.

Все доступные для восстановления объекты этого типа появятся в списке Available Objects.

С помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available перенесите объекты из списка доступных, в список выбранных - Selected Objects, или перетащите их мышкой.

При необходимости, Вы можете изменить порядок объектов в списке Selected Objects, используя кнопки [image] [image], или перетащите объекты мышкой.

Следующий шаг


Задание дополнительных параметров восстановления

На этом шаге задайте дополнительные параметры восстановления базы данных.

Важно: Доступен ли этот шаг, зависит от формата файла резервной копии и версии сервера PostgreSQL.

Restore Database - Setting restore options

Structure options

CheckBox No privileges

Если флажок установлен, то привилегии объектов базы данных будут недействительны при восстановлении.

CheckBox Don't set object ownership

Операторы принадлежности объектов будут блокированы во время выполнения операции.

CheckBox Use set session authorization statements

Если установлен этот флажок, то для аутентификации пользователя будут использованы настройки текущей сессии.

CheckBox Ignore settings tablespace commands

Если этот флажок установлен, то команды установки табличного пространства для объектов не выполняются. Это необходимо, потому что на сервере, куда восстанавливается база, могут быть другие табличные пространства.

CheckBox Use IF EXISTS clause

Добавлять условие IF EXISTS где применимо.

Data options

CheckBox No data for failed tables

Данные не будут восстанавливаться в поврежденных таблицах, если установлен этот флажок.

CheckBox Don't add table access commands

Не выводить команды для выбора табличных методов доступа. При восстановлении все объекты будут создаваться с табличным методом доступа, выбираемым по умолчанию.

Advanced options

CheckBox Stop restoring on error

Прекратить операцию при возникновении ошибки.

CheckBox Restore in single transaction

Проводить восстановление одной транзакцией.

Следующий шаг


Задание параметров процесса восстановления

Этот шаг доступен при восстановлении базы данных PostgreSQL 8.4 из файла *.tar или *.dmp.

Restore Database - Setting restore process options

Role to be used to perform the restore

Используйте этот параметр, чтобы определить роль, которая будет использовать для выполнения операции восстановления.

Number of jobs

Этот параметр указывает на количество потоков, используемых для операции восстановления.

Следующий шаг


Выполнение операции

О процессе выполнения операции сообщается на последнем шаге.

Чтобы начать выполнение операции, нажмите кнопку Run.

Restore Database - Running database restore

CheckBox Если установлен флажок Verbose mode, то будет показан подробный отчет об операции.

CheckBox Если установить флажок Close the Wizard after successful completion, то мастер закроется при нажатии кнопки Run в этом окне. Если же флажок не установлен, то можно изменить свойства мастера, не открывая его заново.

Для того, чтобы каждый раз при выполнении не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Анализ таблиц

Мастер анализа таблиц собирает информацию о содержимом таблиц базы данных и сохраняет результаты в системной таблице pg_statistic. Позднее эта статистика используется для построения более эффективного плана запроса.

Анализ таблиц можно осуществлять только на сервере версии 7.2 и выше.

Чтобы открыть мастер анализа таблиц нужно выбрать пункт Services | Analyze Tables в главном меню программы.

Выбор базы данных

Выбор таблиц

Выполнение операции

Использование шаблонов

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик. |

Смотрите также:

Очистка таблиц

Переиндексация

Статистика базы данных

Таблицы

Использование шаблонов


Выбор базы данных

Из списка Host выберите сервер версии 7.2 или выше.

Базу данных, расположенную на этом сервере выберите из раскрывающегося списка Database.

CheckBox Если установлен флажок Show detailed operation report (VERBOSE), будет показан подробный отчет об операциях.

Analyze Tables - Selecting database

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор таблиц

Таблицы, которые необходимо проанализировать выберите из списка Available и с помощью кнопок переместите их в список выбранных таблиц - Selected, или перетащите мышкой из одного списка в другой.

CheckBox Если установлен флажок All Tables то автоматически будут выбраны все таблицы

Analyze Tables - Selecting tables to be analyzed

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Analyze Tables - Analyzing tables

В текстовом поле отображается подробная информация о выполнении операции.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Очистка таблиц

Мастер очистки таблиц удаляет устаревшие строки из файлов, в которых хранится таблица базы данных. При выполнении обновлений PostgreSQL создает новые записи в файле и помечает все старые записи как устаревшие. Обновленные записи переписываются не сразу. Устаревшие строки могут быть полезными для пользователей, которые всё еще выполняют транзакцию, и для ее завершения должны видеть устаревшие данные.

Чтобы открыть Мастер очистки таблиц выберите пункт Services | Vacuum Tables в главном меню программы.

Выбор базы данных

Задание параметров очистки

Выбор таблиц

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Анализ таблиц

Переиндексация

Статистика базы данных

Таблицы

Использование шаблонов


Выбор базы данных

Из списка Host выберите сервер.

Базу данных, расположенную на этом сервере выберите из раскрывающегося списка Database.

Vacuum Tables - Selecting database

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание параметров очистки

Основные параметры производимой операции задайте на этом шаге.

Vacuum Tables - Setting vacuum parameters

Vacuum parameters

CheckBox Show detailed operation report (VERBOSE),

О произведенной операции будет выведен детальный отчет.

CheckBox Update optimization statistics (ANALYZE)

Статистика, требующаяся оптимизатору, будет обновляться для определения наилучшего способа выполнения запроса.

CheckBox Compact unused space (FULL)

Не используемое на диске место будет сжиматься.

CheckBox Freeze tuples (FREEZE)

Записи будут заморожены во время выполнения операции. Рекомендовано использовать для баз данных, доступных только для чтения.

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор таблиц

Таблицы, которые необходимо очистить, выберите из списка Available и с помощью кнопок переместите их в список выбранных таблиц - Selected, или перетащите мышкой из одного списка в другой.

CheckBox Если установлен флажок All Tables то автоматически будут выбраны все таблицы

Vacuum Tables - Selecting tables

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Vacuum Tables - Vacuuming tables

В текстовом поле отображается информация о проведении и результатах выполняемой операции.

CheckBox Close the Wizard after successful completion

При успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Переиндексация

Мастер переиндексации позволяет Вам восстанавливать поврежденные индексы таблицы.

Чтобы открыть мастер переиндексации таблицы необходимо в главном меню программы выбрать пункт Services | Reindex.

Выбор базы данных

Задание параметров переиндексации

Выбор объектов

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Анализ таблиц

Таблицы

Индексы

Использование шаблонов


Выбор базы данных

Из списка Host выберите сервер.

Базу данных, расположенную на этом сервере выберите из раскрывающегося списка Database.

Reindex - Selecting database

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Задание параметров переиндексации

На этом шаге выберите какие именно объекты базы данных следует переиндексировать.

Reindex

RadioButton Index - индекс

RadioButton Table - таблицу

RadioButton All system indices - все системные индексы

RadioButton All indices - все индексы

Reindex - Setting reindex options

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выбор объектов

Если на предыдущем шаге в качестве объектов для переиндексации Вы выбрали индекс, то на третьем шаге укажите нужный.

Reindex - Selecting objects to reindex

Из раскрывающегося списка выберите таблицу, которой принадлежит нужный индекс.

В списке Available Objects отображаются все индексы выбранной таблицы. Вы можете перенести их в список выбранных - Selected Objects - с помощью кнопок, или перетащите мышкой из одного списка в другой.

Если на предыдущем шаге в качестве объектов для переиндексации Вы выбрали таблицу, то на третьем шаге выберите нужную таблицу из списка Available Objects и, с помощью кнопок, перенесите её в список выбранных - Selected Objects.

Reindex - Selecting tables

Следующий шаг

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

Reindex - Reindexing objects

В текстовом поле отображается информация о проведении и результатах выполняемой операции.

CheckBox Если установлен флажок Close the Wizard after successful completion, то при успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.

Для того, чтобы каждый раз не задавать эти параметры, воспользуйтесь инструментом создания шаблонов.


Мастер загрузки файлов

Мастер загрузки данных позволяет загрузить файлы с сервера на клиентский компьютер и наоборот.

Чтобы открыть мастер в главном меню программы выберите пункт Services | Download Files.

Важно: PostgreSQL функции которые позволяют копировать файлы с/на сервер доступны начиная с версии 8.1 или на более ранних версиях с установленными для этого администраторскими функциями. Функции позволяют копировать только те данные,которые расположены в кластерной директории БД (или ее подпапках).

Выбор способа передачи

Настройки соединения

Выбор файлов

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Расширения

Использование шаблонов


Выбор способа передачи

На первом шаге необходимо выбрать один из методов загрузки.

Download File wizard - Selecting download method

Download method

RadioButton PostgreSQL server function - будет использованы функции PG сервера для передачи файлов.

RadioButton FTP - используется FTP протокол

RadioButton SFTP - SFTP протокол шифрования данных

Важно: Функции PostgreSQL сервера, которые позволяют копировать файлы с сервера и на сервер доступны, начиная с версии сервера 8.1. Для более ранних версий для этих операций необходимо установить администраторские функции.

Функции позволяют копировать только те данные, которые расположены в кластерной директории или ее подпапках.

Следующий шаг


Настройки соединения

Если на первом шаге Вы выбрали PostgreSQL server function, то на втором шаге нужно будет только выбрать один из серверов для передачи данных.

Download File wizard - Selecting database

Если на первом шаге Вы выбрали FTP или SFTP, то на этом шаге задайте параметры соединения.

Download File wizard - Connection setup

Host - имя сервера

Port - порт

User name - имя пользователя

Password - пароль

Проверить правильность указанных данных можно с помощью кнопки Test Connection, которая проверяет, есть ли в настоящий момент связь с указанным сервером.

Следующий шаг


Выбор файлов

На последнем шаге выберите нужные файлы.

Download File wizard - Specifying operation and selecting files

В разделе Select operation выберите тип операции:

RadioButton Load file from server - загрузить файл с сервера.

RadioButton Save file to server - сохранить файл на сервере.

В поле Source c помощью кнопки ExplorerButton, в появившемся диалоговом окне, выберите файл - источник данных.

Download File wizard - PostgreSQL server files

Назначенный файл укажите в поле Destination, с помощью кнопки btnSaveAs.

CheckBox Если установите флажок Rewrite existing file, то назначенный файл при совпадении имен будет перезаписан.

CheckBox Если установлен флажок Do not close wizard after copying, то после завершения процедуры мастер не будет закрыт, и Вы сможете указать другие параметры загрузки файлов.

Для завершения операции нажмите кнопку Finish.


Статистика базы данных

С помощью инструмента Database Statistics Вы можете просмотреть статистику по работе с выбранной базой данных и деятельности сервера.

С его помощью Вы можете отслеживать осуществленный доступ к таблицам и индексам.

Чтобы открыть статистику Базы данных выберите в главном меню программы пункт Services | Database Statistics.

Статистическая информация помещена на несколько вкладок:

Статистика объекта

Статистика столбца

Статистика базы данных

Управление статистикой осуществляется с помощью кнопок, расположенных на панелях инструментов.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Анализ таблиц

Переиндексация


Панели инструментов

Основные операции для работы со статистикой вынесены на панели инструментов.

Панель навигации

Панель навигации располагается слева от основного окна. С ее помощью можно:

Database Statistics - Using Navigation bar

Database

iconDB Выбрать из раскрывающегося списка базу данных

General

iconRefresh Refresh - обновить статистику

iconPrint Print - печатать данные статистики

iconSaveToFile Save statistics - сохранить статистику в файл формата *.dbs или в файлы базы данных (при этом откроется окно выбора файлов)

iconLoadFromFile Load statistics - загрузить статистику из файла формата *.dbs или из файла базы данных (при этом откроется окно выбора файлов)

Compare statistics - сравнить статистику с сохраненной статистикой (при этом откроется окно выбора файлов)

iconProperties Statistics collector options - задание опций инструмента для сбора статистических данных

Reset statistics - обнулить статистику

Object Group (для вкладки Object Statistics)

  • выбрать тип объектов для просмотра статистики
  • выбрать тип статистики
  • выбрать пользовательские или системные объекты для просмотра статистики

Панель Diagram Options активна только при просмотре статистики объектов на вкладке Object Statistics в виде диаграммы на вкладке Diagram View.

  • задать число объектов, отображаемых на диаграмме - Object count
  • из раскрывающегося списка выберите информацию об объектах, которая будет отображаться на диаграмме

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Просмотр в виде диаграммы

Diagram View

Помимо табличного просмотра для статистики объектов базы данных существует ещё и такой вид просмотра как диаграмма.

Переключиться в режим диаграммы можно с помощью кнопки Diagram View, расположенной в нижней части окна просмотра статистики.

Диаграмма строится для каждого типа объектов отдельно.

Database Statistics - Diagram view

По оси X отображаются объекты.

По оси Y - количество строк в объекте.

Красным цветом выделены - строк прочитанные последовательно,

Синим цветом на диаграмме показаны - строки, прочитанные индексно.

Управлять диаграммой можно с помощью кнопок, расположенных на панелях инструментов.


Сохранить/загрузить статистику

Выбор файла

При сохранении, загрузке и сравнении статистики открывается окно выбора файла.

Database Statistics - Loading statistics

RadioButton Если установлен File, то статистика сохраняется/загружается из файла. В этом случае, необходимо будет указать имя и путь к файлу в поле File name.

RadioButton Если установлен Memory, то статистика хранится на сервере. Для того чтобы сохранить статистику в поле Statistics name необходимо указать имя, под которым хотите сохранить данные на сервере.

При загрузке необходимо будет выбрать нужный файл из раскрывающегося списка Statistics name.


Параметры статистики

При нажатии кнопки Statistics collector options на одной из панелей инструментов откроется окно Statistics Option.

Database Statistics - Statistics Collector options

В этом окне можно задавать параметры отображения статистики.


Статистика объекта

На этой вкладке отображается статистика по каждой таблице базы данных.

Database Statistics - Browsing Object Statistics

На этой вкладке отображается следующая информация по объектам:

Если тип объекта выбран Таблицы, то отображается следующая статистическая информация.

Schema - схема.

Table - таблица.

OID - уникальный идентификатор объекта.

Sequential Scans - логические считывания (это поле попадает в тип статистики Query statistics).

Row Reads by Sequential Scans - чтение строк по последовательному считыванию (это поле попадает в тип статистики Query statitics).

Index Scans - индексные считывания (это поле попадает в тип статистики Query statitics).

Row Fetched by Index Scans - столбцы, выбранные индексными чтениями (это поле попадает в тип статистики Query statitics).

Rows Inserted - количество вставленных строк (это поле попадает в тип статистики Data change statitics).

Rows Updated - количество обновленных строк (это поле попадает в тип статистики Data change statitics).

Rows Deleted - количество удаленных строк (это поле попадает в тип статистики Data change statitics).

Block Reads from Disk - блочные считывания с диска (это поле попадает в тип статистики Cache statitics).

Block Reads from Cache - блочные считывания из кэша (это поле попадает в тип статистики Cache statitics).

Index Block Reads from Disk - индексные блочные считывания с диска (это поле попадает в тип статистики Cache statitics).

Index Block Reads from Cache - индексные блочные считывания из кэша (это поле попадает в тип статистики Cache statitics).

Toast Block Reads from Disk - блочные чтения блобов с диска (это поле попадает в тип статистики Cache statitics).

Toast Block Reads from Cache - блочные чтения блобов из кэша (это поле попадает в тип статистики Cache statitics).

Toast Index Block Reads from Disk - блочные индексные чтения блобов с диска (это поле попадает в тип статистики Cache statitics).

Toast Index Block Reads from Cache - блочные индексные чтения блобов из кэша (это поле попадает в тип статистики Cache statitics).

Если тип объекта выбран Индексы, то отображается следующая статистическая информация.

Schema - схема.

Table - таблица.

Index - индекс.

OID - уникальный идентификатор объекта.

Sequential Scans - логические считывания.

Row Reads by Sequential Scans - чтение строк по последовательному считыванию.

Index Scans - индексные считывания (это поле попадает в тип статистики Query statitics).

Index Tuple Reads - индексные кортежные считывания (это поле попадает в тип статистики Query statitics).

Index Tuple Fetches - кортежные индексные чтения (это поле попадает в тип статистики Query statitics).

Index Block Reads from Disk - индексные блочные считывания с диска (это поле попадает в тип статистики Cache statitics).

Index Block Reads from Cache - индексные блочные считывания из кэша (это поле попадает в тип статистики Cache statitics).

Если тип объекта выбран Последовательности, то отображается следующая статистическая информация.

Schema - схема.

Sequence - последовательности.

OID - уникальный идентификатор объекта.

Block Reads from Disk - блочные считывания с диска.

Block Reads from Cache - блочные считывания из кэша.


Статистика столбца

На вкладке Columns Statistics Вы можете просмотреть следующую статистическую информацию по каждому столбцу.

Database Statistics - Browsing Field Statistics

Schema - схема.

Table - таблица.

Column - столбец.

Null Fraction - нулевая мантисса.

Average/Width - средняя ширина.

Distinct - количество разных значений в этом столбце.

Correlation - соотношение.

Most Common Values - наиболее распространенные значения.

Most Common Freq. - наиболее распространенные последовательности.

Histogram Bounds - границы гистограммы.


Статистика базы данных

Статистика по базам данных отображается на вкладке Database Statistics.

Database Statistics - Browsing Database Statistics

Статистика по базам данных содержит следующую информацию.

  • OID - уникальный идентификатор объекта.
  • Database - база данных.
  • Number of Active Server Processes - количество активных процессов сервера.
  • Commited Transaction - количество зафиксированных транзакций.
  • Rolled Back Transaction - количество откаченных транзакций.
  • Total Disk Block Reads - общее число блочных чтений с диска.
  • Total Number of Buffer Hits - общее число обращения к буферу.


Мастер копирования баз данных

С помощью мастера копирования данных Вы можете скопировать любую информацию из базы данных в другую базу. Копируемой информацией могут быть как данные, так и структура базы данных.

Чтобы запустить Мастер копирования баз данных, выберите пункт Tools | Copy Database в главном меню программы.

Мастер состоит из следующих шагов:

  • Выбор исходной базы данных
  • Задание назначенной базы данных
  • Выбор типа копируемых объектов
  • Выбор объектов для копирования структуры
  • Выбор объектов из которых будут скопированы данные
  • Задание дополнительных опций
  • Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Выбор исходной базы данных

На первом шаге выберите базу данных, которую необходимо скопировать.

Из раскрывающегося списка Source database выберите нужную базу данных.

Destination database

Выберите тип базы данных, в которую хотите копировать информацию.

RadioButton Registered database - зарегистрированная база данных.

RadioButton Non-registered database - незарегистрированная база данных.

Если Вы укажете что база, в которую Вы хотите копировать информация уже зарегистрирована, то на втором шаге нужно будет только выбрать её из предоставленного списка

Если назначенная база не является зарегистрированной, то на втором шаге Вы сможете указать параметры подключения к ней.

Copy Database Wizard - Selecting source database

Важно: Чтобы избежать ошибок при копировании, удостоверьтесь что версии серверов совместимы.

Следующий шаг


Задание назначенной базы данных

Если на первом шаге Вы указали, что назначенная база данных зарегистрирована, то на втором шаге Вам нужно будет выбрать из списка Database одну из зарегистрированных баз данных. Сервер можно выбрать из раскрывающегося списка Host.

Copy Database Wizard - Specifying destination database

Если база, в которую Вы хотите копировать информацию не является зарегистрированной, то на втором шаге Вы должны указать параметры регистрации хоста и базы данных.

Из раскрывающегося списка Host name выбираете сервер (хост), к которому хотите подключиться. В этот список попадают имена уже зарегистрированных серверов.

В поле Port задайте порт для подключения. Укажите имя пользователя и пароль в полях User name и Password.

Базу данных, расположенную на указанном сервере, выберите из списка Database.

CheckBox Также Вы можете создать новую базу, установив флажок Create new database.

Если хотите автоматически зарегистрировать базу сразу после создания, то установите флажок Register destination database after execution. В этом случае после завершения создания базы откроется окно Database Registration Info.

Следующий шаг


Выбор типа копируемых объектов

На третьем шаге Вы выбираете, какую информацию базы данных хотите скопировать.

Copy Database Wizard - Selecting components to copy

RadioButton Copy both of structure and data - если установлен этот переключатель, то будут скопированы и данные и сама структура базы данных со всеми объектами.

RadioButton Copy structure only - если хотите копировать только структуру базы, то установите этот переключатель.

RadioButton Copy data only - в назначенную базу данных будут скопированы только данные, если установлен этот переключатель.

Следующий шаг


Выбор объектов для копирования структуры

Этот шаг будет активен только в том случае, если Вы копируете структуру базы данных.

Copy Database Wizard - Selecting objects to copy their structure

Вы можете выбрать объекты, структуру которых следует скопировать.

RadioButton Установленный Copy all objects указывает на то, что будет скопирована структура всех без исключения объектов.

RadioButton Если переключатель установлен в Copy all objects of schema, то копироваться будут объекты схемы, указанной в списке Schema name.

RadioButton Если выбрать Copy selected objects, то можно будет выбрать копируемые объекты.

Из раскрывающегося списка Objects to copy выбираете тип объекта (таблица, представление и т.д.). После выбора типа в списке Available появляются все объекты базы данных, соответствующие выбранному типу. С помощью кнопок переместите объекты из списка доступных - Available в список выбранных - Selected, или перетащите мышкой из одного списка в другой.

Следующий шаг


Выбор объектов, из которых будут скопированы данные

На этом шаге Вы можете выбрать те таблицы, из которых необходимо копировать данные.

Copy Database Wizard - Selecting objects to copy their data

RadioButton Если выберите Copy data of all tables, то данные будут скопированы из всех таблиц базы.

RadioButton Пункт переключателя Copy data of tables selected on previous step указывает на то, что данные будут копироваться только из тех таблиц, которые были выбраны на предыдущем шаге.

RadioButton Если выбран пункт Copy data of the selected tables, то Вы сможете выбрать таблицы из списка доступных - Available, и с помощью кнопок переместить их в список выбранных - Selected, или перетащите мышкой из одного списка в другой.

Следующий шаг


Задание дополнительных опций

На этом шаге укажите общие настройки копирования.

Copy Database Wizard - Setting additional options

Copying options

CheckBox Если хотите, чтобы выполнение операции при возникновении ошибки прекратилось, то установите флажок Abort copying on error.

CheckBox Если установлен флажок Rollback on abort, то при ошибке программа откатит уже выполненные команды.

CheckBox Чтобы скопировать уникальный идентификатор объекта (только для серверов версии 8.1 и выше), то установите флажок Copy OID (8.1 or higher).

Data options

Транзакция будет фиксироваться после копирования каждого блока. В поле Record in a block укажите количество.

CheckBox Можно фиксировать транзакцию после копирования каждого блока данных, установив флажок Commit each data block.

Следующий шаг


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Copy Database Wizard - Copying database

В текстовом поле отображаются все производимые действия и результат их выполнения.

CheckBox Close the Wizard after successful completion

При успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Мастер сравнения баз данных

С помощью мастера сравнения баз данных Можно создать SQL-скрипт для синхронизации структуры баз данных.

Чтобы запустить Мастер сравнения баз данных, выберите пункт Tools | iconCompare Compare Database в главном меню программы.

Мастер состоит из следующих шагов:

Выбор исходной базы данных

Выбор назначенной базы данных

Выбор типа скрипта синхронизации

Задание параметров скрипта

Выполнение операции

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Резервное копирование базы данных

Восстановление базы данных

Мастер копирования баз данных

Использование шаблонов


Выбор исходной базы данных

На этом шаге необходимо указать исходную базу данных для сравнения

Database Comparer Wizard - Select the source database

Source host

Из этого раскрывающегося списка нужно выбрать сервер, на котором расположена исходная база данных.

Source database

Из списка зарегистрированных баз данных на выбранном сервере нужно выбрать исходную базу данных.

Следующий шаг

Шаблоны


Выбор назначенной базы данных

На этом шаге необходимо указать вторую базу данных для сравнения.

Database Comparer Wizard - Specify the target database

Target host

Сервер, на котором расположена назначенная база данных.

Target database

Назначенная для сравнения база данных выбирается из этого раскрывающегося списка.

Следующий шаг

Шаблоны


Выбор типа скрипта синхронизации

На этом шаге необходимо выбрать, в каком направлении будет производиться сравнение баз данных.

Database Comparer Wizard - Select the type of synchronization script

RadioButton Target database into source database

Скрипт, приводящий назначенную базу данных базу в соответствие с исходной.

RadioButton Source database into target database.

Скрипт, приводящий исходную базу (задается на шаге 1) в соответствие с назначенной (задается на шаге 2).

Следующий шаг

Шаблоны


Задание параметров скрипта

На этом шаге задаются дополнительные параметры генерируемого скрипта.

Database Comparer Wizard - Select additional options

Script destination

RadioButton Automatically load to Script Editor

Автоматически открывать созданный скрипт в Редакторе выполнения скриптов.

RadioButton Save to file

Сохранять созданный скрипт в файл.

File name

Укажите имя файла, в который нужно сохранить скрипт. Файл можно выбрать в стандартном диалоговом окне, открывающемся при нажатии кнопки btnSaveAs.

File charset

Выберите кодировку скрипта из раскрывающегося списка.

Следующий шаг

Шаблоны


Выполнение операции

После того, как на предыдущих шагах Вы задали все необходимые опции, нажмите кнопку Run, для начала выполнения операции.

В строке состояния, расположенной в верхней части, в процентах отображается ход выполнения операции.

Compare Database Wizard - Comparing database

В текстовом поле показаны все производимые действия и результат их выполнения.

CheckBox Close the Wizard after successful completion

При успешном выполнении операции мастер автоматически будет закрыт. Если флажок не установлен, то после выполнения, Вы можете вернуться и задать другие параметры операции.


Статус сервера

С помощью инструмента Server Status Вы можете получить всю информацию о текущих соединениях сервера PostgreSQL, блокировках, выполненных транзакциях, а также просмотреть файлы журналов сервера.

Чтобы открыть просмотр статуса необходимо в главном меню программы выбрать пункт Services | Server Status.

С таблицей Вы можете работать как со стандартной сеткой данных.

Важно: Этот инструмент доступен для серверов версии 7.4 и выше.

Просмотр соединений

Блокировки

Управление подготовленными транзакциями

Просмотр файлов-журналов

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Просмотр соединений

На вкладке Connections отображаются текущие соединения с базами данных.

Server Status - Viewing Connections

Для каждого процесса отображается:

  • Database - база данных
  • User - пользователь
  • Client Address - адрес клиента
  • Application Name - имя приложения
  • Query Start - начало запроса
  • Query - запрос
  • Process start - время начала процесса

Работать с таблицей можно так же, как с сеткой просмотрщика данных.


Блокировки

На вкладке Locks показаны текущие блокировки на объекты для которых в данный момент выполняется транзакция.

Server Status - Viewing Locks

Для каждого заблокированного объекта указано:

  • Database - база данных
  • Relation - отношение
  • User - пользователь
  • Transaction - транзакция
  • Access Mode - режим доступа
  • Granted - права предоставлены
  • Query Start - начало запроса
  • Query - запрос

С помощью контекстного меню, открывающегося при нажатии правой кнопкой мыши на таблицу, Вы можете:

  • обновить список - Refresh,
  • прекратить выполнение - Cancel Execution.

Работать с таблицей можно так же, как с сеткой просмотрщика данных.


Управление подготовленными транзакциями

На вкладке Prepared Transactions отображаются подготовленные транзакции, то есть те, фиксирование которых разделено на два этапа. Если фиксация проходит в два этапа, то транзакция не принадлежит текущей сессии сервера. Информация о состоянии транзакции хранится на сервере.

Server Status - Managing Prepared Transactions

О подготовленной транзакции на этой вкладке содержится следующая информация:

Transaction - транзакция

Global ID - глобальный идентификатор

Prepare Time - время подготовки

Owner - владелец

Database - база данных

Работать с таблицей можно так же, как с сеткой просмотрщика данных.


Просмотр журналов

На этой вкладке Вы можете просмотреть журнал событий сервера.

Server Status - Viewing Logfile

Для каждого события отображается следующая информация:

  • Time - время
  • Level - уровень
  • Entry - вхождение

При необходимости, Вы можете изменить параметры журналирования. Используйте для этого кнопку Log Options, находящуюся на одной из панелей инструментов.

Server Status - Viewing Logfile - Log options

CheckBox Enable parameter

Установите флажок Enable parameter, чтобы применить параметры.

В разделе Select which SQL statements are logged выберите какие SQL операторы будут отображаться в журнале.

RadioButton none - никакие.

RadioButton DDL (logs all data definition command) - фиксировать в журнале все DDL команды.

RadioButton mod (all DDL plus DML: INSERT, UPDATE, DELETE, etc.) - все DDL и DML команды.

RadioButton all - все.


Журнал сервера

С помощью журнала сервера (Server Log SQL Parser) пользователь может просмотреть все действия, выполнявшиеся на сервере в течение сеанса.

Чтобы открыть Log SQL Parser необходимо выбрать Services | Server Log SQL Parser в главном меню программы.

Панели инструментов

Работа с Server Log SQL Parser

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.

Смотрите также:

Статус сервера

Конфигурация сервера


Панели инструментов

Основные операции для работы журналом вынесены на панели инструментов.

Панель навигации

Панель навигации располагается слева от основного окна.

Server Log SQL Parser - Using Navigation bar

General

iconLoadFromFile Open server log file - открыть файл журнала на сервере

iconLoadLogFileFromServer Load log file from server - загрузить файл журнала с сервера

Open in Query data - открыть запрос в Редакторе запросов

Open in Design Query - открыть запрос в Визуальном конструкторе запросов

iconCopyToClipboard Copy to clipboard - копировать запрос в буфер обмена

iconRestoreDefaultSize Restore default size - восстановить исходный размер окна

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Работа с Server Log SQL Parser

С помощью Server Log SQL Parser пользователь может просмотреть все действия, выполнявшиеся на сервере в течение сеанса.

Server Log SQL Parser - Working with Server Log SQL Parser

В Server Log SQL Parser могут быть загружены только журналы сервера, содержащие SQL выражения. Для этого необходимо в конфигурационном файле сервера PostgreSQL задать следующие параметры:

  • log_statement = 'all'
  • logging_collector = on
  • log_min_duration_statement = 0

Работать с таблицей можно также как с просмотрщиком данных.

Группировка и фильтрация данных осуществляется на вкладке Grouped.

В главной таблице отображается основная информация о выполненных запросах:

Duration - длительность операции

Time - время, в которое операция была выполнена

Statement - оператор

Error - ошибка

Warning - предупреждение

Нажатие правой кнопкой мыши на таблице вызывает контекстное меню.

С помощью этого меню Вы можете:

  • Open in Query data - открыть запрос в Редакторе запросов.
  • Copy to clipboard - копировать запрос в буфер обмена.

Панели инструментов


Конфигурация сервера

SQL Manager for PostgreSQL предлагает удобный инструмент для просмотра и изменения конфигурации сервера.

Чтобы открыть Server Configuration выберите пункт Services | Server Configuration в главном меню программы.

С таблицей Вы можете работать как со стандартной сеткой данных.

Основные инструменты, позволяющие просмотреть конфигурацию сервера располагаются на вкладках:

Просмотр параметров

Изменение параметров роли

Конфигурационный файл

Изменение аутентификационного файла

Изменение идентификационного файла

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Просмотр параметров

Эта вкладка позволяет Вам увидеть список параметров PostgreSQL сервера. Эти параметры позволяют управлять поведением сервера.

Server Configuration - Viewing Parameters

Для каждого указанного параметра отображается следующая информация:

  • Parameter Group - группа параметров
  • Parameter Name - имя параметра
  • Value - значение
  • Short Description - краткое описание параметра
  • Extra Description - расширенное описание параметра
  • Context - содержание
  • Type - тип
  • Source - источник
  • Minimum - минимум
  • Maximum - максимум


Изменение параметров роли

На этой вкладке Вы можете применить параметры сервера к роли.

Server Configuration - Modifying Role Settings

Для параметров указаны следующие характеристики:

  • Parameter Name - имя параметра,
  • Role Setting - значение параметра для роли.

Для работы с параметрами роли предназначается контекстное меню, которое открывается при нажатии правой кнопкой мыши на рабочей области.

С помощью контекстного меню Вы можете:

  • обновить список параметров - Refresh,
  • добавить параметр - Add Parameter,
  • редактировать параметр - Edit Parameter,
  • удалить параметр - Delete Parameter,
  • копировать из - Copy From (при этом откроется список существующих в системе пользователей и групп),
  • удалить все параметры - Delete All Parameters,
  • сохранить изменения - Save Settings.

Для редактирования параметра существует специальная форма, которая открывается при создании или редактировании.

Server Configuration - Edit Role Parameter

Из раскрывающегося списка Parameter name выберите один из параметров.

В поле Value задайте значение параметра. В разделе Parameter Info отображается информация о выбранном параметре.

Чтобы получить подробную информацию о параметрах сервера, обратитесь к документации PostgreSQL.


Конфигурационный файл

На вкладке Configuration File Вы можете просмотреть информацию о файлах в которых хранятся параметры конфигурации.

Server Configuration - Setting up Configuration Files

Для файла параметра отображается:

Enabled - если флажок установлен, то параметр включен

Parameter Name - имя параметра

Parameter Setting - настройки параметра

Current Setting - текущие настройки


Изменение аутентификационного файла

На вкладке Host-Based Authentication задайте параметры файла аутентификации.

Настройки системы аутентификации хранятся в системном файле pg_hba.conf. Файл pg_hba.conf выполняется при каждой попытке пользователя подключиться к базе данных.

Server Configuration - Changing HBA File

Каждая строка это соединение. Соединение Вы можете добавить с помощью пункта контекстного меню Add Connection.

Для каждого соединения отображаются следующие свойства:

Enabled - активно

Delete - удалить

Type - тип

Database - базы данных на которые пользователь имеет права

User - пользователь, имеющий права на выбранную базу данных

Address - адрес

Crypt Method - метод шифрования

Option - опция

При создании и редактировании соединения открывается диалоговое окно, в котором нужно указать все параметры:

Server Configuration - Changing HBA File - Edit client authentication

Тип записей выберите из раскрывающегося списка Type.

В разделе Database выберите базу данных.

RadioButton From list - выберите базу данных из списка

RadioButton All - все базы данных

RadioButton SameRole - базы данных, на которые имеет права данный пользователь

RadioButton SameGroup - базы данных, на которые имеют право пользователи выбранной группы

RadioButton From file - из файла, указанного в поле

Пользователя укажите в разделе User.

RadioButton From List - Можно выбрать пользователей из списка Roles.

RadioButton Выбрав All, Вы выберете всех пользователей.

RadioButton From file - из файла, указанного в поле.

Address - адрес,

Method - метод аутентификации пользователей

Option - в этом поле укажите специфические опции для некоторых методов аутентификации


Изменение идентификационного файла

При аутентификации типа Ident сервер базы данных запрашивает клиентскую систему о том, кто желает подключиться к серверу. Затем, PostgreSQL сервер решает, разрешено ли пользователю установить связь. Аутентификации типа Ident можно реализовать только в сетях TCP/IP. Рекомендуется применять только в надежно защищенных локальных сетях.

На этой вкладке можно редактировать параметры идентификационного файла. Отображения в этом файле определяют имена пользователей и ролей.

Server Configuration - Changing Ident File

  • Enabled - активно
  • Delete - удалить
  • Map name - имя отображения
  • Ident Name (OS user) - идентификатор
  • Role File - имя роли

Управлять отображениями можно с помощью контекстного меню, которое открывается при нажатии правой кнопкой мыши на списке отображений, или с помощью панелей инструментов.

Контекстное меню

  • Обновить содержимое списка отображений - Refresh.
  • Добавить отображение - Add Map.
  • Редактировать отображение - Edit Map.
  • сохранить изменения - Save Settings.

Удалить отображение можно, нажав клавишу Delete.


Управление экземплярами сервера

Позволяет проверять статус сервиса PostgreSQL сервера и запускать/останавливать сервис. Чтобы открыть окно просмотра, выберите в главном меню программы пункт Services | Instance Manager.

Управлять экземпляром сервера можно с помощью инструментов, находящихся на панелях инструментов.

На одной из панелей инструментов выберите нужный локальный сервер.

В разделе Server Status отображен его текущий статус.

С помощью кнопки Stop/Run Service можно остановить или запустить сервер.

В текстовом поле Log Messages отображаются сообщения о процессе выполнения запуска и остановки сервиса.

Доступность:
Full version (for Windows) | Да
Lite version (for Windows) | Нет
Важно: Посмотреть наличие функций в версиях SQL Manager Full и Lite вы можете в сравнительной таблице характеристик.


Панели инструментов

Основные операции для работы со статистикой вынесены на панели инструментов.

Панель навигации

Панель навигации располагается слева от основного окна. С ее помощью можно:

Instance Manager - Using Navigation Bar

Выбрать сервер из раскрывающегося списка Host.

Выбрать сервис - раскрывающийся список Service.

Service Management

btnExecuteQuery Start service - запустить сервис

btnStopRecordMacro Stop service - остановить сервис

iconRefresh Refresh - обновить статистику

Панель инструментов

Все инструменты навигационной панели доступны на панели инструментов. Панель инструментов - ToolBar - расположена в верхней части окна. Чтобы её активировать, необходимо на вкладке Windows в Environment Options выбрать RadioButton Toolbar или RadioButton Both.

RadioButton Toolbar выберите, если хотите, чтобы отображалась только панель инструментов, а RadioButton Both - если хотите, чтобы отображались обе панели.


Расширения

Расширение для PostgreSQL включает в себя несколько объектов SQL, например, новый тип данных, новые функции, новые операторы, новые классы оператора индекса и т.д. Для упрощения управления базами данных можно собрать все подобные объекты в единый пакет. В PostgreSQL такой пакет называется расширением.

Note: Расширения доступны только для сервера Postgres SQL версии 9.1 и выше.

С помощью инструмента Database Extensions можно управлять подобными расширениями.

Чтобы открыть этот инструмент выберите в главном меню программы пункт Services | Database Extensions.

В открывшемся окне представлен список всех существующих расширений.

Для каждого расширения отображается основная информация:

Extension Name - имя расширения.

Default version - версия по умолчанию.

Installed - установлено данное расширение или нет.

Installed version - версия установленного.

Object Schema - схема, в которую установлены объекты расширения.

Relocatable - можно ли данный объект переносить в другую схему.

Owner - пользователь, являющийся владельцем расширения.

Description - описание расширения.

Config Tables - таблицы, в которых расширение хранит свои настройки.

Контекстное меню

iconCommit Install - установить расширение. Этот пункт доступен только для неустановленных расширений.

Update to new version - обновить расширение до более поздней версии.

iconCross Uninstall - удалить установленное расширение

  • Relocate to other schema - переместить объект в другую схему.
  • Export Data - экспортировать список расширений во внешний файл.


Панели инструментов

Основные операции для работы с расширениями вынесены на панели инструментов.

Панель навигации

Панель навигации располагается слева от основного окна. С ее помощью можно:

Database Extensions - Using Navigation bar

Database

iconDB Выбрать из раскрывающегося списка базу данных.

General

iconRefresh Refresh - обновить список расширений.

iconCommit Install - установить расширение. Этот пункт доступен только для неустановленных расширений.

Update to new version - обновить расширение до более поздней версии.

iconCross Uninstall - удалить установленное расширение

  • Relocate to other schema - переместить объект в другую схему.

ВАЖНО: Вы можете включить\отключить панель навигации в Настройках окружения.


Установить/Обновить расширение

При установке и обновлении расширения появляется диалоговое окно Install/Update Extension. Эти диалоговые окна отличаются названием опции Default schema for current user и Move objects to another schema.

Extension name - имя устанавливаемого расширения.

Version to install

CheckBox Default version

Установите этот флажок, чтобы устанавливаемое расширение имело версию по умолчанию.

Version name

Если нужно выбрать другую версию расширения, то нужно убрать флажок Default version и выбрать нужную версию из этого раскрывающегося списка.

Need superuser to install

Показывает нужно ли обладать правами суперпользователя для установки.

Relocatable to other schema

Показывает возможно ли перемещение объектов расширения в другую схему.

Required schema

Выводит имя схемы, которая требуется для установки.

Prerequisite extensions

Отображает имена расширений, которые требуются для устанавливаемого расширения.

Schema to install objects to

CheckBox Default schema for current user

Установить обекты в схему, используемую по умолчанию для активного пользователя. При необходимости переместить объекты расширения в другую схему отключите данную опцию и выберете схему в списке Schema name.


Настройки

SQL Manager for PostgreSQL предоставляет Вам возможность персонализировать приложение.

Настройки окружения

Основной инструмент для управления свойствами и внешним видом объектов баз данных.

Настройки редакторов

Параметры редакторов задаются с помощью этого инструмента.

Шаблоны клавиатуры

С помощью этого инструмента Вы можете создавать шаблоны быстрого ввода текста.

Сохранение настроек

Мастер, позволяющий сохранить настройки базы данных в один файл.

Локализация

SQL Manager for PostgreSQL позволяет изменять язык интерфейса программы для удобства пользователей.

Шаблоны клавиатуры

С помощью этого инструмента Вы можете создавать шаблоны быстрого ввода текста.

Шаблоны объектов

Вы можете создавать шаблоны объектов с помощью этого инструмента

Важно: На каждой вкладке настроек опций располагается кнопка Reset to defaults button. С её помощью Вы можете восстановить значения по умолчанию на одной вкладке Reset current category, или на всех вкладках Reset all categories.

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Дополнительно

Как...


Настройки окружения

С помощью этого инструмента Вы можете изменять основные настройки программы SQL Manager for PostgreSQL.

Чтобы открыть настройки окружения необходимо в главном меню программы выбрать пункт Options | btnEnvironmentOptions Environment Options.

Предпочтения

Активация режима полной версии

Подтверждения

Внешний вид

Инструменты

Таймауты

Проводник баз данных

Поиск

Редакторы объектов

Получение данных

Монитор SQL

Выполнение скриптов

Дизайнер запросов

Стиль и цвет

Конструктор баз данных

Печать метаданных

Экспорт данных

Зависимости

Шрифты

Параметры сетки

Настройки данных

Настройки печати

Стиль и цвет

Дополнительные настройки

Опции столбцов

Локализация

Сочетания клавиш

Поиск опций

Общая для всех вкладок кнопка By default позволяет отменить все изменения, внесенные пользователем в настройки, и вернуться к настройкам, принятым по умолчанию.

Смотрите также:

Настройки редакторов


Предпочтения

На вкладке Preferences Вы можете задать следующие свойства программы:

Environment Options - Preferences

CheckBox Show splash screen on startup - показывать заставку при запуске.

CheckBox Restore desktop on connect - сохранять состояние рабочего стола при отключении. При следующем запуске программы все редакторы, которые были открыты перед выходом из программы, будут открыты заново.

CheckBox Do not restore if 'Refresh objects on connection' database registration option is off - не выполнять сохранение рабочего стола при отключении, если в Регистрационной информации баз данных не выбрана опция "Refresh objects on connection".

CheckBox Disable multiple instances - отключить возможность запуска нескольких копий программы.

CheckBox Encrypted passwords - хранить пароли в зашифрованном виде.

CheckBox Show desktop panel - показать панель рабочего стола (активно только для MDI вида, настраиваемого при первом открытии программы или на вкладке Windows).

Нажав на кнопку Reset all toolbars and menus, Вы восстановите настройки по умолчанию для всех панелей инструментов, навигационных панелей, а также проводника баз данных.


Активация режима полной версии

Если у вас установлена Lite версия программы, то на этом шаге Вы можете установить флажок CheckBox Show Full Version Features и посмотреть, какими возможностями обладает полная версия. Все возможности полной версии будут доступны для работы в течение тридцати дней. По истечении этого срока флажок будет недоступен.

Сравнительную характеристику Lite и Full версий смотрите в сравнительной таблице возможностей.

Environment Options - Full mode activation


Подтверждения

На вкладке Confirmations Вы можете задать следующие параметры подтверждений, возникающих при выполнении некоторых действий.

Environment Options - Confirmations

CheckBox Confirm saving the object (or document) upon closing the editor - подтверждать сохранение объекта (или документации) при закрытии или после внесения изменений.

CheckBox Confirm dropping of object - подтверждать удаление объекта.

CheckBox Confirm exit from SQL Manager - подтверждать выход из редактора (если объект изменен).

CheckBox Confirm deleting records - подтверждать удаление записей.

CheckBox Confirm metadata changing - подтверждать изменение метаданных.

CheckBox Confirm addition into spell checking dictionary - подтверждать добавление слова в словарь проверки правописания.

CheckBox Confirm transformation of misprint into substitution - подтверждать исправление опечатки.

CheckBox Confirm transaction commit - подтверждать фиксацию транзакции (для просмотрщика данных фиксировать транзакцию нужно при изменении данных).

CheckBox Confirm transaction rollback - подтверждать откат транзакции.

CheckBox Confirm transaction commit on closing data in object editors - подтверждать фиксацию транзакции при закрытии вкладки Data в редакторах объектов.

CheckBox Disable transaction confirmation on closing editor - отключить подтверждение транзакции. Если этот флажок установлен, то транзакции будут закрываться автоматически при выходе из Редактора получения данных и Визуального конструктора запросов.

Действие для транзакции, выполняемое по умолчанию, выбирается в списке Default action on closing the editor:

  • Commit - фиксация транзакции,
  • Rollback - откат.

Из раскрывающегося списка Table altering operations performed via recreation выберите доступно ли изменение таблиц путем их пересоздания.

  • Enabled - доступно.
  • Enabled, show warning - доступно, но будет появляться предупреждение.
  • Disabled - недоступно.


Внешний вид

На этой вкладке можно задать параметры и количество отображаемых окон, а также общий вид всей программы.

Theme

Выберите цветовую схему программы: Light (Светлая), Blue (Голубая) или Dark (Темная).

Environment Options - Windows

В разделе Environment style задайте общий вид программы:

RadioButton MDI environment - программа будет иметь MDI интерфейс. MDI - многодокументный интерфейс, интерфейс составных документов (спецификация, определяющая интерфейс пользователя с Windows-приложениями. Позволяет ему работать одновременно с несколькими документами, каждый из которых выводится на экран в отдельном порожденном (дочернем) окне главного окна приложения). (Приложения MS Office).

RadioButton Floating windows environment - программа будет отображаться в виде плавающих окон (приложения Borland).

CheckBox Number of open editors is restricted

Вы можете ограничить число открытых редакторов.

В разделе Zoom options можно задать настройки масштаба для плавающих окон:

RadioButton Full screen - во весь экран,

RadioButton Restricted by Main form - ограничено главной формой,

RadioButton Restricted by Main form and DB Explorer - ограничено главной формой и проводником баз данных

RadioButton Justified by Main form and DB Explorer - выровнять по главной форме и проводнику баз данных.

В разделе Bar style for child forms укажите те панели инструментов, которые должны отображаться в редакторах:

RadioButton Navigation bar - навигационная панель (располагается слева от основного окна редактора),

RadioButton Toolbar - панель инструментов (находится над основным окном редактора),

RadioButton Both - будут отображаться обе панели.

CheckBox Enable floating toolbars

Активирует плавающие панели инструментов, то есть положение любой панели инструментов можно изменять по желанию.


Инструменты

На этой вкладке можно задать основные настройки инструментов программы.

CheckBox Show only connected databases in drop-down menu

Показывать только подключенные базы данных в раскрывающемся меню.

CheckBox Allow using parameters in query text

Разрешить использование параметров в тексте процедур и запросов.

Parameter sign char

Введите знак, который будет обозначать параметр в запросе.

CheckBox Use transactions in Data tab of object editors, Query data and Design Query

Использовать транзакции на вкладке данных редактора объектов, в этом случае при открытии SQL Manager будет запущена транзакция, которую можно зафиксировать или откатить вручную, либо автоматически при закрытии SQL Manager. Если этот флажок установлен, то транзакция активна до тех пор, пока не закрыта вкладка Data или пока не нажата кнопка Commit. Все редактируемые записи заблокированы до фиксации транзакции. Если флажок не установлен, то транзакция автоматически фиксируется (autocommit) при сохранении каждой записи, которая блокируется только на короткий период времени.

CheckBox Asynchronous query execution

Асинхронное выполнение запроса. Запрос будет выполнен в отдельном потоке, все элементы управления останутся активными при выполнении и его можно прервать.

CheckBox Use separate connection for each data view within a database

Использовать общее подключение для каждого просмотра данных внутри базы данных. Если флажок не установлен, то при открытии просмотрщика данных создастся новое подключение к БД. Не рекомендуется использовать, если установлено ограничение на число подключений к серверу. Эта опция зависит от опции Asynchronous query execution.

CheckBox Convert line end to Linux style in string constants of executed SQL statements

Изменять символ конца строки в строковых константах на символы, используемые в Linux.

Environment Options - Tools

Важно: Изменения параметров, отмеченных символом * не вступят в силу до тех пор, пока данные просматриваются в текущем окне.

Эти опции будут использованы по умолчанию для всех баз данных, которые будут созданы после их изменения. Изменить эти параметры можно на вкладке Регистрационная информация баз данных.

New tool form should be opened for

Задайте, какая база будет выбрана в окне открываемого инструмента.

RadioButton Database currently selected in DB Explorer

В окне инструмента будет выбрана база, которая выбрана в Проводнике баз данных.

RadioButton Database selected in currently focused form

В окне инструмента будет выбрана база, которая выбрана в текущем открытом окне инструмента.


Таймауты

На этой вкладке с помощью счетчиков Вы можете задать максимальное время ожидания событий для выполнени операций. По истечении этого времени будет выведена ошибка.

Environment Options - Tools - Timeouts

Timeouts

Changing metadata

Для изменения метаданных.

Refresh database objects

Для обновления объектов базы данных.

Data tab of object editors, Query data, Design Query and Execute Script

Открытие вкладки данных в редакторах объектов. (Редактор таблиц, Редактор представлений, Редактор запросов, Дизайнер запросов).

Важно: Установленное значение "0" указывает на неограниченное время ожидания


Проводник баз данных

Проводник баз данных можно настроить, используя настройки, расположенные на вкладке DB Explorer.

Environment Options - Tools - DB Explorer

General options

CheckBox Show hosts in DB Explorer

Отображать хосты в проводнике баз данных, Если флажок установлен, то базы данных будут разделены на группы по принадлежности к серверу. Если не установлен, то они будут представлены единым списком.

CheckBox Show table subobjects

Показывать подобъекты таблицы.

CheckBox Sort by aliases

Сортировать хосты и базы данных в проводнике баз данных по псевдонимам.

CheckBox Rename objects by editing in place

Если установлен этот флажок, то объекты можно переименовывать в проводнике баз данных, нажав на выделенный объект мышкой.

CheckBox Refresh object on showing in SQL Assistant

Обновлять информацию о подобъектах, в тот момент когда они отображаются в SQL Assistant.

CheckBox Auto expand navigation pane

Если отмечена эта опция, то список вкладок в Проводнике баз данных будет автоматически открываться при запуске программы.

CheckBox Show hint

Отображать всплывающие подсказки при наведении курсора на объект в проводнике баз данных.

Recent objects count

C помощью счетчика можно задать количество объектов, отображаемых на вкладке недавно использовавшихся объектов.

Function list appearanceэ

Выберите вид отображения функций в проводнике БД.

RadioButton Show arguments list as part of function name - отображать аргументы в названии функции,

RadioButton Show arguments as child nodes - показывать аргументы как подобъект,

RadioButton Group functions by name - группировать функции с одинаковыми именами и разными параметрами.

В разделе Table Details in SQL Assistant выберите, какие именно подобъекты таблицы следует отображать в окне SQL Assistant:

RadioButton Columns - Столбцы

RadioButton Indices - Индексы

RadioButton Foreign keys - Внешние ключи

RadioButton Checks - Ограничения

RadioButton Triggers - триггеры

RadioButton Rules - Правила

RadioButton Table info - информация о таблице

RadioButton Description - текстовое описание

RadioButton Definition - DDL описание

В разделе Expand After Connection установите флажки напротив тех групп объектов, которые следует развернуть в дереве DB Explorer после подключения к базе данных:

CheckBox Tables - таблицы

CheckBox Views - представления

CheckBox Functions - функции

CheckBox Domains - домены

CheckBox Rules - правила

CheckBox Triggers - триггеры

CheckBox Indices - индексы

CheckBox Sequences - последовательности

CheckBox Composite Types - составные типы данных

CheckBox Enum Types - перечислимые типы

CheckBox Base Types - базовые типы данных

CheckBox Aggregates - агрегатные функции

CheckBox Operators - операторы

CheckBox Languages - языки описания процедур

CheckBox Tablespaces - табличные пространства

CheckBox Reports - отчеты

CheckBox Favorite Queries - избранные запросы

Смотрите также:

Проводник баз данных


Поиск

На этой вкладке задаются настройки поиска по Проводнику БД.

CheckBox Search by categories

Если флажок установлен, то поиск в проводнике баз данных будет производиться только внутри указанной категории.

Environment Options - Tools - DB Explorer - Search

CheckBox Use case sensitive search

При поиске с помощью панели поиска учитывать регистр символов.

CheckBox Don't search in collapsed nodes - осуществлять поиск только в развернутых ветках. Снимите флажок для поиска по всему дереву проводника баз данных.

CheckBox Start-with search

Если отмечена эта опция, то при поиске объектов будут показываться те, которые начинаются с введенной строки.


Редакторы объектов

На вкладке Object Editors задайте параметры редакторов объектов.

Environment Options - Tools - Object Editors

All

CheckBox Convert created objects' names to lower case

Автоматически приводить названия созданных объектов к нижнему регистру.

CheckBox Show OWNER on DDL tab

При включении этой опции на вкладке DDL объектов генерируется оператор OWNER. В противном случае он скрывается из определения объекта.

CheckBox Always open the first tab

Всегда открывать редактор на первой вкладке. Если опция отключена, то открываться будет последняя используемая вкладка объекта.

Table Editor

Задайте параметры редактора таблиц.

CheckBox Show Object Explorer

Отображать проводник объектов на навигационной панели.

CheckBox Do not retrieve record count for a table

Не показывать количество записей в таблице. В этом случае количество записей отображается в нижней информационной панели.

CheckBox Serial columns as integer - если этот флажок установлен, то столбцы 'serial' будут иметь тип 'integer'.

Function Editor

Задайте параметры редактора функций.

CheckBox Dollar-quoted function body on server 8.0 and higher

Заключать тело функции в "$" (для серверов версии 8.0 и выше).

CheckBox Split function options into several lines in DDL

Установите этот флажок, если хотите в DDL разделять строки опции. Если хотите, чтобы текст отображался одной строкой, то снимите этот флажок.

CheckBox Execute with definer's privileges as default

При включении опции функция при выполнении будет обладать правами того пользователя, который ее создал. Если флаг не установлен, то правами пользователя, который ее вызывает.

Включение этой опции включает также опцию Execute with definer's privilege в редакторе функции при создании новой функции.

Object list style

Задайте стиль списка объектов.

RadioButton Tree - в виде дерева.

RadioButton List, sorted by namespace - сортировать объекты по имени схемы.

RadioButton List, sorted by name - сортировать объекты по имени.

CheckBox Ignore case - если установлен этот флажок, то при сортировке объектов не учитывается регистр символов.

Смотрите также:

Управление объектами базы данных


Получение данных

На вкладке Query data задайте параметры отображения и работы редактора получения данных.

Environment Options - Tools - SQL Editor

Query results

CheckBox Fetch all data

При включенной опции результаты SQL-запроса загружается полностью. Опция работает, если не задано максимальное количество загружаемых записей с помощью пункта контекстного меню просмотрщика данных Grid mode).

CheckBox Show result for each query

Если установлен этот флажок, то при выполнении двух и более запросов результаты будут отображаться для каждого запроса. Если не установлен, то только для того, который был выполнен последним.

CheckBox Show results on Edit tab

Показывать результаты на вкладке редактирования, в противном случае результаты будут отображаться на отдельной вкладке.

Advanced

CheckBox Execute selected text separately

Выполнять выделенный текст запроса отдельно.

CheckBox Don't save queries automatically for the next session

Не сохранять запросы автоматически до следующего сеанса.

CheckBox Same queries for all database

Если установить этот флажок, то Редактор получения данных сохраняет все запросы в одном репозитории и переключение баз данных не вызывает загрузку запросов этой БД. Изменение опции не затрагивает текущие открытые копии редактора получения данных. Значение опции можно свободно изменять, это не приводит к потере содержимого репозитория запросов.

CheckBox Write only successful executed queries to database SQL log file

Записывать в файл журнала только успешно выполненные запросы.

CheckBox Always save changes in Favorite Queries before closing

Всегда сохранять изменения в избранных запросах перед закрытием.

CheckBox Refresh DB Explorer upon successful DDL statement

Обновлять проводник баз данных после успешного выполнения DDL операторов.

Execution plan

CheckBox Explain query on execution

Отображать план запроса в редакторе запросов. Если установлен этот флажок, то при выполнении запроса план автоматически выводится на вкладку Plan.

CheckBox Explain with verbose (showing execution plan as text only)

План запроса будет выводиться в текстовом виде на вкладке Edit.

CheckBox Explain with analyze

План запроса будет показан на вкладке Plan более подробно, с указанием времени, потраченного на выполнение запроса.

CheckBox Explain buffer usage (PostgreSQL 9.0 and higher)

Отображать на плане запроса информацию об использовании буфера (для серверов версий 9.0 и выше).

CheckBox Display execution plan as text in addition to representation as schema

Отображать план запроса на одной вкладке в виде текста и схемы.

Смотрите также:

Редактор запросов


Монитор SQL

На вкладке SQL Monitor можно задать некоторые параметры монитора SQL.

Environment Options - Tools - SQL Monitor

Operations

Отметьте флажками те операции, которые должны отображаться в SQL-мониторе.

CheckBox Connect - подключение.

CheckBox Start of transaction - начало транзакции.

CheckBox Commit - фиксация транзакции.

CheckBox Rollback - откат транзакции.

CheckBox Execute query - выполнение запроса.

SQL log

CheckBox Log SQL Monitor events to file

Вся информация о выполнении запросов, отображаемая в SQL мониторе, будет сохраняться в файл. В поле имя файла и путь к нему задается с помощью кнопки btnSaveAs.

CheckBox Clear log file when it is greater than

Очищать файл журнала при превышении заданного размер файла в килобайтах.

CheckBox Show time of operation

Отображать время выполнения операции.

CheckBox Always show on top

Всегда показывать Монитор SQL поверх остальных окон.

Смотрите также:

Монитор SQL


Выполнение скриптов

Задайте некоторые особенности выполнения скриптов в редакторе выполнения скриптов SQL.

Environment Options - Tools - SQL Script

CheckBox Abort script execution on error

Прекращать выполнение сценария при ошибке.

CheckBox Execute in transaction, rollback on error

Если опция включена, то весь скрипт выполняется в транзакции, которая откатывается в случае ошибки.

CheckBox Enable parsing

Включать синтаксический анализ.

CheckBox Show message when done

Показывать сообщение об окончании выполнения.

CheckBox Execute selected text separately

Выполнять выделенный текст отдельно.

CheckBox Don't clear error list on selected text execution

Не очищать список ошибок при выполнении фрагмента текста запроса.

CheckBox Show notices in error list

В окне ошибок отображать информационные сообщения.

CheckBox Register newly created databases

Если этот флажок установлен, то мастер регистрации баз данных открывается автоматически после создания базы данных в редакторе выполнения скриптов.

Смотрите также:

Редактор выполнения скриптов


Дизайнер запросов

Задайте некоторые свойства дизайнера апросов на вкладке Design Query.

Environment Options - Tools - Query Builder

General options

CheckBox Allow SELECT queries only

Разрешать выполнение только запросов типа SELECT.

CheckBox Select condition row

Выделять другим цветом строку условия.

CheckBox Drag column name

Отображать имя столбцы при перетаскивании.

CheckBox Hide selection when inactive

Скрывать выделение полей объектов, когда отсутствует фокус.

CheckBox Show columnd types

Показывать типы колонок.

CheckBox Union all by default

Отображать связь "UNION ALL" для нескольких запросов по умолчанию

Visible tabs

Выберите какие вкладки должны быть видимыми.

CheckBox Criteria - Критерии,

CheckBox Selection - Выбор,

CheckBox Group criteria - Критерии группы,

CheckBox Sorting - Сортировка.

Script format

Keywords format

Выберите формат ключевых слов.

Function format

Выберите вид отображения функций.

Для ключевых слов и функций предлагается четыре типа написания.

  • As is - Как есть.
  • Uppercase - ВСЕ ПРОПИСНЫЕ.
  • Lowercase - все строчные.
  • First upper - Начинать С Прописных.

Смотрите также:

Дизайнер запросов


Стиль и цвет

На этой вкладке Вы имеете возможность задать стили и цвета оформления дизайнера запросов

Environment Options - Tools - Query Builder - Style & Color

Style

Задайте стиль отображения элементов управления.

Condition button style

Выберите стиль отображения кнопок.

Object border выберите стиль отображения границ объектов.

CheckBox Flat objects - плоские объекты.

CheckBox Windows style of tables - стиль таблиц XP.

CheckBox Show icons on tabs - показывать значки на вкладках.

Color palette

Вы можете изменить цвета объектов и элементов управления визуального конструктора запросов. Вызвать палитру для выбора цвета можно, нажав на цветной квадрат рядом с наименованием элемента управления.

Элементы, для которых можно задавать цвета:

  • Active condition row - активная строка в окне задания условий отбора.

Environment Options - Tools - QB - Style & Color - Active condition row

  • Condition text - текст условий отбора.

Environment Options - Tools - QB - Style & Color - Condition text

  • Condition item text - текст кнопок, расположенных рядом с условиями отбора.

Environment Options - Tools - QB - Style & Color - Condition item text

  • Table client area - фон объектов, помещенных в окно диаграммы.

Environment Options - Tools - QB - Style & Color - Table client area

  • Active table caption - заголовок активной таблицы.

Environment Options - Tools - QB - Style & Color - Active table caption

  • Inactive table caption - заголовок неактивной таблицы.

Environment Options - Tools - QB - Style & Color - Inactive table caption

  • Column text - текст имен столбцов на диаграмме
  • Selected column text - текст выделенного столбца
  • Work space - цвет рабочей области диаграммы
  • Column - текст имен столбцов в окне задания условий отбора.

Environment Options - Tools - QB - Style & Color - Field

  • Operation - знак операции в окне задания условий отбора.

Environment Options - Tools - QB - Style & Color - Operation

  • Group - знак группировки в окне задания условий отбора, на вкладке Grouping criteria.

Environment Options - Tools - QB - Style & Color - Group

  • Predicate - предикат, если создан подзапрос.

Environment Options - Tools - QB - Style & Color - Predicate

  • Subquery - текст подзапроса в строке условия.

Environment Options - Tools - QB - Style & Color - Subquery


Конструктор баз данных

На этой вкладке задайте параметры конструктора баз данных.

CheckBox Automatically open last diagram file

В конструкторе автоматически открывать последнюю редактируемую диаграмму.

Environment Options - Tools - VDBD

Visual settings

Model notation

Выберите стандарт отображения информации в диаграмме (нотацию модели данных) - IDEF1x или IE.

  • Integration DEFinition for Information Modeling (IDEF1X);
  • Information Engineering (IE).

Нотации IDEF1X и IE используют разные наборы символов для отображения связей.

CheckBox Draw PRIMARY KEY columns separately

Ключевой столбец будет отделен горизонтальной линией от остальных столбцов таблицы.

Environment Options - Tools - VDBD - Draw PRIMARY KEY fields separately

CheckBox Draw entities icons,

Рядом с заголовками таблиц будут отображаться иконки.

Environment Options - Tools - VDBD - Draw entities icons

CheckBox Draw attributes icon

Рядом с названием каждого столбца будет отображаться иконка.

Environment Options - Tools - VDBD - Draw attributes icons

CheckBox Draw only names of entities

На диаграмме отображать только заголовки объектов.

Environment Options - Tools - VDBD - Draw only names of entities

CheckBox Draw attribute information

В скобках после имени и типа аттрибута отображать информацию о свойствах столбца.

Environment Options - Tools - VDBD - Draw attributes information

CheckBox Draw FOREIGN KEY name

Показывать имена внешних ключей.

Environment Options - Tools - VDBD - Draw FOREIGN KEY name

CheckBox Draw page borders

Отображать границы страниц, которые будут устанавливаться при печати диаграммы.

Grid options

Задайте параметры сетки диаграммы:

CheckBox Show grid

Отображать сетку окна диаграммы.

CheckBox Snap to grid

Выравнивать объекты, расположенные на диаграмме, по линиям сетки.

Задать параметры сетки диаграммы можно с помощью счетчиков Grid size. ширина - X, высота - Y.

Style & Color

В этом разделе Вы можете задать цвета для различных элементов диаграммы. Вызвать палитру для выбора цвета можно, нажав на цветной прямоугольник рядом с наименованием элемента управления.

В списке Element выберите элемент:

Workspace - рабочая область,

Environment Options - Tools - VDBD - Color Palette - Work area

Relation - текст связи между сущностями,

Environment Options - Tools - VDBD - Color Palette - Relation

Table - таблица,

Environment Options - Tools - VDBD - Color Palette - Entity

Selected item - выделенный объект,

Environment Options - Tools - VDBD - Color Palette - Selection

Comment - комментарий.

Environment Options - Tools - VDBD - Color Palette - Comment

  • Font name - вид шрифта,
  • Font size - размер шрифта,
  • Font color - цвет шрифта,
  • Brush color - цвет фона объекта,
  • Pen color - цвет рамки объекта.

CheckBox Bold - жирный

CheckBox Italic - курсив

CheckBox Underline - подчеркнутый

Нажав на кнопку Apply to all можно применить все настройки шрифта ко всем объектам.

Смотрите также:

Конструктор баз данных


Печать метаданных

На этой вкладке из всех параметров печати можно задать только размер бумаги, используемый по умолчанию, при создании отчетов в инструменте Печать метаданных.

Environment Options - Tools - Print Metadata

Смотрите также:

Печать метаданных


Экспорт данных

На этой форме Вы задаете, в каком формате по умолчанию будут отображаться данные разных типов.

Environment Options - Tools - Data Export

Data formats

Форматы отображения Вы можете задать для следующих форматов данных.

  • Integer format - Целое число.
  • Float format - Число с плавающей точкой.
  • Date format - Дата.
  • Time format - Время.
  • DateTime format - Дата и время.
  • Currency format - Денежный.
  • Boolean True - Истина.
  • Boolean False - Ложь.
  • Null string - Строка NULL.

CheckBox Auto save format string

Заданный в мастере формат будет сохраняться автоматически.

Также эти форматы можно задать на третьем шаге мастера экспорта данных.

Подробнее о форматах данных читайте в разделе задание форматов данных.

Смотрите также:

Мастер экспорта данных


Шрифты

На вкладке Fonts можно задать вид и размер шрифта для всей программы SQL Manager for PostgreSQL.

Environment Options - Fonts

В поле System font name задается тот шрифт, который используется во всех элементах управления программы SQL Manager for PostgreSQL.

Environment Options - Fonts - System font name

В поле System font size укажите размер шрифта.

В нижнем окне отображается образец текста, показывающий внесенные изменения.

В поле Grid font name задается тот шрифт, который используется в просмотрщике данных в виде таблицы.

В поле Grid font size укажите размер шрифта в просмотрщике данных в виде таблицы.

В приведенном примере отображается таблица с примененными настройками шрифта.


Параметры сетки данных

На этой вкладке можно задать параметры отображения просмотрщика данных.

Environment Options - Grid

General options

CheckBox Striped grids - другой фон четных строк.

CheckBox Show editor immediately - переход в режим редактирования при получении фокуса ввода ячейкой.

CheckBox Always show editor - всегда отображать редактор для ячеек.

CheckBox Enable auto-search in grid - включить автоинкрементный поиск в таблице по записям.

CheckBox Row multi-selection - разрешить выбор нескольких записей.

CheckBox Column auto-width - автоподбор ширины таблицы по ширине окна.

CheckBox Cell auto-height - автоподбор высоты ячейки, при этом ещё можно указать максимальное количество строк на странице в поле Cell max line count.

Grid layout preference

Задайте некоторые параметры размещения сетки просмотрщика данных.

RadioButton Autofit column widths - автовыбор ширины столбцов,

RadioButton Save and restore layout - сохранение расположения и ширины,

CheckBox Restore sorting - сохранять сортировку столбцов.

Root level options

Задайте настройки основного уровня.

CheckBox Show "Group by" box - показывать поле группировки.

CheckBox Show indicator - показывать указатель (панель слева от таблицы).

CheckBox Show navigator - показывать навигатор (дополнительная панель перехода по записям внизу таблицы).

CheckBox Show "New item row" - показывать пустую строчку для добавления новой записи.

Detail level options

Задайте параметры отображения для дочернего уровня таблицы.

CheckBox Show "Group by" box - показывать поле группировки.

CheckBox Show indicator - показывать указатель (панель слева от таблицы).

Environment Options - Grid - Show indicator

CheckBox Show navigator - показывать навигатор (дополнительная панель перехода по записям внизу подуровня).

Environment Options - Grid - Show navigator

CheckBox Show "New item row" - показывать пустую строчку для добавления новой записи.

CheckBox Hide tabs for single detail - скрывать вкладки в случае только одного подуровня.

Selection

Если выбрана опция RadioButton Row selection, то при клике на ячейку в таблице, будет выделена вся запись. В противном случае, будет выделена только та ячейка, по которой кликнули мышкой (опция RadioButton Cell selection).

Отметьте опцию CheckBox Row/cell multi-selection, чтобы разрешить выбор нескольких строк или ячеек в таблице.

Важно: Чтобы изменения параметров, отмеченных символом «*», вступили в силу, Вы можете открыть окно заново, щелкнуть «Обновить» в редакторе таблиц или заново выполнить запрос в редакторе SQL или конструкторе запроса.

Смотрите также:

Просмотр в виде таблицы


Настройки данных

Параметры отображения данных просмотрщика данных задайте на вкладке Data options.

Environment Options - Grid - Data Options

Limit options in table and view editors

RadioButton Select all records from a table - загрузить все записи в инструмент просмотра. В этом случае в таблицу загружаются все данные из возвращаемого сервером набора данных.

RadioButton Select only N rows - загрузить только указанное число записей в таблицу из возвращаемого сервером набора данных.

Advanced

CheckBox OID columns as BLOB - данные типа OID представлены в виде BLOB с возможностью изменения в редакторе BLOB.

Load visible rows mode if records more than

Переходить в режим "только видимые записи", если их больше чем заданное в поле количество.

String columns width (chars)

Задайте фиксированную ширину строк полей.

Locating records on update or delete

Задайте какие столбцы использовать в запросах, генерируемых на обновление и удаление:

RadioButton Use all columns - использовать все столбцы.

RadioButton Use key columns and changed columns - использовать ключевые и измененные столбцы.

RadioButton Use key columns only - использовать только ключевые столбцы.

Default Grid Mode

Это режим загрузки данных в гриде по умолчанию, который влияет на скорость работы.

  • Load all rows - загрузить все записи в инструмент просмотра. В этом случае в таблицу загружаются все данные из возвращаемого сервером набора данных.
  • Load visible rows - загрузить видимые записи. В таблицу из возвращаемого сервером набора данных загружается только строго определенное количество записей.

Важно: Изменения параметров, отмеченных символом «*» не вступят в силу до тех пор, пока данные просматриваются в текущем окне.

Эти опции будут использованы по умолчанию для всех баз данных, которые будут созданы после их изменения. Изменить эти параметры можно на вкладке Регистрационная информация баз данных


Настройки печати

На этой вкладке задайте те настройки печати, которые будут сохранены и применены при последующем открытии диалога:

Environment Options - Grid - Print Data

CheckBox Card view representation - вид карточного представления

CheckBox Detail view representation - вид представления подуровней

CheckBox Expanding - расширение

CheckBox Formatting - форматирование

CheckBox Level options - настройки уровня

CheckBox "on every page" options - параметры «На каждой странице»

CheckBox Pagination - нумерация страниц

CheckBox Preview options - настройка просмотра

CheckBox Image options (refinements) - параметры изображения (обработка)

CheckBox Selection options - параметры выбора

CheckBox Report size options - настройка размера отчета

CheckBox Showing grid elements - показ элементов сетки

CheckBox Page number format -формат номера страницы

CheckBox Page settings - параметры страницы

CheckBox Report title - заголовок отчета


Стиль и цвет

В разделе Color & formats укажите или выберите формат отображения для следующих типов данных:

Environment Options - Grid - Color & Formats

Display formats

Integer columns - целое число.

Float columns - число с плавающей точкой.

Datetime columns - дата и время.

Date columns - дата.

Time columns - время.

Colors

Задайте цвета для следующих объектов.

  • Grid - таблица просмотрщика данных.
  • Row - строка.
  • Strip - выделение четных строк.

Null Values

Для значений NULL Вы можете задать собственные цвета в разделе

  • Text - текст.
  • Font Color - цвет шрифта.


Дополнительные настройки

На вкладке Advanced можно задать следующие параметры просмотрщика данных.

Environment Options - Grid - Advanced

Advanced options

CheckBox Cell hints for clipped text - отображать подсказки для обрезанного текста,

CheckBox Focus cell on cycle - фокусировать ячейки циклически при перемещении маркера,

CheckBox Focus first cell on new record - фокусировать ячейку в новой записи,

CheckBox Next cell on pressing Enter - перейти к следующей ячейке при нажатии на Enter,

CheckBox Show navigation hints - показывать подсказки навигатора,

CheckBox MRU list in column filter - список недавно использовавшихся фильтров,

CheckBox Expand buttons for empty details - отображать кнопки расширения для пустых частей,

Card width - в поле счетчика указывается ширина карточки,

Form view

CheckBox Large Memo Editor - использовать редактор больших записей, если количество строк превышает число, заданное в поле Number of lines,

CheckBox Word wrap in memo editor - переносить текст по словам в редактор больших записей,

CheckBox Word wrap in string editor - переносить текст по словам в редактор строк,

Grid lines - указать, какие линии таблицы будут отображаться ( CheckBox Horizontal - горизонтальные, CheckBox Vertical - вертикальные),

Detail tabs position - расположение вкладок подуровней ( RadioButton Top - вверху, RadioButton Left - слева),

Card layout direction - расположение карточек ( RadioButton Horizontal - по горизонтали, RadioButton Vertical - по вертикали),

Show edit buttons - показывать кнопки редактирования ( RadioButton Never - не показывать, RadioButton For focused record - для активной записи, RadioButton Always - показывать всегда).


Опции столбцов

Common options

CheckBox Auto-select text - Автовыделение текста при переходе в режим редактирования.

CheckBox Hide selection on losing focus - Скрывать выделение при потере фокуса.

Memo editor options (cвойства редактора записи)

CheckBox Inserting Return characters - Возможность вставки символов перехода на новую строку.

CheckBox Inserting Tab characters - Возможность вставки символов табуляции.

CheckBox Word wrap in grid - Перенос по словам в редакторе Memo.

CheckBox Popup memo editors - Всплывающие редакторы столбцов этого типа.

Environment Options - Grid - Column Options

Spin editor options (настройки "быстрого" редактора)

CheckBox Use Ctrl+Up instead of Up to increase value - использовать сочетание клавиш Ctrl+Up вместо Up для увеличения значения в ячейке.

CheckBox Show large increment buttons - показывать кнопки большого приращения.

В поле Increment задайте приращение, большое приращение - в поле Large increment.

Spin editor buttons' position (Положение кнопок "быстрого редактора")

RadioButton Vertical - вертикально.

RadioButton Horizontal / left and right - горизонтально / слева и справа.

RadioButton Horizontal / right - горизонтально / справа


Локализация

С помощью инструментов, расположенных на этой вкладке Вы можете задавать язык программы.

Environment Options - Localization

Вы можете выбрать один из предложенных языков, или создать свой.

В поле Default directory указан путь к папке, в которой по умолчанию находятся все файлы локализации, имеющие формат *.lng.

Из раскрывающегося списка Choose program language выберите язык программы.

CheckBox Если установлен флажок Auto scan languages on startup, то каждый раз при запуске SQL Manager for PostgreSQL папка Default directory будет проверяться на наличие новых файлов *.lng, которые затем автоматически будут добавлены в список доступных языков программы.

В списке Available languages показан список доступных локализаций, которые можно установить как основной язык программы.

При нажатии на кнопку Add defaults проверяется наличие новых файлов *.lng в папке по умолчанию, которые автоматически добавляются в список доступных языков программы.

Нажав на кнопку Add, Вы можете добавить в список Available languages файл локализации, указав в появившемся окне имя локализации и путь к файлу.

Кнопка Edit позволяет редактировать выбранную локализацию.

Нажав на кнопку Delete, Вы удалите выбранную локализацию из списка доступных.

Смотрите также:

Локализация


Сочетания клавиш

На этой вкладке можно просмотреть и при необходимости задать сочетания клавиш для быстрого выполнения операций в SQL Manager.

Environment Options - Global Shortcuts

Для изменения сочетания клавиш необходимо двойным щелчком мышки на нужном пункте вызвать диалоговое окно.

Environment Options - Global Shortcuts - Edit

В этом окне отображаются нажатые в настоящий момент клавиши или сочетания.

Поместив курсор в поле, выберите клавиши, которые следует использовать. В сочетаниях нельзя использовать клавиши TAB и PRINT SCREEN.


Настройки редакторов

С помощью этого инструмента Вы можете задать настройки для всех редакторов SQL-кода, которые есть в программе.

Открыть окно настройки можно, выбрав пункт Options | Editor Options в главном меню программы.

  • Общие настройки
  • Отображение
  • Цветовая схема
  • Автозаполнение кода
  • Форматтер SQL
  • Задание сочетаний клавиш
  • Поиск опций

Смотрите также:

Настройки окружения


Общие настройки

На этой вкладке задайте основные свойства редактора.

Editor Options - General

Editor options

CheckBox Auto indent - каждый новый отступ такой же, как в предыдущей строке.

CheckBox Insert mode - включен режим автоматической вставки символов.

CheckBox Find text from cursor - При поиске с помощью окно поиска осуществлять поиск с того места, на котором стоит курсор. Если флажок не установлен, то поиск будет производиться с начала страницы.

CheckBox Always show hyperlinks - всегда отображать названия объектов в виде гиперссылок.

CheckBox Double click line - двойной щелчок в любом месте строки выделяет строку полностью.

CheckBox Trim trailing spaces - если флажок установлен, то все пробелы после последнего символа строки будут удалены.

CheckBox Fixed line height - фиксированная высота строки.

CheckBox Persistent blocks - не убирать выделение при перемещении курсора с помощью клавиш.

CheckBox Fixed column move - если установлен этот флажок, то при перемещении курсора в редакторе вверх-вниз он будет сохранять свою горизонтальную позицию, относительно начала строки.

CheckBox Optimal fill - установите этот флажок, если хотите включить автоматическое форматирование текста запроса в редакторе.

CheckBox Unindent keep align - сохранять выравнивание для строк без отступа.

CheckBox Smart caret - при перемещении курсора между строками с помощью клавиш, курсор перемещается на ближайший символ текста.

CheckBox Overwrite blocks - заменять выделенный текст текстом вводимым с клавиатуры. Если флажок не установлен, то новый текст будет вводиться сразу после выделенного, также выделенный текст нельзя будет сразу удалить нажатием клавиш Delete, Enter и пробел.

CheckBox Show caret in read only mode - в режиме "только для чтения" показывать курсор.

CheckBox Copy to clipboard as RTF - текст запроса копировать в буфер обмена как текст формата RTF.

CheckBox Drag and drop text - разрешить перетаскивание текста.

CheckBox Group undo - позволяет отменять несколько операций одного вида.

CheckBox Group redo - позволяет возвращать несколько операций одного вида.

CheckBox Cursor beyond EOL - если щелкнуть мышью по пустому пространству после текста в строке, то курсор автоматически переместится в конец текста. Также применяется и при перемещении курсора кнопками Up/Down.

CheckBox Enable column selection - включить возможность выделения столбца.

CheckBox Hide cursor on type - убирать курсор мыши когда пользователь набирает текст.

CheckBox Hide dynamic (no focus) - убирать подсветку, если окно неактивно.

CheckBox Collapse empty lines - автоматически убирать пустые строки.

CheckBox Scroll last line - при прокрутке перейти к последней строке.

CheckBox Word wrap - перенос по словам.

CheckBox Variable horizontal scrollbar - если нет текста, выходящего за границы видимой области, не отображать полосу прокрутки.

CheckBox Float markers - если установлен, то закладки не перемещаются вместе с текстом, а указывают на строку с определенным номером.

CheckBox Undo after save - не очищать список произведенных операций после сохранения, чтобы иметь возможность отменить действие даже после сохранения.

CheckBox Disable selection - отключить возможность выделения при редактировании.

CheckBox Draw current line focus - выделять редактируемую строку не только цветом, но ещё и пунктирной линией.

CheckBox Hide selection (no focus) - скрывать выделение, когда окно редактора становится неактивным.

CheckBox Greedy selection - если установлен этот флажок, то при выделении нескольких строк/столбцов захватывается дополнительно 1 строка/столбец.

CheckBox Keep selection mode - делает возможным выделение при перемещении курсора в тексте.

CheckBox Select search result - выделять результаты поиска.

CheckBox Smart paste - вставляемый из буфера обмена текст в кодировке Unicode и ANSI преобразовывается к кодировке, принятой в базе данных,

CheckBox Disable all code features - отключить все возможности "Быстрого кода" и сбросить настройки цвета на значения по умолчанию.

Collapse level

Cворачивать подуровни.

Undo limit

Число сохраненных операций для отмены действия.

Tab mode

Выберите действие, выполняемое при нажатии клавиши табуляции.

Tab stops

Задайте размер отступа при табуляции.

Comment symbols

Выберите сочетание символов, которое будет означать комментарии.

Block indent

Задайте размер отступа для блоков с установленными закладками.

С помощью кнопки Reset to defaults можно отменить внесенные изменения и вернуть настройкам первоначальные значения.


Отображение

На этой вкладке задайте параметры отображения текста редактора.

Default editor fonts

Font

Задайте шрифт для редактора SQL.

Size

Задайте размер шрифта для редактора SQL.

CheckBox Show only fixed-width fonts - если установлен этот флажок. то в списке выбора шрифтов будут отображаться только те, которые имеют фиксированную ширину символов.

Gutter

В этом разделе вы можете задать параметры левого поля редактора SQL.

CheckBox Show line numbers - отображать номера строк,

CheckBox Gutter auto width - автоматически выравнивать внутренние поля,

CheckBox Display line state - если этот флажок установлен, то в левом поле будет отображаться вертикальная цветная линия, показывающая состояние строк. Состояний у строк существует три: измененная строка показана желтым цветом, новая - зеленым, сохраненная в файл - синим.

CheckBox Use code folding - Вы можете задать иерархическую структуру текста с возможностью скрывать подобъекты.

В счетчике Width задайте ширину левого поля.

Выберите значения Font, Size, Numbering style для задания шрифта и стиля текста в правом поле.

CheckBox Show only fixed-width fonts - если установлен этот флажок. то в списке выбора шрифтов будут отображаться только те, которые имеют фиксированную ширину символов.

Editor Options - Display

Right margin

В этом разделе можно задать свойства правой границы, которая используется при автоматическом форматировании текста запроса. (Задать параметры автоматического форматирования можно на вкладке SQL Formatter).

CheckBox Visible - включает отбражение правой границы

CheckBox Word break - позволяет переносить слова в пределах правого поля.

С помощью счетчика Position задайте отступ от левого края для этой границы.

Из раскрывающегося списка Color выберите цвет границы.

Code staples

Задайте параметры отображения скобок в тексте.

CheckBox Visible - скобки видимы в тексте.

CheckBox Single color - установите этот флажок, если хотите задать единый цвет для всех скобок в тексте.

Offset - задайте значение сдвига для скобок.

С помощью кнопки Reset to defaults можно отменить внесенные изменения и вернуть настройкам первоначальные значения.

Нажав на кнопку Set line numbers font, Вы имеете возможность изменить внешний вид номеров строк.

Из раскрывающегося списка Background color выберите цвет фона редактора.

Стиль нумерации строк можно выбрать из раскрывающегося списка Numbering style.

Все изменения отображаются на образце, расположенном в нижней части формы.

С помощью кнопки Reset to defaults можно отменить внесенные изменения и вернуть настройкам первоначальные значения.


Цветовая схема

Scheme

Выберите цветовую схему для всех редакторов:

Light - Светлая

Dark - Темная

Editor Options - Display - Highlight

В списке Element list вы можете выбрать любой элемент из Редактора SQL и настроить опции его отображения. Все изменения можно посмотреть в области под списком.

CheckBox Bold

Элемент будет отображаться полужирным шрифтом.

CheckBox Italic

Элемент будет отображаться курсивом.

CheckBox Foreground

Выберите цвет шрифта для выбранного элемента.

CheckBox Background

Выберите цвет фона для выбранного элемента.

CheckBox Effects

Задайте дополнительные настройки для выбранного элемента.

Чтобы сохранить принятые изменения нажмите на кнопку Ok.

С помощью кнопки Reset to defaults можно отменить внесенные изменения и вернуть настройкам первоначальные значения.


Автозаполнение кода

На этой вкладке задайте параметры быстрого ввода текста при написании запроса. Быстрый код - это окно подстановки, которое появляется при введении слова в запрос.

Automatic features

В разделе задайте свойства автоматической подстановки.

CheckBox Code Completion - включает/отключает список автодополнения. При вводе первых символов слова, автоматически будет предложен список из слов, начинающихся с этих символов.

CheckBox Parameters completion - включает/отключает автодополнение списка параметров

Sensitivity (char) - задает количество введенных символов, после которых открывается список.

Delay (sec) - задает время ожидания появления подсказки.

CheckBox Group by type

Объекты в списке автодополнения будут сортироваться по типу, иначе они сортируются по имени.

CheckBox Sort column names

Включите опцию для сортировки столбцов таблицы.

CheckBox Show information hints - отображать всплывающие подсказки для каждого слова из списка автоподстановки.

CheckBox Auto launch keyboard templates

Шаблоны клавиатуры будут применяться автоматически, если Вы установите флажок.

CheckBox Accept by Space key too

Подходящий элемент списка будет подставляться по нажатию клавиши Пробел.

Editor Options - Display - Quick Code

Completion list object

В данной секции вы можете можно задать цвет и стиль выбранного элемента списка автодополнения. Изменения отразятся на списке справа.

С помощью кнопки Reset to defaults можно отменить внесенные изменения и вернуть настройкам первоначальные значения.


Форматтер SQL

Средства задания настроек автоматического форматирования SQL запросов расположены на вкладке SQL Formatter.

SQL Formatter также используется при форматировании SQL скриптов и в редакторах некоторых объектов.

На вкладке SQL Words задайте, какие части запроса следует форматировать автоматически.

Editor Options - SQL Formatter

CheckBox Установив флажки Format SQL query и Format subquery, Вы включаете автоматическое форматирование запросов и подзапросов.

Смотрите также:

Редактор запросов


SQL Words

На вкладке SQL Words задайте параметры форматирования текста запроса.

Editor Options - SQL Formatter - SQL Words

В списке Wrap first element выделите флажками те операторы, после которых необходимо выполнить перенос строки.

Params in line/list - в этом списке флажками отмечаются те операторы, для которых нужно изменить вид отображения параметров. Если при открытии запроса параметры отображались в столбец, то после установки этого флажка они будут отображаться в одну строку и наоборот.

В разделе OR - AND задайте положение операторов OR и AND относительно текста:

RadioButton Left - слева от текста,

WHERE

AND ...

AND ...

AND ...

RadioButton Separate - операторы выносятся каждый в отдельную строку,

WHERE

...

AND

...

AND

RadioButton Right - справа от текста.

WHERE

... AND

... AND

... AND

В разделах Keyword case и Identifiers case выберите регистр, в котором будут отображаться ключевые слова и идентификаторы в тексте запроса:

RadioButton Default - оставлять как есть,

RadioButton Upper - ВСЕ ПРОПИСНЫЕ,

RadioButton Lower - все строчные,

RadioButton Capitalize - Начинать С Прописных.

CheckBox Space before bracket - вставлять пробел перед открывающей скобкой и после закрывающей.

CheckBox Space into brackets - автоматическая вставка пробелов между скобками и текстом внутри скобок.

С помощью счетчика Indent in list задайте отступ для элементов списка.

Чтобы отформатировать текст запроса с новыми изменениями нужно в редакторе запросов в контекстном меню выбрать пункт Format SQL.


Задание сочетаний клавиш

На вкладке Key Mapping можно задать сочетания клавиш для быстрого выполнения операций в редакторе SQL запросов.

Editor Options - Key Mapping

Определенный набор сочетания клавиш для различных действий можно сохранить в виде схемы сочетания клавиш. После внесения изменений в существующие сочетания и добавления новых нажмите кнопку Save As, чтобы сохранить эти изменения. Чтобы применить схему достаточно из раскрывающегося списка Scheme name выбрать нужную и нажать кнопку OK. Нажав на кнопку Delete, Вы удалите выбранную схему.

Ниже задаются сочетания клавиш для всех действий, производимых в редакторе.

Из списка Commands, выберите действие, для которого хотите задать сочетание клавиш.

В окне Key combinations отображаются уже добавленные сочетания. Выделив сочетание и нажав кнопку Delete, Вы удалите это сочетание. Если нажать кнопку Clear, то удалятся все сочетания для выбранного действия.

Чтобы добавить новое сочетание нажмите кнопку New и в поле Key укажите нужное сочетание. Если такое уже существует для другого действия, то появится предупреждение, в котором будет название той операции, для которой используется нужное сочетание. Для одного действия допустимо создавать несколько сочетаний клавиш, и даже последовательность сочетаний клавиш. Если задана последовательность, то действие будет выполнено только после того как будут нажаты клавиши в указанной последовательности. Каждая строка в списке Key combinations - это сочетание для выполнения одного действия. С помощью кнопки Add Вы добавляете новое сочетание клавиш в уже существующее. Так создается последовательность сочетаний клавиш.

Схему можно экспортировать в файл, нажав на кнопку Export. При этом откроется Мастер экспорта данных, позволяющий быстро пошагово выполнить эту операцию.

Смотрите также:

Редактор запросов

Сочетания клавиш


Проверка правописания

На вкладке Spell Checking задайте параметры орфографического контроля.

Editor Options - Spell Checking

В разделе Spell checker mode выберите тип проверки правописания:

RadioButton Highlighting - слова с ошибками будут выделены,

RadioButton Autocorrection - ошибки будут автоматически исправляться,

RadioButton None - никаких действий производиться не будет.

Задать параметры учета разряда букв при проверке можно в разделе Case sensitivity:

CheckBox Support case consistency with substitution - разряд подставляемого во время замены слова совпадает с разрядом слова, в котором была допущена ошибка.

CheckBox Ignore case while spell checking - игнорировать разряд при проверке правописания.

CheckBox Keep the misprint case when replacing - сохранять разряд слова при замене опечатки.

В списке Substitutions находятся ключевые слова словаря проверки правописания. На эти слова будут заменяться те, которые написаны с ошибками, если установлена автоматическая замена. Чтобы добавить слово в этот список нужно нажать кнопку Add. Изменить выбранное слово можно с помощью кнопки Edit. Нажатие на кнопку Delete удалит выбранное слово.

Задать параметры проверки опечаток можно в разделе Misprints.

Для слова из списка Substitutions можно задать некоторое количество слов с опечатками, которые будут автоматически заменяться на нужное слово.

В списке Check содержатся варианты ошибок, которые может допустить пользователь в слове.

Чтобы добавить вариант в список нужно нажать на кнопку Add. С помощью кнопки Edit Вы можете изменить выбранный вариант ошибки. С помощью кнопки Auto Вы можете автоматически создать все варианты ошибок, которые могут быть допущены в этом слове. Нажав на кнопку Delete, Вы удалите выбранный вариант опечатки. Кнопка Clear очищает список опечаток полностью.

В список Ignore помещаются те варианты опечаток, которые при автоматической замене будут игнорироваться.

Кнопка Reset to defaults позволяет вернуть все настройки к принятым по умолчанию.


Мастер сохранения настроек

Мастер сохранения настроек позволяет экспортировать все настройки программы SQL Manager for PostgreSQL во внешний файл. Файл настроек имеет расширение *.reg (файл системного реестра Windows). Применить сохраненные настройки Вы можете как для этой программы, так и для заново установленного SQL Manager for PostgreSQL. Чтобы открыть Мастер сохранения настроек в главном меню программы выберите пункт Options | Save Settings.

Чтобы применить настройки, сохраненные в файл *.reg необходимо открыть этот файл двойным щелчком мыши. В появившемся окне нажать кнопку OK. Все настройки автоматически будут применены (добавлены в системный реестр Windows).

Мастер состоит из следующих шагов:

  • Задание файла
  • Выбор настроек для сохранения
  • Выбор баз данных
  • Сохранение настроек


Задание файла

На первом шаге необходимо задать имя файла, в который будут сохранены настройки и путь к нему.

Save Settings - Specifying destination file

В поле Filename с помощью кнопки btnSaveAs, в открывшемся стандартном диалоговом окне укажите имя и адрес создаваемого файла.

Следующий шаг


Выбор настроек для сохранения

Отметьте флажками те настройки, которые необходимо сохранить.

Save Settings - Selecting settings

CheckBox Database Registration Info - Регистрационная информация баз данных

CheckBox Tabs - Вкладки

CheckBox Environment Options - Настройки окружения

CheckBox Editor Options - Настройки редакторов

CheckBox Keyboard Templates - Шаблоны клавиатуры

CheckBox Object Templates - Шаблоны объектов

CheckBox External Tools - Внешние инструменты

CheckBox Form placement - расположение открытых окон

CheckBox MRU lists - Списки недавно использовавшихся объектов

Следующий шаг


Выбор баз данных

На этом шаге необходимо выбрать те базы данных, для которых нужно сохранить регистрационную информацию и настройки.

В списке Available Databases находятся доступные базы данных.

Выберите из списка те, для которых необходимо сохранить регистрационную информацию и настройки и переместите их в список Selected Databases с помощью кнопок или перетащите объект из одного списка в другой.

Save Settings - Selecting databases

Следующий шаг


Сохранение настроек

Нажмите кнопку Run для начала создания файла настройки

Save Settings - Saving settings - Completed

Процесс создания отображается в специальном окне.

В текстовом поле отображается выполнение сохранения.

В текстовом поле отображается отчет о каждом шаге проделанной операции.

Если установлен флажок Close the Wizard, то Мастер сохранения настроек закроется после того, как Вы нажмете кнопку Close в этом окне. Если не установлен, то, не закрывая мастера, можно изменить настройки сохранения.


Локализация

SQL Manager for PostgreSQL позволяет изменять язык интерфейса программы для удобства пользователей. Чтобы изменить это свойство необходимо:

Изменение языка программы

  • выбрать Options | Select Program Language в главном меню программы,
  • выбрать нужный язык интерфейса в окне выбора,
  • нажать OK для сохранения изменений.

Редактирование локализации программы

  • откройте любое окно программы, в котором хотите изменить заголовок или название элементов управления,
  • нажмите Shift+Ctrl+L, чтобы открыть окно редактора локализаций,
  • измените текст по своему усмотрению,
  • сохраните изменения, используя кнопку Save в окне редактирования локализации.

Важно: Локализацию можно изменить только в том случае, если она установлена и не является локализацией по умолчанию. Установить локализацию можно с помощью инструмента Environment Options | Localization.

Создание новой локализации

Чтобы создать новую локализацию необходимо:

  • создать новый файл локализации с расширением *.lng и поместить его в папку Languages в директории, в которой установлен SQL Manager for PostgreSQL,
  • выбрать Options | Environment Options в главном меню программы,
  • открыть вкладку Environment Options | Localization,
  • на этой вкладке нажать кнопку Add,
  • в появившемся окне в поле Language name указать название новой локализации, а в поле Language File указать путь до созданного *.lng файла,
  • после нажатия кнопки OK в списке локализаций появится новый язык, который можно применить к интерфейсу программы.

Смотрите также:

Локализация


Редактор локализаций

Редактор локализаций позволяет изменять любые заголовки, надписи, названия элементов и подсказки в программе SQL Manager for PostgreSQL, но только в том случае если этот язык не является локализацией по умолчанию.

Чтобы изменить названия элементов управления любого окна или редактора программы необходимо открыть это окно и нажать Shift+Ctrl+L.

Localization - Localization Editor

В появившемся окне редактора локализаций до знака "=" прописаны названия элементов управления, а после знака "=" - названия этих же элементов, но на языке выбранной локализации. Изменять можно только то, что написано после знака "=".

Для удобства работы с редактором предусмотрено использование стандартного диалогового окна поиска, открывающегося при нажатии клавиш Ctrl+F.

Чтобы сохранить внесенные изменения, нажмите кнопку Save на панели инструментов.

Смотрите также:

Выбор языка программы


Выбор языка программы

Это диалоговое окно позволит Вам выбрать язык локализации программы SQL Manager for PostgreSQL.

Открыть это окно можно, выбрав Options | Select Program Language в главном меню программы. или на вкладке Localization диалогового окна Environment Options.

В списке представлены все доступные языки программы, установленные с помощью Environment Options | Localization.

Localization - Select Program Language

Смотрите также:

Редактор локализаций


Шаблоны клавиатуры

С помощью инструмента Keyboard Templates задайте шаблоны для быстрого ввода текста.

Чтобы открыть редактор шаблонов клавиатуры выберите в главном меню пункт Options | Keyboard Templates.

Чтобы создать шаблон нажмите на кнопку Add Template. В появившемся окне укажите последовательность символов, которая должна будет при вводе замениться определенным текстом.

Чтобы изменить уже созданный шаблон выделите его в общем списке и нажмите кнопку Edit Template. Нажав на кнопку Delete Template, Вы удалите выбранный шаблон.

CheckBox Если установлен флажок Old Style, то в тексте шаблона будут использоваться обозначения, использовавшиеся в более ранних версиях SQL Manager for PostgreSQL.

В разделе Expansion укажите тот текст, которым должен быть заменен набор символов шаблона.

С помощью кнопок можно вставить автотекст.

  • Cursor - позиция курсора, при применении курсор будет переведен в указанное место.
  • Author - имя учетной записи.
  • Time - время редактирования.
  • Date - дата редактирования.
  • Clipboard - содержимое буфера обмена.
  • Marker - маркер.

Также, в разделе Case of Templates, можно указать регистр, в котором должно вводиться сочетание символов, являющееся шаблоном.

RadioButton As is - оставлять как есть.

RadioButton Uppercase - ВСЕ ПРОПИСНЫЕ.

RadioButton Lowercase - все строчные.

RadioButton First upper - Начинать С Прописных.

Чтобы применить шаблон необходимо в редакторе набрать сочетание символов, указанное в шаблоне, а затем нажать сочетание клавиш Ctrl+J.

Восстановить значения шаблонов, принятые по умолчанию можно, нажав на кнопку By Default.

Смотрите также:

Быстрый код

Сочетания клавиш


Шаблоны объектов

С помощью инструмента Object Templates Вы можете задать шаблон текста, который будет вставлен в создаваемый объект указанного типа.

Чтобы открыть этот инструмент, Вы можете, выбрав пункт главного меню Options | Object Templates.

В дереве объектов выберите нужный тип объекта (View, Function: SQL, C, PL/pgSQL, PL/Tcl, PL/Perl, PL/Python) и задайте его шаблон в области редактора.


Дополнительно

Интерфейс программы

Просмотр DDL

Текстовое описание объекта

Настройка панелей инструментов

Просмотр зависимостей объектов

Маркеры

Шаблоны

Поиск опций

Параметры SSH туннелирования

Параметры HTTP туннелирования

Задание форматов данных

Уникальный идентификатор объекта

Сочетания клавиш

Поддерживаемые форматы файлов

Изменение метаданных

Окно поиска

Назначение прав

Совет дня

Список заданий

SQL Manager Direct

Преобразование скрипта

Смотрите также:

Начало работы

Проводник баз данных

Управление базами данных

Управление объектами базы данных

Управление изменениями

Запросы

Управление данными

Средства импорта и экспорта данных

Инструменты для работы с базой данных

Службы

Персонализация

Как...


Интерфейс программы

Общими особенностями интерфейса программы SQL Manager for PostgreSQL являются:

Главное меню

С помощью главного меню Вы можете получить доступ ко всем инструментам программы и выполнить все действия над объектами базы данных.

Appendix - Program interface - MainMenu

Дополнительно смотрите страницу Настройка панелей управления.

Сплиттеры

Сплиттеры - разделительные полосы между окнами, позволяющие быстро свернуть и развернуть окно.

Для того чтобы свернуть окно достаточно одного нажатия на сплиттер левой кнопкой мыши.

Настройка внешнего вида и действий можно изменить на вкладке Splitters в окне настроек внешнего вида.

Навигационные панели

Почти в каждом редакторе и инструменте отображается навигационная панель. На неё вынесены кнопки, позволяющие выполнять все действия с редактируемым объектом.

Appendix - Program interface - NavBar - Expanded

Набор инструментов на панели зависит от того, какая вкладка редактора в настоящий момент активна.

Для большего удобства навигационные панели можно сворачивать.

Чтобы свернуть некоторый раздел навигационной панели нужно нажать на кнопку, находящуюся рядом с названием раздела.

Свернутую панель можно развернуть, нажав на эту же кнопку [image] [image].

Appendix - Program interface - NavBar - Collapsed

Важно: Изменить настройки навигационных панелей Вы можете на вкладке Navigation bar инструмента Visual Options.

Большая часть инструментов Навигационной панели доступна на Панели инструментов.

Панели инструментов

Панель инструментов - строка или столбец, с вынесенными на него кнопками, позволяющими совершать, практически, все операции с открытым объектом.

Appendix - Program interface - Toolbar

Все инструменты навигационной панели доступны на панели инструментов. Панель инструментов - ToolBar - расположена в верхней части окна. Чтобы её активировать, необходимо на вкладке Windows в Environment Options выбрать RadioButton Toolbar или RadioButton Both.

RadioButton Toolbar выберите, если хотите, чтобы отображалась только панель инструментов, а RadioButton Both - если хотите, чтобы отображались обе панели.

Важно: Вы можете переместить панель инструментов в любое удобное для вас место.

Дополнительно смотрите страницу Настройка панелей управления.

Индикатор прогресса

Во время длительного выполнения некоторых процессов в нижней части окна программы SQL Manager for PostgreSQL появляется индикатор прогресса, в котором в процентах отображается выполнение операции.

Панель инкрементного поиска

Эта панель доступна на панели статуса некоторых инструментов SQL Manager.

Вы можете вызвать эту панель, используя сочетание клавиш Ctrl+I. В поле поиска введите искомое сочетание символов, и на форме открытого инструмента встречающееся искомое сочетание будет выделено другим цветом.


Просмотр DDL

На вкладке DDL Вы можете просмотреть SQL-скрипт метаданных объекта. Текст на этой вкладке нельзя редактировать. Если хотите изменить текст, то скопируйте текст в буфер обмена и вставьте его в Query data или Execute Script Editor.

Appendix - Viewing DDL structure


Текстовое описание объекта

На вкладке Description Вы можете ввести текстовое описание редактируемого объекта.

Внесенные изменения вступят в силу только при переходе на другую вкладку, при выборе другого объекта или при нажатии кнопки Save description на одной из панелей инструментов.

Appendix - Editing object description

Внесенные изменения можно сохранить, нажав Save description на Панели инструментов. Если изменения не сохранены, то при переходе на другую вкладку редактора появится диалоговое окно, в котором программа запросит подтверждение сохранения изменений в тексте описания или откат этих изменений.


Настройка панелей инструментов

Любую панель инструментов можно настроить.

Её можно настраивать, используя функцию Add or Remove Buttons, открывающуюся при нажатии на кнопку More Buttons btnMoreButtons в правом углу панели.

В появившемся окне выбираете те кнопки, которые нужны Вам для работы.

Нажав на любую панель управления правой кнопкой мыши и выбрав пункт Customize.

Если на панели инструментов нажать правой кнопкой мыши, то тоже появится кнопка Customize.

При нажатии на эту кнопку открывается окно редактирования панели инструментов.

Вкладка Toolbars

Appendix - Customize - Toolbars

На этой вкладке можно создавать, редактировать и удалять панели инструментов.

New - добавить панель инструментов,

Rename - переименовать,

Delete - удалить.

Вкладка Commands

На этой вкладке выберите кнопки, которые будут отображаться на панели инструментов.

Appendix - Customize - Commands

В списке Categories выберите категорию, а в списке Commands - команду, относящуюся к выбранной категории.

Чтобы поместить нужную кнопку на панель её нужно перетащить из списка Commands на панель инструментов.

Вкладка Customize

Appendix - Customize - Options

CheckBox Menus show recently used command first - всегда показывать полные меню.

CheckBox Show full menus after a short delay - показывать полные меню после небольшой задержки.

Reset my usage data - сброс.

CheckBox Large icons - крупные значки.

CheckBox Show ToolTips on Toolbars - отображать подсказки для кнопок.

CheckBox Show shortcut keys in ToolTips - включить в подсказки сочетания клавиш.

Menu animations - анимация при выборе меню.


Просмотр зависимостей объектов

В редакторах объектов вкладка Dependencies позволяет просматривать зависимости объектов.

В правой части окна - те объекты, на которые ссылается редактируемый объект.

В левой - те объекты, которые ссылаются на открытый в редакторе объект.

В нижнем окне Вы можете просмотреть DDL выделенного объекта.

Appendix - Browsing object dependencies

Любой объект можно открыть в соответствующем редакторе двойным щелчком мыши.

Во время построения дерева зависимостей внизу отображается индикатор прогресса

Смотрите также:

Дерево зависимостей


Маркеры

Маркеры предназначены для навигации по тексту. Необходимо установить курсор в нужное место и нажать клавишу F2, В этом месте появляется маркер. Теперь при нажатии клавиши Esc курсор возвращается на указанную метку. Метки организованы по принципу стека LIFO.


Шаблоны

В SQL Manager for PostgreSQL для некоторых операций предусмотрена возможность сохранения последовательности действий и параметров в специальных файлах, которые называются шаблоны. Используются шаблоны в мастерах. Например, в мастере экспорта данных или импорта данных и т.п.

Если в мастере в левом нижнем углу расположена кнопка Template, то все параметры, указанные с помощью мастера можно сохранить в файл соответствующего формата. Для каждого мастера предусмотрен специальный формат шаблона. Это позволяет избежать ошибок при открытии шаблона в другом мастере.

При нажатии на кнопку Template открывается список действий.

Using templates - menuTemplates

С помощью этого списка можно:

  • загрузить шаблон - Load Template,
  • сохранить шаблон - Save Template,
  • открыть шаблон заново - Reopen Template.

Сохранять и загружать шаблон можно на любом шаге мастера.


Поиск опций

С помощью этого инструмента Вы можете найти опции программы по их названию.

Поиск осуществляется для каждого диалогового окна настроек, в котором существует вкладка Find Option. Выбор производится только из опций, относящихся к данному диалоговому окну.

Find Option dialog

Сочетание символов, содержащееся в названии опции, введите в поле Option.

Все опции, в названии которых встречается искомое сочетание символов, выводятся в списке.

В поле Available Options отображается название найденных опций. В поле Option Kind отображается раздел, к которому относится указанная функция.

Вкладка, на которой расположена искомая функция, показана в поле Category. Группа элементов управления, к которой относится искомая опция, отображается в столбце Group.

Чтобы перейти к искомой опции, выберите нужную опцию из списка и нажмите кнопку Show Option или два раза нажмите мышкой на нужной опции в общем списке.

После этого будет совершен переход на вкладку, на которой эта опция находится, а сама опция будет обозначена символом iconFindOption.


Добавление параметров

Данный диалог появляется при редактировании или добавлении параметра сервера.

Parameter name

Выберите имя параметра из списка.

Value

В этом поле вы можете изменить значение параметра.

Parameter info

Дополнительная информация о параметре.

Description

Поле комментария к текущему параметру.

Appendix - Add parameter

Для получения дополнительной информации обратитесь к официальной документации по серверу.


Параметры SSH туннелирования

SSH (Secure Shell Host) протокол используется для повышения компьютерной безопасности при работе Unix-системами в Internet. SSH использует несколько алгоритмов шифрования разной степени надежности. Распространенность SSH связана еще и с тем, что многие Linux-подобные ОС (например, FreeBSD) включают в стандартную комплектацию SSH сервер. Для получения дополнительной информации Вы можете посетить http://openssh.org. Опция SHH туннель в SQL Manager представляет собой средство организации безопасного доступа к PostgreSQL серверам при работе по небезопасным каналам связи. Также Вы можете использовать SSH туннель для доступа к удаленным PostgreSQL серверам, если по каким-либо причинам порт 3306 закрыт для внешних подключений. Соединение через SSH туннель выглядит следующим образом. Сначала устанавливается соединение и производится процедура аутентификации между встроенным в SQL Manager for PostgreSQL SSH клиентом и удаленным SSH сервером, затем вся исходящая и входящая информация между программой и PostgreSQL сервером передается через SSH сервер с использованием коммуникационного порта (обычно 22), а SSH сервер транслирует информацию уже непосредственно PostgreSQL серверу. Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием SSH туннеля, Вы должны задать следующие параметры при регистрации базы данных в PostgreSQL:

SSH Host - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH Port - порт SSH сервера на удаленном хосте (по умолчанию равен 22).

SSH User Name - имя пользователя на сервере (пользователь SSH сервера, а не сервера PostgreSQL).

SSH Password - идентификационная фраза (passphrase) пользователя SSH сервера.

Имейте в виду, что в случае использования SSH туннелирования имя хоста PostgreSQL должно быть задано относительно сервера SSH. Например, если PostgreSQL и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.

Appendix - SSH tunneling options

CheckBox Если установлен флажок Use Private Key for authentication, то в поле SSH key file можно указать ключевой файл для аутентификации.

SSH Key file

SSH Private Key - Passphrase

В этом поле укажите путь к Private key файлу, находящемуся на локальном компьютере.

Допустимые форматы Private Key файла:

OpenSSH

Putty

SSH.com


Параметры HTTP туннелирования

HTTP туннелирование - это способ, при котором соединение и передача данных между программой и PostgreSQL сервером происходит через протоколы HTTP/HTTPS, используя порт 80, через который работает обычный веб-браузер. Этот способ подходит для соединения с PostgreSQL, расположенным на удаленным сервере хостинг провайдера, когда прямое соединение невозможно из соображений безопасности. Соединение через HTTP туннель выглядит следующим образом: все исходящие запросы и команды с клиентских программ кодируются и передаются по протоколу HTTP/HTTPS, используя порт 80, специальному скрипту, который декодирует их и передает PostgreSQL серверу на обработку, и возвращает обратно результат. Для использования этого способа на удаленном сервере должен быть установлен HTTP сервер (например, Apache) и PHP с подключенным расширением PostgreSQL. Как правило, это программное обеспечение предлагают все хостинг-провайдеры, предоставляющие услуги хостинга на Linux платформах. Кроме того, Вы должны разместить наш emsproxy.php скрипт на вашем веб-сервере так, чтобы иметь к нему доступ извне (например, поместить его в каталог, где находятся ваши остальные PHP скрипты). Если ваш веб-сервер удовлетворяет данным требованиям и скрипт установлен правильно, то при открытии http://<your_webserver_name>/emsproxy.php в веб-браузере Вы увидите “EmsProxy v1.31” (версия может меняться). Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием HTTP туннеля, Вы должны задать следующие параметры в Мастере Регистрации Баз Данных в SQL Manager for PostgreSQL:

Appendix - HTTP tunneling options

URL - это адрес, где находится скрипт emsproxy.php (например, http://webserver_name/emsproxy.php).


Задание форматов данных

Форматы данных определяют вид данных разных типов.

Форматы Float/Integer

0 | Цифра от 0 до 9
# | Символ разряда. If the value being formatted has a digit in the position where the '#' appears in the format string, then that digit is copied to the output string. Otherwise, nothing is stored in that position in the output string.
. | символ, отделяющий десятичную часть
, | разделитель групп разрядов
E+ | экспоненциальное представление.

Форматы Date/Time format

с помощью следующих команд Вы указываете какую часть даты и в каком виде нужно отображать.

c | Отображает дату, используя краткий формат даты.
d | День отображается в виде числа от 1 до 31 без нулевого старшего разряда.
dd | День отображается в виде числа от 01 до 31 с нулевым старшим разрядом.
ddd | День отображается в виде аббревиатуры (Sun-Sat).
dddd | Отображается полное название дня недели (Sunday-Saturday).
ddddd | Отображать краткий формат.
dddddd | Использовать полный формат даты.
m | Отображать месяц в виде числа без нулевого старшего разряда (1-12).
mm | Отображать месяц в виде числа с нулевым старшим разрядом (01-12)
mmm | Отображать месяц в виде аббревиатуры (Jan-Dec).
mmmm | Отображать полное название месяца (January-December).
yy | Отображать год в виде последних двух цифр (00-99).
yyyy | Отображать год в четырех цифр (0000-9999).
h | Отображать час в виде числа без нулевого старшего разряда (0-23).
hh | Отображать час в виде числа с нулевым старшим разрядом (00-23).
n | Отображать минуты в виде числа без нулевого старшего разряда (0-59).
nn | Отображать минуты в виде числа с нулевым старшим разрядом (00-59).
s | Отображать секунды в виде числа без нулевого старшего разряда (0-59).
ss | Отображать секунды в виде числа с нулевым старшим разрядом (00-59).
z | Отображать миллисекунды в виде числа без нулевого старшего разряда (0-999).
zzz | Отображать миллисекунды в виде числа с нулевым старшим разрядом (000-999).
t | Отображать время используя Short Time Format.
tt | Отображать время используя Long Time Format.
a/p | Использовать двенадцатичасовой формат даты с префиксом a/p.
am/pm | Использовать двенадцатичасовой формат даты с префиксом am/pm.
/ | Использовать этот разделитель даты (mm/dd/yy).
: | Использовать этот разделитель времени (hh:mm).
'xx'/"xx" | Символы, заключенные в одинарные или двойные кавычки не подлежат форматированию.


Уникальный идентификатор объекта

Идентификатор объекта (ID объекта) какой-либо строки. Этот столбец существует только если таблица была создана с использованием WITH OIDS или если была установлена конфигурационная переменная default_with_oids. Тип этого столбца — oid (имя типа такое же как и имя столбца);


Сочетания клавиш

Управление базами данных

Shift+Alt+R | Зарегистрировать базу данных с помощью Мастера регистрации баз данных
Shift+Alt+U | Удалить регистрацию выбранной базы данных
Shift+Ctrl+C | Подключиться к базе данных
Shift+Ctrl+D | Отключиться от базы данных

Управление объектами баз данных

Ctrl+N | Создать новый объект.
Ctrl+O | Открыть выбранный объект в соответствующем редакторе
Ctrl+R | Переименовать выбранный объект
Shift+Del | Удалить выбранный объект
Ctrl+Shift+C | Свернуть текущую ветвь в Проводнике баз данных
Ctrl+H | Редактор функций и

Инструменты SQL Manager

F11 | Открыть/закрыть Проводник баз данных
Ctrl+F | Открыть окно поиска в Проводнике баз данных
Shift+Ctrl+T | Открыть список заданий
F12 | Открыть Редактор получения данных
Shift+F12 | Создать новый запрос в Редакторе получения данных
Shift+Ctrl+M | Открыть Монитор SQL
Shift+Ctrl+S | Открыть Редактор выполнения скриптов
Shift+Ctrl+L | Открыть Редактор локализаций
Ins | Добавить новый подобъект в таблицу (Тип подобъекта определяется открытой вкладкой редактора)
Ctrl+Ins | Добавить параметр в Редакторе функций
Ctrl+Del | Удалить параметр в Редакторе функций

Работа с редактором получения данных и редактором выполнения скриптов

F9 | Выполнить запрос/скрипт
Alt+F9 | Выполнить только выделенную часть кода
Ctrl+Alt+F9 | Выполнить ту часть кода, на которой стоит курсор
Ctrl+Alt+F2 | Удалить контрольную точку (Только для Редактора получения данных)
Shift+Ctrl+<digit> | Установить закладку #<digit>
Ctrl+<digit> | Перейти к закладке #<digit>
Ctrl+Q,N | Перейти к следующей закладке
Ctrl+Q,P | Перейти к предыдущей закладке
F2 | Поставить маркер на текущую позицию
Esc | Убрать маркер (вернуться назад)
Shift+Esc | Заменить маркер (сохранить позицию, вернуться назад)
Ctrl+Z; Alt+BkSp | Отменить
Shift+Ctrl+Z; Shift+Alt+BkSp | Вернуть
Ctrl+F | Открыть окно поиска
Ctrl+R | Найти и заменить
F3 | Продолжить поиск
Ctrl+I | Начать инкрементный поиск
Alt+G | Перейти к строке под номером. Номер введите в появившемся диалоговом окне.
Ctrl+L | Загрузить скрипт из внешнего файла
Ctrl+S | Выгрузить скрипт во внешний файл
Shift+Ctrl+F | Форматировать текст SQL с помощью Форматтера SQL
Alt+<symbol> | Перейти к запросу с символом <&symbol> в имени (только для Редактора получения данных)
Ctrl+J | Вставить шаблон клавиатуры
Ctrl+D | Переключение режимов отображения результатов запроса (на вкладке Edit или на отдельной вкладке)
Ctrl+Alt+Left | Перейти к следующей вкладке Редактора получения данных
Ctrl+Alt+Right | Перейти к предыдущей вкладке Редактора получения данных
Ctrl+Alt+PgUp | Перейти к последней вкладке Редактора получения данных
Ctrl+Alt+PgDown | Перейти к первой вкладке Редактора получения данных
Ctrl+Q,S | Переместить курсор на начало строки
Ctrl+Q,D | Переместить курсор в конец строки
Ctrl+Q,R | Переместить курсор в начало текста
Ctrl+Q,C | Переместить курсор в конец текста
Ctrl+O,N | Обычный режим выделения
Ctrl+O,L | Построчный режим выделения
Ctrl+O,C | Выделение по столбцам
Shift+Ctrl+Left | Выделить символы до предыдущего слова
Shift+Ctrl+Right | Выделить символы до следующего слова
Shift+Home | Выделить текст до начала строки
Shift+End | Выделить текст до конца строки
Shift+PageUp | Выделить текст до начала страницы
Shift+PageDown | Выделить текст до конца страницы
Shift+Ctrl+PageUp | Выделить текст до первой строки на странице
Shift+Ctrl+PageDown | Выделить текст до последней строки на странице
Shift+Ctrl+Home | Выделить текст до начала
Shift+Ctrl+End | Выделить текст до конца
Shift+Alt+Left | Выделить колонку символа слева
Shift+Alt+Right | Выделить колонку символа справа
Shift+Alt+Up | Выделить колонку на строку вверх
Shift+Alt+Down | Выделить колонку на строку вниз
Shift+Ctrl+Alt+Left | Выделить колонку слова слева
Shift+Ctrl+Alt+Right | Выделить колонку слова справа
Shift+Alt+Home | Выделить колонку до начала строки
Shift+Alt+End | Выделить колонку до конца строки
Shift+Alt+PageUp | Выделить колонку на страницу вверх
Shift+Alt+PageDown | Выделить колонку на страницу вниз
Shift+Ctrl+Alt+Home | Выделить колонку до самого начала
Shift+Ctrl+Alt+End | Выделить колонку до самого конца
Ctrl+Up | Прокрутить страницу вверх на строку, не меняя позиции курсора
Ctrl+Down | Прокрутить страницу вниз на строку, не меняя позиции курсора
Alt+Down, Alt+Up | Переключить регистр слова
Ctrl+Alt+Up | Сменить регистр текущего или выделенного символа на верхний
Ctrl+Alt+Down | Сменить регистр текущего или выделенного символа на нижний
Ctrl+G,Ctrl+T | Включить/отключить сворачивание блоков
Ctrl+G,Ctrl+F | Свернуть блок в текущей строке
Ctrl+G,Ctrl+E | Развернуть блок на текущей строке
Ctrl+G,Ctrl+C | Свернуть/развернуть блок на текущей строке
Ctrl+G,Ctrl+M | Свернуть все блоки в тексте
Ctrl+G,Ctrl+P | Развернуть все свернутые блоки в тексте
Ctrl+= | Свернуть/развернуть ближайший блок
Shift+Ctrl+B | Перейти к закрывающей/открывающей скобке
Shift+Ctrl+I | Сместить выделенный блок
Shift+Ctrl+U; Shift+Tab | Убрать отступ выделенного блока
Ctrl+/ | Закомментировать/раскомменитровать выделенные строки
Ctrl+Space | Автозаполнение кода
Ctrl+Alt+Space | Показать таблицу символов
Ctrl+Shift+Space | Показать параметры кода
Ctrl+Alt+Q | Show columns
Ctrl+Alt+T | Show tables
Ctrl+Alt+V | Show views
Ctrl+Alt+U | Show functions
Ctrl+Alt+J | Show domains
Ctrl+Alt+G | Show triggers
Ctrl+Alt+X | Show indices
Ctrl+Alt+S | Show sequences
Ctrl+Alt+M | Show composite types
Ctrl+Alt+E | Show enum types
Ctrl+Alt+Y | Show base types
Ctrl+Alt+A | Show aggregates
Ctrl+Alt+O | Show operators
Ctrl+Alt+N | Show collations
Ctrl+Alt+L | Показать языки описания процедур
Ctrl+Alt+P | Показать табличные пространства
Alt+End | Пропустить опечатку
Ctrl+Alt+End | Пропустить все опечатки
Alt+Home | Исправить все опечатки
F5 | Добавить точку останова в текущей строке
Shift+F5 | Переключить точку останова

Работа с отчетами

Ctrl+O | Загрузить отчет из файла
Ctrl+S | Сохранить отчет в файл
Ctrl+P | Открыть диалоговое окно Print
Ctrl+Home | Перейти к первой странице
Ctrl+Up | Перейти к предыдущей странице
Ctrl+Down | Перейти к следующей странице
Ctrl+End | Перейти к последней странице
Ctrl+D | Открыть Настройщик отчетов
Ctrl+\ | Масштаб 100%
Ctrl+0 | Масштаб по ширине страницы
Ctrl+1 | Целая страница
Ctrl+2 | Две страницы
Ctrl+4 | Четыре страницы
Ctrl+W | Выровнять по ширине
Ctrl+M | Отобразить/скрыть поля
Ctrl+K | Задать цвет фона для отчета

Работа с окнами и вкладками

Ctrl+Tab | Перейти к следующей вкладке
Ctrl+Alt-0 | Открыть список окон
Ctrl+Alt+D | Задать значения по умолчанию для всех окон
Ctrl+F6 | Перейти к предыдущему окну
F6 | Перейти к следующему окну
Ctrl+W | Закрыть активное окно


Поддерживаемые форматы файлов

RadioButton MS Excel 97-2003

Наиболее популярный формат файлов для хранения электронных таблиц, разработанный Microsoft.

(*.xls)

RadioButton MS Access

Файл этого формата представляет собой базу данных Access, с возможностью использования ADO connection.

(*.mdb, *.accdb)

RadioButton MS Word 97-2003

Наиболее популярный формат текстовых документов, разработанный Microsoft.

(*.doc)

RadioButton RTF

Межплатформенный формат хранения размеченных текстовых документов, предложенный Microsoft. RTF-документы поддерживаются большинством современных текстовых редакторов.

(*.rtf)

RadioButton HTML

(от англ. Hypertext Markup Language — «язык разметки гипертекста»)

Формат для отображения web страниц

(*.html, *.htm)

RadioButton PDF

Межплатформенный формат электронных документов, предназначен для представления в электронном виде полиграфической продукции.

(*.pdf)

RadioButton Text file

Текстовый файл

(*.txt)

RadioButton CSV

(от англ. Comma Separated Values — значения, разделенные запятыми)

Текстовый формат, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом (delimiter), например, запятой (,), точкой с запятой(;), символом табуляции. Текстовые значения обрамляются символом двойные кавычки ("); если в значении встречаются кавычки — они представляются в файле в виде двух кавычек подряд.

(*.csv)

RadioButton DIF

Стандарт для файлов обмена данными

(*.dif)

RadioButton SYLK

Формат Символической Связи.

(*.slk)

RadioButton LaTeX

Специфический формат файлов макрорасширений к TeX.

(*.tex)

RadioButton XML

Расширяемый язык разметки. Предназначен для хранения структурированных данных

(*.xml).

RadioButton DBF

Формат хранения данных, используемый в качестве одного из стандартных способов хранения и передачи информации системами управления базами данных, электронными таблицами и т.д.

(*.dbf)

RadioButton MS Excel

Разработанный Microsoft формат файлов для хранения электронных таблиц. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.xlsx)

RadioButton MS Word

Разработанный Microsoft формат файлов для хранения электронных документов. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.docx)

RadioButton ODF Spreadsheets

Открытый формат файлов документов для хранения и обмена редактируемыми офисными документами - электронными таблицами.

(*.ods)

RadioButton ODF text

Открытый формат файлов документов для хранения и обмена редактируемыми текстовыми офисными документами

(*.odt)


Изменение метаданных

В SQL Manager for PostgreSQL существует специальный инструмент, с помощью которого можно выявить ошибки и проследить выполнение SQL скрипта изменения метаданных.

Appendix - Changing Metadata window

Окно изменения метаданных по умолчанию появляется всегда, когда производится изменение метаданных. Если Вы хотите, чтобы оно появлялось только тогда, когда при исполнении будут обнаружены ошибки, то отключите флажок Confirm metadata changing на вкладке Confirmations в Options | Environment Options или установите флажок CheckBox Don't show this window on success.

Если включен контроль управления изменениями, то для окна изменения метаданных появляются дополнительные элементы управления.

Comment for Change Management

В этом поле можно задать комментарий для транзакции. Это позволит упростить поиск нужной транзакции при просмотре истории изменений.

Log to VC

Из раскрывающегося списка необходимо выбрать, следует ли добавлять транзакции в журнал контроля версий.

Always - всегда добавлять.

Only if script changes objects - добавлять только в том случае, если скрипт меняет объекты.

Log only statements that change objects - вносить в журнал только операторы изменяющие объекты.

Важно: Эта опция активна тогда, когда включен контроль управления изменениями.

В главном окне - Compile SQL - показан SQL скрипт, который был сгенерирован в результате изменения метаданных. В этом окне Вы можете его редактировать по своему усмотрению. Если скрипт содержит ошибки, то тогда становится видна область Error, в которой показано описание возникших при компиляции ошибок.

Оператор, который отображается в окне, уже выполнен в запущенной транзакции на изменение метаданных.

Применить эту транзакцию можно с помощью кнопки Commit, которая активна только в случае, если скрипт был выполнен успешно (т.е. транзакция может быть применена). Если Вы не хотите применять изменения, то воспользуйтесь кнопкой Rollback, которая откатит текущую транзакцию.

Если в операторе есть ошибки, то кнопка Commit будет недоступна. В этом случае необходимо исправить все ошибки и нажать кнопку Rollback and Recompile, которая применит внесенные Вами изменения.

Текст операторов и описание ошибок можно полностью скопировать в буфер обмена с помощью кнопки Copy information to clipboard.


Окно поиска

В поле Text to Find укажите искомую последовательность символов или выберите одну з предыдущих.

Options

CheckBox Case Sensitive

При поиске учитывать регистр.

CheckBox Whole words only

Учитывать слово целиком.

CheckBox Regular Expressions

Если отмечена эта опция, то введенный текст будет распознаваться как регулярное выражение.

Например, если Вы введете "empl*", то будет произведен поиск по метаданным всех строк, содержащих подстроку "empl". При вводе "^emp" результатом поиска будут объекты, в метаданных которых есть строки, начинающиеся на "emp", а при поиске

"^emp|emp$" - строки, содержащие "emp" в начале или конце строки.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в поле Text to find, соответствует синтаксису регулярных выражений языка Perl. Более подробная информация может быть найдена по ссылке: http://perldoc.perl.org/perlre.html#Regular-Expressions.

В разделе Direction укажите направление поиска:

RadioButton Forward - вниз,

RadioButton Backward - вверх.

Scope

RadioButton Global - искать во всем тексте.

RadioButton Selected text - искать только в выделенном тексте.

Origin

RadioButton From cursor - поиск начинается с того места где стоит курсор.

RadioButton Entire scope - поиск с начала текста.

CheckBox Mark search result with stack marker

Отмечать найденный текст маркером.

Find in metadata

На этой вкладке можно задать параметры поиска по метаданным.

Из раскрывающегося списка Database можно выбрать базу данных, в которой будет производиться поиск.


Назначение прав

В главном окне расположена таблица, в которой строки - это группы и пользователи базы данных, а столбцы - действия, выполняемые над объектами. Для каждого объекта предоставляется разный набор действий для которых можно задавать права.

Appendix - Setting object permissions

Права на выполнение того или иного действия можно менять тремя способами:

  • с помощью контекстного меню, которое появляется при нажатии правой кнопкой мыши на ячейку.
  • двойным щелчком мыши (при использовании этого метода помните, что смена прав идет в такой последовательности - Grant->Revoke).
  • с помощью одинарного нажатия на активную (выделенную ячейку). При этом появляется раскрывающийся список, из которого можно выбрать один из типов прав.

Grant - Предоставить права на выполнение данного действия,

Revoke - отменить привилегии,

Grant with GRANT OPTION - Предоставить с правами 'GRANT'.

Контекстное меню открывается при нажатии на ячейку области таблицы и позволяет присваивать права на объект.

Grant - предоставить права,

Grant with GRANT OPTION - предоставить с правами 'GRANT',

Revoke - отменить привилегии,

Grant All - предоставить права на все действия для выделенного объекта,

Grant with GRANT OPTION All - предоставить с правами 'GRANT' на все действия для выделенного объекта,

Revoke All - запретить все действия для выделенного объекта,

Grant on All - предоставить права на это действие для всех объектов,

Grant with GRANT OPTION on All - предоставить с правами 'GRANT' на это действие для всех объектов,

Revoke on All - запретить это действие для всех объектов.


Список заданий

Инструмент To-Do List позволяет создавать список задач базы данных. Чтобы открыть этот список выберите в главном меню пункт View | To-Do List.

Чтобы добавить в список новую задачу нажмите кнопку Add Item на одной из панелей управления или выберите пункт Add Item в контекстном меню.

Appendix - To-Do List

Для создания откроется окно редактора заданий.

Appendix - To-Do List - Edit To-Do item

В поле Text задаете описание задачи.

С помощью счетчика Priority задайте приоритет задачи.

В поле User Name укажите пользователя для которого предназначена эта задача.

В поле Category можно задать категорию создаваемой или редактируемой задачи.

Нажмите кнопку OK чтобы добавить задачу в общий список.

Открыть для редактирования уже созданную задачу можно нажав на ней два раза мышью, или выбрать пункт Edit Item на одной из панелей инструментов или выбрав пункт Edit Item в контекстном меню.

Выбрав на панели инструментов или в контекстном меню пункт Delete Item Вы удалите задачу.

Можно удалить все задачи нажав кнопку Delete All и подтвердив удаление в появившемся окне.

Выберите базу данных для которой создаете задачу из раскрывающегося списка Database на одной из панелей инструментов.

Все инструменты для работы располагаются на панелях инструментов и в контекстном меню, которое открывается при нажатии правой кнопкой мыши на задаче.


SQL Manager Direct

SQL Manager Direct позволит Вам получить быстрый доступ к соответствующим ресурсам Интернета и загрузить последнюю версию SQL Manager.

Чтобы открыть SQL Manager Direct выберите пункт Help | SQL Manager Direct в главном меню программы.

При открытии SQL Manager Direct и/или нажатии кнопки Update происходит проверка наличия обновлений SQL Manager на сервере EMS Database Management Solutions, Inc.

Ссылки на ресурсы sqlmanager.net объединены в несколько групп:

  • SQL Manager for PostgreSQL News - Новости
  • General Information - Основная информация
  • Downloads - Загрузки
  • Related Products - Сопутствующие продукты

Appendix - SQL Manager Direct

SQL Manager for PostgreSQL News

В этом разделе Вы можете открыть страницу новостей по продукту на сайте sqlmanager.net.

General Information

В этом разделе предлагается ряд ссылок на продукт - Новости, Таблица характеристик, Системные требования и т.д.

Downloads

Используя эту ссылку, Вы можете загрузить SQL Manager последней версии и документацию со страницы загрузки.

Related Products

Этот раздел позволяет вам просматривать список связанных продуктов, разработанных EMS Database Management Solutions, Inc.

Используйте кнопки btnBack btnForward для перемещения между страницами так же, как в веб-броузере.

Нажатие на кнопку Update позволит обновить программу.

Если существует более новая версия SQL Manager, то отобразится диалоговое окно, сообщающее о наличии новой версии. С его помощью Вы можете сразу загрузить эту версию с сервера.

Appendix - SQL Manager Direct - Question

После загрузки и установки SQL Manager будет перезапущен.

CheckBox Automatically poll network in interval (in days)

Если установлен этот флажок, то страница будет обновляться автоматически через указанное в соответствующем поле число дней. В Lite версии эту опцию отключить нельзя.

Важно: Корректность отображения данной страницы зависит от настроек подключения к интернету, задаваемых в Панели управления Windows. Если для подключения к интернету используется прокси-сервер, требующий авторизации, то при открытии страницы SQL Manager Direct, или при нажатии кнопки Update появится диалоговое окно, в котором необходимо задать параметры авторизации.


Преобразование скрипта

После завершения операции появляется диалоговое окно, в котором можно выбрать кодировку скрипта, загружаемого в Редактор запросов или Редактор SQL скриптов.

Appendix - Script conversion

RadioButton Windows default - кодировка, используемая в операционной системе по умолчанию.

RadioButton Database default - кодировка, используемая в базе данных по умолчанию.

RadioButton Other encoding - другая кодировка, которая выбирается из общего списка.

Текст в выбранной кодировке Вы можете увидеть в поле Preview.


Как...

В этом разделе содержится краткая информация по основным операциям, которые можно выполнить в программе SQL Manager for PostgreSQL.

Работать с базами данных

Подключиться к базе данных

Создать базу данных

Изменить параметры подключения к базе данных

Ускорить работу с базой данных

Визуально спроектировать базу данных

Посмотреть ER-диаграмму базы данных

Создать копию базы данных

Задокументировать базу данных

Сохранить отчет о метаданных в файл другого формата

Вести журнал изменений метаданных и запросов

Получить SQL-дамп базы данных

Синхронизировать базы данных

Работать с объектами базы данных

Группировать объекты

Найти объект

Посмотреть зависимости объектов

Получить DDL объекта

Работать с данными

Просматривать таблицы с большим количеством записей

Фильтровать данные

Сортировать и группировать данные

Экспортировать/импортировать данные

Экспортировать данные в виде SQL скрипта

Редактировать данные многоуровневых таблиц

Добавить изображение в таблицу

Настроить формат отображения данных

Работать с запросами и скриптами

Быстро создать запрос на получение данных

Контролировать производительность запроса

Работать с несколькими запросами одновременно

Сохранить часто используемые запросы

Выполнять запросы с параметрами

Экспортировать результаты запроса в файл

Выполнять скрипты (сценарии)

Выполнить большой SQL-скрипт

Ускорить работу SQL-скрипта

Работать с текстом запроса/скрипта

Просмотреть все выполненные запросы и скрипты

Управлять изменениями

Включить управление изменениями

Включить контроль версий используя локальный репозитарий

Откатить базу данных до предыдущей ревизии

Посмотреть изменения между ревизиями БД

Посмотреть разницу между ревизиями процедуры

Создать простой отчет в Конструкторе отчетов

Перенести настройки программы

Обновить программу

Сообщить об ошибках и предложениях


Подключиться к базе данных

Чтобы подключиться к незарегистрированной базе данных выполните следующую последовательность действий:

  1. Запустите Мастер регистрации баз данных, выбрав пункт Database | btnRegisterDB Register Database... в главном меню программы.
  2. Если база данных находится на сервере, который еще не был зарегистрирован, то на первом шаге Мастера введите имя этого сервера в поле Server name, если же сервер уже зарегистрирован, то выберите его имя из выпадающего списка. При необходимости настройте SSH туннелирование.

Важно: Если Вы хотите зарегистрировать несколько баз данных сразу, то убедитесь, что не отмечена флажком опция CheckBox Register a single database. В этом случае на следующем шаге выберите базы данных, которые Вы хотите зарегистрировать.

  3. На заключительном шаге Мастера выберите базу данных из выпадающего списка всех баз, находящихся на сервере и установите параметры регистрации.

Зарегистрированная база данных отобразится в Проводнике БД. Чтобы подключиться к ней, дважды щелкните по псевдониму БД или выберите пункт btnConnectToDB Connect to Database из контекстного меню.


Создать базу данных

Чтобы создать базу данных на зарегистрированном сервере выполните следующие действия:

  1. Запустите Мастер создания баз данных, выбрав пункт Database | btnCreateDB Create Database главного меню программы.
  2. На первом шаге задайте имя для новой базы данных.
  3. На втором шаге определите необходимые параметры соединения для новой базы: Host name, Port, User name and Password. При необходимости настройте SSH туннелирование.
  4. Если Вы хотите создать базу данных, которая содержала бы данные другой базы, то на третьем шаге из выпадающего списка Template выберите эту базу.
  5. На последнем шаге просмотрите SQL запрос создания новой базы данных. Если Вы на первом шаге установили флажок CheckBox Register after creating, то после создания базы откроется окно Database Registration Info, в котором можно будет указать регистрационную информацию базы данных.


Изменить параметры подключения к базе данных

Если при создании или регистрирации базы данных была допущена ошибка, или указана неполная информация, то её можно исправить при помощи инструмента Database Registration Info. Регистрационную информацию можно посмотреть как для подключенной, так и для неподключенной базы.

Чтобы посмотреть Регистрационную информацию базы данных, необходимо выбрать базу данных в проводнике баз данных, затем в контекстном меню базы данных или в главном меню программы выбрать пункт btnDBRegistrationInfo Database Registration Info.

На вкладке Connection можно изменить следующие настройки подключения базы данных к серверу: имя сервера (Server name), имя пользователя (User name), пароль (Password), базу данных (Database name), псевдоним базы данных (Database alias) и набор шрифтов (Font charset).


Ускорить работу с базой данных

Если ваша база данных содержит большое количество объектов или, если соединение с сервером слишком медленное, Вы можете ускорить работу с БД отключив опцию CheckBox Refresh objects on connection при регистрации базы данных или при редактировании Регистрационной информации баз данных.

Кроме того, Вы можете отключить опцию CheckBox Restore desktop on connect в Предпочтениях.


Визуально спроектировать базу данных

Чтобы спроектировать БД визуально, можно использовать Конструктор баз данных. Он позволяет создавать, редактировать и удалять таблицы и столбцы, устанавливать связи между таблицами и выполнять другие операции. Все новые объекты отображаются на диаграмме.


Посмотреть ER-диаграмму базы данных

Построение диаграммы отношений происходит с помощью операции Обратного проектирования.

Чтобы просмотреть ER-диаграмму выбранной схемы выполните следующую последовательность действий:

  1. Запустите Конструктор баз данных;
  2. На панели инструментов выберите пункт btnReverseEngineer Reverse Engineer или соответствующий пункт контекстного меню.
  3. Выберите схему для обратного проектирования.


Создать копию базы данных

Чтобы создать копию базы данных или отдельных объектов необходимо выполнить одно из следующих действий:

  1. Извлечь структуру объектов базы данных и сами данные в SQL скрипт используя Мастер извлечения баз данных. Полученный скрипт можно использовать для копирования и восстановления базы данных.
  2. Создать резервную копию БД с помощью Мастера резервного копирования.
  3. Создать копии отдельных объектов используя Мастер копирования объекта.
  4. Создать информацию (полностью или частично) из одной базы данных в другую используя Мастер копирования баз данных.


Задокументировать базу данных

Есть несколько способов документации базы данных:

  1. Вы можете сгенерировать подробный HTML отчет о метаданных объектов выбранной базы данных с помощью Мастера создания HTML отчетов.
  2. Вы можете создать и распечатать отчет о метаданных любого объекта БД. Отчет может быть сохранен в любом из следующих форматов: HTML file, Excel file, Text file, RTF file, CSV file, HTML file, BMP image, Excel table (OLE), JPEG image, TIFF image.
  3. Вы можете сохранить диаграмму, созданную в Визуальном конструкторе баз данных в файл с расширением *.pgd. При необходимости диаграмму можно сохранить как рисунок.


Сохранить отчет о метаданных в файл другого формата

Чтобы сохранить отчет о метаданных в файл другого формата, необходимо:

  1. Открыть инструмент Печать метаданных, выбрав пункт главного меню программы Tools | iconPrint Print Metadata.
  2. Нажать кнопку btnPrintPreview Preview на одной из панелей инструментов.
  3. На панели инструментов просмотрщика выбрать пункт btnPreviewExport Export -> из раскрывшегося списка выбрать формат файла, в который будет произведен экспорт.
  4. В появившемся окне выбрать директорию и указать имя файла.


Вести журнал изменений метаданных и запросов

Если Вы хотите вести журнал изменений метаданных и журнал SQL запросов, то:

  1. Установите флажок CheckBox Enable log of metadata changes и укажите, в какой файл следует записывать изменения.
  2. Установите флажок CheckBox Enable log of Query data queries и укажите, в какой файл сохранять эту статистику.

Задание этих опций происходит в окне Регистрационная информация баз данных | Журналы.


Получить SQL-дамп базы данных

Чтобы получить SQL-дамп (файл с расширением *.sql) базы данных используйте Мастер извлечения баз данных. С его помощью можно извлечь структуру объектов базы данных и сами данные в SQL скрипт. Полученный скрипт можно использовать для копирования и восстановления базы данных.


Синхронизировать базы данных

Синхронизация двух баз данных может быть проведена посредством мастера сравнения баз данных. С его помощью Вы можете сравнить базы и создать скрипт, чтобы перенести изменения с одной базы в другую.

Чтобы запустить Мастер сравнения баз данных, выберите пункт Tools | iconCompare Compare Database в главном меню программы.


Группировать объекты

Объекты можно сгруппировать с помощью вкладок проводника баз данных.

Группировка с помощью вкладок

Поместить объект на отдельную вкладку можно выбрав пункт btnNewTabFromHere New Tab from Here в контекстном меню объекта.

Важно: Если объект не является узлом дерева, то эта опция не доступна.


Найти объект

Чтобы найти нужный объект Вы можете:

  1. Пунктом Find Object контекстного меню проводника или сочетанием клавиш Ctrl + F вызывать стандартное окно поиска, в котором указывается искомое слово.
  2. Введите первые символы искомого слова в поле Search. Все объекты, содержащие искомые символы, будут выделены цветом в проводнике баз данных.

Важно: объекты по которым происходит поиск должны быть обновлены и узел объектов раскрыт.

  3. Запустите операцию поиска по метаданным. Для этого выберите пункт Tools | Search in Metadata в главном меню программы или используйте сочетание клавиш Ctrl+Alt+F. На навигационной панели, в разделе Explorer отобразятся все объекты, в метаданных которых встречается искомое слово и словосочетание.


Посмотреть зависимости объектов

Посмотреть зависимости объектов можно одним из способов:

  1. Используя вкладку Dependencies в редакторе таблиц.
  2. Используя Дерево зависимостей.

Эти инструменты могут быть особенно полезны, когда Вы не можете определить, из-за какого объекты не удаляется таблица.


Получить DDL объекта

Просмотреть DDL объекта можно одним из следующих способов:

  1. Дважды щелкните по объекту, чтобы открыть редактор объекта, затем перейдите на вкладку DDL.
  2. Выберите Script to Query data | Create в контекстном меню объекта.
  3. Выберите Data Manipulation | Export Data as SQL Script в контекстном меню объекта.

Для редактирования DDL объекта можно открыть в редакторе запросов, нажав на панели инструментов btnShowSQLEditor Open DDL in Execute Script.


Просматривать таблицы с большим количеством записей

Если ваша таблица содержит большой объем данных Вы можете уменьшить время ее загрузки посредством:

  1. Задания количества выбираемых записей;
  2. Установления опции RadioButton Load visible records для загрузки фиксированного числа записей в память.

Эти опции могут быть настроены для определенной БД на странице Параметры отображения данных при редактировании Регистрационной информации баз данных.

Настройки по умолчанию для только что зарегистрированной БД могут быть заданы на странице Параметры сетки | Настройки данных в Настройках окружения.


Фильтровать данные

Быстрая фильтрация (по текущему значению в ячейке)

Вызовите контекстное меню для столбца с данными -> выберите пункт контекстного меню Quick Filter -> выберите из открывшегося дочернего меню условие фильтрации.

Фильтрация по столбцам

HowTo - Grid View - Quick Filter

Нажать раскрывающийся список в заголовке столбца -> выбрать из списка условие фильтрации.

Более сложные условия задайте с помощью пункта списка значений Custom...

При выборе этого пункта открывается специальное окно для задания условий фильтрации.

Подробная фильтрация

Нажать кнопку btnSetFilter на панели инструментов просмотрщика данных -> задать параметры отбора в конструкторе фильтров -> применить условия фильтрации, нажав кнопку Apply.

Если для таблицы установлен фильтр, то в нижней её части появляется специальная панель, на которой отображаются условия фильтра и история модификации фильтра, которая открывается при нажатии на раскрывающийся список.

Data View - Grid View - Filtering records - Filtering panel

Убрать фильтрацию

Вызвать контекстное меню для столбца с данными -> выбрать пункт Disable filter.

Нажать кнопку btnClose на панели инструментов фильтра.


Сортировать и группировать данные

Чтобы отсортировать данные необходимо:

Открыть данные на вкладке Data или Results -> выбрать столбец, по которому хотите отсортировать данные -> нажать на заголовок этого столбца мышкой.

Если столбец не был отсортирован, то одно нажатие отсортирует его по возрастанию, следующее - по убыванию.

Важно: Чтобы отменить сортировку, вызовите контекстное меню правой кнопкой мыши на нужном столбце,а затем выберите пункт Clear Sorting, или нажмите клавишу Ctrl и щелкните по столбцу, по которому была отсортирована таблица.

Чтобы сгруппировать данные перетащите мышкой заголовок столбца на специальную панель группировки над таблицей.

HowTo - Data View - Grid View - Grouping data by two columns_Small

Важно: Чтобы убрать группировку перетащите заголовок столбца с панели группировки обратно в таблицу.


Экспортировать/импортировать данные

Копировать данные из таблицы базы данных во внешний файл допустимого формата (экспортировать) можно одним из следующих способов:

  1. Открыть вкладку Data или Results -> нажать кнопку [image] Export Data на одной из панелей инструментов просмотрщика данных -> задать параметры экспорта в открывшемся Мастере экспорта данных.
  2. Открыть вкладку Data или Results -> в контекстном меню сетки данных выбрать пункт Data Manipulation | Export Data -> задать параметры экспорта в открывшемся Мастере экспорта данных.
  3. В проводнике баз данных открыть контекстное меню таблицы -> в нем выбрать пункт Export Data задать параметры экспорта в открывшемся Мастере экспорта данных.
  4. Открыть вкладку Data или Results -> использовать сочетание клавиш Ctrl+E.

Копировать данные из внешних источников в таблицу или представление (импортировать) можно одним из следующих способов:

  1. Открыть вкладку Data -> нажать кнопку Import Data на одной из панелей инструментов просмотрщика данных -> задать параметры импорта в открывшемся Мастере импорта данных.
  2. Открыть вкладку Data -> в контекстном меню сетки данных выбрать пункт Data Manipulation | Import Data -> задать параметры импорта в открывшемся Мастере импорта данных.
  3. В проводнике баз данных открыть контекстное меню таблицы -> в нем выбрать пункт Import Data -> задать параметры импорта в открывшемся Мастере импорта данных.
  4. Открыть вкладку Data -> использовать сочетание клавиш Ctrl+I.


Экспортировать данные в виде SQL скрипта

Копировать данные из таблицы базы данных в виде скрипта, содержащего операторы INSERT INTO, можно одним из следующих способов:

  1. Открыть вкладку Data или Results -> нажать кнопку [image] Export Data as SQL Script на одной из панелей инструментов просмотрщика данных -> задать параметры экспорта в открывшемся Мастере экспорта данных в виде SQL скрипта.
  2. Открыть вкладку Data или Results -> в контекстном меню сетки данных выбрать пункт Data Manipulation | [image] Export Data as SQL Script -> задать параметры экспорта в открывшемся Мастере экспорта данных в виде SQL скрипта.
  3. В проводнике баз данных открыть контекстное меню таблицы -> в нем выбрать пункт Data Manipulation | [image] Export Data as SQL Script -> задать параметры экспорта в открывшемся Мастере экспорта данных в виде SQL скрипта.

Важно: Для извлечения DDL таблицы (оператор CREATE TABLE) установите флажок Add CREATE TABLE statement на первом шаге.


Редактировать данные многоуровневых таблиц

Вы можете работать с данными в многоуровневом режиме, то есть Вы можете просматривать и редактировать их в нескольких связанных таблицах одновременно. Чтобы добавить уровень таблицы щелкните правой кнопкой мыши в таблице и выберите пункт Grid Levels из контекстного меню. Далее выберите пункт Add Grid Level, чтобы запустить Мастер создания уровней. После того, как новый уровень будет добавлен, Вы можете редактировать данные в связанных таблицах.


Добавить изображение в таблицу

Это возможно сделать только при наличии в таблице поля типа BLOB.

Открыть таблицу на вкладке Data -> перейти в раздел BLOB View (кнопки перехода расположены в нижней части окна) -> перейти на вкладку Image -> если BLOB поле не одно, то из раскрывающегося списка Select BLOB Column на панели инструментов вкладки Blob View выбрать нужное поле ->

HowTo - Grid View - BLOBView - Select BLOB Column

-> на панели инструментов вкладки Blob View нажать кнопку iconLoadFromFile Load from File -> открывшемся диалоговом окне выбрать файл изображения.


Настроить формат отображения данных

Чтобы настроить формат отображения данных выберите пункт Options | btnEnvironmentOptions Environment Options в главном меню программы -> перейдите на вкладку Color & Formats -> в разделе Display formats укажите или выберите формат отображения для некоторых типов данных.


Быстро создать SQL-запрос

Есть два способа быстрого создания SQL-запроса:

В проводнике баз данных

  1. Щелкните правой кнопкой мыши по имени объекта в проводнике баз данных.
  2. Выберите Script to Query data в контекстном меню объекта.
  3. Определите тип запроса.

В Визуальном конструкторе запросов

  1. Откройте Дизайнер запросов.
  2. На вкладке Builder перетащите таблицу или представление из проводника баз данных или из списка на панели Object в рабочую область.
  3. Выберите отображаемые столбцы, установив флажки напротив нужных. Чтобы добавить в запрос сразу все столбцы объекта необходимо установить флажок, находящийся перед названием объекта в строке заголовка.
  4. Установите связь между объектами. Чтобы установить связь между таблицами по двум столбцам необходимо столбцы из одной таблицы перетащить в другую (поля представлены в виде списка, в котором каждая строчка - столбец). После перетаскивания связь будет отображена в виде черной линии, соединяющей желаемые столбцы.
  5. Задайте свойства связи. Для этого необходимо открыть редактор связи, два раза щелкнув на ней мышкой, или выбрать пункт контекстного меню связи Property. В появившемся окне указываете желаемые свойства редактируемой связи.
  6. На вкладке Edit Вы можете просмотреть и отредактировать свой запрос.


Контролировать производительность запроса

Посмотреть производительность запроса можно на плане запроса. На нем показана последовательность действий, выполняемых сервером базы данных, и объем системных ресурсов, используемых в процессе выполнения запроса.

Чтобы посмотреть план запроса откройте запрос в Редакторе запросов и выберите пункт btnExplainQuery Show estimated execution plan на панели инструментов.

Если включить опцию CheckBox Show actual execution plan on query execution в настройках окружения, то вкладка Plan будет появляться автоматически при выполнении запроса.


Работать с несколькими запросами одновременно

В btnShowSQLEditor Query data Вы можете одновременно открывать и редактировать несколько запросов.

В нижней части окна редактирования запроса можно создавать вкладки. На каждой вкладке - отдельный запрос.

Создать вкладку можно следующими способами:

  1. Открыть btnShowSQLEditor Query data -> на одной из панелей инструментов выбрать пункт btnNewSQLEditor New Query.
  2. Открыть btnShowSQLEditor Query data -> в контекстном меню существующей вкладки выбрать пункт btnNewSQLEditor New Query HowTo - WorkWithQueries - AddNewQuery .
  3. Использовать сочетание клавиш Ctrl + N.

Важно: Каждую вкладку можно переименовывать, или для удобства добавлять запросы в Избранные.


Сохранить часто используемые запросы

Используйте инструмент Избранные запросы чтобы хранить часто выполняемые запросы. Чтобы получить доступ к списку избранных запросов используйте узел Favorite Queries проводника БД или создайте для них отдельную вкладку.

С помощью контекстного меню Вы можете создать новый избранный запрос, редактировать уже существующий в редакторе избранных запросов или удалить запрос при необходимости.


Выполнять запросы с параметрами

Если Вы хотите использовать параметризованные запросы, установите флажок CheckBox Allow using of parameters in query text в окне Настройки окружения | Инструменты.

Эта функция позволяет устанавливать различные значения параметров в окне ввода параметров перед выполнением запроса. Используйте двоеточие перед идентификатором, чтобы указать параметр в запросе.


Экспортировать результаты запроса в файл

При выполнении запроса таблица результатов может отображаться на вкладке Edit или на вкладке Result в просмотрщике данных.

Копировать данные из таблицы базы данных во внешний файл допустимого формата можно одним из следующих способов:

  1. Открыть вкладку Data или Results -> нажать кнопку [image] Export Data на одной из панелей инструментов просмотрщика данных -> задать параметры экспорта в открывшемся Мастере экспорта данных.
  2. Открыть вкладку Data или Results -> в контекстном меню сетки данных выбрать пункт Data Manipulation | [image] Export Data -> задать параметры экспорта в открывшемся Мастере экспорта данных.
  3. В проводнике баз данных открыть контекстное меню таблицы -> в нем выбрать пункт [image] Export Data задать параметры экспорта в открывшемся Мастере экспорта данных.
  4. Открыть вкладку Data или Results -> использовать сочетание клавиш Ctrl+E.


Выполнять скрипты (сценарии)

Используя Редактор выполнения скриптов Вы можете создавать, просматривать, редактировать и выполнять SQL-скрипты (сценарии). Чтобы открыть редактор скриптов выберите Tools | btnShowSQLScript SQL Script в главном меню программы. Этот инструмент предназначен для работы с большим количеством команд и работы со скриптами из файлов. Например, Вы можете выполнить скрипт из файла, не загружая его в редактор, что позволит сократить потребление памяти. Однако редактор позволяет оценить лишь успешность выполнения команд скрипта, но не возвращает результаты запросов.

Важно: Выполнять скрипты необходимо именно в Редакторе скриптов, а не в Редакторе получения данных.

Последний предназначен для создания, редактирования и выполнения запросов. Из его окна можно перейти к редактированию запроса в Design Query. Также он предоставляет возможность просмотра результата запроса, проведения различных операций с ним (импорт, экспорт и др.), управления транзакциями.


Выполнить большой SQL-скрипт

Если вам надо выполнить большой SQL-скрипт, необязательно загружать его из файла в окно редактора выполнения скриптов, так как это может занять много времени. Вместо этого, Вы можете выполнить этот скрипт напрямую из файла с расширением *.sql, *.zsql или *.txt. Чтобы сделать это, выберите пункт iconCompile Execute script from file на панели инструментов в редакторе скриптов.


Ускорить работу SQL-скрипта

Чтобы ускорить работу скрипта можно отключить некоторые функции:

Парсинг

На одной из панелей инструментов редактора SQL скриптов отключить пункт iconDBExplorer Disable Parsing.

Автоматическое создание иерархической структуры текста

В главном меню программы выбрать пункт Options | Editor options -> перейти на вкладку Display -> убрать флажок CheckBox Use code folding.

Подсветку синтаксиса и быстрый ввод текста для алиасов

В главном меню программы выбрать пункт Options | Editor options -> перейти на вкладку General -> убрать флажок CheckBox Resolve aliases - отключить подсветку синтаксиса и быстрый ввод текста для алиасов.


Работать с текстом запроса/скрипта

Перейти по внутренней ссылке

В тексте запроса/скрипта имя объекта, существующего в базе данных, выделено цветом. Открыть объект, на который есть ссылка в тексте, можно щелкнув по нему левой кнопкой мыши, удерживая при этом клавишу Ctrl.

Вставить шаблон текста

Чтобы вставить шаблон клавиатуры нужно использовать сочетание клавиш Ctrl+J.

Автоматическая подстановка (список объектов)

Вызвать список автоматической подстановки можно используя сочетание клавиш Ctrl + пробел.

Настроить параметры автоматической подстановки

В главном меню программы выбрать пункт Options | Editor options -> перейти на вкладку Code Completion -> настроить список и параметры списка автоматической подстановки.

Автоматически форматировать запрос/скрипт

В контекстном меню редактора SQL выбрать пункт Quick Code | Format или использовать сочетание клавиш Shift+Ctrl+F.

Настроить шрифт и формат скрипта на вкладке Display

В главном меню программы выбрать пункт Options | Editor options -> перейти на вкладку Display -> настроить общие параметры формата и шрифта редактора.

Настроить шрифт и формат скрипта на вкладке Highlight

В главном меню программы выбрать пункт Options | Editor options -> перейти на вкладку Color Schema -> настроить параметры шрифта для каждого отдельного элемента.

Важно: Если заданы параметры шрифта на вкладке Color Schema, то к тексту будут применены именно они, а не те, которые заданы на вкладке Display.


Просмотреть все выполненные запросы и скрипты

btnSQLMonitor Монитор SQL позволяет увидеть все скрипты, отправленные SQL Manager for PostgreSQL на сервер, а также результаты их выполнения. Содержимое окна нельзя редактировать, но можно копировать в буфер обмена, сохранять в файл и распечатывать.

Все инструменты для работы с SQL монитором располагаются на панелях инструментов и в контекстном меню.

Чтобы открыть SQL монитор необходимо:

  1. В главном меню программы выбрать пункт Tools | SQL Monitor,
  2. На основной панели инструментов нажать кнопку SQL Monitor,
  3. В контекстном меню базы данных выбрать пункт Tasks | SQL Monitor.

Важно: В SQL монитор попадают те скрипты и запросы, которые были выполнены в SQL Manager for PostgreSQL, в течение того времени, когда он был запущен.

Важно: Постоянно открытый монитор замедляет работу программы.


Управлять изменениями

Система управления изменениями позволяет:

  • Систематизировать процесс выпуска новых версий БД: хранение версий БД; учет изменений; получение (хранение, тестирование) скриптов переходов от версии к версии и т.п.
  • Возможность откатить БД к заданному состоянию (версии).
  • Контроль изменений, внесенных различными разработчиками.

Когда пользователь такой системы выполняет обычные действия, такие как извлечение определённой версии документа, создание новой версии и тому подобное, он работает со своей локальной копией хранилища. По мере внесения изменений, хранилища, принадлежащие разным разработчикам, начинают различаться, и возникает необходимость в их синхронизации. Такая синхронизация может осуществляться с помощью обмена патчами или, так называемыми, наборами изменений (англ. change sets) между пользователями.


Включить управление изменениями

Для работы с системой контроля версий необходимо выполнить следующую последовательность:

  1. Установить систему управления изменениями или её клиентскую часть.

В настоящее время поддерживаются следующие системы:

  • CVS
  • Subversion
  • Microsoft Visual SourceSafe
  • Team Foundation Server
  2. Для CVS и Subversion создать директорию, являющуюся рабочей копией директории СКВ.
  3. В Database Registration Info на вкладке Change Management установить флажок CheckBox Enabled.
  4. С помощью Мастера управления репозиторием создать репозиторий для каждой базы данных, для которой нужен контроль изменений.

Репозиторий - хранилище документов — место, где система управления версиями хранит все документы вместе с историей их изменения и другой служебной информацией.

  5. Указать параметры созданного репозитория на вкладке Change Management диалогового окна Database Registration Info, или подтвердить автозаполнение при закрытии Мастера управления репозиторием.
  6. Подтвердить изменения и заново подключиться к базе данных.

Отдельно параметры подключения к репозиторию, располагающемуся на локальном компьютере можно просмотреть или исправить в диалоговом окне Provider settings, открывающемся при нажатии на кнопку Properties.


Включить контроль версий используя локальный репозитарий

Если Вы только что установили Subversion и хотите создать репозиторий базы данных с нуля, выполните следующие действия:

  1. Укажите сервер для хранения SVN репозитория. Для этого используйте инструмент 'svnadmin', который включен в пакет установки сервера Subversion. Выполните команду:

<msg:code>svnadmin create c:\svnstorage\</msg:code>, чтобы указать путь к существующей пустой директории.

  2. Запустите SQL Manager, откройте Регистрационную информацию для той базы данных, которую хотите подключить к системе контроля версий. Перейдите на вкладку Change Management и нажмите на кнопку Repository Management Wizard.
  3. Выберите RadioButton Create new repository и нажмите 'Next'.
  4. Выберите RadioButton Subversion и нажмите 'Next'.
  5. Укажите путь к библиотекам сервера Subversion в поле Subversion client libraries path (например, "C:\Program Files\CollabNet Subversion Server\"). Если Вы используете только клиентскую часть (в случае удаленного SVN сервера), то необходимо указать путь к установленной клиентской части (например, "C:\Program Files\CollabNet Subversion Client\"). Проверьте, загружаются ли библиотеки, нажав кнопку 'Test', и перейдите на следующий шаг.
  6. Укажите путь к серверному репозиторию в поле Server path в виде 'file:///c:/svnrepository/'; укажите директорию рабочей копии или любую пустую дикректорию, в которой будет создана рабочая копия, в поле Local path в виде 'c:\project\'; укажите имя репозитория базы данных в поле Repository name (например, "mydb"); дважды нажмите кнопку 'Next'.
  7. Запустите создание репозитория нажав кнопку 'Run'.
  8. После завершения операции нажмите кнопку 'Close' и затем кнопку 'Yes', чтобы применить настройки.
  9. Нажмите 'OK', чтобы сохранить настройки системы контроля версий и закройте окно Регистрационной информации баз данных.


Откатить базу данных до предыдущей ревизии

Если Вы хотите откатить базу данных до состояния предыдущей ревизии, необходимо выполнить следующие действия:

  1. Щелкните правой клавишей мыши на необходимой базе данных в Проводнике БД и выберите пункт Change management | Get Change Script из всплывающего меню. Откроется Мастер получения скрипта изменений.
  2. На втором шаге Мастера выберите пункт RadioButton Generate differential script, чтобы создать скрипт. отражающий изменения между двумя состояниями базы данных.
  3. На третьем шаге определите состояние, к которому Вы хотите откатить базу данных. Для этого укажите дату или тег в качестве конечной точки скрипта. После чего будет сгенерирован скрипт обратных изменений.
  4. Выполнение скрипта произведет откат базы данных к необходимому состоянию.


Посмотреть изменения между ревизиями БД

Посмотреть совершенные изменения базы данных можно одним из следующих способов:

  • Используя историю изменений базы данных:
  1. Щелкните правой клавишей мыши на необходимой базе данных в Проводнике БД и выберите пункт Change management | History из всплывающего меню.
  2. В соответствующем разделе укажите период, за который Вы хотите посмотреть изменения. Они отобразятся в основном окне.
  3. В верхней части окна появится таблица, отображающая информацию обо всех изменениях, произведенных в указанный период. Для каждого изменения отображается: идентификатор транзакции, дата совершения изменения, имя пользователя, который внес изменения, комментарий к операции. В нижней части окна отображается SQL скрипт изменений, соответствующий выбранной в верхней части строке изменений.
  • Используя теги и скрипт изменений:
  1. Щелкните правой клавишей мыши на необходимой базе данных в Проводнике БД и выберите пункт Change management | Get Change Script из всплывающего меню. Откроется Мастер получения скрипта изменений.
  2. На втором шаге выберите RadioButton Generate differential script, чтобы создать скрипт. отражающий изменения между двумя состояниями базы данных.
  3. На третьем шаге Вы можете выбрать теги из выпадающего списка, чтобы указать два состояния базы данных, между которыми Вы хотите посмотреть изменения, либо укажите даты, чтобы определить период, за который Вы хотите посмотреть изменения.
  4. В полученном скрипте отразятся различия между состояниями базы данных.


Посмотреть разницу между ревизиями процедуры

Если Вы модифицировали процедуру и хотите посмотреть совершенные изменения, выполните следующие действия:

  1. Щелкните правой клавишей мыши на необходимой процедуре в Проводнике БД
  2. Выберите пункт Change management | History из всплывающего меню. Появится таблица с историей изменений объекта.
  3. Выберите две ревизии процедуры для сравнения.
  4. Щелкните правой клавишей мыши на любом объекте и выберите пункт Compare Properties или Compare DDL, чтобы посмотреть различия в виде таблицы свойств объекта или DDL объекта соответственно.
  5. После проведения операции сравнения свойств появляется диалоговое окно, в котором отображены все свойства объекта и их значения для разных версий. Цветом выделены свойства, имеющие разные значения для разных версий.
  6. После проведения операции сравнения DDL появляется диалоговое окно, отображающее скрипты объекта для разных версий.


Создать простой отчет в конструкторе отчетов

Чтобы создать отчет в Конструкторе отчетов необходимо выполнить следующую последовательность действий:

  1. В главном меню программы выбрать пункт Tools | [image] Report Designer.
  2. В открывшемся Конструкторе отчетов, в главном меню выбрать пункт File | New Report. или на панели инструментов нажать кнопку [image] New Report. На печатную форму отчета будут помещены автоматически ReportTitle, MasterData и PageFooter.
  3. Подключиться к источнику данных.
  4. Добавить элементы ADOTable или ADOQuery.
  5. Подключить ADOTable или ADOQuery к ADODatabase.
  6. На странице Page1 разместите столбцы базы данных. Из DataTree перетащить нужные столбцы в Band MasterData.


Перенести настройки программы

Если Вы хотите применить текущие настройки (частично или полностью) для программы SQL Manager for PostgreSQL установленной на другой машине, Вы можете сохранить их в *.reg файл с помощью Мастера сохранения настроек. Чтобы применить настройки, сохраненные в файл *.reg необходимо открыть этот файл двойным щелчком мыши. В появившемся окне нажать кнопку OK.

Избранные запросы не сохраняются в этом случае. Чтобы получить доступ к запросам с другого устройства необходимо, чтобы они хранились в БД.


Обновить программу

Обновить программу можно одним из следующих способов:

  1. Загрузите установочный файл со страницы загрузки сайта -> полученный файл извлеките из архива в нужную директорию (например, c:\unzipped) -> закройте программу SQL Manager for PostgreSQL, если она запущена -> откройте файл PgManagerFullSetup.exe и следуйте инструкциям мастера обновления.
  2. В главном меню программы выберите пункт Help | SQL Manager Direct -> нажмите кнопку Update -> при наличии на сайте новой версии программы появится окно сообщений -> в этом окне нажмите Yes. Программа обновится автоматически.


Сообщить об ошибках и предложениях

Перед тем как отправить предложения и отчеты об ошибках, убедитесь, что Вы используете последнюю версию SQL Manager for PostgreSQL. Если это так, Вы можете связаться с нами через личный кабинет на сайте https://www.sqlmanager.ru/; используя главное меню программы Help или отправив электронное письмо по адресу support@sqlmanager.net. Пожалуйста, не забудьте указать версию Вашей ОС, версию сервера PostgreSQL и версию программы. Пошагово опишите свои действия перед появлением ошибки и проиллюстрируйте их скриншотами.