Bienvenue dans EMS SQL Studio !

SQL Management Studio for Oracle est une solution complete d'administration et de développement des bases de données. Si vous etes un développeur de bases de données ou d'applications, un DBA ou un analyste commercial, SQL Studio vous offre tous les outils nécessaires pour rendre votre travail plus efficace que jamais. SQL Studio est un environnement de travail puissant et facile a utiliser qui propose tout un ensemble d'outils essentiels.

SQL Studio offre une multitude d'outils puissants pour l'administration de bases de données, la gestion des objets des bases de données, pour la migration, la comparaison, l'extraction des bases de données, pour l'importation, l'exportation et la comparaison des données.

Fonctionnalités :

  • Lancement facile des utilitaires et des services
  • Stockage des modeles dans un seul dépôt
  • Liste commune des sources de données pour tous les services et utilitaires
  • Création de scripts ramifiés et compliqués
  • Possibilité d'exécuter des applications externes a partir de scripts
  • Stockage des journaux d'exécution de tous les scripts dans une seule base de données
  • Exécution planifiée d'un script
  • Création des notifications personnalisées ; l'opportunité d'envoyer les notifications par différents moyens
  • Acces rapide au Service de Support Technique
  • Mode unique de personnalisation de l'apparence de toutes les applications

Avantages :

  • Le lancement rapide des tâches vous permet de vous concentrer sur le résultat
  • Le stockage des modeles dans un seul dépôt facilite le travail avec les utilitaires
  • La flexibilité des scripts permet d'économiser votre temps en vous débarrassant des tâches routinieres
  • L'exécution planifiée de scripts permet d'automatiser les tâches routinieres
  • Les e-mails de notification vous permettent d'etre au courant des nouvelles informations
  • Le stockage des journaux d'exécution de tous les scripts vous permet de contrôler toutes les opérations
  • Le style unique de l'interface de tous les produits rend votre travail plus agréable


Quoi de neuf ?

SQL Management Studio for Oracle 1.2.0.1

Décembre 4, 2008

Quoi de neuf dans SQL Management Studio 1.2 ?

  • Le planificateur des tâches peut etre maintenant exécuté en tant que service systeme (Service Windows) ou processus a part.
  • Si une tâche personnalisée est exécutée manuellement, le processus d’exécution peut etre suivi dans une fenetre spéciale.
  • Le type de connexion SSH ou HTTP s’affiche maintenant dans le champ du nom de l’hôte.
  • Les parametres de la barre d’outils se réinitialisaient apres l’arret du programme. L’erreur est corrigée.
  • La possibilité d’ouvrir la documentation PDF via le menu principal a été ajoutée.
  • D’autres améliorations et corrections d’erreurs mineures ont été réalisées.


Exigences systeme

Pré-requis Windows

  • Pentium II ® 300MHz ou supérieur recommandé
  • Microsoft® Windows NT4 SP4, Microsoft® Windows 2000, Microsoft® Windows 2000 Server, Microsoft® Windows XP, Microsoft® Windows 2003 Server, Microsoft Windows Vista, Microsoft Windows 7
  • 64 Mo RAM (128 Mo ou plus recommandés)
  • 140 Mo d'espace disque minimum sont nécessaires pour une installation
  • Carte vidéo compatible avec Windows® ; Carte vidéo résolution 800x600 (1024x768 recommandé)
  • Souris compatible Windows® ou périphérique de pointage compatible
  • Possibilité de se connecter a Oracle local ou distant


Installation

Si vous installez SQL Management Studio for Oracle pour la premiere fois :

  • Veuillez télécharger le paquet d'installation SQL Management Studio for Oracle depuis le site EMS ;
  • Décompressez le fichier téléchargé dans n'importe quel dossier local, par exemple c:\unzipped ;
  • Exécutez setup.exe depuis le dossier et suivez les instructions de l'assistant d'installation ;
  • Une fois l'installation terminée, vous trouverez un raccourci de SQL Management Studio for Oracle dans le menu de démarrage Windows.

Si vous voulez mettre a niveau SQL Management Studio for Oracle déja installé :

  • Veuillez télécharger le fichier exécutable de SQL Management Studio for Oracle depuis le site EMS ;
  • Décompressez le fichier téléchargé dans n'importe quel dossier local, par exemple c:\unzipped ;
  • Quittez SQL Management Studio for Oracle s'il est lancé ;
  • Remplacez la version précédente de SQL Management Studio for Oracle en copiant les fichiers décompressés depuis le dossier SQL Management Studio for Oracle de EMS ;
  • Exécutez SQL Management Studio for Oracle a l'aide du raccourci situé dans le menu de démarrage Windows.


Enregistrement

Nous avons passé un contrat avec le fournisseur de commerce électronique share-it! pour faciliter les processus d'achat de nos produits. L'achat en ligne via share-it ! est totalement protégé, c'est pourquoi le processus de paiement par carte de crédit est tres rapide et absolument sécurisé.

Share-it ! est le fournisseur mondial de services e-Commerce dédiés a la vente de logiciels et de sharewares sur Internet. Share-it! accepte les paiements en dollars US, Euros, Livres Sterling, Yen Japonais, Dollars Australiens, Dollars canadiens ou Francs suisses par carte de crédit (Visa, MasterCard/EuroCard, American Express, Diners Club), transfert bancaire, cheque ou comptant.

Si vous avez commandé notre logiciel en ligne et voulez revoir l'information de votre commande, ou si vous avez des questions a propos de la commande, du paiement ou de la livraison, visitez notre Customer Care Center, sur le site de Share-it!

Notez s'il-vous-plaît que nous distribuons uniquement tous nos produits via le systeme ESD (Electronic Software Delivery).

Pour en SAVOIR PLUS sur ce produit, rendez-vous sur notre site : http://sqlmanager.net/en/products/studio/oracle

Description du produit | Share It!
EMS SQL Management Studio for Oracle (Business) + maintenance trois ans | Acheter !
EMS SQL Management Studio for Oracle (Business) + maintenance deux ans | Acheter !
EMS SQL Management Studio for Oracle (Business) + maintenance un an | Acheter !
EMS SQL Management Studio for Oracle (Non-commercial) + maintenance trois ans | Commander !
EMS SQL Management Studio for Oracle (Non-commercial) + maintenance deux ans | Commander !
EMS SQL Management Studio for Oracle (Non-commercial) + maintenance un an | Commander !

Le programme de maintenance du logiciel EMS offre les avantages suivants:

  • Les corrections d'erreurs gratuites, les améliorations, les mises a jour mineures et mises a jour majeures gratuites lors de la période de maintenance;
  • L'opportunité de contacter gratuitement notre équipe de support et nous faire part des erreurs de fonctionnement du logiciel
  • L'opportunité de nous contacter gratuitement a propos des aspects opérationnels de notre logiciel

Apres l'expiration de votre maintenance, vous ne pourrez plus obtenir les mises a jour des produits et le support téchnique. Vous devez renouveler votre maintenance pour acquitter vos dépenses et utiliser des nouvelles versions du logiciel.

Vous pouvez renouveler facilement votre maintenance en utilisant le dialogue en ligne Maintenance Reinstatement Interface. Apres avoir renouvelé votre maintenance vous recevrez un email de confirmation avec les informations nécessaires.


Bref historique

Version | Date de sortie
Version 1.1 | Décembre 12, 2007
Version 1.0 | Septembre 3, 2007

http://www.sqlmanager.net/products/studio/oracle/news

Quoi de neuf dans SQL Management Studio 1.1 ?

  1. Planificateur de tâches : nous avons ajouté la possibilité d'exécuter les tâches planifiées plusieurs fois par jour.
  2. Vous pouvez maintenant lancer tous les outils SQL Studio via le menu contextuel d’Agent situé sur la barre des tâches.
  3. Le message correspondant s’affiche ou se crée dans le journal lors de la tentative d’appeler l’utilitaire a l’aide du modele impropre.
  4. SQL Query permet maintenant d’utiliser le dépôt des bases de données partagé avec SQL Studio.
  5. La mise a jour du logiciel via SQL Studio Direct a été améliorée :
  • le progres de téléchargement s’affiche lors du téléchargement de la mise a jour;
  • le message correspondant s’affiche lors de la tentative d’installer la mise a jour qui n’est pas disponible a cause de la maintenance expirée.
  6. Nous avons éliminé l’erreur qui survenait lors de la tentative de supprimer une seule étape de la tâche.
  7. La configuration des options visuelles peut etre maintenant appliquée a tous les composants de SQL Studio.
  8. L’ajout et la suppression des bases de données exécutées dans SQL Manager ne s’affichaient pas dans l’arbre de l’explorateur de SQL Studio lancé. L’erreur est corrigée.
  9. Nous avons corrigé un certain nombre d’artefacts qui survenaient lors du travail avec deux moniteurs.
  10. L’erreur de lancement d’Agent survenait si un utilisateur avec les droits restreints exécutait SQL Studio avec SQL Studio Agent pas lancé. L’erreur est corrigée.
  11. Nous avons considérablement agmenté la vitesse de l’ouverture de la section ‘Gestion de modeles’ (Template Management) avec une grande liste des modeles.
  12. La position de la fenetre SQL Studio se sauvegarde pour la session suivante.
  13. L’erreur "Tool path is not correct" survenait lors de la tentative d’exécuter une tâche pendant le travail avec Windows 2003 Server. L’erreur est corrigée.
  14. Nous avons ajouté la requete de confirmation qui apparait lors de la suppression d’une étape a partir d’une tâche.
  15. D’autres améliorations et corrections d’erreurs mineures ont été réalisées

Lancement de EMS SQL Management Studio!

Fonctionnalités supplémentaires de SQL Studio:

  • Lancement facile des utilitaires et des services
  • Stockage de tous les modeles dans un seul dépot
  • Liste de sources de données commune pour tous les services et utilitaire
  • Création des tâches compliquées et l’exécution des tâches planifiées
  • Possibilité d’exécuter les applications externes en utilisant le planificateur de tâches
  • Stockage de tous les journaux de tâches exécutées dans une seule base de données
  • Création des notifications personnalisées avec des options différentes de livraison
  • Possibilité d’appliquer un style visuel unique pour tous les applications SQL Studio
  • Acces rapide au Service de Support Technique EMS

Avantages de SQL Studio:

  • Lancement rapide des tâches vous permet de vous concentrer sur le résultat
  • Stockage de modeles dans un seul dépôt facilite le travail avec des utilitaire
  • Flexibilité des scripts permet d'économiser votre temps en vous débarrassant des tâches routinieres
  • Exécution planifiée d'un script permet d'automatiser les tâches routinieres
  • E-mails de notification vous permettent d'etre au courant de nouvelles informations
  • Stockage des logs d'exécution de tous les scripts vous permet de contrôler toutes les opérations
  • Style unique de l'interface de tous les produits rend votre travail plus agréable


D'autres produits EMS

Quick navigation

MySQL

Microsoft SQL

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL est une solution complete d’administration et de développement de bases de données MySQL. SQL Studio contient tous les composants nécessaires pour effectuer les tâches critiques de gestion de bases de données. SQL Studio vous fournit les outils must d’administration de bases de données My SQL, de gestion des schémas de base de données et des objets ainsi que les outils de conception de base de données MySQL, de migration, d’extraction, de construction de requetes MySQL, d’importation de données, d’exportation et de comparaison de bases de données. SQL Studio réunit tous les outils de bases de données dans un environnement puissant et facile a utiliser qui peut fonctionner 24 heures sur 24. Si vous etes un développeur de bases de données ou d'application, un DBA ou un analyste commercial, SQL Studio for MySQL vous offre tous les outils MySQL nécessaires pour rendre votre travail plus efficace que jamais!
 | SQL Manager for MySQL EMS SQL Manager for MySQL fournit les outils de hautes performances d’administration et de développement de serveur MySQL. L’outil dispose d’une interface graphique simple d’emploi qui vous permet de créer/modifier tous les objets de bases de données MySQL d’une façon efficace, de concevoir visuellement les bases de données MySQL, d’exécuter les scripts SQL, d’exporter et d’importer les données des bases de données MySQL et fournit beaucoup d’autres services qui permettent de faciliter la gestion de MySQL.
dataexport | Data Export for MySQL EMS Data Export for MySQL est un outil puissant pour exporter rapidement les données des bases de données MySQL vers les dix-neuf formats disponibles y compris MS Access, MS Excel, MS Word, RTF, HTML, TXT, ODF etc. Data Export for MySQL comprend un assistant d’utilisation simple pour le réglage visuel des parametres d’exportation MySQL et l’utilitaire de ligne de commande pour automatiser les tâches d’exportation MySQL a l’aide du fichier de configuration.
dataimport | Data Import for MySQL EMS Data Import for MySQL est un outil puissant d’import de données vers les tables MySQL a partir des fichiers MS Excel 97-2007, MS Access, DBF, TXT, CSV, MS Word 2007, RTF, ODF et HTML. Cet utilitaire vous permet d’importer simultanément vos données vers une ou plusieurs tables ou vues MySQL, de sauvegarder tous les parametres d’import MySQL initialisés lors de la session courante de l’assistant, d’utiliser le mode de l’insertion de lot pour l’import rapide de données vers les tables MySQL.
datapump | Data Pump for MySQL EMS Data Pump for MySQL est un outil excellent de migration pour convertir les bases de données et importer les données des tables depuis n’importe quelle source compatible avec ADO (par exemple les bases de données MS Access, MS SQL ou d’autres bases de données supportant ADO) vers les bases de données MySQL. La conversion des bases de données a l’aide de Data Pump for MySQL est plus simple que jamais!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – est un outil puissant de génération des données de test pour les tables des bases de données MySQL. L’outil vous permet de simuler l’environnement de production de base de données, de remplir simultanément plusieurs tables des bases de données MySQL par les données de test, de définir les tables pour la génération des données, de spécifier les étendues de valeurs et de spécifier de nombreux parametres de génération pour chaque type de champ. Le programme fournit la multitude de fonctionnalités puissantes pour la génération simple et rapide des données de test MySQL.
dbcomparer | DB Comparer for MySQL EMS DB Comparer for MySQL est un excellent outil pour comparer les schémas de bases de données MySQL et découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et exécuter le script généré automatiquement pour synchroniser la structure des bases de données MySQL et éliminer les différences. Votre travail avec l’outil de synchronisation des bases de données MySQL sera plus simple et plus rapide grâce aux parametres de comparaison personnalisés et a la multitude de fonctionnalités utiles.
extract | DB Extract for MySQL EMS DB Extract for MySQL est un outil puissant et facile d’emploi pour la création des copies de sauvegarde des bases de données MySQL sous la forme de scripts SQL.Cette application de création des scripts SQL vous permet de sauvegarder les métadonnées de tous les objets des bases de données MySQL ainsi que les données des tables MySQL en tant que les captures instantanées. La personnalisation facile vous permet de sélectionner les objets et les données des tables nécessaires pour le vidage des bases de données MySQL et de régler d’autres options d’extraction.
query | SQL Query for MySQL EMS SQL Query for MySQLest un outil qui vous permet de construire simplement et rapidement les requetes SQL vers les bases de données MySQL. La possibilité de construire visuellement les requetes SQL vers MySQL ainsi que la modification directe de texte de la requete sont possibles. L’interface utilisateur graphique vous permet de vous connecter aux bases de données MySQL, de sélectionner les tables et les champs pour les requetes au serveur MySQL, d’initialiser les criteres de sélection et beaucoup d’autre.
datacomparer | Data Comparer for MySQL EMS Data Comparer for MySQL est un outil puissant et simple d’emploi pour la comparaison et la synchronisation des données MySQL. En utilisant cet utilitaire vous pouvez découvrir les différences entre les tables MySQL comparées et exécuter un script généré automatiquement pour éliminer ces différences. Data Comparer for MySQL fournit l’éventail de parametres de configuration pour la comparaison et la synchronisation efficaces et rapides des données de bases de données MySQL.
 | En savoir plus

Microsoft SQL

SQL Management Studio for SQL Server

EMS SQL Management Studio for SQL Server est une solution complete d’administration et de développement de bases de données Microsoft SQL Server. SQL Studio contient tous les composants nécessaires pour effectuer les tâches critiques de gestion de bases de données MS SQL Server. SQL Studio vous fournit les outils must d’administration de bases de données My SQL, de gestion des schémas de base de données et des objets ainsi que les outils de conception de base de données SQL Server, de migration, d’extraction, de construction de requetes SQL Server, d’importation de données, d’exportation et de comparaison de bases de données. SQL Studio réunit tous les outils de bases de données pour MSSQL Server dans un environnement puissant et facile a utiliser qui peut fonctionner 24 heures sur 24. Si vous etes un développeur de bases de données ou d'application, un DBA ou un analyste commercial, SQL Studio for SQL Server vous offre tous les outils SQL Server nécessaires pour rendre votre travail plus efficace que jamais!

SQL Manager for SQL Server

EMS SQL Manager for SQL Server est l’outil graphique de hautes performances d’administration et de développement de base de données de Microsoft SQL Server. Le programme permet de créer et de modifier rapidement et facilement les objets des bases de données MS SQL Server, d’exécuter les scripts SQL, de gérer les utilisateurs SQL Server et de leurs droits, de construire visuellement les requetes SQL, de travailler avec les métadonnées, d’exporter et d’importer les données de bases de données etc.

dataexport

Data Export for SQL Server

EMS Data Export for SQL Server est un outil puissant pour exporter rapidement les données des bases de données SQL Server vers les dix-neuf formats disponibles y compris MS Access, MS Excel, MS Word, RTF, HTML, TXT, ODF etc. Data Export for SQL Server comprend un assistant d’utilisation simple pour le réglage visuel des parametres d’exportation SQL Server et l’utilitaire de ligne de commande pour automatiser les tâches d’exportation SQL Server a l’aide du fichier de configuration.

dataimport

Data Import for SQL Server

EMS Data Import for SQL Server est un outil puissant d’import de données vers les tables SQL Server a partir des fichiers MS Excel 97-2007, MS Access, DBF, TXT, CSV, MS Word 2007, RTF, ODF et HTML. Cet utilitaire vous permet d’importer simultanément vos données vers une ou plusieurs tables ou vues SQL Server, de sauvegarder tous les parametres d’import SQL Server initialisés lors de la session courante de l’assistant, d’utiliser le mode de l’insertion de lot pour l’import rapide de données vers les tables SQL Server.

datapump

Data Pump for SQL Server

EMS Data Pump for SQL Server est un outil excellent de migration pour convertir les bases de données et importer les données des tables depuis n’importe quelle source compatible avec ADO (par exemple les bases de données MS Access, MySQL ou d’autres bases de données supportant ADO) vers les bases de données SQL Server. La conversion des bases de données a l’aide de Data Pump for SQL Server est plus simple que jamais!

datagenerator

Data Generator for SQL Server

EMS Data Generator for SQL Server – est un outil puissant de génération des données de test pour les tables des bases de données SQL Server. L’outil vous permet de simuler l’environnement de production de base de données, de remplir simultanément plusieurs tables des bases de données SQL Server par les données de test, de définir les tables pour la génération des données, de spécifier les étendues de valeurs et de spécifier de nombreux parametres de génération pour chaque type de champ. Le programme fournit la multitude de fonctionnalités puissantes pour la génération simple et rapide des données de test SQL Server.

dbcomparer

DB Comparer for SQL Server

EMS DB Comparer for SQL Server est un excellent outil pour comparer les schémas de bases de données SQL Server et découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et exécuter le script généré automatiquement pour synchroniser la structure des bases de données SQL Server et éliminer les différences. Votre travail avec l’outil de synchronisation des bases de données SQL Server sera plus simple et plus rapide grâce aux parametres de comparaison personnalisés et a la multitude de fonctionnalités utiles.

extract

DB Extract for SQL Server

EMS DB Extract for SQL Server est un outil puissant et facile d’emploi pour la création des copies de sauvegarde des bases de données SQL Server sous la forme de scripts SQL. Cette application de création des scripts SQL vous permet de sauvegarder les métadonnées de tous les objets des bases de données SQL Server ainsi que les données des tables SQL Server en tant que les captures instantanées. La personnalisation facile vous permet de sélectionner les objets et les données des tables nécessaires pour le vidage des bases de données SQL Server et de régler d’autres options d’extraction.

query

SQL Query for SQL Server

EMS SQL Query for SQL Server est un outil qui vous permet de construire simplement et rapidement les requetes SQL vers les bases de données SQL Server. La possibilité de construire visuellement les requetes SQL vers SQL Server ainsi que la modification directe de texte de la requete sont possibles. L’interface utilisateur graphique vous permet de vous connecter aux bases de données SQL Server, de sélectionner les tables et les champs pour les requetes au serveur SQL Server, d’initialiser les criteres de sélection et beaucoup d’autre.

datacomparer

Data Comparer for SQL Server

EMS Data Comparer for SQL Server est un outil puissant et simple d’emploi pour la comparaison et la synchronisation des données SQL Server. En utilisant cet utilitaire vous pouvez découvrir les différences entre les tables SQL Server comparées et exécuter un script généré automatiquement pour éliminer ces différences. Data Comparer for SQL Server fournit l’éventail de parametres de configuration pour la comparaison et la synchronisation efficaces et rapides des données de bases de données SQL Server.

En savoir plus

PostgreSQL

SQL Management Studio for PostgreSQL

EMS SQL Management Studio for PostgreSQL est une solution complete d’administration et de développement de bases de données PostgreSQL. SQL Studio contient tous les composants nécessaires pour effectuer les tâches critiques de gestion de bases de données. SQL Studio vous fournit les outils must d’administration de bases de données PostgreSQL, de gestion des schémas de base de données et des objets ainsi que les outils de conception de base de données PostgreSQL, de migration, d’extraction, de construction de requetes PostgreSQL, d’importation de données, d’exportation et de comparaison de bases de données. SQL Studio réunit tous les outils de bases de données dans un environnement puissant et facile a utiliser qui peut fonctionner 24 heures sur 24. Si vous etes un développeur de bases de données ou d'application, un DBA ou un analyste commercial, SQL Studio for PostgreSQL vous offre tous les outils PostgreSQL nécessaires pour rendre votre travail plus efficace que jamais!

SQL Manager for PostgreSQL

EMS SQL Manager for PostgreSQL est l’outil graphique de hautes performances pour l’administration et le développement de base de données de serveur PostgreSQL. Le programme permet de créer et de modifier rapidement et facilement les objets des bases de données PostgreSQL, d’exécuter les scripts SQL, de concevoir visuellement les bases de données PostgreSQL, de construire les requetes SQL, d’extraire, d’imprimer et de rechercher les métadonnées, d’importer et d’exporter les données de bases de données PostgreSQL etc.

dataexport

Data Export for PostgreSQL

EMS Data Export for PostgreSQL est un outil puissant pour exporter rapidement les données des bases de données PostgreSQLvers les dix-neuf formats disponibles y compris MS Access, MS Excel, MS Word, RTF, HTML, TXT, ODF etc. Data Export for PostgreSQL comprend un assistant d’utilisation simple pour le réglage visuel des parametres d’exportation PostgreSQL et l’utilitaire de ligne de commande pour automatiser les tâches d’exportation PostgreSQL a l’aide du fichier de configuration.

dataimport

Data Import for PostgreSQL

EMS Data Import for PostgreSQL est un outil puissant d’import de données vers les tables PostgreSQL a partir des fichiers MS Excel 97-2007, MS Access, DBF, TXT, CSV, MS Word 2007, RTF, ODF et HTML. Cet utilitaire vous permet d’importer simultanément vos données vers une ou plusieurs tables ou vues PostgreSQL, de sauvegarder tous les parametres d’import PostgreSQL initialisés lors de la session courante de l’assistant, d’utiliser le mode de l’insertion de lot pour l’import rapide de données vers les tables PostgreSQL.

datapump

Data Pump for PostgreSQL

EMS Data Pump for PostgreSQL est un outil excellent de migration pour convertir les bases de données et importer les données des tables depuis n’importe quelle source compatible avec ADO (par exemple les bases de données MS Access, MS SQL ou d’autres bases de données supportant ADO) vers les bases de données PostgreSQL. La conversion des bases de données a l’aide de Data Pump for PostgreSQL est plus simple que jamais!

datagenerator

Data Generator for PostgreSQL

EMS Data Generator for PostgreSQL – est un outil puissant de génération des données de test pour les tables des bases de données PostgreSQL. L’outil vous permet de simuler l’environnement de production de base de données, de remplir simultanément plusieurs tables des bases de données PostgreSQL par les données de test, de définir les tables pour la génération des données, de spécifier les étendues de valeurs et de spécifier de nombreux parametres de génération pour chaque type de champ. Le programme fournit la multitude de fonctionnalités puissantes pour la génération simple et rapide des données de test PostgreSQL.

dbcomparer

DB Comparer for PostgreSQL

EMS DB Comparer for PostgreSQL est un excellent outil pour comparer les schémas de bases de données PostgreSQL et découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et exécuter le script généré automatiquement pour synchroniser la structure des bases de données PostgreSQL et éliminer les différences. Votre travail avec l’outil de synchronisation des bases de données PostgreSQL sera plus simple et plus rapide grâce aux parametres de comparaison personnalisés et a la multitude de fonctionnalités utiles.

extract

DB Extract for PostgreSQL

EMS DB Extract for PostgreSQL est un outil puissant et facile d’emploi pour la création des copies de sauvegarde des bases de données PostgreSQL sous la forme de scripts SQL. Cette application de création des scripts SQL vous permet de sauvegarder les métadonnées de tous les objets des bases de données PostgreSQL ainsi que les données des tables PostgreSQL en tant que les captures instantanées. La personnalisation facile vous permet de sélectionner les objets et les données des tables nécessaires pour le vidage des bases de données PostgreSQL et de régler d’autres options d’extraction.

query

SQL Query for PostgreSQL

EMS SQL Query for PostgreSQL est un outil qui vous permet de construire simplement et rapidement les requetes SQL vers les bases de données PostgreSQL. La possibilité de construire visuellement les requetes SQL vers PostgreSQL ainsi que la modification directe de texte de la requete sont possibles. L’interface utilisateur graphique vous permet de vous connecter aux bases de données PostgreSQL, de sélectionner les tables et les champs pour les requetes au serveur PostgreSQL, d’initialiser les criteres de sélection et beaucoup d’autre.

datacomparer

Data Comparer for PostgreSQL

EMS Data Comparer for PostgreSQL est un outil puissant et simple d’emploi pour la comparaison et la synchronisation des données PostgreSQL. En utilisant cet utilitaire vous pouvez découvrir les différences entre les tables PostgreSQL comparées et exécuter un script généré automatiquement pour éliminer ces différences. Data Comparer for PostgreSQL fournit l’éventail de parametres de configuration pour la comparaison et la synchronisation efficaces et rapides des données de bases de données PostgreSQL.

En savoir plus

InterBase / Firebird

SQL Management Studio for InterBase/Firebird

EMS SQL Management Studio for InterBase and Firebird est une solution complete d’administration et de développement de bases de données InterBase and Firebird. SQL Studio for InterBase and Firebird contient tous les composants nécessaires pour effectuer les tâches critiques de gestion de bases de données. SQL Studio vous fournit les outils must d’administration de bases de données InterBase and Firebird, de gestion des schémas de base de données et des objets ainsi que les outils de conception de base de données InterBase and Firebird, de migration, d’extraction, de construction de requetes InterBase and Firebird, d’importation de données, d’exportation et de comparaison de bases de données. SQL Studio réunit tous les outils de bases de données IB and Firebird dans un environnement puissant et facile a utiliser qui peut fonctionner 24 heures sur 24. Si vous etes un développeur de bases de données ou d'application, un DBA ou un analyste commercial, SQL Studio for InterBase and Firebird vous offre tous les outils InterBase et Firebird nécessaires pour rendre votre travail plus efficace que jamais!

SQL Manager for InterBase/Firebird

EMS SQL Manager for InterBase/Firebird est un outil puissant d’administration et de développement de base de données d’InterBase et Firebird. SQL Manager for InterBase/Firebird est compatible avec les dernieres versions des systemes de gestion de base de données IB et Firebird et supporte toutes les dernieres fonctionnalités du serveur. Le programme offre beaucoup d’outils puissants tels que le concepteur visuel de bases de données pour créer les bases de données InterBase et Firebird en quelques clics, le constructeur visuel de requetes et le débogueur des procédures stockées pour le développement des scripts InterBase et Firebird SQL etc.

dataexport

Data Export for InterBase/Firebird

EMS Data Export for InterBase/Firebird est un outil puissant pour exporter rapidement les données des bases de données InterBase/Firebird vers les dix-neuf formats disponibles y compris MS Access, MS Excel, MS Word, RTF, HTML, TXT, ODF etc. Data Export for InterBase/Firebird comprend un assistant d’utilisation simple pour le réglage visuel des parametres d’exportation InterBase/Firebird et l’utilitaire de ligne de commande pour automatiser les tâches d’exportation InterBase/Firebird a l’aide du fichier de configuration.

dataimport

Data Import for InterBase/Firebird

EMS Data Import for InterBase and Firebird est un outil puissant d’import de données vers les tables InterBase/Firebird a partir des fichiers MS Excel 97-2007, MS Access, DBF, TXT, CSV, MS Word 2007, RTF, ODF et HTML. Cet utilitaire vous permet d’importer simultanément vos données vers une ou plusieurs tables ou vues InterBase/Firebird, de sauvegarder tous les parametres d’import InterBase/Firebird initialisés lors de la session courante de l’assistant, d’utiliser le mode de l’insertion de lot pour l’import rapide de données vers les tables InterBase/Firebird.

datapump

Data Pump for InterBase/Firebird

EMS Data Pump for InterBase/Firebird est un outil excellent de migration pour convertir les bases de données et importer les données des tables depuis n’importe quelle source compatible avec ADO (par exemple les bases de données MS Access, MS SQL ou d’autres bases de données supportant ADO) vers les bases de données InterBase/Firebird. La conversion des bases de données a l’aide de Data Pump for InterBase/Firebird est plus simple que jamais!

datagenerator

Data Generator for InterBase/Firebird

EMS Data Generator for InterBase/Firebird – est un outil puissant de génération des données de test pour les tables des bases de données InterBase/Firebird. L’outil vous permet de simuler l’environnement de production de base de données, de remplir simultanément plusieurs tables des bases de données InterBase/Firebird par les données de test, de définir les tables pour la génération des données, de spécifier les étendues de valeurs et de spécifier de nombreux parametres de génération pour chaque type de champ. Le programme fournit la multitude de fonctionnalités puissantes pour la génération simple et rapide des données de test InterBase/Firebird.

dbcomparer

DB Comparer for InterBase/Firebird

EMS DB Comparer for InterBase/Firebird est un excellent outil pour comparer les schémas de bases de données InterBase/Firebird et découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et exécuter le script généré automatiquement pour synchroniser la structure des bases de données InterBase/Firebird et éliminer les différences. Votre travail avec l’outil de synchronisation des bases de données InterBase/Firebird sera plus simple et plus rapide grâce aux parametres de comparaison personnalisés et a la multitude de fonctionnalités utiles.

extract

DB Extract for InterBase/Firebird

EMS DB Extract for InterBase/Firebird est un outil puissant et facile d’emploi pour la création des copies de sauvegarde des bases de données InterBase/Firebird sous la forme de scripts SQL. Cette application de création des scripts SQL vous permet de sauvegarder les métadonnées de tous les objets des bases de données InterBase/Firebird ainsi que les données des tables InterBase/Firebird en tant que les captures instantanées. La personnalisation facile vous permet de sélectionner les objets et les données des tables nécessaires pour le vidage des bases de données InterBase/Firebird et de régler d’autres options d’extraction.

query

SQL Query for InterBase/Firebird

EMS SQL Query for InterBase/Firebird est un outil qui vous permet de construire simplement et rapidement les requetes SQL vers les bases de données InterBase/Firebird. La possibilité de construire visuellement les requetes SQL vers InterBase/Firebird ainsi que la modification directe de texte de la requete sont possibles. L’interface utilisateur graphique vous permet de vous connecter aux bases de données InterBase/Firebird, de sélectionner les tables et les champs pour les requetes au serveur InterBase/Firebird, d’initialiser les criteres de sélection et beaucoup d’autre.

datacomparer

Data Comparer for InterBase/Firebird

EMS Data Comparer for InterBase/Firebird est un outil puissant et simple d’emploi pour la comparaison et la synchronisation des données InterBase/Firebird. En utilisant cet utilitaire vous pouvez découvrir les différences entre les tables InterBase/Firebird comparées et exécuter un script généré automatiquement pour éliminer ces différences. Data Comparer for InterBase/Firebird fournit l’éventail de parametres de configuration pour la comparaison et la synchronisation efficaces et rapides des données de bases de données InterBase/Firebird.

En savoir plus

Oracle

SQL Management Studio for Oracle

EMS SQL Management Studio for Oracle est une solution complete d’administration et de développement de bases de données Oracle. SQL Studio for Oracle contient tous les composants nécessaires pour effectuer les tâches critiques de gestion de bases de données. SQL Studio vous fournit les outils must d’administration de bases de données Oracle, de gestion des schémas de base de données et des objets ainsi que les outils de conception de base de données Oracle, de migration, d’extraction, de construction de requetes Oracle, d’importation de données, d’exportation et de comparaison de bases de données. SQL Studio réunit tous les outils de bases de données Oracle dans un environnement puissant et facile a utiliser qui peut fonctionner 24 heures sur 24. Si vous etes un développeur de bases de données ou d'application, un DBA ou un analyste commercial, SQL Studio for Oracle vous offre tous les outils Oracle nécessaires pour rendre votre travail plus efficace que jamais!

SQL Manager for Oracle

EMS SQL Manager for Oracle - est un outil a hautes performances de développement et d’administration de bases de données Oracle. L’interface graphique conviviale permet de créer/modifier rapidement tous les objets de bases de données Oracle, de concevoir visuellement les bases de données Oracle, d’exécuter les scripts SQL, d’importer et d’exporter les bases de données Oracle et fournit beaucoup d’autres services utiles qui rendent la gestion d’Oracle plus facile que possible.

dataexport

Data Export for Oracle

EMS Data Export for Oracle est un outil puissant pour exporter rapidement les données des bases de données Oracle vers les dix-neuf formats disponibles y compris MS Access, MS Excel, MS Word, RTF, HTML, TXT, ODF etc. Data Export for Oracle comprend un assistant d’utilisation simple pour le réglage visuel des parametres d’exportation Oracle et l’utilitaire de ligne de commande pour automatiser les tâches d’exportation Oracle a l’aide du fichier de configuration.

dataimport

Data Import for Oracle

EMS Data Import for Oracle est un outil puissant d’import de données vers les tables Oracle a partir des fichiers MS Excel 97-2007, MS Access, DBF, TXT, CSV, MS Word 2007, RTF, ODF et HTML. Cet utilitaire vous permet d’importer simultanément vos données vers une ou plusieurs tables ou vues Oracle, de sauvegarder tous les parametres d’import Oracle initialisés lors de la session courante de l’assistant, d’utiliser le mode de l’insertion de lot pour l’import rapide de données vers les tables Oracle.

datapump

Data Pump for Oracle

EMS Data Pump for Oracle est un outil excellent de migration pour convertir les bases de données et importer les données des tables depuis n’importe quelle source compatible avec ADO (par exemple les bases de données MS Access, MS SQL ou d’autres bases de données supportant ADO) vers les bases de données Oracle. La conversion des bases de données a l’aide de Data Pump for Oracle est plus simple que jamais!

datagenerator

Data Generator for Oracle

EMS Data Generator for Oracle – est un outil puissant de génération des données de test pour les tables des bases de données Oracle. L’outil vous permet de simuler l’environnement de production de base de données, de remplir simultanément plusieurs tables des bases de données Oracle par les données de test, de définir les tables pour la génération des données, de spécifier les étendues de valeurs et de spécifier de nombreux parametres de génération pour chaque type de champ. Le programme fournit la multitude de fonctionnalités puissantes pour la génération simple et rapide des données de test Oracle.

dbcomparer

DB Comparer for Oracle

EMS DB Comparer for Oracle est un excellentoutil pour comparer les schémas de bases de données Oracle et découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et exécuter le script généré automatiquement pour synchroniser la structure des bases de données Oracle et éliminer les différences. Votre travail avec l’outil de synchronisation des bases de données Oracle sera plus simple et plus rapide grâce aux parametres de comparaison personnalisés et a la multitude de fonctionnalités utiles.

extract

DB Extract for Oracle

EMS DB Extract for Oracle est un outil puissant et facile d’emploi pour la création des copies de sauvegarde des bases de données Oracle sous la forme de scripts SQL. Cette application de création des scripts SQL vous permet de sauvegarder les métadonnées de tous les objets des bases de données Oracle ainsi que les données des tables Oracle en tant que les captures instantanées. La personnalisation facile vous permet de sélectionner les objets et les données des tables nécessaires pour le vidage des bases de données Oracle et de régler d’autres options d’extraction.

query

SQL Query for Oracle

EMS SQL Query for Oracle est un outil qui vous permet de construire simplement et rapidement les requetes SQL vers les bases de données Oracle. La possibilité de construire visuellement les requetes SQL vers Oracle ainsi que la modification directe de texte de la requete sont possibles. L’interface utilisateur graphique vous permet de vous connecter aux bases de données Oracle, de sélectionner les tables et les champs pour les requetes au serveur Oracle, d’initialiser les criteres de sélection et beaucoup d’autre.

datacomparer

Data Comparer for Oracle

EMS Data Comparer for Oracle est un outil puissant et simple d’emploi pour la comparaison et la synchronisation des données Oracle. En utilisant cet utilitaire vous pouvez découvrir les différences entre les tables Oracle comparées et exécuter un script généré automatiquement pour éliminer ces différences. Data Comparer for Oracle fournit l’éventail de parametres de configuration pour la comparaison et la synchronisation efficaces et rapides des données de bases de données Oracle.

En savoir plus

DB2

 | SQL Manager for DB2 EMS SQL Manager for DB2 fournit les outils de base de données pour l’administration et le développement de base de données DB2. L’outil dispose d’une interface graphique simple d’emploi qui vous permet de créer/modifier tous les objets de bases de données DB2 d’une façon efficace, de concevoir visuellement les bases de données DB2, d’exécuter les scripts SQL, d’exporter et d’importer les données des bases de données DB2 et fournit beaucoup d’autres services qui permettent de faciliter la gestion de DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 est un outil puissant pour exporter rapidement les données des bases de données DB2 vers les dix-neuf formats disponibles y compris MS Access, MS Excel, MS Word, RTF, HTML, TXT, ODF etc. Data Export for DB2 comprend un assistant d’utilisation simple pour le réglage visuel des parametres d’exportation DB2 et l’utilitaire de ligne de commande pour automatiser les tâches d’exportation DB2 a l’aide du fichier de configuration.
dataimport | Data Import for DB2 EMS Data Import for DB2 est un outil puissant d’import de données vers les tables DB2 a partir des fichiers MS Excel 97-2007, MS Access, DBF, TXT, CSV, MS Word 2007, RTF, ODF et HTML. Cet utilitaire vous permet d’importer simultanément vos données vers une ou plusieurs tables ou vues DB2, de sauvegarder tous les parametres d’import DB2 initialisés lors de la session courante de l’assistant, d’utiliser le mode de l’insertion de lot pour l’import rapide de données vers les tables DB2.
datapump | Data Pump for DB2 EMS Data Pump for DB2 est un outil excellent de migration pour convertir les bases de données et importer les données des tables depuis n’importe quelle source compatible avec ADO (par exemple les bases de données MS Access, MS SQL ou d’autres bases de données supportant ADO) vers les bases de données IBM DB2. La conversion des bases de données a l’aide de Data Pump for DB2 est plus simple que jamais!
datagenerator | Data Generator for DB2 EMS Data Generator for DB2 – est un outil puissant de génération des données de test pour les tables des bases de données DB2. L’outil vous permet de simuler l’environnement de production de base de données, de remplir simultanément plusieurs tables des bases de données DB2 par les données de test, de définir les tables pour la génération des données, de spécifier les étendues de valeurs et de spécifier de nombreux parametres de génération pour chaque type de champ. Le programme fournit la multitude de fonctionnalités puissantes pour la génération simple et rapide des données de test DB2.
extract | DB Extract for DB2 EMS DB Extract for DB2 est un outil puissant et facile d’emploi pour la création des copies de sauvegarde des bases de données DB2 sous la forme de scripts SQL. Cette application de création des scripts SQL vous permet de sauvegarder les métadonnées de tous les objets des bases de données DB2 ainsi que les données des tables DB2 en tant que les captures instantanées. La personnalisation facile vous permet de sélectionner les objets et les données des tables nécessaires pour le vidage des bases de données DB2 et de régler d’autres options d’extraction.
query | SQL Query for DB2 EMS SQL Query for DB2 est un outil qui vous permet de construire simplement et rapidement les requetes SQL vers les bases de données DB2. La possibilité de construire visuellement les requetes SQL vers DB2 ainsi que la modification directe de texte de la requete sont possibles. L’interface utilisateur graphique vous permet de vous connecter aux bases de données DB2, de sélectionner les tables et les champs pour les requetes au serveur DB2, d’initialiser les criteres de sélection et beaucoup d’autre.
 | En savoir plus

Tools & components

advancedexport | Advanced Data Export Advanced Data Export (pour Borland Delphi et .NET) est une suite de composants qui permet de sauvegarder vos données dans les formats les plus populair pour la visualisation postérieure des données, pour leur modification, leur impression ou leur publication sur le Web postérieures. Il ne faut plus perdre son temps a convertir les données - Advanced Data Export peut accomplir toutes ces tâches et afficher le résultat au format desiré.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - une suite de composants pour Microsoft Visual Studio .NET 2003, 2005, 2008 et 2010 qui permet de sauvegarder vos données dans les formats les plus populaires pour la visualisation postérieure des données, pour leur modification, leur impression ou leur publication sur le Web postérieures. Vous pouvez exporter les données vers MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV etc! Il ne faut plus perdre son temps a convertir les données - Advanced Data Export peut accomplir toutes ces tâches et afficher le résultat au format desiré.
advancedimport | Advanced Data Import Advanced Data Import VCL (pour Borland Delphi et C++Builder) est une suite de composants, qui vous facilite l’importation simple et rapide de vos données depuis la plupart des formats populaires vers votre base de données. Il ne faut plus perdre son temps a importer les données! Advanced Data Import peut accomplir toutes les tâches et afficher le résultat au format desiré indépendamment du format d’origine.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator est une suite de composants destiné a créer rapidement et simplement les documents PDF depuis vos applications écrites en Delphi et C++ Builder. Vous n'avez plus besoin de connaître la spécification du format PDF! Advanced PDF Generator peut créer automatiquement un document nécessaire.
querybuilder | Advanced Query Builder Advanced Query Builder est une suite de composants pour Borland Delphi et C++ Builder qui facilite la conception visuelle des commandes SQL pour les clauses SELECT, INSERT, UPDATE et DELETE. Vous pouvez créer graphiquement des nouvelles requetes ou représenter graphiquement des requetes existantes dans vos applications. Advanced Query Builder a des composants pour travailler avec la syntaxe standart SQL, avec InterBase/Firebird, MySQL, PostgreSQL et d’autres dialectes SQL.
excelreport | Advanced Excel Report Advanced Excel Report est un puissant générateur de rapports au format MS Excel pour Delphi. Les éditeurs de propriétés Advanced Excel Report simples d’emploi permettent de créer rapidement des rapports au format MS Excel. Vous pouvez maintenant créer des rapports, les éditer, les sauvegarder et les afficher sur n’importe quel ordinateur.
advancedlocalizer | Advanced Localizer Advanced Localizer est une suite de composants pour Borland Delphi, qui permet d’ajouter le support muitilingue dans vos applications Delphi. Les larges possibilités de Advanced Localizer permettent de localiser les propriétés des composants de chaque forme, de générer les fichiers de langue avec les valeurs actuelles des propriétés de composants, de gérér les fichiers de localisation, d'indiquer les composants et les propriétés pour la localisation.
sourcerescuer | Source Rescuer EMS Source Rescuer est une application-assistant simple d’emploi pour Borland Delphi et C++Builder, qui permet de reconstituer un code source perdu. Si vous avez perdu le code source du projet écrit en Delphi ou C++Builder, mais vous avez un ficher exécutable, Source Rescuer va vous aider a reconstituer une partie du code source perdu. Source Rescuer peut restaurer toutes les formes de projet et les modules de données avec les propriétés et les événements définis.
 | En savoir plus


Début du travail

La capture d'écran affichée ci-dessous est l'aperçu de SQL Management Studio for Oracle. Afin d'apprendre a exécuter les opérations essentielles du programme, d'obtenir l'information nécessaire sur les fonctionnalités et l'interface du programme, s'informer a propos des possibilités de personnalisation SQL Management Studio for Oracle, suivez les liens ci-dessous :

Utilisation de Studio Agent

Sélection de la langue

Démarrage

Barre de navigation

Panneau de travail

Explorateur BD

Menu principal

Barre d'outils

Nous espérons que vous aurez plaisir a travailler avec SQL Management Studio for Oracle !


Utilisation de Studio Agent

SQL Management Studio for Oracle Agent est un programme résident qui se trouve dans la zone de notification Windows et vous aide a exécuter les opérations fondamentales de SQL Management Studio for Oracle. Veuillez double-cliquer sur l'icone Agent pour exécuter SQL Management Studio for Oracle.

En utilisant Agent SQL Management Studio for Oracle, vous pouvez exécuter les tâches supplémentaires suivantes :

  • Exécuter une tâche personnalisée ;
  • Suspendre une tâche personnalisée.

Vous pouvez lancer toutes ces actions énumérées via Studio Agent. Ce dernier peut etre appelé par un clic droit sur l'icone correspondante dans la zone de notification.

Note : pour exécuter Studio Agent lors du démarrage de Windows il suffit de sélectionner l'élément correspondant du menu.

Getting Started - Using Studio Agent


Sélection de la langue

Vous pouvez choisir la langue du programme lors du premier démarrage de SQL Management Studio for Oracle. Vous pouvez aussi modifier ces réglages plus tard en sélectionnant l'élément Options | Localisation dans le menu principal.

Getting Started - Select language

Voir aussi :

Personnaliser les réglages


Démarrage

La capture d'écran affichée ci-dessous est l'aperçu de SQL Management Studio for Oracle lors du premier démarrage. Le panneau de travail est l'élément principal de SQL Management Studio for Oracle - il permet de lancer les programmes et les utilitaires EMS en sélectionnant l'élément nécessaire sur la barre de navigation (le lancement avec un modele est aussi possible), de créer des tâches et de planifier leur exécution, d'obtenir le support technique, etc.

La barre de navigation se trouve par défaut dans la partie gauche de la fenetre de SQL Management Studio for Oracle. Vous pouvez basculer entre les différentes opérations avec les données et les bases de données Oracle en sélectionnant la barre nécessaire.

Les barres ci-dessous représentent les activités de gestion des données et des bases de données Oracle.

Voir aussi :

Barre de navigation

Panneau de travail

Explorateur BD


Menu principal

Le menu principal de SQL Management Studio for Oracle vous permet d'exécuter différentes opérations concernant l'enregistrement des bases de données, permettant de basculer entre les activités de gestion des données et des services Oracle, de lancer les outils de SQL Management Studio for Oracle, de personnaliser SQL Management Studio for Oracle, d'appeler Aide etc.

Getting Started - Main menu

Base de données

Enregistrer une base de données

Lance l'Assistant d'enregistrement des bases de données qui va vous guider pour enregistrer une base de données.

Supprimer l'enregistrement de la base de données

Supprime l'enregistrement de la base de données, la retire de l'arbre de l'explorateur de bases.

Information sur l'enregistrement de la base de données

Affiche la fenetre Information sur la base de données enregistrée.

Enregistrer un hôte

Lance l'Assistant d'enregistrement d'un hôte qui va vous guider pour enregistrer un hôte.

Supprimer l'enregistrement d'un hôte

Supprime l'enregistrement d'un hôte (y compris toutes ses bases de données), le retire depuis l'arbre de l'explorateur de bases.

Quitter

Quitte SQL Management Studio for Oracle.

Affichage

Modifie la vue de SQL Management Studio for Oracle. Vous pouvez inverser les barres d'outils et les barres de navigation, afficher ou masquer les descriptions des produits etc.

Aller a

Veuillez utiliser cet élément du menu pour basculer entre les activités de gestion des données et des services Oracle. Cet élément reproduit toutes les fonctions de la barre de navigation.

Start

Lance n'importe quel utilitaire de SQL Management Studio for Oracle.

Options

Modifie les réglages de l'interface de SQL Management Studio for Oracle et sélectionne la langue du programme.

Aide

Démarre le systeme d'aide de SQL Management Studio for Oracle. Vous permet aussi de visiter le site de SQL Management Studio for Oracle et d'enregistrer votre copie du logiciel.


Barres d'outils

La barre d'outils principale se trouve par défaut au-dessus du panneau de travail. Vous pouvez basculer entre les activités de gestion des données et des bases de données Oracle en sélectionnant l'élément nécessaire de la barre.

Les boutons suivants représentent les activités de gestion des données et des bases de données Oracle.

DBManagement Gestion des bases de données

DataManipulation Manipulation de données

DataAnalysis Analyse des données

TemplateManagement Gestion de modeles

CustomTasks Tâches

TaskScheduler Planificateur

Logs Logs

Ressources Internet

SQL Direct Studio

Support

Note : Vous pouvez personnaliser la barre d'outils principale a votre discrétion.

Vois aussi :

Personnaliser les barres d'outils


Panneau de travail

Panneau de travail - le panneau de travail est l'élément principal de SQL Management Studio for Oracle - il permet de lancer les programmes et les utilitaires EMS en sélectionnant l'élément nécessaire dans la Barre de Navigation (le lancement avec un modele est aussi possible), de créer des tâches et de planifier leur exécution, d'obtenir le support technique, etc.

Getting Started - Desktop Panel

En utilisant les éléments du panel du bureau vous pouvez :

DBManagement lancer le programme complet de gestion des bases de données (SQL Manager for Oracle) et d’effectuer tous les services de base deOracle :

  • Sauvegarde de la base (avec ou sans modele);
  • Restauration de la base (avec ou sans modele);
  • Statistiques de la base (avec ou sans modele);

DataManipulation lancer les outils intégrés de manipulation de données :

  • Data Export for Oracle (avec ou sans modele, IUG ou version console);
  • Data Import for Oracle (avec ou sans modele, IUG ou version console);
  • Data Pump for Oracle (avec ou sans modele, IUG ou version console);
  • Data Generator for Oracle (avec ou sans modele, IUG ou version console);
  • SQL Script for Oracle (avec ou sans modele, IUG ou version console);

DataAnalysis lancer les outils implémentés pour l’analyse de données :

  • Data Comparer for Oracle (avec ou sans modele, IUG ou version console);
  • DB Comparer for Oracle (avec ou sans modele, IUG ou version console);
  • DB Extract for Oracle (avec ou sans modele, IUG ou version console);
  • SQL Query for Oracle;

TemplateManagement gérer les modeles pour chaque outil et service intégré;

CustomTasks gestion des tâches diverses;

TaskScheduler gestion des tâches planifiées;

Logs gestion des journaux des tâches;

InternetResources utiliser les ressources internet disponibles :

  • visiter la page d’accueil SQL Studio;
  • parcourir les pages SQL Studio dédiées aux Questions fréquemment posées;
  • parcourir la documentation en ligne concernant les composants SQL Studio;
  • visiter les ressources apparentés au Oracle;

StudioDirect utiliser la fonctionnalité SQL Studio Direct;

Support bénéficier de l’assistance technique en ligne.

Conseil : Afin d’activer/désactiver les descriptions courtes affichées pour chaque outil dans le panel du bureau, vous pouvez utiliser l’élément ‘Afficher| Afficher les descriptions des outils’ (View | Show Tool Descriptions) du menu principal.


Barre de Navigation

La barre de navigation se trouve par défaut dans la partie gauche de la fenetre de SQL Management Studio for Oracle. Vous pouvez basculer entre les activités de gestion de données et de bases de données Oracle en sélectionnant une barre nécessaire.

Les barres ci-dessous représentent les activités de gestion de données et de bases de données :

Barre d'outils

Gestion des bases de données

Manipulation de données

Analyse de données

Gestion de modeles

Barre des tâches

Tâches

Planificateur

Logs

Barre Internet

Ressources Internet

SQL Studio Direct

Support


Explorateur BD

L'explorateur de bases se trouve par défaut au-dessous de la barre de navigation dans la fenetre de SQL Management Studio for Oracle et affiche tous les hôtes enregistrés et les bases de données. Vous pouvez ajouter et supprimer des éléments depuis l'arbre de bases de données, visualiser des informations sur l'enregistrement des hôtes, lancer les services Oracle pour les bases de données sélectionnées. L'information sur l'enregistrement des bases de données peut etre aussi utilisée dans les utilitaires appartenant a SQL Management Studio for Oracle.

Getting Started - DB Explorer

Pour ajouter un hôte ou une base de données dans l'explorateur de bases, utilisez les éléments correspondants du menu contextuel ou choisissez les éléments suivants de menu principal : Base de données | Enregistrer un hôte (Base de données | Enregistrer une base de données). Vous pouvez aussi utiliser les boutons de la barre d'outils de l'explorateur de bases.

Pour supprimer un hôte ou une base de données, utilisez les éléments correspondants du menu contextuel ou choisissez les éléments suivants du menu principal Base de données | Annuler l'enregistrement de l'hôte (Annuler l'enregistrement de la base de données). Vous pouvez aussi utiliser les boutons de la barre d'outils de l'explorateur de bases.

Pour visualiser les informations sur l'enregistrement de la base de données, sélectionnez l'élément correspondant du menu contextuel de l'explorateur de bases ou l'élément correspondant du menu principal de SQL Management Studio for Oracle.

Afin de lancer un service de Oracle pour une base de données enregistrée, vous devez :

  • sélectionner ce service dans l'arbre de l'explorateur de bases ;
  • sélectionner un service dans la section Gestion des bases de données du menu contextuel.


Gestion des données et des bases de données

Toutes les possibilités proposées par SQL Management Studio for Oracle en terme de gestion de bases de données Oracle sont divisées dans les groupes suivants :

Gestion des bases de données

Ce groupe vous permet d'administrer et de développer les bases de données en utilisant SQL Manager for Oracle ainsi que d'activer les services Oracle.

Manipulation de données

Ce groupe vous offre la possibilité d'exporter/importer les données vers les quinze formats les plus populaires. Vous pouvez transférer les données entre les différents serveurs de bases de données, générer les données de test pour les bases de données, analyser les données.

Analyse de données

Vous pouvez comparer et synchroniser le contenu et la structure des bases de données, créer les copies de sauvegarde sous forme de script SQL, analyser et récupérer les données a l'aide de la construction visuelle du script.

Gestion de modeles

Vous pouvez créer et gérer de nouveaux modeles.


Gestion des bases de données

La section Gestion des bases de données vous permet de développer et d'administrer les bases de données en utilisant SQL Manager for Oracle et d'activer les services Oracle.

Database Management - Desktop Panel

Démarrage de SQL Manager

Utilisation des services


Démarrage de SQL Manager

EMS SQL Manager for Oracle est un outil puissant d'administration et de développement de serveurs de bases de données Oracle. SQL Manager for Oracle fonctionne avec toutes les versions de Oracle entre la 8.1.7 et la 11, et supporte toutes les dernieres fonctionnalités de MySQL, y compris les vues, les procédures et les fonctions stockées, les clés étrangeres pour les tables InnoDB etc. A l'aide de l'interface conviviale, vous pouvez travailler avec les objets des bases de données, gérer les tables de données et exécuter les scripts SQL. SQL Manager for Oracle vous permet de gérer les droits des utilisateurs, travailler avec les métadonnées, exporter et importer les données vers les quinze formats les plus populaires, visualiser et éditer les champs BLOB etc.

Pour activer SQL Manager for Oracle, cliquez sur l'icône correspondante ou sur la légende qui se trouvent sur le panneau de travail.

Database Management - Running SQL Manager

SQL Manager documentation.

Voir aussi :

Utilisation des services


Utilisation des services

SQL Management Studio for Oracle vous offre l'opportunité de lancer les services Oracle nécessaires a la maintenance des tables et des bases de données. Les services suivants sont disponibles :

Database Management - Services

Sauvegarde de la base (Backup Database)

Sauvegarde des tables a partir du hôte local vers les fichiers pour les utiliser dans la suite.

Restauration de la base (Restore Database)

Restauration des tables depuis les fichiers sur le disque vers la base de données.

Collecte des statistiques (Gathering Statistics)

Collecte les diverses statistiques afin d’améliorer les performances.

Pour exécuter le service cliquez sur l'icône correspondante ou sur la légende sur le panneau de travail et suivez les étapes de l'assistant.

Voir aussi :

Gestion des bases de données


Manipulation de données

Data Manipulation vous offre la possibilité d'exporter/importer les données vers les quinze formats les plus populaires. Vous pouvez transférer les données entre différents serveurs de bases de données et générer les données de test pour les bases de données.

Getting Started - Desktop Panel

Démarrage de Data Export

Démarrage de Data Import

Démarrage de Data Pump

Démarrage de Data Generator


Démarrage de Data Export

EMS Data Export for Oracle est un outil puissant d'exportation rapide de vos données depuis les bases de données de MySQL® vers les quinze formats les plus populaires tels que MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF etc. Data Export for Oracle comprend un assistant d'utilisation simple pour le réglage visuel des parametres d'exportation de chacune des tables (les noms finals des fichiers, les champs exportés, les formats de données etc). Data Export for Oracle comprend aussi un outil en ligne de commande pour exporter rapidement des données depuis les tables et les requetes.

L'utilitaire Data Export peut etre lancé indépendamment, l'assistant vous guidera pour l'exportation de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Export.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Manipulation - Running Data Export

Data Export documentation.

Voir aussi :

Manipulation de données


Démarrage de Data Import

EMS Data Import for Oracle est un puissant outil d'exportation rapide de vos données depuis les fichiers MS Excel, MS Access, DBF, XML, TXT et CSV vers les tablesOracle. Data Import for Oracle permet d'ajuster les parametres d'importation, y compris les formats source de données pour tous les champs, les parametres des colonnes de destination pour les champs sélectionnés, les validations de données, le nombre de lignes a sauter etc. Data Import for Oracle comprend un assistant de réglage visuel des parametres d'importation pour les différents types de fichiers et d'un outil en ligne de commande pour une importation rapide.

L'utilitaire Data Import peut etre lancé indépendamment, l'assistant vous guidera pour l'importation des données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Import.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Manipulation - Running Data Import

Data Import documentation.

Voir aussi :

Manipulation de données


Démarrage de Data Pump

EMS Data Pump for Oracle est un puissant outil qui vous facilite la conversion des bases de données et l'importation des données depuis n'importe quelle source compatible avec ADO (par exemple, MS Access, les bases de données MS SQL ou n'importe quelle base de données compatible avec ADO) vers les bases de données Oracle. L'assistant simple d'emploi permet d'établir les lignes de connexion avec ADO, de sélectionner les tables, les champs et les indices a convertir, de visualiser et d'éditer le script SQL pour la création d'une base de données Oracle de destination, de sélection des tables a importer. La conversion des bases de données est plus simple que jamais grâce a Data Pump for Oracle !

L'utilitaire Data Pump peut etre lancé indépendamment, l'assistant vous guidera pour la conversion des bases de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Pump.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Manipulation - Running Data Pump

Data Pump documentation.

Voir aussi :

Manipulation de données


Démarrage de Data Generator

EMS Data Generator for Oracle est un puissant outil qui vous permet de générer instantanément les données de test pour les différentes tables des bases de données Oracle. L'assistant simple d'emploi permet de définir les tables et les champs de données a générer, de créer les champs texte en utilisant le masque, de charger les valeurs pour les champs BLOB directement depuis les fichiers, de sélectionner les listes de valeurs dans les requetes SQL et d'exécuter d'autres opérations de génération des données de test simplement et efficacement. L'utilitaire en ligne de commande permet de générer rapidement les données a l'aide de modeles de génération.

Data Generator peut etre lancé indépendamment, l'assistant vous guidera pour la génération des données de test. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Generator.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Manipulation - Running Data Generator

Data Generator documentation.

Voir aussi :

Manipulation de données


Démarrage de SQL Script

SQL Script utility is an easy-to-use tool allowing you to execute your SQL scripts fast and easy.

SQL Script peut etre lancé indépendamment, l'assistant vous guidera pour la génération des données de test. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire SQL Script.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Manipulation - Running SQL Script

SQL Script documentation.

Voir aussi :

Manipulation de données


Analyse de données

La section Analyse des données vous offre la possibilité de comparer et de synchroniser le contenu et la structure des bases de données, de créer des copies de sauvegarde sous forme de script SQL, d'analyser et de récupérer des données a l'aide de la construction visuelle du script.

Data Analysis - Desktop Panel

Démarrage de Data Comparer

Démarrage de Database Comparer

Démarrage de DB Extract

Démarrage de SQL Query


Démarrage de Data Comparer

EMS Data Comparer for Oracle est un utilitaire puissant et simple d'emploi qui effectue la comparaison et la synchronisation des données. En utilisant Data Comparer for Oracle, vous pouvez découvrir les différences entre les tables comparées et exécuter un script généré automatiquement pour éliminer ces différences. Vous pouvez sélectionner les tables et les champs a comparer et modifier d'autres parametres en utilisant les nombreux réglages du processus de comparaison et de synchronisation. Data Comparer for Oracle comprend un assistant graphique qui va vous guider pour comparer et synchroniser les données pas a pas. L'utilitaire en ligne de commande permet d'exécuter la synchronisation des données en un instant.

Data Comparer peut etre lancé indépendamment, l'assistant vous guidera pour la comparaison et la synchronisation du contenu des bases de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Comparer.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Analysis - Running Data Comparer

Data Comparer documentation.

Voir aussi :

Analyse de données


Démarrage de Database Comparer

EMS DB Comparer for Oracle est un puissant outil de comparaison de bases de données DB Comparer for Oracle ce qui vous permet de découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et les éliminer partiellement ou totalement en utilisant le script généré automatiquement. L'interface graphique intuitive vous permet de travailler simultanément sur plusieurs projets, de définir les parametres de comparaison et d'éditer les scripts de modification. Votre travail avec DB Comparer for MySQL sera plus simple et plus rapide grâce a la multitude de fonctionnalités utiles.

Database Comparer peut etre lancé indépendamment, l'assistant vous guidera pour la comparaison et la synchronisation de la structure des bases de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Database Comparer.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Analysis - Running DB Comparer

DB Comparer documentation.

Voir aussi :

Analyse de données


Démarrage de DB Extract

EMS DB Extract for Oracle est un utilitaire simple d'emploi et puissant destiné a créer des copies de sauvegarde des bases de données sous forme de scripts SQL. DB Extract for Oracle permet de sauvegarder partiellement ou completement les métadonnées des objets des bases et les données des tables. Vous pouvez sélectionner les objets et les tables des bases nécessaires et ajuster d'autres parametres a l'aide des réglages flexibles du processus d'extraction. DB Extract for Oracle comprend un assistant graphique qui vous aide a exécuter le processus d'extraction pas a pas. L'utilitaire en ligne de commande permet de créer rapidement des copies de sauvegarde des bases.

DB Extract peut etre lancé indépendamment, l'assistant vous guider pour la génération du script SQL nécessaire pour la création d'une copie de sauvegarde d'une base de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modele, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire DB Extract.

L'étiquette Gestion de modeles va vous rediriger vers la section correspondante de SQL Management Studio for Oracle.

Data Analysis - Running DB Extract

DB Extract documentation.

Voir aussi :

Analyse de données


Démarrage de SQL Query

EMS SQL Query for Oracle est un utilitaire de création simple et rapide de requetes SQL vers les bases de données Oracle. La création visuelle des requetes et l'édition du texte de la requete sont possibles simultanément. L'interface simple d'emploi permet de se connecter aux bases de données, de choisir les tables et les champs, de déterminer les criteres de sélection et de groupement, etc. Vous pouvez travailler simultanément avec plusieurs requetes, modifier les requetes, examiner les résultats d'exécution sous diverses formes et effectuer d'autres opérations nécessaires avec les requetes vers les bases de données.

Pour lancer SQL Query, veuillez cliquer sur l'icône correspondante ou sur la légende correspondante qui se trouvent sur le panneau de travail.

Data Analysis - Running SQL Query

SQL Query documentation.

Voir aussi :

Analyse de données


Gestion de modeles

Pour votre commodité, SQL Management Studio for Oracle vous offre la possibilité de créer des nouveaux modeles et de les gérer. Vous pouvez exécuter ces opérations en utilisant la section Gestion de modeles.

Template Management - Overview

Gérer les modeles existants

Créer un modele


Gérer les modeles existants

La barre d'outils Modeles vous permet d'ajouter et de supprimer les modeles dans/depuis la liste, de créer de nouveaux modeles et de supprimer les modeles existants. Vous pouvez sélectionner et lancer un outil avec un modele en un simple clic. Toutes ces opérations peuvent etre effectuées par sélection des éléments correspondants a partir du menu contextuel.

La liste déroulante Outil ou service vous permet de trier les modeles par outil ou par service sélectionnés.

Template Management - Managing existing templates

Voir aussi :

Créer un modele


Créer un modele

Pour lancer cette opération, choisissez l'élément correspondant du menu contextuel ou cliquez sur le bouton approprié de la barre d'outils Modeles. Suivant l'utilitaire ou le service pour lequel il faut créer un modele, SQL Management Studio for Oracle va lancer un outil ou un dialogue appropriés. Apres avoir passé toutes les étapes de l'assistant correspondant, vous pouvez sauvegarder tous les réglages en tant que modele.

Voir aussi :

Gérer les modeles existants


Planification et exécution des tâches

Vous trouverez ci-dessous toutes les possibilités de la section Planification & Exécution des Tâches fournies par SQL Management Studio for Oracle :

Tâches utilisateur

Cette section vous fournit les possibilités de créer, d'éditer, de supprimer et d'exécuter immédiatement des tâches. Vous pouvez économiser votre temps a l'aide du groupement des tâches. Vous pouvez créer votre propre tâche en utilisant l'éditeur des tâches intégré. Puis, vous pouvez sélectionner une notification confirmant l'exécution de la tâche.

Planification des tâches

Vous avez besoin d'exécuter régulierement une tâche ou remettre l'exécution d'une tâche ? La section Planificateur de tâches vous permet de régler l'exécution des tâches adéquates.

Gestion des traces

Cette section vous permet de contrôler l'exécution des tâches et de visualiser les résultats de l'exécution. Vous pouvez utiliser l'aperçu des traces, un filtre puissant et les options de tri de la grille pour économiser du temps.

Vous pouvez appeler n'importe laquelle de ces sections en sélectionnant l'élément approprié dans la barre de navigation.


Tâches utilisateur

Cette section vous fournit la possibilité de créer, d'éditer, de supprimer et d'éxecuter immédiatement des tâches. Vous pouvez économiser votre temps a l'aide du groupement des tâches. Vous pouvez créer votre propre tâche en utilisant l'éditeur de tâches intégré. Puis, vous pouvez sélectionner une notification confirmant l'exécution de la tâche.

Pour en savoir plus, cliquez sur les liens suivants :

Gestion des tâches

Éditeur des tâches

Modifications des parametres des notifications

Éditeur des étapes


Gestion des tâches

L'onglet Gestion des tâches vous permet de gérer vos tâches. Vous pouvez créer une nouvelle tâche ou supprimer une tâche existante a l'aide de l' élément correspondant du menu contextuel ou en cliquant sur le bouton approprié de la barre d'outils. Pour modifier une tâche existante dans l'éditeur des tâches, choisissez l'élément correspondant du menu contextuel ou cliquez sur le bouton approprié de la barre d'outils.

Vous pouvez exécuter immédiatement une tâche créé ou remettre l'exécution d'une tâche a plus tard. Pour lancer immédiatement une tâche, sélectionnez-la et cliquez sur le bouton correspondant de la barre d'outils (vous pouvez aussi exécuter cette fonction en utilisant l'élément respectif du menu contextuel).

La barre d'état d'une tâche en cours se trouve au-dessous de la fenetre Gestion des tâches. Elle affiche la liste des étapes pour une tâche actuelle, un outil nécessaire, les actions finales "Tâche réussie" ou "Erreur" et d'autres informations.

Note : vous pouvez afficher ou refermer la liste des étapes d'une tâche via le menu contextuel ou en utilisant les boutons correspondants de la barre d'outils.

Scheduling and Performing tasks - Managing task steps

Voir aussi :

Éditeur des tâches


Éditeur des tâches

La fenetre Éditeur des tâches s'ouvre automatiquement lors de la création d'une nouvelle tâche ou lors de la modification d'une tâche existante.

Pour créer une nouvelle tâche, saisissez son nom. Puis précisez les étapes nécessaires pour votre tâche dans l'onglet Étapes (chaque tâche comprend plusieurs étapes exécutées a tour de rôle).

Pour créer une nouvelle étape ou supprimer une étape existante, utilisez les éléments correspondants du menu contextuel ou cliquez sur les boutons respectifs de la barre d'outils. Pour modifier une étape existante dans l'éditeur des étapes, choisissez l'élément correspondant du menu contextuel ou cliquez sur le bouton respectif dans la barre d'outils de l'éditeur des tâches.

En outre, vous pouvez modifier l'ordre d'exécution des étapes a l'aide des boutons "Déplacer en haut" et "Descendre" de la barre d'outils. Vous pouvez aussi exécuter cette fonction en utilisant l'élément respectif du menu contextuel de l'Éditeur des tâches.

Pour en savoir plus, cliquez sur Éditeur des étapes.

La barre d'état d'une étape en cours se trouve au-dessous de l'onglet Étapes. Elle affiche le chemin vers les fichiers exécutables, le nom du modele utilisé, le chemin vers les traces, les actions finales "Tâche réussie" ou "Erreur" ainsi que d'autres informations.

Pour etre informé des résultats de l'exécution d'une tâche, vous pouvez régler les notifications optionnelles (outre les journaux de SQL Management Studio for Oracle, Visionner les journaux). Pour cela, réglez l'onglet Notifications dans l'éditeur des tâches.

En outre, vous pouvez écrire n'importe quel texte en tant que description de votre tâche. Saisissez vos commentaires dans l'onglet Description de l'Éditeur des tâches.

Scheduling and Performing tasks - Task Editor - Steps

Voir aussi :

Modification des parametres des notifications

Éditeur des étapes


Modification des parametres des notifications

Vous pouvez régler les notifications supplémentaires pour etre informé de l'exécution réussie ou échouée d'une tâche. Pour cela, utilisez l'onglet Notifications de l'éditeur des tâches. Vous pouvez sélectionner entre les modes de notification suivants : la notification Net Send, le journal systeme des applications, la notification par e-mail.

Scheduling and Performing tasks - Task Editor - Notifications

La notification Net Send

La notification net send vous permet d'envoyer les messages via net send. Vous pouvez créer dans l'éditeur correspondant un message a envoyer a un ordinateur distant.

Note : afin d'utiliser ce type de notifications, vous devez lancer le service d'affichage des messages (Panneau de configuration | Outils d'administration | Services | Service d'affichage des messages).

Le journal systeme des applications

Il vous permet d'écrire des notifications directement dans le journal systeme. Créez dans l'éditeur correspondant un message a enregistrer dans le journal systeme.

Note : pour afficher le journal systeme des applications, il vous faut ouvrir Panneau de configuration | Outils d'administration | Observateur d'événements | Application.

E-mail

Cela vous permet d'obtenir des notifications par e-mail. Veuillez créer dans l'éditeur correspondant un message a envoyer par e-mail.

Vous devez aussi remplir tous les champs nécessaires : Hôte (adresse du serveur SMTP), Port (25 par défaut) et l'adresse de destination.

Note : vous pouvez aussi utiliser les noms macro (#START, #STOP, #RESULT) dans le texte des notifications. #START - heure de début d'exécution d'une tâche,#STOP - heure de fin d'exécution d'une tâche, #RESULT - rapports sur les résultats de l'exécution d'une tâche.

Deux options d'envoi de notifications sont disponibles : "En cas de succes" et "En cas d'erreur". Le bouton Test vous permet d'envoyer le message de test immédiatement.

Voir aussi :

Éditeur des tâches


Éditeur des étapes

La fenetre de l'éditeur des tâches s'ouvre automatiquement lors de la création d'une nouvelle tâche ou lors de la modification d'une tâche existante.

Pour créer une nouvelle tâche, commencez par saisir son nom dans le champ Nom de l'étape.

Scheduling and Performing tasks - Task Editor - Step Editor

Options de l'outil

Sélectionnez l'outil, indiquez le chemin vers l'outil, réglez un modele optionnel et sélectionnez l'emplacement du journal dans les cases correspondantes.

Options des journaux

Vous pouvez spécifier ici les moyens de formation du journal de SQL Management Studio for Oracle.

L'option Enregistrer l'écran dans un journal permet d'enregistrer les données affichées sur l'écran de l'utilitaire dans le journal de SQL Management Studio for Oracle.

L'option Obtenir les traces depuis un fichier permet d'enregistrer le journal de l'utilitaire dans le journal de SQL Management Studio for Oracle.

Actions finales

Réglez les actions qui succedent a l'exécution réussie ou échouée d'une tâche. Vous pouvez procéder a l'étape suivante ou a l'étape sélectionnée, terminer l'exécution d'une tâche en affichant le rapport sur le résultat de l'exécution ("Réussie" ou "Erreur").

L'éditeur des étapes vous permet de régler le délai d'attente. Vous pouvez régler le temps nécessaire pour le délai d'attente et l'action qui succede a l'expiration du délai d'attente. Vous pouvez exécuter toutes ces actions en utilisant les cases appropriées de l'éditeur des étapes.

Traitement des erreurs

L'option Échec en cas d'erreurs graves seulement permet d'afficher le message qu'une tâche a été terminée avec succes meme si des erreurs sans gravité ont eu lieu lors de l'exécution (par exemple quand le script extract a été exécuté avec des erreurs).

L'option Limite de la taille du journal, Ko permet de limiter la taille du journal pour l'étape actuelle.

Voir aussi :

Éditeur des tâches


Planification des tâches

Vous avez besoin d'exécuter régulierement une tâche planifiée ou de remettre l'exécution d'une tâche a plus tard ? La section Planification des tâches vous permet de régler le lancement des tâches conformément a vos besoins.

Scheduling and Performing tasks - Managing scheduled tasks

Voir aussi :

Planificateur de tâches

Éditeur des tâches planifiées


Planificateur de tâches

La section Planification des tâches vous permet de planifier vos tâches. Vous pouvez planifier une nouvelle tâche ou supprimer une tâche existante a l'aide des éléments correspondants du menu contextuel ou en cliquant sur le bouton approprié de la barre d'outils. Pour modifier une tâche en cours dans l'éditeur des tâches planifiées, sélectionnez l'élément correspondant du menu contextuel ou cliquez sur le bouton de la barre d'outils du planificateur de tâches.

Vous pouvez accéder a l'information générale sur la tâche sélectionnée sur le panneau spécial qui se trouve au-dessous de la section Planification des tâches.

Afin de suspendre une tâche planifiée, vous devez sélectionner cette tâche dans la liste des tâches et cliquer sur le bouton Suspendre la tâche planifiée de la barre d'outils (cette fonction est aussi disponible dans le menu contextuel). Afin de lancer de nouveau une tâche, cliquez sur le bouton approprié de la barre d'outils ou utilisez l'élément correspondant du menu contextuel.

Note : SQL Management Studio for Oracle Agent permet de suspendre/lancer l'exécution des tâches. Cliquez avec le bouton droit de la souris sur l'icône Studio Agent qui se trouve sur la zone de notification Windows, sélectionnez le sous-menu Suspendre la tâche et cochez la tâche requise. Décochez les tâches pour les exécuter de nouveau.

Scheduling and Performing tasks - Task Scheduler

Voir aussi :

Éditeur des tâches planifiées


Éditeur des tâches planifiées

L'éditeur des tâches planifiées s'ouvre automatiquement quand vous ajoutez une nouvelle tâche planifiée ou modifiez une tâche existante.

Pour relancer l'exécution d'une tâche, il vous faut sélectionner une tâche a planifier (sélectionnez une tâche depuis la liste des tâches dans le champ Nom de la tâche).

Scheduling and Performing tasks - Schedule Editor - Daily

Puis définissez un modele de récurrence. L'éditeur des tâches planifiées vous permet d'exécuter une tâche chaque jour, semaine, mois ou année.

Chaque jour

Vous pouvez programmer le lancement d'une tâche : Tous les N jours ou les Jours de semaine (tous les jours sauf weekend).

Chaque semaine

Ce modele de récurrence vous permet de planifier une tâche pour qu'elle soit exécutée certains jours (que vous définissez) pour chaque semaine (lundi, mardi, jeudi etc. - il vous faut cocher les jours correspondants).

Scheduling and Performing tasks - Schedule Editor - Weekly

Par exemple, si vous sélectionnez "Toutes les 3 semaines le mardi", la tâche sera exécutée tous les mardi une fois toutes les trois semaines.

Chaque mois

Vous pouvez planifier une tâche pour qu'elle soit exécutée a certaines dates de chaque X mois; ou d'une autre façon - a certains jours de semaine de chaque X mois.

Scheduling and Performing tasks - Schedule Editor - Monthly

Chaque année

Vous pouvez aussi fixer une date précise de l'exécution d'une tâche (par exemple le 14 juin) ou fixer une date en utilisant le modele Chaque premier/deuxieme/... /jour de semaine de certains mois (par exemple Chaque deuxieme mardi du mois d'avril).

Scheduling and Performing tasks - Schedule Editor - Yearly

Limite de récurrence

Ce groupe de l'éditeur des tâches planifiées vous permet de spécifier la date de début et de fin de la période d'exécution d'une tâche. Pour cela, il vous faut régler la Date et l'Heure de début, puis spécifier la date limite de fin de la période de lancement.

Sans fin signifie que la tâche peut etre exécutée indéfiniment.

Finir apres X signifie que la période de lancement sera finie apres X fois l'exécution de cette tâche.

Finir avant... spécifie la date précise de fin de la période de l'exécution.

Voir aussi :

Planificateur de tâches


Gestion des traces

La section Gestion des traces vous permet de contrôler le processus de l'exécution des tâches et de visualiser le résultat de l'exécution de telle ou telle tâche. Vous pouvez économiser votre temps en utilisant l'aperçu des traces, vous pouvez aussi appliquer un filtre puissant et utiliser les options de tri de la grille.

Scheduling and Performing tasks - Managing logs

La barre d'outils Traces vous permet d'enregistrer les traces des tâches sélectionnés dans un fichier et supprimer les traces inutiles en utilisant le bouton correspondant. Vous pouvez aussi exécuter ces opérations en utilisant les éléments respectifs du menu contextuel.

Note : vous pouvez déployer ou refermer rapidement l'arbre des traces en utilisant le menu contextuel ou les boutons correspondants de la barre d'outils Logs.

La barre d'état d'un journal de traces en cours se trouve au-dessous de l'onglet Traces. Suivant les options sélectionnées pour les traces, elle affiche les données de l'écran de travail de l'utilitaire/service, les données du journal des traces de l'utilitaire/service, ou l'un et l'autre. Vous pouvez régler les options des traces lors de la création de l'étape (voir Éditeur des étapes).

La liste déroulante Afficher les traces pour la période vous permet de trier les traces des tâches par période sélectionnée.

Voir aussi :

Planification des tâches

Tâches utilisateur


Ressources en ligne

Voici les ressources en ligne de SQL Management Studio for Oracle fournies par cette section :

Ressources Internet

Vous trouvez ici les liens concernants SQL Studio et les utilitaires intégrés, les liens vers les FAQ et la documentation en ligne.

SQL Studio Direct

Cette section vous emmene directement vers la section comprenant les dernieres nouvelles d'EMS. Vous y trouvez aussi les liens vers les dernieres nouvelles de SQLManager.net, vers les descriptions des produits et les pages de téléchargement.

Support

Cette section vous renvoie directement vers le centre de support EMS (EMS Support Center). Veuillez vous identifier et poser toutes les questions nécessaires. Si vous etes un utilisateur enregistré du logiciel EMS, vous recevrez une réponse garantie dans les 24 heures.

Vous pouvez naviguer entre ces sections en utilisant les éléments appropriés de la barre de navigation.


Ressources Internet

Vous trouvez ici les liens concernants SQL Studio et les utilitaires intégrés, les liens vers les FAQ et la documentation en ligne.

Cliquez sur le lien qui vous intéresse.

Online Resources - Browsing Internet Resources


SQL Studio Direct

Cette section vous emmene directement vers la section comprenant les dernieres nouvelles d'EMS. Vous y trouvez aussi les liens vers les dernieres nouvelles de SQLManager.net, vers les descriptions des produits et les pages de téléchargement.

Online Resources - SQL Studio Direct


Support

Cette section vous renvoie directement vers le centre de support EMS (EMS Support Center) avec le navigateur incorporé. Veuillez vous identifier et poser toutes les questions nécessaires directement dans la fenetre de SQL Management Studio for Oracle.

Note : si vous etes un utilisateur enregistré du logiciel EMS, vous recevrez une réponse garantie dans les 24 heures.

Online Resources - Support Center


Personnaliser les réglages

Vous pouvez personnaliser SQL Management Studio for Oracle en utilisant cette section. Cliquez sur les liens ci-dessous afin d'obtenir les informations nécessaires.

Sélection de la langue

Personnaliser l'interface

Personnaliser les barres d'outils

Réglages de Studio Agent


Sélection de la langue

Si vous n'avez pas sélectionné la langue du programme lors du démarrage de SQL Management Studio for Oracle ou si vous avez décidé de changer la langue, utilisez l'élément Options | Localisation du menu principal. Dans la fenetre de dialogue qui apparaît, vous accédez a la liste des traductions disponibles. Sélectionnez la langue du programme et cliquez sur le bouton OK.

Options - Localization

Voir aussi :

Personnaliser les réglages


Personnaliser l'intreface

Pour votre commodité, vous pouvez modifier l'apparence et le style de l'environnement de SQL Management Studio for Oracle. Pour personnaliser l'interface du programme, sélectionnez l'élément Options | Interface du menu principal.

Note : vous pouvez appliquer l'interface de SQL Management Studio for Oracle a toutes ces applications en utilisant l'option correspondante.

Options - Interface

Voir aussi :

Personnaliser les réglages


Personnaliser les barres d'outils

Afin de rendre votre travail avec SQL Management Studio for Oracle le plus efficace possible, vous pouvez personnaliser les barres d'outils conformément a vos besoins. Cliquez avec le bouton droit de la souris sur la barre d'outils principale ou sur la barre d'outils de l'explorateur de bases et sélectionnez Personnaliser...

Dans la fenetre de dialogue qui apparait vous pouvez créer et supprimer les barres d'outils (l'onglet Barres d'outils), supprimer ou ajouter les boutons (l'onglet Commands) et changer certains réglages visuels et fonctionnels de la barre d'outils (l'onglet Options).

Pour ajouter un bouton dans la barre d'outils, il vous faut ouvrir le dialogue Personnaliser les barres d'outils et sélectionnez l'onglet Commandes. Puis sélectionnez une commande dont vous avez besoin et déplacez-la sur la barre d'outils. Par exemple, sur la barre d'outils principale, la barre d'outils de l'explorateur de bases ou une barre que vous avez créé vous-meme. Afin de supprimer le bouton, il vous faut le glisser depuis la barre d'outils.

Note : n'importe quelle barre d'outils peut etre déplacée et fixée dans la fenetre de travail de SQL Management Studio for Oracle a votre discrétion.

Options - Customizing menus and toolbars

Voir aussi :

Personnaliser les réglages


Réglages de Studio Agent

Si vous voulez que Studio Agent soit exécuté automatiquement lors du démarrage de Windows, cliquez avec le bouton droit de la souris sur l'icône Windows dans la zone de notifications et sélectionnez l'élément correspondant du menu contextuel.

Options - Setting agent options

Voir aussi :

Personnaliser les réglages


Modeles

SQL Management Studio for Oracle dispose de la possibilité de sauvegarder la suite des opérations et les parametres dans les fichiers spéciaux qu'on appelle "modeles". Les modeles sont utilisés dans les assistants, par exemple dans l'assistant d'export de données ou dans l'assistant d'import de données.

S'il y a le bouton Template dans le coin inférieur gauche de l'assistant, tous les parametres indiqués a l'aide de l'assistant peuvent etre sauvegardés dans un fichier de format correspondant. Le format spécial du modele est prévu pour chaque assistant. Ceci permet d'éviter des erreurs lors de l'ouverture du modele dans un autre assistant.

Cliquez sur le bouton Template pour ouvrir la liste des opérations.

Vous pouvez exécuter les opérations suivantes en utilisant cette liste :

  • 'Charger le modele' (Load Template),
  • 'Sauvegarder le modele' (Save Template),
  • 'Sauvegarder le paramétrage actuel comme défaut' (Save Current Settings As Default),
  • 'Réinitialiser les parametres sauvegardés' (Reset Saved settings).

Vous pouvez sauvegarder et charger le modele lors de n'importe quel étape de l'assistant.


Supported file formats

MS Excel

Format le plus populaire e-table utilisé par Microsoft® Excel (*.xls). Les fichiers de résultat sont entierement compatibles avec Microsoft® Excel versions 97-2000, 2003 et XP.

MS Access

Fichiers de format (*.mdb) Microsoft® Access avec l’utilisation de connexion ADO.

MS Word

Un des formats les plus populaires de traitement de texte utilisé par Microsoft® Word (*.doc). Les fichiers de résultat sont entierement compatibles avec Microsoft® Word versions 97-2000, 2003 et XP.

RTF

Format Rich Text (*.rtf) compatible avec la plupart des programmes de traitement de texte (ex. WordPad).

HTML

Format de fichier Hyper Text Markup Language (*.html, *.htm), la compatibilité complete avec la spécification HTML 4.0.

PDF

Format standard des publications électroniques (*.pdf).

Text file

Format de fichier texte brut (*.txt).

CSV file

Format de fichier de valeurs séparées par une virgule (*.csv).

DIF file

Format Data Interchange File (*.dif).

SYLK

Format de fichier Symbolic Links (*.slk).

Note : tous les formats texte y compris Text file, CSV, DIF, SYLK utilisés généralement pour le travail d’échange entre les formats.

LaTeX

Format de fichier spécifique (*.tex) qui est une macroextention populaire (surtout parmi les mathématiciens et physiciens) du paquet TeX développé par D.Knut.

XML

Language Markup pour les documents contenants les informations structurées (*.xml).

DBF

Format de fichier de base de données (*.dbf) utilisé par dBASE et plusieurs applications xBASE.

MS Excel 2007

Format e-table contemporain utilisé par Microsoft® Excel 2007 (*.xlsx). Les fichiers de résultat sont entierement compatibles avec Microsoft® Excel 2007.

MS Word 2007

Format contemporain de traitement de texte utilisé par Microsoft® Word 2007 (*.docx). Les fichiers de résultat sont entierement compatibles avec Microsoft® Word 2007.

ODF Spreadsheets

Format OASIS Open Document pour Office Applications - format de fichier ‘open document’ pour les feuilles de calcul (*.ods) utilisé par plusieurs applications comprenant OpenOffice.org et KOffice.

ODF text

Format OASIS Open Document pour les applications Office - le format de fichier ‘open document’ pour le traitement des documents word (*.odt) utilisé par plusieurs applications comprenant OpenOffice.org et KOffice.