Willkommen beim EMS SQL Manager for MySQL!

SQL Manager 2007 for MySQL ist leistungsstarkes Werkzeug für die Verwaltung und Entwicklung von Datenbanken des MySQL-Servers. Der SQL Manager for MySQL eignet sich für alle MySQL Versionen von 3.23 bis 6.0 und unterstützt alle relevanten Features, einschließlich der MySQL-Triggers, Views, Gespeicherten Prozeduren und Funktionen, InnoDB Fremdschlüssel, Unicode-Daten und viele weitere. Der SQL Manager for MySQL erlaubt, alle MySQL-Datenbankobjekte zu erstellen/zu bearbeiten, MySQL-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, MySQL-Datenbankdaten zu importieren und zu exportieren, MySQL-Benutzer und ihre Berechtigungen zu verwalten und viele weitere Features für eine effiziente MySQL-Verwaltung. Der SQL Manager for MySQL hat eine neue moderne grafische Benutzeroberfläche mit einem benutzerfreundlichen Assistenten, mit dem auch Einsteiger leicht zurechtkommen.

Produkteingeschaften

Volle Unterstützung aller MySQL Versionen von 3.23 bis 6.0

  • Unterstützung aller MySQL-Objekte (Tabellen, Views, UDFs, Stored Procedures und Funktionen, Triggers und Events)
  • Unterstützung aller MySQL Features und Erweiterungen
  • Unterstützung von UTF8-kodierten Daten

Effiziente Datenbankverwaltung und Navigation

  • Mehrere gleichzeitige Host/Datenbank-Verbindungen
  • Verbindung zum MySQL Server über HTTP
  • Verbindung zum MySQL Server über SSH
  • Registrieren von ausgewählten Datenbanken, um nur mit den benötigten Datenbanken zu arbeiten
  • Projekte um nur mit den ausgewählten Datenbankobjekten zu arbeiten
  • Mehrere benutzerdefinierte Tabs für jeden Baumknoten, um darauf mit einem Mausklick zuzugreifen
  • Gleichzeitiges Arbeiten mit mehreren ausgewählten Objekten
  • Gruppierung/Entgruppierung der registrierten Datenbanken über den Host-Namen

Einfache Verwaltung aller MySQL-Objekte

  • Erstellen und Löschen von Datenbanken
  • Verwaltung von Tabellen und deren Unterobjekte: Felder, Indizes, Fremdschlüssel und Trigger
  • Verwaltung von Views, Stored Funktionen und Procedures, benutzerdefinierten Funktionen (UDF's) und eingeplanten Ereignissen.
  • Duplizieren aller Datenbankobjekte

Fortgeschrittene Werkzeuge zur Datenmanipulation

  • Betrachten, Bearbeiten, Suchen, Gruppieren, Sortieren, Filtern sämtlicher Daten, die in der registrierten Datenbank gespeichert sind
  • Leistungsstarker BLOB Viewer/Editor mit mehreren Arten der Betrachtung von BLOB Daten
  • Master-Detail Ansicht zum gleichzeitigen Arbeiten mit zwei verknüpften Tabellen
  • Tabellen- und Karteiansicht zum Anzeigen der Daten
  • Unterstützung von Abfragen, die mehrere Ergebnissätze liefern
  • Kopieren und Einfügen von ausgewählten Einträgen
  • Exportieren der Daten in SQL Skript als INSERT Anweisung

Exzellentes Sicherheitsmanagement

  • Leistungsstarke Benutzer- und Rechteverwaltung
  • Grant Manager zeigt alle Berechtigungen für Datenbankobjekte in Rasterform an

Ausgezeichnete grafische und textuelle Werkzeuge für die Erstellung von Abfragen

  • Mit Hilfe des Visual Query Builder können komplizierte Abfragen ohne irgendwelche Kenntnisse der SQL Syntax erstellt werden
  • Mehrere SQL Editoren mit der Code-Vervollständigung, Syntax-Highlighting und Code-Folding
  • Ausführung großer Skripte (SQL Skript Editor)
  • SQL Formatierer (aus dem Kontextmenü des SQL Editors verfügbar)
  • Favorisierte Abfragen (Einfacheres Speichern und Benutzen von oft verwendeten Abfragen)

Eindrucksvolle Datenexport und -import Eigenschaften

  • Exportieren von Daten in die gängigsten Formaten: MS Word, MS Access, HTML, PDF, TXT, CSV, DBF, XML, ODF usw.
  • Importieren der Daten aus MS Excel, MS Access, DBF, XML, ODF, TXT and CSV
  • Kopieren der Metadaten aus einer Datenbank in eine andere, komplett oder teilweise

Report Designer mit einerm einfachen Wizard Report erstellen

  • Mit einem neuen Reports-Assistenten können einfache Reports mit ein paar wenigen Klicks erstellt werden
  • Reports werden wie Datenbankobjekte verwaltet: der Zugriff auf die Reports erfolgt direkt über den DB-Explorerbaum.

Andere nützliche Werkzeuge, um Ihre Arbeit mit dem MySQL -Server so einfach wie möglich zu machen

  • Extrahieren der Metadaten in Textdateien und in den SQL Skript Editor
  • Leistungsstarkes Druckmodul für Metadaten, um anpassbare Metadaten-Reports zu erstellen
  • HTML-Report Generator zum schnellen Erstellen eines ausführlichen HTML-Reports über Ihre Datenbank
  • SQL-Monitor
  • Werkzeug für die Erstellung Server Eigenschaften zum Ansehen und Verändern der Systemvariablen, zum Betrachten der Server-Statusinformationen

Leistungsstarker Visual Database Designer

  • Zwei Diagramm-Notationen (IDEF1x und IE)
  • Nützliches Diagramm-Navigationswerkzeug
  • Reverse Engineering
  • Mehrere Seiten in einem Diagramm, um Diagramme in verschiedene Sachgebiete zu unterteilen
  • Datenbankobjekte erstellen/bearbeiten/entfernen und visuelle Verbindungen zwischen ihnen setzen
  • Virtuelle Objekte wie z.B. Kommentare und virtuelle Relationen
  • Speichern als Bild oder Drucken als Datenbankdiagramm
  • Große Anzahl von grafischen Anpassungmöglichkeiten

Benutzerfreundliche Assistenten zum Ausführen von MySQL-Diensten

  • Datenbank-Backup
  • Wiederherstellen der Datenbank
  • Analysieren der Tabellen
  • Prüfen der Tabellen
  • Reparieren der Tabellen
  • Optimieren der Tabellen

Neue moderne grafische Benutzeroberfläche

  • Office 11 und Windows XP visuelle Schemaunterstützung
  • Neues gut beschriebenes Assistentensystem
  • Verbesserter Datenbankexplorer für das leichte Handhaben aller MySQL Objekten
  • Neue Windows-Werkzeugleiste, um zwischen den Fenstern einfach umzuschalten, wie in der Windows-Taskleiste
  • Navigationsleiste mit den Tastaturkürzeln in den meisten Fenstern
  • Speichern alle Programmeinstellungen
  • Anpassbare Werkzeugleisten für alle Programmfenster
  • Vollständig anpassbare Benutzeroberfläche
  • Leistungsfähiges Modul für grafische Optionen
  • Anpassbare Sprache der Benutzeroberfläche

Und andere nützliche Features

  • Tastaturschablonen
  • Aufgabenliste
  • Tool Manager für externe Werkzeuge


Neuigkeiten

19.06.2009 SQL Manager for MySQL 4.4.0.4 freigegeben

Was ist neu im SQL Manager 2007 for MySQL Version 4.4.0.4?

  1. Implementierung der Fähigkeit zum Suchen in Metadaten.
  2. Hinzufügen der Unterstützung für Windows 7.
  3. Prozedur- und Funktionseditoren. Jetzt werden beim Kompilieren einer Prozedur ihre Privilegien automatisch erneut erstellt.
  4. Daten-Editor. Die Operation Set to Now stellt für erneut erstellte und bearbeitete Datensätze keine Daten bereit.
  5. Prozedur-Editor.
  • Die Parameterwerte konnten nicht nach der Prozedurausführung gespeichert werden, wenn die Prozedur einen Parameter von BIGINT-Typ hatte. Dies wurde behoben.
  • Die Ausführung der Prozedur mit dem BIGINT-Parameter verursachte einen Fehler, wenn der Parameterwert mehr als 2147483648 war. Dies wurde behoben.
  6. Assistent zum Exportieren als SQL Skript. Das Programm ignorierte beim Exportieren eines SQL-Skriptes in SQL Server die Erstellung der DDL für die Tabelle. Dies wurde behoben.
  7. Assistent zum Exportieren von Daten. Das Exportieren von Daten ins Format ODF Spreadsheets führte zum Fehler ‘Cannot create basic structure’, wenn das Programm unter Windows Vista 64 gestartet wurde. Dies wurde behoben.
  8. Das Bearbeiten des SET-Feldes setzte gelegentlich den Standardwert zurück. Dies wurde behoben.
  9. Der Standardwert der Felder “BIT (1) DEFAULT ‘\0’” wurde falsch bestimmt. Dies wurde behoben.
  10. Feld-Editor. Der Standardwert der TIMESTAMP-Felder mit der aktivierten Option “on update current_timestamp” wurde nicht gespeichert. Dies wurde behoben.
  11. Weitere Verbesserungen und kleine Bugfixes.


Systemanforderungen

  • Pentium II kompatibler Prozessor 300 Megahertz (MHz) oder höher; empfohlen wird ein 600 MHz oder schnellerer Prozessor
  • Microsoft Windows NT4 mit SP4 oder später, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows Vista
  • 64 MB RAM (128 MB oder mehr empfohlen)
  • 50MB freien Speicherplatz auf der Festplatte für die Installation des Programms
  • Super VGA (800x600) Grafikkarte und Monitor oder besser; empfohlen wird Super VGA (1024x768) oder besser
  • Windows kompatible Maus
  • Verbindung zu einem lokalen oder entfernten MySQL Server


Funktionsmatrix

 | Full Version | Lite Version
Volle Unterstützung aller MySQL Versionen von 3.23 bis 6.0
Unterstützung von allen MySQL-Objekten (Tabellen, Views, UDFs, Stored Procedures und Funktionen, Trigger und Events) | + | +
Unterstützung aller MySQL Features und Erweiterungen | + | +
Unterstützung von UTF8-kodierten Daten | + | +
Effiziente Datenbankverwaltung und Navigation
Mehrere gleichzeitige Host-/Datenbank-Verbindungen | + | +
Verbindung zum MySQL Server über HTTP-Protokoll und HTTP-Tunneling | + | +
Verbindung zum MySQL Server über HTTP-Protokoll und SSH-Tunneling | + |
Registrieren von ausgewählten Datenbanken, um nur mit den benötigten Datenbanken zu arbeiten | + | +
Projekte, um nur mit den ausgewählten Datenbankobjekten zu arbeiten | + | +
Mehrere benutzerdefinierte Tabs für jeden Baumknoten, um darauf mit einem Mausklick zuzugreifen | + | +
Gleichzeitiges Arbeiten mit mehreren ausgewählten Objekten | + | +
Gruppierung/Aufhebung der Gruppierung der registrierten Datenbanken über den Host-Namen | + | +
Einfache Verwaltung aller MySQL-Objekte
Erstellen und Löschen von Datenbanken | + | +
Verwaltung von Tabellen und deren Unterobjekte: Felder, Indizes, Fremdschlüssel und Trigger | + | +
Verwaltung von Views, Stored Funktionen und Procedures, benutzerdefinierten Funktionen (UDF) und eingeplanten Ereignissen | + | +
Duplizieren aller Datenbankobjekte | + | +
Fortgeschrittene Werkzeuge zur Datenmanipulation
Betrachten, Bearbeiten, Suchen, Gruppieren, Sortieren, Filtern sämtlicher Daten, die in der registrierten Datenbank gespeichert sind | + | +
Leistungsstarker BLOB Viewer/Editor mit mehreren Arten der Betrachtung von BLOB Daten | + |
Master-Detail Ansicht zum gleichzeitigen Arbeiten mit zwei verknüpften Tabellen | + |
Tabellen- und Karteiansicht zum anzeigen der Daten | + |
Unterstützung von Abfragen, die mehrere Ergebnissätze liefern | + | +
Kopieren und Einfügen von ausgewählten Einträgen | + |
Exportieren der Daten in SQL Skript als INSERT Anweisung | + |
Exzellentes Sicherheitsmanagement
Leistungsstarke Benutzer- und Rechteverwaltung | + | +
Grant Manager zeigt alle Berechtigungen für Datenbankobjekte in Rasterform an | + | +
Ausgezeichnete grafische und textuelle Werkzeuge für die Erstellung von Abfragen
Mit Hilfe des Visual Query Builders können komplizierte Abfragen ohne irgendwelche Kenntnisse der SQL Syntax erstellt werden | + |
Mehrere SQL Editoren mit der Code-Vervollständigung, Syntax-Highlighting | + | +
Ausführung großer Skripte (SQL Skript Editor) | + | +
SQL Formatierer (aus dem Kontextmenü des SQL Editors verfügbar) | + |
Favorisierte Abfragen (einfacheres Speichern und Benutzen von oft verwendeten Abfragen) | + | +
Eindrucksvolle Datenexport und -import Eigenschaften
Exportieren von Daten in die gängigsten Formaten: MS Excel, MS Word, MS Access, HTML, PDF, TXT, CSV, DBF, XML, ODF usw. | + |
Importieren von Daten aus MS Excel, MS Access, DBF, XML, ODF, TXT and CSV | + |
Kopieren von Metadaten aus einer Datenbank in eine andere, komplett oder teilweise | + |
Report Designer mit einerm einfachen Report-Assistenten erstellen
Mit einem neuen Reports-Assistenten können einfache Reports mit ein paar wenigen Klicks erstellt werden | + |
Reports werden wie Datenbankobjekte verwaltet: der Zugriff auf die Reports erfolgt direkt über den DB-Explorerbaum | + |
Andere nützliche Werkzeuge, um die Arbeit mit dem MySQL -Server so einfach wie möglich zu machen
Extrahieren der Metadaten in Textdateien und in den SQL Skript Editor | + |
Leistungsstarkes Druckmodul für Metadaten, um anpassbare Metadaten-Reports zu erstellen | + |
HTML-Report Generator zum schnellen Erstellen eines ausführlichen HTML-Reports über die Datenbank | + |
SQL-Monitor | + | +
Werkzeug für die Erstellung der Server Eigenschaften zum Ansehen und Verändern der Systemvariablen, zum Betrachten der Server-Statusinformationen | + |
Leistungsstarker Visual Database Designer
Zwei Diagramm-Notationen (IDEF1x und IE) | + |
Nützliches Diagramm-Navigationswerkzeug | + |
Reverse Engineering | + |
Mehrere Seiten in einem Diagramm, um Diagramme in verschiedene Sachgebiete zu unterteilen | + |
Datenbankobjekte erstellen/bearbeiten/entfernen und visuelle Verbindungen zwischen ihnen setzen | + |
Virtuelle Objekte wie z.B. Kommentare und virtuelle Relationen | + |
Speichern als Bild oder Drucken als Datenbankdiagramm | + |
Große Anzahl von grafischen Anpassungmöglichkeiten | + |
Benutzerfreundliche Assistenten zum Ausführen von MySQL-Diensten
Datenbank-Backup | + |
Wiederherstellen der Datenbank | + |
Analysieren der Tabellen | + |
Prüfen der Tabellen | + |
Reparieren der Tabellen | + |
Optimieren der Tabellen | + |
Neue moderne grafische Benutzeroberfläche
Office 11 und Windows XP visuelle Schemaunterstützung | + | +
Neues gut beschriebenes Assistentensystem | + | +
Verbesserter Datenbankexplorer für das leichte Handhaben aller MySQL Objekten | + | +
Neue Windows-Symbolleiste, um zwischen den Fenstern einfach umzuschalten (wie in der Windows-Taskleiste) | + | +
Navigationsleiste mit den Tastaturkürzeln in den meisten Fenstern | + | +
Speichern alle Programmeinstellungen | + | +
Anpassbare Symbolleisten für alle Programmfenster | + | +
Vollständig anpassbare Benutzeroberfläche | + | +
Leistungsfähiges Modul für grafische Optionen | + | +
Anpassbare Sprache der Benutzeroberfläche | + | +
Weitere nützliche Features
Tastaturschablonen | + | +
To-do-Liste | + | +
Tool Manager für externe Werkzeuge | + | +


Installation

Installation von SQL Manager 2007 for MySQL

  • Die Installationsdatei des Programms von der Download-Seite muss herunter geladen werden,
  • Die heruntergeladene Datei muss in das gewünschte Verzeichnis (zum Beispiel, c:\unzipped) entpackt werden,
  • Danach öffnet man die Datei setup.exe und befolgt man den Anweisungen im Installator-Assistenten,
  • Nach dem Installationsprozess sind die Programmverknüpfungen in Start->Programme->EMS zu finden.

Häufig gestellte Fragen zur Installation

Programmaktualisierung

  • Die Ausführungsdatei muss von der Download-Seite unserer Website herunter geladen werden,
  • Die heruntergeladene Datei muss in das gewünschte Verzeichnis (zum Beispiel, c:\unzipped) entpackt werden,
  • Das Programm SQL Manager 2007 for MySQL wird geschlossen, wenn dieses gestartet wurde,
  • Die Dateien im Ordner, der SQL Manager 2007 for MySQL enthält, sind durch die neuen zu ersetzen.

Man kann auch die Programmversion aktualisieren, indem Sie die neue Version darüber installieren.


Erwerb und Registrierung

Um den Erwerb unserer Softwareprodukte zu erleichtern, haben wir einen Vertrag mit dem Registrierungsdienst share-it! abgeschlossen. Der Kaufprozess vom Produkt über share-it! wird durch eine Sicherheitsverbindung geschützt und macht die Online-Bestellung mit der Kreditkarte schnell und sicher.

Haben Sie die Software von EMS online bestellt und möchten sich die Infos über Ihre Bestellung ansehen oder haben Sie Fragen zur Ihrer Bestellung, Bezahlung, Lieferung der Software, dann besuchen Sie bitte den Dienst Customer Care Center, der von share-it zur Verfügung gestellt wird.

Beachten Sie bitte, dass alle unsere Produkte ausschließlich über ESD (elektronische Software-Lieferung) geliefert werden. Nach Erwerb können Sie sofort die Registrierungschlüssel bzw. Kennwörter oder Links auf alle Archive der vollständigen Programmversionen downloaden. Sie erhalten auch eine Kopie der Registrierungsschlüssel oder Kennwörter per Email.

Falls Sie den Registrierungsschlüssel innerhalb der 2 Stunden nicht erhalten haben, kontaktieren Sie bitte unseren Supportdienst: dach-sales@sqlmanager.net.

Sind Sie ein registrierter Benutzer, dann wenden Sie sich bitte bei Problemen oder Fragen während dem Einsatz unserer Software an unseren Supportdienst.

Neues Konto anlegen.

Produkte

Beschreibung des Produktes |
EMS SQL Manager for MySQL (Business) + 3 Jahre Softwarewartung | Kaufen!
EMS SQL Manager for MySQL (Business) + 2 Jahre Softwarewartung | Kaufen!
EMS SQL Manager for MySQL (Business) + 1 Jahr Softwarewartung | Kaufen!
EMS SQL Manager for MySQL (Non-Commercial) + 3 Jahre Softwarewartung | Beantragen!
EMS SQL Manager for MySQL (Non-Commercial) + 2 Jahre Softwarewartung | Beantragen!
EMS SQL Manager for MySQL (Non-Commercial) + 1 Jahre Softwarewartung | Beantragen!


Lizenzvereinbarung

Lizenzvereinbarung für den Einsatz der SHAREWARE-Version der Software

Lizenzvereinbarung für den Einsatz der FREEWARE-Version der Software

Lizenzvereinbarung für den Einsatz der SHAREWARE-Version der Software.

Urheberrechte (C) 1999-2008 EMS Database Management Solutions, Inc. Alle Rechte vorbehalten.

WICHTIG: BEVOR SIE DIE SOFTWARE NUTZEN, LESEN SIE BITTE DIESE LIZENZVEREINBARUNG SORGFÄLTIG.

ENDBENUTZER LIZENZVEREINBARUNG

EMS Database Management Solutions, Inc. ("EMS") gewährt dem Benutzer («BENUTZER») eine Kopie des Software Produkts (im Folgenden als "SOFTWARE" bezeichnet) und eine Lizenz mit dem Recht, die Software zu benutzen. Diese LIZENZVEREINBARUNG ("LIZENZ") legt fest, was der BENUTZER mit diesem Produkt tun darf und enthält die Garantie- und Haftungsbeschränkungen. Im Fall der Verletzung der Bedingungen dieser LIZENZ durch den BENUTZER kann EMS zu jeder Zeit ohne Benachrichtigung die LIZENZ für ungültig erklären. Das Copyright und alle anderen Rechte am Produkt bleiben bei EMS.

LIZENZ FÜR UNREGISTRIERTE KOPIE DER SOFTWARE

Der BENUTZER kann die Software Testversion (im folgenden "UNREGISTRIERTE SOFTWARE") zu Evaluierungszwecken 30-Tage nach der Erstinstallation der UNREGISTRIERTE SOFTWARE benutzen. Am Ende der Evaluierunsperiode ("Test-Periode") muss der BENUTZER sämtliche Kopien der Software von seinem Rechner löschen oder einen Lizenzschlüssel erwerben. Es ist erlaubt, die UNREGISTRIERTE SOFTWARE frei zu kopieren und anderen Benutzern für Evaluierungszwecke zur Verfügung zu stellen.

LIZENZ FÜR REGISTRIERTE SOFTWARE

Der BENUTZER darf höchstens eine REGISTRIERTE KOPIE der Software zur gegebenen Zeit auf einem Computer oder Computernetz benutzen. Wenn beabsichtigt wird, die Software für mehr als einen Benutzer zu verwenden, ist für jeden weiteren Benutzer eine separate Lizenz zu erwerben. Der BENUTZER darf eine Kopie des Produktes als Backup erstellen.

VERBREITUNG DER UNREGISTRIERTEN KOPIE

Die UNREGISTRIERTE SOFTWARE kann frei kopiert werden und anderen Benutzern übertragen werden, vorausgesetzt, die folgenden Bedingungen sind erfüllt. Wenn der BENUTZER die uninstallierte UNREGISTRIERTE KOPIE zum Herunterladen anbietetet, dann verpflichtet sich der BENUTZER:

(1) die uninstallierte UNREGISTRIERTE KOPIE durch die neue Programmversion sofort nach ihrer Veröffentlichung durch EMS zu ersetzen;

(2) die UNREGISTRIERTE KOPIE sofort nach Empfang der schriftlichen Benachrichtigung von EMS zu löschen.

LIZENZLAUFZEIT

Diese Lizenz hat Gültigkeit solange der BENUTZER das Programm benutzt und/oder die UNRIGESTRIERTE KOPIE in Einklang mit den Bedingungen dieser Vereinbarung verbreitet. Im Fall der Verletzung der Bedingungen wird diese LIZENZ für ungültig erklärt. Die unten genannten Garantie- und Haftungsbeschränkungen bleiben allerdings weiterhin in Kraft, auch wenn die Lizenzvereinbarungen hinfällig geworden sind.

ANNAHME DER BEDINGUNGEN DIESER LIZENZVEREINBARUNG

Mit dem Herunterladen und/oder der Installation dieser SOFTWARE erklären Sie Ihr Einverständnis mit den Bestimmungen dieser VEREIBARUNG.

GARANTIE- UND HAFTUNGSBESCHRÄNKUNGEN

Die Software wird "wie sie ist" zur Verfügung gestellt. Die Firma EMS garantiert nicht, dass die Software fehlerfrei ist. Das gesamte Risiko, das aus der Nutzung der Software entsteht liegt beim Benutzer. Soweit gesetzlich zulässig, ist EMS in keinem Fall haftbar für irgendwelche Folgeschäden, zufälligen, indirekten oder anderen Schäden welcher Art auch immer (einschließlich, aber nicht beschränkt auf Schäden aus entgangenem Gewinn, Geschäftsunterbrechung, Verlust von geschäftlichen Informationen oder Vermögensschäden), die aus der Verwendung oder der Unmöglichkeit der Verwendung des Softwareproduktes resultieren, selbst wenn EMS auf die Möglichkeit solcher Schäden hingewiesen worden ist. Die gesamte Haftung ist in allen Fällen beschränkt auf den tatsächlich für die Software gezahlten Preis.

ANDERE BESCHRÄNKUNGEN

Der BENUTZER darf die SOFTWARE nicht vermieten, verleasen, unterlizensieren, übersetzen, deassemblieren, rekonstruieren, decompilieren, modifizieren oder als Teil mit einem anderen Produkt oder einer Sammlung anderer Produkte verbinden oder Nebenprodukte erstellen. Die Rechte unter dieser Lizenz dürfen nicht auf Anrede übertragen werden ohne die vorherige schriftliche Erlaubnis von EMS.

UNGÜLTIGE BESTIMMUNGEN
Wenn eine Bestimmung dieser LIZENZ für ungültig oder nicht durchsetzbar gehalten wird, soll die Gültigkeit aller anderen Bestimmungen vollständig in Kraft bleiben und eine vollständige ähnliche gesetzliche Wirkung haben.
Dabei muss jede Bestimmung, die für ungültig oder nicht durchsetzbar gehalten wird, durch eine möglichst gleiche Bestimmung, die für gültig oder durchsetzbar gehalten wird, ersetzt werden.

ALLGEMEINE LIZENZ

Diese Lizenz ist die ganze Vereinbarung zwischen EMS und BENUTZER und steht über allen anderen mündlichen oder schriftlichen Vereinbarungen und kann nicht ohne schriftliche Zustimmung geändert werden.

Lizenzvereinbarung für den Einsatz der KOSTENFREIEN Version der Software.

Urheberrechte (C) 1999-2007 EMS Database Management Solutions, Inc. Alle Rechte vorbehalten.

WICHTIG: BEVOR SIE DIE SOFTWARE NUTZEN, LESEN SIE BITTE DIESE LIZENZVEREINBARUNG SORGFÄLTIG.

ENDBENUTZER LIZENZVEREINBARUNG

EMS Database Management Solutions, Inc. ("EMS") gewährt dem Benutzer («BENUTZER») eine Kopie des Software Produkts (im Folgenden als "SOFTWARE" bezeichnet) und eine Lizenz mit dem Recht, die Software zu benutzen. Diese LIZENZVEREINBARUNG ("LIZENZ") legt fest, was der BENUTZER mit diesem Produkt tun darf und enthält die Garantie- und Haftungsbeschränkungen. Im Fall der Verletzung der Bedingungen dieser LIZENZ durch den BENUTZER kann EMS zu jeder Zeit ohne Benachrichtigung die LIZENZ für ungültig erklären. Das Copyright und alle anderen Rechte am Produkt bleiben bei EMS.

LIZENZ FÜR PROGRAMM

Diese LITE-Vesion der Software ist KOSTENLOS und kann vom BENUTZER ohne irgendwelche Einschränkungen zeitlich unbegrenzt und auf einer beliebigen Anzahl von Computern eingesetzt werden. Die LITE-Version des PROGRAMMS ist funktionsfähig und enthält KEINE ADWARE oder SRYWARE.

VERBREITUNG DES PROGRAMMS

Die LITE-Version der SOFTWARE kann frei kopiert und an andere Benutzer ohne Einschränkungen verteilt werden.

LIZENZLAUFZEIT

Diese Lizenz hat Gültigkeit solange der BENUTZER das Programm benutzt und/oder das PROGRAMM in Einklang mit den Bedingungen dieser Vereinbarung verbreitet. Im Fall der Verletzung der Bedingungen wird diese LIZENZ für ungültig erklärt. Die unten genannten Garantie- und Haftungsbeschrankungen bleiben allerdings weiter in Kraft, auch wenn die Lizenzvereinbarungen hinfällig geworden sind.

ANNAHME DER BEDINGUNGEN DIESER LIZENZVEREINBARUNG

Mit dem Herunterladen und/oder der Installation dieser SOFTWARE erklären Sie Ihr Einverständnis mit den Bestimmungen dieser VEREIBARUNG.

GARANTIE- UND HAFTUNGSBESCHRÄNKUNGEN

Die Software wird "wie sie ist" zur Verfügung gestellt. Die Firma EMS garantiert nicht, dass die Software fehlerfrei ist. Das gesamte Risiko, das aus der Nutzung der Software entsteht, liegt beim Benutzer bzw. Dritten. Soweit gesetzlich zulässig, ist EMS in keinem Fall haftbar für irgendwelche Folgeschäden, zufälligen, indirekten oder anderen Schäden welcher Art auch immer (einschließlich, aber nicht beschränkt auf Schäden aus entgangenem Gewinn, Geschäftsunterbrechung, Verlust von geschäftlichen Informationen oder Vermögensschäden), die aus der Verwendung oder der Unmöglichkeit der Verwendung des Softwareproduktes resultieren, selbst wenn EMS auf die Möglichkeit solcher Schäden hingewiesen worden ist. Die gesamte Haftung ist in allen Fällen beschränkt auf den tatsächlich für die Software gezahlten Preis.

ANDERE BESCHRÄNKUNGEN

Der BENUTZER darf die SOFTWARE nicht vermieten, verleasen, unterlizensieren, übersetzen, deassemblieren, rekonstruieren, decompilieren, modifizieren oder als Teil mit einem anderen Produkt oder einer Sammlung anderer Produkte verbinden oder Nebenprodukte erstellen. Die Rechte unter dieser Lizenz dürfen nicht auf Anrede übertragen werden ohne die vorherige schriftliche Erlaubnis von EMS.

UNGÜLTIGE BESTIMMUNGEN
Wenn eine Bestimmung dieser LIZENZ für ungültig oder nicht durchsetzbar gehalten wird, soll die Gültigkeit aller anderen Bestimmungen vollständig in Kraft bleiben und eine vollständige ähnliche gesetzliche Wirkung haben.
Dabei muss jede Bestimmung, die für ungültig oder nicht durchsetzbar gehalten wird, durch eine möglichst gleiche Bestimmung, die für gültig oder durchsetzbar gehalten wird, ersetzt werden.

ALLGEMEINE LIZENZ

Diese Lizenz ist die ganze Vereinbarung zwischen EMS und BENUTZER und steht über allen anderen mündlichen oder schriftlichen Vereinbarungen und kann nicht ohne unterschriebene Zustimmung geändert werden.


Vorherige Versionen

22.08.2008 | Freigabe des SQL Managers 2007 for MySQL Version 4.4.0.1
26.02.2008 | Freigabe des SQL Managers 2007 for MySQL Version 4.3.0.1
02.11.2007 | Freigabe des SQL Managers 2007 for MySQL Version 4.2.0.1
07.06.2007 | Freigabe des SQL Managers 2007 for MySQL Version 4.1
19.04.2007 | Freigabe des SQL Managers 2007 for MySQL
20.06.2006 | Freigabe des SQL Managers 2005 for MySQL Version 3.7
28.03.2006 | Freigabe des SQL Managers 2005 for MySQL Version 3.6.5
02.02.2006 | Freigabe des SQL Managers 2005 for MySQL Version 3.6.

22.08.2008 SQL Manager for MySQL 4.4.0.4 freigegeben

Was ist neu im SQL Manager 2007 for MySQL Version 4.4.0.4?

  1. Tabelleneditor.
  • Bei der Verbindung über das HTTP-Tunneling ist jetzt das Filtern von Daten möglich.
  • Unicode wird jetzt korrekt im DB Explorer angezeigt.
  • Partielle Unterstützung von OpenGIS-Feldern ist implementiert.
  • Die Deaktivierung der Option „Use dimension“ in DOUBLE-Feldern wurde gelegentlich ignoriert. Dies wurde behoben.
  2. Datenbank kopieren. Beim Kopieren einer Datenbank, deren Quell- und Zielserverversionen unterschiedlich sind, werden die Einschränkungen der Kommentarlänge für Tabellen und Felder berücksichtigt.
  3. Datenbanken extrahieren.
  • Bei der aktivierten Optionen „Add DELIMITER“ und „Generate DROP IF EXISTS statements for objects“ generierte das Programm gelegentlich falsches Ergebnisskript wegen des falschen Platzes des Trennzeichens der DROP-Anweisung. Dies wurde behoben.
  • Die Datenbankstruktur mit zirkularen Tabellenabhängigkeiten wurde gelegentlich nicht korrekt extrahiert. Dies wurde behoben.
  • Wenn die Option „Record in block“ den Wert “1” hat, werden die Kommentare vor jedem extrahierten Datensatz nicht hinzugefügt.
  • Wenn der Client-Zeichensatz als Windows Charset” eingestellt war, erhalt die Anweisung SET NAMES den falschen Zeichensatz. Dies wurde behoben.
  4. Sicht duplizieren. Der Sichtname blieb unverändert im Ergebnisskript. Dies wurde behoben.
  5. Datenexport. Das Öffnen einer Datei, die ins Format Excel 2007 exportiert wurde, schlug fehl und dabei trat der Fehler “Excel found unreadable content in libri.xlsx” auf. Dies wurde behoben.
  6. Trigger View. Wenn der Anwender keine Rechte SELECT FROM für Tabelle mysql.user hatte, schlug der Versuch einen Trigger zu bearbeiten, fehl. Dies wurde behoben.
  7. Prozedureneditor.
  • Die Prozedur wurde gelegentlich nicht korrekt bearbeitet, wenn der Prozedurkörper den Marker enthielt:
    main: Begin
    …
    END main
    Dies wurde behoben.
  • Bei der Ausführung einer Prozedur wurden die OUT-Parameterwerte als NULL angezeigt. Dies wurde behoben.
  8. SQL Editor. Die Tastenkombinationen Ctrl+C und Ctrl+V funktionierten gelegentlich nicht. Dies wurde behoben.
  9. Die Option "Restore Desktop on connection" funktionierte gelegentlich nicht. Dies wurde behoben.
  10. Weitere kleine Verbesserungen und Bugfixes.

26.02.2008 SQL Manager for MySQL 4.3.0.1 freigegeben

Was ist neu im SQL Manager 2007 for MySQL Version 4.3.0.1?

  1. DB Explorer
  • Hinzufügen einer Suchleiste zum schnellen Suchen innerhalb der Struktur;
  • Fensterliste ist jetzt im DB-Bereich verfügbar, die entsprechende Registerkarte wurde hinzugefügt.

2. Hinzufügen der UTF8-Unterstützung von Metadaten.

  • Procedures, Functions und Triggers mit nationalen Zeichen werden jetzt korrekt compiliert, unabhängig von den Betriebssystemeinstellungen.
  • Nationale Zeichen werden jetzt auch korrekt in ENUM-Feldern angezeigt.

3. Automatisches Wiederherstellen der verloren gegangenen DB-Verbindung: Die entsprechende Option 'Automatically reconnect when connection is lost' wurde in den Optionsbereich des Dialogs Datenbank Registrierungsinfo hinzugefügt.

4. Hinzufügen vom Tool zum Finden der Option (Find Option Tool) sowohl ins Einstellungsformular des SQL Managers, als auch in Datenbank Registrierungsinfo- und Hostregistrierungsformular. Das Tool erlaubt eine gewünschte Option in einer Vielzahl der Programmeinstellungen durch ein Wort bzw. Ausdruck aus dem Titel zu finden.

5. Tabelleneditor. Unterstützung der FEDERATED-Tabellen implementiert.

6. Assistent zum Extrahieren von Datenbanken

  • Erhöhung der Geschwindigkeit beim Arbeiten mit großen Datenbanken.
  • Jetzt kann man Delimiter-Anweisungen nach dem Extrahieren von Procedures und Triggers hinzufügen: Die Option 'Add DELIMITER statements for stored routines and triggers' ist jetzt im Assistenten verfügbar.
  • Hinzufügen von Kommentaren ist jetzt optional: Die Option 'Insert comments' wurde in den Assistenten hinzugefügt.

7. Assistent zum Importieren von Daten

  • Automatische Zuordnung der Tabellenfelder mit Textspalten.
  • Bestimmen der Verschlüsselung für importierte TXT- und CSV-Dateien.
  • Das Auswählen von ANSI- oder OEM -Parametern beim Importieren aus einer DBF-Datei brachte kein Ergebnis. Dies wurde behoben.

8. Visueller Datenbank-Designer

  • Anzeigen des Fremdschlüsselnamens im Diagramm: Die Option 'Draw FOREIGN KEY name' hinzugefügt.
  • Hinzufügen der Funktion 'Materialize virtual relation', die kann bei der Erstellung eines Fremdschlüssels auf der Basis einer virtuellen Relation verwendet werden.
  • Tabellengröße wird jetzt im Diagramm angezeigt.
  • Beim Löschen der Fremdschüssel wird die Bestätigung aufgefordert.

9. Wiederherstellen von Tabellen. Jetzt kann man manuell die Namen der Tabellen, die in Datenbank nicht vorhanden sind, zum Wiederherstellen eingeben.

10. Assistent zum Exportieren von Daten

  • Es ist möglich, beim Exportieren eines Abfrageergebnisses den Abfragentext zur Kopfzeile und/oder zur Fußzeile der Ausgabedatei hinzuzufügen: die entsprechenden Schaltflächen 'Add to Header’/’Add to Footer' wurden hinzugefügt.
  • Der Fehler 'Out of memory' trat gelegentlich beim Exportieren einer Vielzahl von Datensätzen (mehr als 1000000) auf. Dies wurde behoben.

11. Trigger-Editor

  • Möglichkeit zum Hinzufügen und Bearbeiten von DEFINER für Triggers.
  • Codevervollständigung funktionierte nach dem Tabellennamen und Punkt (.) nicht. Dies wurde behoben.

12. Die Werte von unsigned bigint- und unsigned int-Felder, die 2.147.483.647 überschreiten, werden jetzt korrekt angezeigt und bearbeitet.

13. Registerkarten von Rasteransicht und Formularansicht

  • Nulldaten (0000-00-00) werden jetzt korrekt auf dem Tab Form View angezeigt und bearbeitet.
  • Jetzt ist es möglich, Zeit innerhalb des gesamten durch MySQL unterstützten Bereiches von 838:59:59' bis '838:59:59' zu bearbeiten. Man muss einfach das Format 'hhh:nn:ss' zum Anzeigen der Zeit auswählen (the Grid | Color & Formats section of the Environment Options dialog/ zu dt. Grid | Farbe & Formate im Dialog der Umgebungsoptionen).

14. SQL Editor

  • Bei der deaktivierten Option 'Group undo' wird das Rollback logischer ausgeführt.
  • Verbesserung der Funktion Code Folding für zusammengesetzte Abfrage.
  • Erhebliche Erhöhung der Leistungsgeschwindigkeit des Editors: Features wie Syntaxhervorhebung, Objekthyperlinks werden bei der Bearbeitung der großen Skripts nicht deaktiviert.

15. Procedure-Editor. Ein Fehler trat gelegentlich nach dem Compilieren von Procedures mit Namen länger als 60 Zeichen auf. Dies wurde behoben.

16. Assistent zum Speichern von Daten Die Vorlagen funktionierten nicht. Dies wurde behoben.

17. Die Option Execute from file funktionierte für UNICODE-Dateien nicht. Dies wurde behoben.

18. Weitere kleine Verbesserungen und Bugfixes.

02.11.2007 SQL Manager for MySQL 4.2 freigegeben

Was ist neu im SQL Manager 2007 for MySQL Version 4.2.0.1?

  1. Verbesserung der Herstellung von Abhängigkeiten auf den jeweiligen Editor-Tabs.

2. SQL Editor. Wesentliche Verbesserung des Features für die Code-Vervollständigung. Das Highlighting der reservierten Wörter von MySQL 6.0 ist implementiert.

3. Beim Einstellen des koreanischen Gebietsschemas wurden gelegentlich die Zeichendaten in Tabellen nicht korrekt angezeigt. Dies wurde behoben.

4. Datenbank erstellen. Beim Auswählen von UTF8-kodierten Daten trat ein Fehler im Zeichensatzfeld auf. Dies wurde behoben.

5. View Editor. Beim Auswählen des Punktes Mit Query Builder bearbeiten stürzte das Programm gelegentlich ab. Dies wurde behoben.

6. Datenbank extrahieren. Beim Extrahieren von Prozeduren und Funktionen wurden die leeren Kommentare nicht korrekt extrahiert. Dies wurde behoben.

7. Verbesserung der deutschen Lokalisierung.

8. Hinzufügen von russischer Lokalisierung.

9. Hinzufügen von polnischer Lokalisierung.

10. Weitere kleine Verbesserungen und Bugfixes.

SQL Manager 2007 for MySQL Version 4.1 freigegeben

Was ist neu im SQL Manager 2007 for MySQL?

  1. SQL-Editor: Hinzufügen eines Tipps zum Auflisten der Parameter für Prozeduren und Funktionen. Der Tipp kann manuell mit Ctrl+Shift+Space aufgerufen werden.
  2. Prozedur-Editor, Funktion-Editor: Maximieren des Editor-Fensters für die SQL-Definition.
  3. Im BLOB-Editor ist jetzt die Navigation durch die TEXT-Felder möglich.
  4. Wesentliche Verkürzung der Laufzeit vom Werkzeug zum Extrahieren der Datenbank.
  5. Update von allen Assistenten: Beim wiederholten Drücken der Schaltfläche Fertig werden jetzt die Bestätigungsaufforderungen aufgetaucht.

Behoben:

  1. Bei der Verbindung durch HTTP-Tunneling mit einer Datenbank trat ein Fehler in der Datendarstellung im Tabellen-Editor auf dem Datenreiter auf. Dies wurde behoben.
  2. Der Fehler "Illegal mix of collation" ("Mix von Kollation nicht erlaubt"), der bei der Ausführung mancher SQL-Befehlen in MySQL 4.1 - 5.0. auftrat, wurde behoben.
  3. Drucken der Metadaten: beim Versuch, die Metadaten mit der Papiergröße “Letter” zu drucken, trat ein Fehler auf. Dies wurde behoben.
  4. SQL-Skript: Ausführung der Reihenfolge wie
    OPTIMIZE TABLE table1, table2;
    FLUSH TABLES;
    verursachte einen "out of sync" Fehler. Dies wurde behoben.
  5. Dienste | Tabellen optimieren: beim Versuch, InnoDB Tabellen auf MySQL Versionen 5.0 zu optimieren, trat ein Fehler auf. Dies wurde behoben.
  6. Datenbank extrahieren: beim Versuch, die Daten zu extrahieren, trat mit der Optionseinstellung "Login prompt before connection" („Login vor der Verbindung auffordern“) ein Fehler auf. Dies wurde behoben.
  7. Bei der Registrierung werden die Registrierungsinfos der alten Version SQL Manager 2005 nicht gelöscht.
  8. SQL Manager Direct Feature konnte in der Lite Version nicht aktiviert werden. Der Fehler wurde behoben.
  9. SQL-Editor: Anführungszeichen konnten mit den Tastaturbelegungen "USA-international" und "DA - Dänisch" nicht getippt werden. Dies wurde behoben.
  10. SQL-Editor: Die geöffnete Datei wurde nach dem Klicken "Save to file" (“In Datei speichern”) nicht gespeichert. Dies wurde behoben.
  11. SQL-Editor: In einigen Fällen erschien die Liste der Felder für Tabellenalias nicht. Dies wurde behoben.
  12. Hinzufügen der neuen Tastenkombination Ctrl+W zum Schließen des aktiven Fensters.
  13. Weitere kleine Verbesserungen und Bugfixes implementiert.

SQL Manager 2007 for MySQL freigegeben

Was ist neu im SQL Manager 2007 for MySQL?

  1. Unterstützung von UTF8-kodierten Daten im SQL Editor, im Query Builder, in der Rasteransicht sowie im Assistenten für das Exportieren/Importieren der Daten.
  2. Der SQL Manager kann weiter verwendet werden während eine Abfrage im SQL Editor bzw. Query Builder ausgeführt wird oder Tabellen oder Viewdaten in den Editor geladen werden. Eine Abfrage, deren Ausführung zu lange dauert, kann unterbrochen werden.
  3. Alle Assistenten, einschließlich Export/Import von Daten, DB Extrahieren oder DB Kopieren laufen jetzt im Hintergrundmodus, so dass gleichzeitig mit dem Programm weitergearbeitet kann.
  4. Neu verbesserter SQL Editor, ähnlich wie im Visual Studio 2005, mit der Code Folding Funktion und UNICODE-Unterstützung.
  5. Mit dem verbesserten Assistenten für den Datenimport können Daten jetzt 10 Mal schneller importiert werden. Neue Importformate wurden hinzugefügt: HTML, XML Document, Open Document Format (OpenOffice), Open XML Format (MS Word 2007, MS Excel 2007).
  6. Der verbesserte Assistent für das Kopieren der Datenbank arbeitet jetzt schneller und ermöglicht es, Datenbanken und Objekte zwischen den verschiedenen Serverversionen zu kopieren. Die Abhängigkeiten zwischen den Objekten werden beim Kopieren berücksichtigt.
  7. Der verbesserte Assistent für das Extrahieren der Datenbank läuft jetzt schneller und ermöglicht es, beim Generieren des Skripts die benötigte Serverversion anzugeben. Abhängigkeiten zwischen Objekten werden berücksichtigt.
  8. Unterstützung von Abfragen, die mehrere Ergebnissätze liefern.
  9. Generieren von allgemeinen SQL-Befehlen aus dem DB-Explorer heraus (Skript für SQL Editor, Skript für Zwischenablage). Jetzt können einfacher solche SQL-Befehle wie CREATE, ALERT, DROP, SELECT usw. für jedes Datenbankobjekt generiert werden.
  10. Speichern von Abfragen im Favoritenordner im DB Explorer; diese Abfragen können entweder in der lokalen Registry (nur für Ihren Zugriff) oder in einer speziellen Datenbanktabelle (für den gemeinsamen Zugriff von mehreren Benutzern) gespeichert werden.
  11. Verbesserter visueller Datenbank-Designer, neue Objekte wie z.B. Kommentare und virtuelle Relationen. Procedures, Functions und Views können ins Diagramm eingefügt werden. Es kann gewählt werden, ob nur die Objektnamen angezeigt werden oder auch die Felder und Parameter.
  12. Der verbesserte Assistent für das Exportieren der Daten arbeitet jetzt schneller. Neue Exportformate wurden hinzugefügt: XML Document, Open Document Format (OpenOffice), Open XML Format (MS Word 2007, MS Excel 2007).
  13. Mit einer neuen Abhängigkeitsstruktur können die Abhängigkeiten zwischen Datenbankobjekten dargestellt werden.
  14. Verbessertes Werkzeug für die Einstellung der Server Eigenschaften. Variablen können in die Gruppen eingeteilt werden, Modifizierung der Systemvariablen ist möglich. Server-Statusinformationen, InnoDB Status und die allgemeine Abfragen-Logdatei können angezeigt werden.
  15. In einem Datenbank-Eigenschaftenfenster können die Datenbankoptionen dargestellt und geändert werden. Zudem werden hier zusammenfassende Informationen über die Größe und die Objekte der Datenbank dargestellt.
  16. Verbesserter Tabellen-Editor. Die Eigenschaften der Tabelle können in einem neuen Tab dargestellt und geändert sowie der Status der Tabelle angezeigt werden.
  17. Verbindungsparameter und Datenoptionen, die die Leistungsgeschwindigkeit der Datenbank beeinflussen, können in der Registrierungsinfo individuell für jede Datenbank eingestellt werden.
  18. Im DB-Explorer können die Hosts gemäß dem Verbindungstyp (SSH oder HTTP Tunneling) benannt werden.
  19. SSH Tunneling erlaubt jetzt die Verwendung von Schlüsseln.
  20. SQL Skript. Ausführen der ausgewählten Anweisungen und Anweisungen unter Cursor hinzugefügt.
  21. Verbesserung des Systems zum Erstellen von Reports.
  22. Andere kleine Verbesserungen und Bugfixes.

SQL Manager 2005 for MySQL Version 3.7 freigegeben

Was ist neu im SQL Manager 2005 for MySQL Version 3.7?

  1. Unterstützung von Scheduled Events für MySQL 5.1.6
  2. Export als SQL Skript. Jetzt kann man wählen, für welchen DBMS Server das Skript generiert werden muss.
  3. SQL-Editor.
  • Importieren der Daten in die Abfrage, wenn diese die Dateneinfügung unterstützt.
  • Möglichkeit, die Registerkarten umzubenennen und umzuordnen.
  • Die Zeit der Abfrageausführung wird jetzt im Format hh:mm:ss angezeigt.
  • Im SQL-Editor trat der Range Check Fehler bei der Abfrageausführung auf. Dies wurde behoben.
  4. DB Explorer. Hinzufügen des Befehls Add to Projects. Jetzt kann man Objekte in Projekten nicht nur durch Ziehen hinzufügen, sondern mit der Hilfe des entsprechenden Kommandos.
  5. HTTP Tunnel über HTTPS-Protokoll.
  6. Zur Verwendung von Services braucht man jetzt nicht mehr im Voraus mit der Datenbank über den DB-Explorer zu verbinden.
  7. Unterstützung für die Systeme der Datenspeicherung myttNDBCluster und myttBlackHole
  8. Aktualisierung der Liste von Zeichensätzen (Character sets) und Sortierungen (Collations) im Assistenten zur Erstellung der Datenbank
  9. Speichern der Größe und Position der Fenster von neuen Objekteditoren
  10. Raster. Hinzufügen der folgenden Einträge im Kontextmenü: Expand All (Alles ausklappen) und Collapse All (Alles einklappen).
  11. Position der Navigationselemete in Toolleisten wird nach der Installation der neuen Programmversion nicht zurückgesetzt. Man kann sie mit Hilfe des entsprechenden Befehles im Windows-Menü oder der Taste in den Umgebungsoptionen zurücksetzen.
  12. Visueller Datenbank-Designer. Das Format vom Kontextmenü wurde gemäß dem aktuellen visuellen Schema nicht geändert.
  13. Beim gleichzeitigen Arbeiten mit anderen Programmen wird jetzt die CPU weniger ausgelastet.

Behoben:

  1. Definitionen von Views und Triggers wurden bis 8K abgeschnitten. Dies wurde behoben.
  2. Table Editor. Das Funktionieren von Truncate Table wurde korrigiert.
  3. Die gerechneten Felder von Sum()-Typ wurden in Abfragen für Strings gehalten. Dies wurde behoben.
  4. Das falsche Formatieren von Viewbody wie concat(ucase(`staff`.`pref_surname`), ', ', `staff`.`pref_name`) AS `person`. Dies wurde jetzt behoben.
  5. Die Eigenschaft UNIQUE für die Felder wurde nicht richtig aktualisiert, was zum Fehler bei deren Versetzung führte. Dies wurde behoben.
  6. Beim Editieren von Indizes wie UNIQUE KEY `name` (`surname`(5),`name`,`patronymic`) wurde der Fehler behoben.
  7. Auf einigen MySQL Serverversionen erschien der Fehler, wenn ein Report mit Hilfe des Assistenten zum Erstellen von Reporten hinzugefügt wurde. Dies wurde behoben.
  8. Der Fehler beim Erhalt der Standardwerte für die BIT-Felder wurde behoben.
  9. Funktion Editor gab das Ergebnis NULL als leere Zeichenfolge (String) zurück. Dies wurde behoben.
  10. Größe und Position der Fenster wurden nicht gespeichert. Dies wurde behoben.
  11. Datenbank Registrierungsinfos. Beim Speichern der Änderungen wurden die Aliases nicht überprüft. Dies wurde behoben.
  12. In einigen Fällen funktionierte das Gruppieren im Table Editor nicht korrekt. Dies wurde behoben.
  13. Der Fehler mit dem Filter für Feldtyp TEXT wurde behoben.
  14. Kontexthilfe im Report Designer wurde verbessert.
  15. EMS Direct. Einige Symbole des nicht-lateinischen Alphabetes wurden nicht korrekt angezeigt. Dies wurde behoben.
  16. Server Properties gab die Abfrage für die Verbindung mit der Datenbank zweimal aus. Dies wurde behoben.
  17. Naming Rules wurden nach dem Beenden des Programms nicht gespeichert. Dies wurde behoben.
  18. Restore Service gab den Fehler beim Auswählen der nicht registrierten Datenbank und neue Datenbank erstellen einen Fehler aus. Dies wurde behoben.
  19. Query Builder. Nach dem Editieren des Abfragetextes verwandte die Create View Funktion die alte Abfrage vom Builder Tab. Dies wurde behoben.
  20. Weitere kleine Verbesserungen und Bugfixes.

SQL Manager 2005 for MySQL Version 3.6.5 freigegeben

Was ist neu im SQL Manager 2005 for MySQL Version 3.6.5?

  1. SQL-Editor. Die Tastaturkürzel für verschiedene Befehle und Operationen wurden nach Ihren Wünschen verändert.
  2. Query Builder. Die Unterstüzung für die Abfragen mit Tabellen aus verschiedenen Datenbanken, die sich auf einem Server befinden.
  3. Create Table (Tabelle erstellen). Unterstützung der Kommentare für die Tabellen.
  4. Server Properties (Server-Eigenschaften). Hinzufügen von SSH- und HTTP-Tunneling.
  5. Hinzufügen der Option: "Write only successfully executed SQL statements to log" (Datenbank Registrations-Info / Logs).
  6. SQL-Editor.
  • Ausführung des Ausdrucks unter Cursor
  • Hinzufügen von Befehlen: Next Bookmark, Previous Bookmark.
  7. Datenbank extrahieren
  • Hinzufügen der Option "Use tables selected on the previous step" zum Extrahieren der Daten von Tabellen, die zum Extrahieren derer Struktur ausgewählt wurden.
  • Fortschritt-Indikator zeigt jetzt die Zahl der extrahierten Datensätze für die Tabellen.
  • Fehler beim Extrahieren der Prozeduren und Funktionen, wenn der Benutzer keine Rechte hatte, sie anzusehen, wurde behoben.
  • Jetzt fügt das erzeugte Skript den Wert 0 für autoinkrementelle Felder richtig ein.
  8. Datenbank kopieren
  • Hinzufügen der Option "Use tables selected on the previous step" zum Kopieren der Daten von Tabellen, die zum Kopieren derer Struktur ausgewählt wurden.
  • Fortschritt-Indikator zeigt jetzt die Zahl der kopierten Datensätze für die Tabellen.
  • Hinzufügen der Option "Use compressed protocol".
  9. Assistent zum Erstellen der Datenbank. Der erzeugte Datenbankname wird jetzt in Anführungszeichen angezeigt.
  10. Data Import.
  • Bei den abgeschalteten Transaktionen wird im Modus "Commit changes manually" die Bestätigung der Transaktion (Commit bzw. Rollback) beim Beenden des Importierens verlangt.
  • Änderung der Größe des Dialogfensters
  • Die Einstellung des Generatorwertes und unveränderlichen Wertes wurde bei der Formateingabe der zu importierenden Felder ignoriert. Dies wurde beseitigt.
  • Beim Eingeben der Tabellenteile für den Import wurden in die verbleibenden Felder leere Zeilen hinzugefügt. Die Standardwerte, die in der Tabelle für die Felder bestimmt wurden, konnten nicht übernommen werden. Dies wurde beseitigt.

11. Prozedur-Editor. Zusätzliche Unterstützung der Konstruktion in Prozedurkörpern wie:

procd:BEGIN
...
END procd

Behoben:

  1. Prozedur-Editor. Der Fehler, der bei der Erstellung der Prozedur mit den Parametern folgender Art param2 ENUM('a','b','c')

entstand, wurde behoben.

  2. Hatte der Benutzer keine Rechte für mysql.proc, so wurden die Parameter der Funktionen nicht erneuert. Dies wurde behoben.
  3. Dienst Optimize tables (Tabellen optimieren) für InnoDB Tabellen auf MySQL 5.x wird jetzt ohne Fehler ausgeführt.
  4. Nicht korrekter Standardwert für die Feldertypen BIT(n) wurde behoben.
  5. SQL-Editor.
  • Bei der Ausführung von Explain für eine nicht korrekte Abfrage wurde der Fehler "Division by zero" korrigiert.
  • In einigen seltenen Fällen wurde der Text vom Anfang der Reihe unter Verwendung der Codevervollständigung mit der eingeschalteten Option "Trim traling spaces" gelöscht. Dies wurde behoben.
  6. Visueller Datenbank-Designer. Wenn die Tabelle nicht ausgewählt, jedoch das Feld ausgewählt wurde, dann funktionierte der Eintrag Drop Table im Kontextmenü falsch. Dies wurde behoben.
  7. SQL-Skript. Hinzufügen der Bestätigung für den Abbruch der Skriptausführung.
  8. DB-Explorer. Das Kontextmenü verschwand beim Umschalten zu einer anderen Anwendung nicht.
  9. Table Editor, View Editor. Beim Exportieren der Listen von Unterobjekten wurden die Zeilen, die mehr als 32 Symbole enthielten, abgeschnitten. Dies wurde behoben.
  10. Weitere kleine Verbesserungen und Bugfixes.

SQL Manager 2005 for MySQL Version 3.6. freigegeben

Was ist neu im SQL Manager 2005 for MySQL Version 3.6.?

  1. SQL-Formatter. Es werden SELECT, INSERT, UPDATE, DELETE Abfragen formatiert. (SQL-Formatter ist über das Kontextmenü des Editors abrufbar)
  2. SQL-Skript.
  • Jetzt wird der Verlauf der Skriptausführung angezeigt und man kann den Prozess abbrechen.
  • Gleichzeitiges Öffnen mehrerer Fenster.
  • Der Fehler, der unter Verwendung der Option 'Enable Parsing' beim Editieren eines großen Skriptes (> 10MB) das Aufhängen verursachte, wurde jetzt beseitigt.
  3. Jetzt können die Verbindungseinstellungen mit dem Host bei der Verbindung im User Manager, Grant Manager und SQL-Skript vorgenommen werden. Genau funktionieren jetzt die genannten Tools unter Verwendung von HTTP und SHH-Tunneling.
  4. SQL-Editor.
  • Hinzufügen der Option 'Don't save queries automatically for the next session' (“Abfragen für die nächste Sitzung nicht automatisch speichern“). Bei der eingeschalteten Option ist es jetzt möglich den Abfragensatz für jede Datenbank zu erstellen und zu speichern. Dieser wird beim Starten des SQL Editors automatisch abgelesen. Bei der abgeschalteten Option werden die Abfragen der letzten Sitzung gespeichert.
  • Jetzt gibt es keine Begrenzung der Größe der zu bearbeitenden Skripts.
  5. Unterstützung für Datentypen: BOOLEAN und BIT (M).
  6. Der Befehl 'Truncate tables' kann man jetzt für mehrere markierte Tabellen im DB Explorer gleichzeitig ausführen.
  7. Visual Query Builder speichert jetzt auch die Abfrage zwischen den Sitzungen.
  8. Tabellen-Editor.
  • Taste 'Refresh' ('Erneuern') zeigt jetzt Veränderungen, die durch andere Transaktionen (Anwendungen) gespeichert wurden, an.
  • Funktion 'Reorder Fields' wird jetzt korrekt für die InnoDB Tabellen mit Fremdschlüsseln ausgeführt.
  9. Grid (Raster).
  • 'Set to Empty Strings' und die anderen gleichen Kommandos speichern den Datensatz nicht sofort in eine Tabelle.
  • Beim Einfügen der Datensätze aus dem Zwischenspeicher kann man jetzt die Übereinstimmungen der Spalten von Daten aus dem Zwischenspeicher mit den Spalten von Daten aus der Abfrage einstellen.
  • 'Copy to Clipboard' benutzt jetzt Tab-Symbole als Trennzeichen (für das Einfügen in Excel).
  • Form View. Der Editor von Memo-Feldern wurde vergrößert (dieser wird auf der Registerkarte Grid / Avanced im Fenster Environment Options eingestellt).
  10. Datenbank extrahieren. Hinzufügen der Option 'Generate USE statement'.
  11. Data Export Wizard.
  • Hinzufügen der Option 'Allow captions'.
  • Taste 'Fertig' ist in jedem Schritt des Assistenten verfügbar.
  12. Procedure Editor. Jetzt werden alle Werte von Ausgabeparametern angezeigt.
  13. Jetzt können die Tabelleneigenschaften für eine ausgewählte Tabelle im DB Explorer mit Hilfe des Eintrages 'Object Properties' vom Popupmenü oder der gleichnamigen Taste auf der Toolleiste bearbeitet werden.
  14. Blob View: Hinzufügen der Option “Word Wrap” für den Ansichtmodus als Text.
  15. Jetzt können Sie den Grant Manager ohne die vorherige Verbindung zu einer Datenbank laufen lassen.
  16. Trigger Editor. Die Codevervollständigung zeigt jetzt die Liste der Felder von Tabellen für Old und New an.
  17. Ünterstüzung der Option 'Binary flag for char and varchar fields' (für MySQL Version 3.23-4.0)
  18. Die Optionen der Datenbank werden gleich nach einer Veränderung gespeichert und nicht erst nach dem Beenden des Programms. Genauso gehen die Daten beim Absturz des Programms bzw. des Systems nicht verloren.
  19. Report Designer und Report Editor unterstützen die Verbindung mit der Datenbank über das HTTP-Tunneling.
  20. Column Editor. Dieser speichert die Größe beim Ändern des Char-Types auf Varchar und zurück.
  21. Duplicate Object, Modal Query Builder. Jetzt kann die Größe dieser Fenster abgeändert werden.

Behoben:

  1. Das Schließen des Tabellen-Editors mit mehr als 1000 Tabellen in der DB dauerte zu lange. Dies wurde behoben.
  2. Das Sortieren nach den Feldertypen Bignt Type funktionierte bei der aktivierten Option 'SQL sort mode', nicht richtig. Dies wurde behoben.
  3. In der Funktion Codevervollständigung wurden die Felder für die Tabellen nicht ausgegeben. Dies wurde behoben.
  4. Metadaten drucken. 'Alle Objekte anzeigen' Taste funktionierte nicht richtig. Dies wurde behoben.
  5. Procedure Editor. Das Drücken auf 'Execute' führte zur zweimaligen Abfrageausführung. Dies wurde behoben.
  6. View Editor. Bei der Erstellung einer neuen View mit dem Namen, der Großbuchstaben enthielt, trat ein Fehler auf. Dies wurde behoben.
  7. Dezimal-Typ (10, 2) wurde als Dezimal (10, 0) bei der Verbindung über HTTP angezeigt. Dies wurde behoben.
  8. Es trat ein Fehler beim Erneuern der Prozedur und Funktion im DB Explorer auf, wenn der Benutzer keine Zugriffsrechte auf mysql.proc hatte. Dies wurde behoben.
  9. Weitere kleine Verbesserungen und Bugfixes.


Häufig gestellte Fragen (FAQs)

Die häufig gestellten Fragen (FAQs) sind auch auf unserer Website unter http://www.sqlmanager.net/de/products/mysql/manager/faq zu finden.

Inhaltsübersicht:

  • Was ist der EMS SQL Manager for MySQL?
  • Worin liegt der Unterschied zwischen der Full und Lite Version des SQL Managers for MySQL?
  • Was benötige ich, um mit dem EMS SQL Manager for MySQL arbeiten zu können?
  • Worin liegt der Unterschied zwischen den Funktionen des Importes / Exports im MySQL Manager und den Utilities des Data Export/Import for MySQL?
  • Worin liegt der Unterschied zwischen dem Modul Query Builder im Manager for MySQL und dem Utility SQL Query for MySQL?
  • Worin liegt der Unterschied zwischen der eingebauten Funktion "Metadaten extrahieren" im Manager for MySQL und dem Utility DB Extract for MySQL?
  • Ich kann die DDL Datei nicht ändern.Warum?
  • Wie kann ich Datenformate in einem Grid anpassen?
  • Beim Erstellen einer Tabelle wie z.B. 'TestTable` wird sie als `testtable` gespeichert. So darf das nicht sein!
  • Wie kann ich einen Bericht erstellen?
  • Ich versuche, einen Bericht im Report Designer zu erstellen,bekomme aber keinen Zugriff auf die Tabellendaten: 'Quell-Liste der Band Daten ist leer'.
  • Was bedeutet SSH-Tunneling?
  • Ich kann die Verbindung zum MySQL Server über SSH nicht herstellen. Welche Werte muss ich in die Felder des SSH-Reiters im Datenbank Registrierungs-Dialog eintragen?
  • Was bedeutet HTTP Tunneling?
  • Wie kann ich meine Arbeit im Falle von großen Tabellen beschleunigen?
  • Ich habe eine Tabelle mit nur ~ 1000 Einträgen und einer Vielzahl von Feldern. Das Öffnen dieser Tabelle über den Daten Reiter dauert zu lange.
  • Ich habe über eine Million Einträge in der Tabelle, aber das Data-Grid zeigt nur 1.000 Einträge. Was ist das Problem?
  • Ich brauche einige Veränderungen in den Datenbankenobjekten meiner Testdatenbank und dann dieselbe Veränderungen in der Hauptdatenbank vorzunehmen. Gibt es irgendwelche Werkzeuge für diese Zwecke im EMS SQL Manager for MySQL?
  • Ich versuche die Tabelle zu exportieren, aber die LONGTEXT Felder werden nicht exportiert.
  • Wo liegt der Unterschied zwischen den Funktionen „Datenbank extrahieren“ (“Extract Database”) und „Als SQL-Skript exportieren“ (“Export As SQL Script”)?
  • Wie kann ich das voreingestellte Verzeichnis für die exportierten Daten ändern?
  • Warum bekomme ich keine Verbindung zu einem lokalen MySQL Server?
  • Wenn ich versuche eine Datenbank zu registrieren, bekomme ich die folgende Meldung: Zugriff verweigert für User: myuser@myhost.mydomain. Wieso passiert dies?
  • Ich arbeite hinter einer Firewall (Router). Kann ich den SQL Manager einsetzen, um einen Remote MySQL Server zu verwalten? Warum bekomme ich keine Verbindung zu einem Remote MySQL Server?
  • Ich versuche eine MySQL-DB auf einem Webserver zu registrieren, bekomme aber eine Fehlermeldung. Über mein PHP Skript bekomme ich zu dieser DB Verbindung und zwar über den gleichen Loginnamen und Passwort. Wie kann ich mit Hilfe vom SQL Manager Zugriff auf meine Webseiten-DB bekommen?
  • Ich versuche mich zu einem Remote MySQL Host zu verbinden, aber ich erhalte nur folgende Meldung: "Host nicht berechtigt zum Server zu verbinden". Was ist der Grund hierfür?
  • Ich habe die DB registriert, aber beim Versuch sie zu öffnen, kommt die Fehlermeldung "dynamische Bibliothek libmysql.dll nicht gefunden".
  • Ich bekomme beim Versuch mich mit dem MySQL Server 4.1.x zu verbinden, die Mitteilung "Bad Handshake". Unterstützt der SQL Manager den MySQL Server 4.1.x?
  • Ich habe versucht, einen Fremdschlüssel für InnoDB-Tabelle zu erstellen und den Fehler "Kann Tabelle … nicht erzeugen (Fehler 150)" bekommen. Was mache ich falsch?
  • Ich setze das Windows Betriebssystem ein, aber mein MySQL Server läuft auf einem Linux Rechner. Werde ich den SQL Manager einsetzen können um auf diesem Server zu arbeiten?
  • Jedes Mal, wenn ich versuche eine Verbindung zu einem MySQL Server auf einem Linux-Server herzustellen, kommt die Meldung: "Verlorene Verbindung zum MySQL Server während einer Abfrage". Was mache ich falsch?

F:

Was ist der EMS Manager for MySQL ?

A:

EMS Manager for MySQL ist ein leistungsstarkes Tool für MySQL Datenbank-Server-Verwaltung und Entwicklung. Der SQL-Manager arbeitet mit verschiedenen MySQL Versionen von 3.23 bis 5.2 und unterstützt alle aktuellsten MySQL-Eigenschaften einschließlich Views, Stored Procedures und Funktionen, InnoDB Fremdschlüssel (Foreign Keys) usw. Er bietet viele starke Werkzeuge für erfahrene Benutzer an, um all Ihre Anforderungen zu erfüllen. Der SQL Manager for MySQL hat eine neue moderne grafische Programmoberfläche mit einem sehr guten Wizard System. So einfach im Gebrauch, dass sogar ein nicht erfahrener Benutzer damit ohne Probleme klar kommt.

nach oben

F:

Worin liegt der Unterschied zwischen der Full und Lite Version des SQL Managers for MySQL?

A:

Diese Versionen unterscheiden sich im Preis und in der Funktionalität. Sie können die Charakteristiken der Versionen auf der Seite Funktionsmatrix vergleichen. Und auf der Kaufseite können Sie den SQL Manager for MySQL erwerben.

nach oben

F:

Was benötige ich, um mit dem EMS SQL Manager for MySQL arbeiten zu können?

A:

Erstens benötigen Sie die Möglichkeit, sich mit einem lokalen oder entfernten MySQL Server zu verbinden. Sie können den MySQL Server auf der: http://www.mysql.com/downloads/index.html Seite herunterladen. Der Download ist kostenfrei. Zweitens brauchen Sie einen Computer, der den EMS SQL Manager Systemanforderungen entspricht. Für die normale Arbeit mit dem SQL Manager benötigen Sie einen Computer mit Windows NT4/2000/XP/2003/Vista, empfohlen wird mindestens einen Pentium II 600 MHZ / 64 MB RAM.

nach oben

F:

Worin liegt der Unterschied zwischen den Funktionen des Importes / Exports im SQL Manager for MySQL und den Utilities des Data Export/Import for MySQL?

A:

Data Export/Import for MySQL schließen zusätzliche Funktionen in sich ein, die nicht im SQL Manager for MySQL vorhanden sind, wie z.B: Gleichzeitiger Export / Import der Daten aus / in mehrere Tabellen;

Export / Import der Tabellen Daten aus / in mehreren Datenbanken auf einem Host;

Befehlszeile-Utility für den Export / Import unter Verwendung der Konfigurationsdatei, die alle Einstellungen des Exportes / Importes enthält.

nach oben

F:

Worin liegt der Unterschied zwischen dem Modul Query Builder im Manager for MySQL und dem Utility SQL Query for MySQL?

A:

Erstens funktioniert der SQL Query for MySQL schneller. Außerdem schließt der SQL Query for MySQL einige zusätzliche Möglichkeiten ein, z.B:

Das Speichern von Abfragen-History; was Ihnen erlaubt zu beliebigen Abfragen, die zu einem früheren Moment ausgeführt wurden, zurückzukehren;

weitere Verbesserung in der Programmobefläche für eine noch leichtere und produktivere Arbeit.

nach oben

F:

Worin liegt der Unterschied zwischen der eingebauten Funktion "Metadaten extrahieren" im Manager for MySQL und dem Utility DB Extract for MySQL?

A:

DB Extract for MySQL beinhaltet Möglichkeiten, die im Manager for MySQL nicht verfügbar sind, z.B: Gleichzeitiges Extrahieren von Metadaten aus mehreren Tabellen auf einem Host; Kommandozeile-Utility zum leichteren Extrahieren; hohe Geschwindigkeit beim Extrahieren.

nach oben

F:

Ich kann die DDL Datei nicht ändern. Warum?

A:

Die DDL Reiter des Tabellen Editors und des UDF Editors sind schreibgeschützt. Sie zeigen nur den SQL Text der Operationen, die Sie in den Tabellen an den Reitern 'Felder', 'Indizes', etc, oder dem UDF vornehmen. Um diesen Text zu ändern, können Sie ihn in die Zwischenablage kopieren und mit Hilfe des SQL Script Editors ändern.

nach oben

F:

Wie kann ich Datenformate in einem Grid anpassen?

A:

Sie können alle Anzeigeformate ändern: Integer, Float, Datum, Zeit, und Datum/Zeit in dem Dialog Umgebungsoptionen im Menü Optionen.

nach oben

F:

Beim Erstellen einer Tabelle wie z.B. 'TestTable` wird sie als `testtable` gespeichert. So darf das nicht sein!

A:

Es sieht so aus, dass die Bedeutung der Variable "lower_case_table_names" eine ist. Sie können weitere Information über das Thema hier finden: http://dev.mysql.com/doc/mysql/en/Name_case_sensitivity.html.

nach oben

F:

Wie kann ich einen Bericht erstellen?

A:

Um einen Bericht zu erzeugen, können Sie den Assistenten zum Erstellen von Berichten (Erstellen->Bericht) oder den Berichts-Designer (Werkzeuge-> Berichts-Designer) verwenden. Um einen einfachen Bericht auf Basis einer Abfrage zu erstellen, müssen Sie das Master Data Band im zweiten Schritt des Assistenten wählen, doppelklicken oder Edit Button klicken und die Abfrage für Ihren Report auswählen. Danach müssen Sie die weiteren Optionen in den anderen Schritten des Assistenten anpassen und auf Fertig klicken.

nach oben

F:

Ich versuche einen Bericht mit dem Report Designer zu erstellen, aber ich bekomme keinen Zugriff auf die Tabellendaten: "Quell-Liste der Band Daten ist leer".

A:

Um eine Datenquelle für einen Bericht auszuwählen, müssen Sie ein Dialog-Formular zum Bericht hinzufügen (im Berichtsdesigner Menü “Edit/Add dialog form“ wählen). Danach müssen Sie Datenbanken und Komponenten für die Abfrage aus der Symbolleiste auf der linken Seite hinzufügen und die Eigenschaften der Verbindung und der Abfrage setzen. Danach erscheint die Abfrage in der Liste der Datenquellen.

nach oben

F:

Was bedeutet SSH Tunneling?

A:

Das SSH (Secure Shell Host) Protokol wird verwendet um die Computer-Sicherheit unter einem Unix System im Internet zu erhöhen. SSH benutzt verschiedene Verschlüsselungsalgorythmen mit unterschiedlichen Sicherheitsstufen. Die Spannweite des SSH steht auch in Verbindung mit der Tatsache, dass einige Linux-like BS's (z.B. FreeBSD) den SSH Server in ihr Standard-Angebot integrieren. Um zu diesem Thema mehr zu erfahren, sehen Sie bitte unter http://openssh.org nach. Das SSH Tunneling des SQL Manager bedeutet eine sichere Verbindung zum MySQl Server, wenn über unsichere Verbindungskanäle gearbeitet wird. Sie können den SSH Tunnel auch so benutzen, eine Verbindung zum MySQL Remote Host zu bekommen, auch wenn der Port 3306 aus irgendwelchen Gründen für externe Verbindungen geschlossen ist. Die Verbindung über den SSH Tunnel arbeitet folgendermassen: Als erstes wird eine Verbindung zwischen dem SSH Client des SQL Manager und dem Remote MySQL Server hergestellt und es erfolgt eine Authentifizierung. Danach werden alle ein-/und ausgehenden Informationen zwischen den Programmen und dem MySQL Server durch den SSH Server mit Hilfe des Kommunikationsports (gewöhnlich ist es 22) versendet und der SSH Server leitet die Information direkt an den MySQL Server weiter. Um eine Datenbank zu registrieren, die über den SSH Tunnel verbunden ist, müssen Sie die folgenden Parameter im Datenbank Registrations-Wizard des SQL Manager for MySQL einstellen: Beim ersten Schritt: Host ist der Host bei dem der MySQL Server als HTTP Server fungiert. Wenn SSH und der MySQL Server sich auf der gleichen Maschine befinden, ist es der SSH Host, oder kann auch der 'localhost' sein. Port ist ein Port des MySQL Servers auf dem Remote Host, normalerweise ist es 3306. Benutzername ist ein MySQL Username. Passwort ist das Passwort des MySQL Users. Bitte beachten, dass der MySQL Hostname in diesem Falle relativ zum SSH Server gesetzt werden muss. Zum Beispiel, wenn beide, also MySQL Server und SSH Server sich auf dem gleichen Computer befinden, müssen Sie localhost als Hostname anstatt des Server's externe Hostname oder IP Adresse spezifizieren. Bitte nicht vergessen, Tunneling Nutzen und SSH Tunneling zu wählen. Beim zweiten Schritt: SSH host Name ist ein Host bei dem der SSH Server aktiviert ist. SSH Port ist ein Port bei dem der SSH Server aktiviert ist. SSH User Name ist ein User auf der Linux Maschine. (Es ist ein Linux User. Es ist kein User vom MySQL Server.) SSH Passwort ist ein Linux User Passwort.

nach oben

F:

Ich kann die Verbindung zum MySQL Server über SSH nicht herstellen. Welche Werte muss ich in die Felder des SSH-Reiters im Datenbank Registrierungs-Dialog eintragen?

A:

Um eine richtige SSH Verbindung zu erstellen, geben Sie die folgenden Werte in die entsprechenden Felder ein

Bei SSH Page/Tabulator: SSH Hostname ist ein Host, bei dem der SSH Server aktiviert ist. SSH Port ist der Port, bei dem der SSH Server aktiviert ist. SSH Benutzername ist ein User auf der Linux Maschine. (Es ist ein Linux User. Es ist kein MySQL Server User.) SSH Passwort ist ein Linux User Passwort

Bei Eigenschaften Verbindungen/Allgemein Seite/Reiter: Host ist der Host, bei dem der MySQL Server als SSH Server fungiert. Wenn SSH und MySQL Server sich auf der gleichen Maschine befinden, ist es gleich dem SSH Host, oder kann auch 'localhost' sein. Port ein Port des MySQL Servers auf dem Remote Host. Standardmäßig ist es 3306. User name- ist ein MySQL Benutzername. Passwort ist ein Passwort des MySQL Benutzers.

nach oben

F:

Was bedeutet HTTP Tunneling?

A:

HTTP Tunneling ist eine Methode, die es erlaubt Verbindungen herzustellen und Daten zwischen der Anwendung und dem MySQL Server über das HTTP/HTTPS Protokoll und dem Port 80, der von einem regulären Internetbrowser verwendet wird, zu senden. Diese Methode wird eingesetzt um die Remote Verbindung zum MySQL Server einer Hosting Firma herszustellen, wenn eine direkte Verbindung aus Sicherheitsgründen nicht möglich ist. Der HTTP Tunnel arbeitet folgendermaßen: alle von der Client-Software gesendete, ausgehende Abfragen und Kommandos werden verschlüsselt und über das HTTP/HTTPS Protokoll, der den Port 80 nutzt, zu einem spezielles Skript verschickt, welches wiederum die empfangenen Daten entschlüsselt und diese dem verarbeitenden MySQL Server sendet und sendet das Ergebnis zurück. Diese Methode setzt den HTTP Server (Apache) und PHP mit MySQL auf dem Remoteserver voraus. Normalerweise werden diese Softwarepakete vom Hosting Provider gestellt, der auch den Linux Host zur Verfügung stellt. Darüber hinaus müssen Sie auch das spezielle emsproxy.php Skript auf Ihren Webserver hochladen um den Remotezugriff zu gewährleisten (Sie können es unter dem gleichen Verzeichnis wie Ihre anderen PHP Skripte ablegen). Wenn Ihr Webserver mit den Anforderungen übereinstimmt, und das Skript richtig installiert wurde, sehen Sie die Meldung "EmsProxy v 1.31" (die Versionsnummer kann auch unterschiedlich sein) in Ihrem Browser wenn Sie die http:///emsproxy.php Seite öffnen. Wenn Sie eine Remote Datenbank registrieren, die über den HTTP Tunnel angesprochen wird, müssen Sie folgende Parameter in den Datenbank Registrations Wizard des SQL Manager for MySQL eingeben: Der erste Wizard-Schritt: Host ist der Host bei dem der MySQL Server als HTTP Server fungiert. Gewöhnlich sind HTTP und MySQL Server auf der gleichen Maschine und es ist 'localhost'. Port ist der Port des MySQL Servers im Remote Host, gewöhnlich der 3306. Benutzername ist ein MySQL Username. Passwort ist das Passwort des MySQL Users. Aktivieren Sie Tunneling & HTTP Tunneling Der zweite Wizard-Schritt: URL ist eine Adresse des emsproxy.php Skriptes (z.B. http:///emsproxy.php).

nach oben

F:

Wie kann ich meine Arbeit im Falle von großen Tabellen beschleunigen?

A:

Zu Ihrem Nutzen und zu Beschleunigung der Arbeit, bietet die Rasteransicht mehrere Möglichkeiten der Anpassung. Hier die wichtigsten Parameter (erreichbar über Optionen/Umgebungsoptionen): Im Abschnitt Raster:

Begrenzende Optionen in Tabellen und View Editoren. Die Option "Alle Datensätze einer Tabelle auswählen" ermöglicht es Ihnen, ohne erneute Verbindung zum Server alle Datensätze einer Tabelle zu sehen, jedoch im Falle von großen Tabellen oder einer langsamen Verbindung werden die Daten mit großen Zeitverzögerungen empfangen und der eingehende Datenverkehr kann erheblich ansteigen. Dieser Modus wird in privaten Netzen oder mit lokalen Datenbanken empfohlen. Die Option "Nur auswählen" begrenzt die maximale Anzahl der Datensätze, die nach dem Absetzen der Suche zurückgegeben werden. Der Mensch ist nicht in der Lage eine große Menge an Informationen auf einmal zu verarbeiten, deswegen bieten wir diesen Modus an. Um den nächsten Teil der Daten anzufordern und darzustellen, klicken Sie auf den Button Nächste Seite (>>) in der Toolbar der Rasteransicht. Diese Arbeitsweise beschleunigt die Ansicht der Datentabellen erheblich und vermeidet das Hängen sowie den Timeout der Verbindung. Sie wird empfohlen für die Arbeit mit großen Tabellen, bei Verbindungen mit geringer Übertragungsrate und wenn das Übertragungsvolumen eine Rolle spielt. Dies ist der Default Modus. In diesem Modus können die Optionen " SQL-Sortierung verwenden" und "SQL-Filter verwenden" sehr hilfreich sein.
Im Abschnitt Grid->Datenoptionen:
Standard-Rastermodus: Diese Option definiert ob die angeforderten Zeilen komplett in das Raster geladen werden, oder in Teilen (sichtbare Zeilen) wenn der Benutzer durch die Tabellendaten nach unten scrollt. Der erste Modus erhöht die Öffnungszeit der Suche, beschleunigt aber das scrollen. Im zweiten Modus wird die Suche sehr schnell ausgeführt, aber es können Verzögerungen bei der Navigation durch das Raster auftreten.
In der Datenansicht SQL-Sortierung verwenden: Ist die Option eingeschaltet, wird eine neue Anfrage an den Server gesendet, wenn der Benutzer die Datensortierung verwendet. Die Ergebnisse werden erneut im Raster dargestellt. Diese Option ins im Modus "Nur auswählen" sehr hilfreich, erhöht jedoch den Datenverkehr. Ist diese Option ausgeschaltet, wird die Sortierung nur auf dem Client durchgeführt jedoch werden nur die geladenen Daten sortiert. D.h. wenn sie "Nur auswählen" auf 1000 Einträge gesetzt haben, werden nur diese 1000 Datensätze sortiert.
In der Datenansicht SQL Filter verwenden: Ist diese Option eingeschaltet, werden die Daten auf dem Server sortiert, an den die Anfrage geschickt wird und die Ergebnisse werden erneut im Raster dargestellt.
Diese Option ist ebenfalls im "Nur auswählen" Modus sehr hilfreich, erhöht aber auch den Datenverkehr. Ist diese Option ausgeschaltet, wird die Sortierung nur auf dem Client durchgeführt jedoch werden nur die geladenen Daten sortiert. D.h. wenn sie "Nur auswählen" auf 1000 Einträge gesetzt haben, werden nur diese 1000 Datensätze sortiert.

Wir empfehlen folgende Einstellungen der Optionen, um die maximale Effizienz bei der Arbeit mit großen Tabellen zu erreichen: Nur auswählen; Sichtbare Zeilen laden; SQL-Sortierung verwenden; SQL-Filter verwenden.

nach oben

F:

Ich habe eine Tabelle mit nur ~ 1000 Einträgen und einer Vielzahl von Feldern. Das Öffnen dieser Tabelle über den Daten Reiter dauert zu lange.

A:

Sie haben vermutlich die Option 'Spaltenbreite automatisch anpassen' in den Optionen/Umgebungsoptionen Abschnitt Grid gewählt. Versuchen sie diese zu deaktivieren.

nach oben

F:

Ich habe über eine Million Einträge in der Tabelle, aber das Data-Grid zeigt nur 1.000 Einträge. Was ist das Problem?

A:

Bitte wählen Sie die Option 'Alle Datensätze einer Tabelle auswählen' aus dem Abschnitt "Datenoptionen" des Dialogs Registrierungsinfos. Um die Standardoptionen für eine neu registrierte Datenbank einzugeben, können Sie die Option 'Alle Datensätze einer Tabelle auswählen' aus dem Abschnitt 'Raster\Datenoptionen' des Dialogs Optionen/Umgebungsoptionen verwenden.

nach oben

F:

Ich brauche einige Veränderungen in den Datenbankenobjekten meiner Testdatenbank und dann dieselbe Veränderungen in der Hauptdatenbank vorzunehmen. Gibt es irgendwelche Werkzeuge für diese Zwecke im EMS SQL Manager for MySQL?

A:

Der Dialog Datenbank Registrierungsinfo enthält einen Tab für die Protokolldatei, wo Sie die protokollierten Veränderungen der Metadaten in der Datenbank und die im SQL-Editor ausgeführten SQL-Anweisungen einschalten können. Sie müssen auch die Option ‘Protokolldatei der Veränderungen von Metadaten einschalten’ (‘Enable log of metadata changes’) für Ihre Testdatenbank aktivieren, die benötigten Modifikationen in der Datenbank vornehmen und dann die Protokolldatei der Metadaten in Ihrer Hauptdatenbank ausführen.

nach oben

F:

Ich versuche die Tabelle zu exportieren, aber die LONGTEXT Felder werden nicht exportiert.

A:

Die Felder der Typen TEXT, LONGTEXT werden als Voreinstellung nicht exportiert. Sie müssen die Felder dieser Typen manuell auf dem Tab 'Felder/Fields' wählen.

nach oben

F:

Wo liegt der Unterschied zwischen den Funktionen „Datenbank extrahieren“ (“Extract Database”) und „Als SQL-Skript exportieren“ (“Export As SQL Script” )?

A:

„Als SQL-Skript exportieren“ ist für das Exportieren der Tabellendaten, die ins Datenbanksystem anders als der MySQL Server (SQL Server, Oracle, PostgreSQL usw.) eingefügt werden, vorgesehen. Verwenden Sie „Datenbank extrahieren“, um die Daten in eine Tabelle auf dem MySQL Server zu kopieren.

nach oben

F:

Wie kann ich das voreingestellte Verzeichnis für die exportierten Daten ändern?

A:

Um das Verzeichnis zu ändern, gehen Sie bitte wie folgt vor: Drücken Sie mit der rechten Maustaste auf Datenbank Explorer in der jeweiligen DB und wählen Sie den Punkt "Registrierungsinfo der DB " im Popupmenü, indem Sie die linke Maustaste anklicken (Sie können diesen Punkt auch im Hauptmenü "Datenbank" finden). Es wird ein Formular mit den Parametern der Datenbank geöffnet werden. Klicken Sie mit der linken Taste auf dem Tab "Verzeichnisse". Im Abschnitt "Standardverzeichnis für die exportierten Daten" können Sie das Verzeichnis für den Dateisexport auswählen.

nach oben

F:

Warum bekomme ich keine Verbindung zu einem lokalen MySQL Server?

A:

Es gibt mehrere Gründe, weshalb Sie keine Verbindung zur lokalen Datenbank bekommen. Wenn Sie während des Vebindungsaufbaues den Fehler "Kann keine Verbindung zum MySQL Server über 'localhost' (10061)" herstellen, dann ist wahrscheinlich der MySQL Server nicht richtig installiert oder der Service (normalerweise mit dem Namen mysql) läuft nicht. Um zu prüfen, ob der Service läuft, öffnen Sie bitte den Systemsteuerung->Administrative Werkzeuge->Dienste und finden Sie den Dienst MySQL. Wenn Sie diesen Dienst nicht finden können, müssen Sie MySQL erneut installieren. Wenn Sie ihn finden, starten Sie ihn mit dem Start-Knopf oder verwenden Sie den ensprechenden Eintrag im Kontext-Menü. Wenn Sie den Fehler "Access denied for user 'root'@'localhost' (using password: YES)" bekommen, dann prüfen Sie, ob Sie das Passwort für den Root-User richtig eingegeben haben im Fall, dass Sie dies während der Installation geändert haben. Wenn Sie MySQL mit Vorgabewerten installiert haben, müssen Sie die User Name Root verwenden mit dem leeren Passwort und dem Port 3306 um Verbindung zum Server zu erreichen. (mehr Info auf: http://dev.mysql.com/doc/refman/5.1/en/can-not-connect-to-server.html).

nach oben

F:

Wenn ich versuche eine Datenbank zu registrieren, bekomme ich die folgende Meldung: Zugriff verweigert für User: myuser@myhost.mydomain. Wieso passiert dies?

A:

Der MySQL Server benutzt den Client Login ('myuser' in diesem Fall) und der Name des Rechners, von dem versucht wird die Verbindung herzustellen ('myhost.mydomain' in diesem Fall), für die Authetifizierung des Client. In ihrem Fall liegt der Grund darin, dass Ihr ‘myuser’ User vom Host ‘myhost.mydomain’ keine Berechtigung hat, auf den MySQL Server zuzugreifen. Es ist gut möglich, dass Sie sich mit dem gleichen Login und Passwort Ihrer PHP Skripte angemeldet haben oder mit Hilfe von phpMyAdmin, aber in diesem Fall, erkennt der MySQL Server Sie als den 'myuser' User vom 'localhost', der die nötigen Berechtigungen und erlaubt Ihnen somit den Zugang. Um dieses Probelm zu lösen, müssen Sie dafür sorgen, die erforderlichen Rechte dem User myuser@ myhost.mydomain zu geben. Sie können dies mit Hilfe vom phpMyAdmin oder mit SQL Kommandos tun: /*!50003 CREATE USER ‘myuser’@ ‘myhost.mydomain’*/; GRANT ALL PRIVILEGES ON *.* TO ‘myuser’@ ‘myhost.mydomain’ IDENTIFIED BY 'user_password'; Oder Sie können sich an Ihren Systemadministrator wenden (http://dev.mysql.com/doc/refman/5.1/en/privileges.html).

nach oben

F:

Ich arbeite hinter einer Firewall (Router). Kann ich SQL Manager einsetzen, um einen Remote MySQL Server zu verwalten?

A:

Wenn Sie wegen der Sicherheitsrichtlinien in Ihrem Firmennetzwerk oder Ihres Hostproviders keine Verbindung zu einem MySQL Server direkt über TCP/IP (Beispiel: Ihr Firewall verhindert dies), herstellen möchten, können Sie die SSH oder HTTP Tunneling Funktionalität des SQL Manager nutzen, um Ihre Aufgabe dennoch zu erledigen.

nach oben

F:

Warum bekomme ich keine Verbindung zu einem Remote MySQL Server?

A:

Es kann mehrere Gründe geben, die eine erfolgreiche Verbindung zum Remoteserver verhindern. Wenn die Fehlermeldung heißt: "Can't connect to MySQL server on ‘some host' (10061)" dann müssen Sie vermutlich die Richtigkeit des Ports und Host Name, den Sie eingegeben haben, prüfen und ebenfalls, ob der Remote Server läuft. Es passiert oft, dass der Port durch den die Verbindung mit dem MySQl Server erfolgt (in der Regel der 3306) aus Sicherheitsgründen durch den Lokalen Firewal, Firmen Firewall oder Remote Server Firewall geschlossen ist. Der Remote Server Port kann ebenso vom ISP geschlossen werden sein oder das TCP/IP Protokoll Support ist am MySQl Server deaktiviert. Bitte prüfen Sie dieses mit Ihrem Systemadministrator oder ISP. Um diese Einschränkungen zu umgehen, können Sie SSH und HTTP Tunnel (50, 55) verwenden. Wenn die Fehlermeldung besagt “Access denied for user: root@somehost.somedomain” oder "Host not allowed to connect to server", dann ist der Grund hierfür, dass der User keine Berechtigungszugriff auf die Datenbank hat.

nach oben

F:

Ich versuche eine MySQL-DB auf einem Webserver zu registrieren, bekomme aber eine Fehlermeldung. Über mein PHP Skript bekomme ich zu dieser DB Verbindung und zwar über den gleichen Loginnamen und Passwort. Wie kann ich mit Hilfe vom SQL Manager Zugang zu meiner Webseiten-DB bekommen?

A:

Der wahrscheinlichste Grund für dieses Problem ist einer der folgenden: der von MySQL verwendete Port 3306 wird von einer Firewall geblockt, die in Ihrem Netz oder beim Provider installiert ist; oder das TCP Protokoll ist auf dem Remote MySQL Server deaktiviert; oder Ihr Benutzer und Ihre Maschine haben keine Berechtigung sich zum Server zu verbinden.

nach oben

F:

Ich versuche mich zu einem Remote MySQL Host zu verbinden, aber ich erhalte nur folgende Meldung: "Host nicht berechtigt zum Server zu verbinden". Was ist der Grund hierfür?

A:

Dieser Fehler tritt auf, weil Sie keine Berechtigung haben, sich zum Remote MySQL Server von Ihrem Host aus zu verbinden. Bitte kontaktieren Sie Ihren Datenbankadministrator, oder wenn Sie GRANT-Zugriffsrechte auf den MySQL Server haben, können sie das GRANT Statement benutzen, um neuen User anzulegen. Zum Beispiel wird nachfolgendes Kommando dem User den vollen Zugriff von Ihrem Host geben. /*!50003 CREATE USER 'user'@'user_host'*/; GRANT ALL PRIVILEGES ON *.* TO 'user'@'user_host' IDENTIFIED BY ' user_password '; (http://dev.mysql.com/doc/refman/5.1/en/privileges.html)

nach oben

F:

Ich habe die DB registriert, aber beim Versuch sie zu öffnen, kommt die Fehlermeldung "dynamische Bibliothek libmysql.dll nicht gefunden".

A:

Dieser Fehler tritt auf, weil die libmysql.dll Client Library nicht gefunden werden kann. Sie ist für das Arbeiten mit dem MySQL Server sehr wichtig. Die Datei libmysql.dll ist im Studio Installationspaket enthalten. Sie könnten diese Datei versehentlich gelöscht haben oder die exe-Datei wurde in ein anderes Verzeichnis verschoben. Zum Beheben des Problems müssen Sie den SQL Manager neu installieren (sämtliche Einstellungen werden gespeichert) oder Sie kopieren die Datei libmysql.dll in das Verzeichnis mit der exe-Datei.

nach oben

F:

Ich bekomme die Mitteilung "Bad Handshake" beim Versuch mich mit dem MySQL Server 4.1.x zu verbinden. Unterstützt der MySQL Manager den 4.1.x Server?

A:

Am wahrscheinlichsten verwenden Sie eien alte Version der libmySQL.dll Bibliothek. Sie müssen die Bibliothek, die sich im Installationspacket des MySQL Manager befindet, verwenden. Versuchen Sie, diese neu zu installieren.

nach oben

F:

Ich habe versucht, einen Fremdschlüssel für InnoDB-Tabelle zu erstellen und den Fehler "Kann Tabelle … nicht erzeugen (Fehler 150)" bekommen. Was mache ich falsch?

A:

Es bedeutet, dass die Definition des Fremdschlüssels für die geänderte Tabelle nicht korrekt zusammengestellt ist. Z.B. erscheint die referenzierte Spalte nicht als erste Spalte im Index, sowohl in übergeordneten und untergeordneten Tabellen oder die Typen der entsprechenden Felder stimmen nicht überein. Verwenden Sie SHOW ENGINE INNODB STATUS, um eine detaillierte Erklärung des neuesten InnoDB Fremdschlüsselfehlers auf dem Server zu sehen.

nach oben

F:

Ich setze das Windows Betriebssystem ein, aber mein MySQL Server läuft auf einem Linux Rechner. Werde ich den SQL Manager einsetzen können, um auf diesem Server zu arbeiten?

A:

Ja, das ist möglich. Es spielt keine Rolle auf welchem Betriebssystem der MySQL Server läuft, der Manager läuft nur unter der Windows.

nach oben

F:

Jedes Mal, wenn ich versuche eine Verbindung zu einem MySQL Server auf einem Linux-Server herzustellen, kommt die Meldung: "Verlorene Verbindung zum MySQL Server während einer Abfrage". Was mache ich falsch?

A:

Der Fehler kann auftreten, wenn die Linux glibc mehr als 128K Stack Größe verwendet, um den Hostnamen aufzulösen. Er tritt hauptsächlich auf RedHat 8.0 Systemen mit MySQL Versionen älter als 4.0.10 auf, kann aber auch bei anderen Konfigurationen vorkommen. Um das Problem zu beheben, ergänzen/editieren sie die folgenden Zeilen des [mysqld] Abschnittes des MySQL Konfigurationsfiles: set-variable = thread_stack=192k # Wert muss 192K oder größer sein.

nach oben


Verwandte Produkte

MySQL

Microsoft SQL

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

DBISAM

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL ist eine komplette Lösung für MySQL-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der MySQL-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die MySQL-Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie MySQL-Datenbankentwurf, Migrationen, Extrahieren, MySQL-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für MySQL in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank-Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for MySQL alle wichtigen MySQL-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for MySQL EMS SQL Manager for MySQL umfasst leistungsstarke Werkzeuge zur Verwaltung und Entwicklung des MySQL-Servers. Der SQL Manager for MySQL hat eine benutzerfreundliche grafische Oberfläche und erlaubt, alle MySQL-Datenbankobjekte auf eine einfache und direkte Weise zu erstellen/zu bearbeiten, MySQL-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, MySQL-Datenbankdaten zu importieren und zu exportieren. Der SQL Manager for MySQL bietet eine Vielzahl von weiteren Diensten an, die MySQL-Verwaltung erheblich vereinfachen.
dataexport | Data Export for MySQL EMS Data Export for MySQL ist ein leistungsfähiges Programm für den schnellen Export der Daten aus MySQL Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der EMS Data Export for MySQL enthält einen Assistenten zur visuellen Einstellung des Exports aus MySQL-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von MySQL-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for MySQL EMS Data Import for MySQL ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in MySQL-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere MySQL-Tabellen bzw. Sichten zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den MySQL-Import abzuspeichern, einen speziellen Masseneinfügemodus zum schnelleren Importieren von MySQL-Daten zu verwenden und vieles mehr.
datapump | Data Pump for MySQL EMS Data Pump for MySQL ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in MySQL Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for MySQL erheblich vereinfacht!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der MySQL-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche MySQL-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von MySQL-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for MySQL EMS DB Comparer for MySQL ist ein hervorragendes Werkzeug zum Vergleichen von MySQL-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der MySQL-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von MySQL-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for MySQL EMS DB Extract for MySQL ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for MySQL können sowohl die Metadaten aller Datenbankobjekte als auch die MySQL-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für MySQL Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for MySQL EMS SQL Query for MySQL ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die MySQL-Datenbanken erstellen können. Die MySQL-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit MySQL-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum MySQL Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for MySQL EMS Data Comparer for MySQL ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der MySQL-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den MySQL-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for MySQL bieten eine große Anzahl von Konfigurierungsparametern an, um die Daten von MySQL-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

Microsoft SQL

 | SQL Management Studio for SQL Server EMS SQL Management Studio for SQL Server ist eine komplette Lösung für SQL Server-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der SQL Server-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die SQL Server-Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie SQL Server-Datenbankentwurf, Migrationen, Extrahieren, SQL Server-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für SQL Server in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank- Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for SQL Server alle wichtigen SQL Server-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server umfasst leistungsstarke grafische Werkzeuge zur Verwaltung und Entwicklung der Datenbanken des Microsoft SQL Servers. Der EMS SQL Manager for SQL Server erlaubt, Datenbankobjekte des MS SQL Servers einfach und direkt zu erstellen/zu bearbeiten, SQL-Skripts zu starten, Rechte von Benutzern des SQL-Servers und ihre Berechtigungen zu verwalten, SQL-Abfragen grafisch zu erstellen, mit Metadaten zu arbeiten, Datenbankdaten des SQL-Servers zu exportieren und zu importieren und vieles mehr.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server ist ein leistungsfähiges Programm für den schnellen Export der Daten aus SQL-Server-Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for SQL Server enthält einen Assistenten zur visuellen Einstellung des Exports aus SQL-Server-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von SQL-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for SQL Server EMS Data Import for SQL Server ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in SQL Server-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere SQL Server-Tabellen bzw. Sichten zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den SQL Server-Import abzuspeichern, einen speziellen Masseneinfügemodus zum schnelleren Importieren von SQL Server-Daten zu verwenden und vieles mehr.
datapump | Data Pump for SQL Server EMS Data Pump for SQL Server ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in SQL Server Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for SQL Server erheblich vereinfacht!
datagenerator | Data Generator for SQL Server EMS Data Generator for SQL Server ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der SQL Server-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche SQL Server-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von SQL Server-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer for SQL Server ist ein hervorragendes Werkzeug zum Vergleichen von SQL Server-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der SQL Server-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von SQL Server-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for SQL Server EMS DB Extract for SQL Server ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for SQL Server können sowohl die Metadaten aller Datenbankobjekte als auch die SQL Server Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für SQL Server Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for SQL Server EMS SQL Query for SQL Server ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die SQL Server-Datenbanken erstellen können. Die SQL Server-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit SQL Server-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum SQL Server Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for SQL Server EMS Data Comparer for SQL Server ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der SQL Server-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den SQL Server Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for SQL Server bieten eine große Anzahl von Konfigurierungsparametern an, um die Daten von SQL Server-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL ist eine komplette Lösung für PostgreSQL-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der PostgreSQL-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die PostgreSQL-Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie PostgreSQL-Datenbankentwurf, Migrationen, Extrahieren, PostgreSQL-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für PostgreSQL in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank-Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for PostgreSQL alle wichtigen PostgreSQL-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for PostgreSQL EMS SQL Manager for PostgreSQL umfasst leistungsstarke grafische Werkzeuge zur Verwaltung und Entwicklung von Datenbanken des PostgreSQL-Servers. Der EMS SQL Manager for PostgreSQL erlaubt, Datenbankobjekte des PostgreSQL-Servers einfach und direkt zu erstellen/zu bearbeiten, SQL-Skripts zu starten, grafisch PostgreSQL-Datenbanken zu entwerfen, SQL-Abfragen zu erstellen, Metadaten zu extrahieren, auszudrucken und zu suchen, Datenbankdaten des PostgreSQL-Servers zu exportieren und zu importieren und vieles mehr.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL ist ein leistungsfähiges Programm für den schnellen Export der Daten aus PostgreSQL Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for PostgreSQL enthält einen Assistenten zur visuellen Einstellung des Exports aus PostgreSQL-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von PostgreSQL-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in PostgreSQL-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere PostgreSQL-Tabellen bzw. Sichten zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den PostgreSQL-Import abzuspeichern, einen speziellen Masseneinfügemodus zum schnelleren Importieren von PostgreSQL-Daten zu verwenden und vieles mehr.
datapump | Data Pump for PostgreSQL EMS Data Pump for PostgreSQL ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in PostgreSQL Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for PostgreSQL erheblich vereinfacht!
datagenerator | Data Generator for PostgreSQL EMS Data Generator for PostgreSQL ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der PostgreSQL-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche PostgreSQL-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von PostgreSQL-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer for PostgreSQL Server ist ein hervorragendes Werkzeug zum Vergleichen von PostgreSQL-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der PostgreSQL-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von PostgreSQL-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for PostgreSQL EMS DB Extract for PostgreSQL ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for PostgreSQL können sowohl die Metadaten aller Datenbankobjekte als auch die PostgreSQL-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für PostgreSQL Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for PostgreSQL EMS SQL Query for PostgreSQL ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die PostgreSQL-Datenbanken erstellen können. Die PostgreSQL-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit PostgreSQL-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum PostgreSQL Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer for PostgreSQL ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der PostgreSQL-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den PostgreSQL-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for PostgreSQL bietet eine große Anzahl von Konfigurierungsparametern an, um die Daten von PostgreSQL-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

InterBase / Firebird

SQL Management Studio for InterBase/Firebird

EMS SQL Management Studio for InterBase/Firebird ist eine komplette Lösung für InterBase und Firebird Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der InterBase und Firebird -Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die InterBase und Firebird Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie InterBase und Firebird Datenbankentwurf, Migrationen, Extrahieren, InterBase und Firebird -Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für IB und Firebird in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank- Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for InterBase und Firebird alle wichtigen InterBase-Tools und Firebird-Tools, um Sie produktiver als je zuvor zu machen!

SQL Manager for InterBase/Firebird

EMS SQL Manager for InterBase/Firebird ist ein leistungsstarkes Werkzeug zur Verwaltung und Entwicklung von Datenbanken des InterBase/Firebird-Servers. Der EMS SQL Manager for InterBase/Firebird eignet sich mit allen neuen Versionen der Datenbanken für IB und Firebird und unterstützt alle relevanten neuen Serverfeatures. Das Tool bietet eine Anzahl von leistungsstarken Werkzeugen an, wie z.B. Visual Database Designer, Visual Query Builder und Stored Procedure Debugger zur Entwicklung der SQL-Skripts für Interbase und Firebird und vieles mehr.

dataexport

Data Export for InterBase/Firebird

EMS Data Export for InterBase/Firebird ist ein leistungsfähiges Programm für den schnellen Export der Daten aus InterBase/Firebird Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for InterBase/Firebird enthält einen Assistenten zur visuellen Einstellung des Exports aus InterBase/Firebird-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von InterBase/Firebird-Exportaufträgen mithilfe einer Konfigurationsdatei.

dataimport

Data Import for InterBase/Firebird

EMS Data Import for InterBase und Firebird ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in InterBase und Firebird-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere InterBase/Firebird-Tabellen bzw. Sichten schnell zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den InterBase und Firebird-Import abzuspeichern, Import-Parameter für jede Quelldatei anzugeben und vieles mehr.

datapump

Data Pump for InterBase/Firebird

EMS Data Pump for InterBase/Firebird ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in InterBase/Firebird Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for InterBase/Firebird erheblich vereinfacht!

datagenerator

Data Generator for InterBase/Firebird

EMS Data Generator for InterBase/Firebird ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der InterBase/Firebird-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche InterBase/Firebird-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von InterBase/Firebird-Testdaten auf einfache und direkte Weise.

dbcomparer

DB Comparer for InterBase/Firebird

EMS DB Comparer for InterBase/Firebird ist ein hervorragendes Werkzeug zum Vergleichen von InterBase/Firebird-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der InterBase/Firebird-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von InterBase/Firebird-Datenbanken einfach und schnell auszuführen.

extract

DB Extract for InterBase/Firebird

EMS DB Extract for InterBase/Firebird ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for InterBase/Firebird können sowohl die Metadaten aller Datenbankobjekte als auch die InterBase/Firebird-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für InterBase/Firebird Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.

query

SQL Query for InterBase/Firebird

EMS SQL Query for InterBase/Firebird ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die InterBase/Firebird-Datenbanken erstellen können. Die InterBase/Firebird-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit InterBase/Firebird-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum InterBase/Firebird Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.

datacomparer

Data Comparer for InterBase/Firebird

EMS Data Comparer for InterBase/Firebird ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der InterBase/Firebird-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den InterBase/Firebird-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for InterBase/Firebird bietet eine große Anzahl von Konfigurierungsparametern an, um die Daten von InterBase/Firebird-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.

Erfahren Sie mehr

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle ist eine komplette Lösung für Oracle-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der Oracle-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die Oracle- Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie Oracle-Datenbankentwurf, Migrationen, Extrahieren, Oracle-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für Oracle in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank- Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for Oracle alle wichtigen Oracle-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for Oracle EMS SQL Manager for Oracle umfasst leistungsstarke Datenbankwerkzeuge zur Verwaltung und Entwicklung von Datenbanken des Oracle-Servers. Der SQL Manager Oracle hat eine benutzerfreundliche grafische Oberfläche und erlaubt, alle Oracle-Datenbankobjekte auf eine einfache und direkte Weise zu erstellen/zu bearbeiten, Oracle-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, Oracle-Datenbankdaten zu importieren und zu exportieren. Der SQL Manager for Oracle bietet eine Vielzahl von weiteren Diensten an, die Oracle-Verwaltung erheblich vereinfachen.
dataexport | Data Export for Oracle EMS Data Export for Oracle ist ein leistungsfähiges Programm für den schnellen Export der Daten aus Oracle-Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for Oracle enthält einen Assistenten zur visuellen Einstellung des Exports aus Oracle-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von Oracle-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for Oracle EMS Data Import for Oracle ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in Oracle-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere Oracle-Tabellen bzw. Sichten schnell zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den Oracle-Import abzuspeichern und vieles mehr.
datapump | Data Pump for Oracle EMS Data Pump for Oracle ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in Oracle-Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for Oracle erheblich vereinfacht!
datagenerator | Data Generator for Oracle EMS Data Generator for Oracle ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der Oracle-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche Oracle-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von Oracle-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle ist ein hervorragendes Werkzeug zum Vergleichen von Oracle-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der Oracle-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von Oracle-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for Oracle EMS DB Extract for Oracle ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for Oracle können sowohl die Metadaten aller Datenbankobjekte als auch die Oracle-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für Oracle Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for Oracle EMS SQL Query for Oracle ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die Oracle-Datenbanken erstellen können. Die Oracle-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit Oracle-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum Oracle-Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der Oracle-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den Oracle-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for Oracle bietet eine große Anzahl von Konfigurierungsparametern an, um die Daten von Oracle-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

DB2

 | SQL Manager for DB2 EMS SQL Manager for DB2 umfasst leistungsstarke Datenbankwerkzeuge zur Verwaltung und Entwicklung von DB2-Datenbanken. Der SQL Manager Oracle hat eine benutzerfreundliche grafische Oberfläche und erlaubt, alle DB2-Datenbankobjekte auf eine einfache und direkte Weise zu erstellen/zu bearbeiten, DB2-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, DB2-Datenbankdaten zu importieren und zu exportieren. Der SQL Manager for DB2 bietet eine Vielzahl von weiteren Diensten an, die DB2-Verwaltung erheblich vereinfachen.
dataexport | Data Export for DB2 EMS Data Export for DB2 ist ein leistungsfähiges Programm für den schnellen Export der Daten aus DB2-Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for DB2 enthält einen Assistenten zur visuellen Einstellung des Exports aus DB2-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von DB2-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for DB2 EMS Data Import for DB2 ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in DB2-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere DB2-Tabellen bzw. Sichten schnell zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den DB2-Import abzuspeichern und vieles mehr.
datapump | Data Pump for DB2 EMS Data Pump for DB2 ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in DB2 Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for DB2 erheblich vereinfacht!
datagenerator | Data Generator for DB2 EMS Data Generator for DB2 ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der DB2-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche DB2-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von DB2-Testdaten auf einfache und direkte Weise.
extract | DB Extract for DB2 EMS DB Extract for DB2 ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for DB2 können sowohl die Metadaten aller Datenbankobjekte als auch die DB2-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für DB2 Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for DB2 EMS SQL Query for DB2 ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die DB2-Datenbanken erstellen können. Die DB2-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit DB2-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum DB2-Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
 | Erfahren Sie mehr

DBISAM

SQL Manager for DBISAM

EMS SQL Manager for DBISAM umfasst leistungsstarke Werkzeuge zur Verwaltung und Entwicklung des DBISAM-Servers. Der EMS SQL Manager for DBISAM-Server erlaubt, Datenbankobjekte des DBISAM-Servers einfach und direkt zu erstellen/zu bearbeiten, SQL-Skripts zu starten, Rechte von Benutzern des DBISAM-Servers und ihre Berechtigungen zu verwalten, DBISAM-SQL-Abfragen grafisch zu erstellen, mit Metadaten zu arbeiten, Datenbankdaten des DBISAM-Servers zu exportieren und zu importieren und viele weitere Features.

Erfahren Sie mehr

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL (für Borland Delphi und C++ Builder) erlaubt Ihnen, Daten in allen gängigen Datenformaten zum späteren Anzeigen, Ändern, Drucken oder Webveröffentlichen zu speichern. Es ist nicht mehr nötig, Zeit für eine anstrengende Datenkonvertierung zu verschwenden. Der Advanced Data Export wird schnell und einfach die Aufgabe ausführen und das Ergebnis im gewünschten Format ausgeben.
advancedimport | Advanced Data Import Advanced Data Import VCL ist ein Komponentensuite für Borland Delphi und C++ Builder, das Ihnen erlaubt Daten aus allen populären Dateiformaten in Datenbank zu importieren. Sie können Daten aus MS Excel, MS Access, DBF, XML, TXT und CSV importieren. Jetzt ist es nicht mehr nötig Zeit zu verschwenden, um Daten per Hand zu konvertieren.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator Komponenten Paket bittet die einfachste Möglichkeit PDF Dokumente zu erzeugen, die mit Delphi oder C++ Builder geschrieben wurden. Sie müssen nicht unbedingt die obligatorischen Spezifikationen der PDF wissen, aber Sie können einfach und schnell mit Hilfe von Advanced PDF Generator PDF-Dateien generieren.
querybuilder | Advanced Query Builder Advanced Query Builder ist eine leistungsstarke Komponentensuite für Borland Delphi und C++ Builder, bestimmt für die visuelle Konstruktion der SQL-Abfragen für die SELECT, INSERT, UPDATE und DELETE Klauseln. Er erlaubt Ihnen, neue visuelle Abfragen zu erstellen und/oder grafisch die bestehenden Abfragen in Ihrer Anwendung darzustellen.
excelreport | Advanced Excel Report Advanced Excel Report Komponent für Delphi ist ein mächtiger Bericht Generator in MS Excel, gegründet auf dem Sektionsprinzip der Konstruktion mit der Benutzung der Vorlagen. Der bequeme Redakteur der Komponente Eigenschaften lassen schnell Berichte für MS Excel erschaffen.
advancedlocalizer | Advanced Localizer Advanced Localizer ist ein unersetzliches Komponentenpaket für Borland Delphi zur mehrsprachigen Hilfe in Ihrer Delphi Anwendung. Mit Hilfe dieses Paketes können Sie einfach und schnell die Eigenschaft aller Komponenten auf jeder Form lokalisieren. Erstellen Sie eine Sprachdatei, der die aktuelle Werte von sprachspezifierten Teileigenschaften enthalten, verwalten Sie lokale Dateien und spezifieren welche Komponenten zu lokalisieren sind.
sourcerescuer | Source Rescuer EMS Source Rescuer ist ein leichtes Utility, das Ihnen helfen kann, den verlorenen Quellcode wiederherzustellen. Falls Sie die Ausgangstexte Ihrer Anlage, die auf Delphi oder C++Builder geschrieben wurde, verloren haben, aber besitzen noch die exe. Datei, dann hilft Ihnen das Utility den Teil der Ausgangstexte wiederherzustellen.
 | Erfahren Sie mehr


Arbeitsstart

Um das Arbeiten mit MySQL mit Hilfe des SQL Manager 2007 for MySQL zu starten, muss man vor allem eine oder mehrere Datenbanken unter Verwendung des Tools Register Database Wizard/Assistent zur Registrierung der Datenbank registrieren. Haben Sie keine zu registrierenden Datenbanken, dann kann man die mittels des Create Database Wizard/Assistent zur Erstellung der Datenbank erstellen. Dies ermöglicht das Arbeiten mit einer Datenbank:Bearbeiten und Verwalten von Daten usw.

Um zu erfahren, wie man diese Operationen auszuführen sind, machen Sie sich bitte mit den jeweiligen Anweisungen vertraut.

  • Auswählen des Umgebungsstils und der Programmsprache
  • Darstellung des Programms beim ersten Start
  • Arbeiten mit den Datenbanken
  • Arbeiten mit den Objekten von Datenbanken
  • Verwendung des Kontextmenüs von Datenbanken
  • Verwendung des Kontextmenüs von Datenbankobjekten
  • Umschalten zwischen den Fenstern

Haben Sie Spaß beim Arbeiten mit SQL Manager 2007 for MySQL!


Auswählen des Umgebungsstils und der Programmsprache

Beim ersten Start des SQL Manager 2007 for MySQL müssen Sie den Umgebungsstil und die Programmsprache auswählen. Diese Einstellungen kann man später mit Hilfe des Hauptmenüpunktes des Programms Options | Environment Options | Windows zum Auswählen des Umgebungsstils und Options | Select Program Language zum Auswählen der Sprache abändern.

Environment style/Umgebungsstil

Dieses Verwaltungselement lässt angeben, ob das Programm entweder die MDI-Umgebung (wie MS Office) oder Floating-Fenster-Umgebung (wie Borland IDE) haben wird.

Bar style for child forms/Format der Leiste für untergeordnete Formulare

Auswählen des Darstelungsformates der Leisten. Navigationsleiste (nebenher) und/oder Symbolleiste (oben).

Programmsprache/Program Language

Dieser Punkt lässt die Sprache der Programmoberfläche aus der Liste der verfügbaren Sprachen auswählen. Die Standardsprache ist Englisch. (Die Liste der verfügbaren Sprachen stellt sich aufgrund der Sprachdateien (*.lng) zusammen. Diese befinden sich in der Directory "Languages" im Verzeichnis, in dem das Programm installiert wurde).


Erster Start des Programms

So sieht der SQL Manager 2007 for MySQL nach dem ersten Start aus.

Im Kontextmenü des DB-Explorers oder auf der Desktopleiste wählen Sie Create new database/Neue Datenbank erstellen zur Erstellung einer neuen Datenbank. Dabei hilft Ihnen das Werkzeug Create Database Wizard/Assistent zum Estellen der Datenbank.

Um das Arbeiten mit einer schon bestehenden Datenbank anfangen zu können, muss diese registriert werden.

(Eine neue, mit Hilfe des Create Database Wizard/Assistent zum Erstellen der Datenbank erstellte Datenbank wird automatisch registirert).

Drücken Sie auf Manage existing database(s)/Bestehende Datenbank(en) verwalten, um eine Datebank mit Register Database Wizard/Assisten zur Registrierung der Datenbank zu registrieren.


Verwendung der Desktopleiste

Desktop Panel/Desktopleiste ist zu sehen, wenn kein untergeordnetes Fenster geöffnet ist. Darauf werden die zur Anfang der Arbeit benötigten Verwaltungselemente dargestellt.

Schnelleinstieg:

  • Create new database/Neue Datenbank erstellen erstellt und registriert eine neue Datenbank mit Hilfe des Create Database Wizard/Assistent zum Estellen der Datenbank.
  • Manage existing database(s)/Bestehende Datenbank(en) erstellen registriert eine bestehende Datenbank.
  • Create new table/Neue Tabelle erstellen. Dieser Befehl ist verfügbar, wenn die Verbindung mindestens zu einer Datenbank besteht. Eine neue Tabelle kann in der aktiven Bank mit Hilfe des Werkzeuges New table/NeueTabelle erstellt werden.
  • Create new database object/Neues Datenbank-Objekt erstellen erstellt ein neues Objekt von Datenbank in der aktiven Datenbank. Wenn es also keine aktive Verbindung gibt, dann ist dieser Befehl nicht verfügbar.

Datenbank-Werkzeuge

  • Execute SQL Script/SQL-Skript ausführen öffnet den Editor des SQL-Skiptes, den SQL Skript Editor.
  • Manage users/Benutzer verwalten verwaltet die Benutzerkontos im User Manager.
  • Execute query/Abfrage ausführen führt die Abfrage aus, der SQL-Editor wird geöffnet.
  • Manage permissions/Berechtigungen verwalten verwaltet Benutzerkontos. Es werden den Benutzern die Berechtigungen für die Verwaltung mit einem Datenbank-Objekt zugewiesen.

Hilfe und Unterstützung

  • MySQL Manager help system/MySQL Manager Hilfe System öffnet diese Hilfedatei.
  • MySQL reference/MySQL Hinweis öffnet den Hinweis für MySQL.

Internet Ressourcen

  • MySQL Manager home page/MySQL Manager Home Page ist ein Link auf die Haupseite des Produktes mit den allgemeinen Informationen über dessen Anschaffung, Verwendung usw.
  • MySQL Manager on-line documentation/MySQL Manager Online Dokumentation ist die Dokumentation für den SQL Manager 2007 for MySQL auf unserer Website. Es wird der zum Programm beigefügte Hinweis dupliziert.
  • Support Center erlaubt die "Online-Beratung"für beliebige Fragen, Anregungen und Vorschlägen mit Hilfe des Support Ticket Systems erhalten. Um diese Unterstützung zu bekommen, muss man auf der Website registrieren.
  • MySQL Manager FAQ ist ein Abschnitt auf der Website mit der Liste der Häufig gestellten Fragen und Antworten darauf.


Arbeiten mit den Datenbanken

Nachdem eine Datenbank registriert wurde, erscheint diese im DB-Explorer, der im linken Teil des Bildschirmes zu finden ist.

In dem DB-Explorer werden alle registrierten Datenbanken angezeigt. Die Datenbanken, mit denen im Moment keine Verbindungen bestehen, sind mit grauer Farbe markiert.

Im unteren Explorer-Fenster, das SQL Assistant benannt wird, ist der Inhalt des aktiven Elementes zu sehen.

Haben Sie im Explorer eine Tabelle markiert, dann werden im unteren Fenster alle Felder dieser Tabelle erscheinen. Im Falle des Servers werden alle Banken, die zu diesem Server gehören, angezeigt usw.

Falls die Option Show Hosts/Hosts anzeigen aktiviert ist, so hat die Ansicht der Datenbank eine hierarchische Struktur von Servern und Datenbanken. Wenn man diese Option deaktiviert, dann wird im Fenster nur die Liste der Datenbanken angezeigt.

Es gibt zwei Möglichkeiten, die Option Show Hosts zu aktivieren. In Options | Environment Options | DB Explorer | muss man Show Hosts in DB Explorer anklicken oder im Explorer-Kontextmenü, das nach dem rechten Mausklick im DB-Explorer geöffnet wird, den Punkt Show Hosts auswählen.

Kontextmenü der Datenbanken

Einige Punkte dieses Menüs wiederholen sich im Explorer-Kontextmenü und auf der Symbolleiste der DB-Explorer.

Das Kontextmenü einer Datenbank hilft:

  • zu einer ausgewählten Datenbank zu verbinden - Connect to Database/Datenbank verbinden (für eine nicht verbundene Datenbank),
  • sich von einer ausgewählten Datenbank zu trennen- Disconnect from Database/Datenbank trennen (für eine verbundene Datenbank),
  • neue Datenbank mit Hilfe des Register Database Wizard/Assistent zur Registrierung der Datenbank zu registireren - Menüpunkt Register Database/Datenbank registrieren,
  • Registrierung der Datenbank aufzuheben- Unregister Database/Registrierung der Datenbank aufheben,
  • Datenbank Registrierunginfos bearbeiten - Database Registration Info/Datenbank Registrierungsinfo,
  • einen neuen Host mit Hilfe des Register Database Wizard/Assistent zur Registrierung der Datenbank zu registrieren Register Host/Host registrieren,
  • Registrierung des Hostes und aller auf ihm registrierten Datenbanken aufzuheben Unregister Host/Registrierung des Hostes aufheben
  • Option Show Hosts zu aktivieren,
  • Datenbanken nach den Namen zu ordnen Sort by Aliases/Nach Alias ordnen,
  • Nicht angeschloßene Datenbanken auszublenden Hide Disconnected Databases/Getrennte Datenbanken ausblenden,
  • Datenbank zu erneuern Refresh Database/Datenbanken erneuern,
  • Neues Tab zu erstellen New Tab from Here/Neues Tab von hier,
  • aktuelles Tab umzubenennen Rename Current Tab/Aktuelles Tab umbenennen,
  • aktuelles Tab zu entfernen Delete Current Tab/Aktuelles Tab löschen,
  • Find Item/Element suchen sucht von dem Benutzer angegebene Kombination von Buchstaben und Zahlen in den Namen von Datenbanken und Objekten


Arbeiten mit den Objekten von Datenbanken

Der DB-Explorer ermöglicht den Zugriff auf jedes Objekt der registrierten Datenbank, mit der im Moment die Verbindung hergestellt wird.

Der Doppelklick auf das Objekt öffnet dieses im jeweiligen Editor, mit der rechten Maustaste wird das Kontextmenü mit der Liste der für dieses Objekt verfügaberen Operationen aufgerufen. Den Inhalt der entsprechenden Unterstruktur kann man mit dem Drücken der Schaltfläche F5 auf der Tastatur oder durch das Anklicken des jeweiligen Menüpunktes erneuern. Man kann also sowie die ganze Datenbank, als auch einige Objekte aktualisieren.

Möchten Sie den Explorer zum Arbeiten mit den Unterobjekten (Feldern, Indizes usw.) verwenden, dann wählen Sie Show Table Subobjects in Environment Options | DB Explorer. Sie können diese Funktion auch mit Hilfe des Menüeintrages des DB-Explores View Mode einschalten.

Kontextmenü des Objektes

Dieses Menü wird beim Klicken mit der rechten Maustaste auf jedes Datenbank-Objekt geöffnet. Mit Hilfe dieses Menüs kann man:

  • Neues Datenbank-Objekt erstellen - New/Neu <Objekt>,
  • Ausgewähltes Objekt im Editor öffnen - Edit/Bearbeiten <Objektname>,
  • Ausgewähltes Objekt umbenennen - Rename/Umbennen <Objektname>,
  • Ausgewähltes Objekt löschen - Drop/Löschen <Objektname>,
  • Objekt mit Hilfe des Assistent zum Kopieren der Objekte kopieren- Duplicate/Duplizieren <"Objektname">,
  • Abhängigkeitsstruktur für dieses Objekt öffnen - Dependency Tree/Abhängigkeitsbaum.

Die nachfolgenden Optionen sind nur für bestimmte Objekte verfügbar:

  • Objekteingeschaten durchsehen- <"Objektname"> Properties/Eigenschaften ,
  • Berechtigungen von Benutzern verwalten - Grants for/Berechtigungen für <Objektname>,
  • Infos über das Objekt erneuern - Refresh/Erneuern <Objektname>,
  • Datenbank Registrierungsinfo bearbeiten - Database Registration Info/Datenbank Registrierungsinfo,
  • Neues Tab erstellen - New Tab from Here/Neues Tab von hier,
  • Aktives Tab umbenennen - Rename Current Tab/Aktuelles Tab umbenennen ,
  • Aktives Tab löschen - Delete Current Tab/Aktuelles Tab löschen ,
  • DB-Element finden - Find Item/Element finden.


Umschalten zwischen den Fenstern

Das Umschalten zwischen den Fenstern im SQL Manager 2007 for MySQL funktioniert ähnlich wie im Windows-Betriebssystem. Mit dem rechten Mausklick auf das Fenstersymbol auf der Taskleiste des Programms erscheint das Kontextmenü.

Für den Übergang von einem Fenster zum anderen reicht es einen Mausklick auf das gewünschte Fenster.

Mittels Environment Options | Windows | Number of open editors is restricted/

Umgebungsoptionen | Windows | Anzahl geöffneter Editoren ist begrenzt kann man eine maximale Anzahl der geöffneten Editoren von Datenbank-Objekten angeben. Falls die Anzahl der geöffneten Editoren eine angegebene Anzahl überschreitet, dann werden die vorher geöffneten Editoren durch das Programm automatisch geschloßen.

Zur komfortablen Arbeit mit den Fenstern ist ein spezieller Punkt im Hauptmenü des Windows-Programms vorhanden.

Mithilfe dieses Menüs kann man:

  • Windows List - Liste der geöffneten Fenster anzeigen

Zusätzlich wird die Liste der geöffneten Fenster auf einer Registerkarte angezeigt.

  • Cascade - überlappend

  • Minimize All - Alle Fenster minimieren,
  • Tile Horizontal - Untereinander

  • Tile Vertical - Nebeneinander

  • Set Defaults to All Windows - Alle Fenster standardmäßig festlegen
  • Reset All Toolbars and Menus - Alle Symbolleisten und Menüs zurücksetzen
  • Close All - Alle schließen,
  • aus dem Untermenü des Punktes Close wählt man den Objekttyp, der geschlossen werden muss (falls beispielweise Tabellen ausgewählt werden, dann werden alle geöffneten Tabelleneditor geschlossen)
  • Previous Window - vorheriges Fenster,
  • Next Window - nächstes Fenster.


DB-Explorer

Der Datenbank-Explorer (Database Explorer bzw. DB Explorer) ist ein Hauptnavigationsfenster zum Arbeiten mit den Datenbanken und deren Objekten. Dieser hat eine hierarchische Struktur und besteht aus mehreren Fenstern. Der DB-Explorer hilft praktisch alle Operationen mit den Datenbanken auszuführen.

Kontextmenü

Symbolleiste des DB-Explorers

Verbindung zur Datenbank

Bearbeiten der Datenbank-Registrierungsinfos

Hauptoperationen mit den Objekten

Erstellung von Projekten

Verwendung von Tabs

Auswählen mehrerer Objekte

Zuletzt verwendete Objekte

Suche

Ansicht der Infos über die Objekte im SQL-Assistenten

Einstellung des DB-Explorers

Alle Datenbank-Objekte, z.B. Tabellen, Abfragen, Reports usw., sind in die jeweiligen Ordner eingeteilt. Für jedes Typ wird eine vorhandene Anzahl von Objekten angezeigt. Z.B befinden sich alle Tabellen im Order Tables/Tabellen und daneben wird derer Anzahl dargestellt.

Zum Anzeigen bzw. Verstecken des Explorer-Fensters, verwenden Sie bitte den Befehl View | DB Explorer/ Ansicht | DB Explorer im Hauptmenü oder drücken Sie auf die F11. Um schnell den Inhalt einer Datenbank einzuklappen, benutzen Sie die Tastenkombination Ctrl+Shift+С.


Kontextmenü

Das Kontexmenü des DB-Explorers ist eine Liste der Aktionen. Diese kann man öffnen, indem man mit der rechten Maustaste auf den leeren Platz des DB-Explorers klickt.

Mit Hilfe des Kontextmenü kann man:

  • Datenbank registrieren - Register Database/Datenbank registrieren,
  • Host registrieren - Register Host.../Host registrieren... Hierfür wird der Assistent zur Registrierung der Datenbank verwendet,
  • Host-Registrierung aufheben - Unregister Host/Host-Registrierung aufheben,
  • Option Show Hosts/Host anzeigen aktivieren,
  • Datenbanken nach den Namen sortieren Sort by Aliases/Nach Alias ordnen (Standardmäßig sind diese in der Reihenfolge der Registrierung dargestellt),
  • Hide Disconnected Databases/Getrennte Datenbanken ausblenden - diese Funktion wird verwendet, um nicht angeschlossene Datenbanken zu verstecken,
  • New Tab from Here/Neues Tab von hier - neues Tab erstellen,
  • Rename Current Tab/Aktuelles Tab umbenennen - aktuelles Tab umbenennen,
  • Delete Current Tab/Aktuelles Tab löschen - aktuelles Tab löschen,
  • Find Item/Element suchen - Suche nach der vom Anwender angegebenen Kombination von Buchstaben und Zahlen in den Bezeichnungen von Datenbanken und Objekten.


Verbindung zur Datenbank

Der Befehl Connect to database/Datenbank verbinden ist nicht aktiviert, wenn die Verbindung zur ausgewählten Datenbank besteht.

Die Datenbank kann man auf folgende 3 Weisen verbinden

  1. Im Kontextmenü einer getrennten Datenbank den Punkt Connect to database/Datenbank verbinden auswählen.

  2. Ist die Datenbank aktiviert, dann auf der Symbolleiste des Exploreres ist der Punkt Connect to database/Datenbank verbinden auch sichtbar.

  3. Man kann auch das Hauptmenü des Programms benutzen und dort Connect to database/Datenbank verbinden auswählen.


Datenbank Registrierungsinfo

Wurde bei der Erstellung bzw. Registrierung der Datenbank ein Fehler zugelassen, dann kann dieser mit Hilfe des Befehls Database Registration Info/Datenbank Registrierungsinfo behoben werden.

Der DB-Explorer lässt die Registrierungsinfo während des Arbeitsprozesses bearbeiten.

Hierfür wird der Punkt des Kontextmenüs Database Registration Info/Datenbank Registrierungsinfo (für angeschlossene Datenbanken) verwendet. Nach dem Anklicken dieses Menüpunktes wird das Fenster für die Bearbeitung der DB-Registrierungsinfo geöffnet.


Hauptoperationen mit den Objekten

Der DB-Explorer hilft den Zugriff auf die Hauptaktionen mit einem DB-Objekt mittels des Kontextmenüs zu erhalten. Bemerkung: Für jedes Objekttyp ist eigenes Menü vorhanden.

Die Hauptaktionen, die es in jedem Kontextmeü gibt:

  • Erstellung - New/Neu <Objekt>,
  • Bearbeitung - Edit/Bearbeiten <"Objektname">,
  • Löschen - Drop/Löschen <"Objektname">,
  • Umbennenung - Rename/Umbenennen <"Objektname">,
  • Kopieren des Objektes - Duplicate/Duplizieren <"Objektname">,

Diese Aktionen sind gleich für alle Objekttypen.

Zum Öffnen eines Objektes in einem jeweiligen Editor reicht es, das Objekt im DB-Explorer doppelzuklicken.


Arbeiten mit den Projekten

Verwenden Sie Projects/Projekte, wenn Sie mit einer großen Datenbank arbeiten und wenn Sie lediglich daraus nur auf einige Objekte zugreifen.

Für die Projekte ist ein Sonderordner in der Struktur des DB-Exploreres vorgesehen. Selber brauchen Sie den nicht zu erstellen.

Hinzufügen von Objekten in den Projekt

Um die Objekte in den Projekt hineinzubringen, muss man den Unterordner innerhalb des Ordners Projects/Projekte erstellen, indem man den Punkt des Kontextmenüs New Sub Folder/Neuer Unterordner auswählt.

Im erscheinenden Fenster muss der Name des Ordners angegeben werden.

In diesen Ordner können die Objekte platziert werden. Falls es in Projects/Projekten keine Unterordner gibt, dann können keine Objekte dort untergebracht werden.

Das wird mittels des Punktes im Kontextmenü Add Object/Objekt hinzufügen vorgenommen.

Danach wird angeboten, welchen Objekt aus den vorhandenen Objekten hierher untergebracht werden können.

Die Objekte sind in Typen eingegliedert. Das ist sehr komfortabel, falls die Datenbank groß ist.

Im Kontextmenü der Objekte gibt es keinen Punkt In das Projekt hineinbringen, deswegen werden die Objekte mit der Maus in das Projekt gezogen.

In Projects/Projekten werden keine Objekte, sondern derer Verknüpfungen platziert. Wenn man ein Objekt aus dem Projekt oder sogar das gesamte Projekt entfernt, gehen die Infos nicht verloren.

Die im Projekt platzierte Datei kann nicht umbenannt werden.

Löschen des Projektes

Die in den Projekt hinzugefügte Objekte kann man daraus löschen, indem man den Punkt des Kontextmenüs Remove <object name> from Projects/Löschen <Objektname> aus Projekten benutzt.

Man kann auch die in Projects/Projekten erstellten Ordner mit den gesamten Inhalten entfernen.


Verwendung von Tabs

Um Ihre Arbeit möglichst komfortabler zu gestalten, bietet der SQL Manager 2007 for MySQL einen speziellen Dienst von Registerkarten (Tabs). Verwendet werden Tabs, wenn man einen schnellen Zugriff auf eine bestimmte Gruppe der Explorer-Objekte vollziehen möchte. Dies kann ein bestimmter Server bzw. eine Datenbank oder eine Gruppe der Datenbank sein. Man kann z.B. einen Ordner mit Views auf eine gesonderte Registerkarte platzieren bzw. mehrere Registerkarten erstellen, wo jeweils nur eine Datenbank sein wird. Das Objekt auf einem gesonderten Tab kann man mit Hilfe des Punktes vom Kontextmenü New Tab from Here/Neues Tab von hier platziert werden. Dieser Punkt ist im Kontextmenü jedes Objektes dargestellt. Ist das Objekt ein Strukturknoten, dann ist diese Option verfügbar.

Hinweis: Wenn man die Option der Anzeige von Unterobjekten der Tabelle auf der Symbolleiste des Explorers ausschaltet, wird New Tab from Here/Neus Tab von hier nicht aktiv, da die Tabelle keinen Strukturknoten ist.

Ist diese Option eingeschaltet (Button View Mode | Show Table Subobjects)/

(Button Ansichtsmodus | Zeige Tabellen-Unterobjekte), so wird der Menüeintrag New Tab from Here/Neues Tab von hier aktiv.

Im Fenster des DB-Explorers können die Tabs auf zwei Weise dargestellt werden:

  • In Form von Icons auf der unteren Explorerleiste

  • In Form von Registerkarten.

Zum Übergang von einer zur anderen Form muss der Trenner nach oben bzw. unten gezogen werden.

Für diesen Zwecken werden auch Einträge Show more Buttons/Mehr Schaltflächen anzeigen und Show Fewer Buttons/Weniger Schaltflächen anzeigen des Popupmenüs verwendet.

Das Popupmenü erscheint beim Anklicken des Pfeiles Configure buttons/Schaltflächen einstellen [image] .

Zum Umschalten zwischen den Tabs ist der Mausklick auf ein Icon bzw. ein Tab genug.

Für diesen Zweck werden folgende Tastenkürzel verwendet:

  • Ctrl+Shift+N - Übergang zum nächsten Tab,
  • Ctrl+Shift+P - Übergang zum vorherigen Tab.

Umbenennung der Registerkarten

Wollen Sie eine Registerkarte umbenennen, dann muss man zu ihr übergehen und aus dem Kontextmenü des DB-Explorers den Eintrag Rename Current Tab/Aktuelles Tab umbenennen auswählen.

Löschen der Registerkarten

Zum Löschen einer Registerkarte muss man zu ihr übergehen und aus dem Kontextmenü des DB-Explorers den Eintrag Delete Current Tab/Aktuelles Tab löschen auswählen.

Fensterliste

Zum Anzeigen der Liste der geöffneten Fenster und Hintergrundprozessen ist die Registerkarte des DB-Explorers Windows List vorhanden. Diese Registerkarte kann nicht gelöscht werden.


Auswählen mehrerer Objekte

Ab und zu muss man eine große Menge von Objekten löschen, kopieren oder übertragen. Es ist nicht komfortabel, für jedes Objekt eine jeweilige Aktion vorzunehmen. Für diese Fälle ist ein gleichzeitiges Auswählen mehrerer Objekte vorgesehen. Um mehrere Objekte auszuwählen, muss man die mit dem linken Mausklick auswählen, indem man auf den Button Ctrl gedrückt hällt.

Die auf solche Weise ausgewählten Objekte kann man:

  • bearbeiten - Edit/Bearbeiten <n> Ausgewählte Objekte (n - Menge der ausgewählten Objekte),
  • löschen - Drop Database Objects/Ausgewählte Objekte löschen,
  • in Projekte platzieren. Für diese Aktion ist keinen Menüeintrag vorhanden, deswegen werden die Objekte mit der Maus in das Projekt gezogen.

Bemerkung: Wenn es in Projekte keinen Unterordner gibt, dann können die Objekte dorthin nicht verschoben werden.


Zuletzt verwendete Objekte

Den leichten Zugriff auf die zuletzt verwendeten Objekte ermöglicht die Schaltfläche Recent Objects/ auf der Symbolleiste des Explorers. Beim Anklicken dieser Schaltfläche wird eine Liste der während einer Sitzung geöffneten Objekte erscheinen. Beim Schließen des SQL Manager 2007 for MySQL wird die Liste geleert.

Die Anzahl der Elementen in dieser Liste kann man mit Hilfe Options | Environment Options | Tools| DB Explorer | Recent objects count/Optionen | Umgebungsoptionen | Tools| DB Explorer | Anzahl letzter Objekte ändern.


Objektsuche

SQL Manager 2007 for MySQL hilft im DB-Explorer ein Objekt nach der Bezeichnung zu suchen. Diese Option wird eingesetzt, wenn im Explorer eine große Menge von Objekten dargestellt wird und ein bestimmtes Objekt schwierig zu finden ist.

Mittels des Kontexmenüpunktes Find Item/Element finden bzw. der Tastenkombination Ctrl + F

wird ein Standardsuchfenster, in dem das Suchwort eingegeben wird, aufgerufen.


SQL-Assistent

In diesem Fenster werden ausführliche Infos über ein in der DB-Explorer ausgewähltes Objekt angezeigt.

Wurde im Explorer eine Tabelle ausgewählt, dann werden im SQL Assistant/SQL-Assistenten alle Felder dieser Tabelle erscheinen.

Wenn ein Server ausgewählt wurde, dann werden alle Datenabanken, die zu diesem Server gehören, sichtbar usw.

Wenn eine Datenbank im Explorer ausgewählt wurde, dann werden im SQL Assistant/SQL-Assistenten die Gruppen von Objekten dieser Datenbank mit der Eingabe der Anzahl der Objekte in jeder Gruppe erscheinen.

Im SQL Assistant/SQL-Assistenten kann man die Objekte zur Bearbeitung öffnen, ähnlich wie im Explorer, d.h. durch Doppelklick auf das gewünschte Objekt.

Für die Tabellen und Views lässt sich der SQL Assistant/SQL-Assistent einstellen. Man kann bestimmen, was im Assistant/SQL-Assistenten angezeigt wird, wenn im Explorer eine Tabelle ausgewählt wurde:

  • Tabellenfelder- Show Fields/Felder anzeigen,
  • Fremdschlüssel - Show foreign Keys/Fremdschlüssel anzeigen,
  • Indizes - Show Indices/Indizes anzeigen,
  • Triggers - Show Triggers/Trigerrs anzeigen,
  • DDL - Show DDL/DDL anzeigen,
  • Beschreibung - Show Description/Beschreibung anzeigen.

Falls eine Ansicht (View) ausgewählt ist:

  • Felder - Show Fields/Felder anzeigen,
  • Indizes - Show Indices/Indizes anzeigen,
  • Triggers - Show Triggers/Trigerrs anzeigen,
  • DDL - Show DDL/DDL anzeigen,
  • Beschreibung- Show Description/Beschreibung anzeigen.

Die Ansicht wird mit Hilfe der Schaltfläche im Ansichtmodus auf der Symbolleiste des Exploreres eingestellt.

Wählt man den Punkt Tables' Details/Tabellendetails aus, kann im geöffneten Menü angegeben werden, was im SQL-Assistenten angezeigt wird.

Oder man wählt im Kontextmenü den SQL Assistant/SQL-Assistenten und den Punkt Tables' Details/Tabellendetails aus.


Einstellung des DB-Explorers

Symbolleiste des DB-Explorers

Das ist ein Werkzeugsatz über dem Fenster des DB-Explorers. Auf dieser Leiste sind die Schaltflächen der Datenbankverwaltung und Explorereinstellung zu finden.

Standardmäßig werden auf der Symbolleiste folgende Schaltflächen platziert:

  • Create/Erstellen - Objekt erstellen,
  • Refresh Database/Datenbank erneuern - Datenbank erneuern,
  • Connect to Database/Datenbank verbinden - zur Datenbank verbinden,
  • Disconnect from Database/Datenbank trennen - Datenbank trennen,
  • Properties/Eigenschaften - Eigenschaften des ausgewählten Objektes öffnen,
  • Ansichtmodus - Einstellung des Explorers,
  • Resent/Letzte - Liste der zuletzt verwendeten Objekte,
  • Quick Jump To Database/Springe zur Datenbank - Schneller Sprung zur Datenbank

Alle Befehler, außer View Mode/Ansichtsmodus sind zum Arbeiten mit den Datenbanken bestimmt. View Mode/Ansichtsmodus ist für die Einstellung des Explorers und SQL Assistant/SQL-Assistenten zuständig.

Suchleiste

Im Feld Search wird die findende Zeichenkombination eingegeben.

Mithilfe der Schaltflächen [image] kann der Suchprozess verwaltet werden.

Die Symbolleiste kann man nach eigenen Wünschen einstellen, indem man die Funktion Add or Remove Buttons/Schaltflächenhinzufügen oder entfernen verwendet. Diese Funktion wird beim Anklicken der Schaltfläche More Buttons/Mehr Schaltflächen [image] in der rechten Ecke der Leiste geöffnet.

View Mode/Ansichtsmodus hilft:

  • Unterobjekte im DB-Explorer anzeigen- Show Table Subobjects/Zeige Tabellen-Unterobjekte,
  • Hosts anzeigen Show Hosts/Hosts anzeigen,
  • Datenbanken nach den Namen sortieren (standardmäßig sind die Datenbanken innerhalb des Servers nach der Verbindungszeit sortiert) - Sort by Aliases/Nach Alias ordnen,
  • Nicht angeschlossene Datenbanken verstecken Hide Disconnected Databases/Getrennte Datenbanken ausblenden,
  • Tables' Details/Tabellendetails im SQL Assistant/SQL-Assistenten einstellen,

Verwenden Sie Options | Environment Options... | DB Explorer / Optionen | Umgebungsoptionzen... | DB-Explorer für den Zugang zu den zusätzlichen Einstellungen des DB-Explorers.


Verwalten von Datenbanken

SQL Manager 2007 for MySQL bietet dem Anwender alle benötigten Werkzeuge zum Erstellen und Verwalten von Datenbanken.

Mit einer Datenbank im SQL Manager 2007 for MySQL kann nur gearbeitet werden, wenn diese vorher registriert wurde.

Erstellen von Datenbanken

Zur Vereinfachung der Prozedur zum Erstellen von Datenbanken gibt es im SQL Manager 2007 for MySQL ein spezielles Werkzeug - Assistent zum Erstellen von Datenbanken Assistent zum Erstellen von Datenbanken. Mit Hilfe des Assistenten kann schrittweise eine Datenbank erstellt werden.

Zum Erstellen einer Datenbank sind folgende Aktionen auszuführen:

  • den Punkt Datenbank| Datenbank erstellen des Programmhauptmenüs auswählen,
  • Datenbanknamen, Servernamen, Autorisierungstyp eingeben,
  • Option Registrierung nach dem Erstellen für den Aufruf des Assistenten zur Registrierung von Datenbank aktivieren,
  • Ergebniss in Form vom SQL-Skript betrachten und korrigieren.

Datenbankregistrierung

Zum Einsatz des SQL Manager 2007 for MySQL mit einer schon bestehenden Datenbank muss diese registriert werden. Hierfür gibt es ein spezielles Werkzeug Assistent zur Datenbankregistrierung. Zum Starten des Assistenten wird der Punkt Datenbank | Datenbank registrieren des Programmhauptmenüs ausgewählt.

Mit Hilfe dieses Werkzeuges kann man einen Server, eine Datenbank auf diesem Server auswählen und für diese die Verbindungs- und Autorisierungsparameter und weitere Optionen der Registrierung eingeben.

Zur Registrierung mehrerer Datenbanken, die sich auf einem Server befinden, muss man im Schritt der Einstellung der Serversparameter die Fuktion Einzelne Datenbank registrieren ausschalten. Im nächsten Schritt kann man dann mehrere Datenbanken für die Registrierung auswählen und diese alle gleichzeitig registrieren.

Aufhebung der Datenbankregistrierung

Wird keine Datenbank verwendet, dann kann die Funktion Datenbankregistrierung aufheben eingesetzt werden. Nicht registrierte Datenbanken werden im SQL Manager 2007 for MySQL nicht angezeigt.

Zur Registrierungsaufhebung müssen folgende Aktionen ausgeführt werden:

  • eine Datenbank, deren Registrierung aufgehoben werden soll, auswählen

(Klicken auf diese Datenbank im DB-Explorer),

  • den Punkt Datenbank | Datenbankregistrierung aufheben im Hauptmenü des Programms auswählen,
  • Registrierungsaufhebung in dem erscheinenden Fenster bestätigen.

Löschen von Datenbanken

Beim Löschen wird die gesamte Datenbank vom Server entfernt. In dem Fall kann man die Datenbank lediglich aus den vom Anwender während der Arbeit erstellten Sicherungskopien wiederherstellen.

Um eine Datenbank zu löschen, muss man:

  • eine Datenbank, die entfernt werden soll, auswählen (Klicken auf diese im DB-Explorer),
  • den Punkt Datenbank | Datenbank löschen des Programmhauptmenüs auswählen (im Kontextmenü ist dieser Punkt nicht vorhanden),
  • Löschen von Datenbank in dem erscheinenden Fenster bestätigen.

Man kann sowohl die angeschlossenen, als auch nicht angeschlossenen Datenbanken löschen. Falls es keine Verbindung zum Server gibt, dann gelingt es nicht, eine Datenbank zu löschen.

Verbindung zur Datenbank

Den Befehl Datenbank verbinden kann man finden:

  • im Hauptmenü des Programms - Datenbank | Datenbank verbinden,
  • im Kontextmenü des Explorers,
  • im Kontextmenü der Datenbank.

Zur Datenbankverbindung kann man auch die Tastenkombination Ctrl+Shift+C bzw. den Doppelklick auf den Namen der gewünschten Datenbank im Explorer verwenden.

Datenbanktrennung

Ist das Arbeiten mit einer Datenbank beendet, dann kann man diese trennen.

Der Befehl Datenbank trennen ist überall vorhanden, wo es Datenbank verbinden gibt. Die Datenbanktrennung ist auch mittels der Tastenkombination Ctrl+Shift+D möglich.


Finden von Optionen

Mithilfe dieses Werkzeuges können die Programmoptionen nach deren Bezeichnungen gefunden werden.

Die Suche wird für jedes Dialogfenster von Einstellungen, in dem die Registerkarte Find Option vorhanden ist, ausgeführt. Die Suche wird ausschließlich aus den Optionen des jeweilgen Dialogfensters ausgeführt.

Die Kombination von Zeichen, die in der Bezeichnung der Optionen vorhanden sind, muss ins Feld Option eingegeben werden. Alle Optionen mit der zu suchenden Zeichenkombination werden aufgelistet.

Im Feld Available Options | Verfügbare Optionen werden die Bezeichnungen der verfügbaren Optionen angezeigt. Im Feld Option Kind | Optionsart wird der Abschnitt mit der jeweilgen Funktion angezeigt.

Die Registerkarte, auf der sich die zu findende Option befindet, ist im Feld Category | Kategorie zu sehen. Die Gruppe von Verwaltungselementen, zu denen sich die zu findende Optionen gehört, wird in der Spalte Group| Gruppe angezeigt.

Um auf die suchende Optionen zugreifen zu können, muss man die erforderliche Option aus der Liste auswählen und die Schaltfläche Show Option | Zeige Option anklicken bzw. mit der Maus auf eine benötigte Option in der allgemeinen Liste doppelklicken.

Danach wird man zur Registerkarte mit dieser Option gebracht, wo diese Option mit dem Symbol [image] markiert ist.


Assistent zum Erstellen von Datenbanken

Der Assistent zum Erstellen von Datenbanken Create Database Wizard | Erzeuge Datenbank erzeugt automatisch ein SQL-Skript zum Erstellen einer neuen Datenbank und führt dieses auf MySQL aus.

Der Assistent kann man über den Befehl Create Database/Datenbank erstellen aufrufen. Dieser Befehl ist zu finden:

  • im Programmhauptmenü - Datenbank | Datenbank erstellen,
  • auf der Symbolleiste des SQL Manager 2007 for MySQL,
  • auf der Symbolleiste des Explorers,
  • auf der Desktop-Leiste.

Verwenden Sie zum Erstellen einer Datenbank den Befehl Datenbank erstellen, dann wird das Erstellen nur unter Verwendung des Assistenen verlaufen.

Wollen Sie keinen Assistenten einsetzen bzw. haben Sie ein SQL-Skript, dann können Sie den SQL Skript Editor benutzen.

Der Assistent besteht aus folgenden Schritten:

  • Angabe des Namen für eine neue Datenbank - Specify the name for a new database,
  • Bestimmen der Verbindugsparameter für eine neue Datenbank - Set connection properties and collation for a new database,
  • Definieren der Datenbankdateien für eine neue Datenbank Define Database files for a new database.
  • Betrachten des Ergebnisses der SQL-Anweisung - Result SQL statement.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Eingabe des Datenbanknamens

Im Database name wird der Datenbankname eingegeben. Wenn die Datenbank mit dem gleichen Namen auf dem Server schon besteht, dann erscheint eine Warnung.

Soll die Datenbank automatisch nach dem Erstellen registriert werden, dann muss das Häkchen Register after creating/Registrieren nach dem Erstellen aktiviert sein. In diesem Fall wird nach dem Erstellen einer Datenbank ein Fenster Datenbank Registierungsinfo geöffnet.

Nächster Schritt


Einstellung der Verbindungsparameter

Im zweiten Schritt müssen die Server-Verbindungsparameter eingestellt werden.

In der Dropdownliste Host name/Hostname wählt man den Server (Host), zu dem man sich verbinden möchte, aus. In diese Liste werden die Namen von schon registrierten Servern eingetragen.

Im Feld Port ist der Verbindungsport einzugeben. Der Benutzername und das Kennwort sind in den Feldern User name/Benutzername und Password/Passwort einzugeben.

Den Zeichensatz kann man aus der Dropdownliste Character set und aus der Dropdownliste Collation die Vergleichsregeln der Zeichendaten auswählen. Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode usw. vor.

Ist das Häkchen Use server settings/Benutze Servereinstellungen aktiviert, dann werden die Servereinstellungen Character set/Zeichensatz und Collation/Sortierung, die in der Datenbank Registrierungsinfo angegeben werden, verwendet.

Ist das Häkchen Use tunneling/Benutze Tunneling aktiviert, kann man einen der beiden Tunneling verwenden.

  • SSH-Tunneling - SSH-Tunneling,
  • HTTP-Tunneling - HTTP-Tunneling.

SSH-Tunneling ist für den Datenumtausch mit dem Server über einen verschlüsselten Kanal vorgesehen.

Für den Zugriff auf den MySQL-Server über das HTTP-Protokoll wird HTTP-Tunneling ausgewählt.

Nächster Schritt


Tunnel-Parameter

Wenn im zweiten Schritt eingegeben wurde, dass das Tunneling verwendet wurde, dann muss man im dritten Schritt die Tunnelparameter setzen.

Das SSH-Tunneling wird zum Datenumtausch mit dem Server über einen verschlüsselten Kanal verwendet.

Wenn SSH-Tunneling ausgewählt wurde, dann müssen folgende Parameter eingegeben werden:

  • SSH host name - SSH-Servername (Name (ip-Adresse) des MYSQL-Servers muss bei Verwendung von SSH-Tunneling relativ zur Maschine, auf der der SSH-Server installiert ist, eingegeben werden. Der Einsatz von localhost impliziert, dass der SSH-Server und MySQL auf einem Rechner zum Laufen gebracht wurden. Der Name des SSH-Servers wird relativ zum Client-Rechner, auf dem SQL Manager 2007 for MySQL gestartet wurde, eingegeben.),

  • SSH port - Port,
  • SSH user name - Benutzername,
  • SSH password - Kennwort.

Ist das Häkchen Use private Key for authentication aktiviert, dann wird zusätzlich eine Schlüsseldatei, die man im Feld SSH key file eingeben kann, verwendet werden. Braucht man zur Verwendung dieser Datei ein Kennwort einzugeben, dann kann man dies im erscheinenden Feld tun.

Wurde HTTP-Tunneln ausgewählt, muss die Serveradresse im Feld URL eingegeben werden.

Nächster Schritt


Betrachten des Ergebnisses

Im letzten Schritt bietet der Assistent eine Möglichkeit an, sich ein automatisch erstelltes SQL-Skript anzusehen. Bei Bedarf kann dies bearbeitet werden.

Wurde im ersten Schritt das Häkchen Register after creating aktiviert, dann wird nach dem Anklicken der Schaltfläche Finish das Fenster Database Registration Info geöffnet. In diesem Fenster kann man die Registrierungsinfo einer Datenbank angeben.


Assistent zur Datenbankregistrierung

Der Assistent zur Datenbankregistrierung ermöglicht, eine bereits bestehende Datenbank im SQL Manager 2007 for MySQL zu registrieren.

Der Assistent wird mit dem Befehl Register Database |Datenbank registrieren aufgerufen. Der Befehl ist zu finden:

  • im Haupmenü des Programms Database | Register Database,
  • auf der Symbolleiste SQL Manager 2007 for MySQL,
  • im DB-Kontextmenü,
  • beziehungsweise ist er mit Hilfe der Tastenkombination Shift+Alt+R abrufbar.

Der Assistent besteht aus zwei Schritten:

  • Einstellung der Verbindugsparameter,
  • Einstellung der Registrierungsparameter.

Zusätzlich

Assistent zur Datenbankerstellung

Assistent zur Hostregistrierung


Einstellung der Verbindungsparameter

In diesem Schritt werden die Verbindugsparameter zum Server eingestellt.

Aus der Dropdownliste Host name wird der Server (Host), zu dem man sich verbinden möchte, ausgewählt. In diese Liste werden die Namen von bereits registrierten Servern eingetragen.

Im Feld Port wird der Verbindungsport eingegeben. Der Benutzername und das Kennwort sind in den Feldern User name und Password einzugeben.

Der Zeichensatz wird aus der Dropdownliste Character set ausgewählt und aus der Dropdownliste Collation die Vergleichsregeln der Zeichendaten aus. Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und in anderen Fortmaten vor.

Ist das Häkchen Use server settings aktiviert, dann werden die Servereinstellungen Character set und Collation, die in der Datenbank Registrierungsinfo angegeben werden, verwendet.

Ist das Häkchen Use tunneling/Benutze Tunneling aktiviert, so kann man einen der beiden Tunneling verwenden.

  • SSH-Tunneling - SSH-Tunneling,
  • HTTP-Tunneling - HTTP-Tunneling.

SSH-Tunneling wird zum Datenaustausch mit dem Server über einen verschlüsselten Kanal eingesetzt.

Für den Zugriff auf den MySQL-Server über das HTTP-Protokoll wird HTTP-Tunneling ausgewählt.

Tunneling-Paramter

Nächster Schritt


Einstellung der Registrierungsparameter

Auf dieser Registerkarte werden die allgemeinen Parameter von Datenbanken eingestellt:

Diese Optionen ist auch auf dem Tab Optionen in Datenbank-Registrierungsinfo zu finden.

Aus der Dropdownliste Database name kann die benötigte Datenbank ausgewählt werden. Das Alias, unter dem die Datenbank im Explorer angezeigt werden wird, kann man im Feld Database alias angeben.

Client charset

Werden die Zeilendaten, welche die Sonderzeichen enthalten, beim Betrachten im SQL Manager nicht korrekt angezeigt, dann muss manuell aus der Dropdownliste Client charset der Zeichensatz, in dem die Daten auf dem Server abgelagert werden, ausgewählt sein.

Für die Server der Version 4.1 und höher reicht es utf8 anzugeben, und alle Daten werden richtig dargestellt. Die Tabellendaten werden nur dann korrekt angezeigt, wenn der im Feld der Daten abgelagerte Zeichensatz mit dem Zeichensatz des Tabellenfeldes übereinstimmt. D.h. falls in der Tabelle Folgendes zu sehen ist

CREATE TABLE table1 (

str varchar(20) default NULL

) ENGINE=MyISAM DEFAULT CHARSET=latin1;

Werden die Zeilendaten im Zeichensatz greek abgelegt, dann werden solche Daten nicht korrekt angezeigt.

Darüber hinaus können diese Daten in allen anderen Programmen nicht richtig sortiert werden und das Funktionsergebnis einiger Zeilenfunktion wie z.B. UPPER(), LOWER() wird nicht korrekt sein.

Um mit diesen Daten arbeiten zu können, wenn der Zeichensatz von in der Datenbank abgelegten Daten mit dem standardmäßigen Zeichensatz Ihres BS Windows übereinstimmt, kann man den Wert “Windows charset” in der Liste Client charset auswählen (In diesem Fall wird der SQL Manager 2007 ähnlich der früheren Version 2005 funktionieren). Es wird empfohlen, die Zeichensätze von Daten und Tabellenfeldern in Übereinstimmung zu bringen.

Hierfür können Sie die nachfolgenden Befehle einsetzen:

ALTER TABLE table1 MODIFY COLUMN str BINARY(20);

ALTER TABLE table1 MODIFY COLUMN str VARCHAR(20) CHARACTER SET greek;

In diesem Fall müssen evtl. die entspechenden Änderungen in andere Programme, die mit der Datenbank laufen, eintragen werden.

Font charset

Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und in anderen Fortmaten vor.

Auf dem Tab General können die nachfolgenden Parameter eingegeben werden:

  • Refresh objects on connection - Objekte bei der Verbindung erneuern
  • Login prompt before connection - Falls das Kennwort nicht gespeichert werden soll, muss dieses Häkchen aktiviert werden. Jedesmal bei Verbindung wird der SQL Manager anbieten, den Benutzernamen und Kennwort erneuert einzugeben.
  • Use compression protocol - Komprimierungsprotokoll verwenden.
  • Keep connection alive - Server vor jeder Abfrageausführung befragen
  • Use SSL protocol - Datenaustausch verläuft unter Verwendung des entfernten MySQL-Servers mit Hilfe des verschlüsselten Kanals.
  • Interactive mode - Unter Verwendung dieses Häkchens kann der Variablewert interactive_timeout aus der Datei my.cnf statt der Variable wait_timeout für die Angabe der Beschränkung der Verbindugszeit verwendet werden.
  • Quote identifiers - Ist das Häkchen aktiviert, dann werden alle Bezeichner mit öffnenden Anführungszeichen ('`') markiert. Um das SQL-Skript, das sich aus dem Extrahieren der Datenbank ergibt und mit früheren MySQL-Version kompatibel ist, zu erstellen, sollte diese Funktion nicht eingesetzt werden. Hinweis: diese Funktion kann nur mit den Servern, die Alias in Anführungszeichen benutzen, verwendet werden.
  • Autoconnect on startup - beim Starten des Programms SQL Manager 2007 for MySQL wird die Verbindung mit dieser Datenbank automatisch aufgebaut werden.
  • Disable transactions - Durch Aktivierung dieses Häkchens wird angegeben, dass die Transaktionen deaktiviert und die eingetragenen Änderungen automatisch verwendet werden.

Auf dem Tab Logs werden die Einstellungen der Protokolldateien angegeben.

Diese Optionen sind auch unter dem Reiter Logs in Datenbank-Registrierungsinfo zu finden.

Sollen die Protokolländerungen, die mit Metadaten vorgenommen wurden, verfolgt werden, dann muss das Häkchen Enable log of metadata changes aktiviert sein und die Angabe gemacht werden, in welcher Datei die Änderung gespeichert werden müssen.

Write only successfully executed SQL statements to log - Bei Aktivierung dieses Häkchens werden nur die Infos ins Protokoll eingetragen, die erfolgreich ausgeführte Abfragen aufweisen.

Im Feld Log file wird angegeben, in welcher Datei diese Statistik gespeichert werden soll.

Soll man die Statistik über die Ausführung der SQL-Skripten führen, dann muss die Funktion Enable log of SQL Editor queries aktiviert werden. Im Feld Log file wird angegeben, in welcher Datei diese Statistik gespeichert werden muss.


Assistent zur Hostregistrierung

Der Assistent zur Hostregistrierung - Register Host Wizard - ermöglicht mehrere Datenbanken, die zu einem Host (Server) gehören, zu registrieren.

Der Assistent wird mittels des Befehls Register Host... aufgerufen. Dieser Befehl ist vorhanden:

  • im Hauptmenü des Programms Database | Register Host...,
  • auf der Symbolleiste von SQL Manager 2007 for MySQL,
  • im DB-Kontextmenü
  • durch Tastenkombination Shift+Ctrl+R.

Beim Aufrufen dieses Assistenten wird Assistent zur Datenbankregistrierung gestartet. Der einzige Unterschied besteht darin, dass beim Starten von Register Host... das Häkchen Register a single database nicht aktiv ist.


Datenbank-Registrierungsinfo

Wurde bei der Erstellung bzw. Registrierung der Datenbank ein Fehler zugelassen, dann kann dieser mit Hilfe des Befehls Database Registration Info/Datenbank Registrierungsinfo behoben werden.

Der DB-Explorer lässt die Registrierungsinfo während des Arbeitsprozesses bearbeiten.

Hierfür wird der Punkt des Kontextmenüs Database Registration Info/Datenbank Registrierungsinfo (für angeschlossene Datenbanken) verwendet.

Alle Infos sind auf der nachfolgenden Regiesterkarten verfügbar:

  • Connection - Bearbeiten von Verbindugseinstellungen einer Datenbank
  • Options - Eingabe der allgemeinen Einstellungen
  • Display options - Bildschirmoptionen
  • Directories - Auswählen von verwendenten Verzeichnissen
  • Logs - Protokolle
  • SSH tunneling - Parametereinstellung vom SSH-Tunneling
  • HTTP tunneling - Parametereinstellung vom HTTP-Tunneling
  • Data options - Einstellen von Datendarstellung
  • Finden von Optionen

Mit Hilfe dieser Schaltfläche Test Connect kann überprüft werden, ob die Verbindung zur Datenbank mit den vorgegebenen Einstellungen hergestellt werden kann.

Die Schaltfläche Copy Alias From hilft alle Einstellungen aus einer anderen Datenbank zu kopieren. Diese Datenbank kann man aus der Dropdownliste, die nach dem Anklicken der Schaltfläche [image] geöffnet wird, auswählen.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verbindungseinstellungen

Unter diesem Tab kann man die Einstellungen einer Datenbank zur Serververbindung abändern.

Aus der Dropdownliste Host name wird der Server (Host) ausgewählt. In diese Liste werden die Namen von bereits registrierten Servern eingetragen. Im Feld Port wird der Verbindungsport eingetragen. Der Benutzername und das Kennwort sind in den Feldern User name und Passwordeinzugeben. Aus der Dropdownliste Database name wird die benötigte Datenbank ausgewählt. Das Alias, unter dem die Datenbank im Explorer angezeigt werden soll, kann man im Feld Database alias angeben.

Client charset

Werden Ihre Zeilendaten, die Sonderzeichen enthalten, beim Betrachten im SQL Manager nicht richtig angezeigt, dann muss man manuell aus der Dropdownliste Client charset den Zeichensatz, in dem die Daten auf dem Server abgelagert werden, auswähen.

Für die Server der Version 4.1 und höher reicht es utf8 anzugeben, und alle Daten werden richtig dargestellt. Zu beachten ist, dass die Tabellendaten nur dann korrekt angezeigt werden, wenn der im Feld der Daten abgelegte Zeichensatz mit dem Zeichensatz des Tabellenfeldes übereinstimmt. D.h. falls in der Tabelle Folgendes zu sehen ist:

CREATE TABLE table1 (

str varchar(20) default NULL

) ENGINE=MyISAM DEFAULT CHARSET=latin1;

werden die Zeilendaten im Zeichensatz greek abgelagert, dann werden solche Daten nicht korrekt angezeigt.

Darüber hinaus können diese Daten in allen anderen Programmen nicht richtig sortiert werden und das Funktionsergebnis einiger Zeilenfunktion wie z.B. UPPER(), LOWER() wird nicht korrekt sein.

Um mit diesen Daten arbeiten zu können, wenn der Zeichensatz von in der Datenbank abgelagerten Daten mit dem standardmäßigen Zeichensatz des BS Windows übereinstimmt, kann der Wert “Windows charset” in der Liste Client charset ausgewählt werden (in diesem Fall wird der SQL Manager 2007 ähnlich der früheren Version 2005

funktionieren). Es wird empfohlen, die Zeichensätze von Daten und Tabellenfeldern gleich zu wählen.

Hierfür können Sie die nachfolgenden Befehle einsetzen:

ALTER TABLE table1 MODIFY COLUMN str BINARY(20);

ALTER TABLE table1 MODIFY COLUMN str VARCHAR(20) CHARACTER SET greek;

In diesem Fall müssen die entspechenden Änderungen in andere Programme, die mit der Datenbank laufen, eintragen werden.

Font charset

Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und in anderen Fortmaten vor.


Allgemeine Optionen

Unter diesem Tab werden die allgemeinen Optionen eingestellt.

  • Login prompt before connection - Soll das Kennwort nicht gespeichert werden, dann muss dieses Häkchen aktiviert sein. Jedesmal wird der SQL Manager bei Verbindung anbieten, den Benutzernamen und Kennwort erneut einzugeben.
  • Use compression protocol - Komprimierungsprotokoll verwenden.
  • Keep connection alive -Server vor jeder Abfrageausführung befragen
  • Interactive mode - Unter Verwendung dieses Häkchens kann der Variablewert interactive_timeout aus der Datei my.cnf statt der Variable wait_timeout für die Angabe der Beschränkung der Verbindugszeit verwendet werden.
  • Quote identifiers - Ist dieses Häkchen aktiviert, dann werden alle Bezeichner mit öffnenden Anführungszeichen ('`') markiert. Um das SQL-Skript zu erstellen, das sich aus dem Extrahieren der Datenbank ergibt und mit früheren MySQL-Version kompatibel ist, muss diese Funktion nicht aktiviert werden. Hinweis: diese Funktion kann nur mit den Servern, die Alias in Anführungszeichen benutzen, verwendet werden.
  • Connect automatically at startup - beim Starten des SQL Manager 2007 for MySQL wird die Verbindung mit dieser Datenbank automatisch aufgebaut.
  • Use SSL protocol - Datenaustausch verläuft unter Verwendung des entfernten MySQL-Servers mit Hilfe des verschlüsselten Kanals.
  • Disable transactions - Durch Aktivierung des Häkchens wird angegeben, dass die Transaktionen deaktiviert und die eingetragenen Änderungen automatisch verwendet werden.
  • Refresh objects on connection - Objekte bei der Verbindung erneuern.
  • Automatically reconnect when connection is lost - Erneut automatisch verbinden, wenn die Verbindung verloren geht.


Ansichtseinstellungen

Hier sind die Ansichtseinstellungen von Datenbankobjekten.

Wenn man das Häkchen aktiviert, dann wird dieses Objekttyp im DB-Explorer angezeigt.

Standardmäßig werden alle Objekte dargestellt.


Standardverzeichnisse

Unter diesem Tab werden die Verzeichnisse zum Speichern der Fremddaten angegeben.

Default directory for Extract Metadata - in diesem Ordner werden standardmäßig die mit Hilfe des Assistenten zum Extrahieren von Datenbank extrahierten Dateien gespeichert.

Default directory for Export Data - Ordner zum Exportieren von Daten mit Hilfe des Assistenten zum Exportieren von Daten.

Default directory for Import Data ist ein Verzeichnis, das in Export (Import\HTML Report) Assistentenprogramm standardmäßig hinzugefügt wird.

Default directory for HTML Report - in dieses Verzeichnis werden die mit Hilfe des Assistenten zum Erstellen von HTML-Berichten erstellten Berichten extrahiert.

Default directory for Reports - in diesem Ordner werden die von Benutzern erstellten Berichte gespeichert. Vorausgesetzt, dass der Anwender bei der Erstellung der Berichten im Assistenten zum Erstellen von Berichten (Create Report Wizard) markiert, dass man diesen Bericht in der Datenbankdatei speichern muss. Standardmäßig erstellt SQL Manager 2007 for MySQL diesen Ordner in "Meine Dokumente" automatisch beim ersten Speichern des Berichtes.

Default directory for Scripts ist Standardverzeichnis für Skripts, die im SQL-Editor geöffnet oder gespeichert werden


Protokolloptionen

Sollen die Protokolländerungen, die mit Metadaten vorgenommen wurden, verfolgt werden, dann muss das Häkchen Enable log of metadata changes aktiviert sein und die Angabe gemacht werden, in welcher Datei die Änderung gespeichert werden muss.

Write only successfully executed SQL statements to log - Bei Aktivierung dieses Häkchens werden nur die Infos ins Protokoll eingetragen, die erfolgreich ausgeführte Abfragen aufweisen.

Im Feld Log file wird angegeben, in welcher Datei diese Statistik gespeichert werden soll.

Soll die Statistik über die Ausführung der SQL-Skripten geführt werden, dann muss die Funktion Enable log of SQL Editor queries aktiviert werden. Im Feld Log file wird angegeben, in welcher Datei diese Statistik gespeichert werden muss.


Parameter vom SSH-Tunneling

Unter diesem Tab werden die Parameter von SSH-Tunneling angegeben.

Hinweis: Man kann sich nicht über SSH- und HTTP-Tunneling gleichzeitig verbinden. Wenn SSH-Tunneling ausgewählt wurde, dann ist das HTTP-Tunneling deaktiviert.

Bei Aktivierung des Häkchens Connecting through the security Shell (SSH) tunnel wird die Verbindung mit dem Server über einen verschlüsselten Kanal hergestellt.

  • SSH host name - SSH-Servername (Name (ip-Adresse) des MySQL-Servers muss bei Verwendung von SSH-Tunneling relativ zur Maschine, auf der der SSH-Server installiert ist, eingegeben werden. Der Einsatz von localhost impliziert, dass der SSH-Server und MySQL auf einem Rechner zum Laufen gebracht wurden. Der Name des SSH-Servers wird relativ zum Client-Rechner, auf dem SQL Manager 2007 for MySQL gestartet wurde, eingegeben.),
  • SSH port - Port,
  • SSH user name - Benutzername,
  • SSH password - Kennwort.

Wenn das Häkchen Use private Key for authentication aktiviert ist, dann wird zusätzlich eine Schlüsseldatei, die man im Feld SSH key file eingeben kann, verwendet werden. Muß zur Verwendung dieser Datei ein Kennwort eingegeben werden, kann man dies im erscheinenden Feld tun.


Parameter vom HTTP-Tunneling

Unter diesem Tab werden die Parameter von HTTP-Tunneling angegeben.

Hinweis: Man kann sich nicht über SSH- und HTTP-Tunneling gleichzeitig verbinden. Wenn HTTP-Tunneling ausgewählt wurde, dann ist das SSH-Tunneling deaktiviert.

Bei der Aktivierung des Häkchens Connecting through the HTTP tunnel wird die Verbindung mit dem Server über einen

HTTP-Zwischenserver hergestellt.

Um diese Verbindung installieren zu können, muß auf dem HTTP-Server das Skript EMSProxy.php geladen werden, das die Programmdistribution beinhaltet.

Die Serveradresse wird im Feld URL angegeben werden.


Einstellung der Datenoptionen

Unter diesem Tab werden die Parameter der Datendarstellung im Datenbetrachter angegeben.

Im Abschnitt Default limit options in table and view editors wird die Anzahl der Datensätze, die man in eine Tabelle der Datenansicht laden muss, angegeben

Select all records from a table - Alle Datensätze einer Tabelle auswählen

Im Feld Select only n records kann man die Anzahl der zu ladenden Datensätze angeben.

Im Abschnitt Advanced sind die erweiterten Eigenschaften einer Tabelle anzugeben.

  • Use shared connection for each data view within database - Gemeinsame Verbindung für alle Datenansichten in einer Datenbank verwenden
  • Perform data sorting on client in Data View - die Daten werden mittels SQL Manager 2007 for MySQL sortiert. Ist diese Option nicht aktiviert, werden die Daten auf dem MySQL Server mittels ORDER BY in der SQL-Abfrage angeordnet.
  • Perform data filtration on client in Data View - bei Aktivierung dieses Punktes erfolgt das Datenfiltern mittels SQL Manager 2007 for MySQL.

Wenn dieser nicht aktiviert ist, dann wird beim Betrachten von Tabellen- und Sichtdaten ein SQL-Filter verwendet. In diesem Fall wird das Filtern auf dem MySQL Server mittels der Bedingung WHERE in der SQL-Abfrage erfolgen.

  • Load all rows - Alle Zeilen laden. In diesem Fall werden in eine Tabelle alle Daten aus dem Datensatz geladen. Diese Option ermöglicht, bei der Aktualisierung nur die veränderten Zeilen aus dem Datensatz zu erhalten. Bei solchem Laden sind Sortieren, Filtern, Summieren usw. verfügbar.
  • Load visible rows - Sichtbare Zeilen laden. In eine Tabelle werden aus dem Datensatz nur eine bestimmte Anzahl der Datensätze geladen. Das Auto-Sortieren, Filtern, Summieren sind in diesem Modus nicht verfügbar. Die Menge der zu ladenden Zeilen wird im Feld Select only n records bestimmt.

Die Änderungen, die auf diesem Tab vorgenommen wurden, werden zu den geöffneten Datenansichten nicht angewendet.

Diese Einstellungen verändern die Dartstellungsart beim Auswählen von Default im Raster.

Siehe auch:

Raster

Daten


Datenbankparameter

Dieses Werkzeug wird zum Betrachten und zur Bearbeitung der Infos über eine aktive Datenbank und derer Objekte verwendet. Um das Fenster der Eigenschaften von Datenbank zu öffnen, wird der Punkt im DB-Kontextmenü Database Properties/Datenbankeigenschaften ausgewählt oder die Schaltfläche Object properties/Objekteigenschaften auf der Symbolleiste des DB-Explorers gedrückt.

Allgemeine Parameter

Anzahl der Objekte

DDL

Finden von Optionen

Siehe auch: Datenbank Registrierungsinfo


Allgemeine Parameter

Unter diesem Tab werden folgende Infos über eine Datenbank angezeigt:

  • Database name - In diesem Feld ist ein Datenbankname angegeben. Der Datenbankname kann nicht bearbeitet werden.
  • Serverversion ist im Punkt Server version angegeben,
  • Zeichensatz wird aus der Dropdownliste im Punkt Character set ausgewählt,
  • Aus der Dropdownliste Collation werden die Vergleichsregeln der Zeichendaten ausgewählt. Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und anderen Formaten vor.

Hinweis: Character set und Collation, die auf dieser Registerkarte angegeben sind, werden standardmäßig für die Tabellen verwendet werden, wenn man die bei der Erstellung der Tabelle zusätzlich nicht eingibt.


Anzahl der Objekte

Unter diesem Tab kann man sehen, wieviel Objekte verschiedener Typen eine ausgewählte Datenbank enthält. Im Feld Objects ist eine Liste der Objekttypen dargestellt. In der Spalte Count ist die Anzahl der Objekte zu sehen. Die Gesamtgröße, die die Objekte dieses oder anderes Typs auf der Platte belegen, wird in der Spalte Data Size angezeigt. Unten, im Feld Database Size, ist die gesamte Datenbankgröße angegeben.


DDL

Unter dieser Registerkarte kann die DDL einer ausgewählten Datenbank angesehen werden.


Verwalten von Datenbankobjekten

SQL Manager 2007 for MySQL bietet eine Reihe von benötigten Tools zum Arbeiten mit den Datenbankobjekten.

Hinweis: Bevor die Arbeit mit den Objekten begonnen wird, muss die Verbindung zur Datenbank aufgebaut werden.

Hauptoptionen mit den Objekten

Erstellen eines neuen Objektes

Das Erstellen eines Objektes erfolgt durch:

  • Punkt Database | New Object des Hauptmenüprogramms,
  • Kontextmenü eines DB-Objektes,
  • Kontextmenü von Datenbanken
  • Tastenkombination <Ctrl + N>

Kopieren

Zum Kopieren von Objekten ist ein spezieller Assistent vorhanden. Ein Objekt kann man sowohl in eine andere Datenbank, als auch mit bzw. ohne Daten kopieren. Zum Kopieren eines Objektes muss der Punkt Duplicate<Objekttyp><Objektname> im Kontextmenü eines Objektes ausgewählt werden. Soll das Objekt auf solche Weise kopiert werden, dann wird der Assistent zum Objektkopieren im dritten Schritt geöffnet. In den ersten zwei Schritten wird eine Datenbank und ein Objekt ausgewählt, und in diesem Fall ist es nicht nötig.

Bearbeiten eines Objektes

Zum Öffnen eines Datenbankobjektes ist ein Doppelklick im DB-Explorer nötig. Oder man kann den Punkt Edit<Objekttyp><Objektname> im Kontextmenü eines Objektes auswählen. Die Tastenkombination <Ctrl + О> kann dafür auch verwendet werden.

Umbenennung

Soll ein Objektname umbenannt werden, dann muss man:

  • Punkt des Kontexmenü eines Objektes Rename<Objekttyp><Objektname> auswählen,
  • <Ctrl + R> bzw. die Tastenkombination <Ctrl + R> benutzen.

Löschen eines Objektes

Zum Löschen eines Objektes muss man für das ausgewählte Objekt den Punkt eines Kontextmenüs Drop<Objektyp><Objektname> bzw. die Tastenkombination <Ctrl + Del> auswählen.


Neues Objekt

Mit Hilfe dieses Werkzeugs kann man einen Typ des zu erstellenden Objektes auswählen und das jeweilige Werkzeug zum Erstellen des Objektes laufen lassen.

Zum Erstellen eines neuen Objektes wird der Punkt Database | New Object... im Hauptmenü des Programms ausgewählt.

In dem erscheinenden Fenster wählt man eine Datenbank aus der Dropdownliste Database und einen Typ des zu erstellenden Objektes aus der Liste Select the type of object to create aus. In dieser Datenbank wird ein Objekt erstellt (in der Liste werden nur die verbundenen Datenbanken angezeigt).

Nachdem der Objekttyp ausgewählt wurde, muss man drauf doppelklicken und auf die Schaltfläche OK drücken. Danach wird ein Editor eines ausgewählten Objekt geöffnet.

Siehe auch Assistent zum Objektkopieren


Betrachten von Objektabhängigkeiten

In den Objekteditoren ermöglicht die Registerkarte Dependencies die Abhängigkeiten von Objekten zu betrachten.

Im linken Fensterteil sind die Objekte, auf die das bearbeitende Objekt verweist.

Im rechten sind die Objekte, die auf das im Editor geöffnete Objekt verweisen.

Im unteren Fenster kann DDL des ausgewählten Objektes betrachtet werden.

Jedes Objekt kann per Doppelklick im entsprechenden Editor geöffnet werden.


Assistent zum Objektkopieren

Zum Objektkopieren muss der Punkt Duplicate<Objekttyp><Objektname> im Kontextmenü des Objektes bzw. Database | Duplicate Object... im Hauptmenü des Programms ausgewählt werden.

Mittels einer dieser Aktionen wird der Punkt Assistenten zum Objektkopieren gestartet.

Dieser Assistent wird zum Erstellen eines neuen Datenbankobjektes mit den gleichen Eigenschaften ähnlich wie beim kopierenden Objekt verwendet. Zu beachten ist, dass die Objekte zusammen mit den Unterobjekten kopiert werden. Wenn man z.B. eine Tabelle kopiert, dann werden ihre gesamten Felder, Indizes, Fremdschlüssel, Triggers usw. kopiert.

Der Assistent besteht aus vier Schritten:

  • Auswählen einer Quelldatenbank
  • Auswählen eines Objektes
  • Auswählen einer Datenbank
  • Beschreibungsänderung

Siehe auch

  • neues Objekt

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen einer Quelldatenbank

Aus der Dropdownliste Source database wird eine Datenbank, die das Quellobjekt enthält, ausgewählt.

Nächster Schritt


Auswählen eines Objektes

Hiermit wird ein Objekt, das kopiert werden soll, ausgewählt.

Aus der Dropdownliste Object wählt man einen Objekttyp und aus der untenstehenden Liste ein Objekt aus.

Nächster Schritt


Auswählen einer Datenbank

In diesem Schritt muss man eine Datenbank, in die ein neues Objekt eingefügt und ein Name dieses Objektes angegeben werden soll, auswählen.

Aus der Dropdownliste Target database wählt man eine Datenbank aus.

Bei Aktivierung des Häkchens Copy data werden in ein neues Objekt alle Daten, die im kopierenden Objekt enthalten, kopiert.

Wenn das Häkchen nicht aktiviert ist, dann wird lediglich die Struktur des Objektes kopiert.

Bei Aktivierung des Häkchens Copy autoincrement fields wird auch angegeben, dass selbstinkrementierende Felder kopiert werden sollen.

Nächster Schritt


Beschreibungsänderung

Bei Bedarf wird das Skript zum Erstellen eines neuen Objektes im Fenster New object definition geändert.

Zum Erstellen eines Objektes wird die Schaltfläche Finish angeklickt.


Tabellen

Die Tabellen sind Objekte, die alle Daten in Relationsdatenbanken enthalten. Die Tabelle ist eine Sammlung von Spalten.

Die Daten werden in den Tabellen in Form von Zeilen und Spalten, ähnlich wie in einer Tabelle angeordnet. Jede Zeile stellt einen eindeutigen Datensatz und jede Spalte ein Datensatzfeld dar. Zum Beispiel kann eine Tabelle, die die Angaben über die Mitarbeiterinnen und Mitarbeiter enthält, eine Zeile für jede/jeden Mitarbeiterin/Mitarbeiter haben und die Spalten, die die Angaben über die Mitarbeiterinnen und Mitarbeiter anzeigen (zum Beispiel: eine Identifikationsnummer, einen Namen, eine Anschrift, einen Dienstgrad, eine Telefonnummer).

Jede Tabelle kann bis 1024 Spalten enthalten. Die Tabellen- und Spaltennamen müssen den Regeln für die Identifikator entsprechen; sie müssen eindeutig innerhalb einer Tabelle sein. Mit anderen Worten kann man gleiche Spaltennamen in unterschiedlichen Tabellen einer Datenbank verwenden.

Die Tabellen in MySQL haben die nachfolgenden Hauptbestandteile:

  • Spalten

Jede Tabelle stellt ein Attribut eines Objektes, die von der Tabelle modelliert wird, dar. In einer Infotabelle über die Details gibt es beispielweise Spalten für ihre ID, Farbe und Gewicht.

  • Zeilen

Jede Zeile stellt einen separaten Bezug des von einer Tabelle modellierten Objektes dar. Zum Beispiel gibt es in einer Infotabelle unbedingt eine Zeile für jedes Detail, das vom Unternehmen verkauft wird.

Erstellen von Tabellen

Zum Erstellen einer Tabelle kann man Folgendes verwenden:

  • Punkt Datenbank | Neues Objekt des Hauptmenüs. Im Fenster zum Auswählen des Obejktypes muss man eine Tabelle auswählen,
  • Punkt "Neue Tabelle" des Kontextmenüs einer Tabelle
  • Punkt Erstellen | Tabelle Symbolleiste des DB-Explorers
  • Tastenkombination <Ctrl + N>.

Umbennenen von Tabellen

Soll der Tabellenname verändert werden, muss man:

  • Punkt des Kontextmenüs der Tabelle Tabelle umbennenen <Objektname> auswählen,
  • oder die Tastenkombination <Ctrl + R> verwenden.

Bearbeiten von Tabellen

Zum Öffnen einer Tabelle im Tabelleneditor ist ein Doppelklicken auf der Tabelle im DB-Explorer erforderlich.

Ebenso kann man dies vornehmen, indem man den Punkt des Kontextmenüs einer Tabelle Tabelle bearbeiten <Objektname> auswählt.

Löschen von Tabellen

Zum Löschen einer Tabelle muss man den Punkt des Kontextmenüs Tabelle löschen <Objektname> auswählen bzw. die Tastenkombination <Ctrl + Del> verwenden.

Kopieren von Tabellen

Zum Kopieren eines Objektes besteht ein spezieller Assistent, denn man kann das Objekt in eine andere Datenbank, ebenso mit oder ohne die Daten kopieren.

Zum Kopieren einer Tabelle muss man den Punkt Tabelle duplizieren <Objektname> im Kontextmenü der Tabelle auswählen.

Soll die Tabelle auf diese Weise kopiert werden, dann wird der Assistent zum Kopieren von Objekten im 3. Schritt sofort geöffnet. In den ersten zwei Schritten werden eine Datenbank und ein Objekt ausgewählt, was in diesem Fall nicht nötig ist.


Neue Tabelle

Das Werkzeug New Table/Neue Tabelle ermöglicht eine neue Tabelle zu erstellen, die Felder für diese zu bestimmen und die Beschreibung zu bearbeiten.

Dieses Fenster wird automatisch beim Erstellen des Tabelles geöffnet.

  • Verwenden von Symbolleisten
  • Tabelleneigenschaften
  • Einstellen von Tabellenfeldern

Siehe auch:

  • Tabelleneditor
  • Feldereditor


Symbolleiste

Die Symbolleiste befindet sich links vom Editor und über dem Editor.

Die Symbolleiste hilft:

auf der Leiste Object

  • eine Datenbank, in der eine Tabelle erstellt werden muss, auszuwählen.

auf der Leiste General

  • eine Tabelle mit den aktuellen Eigenschaften zu kompilieren - Compile,
  • einen Hilfehinweis zum Erstellen der Tabellen im MySQL zu öffnen - Show SQL help,

Beim Übergang zu den anderen Registerkarten werden die Leisten mit den Sonderfunktionen für jede Registerkarte erscheinen.

Die Symbolleiste ermöglicht:

  • eine Datenbank, in der eine Tabelle erstellt werden muss, aus der Dropdownliste Database auszuwählen,
  • eine Tabelle mit den aktuellen Eigenschaften zu kompilieren - die Schaltfläche Compile,
  • einen Hilfehinweis zum Erstellen der Tabellen im MySQL zu öffnen - Show SQL help,
  • eine Standardgröße eines Fensters wiederherzustellen Restore default size.


Tabelleneigenschaften

Für die zu erstellende Tabelle kann man die nachfolgenden Eigenschaften angeben:

Im Feld Table name wird ein Tabellenname eingegeben. Aus der Dropdownliste Storage engine wählt man eine Art vom Speichern der Tabelle aus. Das Format der Zeilen muss aus der Dropdownliste Row format ausgewählt werden.

Min. rows - minimale Anzahl der Zeilen.

Max. rows - maximale Anzahl der Zeilen.

Mit Hilfe des Indikators Auto increment value wird ein Wert, der im Feld mit dem Typ Autoincrement erzeugt wird, angegeben.

Die durchschnittliche Zeilenlänge ist im Feld Average row length angegeben.

Size for index key blocks - die Größe der verwendeten Blocken im Indexschlüssel.

Check sum (nur für die Tabellen mit dem MyISAM-Typ) - im Programm wird eine Summe der Tabellen gespeichert. Das kann die Arbeit verlangsamen, aber erleichert die Suche der beschädigten Tabellen.

Bei Aktivierung des Häkchens Pack keys werden die Tabellenindexe verkleinert, was die Aktualisierung verlangsamt, aber das Lesen beschleunigt.

Delay key write - wenn dieses Häkchen aktiviert ist, dann wird der Schlüsselpuffer der Tabelle mit dieser Option auf die Platte bei jeder Erneuerung von Indizes nicht zurückgesetzt.

Ist Temporary aktiviert, dann wird die Tabelle temporär angelegt.

Der Zeichensatz wählt man aus der Dropdownliste Character set und aus der Dropdownliste Collation die Vergleichsregeln der Zeichendaten aus. Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und in anderen Formaten vor.

Unter dem Tab File options wird die Directory zum Speichern der Datenbankdateien eingegeben.

Im Feld Data directory gibt man den Ordner, in den die Tabellendaten gespeichert werden, ein.

Im Ordner, der im Feld Index directory angegeben ist, werden die Tabellenindizes gespeichert.

Unter dem Tab Merge Table Options sind die Parameter der Verbindung von Tabellen einzugeben.

Im Feld Union tables wird eine Tabelle, die der bearbeitenden Tabelle identisch ist, eingegeben.

Aus der Dropdownliste Insert method wählt man eine Merge-Methode für die Tabelle aus.

Unter dem Tab Federated Table im Feld Options connection string werden die Verbindungsparameter zur entfernten Tabelle eingegeben.

(Man kann sich mit einer entfernten Tabelle verbinden, wenn die Speicherungsart FEDERATED im Feld Storage engine ausgewählt ist.)


Einstellen der Felder

Die Registerkarte Fields ist zum Einstellen der Felder für eine anzulegende Tabelle bestimmt.

Unter dieser Registerkarte werden die nachfolgenden Eigenschaften des Feldes angezeigt:

  • Primärschlüssel - Primary Key,
  • Spaltename - Column Name,
  • Datentyp - Data Type,
  • Anzahl der Dezimalstellen wird im Feld Precision angegeben,
  • Nicht Null - Not Null,
  • Standardwert wird im Feld Default Value angegeben.

Das Doppelklicken wird ein ausgewählltes Feld im gemäßen Editor Feldeditor öffnen.


DDL-Bearbeitung

Unter der Registerkarte DDL kann man sich DDL einer Tabelle anschauen. Der Text dieser Registerkarte kann nicht bearbeitet werden. Soll DDL verändert werden, dann wird der Text in die Zwischenablage kopiert und in SQL-Editor bzw. SQL Skript Editor eingefügt.


Tabelleneditor

Der Tabelleneditor ist ein Hauptwerkzeug des SQL Manager 2007 for MySQL zum Arbeiten mit den Datenbanktabellen. Das Tool ermöglicht alle Operationen mit den Tabellen und derer Unterobjekten auszuführen.

Eine Tabelle im Tabelleneditor kann durch ein Doppelklick auf eine Tabelle im DB-Explorer geöffnet werden.

Die Werkzeuge des Tabelleneditors:

  • Symbolleisten
  • Neuordnung der Felder
  • Registerkarten

Registerkarten des Tabelleneditors

Für die Benutzerfreundlichkeit wurde der Tabelleneditor in einige Registerkarten eingeteilt. Jede von ihnen ermöglicht eine Menge der Operationen auszuführen und ist für einen bestimmten Eigenschaftssatz einer Tabelle und derer Elementen zuständig.

Registerkarten:

  • Properties - Tabelleneigenschaften,
  • Fields - Arbeiten mit den Feldern,
  • Indices - Arbeiten mit den Indizes einer Tabelle ,
  • Foreign Keys - Verwaltung der Fremdschlüssel,
  • Triggers - Verwaltung der Trigger,
  • Data - Betrachten von Daten in einer Tabelle,
  • Dependencies - Abhängigkeiten der Objekte,
  • DDL - Betrachten der DDL-Beschreibung.

Siehe auch:

Neues Tabelle

Feldeditor

Indexseditor

Triggereditor

Fremdschlüsseleditor


Symbolleiste

Die Symbolleiste liegt links vom Editor und über dem Editor.

Mit der Nagivationsleiste kann man:

auf der Leiste Object:

  • eine Datenbank auswählen,
  • eine Tabelle zur Bearbeitung auswählen.

auf der Leiste General:

  • einen Inhalt der zu bearbeitenden Tabelle erneuern - Refresh,
  • eine Tabelle kompilieren - Compile,
  • Berechtigungen für dieses Objekt einstellen - Grants on Table,
  • Metadaten einer Tabelle drucken - Print,
  • einen Hilfehinweis von MySQL öffnen - Show SQL help,
  • Tabelleneditor im Umgebungsoptionen | Tabelleneditor einstellen - Table Editor options,
  • Standardgröße eines Fensters wiederherstellen - Restore default size,

auf der Leiste Tools:

  • alle Daten aus einer Tabelle löschen- Truncate table.

auf der Leiste Fields:

  • ein neues Feld in einer Tabelle anlegen- New Field,
  • ein ausgewähltes Feld bearbeiten - Edit Field<Namenfeld>,
  • ein ausgewähltes Feld löschen Drop field<Namenfeld>.

auf der Leiste Explorer werden alle Unterobjekte einer im Editor geöffneten Tabelle geöffnet.

Ähnlich wie im DB-Explorer kann man mit der rechten Maustaste das Kontextmenü eines Objektes aufrufen.

Beim Übergang zu den anderen Registerkarten des Editors erscheinen die Leisten mit speziellen Funktionen für jede Registerkarte.

Für die Registerkarte Indizes erscheint die Leiste Indices,

damit kann man:

  • einen neuen Index hinzufügen - Add new index,
  • einen ausgewählten Index bearbeiten - Edit selected index,
  • einen ausgewählten Index löschen - Drop selected index.

Für die Registerkarte Fremdschlüssel erscheint die Leiste Foreign Keys.

damit kann man:

  • einen neuen Schlüssel hinzufügen - Add new foreign key,
  • einen ausgewählten Schlüssel bearbeiten - Edit selected foreign key,
  • einen ausgewählten Schlüssel (bzw. mehrere Schlüssel) löschen - Drop selected foreign key(s).

Für die Registerkarte Triggers erscheint die Leiste Triggers,

damit kann man:

  • einen neuen Trigger hinzufügen - Add new trigger,
  • einen ausgewählten Trigger bearbeiten - Edit selected trigger,
  • einen ausgewählten Trigger löschen - Drop selected trigger.

Für die Registerkarte Daten erscheint die Leiste Data management,

damit kann man:

  • Commit für die Transaktion verwenden - Commit Transaction (aktiv, falls die Transaktionen für die Daten aktiviert sind Options | Umgebungsoptionen | Werkzeuge | Use transactions in Data tab of object editors, SQL Editor and Query Builder),
  • Rollback Transaktion für die Tabellendaten ausführen - Rollback Transaction (aktiv, falls die Transaktionen für die Daten aktiviert sind),
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten importieren - Import Data,
  • Daten laden - Load data,
  • Daten in Datei auf dem Server speichern - Save data to file on server.

Für Regiesterkarte DDL erscheint die Leiste DDL,

damit kann man:

  • DDL in Datei speichern - Save DDL to file,
  • DDL im Editor öffnen - Open DDL in SQL Editor,

Die Symbolleiste ermöglicht:

  • eine Datenbank zum Arbeiten auszuwählen - Dropdownliste Databases,
  • eine Tabelle zum Bearbeiten auszuwählen - Object,
  • einen Inhalt der zu bearbeitenden Tabelle zu erneuern - Refresh,
  • eine Tabelle zu kompilieren - Compile,
  • Berechtigungen für dieses Objekt einzustellen - Grants on Table,
  • Metadaten einer Tabelle zu drucken - Print Table Metadata,
  • Commit für die Transaktion zu verwenden - Commit Transaction (aktiv, falls die Transaktionen für die Daten aktiviert sind Options | Umgebungsoptionen| Werkzeuge |Use transactions in Data tab of object editors, SQL Editor und Query Builde),
  • Rollback Transaktion für die Tabellendaten auszuführen - Rollback Transaction (aktiv, falls die Transaktionen für die Daten aktiviert sind),
  • Daten zu exportieren - Export Data,
  • Daten als SQL-Skript zu exportieren - Export as SQL Script,
  • Daten zu importieren - Import Data,
  • Daten zu laden - Load data,
  • Daten in Datei auf dem Server speichern - Save data to file on server,
  • Alle Daten aus einer Tabelle zu löschen - Truncate table.
  • Tabelleneditor in Umgebungsoptionen | Tabelleneditor einzustellen - Table Editor options,
  • MySQL-Hilfe zu öffnen - Show SQL help,
  • Standartmäßige Größe und Position eines Fensters zurückzusetzen- Restore Default Window Size and Position.


Tabelleneigenschaften

Unter dieser Registerkarte kann man die nachfolgenden Tabelleneigenschaften angeben.

Im Feld Table name ist ein Tabellenname angegeben. Aus der Dropdownliste Storage engine wählt man eine Art vom Speichern der Tabelle aus. Das Zeilenformat kann aus der Dropdownliste Row format ausgewählt werden.

Min. rows - minimale Anzahl der Zeilen.

Max. rows - maximale Anzahl der Zeilen.

Mit Hilfe des Indikators Auto increment value wird ein Wert, der im Feld mit dem Typ Autoincrement erzeugt wird, angegeben.

Die durchschnittliche Zeilenlänge ist im Feld Average row length angegeben.

Size for index key blocks - die Größe der verwendeten Blöcke im Indexschlüssel.

Check sum (nur für die Tabellen mit dem MyISAM-Typ) - im Programm wird eine Summe der Tabellen gespeichert. Das kann die Arbeit verlangsamen, aber erleichert die Suche der beschädigten Tabellen.

Bei Aktivierung des Häkchens Pack keys werden die Tabellenindexe verkleinert, was die Aktualisierung verlangsamt, aber das Lesen beschleunigt.

Delay key write - wenn dieses Häkchen aktiviert ist, dann wird der Schlüsselpuffer der Tabelle mit dieser Option auf die Platte bei jeder Erneuerung von Indizes nicht zurückgesetzt.

Ist Temporary aktiviert, dann wird die Tabelle temporär angelegt.

Den Zeichensatz wählt man aus der Dropdownliste Character set und aus der Dropdownliste Collation die Vergleichsregeln der Zeichendaten aus. Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und in anderen Fortmaten vor.

Unter dem Tab File options wird die Directory zum Speichern der Datenbankdateien eingegeben.

Im Feld Data directory wird der Ordner, in den die Tabellendaten gespeichert werden, eingegeben.

Im Ordner, der im Feld Index directory angegeben ist, werden die Tabellenindizes gespeichert.

Unter dem Tab Merge Table Options werden die Parameter der Verbindung von Tabellen eingegeben.

Im Feld Union tables wird eine Tabelle, die der bearbeitenden Tabelle identisch ist, eingegeben.

Aus der Dropdownliste Insert method wählt man eine Merge-Methode für die Tabelle aus.

Unter dem Tab Federated Table im Feld Options connection string sind die Verbindungsparameter zur entfernten Tabelle einzugeben.

(Man kann sich mit einer entfernten Tabelle verbinden, falls die Speicherungsart FEDERATED im Feld Storage engine ausgewählt ist.)

Im Fenster Table status werden die zusammengesetzten Infos über eine bearbeitende Tabelle angezeigt:

  • Version - Version,
  • Rows - Anzahl der Zeilen in einer Tabelle,
  • Avg row length - durchschnittliche Zeilenlänge,
  • Data length - allgemeine Datenmenge,
  • Index length - allgemeine Menge von Indizes,
  • Data free - Anzahl der verteilten, aber nicht verwendeten Bytes,
  • Auto increment - nächster Wert, der im Feld mit dem Typ Autoincrement erstellt wird,
  • Create time - Datum und Zeit der Erstellung,
  • Update time - Zeit vom Update,
  • Check time - Zeit der letzten Überprüfung,
  • Check sum - Summe für die Überprüfung der Integrität.

Im unteren Textfeld kann man die Kommentare zu einer Tabelle angeben.


Arbeiten mit den Feldern

Die Registerkarte Fields ist zum Arbeiten mit den Tabellenfeldern bestimmt.

Das Feld ist ein Bereich im Fenster bzw. Datensatz, in dem eine separate Bedeutung gespeichert wird.

Das Doppelklicken öffnet ein Feld im Feldeditor. Mit dem rechten Mausklick wird das Kontextmenü des Feldes aufgerufen.

Für jedes Feld auf dieser Registerkarte kann man die nachfolgenden Eigenschaften angeben:

  • Feldnamen - Field Name,
  • Feldtyp - Field Type,
  • Größe - Size,
  • Anzahl der Dezimalstellen - Precision,
  • Nicht Null - Not Null,
  • Standardwert - Default Value.
  • Kommentar - Comment.

Mehr Infos über das Arbeiten mit den Feldern


Neuordnung der Felder

Die Reihenfolge der Felder kann mit Hilfe eines speziellen Werkzeuges Reorder Fields dialog verändert werden. Dieses Werkzeug kann man mittels Kontextmenü des Feldes Reorder Fields öffnen.

In der Liste Column name wird die Liste von Tabellenfeldern in der aktuellen Reihenfolge angezeigt.

Diese Reihenfolge kann auf zwei Weisen verändert werden:

  • durch Betätigen der Schaltflächen [image] und durch Verschieben eines der ausgewählten Felder nach oben bzw. nach unten.
  • mit Hilfe von Drag And Drop - durch einfaches Ziehen eines Feldes zum benötigten Platz.


Arbeiten mit den Indizes

Unter der Registerkarte Indices kann man die Indizes einer Tabelle anlegen, betrachten oder bearbeiten.

Das Doppelklicken ermöglicht einen Index im Index-Editor zu öffnen.

Auf dieser Registerkarte sind die nachfolgenden Infos über die Indizes von Tabellen zu sehen:

  • Indexname - Index Name,
  • Felder - On Fields,
  • eindeutiger Schlüssel - Unique,
  • Volltext Index - Fulltext.

Kontexmenü des Indexes

Mit dem rechten Mausklick wird das Kontexmenü des Indexes aufgerufen.

Damit kann man:

  • Neuen Index erstellen - New Index,
  • Bestehenden Index bearbeiten - Edit Index<Indexname>,
  • Index löschen - Drop Index<Indexname>,
  • Liste von Indizes exportieren - Export List.


Verwaltung der Fremdschlüssel

Unter dieser Registerkarte kann man die Fremdschlüssel der Tabelle anlegen und bearbeiten.

Durch Doppelklick öffnet man einen Schlüssel im Fremdschlüssel-Editor.

Unter der Registerkarte Foreign Keys werden die nachfolgenden Infos über die Fremdschlüssel dargestellt.

  • Name eines Fremdschlüssels - Foreign Key Name,
  • Feldname - Field names,
  • Fremddatenbank - Foreign Database Name,
  • Fremdtabellenname - Foreign Table Name,
  • Fremdfeldname - Foreign Field Name,
  • Aktionen, die beim Löschen vorgenommen werden - Delete Rule,
  • Aktionen, die beim Update vorgenommen werden - Update Rule.

Kontextmenü des Fremdschlüssels

Durch das Betätigen der rechten Schaltfläche wird das Kontextmenü für einen ausgewählten Fremdschlüssel aufgerufen.

Damit kann man:

  • Neuen Fremdschlüssel anlegen - New Foreign Key,
  • Bestehenden Fremdschlüssel bearbeiten - Edit Foreign Key<Objektname>,
  • Schlüssel löschen - Drop Foreign Key<Objektname>,
  • Liste der Fremdschlüssel exportieren- Liste exportieren .


Verwaltung der Triggers

Unter der Registerkarte Triggers kann man die Triggers einer Tabelle anlegen, ansehen oder bearbeiten.

Durch Doppelklick wird der Trigger im Trigger-Editor geöffnet.

Auf dieser Registerkarte sind folgende Infos zu finden:

  • Triggername - Name,
  • Triggertyp - Type,
  • Ereignis - Event.

Kontextmenü des Triggers

Durch rechte Maustastenklick auf dem Trigger wird das Kontextmenü geöffnet.

Mit Hilfe dieses Menü kann man:

  • neuen Trigger anlegen - New Trigger...,
  • ausgewählten Trigger bearbeiten - Edit Trigger <Objektname>,
  • Trigger löschen - Drop Trigger <Objektname>,
  • Liste der Objekte exportieren - Liste exportieren.


Betrachten von Daten

Unter dieser Registerkarte können die Daten in eine Tabelle eingetragen werden. Ebenso ist das Betrachten von Daten und derer Änderung möglich. Die Verwaltung der Daten erfolgt mit Hilfe der Symbolleiste und des Dropdownmenüs.


Betrachten von DDL-Beschreibung

Unter der Registerkarte DDL kann man sich die DDL einer Tabelle anschauen. Der Text unter diesem Tab kann nicht bearbeitet werden. Soll die Tabelle verändert werden, wird der Text in die Zwischenablage kopiert und in den SQL-Editor bzw. SQL Script Editor eingefügt.


Felder

Im Tabelleneditor unter der Registerkarte Felder kann man die Tabellenfelder anlegen, bearbeiten und löschen.

Das Feld ist ein Bereich des Fensters oder Datensatzes, wo ein separater Wert gespeichert wird.

Anlegen von Feldern

Um ein Feld in eine Tabelle hinzuzufügen, muss man die nachfolgenden Aktionen ausführen:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Felder öffnen (standardmäßig wird sie sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet),
  • im Kontextmenü des Feldes den Punkt Neues Feld... auswählen,
  • im geöffneten Feldeditor die benötigten Feldeigenschaften angeben.

Kopieren vom Feldern

Zum Kopieren eines Feldes muss man den Punkt Feld duplizieren <Objektname> im Kontextmenü des Feldes auswählen.

Im ersten sich öffnenden Fenster wird ein Name des neuen Feldes eingegeben, im zweiten wird angegeben, ob das Objekt mit oder ohne die Daten kopiert werden muss.

Bearbeiten von Feldern

Zum Verändern eines Feldes muss man:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Felder öffnen (standardmäßig wird sie sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet),
  • im Kontextmenü des Feldes den Punkt Feld bearbeiten<Objektname> auswählen,
  • im geöffneten Feldeditor die benötigten Feldeigenschaften angeben.

Löschen von Feldern

Um ein Feld zu löschen, muss man:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Feld öffnen (standardmäßig wird sie sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet).
  • im Kontextmenü des Feldes den Punkt Feld löschen <Objektname> auswählen.
  • im geöffneten Fenster das Löschen eines Feldes bestätigen.

Kontextmenü eines Tabellenfeldes

Mit Rechtsklick kann man das Kontextmenü des Feldes aufrufen.

Mit Hilfe dieses Menüs kann man:

  • neues Feld anlegen - New Field...,
  • Feld bearbeiten - Edit Field <Feldname>,
  • Feld umbenennen - Rename Field <Feldname>,
  • Feld löschen - Drop Field <Feldname>,
  • Feld kopieren - Duplicate Field,
  • Felder neuordnern - Reorder Fields,
  • Liste der Feldernamen in Zwischenablage kopieren - Copy list of field Names to clipboard,
  • Liste der Felder exportieren - Export List.


Feld-Editor

Dieses Werkzeug ermöglicht die Eigenschaften der Felder von einer Datenbanktabelle beim Erstellen und Bearbeiten des Feldes zu ändern.

Das Feld kann man im Editor auf folgende Weise öffnen:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Fields öffnen (standardmäßig wird diese sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet),
  • im Kontextmenü des Feldes den Punkt Edit Field<Objektname> auswählen.

Es gibt eine weitere Änderungsmöglichkeit, falls im SQL-Assistenten die Felder einer Tabelle angezeigt werden.

Ein Feld wird in diesem Fall durch ein Doppelklick im SQL-Assistenten geöffnet. Den SQL-Assistenten kann man mittels der Schaltfläche Ansichtsmodus des DB-Explorers einstellen.

Nach der Ausführung einer dieser Operationen wird ein Feldeditor, in dem man alle Eigenschaften des Feldes angeben kann, geöffnet.

Mit Hilfe dieses Editors kann man die Eigenschaften von Feldern angeben und verändern:

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Feldeigenschaften

Mit Hilfe des Feldeditors können alle im MySQL verfügbaren Feldeigenschaften angegeben werden.

Im Feld Field name wird ein Feldname angegeben, dieser muss den Benennungsregeln von MySQL-Feldern entsprechen.

Aus der Dropdownliste Type wählt man den Typ von Daten, die in diesem Feld gespeichert werden, aus. Wenn das Häkchen Use dimension aktiviert ist, kann man für den ausgewählten Feldtyp die Größe und die Genauigkeit der Anzeige einstellen. Mit Hilfe des Indikators Size wird die Größe des Feldes angegeben. Für die Zahlen mit dem Fließkomma im Feld Precision ist die Anzahl der Nachkommastellen anzugeben.

Im Abschnitt Field flags werden nachfolgende Parameter eines Feldes eingestellt:

  • Ist das Häkchen Not null aktiviert, dann kann das Feld keinen NULL-Wert haben.
  • Unsigned - stellt für ein Feld das Attribut UNSIGNED ein. In diesem Fall werden die Ganzzahldaten ohne Zeichen dargestellt werden.
  • Zerofill - wenn man für eine Spalte, die den Zahlendatentyp hat, das Häkchen aktiviert, dann wird MySQL automatisch die Nullen vor der ersten wertvollen Datenziffer in diese Spalte hinzufügen
  • Bei Aktivierung des Häkchens Unique wird angegeben, dass das Feld ein Teil des eindeutigen Schlüssels ist.
  • Zum automatischen Erstellen eines eindeutigen Identifikators im Feld für die neuen Zeilen wird das Häkchen Autoincrement aktiviert.
  • Das zu bearbeitende Feld kann man als Primärschlüssel einstellen, indem man das Häkchen Primary key aktiviert.

In der Tabelle muss lediglich eine Einschränkung Primary key sein und die Spalte mit der vorhandenen Einschränkung kann den NULL-Wert nicht enthalten.

Den Wert Values kann man nur für die Felder mit den Datentypen ENUM und SET angeben. Durch Betätigen der Schaltfläche wird im Feld Values ein Fenster, in dem eine Liste der Werte eingeben werden kann, geöffnet.

Im unteren Teil des Feldeditors, auf der Registerkarte Default, kann man den Wert für ein Feld standardmäßig angeben.

Auf der Registerkarte Field charset für die Textfelder sind die Parameter des Zeichensatzes anzugeben.

Den Zeichensatz wählt man aus der Dropdownliste Character set und aus der Dropdownliste Collation die Vergleichsregeln der Zeichendaten aus. Diese Regeln geben die Zeichenseite und die Vergleichsreihenfolge der Zeichendaten mit den Daten im Unicode und in anderen Fortmaten vor.

Unter der Registerkarte Description kann man einen Textkommentar für ein Feld hinzufügen.

Beim Erstellen eines neuen Feldes im Feldeditor kann der Platz ausgewählt werden, wo das zu erstellende Feld platziert wird.

  • Insert first - ein neues Feld wird vor dem ersten Feld der Tabelle platziert.
  • Insert last - ein neues Feld wird nach dem letzten Feld der Tabelle platziert.
  • wählt man Insert after field aus, dann kann man aus der Liste Insert after ein Feld, nach dem das zu erstellendes Feld gesetzt werden muss, auswählen.


Bearbeitung der Felder mit den ENUM- und SET-Typen

ENUM ('Wert1','Wert2',...)

Aufzählung. Aufzählungsdatentyp. Das Objekt einer Zeile kann nur einen Wert, der aus der vorgegeben Liste von Werten 'Wert1', 'Wert2',.., NULL bzw. spezieller Fehlerwert"" ausgewählt wird, haben. Die ENUM-Liste kann maximal 65535 unterschiedliche Werten enthalten.

SET ('Wert1','Wert2',...)

Das ist ein Zeilendatentyp, der Null und mehrere Werte annehmen kann. Jeder dieser Werte muss aus der Liste von zulässigen, beim Erstellen der Tabelle bestimmten Werten ausgewählt werden. Die SET-Menge kann maximal 64 verschiedene Elemente haben.

Die Werte werden in der Liste Values angezeigt. Um in die Liste einen neuen Wert hinzuzufügen, wird dieser im Feld Value angegeben und danach klickt man die Schaltfläche Add an. Wenn man in der Liste einen Wert auswählt, im Feld Value einen neuen angibt und auf die Schaltfläche Replace drückt, wird ein alter Wert durch den neuen ersetzt. Um den Punkt in der Liste zu löschen, muss man den auswählen und die Schaltfläche Remove drücken. Die Reihenfolge von Werten kann man in der Liste mittels der Schaltflächen Up und Down festlegen.


Indizes

Der Index ist ein Objekt der Relationsdatenbank. Der ermöglicht einen schnellen Zugriff auf die Daten in den Tabellenzeilen anhand der Schlüsselwerte. Ebenso machen die Indizes die Tabellenzeilen eindeutig. Der Primärschlüssel einer Tabelle wird automatisch indiziert. Bei Volltextsuche werden die Infos über die Schlüsselwörter und derer Anordnung in einer bestimmten Spalte im Volltextindex gespeichert.

Erstellen von Indizes

Um einen Index in die Tabelle hinzuzufügen, muss man die nachfolgendenen Operationen ausführen:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Indizes öffnen
  • im Kontextmenü des Indexes den Punkt Neuer Index... auswählen,
  • im sich öffnenden Indexeditor benötigte Indexeigenschaften angeben.

Bearbeiten von Indizes

Um einen Index zu verändern, muss man:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Indizes öffnen
  • im Kontextmenü des Indexes den Punkt Index bearbeiten <Objektname> auswählen,
  • im sich öffnenden Indexeditor die benötigten Indexeigenschaften angeben.

Löschen von Indizes

Um einen Index zu löschen, muss man:

  • Tabelle im Tabelleneditor durch Doppelklick auf eine benötigte Tabelle im DB-Explorer öffnen.
  • Registerkarte Indizes öffnen
  • im Kontextmenü des Indexes den Punkt Index löschen <Objektname> auswählen,
  • im sich öffnenden Indexeditor das Löschen eines Indexes bestätigen


Indexeditor

Dieses Werkzeug ermöglicht Indizes anzulegen und bereits bestehende Indizes zu bearbeiten.

Im Feld Index name wird ein Indexname angegeben. Der Name kann nur dann nicht verändert werden, wenn der Index den Status Primary hat.

Danach wählt man im Abschnitt Fields for index die Tabellenfelder, die in den Index eingeschlossen werden.

In der Liste Available Fields sind die verfügbaren Felder, die man mit Hilfe der Schaltflächen in die Felderliste des Indexes - Included Fields verschieben kann.

Im Abschnitt Index properties werden die Indexeingenschaften angegeben:

  • Primary - wählt man diesen Wert, wenn der Primärschlüssel anlegegt werden soll
  • Bei Aktivierung des Häkchens Fulltext wird der anzulegende Index zum Volltext
  • Unique erstellt einen eindeutigen Index für eine Tabelle und eine View. Der eindeutige Index ist derjenige, in dem keine zwei Zeilen mit den gleichen Werten des Indexschlüssels möglich sind.

Im Feld Length ist die Länge des Indexes für das Feld anzugeben.

Siehe auch:

Tabelleneditor

Fremdschlüsseleditor

Triggereditor

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Triggers

Der Trigger ist eine Art der gespeicherten Prozedur, die automatisch bei der Auslösung eines Ereignisses auf dem Datenbankserver ausgeführt wird. Die Trigger der Datenverarbeitungssprache werden nach den Ereignissen ausgeführt. Diese werden durch den Versuch des Benutzers, die Daten mit Hilfe der Datenverarbeitungssprache zu verändern, aufgerufen. Die DML-Ereignisse schließen INSERT-, UPDATE- oder DELETE-Anweisungen ein, die Daten in einer angegebenen Tabelle oder Sicht ändern. Die DDL-Trigger werden als Ergebnis einer Reihe der DDL-Ereignisse ausgelöst. Diese Ereignisse sind vor allem die CREATE-, ALTER-, DROP-Anweisungen und einige im System gespeicherte Prozeduren, die mit DDL gleiche Operationen ausführen.

Trigger erstellen

Um einen Trigger in eine Tabelle einzutragen, muss man wie folgt vorgehen:

  • es wird die Tabelle im Tabelleneditor geöffnet. Hierfür reicht ein Doppelmausklick auf der benötigten Tabelle im DB-Explorer,
  • danach wird die Registerkarte Trigger geöffnet,
  • im Trigger-Kontextmenü ist danach der Punkt Neuer Trigger... auszuwählen,
  • im erscheinenden Triggereditor werden dann die benötigten Triggereingenschaften angegeben.

Trigger bearbeiten

Um einen Trigger zu verändern, muss man wie folgt vorgehen:

  • es wird die Tabelle im Tabelleneditor geöffnet. Hierfür reicht ein Doppelmausklick auf der benötigten Tabelle im DB-Explorer,
  • danach wird die Registerkarte Trigger geöffnet,
  • im Trigger-Kontextmenü ist danach der Punkt Trigger bearbeiten <Objektname> auszuwählen,
  • im erscheinenden Triggereditor werden dann die benötigten Triggereingenschaften angegeben.

Trigger löschen

Um einen Trigger zu löschen, muss man wie folgt vorgehen:

  • es wird die Tabelle im Tabelleneditor geöffnet. Hierfür reicht ein Doppelmausklick auf der benötigten Tabelle im DB-Explorer,
  • danach wird die Registerkarte Trigger geöffnet,
  • im Trigger-Kontextmenü ist danach der Punkt Trigger löschen <Objektname> auszuwählen,
  • im erscheinenden Fenster muss das Löschen des Triggers bestätigt werden.


Triggereditor

Dieser Editor ist für das Anlegen und Bearbeiten von Triggern bestimmt.

Alle Triggereigenschaften werden im Editor auf den nachfolgenden Registerkarten untergebracht:

  • Triggereingenschaften - Trigger,
  • Objektabhängigkeiten - Dependencies,
  • DDL-Beschreibung - DDL.

Siehe auch:

Tabelleneditor

Fremdschlüsseleditor

Indexeditor

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Trigger bearbeiten

Die Hauptparameter des Triggers werden auf der Registerkarte Trigger eingestellt.

Im Feld Name ist der Triggername anzugeben.

Aus der Dropdownliste Table wählt man dann eine Tabelle, für die der Trigger angelegt wird, aus. Das Feld ist lediglich für das Bearbeiten beim Anlegen des Triggers verfügbar.

Mittels Type wird der Schaltertyp des Triggers eingestellt.

Ist der Typ After aktiviert, wird der DML-Trigger nur nach der erfolgreichen Ausführung aller Operationen in der SQL-Anweisung, die durch den Trigger aufgerufen wurde, ausgelöst. Alle überlappenden Aktionen und Überprüfungen der Verweiseinschränkungen müssen vor dem Starten des Triggers beendet werden. Ist der Typ Before aktiviert, wird der Trigger vor dem Beenden der Operationen ausgelöst.

Im Abschnitt On Event wird ein Ereignis, dass nach der Ausführung zur Auslösung des Triggers führt, ausgewählt.

Man kann eines der angebotenen Ereignisse auswählen: Insert, Update bzw. Delete.

Die Anweisung des Triggers wird manuell im Fenster Definition angegeben.


DDL-Trigger betrachten

Unter der Registerkarte DDL kann DDL des Triggers betrachtet werden. Der Text kann unter diesem Tab nicht bearbeitet werden.

Soll ein Trigger geändert werden, dann muss der Text in die Zwischenablage kopiert und in SQL Editor bzw. SQL Script Editor eingefügt werden.


Fremdschlüssel

Der Fremdschlüssel/Foreign Key ist eine Spalte bzw. eine Spaltenkombination, deren Werte einem primären bzw. eindeutigen Schlüssel aus derselben oder anderen Tabelle entsprechen. Der Fremdschlüssel wird ebenso als Verweisschlüssel bezeichnet.

Die Erstellung und Bearbeitung der Fremdschlüssel erfolgt mit Hilfe des speziellen Werkzeuges - Fremdschlüsseleditor.

Diese Einschränkung versorgt die Ganzheit von Verweisdaten. Der Fremdschlüssel wird für zwangsläufige Relationen zwischen den Daten in zwei Tabellen verwendet.

Fremdschlüssel erstellen

Um einen Fremdschlüssel in eine Tabelle einzutragen, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür reicht ein Doppelmausklick auf der benötigten Tabelle im DB-Explorer,
  • Registerkarte Fremdschlüssel öffnen,
  • im Kontextmenü des Fremdschlüssels den Punkt Neuer Fremdschlüssel... auswählen,
  • im erscheinenden Fremdschlüsseleditor die benötigten Eigenschaften des Fremdschlüssels angeben.

Fremdschlüssel bearbeiten

Um einen Fremdschlüssel zu verändern, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür reicht ein Doppelmausklick auf der benötigten Tabelle im DB-Explorer genug,
  • Registerkarte Fremdschlüssel öffnen,
  • im Kontextmenü des Fremdschlüssels den Punkt Fremdschlüssel bearbeiten <Obejktname> auswählen,
  • im erscheinenden Fremdschlüsseleditor die benötigten Eingeschaften des Fremdschlüssels angeben.

Hinweis: einige Eigenschaften des Fremdschlüssels kann man lediglich beim Anlegen einstellen. Beim Bearbeiten des schon erstellten sind diese bereits nicht verfügbar.

Fremdschlüssel löschen

Um einen Fremdschlüssel zu löschen, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür reicht ein Doppelmausklick auf der benötigten Tabelle im DB-Explorer genug,
  • Registerkarte Fremdschlüssel öffnen,
  • im Kontextmenü des Fremdschlüssels den Punkt Fremdschlüssel löschen<Objektname> auswählen,
  • im erscheinenden Fenster das Löschen des Fremdschlüssels bestätigen


Fremdschlüsseleditor

Dieser Editor wird für die Eigenschaftenänderung des Fremdschlüssels verwendet. Der Editor wird beim Anlegen eines neuen Fremdschlüssels bzw. Bearbeiten eines schon bestehenden geöffnet.

Der Fremdschlüsselname wird im Feld Foreign Key Name angegeben. Das System erstellt automatisch einen Namen, der aus der Bezeichnung der ausgewählten Tabelle und des Suffixes_fk besteht. Aus der Dropdownliste Table wählt man danach eine Tabelle, in der der Fremdschlüssel erstellt wird, aus. Hinweis: Dieses Feld kann nur beim Anlegen des Schlüssels erstellt werden.

Um die Tabellenfelder in den Fremdschlüssel einzutragen, müssen diese aus der Liste der verfügbaren Felder Available Fields in die Liste der enthaltenen Felder Included Fields übertragen werden.

Danach wählt man aus der Dropdownliste Foreign table eine Fremdtabelle aus. Die Felder aus der Liste der verfügbaren Felder Available Fields werden in die Liste der enthaltenen Felder Included Fields übertragen.

Aus der Dropdownliste On delete rule kann man eine Aktion, die beim Löschen der Daten ausgeführt wird, auswählen.

Aus der Dropdownliste On update rule kann man eine Aktion, die bei der Aktualisierung von Tabellendaten ausgeführt wird, auswählen.

Mehr Infos darüber siehe unter:

  • Tabelleneditor
  • Indexeditor
  • Triggereditor

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Views

Die View (zu dt. Sicht) ist eine virtuelle Tabelle, die die Daten einer oder mehrerer Tabellen alternativ darstellt.

Die Sicht kann nur in einer aktuellen Datenbank erstellt werden und nicht mehr als 1024 Spalten enthalten.

Erstellen von Views

Um eine Sicht zu erstellen, verwendet man einen der folgenden Punkte:

  • Punkt Datenbank | Neues Objekt des Hauptmenüs vom Programm. Im Auswahlfenster des Objekttypes muss man View auswählen
  • Kontextmenü von Datenbankobjekten Sichten | Punkt Neue View,
  • Tastenkombination <Ctrl + N>.

Kopieren von Views

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, denn man kann ein Objekt in eine andere Datenbank mit bzw. ohne Daten kopieren.

Um eine View zu kopieren, muss man den Punkt View duplizieren <Objektname> im Kontextmenü der View auswählen.

Soll das Objekt auf diese Weise kopiert werden, dann wird der Assistent zum Objektkopieren sofort im 3. Schritt geöffnet, denn in den ersten zwei Schritten wird eine Datenbank und ein Objekt ausgewählt, was in diesem Fall unbrauchbar ist.

Bearbeiten von Views

Zum Arbeiten mit einer View gibt es im SQL Manager 2007 for MySQL ein spezielles Werkzeug Vieweditor (Sicht-Editor).

Um eine View im Vieweditor zu öffnen, reicht ein Doppelmausklick auf dem Objekt im DB-Explorer. Das funktioniert auch, indem man den Punkt des Kontextmenüs einer View View bearbeiten <Objektname> auswählt.

Umbenennen von Views

Soll der Namen einer View umbenannt werden, dann braucht man:

  • Punkt des Kontextmenüs der View View umbenennen <Objektname> auswählen,
  • Tastenkombination <Ctrl + R> verwenden.

Löschen von Views

Um eine View zu löschen, muss man im DB-Explorer den Punkt im Kontextmenü View löschen <Objektname> auswählen und die Tastenkombination <Ctrl + Del> verwenden.


Vieweditor

Zum Arbeiten mit Views gibt es im SQL Manager 2007 for MySQL ein spezielles Werkzeug Vieweditor (Sicht-Editor).

Im Editor kann man neue Views anlegen und bereits bestehende Views bearbeiten.

Bei der Erstellung einer neuen View wird der Editor automatisch geöffnet.

  • Symbolleisten
  • Bearbeitung der SQL-Beschreibung
  • Betrachten von Feldern
  • Betrachten von Daten
  • Betrachten von Abhängigkeiten
  • Betrachten von DDL

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Werkzeugleisten

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Symbolleisten

Die Symbolleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Symbolleiste kann man:

auf der Leiste Object

  • Datenbank auswählen,
  • View zum Bearbeiten auswählen.

auf der Leiste General:

  • Inhalt der bearbeitenden View erneuern - Refresh,
  • View bearbeiten, indem man einen visuellen Query-Builder verwendet - Edit query using Query Builder,
  • View mit den aktuellen Eigenschaften kompilieren - Compile,
  • Metadaten vom Objekt drucken - Print,
  • Berechtigungen für dieses Objekt einstellen - Grants on Object,
  • MySQL-Hilfe öffnen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore default size.

Beim Übergehen zu den anderen Registerkarten erscheinen auf der Symbolleiste zusätzliche Symbolleisten zum Arbeiten auf diesen Registerkarten.

Für die Registerkarte Felder erscheint die Leiste Fields:

damit kann man:

  • Liste von Feldern in Zwischenablage kopieren - Copy list to Clipboard,
  • Liste von Feldern in Datei exportieren - Export list.

Für die Registerkarte Daten erscheint die Leiste Data management,

damit kann man:

  • Transaktion von Daten einsetzen - Commit Transaction (aktiviert, falls die Transaktionen für die Daten Options | Umgebungsoptionen | Werkzeuge | Use transactions in Data tab of object editors, SQL Editor and Query Builder eingeschaltet sind),
  • Transaktion für Tabellendaten zurücksetzen - Rollback Transaction (aktiviert, falls die Transaktionen für Daten eingeschaltet sind),
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten importieren - Import Data,
  • Daten in Datei auf dem Server speichern - Save data to file on server.

Für die Registerkarte DDL erscheint die Leiste DDL,

damit kann man:

  • DDL-Beschreibung in Datei speichern - Save DDL to file,
  • DDL im SQL-Editor öffnen - Open DDL in SQL Editor.

Mit Hilfe der Symbolleiste kann man:

  • Datenbank zum Arbeiten auswählen - Dropdownliste Databases,
  • View zum Bearbeiten auswählen - Object,
  • Inhalt der bearbeitenden View erneuern - Refresh,
  • View bearbeiten, indem man einen visuellen Query-Builder verwendet - Edit query using Query Builder,
  • View mit den aktuellen Eigenschaften kompilieren - Compile,
  • Metadaten der View drucken - Print,
  • Transaktion von Daten einsetzen - Commit Transaction (aktiviert, falls die Transaktionen für die Daten Options | Umgebungsoptionen | Werkzeuge | Use transactions in Data tab of object editors, SQL Editor and Query Builder eingeschaltet sind),
  • Transaktion für Tabellendaten zurücksetzen - Rollback Transaction (aktiviert, falls die Transaktionen für Daten eingeschaltet sind),
  • Daten exportieren - Export Data (aktiviert nur auf der Registerkarte Data),
  • Daten als SQL-Skript exportieren - Export as SQL Script (aktiviert nur auf der Registerkarte Data),
  • Daten importieren - Import Data (aktiviert nur auf der Registerkarte Data),
  • Daten in Datei auf dem Server speichern - Save data to file on server,
  • MySQL-Hilfe öffnen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore Default Window Size and Position,


SQL-Beschreibung

Unter der Registerkarte View kann man das SQL-Skript der Viewerstellung anlegen, betrachten und bearbeiten.

Soll der Text erstellt bzw. verändert werden, muss man Compile auf der Navigationsleiste anklicken, damit diese Änderungen übernommen werden.


Betrachten von Feldern

Unter der Registerkarte Fields können alle in der View angezeigten Felder betrachtet werden.


Betrachten von Daten

Unter dieser Registerkarte können die Daten in eine Tabelle eingetragen werden. Man kann ebenso die Daten betrachten und diese abändern. Zu beachten ist, dass man die Daten in den Views, die auf einfachen Abfragen erstellt wurden, verändern kann. Die Datenverwaltung erfolgt mit Hilfe der Symbolleiste und mittels des Dropdownmenüs.


Betrachten von DDL

Unter der Registerkarte DDL können die DDL-Views betrachtet werden. Der Text kann unter dieser Registerkarte nicht bearbeitet werden. Soll der Trigger verändert werden, muss der Text in die Zwischenablage kopiert und in SQL-Editor bzw. SQL Skript Editor eingefügt werden.


Gespeicherte Prozeduren

Die gespeicherten Prozeduren sind ein Satz von den SQL-Befehlen, die auf dem Server kompiliert und gespeichert werden können. Bei der Ausführung kann die Prozedur die Datentabelle zurückgeben.

Erstellen von Prozeduren

Um eine Prozedur anzulegen, verwendet man:

  • Punkt Datenbank | Neues Objekt des Programmhauptmenüs. Im Auswahlfenster des Objekttyps muss man Prozedure auswählen,
  • bzw. Kontextmenü des Datenbankobjektes Prozeduren | Punkt Neue Prozedure...,
  • bzw. Tastenkombination <Ctrl + N>.

Die angelegte Prozedur wird automatisch im Prozedureditor geöffnet.

Kopieren von Prozeduren

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um eine Prozedur zu kopieren, muss man den Punkt Prozedur duplizieren<Objektname> im Kontextmenü der Prozedur auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren gleich im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.

Bearbeiten von Prozeduren

Zum Arbeiten mit den Prozeduren im SQL Manager 2007 for MySQL gibt es ein spezielles Werkzeug - Prozedureditor.

Um eine Prozedur im Prozedureditor zu öffnen, reicht ein Doppelmausklick auf ein Objekt im DB-Explorer genug.

Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Prozedur bearbeiten <Objektname> auswählt.

Umbenennen von Prozeduren

Soll die Bezeichnung der Prozedur verändert werden, dann kann man:

  • Punkt des Kontextmenüs der Prozedur Prozedure umbenennen<Objektname> auswählen,
  • bzw. die Tastenkombintaion <Ctrl + R> verwenden.

Löschen von Prozeduren

Um eine Prozedur zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Prozedur löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Prozedureditor

Dieser Editor hilft die Prozeduren zu erstellen, auszuführen und zu bearbeiten. Er wird automatisch beim Anlegen der neuen Prozedur bzw. Bearbeiten bereits bestehenden geöffnet.

  • Verwendung von Navigationsleisten
  • Bearbeiten von Prozedurdefinition
  • Betrachten von Objektabhängigkeiten
  • Bearbeiten von Prozedurbeschreibung
  • Ausführen von Prozeduren
  • Bestimmen von Eingabeparametern
  • Betrachten von DDL
  • Betrachten von Ergebnissen

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwenden von Navigationsleisten

Die Navigationsleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Navigationsleiste kann man:

auf der Leiste Object

  • Datenbank auswählen,
  • Prozedur zum Bearbeiten auswählen.

auf der Leiste General:

  • Inhalt der bearbeitenden Prozedur erneuern - Refresh,
  • Prozedur mit den aktuellen Eigenschaften kompilieren - Compile,
  • Prozedur ausführen - Execute procedure,
  • Metadaten der Prozedur drucken - Print,
  • MySQL-Hilfe öffnen - Show SQL help,

auf der Leiste Transaction:

  • Transaktion von Daten einsetzen - Commit Transaction (aktiviert, falls die Transaktionen für die Daten Options | Umgebungsoptionen | Werkzeuge | Use transactions in Data tab of object editors, SQL Editor and Query Builder eingeschaltet sind),
  • Transaktion für Tabellendaten zurücksetzen - Rollback Transaction (aktiviert, falls die Transaktionen für Daten eingeschaltet sind).

Falls die Prozedur ausgeführt und das Ergebnis zurückgegeben wurde, erscheint außer der Registerkarte Ergebnisse noch die Leiste Data Management.

Mit Hilfe dieser Leiste kann man:

  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,

Beim Übergehen zu den anderen Registerkarten erscheinen die Symbolleisten mit den speziellen Funktionen für jede Registerkarte.

Für die Registerkarte Beschreibung erscheint die Leiste Description,

damit kann man:

  • Beschreibung in Datei speichern - Save Description to file,
  • Beschreibung in Zwischenablage kopieren - Copy description to clipboard,

Für die Registerkarte DDL erscheint die Leiste DDL,

damit kann man:

  • DDL-Beschreibung in Datei speichern - Save DDL to file,
  • DDL im SQL-Editor öffnen - Open DDL in SQL Editor.

Mit Hilfe der Navigationsleiste kann man:

  • Datenbank zum Arbeiten auswählen - Dropdownliste Databases,
  • Prozedur zum Bearbeiten auswählen - Object,
  • Inhalt der bearbeitenden Prozedur erneuern - Refresh,
  • Prozedur kompilieren - Compile,
  • In Beschreibung eingetragene Änderungen speichern (der Befehl ist nur dann aktiviert, wenn in Beschreibung auf der Registerkarte Description die Änderungen eingetragen wurden) - Save Descriptions,
  • Prozedur ausführen - Execute Procedure,
  • Transaktion von Daten einsetzen - Commit Transaction (aktiviert, falls die Transaktionen für die Daten Options | Umgebungsoptionen | Werkzeuge | Use transactions in Data tab of object editors, SQL Editor and Query Builder eingeschaltet sind und die Prozedur ausgeführt und das Ergebnis zurückgegeben wurde),
  • Transaktion für Tabellendaten zurücksetzen - Rollback Transaction (aktiviert, falls die Transaktionen für Daten eingeschaltet sind, die Prozedur ausgeführt und das Ergebnis zurückgegeben wurden),
  • Daten exportieren - Export Data (aktiviert nur auf der Registerkarte Data),
  • Daten als SQL-Skript exportieren - Export as SQL Script (aktiviert nur auf der Registerkarte Data),
  • Metadaten der Prozedur drucken - Print Metadata,
  • Daten importieren - Import Data (aktiviert nur auf der Registerkarte Data),
  • MySQL-Hilfe anzeigen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore Default Window Size and Position,


Bearbeiten von Prozedurdefinition

Unter der Registerkarte Edit kann man die Hauptparameter der Prozedur eingeben.

Im Feld Name wird der Name der zu erstellenden Prozedur eingegeben. Dieses Feld kann nur bei der Erstellung eines Objektes bearbeitet werden. Im Abschnitt Procedure type wählt man einen Prozedurtyp aus:

  • Deterministic - deterministische,
  • Not Deterministic - nicht deterministische.

Im Abschnitt SQL security werden die Sicherungsparameter der Prozedur eingegeben:

  • Definer - Prozedur wird der Erstellte verwenden,
  • Invoker - Prozedur wird der Datenbankanwender benutzen

Aus der Dropdownliste SQL Data Access wählt man den Zugriffstyp auf die Daten.

Aus der Dropdownliste Definer wird die Bezeichnung vom Nutzer, dessen Berechtigungen bei der Prozedurausführung verwendet werden, ausgewählt.

In der Tabelle Parameters werden die im Prozedurtext vorgegeben Parameter angezeigt. In dieser Tabelle kann man für den Parameter einen Typ, Namen und Datentyp angeben.

Der Prozedurtext wird im Fenster des SQL-Editors - Definition angegeben.

Im unteren Teil des Formulars befindet sich ein Meldungsfenster, indem die Infos über die Prozedurausführung angezeigt werden.


Bearbeiten von Prozedurbeschreibung

Soll ein Kommentar zur Prozedur hinzugefügt bzw. geändert werden, kann man dies unter der Registerkarte Description vornehmen. Die eingetragenen Änderungen werden lediglich beim Übergehen zur anderen Registerkarte, Auswählen eines anderen Objektes oder Drucken auf die Schaltfläche Save Descriptions auf Navigationsleisten übernommen.


Ausführen von Prozeduren

Der Prozedureditor hilft eine bearbeitende Prozedur auszuführen. Um eine Prozedur auszuführen, verwendet man den Befehl Execute, der sich auf der Navigationsleiste oder auf der Symbolleiste befindet. Enthält die Prozedur die Parameter, dann kann diese im speziellen Fenster Parameterwerte eingeben eingestellt werden. Dieses Fenster erscheint vor der Prozedurausführung.

Wenn die Prozedur ein Ergebnis zurückbringt, z.B. eine Tabelle, dann kann dieses Ergebnis auf der erscheinenden Registerkarte Betrachten von Ergebnissen angesehen werden.


Bestimmen von Eingabeparametern

Enthält die Prozedur die Parameter, wird bei der Ausführung das Fenster Parameterwerte eingeben geöffnet.

In diesem Fenster können alle Parameter der auszuführenden Prozedur eingegeben werden.

SQL Manager 2007 for MySQL bildet dieses Fenster aufgrund der Parametereigenschaften der Prozedur heraus:

  • Menge der Felder im Formular entspricht der Anzahl von Parametern,
  • Bezeichnungen von Parametern sind die Feldernamen, in denen diese benannt werden müssen.
  • Feldertyp wird durch den Parametertyp bestimmt.

Ist neben dem Parameter das Häkchen Null aktiviert, nimmt der Parameter den Wert NULL an, unabhängig davon, was im Bearbeitungsfeld eingetragen wurde.

Die Schaltfläche Ok muss angeklickt werden, um die Prozedurausführung fortzusetzen. Man kann auf die Schaltfläche Cancel drucken, um die Ausführung abzubrechen.


Betrachten von DDL

Unter der Registerkarte DDL können die DDL-Prozeduren betrachtet werden. Der Text kann unter dieser Registerkarte nicht bearbeitet werden. Soll die Prozedur verändert werden, muss man zur Registerkarte Edit übergehen.


Betrachten von Ergebnissen

Diese Registerkarte ist nur dann aktiviert, wenn die Prozedur ausgeführt und ihr Ergebniss zurückgebracht wurde.

Die Ergebnisse der Ausführung werden in Datenansicht angezeigt. Im Fenster, das im unteren Teil untergebracht ist, werden die Servermeldungen über die Prozedurausführungen angezeigt.


Gespeicherte Funktionen

Die gespeicherten Prozeduren sind ein Satz von den SQL-Befehlen, die auf dem Server kompiliert und gespeichert werden können. Sie unterscheiden sich von den gespeicherten Prozeduren dadurch, dass sie nicht die Tabellen-Daten, sondern einen einzelnen Wert zurückgeben können.

Erstellen von Funktionen

Um eine Funktion anzulegen, verwendet man:

  • Punkt Datenbank | Neues Objekt des Programmhauptmenüs. Im Auswahlfenster des Objekttypes muss man Funktion auswählen,
  • bzw. Kontextmenü des Datenbankobjektes Funktionen | Punkt Neue Funktion...,
  • bzw. Tastenkombination <Ctrl + N>.

Die angelegte Funktion wird automatisch im Funktionseditor geöffnet.

Kopieren von Funktionen

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um eine Funktion zu kopieren, muss man den Punkt Funktion duplizieren <Objektname> im Kontextmenü der Funktion auswählen. Soll das Objekt auf solche Weise kopiert werden, dann wird der Assistent zum Objektkopieren im 3. Schritt geöffnet, da in ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.

Bearbeiten von Funktionen

Zum Arbeiten mit den Prozeduren im SQL Manager 2007 for MySQL gibt es ein spezielles Werkzeug - Funktionseditor

Um eine Prozedur im Funktionseditor zu öffnen, reicht ein Doppelmausklick auf ein Objekt im DB-Explorer.

Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Funktion bearbeiten <Objektname> auswählt.

Umbenennen von Funktionen

Soll die Bezeichnung der Funktion verändert werden, dann kann man:

  • Punkt des Kontextmenüs der Funktion Funktion umbenennen <Objektname> auswählen,
  • bzw. die Tastenkombinataion <Ctrl + R> verwenden.

Löschen von Funktionen

Um eine Funktion zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Funktion löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Editor der gespeicherten Funktionen

Dieser Editor hilft die Funktion zu erstellen, auszuführen und zu bearbeiten. Er wird automatisch beim Anlegen einer neuen Funktion bzw. Bearbeiten einer schon bestehenden geöffnet.

  • Verwendung von Navigationsleisten
  • Betrachten von Objektabhängigkeiten
  • Bestimmen von Funktionen
  • Beschreibung der Funktion
  • Funktionausführung
  • Bestimmen von Eingabeparametern
  • Betrachten von DDL

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwendung von Navigationsleisten

Die Navigationsleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Navigationsleiste kann man:

auf der Leiste Object

  • Datenbank auswählen,
  • Funktion zum Bearbeiten auswählen.

auf der Leiste General:

  • Inhalt der bearbeitenden Prozedur erneuern - Refresh,
  • Funktion mit den aktuellen Eigenschaften kompilieren - Compile,
  • Funktion ausführen - Execute procedure,
  • Metadaten der Funktion drucken - Print,
  • MySQL-Hilfe öffnen - Show SQL help,

Beim Übergehen zu den anderen Registerkarten erscheint eine Symbolleiste mit den speziellen Funktionalitäten für jede Registerkarte.

Für die Registerkarte Beschreibung erscheint die Leiste Description,

damit kann man:

  • Beschreibung in Datei speichern - Save Description to file,
  • Beschreibung in Zwischenablage kopieren - Copy description to clipboard

Für die Registerkarte DDL erscheint die Leiste DDL,

damit kann man:

  • DDL-Beschreibung in Datei speichern - Save DDL to file,
  • DDL im SQL-Editor öffnen - Open DDL in SQL Editor.

Mit Hilfe der Navigationsleiste kann man:

  • Datenbank zum Arbeiten auswählen - Dropdownliste Databases,
  • Funktion zum Bearbeiten auswählen - Object,
  • Inhalt der bearbeitenden Funktion erneuern - Refresh,
  • Funktion kompilieren - Compile,
  • In Beschreibung eingetragene Änderungen speichern (der Befehl ist nur dann aktiviert, wenn in Beschreibung auf der Registerkarte Description die Änderungen eingetragen wurden) - Save Descriptions,
  • Funktion ausführen - Execute Procedure,
  • Metadaten der Funktion drucken - Print Metadata,
  • MySQL-Hilfe anzeigen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore Default Window Size and Position,


Bearbeiten von Funktionsdefinition

Unter der Registerkarte Edit kann man die Hauptparameter der Funktion eingeben.

Im Feld Name wird der Namen der zu erstellenden Funktion eingegeben. Dieses Feld kann nur bei der Erstellung eines Objektes bearbeitet werden. Den Typ des zurückgegebenen Wertes wählt man aus der Liste Returns aus.

Aus der Dropdownliste Definer muss man die Bezeichnung vom Nutzer, dessen Berechtigungen bei der Funktionausführung verwendet werden, auswählen.

Im Abschnitt Function type wird ein Funktionstyp ausgewählt:

  • Deterministic - deterministische,
  • Not Deterministic - nicht deterministische.

Im Abschnitt SQL security sind Sicherungsparameter einzugeben:

  • Definer - Funktion wird der Erstellte verwenden,
  • Invoker - Funktion wird der Datenbankanwender benutzen

Aus der Dropdownliste SQL Data Access muss der Zugriffstyp auf die Daten ausgewählt werden.

In der Tabelle Parameters werden die im Funktionstext vorgegeben Parameter angezeigt. In dieser Tabelle kann man für den Parameter einen Typ, Namen und Datentyp angeben.

Der Funktiontext wird im Fenster des SQL-Editors - Definition angegeben.

Im unteren Teil des Formulars befindet sich ein Meldungsfenster, in dem die Infos über die Prozedurausführung angezeigt werden.


Bearbeiten von Funktionsbeschreibung

Soll ein Kommentar zur Prozedur hinzugefügt bzw. geändert werden, kann man dies unter der Registerkarte Description vornehmen. Die eingetragenen Änderungen werden lediglich beim Übergehen zur anderen Registerkarte, Auswählen eines anderen Objektes oder Drucken auf die Schaltfläche Save Descriptions auf Navigationsleisten übernommen.


Ausführen von Funktionen

Der Editor der gespeicherten Funktionen hilft eine bearbeitende Funktion auszuführen. Hierfür wird der Befehl Compile, der sich auf der Navigationsleiste oder auf der Symbolleiste befindet, verwendet. Enthält die Funktion die Parameter, dann können Sie bei der Ausführung diese im speziellen Fenster Parameterwerte eingeben einstellen. Dieses Fenster erscheint vor der Prozedurausführung.


Bestimmen von Eingabeparametern

Enthält die Funktion die Parameter, wird bei der Ausführung das Fenster Enter parameters values geöffnet.

In diesem Fenster können alle Parameter der auszuführenden Prozedur eingegeben werden.

SQL Manager 2007 for MySQL bildet dieses Fenster aufgrund der Parametereigenschaften der Prozedur heraus:

  • Menge der Felder im Formular entspricht der Anzahl von Parametern,
  • Bezeichnungen von Parametern sind die Feldernamen, in denen diese benannt werden müssen.
  • Feldertyp wird durch den Parametertyp bestimmt.

Ist neben dem Parameter das Häkchen Null aktiviert, nimmt der Parameter den Wert NULL an, unabhängig davon, was im Bearbeitungsfeld eingetragen wurde.

Die Schaltfläche Ok wird angeklickt, um die Prozedurausführung fortzusetzen. Man kann auf die Schaltfläche Cancel klicken, um die Ausführung abzubrechen.


Betrachten von DDL

Unter der Registerkarte DDL können die DDL-Funktionen betrachtet werden. Der Text kann unter dieser Registerkarte nicht bearbeitet werden. Soll die Funktion verändert werden, muss man zur Registerkarte Edit übergehen.


Benutzerdefinierte Funktionen(UDFs)

Die benutzerdefinierte Funktion (UDF) ist ein Mittel zur MySQL-Erweiterung mit Hilfe einer neuen Funktion, die ähnlich wie die eingebauten MySQL-Funktionen arbeitet.

Rowset-Funktionen

Es ist eine Funktion vom Rückgabenwert der Tabelle, falls die Klausel RETURNS die Variable TABLE enthält. Unabhängig davon, wie der Funktionskörper bestimmt wurde, werden die Funktionen mit Rückgabenwert der Tabelle in die eingebauten Funktionen und die aus mehreren Anweisungen bestehenden Funktion eingestuft.

Aggregate-Funktionen

Die Aggregate-Funktion operiert mit einer Vielzahl von Werten und gibt einen einzelnen Ergebniswert zurück.

Ranking-Funktionen

Diese Funktion bildet das Ranking (bzw. Rankingwert), das auf die Relevanz der Rückgabendaten hinweist, heraus.

Scalar-Funktionen

Die Funktion ist eine Scalar-Funktion, wenn in ihr der Satz RETURNS, der einem der Scalartypen von Daten entspricht, angegeben wird. Die Scalar-Funktionen können mehrere Anweisungen umfassen.

Erstellen von benutzerdefinierten Funktionen

Um dieses Objekt anzulegen, verwendet man:

  • Punkt Datenbank | Neues Objekt des Hauptmenüprogramms. Im Auswählfenster des Objekttypes muss man Benutzerdefinierte Funktion auswählen,
  • bzw. den Punkt Neue benutzerdefinierte Funktion im Kontextmenü der Gruppe von Datenbankobjekten UDFs,
  • bzw. die Tastenkombination <Ctrl + N>.

Das angelegte Objekt wird automatisch im Editor der benutzerdefinierten Funktionen geöffnet.

Kopieren von benutzerdefinierten Funktionen

Zum Kopieren von Objekten besteht ein spezieller Assistent, da das Objekt in eine andere Datenbank kopiert werden kann. Um eine Funktion zu kopieren, muss man den Punkt Benutzerdefinierten Funktion duplizieren <Objektname> im Kontextmenü der Gruppe von Datenbankobjekten UDFs auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.

Bearbeiten von benutzerdefinierten Funktionen

Zum Arbeiten mit den Funktionen im SQL Manager 2007 for MySQL gibt es ein spezielles Werkzeug: UDF-Editor.

Um ein Objekt im Editor zu öffnen, reicht ein Doppelmausklick auf ein Objekt im DB-Explorer.

Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Benutzerdefinierte Funktion bearbeiten<Objektname> auswählt.

Umbenennen von benutzerdefinierten Funktionen

Soll die Bezeichnung der Funktion verändert werden, kann man:

  • Punkt Benutzerdefinierte Funktion umbenennen <Objektname> des Kontextmenüs der Gruppe von Datenbankobjekten UDFs auswählen,
  • bzw. die Tastenkombintaion <Ctrl + R> verwenden.

Löschen von benutzerdefinierten Funktionen

Um ein Objekt zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Benutzerdefinierte Funktion löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


UDF-Editor

Dieser UDF-Editor hilft die benutzerdefinierten Funktionen zu erstellen und zu bearbeiten. Er wird automatisch beim Anlegen einer neuen Funktion bzw. Bearbeiten einer schon bestehenden geöffnet.

Um eine Funktion im Editor zu öffnen, reicht ein Doppelmausklick.

Die Werkzeuge des Editors befinden sich auf den Registerkarten und Symbolleisten.

Die Registerkarten des Editors sind:

  • Funktionsparameter
  • Betrachten von DDL

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Symbolleisten

Die Symbolleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Navigationsleiste kann man:

auf der Leiste Object

  • Datenbank auswählen,

auf der Leiste General:

  • benutzerdefinierte Funktion mit den aktuellen Eigenschaften kompilieren - Compile,
  • MySQL-Hilfe für die Erstellung einer benutzerdefinierten Funktion öffnen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore default size.

Mit Hilfe der Symbolleiste kann man:

  • Datenbank auswählen,
  • Funktion zum Bearbeiten auswählen,
  • benutzerdefinierte Funktion mit den aktuellen Eigenschaften kompilieren - Compile,
  • MySQL-Hilfe für die Erstellung einer benutzerdefinierten Funktion öffnen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore default size.


Funktionsparameter

Unter der Registerkarte Edit kann man die Parameter der Funktion eingeben.

Im Feld Name wird der Namen der Funktion eingegeben. Den Typ des Rückgabenwertes wählt man aus der Liste Returns aus.

Im Feld Library name wird der Namen der Bibliothekdatei, die den Funktionstext enthält, angegeben.

Ist das Häkchen Aggregate aktiviert, wird die Funktion zur Aggregate-Funktion. Die Aggregate-Funktion operiert mit einer Vielzahl von Werten und gibt einen einzelnen Ergebniswert zurück.


Betrachten von DDL

Unter der Registerkarte DDL kann DDL der benutzerdefinierten Funktionen betrachtet werden. Der Text kann unter dieser Registerkarte nicht bearbeitet werden. Soll der Trigger verändert werden, muss der Text in die Zwischenablage kopiert und in SQL Editor bzw. SQL Skript Editor eingefügt werden.


Geplante Ereignisse

Das geplante Ereignis ist ein Satz von den SQL-Befehlen, das auf dem Server kompiliert und gespeichert werden kann.

Erstellen von geplanten Ereignissen

Um dieses Objekt anzulegen, verwendet man:

  • Punkt Datenbank | Neues Objekt des Hauptmenüprogramms. Im Auswählfenster des Objekttyps muss man Geplantes Ereignis auswählen,
  • bzw.den Punkt Neues geplantes Ereignis im Kontextmenü der Gruppe von Datenbankobjekten Geplante Ereignisse,
  • bzw. die Tastenkombination <Ctrl + N>.

Das angelegte Objekt wird automatisch im Editor der geplanten Ereignisse geöffnet.

Kopieren von Ereignissen

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um ein geplantes Ereignis zu kopieren, muss man den Punkt Geplantes Ereignis duplizieren <Objektname> im Kontextmenü der Gruppe von Datenbankobjekten Geplante Ereignisse auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.

Bearbeiten von geplanten Ereignissen

Zum Arbeiten mit den eingeplanten Ereignissen im SQL Manager 2007 for MySQL gibt es ein spezielles Werkzeug: Editor der geplanten Ereignisse.

Um ein Objekt im Editor zu öffnen, reicht ein Doppelmausklick auf ein Objekt im DB-Explorer.

Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Geplantes Ereignis bearbeiten <Objektname> auswählt.

Umbenennen von geplanten Ereignissen

Soll die Bezeichnung des Ereignisses verändert werden, dann kann man:

  • Punkt Geplantes Ereignis umbenennen <Objektname> des Kontextmenüs der Gruppe von Datenbankobjekten Geplante Ereignisse auswählen,
  • bzw. die Tastenkombination <Ctrl + R> verwenden.

Löschen von geplanten Ereignissen

Um ein Objekt zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Geplantes Ereignis löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Editor der geplanten Ereignisse

Dieser Editor hilft die geplanten Ereignisse zu erstellen und zu bearbeiten. Er wird automatisch beim Anlegen eines neuen Ereignisses bzw. Bearbeiten eines schon bestehenden geöffnet.

Symbolleisten

Parametereingabe des Ereignisses

Betrachten von Objektabhängigkeiten

Beschreibung des geplanten Ereignisses

Betrachten von DDL

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Symbolleisten

Die Symbolleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Navigationsleiste kann man:

auf der Leiste Object

  • Datenbank auswählen,
  • Ereignis zum Bearbeiten auswählen

auf der Leiste General:

  • Inhalte des bearbeitenden Objektes erneuern - Refresh,
  • Ereignis mit den aktuellen Eigenschaften kompilieren - Compile,
  • Metadaten der Funktion drucken - Print,
  • MySQL-Hilfe für die Erstellung der geplanten Ereignisse öffnen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore default size.

Beim Übergehen zu den anderen Registerkarten erscheinen Symbolleisten mit den speziellen Funktionalitäten für jede Registerkarte.

Für die Registerkarte Beschreibung erscheint die Leiste Description,

damit kann man:

  • Beschreibung in Datei speichern - Save Description to file,
  • Beschreibung in Zwischenablage kopieren - Copy description to clipboard

Für die Registerkarte DDL erscheint die Leiste DDL,

damit kann man:

  • DDL-Beschreibung in Datei speichern - Save DDL to file,
  • DDL im SQL-Editor öffnen - Open DDL in SQL Editor.

Mit Hilfe der Navigationsleiste kann man:

  • Datenbank zum Arbeiten auswählen - Dropdownliste Databases,
  • Objekt zum Bearbeiten auswählen - Object,
  • Inhalt des bearbeitenden Ereignisses erneuern - Refresh,
  • Ereignis kompilieren - Compile,
  • Metadaten des Objektes drucken - Print Metadata,
  • MySQL-Hilfe für die Erstelleung der geplanten Ereignisse anzeigen - Show SQL help,
  • Standardgröße des Fensters wiederherstellen - Restore Default Window Size and Position,


Parametereingabe des Ereignisses

Unter der Registerkarte Edit wird der Text und die Zeit der Ausführung eines geplanten Ereignisses eingegeben.

Die Bezeichnung eines geplanten Ereignisses wird im Feld Name eingegeben.

Im Abschnitt Schedule ist die Ausführungszeit und der -Intervall eines geplanten Ereignisses anzugeben.

Mit Hilfe des Schalters At/Every wählt man aus, ob die Aufgabe einmal (At) oder mit dem vorgegebenen Intervall (Every) ausgeführt werden soll.

Wenn der Punkt At ausgewählt wurde:

  • muss man im Feld das Datum und die Zeit der Ausführung angeben
  • muss man im Feld und in der Dropdownliste Interval ein Intervall der Aufgabenausführung eingeben. Zum Beispiel: 1 Stunde.

Wenn der Punkt Every ausgewählt wurde, wird im Feld und in der Dropdownliste das Intervall der Aufgabenausführung und in den Feldern Starts und Ends der Anfang und das Ende der Aufgabenausführung eingegeben.

Die Aufgabe wird ausgeführt, wenn das Häkchen Enabled aktiviert wurde.

Ist On completion not preserve angehakt, wird die Aufgabe nach dem Ausführungsende nicht gespeichert.

Normalerweise wird die Aufgabe nach der Ausführung gelöscht. Sie können die Aktion rückgängig machen, indem Sie das Häkchen On completion not preserve deaktivieren.

Im Fenster SQL-Editor Definition wird der Text einer auszuführenden Aufgabe eingegeben.


Beschreibung des geplanten Ereignisses

Soll ein Kommentar zum Ereignis hinzugefügt bzw. geändert werden, kann man dies unter der Registerkarte Description vornehmen. Die eingetragenen Änderungen werden lediglich beim Übergehen zur anderen Registerkarte, Auswählen eines anderen Objektes oder Drucken auf die Schaltfläche Save Descriptions auf Navigationsleisten übernommen.


Betrachten von DDL

Unter der Registerkarte DDL kann DDL eines geplanten Ereignisses angesehen werden. Der Text kann unter dieser Registerkarte nicht bearbeitet werden. Soll der Trigger verändert werden, muss der Text in die Zwischenablage kopiert und in SQL Editor bzw. SQL Skript Editor eingefügt werden.


Abfragen

SQL Manager 2007 for MySQL bietet zwei Werkzeuge zum Arbeiten mit SQL-Abfragen an:

  • SQL Editor zum Bearbeiten von Abfragetexten,
  • Visueller Query Builder zum visuellen Erstellen von Abfragen.

Erstellen von Abfragen:

Im Abfrageneditor,

Um dieses Objekt zu erstellen,

  • verwendet man den Punkt Werkzeuge | Neuer SQL Editor des Programm-Hauptmenüs,
  • bzw. drückt man auf die Schaltfläche Neuer SQL Editor [image] auf der Standardleiste der Programmwerkzeuge,
  • bzw. verwendet man die Tastenkombination <Shift+F12>.

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im SQL-Editor geöffnet.

Im Visuellen Query Builder.

Um dieses Objekt zu erstellen,

  • verwendet man den Punkt Werkzeuge| Neuer Query Builder des Programm-Hauptmenüs,
  • bzw. drückt man auf die Schaltfläche Neuer Query Builder [image] auf der Standardleiste der Programmwerkzeuge,

Nach der Ausführung einer diesen Operationen wird automatisch der Visuellen Query Builder geöffnet.

Bearbeiten von Abfragen:

Im Abfrageneditor,

Um eine zum Bearbeiten erstellte Abfrage zu öffnen,

  • wird der Punkt Werkzeuge| SQL Editor anzeigen des Programm-Hauptmenüs verwendet,
  • bzw. drückt man auf die Schaltfläche SQL Editor anzeigen [image] auf der Standardleiste der Programmwerkzeuge,
  • bzw. verwendet man die Tastenkombination <F12>.

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im SQL-Editor geöffnet.

Im visuellen Query Builder.

Um eine zum Bearbeiten erstellte Abfrage zu öffnen,

  • wird der Punkt Werkzeuge | Query Builder anzeigen des Programm-Hauptmenüs verwendet,
  • bzw. drückt man auf die Schaltfläche Query Builder anzeigen [image] auf der Standardleiste der Programmwerkzeuge.

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im Visuellen Query-Builder geöffnet.

Abfrageausführung

Um eine Abfrage in jedem Editor auszuführen, muss man:

  • neue Abfrage erstellen bzw. eine schon bestehende Abfrage öffnen
  • die Schaltfläche Execute query auf der Navigationsleiste bzw. auf der Symbolleiste des Editors oder die Schaltfläche F9 anklicken
  • betrachten und die erhaltenen Daten auf der Registerkarte Results bearbeiten.

Speichern von Abfragen

Um eine Abfrage zu speichern, muss man:

  • neue Abfrage erstellen bzw. eine schon bestehende Abfrage öffnen
  • den Punkt Save to file auf der Navigationsleiste des Abfrageeditors bzw. den Punkt Save diagram auf der Navigationsleiste des Visuellen Query Builder verwenden.
  • in dem erscheinenden Fenster auswählen, in der die Datei bzw. der Typ der gespeicherten Datei gespeichert werden muss.

Zum Speichern mehrerer Abfragen in einer Datei, drückt man auf Save All auf der Navigationsleiste des Abfrageneditors. Für den Visuellen Query Builder besteht keine solche Funktion.


SQL-Editor

Der SQL-Editor ist ein Hauptwerkzeug des Programms SQL Manager 2007 for MySQL zum Arbeiten mit den Abfragen. Das Tool ermöglicht die Abfragen zu erstellen, zu bearbeiten und diese auszuführen. Darüber hinaus kann man mit seiner Hilfe die Ergebnisse der Abfrageausführung anschauen.

Zum Erstellen von Abfragen im SQL-Editor muss man eine der nachfolgenden Operationen vornehmen:

  • Punkt Tools | New SQL Editor des Hauptmenüs auswählen,
  • bzw. den Button New SQL Editor [image] auf der Standardleiste von Programmwerkzeugen anklicken,
  • bzw. die Tastenkombination <Shift+F12> verwenden.

Zum Öffnen von einer bereits bestehenden Abfrage im SQL-Editor muss man:

  • Punkt Tools | Show SQL Editor des Hauptmenüs auswählen,
  • bzw. den Button Show SQL Editor [image] auf der Standardleiste von Programmwerkzeugen anklicken,
  • bzw. die Taste <F12> verwenden.

Die in Datei gespeicherten Abfragen werden im Editor mit Hilfe des Befehles Load from file [image] , der sich auf der Navigationsleiste des Editors und auf der Symbolleiste befindet, geöffnet.

Verwenden von Navigationsleisten

Arbeiten mit dem Editor-Bereich

Kontextmenüs

Betrachten des Abfrageplanes

Abfrageausführung und Betrachten derer Ergebnisse

Siehe auch:

Visueller Query-Builder

SQL Skript Editor

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwenden von Navigationsleisten

Die Navigationsleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Navigationsleiste kann man:

Auf der Leiste Database:

  • Datenbank, für die die Abfrage erstellt wird, auswählen

Auf der Leiste General:

  • aktuelle Abfrage ausführen - Execute query,
  • Abfrage in Form eines Planes auf einer speziellen Leiste öffnen - Explain query,
  • neue Abfrage erstellen - Add new query,
  • aktuelle Abfrage löschen - Delete current query,
  • alle im Editor geöffneten Abfragen löschen - Clear all queries,
  • aktuelle Abfrage umbenennen - Rename current query,
  • Visuellen Query-Builder starten (in diesem Builder wird keine Abfrage, die im Editor geöffnet ist, geöffnet, sondern die, die zuletzt im Query-Builder bearbeitet wurde) - Run Query Builder,
  • Abfrageeditor einstellen - SQL Editor Options,
  • Ergebnisse der Abfrage auf derselben/auf anderer Registerkarte anzeigen - Results on Edit tab/Results on separate tab.
  • Standardgröße wiederherstellen - Restore default size,

Auf der Leiste Queries:

  • Add new query - neue Abfrage hinzufügen,
  • Rename current query - aktuelle Abfrage umbenennen,
  • Remove current query - aktuelle Abrage löschen,
  • Remove all queries - alle Abfragen löschen,

Add to Favorite Queries - Abfrage in Favorisierte Abfragen hinzufügen.

Auf der Leiste Edit:

  • Abfrage aus Datei laden - Load from file,
  • aktuelle Abfrage in Datei speichern - Save to file,
  • alle geöffneten Abfragen gleichzeitig speichern - Save all.

Beim Übergehen zu den anderen Registerkarten erscheinen Symbolleisten mit den speziellen Funktionalitäten für jede Registerkarte.

Für die Registerkarte Data erscheint die Leiste Data management,

  • Transaktion von Daten verwenden - Commit Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind Options | Environment Options | Tools | Use transactions in Data tab of object editors, SQL Editor and Query Builder),
  • Transaktion für Tabellendaten rückgängig machen - Rollback Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind),
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten importieren - Import Data.

Für die Registerkarte Logs erscheint die Leiste Logs. Auf dieser Leiste kann man:

  • Text im Log finden - Find text,
  • Logs in Datei speichern - Save logs to file,
  • Logs leeren - Clear logs.

Die Werkzeugsleiste befindet sich über den Abrageeditor.

Mit der Werkzeugsleiste kann man:

  • Datenbank, für die die Abfrage erstellt wird, auswählen - Dropdownliste Databases,
  • Abrage aus Datei laden - Load from file,
  • aktuelle Abfrage in Datei speichern - Save to file,
  • alle geöffneten Abfragen gleichzeitig speichern - Save all,
  • Abfrageeditor einstellen - SQL Editor Options,
  • Standardgröße wiederherstellen - Restore default size,
  • Text im Log finden - Find text,
  • aktuelle Abfrage ausführen - Execute query,
  • Abfrageausführung abbrechen - Cancel Query Execution,
  • Abfrage in Form eines Planes auf einer speziellen Leiste öffnen - Explain query,
  • Ergebnisse der Abfrage auf derselben/auf anderer Registerkarte anzeigen - Results on Edit tab/Results on separate tab,
  • Visuellen Query-Builder starten (in diesem Builder wird keine Abfrage, die im Editor geöffnet ist, geöffnet, sondern die, die zuletzt im Query-Builder bearbeitet wurde) - Run Query Builder,
  • neue Abfrage erstellen - Add new query,
  • aktuelle Abfrage löschen - Delete current query,
  • alle im Editor geöffneten Abfragen löschen - Clear all queries,
  • aktuelle Abfrage umbenennen - Rename Current Query,
  • Transaktion von Daten verwenden - Commit Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind Options | Environment Options | Tools | Use transactions in Data tab of object editors, SQL Editor and Query Builder),
  • Transaktion für Tabellendaten rückgängig machen - Rollback Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind),
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten importieren - Import Data.


Arbeiten mit dem Editor-Bereich

Im Hauptfenster können die Abfragen erstellt und gelöscht werden.

Hauptbesonderheiten:

  • Darstellen von Objektnamen als Links auf diese Objekte,
  • Aufrufen und Einstellen der Liste der Code-Vervollständigung,
  • Zeilennummern,
  • Reduzieren von Abfragen und Unterabfragen,
  • Bestimmen von Eigenschaften der ausgewählten Objekte,
  • Einstellen der Felder und Zeilennummern,
  • Änderung von Parametern der verschiedenen Objekten der Textabfrage,
  • Einstellen von automatischem Formatieren des Abfragetextes,
  • Bestimmen der Tastenkombinationen für eine schnelle Texteingabe und Befehlausführung.

Die Hauptwerkzeuge zum Einstellen des Editors befinden sich auf den nachfolgenden Registerkarten:

  • General,
  • Display,
  • Color,
  • Quick Code,
  • SQL Formatter,
  • Key Mapping.

Das Objekt kann man in die Abfrage aus dem DB-Explorer direkt hereinbringen, indem man dies mit der Maus aus dem Explorerfenster bzw. SQL -Assistenten in den Editor zieht. In diesem Fall erscheint ein Dialogfenster, in dem man die Anweisung für dieses Objekt angeben muss.


Abfrageausführung

Um eine Abfrage auszuführen, muss man Execute auf einer der Werkzeugsleisten bzw. Kontextmenü anklicken. Enthält der Abfragetext die Fehler, weist das Programm darauf hin. Bevor nicht alle Fehler behoben werden, ist das Ergebniss nicht verfügbar.

Falls die Abfrage die Daten zurückgeben wird (im Text gibt es SELECT), dann wird im Editor eine neue Registerkarte Results, auf der die erhaltenen Ergebnisse sichtbar werden, erscheinen.

Unter dieser Registerkarte werden die von der Abfrage zurückgegebenen Daten in der Datenansicht angezeigt. Der Betrachter erlaubt, Daten zu exportieren und Daten als SQL-Skript zu exportieren.

Wenn bei der Abrageausführung die Fehler auftreten, wird ihre Beschreibung ins Info-Fenster, das sich im unteren Teil des Editors befindet, eingetragen. Der Doppelklick auf dem Fehler aktiviert die Zeile, in der dieser Fehler entdeckt wurde.


Kontextmenü

Für den Editor des Abfragetextes besteht ein spezielles Kontextmenü, das durch das Betätigen der rechten Maustaste auf der beliebigen Position des Editor-Bereiches aufgerufen wird. Dieses Menü ermöglicht, die oft benutzenden Befehle schnell zu verwenden.

Mit dem Kontextmenü kann man:

  • Abfrage ausführen - Execute Query,
  • Nur ausgewählte ausführen - Execute Selected Only,
  • Ausführen under Cursor - Execute under Cursor,
  • Ausführungspunkt zurücksetzen - Reset Execution Point,
  • Lesezeichen ein/ausschalten - Toggle Bookmarks,
  • Zum Lesezeichen gehen - Goto Bookmarks,
  • Aktion rückgängig machen- Undo,
  • Aktion wiederholen- Redo,
  • Ausgewählte ausschneiden- Cut,
  • Ausgewählte kopieren- Copy,
  • Einfügen- Paste,
  • Alles auswählen- Select All,
  • Finden - Find,
  • Finden und ersetzen - Replace,
  • Weitersuchen - Search Again,
  • Zu Zeilennummer gehen... - Go To Line By Number...,
  • Zu Groß/Kleinbuchstaben wechseln - Change Case,
  • Laden aus Datei - Load from File...,
  • Speichern in Daten - Save to File...,
  • Vorschau - Preview,
  • Drucken - Print,
  • SQL-Abfrage formatieren (dabei werden die in den SQL-Formatter eingetragenen Änderungen übernommen) - Format SQL,
  • Ausgewählter Text in Kommentare umsetzen - Toggle Comment,
  • Eigenschaften betrachten und in Editoroptionen ändern - Properties.


Betrachten des Abfrageplanes

Auf dieser Registerkarte wird die Reihenfolge der Aktionen, die im System bei der Abfrageausführung ausgeführt werden, dargestellt. Die nützlichen Infos über jeden Schritt der Ausführung werden in den Eigenschaftsfenstern, die sich rechts und unten des Hauptfensters befinden, angezeigt.

Im rechten Teil ist das Eigenschaftsfenster zu sehen:

  • in der Spalte Properties werden die Eigenschaften angezeigt,
  • in der Spalte Values werden die Werte angezeigt.

Im unteren Teil des Fensters befindet sich die Struktur des Abfrageplanes. In den Spalten sind die nachfolgenden Eigenschaften jedes Planelementes dargestellt:

  • Operationen - Operation,
  • Logische Operation - Logical operation,
  • Kosten des Verzweigungsbereiches - Subtree Cost,
  • I/O-Kosten - IO Cost,
  • CPU-Kosten - CPU Cost,
  • Ausführungen - Executions,
  • Zeilen - Rows,
  • Zeilengröße - Row Size,
  • Parallel - Parallel,
  • Anweisung - Statement,
  • Argument - Argument,
  • Definierte Werte - Defined Values,
  • Ausgabe - Output,
  • Warnungen - Warnings.


Logs

Alle Operationen, die durch Abfrage ausgeführt werden, trägt das Programm in Protokolldateien - Logs ein. Die werden auf der Registerkarte Logs des SQL-Editors angezeigt.

Ins Protokoll werden folgende Infos eingetragen:

  • Datum der Abfrageänderung,
  • Abfragetext,
  • Fehler, die bei der Ausführung auftreten (falls solche aufgetreten sind)
  • Gab es keine Fehler, dann werden die Infos über das Ergebniss der Abfrageausführung angezeigt.

Die zusätzlichen Infos über die Ausführung werden in Form der Kommentare angezeigt. Das ermöglicht, den Abfragentext zu kopieren und diesen auszuführen. Alle zusätzlichen Infos werden keine Fehler verursachen.


Visueller Abfrage-Generator

Dieses Tool ermöglicht die Abfragen grafisch ohne derer textuelle Beschreibung auf SQL-Sprache zu erstellen. Man kann die Abfragen erstellen, diese ausführen und die Ergebnisse betrachten, wenn die grafischen Methoden des Visuellen Query-Builders eingesetzt werden. Des weiteren kann man mit Hilfe des Visuellen Query-Builders die grafische Darstellung einer Abfrage, die in textueller Form verfasst wurde, erhalten. Hierfür muss der Abfragetext ins Edit-Fenster eingefügt werden.

Zum Erstellen einer Abfrage im Query-Builder muss eine der nachfolgenden Operationen ausgeführt werden:

  • der Punkt Tools | New Query Builder (zu dt. Werkzeuge | Neuer Query Builder) des Hauptmenüs muss ausgewählt werden;
  • bzw. drückt man auf den Button New Query Builder (zu dt. Neuer Query Builder) [image] auf der Standardleiste der Programmwerkzeuge

Nach der Ausführung einer dieser Operationen wird die Abfrage automatisch in dem Visuellen Query-Builder geöffnet.

Die Hauptwerkzeuge des Query-Builders:

Navigationsleisten

Diagrammfenster

Herstellen von Relationen

Bestimmen von Kriterien

Ausgabefelder

Kriterien der Gruppierung

Sortierungsparameter

Edit-Fenster

Abfrageausführung

Siehe auch:

Abfrageeditor

Visueller Datenbank-Designer

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwenden von Navigationsleisten

Die Navigationsleisten befinden sich links vom Editor und über dem Editor.

Mit Hilfe der Navigationsleiste kann man:

Auf der Leiste Database:

  • Datenbank, für die die Abfrage erstellt wird, auswählen

Auf der Leiste General:

  • aktuelle Abfrage ausführen - Execute query,
  • Abfrage in Form eines Planes auf einer speziellen Leiste öffnen - Explain query,
  • aktuelle Abfrage löschen - Clear query,
  • View erstellen - Create View,
  • MySQL-Hilfe anzeigen - Show SQL help.
  • Visuellen Query-Builder einstellen - Query Builder Options,
  • Druckparameter eingeben - Print setup,
  • Vorschau drucken - Print preview.

Auf der Leiste Visual Builder:

  • Diagramm laden - Load Diagram,
  • Diagramm speichern - Save Diagram.

Auf der Leiste Data Management:

  • Transaktion von Daten verwenden - Commit Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind Options | Environment Options | Tools | Use transactions in Data tab of object editors, SQL Editor and Query Builder),
  • Transaktion für Tabellendaten rückgängig machen - Rollback Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind),
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten in Datei speichern - Save data to a file.

Auf der Leiste Object ist die Liste aller Objekte, die in der Datenbank enthalten sind, dargestellt. Diese kann man im Diagramm verwenden. Die Objekte können aus diesem Fenster ins Diagrammfenster durch Drag & Drop übertragen werden.

Beim Übergehen zu den anderen Registerkarten erscheinen Symbolleisten mit den speziellen Funktionalitäten für jede Registerkarte.

Für die Registerkarte Edit erscheint die Leiste Edit.

Damit kann man:

  • SQL-Text der Abfrage aus Datei laden - Load SQL,
  • Abfragetext in Datei speichern - Save query.

Mit der Werkzeugsleiste kann man:

  • Datenbank, für die die Abfrage erstellt wird, auswählen - Dropdownliste Databases,
  • aktuelle Abrage löschen - Clear query,
  • Abfrage aus Datei laden - Load query (mit Hilfe der Dropdownliste können Sie auswählen, ob eine Abfrage als SQL bzw. ein Diagramm geladen werden muss),
  • Abfrage in Datei speichern - Save query (mit Hilfe der Dropdownliste können Sie auswählen, in welcher Form die Abfrage geladen werden muss: als SQL-Text bzw. als Diagramm),
  • aktuelle Abfrage ausführen - Execute query,
  • Abfrageausführung abbrechen - Cancel Query Execution,
  • View erstellen - Create View,
  • Transaktion von Daten verwenden - Commit Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind Options | Environment Options | Tools | Use transactions in Data tab of object editors, SQL Editor and Query Builder),
  • Transaktion für Tabellendaten rückgängig machen - Rollback Transaction (aktiviert, falls die Transaktionen für die Daten eingeschaltet sind),
  • Druckparameter eingeben - Print setup,
  • Vorschau drucken - Print preview,
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten in Datei speichern - Save data to a file.
  • Darstellung der Objekte einstellen - Show objects (aus der Dropdownliste können Sie auswählen, welche Objekte auf der Leiste Object angezeigt werden),
  • MySQL-Hilfe anzeigen - Show SQL help,
  • Standardgröße wiederherstellen - Restore default size.


Arbeiten mit dem Diagrammfenster

Die Hauptoptionen werden auf der Leiste Builder des Visuellen Query-Builders ausgeführt. Das Hauptwerkzeug ist der Builder-Bereich.

Hinzufügen des Objektes in den Builder-Bereich

Die Tabellen werden in den Builder-Bereich übertragen. Um eine Tabelle in den Builder-Bereich hinzuzufügen, muss man diese aus dem DB-Explorer bzw. aus der Liste auf der Leiste Object, die sich auf der Navigationsleiste befindet, ziehen. Das Objekt, das auf der Leiste Object angezeigt wird, kann man in den Builder-Bereich durch einen Doppelmausklick hinzufügen.

Auswählen von Feldern

Um die Tabellenfelder bzw. Views in die zu erstellende Abfrage hinzuzufügen, muss man dieses Feld anhaken bzw. das Feld durch einen Doppelmausklick auswählen. Alle aktivierten Felder geraten in die Abfrage. Um alle Objektfelder direkt in die Abfrage hinzuzufügen, muss man ein Häkchen vor der Objektbezeichnung in die Kopfzeile einsetzen.

Löschen des Objektes aus dem Builder-Bereich

Um das Objekt aus dem Builder-Bereich zu löschen, muss man eine der nachfolgenden Operationen ausführen:

  • Button "Schließen" [image] in der Überschrift des Objektes anklicken,
  • Punkt Delete des Kontextmenüs, das durch das Betätigen der rechten Maustaste auf der Überschrift des Objektes geöffnet wird, auswählen.

Das Objekt wird nur aus dem Builder-Bereich gelöscht werden. In der Datenbank wird es beibehalten.

Umbenennen des Objektes

Das Objekt lässt sich mit Hilfe des Kontextmenüpunktes Rename, das durch das Betätigen der rechten Maustaste auf der Überschrift des Objektes geöffnet wird, öffnen. Man kann ebenso zweimal auf die Bezeichnung des Objektes klicken.

Herstellen von Relationen

Unter dem Builder-Bereich liegt das Fenster fürs Arbeiten mit den Feldern.

Damit kann man:

  • Kriterien zum Auswählen von Daten in der Abfrage bestimmen,
  • auswählen, welche Felder als Ergebnis der Abfrage ausgegeben werden,
  • Kriterien der Gruppierung einstellen,
  • Sortierungsparameter eingeben.

Links von dem Builder-Bereich befindet sich die Struktur der Unterfragen.

Darin werden die eingebetteten Abfragen und zusammengesetzten Abfragenteile angezeigt: UNION und UNION ALL.

Im unteren Teil des Fensters befindet sich die Informationsleiste. Wurde die Abfrage erfolgreich ausgeführt, wird dort ein kurzes Ausführungsergebnis eingetragen. Falls nicht, wird dort die Fehlermeldung angezeigt.


Herstellen von Relationen

In relationalen Datenbanken müssen die Relationen zwischen den Tabellen hergestellt werden.

Der Visuelle Query-Builder hilft schnell die Relationen unter den in den Builder-Bereich hinzugefügten Objekten herzustellen.

Um eine Relation zwischen den Tabellen zweier Feldern herzustellen, muss man das Feld aus einer Tabelle in eine andere übertragen (Felder sind als Liste, wo jede Zeile ein Feld ist, dargestellt). Nach Drag & Drop wird die Relation als schwarze Linie, die die gewünschten Felder verbindet, angezeigt.

Linkeigenschaften

Die Linkeigenschaften kann man bearbeiten. Hierfür muss man den Linkeditor öffnen, entweder durch einen Doppelmausklick oder den Kontextmenüpunkt der Linkeigenschaften Properties.

In dem erscheinenden Fenster werden die gewünschten Eigenschaften des bearbeitenden Links eingegeben.

  • Linkbedingungen werden aus der Dropdownliste, die sich zwischen den Feldernamen (=, >, <, >=, <=, <>) befinden, ausgewählt.
  • Mit dem Häkchensetzen wird der Linktyp angegeben. Wenn der Punkt aktiviert ist, dann ist der Linktyp "eins zu mehreren".

Mit dem Kontextmenü kann man:

  • Insert point - einen Punkt in der Linklinie erstellen. Damit kann diese Linie für eine komfortable grafische Darstellung verschoben werden.
  • Delete link - Link löschen,
  • Property - Linkeigenschaften bearbeiten.


Bestimmen von Kriterien

Auf der Leiste Criteria können die Kriterien zum Auswählen von Daten in der Abfrage bestimmt werden.

Um eine Einschränkungsbedingung hinzuzufügen, muss man den Button [image] im Formular anklicken und aus dem erscheinenden Kontextmenü den Punkt Add condition auswählen. Es wird eine Zeile hinzugefügt, der die laufende Nummer zugewiesen wird. In dieser Zeile müssen Sie das Auswahlkriterium angeben.

Zur Angabe des Typs von der zusammengesetzten Bedingung drückt man auf die Überschrift All. Dies befindet sich neben der Schaltfläche [image] . Danach wird einer aus den angebotenen Typen ausgewählt.

Nach dem Drücken auf die Dropdownliste [image] werden die Listen geöffnet. Diese bestehen aus allen Objektfeldern, die an der Abfrage teilnehmen. Das können sowohl die Feldernamen, als auch die Konstanten bzw. Ausdrücke sein.

Beim Klicken auf [image] erhalten Sie die Möglichkeit, die Korrelationen zwischen den Anweisungen herzustellen.

Die Bedingung lässt sich mit Hilfe des Kontextmenüs verwalten. Das Kontextmenü wird beim Klicken der linken Maustaste auf die laufende Nummer geöffnet.

Mit diesem Menü kann man:

  • neue Bedingung hinzufügen - Add condition,
  • zusammengesetzte Bedingung machen - Make composite condition,
  • Bedingung löschen - Delete condition,
  • Bedingung erweitern - Expand condition.

(Dieser Punkt ist aktiviert, wenn die zusammengesetzten Bedingungen hinzugefügt sind. Wenn die Bedingung erweitert ist, dann wird dieser Punkt durch "Bedingung reduzieren" - Collapse condition ersetzt).

Klickt man mit der rechten Maustaste in eine beliebige Position der Bedingung, dann wird ein Menü mit dem folgenden Punkt erscheinen - Insert query. Wenn man diesen Punkt anklickt, wird eine eingebettete Abfrage erstellt. Damit kann man, ähnlich wie mit der Hauptabfrage, arbeiten. Die Hierarchie der Abfragen wird in der Struktur der Unterabfragen, die sich links vom Builder-Bereich befindet, angezeigt. Ist eine Unterabfrage erstellt, wird die Bedingung so aussehen: . Der erste Bedinungsoperator nach dem Bindungssymbol gibt den Abfrageparameter an. Im zweiten wird der Anfang der eingebetteten Abfrage dargestellt. Den Abfrageparameter kann man aus der Liste, die beim Klicken auf die linke Maustaste geöffnet wird, auswählen.

Die Abfrage kann man mittels des Kontextmenüpunktes Delete query löschen. Dieses Kontextmenü wird beim Drücken der rechten Maustaste auf die Bedingung, die Unterabfragen enthält, geöffnet. Damit kann man:

  • Unterabfrage löschen - Delete query,
  • Unterabfrage öffnen - Show query.


Ausgabefelder

Auf dieser Regiesterkarte wird die Ausgabeform der Abfrage herausgebildet.

Es wird angegeben, welche Felder nach der Abfrageausführung angezeigt und wie diese sortiert und gruppiert werden.

Man kann ebenso die berechneten Felder erstellen.

  • In der Spalte Name of output ist ein Feldalias, unter dem das Feld im Abfrageergebnis ausgegeben wird, angegeben.
  • Die Spalte Aggregate enthält eine Aggregatfunktion.
  • Source field name enthält die Quellnamen der Spalten, die als Abfrageergebnis ausgegeben werden.
  • Grouping gibt an, ob die Spalte gruppiert ist oder nicht.

Bei Aktivierung des Select only unique records werden als Abfrageergebnis nur unikale Datensätze angezeigt.

Die Hauptaktionen mit den Feldern werden mit Hilfe des Kontextmenüs, das beim Klicken auf dem Feld mit der rechten Maustaste, geöffnet wird, ausgeführt.

Mit Hilfe dieses Menüs werden folgende Operationen ausgeführt:

  • Löschen einer ausgewählten Zeile - Delete current row,
  • Einfügen einer eingebetteten Abfrage - Insert Query,
  • Einfügen eines berechneten Feldes - Insert CASE.

Die Felder kann man auch sortieren, indem man mit der linken Maustaste auf den Kopf der Spalte, in der die Felder enthalten sind, klickt. Die Reihenfolge der Felder wird im Abfrageergebnis ihrer Folge in dieser Tabelle entsprechen. Die eingebettete Abfrage wird auf einer separaten Registerkarte des Builder-Bereichs zum Editieren geöffnet und in der Struktur der Unterabfragen im linken Teil des Visuellen Builders angezeigt.


Kriterien der Gruppierung

Unter dieser Registerkarte werden die Kriterien, nach deren die nach der Abfrageausführung erhaltenen Daten gruppiert werden, angegeben.

Um ein Kriterium der Gruppierung hinzuzufügen, drückt man auf den Button [image] im Formular und aus dem erscheinenden Kontextmenü wird der Punkt Add condition ausgewählt. Es wird ein Punkt, dem eine laufende Nummer zugewiesen wird, hinzugefügt. In dieser Zeile müssen die Bedingung der Gruppierung angegeben werden.

Um einen Typ der Bedingung anzugeben, klickt man auf die Überschrift All, die neben mit dem Symbol [image] liegt und wählt man einen aus den angebotenen Typen aus. Beim Klicken auf die Dropdownlisten [image] werden die Listen, die aus allen Feldern von an der Abfrage teilnehmenden Objekten bestehen, geöffnet. In diesen Feldern können die Bedingungsoperatoren angegeben werden. Das können sowohl die Feldernamen, als auch die Konstanten bzw. Ausdrücke sein.

Die Aggregatfunktion werden aus der Liste [image] ausgewählt.

Beim Klicken auf [image] erhält man die Möglichkeit, die Korrelationen zwischen den Anweisungen herzustellen.

Die Gruppierungsbedingung lässt sich mit Hilfe des Kontextmenüs verwalten. Das Kontextmenü wird beim Klicken der linken Maustaste auf die laufende Nummer geöffnet.

Mit diesem Menü kann man:

  • neue Bedingung hinzufügen - Add condition,
  • zusammengesetzte Bedingung machen - Make composite condition,
  • Bedingung löschen - Delete condition,
  • Bedingung erweitern - Expand condition.

(Dieser Punkt ist aktiviert, wenn die zusammengesetzten Bedingungen hinzugefügt sind. Wenn die Bedingung erweitert ist, dann wird dieser Punkt durch "Bedingung reduzieren" - Collapse condition ersetzt).


Sortierungsparameter

Das Fenster für das Arbeiten mit den Feldern befindet sich unter dem Builder-Bereich. In diesem Fenster gibt es eine spezielle Registerkarte, auf der die Sortierungsparameter von Feldern in der Abfrage angegeben werden können.

Die Liste Output fields enthält alle Objektfelder, die an der Abfrage teilnehmen. Um anzugeben, nach welchem Feld die nach der Abfrageausführung erhaltene Tabelle sortiert wird, muss man die Felder aus der Liste Output fields in die Liste Sorted fields übertragen. Das kann man entweder mit Hilfe der Schaltflächen oder durch Drag & Drop des ausgewählten Elementes verwirklichen.

In der Liste Sorted fields sind die Sortierungsparameter für ausgewählte Felder anzugeben:

  • Ordnung der Sortierung "Aufsteigend" ("Ascending") bzw. "Absteigend" ("Descending") wird im Feld Sort order mit Hilfe der Schaltfläche A...Z angegeben.
  • Reihenfolge der Sortierung (nach welchem Feld muss das Sortieren zuerst und nach welchem danach sortiert werden) wird mittels der Reihenfolge der Felder in der Liste Sorted fields angegeben. Nach dem ersten Feld wird das Sortieren in der Liste ausgeführt usw. Mit Hilfe der Schaltflächen Up und Down können die Felder in der Liste verschoben werden.


Arbeiten mit den Edit-Fenstern

Im Edit-Fenster wird automatisch den Abfragetext erstellt. In diesem Fenster kann man sich die Abfrage anschauen und diese korrigieren. Alle Änderungen werden im Diagrammfenster angezeigt.

Alles, was im Abfragetext grün markiert ist, stellt die Links für Objekte dar.

Um ein Objekt zur Ansicht zu öffnen, das im Text auf einen Link verweist, muss die linke Maustaste gleichzeitig mit der Taste Button Strg betätigt werden. Soll in diesem Editor ein Abfragetext erstellt werden, wird diese Abfrage in diesem Builder-Bereich grafisch dargestellt.

Mehr Infos zum Arbeiten mit dem Edit-Fenster des SQL-Textes


Abfrageausführung

Um eine Abfrage auszuführen, muss man Execute auf einer der Navigationsleisten drücken.

Bei der Abfrageausführung wird eine neue Registerkarte Results, auf der die erhaltenen Ergebnisse zu sehen sind, erscheinen. Unter dieser Registerkarte werden die Rückgabedaten in der Datensicht angezeigt. Mit Hilfe des Assistenten kann man die Daten exportieren und die Daten als SQL-Skript exportieren.


Abfrageparameter

Der SQL-Editor und der Visuelle Query-Builder ermöglichen die Parameter im Abfragetext zu verwenden.

Der Parameter ist eine Variable, deren Wert direkt vor der Abfrageausführung bestimmt werden kann. Im Abfragetext sind die Parameter mit dem Zeichen ":", das vor dem Parameter gesetzt wird, markiert.

:param1

Hinweis: Um die Parameter zu verwenden, muss man das Häkchen Allow using of parameters in query text in Options | Environment options | Tools (zu dt. Parameter im Abfrage-Text erlauben in Optionen | Umgebungsoptionen | Tools) aktivieren.


Eingabefenster der Parameter

Der Parameter ist eine Variable, deren Wert direkt vor der Abfrageausführung bestimmt werden kann. Im Programm SQL Manager 2007 for MySQL steht zur Verfügung ein spezielles Werkzeug zur Verfügung, mit dessen Hilfe die Parameter bei der Abfrageausführung eingegeben werden können.

Das Fenster Input Parameters wird aufgrund der im Abfragetext eingegeben Parameter gestaltet.

Für jeden Parameter wird ein Eingabefeld, das ähnlich wie der Parameter benannt wird, erstellt.

Für verschiedene Feldertypen sind spezielle Eingabefelder von Parametern bestimmt.

Für den Feldertyp wie datetime erscheint z. B. ein Kalender, das die Fehler bei der Dateneingabe vermeiden lässt.

Für Zahlentypen ist ein Rechner verfügbar.

In diesem Feld kann man den Parameterwert eingeben oder man lässt ihn weg.

Beim Drücken der Schaltfläche Ok kann man die Abfrageausführung unter Berücksichtigung der eingegeben Parameter fortsetzten. Klickt man Cancel an, so wird die Abfrage abgebrochen.


Favorisierte Abfragen

SQL Manager 2007 for MySQL ermöglicht einen schnellen Zugriff auf die Abfragen bzw. einige Abfrageteilen mit Hilfe des Werkzeuges Favorite Queries (zu dt. Favoritenabfragen)

Neue Favoritenabfrage erstellen

Um eine neue Favoritenabfrage zu erstellen, muss man:

  • im DB-Explorer aus dem Kontextmenü der Objektgruppe Favorite Query (zu dt. Favoritenabfrage) den Punkt New Favorite Query (zu dt. Neue Favoritenabfrage) auswählen,
  • den ausgewählten Abfragetext in den Ordner Favorite Query (zu dt. Favoritenabfrage) übertragen, dabei wird der Editor der favorisierten Abfragen geöffnet.

Editor der favorisierten Abfragen

Dieser Editor wird nur in dem Fall geöffnet, wenn im Kontextmenü der Favoritenabfrage den Punkt Edit Favorite Query ausgewählt wird. Wenn die Abfrage mit einem Doppelmausklick geöffnet wird, wird diese im SQL-Editor geöffnet.

Mit Hilfe des Editors kann man die Favoritenabfrage erstellen und bearbeiten.

Im Feld Name wird der Abfragenamen angegeben.

Aus der Dropdownliste Storage wählt man den Speicherplatz aus.

Im SQL-Editor kann man mit dem Abfragetext ähnlich wie im SQL-Editor arbeiten.


Verwalten von Daten

Die in den Tabellen gespeicherten Daten und die Abfrageergebnisse, die auf den speziellen Editor-Registerkarten angezeigt werden, sind zur Ansicht von Daten bestimmt. Die Tabellendaten kann man auf der Registerkarte Data und die Abfrageergebnisse auf der Registerkarte Results betrachten und bearbeiten. Überall da, wo die Möglichkeit zum Betrachten und Bearbeiten besteht, wird das Werkzeug Datenansicht verwendet.

Dies wird verwendet in:

Tabelleneditor

Vieweditor

SQL-Editor

Visuellem Query-Builder und anderen Werkzeugen.

Die Daten können in dem Datenansicht-Werkzeug auf drei verschiedene Weise angezeigt werden:

  • als Tabelle auf der Registerkarte Rasteransicht,
  • als Formular auf der Registerkarte Formularansicht,
  • als Druckformular auf der Registerkarte Druckdaten (Daten drucken),
  • als Editor von Datentyp BLOB auf der Registerkarte Blob View

Mit Hilfe des Kontextmenüs und den Symbolleisten der Datenansicht kann man folgende Hauptoperationen vornehmen:

  • Exportieren von Daten,
  • Exportieren von Daten als SQL-Skript,
  • Importieren von Daten,
  • Bearbeiten vom BLOB-Datentyp.


Datenansicht

Im SQL Manager 2007 for MySQL steht ein leistungsfähiges Werkzeug zum Betrachen, Bearbeiten und Drucken von Daten aus den Tabellen, Abfragen und Views zur Verfügung.

Die meist verwendeten Tools der Datenansicht befinden sich im Kontextmenü.

Die Registerkarten des Datenansicht-Werkzeuges sind im unteren Teil zu finden.

Mit deren Hilfe kann man die Daten folgenderweise betrachen:

  • als Tabelle auf der Registerkarte Rasteransicht,
  • als Formular, wo jede Zeile zum separaten Formular ausgegeben ist, auf der Registerkarte Formularansicht,
  • als Vorschauseite auf der Registerkarte Druckdaten.

Die Datenansicht wird in den nachfolgenden Werkzeugen verwendet:

Tabelleneditor - Registerkarte Data,

Vieweditor - Registerkarte Data,

Abfrageeditor - Registerkarte Results,

Visueller Query-Builder - Registerkarte Results.

Die Datenansicht kann man mit Hilfe der Registerkarte Grid (Raster) in Optionen |Umgebungsoptionen einstellen.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Symbolleisten

Editorleisten

Navigationsleiste

Im Editor, in dem die Datenansicht verwendet wird, erscheint auf der Navigationsleiste beim Übergehen zur Registerkarte Data (Daten) bzw. Results (Ergebnisse) die Leiste Data management (Datenverwaltung).

Mit Hilfe dieser Leiste kann man:

  • Transaktion von Daten einsetzen - Commit Transaction (aktiviert, falls die Transaktionen für die Daten Options | Umgebungsoptionen | Tools | Use transactions in Data tab of object editors, SQL Editor and Query Builder eingeschaltet sind),
  • Transaktion für Tabellendaten zurücksetzen - Rollback Transaction (aktiviert, falls die Transaktionen für Daten eingeschaltet sind).
  • Daten exportieren - Export Data,
  • Daten als SQL-Skript exportieren - Export as SQL Script,
  • Daten importieren - Import Data,
  • Massenimport von Daten vornehmen - BULK INSERT.

Werkzeugleiste

Beim Übergehen zur Registerkarte der Datenansicht auf der Editor-Werkzeugleiste werden die nachfolgenden Buttons aktiviert:

  • Transaktion von Daten einsetzen - Commit Transaction (aktiviert, falls die Transaktionen für die Daten Options | Umgebungsoptionen | Tools | Use transactions in Data tab of object editors, SQL Editor and Query Builder eingeschaltet sind),
  • Transaktion für Tabellendaten zurücksetzen - Rollback Transaction (aktiviert, falls die Transaktionen für Daten eingeschaltet sind).
  • Daten exportieren - Export Data (nur auf der Registerkarte Data aktiviert),
  • Daten als SQL-Skript exportieren - Export as SQL Script (nur auf der Registerkarte Data aktiviert),
  • Daten importieren - Import Data (nur auf der Registerkarte Data aktiviert),
  • BULK INSERT - Massenimport von Daten (nur auf der Registerkarte Data aktiviert).

Werkzeugleiste der Datenansicht

Werkzeugleiste mit den Datensätzen:

Damit kann man:

  • zum ersten Datensatz übergehen - First record,
  • zur vorherigen Seite übergehen - Prior page,
  • zum vorherigen Datensatz übergehen - Prior record,
  • zum nächsten Datensatz übergehen - Next record,
  • zur nächsten Seite übergehen- Next page,
  • zum letzten Datensatz übergehen - Last record,
  • Datensatz hinzufügen - Insert record,
  • Datensatz löschen - Delete record,
  • Datensatz bearbeiten - Edit record,
  • Bearbeitung speichern - Post edit,
  • Bearbeitung abbrechen - Cancel edit,
  • Daten aktualisieren- Refresh data,
  • Lesezeichen festlegen - Set bookmark,
  • zum Lesezeichen übergehen - Go to Saved Bookmark,
  • Daten filtern - Filter data (es wird der Filter-Builder geöffnet).
  • Im Feld Find wird der Zeichensatz angegeben, der in der ausgewählten Spalte gefunden werden soll.

Werkzeugleiste der Registerkarte Druckdaten (Daten drucken):

Mit Hilfe dieser Leiste kann man:

  • Design des Berichtes mittels des Werkzeuges Berichtdesigner einstellen - Design Report,
  • Bericht aus Datei laden - Load Report,
  • Bericht in Datei speichern - Save Report,
  • drucken - Print,
  • Druckdialog öffnen - Print Dialog (es wird ein standardmäßiges Dialogfenster, in dem die Druckparameter eingegeben werden können, geöffnet),
  • Seitenparameter einstellen - Page Setup,
  • Miniaturansichten der Seiten anzeigen - Show Thumbnails,
  • Einstellen der Bemerkungen - Title...:

Einfügen von Datum und Zeit - Date and Time...,

Einfügen der Seiten-Nummerierung - Page Numbering...,

  • Alles auf einer Seite anzeigen - Shrink To Page,
  • Farben vom Seitenhintergrund einstellen - Background,
  • Zoom eingeben - Zoom,
  • Seite zoomen - Zoom Page,
  • Ganze Seite - Whole Page,
  • Mehrere Seiten - Multiple Page.
  • Zoom wird mit Hilfe der Dropdownliste eingestellt - Zoom,
  • zur ersten Seite übergehen - First Page,
  • zur vorherigen Seite übergehen - Previous Page,
  • Seitennummer angeben, zu der man übergehen möchtet - Indikator Active Page (darüber hinaus wird in ihm die Seitennummer angezeigt, wo man sich jetzt befindet)
  • zur nächsten Seite übergehen - Next Page,
  • zur letzten Seite übergehen - Last Page.

Werkzeugleiste der Registerkarte Blob View:

Mit Hilfe dieser Leiste auf der Leiste für den Editor vom BLOB-Datentyp kann man:

  • aus der Dropdownliste den BLOB-Feldertyp auswählen,
  • aus Datei laden - Load from File (Sie können einen beliebigen Dateityp auswählen. Das kann ein Text, ein Bild usw. sein.),
  • in Datei speichern - Save to File,
  • in die Zwieschenablage ausschneiden - Cut To Clipboard,
  • in die Zwischenablage kopieren - Copy To Clipboard,
  • aus der Zwischenablage einfügen - Paste From Clipboard,
  • Aktion rückgängig machen - Undo,
  • drucken - Print.

(Die nachfolgenden Buttons sind lediglich für die Registerkarte Rich-Text-Feld aktiviert.)

  • Schrift mittels der Dropdownliste auswählen Font,
  • Schriftgröße auswählen - Indikator Font Size,
  • Fett auswählen - Bold,
  • Kursiv auswählen - Italic,
  • Unterstrichen auswählen - Underline,
  • Links ausrichten - Align Left,
  • Zentriert ausrichten - Align Center,
  • Rechts ausrichten - Align Right,
  • Aufzählungszeichen erstellen - Bullets.

Einstellen von Verwaltungsleisten


Kontextmenü

Mit Hilfe dieses Kontextmenüs kann man die nachfolgenden Aktionen vornehmen:

  • Zelle kopieren- Copy Cell,
  • Zelle einfügen - Paste Cell,
  • Alle Datensätze kopieren - Copy All Records,
  • Ausgewählte Datensätze kopieren - Copy Selected Records,
  • Datensätze einfügen - Paste Records,
  • Daten manipulieren - Data Manipulation, (d.h.: Daten exportieren - Export Data, Daten als SQL-Skript exportieren - Export as SQL Script, Daten importieren - Import Data, Massenimport vornehmen - BULK INSERT.)
  • Datenfiltern einstellen - Quick Filter,
  • Filter deaktivieren - Disable Filter,
  • Sortierreihenfolge löschen - Clear Sorting,
  • Wert festlegen - Set Value,
  • BLOB-Daten bearbeiten - Edit BLOB (dieser Menüpunkt ist aktiviert, wenn das Menü für das Feld, das die Blob-Objekte enthält, aufgerufen wurde),
  • BLOB in Datei speichern - Save BLOB to File (dieser Menüpunkt ist aktiviert, wenn das Menü für das Feld, das die Blob-Objekte enthält, aufgerufen wurde),
  • Alles erweitern - Expand All (der Befehl ist aktiviert, wenn die Datengruppierung nach einem bzw. mehreren Feldern besteht oder die Unterebenen der Tabelle vorhanden sind),
  • Alle zusammenklappen - Collapse All (der Befehl ist aktiviert, wenn die Datengruppierung nach einem bzw. mehreren Feldern besteht oder die Unterebenen der Tabelle vorhanden sind),
  • zur nächsten Registerkarte übergehen - Next Tab (dieser und nächster Menüpunkt ist für die Ergebnisse derer Abfragen, die mehr als einen Datensatz zurückgeben, aktiviert. In diesem Fall wird für jedes Abfrageergebnis, ebenso für die Tabellen, die mehr als eine Unterebene besitzen, eine separate Registerkarte erstellt),
  • zur vorherigen Registerkarte übergehen - Previous Tab,
  • mit Rasterebenen arbeiten - Grid Levels,

Raster-Ebene hinzufügen - Add Grid Level... (beim Auswählen dieses Punktes wird der Assistent zum Erstellen von Ebenen geöffnet),

Raster-Ebene löschen - Delete Grid Level,

Tabellenansicht - Table View,

Kartenansicht - Card View,

  • Spaltenzusammenfassung einstellen - Column Summary...,
  • Sichtbare Spalten auswählen - Visible Columns (Die sichtbaren Spalten kann man auch mit Hilfe der Schaltfläche [image] in der linken oberen Tabellenecke, in der Nähe von Spaltenübersichten auswählen),
  • Spaltenbreite anpassen - Fit Columns Widths,
  • Raster-Modus auswählen - Grid Mode (alle Spalten anzeigen, nur die sichtbaren Spalten anzeigen bzw. Standardmodus),
  • Eigenschaften betrachten und verändern - Properties....(Optionen | Umgebungsoptionen | Grid)


Rasteransicht

Aufgrund der Tabellenfelder bzw. der Abfrage wird ein Raster zum Betrachten der Daten erstellt. Die Spalten bilden sich aus Feldern heraus. Sind die Daten in der Rasteransicht einer Tabelle geöffnet, kann man diese nach dem Benutzerwunsch hinzufügen, löschen und bearbeiten. Ist in der Datenansicht das Abfrageergebnis ausgegeben, dann hängt die Möglichkeit der Bearbeitung von der Abfrage ab.

Alle weiteren Operationen mit den Daten sind für die Tabellendaten und Abfrageergebnisse gleich.

Mit Hilfe der Symbolleisten kann man den Übergang nach den Datensätzen, Hinzufügen und Löschen von Zeilen usw. vornehmen. Das Kontextmenü ermöglicht die Zellen zu kopieren, die Ebenen zu erstellen, die Spaltenzusammenfassung einzustellen usw.

Die Hauptoperationen mit den Daten sind:

  • Sortieren in den Spalten gemäß den Regeln der Oberfläche
  • Datengruppierung,
  • Datenfiltern,
  • Arbeiten mit mehreren Ebenen,
  • Kartenansicht,
  • Spaltenzusammenfassung,
  • Änderung der Spaltenreihenfolge.

Auswählen von sichtbaren Spalten

Man kann angeben, welche Tabellenspalten sichtbar werden.

Dazu muss man den Kontextmenüpunkt Visible Columns verwenden bzw. den Button [image] in der linken oberen Tabellenspalte in der Nähe von den Spaltenübersichten betätigen. Beim Anklicken dieser Schaltfläche wird ein Fenster geöffnet. Setzt man dort ein Häkchen ein, werden die sichbaren Felder markiert.

Änderung der Spaltenreihenfolge

Soll die Reihenfolge von Spalten geändert werden, dann reicht das Ziehen des Spaltenkopfs in die gewünschte Position aus. Falls die Spalte hierher übertragen werden kann, wird die Stelle mit grünen Pfeilen markiert. Die erscheinen bei der Annäherung zur Einfügestelle.

Kopieren von Datensätzen

Zum Kopieren von Datensätzen aus einer Tabelle in die andere sind im Kontextmenü zwei Punkte vorhanden:

  • Ausgewählte Datensätze kopieren - Copy Selected Records,
  • Datensätze einfügen - Paste Records.

Beim Kopieren einiger Zeilen kann die Übereinstimmung der Tabellenfelder und der einzufügenden Zeilen angegeben werden.

In der Liste Clipboard Columns werden die Felder der kopierenden Zeilen angezeigt.

In der Liste Grid Columns werden die Felder der Tabelle, in der die Zeilen kopiert werden, dargestellt.

Mit Hilfe der Schaltflächen werden die Übereinstimmungen zwischen den Feldern festgelegt. Diese werden in der Liste der Übereinstimmungen im unteren Teil des Formulars angezeigt.

Mit dem Button Add wird zwischen den ausgewählten Feldern eine neue Übereinstimmung in die Liste hinzuzufügt.

Der Button Add All ermöglicht automatisch den Tabellen-Feldern, in denen die Daten kopiert werden, die entspechenden Felder der Quelldaten hinzuzufügen.

Beim Drücken auf den Button Remove wird die ausgewählte Übereinstimmung gelöscht. Beim Drücken auf den Button Remove All wird die Liste der Übereinstimmungen vollständig gelöscht.


Datengruppierung

Man kann die Daten in der Tabelle nach einer bzw. mehreren Spalten gruppieren. Um die Tabelle nach der Spalte zu gruppieren, muss man den Spaltenkopf zur speziellen Leiste über der Tabelle übertragen. Das ist die sogenannte "Gruppierungsleiste".

Gruppierung nach einer Spalte

Nehmen wir an, man hat eine Tabelle mit den Adressen der Mitarbeiterinnen und Mitarbeiter in verschiedenen Städten.

Beim Platzieren des Feldkopfes "City" auf der Gruppierungsleiste werden alle Adressen nach dem Feld "Stadt" gruppiert.

Die Tabelle wird also so aussehen.

Dank diesem Formular kann man sich anschauen, wie viele Mitarbeiterinnen und Mitarbeiter Sie in der jeweiligen Stadt haben.

Gruppierung nach mehreren Spalten

In jeder Stadt gibt es mehrere Stadtteile. Für jeden Stadtteil ist eine bestimmte Postleitzahl vorhanden. Man kann die Tabelle nach dem Feld "Stadt" und danach nach dem Feld "Postleitzahl" gruppieren und so die Anzahl der Mitarbeiterinnen und Mitarbeiter, die in jedem Stadtteil wohnen, erhalten.

Hierfür muss man den Feldkopf "PostalCode" zur Gruppierungsleiste übertragen.

Die Tabelle wird folgender Weise aussehen.

In den Gruppenüberschriften können die Infos über die gruppierten Daten angezeigt werden, falls die Spaltenzusammenfassung vorgegeben wurde. Auf der Gruppierungsleiste ist die Überschrift, die sich unten befindet, untergeordnet. Die Gruppierung nach ihm wird in zweiter Linie ausgeführt werden. Die Objekte auf der Gruppierungsleiste sind zum Datenfiltern verfügbar.

Die Gruppierung kann man aufheben, indem man den Spaltenkopf in die Tabelle zurück verschiebt. Dabei lässt sich die Spaltenreihenfolge ändern.


Datenfiltern

Der Filter ist eine schnelle Methode zum Suchen nach der Untermenge der Daten und zum Arbeiten in der Tabelle. In der gefilterten Tabelle werden die Zeilen angezeigt, die den Voraussetzungen für eine Spalte entsprechen. Der Filter verändert keine Reihenfolge der Datensätze. Beim Filtern werden zeitweilig die Zeilen, die den vorgegebenen Bedingungen nicht entsprechen, unsichtbar.

Das Filtern von Daten kann man auf drei verschiedene Weisen vornehmen.

1. Mit Hilfe des Kontextmenüpunktes Quick Filter

Reihenfolge der Aktionen:

  • Kontextmenü für die Zelle mit den Daten aufrufen,
  • Kontextmenüpunkt Quick Filter auswählen,
  • aus dem untergeordneten Menü die Filterbedingung auswählen
  • = Value in der Tabelle werden nur die Zeilen angezeigt, die in diesem Feld den gleichen Wert ähnlich wie der aktive Wert haben (aktiver Wert ist der Wert, für den das Kontextmenü aufgerufen wurde),
  • <> Value - in der Tabelle werden nur die Datensätze angezeigt, dessen Wert in diesem Feld dem aktiven Wert nicht gleich ist,
  • < Value - in diesem Fall werden die Werte strikt weniger als der aktive Wert ausgewählt,
  • > Value - in diesem Fall werden die Werte strikt größer als der aktive Wert ausgewählt,
  • <= Value - in diesem Fall werden die Werte weniger als der aktive Wert und ihm gleiche Werte ausgewählt,
  • >= Value - in diesem Fall werden die Werte größer als der aktive Wert und ihm gleiche Werte ausgewählt.

Mit Hilfe des Quick Filter lassen sich die BLOB-Daten und sysname nicht kopieren.

2. Mit Hilfe der Spaltenköpfe

In jedem Spaltenkopf gibt es eine Schaltfläche mit einem Pfeil. Klickt man auf diesen Pfeil, dann erscheint eine Liste von Werten, die in dieser Spalte enthalten sind. Falls man einer dieser Werte auswählt, wird dies zur Filterbedingung. In der Tabelle werden nur die Zeilen sichtbar, die dieser Bedingung entsprechen. Darüber hinaus kann man die zusammengesetzten Bedingungen mit Hilfe des Punktes der Wertlisten (Custom...) vorgeben. Beim Auswählen dieses Punktes wird ein spezielles Fenster für die Eingabe der Filterbedingungen geöffnet.

In diesem Dialogfenster kann man 2 Filterbedingungen und deren Relationen eingeben - ob beide gleichzeitig ausgeführt werden oder nur eine Ausführung davon genügt.

Mit Hilfe dieses Fensters kann man leicht die Intervalle eingeben.

Aus der Dropdownlisten werden die Filterbedingungen ausgewählt:

  • ist gleich - equals,
  • ist nicht gleich - does not equal,
  • ist weniger als - is less than,
  • ist weniger als oder gleich wie - is less than or equal to,
  • ist größer als - is greater than,
  • ist größer als oder gleich wie- is greater than or equal to,
  • ist ähnlich - like,
  • ist nicht ähnlich - not like,
  • ist leer - is blank,
  • ist nicht leer - is not blank,

Im Feld wird die Reihenfolge der Zeichen angegeben. Das Zeichen "%" wird zur Eingabe jedes Zeichensatzes und das Zeichen "_" zur Eingabe jedes Zeichens verwendet. Bei der Ausführung einer Bedingung werden nur die Werte ausgewählt, die der angegebenen Bedingung entsprechen. Man hat z.B. aus der Liste den Punkt "ist größer als" ausgewählt und im Feld wurde 100 eingegeben. Daraus folgt, dass in der Tabelle nur die Zeilen, in deren der Wert größer als 100 ist, angezeigt werden. Die zweite Bedingung ist nicht verbindlich.

Wenn sich der Schalter im Stand AND befindet, werden beide Verbindungen gleichzeitig ausgeführt. Wurde OR angegeben, dann muss nur eine der Bedingungen ausgeführt werden.

3. Mit Hilfe der Schaltfläche auf der Symbolleiste

Die Schaltfläche [image] lässt den Filter-Builder öffnen, mit dessen Hilfe die Filterbedingungen eingegeben und verwendet werden.

Ist für die Tabelle ein Filter gesetzt, erscheint im unteren Teil eine spezielle Leiste, in der die Filterbedingung angezeigt wird.

Mit Hilfe dieser Leiste kann man:

  • Filter löschen, indem man den Button [image] anklickt,
  • Filter einschalten, indem man das Häkchen setzt,
  • Filterbedingungen mit Hilfe der Schaltfläche Customize.... verändern. Diese Schaltfläche lässt den Filter-Builder öffnen.

Außerdem werden auf der Leiste kurz und bündig die Filterbedingungen und ebenso der Verlauf der Filtermodifikation, die beim Betätigen der Schaltfläche [image] geöffnet wird, dargestellt.


Arbeiten mit mehreren Ebenen

Zu den einzigartigen Funktionalitäten des SQL Manager 2007 for MySQL gehört die Möglichkeit, mit den Daten im Modus in mehreren Ebenen zu arbeiten. Dies ermöglicht, die Daten in mehreren verknüpften Tabellen gleichzeitig zu verändern und zu betrachten.

Die Ebenen lassen sich mit Hilfe des Kontextmenüpunktes Grid Levels verwalten.

  • Raster-Ebene hinzufügen - Add Grid Level...(beim Auswählen dieses Punktes wird der Assistent zum Erstellen von Ebenen geöffnet),
  • Rasterebene löschen - Delete Grid Level,
  • Tabellenansicht - Table View,
  • Kartenansicht - Card View.

Wenn eine Ebene hinzugefügt ist, dann kann man für jeden Datensatz der Tabelle die jeweiligen Datensätze in einer anderen Tabelle anschauen. Eine solche untergeordnete Tabelle nennt man Unterebene.

Um die Unterebene einer Tabelle zu öffnen (aufzulösen), muss man auf das Zeichen "+" klicken. Dies befindet sich am Anfang der Zeile. Beim Klicken auf das Zeichen "-" wird die Unterebene reduziert.

Es kann eine Anzahl der Unterebenen sein. In diesem Fall wird jede auf einer separaten Registerkarte im Fenster der Unterebenen untergebracht. Zwischen den Registerkarten kann man sich umschalten, indem man sie mit der Maus bzw. mit Hilfe der Kontextmenüpunkte anklickt:

  • zur nächsten Registerkarte übergehen - Next Tab,
  • zur vorherigen Registerkarte übergehen - Previous Tab

Zum Öffnen der Unterebenen für alle Datensätze wird der Kontextmenüpunkt Expand All verwendet.

Der Punkt Collapse All lässt alle Unterebenen reduzieren.


Assistent zum Erstellen von Ebenen

Der Assistent zum Erstellen von Ebenen ermöglicht für eine Tabelle neue Unterebenen zur komfortablen Darstellung der Daten zu erstellen.

Der Assistent zum Erstellen von Ebenen besteht aus vier Schritten:

  • Auswählen der Haupttabelle
  • Auswählen der Abhängigkeiten der Tabelle bzw. der Abfrage
  • Herstellung der Verbindung zwischen der übergeordneten und untergeordneten Tabellen
  • Parametereingabe

Um den Assistenten zu starten, muss man den Punkt des untergeordneten Menüs Add Grid Level... des Kontextmenüpunktes Grid Levels auswählen.


Auswählen der Haupttabelle

Im ersten Schritt wird eine Tabelle bzw. eine Abfrage, die als Hauptebene gelten wird, ausgewählt. Zu dieser Hauptebene kann man dann die Unterebene anbinden.

Aus der Dropdownliste wählt man die Hauptebene aus.

Danach wird mit Hilfe des Schalters Source of New level data eine Quelle für die Unterebene ausgewählt.

Falls Table ausgewählt wird, kann man im zweiten Schritt eine Tabelle oder eine View auswählen.

Wählt man Query aus, muss man im nächsten Schritt eine manuelle Abfrage, die die Unterebene bestimmt, zusammenstellen.

Nächster Schritt


Auswählen der Abhängigkeiten der Tabelle bzw. der Abfrage

Die Darstellung des Assistenten im zweiten Schritt hängt davon ab, welche Quelle für die Unterebene im ersten Schritt ausgewählt wurde.

Wenn als Quelle Table ausgewählt wurde, dann wird im zweiten Schritt angeboten, eine konkrete Tabelle aus der Dropdownliste Table Name auszuwählen. In der Liste sind alle in der Datenbank vorhandenen Tabellen und Views. Man kann ihre Anzahl bei Aktivierung des Häkchens Show tables related by foreign keys only verkleinern. In diesem Fall bleiben in der Liste nur die Tabellen, die mit der Haupttabelle mit Hilfe des Fremdschlüssels verknüpft sind.

Wurde im ersten Schritt als Quelle eine Abfrage ausgewählt, muss man im zweiten Schritt im Abfrageneditor eine Abfrage erstellen.

In diesem Fenster befindet sich der SQL-Editor der Abfragen.

Man kann die SQL-Abfrage manuell im Editor erstellen oder diese kopieren und in den Editor einfügen.

Mit Hilfe der Schaltfläche Query Builder... können Sie den Visuellen Query-Builder starten. Er wird in einem Modulfenster geöffnet und dort die Abfrage erstellen.

Nachdem die Tabelle ausgewählt und eine Abfrage erstellt wurde, kann man zum nächsten Schritt übergehen.

Nächster Schritt


Herstellung der Verbindung zwischen den übergeordneten und untergeordneten Tabellen

Im dritten Schritt wählt man die Felder aus, nach denen die übergeordneten und untergeordneten Tabellen zu verbinden sind.

Aus den Listen Master Level Key Fields und Detail Level Key Fields werden die Felder der übergeordneten und untergeordneten Tabellen ausgewählt. Nach diesen Feldern werden die Tabellen verknüpft werden.

Mit Hilfe der Schaltfläche Add fügt man in die Liste Links Between Master and Detail Levels einen neuen Verweis, der sich aus den ausgewählten Feldern herausbildet, hinzu.

Es können mehrere Verweise bestehen. In diesem Fall wird jede untergeordnete Tabelle auf der separaten Registerkarte der Unterebene angezeigt. Zwischen den Registerkarten kann man umschalten, indem man einfach diese mit der Maus anklickt oder die Kontextmenüpunkte verwendet:

  • zur nächsten Registerkarte übergehen - Next Tab,
  • zur vorherigen Registerkarte übergehen - Previous Tab.

Den Link kann man aus der Liste mit Hilfe der Schaltfläche Remove entfernen.

Nächster Schritt


Parametereingabe

Im letzten Schritt muss man eine Darstellungsart der Unterebene auswählen und diese im Kopf angeben.

Der Kopf wird im oberen Teil der Unterebene angezeigt. Diesen kann man im Feld Level caption angeben.

Mit Hilfe des Umschalters Level type wählen Sie bitte die Darstellungsart der Unterebene aus:

  • Table view - Tabellenansicht,
  • Card View - Kartenansicht.

Beim Betätigen der Schaltfläche Finish wird die Herstellung der Ebene beendet.


Kartenansicht

Im Fenster der Tabellenansicht gibt es einen zusätzlichen Ansichtsmodus - Card View (zu dt. Kartenansicht).

Gibt es in der Tabelle die Unterebenen, kann man als Karten nur die unterste Ebene der Hierarchie darstellen.

Um die Kartenansicht einzuschalten, muss man einen Punkt des untergeordneten Menüs Card View des Kontextmenüpunktes Grid Levels verwenden.

Um die Tabellenansicht zurückzusetzen, wird ein Punkt eines untergeordneten Menüs des Kontextmenüpunktes Grid Levels verwendet.


Spaltenzusammenfassung

Im SQL Manager 2007 for MySQL ist ein spezielles Werkzeug zum Anzeigen der Spaltenzusammenfassung enthalten. Mit Hilfe dieses Werkzeuges kann man im unteren bzw. oberen Teil der Tabelle eine Zusammenfassung austragen. Das Werkzeug der Spaltenzusammenfassung wird mittels des Kontextmenüpunktes Column Summary.... aufgerufen.

Im Fenster Column Summary aus der Liste Column wird eine Tabellenspalte, für die die zusätzlichen Infos angezeigt werden müssen, ausgewählt.

Footer summary zeigt die Zusammenfassung in der Fußzeile der Tabelle an.

Group header zeigt die Infos in der Kopfzeile der Datengruppierung an.

Group footer zeigt die Daten in der Fußzeile der gruppierten Daten an.

Die Informationen, die für die Spalten mit den Daten des Zahlen- bzw. Datum/Zeit Formates ausgegeben können.

  • keine - None,
  • Summe von Werten in der Spalte - Sum,
  • Minimaler Wert in der Spalte - Minimum,
  • Maximaler Wert in der Spalte - Maximum,
  • Anzahl der Werte in der Spalte - Count,
  • Mittelwert in der Spalte - Average.

Für alle anderen Spaltentypen ist nur die Anzahl der Werte in der Spalte Count zugänglich.

Im Feld Number format stellt man das Format der Anzahl an.


Formularansicht

Unter der Registerkarte Form View ist jeder Datensatz als Formular angezeigt. Die Daten lassen sich komfortabler bearbeiten, wenn diese in solch einer Form dargestellt sind.

Wenn auf der Registerkarte Grid View eine Zeile bzw. eine Zelle hervorgehoben wurde und man anschließend zur Registerkarte Form View übergegangen ist, wird auf dieser Registerkarte ein ausgewählter Datensatz angezeigt.

Für jeden Datensatz wird Folgendes angezeigt:

  • Felderbezeichnungen
  • Feldertypen
  • Felder zur Datenbearbeitung

In der Nähe jedes Feldes befindet sich das Häkchen Null. Damit kann man dieses Feld leeren. Es ist nicht möglich, die Daten bei Aktivierung des Häkchens zurückzubringen. Um die Daten wiederherzustellen, muss man den Button [image] anklicken. Um die Änderungen abzulehnen, ist der Button Cancel edit auf den Symbolleisten anzuklicken.

Zwischen den Datensätzen kann man mit Hilfe der Schaltflächen, die sich auf den Symbolleisten befinden, umschalten. Diese Buttons ermöglichen, die Datensätze anzulegen, zu bearbeiten, zu löschen und durch die Datensätze zu navigieren. Für jeden Datentyp wird ein Eingabefeld, das dem jeweiligen Datentyp entspricht, erstellt. So erscheint beispielsweise für den Feldtyp Datetime ein Kalender. Dies vermeidet die Fehler bei der Eingabe des Datums. Für die Feldertypen mit dem größeren Umfang werden die großen Textfelder erstellt.

Unter dieser Registerkarte werden die Bedingungen zum Datenfiltern bestimmt, so wird der erste Tabellendatensatz, der diesen Bedingungen entspricht, angezeigt.

Man kann für den Feldtyp Datetime ein bei MySQL standardmäßiges Datumformat festlegen:yyyy-mm-dd hh:nn:ss.

In diesem Fall besitzt das Feld zum Bearbeiten von Datentypen keinen Kalender, der sich automatisch öffnet und das Null-Datum eingeben lässt.

Um das MySQL-Format einzustellen, muss man den Punkt yyyy-mm-dd hh:nn:ss aus der Dropdownliste Datetime fields auf der Registerkarte Umgebungsoptionen | Format- und Farbpalette auswählen.


Druckdaten

Unter der Registerkarte Print Data sind die Daten im Modus der vollständigen Übereinstimmung der Druckvariante mit der Anzeige des bearbeitenden Dokumentes auf dem Bildschirm dargestellt.

Man kann die Druckform verändern, die Seitenparameter eingeben, die Berichte in Datei speichern und aus Datei laden.

Das lässt sich alles mit Hilfe der Symbolleisten abwickeln.

Auf der oberen Leiste werden die Merkmale der Felder und Kopf- und Fußzeilen des Druckdokumentes angezeigt:

  • Left - linkes Feld,
  • Top - oberes Feld,
  • Right - rechtes Feld,
  • Bottom - unteres Feld,
  • Header - Kopfzeile,
  • Footer - Fußzeile

Auf der unteren Leiste wird die Statistik angezeigt:

  • Page - Seiten,
  • Pages - Anzahl von Seiten,
  • Paper size - Papiergröße,
  • Status - Status.


Seitenparameter

Mit Hilfe dieses Werkzeuges kann man die Seitenparameter beim Drucken einstellen.

Unter der Registerkarte Page werden die Größe und Seitenausrichtung angegeben.

Aus der Liste Type wird einer aus den Formattypen ausgewählt.

Passen die Standardtypen nicht, gibt man die Höhe und die Breite eines Blattes im Abschnitt Dimension an.

Im Feld Width wird die Breite, im Feld Height wird die Höhe angegeben.

Aus der Dropdownliste Paper source wird die Papierquelle ausgewählt.

Mit Hilfe des Optionsfeldes wird im Abschnitt Orientation Seitenausrichtung ausgewählt.

  • Portrait - Hochformat
  • Landscape - Querformat

Da die Daten in Form einer Tabelle dargestellt sind, muss man beim Drucken die Reihenfolge der Seiten im Abschnitt Print Order angeben:

  • Down, then over - unten, dann über,
  • Over, then down - über, dann unten.

Bei Aktivierung des Punktes Print using gray shading werden beim Drucken nicht nur die Schattierungen der grauen Farbe, sondern auch schwarze und weiße Farben verwendet.

Unter der Registerkarte Margins können die Größe der Ränder von Dokumenten und die Größe der Kopf- und Fußränder angegeben werden.

  • Top - Größe des oberen Randes
  • Bottom - Größe des unteren Randes
  • Left - Größe des linken Randes
  • Right - Größe des rechten Randes
  • Header - Größe des Kopfrandes
  • Footer - Größe des Fußrandes

Bei Aktivierung des Häkchens im Abschnitt Center on page wird angegeben, ob der Text auf der Seite zentriert werden muss. Wenn der Punkt Horizontally aktiviert wird, wird der Text horizontal zentriert.

Durch Aktivierung des Punktes Vertically wird der Text vertikal zentriert.

Unter der Registerkarte Header\Footer kann man die Eigenschaften der oberen und unteren Kopf- und Fußzeilen eingeben.

Jede Kopf- und Fußzeile ist in 3 Teilen eingeteilt. In jedem Abschnitt kann man unterschiedliche Infos angeben. Den Text kann man selber verfassen bzw. einen Standardtext mit Hilfe der Schaltflächen Predefined Function auswählen:

  • Machine name - Rechnername,
  • User Name - Nutzername,
  • Time Printed -Druckzeit,
  • Date Printed - Datumdruck,
  • Date & Time Printed - Zeit und Datum des Druckens
  • Page # of Pages # - Seite № aus der gesamten Seitenmenge
  • Total Pages - gesamte Zahl der Seiten
  • Page # - Seitennummer

Für die Kopf- und Fußzeile kann man die Schrift mit Hilfe der Schaltfläche Font... und den Hintergrund mit Hilfe der Schaltfläche Background angeben.

Die vertikale Ausrichtung wird beim Betätigen der Schaltflächen Vertical Alignment ermöglicht.

Auf der Registerkarte Scaling wird der Seitenmaßstab angegeben.

Adjust To heißt n Prozente der normalen Größe angeben. Die Prozente werden in einem speziellen Feld angegeben.

Fit To heißt nicht mehr als auf n Seiten in Breite und n Seiten in Höhe platzieren. Die Menge der Seiten wird in speziellen Feldern angegeben.


Berichtdesigner

Die Darstellung des Druckformulars kann man mit Hilfe des Werkzeuges Format report einstellen. Das Werkzeug wird beim Betätigen der Schaltfläche [image] Design Report auf Symbolleiste der Registerkarte Druckdaten der Datenansicht geöffnet.

Alle Werkzeuge sind auf nachfolgenden Registerkarten zu finden:

  • Einstellen der Ansichten,
  • Verhalten,
  • Formatieren,
  • Designs,
  • Vorschau,
  • Karten.

Beim Betätigen der Schaltfläche Title Properties kann man die Parameter des Titelblattes vom Bericht angeben.

Funktion vorhanden

Windows Full | Ja
Windows Lite | Nein


Einstellen der Ansichten

Unter der Registerkarte View kann man bei Aktivierung des Häkchens die im Bericht anzuzeigenden Ansichten auswählen. Im Abschnitt Show werden die Elemente, die für die ganze Tabelle angezeigt werden, ausgewählt.

  • Caption - Beschriftung,
  • Bands - Bänder,
  • Headers - Kopfzeilen,
  • Footers - Fußzeilen,
  • Group Footers - Gruppenfüße,
  • Expand Buttons - Button erweitern,
  • Filter Bar - Filterleiste. Wurden die Daten filtriert, werden in dieser Zeile die Filterbedingungen angezeigt.

Im Abschnitt On Every Page kann man die Abschnitte angeben, die auf jeder Seite sichtbar werden.

  • Caption - Beschriftung,
  • Bands - Bänder,
  • Headers - Kopfzeilen,
  • Footers - Fußzeilen,
  • Filter Bar - Filterleiste.

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Verhalten

Auf dieser Registerkarte werden folgende Charakteristiken angegeben:

Im Abschnitt Selection werden die Auswahlparameter bestimmt:

  • Process Selection - Prozess des Auswählens,
  • Process Exact Selection - Prozess des exakten Auswählens

Die Abschnitte, für die die Breite entsprechend der Seitenbreite eingestellt wird, wählt man im Abschnitt Expanding.

  • Groups - Gruppen,
  • Details - Details,
  • Cards - Karten.

Bei Aktivierung des Punktes Auto Width wird die Tabellenbreite der Seitenbreite gleich sein.

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Formatieren

Die Parameter des Formatierens werden auf der Registerkarte Formatting angegeben.

Aus der Dropdownliste Look and Feel wird die Darstellung der Zellenränder einer Kopfzeile ausgewählt.

Im Abschnitt Refinements kann man die Komprimierungsparameter eines Berichtes angeben.

  • Transparent Graphics - transparente grafische Darstellungen,
  • Display Graphic As Text - Grafik als Text anzeigen
  • Flat CheckMarks - Flache Häkchen verwenden

Suppress Background Textures - Hintergrundsstrukturen ausgleichen.

Consume Selection Style - keine Auswahlstile verwenden

Die Seitenzählung wird im Abschnitt Pagination angegeben.

By TopLevel Groups - Seitenteilung entsprechend der Gruppierung

One Group Per Page - eine Gruppe per Seite

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Designs

Unter dieser Registerkarte kann man die Darstellungsart des Berichtes verändern.

Ist Use Native Styles aktiviert, dann wird nur das standardmäßige Design benutzt. Die Änderungen sind nicht einzutragen.

In der Liste befinden sich alle Elemente des Berichtes. Hinzu kommen noch der Hintergrund, die Art und die Schriftgröße.

Für jedes Element kann man die nachfolgenden Eigenschaften eingeben:

  • Font - Schrift,
  • Color - Farbe,
  • Texture - Struktur,
  • Clear - Einstellungen zurücksetzten

Beim Drucken auf die Schaltfläche Restore Defaults werden alle eingetragenen Änderungen des ausgewählten Objektes zurückgesetzt und standardmäßige Einstellungen eingestellt.

Mit Hilfe der Schaltfläche Save As... kann man die Änderungen in Schemadatei speichern.

Alle Schemadateien werden in der Liste Style Sheets angezeigt. Bei Aktivierung der Schaltfläche New wird eine neue Schemadatei angelegt. Das benötigte Schema kann man beim Anklicken der Schaltfläche Copy kopieren. Der Button Delete lässt das ausgewählte Schema löschen. Um das aktive Schema umzubenennen, klickt man den Button Rename an.

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Vorschau

Die Vorschauparameter werden unter dieser Registerkarte angegeben.

Ist Visible aktiviert, werden die Zeilen der Gruppierung angezeigt.

Ist Auto Height aktiviert, wird die Höhe der Zeilen automatisch angegeben.

Die maximale Menge der Zeilen wird auf der Seite im Indikator Max Line Count angegeben.

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Karten

Unter dieser Registerkarte kann man die Darstellungsart von Karten einstellen.

Im Abschnitt Sizes sind die Größe der Karten zu bestimmen:

  • der mit dem Häkchen aktivierte Punkt Auto Width wird die Breite der Karten automatisch angepasst
  • Keep Same Width - hiermit wird die ursprüngliche Breite festgelegt
  • Keep Same Height - hiermit wird die ursprüngliche Höhe festgelegt

Im Abschnitt Spacing wird der Zwischenraum bei den Karten bestimmt:

Horizontal - Zwischenraum horizontal

Vertical - Zwischenraum vertikal

Im Abschnitt Framing kann man die Parameter der Kartenrahmen angeben.

  • Border - ist das Häkchen aktiviert, dann wird die Karte eine Außengrenze haben,
  • Horizontal Lines - in der Karte werden die horizontalen Linien für jede Zeile gesetzt
  • Vertical Lines - hiermit werden die vertikalen Linien hinzugefügt

Mit Hilfe des Werkzeuges im Abschnitt Shadow sind die Parameter des Kartenschattens anzugeben.

Color - Farbe

Depth - Schärfe

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Diagramme

Unter dieser Registerkarte können bei Aktivierung des Häkchens Transparent Diagramm-Eigenschaften, wie Transparenz, eingestellt werden.

Alle eingetragenen Änderungen werden im Entwurf, der sich im rechten Teil des Formulars befindet, angezeigt.


Editor vom BLOB-Datentyp

Enthält die Tabelle Felder mit dem BLOB-Datentyp (dazu gehören solche Typen wie ntext, text, image, binary, varbinary, XML), dann erscheint in der Datenansicht eine zusätzliche Registerkarte Blob View. Unter dieser Registerkarte kann man jeden BLOB-Datentyp bearbeiten. Es steht für jeden Typ eine Registerkarte zur Verfügung:

im hexadezimalen Modus bearbeiten

als Text bearbeiten

als Rich-Text-Feld bearbeiten

als Bild bearbeiten

als HTML bearbeiten

Das Arbeiten mit den Datensätzen unter der Registerkarte Blob View.

Zum Navigieren durch die Datensätze verwendet man eine standardmäßige Symbolleiste der Datenansicht.

Auf dieser Leiste befinden sich ebenso die Schaltflächen zum Speichern der Änderungen, Abbrechen vom Speichern der Änderungen, Hinzufügen und Löschen von Datensätzen.

Die Schaltflächen zum Arbeiten mit den BLOB-Daten sind auf der Symbolleiste der Registerkarte Blob View zu finden.

Siehe auch:

Datenansicht

Tabelleneditor

SQL-Editor

Visueller Query-Builder

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Im hexadezimalen Modus bearbeiten

Unter der Registerkarte Hexadecimal können die Infos in einer Zelle des BLOB-Feldes betrachtet und bearbeitet werden. Im linken Teil des Formulars ist der Inhalt der Zelle im hexadezimalen Modus (hexadezimale Werte der Bytes) angezeigt, im rechten ist ein gewöhnlicher Text dargestellt.

Zum Navigieren durch die Datensätze verwendet man eine standardmäßige Symbolleiste der Datenansicht.

Auf dieser Leiste befinden sich ebenso die Schaltflächen zum Speichern der Änderungen, Abbrechen vom Speichern der Änderungen, Hinzufügen und Löschen von Datensätzen.

Die Schaltflächen zum Arbeiten mit den BLOB-Daten sind auf der Symbolleiste der Registerkarte Blob View zu finden.


Als Text bearbeiten

Unter der Registerkarte Text ist der Inhalt einer Zelle als bearbeitbarer Text dargestellt.

Zum Navigieren durch die Datensätze verwendet man eine standardmäßige Symbolleiste der Datenansicht.

Auf dieser Leiste befinden sich ebenso die Schaltflächen zum Speichern der Änderungen, Abbrechen vom Speichern der Änderungen, Hinzufügen und Löschen von Datensätzen.

Die Schaltflächen zum Arbeiten mit den BLOB-Daten sind auf der Symbolleiste der Registerkarte Blob View zu finden.


Als Rich-Text-Feld bearbeiten

Unter der Registerkarte Rich Text ist der Text als RTF (Rich-Text-Format) dargestellt. Dieser kann formatiert werden: man kann die Schrift verändern, deren Form und Größe verändern, Listen hinzufügen, Intervalle zwischen den Zeilen bestimmen usw.

Zum Navigieren durch die Datensätze verwendet man eine standardmäßige Symbolleiste der Datenansicht.

Auf dieser Leiste befinden sich ebenso die Schaltflächen zum Speichern der Änderungen, Abbrechen vom Speichern der Änderungen, Hinzufügen und Löschen von Datensätzen.

Die Schaltflächen zum Arbeiten mit den BLOB-Daten sind auf der Symbolleiste der Registerkarte Blob View zu finden.


Als Bild bearbeiten

Hat das Feld in der Datenbank den Image-Typ, kann man in diesem Feld das Bild auf der Registerkarte Image des Werkzeuges Blob View hinzufügen und bearbeiten.

Zum Navigieren durch die Datensätze verwendet man eine standardmäßige Symbolleiste der Datenansicht.

Auf dieser Leiste befinden sich ebenso die Schaltflächen zum Speichern der Änderungen, Abbrechen vom Speichern der Änderungen, Hinzufügen und Löschen von Datensätzen.

Die Schaltflächen zum Arbeiten mit den BLOB-Daten sind auf der Symbolleiste der Registerkarte Blob View zu finden.

Unter der Registerkarte im unteren Teil des Formulars werden die Infos über die Größe und das Format des Bildes

angezeigt.


Als HTML bearbeiten

Ist in der Zelle der HTML-Datentyp, ist es besser, diesen auf der Registerkarte HTML zu bearbeiten.

Zum Navigieren durch die Datensätze verwendet man eine standardmäßige Symbolleiste der Datenansicht.

Auf dieser Leiste befinden sich ebenso die Schaltflächen zum Speichern der Änderungen, Abbrechen vom Speichern der Änderungen, Hinzufügen und Löschen von Datensätzen.

Die Schaltflächen zum Arbeiten mit den BLOB-Daten sind auf der Symbolleiste der Registerkarte Blob View zu finden.


Filter-Builder

Im SQL Manager 2007 for MySQL steht ein spezielles Werkzeug zum Bestimmen des Datenauswählens in der Tabelle der Datenansicht zur Verfügung. Mit Hilfe des Filter-Builders kann man nicht nur die Bedingung des Auswählens eines beliebigen Schwierigkeitsniveaus erstellen, sondern auch diese in Datei speichern und aus Datei laden (siehe Schaltflächen des Filter-Builders). Somit wird ermöglicht, mehrmals ein Filter zu verwenden.

Start des Filter-Builders

Arbeiten mit den Bedingungen

Arbeiten mit den Gruppen

Filtereinsatz

Siehe auch:

Datenansicht

Tabelleneditor

SQL-Editor

Visueller Query-Builder

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Start des Filter-Builders

Der Filter-Builder kann man auf zwei verschiedenen Weisen öffnen:

  • mit Hilfe der Schaltfläche Filter data [image] auf der Symbolleiste der Arbeit mit den Datensätzen:
  • mit Hilfe der Schaltfläche Customize.... auf der Leiste des unteren Teils der Tabelle.

Ist für eine Tabelle das Filter gesetzt, erscheint im unteren Teil eine spezielle Leiste, in der die Filterbedingungen zu sehen sind.

Mit Hilfe dieser Leiste kann man:

  • Filter löschen, indem man die Schaltfläche [image] drückt,
  • Filter aktivieren, indem man das Häkchen setzt,
  • Filterbedingungen mit Hilfe der Schaltfläche Customize.... Diese Schaltfläche lässt den Filter-Builder starten.

Des Weiteren werden auf dieser Leiste die Filterbedingungen und ebenso der Modifikationsverlauf angezeigt. Dies wird beim Betätigen der Schaltfläche [image] geöffnet.


Arbeiten mit den Bedingungen

Neue Bedingung kann man auf zwei verschiedene Weisen hinzufügen:

  • Button press the button to add condition anklicken,
  • Punkt Add Condition aus dem Menü, das beim Betätigen der Schaltfläche Filter geöffnet wird, auswählen.

Die Bedingungen kann man in Gruppen vereinigen.

Die Relation zwischen den Gruppen wird durch den Gruppenoperator bestimmt. Dieser wird aus der Liste, die beim Öffnen des Datensatzes AND geöffnet wird, ausgewählt.

Die Beschriftung nach AND verweist auf die Gruppe mit den Bedingungen. Der Bezeichner der Hauptgruppe ist <root>.

Danach muss man eine oder mehrere Bedingungen des Datenauswählens angeben. Jede Zeile ist eine Bedingung.

Mit Hilfe des Menüs kann man die Bedingung hinzufügen bzw. entfernen.

Das Menü wird beim Betätigen der Schaltfläche [image] geöffnet.

  • Bedingung hinzufügen - Add Condition,
  • Gruppe hinzufügen - Add Group,
  • Gruppe bzw. Bedingung entfernen - Remove Row.

Beim Drücken auf die grün markierte Beschriftung wird eine Tabellenliste von Feldern, Abfrage bzw. View geöffnet. Aus der Liste wird ein Feld, für das die Auswahlbedingungen angegeben werden müssen, ausgewählt.

Drückt man auf die nächste Beschriftung, wird ein Operator aus der Dropdownliste ausgewählt.

In der Liste sind die nachfolgenden Operatoren vorhanden:

  • ist gleich - equals,
  • ist nicht gleich - does not equal,
  • ist größer als - is greater than,
  • ist größer als oder gleich wie - is greater than or equal to,
  • ist weniger als - is less than,
  • ist weniger als oder gleich wie - is less than or equal to,
  • wie (für Textfelder) - like,
  • nicht wie (für Textfelder) - not like,
  • ist leer - is blank,
  • ist nicht leer - is not blank,
  • zwischen <Wert> und <Wert> - between,
  • nicht zwischen - not between,
  • in - in,
  • nicht in - not in.

Standardmäßig wird für die Zeilenfelder bzw. die Felder mit dem Typ datetime der Operator equals, für Textfelder - like verwendet)

Für den Feldertyp Data erscheinen in dieser Liste noch einige Parameter:

  • ist gestern - is yesterday,
  • ist heute - is today,
  • ist morgen - is tomorrow,
  • ist letzte Woche - is last week,
  • ist letzter Monat - is last month,
  • ist letztes Jahr - is last year,
  • ist diese Woche- is this week,
  • ist dieser Monat - is this month,
  • ist dieses Jahr - is this year,
  • ist nächste Woche - is next week,
  • ist nächster Monat - is next month,
  • ist nächstes Jahr - is next year.

Nach dem Auswählen des Operators muss ein Auswahlkriterium bestimmt werden. Beim Drücken auf die Beschriftung <empty> erscheint statt dessen ein Feld zur Eingabe des Wertes. Der Feldtyp entspricht dem Datentyp. Für den Text gibt es ein Textfeld, für Zeilen einen Zähler und für Datum/Zeit einen Kalender. Mit dem Zeichen "%" wird ein beliebiger Zeichensatz und mit dem Zeichen "_" ein beliebiges Zeichen angegeben.

Für die Operatoren between und not between erscheinen zwei Felder, da ein Intervall angegeben werden muss.

Im Feld wird die Reihenfolge von Zeichen angegeben. Beim Ausführen der Bedingungen werden nur die Werte, die einer angegeben Bedingung entsprechen, ausgewählt.

Wenn beispielsweise der Operator is greater than (ist größer als) ausgewählt und im Feld 100 angegeben wurde, werden in der Tabelle nur die Zeilen angezeigt, in deren dieser Wert mehr als 100 beträgt.


Arbeiten mit den Gruppen

Man kann man mehrere Bedingungen für den Filter angeben. Die Bedingungen lassen sich in Gruppen vereinigen. Zwischen den Gruppenbedingungen kann man die Relationen erstellen. Die Gruppen haben eine hierarchische Struktur. Der Gruppenoperator erstreckt sich über die Gruppen, die sich in der Hauptgruppe befinden.

In jeder Gruppe werden die Bedingungen für jedes Feld gesetzt.

Mit Hilfe des Kontextmenüpunktes Add Group kann man eine Gruppe hinzufügen [image] . Das Kontextmenü wird beim Klicken auf den Button [image] geöffnet.

Die Relationen zwischen den Gruppen werden durch den Gruppenoperator bestimmt, der beim Klicken auf die Beschriftung AND ausgewählt wird.

Es stehen vier Gruppenoperatoren zur Verfügung:

  • AND - alle Aktionen müssen gleichzeitig ausgeführt werden
  • OR - mindestens eine Gruppenbedingung muss ausgeführt werden
  • NOT AND - mindestens eine der aufgezählten Aktionen muss nicht ausgeführt werden
  • NOT OR - keine der aufgezählten Aktionen muss ausgeführt werden


Schaltflächen des Filter-Builders

Der Dateifilter hat eine Erweiterung .flt. Solche Dateien kann man mit Hilfe der Schaltfläche Open, die sich unten im Formular befindet, öffnen. Die Schaltfläche Save As erlaubt den erstellten Filter in Datei zu speichern.

Um den erstellten Filter einzusetzen, werden die Schaltflächen Ok bzw. Apply benutzt. Beim Klicken auf Ok wird der Builder geschlossen, beim Klicken auf Apply bleibt dieser geöffnet. Sie können den erstellten Filter unter Berücksichtigungen der Ergebnisse verbessern.

Beim Betätigen der Schaltfläche Cancel wird der Builder geschlossen, ohne Änderungen gespeichert zu haben.


Tools zum Import und Export von Daten

SQL Manager 2007 for MySQL stellt dem Benutzer eine Vielzahl von Werkzeugen zum schnellen und komfortablen Import und Export von Daten zur Verfügung.

Datenexport

Beim Datenexport werden die Daten in Dateien mit unterschiedlichen Formaten exportiert. Darunter sind: MS Excel, MS Access, RTF, HTML, PDF und weitere.

Datenimport

Beim Datenimport werden die Daten aus Dateien folgender Formate importiert: MS Excel, MS Access, DBF, TXT, and CSV, HTML, XML Document, MS Excel 2007, Word 2007, ODF Spreadcheets, ODF Text.

Export als SQL-Skript

Beim Export als SQL-Skript wird der Datenexport ins SQL-Skript als ein Satz von INSERT-Anweisungen ausgeführt.

Laden von Daten

Beim Laden von Daten werden die Daten in eine Tabelle oder eine View geladen.

Speichern von Daten

Dieses Tool hilft Daten zu speichern.

Verwendung von Vorlagen


Assistent zum Exportieren von Daten

Der Assistent zum Exportieren von Daten - Export Data Wizard - hilft die Daten aus Tabellen, Views, Abfrageergebnissen in die gängigsten Dateiformate zu exportieren.

Das Exportieren von Daten wird ausschließlich aus den Editoren ausgeführt, wo die Registerkarte Data bzw. Results vorhanden ist. Das wären Tabelleneditor, Vieweditor, SQL-Editor und visueller Query-Builder.

Dieses Werkzeug wird mit Hilfe des Buttons Export Data geöffnet. Dieser Button befindet sich auf der Navigationsleiste Data Management und auf der Werkzeugsleiste. Der Button ist verfügbar, wenn im Editor der Datenviewer geöffnet ist, also auf der Registerkarte Data oder Results. Dieser Befehl ist ebenso im Kontextmenü von Objekten einer Tabelle oder einer View, im DB-Explorer und im Untermenü des Punktes Data Manipulation vorhanden.

Bestimmen des Zieldateinamens und des Formates für die zu exportierenden Daten

Auswählen von den zu exportierenden Feldern

Einstellen von Datenformaten

Bestimmen von Kopf- und Fußzeilen

Eingabe der Formatspezifizierungen

Eingabe der gesamten Exportoptionen

Betrachten von Ergebnissen

Verwendung der Vorlagen.

Datenexport als SQL-Skript

Datenimport

Laden von Daten

Speichern von Daten

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Bestimmen des Zieldateinamens und des Formates für die zu exportierenden Daten

In diesem Schritt des Assistenten zum Exportieren von Daten muss man:

  • ein Format der zu exportierenden Datei im Abschnitt Destination format auswählen, indem man den Indikator gegenüber dem gewünschten Format setzt.
  • im Feld Destination file name wird der Name der zu exportierenden Datei und der Pfad zu derer mit Hilfe des Buttons [image] angegeben

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen der zu exportierenden Felder

In diesem Schritt werden aus der Liste aller Tabellenfelder die zu exportierenden Felder ausgewählt.

Aus der Liste Available Fields werden die verfügbaren Felder ausgewählt und mit Hilfe der Buttons in die Liste der zu exportierenden Felder übertragen. Wählt man kein Feld, dann werden standardmäßig alle Felder exportiert.

Bei Aktivierung des Häkchens Allow Caption werden die Spaltenköpfe in die erste Zeile gebracht.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Einstellen von Datenformaten

Im dritten Schritt wird angegeben, in welchem Format die Daten angezeigt werden.

Man kann Formate für folgende Datenformate angeben:

  • Integer format - Ganzzahlenformat,
  • Float format - Gleitkomma-Format,
  • Date format - Datumsformat,
  • Time format - Uhrzeitformat,
  • DateTime format - Datum/Uhrzeit Format,
  • Currency format - Währungsformat,
  • Boolean True - Logisch Wahr,
  • Boolean False - Logisch Falsch,
  • Null string - NULL -Zeichenfolge

Für einige Datentype kann man zusätzlich Trennzeichen angeben:

Decimal Separator - Trennzeichen für Dezimalzahlen

Date Separator - Trennzeichen für Datum,

Thousand Separator - Trennzeichen für Tausendzahlen

Time Separator - Tausendzahlen für Uhrzeit

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Bestimmen von Kopf- und Fußzeilen

In diesem Schritt wird angegeben, welcher Text im Kopf- bzw. Fußzeile der zu exportierenden Datei angezeigt wird.

Wenn ein Dateiformat ausgewählt wurde, das Kopf- bzw. Fußzeilen nicht unterstützt, fällt dieser Schritt weg.

Im Feld Header text wird der Text der Kopfzeile angegeben.

Im Feld Footer text wird der Text der Fußzeile angegeben.

Dieser Text wird auf jeder Seite der Zieldatei wiederholt werden.

Beim Exportieren des Ausführungsergebnisses einer Abfrage, die im SQL-Editor und Visuellen Abfrage-Generator erstellt wurde, kann man den Abfragetext in der Kopfzeile der zu erhaltenden Datei mithilfe der Schaltfläche Add query text to Header hinzufügen.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Eingabe der Formatspezifizierungen

Der Optionssatz wird im fünften Schritt durch das ausgewählte Format der Zieldatei bestimmt.

Man kann unterschiedliche Eigenschaften für folgende Formate angeben:

Excel

Access

Word / RTF

HTML

PDF

TXT

CSV

XML

Excel 2007/ODS

Word 2007/ODT

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Anpassen des Exports im Excel

Werden die Daten in eine Datei mit dem Excelformat exportiert, können folgende Eigenschaften im fünften Schritt angegeben werden:

  • Datenformat - unter der Registerkarte Datenformat,
  • Erweiterungen - unter der Registerkarte Erweiterungen,
  • Erweitertes Format - unter der Registerkarte Erweitert.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Format der Tabellen und Daten

Die Registerkarte Data format enthält Werkzeuge zum Formatieren der Zellen einer zu exportierenden Datei.

Solche Parameter wie z.B. Schrift, Ausrichtungen, Grenzen und andere können für alle Zellentypen

(Zellen mit Daten, Köpfen, Links usw.) eingestellt werden. Man kann ebenso Formate erstellen, die für alle Zellentypen verwendbar sind.

Design der Felder

Optionen

Formate

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Design der Felder

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Design der Feldern

Unter der Registerkarte Fields können Designparameter für jedes Feld angegeben werden.

Alle Werzeuge zum Einstellen der Schrift befinden sich auf der Registerkarte Font:

aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen),

Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Auf der Registerkarte Borders wird die Breite und die Art der Zellenrahmen angegeben.

Ist der Button [image] angeklickt, werden die Rahmen angezeigt. Es gibt einen einzelnen Button für obere, untere, rechte und linke Rahmen.

Aus der Dropdownlisten werden die Rahmenarten (einfach, doppelt, gestrichelt und andere) ausgewählt. Beim Anklicken des Buttons [image] kann man für einen Rahmen die Farbe angeben.

Unter der Registerkarte Fill wird das Hintergrundbild einer Zelle bestimmt.

Der Button [image] ist für die Farbe des Hintergrundes bestimmt.

Aus der Dropdownliste ist ein Muster auszuwählen.

Der Button [image] hilft, die Musterfarbe auszuwählen.

Unter der Registerkarte Aggregate kann man für eine Spalte die Ergebnisfunktion eingeben. Das bedeutet, dass für die Daten Folgendes in der Spalte gefunden werden kann:

  • Summe - SUM,
  • Mittelwert - AVG,
  • Minimaler Wert - MIN,
  • Maximaler Wert - MAX.

Im untenliegenden Fenster sind alle Änderungen, die mit einem Feld ausgeführt werden, zu sehen. Sie werden im Textmuster dargestellt.

Die Buttons Reset Item und Reset All sind zum Zurücksetzen der Änderungen eines Feldes bzw. aller Felder vorgesehen.


Optionen

Unter der Registerkarte Options können die Eigenschaften eines Hilfetextes eingegeben werden:

  • Kopfzeile - HEADER,
  • Kopf - CAPTION,
  • Aggregate-Funktionen - AGGREGATE,
  • Fußzeile - FOOTER,
  • Hyperlink - HYPERLINK.

Alle Werkzeuge zum Einstellen der Schrift befinden sich auf der Registerkarte Font:

aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen),

Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Unter der Registerkarte Borders wird die Breite und die Art der Zellenrahmen angegeben.

Ist der Button [image] angeklickt, werden die Rahmen angezeigt. Es gibt einen einzelnen Button für obere, untere, rechte und linke Rahmen.

Aus der Dropdownlisten werden die Rahmenarten (einfach, doppelt, gestrichelt und andere) ausgewählt. Beim Anklicken des Buttons [image] kann man für einen Rahmen die Farbe angeben.

Unter der Registerkarte Fill wird das Hintergrundbild einer Zelle bestimmt.

Der Button [image] ist für die Farbe des Hintergrundes bestimmt.

Aus der Dropdownliste ist ein Muster auszuwählen.

Der Button [image] hilft die Musterfarbe auszuwählen.

Im untenliegenden Fenster sind alle Änderungen, die mit einem Feld ausgeführt werden, zu sehen. Sie werden im Textmuster dargestellt.

Die Buttons Reset Item und Reset All sind zum Zurücksetzen der Änderungen eines Feldes bzw. aller Felder vorgesehen.


Formate

Man kann einen eigenen Satz von Formaten erstellen, die bei den Spalten und Zeilen verwendet werden.

Die Formate werden auf der Registerkarte Styles angelegt.

Damit können Tabellen bestimmt werden, indem man diverse Farben für Spalten und Zeilen angibt.

Um ein Format zu erstellen, muss man auf den Button "+" klicken. Zum Löschen des Formates wird der Button "-" angeklickt.

Durch Betätigen dieser Buttons [image] wird die Reihenfolge der Formate verändert.

Mit Hilfe der beiden Buttons - Load Styles und Save styles - können Formate aus einer Datei geladen und in einer Datei gespeichert werden.

Das Optionsfeld Strip style bestimmt, wie die erstellten Formate verwendet werden:

  • None - nicht verwendbar,
  • Col - für Spalten verwendbar,
  • Row - für Zeilen verwendbar.

Falls ein Format erstellt und Col bzw. Row im Optionsfeld Strip style ausgewählt werden, wird das Format für die gesamte Tabelle verwendet.

Falls zwei Formate erstellt und Col ausgewählt wird, wird für ungerade Spalten das erste Format verwendet und für gerade Spalten wird jeweils das zweite Format verwendet.

Alle Werkzeuge zum Einstellen der Schrift befinden sich auf der Registerkarte Font:

aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen), Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Auf der Registerkarte Borders wird die Breite und die Art der Zellenrahmen angegeben.

Ist der Button [image] angeklickt, werden die Rahmen angezeigt. Es gibt einen einzelnen Button für obere, untere, rechte und linke Rahmen.

Aus der Dropdownlisten werden die Rahmenarten (einfach, doppelt, gestrichelt und andere) ausgewählt. Beim Anklicken des Buttons [image] kann man für einen Rahmen die Farbe angeben.

Auf der Registerkarte Fill wird das Hintergrundbild einer Zelle bestimmt.

Der Button [image] ist für die Farbe des Hintergrundes bestimmt.

Aus der Dropdownliste ist ein Muster auszuwählen.

Der Button [image] hilft die Musterfarbe auszuwählen.

Im untenliegenden Fenster sind alle Änderungen, die mit einem Feld ausgeführt werden, zu sehen. Sie werden im Textmuster dargestellt.

Die Buttons Reset Item und Reset All sind zum Zurücksetzen der Änderungen eines Feldes bzw. aller Felder vorgesehen.


Erweiterungen

Die Registerkarte Extensions erlaubt:

Links in Zellen zu erstellen - Objekte Hyperlinks,

Anmerkungen für jede Zeile der zu exportierenden Datei zu erstellen - Notes,

Eigenschaften eines Diagramms einzustellen - Charts,

Wert und Typ einer Zelle zu bestimmen - Cells,

die zu verbindenden Zellen anzugeben - Merged Cells

Alle diese Objekte in Form einer hierarchischen Liste dargestellt.

Zum Erstellen eines Objektes muss die Schaltfläche "+", zum Löschen eines Objektes die Schaltfläche "-" angeklickt werden.

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Hyperlinks

Unter dieser Registerkarte können die Parameter des erstellten Hyperlinks verändert werden.

Hinweis: Falls ein Hyperlink erstellt wurde, wird sein angegebener Name im Feld Title den Inhalt der Zelle, der dafür erstellt wurde, erstetzen.

Eigenschaften des Hyperlinks:

Mit Hilfe der Optionsfelder Col und Row wird die Zelle, in der sich der Hyperlink befinden wird, bestimmt. Col ist die Nummer einer Spalte, Row ist die Nummer einer Zeile.

Im Abschnitt Style wird ein Linktyp: eine URL, d.h. Adresse im Internet oder Local file, d.h. eine Datei im Rechner, auf dem der SQL Manager 2007 for MySQL gestartet wurde bzw. eine Datei im lokalen Netz ausgewählt.

Im Feld Title wird der Name des Hyperlinks angezeigt.

Im Feld Target wird der Pfad zu einer Datei bzw. einer Website angegeben.

Die Schaltfläche [image] hilft eine auf dem Rechner oder im lokalen Netz abgelegte Datei auszuwählen.


Anmerkungen

Der Hinweis bezieht sich auf eine Zelle und wird von dem Inhalt der Zelle getrennt gespeichert.

Die Zellen mit Hinweisen werden durch ein Dreieck in der rechten oberen Ecke markiert. Beim Hinweisen auf eine Zelle, die auf solche Weise markiert wurde, werden die Hinweisen angezeigt. Zum Erstellen der Hinweise für die Zellen der zu exportierenden Datei ist auf dem Tab Extensions die Registerkarte Notes vorhanden.

Mit Hilfe der Optionsfelder Col und Row kann eine Zelle, in der die Anmerkung gespeichert wird, angegeben. Col ist die Nummer einer Spalte, Row ist die Nummer einer Zeile.

Im Feld Text wird eine Anmerkung verfasst.

Alle Werkzeuge zur Anmerkungsschrift befinden sich auf der Registerkarte Font:

Aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen), Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Unter der Registerkarte Fill kann der Hintergrund eines Anmerkungsfensters eingestellt werden.

  • Solid - einfarbig,
  • Gradient - Farbverlauf,
  • Horizontal - horizontal,
  • Vertical - vertikal,
  • Diagonal Up - Diagonal oben,
  • Diagonal Down - Diagonal unten,
  • From Corner - von der Ecke aus,
  • From Center - von der Mitte aus.

Die Schaltfläche [image] ist für die Farbe des Hintergrundes bestimmt.

Mit Hilfe der Schaltfläche [image] kann die Farbe des Musters ausgewählt werden.

Indem man den Läufer Transparency von 0% bis 100% schiebt, kann der Transparenzgrad des Anmerkungsfensters eingestellt werden.


Diagramme

In dem zu exportierenden Microsoft Excel Datei kann ein Diagramm erstellt werden.

Hierfür muss man auf der Registerkarte Extensions ein Objekt Chart anlegen.

Die Haupteigenschaften des Diagramms werden auf der Registerkarte Base bestimmt.

Im Feld Title wird der Name des Diagramms angezeigt.

Aus der Dropdownliste Style ist ein Diagrammtyp auszuwählen. Die Liste der Diagramme besteht aus den Standardtypen, wie Histogramm, Kreisdiagramm, Punktdiagramm und anderen.

Im Abschnitt Legend position wird die Position einer Legende angegeben:

  • Bottom - unten,
  • Corner - in der Ecke,
  • Top - oben,
  • Right - rechts,
  • Left - links.

Bei Aktivierung des Häkchens Show legend wird die Legende angezeigt.

Bei Aktivierung des Häkchens Auto color wird im Diagramm jeder Abschnitt mit eigener Farbe markiert. Falls nicht, erhalten alle Abschnitte die gleiche Farbe.

Unter der Registerkarte Position wird die Position eines Diagramms auf dem Blatt angegeben.

Automatisch - Auto:

Im Abschnitt Placement wird die Position eines Diagramms in Bezug auf Daten angegeben.

  • Bottom - unten,
  • Right - rechts.

Unten werden, mit Hilfe der Optionsfelder, die Größe eines Diagramms und Absätze von oben und links in Zentimeter angegeben.

Left - links,

Top - oben,

Height - Höhe,

Width - Breite.

Im Abschnitt Custom wird eine benutzerdefinierte Position eines Diagramms eingestellt.

Unter der Registerkarte Category Labels kann man bestimmen, in welchen Zeilen und Spalten das Diagramm erstellt wird. Aus der Dropdownliste Column wird eine Tabellenspalte, die als X-Achse im Diagramm gilt, ausgewählt.

Beziehungsweise kann man mit Hilfe der Optionsfelder des Abschnittes Custom den Zellenbereich angeben.

Um ein Diagramm zu erstellen, muss ein Objekt Series angelegt werden. Dieses Objekt weist auf die Werte hin, die im Diagramm in der Y-Achse liegen. Für dieses Diagramm können mehrere Serien erstellt werden.

Die Eigenschaften der Serien werden auf einer speziellen Registerkarte angegeben:

Title - Serientitel,

Column - Tabellenspalte, deren Werte eine Serie bildet

Mit Hilfe der Optionsfelder des Abschnittes Custom wird der Zellenbereich angegeben.

Beim Klicken auf die Schaltfläche [image] wird eine Farbe für die Serie eingestellt.


Zellen

Unter dieser Registerkarte wird das Format einer Zelle und ein Wert, der in dieser Zelle gespeichert wird, bestimmt.

Im Optionsfeld Col wird die Nummer einer Spalte und im Optionsfeld Row die Nummer einer Zeile angegeben. Bei ihrer Kreuzung wird sich die zu bearbeitende Zelle befinden. Der Zellentyp wird aus der Dropdownliste Cell type ausgewählt. Im Feld Value wird der Wert, der in einer Zelle gespeichert wird, angegeben.

Im Abschnitt Formats wird bestimmt, in welchem Format die Zahlen- bzw. das Datum angezeigt wird.

Im Feld Data kann der Typ, in dem die Zahlen- bzw. das Datum dargestellt wird, ausgewählt werden. Im Feld Numeric ist ein Format der Zahlenwerte anzugeben.

Alle Werkzeuge zum Einstellen der Schrift befinden sich unter der Registerkarte Font:

Aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen),

Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Unter der Registerkarte Borders wird die Breite und die Art der Zellenrahmen angegeben.

Ist der Button [image] angeklickt, werden die Rahmen angezeigt. Es gibt einen einzelnen Button für obere, untere, rechte und linke Rahmen.

Aus der Dropdownlisten werden die Rahmenarten (einfach, doppelt, gestrichelt und andere) ausgewählt. Beim Anklicken des Buttons [image] kann man für einen Rahmen die Farbe angeben.

Unter der Registerkarte Fill wird das Hintergrundmuster einer Zelle bestimmt.

Der Button [image] ist für die Farbe des Hintergrundes bestimmt.

Aus der Dropdownliste ist ein Muster auszuwählen.

Der Button [image] hilft die Musterfarbe auszuwählen.


Verbundene Zellen

Mit Hilfe der Werkzeuge aus dem Abschnitt Merged Cells können die Zellen in dem zu exportierenden Dokument verbunden werden. Bei Bedarf können mehrere verbundene Zellen erstellt werden. Hierfür müssen auf der Registerkarte Extensions mehrere Objekte Merged Cells angelegt werden.

Mit Hilfe der Optionsfelder wird angegeben, welche Zellen zu verbunden sind:

  • First col - erste Spalte,
  • First row - erste Zeile,
  • Last col - letzte Spalte,
  • Last row - letzte Zeile.


Erweiterte Seitenparameter

Unter der Registerkarte Advanced können die Haupteigenschaften der Seite angegeben werden:

  • Kopfzeile der Seite - im Feld Page header,
  • Fußzeile der Seite - im Feld Page footer,
  • Blattname - im Feld Sheet title,
  • Seitenhintergrund - mit Hilfe der Dropdownliste Page background.

Ist Calculate column width automatically angehakt, wird die Spaltenbreite automatisch angegeben.

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Besonderheiten des Exportierens in Access

Werden die Daten in Access exportiert, müssen im fünften Schritt die Tabellenoptionen angezeigt werden. Im Feld Table name wird der Tabellenname angegeben. Besteht keine Tabelle mit einem Namen, kann diese erstellt werden, indem man Create new table if it does not exist anhakt.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Besonderheiten des Exportierens in Word / RTF

Beim Exportieren von Daten ins Microsoft Word Dokument können folgende Eigenschaften der zu exportierenden Datei angegeben werden:

  • Hauptformate
  • Zeilenformate

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Basisstil

Unter der Registerkarte Base Styles können die Haupteigenschaften des zu exportierenden Dokumentes angezeigt werden.

Aus der Liste wird ein Objekt, für das die Eigenschaften eingegeben werden, ausgewählt:

Kopfzeile - HEADER,

Kopf- CAPTION,

Fußzeile - FOOTER,

Hyperlink - HYPERLINK.

Im Abschnitt Page orientation wird die Seitenausrichtung eingestellt:

Portrait - Hochformat,

Landscape - Querformat.

Aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen),Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Die Schaltfläche [image] ist für die Farbe des Hintergrundes bestimmt. Ist Background aktiviert, wird die Hintergrundsfarbe in der zu exprortierenden Datei angezeigt.

Mit Hilfe der Schaltfläche [image] kann die Farbe des Textes ausgewählt werden. Ist Highlight aktiviert, dann wird in der zu exportierenden Datei der Text mit der angegebenen Farbe markiert.

Im untenliegenden Fenster sind alle Änderungen, die mit einem Feld ausgeführt werden, zu sehen. Diese werden im Textmuster dargestellt.

Die Buttons Reset Item und Reset All sind zum Zurücksetzen der Änderungen eines Objektes bzw. aller Objekte bestimmt.


Zeilendarstellungsstil

Unter der Registerkarte Styles können eigene bei der Darstellung der Spalten und Zeilen verwendete Stile erstellt werden. Mit deren Hilfe kann man sich die Tabelle anzeigen lassen, indem man verschiedene Farbe für Spalten und Zeilen angibt.

Zum Erstellen eines Stiles wird die Schaltfläche "+", zum dessen Löschen die Schaltfläche "-" gedrückt.

Die Reihenfolge der Stile kann mittels der Schaltflächen [image] verändert werden.

Mit Hilfe der folgenden zwei Schaltfläche - Load Styles und Save styles - können Stile aus einer Datei geladen bzw. in einer Datei gespeichert werden.

Das Optionsfeld Strip style bestimmt, wie die erstellten Stile verwendet werden:

  • None - nicht verwendbar,
  • Col - für Spalten verwendbar,
  • Row - für Zeilen verwendbar.

Wird ein Stil angelegt und Col bzw. Row im Optionsfeld Strip style ausgewählt, dann wird der Stil für die ganze Tabelle verwendet werden.

Werden zwei Stile angelegt und Col ausgewählt, wird für die ungeraden Spalten der erste Stil verwendet und für die geraden Spalten - der zweite Stil.

Aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen), Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Die Schaltfläche [image] ist für die Farbe des Hintergrundes bestimmt. Ist Background aktiviert, wird die Hintergrundfarbe in der zu exportierenden Datei angezeigt.

Mit Hilfe der Schaltfläche [image] kann die Farbe des Textes ausgewählt werden. Ist Highlight aktiviert, wird in der zu exportierenden Datei der Text mit der angegebenen Farbe markiert.

Im untenliegenden Fenster sind alle Änderungen, die mit einem Feld ausgeführt werden, zu sehen. Sie werden im Textmuster dargestellt.

Die Buttons Reset Item und Reset All sind zum Zurücksetzen der Änderungen eines Objektes bzw. aller Objekte bestimmt.


Besonderheiten des Exportierens in HTML

Exportiert man die Daten im HTML-Format, dann können für die zu exportierende Datei folgende Merkmale bestimmt werden:

  • Darstellungsart der Tabelle in der zu exportierenden Datei ist aus den angebotenen Formaten auf der Registerkarte Preview auszuwählen,
  • Hauptfunktionen der zu exportierenden Datei werden auf der Registerkarte Basic angegeben,
  • Eigenschaften eines mehrseitigen Dokumentes kann man auf der Registerkarte Multi-file angeben,
  • Schrift und Format der Tabellenzellen sind auf der Registerkarte Advanced einzustellen.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Autoformat

Unter der Registerkarte Preview wird die Darstellungsart der Tabellendaten eingestellt.

Aus der Dropdownliste Template kann bereits eine fertig erstellte Vorlage für die Darstellung des Dokumentes ausgewählt werden. Im Fenster der Vorschau ist angezeigt, wie die Endtabelle aussehen wird, wenn man für diese eine ausgewählte Vorlage der Darstellungsart verwendet.

Zur Änderung der Vorlage muss ein beliebiges Element im Vorschaufenster angeklickt werden. Beim Anklicken des Elementes erscheint eine Standardpalette, aus der eine gewünschte Farbe für dieses Element ausgewählt werden kann.

Man kann die Farbe eines Textes, eines Hintergrundes und unterschiedliche Hyperlinks abändern.

Die eingetragenen Änderungen sind als Vorlage beim Betätigen der Schaltfläche Save template zu speichern. In diesem Fall kann man beim Exportieren schon die fertig erstellte Vorlage einsetzen, indem man diese mittels der Schaltfläche Load template lädt.


Basisoptionen

Die Eigenschaften der zu exportierenden Datei können auf der Registerkarte Basic eingestellt werden.

Der Titel einer ursprünglichen HTML-Datei wird im Feld Title angezeigt. Standardmäßig entspricht dieser dem Titel des zu exportierenden Objektes.

Im Abschnitt Cascade style sheet options kann der Speicherort für Tabellenstile ausgewählt werden:

Internal - Stile werden in der zu exportierenden HTML-Datei gespeichert,

External- es wird für Tabellenstile eine separate Datei im Format *.css erstellt werden.

Im Feld CSS file name wird der Name einer CSS-Datei angegeben und ebenso ausgewählt, wo diese mittels der Schaltfläche [image] gespeichert werden kann.

Ist Overwrite CSS file if it exist aktiviert, wird bei der Erstellung einer neuen CSS-Datei die bestehende Datei durch die neue Datei ersetzt.

Bei Aktivierung des Punktes Export boolean fields as HTML check boxes wird angegeben, dass alle boolean-Tabelle als Kennzeichen angezeigt werden.


Mehrseitiges Dokument

SQL Manager 2007 for MySQL hilft Tabellen, die eine beliebige Anzahl der Datensätze enthalten, zu exportieren. Zum komfortablen Anschauen einer Tabelle mit einer Vielzahl der Datensätze in der zu exportierenden HTML-Datei kann man beim Exportieren angeben, dass die zu exportierende Datei aus mehreren Seiten bestehen wird. Hinzu kann die Anzahl der Zeilen auf jeder Seite angegeben werden.

Im Abschnitt Multi-file export können Parameter des zu exportierenden mehrseitigen Dokumentes eingestellt werden:

  • beim Anhaken des Eintrages Use Multi-file export wird angegeben, dass das zu erstellende HTML-Dokument mehrseitig sein wird,
  • im Optionsfeld Record(s) in a single file wird eingestellt, wie viele Datensätze auf jeder Seite zu enthalten sind,
  • ist Generate index angehakt, dann eine Inhaltsseite erstellt, in der die Links auf alle Seiten mit Daten zu finden sind.
  • im Feld ist der Seitentitel, der im Inhalt neben der Nummerseite angezeigt wird, zu schreiben.

Es muss im mehrseitigen Dokument ein System zum Übergehen von einer zur anderen Seite bzw. zum Inhalt geben.

Im Abschnitt Navigation werden Eigenschaften der Navigationselemente der Verwaltung eingestellt. Dies sind Elemente zum Übergehen zwischen der Seite des Dokumentes. Die Navigation im mehrseitigen Dokument wird mit Hilfe der Links, die sich in einer Zeile befinden, ausgeführt. Diese Zeile kann man platzieren:

  • oben der Seite - indem man das Kennzeichen On top setzt,
  • unten der Seite - indem man das Kennzeichen On bottom setzt.

Des Weiteren wird in den Textfeldern der Text von Links angezeigt:

  • Index link - Linktext auf die Seite des Inhaltes,
  • First link - Linktext auf die erste Seite mit Daten,
  • Prior link - Linktext auf die vorherige Seite mit Daten,
  • Next link - Linktext auf die nächste Seite mit Daten,
  • Last link - Linktext auf die letzte Seite mit Daten


Darstellung der zu exportierenden Datei

Wie die zu exportierende Datei aussehen wird, kann mit Hilfe der Werkzeuge auf der Registerkarte Advanced

einstellt werden.

Im Abschnitt Body options werden Eigenschaften für die ganze Seite bestimmt werden:

  • Default font - Schrift aller Seiten der zu exportierenden Datei,
  • Background - Hintergrund des Dokumentes (mit Hilfe der Schaltfläche [image] kann als Hintergrund ein beliebiges Bild ausgewählt werden),
  • Advanced attributes - erweiterte Attribute einer Seite.

Im Abschnitt Table Options können einige Eigenschaften der Tabellendaten angegeben werden, z.B.:

  • Cell padding - Füllzeichen,
  • Cell spacing - Zellenabstand,
  • Border - Rahmen,
  • Background - Hintergrund (mit Hilfe der Schaltfläche [image] kann als Hintergrund ein beliebiges Bild ausgewählt werden)
  • Advanced attributes - erweiterte Attribute einer Seite.


Besonderheiten des Exportierens in PDF

Sollen die Daten in eine PDF-Datei exportiert werden, können im fünften Schritt folgende Eigenschaften angegeben werden:

Aus der Liste wird ein Objekt ausgewählt, für das eine Darstellungsart der Schrift bestimmt werden muss:

Header font - Kopfzeile,

Caption font - Kopf,

Hyperlink - Hyperlink,

Footer font - Fußzeile.

Aus der Dropdownliste Base font name wird die gewünschte Schrift ausgewählt. Die Zeichencodierung wird aus der Liste Font encoding ausgewählt. Im Optionsfeld Font size wird die Schriftgröße angegeben.

Die Schaltfläche [image] bestimmt die Schriftfarbe.

Im unten liegenden Feld können alle mit einem Objekt ausgeführten Änderungen angesehen werden. Sie werden im Muster "SAMPLE" dargestellt.

Im Abschnitt Page options können Seitenparameter eingestellt werden:

  • aus der Dropdownliste Page size wird die Seitengröße ausgewählt. Standardmäßig ist die Größe А4 eingestellt,
  • Seitenbreite wird im Optionsfeld Width angegeben,
  • Seitenhöhe wird im Optionsfeld Height eingestellt,
  • in der Dropdownliste Units gibt es Messeinheiten der Seitengröße,
  • aus der Dropdownliste Orientation wird die Seitenausrichtung ausgewählt: (Portrait - Hochformat, Landscape - Querformat)

Im Abschnitt Margins kann die Größe der Seitenrahmen angegeben werden:

Left - links,

Right -rechts,

Top - oben,

Bottom - unten.

Grid options. In diesem Abschnitt können einige Rasteroptionen gesetzt werden:

Col spacing - Spaltenabstand,

Row spacing - Zeilenabstand,

Line width - Linienbreite

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Besonderheiten des Exportierens in TXT

Sollen die Daten in eine TXT-Datei exportiert werden, können im fünften Schritt folgende Eigenschaften angegeben werden:

  • in der zu exportierenden Datei wird automatisch die Spaltenbreite eingestellt, falls Calculate column width angehakt wurde
  • Zellenabstand wird mit dem Optionsfeld Spacing angegeben.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Besonderheiten des Exportierens in CSV

Sollen die Daten in eine CSV-Datei exportiert werden, können im fünften Schritt folgende Eigenschaften angegeben werden:

  • falls Quote strings angehakt ist, wird jeder Zellenwert in Anführungszeichen gesetzt. Aus der Dropdownliste Quote ist die Art der Anführungszeichen auszuwählen.
  • aus der Dropdownliste kann ein Trennzeichen der Spalten ausgewählt werden.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Besonderheiten des Exportierens in XML

Sollen die Daten in eine XML-Datei exportiert werden, können im fünften Schritt folgende Eigenschaften angegeben werden:

  • Codierung wird aus der Dropdownliste Encoding ausgewählt,
  • falls Standalone angehakt ist, wird eine eigenständige Codierung verwendet.

Aus der Dropdownliste XML type wird der zu verwendete XML-Typ ausgewählt. Wurde der Typ Access ausgewählt, kann das Kennzeichen Export XSD Schema eingestellt werden. Dies ermöglicht, das XSD-Schema zu exportieren.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Besonderheiten des Exportierens in Excel 2007/ODS

Sollen die Daten in eine Excel 2007-/ODS-Datei exportiert werden, können im fünften Schritt folgende Parameter zur Darstellung des Textes angegeben werden:

Die Parameter, zur Darstellung des standardmäßigen Dateibereiches, können auf der Registerkarte Base Style eingestellt werden. Die folgenden Parameter können geändert werden:

  • HEADER - Kopfzeile,
  • CAPTION - Kopf,
  • DATA - Daten,
  • FOOTER - Fußzeile.

Unter der Registerkarte Strip Styles werden unterschiedliche Farben für Spalten und Zeilen bestimmt:

Zum Erstellen eines Stiles wird die Schaltfläche "+", zum dessen Löschen die Schaltfläche "-" gedrückt.

Die Reihenfolge der Stile kann mittels der Schaltflächen [image] verändert werden.

Mit Hilfe der folgenden zwei Schaltfläche - Load Styles und Save styles - können Stile aus einer Datei geladen bzw. in einer Datei gespeichert werden.

Das Optionsfeld Strip style bestimmt, wie die erstellten Stile verwendet werden:

  • None - nicht verwendbar,
  • Col - für Spalten verwendbar,
  • Row - für Zeilen verwendbar.

Wird ein Stil angelegt und Col bzw. Row im Optionsfeld Strip style ausgewählt, wird der Stil für die ganze Tabelle verwendet.

Werden zwei Stile angelegt und Col ausgewählt, dann wird für die ungeraden Spalten der erste Stil verwendet und für gerade Spalten - der zweite Stil.

Für einen standardmäßigen bzw. erstellten Stil können folgende Charakteristiken angegeben werden:

  • Auf der Registerkarte Font werden Schrifteigenschaften eines bearbeitenden Stils ausgewählt.

Aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftarten (Fett, Kursiv bzw. Durchgestrichen),Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Ist Background aktiviert, dann wird eine spezielle Schaltfläche [image] zum Öffnen des Standardfensters für die Farbeauswahl geöffnet. Beim Betätigen der Schaltfläche Wrap text wird angegeben, dass der Text in Zellen wörtlich übertragen werden kann.

  • Unter der Registerkarte Border werden Seitenparameter gesetzt:

Sollen spezielle Seitenparameter für Zellenrahmen eingestellt werden, muss Use Border aktiviert werden.

Beim Anklicken der Schaltfläche [image] - Border Color kann die Rahmenfarbe bestimmt werden. Aus der Dropdownliste Border Style wird ein Rahmentyp ausgewählt (einfach, doppelt, gestrichelt und andere).


Besonderheiten des Exportierens in Word 2007/ODT

Sollen die Daten in eine Word 2007-/ODT-Datei exportiert werden, können im fünften Schritt folgende Parameter zur Darstellung des Textes angegeben werden:

Die Parameter zur Darstellung des standardmäßigen Dateibereiches können auf der Registerkarte Base Style eingestellt werden. Die folgenden Parameter können geändert werden:

  • HEADER - Kopfzeile,
  • CAPTION - Kopf,
  • DATA - Daten,
  • FOOTER - Fußzeile.

Aus der Dropdownliste Font werden die gewünschten Schriften ausgewählt.

In der Liste Size wird die Größe angegeben oder ausgewählt.

Mit Hilfe der Buttons, die sich unten befinden, kann man die Schriftfarbe, Schriftart (Fett, Kursiv bzw. Durchgestrichen), Arten des Unterstreichens, horizontale und vertikale Ausrichtung des Textes einstellen.

Ist Background aktiviert, wird eine spezielle Schaltfläche [image] zum Öffnen des Standardfensters für die Farbeauswahl geöffnet. Ist Highlight aktiviert, kann aus der Dropdownliste eine Farbe, mit der der Text markiert wird, ausgewählt werden.

Unter der Registerkarte Strip Styles werden unterschiedliche Farben für Spalten und Zeilen bestimmt:

Zum Erstellen eines Stiles wird die Schaltfläche "+", zum dessen Löschen die Schaltfläche "-" gedrückt.

Die Reihenfolge der Stile kann mittels der Schaltflächen [image] verändert werden.

Mit Hilfe der folgenden zwei Schaltflächen - Load Styles und Save styles - können Stile aus einer Datei geladen bzw. in einer Datei gespeichert werden.

Das Optionsfeld Strip style bestimmt, wie die erstellten Stile verwendet werden:

  • None - nicht verwendbar,
  • Col - für Spalten verwendbar,
  • Row - für Zeilen verwendbar.

Wird ein Stil angelegt und Col bzw. Row im Optionsfeld Strip style ausgewählt, dann wird der Stil für die ganze Tabelle verwendet werden.

Werden zwei Stile angelegt und Col ausgewählt, dann wird für die ungeraden Spalten der erste Stil verwendet und für die geraden Spalten - der zweite Stil.

Für einen standardmäßigen bzw. erstellten Stil können folgende Charakteristiken angegeben werden:

Unter der Registerkarte Border werden Seitenparameter gesetzt:

Sollen spezielle Seitenparameter für Zellenrahmen eingestellt werden, muss Use Border aktiviert werden.

Beim Anklicken der Schaltfläche [image] - Border Color kann die Rahmenfarbe bestimmt werden. Aus der Dropdownliste Border Style wird ein Rahmentyp ausgewählt (einfach, doppelt, gestrichelt und andere).


Eingabe der allgemeinen Exportoptionen

Im letzten Schritt können die Haupteigenschaften des Datenexports angegeben werden.

Export empty tables - Exportieren einer leeren Tabelle in eine Datei.

Skip n records - n Datensätze überspringen. Falls im Optionsfeld eine 0 angegeben ist, werden alle Datensätze exportiert. Falls der Wert mehr als 0 beträgt, werden die ersten n Datensätze übersprungen.

Export all records - Alle Datensätze exportieren

Export only n records ist ein Optionsfeld zum Exportieren von ausschließlich der angegebenen Anzahl der Datensätze.

Zum Öffnen einer Datei nach dem Export wird Open file after export aktiviert.

Print file after export wird aktiviert, um eine Datei nach dem Export auszudrucken.

Nächster Schritt

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Betrachten von Ergebnissen

Nach dem Einstellen in den vorherigen Schritten der gewünschten Optionen wird die Schaltfläche Finish zum Starten der Operationsausführung betätigt.

In diesem Fenster werden folgende Infos über die Operation angezeigt:

  • Exported - Anzahl der exportierten Datensätze
  • Time - Zeit, die für den Export in Anspruch genommen wurde
  • Speed - Geschwindigkeit des Datenexports

Wenn das Optionsfeld Close the Wizard after successful completion aktiviert ist, wird der Assistent nach einer erfolgreichen Operationsausführung automatisch geschlossen. Wenn dies nicht aktiviert ist, kann man zurückgehen und andere Operationsparameter einstellen.

Um beim Export nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Assistent zum Importieren von Daten

Der Assistent zum Importieren von Daten - Import Data Wizard - hilft Daten in eine Tabelle, eine View oder ein Abfrageergebnis aus den gängigen Datenformaten zu importieren.

Das Importieren von Daten kann mit Hilfe den Editoren, die auf der Registerkarte Data und Results verfügbar sind, ausgeführt werden. Dies wären der Tabelleneditor, Vieweditor, SQL-Editor und visueller Query-Builder .

Dieses Tool wird mit Hilfe der Schaltfläche Import Data, die in der Navigationsleiste Data Management und auf der Symbolleiste zu finden ist, geöffnet. Die Schaltfläche ist verfügbar, wenn im Editor die Datenansicht geöffnet ist, d.h. auf der Registerkarte Data oder Results. Dieser Befehl ist ebenso im Kontextmenü der Objekte einer Tabelle und einer View, im DB-Explorer und im Untermenü des Punktes Data Manipulation vorhanden.

Angeben einer Quelldatei

Auswählen einer Datenquelle

Bestimmen der Tabellenzuordnung

Bestimmen von Datenformaten

Bestimmen von Feldformaten

Auswählen vom Importmodus

Einstellen von Hauptoptionen

Betrachten von Ergebnissen

Verwendung der Vorlagen

Exportieren von Daten

Exportieren von Daten als INSERT-Anweisungen

Massenimport

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Angaben einer Quelldatei

Im ersten Schritt des Assistenten zum Importieren von Daten muss der zu importierende Dateityp und der Pfad zu dieser Datei angegeben werden.

Import type: mit Hilfe eines Optionsfeldes wird der gewünschte Dateityp ausgewählt:

  • MS Excel,
  • MS Access,
  • DBF,
  • XML,
  • TXT,
  • CSV,
  • HTML,
  • XML Document
  • MS Excel 2007
  • MS Word 2007
  • ODF Spreadsheets
  • ODF Text

Für eine CSV-Datei können zusätzliche Eigenschaften angegeben werden:

  • aus der Dropdownliste Quote kann eine Art der Anführungszeichen ausgewählt werden,
  • aus der Dropdownliste Delimiter kann ein Trennzeichen von Spalten ausgewählt werden.

In der Zeile Source file name wird ein Pfad zur Dateiquelle angegeben. Beim Betätigen der Schaltfläche [image] wird ein standardmäßiges Dialogfenster zum Auswählen einer Datei geöffnet.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen einer Datenquelle

Dieser Schritt ist nur dann verfügbar, wenn die Daten aus der MS Access-Datenbank importiert werden.

In diesem Schritt wird eine Tabelle bzw. eine Abfrage der Access-Datenbank ausgewählt oder eine neue Abfrage für eine Datenbank erstellt. Der Abfragetext kann aus einer Datei mit der Schaltfläche Load from file geladen und in eine Datei mit Hilfe der Schaltfläche Save to File gespeichert werden.

Wenn der Punkt I would like to import data from a table aktiviert ist, kann für den Import eine Tabelle bzw. eine Abfrage aus der Datenbank ausgewählt werden.

Wenn der Punkt I would like to import data from a SQL query aktiviert ist, kann im Abfrageeditor ein Abfragetext für die Datenbank ausgewählt werden.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Bestimmen der Tabellenzuordnung

Beim Importieren von Daten in eine Tabelle müssen die Felder der Tabelle, in der die Daten importiert werden, und der Tabelle, aus der diese importiert werden, zugeordnet werden. Alle Operationen für diese Zuordnung werden im zweiten Schritt ausgeführt (beim Importieren von Daten aus MS Access werden diese im dritten Schritt ausgeführt, da es einen zusätzlichen Schritt gibt).

Für jedes Dateiformat gibt es Besonderheiten bei der Zuordnung der Felder:

Excel

Access, DBF, XML

TXT

CSV

HTML

XML Document

MS Excel 2007/ODF Spreadcheets

Word 2007/ODF Text

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Excel

In diesem Schritt müssen Spalten mit Daten im MS Excel Buch und Tabellenfelder zugeordnet werden.

Im linken Teil, in der Liste Fields, wird die Liste einer Tabelle, in der die Daten importiert werden, angezeigt. Im rechten Teil wird ein Ausschnitt des zu importierenden MS Excel Dokumentes dargestellt.

In der Liste Ranges wird die Zuordnung, die zwischen den Feldern einer Datenbanktabelle und den Spalten einer Excel-Tabelle

erstellt wurde, angezeigt.

Mit Hilfe der Schaltflächen kann diese Zuordnung automatisch erstellt und gelöscht werden:

die Schaltfläche [image] lässt automatisch die Zuordnung zwischen Tabellen und Spalten erstellen,

die Schaltfläche [image] lässt automatisch die Zuordnung zwischen einem Feld und einer Zeile erstellen,

die Schaltfläche [image] lässt eine Zuordnung löschen,

die Schaltfläche [image] lässt alle Zuordnungen löschen.

Im Abschnitt Skip werden Zeilen und/oder Spalten, die nicht importiert werden, angezeigt. Dies wird zur Ausschließung der Köpfe aus den zu importierenden Daten verwendet.

Im Optionsfeld Col(s) wird angegeben, wie viele Spalten, von erster Spalte an, auszuschließen sind. Im Optionsfeld Row(s) wird die Anzahl der auszuschließenden Zeilen angezeigt.

Das Objekt in der Liste Ranges kann zum Bearbeiten mit dem Doppelklicken geöffnet werden.

Im Abschnitt Range Type wird ein Bereichstyp angegeben.

Aus der Dropdownliste wird ausgewählt, ob dies ein Bereich der Zeilen (Row) oder der Spalten (Col) ist. Danach wird aus der Liste, die sich in der Nähe befindet, der Bereichsanfang ausgewählt.

In den Abschnitten Start und Finish sind die Parameter des Anfanges und des Endes des zu bearbeitenden Bereiches anzugeben.

Das kann man automatisch machen, indem der Punkt Where data started für den Anfang und der Punkt Where data Finished für das Ende eines Bereiches ausgewählt wird. Man kann auch manuell die Nummer einer Zeile oder einer Spalte in den Optionsfeldern Start Row und Finish Row angeben.

Mit Hilfe des Optionsfeldes Direction wird die Richtung der Datenauslesung ausgewählt.

  • Down - unten,
  • Up - oben.

Man kann ebenso ein Blatt im Buch Microsoft Excel, auf dem die erforderlichen Daten zu finden sind, angeben.

Wenn man im Abschnitt Sheet den Punkt Default Sheet auswählt, werden die Daten eines ersten Blattes benutzt.

Wenn der Punkt Custom Sheet ausgewählt wird, kann das gewünschte Blatt nach einer Nummer (Sheet number) bzw. nach einem Namen (Sheet name) angegeben werden.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Access, DBF, XML

Dieser Schritt ist für die Formate Access, DBF und XML gleich.

In der Liste Destination Fields werden Felder einer Tabelle, in der die Daten importiert werden, angezeigt.

In der Liste Source Fields werden Felder einer Tabelle, aus der die Daten importiert werden, dargestellt.

Mit Hilfe der Schaltflächen zwischen den Listen werden die Felder zugeordnet. Diese werden in der Zuordnungsliste, die sich im unteren Teil des Formulars befindet, angezeigt.

Beim Betätigen der Schaltfläche Add wird eine neue Zuordnung zwischen den ausgewählten Feldern in die Zuordnungsliste hinzugefügt.

Die Schaltfläche Auto Fill lässt automatisch Felder einer Tabelle, in der die Daten importiert werden, die jeweiligen Felder aus der Tabelle der Quelldatei auswählen.

Beim Anklicken der Schaltfläche Remove wird eine ausgewählte Zuordnung gelöscht. Beim Betätigen der Schaltfläche Clear wird die Zuordnungsliste vollständig gelöscht.

Beim Importieren von Daten aus einer DBF-Datei erscheint ein zusätzliches Kennzeichen Skip deleted records.

Wenn man diesen Punkt anhakt, können beim Importieren die gelöschten Datensätze übersprungen werden.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


TXT

In diesem Schritt muss eine Zuordnung zwischen den Spalten mit Daten in einem Textdokument und den Tabellenfeldern erstellt werden. Im linken Teil des Fensters befindet sich die Liste einer Tabelle, in der die Daten importiert werden. In derselben Liste wird die Zuordnung der Tabellenfelder und Spalten eines Textdokumentes dargestellt.

Im rechten Teil ist der Teil eines Textdokumentes - einer Datenquelle - zu sehen.

In einem Textdokument gibt es keine Felder und Spalten, deswegen werden im SQL Manager 2007 for MySQL beim Importieren manuell die Trennzeichen für Spalten der Textdateien gesetzt. Die Trennzeichen sind vertikale schwarze Linien, die die Spalten voneinander trennen. Ursprünglich sind keine Trennzeichen im Dokument vorhanden. Sie werden mit Hilfe eines Doppelklicks auf dem Dokumentmuster gesetzt. Die Trennzeichen müssen zwischen den Spalten, vor den ersten Spalten und nach den letzten Spalten gesetzt werden. Die Spaltengröße wird durch die Anzahl ihrer Zeichen bestimmt. Hierfür sind im Dokumentmuster oben und unten die Linien vorgesehen, auf denen jede Teilung einem Zeichen entspricht.

Die Zuordnung zwischen den Spalten wird folgendermaßen erstellt:

In der Liste der Tabellenfelder wird ein Feld ausgewählt. In dem Dokumentmuster wird eine Spalte ausgewählt. Falls die Zuordnung erstellt wurde, dann erscheinen neben dem Feldnamen zwei Zahlen. Die erste Zahl bedeutet die Nummer eines Zeichens, dort wo die Spalte beginnt, die zweite ist die Anzahl der Spaltenzeichen.

Mithilfe der Schaltfläche Fill kann man die Spalten von Daten in einem TXT-Dokument auswählen und die Zuordnung herstellen. Zum Löschen aller erstellten Zuordnungen muss die Schaltfläche Clear angeklickt werden.

Mithilfe des Optionsfeldes Skip Lines kann man die Anzahl der ersten Zeilen, die beim Importieren nicht berücksichtigt werden, angeben. Somit werden die Spaltenköpfe aus den importierenden Daten ausgeschlossen. Aus der Dropdownliste Charset wird die Kodierung ausgewählt.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


CSV

Damit beim Importieren von Daten aus einer CSV-Datei alle Spalten von Daten korrekt im zweiten Schritt angezeigt werden können, muss im ersten Schritt das Trennzeichen von Spalten richtig bestimmt werden.

Im linken Teil des Fensters ist die Liste von Feldern der Tabelle, in der die Daten importiert werden. In derselben Liste wird die Zuordnung der Tabellenfelder und Spalten des Dokumentes angezeigt. Im rechten Teil wird ein Ausschnitt des CSV-Dokumentes dargestellt. Alle Spalten sind dort numeriert. Die Spalten werden nach der Spaltennummer eines CSV-Dokumentes zugeordnet.

Um die Zuordnung eines Tabellenfeldes, in das die Daten importiert werden und eine Spalte in der Dokument-Datenquelle zu erstellen, muss ein Feld in der Felderliste und eine Spalte im CSV-Dokumentenmuster ausgewählt werden. Man kann ebenso eine erforderliche Spaltennummer aus der Liste Col auswählen. Wurde die Zuordnung erstellt, erscheint gegenüber dem Feldnamen eine Spaltennummer, die gemäß diesem Feld gesetzt wurde.

Die Schaltfläche [image] lässt automatisch Felder und Spalten zuordnen.

Die Schaltfläche [image] lässt alle Zuordnungen löschen.

Mit Hilfe des Optionsfeldes Skip kann man die Anzahl der ersten Zeilen, die beim Importieren nicht berücksichtigt werden, angeben. Somit werden die Spaltenköpfe aus den importierenden Daten ausgeschlossen. Die Anzahl der zu überspringenden Spalten werden im Feld Col(s) angegeben. Aus der Dropdownliste wird die Kodierung ausgewählt.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


HTML

In diesem Schritt müssen die Daten-Spalten in der Tabelle einer HTML-Datei und die Felder in einer Datenbanktabelle zugeordnet werden.

Im linken Teil der Liste Fields wird die Liste einer Tabelle, in die die Daten importiert werden, angezeigt. Im rechten Teil wird ein Ausschnitt des zu importierenden MS Excel Dokumentes dargestellt. In der Liste Ranges wird die Zuordnung, die zwischen den Feldern einer Datenbanktabelle und den Tabellenspalten eines Importdokumentes erstellt wurde, angezeigt.

Mit Hilfe der Schaltflächen kann diese Zuordnung automatisch erstellt und gelöscht werden:

die Schaltfläche [image] lässt automatisch die Zuordnung zwischen Feldern und Spalten erstellen

die Schaltfläche [image] lässt eine Zuordnung löschen,

die Schaltfläche [image] lässt alle Zuordnungen löschen.

Aus der Dropdownliste wird die Nummer einer Tabelle, aus der die Daten importiert werden, angegeben. Dies kann man verwenden, wenn in einem HTML-Dokument mehrere Tabellen vorhanden sind.

Im Optionsfeld Col wird die Nummer einer Spalte angegeben, die dem ausgewählten Feld einer Datenbanktabelle entspricht.

Mit Hilfe des Optionsfeldes Skip kann man die Anzahl der ersten Zeilen, die beim Importieren nicht berücksichtigt werden, angeben. Somit werden die Spaltenköpfe aus den importierenden Daten ausgeschlossen.

Im unteren Teil des Formulars ist eine Tabelle mit Daten jenes Dokumentes, aus dem die Daten importiert werden, dargestellt.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


XML Document

In diesem Schritt müssen die Daten-Spalten in der Tabelle einer XML-Datei und die Felder in einer Datenbanktabelle zugeordnet werden.

Im linken Teil der Liste Fields wird die Liste einer Tabelle, in der die Daten importiert werden, angezeigt. Im rechten Teil wird ein Ausschnitt des zu importierenden XML Document Dokumentes dargestellt.

Mit Hilfe der Schaltflächen kann diese Zuordnung automatisch erstellt und gelöscht werden:

die Schaltfläche [image] lässt automatisch die Zuordnung zwischen Feldern und Spalten erstellen

die Schaltfläche [image] lässt eine Zuordnung löschen,

die Schaltfläche [image] lässt alle Zuordnungen löschen.

Im Optionsfeld Col(s) wird eine laufende Nummer der Spalte, die dem Tabellenfeld entspricht, das in der Liste Fields ausgewählt wurde, angegeben. Im Optionsfeld Skip wird angegeben, wie viele Spalten, von der ersten Spalte an, auszuschließen sind.

Um eine Tabelle im Formular mit dem Text der entsprechenden Unterknoten zu füllen, muss man im Feld XPath den Pfad gemäß der XPath Spezifikation (http://www.w3.org/TR/xpath) angeben und die Schaltfläche [image] anklicken.

Im unteren Teil des Formulars ist eine Tabelle mit Daten jenes Dokumentes, aus dem die Daten importiert werden, dargestellt.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


MS Excel 2007/ODF Spreadcheets

In diesem Schritt müssen die Daten-Spalten eines Dokumentes und die Felder in einer Datenbanktabelle zugeordnet werden.

Mit Hilfe der Schaltflächen kann diese Zuordnung automatisch erstellt und gelöscht werden:

die Schaltfläche [image] lässt automatisch die Zuordnung zwischen Feldern und Spalten erstellen

die Schaltfläche [image] lässt eine Zuordnung löschen,

die Schaltfläche [image] lässt alle Zuordnungen löschen.

Aus der Dropdownliste wird die Nummer einer Tabelle, aus der die Daten importiert werden, angegeben. Dies kann man verwenden, wenn in einem HTML-Dokument mehrere Tabellen vorhanden sind.

Im Optionsfeld Col wird die Nummer einer Spalte angegeben, die dem ausgewählten Feld einer Datenbanktabelle entspricht.

Mit Hilfe des Optionsfeldes Skip kann man die Anzahl der ersten Zeilen, die beim Importieren nicht berücksichtigt werden, angeben. Somit werden die Spaltenköpfe aus den importierenden Daten ausgeschlossen.

Im unteren Teil des Formulars ist eine Tabelle mit Daten jenes Dokumentes, aus dem die Daten importiert werden, dargestellt.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Word 2007/ODF Text

In diesem Schritt müssen die Spalten mit Daten eines Word-Dokumentes und die Felder in einer Tabelle zugeordnet werden.

Im linken Teil, in der Liste Fields, wird die Liste einer Tabelle, in die die Daten importiert werden, angezeigt. Im rechten Teil wird ein Ausschnitt des zu importierenden MS Excel Dokumentes dargestellt.

Mit Hilfe der Schaltflächen kann diese Zuordnung automatisch erstellt und gelöscht werden:

die Schaltfläche [image] lässt automatisch die Zuordnung zwischen Feldern und Spalten erstellen

die Schaltfläche [image] lässt eine Zuordnung löschen,

die Schaltfläche [image] lässt alle Zuordnungen löschen.

Im Optionsfeld Col wird die Nummer einer Spalte angegeben, die dem ausgewählten Feld einer Datenbanktabelle entspricht. Mit Hilfe des Optionsfeldes Skip kann man die Anzahl der Zeilen, die beim Importieren nicht berücksichtigt werden, angeben. Somit werden die Spaltenköpfe aus den importierenden Daten ausgeschlossen.

Im unteren Teil des Formulars ist eine Tabelle mit Daten jenes Dokumentes, aus dem die Daten importiert werden, dargestellt.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Bestimmen von Datenformaten

In diesem Schritt muss ein Datenformat der zu importierenden Datei angegeben werden. Dieses Format muss dem Datenformat in der Datei, in der die Daten importiert werden, entsprechen.

Im Abschnitt Date & Time formats werden die Daten zum Anzeigen des Datums und der Zeit bestimmt.

  • Short date - Datum (Kurzformat),
  • Long date - Datum (Langformat),
  • Short time - Zeit (Kurzformat),
  • Long time - Zeit (Langformat).

Im Abschnitt Separators werden Trennzeichen angegeben:

  • Decimal - Dezimal,
  • Thousand - Tausend,
  • Date - Datum,
  • Time - Zeit.

Boolean True - in dieses Feld wird der Text eingetragen, wenn der Wert in der Zelle "Logisch Wahr" ist

(der Wert ist Logisch wahr, wenn die Daten in diesem Dokument und in diesem Feld übereinstimmen)

Boolean False - in dieses Feld wird der Text eingetragen, wenn der Wert in der Zelle "Logisch Falsch" ist,

Null Values - in dieses Feld wird der Text eingetragen, der beim NULL-Wert in der Zelle angezeigt wird.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Bestimmen von Feldformaten

In diesem Schritt kann aus der Liste Field name ein Feld ausgewählt und im Abschnitt Formats die Eigenschaften des Feldformates angegeben werden.

Generator value - Generator der Werte. Wenn das Feld, in dem die Daten importiert werden, den Typ Identity hat, wird der Generator nicht funktionieren.

Constant value - in dieses Feld wird ein Wert, der alle Werte in der Spalte ersetzt, eingetragen.

Null value ist ein Wert, der in die Zelle eingetragen wird, falls ihr Wert nach dem Import Null beträgt.

Im Feld Default Value wird ein Standardwert eingetragen.

Im Feld Left quote wird ein linkes Anführungszeichen, im Feld Right ein rechtes Anführungszeichen gesetzt.

Quotation action ist eine Aktion, die mit Anführungszeichen ausgeführt wird. In diese Anführungszeichen wurden ursprünglich die Daten gesetzt:

  • As Is - Anführungszeichen werden ohne Änderungen belassen,
  • Add - Anführungszeichen werden hinzugefügt,
  • Remove - Anführungszeichen, die in einer Quelldatei verwendet wurden, werden entfernt.

Aus der Dropdownliste Character case wird die Groß-/Kleinschreibung der Textdaten ausgewählt.

Aus der Dropdownliste Charset wird der Zeichensatz ausgewählt.

In diesem Schritt besteht die Möglichkeit beim Importieren einige Werte durch andere Werte im Feld zu ersetzen.

Die Ersetzungen werden im Abschnitt Replacement eingetragen.

Man kann mehrmals den Text verändern. Mit Hilfe der Schaltfläche [image] Add Replacement kann ein neuer Ersatz hinzugefügt werden. Alle Parameter werden in einer Liste angezeigt, in der sich in der Spalte Text to find die zu ersetzenden Textwerte befinden. In der Spalte Replace ist der Text, durch den die angegebenen Parameter zu ersetzen sind.

Falls Ignore case angehakt ist, wird die Änderung ohne Rücksicht auf die Groß-/Kleinschreibung ausgeführt. Mit Hilfe der Schaltfläche [image] können alle Ersatzvoraussetzungen bearbeitet werden. Die Schaltfläche [image] Delete Replacement lässt die Voraussetzungen des Ersatzes entfernen.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen vom Importmodus

Mit dem Optionsfeld Import mode kann man Einträge eingeben, die in eine Tabelle importiert werden.

Insert all - alle Einträge eingeben,

Insert new - nur alle Einträge eingeben,

Update - Einträge aktualisieren,

Update or insert - bestehende Einträge aktualisieren und neue Einträge eingeben

Delete - Einträge löschen

Delete or insert - übereinstimmende Einträge löschen und neue eingeben

Mit dem Optionsfeld Import type wird der Importtyp angegeben:

Single commands - Einzelne Befehle,

Universal mode - Universalmodus,

Batch insert - Stapeleingabe.

Im Abschnitt Key columns wird ein Schlüsselfeld, nach dem die Felder einer Tabelle und einer Datei der Datenquelle verglichen werden, ausgewählt.

Aus der Liste Available columns werden die verfügbaren Felder ausgewählt und mit Hilfe der Schaltflächen in die Liste der Schlüsselfelder Selected columns übertragen.

Zum Beispiel:

Tabelle in einer Datenbank

Daten aus einer Fremddatei

Als Schlüsselfeld ist ein ID-Feld ausgewählt.

Import mode | Результат
Insert all |
Insert new |
Update |
Update or insert |
Delete |
Delete or insert |

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Einstellen von Hauptoptionen

Im Abschnitt Commit wird ein Commit der Transaktion eingegeben:

  • Commit when done - Commit wenn ausgeführt,
  • Commit after each block - Commit nach jedem Block ausführen. Dies wird für große Tabellen verwendet. Die Anzahl der Datensätze im Block wird in einem Optionsfeld Block size angegeben.
  • Commit changes manually - Commit manuell ausführen.

Im Abschnitt Record count kann die Anzahl der zu importierenden Datensätze eingegeben werden.

Es wird der Punkt Import all records ausgewählt, damit alle Datensätze importiert oder die Anzahl im Optionsfeld Import only n records ausgewählt wurde.

Nächster Schritt

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Betrachten von Ergebnissen

Nachdem in den vorherigen Schritten alle gewünschten Optionen angegeben wurden, wird eine Schaltfläche Finish zum Starten der Operationsausführung angeklickt.

In diesem Fenster werden folgende Infos über Operationen angezeigt:

  • Inserted - Anzahl der importierten Datensätze,
  • Updated - Anzahl der aktualisierten Datensätze,
  • Deleted - Anzahl der gelöschten Datensätze,
  • Errors - Anzahl der beim Import aufgetretenen Fehler
  • Commited - Anzahl der festgelegten Datensätze,
  • Time - Zeit zum Importieren der Datensätze

Wenn der Punkt Close the Wizard after successful completion aktiviert ist, dann wird der Assistent bei erfolgreicher Ausführung automatisch geschlossen. Wenn der Punkt nicht aktiviert ist, kann man nach der Ausführung zurückkehren und andere Operationsparameter einstellen.

Um beim Import nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Assistent zum Exportieren von Daten als SQL-Skript

Das Exportieren von Daten als SQL-Skript wird ausschließlich aus den Editoren ausgeführt, in dem die Registerkarte Data bzw. Results vorhanden ist. Dies wären der Tabelleneditor, Vieweditor, SQL-Editor und visueller Query-Builder.

Dieses Werkzeug wird mit Hilfe des Buttons Export as SQL script geöffnet. Dieser Button befindet sich auf der Navigationsleiste Data Management und auf der Werkzeugsleiste. Der Button ist verfügbar, wenn im Editor der Datenviewer geöffnet ist, also unter der Registerkarte Data oder Results. Dieser Befehl ist ebenso im Kontextmenü von Objekten einer Tabelle oder einer View, im DB-Explorer und im Untermenü des Punktes Data Manipulation vorhanden.

Auswählen des Types eines Zielservers

Bestimmen des Namen einer Zieldatei

Auswählen der Exportmethode von BLOB-Feldern

Auswählen der zu exportierenden Felder

Einstellen der Exportoptionen

Bearbeiten eines endgültigen SQL-Skriptes

Betrachten von Ergebnissen

Verwendung der Vorlagen

Exportieren von Daten

Importieren von Daten

Laden von Daten

Speichern von Daten

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Auswählen des Types eines Zielservers

Im ersten Schritt muss ein Zielserver ausgewählt werden. Das Skript wird im Format, das mit dem ausgewählten Servertyp kompatibel ist, erstellt werden.

Die verfügbaren Servertypen sind:

  • DB2,
  • InterBase/Firebird,
  • MS SQL,
  • MySQL,
  • Oracle,
  • PostgreSQL

Wenn der Punkt Add CREATE TABLE statement aktiviert ist, wird im Skript eine Anweisung CREATE TABLE hinzugefügt. Diese wird gemäß im Syntax eines ausgewählten Servertyps erstellt.

Nächster Schritt


Bestimmen des Namen einer Zieldatei

Im zweiten Schritt muss ein Name des zu erstellenden Skriptes und sein Speicherort bestimmt werden.

Im Abschnitt Script destination wird angegeben, ob das erstellte Skript im SQL-Editor geöffnet oder sofort in einer Datei gespeichert wird:

  • Automatically load to Script Editor - das erstellte Skript wird im SQL-Editor automatisch geöffnet,
  • Save to file - das erstellte Skript wird in einer Datei gespeichert. Der Name und der Pfad sind im Feld File name anzugeben.

Die Datei kann mit Hilfe eines Dialogfensters beim Betätigen der Schaltfläche [image] geöffnet werden.

Im Feld Table name (as it will be represented in the script file) wird eine Tabelle angegeben, die mit Hilfe dieses Skriptes erstellt wird. Im Feld Schema name (as it will be represented in the script file, if need) wird der Name eines Schemas angegeben. Das Schema wird für die Server, in denen solche Objektklasse vorhanden ist, angegeben.

Nächster Schritt


Auswählen der Exportmethode von BLOB-Feldern

In diesem Schritt kann die Art des Exportierens von BLOB-Feldern eingestellt werden.

Falls man den Punkt Don't extract BLOB fields auswählt, dann werden die BLOB-Felder nicht exportiert.

Beim Auswählen des Punktes Extract BLOB fields as strings werden die BLOB-Felder als Zeilen exportiert.

Man kann die Felder dieser Typen in eine Datei exportieren, indem man den Punkt Extract BLOB fields into file auswählt.

Für eine Datei, in der diese Felder exportiert werden, kann man folgende Eigenschaften angeben:

  • Im File name wird der Dateiname und der Pfad beim Betätigen der Schaltfläche [image] angegeben,
  • Die zu erstellende Datei kann komprimiert werden, indem man den Punkt Compress file aktiviert,
  • Die Komprimierungsart wird aus der Dropdownliste Compression ausgewählt. Es stehen vier Komprimierungsarten zur Verfügung: None - ohne Komprimierung, Fastest - schnelle Komprimierung, Default - standardmäßige Komprimierung und Best - beste Komprimierung.

Falls im ersten Schritt das Format MySQL oder PostgreSQL ausgewählt wurde, kann man in diesem Schritt folgende Punkte auswählen:

  • Don't extract BLOB fields - BLOB-Felder werden nicht exportiert.
  • Extract BLOB fields as strings - beim Auswählen dieses Punktes werden BLOB-Felder als Zeilen exportiert.

Nächster Schritt


Auswählen der zu exportierenden Felder

In diesem Schritt müssen aus der Liste der Felder einer Tabelle oder einer View die zu exportierenden Felder ausgewählt werden.

Aus der Liste Available Fields werden verfügbare Felder ausgewählt und mit Hilfe der Schaltflächen in die Liste der zu exportierenden Felder - Selected fields übertragen. Wenn man kein Feld auswählt, dann werden standardmäßig alle Felder exportiert.

Nächster Schritt


Einstellen der Exportoptionen

In diesem Schritt werden allgemeine Exporteigenschaften eingestellt.

Beim Anhaken Replace non-print characters in strings with spaces werden nicht ausgedruckte Buchstaben in der Zeichenfolge mit Leerzeichen ersetzt.

Im Abschnitt Data options werden die Commit-Transaktionen angegeben.

Wenn der Punkt Insert COMMIT after each block aktiviert ist, wird die Transaktion nach der im Optionsfeld Records in a block angegebenen Anzahl der Datensätze festgelegt.

Nächster Schritt


Bearbeiten eines endgültigen SQL-Skriptes

In diesem Schritt kann das zu erstellende Skript im SQL-Editor angesehen und bearbeitet werden.

Dieser Schritt ist verfügbar, wenn im ersten Schritt der Punkt Add CREATE TABLE statement aktiviert wurde.

Nächster Schritt


Betrachten von Ergebnissen

Nachdem in den vorherigen Schritten alle gewünschten Optionen angegeben wurden, wird eine Schaltfläche Finish zum Starten der Operationsausführung angeklickt. In der Statuszeile, die sich im oberen Teil befindet, wird der Operationsverlauf in Prozenten angezeigt.

Registerkarte Operations.

Unter der Registerkarte Operation sind alle ausgeführten Aktionen und deren Ergebnisse angezeigt.

Wenn der Punkt Load generated script into Script Editor aktiviert ist, wird das erstellte Skript im SQL Skript Editor sofort geöffnet.

Bei Aktivierung des Häkchens Close the Wizard after successful completion wird der Assistent automatisch geschlossen. Wenn der Punkt nicht aktiviert ist, kann man zurückkehren und andere Parameter der Operation einstellen.


Assistent zum Laden von Daten

Der Assistent zum Laden von Daten - Load Data Wizard - ermöglicht die Daten aus einer Textdatei zu laden und diese in eine Tabelle einzufügen, indem man den Befehl LOAD DATA INFILE verwendet.

Das Laden von Daten wird ausschließlich aus den Editoren ausgeführt, wo die Registerkarte Data bzw. Results vorhanden ist. Dies wären Tabelleneditor, Vieweditor, SQL-Editor und visueller Query-Builder.

Dieses Werkzeug wird mit Hilfe der Schaltfläche Load Data geöffnet, die sich auf der Navigationsleiste Data Management und Symbolleiste befindet.

Die Schaltfläche ist verfügbar, wenn der Datenviewer im Editor geöffnet ist, d.h. auf den Registerkarten Data bzw. Results.

Dieser Befehl ist ebenso im Kontextmenü der Objekte einer Tabelle und einer View, im DB-Explorer und im Untermenü des Punktes Data Manipulation vorhanden.

  • Auswählen der Datenquelle
  • Einstellen von Hauptparametern
  • Auswählen von Spalten
  • Einstellen von Optionen einer Datenquelldatei
  • Betrachten von Ergebnissen
  • Verwendung der Vorlagen

Exportieren von Daten

Exportieren von Daten als SQL Skript

Importieren von Daten

Speichern von Daten

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Auswählen der Datenquelle

In diesem Schritt des Assistenten wird der Dateityp, aus dem die Infos geladen werden, und der Pfad zu dieser Datei angegeben.

In der Zeile Data file name wird der Pfad zur Dateiquelle angegeben. Beim Betätigen der Schaltfläche [image] wird ein standardmäßiges Dialogfenster zum Auswählen einer Datei ausgewählt.

Im Abschnitt Data file location wird der Speicherort der Datenquelle ausgewählt:

  • On server - auf dem Server,
  • On client - auf dem Client-Rechner.

Nächster Schritt

Um beim Laden nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Einstellen von Hauptparametern

Im Abschnitt Loading priority wird die Priorität des Ladens bestimmt.

Wenn Not specified aktiviert ist, wird die Priorität automatisch eingestellt.

Low priority - so lange die Benutzer irgendwelche Operationen mit einer Tabelle ausführen, wird kein Laden von Daten ausgeführt.

Concurrent - wählt man diesen Prioritätentyp aus, kann man beim Laden von Daten mit einer Tabelle arbeiten.

Danach muss das Verhalten bei der Übereinstimmung der Werte in Schlüsselfeldern ausgewählt werden.

Default processing - in diesem Fall wird das Laden von Daten in eine Tabelle bei der kommenden Übereinstimmung der Werte abgebrochen,

Replace - ist dieser Punkt ausgewählt, werden die Werte in der Tabellenzeile bei der Übereinstimmung ersetzt,

Ignore - in diesem Fall werden die Werte in den Zeilen nicht durch neue ersetzt.

Nächster Schritt

Um beim Laden nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen von Spalten

In diesem Schritt müssen aus der Liste aller Felder einer Tabelle oder View nur die zu ladenden Daten ausgewählt werden.

Aus der Liste Available Fields werden verfügbare Felder ausgewählt und mit Hilfe der Schaltflächen in die Liste der zu ladenden Felder - Selected fields übertragen. Wenn man kein Feld auswählt, werden standardmäßig alle Felder ausgewählt.

Nächster Schritt

Um beim Laden nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Einstellen von Optionen einer Datenquelldatei

In diesem Schritt werden die Parameter einer Text-Datei, aus der das Laden von Daten ausgeführt wird, eingestellt.

Für eine Datei müssen folgende Parameter eingestellt werden:

Fields terminated by - Trenner der Felder.

Fields enclosed by - Felder, die in Anführungszeichen gesetzt werden.

Falls der Punkt Optionally angehakt wird, dann werden in Anführungszeichen ausschließlich die CHAR- und VARCHAR-Felder gesetzt.

Enthält eine Quelldatei nicht gedruckte Zeichen, kann man im Feld Fields escaped by einen Satz von Zeichen erstellen, die nicht gedruckte Zeichen ersetzen wird.

Im Feld Lines terminated wird ein Satz von Zeichen, die die Zeilen trennen, angegeben.

Die Anzahl von Feldern, die in eine Tabelle nicht zu transportiert sind, werden ins Feld Ignore lines count eingetragen.

Nächster Schritt

Um beim Laden nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Assistent zum Speichern von Daten

Mit Hilfe des Assistenten zum Speichern von Daten können die Tabellendaten in eine Datei, die sich auf dem Server oder auf dem Client-Rechner befindet, abgespeichert werden.

Das Speichern von Daten wird ausschließlich aus den Editoren ausgeführt, in denen die Registerkarte Data bzw. Results vorhanden ist. Dies wären Tabelleneditor, Vieweditor, SQL-Editor und visueller Query-Builder.

Dieses Werkzeug wird mit Hilfe der Schaltfläche Save Data geöffnet, die sich auf der Navigationsleiste Data Management und Symbolleiste befindet.

Die Schaltfläche ist verfügbar, wenn der Datenviewer im Editor geöffnet ist, d.h. auf den Registerkarten Data bzw. Results.

Dieser Befehl ist ebenso im Kontextmenü der Objekte einer Tabelle und einer View, im DB-Explorer und im Untermenü des Punktes Data Manipulation vorhanden.

Der Assistent besteht aus den folgenden Schritten:

  • Auswählen einer Datei
  • Auswählen von Feldern
  • Einstellen von Parametern einer ausgewählten Datei
  • Betrachten von Ergebnissen
  • Verwendung der Vorlagen

Exportieren von Daten

Exportieren von Daten als SQL Skript

Importieren von Daten

Speichern von Daten

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Auswählen einer Datei

In diesem Schritt des Assistenten zum Speichern von Daten wird der Dateityp, in den die Infos geladen werden, und der Pfad zu dieser Datei angegeben.

In der Zeile Data file name wird der Pfad zur Datendatei angegeben.

Die Datei wird auf dem Server gespeichert.

Nächster Schritt


Auswählen von Feldern

In diesem Schritt müssen aus der Liste aller Tabellen und Views nur die Felder ausgewählt werden, deren Daten in eine Datei zu laden sind.

Aus der Liste Available Fields werden verfügbare Felder ausgewählt und mit Hilfe der Schaltflächen in die Liste der enthaltenen Felder - Included fields- transferiert. Wenn kein Feld ausgewählt wird, dann werden standardmäßig die Daten aus allen Feldern ausgewählt.

Nächster Schritt

Um beim Speichern nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Einstellen von Parametern einer ausgewälten Datei

In diesem Schritt werden die Parameter einer Text-Datei, in die das Laden von Daten ausgeführt wird, eingestellt.

Für eine Datei müssen folgende Parameter eingestellt werden:

Fields terminated by - Trennen der Felder.

Fields enclosed by - Anführungszeichen, in die das Feld gesetzt wurde.

Falls der Punkt Optionally angehakt wird, dann werden in Anführungszeichen ausschließlich die CHAR- und VARCHAR-Felder gesetzt.

Im Feld Fields escaped by kann man einen Satz von Zeichen erstellen, die als nicht gedruckte Zeichen bezeichnen wird.

Im Feld Lines starting by werden die Zeichen, mit denen die Zeilen anfangen, angegeben.

Im Feld Lines terminated wird ein Satz von Zeichen, die die Zeilen trennen, angegeben.

Nächster Schritt

Um beim Laden nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


DB-Werkzeuge

SQL Manager 2007 for MySQL verfügt über einen Satz von Datenbank-Werkzeugen.

Dies sind:

Visueller Datenbank-Designer

Das Werkzeug hilft, eine grafische Sicht einer Datenbank zu erstellen.

SQL-Monitor

Das Werkzeug zeigt alle SQL-Operationen an, die während einer Sitzung des SQL Manager 2007 for MySQL ausgeführt wurden.

SQL Skript Editor

Das Werkzeug hilft SQL-Skripts zu erstellen und auszuführen.

Assistent zum Kopieren von Datenbanken

Mit Hilfe dieses Werkzeuges können die Daten und die Objekte einer Datenbank von einer zu anderer Datenbank übertragen werden.

Assistent zum Extrahieren von Datenbanken

Das Werkzeug lässt die Metadaten von Tabellen ins SQL-Skript extrahieren. Dieses Skript kann danach auf einem anderen Rechner zur Wiederherstellung der Struktur einer Datenbank ausgeführt werden.

Drucken von Metadaten

Das Werkzeug hilft einen Bericht über die DB-Metadaten zu erstellen.

Assistent zum Erstellen von HTML-Berichten

Mit Hilfe dieses Werkzeuges kann ein Bericht über die DB-Metadaten im HTML-Format erstellt werden.

Arbeiten mit Berichten

Dieser Werkzeugsatz ermöglicht Berichte zu erstellen und zu drucken.

Abhängigkeitsstruktur

Mit Hilfe dieses Werkzeuges können die Abhängigkeiten von Objekten als Diagramm angezeigt werden.

Verwendung der Vorlagen


Visueller Datenbank-Designer

Mit dem visuellen Datenbank-Designer können die Tabellen und die Relationen von Datenbanken betrachtet, erstellt und bearbeitet werden.

Zum Öffnen dieses Werkzeuges muss der Punkt Tools | Visual Database Designer / Werkzeuge | Visueller Datenbank- Designer des Programm-Hauptmenüs ausgewählt werden.

Verwendung der Symbolleisten

Navigation durch das Diagramm

Hinzufügen von Objekten

Erstellen von Relationen

Arbeiten mit mehreren Seiten

Reverse Engineering

Drucken von Diagramm

Speichern/Laden von Diagramm

Einstellen von Diagramm

Siehe auch:

Visueller Query-Builder

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Verwendung der Werkzeugleisten

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Verwendung der Symbolleisten

Symbolleiste

auf der Leiste Database:

  • auf dieser Leiste kann eine Datenbank ausgewählt werden.

auf der Leiste General kann man:

  • Diagrammoptionen einstellen - Diagram options,
  • Drucken einstellen - Print setup,
  • Vorschau drucken - Print Preview,
  • Metadaten eines Objektes drucken - Print,
  • Diagramm aktualisieren - Refresh.

auf der Leiste Navigator:

Im Navigatorfenster ist ein verkleinertes Musters eines Diagramms zur komfortablen Navigation durch dieses Diagramm zu finden.

auf der Leiste Object:

Hier ist eine Liste der Elemente, die ins Diagramm platziert werden können.

Auf der Symbolleiste kann man

  • Datenbanken auswählen Databases,
  • neues Diagramm erstellen - New Diagram,
  • Diagramm öffnen - Open Diagram,
  • Diagramm speichern- Save Diagram,
  • Diagramm als Bild speichern - Save as Image,
  • Inkrementelle Suche starten- Incremental Search,
  • vergrößern - Zoom In,
  • verkleinern - Zoom Out,
  • Rechteck zum Anpassen auswählen - Select rectangle to fit,
  • Modell anpassen- Fit model,
  • Metadaten von Objekten drucken - Print,
  • Setup drucken - Print setup,
  • Druckvorschau vornehmen - Print Preview,
  • Objekte anordnen - Arrange objects,
  • Metadaten extrahieren - Extract metadata,
  • Reverse Engineering vornehmen (Erstellung des Datenmodells aufgrund der Analyse der bestehenden Datenbank) - Reverse Engineer,
  • Designeroptionen einstellen - Designer options, dabei werden Einstellungen des Visuellen Datenbank-Designers

geöffnet,

  • Zoomfeld bestimmen,
  • Standardgröße wiederherstellen - Restore default size,
  • neue Seite erstellen - New Page,
  • Seite löschen - Delete Page,
  • alle Diagrammseiten löschen - Delete all.

Mit der Symbolleiste eines Diagramms kann man:

  • alle ausgewählten Objekte links ausrichten - Align left edges,
  • alle ausgewählten Objekte rechts ausrichten - Align right edges,
  • alle ausgewählten Objekte oben ausrichten - Align tops,
  • alle ausgewählten Objekte unten ausrichten - Align bottom,
  • alle ausgewählten Objekte horizontal ausrichten - Align horizontal centers,
  • alle ausgewählten Objekte vertikal ausrichten - Align vertical centers,
  • gleicher Bereich, horizontal - Space equally, horizontal,
  • gleicher Bereich, vertikal - Space equally, vertical.

Des Weiteren wird mit Hilfe der Schaltflächen der Arbeitsmodus des Cursors bestimmt:

  • Select - Auswählen,
  • Create table - Tabelle erstellen
  • View erstellen - Create view,
  • Prozedur erstellen - Create procedure,
  • Funktion erstellen - Create function,
  • Relationen erstellen - Create relation,
  • virtuelle Relationen erstellen - Create virtual relation,
  • Kommentar erstellen - Create comment.

Kontextmenü

Mit dem Kontextmenü eines Diagrammbereiches kann man:

  • Select All - alle Objekte auswählen,
  • Zoom - Zoom eines Diagramms auswählen,
  • Create - erstellen,
  • Grid - Raster bestimmen,
  • Style - Format einstellen,
  • Reverse Engineer - Reverse Engineering,
  • Extract Metadata - Metadaten extrahieren,
  • Designer options - Designeroptionen eingeben.

Mit Hilfe des Kontextmenüs eines Tabellenkopfes kann man:

  • Tabelle bearbeiten - Edit Table "Objektname",
  • Tabelle erstellen - New Table...,
  • Tabelle aus einer Datenbank löschen - Drop Table "Objektname",
  • Tabelle aus einem Diagramm löschen - Remove Table "Objektname".

Mit dem Kontextmenü eines Feldes kann man Tabellenfelder bearbeiten, hinzufügen und löschen.


Navigation durch das Diagramm

Zur schnellen und komfortablen Navigation durch das Diagramm steht ein spezielles Werkzeug zur Verfügung, das auf der Navigationsleiste zu finden ist. Das Navigationswerkzeug ist ein Muster des Diagrammfensters, in dem mit einem roten Rechteck ein sichtbarer Bereich markiert ist. Dies ermöglicht, das gesamte Diagramm in verkleinerter Form zu bearbeiten. Im Navigationswerkzeug kann man ähnlich wie im Diagrammfenster mit Objekten arbeiten, d.h. markieren, verschieben, anlegen und bearbeiten.

Beim Betätigen des linken Mausbuttons im Navigationsfenster wird die Mitte des sichtbaren Diagrammbereiches in diesen Punkt verschoben. Somit kann man durch das Diagramm navigieren, ohne die Bildlaufleiste zu verwenden.


Arbeiten mit Diagramm-Objekten

Die Tabellen und die Tabellenfelder sind die Objekte eines Diagramms.

Die Felder, die ausgefüllt werden müssen, sind "fett" markiert. Die Schlüsselfelder sind von der anderen Tabelle getrennt und mit einem speziellen Icon markiert. Alle Views der Tabellen und Relationen können eingestellt werden.

Hinzufügen von Objekten ins Diagramm

Man kann eine Tabelle in den Diagrammbereich auf zwei verschiedene Weisen hinzufügen:

  • eine Tabelle aus dem Fenster des DB-Explorers schieben,
  • aus der Liste der verfügbareren Objekte, die sich auf der Navigationsleiste befindet.

Löschen von Objekten aus dem Diagramm

Um eine Tabelle aus dem Diagramm zu löschen (nicht aus der Datenbank), kann der Punkt des Kontextmenüs des Tabellenkopfes Remove Table "Objektname" verwendet werden.

Anlegen eines neuen Objektes

Im Diagrammfenster kann man eine neue Tabelle anlegen, indem der Punkt des Kontextmenüs des Tabellenkopfes New Table... verwendet wird. Danach werden in einem geöffneten Tabelleneditor alle Felder und Eigenschaften einer neuen Tabelle angegeben und OK angeklickt. Die erstellte Tabelle wird dann auf dem Diagramm erscheinen.

Bearbeiten eines Objektes

Im Diagrammfenster kann man sowohl Tabellen, als auch Tabellenfelder bearbeiten.

Um eine Tabelle im Tabelleneditor zu öffnen, muss man im Kontextmenü des Tabellenkopfes den Punkt Edit Table "Objektname" auswählen.

Das Arbeiten mit Feldern wird mit Hilfe des Kontextmenüs eines Feldes ausgeführt.


Erstellen von Relationen

SQL Manager 2007 for MySQL ermöglicht die Relationen zwischen den Tabellen - Fremdschlüssel - im

Diagrammfenster zu erstellen. Hierfür muss man auf der Symbolleiste des Diagrammfensters den Button Create relation drücken. Um eine Relation zwischen zwei Tabellen aufzubauen, muss jede von ihnen mit der Maus angeklickt werden. Danach wird Fremdschlüsseleditor geöffnet, indem alle Eigenschaften der zu erstellenden Relation anzugeben sind.

Die Relation zwischen den Tabellen wird in Form einer verknüpfenden Linie angezeigt.

Die Verwaltung der Relation wird mit Hilfe des Kontextmenüs verwirklicht, die beim Drücken der rechten Maustaste auf die Relation geöffnet wird.

Mit Hilfe dieses Menüs kann man:

  • Relation im Fremdschlüsseleditor öffnen - Edit Foreign Key "Objektname",
  • Relation löschen Drop Foreign Key "Objektname".

Bei der Erstellung einer Relation mit Hilfe der Schaltfläche Create relation auf der Leiste Verwendung der Symbolleisten werden ausgewählte Felder automatisch in den Editor der Fremdschlüssel eingetragen.

Wenn das Diagramm virtuelle Relationen enthält, dann können diese in gewöhnliche unter Verwendung des Kontextmenüs der vertuellen Relation Materialize Virtual Relation umgewandelt werden.


Arbeiten mit mehreren Seiten

In dem Diagramm einer Datenbank können mehrere Seiten für die Aufteilung der Objekte in Gruppen zur besseren Vorschau erstellt werden.

Arbeiten mit Seiten:

  • neue Seite erstellen - New Page,
  • Seite löschen - Delete Page,
  • alle Seiten löschen - Delete All Pages,
  • Seite umbenennen - Rename Page.

Alle diese Befehle befinden sich im Kontextmenü der Seite und auf der Symbolleiste.


Reverse Engineering

Um schnell alle DB-Tabellen auf das Diagramm mit Relationen zu übertragen, wird der Button Reverse Engineer [image] (Reverse Engineering) auf der Symbolleiste verwendet. Alle DB-Tabellen werden auf dem Diagramm mit jeweiligen Relationen angeordnet.

In dem erscheinenden Fenster werden die Objekttypen ausgewählt, die auf dem Diagramm zu platzieren sind:

  • Tables - Tabellen,
  • Views - Sichten,
  • Procedures - Prozeduren,
  • Functions - Funktionen.


Diagrammdrucken

Der visuelle Datenbank-Designer hilft ein Diagramm im Vorschaufenster zu öffnen und dies auszudrucken.

Das Werkzeug zum Vorschau des Diagramms - Print Preview - wird beim Betätigen der Schaltfläche Print Preview auf der

Symbolleiste geöffnet.

Um die Einstellungen des Druckdokumentes zu setzen, wird Print Setup Dialog verwendet. Dieser wird beim Betätigen

der Schaltfläche Print setup auf der Symbolleiste geöffnet. Mit Hilfe dieses Werkzeuges kann man auch das Dokument ausdrucken.


Vorschau

Die Vorschau ist ein Schaumodus des Dokumentes. Das Dokument wird in der angezeigten Form ausgedruckt.

Mit Hilfe des Dokumentes Print Preview kann das Diagramm vor dem Drucken angesehen werden.

Folgende Aktionen sind mittels der Symbolleiste auszuführen:

  • Nummer der betrachtenden Seite kann eingegeben werden. Mit Hilfe der Optionen kann man vorherige bzw. nächste Seite öffnen, im Optionsfeld wird die Nummer der gewünschten Seite angeben,
  • Button Print all ermöglicht alle Seiten oder ausschließlich eine aktuelle Seite auszudrucken (Dropdownliste der Schaltfläche),
  • Druckparameter setzen - Button Print options,
  • Vorschauzoom kann eingestellt werden - Preview zoom.


Einstellen von Drucken

Dieses Dialogfenster ermöglicht Druckoptionen einzustellen:

  • Druckerparameter sind auf der Registerkarte Printer anzugeben,
  • Seitenparameter sind auf der Registerkarte Page options anzugeben.

Die Werkzeuge, die sich auf der Registerkarte Printer befinden

  • Druckername wird im Feld Name angezeigt,
  • Auswählen des aktiven Druckers erfolgt mit Hilfe des Buttons Choose printer,
  • Infos über Printertreiber werden im Feld Driver angezeigt,
  • Port des Druckeranschlusses wird im Feld Port bestimmt,
  • Skalierfaktor verwenden - Use scale factor,
  • Diagramm auf n Seiten horizontal und n Seiten vertikal anordnen - Arrange diagram at n pages horizontally and n pages vertically,
  • wenn Skip empty pages aktiviert ist, werden beim Drucken leere Seiten übersprungen,
  • wenn Print only selected objects aktiviert ist, werden nur ausgewählte Objekte ausgedruckt,
  • Print page borders ermöglicht Seitenrahmen auszudrucken,
  • All pages gibt an, dass alle Seiten ausgedruckt werden,
  • Pages from... to... hilft den Seitenbereich anzugeben.

Die Werkzeuge, die sich auf der Registerkarte Page options befinden

  • Top margin (mm) - Größe des oberen Ranges in mm,
  • Bottom margin (mm) - Größe des unteren Ranges in mm.,
  • Left margin (mm) - Größe des linken Ranges in mm.,
  • Right margin (mm) - Größe des rechten Ranges in mm.,
  • im Feld Page Header wird der Text der Kopfzeile angegeben,
  • Left align - Ausrichtung links,
  • Center align - Ausrichtung Mitte,
  • Right align - Ausrichtung rechts,
  • Page Footer - Seitenfuß,
  • Left align - Ausrichtung links,
  • Center align - Ausrichtung Mitte,
  • Right align - Ausrichtung rechts.


Speichern/Laden von Diagramm

SQL Manager 2007 for MySQL ermöglicht ein gespeichertes Diagramm zu speichern und zu laden.

Die Diagrammdateien werden im Format .myd. gespeichert.

Die Schaltflächen für Laden und Speichern des Diagramms befinden sich auf der Symbolleiste:

  • Diagramm öffnen - Open Diagram,
  • Diagramm speichern - Save Diagram,
  • Diagramm als Bild speichern - Save as Image.

Beim Versuch das Diagramm für eine andere Datenbank zu öffnen, wird das Programm eine Fehlermeldung erscheinen lassen, ohne eine jeweilige Tabelle zu finden.


Einstellen von Diagramm

Das Einstellen von Diagrammen erfolgt durch das Kontextmenü des Diagramms oder mit Hilfe Options | Environment Options | Tools | Visual Database Designer (zu dt. Optionen | Umgebungsoptionen | Tools | Visueller Databank-Designer).

Im Einstellungsfenster, das nach dem Anklicken Designer Options geöffnet wird, sind zwei Registerkarten vorhanden.

Auf der ersten Registerkarte sind die Einstellungen des Designs, auf der zweiten Registerkarte können die Farbeinstellungen des Diagramms getrennt werden.

Die Werkzeuge der Registerkarte Options:

  • aus der Dropdownliste Model notation kann der Anzeigestandard der Infos im Diagramm - IDEF1x bzw. IE ausgewählt werden,
  • wenn Draw PRIMARY KEY fields separately angehakt ist, wird das Schlüsselfeld von der ganzen Tabelle getrennt,
  • wenn Draw entities icons angehakt ist, werden mit Tabellenköpfen Icons angezeigt,
  • wenn Draw attributes icon angehakt ist, werden mit Feldköpfen Icons angezeigt,
  • wenn Draw only names of entities angehakt ist, werden die Objekte auf dem Diagramm als Kopfzeilen angezeigt,
  • der Fremdschlüsselname kann auf dem Diagramm angezeigt werden, wenn Draw FOREIGN KEY name angehakt ist,
  • wenn Show grid angehakt ist, wird der Raster des Diagrammfensters angezeigt,
  • am Raster ausrichten - Snap to grid,
  • Parameter des Diagrammrasters können mit Hilfe der Optionsfelder Grid size. Breite - X, Höhe - Y eingestellt werden

Im Abschnitt Entity header font werden die Schriftparameter der Tabellenkopfzeilen angegeben:

  • Name - Name,
  • Size - Größe.

Im Abschnitt Attributes font werden die Schriftparameter der Tabellenfelder angegeben:

  • Name - Name,
  • Size - Größe.

Auf der Registerkarte Palette kann man die Farbe für jedes Diagrammelement angeben.

  • Work area - Arbeitsbereich,
  • Work area text - Arbeitsbereich für Text,
  • Entity - Entität,
  • Entity caption text - Text der Entitätsüberschrift,
  • Attribute text - Attribut-Text,
  • Selection - Auswahl,
  • Selected entity caption text - ausgewählter Text der Entitätsüberschrift,
  • Selected attribute text - ausgewählter Attribut-Text,

Wenn nach Änderungen Default angehakt wird, werden alle Änderungen Default-Eigenschaften haben. Die Diagramme, die danach erstellt werden, werden mit diesen Eigenschaften erstellt werden.


SQL-Monitor

Der SQL-Monitor ermöglicht, dass alle Abfragen, die vom SQL Manager 2007 for MySQL auf den Server geschickt wurden und deren Ausführungsergebnisse angeschaut werden können. Man kann den Inhalt des Fensters nicht bearbeiten, kann diesen aber in die Zwischenablage kopieren, in eine Datei speichern und ausdrucken.

Alle Symbolleiste zum Arbeiten mit dem SQL-Monitor befinden sich auf den Symbolleisten und im Kontextmenü.

Um den SQL-Monitor zu öffnen, muss das Hauptmenü des Programms Tools | SQL Monitor ausgewählt werden.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwenden von Werkzeugleisten

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Использование панелей инструментов

Unter der Navigationsleiste befinden sich folgende Werkzeuge:

  • Clear contents - Inhalte löschen,
  • Save to file - Speichern in Datei,
  • Find - Finden,
  • SQL Monitor option - SQL Monitor Optionen (diese Einstellungen sind auch hier Options | Environment Options | Tools | SQL Monitor) (zu dt. Optionen | Umgebungsoptionen | Tools | SQL Monitor),
  • Restore default size - Standardgröße wiederherstellen

Auf der Symbolleiste sind folgende Buttons vorhanden:

  • Clear contents - Inhalte löschen,
  • Save to file - Speichern in Datei,,
  • Find - Finden,
  • Search again - Weitersuchen,
  • SQL Monitor option - SQL Monitor Optionen (diese Einstellungen sind auch hier Options | Environment Options | Tools | SQL Monitor) (zu dt. Optionen | Umgebungsoptionen | Tools | SQL Monitor),
  • Restore default size - Standardgröße wiederherstellen.


Verwenden von Kontextmenü

Mit Hilfe des Kontextmenüs können folgende Aktionen ausgeführt werden:

  • Lesezeichen ein/ausschalten - Toggle Bookmarks,
  • Gehe zum Lesezeichen (aktiv, falls Registerkarten erstellt wurden) - Goto Bookmarks,
  • Rückgängig- Undo,
  • Wiederholen - Redo,
  • Kopieren - Copy,
  • Alles auswählen - Select All,
  • Finden- Find,
  • Weitersuchen - Search Again,
  • Inkrementelle Suche - Incremental Search,
  • Gehe zur Zeilennummer... - Go To Line By Number...,
  • Zu Groß/Kleinbuchstaben wechseln - Change Case,
  • Speichern - Save,
  • Vorschau - Preview,
  • Drucken - Print,
  • Als favorisierte Abfrage speichern - Save as Favorite Query,
  • Eigenschaften - Properties.


SQL Skript Editor

Mit Hilfe des SQL Script Editors können SQL-Skripts erstellt, angesehen, bearbeitet und ausgeführt werden.

Zum Öffnen des Editors muss man Tools | SQL Script im Porgramm-Hauptmenü auswählen. Die DB-Struktur des Skriptes ist im Explorer des Skripteditors dargestellt.

Editor-Bereich

Zum Arbeiten mit den SQL-Skripts sind Editorwerkzeuge auf der Symbolleiste verfügbar:

  • Navigationsleiste,
  • Verbindungseinstellung
  • Symbolleiste,
  • Kontextmenü.

Hinweis: Im Skripteditor werden keine Abfrageergebnisse ausgegeben. Hierfür wird der SQL-Editor verwendet.

Wenn bei der Skriptausführung Fehler auftreten, werden diese im speziellen Fenster, das über den Editorbereich platziert ist, angezeigt. Die Fehleranzeige wird mit Hilfe Options | Environment Options | Tools | SQL Script ( zu dt. Optionen | Umgebungsoptionen | Tools | SQL Script) und mit Hilfe der Schaltfläche SQL Script Options auf der Symbolleiste und Navigationsleiste eingestellt.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwendung der Navigationsleiste

Die Werkzeuge für die Arbeit mit SQL-Skripts sind

Navigationsleiste

Auf der Leiste Destination:

  • Host auswählen,
  • Datenbank auswählen.

Auf der Leiste General:

  • Skript ausführen - Execute script,
  • Skript aus Datei ausführen - Execute script from file,
  • Neues Skript - New script,
  • Skript öffnen (Skripts werden als ".sql"-Dateien gespeichert) - Open script,
  • Skript speichern - Save script,
  • Skript speichern als - Save as,
  • Parsing deaktivieren - Disable Parsing,
  • Ergebnisprotokollierung aktivieren - Enable result log,
  • SQL Skript-Optionen - SQL Script options,
  • Standardgröße wiederherstellen - Restore default size.

Auf der Symbolleiste Explorer ist der Explorer des Skripteditors verfügbar.

Symbolleiste

  • Neues Skript - New script,
  • Skript öffnen (Skripts werden als ".sql"-Dateien gespeichert) - Open script,
  • Skript speichern - Save script,
  • Skript aus Datei ausführen - Execute script from file,
  • Skript ausführen - Execute script,
  • aus der Dropdownliste eine Datenbank auswählen,
  • Parsing deaktivieren - Disable Parsing,
  • Ergebnisprotokollierung aktivieren - Enable result log,
  • SQL Skript-Optionen - SQL Script options,
  • Standardgröße wiederherstellen - Restore default size.


Verbindungseinstellung

Wenn es keine verbundene Datenbank gibt, wird vom SQL Manager 2007 for MySQL angeboten, sich bei der SQL-Skriptausführung zu einer Datenbank verbinden zu lassen.

In dem erschienenen Formular können Verbindungsparameter zum Server und zur Datenbank angegeben werden.


Verwendung der Werkzeugleiste

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Verwendung der Symbolleiste

Das Kontextmenü wird beim Betätigen des rechten Mausbuttons im Editorbereich geöffnet.

  • Skript ausführen - Execute Script,
  • Nur ausgewählte ausführen - Execute Selected Only,
  • Ausführen under Cursor - Execute under Cursor,
  • Parsing deaktivieren - Disable Parsing,
  • Lesezeichen ein/ausschalten - Toggle Bookmarks,
  • Gehe zum Lesezeichen (aktiv, wenn Lesezeichen erstellt sind) - Goto Bookmarks,
  • Rückgängig- Undo,
  • Wiederholen - Redo,
  • Ausschneiden - Cut,
  • Kopieren - Copy,
  • Einfügen - Paste,
  • Alles auswählen - Select All,
  • Finden- Find,
  • Ersetzen - Replace,
  • Weitersuchen - Search Again,
  • Inkrementelle Suche - Incremental Search,
  • Gehe zur Zeilennummer... - Go To Line By Number...,
  • Zu Groß/Kleinbuchstaben wechseln - Change Case,
  • Text des Skriptes laden - Load,
  • Speichern - Save,
  • Vorschau - Preview,
  • Drucken- Print,
  • SQL formatieren - Format SQL,
  • Darstellung Kommentare umschalten - Toggle Comment,
  • Als favorisierte Abfrage speichern - Save as Favorite Query,
  • Eigenschaften - Properties.


Explorer des Skripteditors

Auf der Navigationsleiste ist das Werkzeug Explorer verfügbar, das ermöglicht, alle Objekte mit SQL-Skripts als Struktur anzuzeigen. Mit Hilfe des Explorers kann man schnell zum gewünschten Objekt im Skripttext übergehen.


Assistent zum Kopieren von Datenbanken

Mit dem Assistenten zum Kopieren von Datenbanken können beliebige Infos aus einer Datenbank in eine andere kopiert werden. Man kann sowohl die Daten, als auch die DB-Struktur kopieren. Um Kopieren zu starten, muss der Punkt Tools | Copy Database (zu dt. Werkzeuge | Datenbank kopieren) mit dem Punkt im Hauptmenü des Programms ausgewählt werden.

Der Assistent besteht aus folgenden Schritten:

  • Auswählen der Quelldatenbank
  • Eingabe der Zieldatenbank
  • Auswählen der zu kopierenden Objekttypen
  • Auswählen von Objekten zum Kopieren ihrer Struktur
  • Auswählen von Objekten zum Kopieren ihrer Daten
  • Einstellen der zusätzlichen Optionen
  • Betrachten der Ergebnisse

Siehe auch:

Assistent zum Extrahieren von Datenbanken

SQL Skript Editor

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Auswählen der Quelldatenbank

Im ersten Schritt wird eine zu kopierende Datenbank ausgewählt.

Aus der Dropdownliste Source database ist eine erforderliche Datenbank auszuwählen.

Im Abschnitt Destination database muss der Typ einer Zieldatenbank ausgewählt werden.

  • Registered database - registrierte Datenbank.
  • Non-registered database - nicht registrierte Datenbank

Wenn die Zieldatenbank schon registriert ist, muss diese im zweiten Schritt aus der Dropdownliste ausgewählt werden. Wurde die Zieldatenbank nicht registriert, können im zweiten Schritt die Verbindungsparameter zu dieser Datenbank angegeben werden.

Nächster Schritt


Eingabe der Zieldatenbank

Wenn im ersten Schritt angegeben wurde, dass die Zieldatenbank registriert ist, muss im zweiten Schritt nur eine der registrierten Datenbanken aus der Liste Database ausgewählt werden. Der registrierte Server kann aus der Dropdownliste Host ausgewählt werden.

Ist die Zieldatenbank nicht registriert, müssen im zweiten Schritt die Registrierungsparameter eines Hosts und einer Datenbank angegeben werden.

Aus der Dropdownliste Host name muss der Server (Host), zu dem Sie sich verbinden möchten, ausgewählt werden.

In diese Liste werden die Namen von schon bereits registrierten Servern eingetragen.

Im Feld Port muss der Port für die Verbindung angegeben werden. Danach ist der Benutzername und das Kennwort in den jeweiligen Feldern User name und Password anzugeben.

Die Datenbank, die sich auf dem angegebenen Server befindet, wird aus der Liste Database ausgewählt. Man kann auch eine neue Datenbank anlegen, indem Create new database angehakt wird.

Nächster Schritt


Auswählen der zu kopierenden Objekttypen

Im dritten Schritt wird ausgewählt, welche Infos der Datenbank kopiert werden müssen:

  • Copy both of structure and data - Ist dieses Optionsfeld aktiviert, werden die Daten und die DB-Struktur mit allen Tabellen, Abfragen, Views, Funktionen und Prozeduren kopiert werden.
  • Copy structure only - falls ausschließlich die Struktur einer Datenbank kopiert werden muss, wird dieses Optionsfeld angehakt.
  • Copy data only - es werden in die Zieldatenbank nur die Daten kopiert, falls dieses Optionsfeld ausgewählt wird

Nächster Schritt


Auswählen von Objekten zum Kopieren ihrer Struktur

Dieser Schritt wird nur dann aktiv, wenn die DB-Struktur kopiert wird.

Man kann Objekte, deren Struktur zu kopieren ist, auswählen.

Wenn der Punkt Copy all objects aktiviert ist, wird die Struktur aller Objekte kopiert werden.

Aus der Dropdownliste Objects to copy wird der Typ eines Objektes (Tabelle, View usw.) ausgewählt. Nach dem Auswählen des Typs werden in der Liste Available alle Datenbankobjekte, die diesem Typ entsprechen, erscheinen.

Mit den Buttons werden die Objekte aus der Liste der verfügbaren Objekte - Available in die Liste der ausgewählten Objekte - Selected verschieben.

Nächster Schritt


Auswählen von Objekten zum Kopieren ihrer Daten

In diesem Schritt sind die Tabellen, aus denen die Daten kopiert werden, auszuwählen.

Beim Auswählen des Optionsfeldes Copy data of selected tables werden die Daten nur aus den im vorherigen Schritt ausgewählten Tabellen kopiert. Wenn man Copy data of all tables auswählt, werden die Daten aller DB-Tabellen kopiert werden. Wenn man Copy selected Tables auswählt, können Tabellen ausschließlich aus der Liste der verfügbaren Objekte - Available ausgewählt und mit Hilfe der Schaltflächen in die Liste der ausgewählten - Selected verschoben werden.

Nächster Schritt


Einstellen der zusätzlichen Optionen

In diesem Schritt werden allgemeine Einstellungen vom Kopieren eingegeben:

Bei dem Datentransfer kann das Komprimierungsprotokoll verwendet werden. Hinzu muss Use compression protocol aktiviert werden. Bestehen in der Datenbank bereits Objekte, die mit den kopierenden Objekten identisch sind, werden diese gelöscht, falls Drop object if exists ausgewählt wurde.

Beim Auswählen von Disable foreign key checks wird die Überprüfung der Fremdschlüssel deaktiviert.

Wenn Extract dependent objects aktiviert wurde, werden für Objekte ihre Abhängigkeitsobjekte extrahiert.

Aus der Dropdownliste Extract structure for version kann die Version des MySQL-Servers, auf dem die Datenbank abgelagert ist und in den die Infos kopiert werden, ausgewählt werden.

Die Tabellendaten kann man mit Datenblocken kopieren. Im Feld Record count per each data block wird deren Anzahl angegeben. Bei Aktivierung des Häkchens Commit each data block kann Commit der Transaktion nach jedem Kopieren vom Datenblock ausgeführt werden.

Nächster Schritt


Betrachten von Ergebnissen

Nachdem alle gewünschten Optionen in den vorherigen Schritten eingegeben wurden, muss der Button Finish für den Ausführungsstart der Operationen angeklickt werden. In der Statuszeile, die sich oben befindet, wird der Verlauf von Operationsausführung in Prozenten angezeigt.

Registerkarte Operations

Unter der Registerkarte Operation sind alle ausgeführten Aktionen und deren Ausführungsergebnisse angezeigt.

Die Operationsausführung wird beim Fehlerauftritt abgebrochen, falls Abort copying on error ausgewählt wurde.

Bei Aktivierung des Häkchens Close the Wizard after successful completion wird der Assistent bei der erfolgreichen Operationsausführung geschlossen. Wenn das Häkchen nicht aktiviert ist, kann man nach der Ausführung zurückgehen und andere Operationsparameter eingeben.


Assistent zum Extrahieren von Datenbanken

Mit dem Assistenten zum Extrahieren von Datenbanken kann die Struktur von DB-Objekten und die Objekte ins SQL-Skript extrahiert werden. Das Skript kann zum Kopieren oder Wiederherstellen von Datenbanken eingesetzt werden. Zum Öffnen des Assistenten wird der Punkt des Programmhauptmenüs Tools | Extract Database (zu dt. Werkzeuge | Datenbank extrahieren) verwendet.

Auswählen der Quelldatenbank

Auswählen einer Zieldatei

Auswählen von DB-Komponenten zum Extrahieren

Auswählen von Objekten zum Extrahieren

Auswählen von Tabellen, aus denen die Daten extrahiert werden

Einstellen von Skriptoptionen

Betrachten von Ergebnissen

Siehe auch Exportieren von Daten als SQL-Skript.

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dies wird beim Öffnen auf den Button Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen der Quelldatenbank

Im ersten Schritt wird die zu extrahierende Datenbank ausgewählt. Aus der Dropdownliste Source database kann eine erforderliche Datenbank ausgewählt werden.

Bei Aktivierung des Häkchens Extract all metadata and data of the database können alle DB-Objekte und DB-Daten extrahiert werden.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen einer Zieldatei

In diesem Schritt kann man bestimmen, ob das zu erstellende Skript in einer Datei gespeichert oder direkt im Editor von SQL-Skripten geöffnet werden muss.

Um automatisch das Skript im Editor von SQL-Skripten zu öffnen, muss das Optionsfeld Automatically load to Script Editor ausgewählt werden.

Wollen Sie das Skript in einer Datei speichern, wird der Punkt Save to file ausgewählt. In diesem Fall muss man im Feld File name einen Dateinamen bzw. einen Pfad angeben. Die Datei kann man auch mit Hilfe eines standardmäßigen Dialogfensters, das beim Öffnen auf den Button [image] geöffnet wird, auswählen.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen von DB-Komponenten zum Extrahieren

Dieser Schritt ist nicht aktiv, wenn im ersten Schritt bei Aktivierung des Häkchens Extract all metadata and data of database angegeben wurde, dass die gesamte Struktur und DB-Daten extrahiert werden.

Man kann eine aus drei Varianten des Exportierens auswählen:

  • Datenbankstruktur und -Daten extrahieren - Extract both of structure and data,
  • Nur Struktur extrahieren - Extract structure only,
  • Nur Daten extrahieren - Extract data only,

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen von Objekten zum Extrahieren

Dieser Schritt wird aktiv, falls die DB-Struktur extrahiert wird.

Man kann Objekte, deren Struktur extrahiert werden muss, auswählen.

Bei Extract all objects wird die Struktur aller Objekte ausgeführt.

Aus der Dropdownliste Objects to copy wird ein Objekttyp (Tabelle, View usw.) ausgewählt. Nach dem Auswählen des Types in der Liste Available erscheinen alle DB-Objekte, die diesem Typ entsprechen. Mit Hilfe der Schaltflächen werden Objekte aus der Liste der verfügbaren Objekte Available in die Liste der ausgewählten Selected verschoben.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen von Tabellen, aus denen die Daten extrahiert werden

In diesem Schritt können Tabellen ausgewählt werden, aus denen die Daten extrahiert werden.

Wenn der Punkt Extract data of the selected tables ausgewählt wurde, können Tabellen aus der Liste der verfügbaren Tabellen Available und mit Hilfe der Schaltflächen in die Liste der ausgewählten Selected verschoben werden. Wenn der Punkt Extract data of all tables ausgewählt wird, werden die Daten aus allen DB-Tabellen extrahiert. Das Optionsfeld Extract data of tables selected on previous step gibt an, dass die Daten ausschließlich aus den Tabellen, die im vorherigen Schritt ausgewählt wurden, extrahiert werden.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Einstellen von Skriptoptionen

Im letzten Schritt können einige allgemeine Optionen des zu erstellenden SQL-Skriptes angegeben werden.

Bei Aktivierung des Häkchens Generate "CREATE DATABASE" statement wird im Skript die Anweisung CREATE DATABASE angelegt.

Bei Aktivierung des Häkchens Generate "DROP DATABASE IF EXIST" statement wird angegeben, dass beim Extrahieren die DROP-Anweisungen erstellt werden. Diese werden Datenbanken, die den Datenbanken mit dem erstellenden Skript entsprechen, vor deren Erstellung löschen.

Wenn Generate "USE db_name" statement aktiviert ist, dann wird im Skript der Befehl USE db_name erstellt. Mit diesem Befehl wird MySQL die Datenbank mit dem Namen db_name in nächsten Abfragen standardmäßig verwenden. Die angegebene Datenbank bleibt in diesem Status bis zum Ende dieser Sitzung oder solange noch ein USE-Befehl nicht ausgegeben wird.

Bei Aktivierung des Häkchens Generate "DROP IF EXIST" statement wird angegeben, dass beim Extrahieren die DROP-Anweisungen erstellt werden. Diese werden Objekte, die den Objekten mit dem erstellenden Skript entsprechen, vor deren Erstellung löschen.

Bei Aktivierung des Häkchens Disable foreign key checks wird die Überprüfung der Fremdschlüssel deaktiviert.

Generate "SET NAMES" statement erstellt die Anweisung SET NAMES, in dem der Zeichensatz festgelegt wird.

Wenn Extract dependent objects aktiviert ist, werden für Objekte ihre Abhängigkeitsobjekte extrahiert.

Add DELIMITER statement for stored routines and triggers - DELIMITER-Anweisung für gespeicherte Routines und Triggers hinzufügen

Insert comments - Kommentare hinzufügen

Unter der Registerkarte Data Options werden Datenoptionen eingegeben.

Die Anzahl der Datensätze in einem Block wird im Optionsfeld Records in a block angegeben.

Wenn der Punkt Insert "COMMIT" statement after each block aktiviert ist, wird nach jedem Block die Anweisung COMMIT hinzugefügt.

Bei Aktivierung des Häkchens Extract table data just after its definition werden Anweisungen INCERT in dem erstellenden Skript direkt nach dem Skript der Tabellenerstellung eingetragen. Die Daten können aus verbundenen Tabellen extrahiert werden, indem man das Häkchen Extract data from Merge tables aktiviert.

Die Operation des Extrahierens kann beim Fehlerauftritt abgebrochen werden, wenn das Häkchen Abort extraction on error aktiviert wurde. Im Gegenfall wird das Skript ohne Unterbrechungen ausgeführt werden und alle erscheinenden Fehler werden in einem speziellen Fenster angezeigt.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Betrachten von Ergebnissen

Nachdem alle gewünschten Optionen in den vorherigen Schritten eingegeben wurden, muss der Button Finish für den Ausführungsstart der Operationen angeklickt werden. In der Statuszeile, die sich oben befindet, wird der Verlauf von Operationsausführung in Prozenten angezeigt.

Registerkarte Operations

Unter der Registerkarte Operation sind alle ausgeführten Aktionen und deren Ausführungsergebnissse angezeigt.

Zum Öffnen eines erstellten Skriptes im SQL Skript Editor wird das Häkchen Load script to Script Editor aktiviert.

Bei Aktivierung des Häkchens Close the Wizard after successful completion wird der Assistent bei der erfolgreichen Operationsausführung geschlossen. Wenn das Häkchen nicht aktiviert ist, kann man nach der Ausführung zurückgehen und andere Operationsparameter eingeben.


Drucken von Metadaten

Das Tool ermöglicht das Drucken von Metadaten jedes DB-Objektes. Zum Öffnen dieses Werkzeuges muss man

Tools | Print Metadata (zu dt. Werkzeuge | Metadaten drucken) auswählen.

Die Optionseinstellungen kann man mit Hilfe der Werkzeuge, die sich auf den Werkzeugsleisten befinden, vornehmen.

Siehe auch Assistent zum Erstellen von HTML-Berichten.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwendung der Werkzeugleiste

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Verwendung der Symbolleiste

Die Hauptwerkzeuge sind auf Symbolleisten zu finden.

Navigationsleiste

Auf der Leiste Database:

  • Datenbank auswählen.

Auf der Leiste General:

  • drucken - Print,
  • Vorschau- Preview,
  • Standardgröße wiederherstellen - Restore default size.

Auf der Leiste Show befindet sich die Liste von Objekttypen:

  • alle Objekte anzeigen - Show All,
  • Tabellen - Tables,
  • Views - Views,
  • Prozeduren - Procedures,
  • Benutzerdefinierte Funktionen - UDFs.
  • Geplante Ereignisse - Show scheduled events.

Symbolleiste

  • Datenbank auswählen,
  • alle Objekte anzeigen - Show All,
  • Tabellen - Tables,
  • Views - Views,
  • Gespeicherte Prozeduren - Stored procedures,
  • Gespeicherte Funktionen - Stored functions,
  • Benutzerdefinierte Funktionen - User-Defined functions,
  • Geplante Ereignisse - Scheduled Events,
  • Vorschau - Preview,
  • Drucken - Print,
  • Standardgröße wiederherstellen - Restore default size.


Druckeneinstellung

Bei der Druckereinstellung muss man die DB-Objekte, deren Metadaten auszudrucken sind, auswählen.

Auf einer der Verwaltungsleisten muss ein Objekttyp ausgewählt werden. Danach werden in der Liste Available <Objekttyp> alle sich in der Datenbank gespeicherten Objekte mit diesem Typ erscheinen. Mit Hilfe der Schaltflächen bzw. mit einem Doppelmausklick werden die Objekte in die Liste der ausgewählten Objekten <Objekttyp> zum Drucken eingetragen. Mehrere Objekte können mit Hilfe der Schaltflächen Ctrl und Shift ausgewählt werden.

Im unteren Teil der Liste von ausgewählten Objekten kann man angeben, welche Infos über jeweiliges Objekt auszudrucken sind.

  • Fields/Params - Felder/Parameter,
  • Indices - Indizes
  • DDL,
  • Description - Beschreibung.

Das Objekt kann aus der Liste der ausgewählten Objekten mit Hilfe der Schaltflächen bzw. mit einem Doppelmausklick entfernt werden.


Assistent zum Erstellen von HTML-Berichten

Der Assistent zum Erstellen von HTML-Berichten ermöglicht Ihnen, einen ausführlichen zusammengesetzten Bericht über die Metadaten einer ausgewählten Datenbank zu erstellen. Dies wird mit Hilfe des Menüpunktes Tools | HTML Report (Werkzeuge | HTML Report ) geöffnet.

Auswählen einer Datenbank und eines Zielordners

Auswählen des DB-Objekttyps

Bestimmen des Berichtformates

Auswählen von zusätzlichen Berichtsoptionen

Betrachten von Ergebnissen

Siehe auch:

Drucken von Metadaten

Assistent zum Exportieren von Daten

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses wird beim Klicken auf den Button Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Auswählen einer Datenbank und eines Zielordners

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Auswählen einer Quelldatenbank und eines Zielordners

Im ersten Schritt muss man eine Datenbank auswählen, nach deren Metadaten ein Bericht erstellt werden muss.

Die Quelldatenbank wird aus der Dropdownliste Source database ausgewählt, in der alle registrierten und angeschlossenen Datenbanken enthalten sind.

Im Feld Output directory wird mit Hilfe des Buttons [image] den Pfad zum Ordner angegeben, in dem der HTML-Bericht erstellt werden muss.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen des DB-Objekttypes

Im zweiten Schritt können Objekttypen ausgewählt werden. Die Infos über diese Objekttypen werden in den Bericht eingetragen. Standardmäßig werden alle Objekttypen ausgewählt.

  • Tabellen - Tables,
  • Triggers - Triggers,
  • Views - Views,
  • Prozeduren - Procedures,
  • Gespeicherte Funktionen - Functions,
  • Benutzerdefinierte Funktionen - UDFs,

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Bestimmen des Berichtformates

Im dritten Schritt kann das Berichtformat der HTML-Ausgabedatei bestimmt werden. Man kann den Beschreibungstext des Formates manuell bearbeiten bzw. diesen aus der Datei *.css kopieren.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Auswählen von zusätzlichen Berichtsoptionen

Im letzten Schritt werden zusätzliche Berichtsoptionen angegeben:

  • Zeichensatz - dies wird aus der Liste Charset ausgewählt,
  • Kopfzeile des Berichts - Report header,
  • Fußzeile des Berichts- Report footer.

Nächster Schritt

Um nicht jedes Mal die Parameter eingeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet.


Betrachten von Ergebnissen

Nachdem alle gewünschten Optionen in den vorherigen Schritten eingegeben wurden, muss der Button Finish für den Ausführungsstart der Operationen angeklickt werden. In der Statuszeile, die sich oben befindet, wird der Verlauf von Operationsausführung in Prozenten angezeigt.

Registerkarte Operations

Unter der Registerkarte Operation sind alle ausgeführten Aktionen und deren Ausführungsergebnisse angezeigt.

Wenn man den erstellten Bericht sofort öffnen will, muss Show report after generating aktiviert werden.

Wenn der Punkt Close the Wizard after successful completion aktiviert wurde, wird der Assistent bei der erfolgreichen Operationsausführung automatisch geschlossen. Wenn das Häkchen deaktiviert wurde, kann man nach der Ausführung zurückkommen und weitere Operationsparameter eingeben.


Arbeiten mit Berichten

Die Berichte können im SQL Manager 2007 for MySQL mit Hilfe der folgenden Werkzeuge ausgeführt werden:

Assistent zum Erstellen von Berichten und Berichtdesigner ermöglichen die Berichte auf eine einfache Weise zu erstellen.

Berichts-Designer ist das Hauptwerkzeug zum Erstellen von Berichten.

Berichtsviewer ist ein Werkzeug zum Betrachten von Ergebnissen.

Die Berichte werden in Verzeichnissen, die in der Datenbank bei Bearbeitung der DB-Registrierungsinfos auf der Registerkarte Verzeichnisse bestimmt wurden, gespeichert.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Assistent zum Erstellen von Berichten

Der Assistent zum Erstellen von Berichten ist für eine schnelle und schrittweise Erstellung des Berichtformulars bestimmt. Die Datenquelle, die angezeigten Bereiche und Seitenparameter sind dafür ausgewählt. Um den Assistenten zu starten, muss eine der Aktionen ausgeführt werden:

  • Objekt Report im DB-Explorer anlegen,
  • Hauptmenüpunkt des Programms Database | New Object (zu dt.: Datenbank | Neues Objekt) auswählen,
  • Punkt Report aus der Liste, die beim Anklicken der Schaltfläche Create auf der Symbolleiste des DB-Explorers geöffnet wird, auswählen.

Berichtsoptionen

Auswählen von den anzuzeigenden Bereichen im Bericht

Auswählen des Berichtsformates

Eingabe von Seitenparametern

Siehe auch:

Berichts-Designer

Berichtsviewer

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Auswählen von Berichtsoptionen

Im ersten Schritt muss eine Datenbank, für die einen Bericht erstellt wird, aus der Liste Database ausgewählt werden.

Die Liste besteht aus registrierten und angeschlossenen Datenbanken.

Im Abschnitt Report creation method muss man auswählen, wie der Bericht erstellt wird:

  • New report - Es wird ein neuer Bericht erstellt;
  • Import from file - Der Bericht wird aus einer Datei importiert

Im Abschnitt Save options kann man die Parameter zum Speichern von Optionen angeben:

  • Dateiname wird im Feld Report name angegeben,
  • Wenn Save to database aktiviert ist, wird der Bericht in einem Ordner, der für die Berichte bestimmt ist, gespeichert.
  • Wenn man Save to file auswählt, wird der Bericht in einer Berichtsdatei mit Erweiterung *.fr3. gespeichert.

Nächster Schritt


Auswählen von den anzuzeigenden Bereichen im Bericht

Im zweiten Schritt muss man Bereiche, in denen zusätzliche Daten angezeigt werden, auswählen, d.h. Kopf- und Fußzeilen, Summen, Feldgruppierungen usw.

Die gewünschten Bereiche werden aus der Liste der verfügbaren Bereiche - Available Bands - ausgewählt und mit Hilfe der Schaltflächen in die Liste der angezeigten Bereiche - Report Bands- übertragen.

Für die Bereiche Master data, Detail data und Subdetail data kann man Werte mit Hilfe des Buttons [image] eingeben.

Beim Anklicken dieser Schaltfläche wird der Query-Builder geöffnet, mit dem die im Bericht anzuzeigenden Daten angegeben werden können.

Die Bereiche, für die die Daten angegeben sind, werden angehakt.

Hinweis: Man kann die Daten für Detail data nur dann eingeben, wenn diese bereits für Master data eingegeben werden. Die Daten für Subdetail data werden nach Master data eingegeben.

Nächster Schritt


Auswählen des Berichtformates

Im dritten Schritt kann das Berichtformat ausgewählt werden. Auf dem Formular sind verschiedene Seitenformate zu sehen. Zum Auswählen muss man das benötigte Format mit der linken Maustaste anklicken.

Nächster Schritt


Eingabe von Seitenparametern

In diesem Schritt müssen die Seitenparameter des zu druckenden Berichtdokumentes eingestellt werden.

Diese Eigenschaften werden in drei Registerkarten eingestellt:

Registerkarte Paper/Papier

Im Abschnitt Size wird die Seitengröße angegeben.

Aus der Dropdownliste wählt man eine der Standardgrößen. Wenn die Standardgrößen nicht passen, wird der Punkt Extrapapier ausgewählt. In diesem Fall werden die Felder verfügbar, in denen die Breite und die Höhe des Papierblattes in Millimeter angegeben werden.

Mit Hilfe des Optionsfeldes im Abschnitt Orientation wird Seitenausrichtung ausgewählt.

  • Portrait - Hochformat
  • Landscape - Querformat.

Registerkarte Margins/Ränder

Unter der Registerkarte Margins kann man die Größe der Seitenränder angeben.

Wenn der Punkt Stretch to print area aktiviert ist, werden die Seitenränder automatisch bis zum Druckbereich ausgedehnt.

Man kann die Seitenränder manuell mit Hilfe der folgenden Felder einstellen:

  • Left, mm - linkes Feld,
  • Top, mm - oberes Feld,
  • Right, mm - rechtes Feld,
  • Bottom, mm - unteres Feld.

Registerkarte Others/Weitere

Unter der Registerkarte Others können mehrere zusätzliche Charakteristiken des Berichtes eingegeben werden.

Print to previous page. Diese Option ermöglicht beim Drucken des Berichtes den leeren Bereich einer vorherigen Seite zu verwenden. Die Funktion wird benutzt, wenn der Bericht aus mehreren Seiten besteht.

Wenn Two-pass report aktiviert ist, wird die Erstellung des Berichtes in zwei Phasen stattfinden.

In der ersten Phase wird der Bericht erstellt, danach kommt dessen Gliederung in Seiten, aber das Ergebnis wird jedoch nicht gespeichert. In der zweiten Phase wird der Bericht erstellt und das Ergebnis gespeichert. Wenn Page numbering angehakt ist, werden die Berichtsseiten numeriert.

Columns

Im Optionsfeld Number wird die Anzahl der Spalten im Bericht angegeben.

Im Feld Gap, mm wird die Lücke zwischen den Spalten angegeben.

Wenn der Punkt Open the report after the wizard has finished aktiviert ist, wird der mit Hilfe des Assistenten erstellte Bericht automatisch im Berichts-Designer geöffnet.

Zur Erstellung des Berichtes wird der Button Finish angeklickt.


Berichts-Designer

Der Bericht-Designer ermöglicht Ihnen Berichte zu erstellen und zu bearbeiten. Dieses Werkzeug wird beim Auswählen des Punktes Tools | Report Designer (zu dt.: Werkzeuge | Berichts-Designer) bzw. nach der Berichtserstellung mit Hilfe des Assistenten zum Erstellen von Berichten geöffnet.

Das Modul Report Designer ist eine Komponente des Programms FastReport (http://www.fast-report.com). Deswegen gibt es dafür eine separate Hilfsdatei, die beim Anklicken auf den Button F1 im Designer-Fenster geöffnet wird.

Hinzufügen des Dialogformulars

Hinzufügen der DB-Objekte

Hinzufügen der Abfragekomponenten

Hinzufügen der Felder

Berichtsvorschau

Siehe auch:

Assistent zum Erstellen von Berichten

Berichtsviewer

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Hinzufügen des Dialogformulars

Um ein Dialogformular hinzuzufügen, muss man auf der Symbolleiste den Button Add dialog form anklicken.


Hinzufügen der DB-Objekte

Um DB-Objekte in einen Bericht hinzuzufügen, gehen Sie bitte wie folgt vor:

  • Objekt ZeosMyDatabase, das sich links vom Hauptfenster befindet, auf der Symbolleiste auswählen und zum erstellten Formular bringen;
  • im Fenster Object Inspector unter der Registerkarte Properties den Server (Host) und die Datenbank (DatabaseName) angeben;
  • True für die Eigenschaft LoginPrompt angeben;
  • True für die Eigenschaft Connected angeben;
  • Login und Kennwort eingeben;
  • False für die Eigenschaft LoginPrompt angeben;

Hinweis: Object Inspector wird beim Betätigen der Schaltfläche F11 geöffnet.


Hinzufügen der Abfragekomponenten

Um die Abfragekomponenten hinzuzufügen, muss man:

  • Insert query auf der Symbolleiste, die sich links vom Hauptfenster befindet, auswählen und zum erstellten Formular bringen;
  • aus der Liste Database eine Datenbank auswählen;
  • Abfragetext im Fenster, das beim Auswählen des Punktes SQL im Fenster Object Inspector geöffnet wird, auswählen;
  • die Eigenschaft Active als True einstellen.

Hinweis: Object Inspector wird beim Betätigen der Schaltfläche F11 geöffnet.


Hinzufügen der Felder

Auf der Seite Page1 werden DB-Felder, aus denen der Bericht zusammengesetzt werden muss, platziert. Hierfür muss man die Felder der Datenbank aus der Liste, die sich im Fenster Insert fields befindet, auswählen.


Berichtsvorschau

Um den erstellten Bericht anzusehen und auszudrucken, wird der Button Preview auf der Symbolleiste angeklickt.


Berichtsviewer

Mit Hilfe dieses Werkzeuges kann man die Berichte betrachten, bearbeiten, speichern oder ausdrucken.

Um den Bericht im Viewer zu öffnen, muss man auf den Bericht, der in der Gruppe von Objekten Reports im DB-Explorer zu finden ist, doppelt klicken. Die Hauptwerkzeuge befinden sich auf den Symbolleisten.

Siehe auch:

Assistent zum Erstellen von Berichten

Berichts-Designer

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Werkzeugleisten

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Symbolleisten

Navigationsleiste

Auf der Leiste Object:

  • Datenbank auswählen,
  • Bericht auswählen.

Auf der Leiste General:

  • Aktualisieren - Refresh,
  • Bericht im Berichts-Designer bearbeiten - Edit report,
  • Bericht speichern unter - Save report as,
  • Bericht ausdrucken - Print,
  • Standardgröße wiederherstellen - Restore default size.

Symbolleiste

  • Datenbank auswählen,
  • Bericht auswählen,
  • Aktualisieren - Refresh,
  • Speichern - Save,
  • Bericht speichern unter - Save report as,
  • Bericht im Berichts-Designer bearbeiten- Edit report,
  • Bericht ausdrucken - Print,
  • Standardgröße wiederherstellen - Restore default size.


Abhängigkeitsstruktur

Dieses Tool ermöglicht, die Abhängigkeiten aller Objekte als Diagramm anzusehen.

Im Hauptfenster dieses Werkzeuges wird die Objektabhängigkeit als Abhängigkeitsstruktur dargestellt.

Um die Abhängigkeitsstruktur zu öffnen, muss der Punkt des Hauptmenüs Tools | Dependency Tree (Tools | Abhängigkeitsbaum) ausgewählt werden.

Alle wichtigen Tools zum Arbeiten mit Objekten und Abhängigkeitsdiagramm befinden sich auf den Symbolleisten:

  • auf der Navigationsleiste,
  • auf der Symbolleiste,
  • im Kontextmenü.

Um die Abhängigkeiten eines Objektes anzusehen, muss das Objekt ausgewählt werden. Dies kann man auf eine der folgenden Weisen vornehmen:

  • Button Select object auf der Navigationsleiste anklicken,
  • Objekt aus dem Fenster des DB-Explorers ins Hauptfenster des Abhängigkeitsbaumes übertragen

Das ausgewählte Objekt ist ein Hauptobjekt und unterscheidet sich von anderen durch die Rahmenfarbe. Das Hauptobjekt hat eine dunkelblaue Farbe, alle weiteren Objekte haben eine schwarze Farbe. Die Abhängigkeiten unter den Objekten sind mit Pfeilen angezeigt. Wenn man ein Objekt, das im Abhängigkeitsdiagrammm angezeigt wird, anklickt, wird das Objekt zum Hauptobjekt und alle Abhängigkeiten werden für dieses Objekt angezeigt. Um die Infos über das vorherige Objekt anzusehen, muss der Punkt Previous object auf der Navigationsleiste, auf der Symbolleiste und im Kontextmenü ausgewählt werden.

Im Abhängigkeitsdiagramm gibt es eine Möglichkeit, die abhängigen Unterobjekte anzuzeigen und auszublenden.

Dies kann man mit Hilfe des Buttons Hide subobjects/Subobjekte ausblenden auf der Symbolleiste vornehmen.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Werkzeugleisten

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Symbolleisten

Die Symbolleisten befinden sich links vom Editor und über dem Editor.

Navigationsleiste

auf der Leiste Database:

  • Datenbank auswählen.

auf der Leiste General:

  • Aktualisieren - Refresh,
  • Metadaten des Objektes ausdrucken - Print,
  • Druckeinstellungen - Print setup,
  • Als Bild speichern - Save as image,
  • SQL Hilfe anzeigen - Show SQL help.

auf der Leiste Object:

  • Vorheriges Objekt - Previous object,
  • Nächstes Objekt - Next object,
  • Subobjekte anzeigen- Show subobjects,
  • Objekt auswählen - Select object.

Symbolleiste

  • Datenbanken - Databases,
  • Metadaten des Objektes ausdrucken - Print,
  • Druckeinstellungen - Print setup,
  • Als Bild speichern - Save as image,
  • Aktualisieren - Refresh,
  • Vorheriges Objekt - Previous object,
  • Nächstes Objekt - Next object,
  • Objekt auswählen - Select object,
  • Subobjekte anzeigen - Show subobjects,
  • Standardgröße wiederherstellen - Restore default size.

Kontextmenü

Das Kontextmenü wird beim Betätigen der rechten Maustaste im beliebigen Leerraum des Abhängigkeitsdiagramms geöffnet.

  • Aktualisieren - Refresh,
  • Vorheriges Objekt - Previous object,
  • Nächstes Objekt - Next object,
  • Objekt auswählen- Select object,
  • Subobjekte anzeigen - Show subobjects. (Indizes, Triggers und Fremdschlüssel).


Suche nach Metadaten

Diese Option wird eingesetzt, wenn eine Zeichenkombination im Text der Metadaten einer Datenbank gefunden werden muss.

Um das Fenster zum Suchen von Metadaten zu öffnen, muss der Punkt „Tools | Search in Metadata“ (zu dt.: „Werkzeuge | Suchen in Metadaten“) im Hauptmenü des Programms ausgewählt oder die Tastenkombination Ctrl+Alt+F verwendet werden.

Search in Metadata

Im Feld „Text to find“ ist das zu suchende Wort einzugeben. Aus der Dropdownliste „Database“ muss eine Datenbank, in der die Suche ausgeführt wird, ausgewählt werden.

Case Sensitive - Unterscheidung nach Groß-/Kleinschreibung

Whole words only - Nur ganzes Wort suchen

Regular Expressions - Reguläre Ausdrücke

Im Abschnitt „Direction“ muss die Suchrichtung angegeben werden:

  • Forward - vorwärts,
  • Backward - rückwärts.

Die Ergebnisse der Suche werden in einem speziellen Fenster angezeigt.

Search in Metadata_1

In der Navigationsleiste im Abschnitt Explorer werden alle Objekte angezeigt, in deren Metadaten das gesuchte Wort und die Wortverbindung vorkommen.

Die Metadaten eines Objekts werden im SQL-Editor beim Drücken auf die Bezeichnung des Objektes im Abschnitt Explorer angezeigt.


Sicherheitsmanagement

Für Sicherheitsmanagement im SQL Manager 2007 for MySQL sind zwei Werkzeuge verfügbar, mit deren Hilfe die Benutzerzugriffsrechte auf die Datenbankdaten und -Metadaten erteilt werden können.

Verwaltung von Benutzern (User manager) ist ein Werkzeug zum Hinzufügen, Löschen der registrierten Benutzernamen des Servers und auch zur Einrichtung und Bearbeitung von Benutzerrechten.

Verwaltung von Rechten (Grant manager) ist ein Werkzeug zur Verwaltung von Benutzerrechten auf das Arbeiten mit DB-Objekten.

Die globalen Benutzerrechte bestimmen die Rechte von Benutzern für den Zugriff auf alle DB-Objekte. Die Rechte werden für den Zugriff auf eine Datenbank, DB-Tabellen und Tabellenfelder erteilt. Die Benutzerzugriffsrechte ermöglichen diverse Operationen (Anlegen, Ändern, Löschen) mit einer Datenbank, Tabellen und Feldern auszuführen.


Verwaltung von Benutzern

Der DB-Benutzer ist ein Hauptbestandteil, der den Zugriff auf DB-Objekte verwaltet.

Im Editor für Rechte werden Name, Kennwort und Zugriffsrechte auf DB-Objekte angegeben.

Erstellen von Benutzern

Um einen neuen Benutzer zu erstellen, muss man wie folgt vorgehen:

  • Hauptmenüpunkt des Programms Werkzeuge | Benutzer-Manager auswählen,
  • Benutzer hinzufügen auf einer der Symbolleisten anklicken.

Das erstellte Objekt wird automatisch im jeweiligen Editor geöffnet.

Bearbeiten von Benutzern

Alle Änderungen von Eigenschaften dieses Objektes werden im Login-Editor vorgenommen.

Um ein Objekt im Editor zu öffnen, muss man:

  • Benutzer hinzufügen auf einer der Symbolleisten des Benutzer-Manager anklicken (im Editor wird ein markierter Benutzer geöffnet),
  • in der allgemeinen Liste auf das benötigte Objekt mit der Maus doppelklicken.

Löschen von Benutzern

Um ein Login zu löschen, muss man:

  • Befehl Benutzer löschen auf einer der Symbolleisten des Benutzer-Manager auswählen,
  • Punkt Benutzer löschen im Kontextmenü des ausgewählten Objektes auswählen.

Verwenden von Symbolleisten

Benutzereditor

Siehe auch:

Grant Manager

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Verwenden von Werkzeugleisten

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Verwenden von Symbolleisten

Die Hauptwerkzeuge, die das Arbeiten mit Login ermöglichen, sind auf den Symbolleisten vorhanden.

Navigationsleiste:

Auf der Leiste Servers:

  • aus der Dropdownliste kann der Server ausgewählt werden. Wenn zum Server keine Verbindung aufgebaut wurde, wird der Server aus der Dropdownliste ausgewählt. Danach wird der Name und das Passwort in dem erscheinenden Fenster eingegeben. Wenn der Host nicht registriert ist, wird für die Registrierung der Assistent zur Hostregistrierung verwendet.

Auf der Leiste General:

  • Refresh - Aktualisieren,
  • Add user - Benutzer hinzufügen,
  • Edit user - Benutzer im Benutzereditor bearbeiten,
  • Delete user - Benutzer löschen,
  • Restore default size - Standardgröße wiederherstellen.

Symbolleiste:

aus der Dropdownliste kann der Server ausgewählt werden:

  • Refresh - Aktualisieren,,
  • Add user - Benutzer hinzufügen,
  • Edit user - Benutzer im Benutzereditor bearbeiten,
  • Delete user - Benutzer löschen,
  • Restore default size - Standardgröße wiederherstellen.


Benutzereditor

Bei der Erstellung eines neuen bzw. bei der Bearbeitung eines bereits bestehenden Benutzers wird der Editor geöffnet, in dem alle Benutzereigenschaften angegeben werden können.

Im Feld Name wird der Benutzername angegeben. Der Server, für den die Rechte des bearbeitenden Benutzers gültig sind, wird im Feld Host angegeben. Danach werden in den Feldern Password und Confirm password, ein Kennwort und eine Bestätigung des Kennwortes angegeben.

Die globalen Rechte sind im Abschnitt Global privileges zu erteilen. Es werden die Operationen aktiviert, zu deren Ausführung der Benutzer berechtigt ist.

Wenn ein Benutzer zur Ausführung aller Operationen berechtigt ist, wird der Punkt All privileges aktiviert.

Der Benutzer, für den der Punkt With grant option aktiviert ist, ist zur Eingabe der Rechte auf alle aufgelisteten Aktionen für einen anderen Benutzer berechtigt.

Zudem sind für den Benutzer folgende Einschränkungen zu setzen:

  • Max. queries per hour - maximale Anzahl der Abfragausführungen pro Stunde,
  • Max. updates per hour - maximale Anzahl von Updates pro Stunde,
  • Max. connections per hour - maximale Anzahl der Verbindungen zu Datenbanken pro Stunde

Die Benutzerrechte auf die Aktionsausführung mit separaten DB-Objekten können im Grant Manager erteilt werden.


Grant Manager

Mit Hilfe des Werkzeuges Grant Manager können die Zugriffsrechte auf geschützte Objekte wie: Datenbanken, Tabellen, Funktionen, Schemas usw. erteilt werden.

Um den Grant Manager zu öffnen, muss man im Hauptmenü des Programm Tools | Grant Manager (zu dt. Werkzeuge | Berechtigungs-Manager ) auswählen.

  • Verwenden von Symbolleisten und Kontextmenü
  • Verwaltung von globalen Rechten
  • Erteilen von zusätzlichen Rechten
  • Verwaltung von Rechten auf DB-Objekte
  • Filtern von Objekten

Siehe auch:

Verwaltung von Benutzern

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Verwenden von Werkzeugleisten und Kontextmenü

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Verwenden von Symbolleisten und Kontextmenü

Die Hauptwerkzeuge zum Arbeiten mit Rechten befinden sich auf den Symbolleisten und im Kontextmenü.

Navigationsleiste

Auf der Leiste Host oder Database:

  • aus der Dropdownliste kann der Server ausgewählt werden. Wenn zum Server keine Verbindung aufgebaut wurde, wird der Server aus der Dropdownliste ausgewählt. Danach wird der Name und das Passwort in dem erscheinenden Fenster eingegeben. Wenn der Host nicht registriert ist, wird für die Registrierung der Assistent zur Hostregistrierung verwendet.

Auf der Leiste General:

  • Refresh - Aktualisieren,
  • Add new user - Neuen Benutzer hinzufügen,
  • Edit selected user - Ausgewählten Benutzer im Benutzereditor bearbeiten,
  • Delete selected user - Ausgewählten Benutzer löschen,
  • Extract user's grants - Benutzerrechte extrahieren,
  • Extract all user's grants - Alle Benutzerrechte extrahieren,
  • Restore default size - Standardgröße wiederherstellen.

Auf der Leiste Privileges for:

Aus der Liste User/Role kann ein Benutzer bzw. eine Rolle, für die die Rechte zu erteilen sind, ausgewählt werden.

Symbolleiste

  • aus der Dropdownliste Databases werden Datenbanken zum Arbeiten ausgewählt,
  • aus der Liste User kann man einen Benutzer, für den die Rechte zu erteilen sind, auswählen,
  • Refresh - Aktualisieren,
  • Edit selected user - Ausgewählten Benutzer im Benutzereditor bearbeiten,
  • Add new user - Neuen Benutzer hinzufügen,
  • Delete selected user - Ausgewählten Benutzer löschen,
  • Extract user's grants - Benutzerrechte extrahieren,
  • Extract all user's grants - Alle Benutzerrechte extrahieren,
  • Restore default size - Standardgröße wiederherstellen.

Kontextmenü

Das Kontextmenü wird beim Klicken auf die Zelle des Bereiches Grant Manager geöffnet und erlaubt, die Rechte auf die Aktionen mit Objekten zu erteilen.

  • Grant - Granten/Berechtigen,
  • Revoke - Aufheben,
  • Grant GRANT OPTION - Mit Option 'GRANT' granten,
  • Revoke GRANT OPTION - mit Option 'GRANT' aufheben,
  • Grant All - Alle granten,
  • Grant All with GRANT OPTION - Alle granten mit GRANT OPTION,
  • Revoke оn All - Für alle aufheben,
  • Grant on All - Alle granten,
  • Grant All with GRANT OPTION - Alle granten mit GRANT OPTION,
  • Revoke on All - Für alle aufheben,
  • Grant All on All - Rechte auf alle Aktionen für alle Objekte erteilen,
  • Grant All on All with GRANT OPTION - Alle Aktionen für alle Objekte mit GRANT OPTION granten,
  • Revoke All on All - Für alle Aktionen alle Objekte aufheben,
  • Sort by Type - Objekte nach dem Typ sortieren,
  • Sort by Name - Objekte nach dem Namen sortieren.


Verwaltung von globalen Rechten

Die globalen Rechten werden im Grant Manager, im oberen Teil, der als Global privileges benannt ist, erteilt.

Den Benutzer, dessen Rechte zu ändern sind, muss man aus der Liste auf der Navigationsleiste bzw. aus der Dropdownliste auf der Symbolleiste auswählen.

Die globalen Rechten sind im Abschnitt Global privileges zu erteilen. Es werden die Operationen aktiviert, zu deren Ausführung der Benutzer berechtigt ist.

Wenn ein Benutzer zur Ausführung aller Operationen berechtigt ist, dann wird der Punkt All privileges aktiviert.

Der Benutzer, für den der Punkt With grant option aktiviert ist, ist zur Eingabe der Rechte auf alle aufgelisteten Aktionen für einen anderen Benutzer berechtigt.

Zudem sind für den Benutzer folgende Einschränkungen zu setzen:

  • Max. queries per hour - maximale Anzahl der Abfragausführungen pro Stunde,
  • Max. updates per hour - maximale Anzahl von Updates pro Stunde,
  • Max. connections per hour - maximale Anzahl der Verbindungen zu Datenbanken pro Stunde.


Verwaltung von Rechten auf DB-Objekte

Im Fenster Database-specific privileges befindet sich eine Tabelle, in der die Zeilen die DB-Objekte sind und die Spalten die mit den Objekten ausgeführten Aktionen darstellen. Um Rechte für eine Datenbank zu erteilen, muss man den Server und eine Datenbank mit Hilfe der Werkzeugen auf Symbolleisten auswählen.

Die Rechte auf die Ausführung einer der Aktionen kann man auf folgenden Weisen ändern:

  • mit Hilfe des Kontextmenüs, das beim Betätigen der rechten Maustaste auf die Zelle erscheint.
  • mit dem Doppelmausklick (beachten Sie bitte bei der Verwendung dieser Methode, dass die Rechtsänderung in folgender Reihenfolge erfolgt - Revoke->Grant->Grant with GRANT OPTION->Deny->Revoke),
  • durch das Klicken auf eine aktive (ausgewählte) Zelle. Dabei erscheint eine Dropdownliste, aus der einer der Rechtstypen ausgewählt werden kann.

  • Grant - Rechte auf die Ausführung dieser Aktion erteilen [image] ,
  • Revoke - Rechte aufheben,
  • Grant with GRANT OPTION - Mit GRANT OPTION granten [image] .


Filtern von Objekten

In großen Datenbanken mit einer Vielzahl von Objekten ist es ziemlich schwierig, das gewünschte Objekt zu finden.

Hierfür sind im Grant Manager mehrere Werkzeuge, die sich auf der Leiste über der Haupttabelle befinden, verfügbar.

  • aus der Dropdownliste All Objects kann man einer der DB-Typen auswählen. Mit Hilfe dieser Liste kann man in der Tabelle entweder nur Tabellen, oder nur Views usw. belassen.
  • der Sonderfilter ermöglicht, die Objekte, auf die keine Rechte erteilt wurden, auszublenden. Falls der Punkt Granted only aktiviert ist, werden nur die DB-Objekte, auf die die Rechte erteilt werden, sichtbar.
  • der Filter ermöglicht, ein Objekt nach den ersten Buchstaben der Benennung zu finden - das ist das Feld Filter.


Dienste des MySQL-Servers

Im SQL Manager 2007 for MySQL sind spezielle Dienste zum Arbeiten mit dem Server und den Datenbanken, die sich auf dem Server befinden, vorhanden. Um das Arbeiten mit Datenbanken bei der Ausführung einiger Operationen zu erleichtern, stehen im SQL Manager 2007 for MySQL eine Vielzahl von Werkzeugen zur Verfügung.

Dienste des MySQL-Servers

Sicherung von Tabellen

Wiederherstellen von Tabellen

Analysieren von Tabellen

Prüfen von Tabellen

Reparieren von Tabellen

Optimieren von Tabellen

Leeren von Tabellen

Servereigenschaften

Betrachten von Ergebnissen

Serveranpingen

Leeren von Cashe


Sichern von Tabellen

Der Assistent zum Sichern von Tabellen ermöglicht alle DB-Tabellen in einem angegebenen Verzeichnis zu speichern.

Dieser Assistent kopiert ins Sicherungsverzeichnis minimale zur Wiederherstellung genügende Anzahl von Tabellendateien nach allen vorgenommenen Änderungen. Zurzeit funktioniert dies ausschließlich für MyISAM-Tabellen. Der Assistent kopiert die Dateien .frm (von Attributen) und .MYD (von Daten). Die bestehenden Kopien von Tabellen werden nicht erneut umgeschrieben: Beim Versuch der Wiederherstellung über einer bestehenden Tabelle wird ein Fehler auftreten.

Beim Erstellen einer Sicherungskopie wird das Lesen jeweiliger Tabelle während des Kopierprozesses blockiert.

Anmerkung: Sie sind in der Lage, eine Datenbank ausschließlich auf einem lokalen Rechner zu speichern. Um eine Sicherungskopie der Tabellen auf dem entfernten Server zu erstellen, wird das Werkzeug Assistent zum Extrahieren von Datenbanken verwendet. Danach werden Objekte wiederhergestellt, indem man den SQL Skript Editor benutzt.

Um den Assistenten zum Sichern von Tabellen zu öffnen, muss man den Punkt Services | Backup Tables

(zu dt.: Dienste | Tabellen speichern) im Hauptmenü des Programms auswählen.

Auswählen von Datenbank

Auswählen von Tabellen

Betrachten von Ergebnissen

Siehe auch:

Assistent zum Extrahieren von Datenbanken

Wiederherstellen von Tabellen

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Datenbank

Die Datenbank wird aus der Dropdownliste Database, in der alle registrierten und angeschlossenen Datenbanken enthalten sind, ausgewählt.

Im Feld Backup directory wird mit Hilfe der Schaltfläche [image] den Pfad zum Ordner, in dem eine Sicherungskopie erstellt wird, angegeben. Hinweis: Man kann eine Datenbank ausschließlich auf einem lokalen Rechner speichern. Um eine Sicherungskopie der Tabellen auf dem entfernten Server zu erstellen, wird das Werkzeug Assistent zum Extrahieren von Datenbanken verwendet. Danach werden Objekte wiederhergestellt, indem man den SQL Skript Editor benutzt.

Nächster Schritt

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller DB-Tabellen die zu sichernden Tabellen auswählen.

Aus der Liste Available Tables werden die verfügbaren Tabellen ausgewählt und mit Hilfe der Schaltflächen in die Liste der ausgewählten Selected Tables verschoben. Wenn Sie für alle Tabellen eine Sicherungskopie erstellen wollen, muss der Punkt Backup All aktiviert werden.

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Wiederherstellen von Tabellen

Der Assistent zum Wiederherstellen von Tabellen wird zum Wiederherstellen einer Sicherungskopie, die mithilfe des

Assistenten zum Sichern von Tabellen erstellt wurde, verwendet. Die bestehenden Tabellen werden nicht umgeschrieben: Beim Versuch der Wiederherstellung über einer bestehenden Tabelle wird ein Fehler auftreten. Das Wiederherstellen von Tabellen dauert länger als die Erstellung einer Sicherungskopie, weil der Index erneut aufgebaut werden muss. Je mehr Schlüssel eine Tabelle enthält, desto länger dauert das Wiederherstellen von Tabellen. Das Sichern von Tabellen funktioniert zurzeit nur für MyISAM-Tabellen.

Um den Assistenten zum Wiederherstellen von Tabellen zu öffnen, muss man den Punkt Services | Restore Tables

(zu dt.: Dienste | Tabellen wiederherstellen) im Programm-Hauptmenü auswählen.

Auswählen von Verzeichnis

Auswählen von Datenbank

Auswählen von Tabellen

Betrachten von Ergebnissen

Siehe auch:

Sichern von Tabellen

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Verzeichnis

Im ersten Schritt wird eine Datenbank, die wiederhergestellt werden muss, ausgewählt.

Aus der Dropdownliste Source directory wählt man ein Verzeichnis, in dem sich die Sicherungskopien befinden.

Die Tabellen werden aus diesen Sicherungskopien wiederhergestellt.

Im Abschnitt Destination database wählt man eine Zieldatenbank.

  • Registered database profile - registrierte Datenbank.
  • Non-registered database - nicht registrierte Datenbank.

Wenn man angibt, dass die Datenbank bereits registriert wurde, muss diese im zweiten Schritt aus der verfügbaren Liste ausgewählt werden. Wenn die Datenbank nicht registriert ist, kann man im zweiten Schritt die Verbindungsparameter zu ihr angeben.

Nächster Schritt

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Auswählen von Datenbank

Aus der Dropdownliste Host wird der Server, auf dem sich eine Datenbank befindet, ausgewählt. Falls der Server nicht registriert ist, dann muss dieser registriert werden, indem man den Assistenten zur Hostregistrierung verwendet.

Die Datenbank wird aus der Dropdownliste Database, indem alle registrierten und angeschlossenen Datenbanken enthalten, ausgewählt.

Nächster Schritt

Um jedes Mal die Paramer nicht anzugeben, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller Tabellen, die sich in der Sicherungskopie befinden, die zu wiederherstellenden Tabellen auswählen.

Aus der Liste Available Tables wählt man verfügbare Tabellen. Mithilfe der Schaltflächen werden diese in die Liste der ausgewählten Tabellen - Selected Tables übertragen.

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Analysieren von Tabellen

Der Assistent zum Analysieren von Tabellen analysiert und speichert die Schlüsselzuweisung für Tabellen.

Beim Analysieren wird das Lesen der Tabellen blockiert. Diese Funktion ist für MyISAM- und BDB-Tabellen gültig.

Die gespeicherte Schlüsselzuweisung im MySQL wird beim Entscheidungstreffen verwendet, in welcher Reihenfolge die Tabellen verknüpft werden müssen, wenn man für die Verknüpfung keine Konstanten, sondern eine andere Datenbank benutzt.

Um den Assistenten zum Analysieren von Tabellen zu öffnen, muss man den Punkt Services | Analyze Tables

(zu dt.: Dienste | Tabellen analysieren) im Hauptmenü des Programms auswählen.

Auswählen von Verzeichnis

Auswählen von Tabellen

Betrachten von Ergebnissen

Siehe auch:

Prüfen von Tabellen

Reparieren von Tabellen

Optimieren von Tabellen

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Datenbank

Aus der Dropdownliste Host wird der Server, auf dem sich eine Datenbank befindet, ausgewählt. Wenn der Server nicht registriert ist, muss dieser registriert werden, indem man den Assistenten zur Hostregistrierung verwendet.

Die Datenbank wird aus der Dropdownliste Database, indem alle registrierten und angeschlossenen Datenbanken enthalten, ausgewählt.

Nächster Schritt

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller Tabellen die zu analysierenden Tabellen auswählen.

Aus der Liste Available Tables wählt man verfügbare Tabellen. Mithilfe der Schaltflächen werden diese in die Liste der ausgewählten Tabellen - Selected Tables übertragen.

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Prüfen von Tabellen

Der Assistent zum Prüfen von Tabellen überprüft fehlerhafte Tabellen. Für MyISAM-Tabellen wird die Schlüsselstatistik aktualisiert. Das Prüfen von Tabellen ist nur für MyISAM- und InnoDB-Tabellen möglich.

Das Prüfen kann auf verschiedene Weisen ausgeführt werden. Dies ermöglicht eine allseitige Überprüfung von Indizes und den Großteil der Fehler zu entdecken.

Um den Assistenten zum Analysieren von Tabellen zu öffnen, muss man den Punkt Services | Check Tables

(zu dt.: Dienste | Tabellen prüfen) im Hauptmenü des Programms auswählen.

Auswählen von Datenbank

Auswählen von Tabellen

Betrachten von Ergebnissen

Siehe auch:

Analysieren von Tabellen

Reparieren von Tabellen

Optimieren von Tabellen

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller DB-Tabellen die zu prüfenden Tabellen auswählen und den Prüfungstyp einstellen.

Unterschiedliche Prüfungstypen bedeuten Folgendes:

Quick - Zeilen müssen nicht auf unkorrekte Verbindungen überprüft werden.

Fast - Tabellen, die nicht korrekt geschlossen wurden, müssen überprüft werden.

Medium - Zeilen überprüfen, ob alle vernichteten Verbindungen in Ordnung sind. Dabei wird die endgültige Kontrollsumme für eine Zeile gezählt und mit berechneter Kontrollsumme für Schlüssel verglichen.

Changed - Tabellen, die seit der letzten Überprüfung abgeändert und nicht korrekt geschlossen wurden, müssen überprüft werden.

Extended - Vollständige Überprüfung eines Schlüssels für alle Schlüssel jeder Zeile muss ausgeführt werden. Obwohl diese Überprüfung relativ lange dauert, kann sie 100% garantieren, dass es in der Tabelle keine Widersprüche gibt.

Aus der Liste Available Tables wählt man verfügbare Tabellen. Mithilfe der Schaltflächen werden diese in die Liste der ausgewählten Tabellen - Selected Tables übertragen.

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Reparieren von Tabellen

Das Reparieren von Tabellen kann ausschließlich in MyISAM-Tabellen ausgeführt werden.

Üblicherweise muss dieser Befehl nicht aufgerufen werden. Nach schwierigen Abstürzen können aus MyISAM-Tabellen die Daten zurückgesetzt werden. Der Assistent zum Reparieren von Tabellen kann eine beschädigte Tabelle reparieren.

Um den Assistenten zum Analysieren von Tabellen zu öffnen, muss man den Punkt Services | Repair Tables

(zu dt.: Dienste | Tabellen reparieren) im Hauptmenü des Programms auswählen.

Auswählen von Datenbanken

Auswählen von Tabellen

Betrachten von Ergebnissen

Siehe auch:

Analysieren von Tabellen

Prüfen von Tabellen

Optimieren von Tabellen

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller DB-Tabellen die zu reparierenden Tabellen auswählen und einige Optionen einstellen.

  • Wenn Quick aktiviert ist, wird der SQL Manager 2007 for MySQL die Fehler in der Indexstruktur beheben
  • Wird Extended verwendet, wird der Index zeilenweise statt einzeln mithilfe der Sortierung erstellt. Dies funktioniert für Schlüssel mit fixierter Länge besser, sollte es sich um gut komprimierende Schlüssel, wie CHAR-Schlüssel mit großer Länge handeln. Dies ist dieselbe Reparatur, die mit Hilfe von myisamchk --safe-recover ausgeführt wird.
  • Modus Use .FRM wird verwendet, falls die Datei .MYI fehlt bzw. ihre Kopfzeile beschädigt wurde. In diesem Modus wird MySQL eine Tabelle wiederherstellen, indem die Infos aus der Datei .frm verwendet wird.

Aus der Liste Available Tables wählt man verfügbare Tabellen. Mithilfe der Schaltflächen werden diese in die Liste der ausgewählten Tabellen - Selected Tables übertragen.

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Optimieren von Tabellen

Der SQL Manager 2007 for MySQL ermöglicht, die Optimierung mithilfe eines speziellen Werkzeuges - des Assistenten zum Optimieren von Tabellen - auszuführen.

Die Optimierung von Tabellen muss in folgenden Fällen verwendet werden:

  • größter Teil der Tabelle wurde behoben,
  • viele Änderungen wurden in die Zelle der variablen Länge eingetragen (Tabellen mit VARCHAR-, BLOB- bzw. TEXT-Felder)
  • Indexseiten wurden nicht sortiert.

Die gelöschten Datensätze werden mithilfe der verknüpften Liste unterstützt. Die nachfolgenden Operationen INSERT verwenden wieder die Positionen der alten Datensätze.

Zurzeit können ausschließlich die MyISAM- und BDB-Tabellen optimiert werden.

Um den Assistenten zum Analysieren von Tabellen zu öffnen, muss man den Punkt Services | Optimize Tables

(zu dt.: Dienste | Tabellen optimirien) im Hauptmenü des Programms auswählen.

Auswählen von Datenbank

Auswählen von Tabellen

Betrachten von Ergebnissen

Siehe auch:

Analysieren von Tabellen

Prüfen von Tabellen

Reparieren von Tabellen

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller DB-Tabellen die zu optimierenden Tabellen auswählen.

Aus der Liste Available Tables wählt man verfügbare Tabellen. Mithilfe der Schaltflächen werden diese in die Liste der ausgewählten Tabellen - Selected Tables übertragen.

Um nicht jedes Mal die Parameter angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Leeren von Tabellen

Die Operation Truncate erlaubt, alle Daten aus der Tabelle zu löschen.

Um den Assistenten zum Analysieren von Tabellen zu öffnen, muss man den Punkt Services | Truncate Tables

(zu dt.: Dienste | Tabellen leeren) im Hauptmenü des Programms auswählen.

  • Diese Operation löscht und stellt die Tabelle wieder her, was schneller als aufeinander folgendes Löschen von Zeilen ist.
  • Es ist keine Transaktionsoperation, wenn gleichzeitig die Transaktion bzw. aktive Blockierung der Tabelle ausgeführt wird, dies kann zu einem Fehler führen.
  • Die Anzahl der gelöschten Zeilen wird nicht zurückgesetzt.
  • Solange eine korrekte Datei table_name.frm besteht, kann die Tabelle mit ihrer Hilfe, auch wenn die Daten- und Indexdateien beschädigt sind, wieder hergestellt werden.

Auswählen von Datenbank

Auswählen von Tabellen

Betrachten von Ergebnissen

Um nicht jedes Mal die Paramer angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Auswählen von Datenbank

Aus der Dropdownliste Host wird der Server, auf dem sich eine Datenbank befindet, ausgewählt. Wenn der Server nicht registriert ist, muss dieser registriert werden, indem man den Assistenten zur Hostregistrierung verwendet.

Die Datenbank wird aus der Dropdownliste Database, indem alle registrierten und angeschlossenen Datenbanken enthalten, ausgewählt.

Nächster Schritt

Um nicht jedes Mal die Paramer angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Auswählen von Tabellen

In diesem Schritt muss man aus der Liste aller DB-Tabellen die zu leerenden Tabellen auswählen.

Aus der Liste Available Tables wählt man verfügbare Tabellen. Mithilfe der Schaltflächen werden diese in die Liste der ausgewählten Tabellen - Selected Tables übertragen.

Um nicht jedes Mal die Paramer angeben zu müssen, wird das Werkzeug zum Erstellen von Vorlagen verwendet. Dieses Werkzeug wird beim Betätigen der Schaltfläche Templates geöffnet.


Servereigenschaften

Möchten Sie sich die Infos über den Zustand des aktiven Servers ansehen, muss das Fenster Server Properties/ (zu dt. Server-Eigenschaften) mithilfe des Punktes Services | Server Properties ( zu dt. Dienste | Server-Eigenschaften im Hauptmenü des Programms geöffnet werden. Nach dem Auswählen dieser Option erscheint das Standardfenster zum Eingeben der Serververbindungsoptionen.

Symbolleisten

Systemvariablen

Prozessliste

InnoDB-Status

Allgemeine Abfrage-Logdatei

Siehe auch:

Serveranpingen

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Symbolleisten

Navigationsleiste

Auf der Leiste Servers:

  • aus der Dropdownliste kann der Server ausgewählt werden. Ist die Verbindung zum Server nicht vorhanden, dann kann man dies aus dieser Dropddownliste auswählen. Danach wird der Name im erscheinenden Fenster eingegeben. Wenn der Host nicht registriert ist, kann der Assistent zur Hostregistrierung verwendet werden.

Auf der Leiste General:

  • Refresh - Aktualisieren,
  • Show SQL Help - MySQL-Hilfe anzeigen,
  • Restore default size - Standardgröße wiederherstellen,
  • Options - Optionen Umgebungsoptionen | Server-Eigenschaften,

Beim Übergang zu anderen Registerkarten erscheinen die Leisten zum Arbeiten mit Objekten, die sich auf diesen Registerkarten befinden.

Auf der Leiste Variables:

  • Edit variable (nur für Systemvariablen) - Variable bearbeiten,
  • Export variables - Variabelliste in Datei exportieren
  • Copy variables to Clipboard - Variablen in Zwischenablage kopieren

Auf der Leiste Process list:

  • Export process list - Prozessliste exportieren
  • Copy process list to Clipboard - Prozessliste in Zwischenablage kopieren

Werkzeugsleiste:

  • aus der Dropdownliste kann der Server ausgewählt werden. Ist die Verbindung zum Server nicht vorhanden, kann man dies aus der Dropddownliste auswählen. Danach wird der Name im erscheinenden Fenster eingegeben. Wenn der Host nicht registriert ist, kann der Assistent zur Hostregistrierung verwendet werden.
  • Refresh - Aktualisieren,
  • Export - Objektliste in Datei exportieren,
  • Edit (nur für Systemvariablen) - Variable bearbeiten,
  • Copy list to Clipboard - Objektliste in Zwischenablage kopieren
  • Options - Optionen Umgebungsoptionen | Server-Eigenschaften,
  • Show SQL Help - MySQL-Hilfe anzeigen,
  • Restore default size - Standardgröße wiederherstellen.


Systemvariablen

Unter der Registerkarten Status variables und System variables werden alle Statusvariablen und Systemvariablen angezeigt.

Die Variabelliste kann in Zwischenablage mithilfe des Befehls Copy variables to Clipboard/Variablen in Zwischenablage kopieren kopiert und mittels des Befehls Export variables/Variablen exportieren in eine Datei des gewünschten Formates exportiert werden. Beide Befehle befinden sich auf Symbolleisten.

Die Statusvariablen können manuell nicht verändert werden.

Die Systemvariablen können entweder mithilfe des Punktes aus dem Kontextmenü Edit variable, oder beim Doppelmausklick auf der Zeile verändert werden.

Im erscheinenden Fenster werden folgende Variabeleinstellungen angegeben:

  • neuer Variabelwert - im Textfeld,
  • wenn Global angehakt ist, wird die Variabel als global gelten,
  • ob die Variabel während einer Sitzung gültig werden muss - Session.


Prozessliste

Unter der Registerkarte Process List wird die Liste der Prozesse, die im Moment auf dem Server ausgeführt werden und die zusätzlichen Infos bezüglich jedes Prozesses angezeigt.

Zusätzliche Infos:

Id - Identifizierung des Prozesses,

User - Anwender,

Host - Host,

DB - Datenbank, in der das Prozess läuft,

Command - Befehl,

Time - Zeit,

State - Status,

Info - zusätzliche Information bezüglich des Prozesses.

Mithilfe des Kontextmenüs, das beim Betätigen der rechten Maustaste auf dem Prozess geöffnet wird, kann man:

  • Kill Process - Prozess beenden,
  • Refresh - Aktualisieren,
  • Export List - Prozessliste in Datei exportieren,
  • Copy List to Clipboard - Liste in Zwischenablage kopieren.


InnoDB-Status

Unter dieser Registerkarte kann der Statusverlauf von InnoDB-Objekten angesehen werden.


Allgemeine Abfrage-Logdatei

Die Infos sind unter der Registerkarte verfügbar, wenn die Eigenschaften des MySQL-Servers der Version 5.1.6. oder höher angesehen werden.

Unter dieser Registerkarte wird die Liste von den auf dem Server ausgeführten Vorgängen und auch die zusätzlichen Infos über diese Vorgänge angezeigt.

Siehe auch:

Protokolloptionen


Betrachten von Ergebnissen

Nachdem alle gewünschten Optionen in den vorherigen Schritten gesetzt wurden, muss der Button Finish/Fertig zum Starten der Operation angeklickt werden. In der Statuszeile, die sich im oberen Teil befindet, wird in Prozenten der Verlauf der Operationsausführung angezeigt.

Unten befinden sich zwei Registerkarten, auf denen genaue Informationen über den Verlauf und Ergebnisse dargestellt sind.

Registerkarte Operations.

Unter der Registerkarte Operation sind alle ausgeführten Aktionen und deren Ausführungsergebnisse angezeigt.

Registerkarte Results.

Unter dieser Registerkarte werden Infos über Ausführungsergebnisse angezeigt:

  • Objektname,
  • Operation, die mit ihm ausgeführt wurde,
  • Meldung über Ausführungsergebnisse

Wenn der Punkt Close the Wizard after successful completion/Assistenten nach der erfolgreichen Ausführung schließen aktiviert ist, wird der Assistent nach der erfolgreichen Ausführung automatisch geschlossen werden. Wenn das Häkchen deaktiviert wurde, kann man zurückgehen und andere Parameter eingeben.


Serveranpingen

Mithilfe des SQL Manager 2007 for MySQL kann man prüfen, ob im Moment die Verbindung mit dem Server besteht. Hierfür muss der Befehl Ping Server aus dem Programm-Hauptmenü Services | Ping Server (zu dt.: Dienste | Server anpingen) verwendet werden.

Wenn die Verbindung mit dem Server besteht, erscheint folgende Meldung.

Wenn die Verbindung beim Anpingen unterbrochen wurde, erscheint folgende Meldung.

Die Meldung MySQL server has gone away erscheint, wenn keine Verbinung mit dem Server besteht.

Um die Verbindung mit dem Server zu beenden, muss im Programm-Hauptmenü der Punkt Services | Shutdown Server (zu dt. Dienste |Server herunterfahren) ausgewählt und danach im erscheinenden Fenster der Button Yes/Ja angeklickt werden.

Siehe auch:

Servereigenschaften

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Leeren von Cashe

Der Punkt des Hauptmenüs Services | Flush (zu dt.: Dienste | Flush) wird zum Leeren von Cashe verwendet.

Zum Starten dieses Befehls muss man RELOAD-Rechte besitzen.

  • Hosts - dabei wird das Leeren von Cashe des entfernten Rechners ausgeführt. Das Leeren von Tabellen eines entfernten Rechners muss dann ausgeführt werden, wenn einer der entfernten Rechner die IP-Adresse verändert hat oder die Fehlermeldung Host ... is blocked erhalten wurde.

  • Logs - dabei werden alle Logdateien geschlossen und erneut geöffnet. Wenn die Update-Logdatei bzw. die Binärlogdatei ohne die Erweiterung angegeben wurde, dann wird die Nummer der Logdateierweiterung um Eins vergrößert werden. Wurde im Dateinamen die Erweiterung angegeben, wird MySQL die Update-Logdatei schließen und erneut öffnen.

  • Privileges - dabei wird das Neustarten von Rechten aus Tabellen in der Datenbank mysql ausgeführt.

  • Tables - alle geöffneten Tabellen werden geschlossen und alle verwendeten Tabellen werden zwangsläufig beendet. Die Zwischenablage von Abfragen wird geleert.

  • Tables With Read Lock - alle geöffneten Tabellen werden geschlossen und der Zugriff auf das Lesen aller Tabellen von gesamten Datenbanken blockiert, solange der Befehl UNLOCK TABLES nicht gestartet wird. Das ist eine gute Methode zum Erstellen von Sicherungskopien, wenn man ein Dateisystem ähnlich wie Veritas hat, das momentane Datenaufnahmen im Live-Modus ermöglicht.

  • Status - Großteil von Statusvariablen werden auf Null zurückgestellt. Dieser Befehl muss man beim Debuggen von Abfragen verwenden.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Optionen des MySQL-Managers

Der SQL Manager 2007 for MySQL verfügt über einen Toolsatz, mit dessen Hilfe Umgebungs-, Editorparameter-, Darstellungseinstellungen geändert werden können.

Umgebungsoptionen

Das ist das Hauptwerkzeug zum Verwalten der Eigenschaften und der Darstellungsart von DB-Objekten.

Editoroptionen

Die Editorparameter werden mithilfe dieses Werkzeuges eingegeben.

Ansichtsoptionen

Dieses Werkzeug ermöglicht die Darstellungsart von Programm-Verwaltungselementen einzugeben.

Tastaturvorlagen

Mithilfe dieses Werkzeuges können die Vorlagen zur schnellen Texteingabe erstellt werden.

Assistent zum Speichern von Optionen

Der Assistent zum Speichern von Optionen ermöglicht, die DB-Einstellungen in einer Datei zu speichern.


Umgebungsoptionen

Mit Hilfe dieses Werkzeuges können die Haupteinstellungen des Programms SQL Manager 2007 for MySQL geändert werden.

Um die Einstellungen der Umgebungsoptionen zu öffnen, muss man im Programm-Hauptmenü den Punkt

Options | Environment Options (zu dt.: Optionen | Umgebungsoptionen) auswählen.

Präferenzen

Aktivierung des Vollversionmodus

Bestätigungen

Окна

Fenster:

  • DB-Expolorer
  • Namensregel
  • Tabelleneditor
  • SQL-Editor
  • SQL- Monitor
  • SQL-Skript
  • Abfrage-Generator
  • Format- und Farbpalette
  • Grafischer Datenbank-Designer
  • Farbpalette
  • Drucken von Metadaten
  • Datenexport
  • Servereigenschaften

Schriften

Rasterparameter:

  • Datenoptionen
  • Drucken von Daten
  • Format- und Farbpalette
  • Erweiterte Optionen
  • Spaltenoptionen

Lokalisierung

Finden von Optionen

Die für alle Registerkarten allgemein gültige Schaltfläche By default ermöglicht, alle vom Anwender eingetragenen Änderungen zurückzustellen und standardmäßige Einstellungen zurückzusetzen.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Präferenzen

Unter der Registerkarte Preferences kann man folgende Eigenschaften des Programms eingeben:

  • Show splash screen on startup - Begrüßungsbild beim Start zeigen
  • Restore desktop on connect - Beim Verbinden Desktop wiederherstellen
  • Disable multiple instances - Multiple Instanzen deaktivieren
  • Encrypted passwords - Verschlüsselte Passwörter
  • Show desktop panel - Desktop-Panel anzeigen (nur für MDI Umgebung, die beim ersten Starten des Programms eingestellt wird)

Beim Betätigen der Schaltfläche Reset all toolbars and menus werden alle Symbolleisten und Menüs zurückgesetzt.


Aktivierung des Vollversionmoduses

Wenn eine Lite-Version des Programms installiert ist, kann man in diesem Schritt den Punkt Show Full Version Features aktivieren und betrachten, welche Features eine Vollversion beinhalten. Alle Features der Vollversion können 30 Tage eingesetzt werden.

Die Vergleichscharakteristik der Lite- und Full-Version kann in der Funktionsmatrix angesehen werden.


Bestätigungen

Unter der Registerkarte Confirmations können folgende Eigenschaften des Programms eingestellt werden:

  • Confirm saving of object - Speichern von Objekten (bzw. Dokumentation) beim Schließen oder nach Änderungen bestätigen
  • Confirm dropping object - Löschen von Objekten bestätigen
  • Confirm exit from SQL Manager - Ausgang vom SQL Manager bestätigen (falls Objekte verändert wurden),
  • Confirm transaction commit - Transaktion Commit ausführen bestätigen (für Datenansicht muss der Commit für Transaktion bei der Datenänderung ausgeführt werden),
  • Confirm transaction rollback - Transaktion-Rollback bestätigen,
  • Confirm deleting records - Löschen von Datensätzen bestätigen,
  • Confirm reorder fields - Neue Reihenfolge der Felder bestätigen,
  • Confirm compiling procedures - Kompilieren von Prozeduren bestätigen.


Fenster

Unter dieser Registerkarte kann man die Parameter, die Anzahl der angezeigten Fenster und auch die allgemeine Umgebung des Programms einstellen.

Im Abschnitt Environment style wird der Umgebungs-Stil angegeben:

  • MDI environment - MDI Umgebung (wie MS Office).
  • Floating windows environment - Umgebung mit unverankerten Fenstern (wie Borland).

Wenn der Punkt Number of open editors is restricted aktiviert ist, kann die Anzahl der geöffneten Editoren begrenzt werden.

Im Abschnitt Zoom option kann man Zoom-Optionen für unverankerte Fenster setzen:

  • Full screen - Voller Screen,
  • Restricted by Main form - Registriert durch Main-Form,
  • Restricted by Main form and DB Explorer - Registriert durch Main-Form und DB-Explorer,
  • Justified by Main form and DB Explorer - Durch Main-Form und DB-Explorer ausrichten.

Im Abschnitt Bar style for child forms kann der Leistenstil für untergeordnete Fenster, die in Editoren anzuzeigen sind, angegeben werden:

  • Navigation bar - Navigationsleiste (links vom Hauptfenster des Editors),
  • Toolbar - Symbolleiste (über dem Hauptfenster des Editors),
  • Both - Beide.

Wenn der Punkt Enable floating toolbars aktiviert ist, werden alle unverankerten Symbolleisten aktiviert, d.h. die Lage jeder Symbolleiste kann nach Wunsch geändert werden.


Tools

Unter dieser Registerkarte kann man folgende Eigenschaften der Programmumgebung eingeben:

  • Show only connected databases in drop-down menu - nur die angeschlossenen Datenbanken in der Dropdownliste anzeigen.
  • Allow using parameters in query text - Verwendung von Parametern in Abfragetexten erlauben.
  • Asynchronous query execution - Asynchrone Abfrageausführung. Die Abrage wird separat ausgeführt, alle Steuerelemente bleiben aktiv. Die Abfrageausführung kann unterbrochen werden.


DB-Expolorer

Der DB-Explorer kann mithilfe der Werkzeuge auf der Registerkarte DB Explorer eingestellt werden.

Show hosts in DB Explorer - Hosts in DB-Explorer anzeigen. Wenn dieser Punkt aktiviert ist, werden die Datenbanken nach Gruppen gemäß dem Server eingeteilt.

Show Table Subobjects - Unterobjekte der Tabelle anzeigen.

Sort by aliases - Host und Datenbanken im DB-Explorer nach Aliasen sortieren

Rename objects by editing in place - Objekte durch Editieren im DB-Explorer beim klicken der Maustaste auf das ausgewählte Objekt umbenennen.

Refresh object on showing in SQL Assistant - Objekt beim Anzeigen im SQL-Assistenten aktualisieren.

Recent objects count - Anzahl der letzten Objekte

Im Abschnitt Tables' Details in SQL Assistant wählt man, welche Unterobjekte der Tabelle im Fenster des SQL-Assistenten angezeigt werden müssen.

Fields - Felder,

Indices - Indizes,

Foreign keys - Fremdschlüssel,

Triggers - Triggers,

Table status - Tabellenstatus,

Description - Beschreibung,

Definition - Definition,


Namensregeln

Unter dieser Registerkarte kann man Namensregeln, die automatisch den erstellten Unterobjekten der Tabelle zugewiesen werden, einstellen.

Die Registerkarte Foreign keys ist für die Namen, die bei der Erstellung der Fremdschlüssel zugewiesen werden, zuständig.

Im Feld Foreign key naming template wird die Vorlage des Fremdschlüsselnamen eingegeben.

Mithilfe der Dropdownliste, die beim Betätigen der Schaltfläche Insert Tag geöffnet wird, kann man den Tag in den Namen einfügen. Somit kann der folgende Text in dem zu erstellenden Namen automatisch eingefügt werden.

  • Tabellenname - {table_name},
  • Reihenzahl für Kopien - {num_for_dup},
  • Name der gelöschten Tabelle - {ref_table_name},

Unter der Registerkarte Triggers werden die Vorlagen der Triggernamen angegeben.

Im Feld Trigger naming template wird die Vorlage des Triggernamen angegeben.

Man kann folgende Tags für Trigger angeben:

  • Tabellenname - {table_name},
  • Reihenzahl für Kopien - {num_for_dup},
  • Triggertyp - {trig_type},
  • Triggerereignis - {trig_events}

Man kann ebenso Präfixe für verschiede Triggertypen angeben:

  • After - Danach,
  • Instead of - Anstelle von,
  • Insert - Einfügen,
  • Update - Aktualisieren,
  • Delete - Löschen.

Zum Beispiel:

Für einen neu erstellten Fremdschlüssel kann Folgendes eingegeben werden:

  • Präfix "fk_"
  • Identifizierung der ersten Tabelle "T1"
  • Tag - Tabellenname - {table_name}
  • Identifizierung der verknüpften Tabelle "T2"
  • Tag - Name der verknüpften Tabelle - {ref_table_name}

Die Namenvorlage sieht in diesem Fall so aus: "fk_T1{table_name}_T2{num_for_dup}"

Der Fremdschlüsselname, der nach dieser Vorlage erstellt wurde, sieht so aus:

"fk_T1Lotti_MateriePrime_T2Commesse_Lotti", wo Lotti_MateriePrime und Commesse_Lotti Tabellennamen sind.


Tabelleneditor

Unter der Registerkarte Table Editor werden die Parameter für den Tabelleneditor angegeben.

  • Always open the Fields tab - immer den Tabelleneditor auf der Registerkarte "Felder" öffnen,
  • Show Object Explorer - Objekt-Explorer anzeigen,
  • Show table status panel - Statusleiste der Tabelle anzeigen,
  • Do not retrieve record count for a table - Die Anzahl der Datensätze für eine Tabelle nicht abrufen. Die Anzahl der Datensätze wird in diesem Fall auf der unteren Infoleiste angezeigt.
  • Allow to edit tables with no keys - ermöglicht, die Tabellen ohne Schlüssel zu bearbeiten. (Beachten Sie bitte, dass das Bearbeiten von Tabellen ohne den Unique- bzw. Primärschlüssel zur Datenbeschädigung führen kann).

Im Abschnitt Default storage engine for new tables wird eines der Speichermodule angegeben, das standardmäßig zu neuen Tabellen verwendet wird:

  • Use default engine defined on this server - Standardmodul, das auf diesem Server eingesetzt wird, verwenden.
  • Use the following engine for all databases - Folgendes Modul für alle Datenbanken verwenden. In diesem Fall muss aus der Dropdownliste Default storage engine eines der verfügbaren Speichermodule ausgewählt werden.


SQL-Editor

Unter der Registerkarte SQL Editor werden die Umgebungsparameter von SQL-Editoren angegeben.

Wenn der Punkt Fetch all data aktiviert ist, werden Ergebnisse der SQL-Abfrage vollständig geladen

(dies funktioniert, wenn keine maximale Anzahl der geladenen Datensätze mithilfe des Punktes Kontextmenü der Datenansicht Grid mode/Rastermodus angegeben wurde).

Explain query - Abfrageplan im SQL-Editor anzeigen.

Show result for each query - Wenn dieser Punkt aktiviert ist, werden die Ergebnisse bei der Ausführung zwei oder mehrerer Abfragen für jede Abfrage angezeigt. Wenn dieser Punkt deaktiviert ist, werden die Ergebnisse für die zuletzt ausgeführte Abfrage angezeigt.

Execute selected text separately - Ausgewählter Text separat ausführen.

Write only successful executed queries to database SQL log file - Nur erfolgreich ausgeführte Abfragen in SQL-Logdatei der Datenbank eintragen

Show results on Edit tab - Ergebnisse auf der Registerkarte Edit/Bearbeiten anzeigen. Im Gegenfall werden Ergebnisse auf der separaten Registerkarte dargestellt.

Don't save queries automatically for the next session - Abfragen automatisch für die nächste Sitzung nicht speichern.

Always save changes in Favorite Queries before closing - Änderungen in favorisierten Abfragen vor dem Schließen speichern.

Disable transaction confirmation - Transaktionsbestätigung deaktivieren. Bei Aktivierung dieses Punktes werden die Transaktionen beim Beenden des SQL-Editors und visuellen Abfrage-Generators automatisch geschlossen.

Standardaktion beim Beenden des Editors wird in der Liste ausgewählt: Default action on closing the editor:

  • Commit - Commit ausführen,
  • Rollback - Rollback ausführen.


SQL- Monitor

Unter der Registerkarte SQL Monitor können einige Parameter des SQL-Monitors eingestellt werden.

Im Abschnitt Operations müssen die im SQL-Monitor anzuzeigenden Operationen angehakt werden:

  • Connect - Verbinden,
  • Disconnect - Trennen,
  • Start of transaction - Transaktionsbeginn,
  • Commit - Commit ausführen,
  • Rollback - Rollback ausführen,
  • Show objects - Anzeigen von Objekten,
  • Execute query - Abfrageausführung.

Wenn der Punkt Log SQL Monitor events to file aktiviert ist, werden alle am SQL-Monitor angezeigten Infos über die Abfrageausführung in einer Datei gespeichert. Im Feld wird der Dateiname und der Pfad zu dieser Datei mithilfe der Schaltfläche [image] angegeben. Man kann eine maximale Größe der Protokollierung einstellen, indem der Punkt Clear log file when it is greater than (Protokolldatei leeren, wenn sie größer ist als (KB)) aktiviert wird und mithilfe des Optionsfeldes eine maximale Größe in KB eingeben.

Wenn man sich nicht nur eine Operation, sondern auch Zeit der Ausführungsoperation anschauen möchte, muss der Punkt Show time of operation aktiviert werden.

Die Aktivierung des Häkchens Show always on top lässt zu, den SQL-Monitor oberhalb anderer Fenster anzuzeigen.


SQL-Skript

Unter der Registerkarte SQL-Skript können einige Ausführungsparameter des SQL-Skriptes eingegeben werden.

Abort script on error - Skript beim Fehler abbrechen.

Rollback on abort - Rollback beim Abbruch ausführen. Wenn diese Option aktiviert ist, wird das ganze Skript in Transaktion, die beim Abbrechen rückgängig gemacht wird, ausgeführt.

Enable parsing - Parsing aktivieren.

Show message when done - Meldung nach dem Beenden der Ausführung anzeigen.

Execute selected text separately - Ausgewählten Text separat auswählen.

Show information messages in error list - in der Fehlerliste die Informationsmeldungen anzeigen.


Abfrage-Generator

Unter der Registerkarte Query Builder kann man einige Eigenschaften des visuellen Abfrage-Generators angeben.

Allow SELECT queries only - Nur SELECT Abfragen zulassen

Select condition row - Bedingungszeile auswählen

Drag field name - Feldnamen ziehen

Hide selection when inactive - Auswahl ausblenden, wenn inaktiv

Show field types - Feldtypen anzeigen

Union all by default - UNION als Standardeinstellung

Im Abschnitt Visible Tabs werden die Registerkarten ausgewählt, die sichtbar werden müssen:

Criteria - Kriterien,

Selection - Auswahl,

Group criteria - Gruppenkriterien,

Sorting - Sortierung,

Im Abschnitt Script Format kann man einige Besonderheiten des Skriptformates einstellen:

Aus der Dropdownliste Keywords format muss man das Format der Schlüsselwörter auswählen.

Das Funktionsformat wird aus der Dropdownliste Function format ausgewählt.

Für Schlüsselwörter und Funktionen sind folgende vier Schreibungsarten verfügbar:

  • As is - Ist al,
  • Uppercase - Großbuchstaben,
  • Lowercase - Kleinbuchstaben,
  • First upper - Erster Großbuchstabe.


Format- und Farbpalette

Unter dieser Registerkarte kann man Formate und Farben des visuellen Abfrage-Generators angeben.

Im Abschnitt Style kann man Formate der Steuerelemente einstellen:

Aus den Dropdownlisten Condition button style und Object border kind wählt man das Format der Bedingungsschaltflächen und die Objekt-Rahmenart aus.

Flat object's buttons - Flache Objekt-Schaltflächen.

Flat objects - Flache Objekte.

XP tables style - XP-Tabellenformat.

Show icons on tabs - Symbole auf Registerkarten anzeigen.

Im Abschnitt Color palette kann man die Farben von Objekten und Steuerelementen des visuellen Abfrage-Generators

abändern. Die Farbpalette zum Auswählen der Farbe wird beim Drücken auf ein farbiges Quadrat ausgewählt.

Die Elemente, für die die Farbe ausgewählt werden kann:

  • Active condition row - aktive Bedingungszeile im Fenster zum Bestimmen von Kriterien

  • Condition text - Bedingungstext

  • Condition item text - Element des Bedingungstextes

  • Table client area - Tabellen-Clientbereich

  • Active table caption - Kopfzeile der aktiven Tabelle

  • Field text - Feldtext
  • Selected field text - Text des ausgewählten Feldes
  • Work space - Hauptfarbe des Diagrammfensters
  • Field - Feld im Fenster zum Bestimmen von Kriterien

  • Operation - Zeichen von Operation im Fenster zum Bestimmen von Kriterien

  • Group - Gruppierungszeichen im Fenster zum Bestimmen von Kriterien, auf der Registerkarte Kriterien der Gruppierung.

  • Predicate - Prädikat, falls Unterabfrage erstellt wurde.

  • Subquery - Unterabfrage


Grafischer Datenbank-Designer

Unter dieser Registerkarte werden Parameter für Datenansicht angegeben.

Tools des Abschnittes Visual settings/Visuelle Einstellungen:

  • aus der Dropdownliste Model notation wird die Modelldarstellung der Infos im Diagramm ausgewählt - IDEF1x bzw.IE,
  • wenn der Punkt Draw PRIMARY KEY fields separately aktiviert ist, werden die "Primärschlüssel"-Felder separat gezeichnet

  • wenn der Punkt Draw entities icons aktiviert ist, werden Entitäten-Symbole gezeichnet,
  • wenn der Punkt Draw attributes icon aktiviert ist, werden Attribute-Symbole gezeichnet,
  • Draw only names of entities - Nur die Namen der Entitäten anzeigen.

  • Draw FOREIGN KEY name - Name der Fremdschlüssel anzeigen.

Im Abschnitt Grid options/Rasteroptionen werden Parameter der Datenansicht angegeben:

  • wenn der Punkt Show grid aktiviert ist, wird der Raster des Fensterdiagramms angezeigt
  • durch die Aktivierung des Häkchens Snap to grid werden Objekte auf dem Diagramm am Raster ausgerichtet
  • Parameter des Diagrammrasters werden mit Hilfe des Optionsfeldes Grid size/Rastergröße angegeben. Breite - X, Höhe - Y.

Im Abschnitt Entity header font werden die Schriftparameter der Tabellenkopfzeilen angegeben:

  • Name - Name,
  • Size - Größe.
  • Im Abschnitt Attributes font werden die Schriftparameter der Tabellenfelder angegeben:
  • Name - Name,
  • Size - Größe.

Die Objektfarben des Diagramms werden im Abschnitt Farbpalette eingestellt.


Farbpalette

In diesem Abschnitt werden die Farben für unterschiedliche Diagrammelemente eingestellt. Die Farbpalette zum Auswählen der Farbe kann man aufrufen, indem man das schwarze Quadrat neben dem Steuerelement anklickt.

  • Work area - Arbeitsbereich,

  • Work area text - Text des Arbeitsbereiches,

  • Entity - Entität,

  • Entity caption text - Text der Entity-Beschriftung,

  • Attribute text - Schrift der Tabellenfelder,

  • Selection - Auswahl,

  • Selected entity caption text - Text der ausgewählten Entity-Beschriftung

  • Selected attribute text - Ausgewählter Attributstext


Drucken von Metadaten

Unter dieser Registerkarte kann man eine standardmäßige Papiergröße bei der Erstellung von Berichten im Tool Drucken von Metadaten angeben.


Datenexport

In diesem Formular wird angegeben, in welchem Format die unterschiedlichen Datentypen standardmäßig angezeigt werden.

Die Anzeigeformate können für folgende Datenformate angezeigt werden:

  • Integer format - Ganzzahlformat,
  • Float format - Fließkommaformat,
  • Date format - Datumsformat,
  • Time format - Zeitformat,
  • DateTime format - Datum-Zeit-Format ,
  • Currency format - Währungsformat,
  • Boolean True - Boolescher True-Wert,
  • Boolean False - Boolescher False-Wert,
  • Null string - NULL-Zeichenfolge.

Wenn man Auto save format string aktiviert, werden alle eingetragen Änderungen gespeichert.

Man kann auch einen Standard-Wert einstellen, indem man den Button Set defaults anklickt.

Diese Formate können auch im dritten Schritt des Assistenten zum Exportieren von Daten eingestellt werden.

Mehr über Datenformate kann man im Abschnitt Eingabe von Datenformaten lesen.


Servereigenschaften

Unter dieser Registerkarte können zusätzliche Serverparameter angegeben werden.

Process list refresh interval (sec.) - Aktualisierungsintervall der Prozessliste (sec.)

Logs refresh interval (sec.) - Aktualisierungsintervall der Protokollierung (sec.)

List log items in descending date order - Protokollelemente in einer absteigenden Datenreihenfolge auflisten

Im Abschnitt Limit options in General Query Log werden folgende Einschränkungen für Abfrageprotokollierung angegeben:

  • Select all records from a log - alle Datensätze aus einer Datei auswählen
  • Select only Records - nur Datensätze auswählen


Schriften

Unter der Registerkarte Fonts kann man den Schrifttyp und die Schriftgröße für das ganze Programm des SQL Manager 2007 for MySQL einstellen.

Im Feld System font name wird die Schrift eingegeben, die in allen Verwaltungselementen des Programms SQL Manager 2007 for MySQL eingesetzt wird.

Im Feld System font size wird die Schriftgröße angegeben.

Im unteren Fenster wird ein Textmuster mit eingetragenen Änderungen angezeigt.


Grid

Unter dieser Registerkarte können Anzeigeparameter der Datenansicht eingestellt werden.

Im Abschnitt General options werden allgemeine Optionen angegeben:

  • Stripped grids - gestreifte Raster
  • Show editor immediately - Editor sofort anzeigen
  • Always show editor - Editor immer anzeigen
  • Enable auto-search in grid - automatische Suche im Raster aktivieren
  • Row multi-selection - Multi-Zeilen-Auswahl

  • Column auto-width - Auto-Breite des Spalte,
  • Cell auto-height - Auto-Hölle der Zelle,
  • Use compact view for TEXT fields - kompakte Ansicht der TEXT-Felder verwenden.

Im Abschnitt Grid layout preference wird Voreinstellung der Rasteranordnung eingegeben:

  • Autofit column widths - Spaltenbreite automatisch anpassen
  • Save and restore layout - Layout speichern und wiederherstellen
  • Restore sorting (except SQL sort) - Sortierung der Spalten wiederherstellen

Im Abschnitt Root level options werden Optionen der Stammebene angezeigt:

  • Show "Group by" box - nach Datengruppierung anzeigen,
  • Show indicator - Indikator anzeigen (Leiste links von der Tabelle)
  • Show navigator - Navigator anzeigen
  • Show "New item row" - "Neue Artikelreihe" anzeigen

Im Abschnitt Detail level options werden Parameter für Optionen der Detailebene angezeigt.

  • Show "Group by" box - nach Datengruppierung anzeigen,
  • Show indicator - Indikator anzeigen (Leiste linnks von der Tabelle)

  • Show navigator - Indikator anzeigen

  • Show "New item row" - "Neue Artikelreihe" anzeigen
  • Hide tabs for single detail - Registerkarten für Einzeldetails deaktivieren


Datenoptionen

Die Parameter der Datenanzeige sind auf der Registerkarte Data options anzugeben.

  • Select all records from a table - Alle Datensätze von einer Tabelle auswählen
  • Select only N rows - Nur N Zeilen auswählen

Im Abschnitt Advanced werden erweiterte Optionen angegeben.

  • Use shared connection for each data view within database - Freigegebene Verbindung für jede Datenansicht innerhalb einer Datenbank verwenden
  • Perform data sorting on client in Data View - Sortieren von Daten auf Client in Datensicht ausführen; die Daten werden mittels des SQL Manager 2007 for MySQL sortiert. Falls diese Option nicht aktiviert ist, werden Daten auf dem MySQL Server mittels ORDER BY in der SQL-Abfrage sortiert.
  • Perform data filtration on client in Data View - Filtern von Daten auf Client in Datensicht ausführen; das Filtern wird mit Hilfe des SQL Manager 2007 for MySQL ausgeführt. Falls diese Option nicht aktiviert ist, wird der SQL-Filter beim Betrachten von Tabellen- und Viewdaten verwendet.

Load visible rows mode if records more than - sichtbarer Zeilen-Modus bei mehr als "" Datensätzen laden

Im Feld String fields width (chars) wird eine bestimmte Breite der String-Felder (Zeichen) eingestellt.

Default Grid Mode/Standard-Rastermodus

  • Load all rows - Alle Zeilen laden
  • Load visible rows - Alle sichtbare Zeilen laden

Hinweis:

Änderungen in den Optionen gekennzeichnet mit * Zeichen, beeinflussen nicht die Datenansicht in den aktuell geöffneten Fenstern. Diese Optionen werden als Standardwerte für Datenoptionen bei einer neu registrierten Datenbank verwendet. Zum Ändern der Optionen für registrierte Datenbanken wird der Dialog Datenbank Registrierungsinfo aufgerufen.


Drucken von Daten

Unter dieser Registerkarte werden Druckeinstellungen angegeben, die beim nächsten Öffnen des Dialogs gespeichert und übernommen werden:

  • Card view representation - Darstellung der Kartenansicht
  • Detail view representation - Darstellung der Detailansicht
  • Expanding - Erweitern
  • Formatting - Formatierung
  • Level options - Ebenoptionen
  • "on every page" options - «Auf jeder Seite» Optionen
  • Pagination - Seitennummerierung
  • Preview options - Vorschauoptionen
  • Image options (refinements) - Bildoptionen (Verfeinerung)
  • Selection options - Auswahloptionen
  • Report size options - Optionen der Berichtgröße
  • Showing grid elements - Anzeige der Rasterelemente
  • Page number format - Format der Seitennummer
  • Page settings - Seiteneinstellung
  • Report title - Berichtstitel


Format- und Farbpalette

Im Abschnitt Display formats wird ein Anzeigeformat für nachfolgende Datentypen ausgewählt:

Integer fields - Ganzzahlfelder,

Float fields - Flußkommafelder,

Datetime fields - Datum-Zeit-Felder,

Date fields - Datumsfelder,

Time fields - Zeitfelder.

Im Abschnitt Colors werden Farben für nachfolgende Objekte angegeben:

  • Grid - Raster,
  • Row - Zeile,
  • Stripy - Stripy.

Man kann für NULL-Werte eigene Farben im Abschnitt Null Values eingeben.

  • Text - Text,
  • Font Color - Schriftfarbe.


Erweiterte Optionen

Unter der Registerkarte Advanced werden folgende Parameter für Datenansicht eingegeben.

  • Invert selection - Auswahl invertieren,
  • Cell hints for clipped text - Zell-Hinweise für ausgeschnittenen Text,
  • Focus cell on cycle - Zellen am Zyklus fokussieren,
  • Focus first cell on new record - Erste Zelle an einem neuen Eintrag fokussieren,
  • Next cell on pressing Enter - zur nächsten Zelle beim Drücken auf Enter übergehen,
  • Show navigation hints - Navigationshinweise anzeigen,
  • MRU list in column filter - MRU-Liste im Spaltenfilter,
  • Expand buttons for empty details - Erweiterungsbutton für leere Details,
  • Card width - Breite der Karte,
  • Large Memo Editor - Großer Memo-Editor,
  • Word wrap in memo editor - Zeilenumbruch im Memo-Editor,
  • Grid lines - Rasterlinien (Horizontal - horizontal, Vertical - vertikal),
  • Show edit buttons - Editbuttons anzeigen (Never - nie, For focused record - für fokussierten Datensatz, Always - immer),
  • Detail tabs position - Lage der Detail-Registerkarten (Top - oben, Left - links),
  • Card layout direction - Richtung der Kartenanordnung (Horizontal - horizontal, Vertical - vertikal).


Spaltenoptionen

Allgemeine Optionen

Auto-select text - Text automatisch markieren

Hide selection on losing focus - Auswahl ausblenden, wenn es keinen Fokus gibt

Memo-Editor-Eigenschaften

Inserting Return characters - Returnzeichen einfügen

Inserting Tab characters - Tabulatorzeichen einfügen

Word wrap in grid - Zeilenumbruch im Grid

Popup memo editors - Popup-Memo-Editoren.

Spin-Editor-Optionen

Use Ctrl+Up instead of Up to increase spin values - zur Erhöhung des Spinwertes Tastenkombination Ctrl+Up statt Up benutzen

Show large increment buttons - Große inkrementelle Buttons anzeigen

Im Feld Increment wird die Erhöhung angegeben, große Erhöhung - im Feld Large increment.

Lage der Buttons vom Spineditor

Vertical - Vertikal.

Horizontal / left and right - horizontal / links und rechts.

Horizontal / right - horizontal / rechts


Lokalisierung

Mit Hilfe der Tools, die sich auf dieser Registerkarte befinden, kann die Sprache des Programms eingestellt werden.

Man kann eine der verfügbaren Sprachen auswählen bzw. eigene anlegen.

Im Feld Default directory ist der Pfad zum Ordner, in dem standardmäßig alle Lokalisierungsdateien mit *.lng Format abgelagert sind, angegeben.

Aus der Dropdownliste Choose program language wird die Programmsprache ausgewählt.

Wenn der Punkt Auto scan languages on startup aktiviert ist, wird der Ordner Default directory jedes Mal beim Starten des SQL Manager 2007 for MySQL auf neue *.lng Dateien überprüft, die danach automatisch in die Liste der verfügbaren Programmsprachen hinzugefügt werden.

In der Liste Available languages ist eine Liste der verfügbaren Lokalisationen angezeigt, die als Hauptsprache des Programms eingestellt werden kann.

Beim Klicken auf Add defaults werden neue Dateien *.lng im Ordner standardmäßig ausgewählt, die automatisch in die Liste der verfügbaren Programmsprachen hinzugefügt werden.

Wenn man den Button Add aktiviert, kann die Lokalisierungsdatei in Liste Available languages eingetragen werden, indem man den Lokalisierungsnamen und den Pfad zur Datei in dem erscheinenden Fenster angibt.

Das Betätigen der Schaltfläche Edit ermöglicht eine ausgewählte Lokalisierung zu bearbeiten.

Klickt man die Schaltfläche Delete an, kann die ausgewählte Lokalisierung aus der Liste der verfügbaren Lokalisierungen gelöscht werden.


Editoroptionen

Mithilfe dieses Werkzeuges kann man Einstellungen für den SQL-Editor eingeben.

Das Fenster zur Eingabe der Einstellungen kann man öffnen, indem man den Punkt Options | Editor Options im Programm-Hauptmenü auswählt.

Registerkarten:

  • Allgemeine Einstellungen
  • Dartstellung
  • Farbe
  • Code-Vervollständigung
  • SQL-Formatter
  • Bestimmen von Tastenkombinationen
  • Finden von Optionen

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Allgemeine Einstellungen

Unter dieser Registerkarte können allgemeine Editor-Eigenschaften eingestellt werden.

Auto indent - Auto-Einzug

Insert mode - Einfügemodus

Find text at cursor - Cursor Text finden. Das Wort, an dem sich der Cursor befindet, gerät automatisch ins

Fenster der Objektsuche beim Klicken der Tastenkombination Ctrl+F

Always show hyperlinks - Immer Hyperlinks anzeigen

Double click line - Doppelklick-Zeile. Der Doppelklick auf einer beliebigen Stelle der Zeile wird die Zeile automatisch

vollständig markieren.

Trim trailing spaces - nachfolgende Leerzeichen kürzen. Falls der Punkt angehakt ist, werden alle Leerzeichen nach dem letzten Zeichen gelöscht.

Fixed line height - feste Zeilenhöhe

Persistent blocks - Beständige Blöcke. Die Hervorhebung wird beim Übertragen des Cursors mithilfe der Tasten nicht

beseitigt.

Fixed column move - feste Zeilenverschiebung. Wenn dieser Punkt aktiviert ist, dann wird der Cursor im Editor beim Verschieben nach oben und unten seine Position bezüglich des Zeilenanfangs behalten.

Optimal fill - Optimal ausfüllen. Wenn dieser Punkt aktiviert ist, wird die automatische Formatierung des Abfragetextes im Editor aktiviert.

Unindent keep align - Ohne Einzug Ausrichtung behalten.

Smart caret - Smartcaret. Beim Verschieben des Cursors zwischen Zeilen mithilfe der Tasten wird der Cursor

zum nächsten Textzeichen verschoben.

Overwrite blocks - Blöcke überschreiben. Dabei wird der ausgewählte Text durch den mithilfe der Tastatur eingegebene Text ersetzt. Wenn das Häkchen deaktiviert ist, wird der neue Text sofort nach dem ausgewählten eingetragen. Der ausgewählte Text kann beim Betätigen der Schaltflächen Delete, Enter und Leertaste nicht gelöscht werden.

Show caret in read only mode - Caret im schreibgeschützten Modus anzeigen

Copy to clipboard as RTF - In Zwischenablage als RTF kopieren

Drag and drop text - Drag & Drop Text

Group undo - Gruppe rückgängig machen

Group redo - Gruppe wiederholen. Die Option ermöglicht, mehrere Operationen einer Art zu wiederholen.

Keep caret horizontal position - Horizontale Caretposition speichern. Wenn man mit der Maustaste nach dem Text in Zeile auf den leeren Raum klickt, wird der Cursor automatisch zum Textende verschoben. Zum Verschieben werden auch die Schaltflächen Up/Down verwendet.

Enable column selection - Spaltenauswahl aktivieren

Hide cursor on type - Cursor beim Tippen ausblenden

Hide dynamic (no focus) - Dynamic ausblenden (kein Fokus)

Collapse empty lines - Anzahl der leeren Zeilen reduzieren

Scroll to last line - Zur letzten Zeile scrollen

Word wrap - Zeilenumbruch

Variable horizontal scrollbar - Variable horizontale Bildlaufleiste

Float markers - Unverankerte Marken. Wenn diese Option aktiviert ist, werden die Registerkarten nicht mit dem Text zusammen verschoben, sondern verweisen mit einer bestimmten Nummer auf die Zeile.

Undo after save - Nach dem Speichern rückgängig machen. Die Liste mit den ausgeführten Operationen wird nach dem Speichern nicht gelöscht. Somit besteht die Möglichkeit, die Aktionen sogar nach dem Speichern rückgängig zu machen.

Disable selection - Auswahl deaktivieren

Draw current line focus - Aktuellen Zeilenfokus anzeigen

Hide selection (no focus) - Auswahl ausblenden (kein Fokus)

Greedy selection - Greedy-Auswahl. Bei Aktivierung dieser Option werden beim Auswählen mehrerer Zeilen/Spalten zusätzlich 1 Zeile/Spalte mit ausgewählt.

Keep selection mode - Auswahlmodus speichern. Diese Option ermöglicht, das Auswählen bei der Cursorverschiebung im Text auszuführen.

Select search result - Suchergebnisse auswählen

Collapse level - Anzahl der Ebenen reduzieren. Im Optionsfeld wird angegeben, auf welche Ebene die Unterebenen reduziert werden müssen.

Undo limit - Anzahl der Operationen "Rückgängig machen" begrenzen. Im Optionsfeld Undo limit wird die Anzahl der gespeicherten Operationen für die Aktion "Rückgängig machen" angegeben.

Tab mode - Tabmodus. Aus dieser Dropdownliste kann man Folgendes auswählen: Use tab character - Tabstoppzeichen verwenden, Insert spaces - Leerzeichen einfügen, Dialog behaviour - Dialogverhalten,

Smart tab - Smart-Tab, dabei werden die Tabstoppzeichen in Leerzeichen umgesetzt. Es wird der gleiche Einzug wie für eine vorherige Zeile gesetzt.

Tab Stops - Tabstopps. In diesem Optionsfeld wird die Größe des Einzuges beim Tab gesetzt.

Aus der Dropdownliste Comment symbols werden Kommentarsymbole ausgewählt.

Mit Hilfe des Optionsfeldes Block indent/Blockeinzug wird die Einzugsgröße für Blöcke mit eingestellten Registerkarten angegeben.

Reset to defaults - auf Voreinstellung zurücksetzen


Anzeige

Im Abschnitt Gutter werden folgende Bundsteg-Parameter eingegeben:

  • Visible - sichtbarer Bundsteg.
  • Show line numbers - Zeilennummer anzeigen.
  • Display line state - Zeilenstatus anzeigen. Es stehen drei Zeilenstatus zur Verfügung: eine veränderte Zeile wird als gelb, eine neue als grün und eine in der Datei gespeicherte Zeile als dunkelblau markiert.
  • Use code folding - Code-Folding verwenden

Im Optionsfeld Width wird Bundstegbreite angegeben. Aus der Dropdownliste Color wird eine Schriftfarbe ausgewählt.

Im Abschnitt Right margin werden Eigenschaften des rechten Randes, der bei der automatischen Formatierung des Abfragetextes verwendet wird, eingestellt.

(Die Parameter der automatischen Formatierung können auf der Registerkarte SQL Formatter eingestellt werden. Um diesen Rand sichtbar zu machen, muss der Punkt Visible angehakt werden).

Word break - Wortumbruch

Im Optionsfeld Position wird eine Position angegeben. Aus der Dropdownliste Color wird eine Farbe ausgewählt.

Im Abschnitt Code staples werden Parameter von Codeklammern gesetzt.

Visible - sichtbar

Single color - einzelne Farbe für alle Klammern im Text

Offset - Klammerabstand

Color - Klammerfarbe angeben (falls Single color angehakt). Die Farbe wird aus der Dropdownliste ausgewählt.

Im Abschnitt Fonts werden Schriftparameter des Abfrageneditors eingestellt.

Show only fixed-width fonts - Nur Schriften mit fester Breite anzeigen

Beim Betätigen der Schaltfläche Set editor font wird ein Standardfenster der Schriftparameter geöffnet, in dem man die im SQL Editor standardmäßig verwendeten Schriftparameter angegeben werden können. Wenn auf der Registerkarte Farbe keine Parameter für unterschiedliche Elemententype eingestellt wurden, wird diese Schrift als Voreinstellung verwendet. Diese Schrift wird ebenso zum Anzeigen von Fehlern und Warnungen benutzt.

Beim Betätigen der Schaltfläche Set line numbers font kann man die Schrift von Zeilennummern einstellen.

Aus der Dropdownliste Background color wird eine Hintergrundfarbe des Editors ausgewählt.

Aus der Dropdownliste Numbering style wird das Nummerierungsformat ausgewählt.

Alle Änderungen werden auf dem Muster im unteren Teil des Formulars angezeigt.

Alle eingetragenen Änderungen können mit Hilfe der Schaltfläche Reset to defaults rückgängig gemacht werden. Die Werte werden auf Voreinstellungen zurückgesetzt.


Farbe

Unter der Registerkarte Color können Farbe und Schrift unterschiedlicher Textelemente, wie z.B. Schlüsselwörter, Zeichen, Kommentare, Links usw. eingestellt werden.

Im oberen Teil des Formulars sind in der Liste Element alle Elemente dargestellt. Die Änderungen werden auf dem Muster, das sich rechts befindet, angezeigt.

Beim Betätigen der Schaltfläche Disable element wird auf dieses Textelement eine Standardschrift ohne Möglichkeit zum Ändern angewandt. Dabei wird die Überschrift auf der Schaltfläche in Enable element geändert. Beim Anklicken dieser Schaltfläche wird für das ausgewählte Element die Möglichkeit zum Ändern der Schriftart und -farbe aktiviert.

Im unteren Teil des Formulars befinden sich Verwaltungselemente, mit deren Hilfe der Typ des in der Liste Element ausgewählten Objektes verändert wird.

Aus der Dropdownliste Style werden die verfügbaren Änderungsparameter ausgewählt.

Im Standardfenster, das beim Öffnen der Schaltfläche Set custom font geöffnet wird, kann man die Schriftart und - Größe des ausgewählten Elementes einstellen.

Im Abschnitt Font style werden separat Schriftformate ausgewählt:

  • Bold - Fett,
  • Italic - Kursiv,
  • Underline - Unterstreichen,
  • Strike out - Durchgestrichen.

Aus der Dropdownliste Vertical alignment wird der Typ der vertikalen Textausrichtung ausgewählt.

Aus der Liste Foreground color wird die Vordergrundfarbe des Textes ausgewählt. Wenn der Punkt Default aktiviert ist, wird eine voreingestellte Farbe ohne Veränderungsmöglichkeit verwendet.

Aus der Liste Background color wird die Farbe ausgewählt, mit der dieser Text markiert wird. Falls der Punkt Default angehakt ist, wird eine voreingestellte Farbe ohne Veränderungsmöglichkeit verwendet.

Wenn der Punkt Read only aktiviert ist, können Elemente dieses Typs nicht geändert werden.

Die Elemente werden angezeigt, wenn der Cursor auf diese hinweist und der Punkt Hidden aktiviert ist.

Aus der Dropdownliste Capitalization kann die Großschreibung des ausgewählten Elementes ausgewählt werden:

  • Unchanged - ohne Änderungen,
  • Upper case - Großbuchstaben,
  • Lower case - Kleinbuchstaben,
  • Toggle case - Alle Großbuchstaben außer des ersten Buchstaben
  • Initial caps - Anfangsbuchstaben

Im Abschnitt Borders werden Rahmen für das zu bearbeitende Element eingestellt:

  • Left - links,
  • Top - oben,
  • Right - rechts,
  • Bottom - unten.

Aus der ersten Dropdownliste wird der Rahmentyp und aus der zweiten die Farbe ausgewählt.

Multiline border - Mehrzeiliger Rahmen.

Die Linie wird sowohl am Anfang, als auch am Ende der Zeile angezeigt und kann nur auf Default-Objekte angewendet werden.

Um vorgenommene Änderungen zu speichern, wird die Schaltfläche Ok verwendet.

Alle eingetragenen Änderungen können mit Hilfe der Schaltfläche Reset to defaults rückgängig gemacht werden. Die Werte werden auf Voreinstellungen zurückgesetzt.


Code-Vervollständigung

Unter dieser Registerkarte werden Parameter für die Code-Vervollständigung beim Erstellen des Abfragetextes eingestellt. Hierfür wird die Vervollständigungsliste (Completion list) verwendet, die aus verfügbaren Objekten und Schlüsselwörtern besteht. Alle Objekttypen, die die Vervollständigungsliste beinhalten, sind in der Liste Completion list objects aufgeführt. Beim Betätigen der Schaltfläche Disable element werden die Objekte dieses Typs der Liste entnommen. Dabei wird die Überschrift der Schaltfläche auf Enable element abgeändert. Beim Anklicken dieser Schaltfläche werden in die Vervollständigungsliste die Objekte dieses Typs eingetragen.

Im Abschnitt Automatic features werden automatische Features der Vervollständigung eingestellt.

Wenn der Punkt Code Completion aktiviert ist, wird bei der Eingabe der ersten Zeichen automatisch die Liste der Wörter, die mit diesen Zeichen beginnen, angeboten. Dabei werden auch Vervollständigungen für Funktionen aktiviert.

Die Dienstwörter werden hervorgehoben.

Die Anzahl der eingegebenen Zeichen, nach denen die Liste geöffnet wird, kann im Optionsfeld Sensitivity (char) gesetzt werden. Wenn der Punkt Sort field names aktiviert ist, werden die Wörter in der angebotenen Liste sortiert:

  • Sort By type - Nach Typ sortieren,
  • Sort By Name - Nach Namen sortieren.

Die Tastaturvorlagen werden automatisch verwendet, falls der Punkt Auto launch keyboard templates angehakt wird.

Aus der Dropdownliste Style werden die verfügbaren Änderungsparameter ausgewählt.

Im Standardfenster, das beim Öffnen der Schaltfläche Set custom font geöffnet wird, kann man die Schriftart und - Größe des ausgewählten Elementes einstellen.

Im Abschnitt Font style werden separat Schriftformate ausgewählt:

  • Bold - Fett,
  • Italic - Kursiv,
  • Underline - Unterstreichen,
  • Strike out - Durchgestrichen.

Aus der Dropdownliste Vertical alignment wird der Typ der vertikalen Textausrichtung ausgewählt.

Aus der Liste Foreground color wird die Vordergrundfarbe des Textes ausgewählt. Wenn der Punkt Default aktiviert ist, wird eine voreingestellte Farbe ohne Veränderungsmöglichkeit verwendet.

Aus der Liste Background color wird die Farbe ausgewählt, mit der dieser Text markiert wird. Falls der Punkt Default angehakt ist, wird eine voreingestellte Farbe ohne Veränderungsmöglichkeit verwendet.

Wenn der Punkt Read only aktiviert ist, können Elemente dieses Typs nicht geändert werden.

Die Elemente werden angezeigt, wenn der Cursor auf diese hinweist und der Punkt Hidden aktiviert ist.

Aus der Dropdownliste Capitalization kann Großschreibung des ausgewählten Elementes ausgewählt werden:

  • Unchanged - ohne Änderungen,
  • Upper case - Großbuchstaben,
  • Lower case - Kleinbuchstaben,
  • Toggle case - Alle Großbuchstaben außer des ersten Buchstaben
  • Initial caps - Anfangsbuchstaben

Im Abschnitt Borders werden Rahmen für das zu bearbeitende Element eingestellt:

  • Left - links,
  • Top - oben,
  • Right - rechts,
  • Bottom - unten.

Aus der ersten Dropdownliste wird der Rahmentyp und aus der zweiten die Farbe ausgewählt.

Multiline border - Mehrzeiliger Rahmen.

Die Linie wird sowohl am Anfang, als auch am Ende der Zeile angezeigt und kann nur auf Default-Objekte angewendet werden.

Um vorgenommene Änderungen zu speichern, wird die Schaltfläche Ok verwendet.

Alle eingetragenen Änderungen können mit Hilfe der Schaltfläche Reset to defaults rückgängig gemacht werden und die Werte werden auf Voreinstellungen zurückgesetzt.


SQL-Formatter

Die Einstellungen zur automatischen Formatierung von SQL-Abfragen können auf der Registerkarte SQL Formatter vorgenommen werden.

Unter der Registerkarte Settings kann man angeben, welche Abfrageteile automatisch formatiert werden.

Wenn die Punkte Format SQL query und Format subquery aktiviert sind, wird die automatische Formatierung der Abfragen und Unterabfragen aktiviert.

Unter der Registerkarte SQL Words können Formatierungsparameter des Abfragetextes eingestellt werden.

In der Liste Wrap first element kann man Anweisungen, nach denen der Zeilenumbruch ausgeführt werden muss, aktivieren.

Params in line/list - in dieser Liste werden die Anweisungen aktiviert, für die das Anzeigeformat von Parametern verändert werden muss. Wenn beim Öffnen der Abfrage die Parameter spaltenweise angezeigt wurden, werden sie nach dem Anhaken zeilenweise und umgekehrt angezeigt.

Im Abschnitt OR - AND werden OR- und AND-Anweisungen bezüglich des Textes eingestellt:

  • Left - links,
  • Separate - separat,
  • Right - rechts.

In Abschnitten Keyword case und Identifiers case kann Groß-/Kleinschreibung von Schlüsselwörtern und Bezeichnern eingestellt werden.

  • Default - Standard,
  • Upper - Großschreibung,
  • Lower - Kleinschreibung,
  • Capitalize - Mit Großschreibung beginnen

Space before bracket - Leerzeichen vor den eckigen Klammern

Space into brackets - Leerzeichen in eckige Klammern

Mit Hilfe des Optionsfeldes Indents in list werden Einzüge in die Liste eingetragen.

Um den Abfragetext mit neuen Änderungen zu formatieren, muss man im SQL-Editor in Kontextmenü den Punkt Format SQL auswählen.


Zuordnung von Tastenkombinationen

Unter der Registerkarte Key Mapping können Tastenkombinationen für eine schnelle Operationsausführung im SQL-Editor zugeordnet werden.

Die Zuordnung von Tastenkombinationen für diverse Aktionen kann als Tastenkombinationsschema gespeichert werden. Nach dem Eintragen der jeweiligen Änderungen in die Tastenkombination und Hinzufügen von neuen, muss der Button Save As zum Speichern von Änderungen angeklickt werden. Um das Schema einzusetzen, muss man aus der Dropdownliste Scheme name ein jeweiliges Schema auswählen und den Button OK anklicken. Beim Betätigen der Schaltfläche Delete wird das ausgewählte Schema entfernt.

Unten werden alle Tastenkombinationen für die im Editor ausgeführten gesamten Aktionen eingestellt.

Aus der Liste Commands wird ein Befehl, für den eine Tastenkombination zugeordnet wird, ausgewählt.

Im Fenster Key combinations werden bereits hinzugefügte Tastekombinationen angezeigt. Markiert man die Kombination und klickt den Button Delete an, wird diese Tastenkombination entfernt.

Beim Betätigen der Schaltfläche Clear werden alle Tastenkombinationen für ausgewählte Aktion gelöscht.

Zum Hinzufügen einer neuen Tastenkombination muss der Button New angeklickt und im Feld Key eine gewünschte Tastenkombination angegeben werden. Wenn eine solche Tastenkombination bereits besteht, erscheint eine Warnung mit der Angabe der Operation, für die die benötigte Kombination verwendet wird. Es besteht die Möglichkeit, für eine Aktion mehrere Tastenkürzel und sogar eine Reihenfolge von Tastenkürzeln anzulegen. Wenn die Reihenfolge von Tastenkürzeln eingestellt ist, wird die Aktion nach dem Anklicken der Tasten in der angegeben Reihenfolge ausgeführt.

Jede Zeile in der Liste Key combinations ist die Tastenkombination zum Ausführen einer Aktion. Mithilfe der Schaltfläche Add wird ein neues Kürzel in die bereits bestehende Tastenkombination hinzugefügt. Somit wird die Reihenfolge der Tastenkombinationen erstellt.

Das Schema kann in eine Datei exportiert werden, indem man den Button Export anklickt. Dabei wird ein Dialogfenster zum Auswählen einer bestehenden Datei bzw. zum Erstellen einer neuen Datei geöffnet.


Rechtsschreibprüfung

Unter der Registerkarte Spell Checking werden Parameter der Rechtsschreibprüfung angegeben.

Im Abschnitt Spell checker mode wird der Typ der Rechtsschreibprüfung ausgewählt:

  • Highlighting - Wörter mit Fehlern werden hervorgehoben,
  • Autocorrection - Fehler werden automatisch behoben,
  • None - keine Aktionen werden ausgeführt.

Die Parameter zum Beachten der Groß-/Kleinbuchstaben während der Rechtsschreibprüfung können im Abschnitt Case sensitivity gesetzt werden.

Support case consistency with substitution - Unterstützung der Groß-/Kleinbuchstaben mit Ersetzung

Ignore case while spell checking - Groß-/Kleinbuchstaben bei der Rechtsschreibprüfung nicht beachten

Keep the misprint case when replacing - Groß-/Kleinbuchstaben beim Ersetzen des Druckfehlers behalten

In der Liste Substitutions befinden sich Schlüsselbegriffe des Wörterbuches zur Rechtsschreibprüfung. Falls eine automatische Ersetzung der Fehler aktiviert ist, werden die Wörter mit Fehlern durch diese Wörter ersetzt.

Um ein Wort in diese Liste einzutragen, muss man den Button Add anklicken. Mithilfe des Buttons Edit kann das ausgewählte Wort abgeändert werden. Beim Betätigen der Schaltfläche Delete wird das ausgewählte Wort gelöscht.

Die Parameter zur Prüfung auf Druckfehler werden im Abschnitt Misprints eingestellt.

Man kann für ein Wort aus der Liste Substitutions eine Anzahl von Wörtern mit Druckfehlern, die automatisch durch das gewünschte Wort ersetzt werden, eingeben.

In der Liste Check sind Varianten der Fehler, die beim Schreiben vom Benutzer zugelassen werden können, vorhanden.

Um eine Variante hinzuzufügen, muss der Button Add angeklickt werden. Mithilfe des Buttons Edit kann man die ausgewählte Variante des Fehlers ändern. Beim Betätigen der Schaltfläche Auto kann man automatisch alle Varianten der Fehler, die in diesem Wort zugelassen werden können, erstellen. Beim Betätigen der Schaltfläche Delete wird die ausgewählte Variante des Druckfehlers gelöscht. Mithilfe der Schaltfläche Clear wird die gesamte Liste vollständig entleert.

In die Liste Ignore werden die Varianten der Druckfehler eingetragen, die bei der automatischen Ersetzung nicht beachtet werden.

Alle eingetragenen Änderungen können mit Hilfe der Schaltfläche Reset to defaults zurückgesetzt werden.


Ansichtsoptionen

Mithilfe dieses Werkzeuges kann das Anzeigeformat aller Elemente der Programmoberfläche eingestellt werden.

Um das Einstellungsfenster von Ansichtsoptionen zu öffnen, muss man im Programm-Hauptmenü den Punkt Options | Visual Options (zu dt.: Optionen | Ansichtsoptionen) auswählen.

Alle Werkzeuge sind auf den Registerkarten zu finden:

  • Leisten und Menüs
  • Strukturen und Listen
  • Anpassen von Editelementen
  • Kontrollkästchen
  • Schaltflächen
  • Registerkarten
  • Gruppierungsboxen
  • Teiler
  • Navigationsleiste
  • Finden von Optionen

Die eingetragenen Änderungen können als Schema gespeichert werden. Hierfür muss im oberen Teil die Schaltfläche Save as angeklickt werden. Nach dem Anklicken dieser Schaltfläche muss man den Namen des gespeicherten Schemas eingeben. Das Schema kann aus der Liste Scheme Name ausgewählt werden, in der die Standardschemas und vom Benutzer erstellten Schemas enthalten sind. Mithilfe der Schaltfläche Delete kann das Schema gelöscht werden.

Im unteren Teil jeder Registerkarte, auf dem Muster, werden alle eingetragenen Ansichtsänderungen angezeigt.

Die Einstellungen können in die Datei exportiert werden, indem die Schaltfläche Export settings angeklickt wird.

Dabei wird der Assistent zum Exportieren von Daten geöffnet, der diese Operation schrittweise ausführen lässt.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Leisten und Menüs

Die Registerkarte Bars and menus wird zur Ansichtseinstellung von Programmleisten und -menüs verwendet.

Aus der Dropdownliste Bar style wird eines der standardmäßigen Leistenformate ausgewählt.

Aus der Liste Menu Animation kann eine der Animationsvarianten beim Öffnen des Menüs ausgewählt werden.

Sunken border - Abgesenkte Rahmen

Use F10 for menu - F10 für Menü einsetzen.

Menu shows recent command first - Im Menü werden die zuletzt ausgeführten Befehle angezeigt

Show full menus after delay - Vollständige Menüs nach Verzörgerung anzeigen

Flat close buttons - Flache Beenden-Schaltflächen verwenden

Gray-scale disabled images - Graustufige deaktivierte Darstellungen


Bäume und Listen

Unter der Registerkarte Trees and Lists kann die Darstellung von Bäumen (bzw. Strukturen) und Listen eingestellt werden.

Aus der Dropdownliste Look & Feel wird eines der standardmäßigen Darstellungsformate der Listen ausgewählt.

Standard - Standard,

Flat - Flach,

Ultraflat - Ultraflach.

Hide selection - Auswahl ausblenden

Hide focus rectangle - Fokusrechteck ausblenden

Native style - Einheitliches Format


Kontrollen bearbeiten

Unter der Registerkarte Edit controls wird das Format von Verwaltungs- und Bearbeitungselementen eingestellt.

Aus der Dropdownleiste Border style wird ein Rahmenformat ausgewählt:

None - Keine,

Single - Einzeln,

Thick - Dick,

Flat - Flach,

3D - 3D,

Ultraflat - Ultraflach.

Aus der Liste Button style wird ein Schaltflächenformat ausgewählt.

3D - 3D,

Flat - Flach,

Simple - Einfach,

Hotflat - Hotflat

Ultraflat - Ultraflach

Mithilfe der Liste Button transparency wird die Transparenz der Schaltflächen eingestellt.

None - Keine,

Inactive - Inaktive,

Always - Immer,

Hide inactive - Inaktive ausblenden,

Hide unselected - Nicht ausgewählte ausblenden

Hot track - Hot-Track.

Shadow - Schatten.

Native style - Einheitliches Format.

Edges - Rahmen:

  • Left - links;
  • Right - rechts;
  • Top - oben;
  • Bottom - unten.


Kontrollkästchen

Unter der Registerkarte Check boxes werden Kontrollkästchen eingestellt.

Aus der Dropdownliste Border style muss ein Rahmenformat ausgewählt werden:

None - Keine,

Single - Einzeln,

Thick - Dick,

Flat - Flach,

3D - 3D,

Ultraflat - Ultraflach.

Hot track - Hot-Track.

Shadow - Schatten.

Native style - Einheitliches Format.


Schaltflächen

Unter dieser Registerkarte kann die Darstellung der Schaltflächen eingestellt werden.

Aus der Liste Button kind wird eine Schaltflächenart ausgewählt:

Standard - Standard,

Flat - Flach,

Ultraflat - Ultraflach.

Native style - Einheitliches Format.


Registerkarten

In diesem Fenster kann die Darstellung der Registerkarten (Tabs) eingestellt werden.

Aus der Liste Tab Style wird ein gewünschtes Format der Registerkarte ausgewählt.

Tabs - Registerkarten,

Buttons -Schaltflächen

Flat - Flach

Hot track - Hot-Track

Shadow - Schatten.

Native style - Einheitliches Format.


Gruppierungsboxen

Unter der Registerkarte Group boxes kann die Darstellung von Gruppierungsboxen eingestellt werden.

Aus der Dropdownleiste Border style wird ein Rahmenformat ausgewählt:

None - Keine,

Single - Einzeln,

Thick - Dick,

Flat - Flach,

3D - 3D,

Ultraflat - Ultraflach.

Shadow - Schatten,

Native style - Einheitliches Format.


Teiler

Unter der Registerkarte Splitters wird das Format der Teiler eingestellt.

Aus der Dropdownliste Hot zone style wird die Darstellung des Formates Hot-Zone ausgewählt.

Windows XP task bar - Taskleiste Windows XP,

Media Player 8 - Media Player 8,

Media Player 9 - Media Player 9,

Simple - einfach,

None - keine.

Falls der Punkt Hot zone drags a splitter aktiviert ist, kann der Teiler beim Ziehen der mittleren

Arbeitsfläche [image] verschoben werden. Falls nicht, wird beim Drücken auf die Fläche das durch den Teiler begrenztes Fenster minimiert und maximiert.


Navigationsleiste

Unter dieser Registerkarte kann die Darstellungsart der Navigationsleiste eingestellt werden.

Aus der Dropdownliste View style wird ein Anzeigeformat der Navigationsleiste ausgewählt:

Office 11 - Office 11,

XP - Windows XP,

Simple - Einfach,

Advanced - Erweitertes Format.

Falls der Punkt Border aktiviert ist, wird der Rahmen der Navigationsleiste angezeigt.


Tastaturvorlagen

Mithilfe des Werkzeuges Keyboard Templates kann man Vorlagen zur schnellen Texteingabe einstellen.

Um den Editor der Tastaturvorlagen zu öffnen, muss man im Programm-Hauptmenü den Punkt Options | Keyboard Templates (zu dt.: Optionen | Tastaturvorlagen) auswählen.

Zum Erstellen von Vorlagen wird die Schaltfläche Add Template angeklickt. Im erscheinenden Fenster geben Sie die Reihenfolge der Zeichen an, die beim Einfügen durch den bestimmten Text ersetzt werden muss.

Um bereits eine erstellte Vorlage zu ändern, muss man dies in der allgemeinen Liste auswählen und die Schaltfläche Edit Template anklicken. Beim Betätigen der Schaltfläche Delete Template wird eine ausgewählte Vorlage entfernt.

Falls der Punkt Old Style angehakt ist, wird im Text der in früheren Versionen des SQL Manager 2007 for MySQL verwendete Stil benutzt.

Im Abschnitt Expansion wird der Text, durch den der Satz von Vorlagenzeichen ersetzt werden muss, eingegeben.

Mithilfe der Schaltflächen kann man den Autotext eingeben:

  • Cursor - Cursor,
  • Author - Author,
  • Time - Zeit,
  • Date - Datum,
  • Clipboard - Zwischenablage,
  • Marker - Marker.

Im Abschnitt Case of Templates wird die Schreibweise der Vorlagen eingestellt:

  • As is - Unverändert,
  • Uppercase - Großbuchstaben,
  • Lowercase - Kleinbuchstaben,
  • First upper - Erster Buchstabe groß.

Um die Vorlage zu verwenden, muss man im Editor die in der Vorlage eingestellte Zeichenkombination eingeben und danach die Leertaste bzw. die Tastenkombination Ctrl+J anklicken.

Die Standardwerte der Vorlagen können beim Betätigen der Schaltfläche By Default zurückgesetzt werden.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Assistent zum Speichern von Optionen

Der Assistent zum Speichern von Optionen ermöglicht, alle Einstellungen des Programms SQL Manager 2007 for MySQL in eine externe Datei zu exportieren. Die Einstellungsdatei hat die Erweiterung *.reg (Datei der Windows-Systemregistrierung). Die gespeicherten Einstellungen können sowohl für dieses Programm, als auch für ein erneut installiertes Programm SQL Manager 2007 for MySQL übernommen werden. Um den Assistenten zum Speichern von Optionen zu öffnen, muss man im Programm-Hauptmenü den Punkt Options | Save Settings (zu dt. Optionen | Einstellungen speichern) auswählen.

Um die Einstellungen, die in der Datei *.reg gespeichert wurden, zu übernehmen, muss diese Datei mit einem Doppelmausklick geöffnet werden. In dem erscheinenden Fenster muss die Schaltfläche OK angecklickt werden. Alle Einstellungen werden automatisch übernommen (in die Windows-Systemregistrierung hinzugefügt).

Der Assistent besteht aus folgenden Schritten:

  • Eingabe der Datei
  • Auswählen von Einstellungen zum Speichern
  • Auswählen von Datenbanken zum Speichern
  • Speichern von Einstellungen

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Eingabe der Datei

Im ersten Schritt muss der Name einer Datei, in die diese Einstellungen gespeichert werden und der Pfad zu ihr angegeben werden. Im Feld Filename wird mithilfe der Schaltfläche [image] im geöffneten Standard-Dialogfenster der Name und die Adresse der erstellten Datei angegeben.

Nächster Schritt


Auswählen von Einstellungen zum Speichern

Die zu speichernden Einstellungen müssen angehakt werden:

  • Database Registration Info - Datenbank-Registrierungsinfo,
  • Database projects - Datenbankprojekte,
  • Tabs - Registrierkarten,
  • Environment Options - Umgebungsoptionen,
  • Visual Options - Ansichtsoptionen,
  • Keyboard Templates - Tastaturvorlagen,
  • External Tools - Externe Tools,
  • Form placement - Platzierung von Formularen,
  • MRU lists - Liste der zuletzt verwendeten Objekte,

Nächster Schritt


Auswählen von Datenbanken zum Speichern

In diesem Schritt muss man die Datentabanken, für die Registrierungsinformationen und Einstellungen zu speichern sind, auswählen. In der Liste Available Databases befinden sich die verfügbaren Datenbanken. Man muss aus der Liste die Datenbanken auswählen, für die die Registrierungsinformationen und Einstellungen zu speichern sind. Danach müssen diese in Liste Selected Databases mithilfe der Schaltflächen übertragen werden.

Nächster Schritt


Speichern von Einstellungen

Zur Erstellung der Einstellungsdatei muss die Schaltfläche Finish angeklickt werden.

Der Bearbeitungsstatus wird in einem speziellen Fenster angezeigt.

Mithilfe dieses Fensters kann man das Speichern verfolgen und sich im Fenster Operations auch den Bericht über jeden Schritt der ausgeführten Operation ansehen. Das Fenster Operations wird beim Klicken auf die Schaltfläche Details geöffnet. Bei Aktivierung des Punktes Close the Wizard wird der Assistent zum Speichern von Optionen geschlossen, sobald man die Schaltfläche Close in diesem Fenster anklickt.


Plug-ins und externe Tools

Um mit dem SQL Manager 2007 for MySQL noch effizienter arbeiten zu können, kann man eine Anzahl von externen Programmen und Plug-Ins hinzufügen.

Plug-Ins sind Hilfsprogramme, die zusätzliche Funktionen im Hauptprogramm ausführen.

Dies kann gleichzeitig mit der Anwendung geladen und als Option im Menü Plugins dargestellt werden.

Externe Tools sind kein Bestandteil des SQL Manager 2007 for MySQL. Sie ermöglichen aber die Arbeit mit dem Programm effizienter zu machen. Das auf solche Weise angeschlossene Programm kann aus dem Menü Tools | External Tools (zu dt.: Tools | Externe Tools) gestartet werden.


Plug-ins

Die Plug-ins zum Arbeiten mit dem SQL Manager 2007 for MySQL können mithilfe des Werkzeuges, das beim Auswählen des Punktes Options | Plugins Options (zu dt. Optionen | Plugin-Optionen ) im Programm-Hauptmenü geöffnet wird, eingestellt werden.

Einrichten von Plug-Ins

Um ein Plug-in hinzuzufügen, muss man:

  • Punkt Options | Plugins Options im Hauptmenü des Programms auswählen,
  • im erscheinenden Plugins-Editor die Schaltfläche Add anklicken,
  • mithilfe des Standard-Dialogfensters eine Datei mit der Erweiterung *.dll auswählen,
  • OK anklicken, um eine ausgewählte Datei in die Plug-In-Liste hinzuzufügen.

Um ein eingestelltes Plug-In zu starten, muss man im Punkt Plugins | Plugins-Name auswählen.

Löschen von Plug-ins

Um ein Plug-in zu löschen, muss man:

  • Punkt Options | Plugins Options im Hauptmenü des Programms auswählen,
  • im erscheinenden Plug-In-Editor das gewünschte Programm auswählen,
  • Schaltfläche Delete anklicken.

Plug-In-Editor

Optionen von Plug-ins

Datengenerator

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Plugins-Editor

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Einstellen von Plug-ins

Mithilfe dieses Fensters kann man Plug-Ins, die am SQL Manager 2007 for MySQL angeschlossen sind, verwalten. Unter der Registerkarte Common tools werden Plug-Ins angezeigt, die zum Arbeiten mit gesamter Datenbank bestimmt sind. Die Plug-Ins zum Arbeiten mit separaten Datenbanken befinden sich auf der Registerkarte Tools for objects.

Um ein Plug-In hinzuzufügen, muss die Schalfläche Add plugin angeklickt werden.

Um ein Plug-In zu löschen, muss die Schalfläche Remove plugin angeklickt werden.

Da alle Plug-Ins im Programm als Menüpunkte angezeigt werden, kann man in diesem Fenster ihre Position in diesem Menü verwalten, indem neue Untermenüs erstellt werden.

Beim Betätigen der Schaltfläche New submenu, wird ein neues Untermenü erstellt, wo ursprüngliche Objekte gespeichert werden können. Der Name des Untermenüs kann mithilfe der Schaltfläche Rename geändert werden.

Um das Untermenü zu löschen, muss man die Schaltfläche Delete anklicken.

Um die Reihenfolge der Objekte in der Liste zu ändern, können die Schaltflächen [image] bzw. die Tastenkombinationen Shift+Ctrl+Up / Shift+Ctrl+Down (zu dt. Shift+Strg+Up / Shift+Strg+Down) verwendet werden. Darüber hinaus kann die Objektstelle durch Mausziehen verändert werden.

Unten befindet sich das Fenster, in dem die Beschreibung und der Pfad zum ausgewählten Plug-In angegeben wird.


Optionen von Plug-ins

Unter dieser Registerkarte kann man sich Infos über das installierte Plug-In ansehen.

Plugin is a common tool/ Plugin ist ein gemeinsames Werkzeug. Diese Option erlaubt, das Plug-In mit der gesamten Datenbank zu verwenden.

Plugin is built in object editor/Plugin ist mit Objekteditor erstellt. Das Plug-In wird in Objekteditoren eingebaut.

Plugin has options dialog/Plugin hat Einstellungs-Dialog - Plug-In enthält ein Dialog zum Einstellen von Optionen.

Unload plugin after executing/Plugin nach Ausführen entladen - Plug-In wird nach dem Ausführen entladet.

Im Abschnitt Object Editors wird angegeben, in welche Editoren das vorhandene Plug-In eingebaut ist.

Im Abschnitt Options können Darstellungsparameter vom Plug-In im Programm-Menü eingestellt werden.

Menu caption/Menü-Bezeichnung - Die Plug-In-Beschriftung im Programm-Hauptmenü und Tastenkombination zum schnellen Aufruf

Options menu caption - Optionsmenü-Bezeichnung

Place button on toolbar - Schaltfläche auf Symbolleiste platzieren


Datengenerator

Data Generator Plugin ist eine leistungsfähige Anwendung für das Erzeugen von Testdaten für MySQL-Datenbanken. Mit Hilfe eines einfachen und benutzerfreundlichen Assistenten werden Tabellen und Felder für die Erzeugung der Daten definiert und Textfelder durch Maskierung erzeugt. Des Weiteren ist es möglich, Werte für BLOB-Felder aus Dateien zu laden und Wertelisten aus SQL-Abfragen zu erstellen. Mit Hilfe des dazugehörigen Kommandozeilen-Programms kann die Datengenerierung durch das Verwenden von Generator-Vorlagen automatisiert durchgeführt werden.

Um den Data Generator zu starten, muss der Punkt Plugins | Data Generator im Hauptmenü ausgewählt werden. Aus der Dropdownliste Database wählt man eine Datenbank, für die die Daten erstellt werden müssen.

Die Tabelle kann aus der Liste Table ausgewählt werden.

Die Tabellenfelder werden in der Liste Field Name angegeben. Zur Erstellung der erforderlichen Daten muss man für jedes Tabellenfeld einen Datentyp in der Spalte Type angeben.

Die Anzahl der zu erstellenden Datensätze muss im Feld Number of records to be generated angegeben werden.

Nach der Eingabe aller Parameter muss die Schaltfläche Generate angeklickt werden, um den Erstellungsprozess zu starten.

Siehe auch:

Optionen von Plug-ins

Plug-In einrichten

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Nein


Externe Tools

Um mit dem SQL Manager 2007 for MySQL noch effizienter arbeiten zu können, kann man eine Anzahl von externen Tools hinzufügen.

Hinzufügen von externen Tools

Um ein anderes Programm hinzuzufügen, muss man:

  • Punkt Optionen | Externes Tool im Programm-Hauptmenü auswählen,
  • im erscheinenden Fenster von externen Tools die Schaltfläche Hinzufügen hinzufügen,
  • im Dialogfenster Verbindungsparameter angeben,
  • OK anklicken, um alle eingetragenen Änderungen abzuspeichern.

Diese Reihenfolge der Aktionen hilft Ihnen das angegebene Programm in die Liste der externen Tools hinzuzufügen.

Das in die Liste hinzugefügte Programm kann mithilfe des SQL Manager 2007 for MySQL gestartet werden, nachdem dies aus dem Menü Tools | Externes Tool.. ausgewählt wurde.

Löschen von externen Tools

Um das Programm aus der Liste der externen Tools zu löschen, muss man:

  • Punkt Optionen | Externes Tool im Hauptmenü des Programms auswählen,
  • im erscheinenden Fenster von externen Tools ein erforderliches Programm auswählen,
  • Schaltfläche Löschen anklicken.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Fenster von externen Tools

Dieses Fenster wird beim Auswählen des Punktes Options | External Tools im Programm-Hauptmenü ausgewählt.

Im Fenster Tools wird die Liste der bereits hinzugefügten externen Tools angezeigt.

Beim Betätigen der Schaltfläche Add kann man das Programm in die Liste hinzufügen.

Beim Klicken auf die Schaltfläche Edit wird das Fenster Bearbeiten von externen Tools geöffnet. Damit können die Eigenschaften eines hinzugefügten Programms geändert werden.

Beim Klicken auf die Schaltfläche Delete, wird das Programm aus der Liste entfernt.

Um in der Liste die Reihenfolge der Programme in der Liste zu ändern, werden die Schaltflächen [image] bzw. die Tastenkombinationen Shift+Ctrl+Up / Shift+Ctrl+Down benutzt. Die Objekte können auch mithilfe der Maus verschoben werden.


Bearbeiten von externen Tools

Mithilfe des Fensters Edit External Tool Info können externe Tools des Programms SQL Manager 2007 for MySQL hinzugefügt und bearbeitet werden.

Dieses Fenster wird beim Betätigen der Schaltflächen Add und Edit im Fenster von externen Tools geöffnet.

Im Feld Title wird der Name, der für dieses Programm in der Liste der externen Tools angezeigt wird, angegeben.

Im Feld Hot Key kann die Tastenkombination, mit der sich das Programm künftig öffnen soll, hinterlegt werden.

Dieses Feld kann gewöhnlicherweise nicht bearbeitet werden.

Im Feld Program wird der Pfad zum Programm (zur Datei mit der Erweiterung *.exe) eingegeben. Das kann man auch mithilfe des Standard-Dialogfensters beim Klicken auf die Schaltfläche [image] vornehmen.

Im Feld Working Dir wird das Arbeitsverzeichnis für dieses Programm angegeben.

Die Parameter der Programmausführung können im Feld Parameters eingestellt werden.


Lokalisierung

Der SQL Manager 2007 for MySQL ermöglicht, die Sprachen der Bedienungsoberfläche anzupassen.

Änderung der Programmsprache

Um eine Programmsprache zu ändern, muss man wie folgt vorgehen:

  • im Programm-Hauptmenü den Punkt Optionen | Sprache wählen auswählen,
  • erforderliche Sprache der Bedienungsoberfläche im Fenster zum Auswählen der Programmsprache auswählen,
  • OK anklicken, um Änderungen abzuspeichern.

Bearbeiten der Programmlokalisierung

Um die Programmlokalisierung zu bearbeiten, muss man:

  • Programmfenster, in dem die Beschriftung bzw. die Benennung der Verwaltungselemente geändert werden soll, öffnen,
  • Tastenkombination Shift+Ctrl+L anklicken, um das Fenster des Lokalisierungseditors zu öffnen,
  • Text nach Ihrem Wusch verändern,
  • Änderungen speichern, indem man die Schaltfläche Speichern im Fenster der Lokalisierungsbearbeitung verwendet.

Hinweis:

Die Lokalisierung kann man nur in dem Fall ändern, wenn diese installiert und keine Standardlokalisierung ist.

Man kann die Lokalisierung mithilfe des Werkzeuges Environment Options | Localization (zu dt. Umgebungsoptionen | Lokalisierung) installieren.

Erstellung einer neuen Lokalisierung

Um eine neue Lokalisierung zu erstellen, muss man:

  • neue Lokalisierungsdatei mit der Erweiterung *.lng erstellen und diese in den Ordner Languages ins Verzeichnis, in dem der SQL Manager 2007 for MySQL installiert ist, platzieren,
  • im Hauptmenü des Programms den Punkt Optionen | Umgebungsoptionen auswählen
  • Registerkarte Umgebungsoptionen | Lokalisierung öffnen,
  • unter dieser Registerkarte die Schaltfläche Hinzufügen anklicken,
  • im erscheinenden Fenster im Feld Sprachname den Namen dieser neuen Lokalisierung und im Feld Sprachdatei den Pfad zur erstellten Datei mit der *.lng Erweiterung angeben,
  • nach dem Klicken auf die Schaltfläche OK erscheint in der Liste der Lokalisierungen eine neue Sprache, die bearbeitbar und als Programmsprache installierbar ist

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Lokalisierungseditor

Der Lokalisierungseditor ermöglicht, alle Kopfzeilen, Beschriftungen, Bezeichnungen von Elementen und Hinweisen im Programm SQL Manager 2007 for MySQL zu ändern. Die ist jedoch nur machbar, wenn diese Sprache keine Standardsprache ist. Die Lokalisierungsdatei kann in jedem Texteditor geöffnet und geändert werden.

Vor dem Zeichen "=" sind Verwaltungselemente und nach dem Zeichen "=" die Bezeichnungen dieser Elemente auf der ausgewählten Lokalisierungssprache angegeben. Man kann nur das verändern, was nach dem Zeichen "=" geschrieben steht.

Zur komfortablen Arbeit ist der Editor mit einem standardmäßigen Dialogfenster und einer Suchfunktion vorgesehen.

Dieses Fenster kann beim Klicken auf die Tastenkombination Ctrl+F geöffnet werden.

Um die eingetragenen Änderungen zu speichern, muss die Schaltfläche Save auf der Symbolleiste angeklickt werden.

Siehe auch Environment Options | Localization ( zu dt. Umgebungsoptionen | Lokalisierung)


Auswählen der Programmsprache

Mithilfe dieses Dialogfensters kann die Lokalisierungssprache des Programms SQL Manager 2007 for MySQL ausgewählt werden.

Das Fenster kann man öffnen, indem man den Punkt Options | Select Program Language (zu dt. Optionen | Sprache wählen) im Programm-Hauptmenü auswählt.

In der Liste sind alle verfügbaren Programmsprachen, die mithilfe Environment Options | Localization (zu dt. Umgebungsoption | Lokalisierung) installiert wurden, vorhanden.

Funktion vorhanden in:

Windows Full | Ja
Windows Lite | Ja


Datenbank erstellen

Erstellen von Datenbanken

Zur Vereinfachung der Prozedur zum Erstellen von Datenbanken gibt es im SQL Manager 2007 for MySQL ein spezielles Werkzeug - Assistent zum Erstellen von Datenbanken Assistent zum Erstellen von Datenbank. Mit Hilfe des Assistenten kann der Anwender schrittweise eine Datenbank erstellen.

Zum Erstellen einer Datenbank muss man folgende Aktionen ausführen:

  • den Punkt Datenbank| Datenbank erstellen des Programmhauptmenüs auswählen,
  • Datenbanknamen, Servernamen, Autorisierungstyp eingeben,
  • Option Registrierung nach dem Erstellen für den Aufruf des Assistenten zur Registrierung von Datenbank aktivieren,
  • Ergebniss in Form vom SQL-Skript betrachten und korrigieren.


Datenbank löschen

Löschen von Datenbanken

Beim Löschen wird die gesamte Datenbank vom Server entfernt. In diesem Fall kann man die Datenbank lediglich aus den vom Anwender während der Arbeit erstellten Sicherungskopien wiederherstellen.

Um eine Datenbank zu löschen, muss man:

  • eine Datenbank, die entfernt werden soll, auswählen (Klicken Sie auf diese mit der Maus im DB-Explorer),
  • den Punkt Datenbank | Datenbank löschen des Programmhauptmenüs auswählen (im Kontextmenü ist dieser Punkt nicht vorhanden),
  • Löschen von Datenbank in einem erscheinenden Fenster bestätigen.

Man kann sowohl die angeschlossenen, als auch die nicht angeschlossenen Datenbanken löschen. Eine Datenbank kann nicht gelöscht werden, wenn keine Verbindung zum Server besteht.


Datenbank registrieren

Datenbankregistrierung

Zum Einsatz des SQL Manager 2007 for MySQL mit einer schon bestehenden Datenbank muss diese registriert werden. Hierfür ist ein spezielles Werkzeug Assistent zur Datenbankregistrierung vorhanden. Zum Starten des Assistenten wird der Punkt Datenbank | Datenbank registrieren im Programmhauptmenü ausgewählt.

Mit Hilfe dieses Werkzeuges kann man einen Server, eine Datenbank auf diesem Server auswählen und für diese die Verbindungs- und Autorisierungsparameter und weitere Optionen der Registrierung eingeben.

Zur Registrierung mehrerer Datenbanken, die sich auf einem Server befinden, muss man im Schritt der Einstellung der Serversparameter die Funktion Einzelne Datenbank registrieren deaktivieren. Im nächsten Schritt kann man dann mehrere Datenbanken für die Registrierung auswählen und diese alle gleichzeitig registrieren.


Datenbankregistrierung aufheben

Aufhebung der Datenbankregistrierung

Wenn keine Datenbank verwendet wird, kann die Funktion Datenbankregistrierung aufheben eingesetzt werden. Eine nicht registrierte Datenbank wird im SQL Manager 2007 for MySQL nicht angezeigt.

Zur Registrierungsaufhebung müssen folgende Aktionen ausgeführt werden:

  • eine Datenbank, derer Registrierung Sie aufheben wollen, auswählen

(Klicken Sie auf diese mit der Maus im DB-Explorer),

  • den Punkt Datenbank | Datenbankregistrierung aufheben im Programm-Hauptmenü auswählen,
  • Registrierungsaufhebung in einem erscheinenden Fenster bestätigen.


Datenbank verbinden

Verbindung zur Datenbank

Den Befehl Datenbank verbinden kann man finden:

  • im Programm-Hauptmenü - Datenbank | Datenbank verbinden,
  • im Kontextmenü des Explorers,
  • im Kontextmenü der Datenbank.

Zur Datenbankverbindung kann man auch die Tastenkombination Ctrl+Shift+C bzw. den Doppelklick auf den Namen der gewünschten Datenbank im Explorer verwenden.


Datenbank trennen

Datenbanktrennung

Wenn das Arbeiten mit einer Datenbank beendet ist, kann diese getrennt werden.

Der Befehl Datenbank trennen ist überall vorhanden, wo es Datenbank verbinden gibt. Die Datenbanktrennung ist auch mittels der Tastenkombination Ctrl+Shift+D möglich.


Tabelle erstellen

Die Tabellen sind Objekte, die alle Daten in Relationsdatenbanken enthalten. Die Tabelle ist eine Sammlung von Spalten.

Die Daten werden in den Tabellen in Form von Zeilen und Spalten, ähnlich wie in einer elektronischen Tabelle, angeordnet. Jede Zeile stellt einen eindeutigen Datensatz und jede Spalte ein Datensatzfeld dar. Zum Beispiel kann eine Tabelle, die die Angaben über die Mitarbeiterinnen und Mitarbeiter enthält, eine Zeile für jede/jeden Mitarbeiterin/Mitarbeiter haben und die Spalten, die die Angaben über die Mitarbeiterinnen und Mitarbeiter anzeigen (zum Beispiel: eine Identifikationsnummer, einen Namen, eine Anschrift, eine Dienststellung, eine Haustelefonnummer).

Jede Tabelle kann bis 1024 Spalten enthalten. Die Tabellen- und Spaltennamen müssen den Regeln des Identifikators entsprechen; sie müssen eindeutig innerhalb einer Tabelle sein. Mit anderen Worten, man kann gleiche Spaltennamen in unterschiedlichen Tabellen einer Datenbank verwenden.

Die Tabellen in MySQL haben folgende Hauptbestandteile:

  • Spalten

Jede Tabelle stellt irgendein Attribut eines Objektes dar, was von der Tabelle modelliert wird. Für die Details in einer Infotabellen gibt es beispielsweise Spalten für ihre ID, Farbe und Gewicht.

  • Zeilen

Jede Zeile stellt einen separaten Bezug des von einer Tabelle modellierten Objektes dar. Zum Beispiel gibt es in einer Infotabelle unbedingt eine Zeile für jedes Detail, das vom Unternehmen verkauft wird.

Erstellen von Tabellen

Um eine Tabelle zu erstellen, muss man:

  • Punkt Datenbank | Neues Objekt des Hauptmenüs. Im Fenster zum Auswählen des Objektyps muss man eine Tabelle auswählen,
  • Kontextmenü des DB-Objektes Tables,
  • Kontextmenü der Datenbank,
  • Tastenkombination <Ctrl + N>.

Umbenennen von Tabellen

Wollen Sie den Tabellennamen verändern, dann müssen Sie:

  • Punkt des Kontextmenüs der Tabelle Tabelle umbenennen <Objektname>auswählen,
  • oder die Tastenkombination <Ctrl + R> verwenden.

Kopieren von Tabellen

Zum Kopieren eines Objektes ist ein spezielles Assistentenprogramm vorhanden. Man kann das Objekt in eine andere Datenbank mit oder ohne die Daten kopieren.

Zum Kopieren einer Tabelle muss man den Punkt Tabelle dupliezieren <Objektname im Kontextmenü der Tabelle auswählen.

Soll die Tabelle auf diese Weise kopiert werden, wird der Assistent zum Kopieren von Objekten im 3. Schritt sofort geöffnet. In den ersten zwei Schritten wird eine Datenbank und ein Objekt ausgewählt, was in diesem Fall nicht nötig ist.


Tabelle bearbeiten

Bearbeiten von Tabellen

Zum Öffnen einer Tabelle im Tabelleneditor genügt ein Doppelmausklick auf die benötigte Tabelle im DB-Explorer.

Dies kann man ebenso vornehmen, indem man den Punkt des Kontextmenüs einer Tabelle Tabelle bearbeiten <Objektname> auswählt.


Tabelle löschen

Löschen von Tabellen

Zum Löschen einer Tabelle muss man den Punkt des Kontextmenüs Tabelle löschen <Objektname> auswählen bzw. die Tastenkombination <Ctrl + Del> verwenden.


Feld in Tabelle hinzufügen

Anlegen eines Feldes

Um ein Feld in eine Tabelle hinzuzufügen, muss man nachfolgende Aktionen ausführen:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer.
  • Registerkarte Felder öffnen (standardmäßig wird sie sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet),
  • im Kontextmenü des Feldes den Punkt Neues Feld... auswählen,
  • im erschienenen Feldeditor benötigte Feldeigenschaften angeben.


Tabellenfeld bearbeiten

Bearbeiten von Feldern

Zum Verändern eines Feldes muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer.
  • Registerkarte Felder öffnen (standardmäßig wird sie sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet),
  • im Kontextmenü des Feldes den Punkt Feld bearbeiten <Objektname> auswählen,
  • im erschienenen Feldeditor die benötigten Feldeigenschaften angeben.


Tabellenfeld löschen

Löschen von Feldern

Um ein Feld zu löschen, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer.
  • Registerkarte Felder öffnen (standardmäßig wird sie sofort beim Öffnen einer Tabelle im Tabelleneditor geöffnet),
  • im Kontextmenü des Feldes den Punkt Feld löschen <Objektname> auswählen,
  • im erschienenen Fenster das Löschen eines Feldes bestätigen


Index erstellen

Der Index ist ein Objekt der Relationsdatenbank. Er ermöglicht, anhand der Schlüsselwerte, einen schnellen Zugriff auf die Daten der Tabellenzeilen. Ebenso machen die Indizes die Tabellenzeilen eindeutig. Der Primärschlüssel einer Tabelle wird automatisch indiziert.

Bei Volltextsuche werden die Infos über die Schlüsselwörter und derer Anordnung in einer bestimmten Spalte im Volltextindex gespeichert.

Erstellen von Indizes

Um einen Index in die Tabelle hinzuzufügen, muss man wie folgt vorgehen:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer.
  • Registerkarte Indizes öffnen
  • im Kontextmenü des Indexes den Punkt Neuer Index... auswählen,
  • im erschienenen Indexeditor benötigte Indexeigenschaften angeben.


Index bearbeiten

Bearbeiten von Indizes

Um einen Index zu bearbeiten, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer.
  • Registerkarte Indizes öffnen
  • im Kontextmenü des Indexes den Punkt Index bearbeiten <Objektname> auswählen,
  • im erschienenen Indexeditor benötigte Indexeigenschaften angeben.


Index löschen

Löschen von Indizes

Um einen Index zu löschen, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer,
  • Registerkarte Indizes öffnen,
  • im Kontextmenü des Indexes den Punkt Index löschen <Objektname> auswählen,
  • im erschienenen Indexeditor das Löschen eines Indexes bestätigen


Trigger erstellen

Der Trigger ist eine Art der gespeicherten Prozedur, die automatisch bei der Auslösung eines Ereignisses auf dem Datenbankserver ausgeführt wird. Die Trigger der Datenverarbeitungssprache werden nach den Ereignissen ausgeführt. Diese werden durch den Versuch des Benutzers, die Daten mit Hilfe der Datenverarbeitungssprache zu verändern, aufgerufen. Die DML-Ereignisse schließen INSERT-, UPDATE- oder DELETE-Anweisungen ein, die Daten in einer angegebenen Tabelle oder Sicht ändern. Die DDL-Trigger werden als Ergebnis einer Reihe der DDL-Ereignisse ausgelöst. Diese Ereignisse sind vor allem die CREATE-, ALTER-, DROP-Anweisungen und einige im System gespeicherte Prozeduren, die mit DDL gleiche Operationen ausführen.

Trigger erstellen

Um einen Trigger in eine Tabelle einzutragen, gehen Sie bitte wie folgt vor:

  • öffnen Sie die Tabelle im Tabelleneditor. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer.
  • öffnen Sie die Registerkarte Triggers,
  • im Trigger-Kontextmenü ist danach den Punkt Neuer Trigger... auszuwählen,
  • im erscheinenden Triggereditor geben Sie dann die benötigten Triggereigenschaften an.


Trigger bearbeiten

Trigger bearbeiten

Um einen Trigger zu bearbeiten, muss man wie folgt vorgehen:

  • die Tabelle im Tabelleneditor soll geöffnet werden. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer,
  • die Registerkarte Triggers ist zu öffnen,
  • im Trigger-Kontextmenü ist danach der Punkt Trigger bearbeiten <Objektname> auszuwählen,
  • im erscheinenden Triggereditor werden die benötigten Triggereigenschaften angegeben.


Trigger löschen

SQL Manager 2007 for MySQL
  • Index
  • « Prev
  • Next »

Удалить тригер

Trigger löschen

Um einen Trigger zu löschen, muss man wie folgt vorgehen:

  • die Tabelle im Tabelleneditor soll geöffnet werden. Hierfür genügt ein Doppelmausklick auf eine benötigten Tabelle im DB-Explorer,
  • die Registerkarte Triggers ist zu öffnen,
  • im Trigger-Kontextmenü ist danach der Punkt Trigger löschen <Objektname> auszuwählen,
  • im erscheinenden Fenster bestätigen Sie das Löschen des Triggers.


Fremdschlüssel erstellen

Der Fremdschlüssel - Foreign Key - ist eine Spalte bzw. eine Spaltenkombination, deren Werte einem primären bzw. eindeutigen Schlüssel aus derselben oder anderen Tabelle entsprechen. Der Fremdschlüssel wird ebenso als Verweisschlüssel bezeichnet. Die Erstellung und Bearbeitung der Fremdschlüssel erfolgt mit Hilfe des speziellen Werkzeuges - Fremdschlüsseleditor. Diese Einschränkung versorgt die Ganzheit von Verweisdaten. Der Fremdschlüssel wird für zwangsläufige Relationen zwischen den Daten in zwei Tabellen verwendet.

Fremdschlüssel erstellen

Um einen Fremdschlüssel in eine Tabelle einzutragen, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer,
  • Registerkarte Fremdschlüssel öffnen,
  • im Kontextmenü des Fremdschlüssels den Punkt Neuer Fremdschlüssel... auswählen,
  • im erscheinenden Fremdschlüsseleditor die benötigten Eigenschaften des Fremdschlüssels angeben.


Fremdschlüssel bearbeiten

Fremdschlüssel bearbeiten

Um einen Fremdschlüssel zu verändern, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer,
  • Registerkarte Fremdschlüssel öffnen,
  • im Kontextmenü des Fremdschlüssels den Punkt Fremdschlüssel bearbeiten <Obejktname> auswählen,
  • im erscheinenden Fremdschlüsseleditor die benötigten Eigenschaften des Fremdschlüssels angeben.

Hinweis: Einige Eigenschaften des Fremdschlüssels kann man lediglich beim Anlegen einstellen. Beim Bearbeiten des schon erstellten Fremdschlüssels sind diese bereits nicht verfügbar.


Fremdschlüssel löschen

Fremdschlüssel löschen

Um einen Fremdschlüssel zu löschen, muss man:

  • Tabelle im Tabelleneditor öffnen. Hierfür genügt ein Doppelmausklick auf eine benötigte Tabelle im DB-Explorer genug,
  • Registerkarte Fremdschlüssel öffnen,
  • im Kontextmenü des Fremdschlüssels den Punkt Fremdschlüssel löschen<Objektname> auswählen,
  • im erscheinenden Fenster das Löschen des Fremdschlüssels bestätigen


View erstellen

Die View (zu dt. Sicht) ist eine virtuelle Tabelle, die die Daten einer oder mehrerer Tabellen alternativ darstellt.

Die View kann nur in einer aktuellen Datenbank erstellt werden und nicht mehr als 1024 Spalten enthalten.

View erstellen

Um eine View zu erstellen, verwenden Sie bitte einen der folgenden Punkte:

  • Punkt Datenbank | Neues Objekt des Programm-Hauptmenüs. Im Auswahlfenster des Objekttyps muss man View auswählen
  • Kontextmenü von Datenbankobjekten Views| Punkt Neue View,
  • Tastenkombination <Ctrl + N>.

View kopieren

Zum Kopieren von Objekten gibt es einen speziellen Assistenten. Man kann ein Objekt in eine andere Datenbank mit bzw. ohne Daten kopieren.

Um eine View zu kopieren, muss man den Punkt View duplizieren <Objektname> im Kontextmenü der View auswählen.

Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren sofort im 3. Schritt geöffnet, denn in den ersten zwei Schritten wird eine Datenbank und ein Objekt ausgewählt, was in diesem Fall unbrauchbar ist.


View bearbeiten

View bearbeiten

Zum Arbeiten mit einer View gibt es im SQL Manager 2007 for MySQL ein spezielles Werkzeug Vieweditor (Sicht-Editor).

Um eine View im Vieweditor zu öffnen, genügt ein Doppelmausklick auf dem Objekt im DB-Explorer. Dies funktioniert auch, indem man den Punkt des Kontextmenüs einer View View bearbeiten <Objektname> auswählt.

View umbenennen

Soll der Name einer View umbenannt werden, kann man:

  • Punkt des Kontextmenüs der View View umbenennen <Objektname> auswählen,
  • Tastenkombination <Ctrl + R> verwenden.


View löschen

View löschen

Um eine View zu löschen, muss man im DB-Explorer den Punkt im Kontextmenü View löschen <Objektname> auswählen und die Tastenkombination <Ctrl + Del> verwenden.


Benutzerdefinierte Funktion (UDF) erstellen

Die benutzerdefinierte Funktion (UDF) ist ein Mittel zur MySQL-Erweiterung mit Hilfe einer neuen Funktion, die ähnlich wie die eingebauten MySQL-Funktionen arbeitet.

Erstellen von benutzerdefinierten Funktionen

Um dieses Objekt anzulegen, muss man:

  • Punkt Datenbank | Neues Objekt des Hauptmenüprogramms verwenden. Im Auswählfenster des Objekttypes muss man Benutzerdefinierte Funktion auswählen,
  • bzw. den Punkt Neue benutzerdefinierte Funktion im Kontextmenü der Gruppe von Datenbankobjekten UDFs verwenden,
  • bzw. die Tastenkombination <Ctrl + N>benutzen.

Das angelegte Objekt wird automatisch im Editor der benutzerdefinierten Funktionen geöffnet.

Kopieren von benutzerdefinierten Funktionen

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um eine Funktion zu kopieren, muss man den Punkt Benutzerdefinierten Funktion duplizieren <Objektname> im Kontextmenü der Gruppe von Datenbankobjekten UDFs auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.


Benutzerdefinierte Funktion (UDF) bearbeiten

Bearbeiten von benutzerdefinierten Funktionen

Zum Arbeiten mit den Funktionen im SQL Manager 2007 for MySQL ist ein spezielles Werkzeug vorhanden: UDF-Editor. Um ein Objekt im Editor zu öffnen, genügt ein Doppelmausklick auf ein Objekt im DB-Explorer.

Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Benutzerdefinierte Funktion bearbeiten<Objektname> auswählt.

Umbenennen von benutzerdefinierten Funktionen

Soll die Bezeichnung der Funktion verändert werden, kann man:

  • Punkt Benutzerdefinierte Funktion umbenennen <Objektname> des Kontextmenüs der Gruppe von Datenbankobjekten UDFs auswählen,
  • bzw. die Tastenkombination <Ctrl + R> verwenden.


Benutzerdefinierte Funktion (UDF) löschen

Löschen von benutzerdefinierten Funktionen

Um ein Objekt zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Benutzerdefinierte Funktion löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Prozedur erstellen

Erstellen von Prozeduren

Um eine Prozedur anzulegen, verwendet man:

  • den Punkt Datenbank | Neues Objekt des Programmhauptmenüs. Im Auswahlfenster des Objekttypes muss man Prozedur auswählen,
  • bzw. Kontextmenü des Datenbankobjektes Prozeduren | Punkt Neue Prozedur...,
  • bzw. Tastenkombination <Ctrl + N>.

Die angelegte Prozedur wird automatisch im Prozedureditor geöffnet.

Kopieren von Prozeduren

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um eine Prozedur zu kopieren, muss man den Punkt Prozedur duplizieren<Objektname> im Kontextmenü der Prozedur auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren gleich im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.


Prozedur bearbeiten

Bearbeiten von Prozeduren

Zum Arbeiten mit den Prozeduren im SQL Manager 2007 for MySQL ist ein spezielles Werkzeug - Prozedureditor vorhanden. Um eine Prozedur im Prozedureditor zu öffnen, genügt ein Doppelmausklick auf ein Objekt im DB-Explorer. Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Prozedur bearbeiten <Objektname> auswählt.

Umbenennen von Prozeduren

Soll die Bezeichnung der Prozedur bearbeitet werden, kann man:

  • Punkt des Kontextmenüs der Prozedur Prozedur umbenennen<Objektname> auswählen,
  • bzw. die Tastenkombination <Ctrl + R> verwenden.


Prozedur löschen

Löschen von Prozeduren

Um eine Prozedur zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Prozedur löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Funktion erstellen

Erstellen von Funktionen

Um eine Funktion anzulegen, verwendet man:

  • Punkt Datenbank | Neues Objekt des Programmhauptmenüs. Im Auswahlfenster des Objekttypes muss man Funktion auswählen,
  • bzw. Kontextmenü des Datenbankobjektes Funktionen | Punkt Neue Funktion...,
  • bzw. Tastenkombination <Ctrl + N>.

Die angelegte Funktion wird automatisch im Funktionseditor geöffnet.

Kopieren von Funktionen

Zum Kopieren von Funktionen ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um eine Funktion zu kopieren, muss man den Punkt Funktion duplizieren <Objektname> im Kontextmenü der Funktion auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.


Funktion bearbeiten

Bearbeiten von Funktionen

Zum Arbeiten mit den Prozeduren im SQL Manager 2007 for MySQL gibt es ein spezielles Werkzeug - Funktionseditor. Um eine Prozedur im Funktionseditor zu öffnen, genügt ein Doppelmausklick auf ein Objekt im DB-Explorer. Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Funktion bearbeiten <Objektname> auswählt.

Umbenennen von Funktionen

Wollen Sie die Bezeichnung der Funktion ändern, kann man:

  • Punkt des Kontextmenüs der Funktion Funktion umbenennen <Objektname> auswählen,
  • bzw. die Tastenkombination <Ctrl + R> verwenden.


Funktion löschen

Löschen von Funktionen

Um eine Funktion zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Funktion löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Geplantes Ereignis erstellen

Das geplante Ereignis ist ein Satz von den SQL-Befehlen, das auf dem Server kompiliert und gespeichert werden kann.

Erstellen von geplanten Ereignissen

Um dieses Objekt anzulegen, verwendet man:

  • Punkt Datenbank | Neues Objekt des Hauptmenüprogramms. Im Auswählfenster des Objekttypes muss man Geplantes Ereignis auswählen,
  • bzw.den Punkt Neues geplantes Ereignis im Kontextmenü der Gruppe von Datenbankobjekten Geplante Ereignisse,
  • bzw. die Tastenkombination <Ctrl + N>.

Das angelegte Objekt wird automatisch im Editor der geplanten Ereignisse geöffnet.

Kopieren von Ereignissen

Zum Kopieren von Objekten ist ein spezielles Assistentenprogramm vorhanden, da das Objekt in eine andere Datenbank kopiert werden kann. Um ein geplantes Ereignis zu kopieren, muss man den Punkt Geplantes Ereignis duplizieren <Objektname> im Kontextmenü der Gruppe von Datenbankobjekten Geplante Ereignisse auswählen. Soll das Objekt auf diese Weise kopiert werden, wird der Assistent zum Objektkopieren im 3. Schritt geöffnet, da in den ersten zwei Schritten eine Datenbank und ein Objekt ausgewählt werden, was in diesem Fall nicht nötig ist.


Geplantes Ereignis bearbeiten

Bearbeiten von geplanten Ereignissen

Zum Arbeiten mit den eingeplanten Ereignissen im SQL Manager 2007 for MySQL gibt es ein spezielles Werkzeug: Editor der geplanten Ereignisse.

Um ein Objekt im Editor zu öffnen, genügt ein Doppelmausklick auf ein Objekt im DB-Explorer.

Dies funktioniert auch, indem man den Punkt des Kontextmenüs der Prozedur Geplantes Ereignis bearbeiten <Objektname> auswählt.

Umbenennen von geplanten Ereignissen

Möchten Sie die Bezeichnung des Ereignisses verändern, können Sie:

  • Punkt Geplantes Ereignis umbenennen <Objektname> des Kontextmenüs der Gruppe von Datenbankobjekten Geplante Ereignisse auswählen,
  • bzw. die Tastenkombination <Ctrl + R> verwenden.


Geplantes Ereignis löschen

Löschen von geplanten Ereignissen

Um ein Objekt zu löschen, muss man im DB-Explorer den gewünschten Punkt des Kontextmenüs Geplantes Ereignis löschen <Objektname> auswählen oder die Tastenkombination <Ctrl + Del> benutzen.


Abfrage erstellen

SQL Manager 2007 for MySQL bietet zwei Werkzeuge zum Arbeiten mit SQL-Abfragen an:

  • SQL Editor zum Bearbeiten von Abfragetexten,
  • Visueller Query Builder zum visuellen Erstellen von Abfragen.

Erstellen von Abfragen:

Im Abfrageneditor,

Um dieses Objekt zu erstellen,

  • muss der Punkt Werkzeuge | Neuer SQL Editor des Programm-Hauptmenüs verwendet werden,
  • bzw. man drückt auf die Schaltfläche Neuer SQL Editor [image] auf der Standardleiste der Programmwerkzeuge,
  • bzw. verwendet man die Tastenkombination <Shift+F12>.

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im SQL-Editor geöffnet.

Im visuellen Query Builder.

Um dieses Objekt zu erstellen,

  • muss der Punkt Werkzeuge| Neuer Query Builder des Programm-Hauptmenüs verwendet werden,
  • bzw. man drückt auf die Schaltfläche Neuer Query Builder [image] auf der Standardleiste der Programmwerkzeuge,

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im visuellen Query Builder geöffnet


Abfrage bearbeiten

Bearbeiten von Abfragen:

Im Abfrageneditor,

Um eine zum Bearbeiten erstellte Abfrage zu öffnen,

  • muss der Punkt Werkzeuge| SQL Editor anzeigen des Programm-Hauptmenüs verwendet werden,
  • bzw. man drückt auf die Schaltfläche SQL Editor anzeigen [image] auf der Standardleiste der Programmwerkzeuge,
  • bzw. verwendet man die Tastenkombination <F12>.

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im SQL-Editor geöffnet.

Im visuellen Query Builder.

Um eine zum Bearbeiten erstellte Abfrage zu öffnen,

  • verwendet man den Punkt Werkzeuge | Query Builder anzeigen des Programm-Hauptmenüs,
  • bzw. man drückt auf die Schaltfläche Query Builder anzeigen [image] der Standardleiste der Programmwerkzeuge.

Nach der Ausführung einer diesen Operationen wird die Abfrage automatisch im Visuellen Query-Builder geöffnet.


Abfrage ausführen

Abfrageausführung

Um eine Abfrage in jedem Editor auszuführen, muss man:

  • neue Abfrage erstellen bzw. eine schon bestehende Abfrage öffnen
  • die Schaltfläche Abfrage ausführen auf der Navigationsleiste bzw. auf der Symbolleiste des Editors oder die Schaltfläche F9 anklicken
  • betrachten und erhaltene Daten auf der Registerkarte Ergebnisse bearbeiten.


Abfrage speichern

Speichern von Abfragen

Um eine Abfrage zu speichern, muss man:

  • neue Abfrage erstellen bzw. eine schon bestehende Abfrage öffnen
  • den Punkt Speichern in Datei auf der Navigationsleiste des Abfrageeditors bzw. den Punkt Diagramm speichern auf der Navigationsleiste des Visuellen Query Builder verwenden.
  • in dem erscheinenden Fenster wählt man aus, wo die Datei bzw. der Typ der gespeicherten Datei gespeichert werden soll.

Sollen mehrere Abfragen in einer Datei gespeichert werden, dann drückt man auf Alle speichern auf der Navigationsleiste des Abfrageneditors. Für den Visuellen Query Builder ist eine solche Funktion nicht vorhanden.


Benutzer hinzufügen

Der DB-Benutzer ist ein Hauptobjekt, der den Zugriff auf DB-Objekte verwaltet.

Im Editor für Rechte werden Name, Kennwort und Zugriffsrechte auf DB-Objekte angegeben.

Erstellen von Benutzern

Um einen neuen Benutzer zu erstellen, muss man wie folgt vorgehen:

  • Hauptmenüpunkt des Programms Werkzeuge | Benutzer-Manager auswählen,
  • Benutzer hinzufügen auf einer der Symbolleisten anklicken.

Das erstellte Objekt wird automatisch im jeweiligen Editor geöffnet.


Benutzer bearbeiten

Bearbeiten von Benutzern

Alle Änderungen von Eigenschaften dieses Objektes werden im Logineditor vorgenommen.

Um ein Objekt im Editor zu öffnen, muss man:

  • Benutzer hinzufügen auf einer der Symbolleisten des Benutzer-Manager anklicken (im Editor wird ein markierter Benutzer geöffnet),
  • in der allgemeinen Liste auf das benötigte Objekt doppelklicken.


Benutzer löschen

Löschen von Benutzern

Um ein Login zu löschen, muss man:

  • Befehl Benutzer löschen auf einer der Symbolleisten des Benutzer-Manager auswählen,
  • Punkt Benutzer löschen im Kontextmenü des ausgewählten Objektes auswählen.


Plug-In einrichten

Die Plug-Ins zum Arbeiten mit SQL Manager 2007 for MySQL können mithilfe des Werkzeuges, das beim Auswählen des Punktes Optionen | Plugin-Optionen im Programm-Hauptmenü geöffnet wird, eingestellt werden.

Einrichten von Plug-Ins

Um ein Plug-In hinzuzufügen, muss man:

  • Punkt Optionen | Plugin-Optionen im Programm-Hauptmenü auswählen,
  • im erscheinenden Plugins-Editor die Schaltfläche Hinzufügen anklicken,
  • mithilfe des Standard-Dialogfensters eine Datei mit der Erweiterung *.dll auswählen,
  • OK anklicken, um eine ausgewählte Datei in die Plug-Ins-Liste hinzuzufügen.

Um ein eingerichtetes Plug-In zu starten, muss man im Punkt Plugins | Plugins-Name auswählen.


Plug-In löschen

Löschen von Plug-Ins

Um ein Plug-In zu löschen, muss man:

  • Punkt Optionen | Plugin-Optionen im Programm-Hauptmenü auswählen,
  • im erscheinenden Plugins-Editor das gewünschte Programm auswählen,
  • Schaltfläche Löschen anklicken.


Externes Tool hinzufügen

Um noch effizienter mit dem SQL Manager 2007 for MySQL arbeiten zu können, kann man eine Anzahl von externen Tools hinzufügen.

Hinzufügen von externen Tools

Um ein anderes Programm hinzuzufügen, muss man:

  • Punkt Optionen | Externes Tool im Programm-Hauptmenü auswählen,
  • im erscheinenden Fenster von externen Tools die Schaltfläche Hinzufügen anklicken,
  • im Dialogfenster Verbindungsparameter angeben,
  • OK anklicken, um alle eingetragenen Änderungen abzuspeichern.

Diese Reihenfolge der Aktionen hilft Ihnen das angegebene Programm in die Liste der externen Tools hinzuzufügen.

Das in die Liste hinzugefügte Programm kann mithilfe des SQL Manager 2007 for MySQL gestartet werden, nachdem dies aus dem Menü Tools | Externes Tool.. ausgewählt wurde.


Externes Tool löschen

Löschen von externen Tools

Um das Programm aus der Liste der externen Tools zu löschen, muss man:

  • Punkt Optionen | Externes Tool im Programm-Hauptmenü auswählen,
  • im erscheinenden Fenster von externen Tools ein erforderliches Programm auswählen,
  • Schaltfläche Löschen anklicken.


Programmsprache ändern

Der SQL Manager 2007 for MySQL ermöglicht, die Sprachen der Bedienungsoberfläche anzupassen.

Änderung der Programmsprache

Um eine Programmsprache zu ändern, muss man wie folgt vorgehen:

  • im Programm-Hauptmenü den Punkt Optionen | Sprache wählen auswählen,
  • erforderliche Sprache der Bedienungsoberfläche im Fenster zum Auswählen der Programmsprache auswählen,
  • OK anklicken, um Änderungen abzuspeichern.


Erstellung der Lokalisierung

Erstellung einer neuen Lokalisierung

Um eine neue Lokalisierung zu erstellen, muss man:

  • neue Lokalisierungsdatei mit der Erweiterung *.lng erstellen und diese in den Ordner Languages ins Verzeichnis, in dem der SQL Manager 2007 for MySQL installiert ist, platzieren,
  • im Hauptmenü des Programms den Punkt Optionen | Umgebungsoptionen auswählen
  • Registerkarte Umgebungsoptionen | Lokalisierung öffnen,
  • unter dieser Registerkarte die Schaltfläche Hinzufügen anklicken,
  • im erscheinenden Fenster im Feld Sprachname den Namen dieser neuen Lokalisierung und im Feld Sprachdatei den Pfad zur erstellten Datei mit der *.lng Erweiterung angeben,
  • nach dem Klicken auf die Schaltfläche OK erscheint in der Lokalisierungs-Liste eine neue Sprache, die bearbeitet und als Programmsprache installiert werden kann.


Programmoberfläche

Die allgemeinen Besonderheiten der Oberfläche des SQL Manager 2007 for MySQL sind:

Teiler

Die Teiler sind partitive Linien zwischen den Fenstern, zum schnellen Minimieren und Maximieren von Fenstern.

Um das Fenster zu minimieren, muss der Teiler mit der linken Maustaste angeklickt werden.

Die Einstellung der Ansicht und der Aktionen kann auf der Registerkarte Teiler im Fenster Ansichtsoptionen geändert werden.

Navigationsleisten

Die Navigationsleisten können zur komfortablen Arbeit reduziert werden.

Um einen der Abschnitte der Navigationsleiste zu minimieren, muss die Schaltfläche in der Nähe der Abschnittsbeschriftung angeklickt werden.

Die minimierte Leiste kann beim Klicken derselben Schaltfläche maximiert werden.

Sortierung

Wenn sich auf dem Formular eine Tabelle aus einer bzw. mehreren Spalten befindet, kann sie beim Klicken auf die Spaltenbeschriftung nach einer Spalte sortiert werden. In diesem Fall erscheint neben der Spaltenbeschriftung ein Dreieck.

  • Beim ersten Klick werden die Werte aufsteigend sortiert.
  • Beim Klicken auf die Beschriftung einer Spalte, die aufsteigend sortiert ist, werden die Daten in der Spalte absteigend sortiert.
  • Beim dritten Klick ist die Sortierung weg.

Standardschaltflächen

Die Standardschaltflächen, die das Dialogfenster zum Auswählen von Dateien öffnen, sind:


Einstellen von Symbolleisten

Jede Symbolleiste kann angepasst werden.

Die Symbolleiste kann man einstellen, wenn man die Funktion Add or Remove Buttons verwendet, die beim Klicken auf die Schaltfläche More Buttons [image] in der rechten Ecke der Leiste geöffnet wird.

Im erschienenen Fenster werden die für Ihre Arbeit erforderlichen Schaltflächen ausgewählt,

wenn man eine beliebige Leiste mit der rechten Maustaste anklickt und den Punkt Customize auswählt.

Wenn man die Symbolleiste mit der rechten Maustaste anklickt, erscheint auch die Schaltfläche Customize.

Beim Betätigen dieser Schaltfläche wird das Fenster zum Bearbeiten der Symbolleiste geöffnet.

Registerkarte Toolbars:

Unter dieser Registerkarte können die Symbolleisten erstellt, bearbeiten und gelöscht werden.

New - Symbolleiste hinzufügen,

Rename - Umbenennen,

Delete - Löschen.

Registerkarte Commands:

Unter dieser Registerkarte werden die auf der Symbolleiste anzuzeigenden Schaltflächen ausgewählt.

In der Liste Categories werden Kategorien ausgewählt. In der Liste Commands werden Befehle für die ausgewählten Kategorien ausgewählt.

Um eine erforderliche Schaltfläche auf die Leiste zu bringen, muss diese aus der Liste Commands zur Symbolleiste verschoben werden.

Registerkarte Option:

  • Menus show recently used command first - Menü mit zuletzt verwendeten Befehlen anzeigen,
  • Show full menus after a short delay - Vollständige Menüs nach einer kurzen Verzögerung anzeigen,
  • Reset my usage data - Meine Nutzungsdaten zurücksetzen,
  • Large icons - Große Symbole,
  • Show ToolTips on Toolbars - Auf den Symbolleisten Quickinfo anzeigen,
  • Show shortcut keys in ToolTips - Tastenkombinationen in Quickinfo anzeigen,
  • Menu animations - Menüanimationen.


Vorlagen

Im SQL Manager 2007 for MySQL ist für einige Operationen die Möglichkeit zum Speichern von Reihenfolgen der Aktionen und Parameter in den speziellen Dateien vorhanden. Diese Dateien werden als Vorlage bezeichnet und in den Assistentenprogrammen verwendet, z.B. im Assistenten zum Import und Export von Daten und in weiteren Assistenten.

Wenn sich im Assistenten in der linken unteren Ecke die Schaltfläche [image] befindet, können alle mithilfe des Assistenten angegebenen Parameter in eine Datei mit dem jeweiligen Format gespeichert werden. Jeder Assistent hat ein spezielles Vorlageformat. Dies vermeidet die Fehler beim Öffnen von Vorlagen in einem anderen Assistenten.

Beim Betätigen der Schaltfläche [image] wird die Aktionsliste geöffnet.

Mithilfe dieser Liste kann man:

  • Vorlage laden - Load Template,
  • Vorlage speichern - Save Template,
  • Aktuelle Einstellungen als Standardeinstellungen speichern - Save Current Settings As Default,
  • Gespeicherte Einstellungen zurücksetzen - Reset Saved settings.

Die Vorlage kann in jedem Schritt des Assistentenprogramms gespeichert und geladen werden.


Parameter von SSH-Tunneling

Das SSH (Secure Shell Host) Protokoll wird verwendet, um die Computer-Sicherheit unter einem Unix System im Internet zu erhöhen. SSH benutzt verschiedene Verschlüsselungsalorythmen mit unterschiedlichen Sicherheitsstufen. Die Spannweite des SSH steht auch in Verbindung mit der Tatsache, dass einige Linux-like BS's (z.B. FreeBSD) den SSH Server in ihr Standard-Angebot integrieren. Um zu diesem Thema mehr zu erfahren, sehen Sie bitte unter http://openssh.org nach. Das SSH Tunneling des SQL Manager bedeutet eine sichere Verbindung zum MySQl Server, wenn über unsichere Verbindungskanäle gearbeitet wird. Sie können den SSH Tunnel auch so benutzen, um eine Verbindung zum MySQL Remote Host zu bekommen, auch wenn der Port 3306 aus irgendwelchen Gründen für externe Verbindungen geschlossen ist. Die Verbindung über den SSH Tunnel arbeitet folgendermaßen: Als erstes wird eine Verbindung zwischen dem SSH Client des SQL Manager und dem Remote MySQL Server hergestellt, danach erfolgt eine Authentifizierung. Dann werden alle ein-/und ausgehenden Informationen zwischen den Programmen und dem MySQL Server durch den SSH Server mit Hilfe des Kommunikationsports (gewöhnlich ist es 22) versendet und der SSH Server leitet die Information direkt an den MySQL Server weiter. Um eine Datenbank zu registrieren, die über den SSH Tunnel verbunden ist, müssen Sie folgende Parameter im Datenbank Registrations-Wizard des SQL Manager for MySQL einstellen:

Beim ersten Schritt:

Host ist der Host bei dem der MySQL Server als HTTP Server fungiert. Wenn sich der SSH und MySQL Server auf der gleichen Maschine befinden, kann es der SSH Host oder auch der 'localhost' sein.

Port ist ein Port des MySQL Servers auf dem Remote Host, normalerweise ist es 3306.

Benutzername ist ein MySQL Username.

Passwort ist das Passwort des MySQL Users. Bitte beachten Sie, dass der MySQL Hostname in diesem Falle relativ zum SSH Server gesetzt werden muss. Zum Beispiel, wenn beide, also MySQL Server und SSH Server sich auf dem gleichen Computer befinden, müssen Sie localhost als Hostname anstatt des Server's externe Hostname oder IP Adresse spezifizieren. Bitte nicht vergessen, Tunneling Nutzen und SSH Tunneling zu wählen.

Beim zweiten Schritt:

SSH Hostname ist ein Host bei dem der SSH Server aktiviert ist.

SSH Port ist ein Port bei dem der SSH Server aktiviert ist.

SSH User Name ist ein User auf der Linux Maschine. (Es ist ein Linux User. Es ist kein User vom MySQL Server.)

SSH Passwort ist ein Linux User Passwort.

Um eine richtige SSH Verbindung zu erstellen, sollten folgende Werte eingegeben werden

Unter der Registerkarte SSH

SSH Host ist ein Host, bei dem der SSH Server aktiviert ist.

Port ist der Port, bei dem der SSH Server aktiviert ist.

SSH User Name ist ein User auf der Linux Maschine. (Es ist ein Linux User. Es ist kein MySQL Server User.)

Password ist ein Linux User Passwort

Unter der Registerkarte Verbindungseigenschaften/Allgemeine Seite:

Host ist der Host, bei dem der MySQL Server als SSH Server fungiert. Wenn sich der SSH und MySQL Server auf der gleichen Maschine befinden, kann es der SSH Host oder auch der 'localhost' sein.

Port ist ein Port des MySQL Servers auf dem Remote Host. Standardmäßig ist es 3306.

User name ist ein MySQL Benutzername.

Passwort ist ein Kennwort des MySQL Benutzers


Parameter von HTTP-Tunneling

HTTP Tunneling ist eine Methode, die es ermöglicht, Verbindungen herzustellen und Daten zwischen der Anwendung und dem MySQL Server über das HTTP/HTTPS Protokoll und dem Port 80, der von einem regulären Internetbrowser verwendet wird, zu senden. Diese Methode wird eingesetzt, um die Remote Verbindung zum MySQL Server einer Hosting Firma herzustellen, wenn eine direkte Verbindung aus Sicherheitsgründen nicht möglich ist. Der HTTP Tunnel arbeitet auf folgende Weise: Alle von der Client-Software gesendete, ausgehende Abfragen und Kommandos werden verschlüsselt und über das HTTP/HTTPS Protokoll, das den Port 80 nutzt, zu einem spezielles Skript verschickt, welches wiederum die empfangenen Daten entschlüsselt und diese dem verarbeitenden MySQL Server sendet und das Ergebnis zurücksendet. Diese Methode setzt den HTTP Server (Apache) und PHP mit MySQL auf dem Remoteserver voraus. Normalerweise werden diese Softwarepakete vom Hosting Provider gestellt, der auch den Linux Host zur Verfügung stellt. Darüber hinaus müssen Sie auch das spezielle emsproxy.php Skript auf Ihren Webserver hochladen um den Remotezugriff zu gewährleisten (Sie können es unter dem gleichen Verzeichnis wie Ihre anderen PHP Skripte ablegen). Wenn Ihr Webserver mit den Anforderungen übereinstimmt und das Skript richtig installiert wurde, sehen Sie die Meldung "EmsProxy v 1.31" (die Versionsnummer kann auch unterschiedlich sein) in Ihrem Browser wenn Sie die http:///emsproxy.php Seite öffnen. Wenn Sie eine Remote Datenbank registrieren, die über den HTTP Tunnel angesprochen wird, müssen Sie folgende Parameter in den Datenbank Registrations Wizard des SQL Manager for MySQL eingeben:

im ersten Schritt:

Host ist der Host bei dem der MySQL Server als HTTP Server fungiert. Gewöhnlich sind HTTP und MySQL Server auf der gleichen Maschine und es ist 'localhost'.

Port ist der Port des MySQL Servers im Remote Host, gewöhnlich ist es 3306.

Benutzername ist ein MySQL Username.

Passwort ist das Kennwort des MySQL Users. Aktivieren Sie Tunneling & HTTP Tunneling

im zweiten Schritt: URL ist eine Adresse des emsproxy.php Skriptes (z.B. http:///emsproxy.php).


Eingabe von Datenformaten

Die Datenformate bestimmen die Darstellung von unterschiedlichen Datentypen.

Formate Float/Integer (zu dt.: Gleitkommazahl/Ganzzahl)

0 | Zahlen von 0 bis 9
# | Ziffernzeichen
. | Dezimalzeichen
, | Trenner von Ziffergruppen
E+ | Exponentieller Wert

Formate Date/Time format (zu dt.: Datum-/Zeitformat)

Mithilfe der nachstehenden Befehlen kann man angeben, welchen Teil des Datums und in welcher Darstellungsart er anzuzeigen ist.

c | Identisch mit dem vordefinierten Format des Standarddatums.
d | Tag des Monats mit ggf. einer oder zwei numerischen Ziffern (1 bis 31).
dd | Tag des Monats mit zwei numerischen Ziffern (01 bis 31).
ddd | Die ersten drei Buchstaben des Wochentags (So bis Sam).
dddd | Vollständiger Name des Wochentags (Sonntag bis Samstag).
ddddd | Identisch mit dem vordefinierten Datum Datum, kurz.
dddddd | Identisch mit dem vordefinierten Datum Datum, lang.
m | Monat des Jahres in ggf. einer oder zwei numerischen Ziffern (1 bis 12).
mm | Monat des Jahres in zwei numerischen Ziffern (01 bis 12).
mmm | Die ersten drei Buchstaben des Monats (Jan bis Dez).
mmmm | Vollständiger Name des Monats (Januar bis Dezember).
yy | Die letzten zwei Ziffern des Jahres (01 bis 99).
yyyy | Vollständiges Jahr (0100 bis 9999).
h | Stunde mit ggf. einer oder zwei Ziffern (0 bis 23).
hh | Stunde mit zwei Ziffern (00 bis 23).
n | Minute mit ggf. einer oder zwei Ziffern (0 bis 59).
nn | Minute mit zwei Ziffern (00 bis 59).
s | Sekunde mit ggf. einer oder zwei Ziffern (0 bis 59).
ss | Sekunde mit zwei Ziffern (00 bis 59).
z | Millisekunde mit ggf. einer oder drei Ziffern (0-999).
zzz | Millisekunde mit drei Ziffern (0-999).
t | 24-Stunden-Zeitformat
tt | Langes Zeitformat
a/p | Uhrzeit im 12-Stunden-Format mit ggf. den Kleinbuchstaben "a" oder "p".
am/pm | Uhrzeit im 12-Stunden-Format mit ggf. den Kleinbuchstaben "am" oder "pm".
/ | Datenaufteilung (mm/dd/yy).
: | Trennzeichen für die Uhrzeit (hh:mm).
'xx'/"xx" | Die Zeichen mit solchen Anführungsstrichen werden nicht formatiert.


Speicher-Engine

Die Speicher-Engine wird beim Erstellen von Tabellen auf der Registerkarte Eigenschaften des Tabelleneditors angegeben.

MyISAM

MyISAM ist die Standard-Speicher-Engine. Sie baut auf dem älteren ISAM-Code auf, hat aber viele praktische Erweiterungen.

MyISAM zeichnet sich durch hohe Effizienz im Vergleich zu anderen von MySQL unterstützten Tabellentypen aus und unterstützt seit Version 3.23. von MySQL eine leistungsfähige Volltextsuche und eine große Anzahl an nützlichen Erweiterungen.

InnoDB

Mit InnoDB verfügt MySQL über eine transaktionssichere (ACID-konforme) Speicher-Engine mit Commit-, Rollback- und Datenwiederherstellungsfähigkeiten. InnoDB beherrscht sowohl Zeilensperren als auch, ähnlich wie Oracle, eine konsistente Leseoperation ohne Sperren für SELECT-Anweisungen. Diese Features verbessern die Mehrbenutzertauglichkeit und die Leistung. InnoDB benötigt keine Sperreneskalation da Zeilensperren sehr wenig Platz beanspruchen. InnoDB wurde für maximale Leistung bei der Verarbeitung großer Datenmengen ausgelegt. Es gibt wohl keine andere festplattengestützte Speicher-Engine für relationale Datenbanken, die so effizient mit der CPU umgeht.

Berkeley_db

Die Verwendung von BerkeleyDB erhöht die Chance im Falle des Absturzes von Tabellen, die Tabellendaten nicht zu verlieren. Des Weiteren ermöglicht dies, die Anweisungen COMMIT und ROLLBACK für Transaktionen auszuführen. Die Distribution des MySQL-Quellcodes wird mit BDB-Distribution, die einige kleine Korrekturen beinhaltet, mitgeliefert, die zur bestimmten Fehlerbehebung beim Arbeiten mit MySQL verhelfen. Nicht korrigierte BDB-Versionen können beim Arbeiten mit MySQL nicht verwendet werden.

ISAM

In den ISAM-Tabellen wird der B-tree-Index eingesetzt. Der Index wird in der Datei mit .ISM Erweiterung und die Daten werden in der Datei mit .ISD Erweiterung gespeichert. Die ISAM-Tabellen können mithilfe des Utilites isamchk überprüft bzw. wiederhergestellt werden.

HEAP

Bei den HEAP-Tabellen werden Hash-Indizes verwendet. Diese Tabelle wird im Speicher abgelagert. Dadurch werden sie sehr schnell bearbeitet, obwohl beim MySQL-Absturz alle Tabellendaten verloren gehen. Aus diesen Gründen passt der HEAP-Typ hervorragend für temporäre Tabellen! Die Tabellen verwenden 100% dynamisches Hashing für Einfügeoperationen. Es werden keine Overflow-Bereiche und kein zusätzlicher Platz für Schlüssel oder für Freelists benötigt. Bei Verwendung von HEAP-Tabellen gibt es keine Probleme mit den Befehlen zum Löschen und Einfügen, die oft in Hash-Tabellen verwendet werden:

MRG_MyISAM

Eine MERGE-Tabelle, auch bekannt als MRG_MyISAM, ist eine Sammlung identischer MyISAM-Tabellen, die als eine einzige Tabelle verwendet werden können. Mit MERGE-Tabellen können Sie die Anweisungen SELECT, DELETE, UPDATE und INSERT verwenden. Wenn Sie die MERGE-Tabelle mit DROP löschen, löschen Sie damit nur die MERGE-Spezifikation. Die zugrunde liegenden Tabellen sind davon nicht betroffen.

GEMINI

Das ist ein Tabellentyp, der vom Unternehmen NuSphere entwickelt wurde. Zurzeit wird dies von den aktuellen MySQL-Versionen nicht unterstützt.

FEDERATED

In MySQL 5.0 können Tabellen auf dem entfernten Server, als ob sie lokal sind, verwenden. In diesem Fall sind keine Transaktionen vorhanden.


Vereinigte Taballen

Das Dialogfenster Union Tables List ermöglicht, die Liste der vereinigten Tabellen zu verwalten. Dieses Fenster kann man beim Bearbeiten von Tabelleneigenschaften im Tabelleneditor auf der Registerkarte Tabelleneigenschaften öffnen.

Mithilfe der Schaltfläche Add kann eine Tabelle in die Liste hinzugefügt werden.

Beim Betätigen der Schaltfläche Replace kann die Tabelle in der allgemeinen Liste durch die in der Dropdownliste ausgewählte Tabelle ersetzt werden.

Beim Klicken auf die Schaltfläche Delete wird das Programm aus der Liste gelöscht.

Um die Reihenfolge von Programmen in der Liste zu ändern, muss man die Schaltflächen Up/Down bzw. die Tastenkombination Shift+Ctrl+Up / Shift+Ctrl+Down verwenden. Die Objekte können auch mit der Maus verschoben werden.


Verbindung zu entfernten Tabellen

In MySQL 5.0 kann man die Tabellen, die sich auf dem entfernten Server befinden, als lokale Tabellen verwenden.

Dies läuft natürlich mit einigen Einschränkungen, z.B. wenn keine Transaktionen vorhanden sind. Dafür ist aber JOIN vorhanden. Dieses Features ist seit MySQL 5 möglich. Es unterstützt die Tabelle, die sich physisch auf einem entfernten MySQL-Server befindet, d.h. man kann auf eine entfernte Tabelle, so als wäre sie lokal, zugreifen.

Um eine entfernte Tabelle zu verbinden, muss man folgende Parameter einstellen:

Host name ist der Hostname, auf dem sich die erforderliche Tabelle befindet. In der Liste werden die registrierten Server angezeigt. Um ein Server zu registrieren, muss der Assistent zur Hostregistrierung verwendet werden.

Port ist der Port des MySQL Servers, standardmäßig ist es 3306.

In den Optionsfeldern User name и Password muss ein Benutzername und ein Kennwort angegeben werden.

Aus der Liste Database name wird eine erforderliche Datenbank ausgewählt. Die Tabelle Table name enthält die Tabellen der angegebenen Datenbank. Daraus muss man eine benötigte Datenbank auswählen.