Добро пожаловать в EMS SQL Studio!

SQL Management Studio for SQL Server – это законченное решение для администрирования и разработки баз данных. Для разработчиков приложений или баз данных, администраторов или аналитиков, в SQL Studio найдутся все необходимые средства, чтобы сделать вашу работу продуктивной как никогда ранее. SQL Studio соединяет эти средства в единую мощную и удобную рабочую среду.

SQL Studio предоставляет незаменимые средства для администрирования баз данных и управления их объектами, а также для миграции, сравнения и извлечения баз данных, импорта, экспорта и сравнения данных.

Подробную информацию можно найти по адресу: http://www.sqlmanager.net/ru/

Документация на других языках доступна по адресу: http://www.sqlmanager.net/products/studio/mssql/downloads

Особенности:

  • Удобный запуск утилит и сервисов
  • Хранение шаблонов в едином репозитории
  • Единый список источников данных для всех сервисов и утилит
  • Создание сложных разветвленных сценариев
  • Возможность выполнения внешних приложений из сценариев
  • Хранение журналов выполнения всех сценариев в единой базе данных
  • Выполнение сценариев по расписанию
  • Создание настраиваемых уведомлений; их рассылка различными способами
  • Быстрый доступ к службе технической поддержки
  • Единый способ настройки внешнего вида всех приложений

Преимущества:

  • Быстрый запуск любых задач позволяет сосредоточиться на результате
  • Единое место хранения шаблонов упрощает работу с утилитами
  • Гибкие сценарии экономят массу времени, выполняя рутинную работу за вас
  • Выполнение сценариев по расписанию автоматизирует повседневную работу
  • Отправка уведомлений позволяет оперативно отреагировать в случае возникновения непредвиденных ситуаций
  • Сохранение логов выполнения всех операций обеспечивает полный контроль
  • Единый способ настройки стиля интерфейса всех продуктов добавит комфорт в работе

Информация о продукте:

Домашняя страница: | http://www.sqlmanager.net/ru/products/studio/mssql
Центр технической поддержки: | http://www.sqlmanager.net/ru/support
Онлайн регистрация: | http://www.sqlmanager.net/ru/products/studio/mssql/buy


Что нового

SQL Management Studio for SQL Server
  • В начало
  • « Назад
  • Вперед »

Что нового?

Версия | Дата выхода
SQL Management Studio for SQL Server 1.3 | 6 августа 2015

Что нового в SQL Management Studio for SQL Server?

  • Новые сервисы Check Database, Indices Management, Shrink Database и Update Statistics в SQL Management Studio for SQL Server.
  • Добавлена возможность "тихой" установки.
  • Исправлена проблема установки программы на диски, имеющие более 2Тб свободного места.
  • Папки для логов по умолчанию теперь задаются в профиле пользователя.
  • Исправлена отправка сетевых уведомлений (NetSend) для ОС Windows Vista и новее.
  • При выполнении задач, генерирующих большой объем логов, процесс агента SQL Studio загружал CPU на 100%. Исправлено.
  • Корректная остановка запущенных процессов при обновлении.
  • Исправлена кодировка логов утилит при включенной локализации.
  • Другие улучшения и исправления.

Смотрите также:

История версий


Требования к системе

Системные требования для SQL Management Studio for SQL Server

  • Процессор с тактовой частотой 300 мегагерц (МГц); рекомендуется 600 МГц или выше
  • Microsoft Windows NT4 с SP4 или более поздней версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows 2008 Server, Microsoft Windows Vista, Microsoft Windows 7
  • 64 Мб RAM (рекомендуется 128 Мб или более)
  • 50Мб свободного пространства на жестком диске для установки программы
  • Видео-карта Super VGA и монитор с минимальным разрешением 800x600 (рекомендуется Super VGA с разрешением 1024x768 или выше)
  • Cовместимая c Windows мышь
  • Microsoft Data Access Components (MDAC) или SQL Server Native Client
  • Возможность соединения с локальным или удаленным SQL Server™


Установка

Для первичной установки SQL Studio вам необходимо:

  • загрузите установочный файл программы со страницы загрузки,
  • полученный файл извлеките из архива в нужную директорию (например, c:\unzipped),
  • запустить msstudio.msi и следовать инструкциям мастера установки;
  • после завершения установки найдите в соответствующем разделе меню "Пуск" ярлык SQL Studio, чтобы запустить SQL Management Studio for SQL Server;

Если требуется обновить установленную копию SQL Studio до последней версии, то необходимо:

  • загрузите установочный файл программы со страницы загрузки,
  • распаковать его в любую локальную директорию, например C:\unzipped;
  • закрыть запущенные приложения SQL Studio;
  • запустить msstudio.msi и следовать инструкциям мастера обновления.

В ходе установки будет предложено установить SQL Studio как приложение или как службу.

Если SQL Studio установлена как служба, то для ее работы используется существующая учетная запись, указанная в ходе установки, даже если для входа в Windows использовалась другая.

Чтобы использовать учетную запись доменного пользователя для запуска службы, необходимо указать имя пользователя в формате: DOMAIN_NAME\USER_NAME.

Важно: Запуск SQL Studio должен осуществляться под учетной записью пользователя, указанной при установке SQL Studio как службы. В противном случае, работа SQL Studio не будет корректной.

Чтобы установить программу в silent mode как приложение, нужно выполнить команду:

msiexec.exe /i /quiet xxstudio.msi

Чтобы установить программу как службу, выполните:

msiexec.exe /i /quiet xxstudio.msi SERVICE_INSTALL=1 SERVICE_USERNAME="computer_name\user_name" SERVICE_PASSWORD="password"

Помните, что имя пользователя в этом случае должно быть указано с указанием домена или имени компьютера, как указано в примере. Также можно использовать формат: ".\user_name".

Смотрите также:

Требования к системе


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Share-it!. Процедура совершения покупки через Share-it! защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернет и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией Share-it!.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery). Сделав заказ, Вы сможете немедленно скачать регистрационные ключи или пароли и ссылки на архивы полных версий программ. Также Вы получите копию регистрационных ключей или паролей по электронной почте.

Если при оформлении не получили регистрационный ключ в течение двух часов, обратитесь в службу поддержки по этому адресу sales@sqlmanager.net.

Если Вы являетесь зарегистрированным пользователем, то при возникновении проблем или вопросов при использовании нашего программного обеспечения обращайтесь в службу поддержки.

Чтобы получить более подробную информацию по SQL Management Studio for SQL Server перейдите по ссылке: http://sqlmanager.net/ru/products/studio/mssql

Product distribution | Share It!
SQL Management Studio for SQL Server (Бизнес версия) + 1 год Сопровождения* | Купить!
SQL Management Studio for SQL Server (Бизнес версия) + 2 года Сопровождения*
SQL Management Studio for SQL Server (Бизнес версия) + 3 года Сопровождения*
SQL Management Studio for SQL Server (Некоммерческая версия) + 1 год Сопровождения*
SQL Management Studio for SQL Server (Некоммерческая версия) + 2 года Сопровождения*
SQL Management Studio for SQL Server (Некоммерческая версия) + 3 года Сопровождения*
SQL Management Studio for SQL Server (Пробная версия) | Скачать

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Подробнее об услуге сопровождения читайте на странице http://sqlmanager.net/ru/support/faq/maintenance

Смотрите также:

Регистрация


Регистрация

Для установленной SQL Management Studio for SQL Server предоставляется 30 дней для оценки продукта. Пробная версия является полностью функциональной, с некоторыми незначительными ограничениями. Все время оценочного периода диалог, показанный ниже, будет отображаться при запуске программы.

Welcome to SQL Studio - Unregistered copy

После окончания пробного периода Вы не сможете более пользоваться программой. Последующее использование копии SQL Management Studio for SQL Server будет доступно после ее приобретения и регистрации.

Регистрация

Чтобы зарегистрировать приобретенную копию SQL Management Studio for SQL Server, необходимо выполнить следующие действия:

  • От службы Share-it! получить извещение, содержащее регистрационную информацию.
  • в диалоговом окне Register SQL Management Studio for SQL Server ввести Регистрационное имя и Регистрационный ключ в поля Registration Name и Registration Key соответственно. Это окно открывается при выборе в главном меню пункта Help | Enter registration key. Также можно зарегистрировать копию SQL Management Studio for SQL Server выбрав пункт меню Help | About и нажав на кнопку Register Now в открывшемся диалоговом окне.

Welcome to SQL Studio - Register product

В диалоговом окне About SQL Management Studio for SQL Server, открывающемся при выборе в главном меню понкта Help | About, можно проверить правильность регистрационных данных.

Welcome to SQL Studio - About

Сопровождение

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов.
  • Консультации по вопросам работы ПО.
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО.
  • Доступ к персональной учетной записи клиента EMS.
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн.
  • Эксклюзивные заблаговременные уведомления о специальных предложениях.
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

В случае, когда Вы приобрели продукт в комплекте с подпиской на Сопровождение, подписка будет автоматически активирована после ввода регистрационного ключа в регистрационный диалог Вашей программы. Если же Вы приобрели подписку на Сопровождение отдельно, просто откройте регистрационный диалог Вашей программы и введите полученные Вами регистрационное имя и ключ.

После введения правильного регистрационного ключа появляется информационное окно сообщающее о том, что Вы теперь имеете право пользоваться программой.

За пять дней до окончания срока сопровождения, в стартовом окне появляется строка состояния, указывающая, какое количество дней осталось до истечения срока сопровождения.

Подробнее о поддержке читайте на сайте. http://www.sqlmanager.net/ru/support/faq/maintenance


История версий

Версия | Дата выхода
Версия 1.2 | 4 декабря 2008
Версия 1.1 | 12 декабря 2007
Версия 1.0 | 18 октября 2006

Полная история версий доступна по ссылке: http://www.sqlmanager.net/ru/products/studio/mssql/news

Версия 1.2

  • Планировщик задач теперь может быть запущен как Служба или как приложение.
  • Если задача выполняется вручную, то процесс ее выполнения можно отследить в специальном окне.
  • В предыдущих версиях программы настройки панелей инструментов сбрасывались по завершении программы. Исправлено.
  • Документацию в PDF формате теперь можно открыть из главного меню.
  • Другие различные улучшения и исправления.

Версия 1.1

  • Планировщик. Добавилась возможность планировать выполнение задач несколько раз в день.
  • Теперь можно запустить любой инструмент SQL Studio через контекстное меню Агента, расположенного на панели задач.
  • При попытке вызвать утилиту с не принадлежащим ей шаблоном теперь выводится или записывается в журнал соответствующее сообщение.
  • SQL Query теперь может использовать общий с SQL Studio репозиторий баз данных.
  • Усовершенствована процедура обновления через SQL Studio Direct: при скачивании обновления теперь показывается прогресс загрузки; при попытке установить обновление, которое недоступно по причине истекшего срока сопровождения, теперь выдается соответствующее предупреждение.
  • Исправлена ошибка, возникающая при попытке удалить единственный шаг в задаче.
  • Выбор схемы в Опциях отображения теперь применяется ко всем компонентам студии.
  • Добавление и удаление баз данных, сделанное в SQL Manager, не отражалось в Проводнике БД запущенной SQL Studio. Исправлено.
  • Исправлен ряд артефактов при работе с двумя мониторами.
  • При запуске SQL Studio под пользователем с ограниченными правами при выключенном Агенте происходила ошибка запуска Агента. Исправлено.
  • Ускорено открытие раздела “Управление шаблонами” при наличии большого списка шаблонов.
  • Позиция окна SQL Studio теперь восстанавливается при следующем сеансе работы.
  • При работе с Windows 2003 Server запуск задачи вызывал ошибку "Tool path is not correct". Исправлено.
  • Добавлен запрос подтверждения при удалении шага в задаче.
  • Прочие улучшения и исправления.

Версия 1.0

Ключевые свойства:

  • Удобный запуск утилит и сервисов
  • Хранение всех шаблонов в одном репозитории
  • Единый список источников данных для всех сервисов и утилит
  • Создание сложных задач и их автоматизированное выполнение
  • Возможность запуска внешних приложений в задачах
  • Хранение журналов выполнения всех задач в единой базе данных
  • Создание настраиваемых уведомлений; их рассылка различными способами
  • Возможность установить единый визуальный стиль для всех приложений
  • Быстрый доступ к службе технической поддержки

Преимущества:

  • Минимальное время, требуемое для запуска задач
  • Единый репозиторий всех баз данных значительно облегчает работу с утилитами
  • Значительная экономия времени благодаря возможности создавать разнообразные задачи для выполнения рутинной работы
  • Планировщик поможет автоматизировать повседневные задачи
  • Электронные уведомления позволят вам контролировать и оперативно реагировать на выполнение всех задач
  • Все журналы хранятся в отдельной закладке, что позволяет вам быть в курсе всех выполненных операций
  • Единый настраиваемый графический интерфейс для всех приложений

Смотрите также:

Что нового


Часто задаваемые вопросы по SQL Studio

Пожалуйста внимательно прочтите эту страницу, если у Вас возникли вопросы по EMS SQL Management Studio for SQL Server.

Содержание

Что такое STUDIO

  • Что такое EMS SQL Management Studio?
  • STUDIO содержит очень много возможностей, но буду ли я их использовать? Нет ли более простого продукта?
  • Что мне необходимо для начала работы с STUDIO?
  • Многие утилиты, входящие в STUDIO, вы продаете отдельно. В чем преимущество покупки их в составе STUDIO?

Регистрация баз данных и подключение

  • Могу ли я работать с несколькими базами данных одновременно?
  • Как соединиться с именованным экземпляром с помощью SQL Manager for SQL Server?
  • При соединении с SQL Server я получаю ошибку "SQL Server does not exist or access denied". В чем причина?
  • Как переустановить Microsoft Data Access Components (MDAC)?
  • Я получаю доступ к своему серверу через альтернативный порт. Я пытался найти в SQL Manager for SQL Server опцию, чтобы изменить порт для соединения, но безрезультатно. Как я могу изменить порт?
  • Моя рабочая станция подключена в сеть через файервол (роутер). Могу ли я использовать СТУДИЮ для управления удаленным SQL Server сервером?

Управление объектами

  • Какие объекты базы данных будут доступны мне при работе в STUDIO?
  • У меня в таблице более миллиона записей, однако в сетке данных отображаются только 1000. В чем проблема?
  • Как повысить скорость работы с большими таблицами?
  • Какие действия я могу выполнять с объектами базы данных?
  • При создании таблицы с именем `TestTable` она сохраняется как`testtable`. Это неправильно!
  • Как я могу настроить форматы данных в сетке?
  • Моя база данных имеет кодировку "Greek". В сетке данных все данные отображаются как «?????????». В чем ошибка?
  • Я не могу изменить DDL. Почему?

Запросы

  • Я новичок в SQL Server. Я плохо строю SQL-запросы. Есть ли в STUDIO визуальный конструктор запросов, как в MS ACCESS?
  • Могу ли я использовать визуальный конструктор запросов STUDIO для создания сложных запросов (включая составные и вложенные)?
  • Могу ли я сохранить созданный запрос для будущего использования?
  • Могу ли я выполнить запрос из командной строки?
  • Могу ли я сохранить результат выполнения запроса в csv или xls файле?

Конструктор отчетов

  • Как я могу создать отчет?
  • Как создать отчет на основе запроса?
  • Могу ли я сохранить полученный отчет в HTML, EXCEL, WORD?

Управление данными

  • В чем отличие между функциями экспорта/импорта STUDIO и одноименными функциями SQL Manager for SQL Server?
  • Мне необходимо импортировать данные из CSV-файла. Как я могу сделать это с помощью STUDIO?
  • Как изменить директорию, в которой будут сохранены экспортированные данные?
  • Для чего в состав STUDIO входят консольные версии утилит манипулирования данными?
  • У меня есть база данных в MS Access. Мне необходимо мигрировать ее на удаленный сервер SQL Server. Как это сделать с помощью STUDIO?
  • У меня есть источник данных ODBC. Могу ли я мигрировать из него в SQL Server?
  • Из каких баз данных я могу мигрировать в SQL Server, используя STUDIO?
  • Я только разрабатываю приложение. Структура базы данных уже создана. Как STUDIO может помочь в заполнении базы данных тестовыми данными?
  • Моя база содержит много связей между таблицами и других ограничений. Будет ли STUDIO учитывать это при генерации тестовых данных?

Анализ данных

  • Мне необходимо найти различия в метаданных в двух базах данных и затем их синхронизировать. Как STUDIO может помочь это сделать?
  • Мне необходимо найти различия в данных между существующей базой данных и ее вчерашней резервной копией. Каковы мои действия?
  • Могу ли я запустить синхронизацию метаданных или данных из командной строки?
  • Может ли STUDIO синхронизировать SQL Server базу данных с базой данных других DBMS?

Резервное копирование/Восстановление

  • Какие возможности для создания резервной копии предоставляет STUDIO?
  • Можно ли резервную копию, сделанную на одном сервере, восстановить на другом сервере?
  • Чем отличается функции извлечения базы данных и создания резервной копии в STUDIO?
  • На какие устройства можно выполнять резервное копирование и где устройство должно находиться?

Управление шаблонами

  • Что такое шаблоны, используемые, например, в функциях импорта/экспорта? Для чего они нужны?
  • Где хранятся шаблоны STUDIO?
  • Удаление шаблона из списка в STUDIO приводит к удалению шаблона с диска?
  • Как я могу создать новый шаблон для Импорта?

Планировщик

  • Мне необходимо выполнить ряд функций по обслуживанию базы данных (экспорт из одной базы данных, импорт этих данных в другую базу данных, резервное копирование обоих баз данных) во внерабочее время (ночью). STUDIO имеет решение для этого?
  • Как настроить задачу, чтобы при неудачном ее выполнении я получал e-mail на указанный адрес?
  • Может ли ход выполнения задачи меняться в зависимости от результатов выполнения ее шагов?
  • Как я могу посмотреть информацию о выполненных задачах?
  • Что произойдет, если в процессе выполнения задачи вызванное приложение не может завершиться (критическая ошибка, задача не отвечает)? Выполнение задачи остановится?
  • Что необходимо для работы Планировщика?
  • Что произойдет, если после включения компьютера планировщик обнаружит задачи, которые должны были быть выполнены в прошлом, но не были выполнены?

Управление журналами

  • Для меня важна информация из журналов приложений, выполняемых планировщиком. STUDIO сохраняет эти журналы?
  • Внешнее приложение, которое выполняется в одной из задач, не имеет журнала – только экранный вывод. Как мне сохранить выводимые на экран данные?
  • Как долго хранятся журналы в STUDIO?

Локализация

  • Какие локализации интерфейса доступы для STUDIO?

Список ответов

Что такое STUDIO

Q: Что такое EMS SQL Management Studio?

A: EMS SQL Management Studio – это комплексное решение для администрирования и разработки баз данных. STUDIO представляет собой набор мощных инструментов для работы с базами данных, объединенных удобной, функциональной оболочкой. Разработчики по достоинству оценят возможность создания/редактирования/удаления любых объектов базы данных. Полезными для них будут инструменты сравнения БД, экспорта и импорта данных, генерации тестовых данных. Администраторам будут интересны инструменты для миграции БД, создания резервных копий и их последующего восстановления и, конечно, Планировщик, позволяющий автоматизировать большую часть работы администратора.

Q: STUDIO содержит очень много возможностей, но буду ли я их использовать? Нет ли более простого продукта?

A: Такой вопрос, в основном, задают новички в администрировании и разработке баз данных. Они не могут понять, для чего нужно столько различных инструментов!? Мы хотим сказать, что с каждым днем ваш опыт будет расти, перед вами будут стоять новые, более сложные задачи, и для их решения вам будет необходимо иметь все больше инструментов. STUDIO содержит в себе ВСЕ необходимые инструменты для администратора или разработчика баз данных. STUDIO уже готова к вашему профессиональному росту! Более того, изучив и поняв инструменты STUDIO, вы сможете находить более простые, удобные и надежные решения ваших задач! Конечно, мы понимаем, что нашим продуктом пользуются не только профессионалы, поэтому в STUDIO включены многочисленные мастера, делающие работу легкой и приятной даже для новичка. Интерфейс STUDIO спроектирован так, чтобы многочисленные инструменты не мешались пользователю, а вызывались исключительно тогда, когда это необходимо. Наш опыт показывает, что подавляющее большинство пользователей очень быстро привыкают к нашим мощным продуктам, и мы не имеем никаких обращений от пользователей с просьбами сделать даунгрейд на более простой продукт.

Q: Что мне необходимо для начала работы с STUDIO?

A: Для начала работы с STUDIO вам необходимо скачать установочный пакет здесь. На компьютере с MS Windows запустить программу-инсталлятор. По окончании работы инсталлятора программа готова к использованию в триальном режиме. Вы можете использовать программу в триальном режиме в течение 30 дней. За это период вам необходимо принять решение о приобретении STUDIO. Оплатить STUDIO можно здесь. После оплаты вы получите по электронной почте регистрационный ключ, после ввода которого (Главное меню/Справка/Зарегистрировать) ваша копия STUDIO станет зарегистрированной.

Q: Многие утилиты, входящие в STUDIO, вы продаете отдельно. В чем преимущество покупки их в составе STUDIO?

A: Действительно, для решения какой-либо одной несложной задачи можно приобрести один или несколько наших инструментов. Однако покупая эти инструменты в составе STUDIO, вы получаете дополнительные возможности. Прежде всего, это возможность запускать инструменты студии из планировщика задач. Т.е. вы можете задать последовательность использования нескольких инструментов, указать, с какими параметрами должны быть использованы инструменты, задать время и/или частоту выполнения задач. Планировщик выполнит все ваши задачи, сохранит журналы выполненных инструментов и вышлет вам уведомление об удачном/неудачном завершении задачи на ваш электронный адрес. С помощью Планировщика вы реально можете автоматизировать большинство сервисных задач по обслуживанию вашей БД. Вторая возможность - это хранение всех зарегистрированных БД в одном репозитории. Таким образом, однажды зарегистрировав источник данных, вы можете использовать его во всех инструментах STUDIO. Это экономит ваше время и снижает вероятность ошибки. Третий, очень немаловажный момент, - это цена. Приобретая инструменты в составе студии, вы платите за них существенно меньше, чем при покупке отдельными продуктами. Скидка достигает 40%!

Наверх

Регистрация баз данных и подключение

Q: Могу ли я работать с несколькими базами данных одновременно?

A: Да, STUDIO позволяет работать с неограниченным количеством БД одновременно. Единственное условие для этого - БД должна быть корректно зарегистрирована в репозитории баз данных.

Q: Для чего нужен общий репозиторий зарегистрированных баз данных?
A: Единый репозиторий баз данных позволяет после однократной регистрации базы данных иметь возможность обращаться к ней из разных инструментов STUDIO. Для сравнения, покупая ранее наши наборы инструментов (бандлы), вы должны были в каждом инструменте вводить информацию о соединении с источником данных. Это приводило к дополнительным затратам времени и ошибкам. Теперь в STUDIO такой проблемы нет.

Q: Как соединиться с именованным экзепляром с помощью SQL Manager for SQL Server?

A: Для соединения с именованным экземпляром на SQL Server 2005 введите имя экземпляра после имени хоста через наклонную черту в поле "Хост" диалога "Регистрационная информация базы данных". (Например, my_server\my_instance.)

Для того, чтобы соединиться с именованным экземпляром на SQL Server 2000, вам необходимо:

  • Запустить SQL Server Client Network Utility (WINDOWS\\SYSTEM32\\cliconfig.exe) на клиентском компьютере, где установлена STUDIO (в частности EMS SQL Manager for SQL Server).
  • Перейти на вторую закладку (Alias).
  • Добавить новый алиас с именем сервера в виде <server_name>\\<instanse_name> и TCP/IP в качестве сетевой библиотеки.
  • Использовать имя алиаса в качестве имени хоста в STUDIO.

Q: При соединении с SQL Server я получаю ошибку "SQL Server does not exist or access denied". В чем причина?

A: Возможно, ваш SQL Server установлен как именованный экземпляр (См. вопрос "Как соединиться с именованным экземпляром с помощью SQL Manager for SQL Server?").

Кроме этого возможными причинами проблем с соединением могут быть:

  • Вы соединяетесь с SQL Server за пределами вашей локальной сети за файервол (См. вопрос "Моя рабочая станция подключена к сети через файрвол (роутер). Я могу использовать STUDIO для управления удаленным SQL Server'ом?").
  • Введен неверный логин/пароль. Либо вы используете аутентификацию SQL Server'a, но этот вид аутентификации запрещен на сервере. Либо вы используете аутентификацию Windows для установления соединения, но на SQL Server отсутствует имя пользователя, соответствующее вашему доменному логину.
  • Некорректно работает MDAC (См. вопрос "Как переустановить Microsoft Data Access Components (MDAC)?").
  • SQL Server работает на нестандартном (не 1433) порту (См. вопрос "Я получаю доступ к своему серверу через альтернативный порт. Я пытался найти в SQL Manager for SQL Server опцию, чтобы изменить порт для соединения, но безрезультатно. Как я могу изменить порт?").
  • Отключены протоколы клиентских соединений, либо включенные протоколы отключены на стороне сервера. Воспользуйтесь SQL Server Client Network Utility (WINDOWS\\SYSTEM32\\cliconfig.exe) для соединения с SQL Server 2000 или ниже, либо используйте SQL Server Configuration Manager, чтобы включить соответствующие протоколы.

Q: Как переустановить Microsoft Data Access Components (MDAC)?

A: Если вы используете Windows XP без SP2, скачайте последнюю версию MDAC здесь: http://www.microsoft.com/downloads/ и установите ее.

Если вы используете Windows XP с SP2, то выполните следующие шаги:

Нажмите правой кнопкой мыши на C:\Windows\Inf\mdac.inf и выберите "Установить".

При запросе указать путь для установочных файлов XP SP2, укажите на папку i386 одним из следующих способов:

  1. На папку \i386 на диске XP SP2. Если на вашем диске есть XPSP2.EXE, но папка \i386 отсутствует, то вам необходимо создать папку i386 с помощью следующей команды: XPSP2.EXE /X:C:\XpSp2, затем укажите путь C:\XpSp2\i386.
  2. На папку \i386 на установочном диске для XP+SP2 (slipstreamed XP SP2).

При запросе указать путь для установочных файлов XP, укажите папку i386 следующим образом:

  1. C:\Windows\ServicepackFiles\i386 (если данный путь не подойдет, переходите к следующему пункту);
  2. Папка \i386 на установочном диске для XP.

Q: Я получаю доступ к своему серверу через альтернативный порт. Я пытался найти в SQL Manager for SQL Server опцию, чтобы изменить порт для соединения, но безрезультатно. Как я могу изменить порт?

A: Для соединения с SQL Server 2005 с помощью альтернативного порта, выполните следующее:

  • Запустите SQL Server Configuration Manager на клиентском компьютере, где установлена STUDIO.
  • Разверните секцию SQL Native Client Configuration.
  • Выберите секцию Aliases.
  • Добавьте новый псевдоним и задайте его имя, номер порта и TCP/IP в качестве сетевой библиотеки.
  • Используйте имя псевдонима в качестве имени хоста в STUDIO.
  • Для соединения с SQL Server 2000 с помощью альтернативного порта, выполните следующее:
  • Запустите SQL Server Client Network Utility (WINDOWS\\SYSTEM32\\cliconfg.exe) на клиентском компьютере, где установлена STUDIO.
  • Выберите вторую закладку (Alias).
  • Добавьте новый псевдоним и задайте его имя, номер порта и TCP/IP в качестве сетевой библиотеки.
  • Используйте имя псевдонима в качестве имени хоста в STUDIO.

Q: Моя рабочая станция подключена в сеть через файрвол (роутер). Могу ли я использовать СТУДИЮ для управления удаленным SQL Server сервером?

A: Да, но для этого Вы должны открыть порт, на котором работает SQL Server, (по умолчанию 1433) на Вашем файрволе и на файрволе удаленного сервера.

Наверх

Управление объектами

Q: Какие объекты базы данных будут доступны мне при работе в STUDIO?

A: Вы можете работать с любыми объектами баз данных SQL Server, такими, как таблицы, поля, индексы, представления, хранимые процедуры и функции, триггеры и т.д.

Q: У меня в таблице более миллиона записей, однако в сетке данных отображаются только 1000. В чем проблема?

A: Пожалуйста, выберите опцию "Выбирать все записи из таблицы" на закладке "Сетка" диалога "Настройки/Настройки окружения". При этом помните, что на выборку всех записей из таблицы может потребоваться значительное время.

Q: Как повысить скорость работы с большими таблицами?

A: В целях повышения скорости работы и удобства Сетка Данных позволяет производить гибкую настройку многих параметров отображения данных. Ниже приведены наиболее важные из них (пункт меню "Настройки/Настройки окружения"):

1. На закладке Сетка:

  • Ограничения в редакторах. При включении опции "Выбирать все записи из таблицы" вы будете иметь возможность видеть все записи таблицы без дополнительных запросов к серверу, однако для больших таблиц или при низкоскоростном канале связи возможны значительные задержки при получении данных, также входящий трафик может быть большим. Режим рекомендуется при работе с базами данных, расположенными локально либо в частной сети. Режим "Выбирать только" ограничивает максимальное число записей, возвращаемых в результате запроса. Режим обусловлен тем, что человек не способен осмысленно просмотреть огромный объем информации за один раз. Для запроса и отображения следующей порции данных служит кнопка "Далее" в панели инструментов "Сетка Данных". Данный режим значительно ускоряет просмотр данных таблицы, предотвращает зависание и разрыв соединения при таймауте. Рекомендуется для работы с большими таблицами, при низкоскоростных каналах связи и когда объем трафика имеет значение. Данный режим включен по умолчанию. При данном режиме очень полезны опции "Использовать сортировку SQL" и "Использовать фильтр SQL".

2. На странице "Сетка/Настройки данных":

  • Режим сетки по умолчанию. Данная опция определяет, будут ли все строки запроса загружаться в Сетку сразу ("Загружать все строки"), либо по мере необходимости ("Загружать видимые строки"), т.е. когда пользователь пролистывает данные в таблице. Первый режим увеличивает время открытия результата запроса, но уменьшает задержки при пролистывании. При втором режиме время открытия результата запроса минимально, но возникают задержки при навигации по сетке.
  • Использовать сортировку SQL при просмотре данных. При включенной опции при задании пользователем сортировки данных на сервер отправляется новый запрос, результат которого заново отображается в сетке. Очень полезна опция при включенном режиме - "Выбирать только", но она увеличивает трафик. При отключенной опции сортировка выполняется на клиенте без участия сервера, но только в уже загруженных данных. Т.е. если указано "Выбирать только 1000 записей", то отсортируются только эти записи.
  • Использовать фильтр SQL при просмотре данных. При включенной опции фильтрация данных будет производиться на сервере, куда отправляется новый запрос, результат которого заново отображается в сетке.
  • Также очень полезна опция при включенном режиме - "Выбирать только", но она увеличивает трафик. При отключенной опции фильтрация выполняется на клиенте без участия сервера, но только в уже загруженных данных. Т.е. если указано "Выбирать только 1000 записей", то фильтр будет выбирать только из этих записей.

3. Для максимальной производительности при работе с большими таблицами мы рекомендуем установить следующие значения для опций:

- Выбирать только – Включено

- Загружать все строки – Включено

- Использовать сортировку SQL – Включено

- Использовать фильтр SQL – Включено

Q: Какие действия я могу выполнять с объектами базы данных?

A: Вы можете создавать новые объекты, удалять и модифицировать существующие. Также можете копировать объекты между базами данных, расположенных как на одном, так и на разных серверах.

Q: При создании таблицы с именем `TestTable` она сохраняется как `testtable`. Это неправильно!

A: Проверьте значение опции 'Конвертировать имена созданных объектов в нижний регистр' в меню "Настройки/Настройки окружения/Редакторы объектов". Если необходимо, отключите ее

Q: Как я могу настроить форматы данных в сетке?

A: Вы можете настроить любой из форматов отображения данных: integer, float, date, time и date/time в окне "Настройки окружения". Вы можете это сделать, используя Главное меню "Настройки/Настройки окружения/Сетка/ Цвета и Форматы".

Q: Моя база данных имеет кодировку "Greek". В сетке данных все данные отображаются как «?????????». В чем ошибка?

A: Вы должны настроить значение опции "Кодировка", чтобы указать серверу кодировку, в которой он должен возвращать данные клиенту (нашей программе). Пожалуйста, откройте окно "Регистрационная информация базы данных" и установите значение опции "Кодировка" как 'greek (ISO 8859-7 Greek)'.

Q: Я не могу изменить DDL. Почему?

A: Вкладки "DDL" в Редакторе таблиц и в Редакторе UDF доступны только для чтения. Они отображают SQL текст операций, производимых вами во вкладках "Поля", "Индексы" и прочих или через UDF. Чтобы изменить этот текст, вы можете скопировать его в буфер обмена и изменить его, используя Редактор SQL-скрипта.

Наверх

Запросы

Q: Я новичок в SQL Server. Я плохо строю SQL-запросы. Есть ли в STUDIO визуальный конструктор запросов, как в MS ACCESS?

A: Да, STUDIO имеет мощный визуальный конструктор запросов, позволяющий даже новичку строить достаточно сложные запросы, а профессионалу тратить на это значительно меньше времени. Вам только необходимо указать, какие таблицы участвуют в запросе, как они связаны между собой и какие данные вы хотите получить. Визуальный конструктор сам составит текст запроса. Вам останется только выполнить его. Вы сразу же можете увидеть результат выполнения запроса и внести, в случае необходимости, изменения в запрос. Изменения можно делать как в визуальном редакторе, так и в текстовом. Причем изменения, сделанные в тексте запроса, будут отображены в визуальном редакторе, и наоборот.

Q: Могу ли я использовать визуальный конструктор запросов STUDIO для создания сложных запросов (включая составные и вложенные)?

A: Да, визуальный конструктор запросов позволяет строить и сложные запросы, включая составные (оператор UNION) и вложенные (SUBQUERIES).

Q: Могу ли я сохранить созданный запрос для будущего использования?

A: Да, конечно. Для того чтобы необходимый запрос можно было быстро найти и выполнить, STUDIO обладает следующими возможностями:

1. ВСЕ выполненные запросы автоматически сохраняются в Истории. Вы можете просмотреть Историю и выполнить любой запрос еще раз, либо отредактировать его.

2. Наиболее часто используемые запросы вы можете поместить в список фаворитных запросов.

3. Вы можете сохранить любой запрос как SQL-скрипт в файл на диске и позднее загрузить его, либо выполнить с помощью консольного инструмента SQL скрипт.

4. Вы можете сохранить ваш запрос вместе с диаграммой. В этом случае в будущем, после загрузки этого запроса в STUDIO вы увидите диаграмму запроса такой, какой вы ее создали.

5. STUDIO позволяет сохранить диаграмму запроса как рисунок bitmap.

Q: Могу ли я выполнить запрос из командной строки?

A: Да. Для этого в состав STUDIO входит инструмент SQL скрипт, который в том числе может выполнить скрипт, сохраненный в файле. Эта возможность позволяет вам создавать запросы и отдавать их на выполнение Планировщику STUDIO. Планировщик выполнит ваш запрос строго в назначенное вами время и сообщит вам о результате выполнения.

Q: Могу ли я сохранить результат выполнения запроса в csv или xls файле?

A: Да, конечно. STUDIO имеет мощный инструмент для экспорта данных (в том числе и результатов запроса). Кроме указанных вами форматов STUDIO позволяет выполнить экспорт в файлы следующих типов: MS Access, MS Word, HTML, RTF, DBF, XML и другие. Для облегчения настройки операции экспорта STUDIO содержит дружественный Мастер Экспорта Данных.

Наверх

Конструктор отчетов

Q: Как я могу создать отчет?

A: Вы можете использовать для создания отчета Мастер Создания Отчетов ("Создать -> Отчет") или Конструктор отчетов ("Инструменты/Конструктор отчетов"). Чтобы создать простейший отчет на основе запроса, вам нужно выбрать "Master Data band" на втором шаге мастера, дважды щелкнуть на нем, либо щелкнуть на кнопке "Edit" и задать запрос для вашего отчета. После этого настроить необязательные опции на оставшихся шагах и нажать "Готово".

Q: Как создать отчет на основе запроса?

A: Используйте Мастер Создания Отчетов, чтобы создать отчет на основе запроса. Для этого вам нужно нажать в панели инструментов Создать -> Отчет, затем нужно выбрать Master Data band на втором шаге мастера, дважды щелкнуть на нем, либо щелкнуть на Edit кнопке и задать запрос для вашего отчета. После этого настроить необязательные опции на оставшихся шагах и нажать Готово.

Q: Могу ли я сохранить полученный отчет в HTML, EXCEL, WORD?

A: Откройте отчет для просмотра, дважды кликнув на нем мышкой в Проводнике баз данных, затем выберите "Save report as" в панели навигации или инструментов и выберите тип сохраняемого файла в поле "Save as type".

Наверх

Управление данными

Q: В чем отличие между функциями экспорта/импорта STUDIO и одноименными функциями SQL Manager for SQL Server?

A: Инструменты для экспорта/импорта, входящие в состав STUDIO, обладают большими возможностями по сравнению с одноименными функциями SQL Manager for SQL Server.
  • Экспорт/импорт данных из/в таблицы разных баз данных одного хоста.
  • Экспорт/импорт данных из/в таблицы разных баз данных разных хостов.
  • Наличие консольной утилиты, позволяющей, например, выполнять операции экспорта/импорта в автоматическом режиме с помощью Планировщика STUDIO.
  • Использование общего репозитория зарегистрированных баз данных.

Q: Мне необходимо импортировать данные из CSV-файла. Как я могу сделать это с помощью STUDIO?

A: Для этого необходимо воспользоваться Мастером импорта. Он поможет установить все необходимые параметры для операции импорта. Более того, вы можете сохранить эти настройки для импорта в качестве шаблона и использовать их в будущем. Кроме CSV-файла вы можете выполнить импорт из MS Excel, MS Access, DBF, XML, TXT и других форматов.

Q: Как изменить директорию, в которой будут сохранены экспортированные данные?

A: Чтобы изменить директорию, вам необходимо выполнить следующие шаги:

  • Выберите базу данных в Проводнике и щелкните на ней правой кнопкой мыши, затем в появившемся меню выберете "Информация о регистрации" (вы также можете найти этот пункт в главном меню "База данных"). Откроется окно со свойствами базы данных.
  • Нажмите на закладку "Каталоги".
  • В секции "Каталог по умолчанию для экспортируемых данных" вы можете выбрать директорию по умолчанию для экспортируемого файла.

Q: Для чего в состав STUDIO входят консольные версии утилит манипулирования данными?

A: Основное назначение консольных версий инструментов STUDIO - это выполнение некоторых сервисных операций с базой данных без непосредственного участия пользователя. Все консольные инструменты поддерживают конфигурационные файлы (шаблоны), созданные в их одноименных GUI-версиях. Файл шаблона содержит все необходимую информацию для работы консольной версии инструмента. Имея консольную версию инструмента и шаблон, вы можете создать в Планировщике STUDIO задачу с необходимым временем выполнения и/или периодичностью. Конечно, вы можете использовать консольные версии инструментов STUDIO и в собственных приложениях автоматизации.

Q: У меня есть база данных в MS Access. Мне необходимо мигрировать ее на удаленный SQL Server. Как это сделать с помощью STUDIO?

A: Вы можете использовать Data Pump for SQL Server для этой цели. Для запуска Data Pump из STUDIO выберите закладку "Управление данными" и кликните на Data Pump for SQL Server, или выберите Пуск->Программы->EMS->SQL Studio for SQL Server->Data Pump for SQL Server. Мы рекомендуем вам использовать провайдер Microsoft Jet 4.0 OLE DB для соединения с вашей базой данных MS Access.

Q: У меня есть источник данных ODBC. Могу ли я мигрировать из него в SQL Server?

A: ODBC (Open DataBase Connectivity) — это открытый, стандартный интерфейс доступа к базам данных, разработанный фирмой Microsoft. Абсолютное большинство систем управления базами данных имеют собственный, либо разработанный сторонними производителями программного обеспечения ODBC драйвер.

Для миграции из ODBC источника данных вам нужно использовать Data Pump for SQL Server. Для запуска Data Pump из STUDIO выберите закладку Манипулирование данными и кликните на Data Pump for SQL Server, или выберите Пуск->Программы->EMS->SQL Studio for SQL Server->Data Pump for SQL Server. В утилите вы должны использовать OLE DB провайдер для ODBC драйверов для соединения c вашим источником данных ODBC.

Q: Из каких баз данных я могу мигрировать в SQL Server, используя STUDIO?

A: С помощью утилиты Data Pump for SQL Server вы можете мигрировать из любых баз данных, к которым вы можете подсоединиться, используя OLE DB провайдер (например, SQL Server, Oracle, MS Access, DB2 и др.), а также ODBC драйвер (MySQL, PostgreSQL, Interbase, Firebird, dbase файлы и др.).

Q: Я только разрабатываю приложение. Структура базы данных уже создана. Как STUDIO может помочь в заполнении базы данных тестовыми данными?

A: STUDIO обладает мощным инструментом для генерации тестовых данных - Data Generator for SQL Server. Используя имеющийся мастер, вы можете настраивать такие параметры генерации, как количество генерируемых строк, диапазон значений для каждого поля, доля строк со значением NULL и др. Data Generator реализует случайную, инкрементную, по заданному списку значений генерацию данных и другие алгоритмы. Естественно, что все это обилие настроек STUDIO может сохранить как шаблон для будущего использования.

Q: Моя база содержит много связей между таблицами и других ограничений. Будет ли STUDIO учитывать это при генерации тестовых данных?

A: Да, конечно. При генерации тестовых данных STUDIO учитывает все связи и ограничения, уже имеющиеся в базе данных.

Наверх

Анализ данных

Q: Мне необходимо найти различия в метаданных в двух базах данных и затем их синхронизировать. Как STUDIO может помочь это сделать?

A: Для этой цели STUDIO имеет инстумент Database Comparer (DB Comparer). Его интерфейс прост и понятен, но результаты работы просто впечатляют! Вам достаточно указать две базы данных, метаданные которых вы хотите сравнить, а также некоторые дополнительные параметры, такие как сравниваемые объекты БД, направление синхронизации и др. Результатом работы DB Comparer будет перечень найденных различий в метаданных этих двух БД и скрипт, с помощью которого вы можете синхронизировать одну базу с другой. Причем вы можете синхронизировать каждое отличие отдельно от всех остальных, применяя только необходимые изменения в нужном вам порядке.

Q: Мне необходимо найти различия в данных между существующей базой данных и ее вчерашней резервной копией. Каковы мои действия?

A: Для этой операции вам необходимо запустить мастер Data Comparer и в качестве исходной базы данных указать существующую рабочую базу, а в качестве целевой базы данных указать вчерашнюю резервную копию базы данных (ее необходимо предварительно восстановить на любом доступном SQL Server). Затем указать, данные в каких таблицах вы хотите сравнить. Далее следуйте по шагам мастера. Помните, что Data Comparer позволяет сравнивать данные в таблицах с неидентичными метаданными. После выполнения операции сравнения вы увидите список различий между вашими двумя базами данных и предложение выполнить синхронизацию данных либо от исходной базы данных к целевой, либо от целевой к исходной. Вы можете сохранить SQL-скрипт, выполняющий синхронизацию, в отдельный файл на диске и выполнить его позднее с помощью инструмента SQL скрипт (возможно, с использованием планировщика STUDIO).

Q: Могу ли я запустить синхронизацию метаданных или данных из командной строки?

A: Да, для этого существуют консольные версии наших утилит - DB Comparer for SQL Server Console Application и Data Comparer for SQL Server. Все консольные инструменты поддерживают конфигурационные файлы (шаблоны), созданные в их одноименных GUI-версиях. Файл шаблона содержит всю необходимую информацию для работы консольной версии инструмента. Имея консольную версию инструмента и шаблон, вы можете элементарно выполнять синхронизацию из командной строки, не задавая множества параметров вручную.

Q: Может ли STUDIO синхронизировать SQL Server базу данных с базой данных других DBMS?

A: Данная возможность не поддерживается нашими утилитами, поскольку они допускают синхронизацию данных и метаданных только между серверами одного типа, т.е. SQL Server c SQL Server.

Наверх

Резервное копирование/Восстановление

Q: Какие возможности для создания резервной копии предоставляет STUDIO?

A: SQL Studio поддерживает несколько способов резервного копирования баз данных.
  • С помощью Мастера резервного копирования.

Он выполняет полное или дифференцированное резервное копирование базы данных, резервное копирование журнала транзакций. Можно делать резервную копию всей базы данных или отдельных ее файлов. Этот метод отличается высокой надежностью. Во время резервного копирования пользователи могут продолжать работать с базой данных - целостность данных обеспечивается. Копирование может производиться в логическое устройство резервного копирования, в файл, на ленту, или в именованный канал. Во всех случаях устройство должно находиться на сервере или в локальной сети, где расположен сервер. Путь к устройству указывается с точки зрения сервера. Для записи на сетевые устройства, сервис SQL Server должен быть запущен от имени пользователя, имеющего доступ к устройству. Для вызова данного сервиса откройте закладку "Управление базами данных" в STUDIO и выберите "Backup Tables". Для вызова из SQL Manager for SQL Server используйте "Обслуживание/Резервное копирование таблиц" в главном меню. Для восстановления базы данных или журнала транзакций из созданных этим способом резервных копий используется Мастер восстановления таблиц. Можно восстанавливать резервную копию либо в новую, либо в существующую базу данных. В первом случае, если оригинальная база данных существует, нужно указать новые имена файлов для восстанавливаемой базы данных.

  • С помощью Data Export for SQL Server либо Мастера экспортирования данных в SQL Manager for SQL Server. Данный способ подходит для резервного копирования данных любого вида таблиц. Используйте его, если вы хотите сохранить только данные, без сохранения структуры. Мы рекомендуем использовать CSV формат для резервного копирования данных. Для вызова Data Export откройте закладку "Управление базами данных" в STUDIO и выберите Data Export for SQL Server. Для вызова Мастера экспортирования данных из SQL Manager for SQL Server откройте вашу таблицу на закладке "Данные" и выберите "Экспорт данных". Для восстановления данных из созданного таким образом файла вы можете использовать утилиту Data Import for SQL Server или Мастера импортирования данных в SQL Manager for SQL Server. Отличия между Data Import for SQL Server и Мастером импортирования данных в SQL Manager for SQL Server вы можете найти здесь.

Q: Можно ли резервную копию, сделанную на одном сервере, восстановить на другом сервере?

A: Существует несколько случаев:

1) Резервную копию, созданную с помощью Мастера резервного копирования, можно восстановить на любом сервере, имеющем версию равную либо выше версии сервера, на котором была сделана резервная копия.

2) Резервную копию, созданную с помощью утилиты DB Extract for SQL Server, либо Мастера извлечения базы данных в SQL Manager for SQL Server можно восстановить на любом сервере, имеющем версию равную либо выше версии сервера, на котором была сделана резервная копия.

3) Данные, сохраненные с помощью утилиты Data Export for SQL Server или Мастера сохранения данных в SQL Manager for SQL Server, можно восстановить в таблицу на сервере SQL Server любой версии.

Q: Чем отличается функции извлечения базы данных и создания резервной копии в STUDIO?

A:Мастер резервного копирования может выполнять: - полное резервное копирование базы данных; - дифференцированное резервное копирование базы данных; - резервное копирование отдельных файлов и их групп; - дифференцированное резервное копирование отдельных файлов и их групп; - резервное копирование журнала транзакций. Данный метод не может использоваться для резервного копирования отдельных объектов базы данных или схем. Резервная копия находится на сервере. При наличии резервных копий журнала транзакций база данных может быть восстановлена на определенный момент времени.

Утилита DB Extract for SQL Server, или Мастер извлечения базы данных в SQL Manager for SQL Server создают резервные копии либо баз данных целиком, либо только отдельных объектов или схем в форме SQL-скрипта. Генерируемый скрипт может содержать управляющие SQL команды, команды создания объектов и команды вставка данных. Резервная копия находится на клиенте. Можно восстановить данные только на момент создания резервной копии. Таким образом, Мастер резервного копирования использует возможности SQL Server для выполнения резервного копирования баз данных, отличается высокой надежностью, но не может поместить файлы резервных копий в произвольную папку на клиенте. Для резервного копирования баз данных рекомендуется использовать этот метод. Основными преимуществами резервного копирования с помощью утилиты DB Extract for SQL Server являются возможность сохранения структуры и данных только определенных объектов или схем БД, а также то, что файл резервной копии создается на клиенте. Из недостатков следует выделить значительные время и трафик, которые может потребовать резервное копирование больших баз данных, а также более низкую надежность.

Q: На какие устройства можно выполнять резервное копирование и где устройство должно находиться?

A: Копирование может производиться в логическое устройство резервного копирования, в файл, на ленту, или в именованный канал. Во всех случаях устройство должно находиться на сервере или в совместно используемых ресурсах локальной сети, где расположен сервер. Путь к устройству указывается с точки зрения сервера. Для записи на сетевые устройства, сервис SQL Server должен быть запущен от имени пользователя, имеющего доступ к устройству.

Наверх

Управление шаблонами

Q: Что такое шаблоны, используемые, например, в функциях импорта/экспорта? Для чего они нужны?

A: Шаблоны в STUDIO предназначены для хранения параметров, необходимых для выполнения того или иного инструмента STUDIO. Благодаря шаблонам вы можете многократно выполнять одну и ту же операцию с помощью инструмента STUDIO без необходимости каждый раз вводить в мастере по 10-20 необходимых параметров. Хранимые в шаблоне параметры можно легко изменить или создать новый шаблон на основе существующего.

Q: Где хранятся шаблоны STUDIO?

A: Шаблон представляет из себя файл, в котором в определенном формате хранятся необходимые параметры. Файлы шаблонов могут располагаться в любом месте на диске компьютера, главное, что бы вы помнили, где они находятся :). Для облегчения задачи по хранению и поиску шаблонов STUDIO имеет менеджера шаблонов. Он позволяет вам зарегистрировать необходимые шаблоны в STUDIO и больше не задумываться о том, куда же вы сохранили нужный шаблон. Если вы создаете новый шаблон в студии, то менеджер шаблонов автоматически запомнит его месторасположение на диске. Все зарегистрированные шаблоны будут сгруппированы по инструментам, для которых они предназначены, и доступны вам в любой момент. Для запуска инструмента с выбранным шаблоном будет достаточно просто сделать двойной клик на шаблоне.

Q: Удаление шаблона из списка в STUDIO приводит к удалению шаблона с диска?

A: Менеджер шаблонов позволяет вам выполнить оба действия: просто удалить шаблон из списка зарегистрированных шаблонов либо, дополнительно, удалить и сам файл шаблона с диска компьютера.

Q: Как я могу создать новый шаблон для Импорта?

A: Для создания шаблона для инструмента Импорта вы можете запустить инструмент Импорта ("Запуск/Data Import" в главном меню). Затем, используя кнопку NEXT, заполнить все необходимые параметры для импорта. По достижении последнего шага мастера, используя кнопку "Настройки/Сохранить шаблон", указать, куда и с каким именем вы хотите сохранить только что созданный шаблон.

Наверх

Планировщик

Q: Мне необходимо выполнить ряд функций по обслуживанию базы данных (экспорт из одной базы данных, импорт этих данных в другую базу данных, резервное копирование обоих баз данных) во внерабочее время (ночью). STUDIO имеет решение для этого?

A: Да, конечно. Именно для таких ситуаций и предназначен Планировщик STUDIO. Планировщик может запускать на выполнение предварительно созданные вами Задачи. Вы можете настроить время запуска Задачи и периодичность ее запуска. Каждая Задача может состоять из неограниченного количества Шагов (элементарных действий). Задача должна состоять как минимум из одного шага. В вашем случае следует выполнить следующее:

1. Создать новую Задачу

2. Создать в этой Задаче 4 шага (Экспорт, Импорт, Резервное копирование, Резервное копирование). При создании этих шагов вам будет необходимо указать, в каких файлах шаблонов хранятся необходимые для работы инструментов параметры.

3. Создать в Планировщике Запланированную Задачу, использующую только что созданную (п.1) Задачу.

Q: Как настроить задачу, чтобы при неудачном ее выполнении я получал e-mail на указанный адрес?

A: В окне редактирования Задачи есть закладка "Уведомления". Переключившись на нее, вы можете указать наиболее подходящий вам способ уведомления как об успехе выполнения Задачи, так и о неудачном ее завершении. В текущей версии STUDIO поддерживаются следующие виды уведомлений: NetSend, системный журнал приложений, электронная почта.

Q: Может ли ход выполнения задачи меняться в зависимости от результатов выполнения ее шагов?

A: Да. При создании/редактировании каждого Шага Задачи вы можете определять, какой шаг должен выполняться далее. Причем для каждого из трех обрабатываемых событий (успешное выполнение шага, выполнение шага с ошибкой, завершение шага по таймауту) можно указать свой вариант продолжения работы Задачи.

Q: Как я могу посмотреть информацию о выполненных задачах?

A: Вся информация о запуске Задач фиксируется в журнале. Вам будет доступна информация не только о выполнении Задачи, но и входящих в нее Шагов. Более того, вы сможете посмотреть журнал приложения, выполненного в конкретном шаге. Это очень удобно при анализе причин неудачного завершения Задачи/Шага. Мощные фильтры журнала позволят отобразить только интересующие вас записи.

Q: Что произойдет, если в процессе выполнения задачи вызванное приложение не может завершиться (критическая ошибка, задача не отвечает)? Выполнение задачи остановится?

A: Для разрешения таких конфликтов в каждом Шаге Задачи вы можете определить его таймаут. Если Шаг выполняется дольше, чем указано в его таймауте, то Шаг завершается с событием "По таймауту" и выполнение задачи продолжается в соответствии с заложенным вами алгоритмом.

Q: Что необходимо для работы Планировщика?

A: Для работы Планировщика необходимо, чтобы был запущен агент студии (иконка в панели задач). И конечно, компьютер должен оставаться включенным все время, в течение которого должны запускаться задачи.

Q: Что произойдет, если после включения компьютера планировщик обнаружит задачи, которые должны были быть выполнены в прошлом, но не были выполнены?

A: Эти задачи выполнены не будут.

Наверх

Управление журналами

Q: Для меня важна информация из журналов приложений, выполняемых планировщиком. STUDIO сохраняет эти журналы?

A: Да. STUDIO обладает удобным инструментом для работы с журналами. При создании любого Шага в Задаче вы можете указать месторасположение журнала выполняемой утилиты. При выборе инструментов, входящих в STUDIO, расположение журнала заполняется автоматически. Журналы выполненных шагов сохраняются во внутренней базе данных STUDIO и доступны вам через меню "Навигация/Журналы".

Q: Внешнее приложение, которое выполняется в одной из задач, не имеет журнала – только экранный вывод. Как мне сохранить выводимые на экран данные?

A: Если выполняемая утилита не имеет журнала, а выводит что-либо на экран (в текстовом режиме, а не в GUI), то STUDIO может сохранить этот экранный вывод в качестве журнала. Для этого при создании задачи поставьте галочку "Внести в журнал рабочий экран".

Q: Как долго хранятся журналы в STUDIO?

A: Журналы хранятся в STUDIO неограниченное время. Удалить ненужные журналы вы можете вручную с помощью STUDIO (закладка "Журналы").

Наверх

Локализация

Q: Какие локализации интерфейса доступы для STUDIO?

A: В настоящей версии оболочка STUDIO поддерживает следующие локализации: английскую, немецкую, русскую, французскую.

Наверх

Если у Вас все еще есть вопросы, обратитесь в Службу поддержки.


Начало работы

SQL Management Studio for SQL Server - это законченное решение для разработки и администрирования и баз данных.

Чтобы получить информацию об основных операциях программы, о ее функциональных возможностях и основных разделах, либо узнать о способах настройки программы, выберите одну из следующих ссылок:

Работа со Studio Agent

Выбор языка программы

Первый запуск

Главное меню

Панели инструментов

Рабочая область

Панели навигации

Проводник БД

Приятной работы с SQL Management Studio for SQL Server!

Смотрите также:

Управление БД и данными

Планирование и выполнение задач

On-line ресурсы

Настройка опций программы


Работа со Studio Agent

SQL Management Studio for SQL Server Agent - это программа, необходимая для выполнения основных операций. Ее значок располагается в области уведомлений Windows. Для запуска SQL Management Studio for SQL Server щелкните два раза на значке Studio Agent в области уведомлений.

Getting Started - Using Studio Agent

С помощью Studio Agent можно:

  • Открыть окно содержащее информацию о версии программы и статусе регистрации;
  • Запустить SQL Studio или приложение;
  • Указать, стартовать ли Studio Agent при запуске Windows;
  • Запустить службу;
  • Приостановить работу службы.

Перечисленные действия могут быть выполнены при помощи выбора соответствующих пунктов контекстного меню Studio Agent. Вызов меню осуществляется щелчком правой кнопкой мыши на соответствующем значке в области уведомлений Windows.

Смотрите также:

Выбор языка программы

Первый запуск

Панели инструментов

Рабочая область

Панель навигации

Проводник БД


Выбор языка программы

При первом запуске SQL Management Studio for SQL Server будет предложено выбрать язык программы. При необходимости можно изменить эти установки позже, выбрав пункт главного меню Options | Localization.

Getting Started - Select language

Program Language

Выберите язык интерфейса SQL Management Studio for SQL Server из списка доступных.

Смотрите также:

Работа со Studio Agent

Первый запуск

Панели инструментов

Рабочая область

Панель навигации

Проводник БД


Первый запуск

Так выглядит SQL Management Studio for SQL Server при первом запуске.

В верхней части окна располагается Главное меню. из которого можно получить доступ ко всем элементам управления SQL Studio.

Под главным меню располагается панель инструментов, на которой расположены основные, часто используемые элементы управления.

В левой части отображается панель навигации.

Desktop Panel - главная рабочая область SQL Management Studio for SQL Server.

Отображающийся на ней набор инструментов изменяется в зависимости от выбранного на Панели навигации раздела.

В нижней части панели навигации располагается Проводник баз данных - DB Explorer. В нем в виде дерева отображаются все зарегистрированные серверы и базы данных. В проводнике баз данных можно добавлять и удалять элементы дерева баз данных, получать информацию об их регистрации, запускать службы SQL Server для выбранных баз данных.

Важно: Вся регистрационная информация зарегистрированных баз данных используется в утилитах, входящих в состав SQL Management Studio for SQL Server.

Смотрите также:

Работа со Studio Agent

Выбор языка программы

Панели инструментов

Рабочая область

Панель навигации

Проводник БД


Начало работы

Для начала работы с SQL Studio необходимо зарегистрировать базу данных.

Чтобы подключиться к незарегистрированной базе данных, необходимо выбрать в главном меню программы пункт Database | RegisterDB Register Database или Database | RegisterHost Register Host. Эти же пункты доступны в контекстном меню сервера или базы в Проводнике БД.

Зарегистрированные сервер базы данных отобразятся в Проводнике БД.

Удалить регистрации баз данных и серверов можно с помощью кнопок UnregisterDB Unregister Database и UnregisterHost Unregister Host, расположенных там же.

DBRegistrationInfo Database Registration Info - информацию о регистрации базы данных можно просмотреть в окне, открывающемся при выборе пункта Database Registration Info в контекстном меню базы данных.

После того, как заданы все необходимые настройки соединения, можно осуществлять Управление базами данных, управление данными, Планирование и выполнение задач, и использование других инструментов SQL Studio.


Панели инструментов

По умолчанию, Главная панель инструментов расположена в верхней части окна программы, над Рабочей областью. При нажатии той или иной кнопки панели, происходит переключение между различными видами действий, связанных с управлением данными и базами данных SQL Server.

DBManagement Database management - Работа с базами данных

DataManipulation Data Manipulation - Манипулирование данными

DataAnalysis Data Analysis - Анализ данных

TemplateManagement Template Management - Управление шаблонами

CustomTasks Custom Tasks - Работа с задачами

TaskScheduler Task Scheduler - Планировщик

Logs Logs - Журналы

Панель инструментов DB Explorer содержит элементы управления для работы с регистрацией баз данных SQL Server.

RegisterHost Register Host - Зарегистрировать хост

UnregisterHost Unregister Host - Удалить регистрацию сервера

RegisterDB Register Database - Зарегистрировать базу данных

UnregisterDB Unregister Database - Удалить регистрацию базы данных

DBRegistrationInfo Database Registration Info - Информация о регистрации

Панель инструментов можно настроить.

Можете переместить панель инструментов в любое удобное место в пределах окна программы.

Смотрите также:

Работа со Studio Agent

Выбор языка программы

Первый запуск

Рабочая область

Панель навигации

Проводник БД


Панель навигации

По умолчанию, Панель навигации расположена в левой части окна SQL Management Studio for SQL Server. Переключение между различными видами действий над базами данных и данными непосредственно происходит при выборе одного из пунктов на этой панели.

Tools - Инструменты:

  • Управление базами данных
  • Манипулирование данными
  • Анализ данных
  • Управление шаблонами

Tasks - Задачи:

  • Настройка задач
  • Планирование задач
  • Журналы

Internet - Интернет:

  • Ресурсы интернета
  • SQL Studio Direct
  • Поддержка

Explorer - проводник баз данных.

Включить или отключить отображение панели навигации можно с помощью пункта главного меню View | Navigation bar.

Чтобы свернуть некоторый раздел навигационной панели нужно нажать на кнопку, находящуюся рядом с названием раздела. Свернутую панель можно развернуть, нажав на эту же кнопку [image] [image] .

Смотрите также:

Работа со Studio Agent

Выбор языка программы

Первый запуск

Панели инструментов

Рабочая область

Проводник БД


Рабочая область

Desktop Panel - главная рабочая область SQL Management Studio for SQL Server. В зависимости от выбранного на панели инструментов или навигационной панели элемента на ней отображаются различные программы и утилиты EMS.

Getting Started - Desktop Panel

DBManagement Запуск SQL Manager for SQL Server, включающий в себя все основные возможности управления базами данных, или специальные средства SQL Server:

  • Backup Database - Резервное копирование базы данных (с шаблоном или без);
  • Restore Database - Восстановление базы данных из резервной копии (с шаблоном или без);
  • Attach Database - Присоединение базы данных (с шаблоном или без);
  • Detach Database - Отсоединение базы данных (с шаблоном или без);
  • Shrink Database (с шаблоном или без);
  • Indices Management (с шаблоном или без);
  • Update Statistics (с шаблоном или без);
  • Check Database (с шаблоном или без);

DataManipulation Запуск встроенных утилит управления данными:

  • Data Export for SQL Server (с шаблоном или без, GUI или консольная версия);
  • Data Import for SQL Server (с шаблоном или без, GUI или консольная версия);
  • Data Pump for SQL Server (с шаблоном или без, GUI или консольная версия);
  • Data Generator for SQL Server (с шаблоном или без, GUI или консольная версия);
  • SQL Script for SQL Server (с шаблоном или без, GUI или консольная версия);

DataAnalysis Запускать утилиты, предназначенные для анализа данных:

  • Data Comparer for SQL Server (с шаблоном или без, GUI или консольная версия);
  • DB Comparer for SQL Server (с использованием файла проекта или без, GUI или консольная версия);
  • DB Extract for SQL Server (с шаблоном или без, GUI или консольная версия);
  • SQL Query for SQL Server;

TemplateManagement управление шаблонами встроенных сервисов и инструментов;

CustomTasks управление различными задачами;

TaskScheduler управление запланированными задачами;

Logs управление журналами задач;

InternetResources использование доступных интернет ресурсов:

  • открытие Домашней страницы SQL Studio;
  • открытие страницы SQL Studio посвященной часто задаваемым вопросам;
  • открытие онлайн документации по компонентам SQL Studio;
  • посещение ресурсов, связанных с SQL Server;

StudioDirect использование SQL Studio Direct;

Support получение технической поддержки онлайн.

Чтобы включить или выключить краткое описание инструментов в Рабочей области можно в главном меню выбрать пункт View | Show Tool Descriptions.

Смотрите также:

Работа со Studio Agent

Выбор языка программы

Первый запуск

Панели инструментов

Панель навигации

Проводник БД


Проводник БД

По умолчанию, под Панелью навигации располагается Проводник БД, отображающий все зарегистрированные серверы и базы данных в виде дерева. С помощью Проводника БД можно добавлять и удалять из элементы дерева БД, получать информацию о их регистрации, запускать службы SQL Server для выбранных баз данных.

Важно: информация о зарегистрированных базах данных также используется в утилитах, входящих в состав SQL Management Studio for SQL Server.

Getting Started - DB Explorer

Включить или отключить отображение Проводника БД можно с помощью пункта главного меню View | Navigation bar | DB Explorer.

Контекстное меню элемента проводника баз данных

RegisterDB Register Database - Зарегистрировать базу данных.

UnregisterDB Unregister Database - Удалить регистрацию базы данных.

DBRegistrationInfo Database Registration - Info информации о регистрации базы данных.

RegisterHost Register Host - Зарегистрировать сервер.

UnregisterHost Unregister Host - Удалить регистрацию сервера.

  • Database Management - Управление базами данных.
  • Data Manipulation - Манипулирование данными.
  • Data Analysis - Анализ данных.

Смотрите также:

Работа со Studio Agent

Выбор языка программы

Первый запуск

Панели инструментов

Панель навигации

Проводник БД


Работа с базами данных и данными

Все возможности по управлению базами данных SQL Server, предоставляемые SQL Management Studio for SQL Server, объединены по типу действий.

Database Management - Управление базами данных

В данном разделе можно разрабатывать и администрировать базы данных при помощи SQL Manager for SQL Server, а так же запускать службы SQL Server.

Data Manipulation - Манипулирование данными

Эта группа предоставляет широкие возможности для экспорта/импорта данных с поддержкой более 15 распространенных форматов, для переноса данных между различными серверами БД и для генерации тестовых данных для баз данных.

Data Analysis - Анализ данных

Основными возможностями данного раздела являются сравнение и синхронизация структуры и содержания баз данных, создание резервных копий баз данных в виде скрипта SQL, получение и анализ данных при помощи визуально построенного запроса.

Template Management - Управление шаблонами

Для облегчения часто выполняемых операций в SQL Management Studio for SQL Server включены возможности создания шаблонов и управления ими.

Выбрать нужный раздел можно нажав соответствующий элемент Навигационной панели.

Смотрите также:

Начало работы

Планирование и выполнение задач

On-line ресурсы

Настройка опций программы


Управление базами данных

В разделе Database Management расположены элементы управления, с помощью которых можно разрабатывать и администрировать базы данных в SQL Manager for SQL Server, а также осуществлять запуск служб SQL Server.

Database Management - Desktop Panel

Запуск SQL Manager

Использование служб

Смотрите также:

Манипулирование данными

Анализ данных

Управление шаблонами


Запуск SQL Manager

EMS SQL Manager for SQL Server – это мощнейший инструмент для разработки и администрирования SQL Server. Поддерживает работу с версиями SQL Server с 7 до 2012, а также большинство нововведений SQL Server. Простой и понятный интерфейс упрощает работу с базами данных и их объектами, позволяет управлять таблицами данных и выполнять сценарии SQL. SQL Manager for SQL Server позволяет визуально разрабатывать базы данных, управлять записями пользователей и их привилегиями. Также можно свободно работать с метаданными, экспортировать данные в 15 наиболее популярных офисных форматов и импортировать их, просматривать/редактировать BLOB-поля и многое другое.

Для запуска SQL Manager for SQL Server щелкните на его значке или названии расположенным на рабочей области (Desktop Panel).

Database Management - Running SQL Manager

Для получения подробной информации смотрите документацию SQL Manager.

Смотрите также:

Использование служб


Использование служб

SQL Management Studio for SQL Server предоставляет возможность удобного запуска служб SQL Server, предназначенных для обслуживания баз данных и таблиц. Доступны следующие службы:

Database Management - Services

Для запуска службы щелкните ее значок или название на рабочей области. При необходимости использовать запуск службы с шаблоном, используйте выпадающий список Run wizard with template.

Для управления шаблонами используйте ссылку Manage templates.

Backup Database - Резервное копирование базы данных

Создание копии базы данных SQL Server.

Restore Database - Восстановление базы данных

Восстановление базы данных SQL Server из резервной копии.

Attach Database - Присоединение базы данных

Позволяет присоединить скопированную или отсоединенную базу данных к экземпляру SQL Server.

Detach Database - Отсоединение базы данных

Позволяет отсоединить базу данных от экземпляра SQL Server.

Indices Management - Управление индексами

Позволяет изменяет существующие индексы таблицы или представления (реляционного или XML) посредством отключения, перестройки, реорганизации или настройки индексных параметров.

Shrink Database - Сжатие базы данных

Сжатие базы данных позволяет сократить размер файлов данных и файлов журнала в заданной базе данных.

Update Statistics - Обновление статистики

Позволяет обновить данные о распространении значений ключей для одной или нескольких групп статистики (коллекций) в указанной таблице или индексированном представлении.

Check Database - проверка базы данных

Позволяет проверять целостность выделения пространства, структурную и логическую целостность всех объектов в указанной базе данных.

Смотрите также:

Запуск SQL Manager


Манипулирование данными

В разделе Data Manipulation расположены элементы управления, с помощью которых можно работать с данными.

с их помощью можно осуществлять экспорт, импорт данных в наиболее распространенных форматах, переносить данные между различными серверами БД и генерировать тестовые данные для баз данных.

Getting Started - Desktop Panel

Запуск Data Export

Запуск Data Import

Запуск Data Pump

Запуск Data Generator

Запуск SQL Script

Смотрите также:

Управление базами данных

Анализ данных

Управление шаблонами


Запуск Data Export

EMS Data Export for SQL Server – это приложение, предназначенное для экспорта данных из баз данных SQL Server в один из наиболее распространенных форматов, включая MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (конечные имена файлов, экспортируемые поля, форматы данных и многое другое) и консольной утилитой для автоматизации экспорта данных из таблиц и запросов.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса экспорта данных, - щелкните на ее значке или названии расположенным на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Manipulation - Running Data Export

Для получения подробной информации смотрите документацию по Data Export.

Смотрите также:

Запуск Data Import

Запуск Data Pump

Запуск Data Generator

Запуск SQL Script


Запуск Data Import

EMS Data Import for SQL Server – это инструмент для импорта данных из файлов форматов MS Excel, MS Access, DBF, XML, TXT и CSV в таблицы SQL Server. Data Import for SQL Server предусматривает настраиваемые параметры импорта, включая исходные форматы данных для всех полей, параметры столбцов для выбранных полей, параметры фиксации данных, количество пропускаемых строк и так далее. Data Import for SQL Server располагает удобным мастером для визуальной настройки опций импорта для различных типов файлов и консольной утилитой для автоматизации импорта.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса импорта данных, - щелкните на ее значке или названии расположенным на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Manipulation - Running Data Import

Для получения подробной информации смотрите документацию по Data Import.

Смотрите также:

Запуск Data Export

Запуск Data Pump

Запуск Data Generator

Запуск SQL Script


Запуск Data Pump

EMS Data Pump for SQL Server – это инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных SQL Server. Удобный и простой в использовании мастер настройки позволяет задавать строки соединения c ADO, выбирать таблицы, поля и индексы для переноса, просматривать и редактировать сценарии SQL для создания требуемой базы данных SQL Server, а также выбирать таблицы для импорта. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса переноса данных, - щелкните на ее значке или названии расположенным на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Manipulation - Running Data Pump

Для получения подробной информации смотрите документацию по Data Pump.

Смотрите также:

Запуск Data Export

Запуск Data Import

Запуск Data Generator

Запуск SQL Script


Запуск Data Generator

EMS Data Generator for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных SQL Server. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, создавать текстовые поля по маске, загружать значения для BLOB-полей напрямую из файлов, выбирать списки значений из запросов SQL, а также выполнять другие операции, связанные с генерацией тестовых данных простым и понятным способом. Консольное приложение из комплекта поставки позволяет автоматизировать генерацию данных, используя шаблоны.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса переноса данных, - щелкните на ее значке или названии расположенным на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Manipulation - Running Data Generator

Для получения подробной информации смотрите документацию по Data Generator.

Смотрите также:

Запуск Data Export

Запуск Data Import

Запуск Data Pump

Запуск SQL Script


Запуск SQL Script

SQL Script - утилита, позволяющая создавать и исполнять скрипты SQL.

SQL Management Studio for SQL Server также располагает консольной версией позволяющей автоматизировать исполнение скриптов, в том числе с использованием шаблонов.

Утилита может быть запущена самостоятельно.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Manipulation - Running SQL Script

Для получения подробной информации SQL Server смотрите документацию по SQL Script.

Смотрите также:

Запуск Data Export

Запуск Data Import

Запуск Data Generator

Запуск SQL Script


Анализ данных

В разделе Data Analysis расположены элементы управления, с помощью которых можно выполнять сравнение и синхронизацию структуры и содержания баз данных, создание резервных копий баз данных в виде сценария SQL, получение и анализ данных при помощи визуально построенного запроса.

Data Analysis - Desktop Panel

Запуск Data Comparer

Запуск Database Comparer

Запуск DB Extract

Запуск SQL Query

Смотрите также:

Управление базами данных

Манипулирование данными

Управление шаблонами


Запуск Data Comparer

EMS Data Comparer for SQL Server – приложение для сравнения и синхронизации данных. С помощью Data Comparer for SQL Server можно отслеживать все различия в сравниваемых таблицах и запускать автоматически исполняемый сценарий для их устранения. Гибкие параметры настройки процессов сравнения и синхронизации позволяют выбирать таблицы и поля для сравнения, а также настраивать другие функциональные опции. Data Comparer for SQL Server обладает графическим мастером настройки, который поэтапно проведет Вас через процессы сравнения/синхронизации, и консольной утилитой для синхронизации данных одним нажатием клавиши.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса переноса данных, - щелкните на ее значке или названии расположенным на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Analysis - Running Data Comparer

Для получения подробной информации смотрите Data Comparer documentation.

Смотрите также:

Запуск DB Comparer

Запуск DB Extract

Запуск SQL Query


Запуск Database Comparer

EMS DB Comparer for SQL Server – это отличный инструмент для сравнения и синхронизации баз данных. Он позволяет просмотреть все различия в объектах сравниваемых баз данных и выполнить автоматически сгенерированный сценарий SQL для устранения всех или выбранных отличий. Используя EMS DB Comparer for SQL Server, можно работать с несколькими проектами одновременно, задавать параметры сравнения, печатать отчеты о сравнении и изменять сценарии модификации. Его интуитивно понятный интерфейс значительно упрощает поиск и устранение различий в структуре баз данных SQL Server, сохраняя ваше время.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса сравнения структуры базы данных и синхронизации, - щелкните на ее значке или названии расположенных на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Analysis - Running DB Comparer

Для получения подробной информации смотрите документацию по DB Comparer.

Смотрите также:

Запуск Data Comparer

Запуск DB Extract

Запуск SQL Query


Запуск DB Extract

EMS DB Extract for SQL Server – это приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. Изменяя настройки процесса извлечения можно выбирать необходимые объекты и таблицы баз данных, а также настраивать многие другие параметры. Графический мастер настройки из комплекта поставки пошагово проведет Вас через процесс извлечения, а консольное приложение поможет быстро создать резервные копии баз данных.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса сравнения структуры базы данных и синхронизации, - щелкните на ее значке или названии расположенных на рабочей области.

При необходимости использовать запуск утилиты с шаблоном, используйте выпадающий список Run wizard with template, или Run console with template для запуска консольной версии утилиты с шаблоном.

Для управления шаблонами используйте ссылку Manage templates.

Data Analysis - Running DB Extract

Для получения подробной информации смотрите документацию по DB Extract.

Смотрите также:

Запуск Data Comparer

Запуск DB comparer

Запуск SQL Query


Запуск SQL Query

EMS SQL Query for SQL Server - это утилита для построения SQL запросов к базам данных SQL Server. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое. Можно работать с несколькими запросами одновременно, изменять запросы и просматривать результаты выполнения в различных режимах, а также выполнять любые другие операции, необходимые в повседневной работе с запросами к базам данных.

Утилита может быть запущена самостоятельно, Мастер проведет Вас через все этапы процесса сравнения структуры базы данных и синхронизации, - щелкните на ее значке или названии расположенных на рабочей области.

Data Analysis - Running SQL Query

Для получения подробной информации смотрите документацию по SQL Query.

Смотрите также:

Запуск Data Comparer

Запуск DB comparer

Запуск DB Extract


Управление шаблонами

В SQL Management Studio for SQL Server при использовании мастера предусмотрена возможность сохранения последовательности действий и параметров в специальных файлах, которые называются шаблоны. В зависимости от утилиты или службы, для которой должен быть создан шаблон, SQL Management Studio for SQL Server осуществит запуск соответствующего инструмента или диалога. На последнем шаге соответствующего Мастера можно сохранить настройки в качестве шаблона

Существующие шаблоны отображаются в разделе Template Management.

Template Management - Managing existing templates

Элементы управления для работы с шаблонами расположены на панели инструментов раздела Template Management и в контекстном меню шаблона.

AddTemplate Add existing Template to List - добавить в список существующий шаблон.

DeleteTemplateFromList Remove Templates from list - удалить существующий шаблон из списка.

CreateNewTemplate Create New Template - создать новый шаблон.

DeleteTemplateFromDisk Delete Templates from Disk - удалить шаблон с диска.

StartTemplate Start Tool with Template - запустить выполнение шаблона в соответствующей утилите.

Для отображения в списке шаблонов, относящихся только к одному приложению или службе, необходимо выбрать это приложение или службу из раскрывающегося списка Tool or Service.

Смотрите также:

Управление базами данных

Манипулирование данными

Анализ данных


Планирование и выполнение задач

Customizing tasks - Настройка задач

в данном разделе предоставлены возможности для создания, редактирования, удаления и неотложного запуска задач. Сэкономьте время и физические усилия при помощи пакетно-организованных задач. Создайте свою задачу при помощи встроенного Редактора Задач. Выберите подходящий для Вас тип уведомления из многих.

Scheduling tasks - Планирование задач

в этом разделе можно настроить отложенный или регулярный запуск задачи. Установите расписание запуска необходимых задач.

Managing logs - Управление журналами

Для контроля над выполнением задач, а также для просмотра результатов выполнения той или иной задачи создан раздел Управление журналами. Используйте просмотр журналов, задействуйте фильтр и возможности сортировки сетки данных.

Навигация между разделами с тем же успехом может быть осуществлена при помощи соответствующих пунктов Панели навигации.

Смотрите также:

Начало работы

Управление базами данных

On-line ресурсы

Настройка опций программы


Настройка задач

В разделе Custom Tasks предоставлены возможности для создания, редактирования, удаления и запуска задач. Задать настройки создаваемой и изменяемой задачи можно в специальном редакторе задач.

Управление задачами

Редактор задач

При ручном запуске задачи появляется окно Task Output, в котором отображается ее ход выполнения.

Customizing tasks - Task Output

Смотрите также:

Планирование задач

Управление журналами


Управление задачами и шагами

На вкладке Custom Tasks можно просматривать и изменять список задач.

Scheduling and Performing tasks - Managing task steps

Управлять задачами можно с помощью кнопок на панели инструментов, или пунктов контекстного меню задачи.

AddTask Add Custom Task - создать новую задачу.

EditTask Edit Custom Task - открыть существую задачу с помощью Редактора Задач.

DeleteTask Delete Custom Task - удалить существующую задачу.

RunCustomTask Run Custom Task - выполнить существующую задачу.

Созданная задача может быть выполнена сразу же или запланирована.

Для шагов задачи отображается отдельное контекстное меню, и становятся активны соответствующие кнопки на панели инструментов.

AddStep Add step - добавить шаг.

EditStep Edit step - редактировать шаг.

DeleteStep Delete Step - удалить шаг.

Изменять порядок задач или шагов внутри задачи можно с помощью кнопок MoveStepUp и MoveStepDown.

При необходимости можно быстро раскрыть или свернуть список задач с помощью кнопок CollapseAll Collapse All - Свернуть все и ExpandAll Expand All - Развернуть все на панели инструментов или в контекстном меню.

В нижней части окна располагается панель состояния текущей задачи. Там отображается список шагов для текущей задачи, утилиты/службы для ее выполнения, действия по окончании каждого из шагов и другую нужную информацию.

Смотрите также:

Редактор задач


Редактор задач

Окно Редактора Задач открывается автоматически при создании новой задачи, или при редактировании существующей.

В поле Task Name необходимо ввести имя создаваемой задачи.

Вкладки редактора

Steps - Шаги

Notifications - Уведомления

Description - Описание

Scheduling and Performing tasks - Task Editor - Steps

Steps

Каждая задача состоит из последовательности шагов, исполняемых в строгом порядке.

Для работы с шагами предназначены кнопки панели инструментов и пункты контекстного меню.

AddStep Add step - добавить шаг.

EditStep Edit step - редактировать шаг.

DeleteStep Delete Step - удалить шаг.

Порядок следования шагов можно менять при помощи кнопок MoveStepUp Move Step Up и MoveStepDown Move Step Down на панели инструментов.

В нижней части вкладки располагается панель состояния текущего шага. Она отображает пути к исполнимым файлам, имя используемого шаблона, путь к журналу, действия после выполнения шага и другую нужную информацию.

Для информирования о факте выполнения задачи можно использовать по желанию, в дополнение к журналам SQL Management Studio for SQL Server, специальные уведомления, которые могут быть установлены на вкладке Уведомления редактора задач.

Текстовое описание объекта можно задать на вкладке Description.

Смотрите также:

Управление задачами и шагами


Настройка уведомлений

На вкладке Notifications укажите адресата, которому необходимо отправлять результаты выполнения задачи.

Scheduling and Performing tasks - Task Editor - Notifications

Use net send operator

Уведомления отправляются с помощью оператора net send. Создайте сообщение для передачи на удаленный компьютер в окне соответствующего редактора.

Важно: на компьютере должна быть запущена служба Сообщения для использования данного типа уведомления. Панель управления | Администрирование | Службы | Оповещатель.

Use system application Log

- записать в журнал операций Windows,

Использовать системный журнал приложения

Позволяет производить отметку о выполнении задачи в системный лог. Создайте сообщение для записи в системный журнал приложения в окне соответствующего редактора.

Важно: для просмотра системного журнала приложения откройте в ОС Пуск | Панель управления | Администрирование | Просмотр событий | Приложение).

Use e-mail

Обеспечивает передачу уведомлений по электронной почте. Создайте сообщение для передачи по е-мейлу в окне соответствующего редактора. Заполните все необходимые поля - Хост (адрес smtp-сервера), его Порт (25 по умолчанию) и строку адреса.

Примечание: в тексте уведомления по электронной почте Вы также можете использовать макроимена (#START, #STOP, #RESULT). #START - время старта выполнения задачи, #STOP определяет время завершения выполнения задания; #RESULT содержит результат выполнения задачи.

Для отправки уведомления доступны две опции

CheckBox When job succeeds - отправлять отчет в случае удачного выполнения задания.

CheckBox When job fails - отправлять отчет в случае невыполнения или выполнения с ошибками.

Отослать тестовое сообщение можно с помощью кнопку Test.


Редактор шагов

Step Editor открывается автоматически при создании нового шага или при редактировании существующего.

Scheduling and Performing tasks - Task Editor - Step Editor

Step name

Имя шага.

Tool settings

Tool (Service) - из этого раскрывающегося списка необходимо выбрать утилиту или службу, для которой был создан шаблон.

Path - путь к нужной утилите прописывается автоматически.

Template (Parameters) - путь к файлу шаблона. Если шаблон уже был использован, то его можно выбрать из раскрывающегося списка.

Log file - путь к файлу журнала.

Log settings

В этой группе можно задать способы формирования журнала файла SQL Management Studio for SQL Server.

CheckBox Save screen to log - записать все сообщения, выводимые на экран утилитой/службой, в файл журнала SQL Management Studio for SQL Server.

CheckBox Get log from file - все содержимое журнала утилиты/службы будет сохранено в файле журнала SQL Management Studio for SQL Server.

Finish actions Действия по завершении

Successful action - действие, выполняемое при успешном завершении задачи.

Failure action - действие, выполняемое при возникновении ошибки при выполнении.

Timeout - время ожидания

Timeout action - событие, выполняемое при наступлении времени ожидания.

Для каждого случая можно выбрать одно из действий в соответствующем поле Step:

Perform next step - перейти к следующему шагу.

Perform step by name - перейти к указанному шагу.

Successful task ending - завершение успешно выполненной задачи.

Unsuccessful task ending - завершение задачи, выполненной с ошибками.

CheckBox Failure only for serious errors - если этот флажок установлен, то если во время выполнения произошли незначительные ошибки, подразумевающие возможность успешного продолжения работы, то будет сообщаться об успешном завершении задачи.

CheckBox Log size limitation

Установить максимальный размер файла журнала в Кб для текущего шага.


Планирование задач

На вкладке Task Scheduler можно задать расписание для выполнения каждой задачи.

Запланированные задачи

Редактор запланированных задач

Scheduling and Performing tasks - Managing scheduled tasks

Смотрите также:

Настройка задач

Управление журналами


Запланированные задачи

На вкладке Task Scheduler расположены элементы управления, с помощью которых можно управлять расписанием запуска заданий.

Scheduling and Performing tasks - Task Scheduler

Запланированные для выполнения задачи отображаются в виде таблицы. Эту таблицу можно сортировать и группировать.

Для каждой задачи отображается:

State - состояние задачи.

Task Name - имя задачи.

Start Date - дата и время первого запуска.

Last Run Date - дата и время последнего запуска.

Next Run Date - дата и время следующего запуска.

Last Result - результат последнего выполнения.

в нижней части окна отображается более подробная информация о выбранной задаче.

Управлять задачами можно с помощью кнопок, расположенных на панели инструментов и пунктов контекстного меню.

AddTask Add Scheduled Task - создать запланированную задачу.

EditTask Edit Scheduled Task - изменить расписание выполнения задачи.

DeleteTask Delete Scheduled Task - удалить запланированную задачу.

RunCustomTask Run Scheduled Task - выполнить задачу.

PauseTask Pause Scheduled Task - приостановить выполнение задачи.

Важно: Приостанавливать и выполнять задачи можно с помощью SQL Management Studio for SQL Server Agent. Для этого необходимо щелкнуть правой кнопкой мыши на значке Studio Agent в области уведомлений Windows, выбрать пункт меню PauseTask Suspend Scheduled Task или RunCustomTask Execute Scheduled Task и отметить необходимые задачи.

Смотрите также:

Редактор запланированных задач


Редактор запланированных заданий

Редактор запланированных заданий - Scheduled task editor - диалоговое окно, предназначенное для задания периодичности выполнения создаваемой или редактируемой задачи.

Scheduling and Performing tasks - Schedule Editor - Daily

Task name

Из этого списка выберите задачу, для которой надо создать расписание.

CheckBox Suspended - Задача находится в состоянии ожидания.

В разделе Recurrence pattern необходимо задать периодичность запуска выполнения задачи.

RadioButton Daily - ежедневно.

RadioButton Every n day(s) - каждые N дней.

RadioButton Every weekday - выполнение происходит по будням, исключая запуски в выходные дни.

RadioButton Weekly - еженедельно.

Данный шаблон повторений позволяет настроить запуск задачи по определенным дням недели каждые N недель.

Scheduling and Performing tasks - Schedule Editor - Weekly

RadioButton Monthly - ежемесячно

Можно настроить запуск задания на выполнение определенного числа каждые N месяцев; другой вариант - запуск выполнения задачи по определенным дням недели каждые N месяцев.

Scheduling and Performing tasks - Schedule Editor - Monthly

RadioButton Yearly - Ежегодно

В этом разделе можно задать конкретную дату выполнения (например, 14 июня), или установить для выполнения задания определенный день года по приведенному ниже шаблону.

Scheduling and Performing tasks - Schedule Editor - Yearly

Range of recurrence

В этом разделе необходимо задать период повторений задания.

Start date - дата начала выполнения задачи.

Start time - время начала выполнения задачи.

В список Daily launches, с помощью кнопок Add Launch и Delete Launch можно добавлять и удалять фиксированные часы для запуска задачи.

RadioButton No end date - отсутствие каких-либо ограничений для выполнения задачи.

RadioButton End after - окончание периода для задачи после выполнения ее N раз.

RadioButton End by - точная дата, к наступлению которой регулярное выполнение задачи будет завершено.

Смотрите также:

Запланированные задачи


Журналы

Для контроля над выполнением задач, а также для просмотра результатов выполнения той или иной задачи используется вкладка Logs. На ней отображаются журналы выполнения задач.

Scheduling and Performing tasks - Managing logs

Все выполненные задачи отображаются на вкладке Logs в виде таблицы. Строки этой таблицы можно сортировать и группировать.

Журнал представляет собой таблицу с полями Task Name - Имя задачи, Started at - время запуска, Stopped at - время остановки, Result - Результат выполнения.

Контекстное меню, появляющееся при нажатии правой клавиши мыши на объекте, позволяет Вам сохранять, удалять выбранный журнал, а также разворачивать или сворачивать дерево журналов шагов. Кнопки на панели инструментов дублируют функции контекстного меню.

В нижней части вкладки Logs отображается панель состояния для текущего журнала. В зависимости от выбранных установок для записи журналов она отображает данные, взятые с рабочего экрана утилиты или службы, данные из файла журнала утилиты или службы, либо и то и другое. Параметры записи журнала устанавливаются в процессе создания шага.

Панель инструментов Logs позволяет Вам сохранять журналы выбранных заданий как файл, ненужные журналы могут быть удалены с помощью одноименной кнопки. Элементы контекстного меню таблицы дублируют элементы управления, расположенные на панели инструментов.

Важно: для того, чтобы быстро свернуть или развернуть дерево журналов, используйте контекстное меню или соответствующие кнопки на панели инструментов.

Выпадающий список Show logs for позволяет фильтровать журналы задач в соответствии с выбранным периодом.

Смотрите также:

Настройка задач

Планирование задач


On-line ресурсы

В разделе On-line ресурсы расположены ссылки на полезные материалы по SQL Management Studio for SQL Server.

Internet Resources - Ресурсы интернета

Содержит ссылки, относящиеся к SQL Studio и утилитам, входящим в состав SQL Management Studio for SQL Server, а также на FAQ и онлайн документацию.

SQL Studio Direct

В этом разделе содержатся новости EMS, ссылки на последние новости SQLManager.net, ссылки на описание продуктов и страницы загрузки.

Contacting Support Center - Связь с центром поддержки

Осуществляет соединение с центром поддержки EMS (EMS Support Center). После входа в систему Вы получите ответы на все интересующие Вас вопросы прямо в окне SQL Management Studio for SQL Server. Если Вы являетесь зарегистрированным пользователем программного обеспечения EMS, Вы получаете гарантированный ответ в течение 24 часов.

Навигация между осуществляется при помощи соответствующих пунктов Панели навигации.

Смотрите также:

Начало работы

Управление базами данных

Планирование и выполнение задач

Настройка опций программы


Ресурсы интернета

Данная вкладка содержит ссылки, относящиеся к SQL Studio и утилитам, входящим в состав SQL Management Studio for SQL Server, а также на FAQ и онлайн документацию.

Выберите ссылку из числа представленных в окне и щелкните по ней.

Online Resources - Browsing Internet Resources

Смотрите также:

SQL Studio Direct

Центр поддержки


SQL Studio Direct

Данный раздел предоставляет доступ к последним новостям EMS. Он также содержит ссылки на последние новости SQLManager.net, ссылки на описание продуктов и страницы загрузки.

Опция Automatically poll network in interval (in days) позволит вам установить интервал обновления в днях. Чтобы отключить автоматическое обновление (не рекомендуется), просто кликните на иконку AutomaticallyPoll опции.

Online Resources - SQL Studio Direct

В нижней части страницы можно найти прямые ссылки на выбранный ресурс.

Смотрите также:

Ресурсы Интернета

Центр поддержки


Поддержка

В этом разделе осуществляется соединение с центром поддержки EMS - EMS Support Center. После входа в систему Вы получите ответы на все интересующие Вас вопросы прямо в окне SQL Management Studio for SQL Server.

Важно: если Вы являетесь зарегистрированным пользователем программного обеспечения EMS, Вы гарантированно получаете ответ в течение 24 часов.

Online Resources - Support Center

Смотрите также:

Ресурсы Интернета

SQL Studio Direct


Настройка опций программы

В данном разделе можно изменить настройки программы SQL Management Studio for SQL Server.

Выбор языка

Опции отображения

Настройка Studio Agent

Смотрите также:

Начало работы

Управление базами данных

Планирование и выполнение задач

On-line ресурсы


Выбор языка

Если необходимо изменить язык программы, выбранный при первом запуске SQL Management Studio for SQL Server, то можно это сделать в диалоговом окне Options на вкладке Localization. Чтобы открыть это окно, необходимо в главном меню программы выбрать пункт Options | Localization.

Options - Localization

В списке представлены все доступные языки программы. Для подтверждения выбора нужно нажать кнопку OK.

Чтобы создать новую локализацию необходимо создать новый файл локализации с расширением *.lng, поместить его в папку %program_directory%\Studio\Languages, затем нажать кнопку Load languages. После этого в списке локализаций появится новый язык, который можно устанавливать как программный.

Смотрите также:

Опции отображения

Настройка Studio Agent


Опции отображения

Для достижения максимального удобства при работе с SQL Management Studio for SQL Server, можно настроить ее внешний вид и выбрать визуальный стиль окружения. Диалоговое окно настроек опций отображения программы вызывается пунктом главного меню Options | Visual options.

Options - Interface

Применить опции отображения SQL Management Studio for SQL Server для всех приложений, входящих в ее состав, установив флажок CheckBox Apply to all studio applications.

Смотрите также:

Выбор языка

Настройка Studio Agent


Настройка Studio Agent

Для автоматического запуска Studio Agent вместе с Windows, щелкните левой кнопкой мыши на значке Windows в области уведомлений Windows и выберите соответствующий пункт меню.

Options - Setting agent options

Используя меню Studio Agent можно вызвать меню About, открыть SQL Management Studio for SQL Server, запустить любую утилиту для управления базами данных и манипуляции данными, выполнить задачу, или отложить выполнение запланированной. можно указать загружать или нет Studio Agent при запуске системы, а также управлять работой службы (если студия была установлена в режиме службы).

Смотрите также:

Выбор языка

Опции отображения


Интерфейс программы

Общими особенностями интерфейса программы SQL Management Studio for SQL Server являются:

Главное меню

С помощью главного меню можно получить доступ ко всем инструментам программы и выполнить все действия над объектами базы данных.

Getting Started - Main menu

Дополнительно смотрите страницу Настройка панелей управления.

Сплиттеры

Сплиттеры - разделительные полосы между окнами, позволяющие быстро свернуть и развернуть окно.

Customization - Splitter

Для того чтобы свернуть окно достаточно одного нажатия на сплиттер левой кнопкой мыши.


Настройка панелей управления

Любую панель инструментов можно настроить.

Её можно настраивать, используя функцию Add or Remove Buttons, открывающуюся при нажатии на кнопку More Buttons MoreButtons в правом углу панели.

В появившемся окне выберите кнопки, которые должны отображаться на панели.

Нажав на любую панель управления правой кнопкой мыши и выбрав пункт Customize.

Если на панели инструментов нажать правой кнопкой мыши, то тоже появится кнопка Customize.

При нажатии на эту кнопку открывается окно редактирования панели инструментов.

Вкладка Toolbars

Appendix - Customize - Toolbars

На этой вкладке можно создавать, редактировать и удалять панели инструментов.

New - добавить панель инструментов,

Rename - переименовать,

Delete - удалить.

Вкладка Commands

На этой вкладке выберите кнопки, которые будут отображаться на панели инструментов.

Options - Customizing menus and toolbars

В списке Categories выберите категорию, а в списке Commands - команду, относящуюся к выбранной категории.

Чтобы поместить нужную кнопку на панель её нужно перетащить из списка Commands на панель инструментов.

Вкладка Options

Appendix - Customize - Options

CheckBox Menus show recently used command first - всегда показывать полные меню.

CheckBox Show full menus after a short delay - показывать полные меню после небольшой задержки.

Reset my usage data - сброс.

CheckBox Large icons - крупные значки.

CheckBox Show ToolTips on Toolbars - отображать подсказки для кнопок.

CheckBox Show shortcut keys in ToolTips - включить в подсказки сочетания клавиш.

Menu animations - анимация при выборе меню.


Использование шаблонов

В SQL Management Studio for SQL Server при использовании мастера предусмотрена возможность сохранения последовательности действий и параметров в специальных файлах, которые называются шаблоны.

На последнем шаге мастера можно сохранить все текущие настройки утилиты. Для этого необходимо нажать кнопку Templates и выбрать пункт Save Template. Вам будет предложено указать имя шаблона и сохранить необязательный комментарий к нему.

При последующей работе с мастером можно загрузить сохраненный шаблон, нажав кнопку Templates и выбрав пункт меню Load Template.


Поддерживаемые форматы

MS Excel

Наиболее популярный формат файлов для хранения электронных таблиц, разработанный Microsoft.

(*.xls)

MS Access

Файл этого формата представляет собой базу данных Access, с возможностью использования ADO connection.

(*.mdb)

MS Word

Наиболее популярный формат текстовых документов, разработанный Microsoft.

(*.doc)

RTF

Межплатформенный формат хранения размеченных текстовых документов, предложенный Microsoft. RTF-документы поддерживаются большинством современных текстовых редакторов.

(*.rtf)

HTML

(от англ. Hypertext Markup Language — "язык разметки гипертекста")

Формат для отображения web страниц

(*.html, *.htm)

PDF

Межплатформенный формат электронных документов, предназначен для представления в электронном виде полиграфической продукции.

(*.pdf)

Text file

Текстовый файл

(*.txt)

CSV

(от англ. Comma Separated Values — значения, разделенные запятыми)

Текстовый формат, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом (delimiter), например, запятой (,), точкой с запятой(;), символом табуляции. Текстовые значения обрамляются символом двойные кавычки ("); если в значении встречаются кавычки — они представляются в файле в виде двух кавычек подряд.

(*.csv)

DIF

Стандарт для файлов обмена данными

(*.dif)

SYLK

Формат Символической Связи.

(*.slk)

LaTeX

Специфический формат файлов макрорасширений к TeX.

(*.tex)

XML

Расширяемый язык разметки. Предназначен для хранения структурированных данных

(*.xml).

DBF

Формат хранения данных, используемый в качестве одного из стандартных способов хранения и передачи информации системами управления базами данных, электронными таблицами и т.д.

(*.dbf)

MS Excel 2007

Разработанный Microsoft формат файлов для хранения электронных таблиц. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.xlsx)

MS Word 2007

Разработанный Microsoft формат файлов для хранения электронных документов. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.docx)

MS Access 2007

Разработанный Microsoft формат файлов для хранения баз данных. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.accdb)

ODF Spreadsheets

Открытый формат файлов документов для хранения и обмена редактируемыми офисными документами - электронными таблицами.

(*.ods)

ODF text

Открытый формат файлов документов для хранения и обмена редактируемыми текстовыми офисными документами

(*.odt)


Sorting

SQL Management Studio for SQL Server
  • В начало
  • « Назад

Сортировка, группировка, фильтрация

Сортировка

Чтобы отсортировать данные необходимо нажать на заголовок этого столбца мышкой. Если столбец не был отсортирован, то одно нажатие отсортирует его по возрастанию, следующее - по убыванию. Индикатором сортировки служит стрелочка в заголовке столбца.

Группировать

Группировка осуществляется с помощью панели группировки, расположенной над заголовками столбцов таблицы.

Чтобы сгруппировать таблицу по одному или нескольким столбцам необходимо перетащить заголовки столбцов на панель группировки, расположенную над таблицей.

Сгруппированные данные отображаются в виде таблицы со свернутыми подуровнями.

Чтобы развернуть все подуровни, используйте пункт контекстного меню области группировки ExpandAll Full Expand.

Чтобы свернуть все подуровни, используйте пункт контекстного меню области группировки CollapseAll Full Collapse.

Grouping by two columns

Убрать группировку

Переместить заголовок столбца с панели группировки на его прежнее место.

Фильтрация

В правом верхнем углу заголовка столбца нажать значок фильтра CustomFilter. Выбрать из раскрывшегося списка одно из условий фильтра - Custom, Blanks (пустые ячейки), Non blanks (непустые ячейки) или одно из значений списка. При выборе Custom задать необходимые параметры отбора в появившемся диалоговом окне.

Custom Auto Filter

В этом диалоговом окне можно задать два условия фильтрации и их отношение - должны ли выполняться оба условия сразу, или достаточно выполнения одного. Установив переключатель в положение RadioButton AND укажите, что оба условия должны выполняться одновременно, в положение RadioButton OR укажите, что должно выполняться только одно из них.

Custom Auto Filter

Из раскрывающихся списков выбираем условие отбора:

  • равно - equals,
  • не равно - does not equal,
  • больше - is greater than,
  • больше или равно - is greater than or equal to,
  • меньше - is less than,
  • меньше или равно - is less than or equal to,
  • пустые - is blank,
  • непустые - non blank,
  • похоже (для текстовых полей) - like,
  • не похоже (для текстовых полей) - not like.

В поле указываем последовательность символов. Используйте символ "%" для указания любого набора символов и символ "_" для обозначения любого символа. При выполнении условия отбираются только те значения, которые отвечают указанному условию.

Удалить фильтр

Удалить фильтр и отобразить все записи таблицы можно Выбрав пункт All в раскрывающемся списке заголовка столбца.