Добpо пожаловать в EMS DB Extract!

DB Extract for SQL Server
  • В начало
  • Вперед »

Добро пожаловать в EMS DB Extract!

EMS DB Extract for SQL Server – это простая и высокопроизводительная программа для создания резервных копий баз данных SQL Server в виде сценариев SQL. Приложение для создания SQL скриптов позволяет сохранять как метаданные всех объектов баз данных SQL Server, как и данные из таблиц SQL Server в виде снимков. DB Extract сохраняет объекты баз данных SQL Server в определенном порядке в соответствии с их зависимостями. Благодаря широкому выбору настроек вы можете выбирать необходимые объекты и таблицы для создания дампа базы данных SQL Server, а также задавать многие другие параметры. DB Extract for SQL Server включает графический мастер, который пошагово проведет вас через процесс извлечения, и консольное приложение для быстрого создания резервных копий баз данных SQL Server.

Посетите наш сайт http://www.sqlmanager.net/ru/

Ключевые особенности:

  • Поддержка данных в формате Unicode
  • Дружественный интерфейс мастера настройки
  • Возможность выбора объектов для извлечения
  • Возможность задавать ограничения для извлекаемых данных
  • Возможность вставки запросов для очистки таблиц перед вставкой извлеченных данных
  • Извлечение данных в сценарии SQL в виде команд INSERT
  • Возможность извлекать объекты БД в правильном порядке, учитывая зависимости между ними
  • Возможность сжимать итоговый сценарий и разбивать его на тома
  • Возможность выбора кодировки символов в итоговом файле
  • Возможность сохранения всех параметров текущей сессии в файл конфигурации
  • Консольная утилита для извлечения данных и метаданных с помощью файла конфигурации

Информация по продукту:

Домашняя страница: | http://www.sqlmanager.net/ru/products/mssql/extract
Служба поддержки: | http://www.sqlmanager.net/ru/support
Регистрация: | http://www.sqlmanager.net/ru/products/mssql/extract/buy


Новости

Версия | Дата выпуска
DB Extract for SQL Server 3.0.1.1 | 30.09.2011

Что нового в DB Extract?

Извлечение данных:

  • Добавлена поддержка Unicode.
  • Скорость извлечения данных значительно увеличена.
  • Данные из двоичных полей извлекались неверно. Исправлено .

Извлечение метаданных.

  • Добавлена поддержка Unicode в описаниях объектов, процедурах, телах триггеров и т.д.
  • Поддержка версий сервера SQL Server до версии 2008.
  • Добавлена поддержка новых серверных объектов и объектов баз данных
  • Улучшен алгоритм извлечения зависимостей объектов.
  • Скорость извлечения метаданных значительно увеличена.
  • Таблицы с внешними ключами извлекались неверно. Исправлено

Параметры файлов:

  • Теперь для итогового файла доступно несколько кодировок.
  • Архивы теперь можно разбивать на части.
  • Появилась возможность добавлять текущее время, дату или дату и время к пути к файлу, к имени архива, сценария или файла BLOB.
  • Шаблоны с параметрами для запланированных задач сохранялись неверно. Исправлено.

Интерфейс:

  • Теперь можно изменять размер окна программы.

Другие исправления и изменения.

Смотрите также:

Предыдущие версии


Сиcтемные требования

  • Процессор с тактовой частотой 300 мегагерц (МГц); рекомендуется 600 МГц или выше
  • Microsoft Windows NT4 c SP4 или более поздней версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows 2008 Server, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8, Microsoft Windows Server 2012
  • 64 MB RAM (рекомендуется 128 MB или более)
  • 20MB свободного пространства на жестком диске для установки программы
  • Видео-карта Super VGA и монитор с минимальным разрешением 800x600 (рекомендуется Super VGA с разрешением 1024x768 или выше)
  • Совместимая c Windows мышь
  • Microsoft Data Access Components (MDAC) или SQL Server Native Client
  • Возможность соединения с локальным или удаленным сервером SQL Server™
  • Поддерживаемые версии сервера MS SQL Server: с 7.0 по 2008


Установка

Установка программы DB Extract for SQL Server

  • загрузите установочный файл программы со страницы загрузки,
  • извлеките из архива полученный файл в нужную директорию (например, c:\unzipped),
  • откройте файл MsExtract.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Часто задаваемые вопросы по установке ПО

Обновление программы

  • загрузите установочный файл программы со страницы загрузки сайта,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • закройте программу DB Extract for SQL Server, если она запущена,
  • откройте файл MsExtract.exe и следуйте инструкциям мастера обновления.

Смотрите также:

Системные требования


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Share-it!. Процедура совершения покупки через Share-it! защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернет и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией Share-it!.

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Если Вы приобрели продукт в комплекте с подпиской на Сопровождение, подписка будет автоматически активирована после ввода регистрационного ключа в регистрационный диалог Вашей программы. Если же Вы приобрели подписку на Сопровождение отдельно, просто откройте регистрационный диалог Вашей программы и введите полученные Вами регистрационное имя и ключ.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Описание продукта | Share It!
EMS DB Extract for SQL Server (Бизнес версия) + 3 года Сопровождения | Купить!
EMS DB Extract for SQL Server (Бизнес версия) + 2 года Сопровождения
EMS DB Extract for SQL Server (Бизнес версия) + 1 года Сопровождения
EMS DB Extract for SQL Server (Некоммерческая версия) + 3 года Сопровождения
EMS DB Extract for SQL Server (Некоммерческая версия) + 2 года Сопровождения
EMS DB Extract for SQL Server (Некоммерческая версия) + 1 года Сопровождения
EMS DB Extract for SQL Server (Пробная версия) | Загрузить!

Смотрите также:

Регистрация


Регистрация

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией из Share-it!
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно - проверить наличие регистрационного имени и пароль на стартовой странице. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

hs1500 - Register product

Смотрите также:

Приобретение


Предыдущие версии

Версия | Дата выпуска
DB Extract 2005 for SQL Server Версия 2.2 | 07.03.2007
DB Extract 2005 for SQL Server Версия 2.1 | 08.02.2006

Полная история версий доступна на сайте http://www.sqlmanager.net/ru/products/mssql/extract/news

DB Extract 2005 for SQL Server Версия 2.2

  • Улучшенный алгоритм извлечения объектов с учетом зависимостей между ними.
  • Добавлена выгрузка BLOB полей
  • В опции Удалять записи перед вставкой (“Delete records before insert”) для очистки таблиц теперь применяется оператор TRUNCATE вместо оператора DELETE
  • Значительно возросла скорость выгрузки данных.
  • Другие улучшения и дополнения

DB Extract 2005 for SQL Server Версия 2.1

  • Добавлена возможность извлечения прав.
  • В Мастере на шаге "Выбор объектов" добавлена поддержка новых типов объектов
  • Улучшена работа с шаблонами благодаря новым возможностям сохранения
  • Добавлена опция "Add PRINT <object name> statement before extraction" на Шаге 6.

Смотрите также:

Новости


Часто задаваемые вопросы

  • Что такое DB Extract for SQL Server?
  • Что мне необходимо для начала работы с DB Extract for SQL Server?
  • Как проще всего сконфигурировать файлы-шаблоны для работы с консольным приложением?
  • Чем отличается функция "Извлечь метаданные/Extract Metadata" доступная в SQL Manager от приложения DB Extract for SQL Server?
  • Есть ли какие нибудь ограничения в триальной версии?

В: Что такое DB Extract for SQL Server?

О: EMS DB Extract for SQL Server - это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.

В: Что мне необходимо для начала работы с EMS DB Extract for SQL Server?

О: Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному серверу SQL Server (http://www-306.ibm.com/software/data/db2/ http://www.microsoft.com/downloads/). Загрузка бесплатна.

Во-вторых, Вам нужен компьютер, работающий под управлением ОС Microsoft Windows NT4 c SP4 или более поздний версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows Vista и удовлетворяющий следующим системным требованиям: Pentium 300, 64 Mb RAM.

В: Как проще всего сконфигурировать файлы-шаблоны для работы с консольным приложением?

О: Сконфигурировать файлы-шаблоны для каждой таблицы проще всего визуально, используя DBDB Extract for SQL Server. На третьем Шаге мастера настройте необходимые параметры и нажмите кнопку Tools | Save template. Все настройки будут сохранены в файле-шаблоне, который может быть использован консольным приложением.

В: Чем отличается функция "Извлечь метаданные/Extract Metadata" доступная в SQL Manager от приложения DB Extract for SQL Server?

О: DB Extract for SQL Server включает в себя несколько дополнительных возможностей, отсутствующих в SQL Manager for SQL Server:

  • консольное приложение для упрощенного процесса извлечения;
  • извлечение метаданных из нескольких баз данных, расположенных на одном сервере;
  • большая скорость работы.

В: Есть ли какие нибудь ограничения в триальной версии?

О: Триальная версия не отличается от полной версии. Вы можете использовать все инструменты программы в течение тридцатидневного тестового периода.

Наверх

С появившимися вопросами обращайтесь в Центр технической поддержки.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Мастер извлечения баз данных

Мастер извлечения базы данных обладает простым и интуитивно понятным интерфейсом. С его помощью Вы без труда сможете выполнить необходимые операции.

Использование мастера

Файлы конфигурации

Настройки программы

hs2000 - Wizard application

Смотрите также:

Консольное приложение


Использование мастера

Мастер позволит Вам быстро выполнить операцию. На каждом его шаге необходимо указывать определенные параметры излечения баз данных.

Начало

Шаг 1 - Задание параметров подключения

Шаг 2 - Выбор баз данных

Шаг 3 - Указание типов объектов

Шаг 4 - Выбор объектов для извлечения метаданных

Шаг 5 - Выбор таблиц для извлечения данных

Шаг 6 - Задание параметров извлечения

Шаг 7 - Указание имен файлов и директорий

Шаг 8 - Параметры расписания

Шаг 9 - Выполнение операции

hs2000 - Wizard application

Смотрите также:

Использование консольного приложения


Начало

Так выглядит DB Extract for SQL Server при первом запуске.

На этой форме Вы можете просмотреть регистрационную информацию, или, нажав кнопку Enter Registration Code, ввести имя и регистрационный ключ в появившемся окне.

Если регистрационный ключ указан правильно, то появится сообщение о дате окончания периода сопровождения.

Если копия программы не зарегистрирована, то в нижней части формы отображается количество дней, оставшихся до окончания действия ознакомительной копии.

hs2101 - Getting started

Нажмите кнопку Next для перехода к первому шагу

Смотрите также:

Приобретение


Шаг 1 - Задание параметров подключения

На этом шаге задайте параметры подключения к серверу SQL Server.

hs2103 - Step1 - Setting connection properties

В разделе Connection type выберите тип соединения с сервером.

RadioButton Local - локальное соединение (сервер установлен на этом компьютере)

RadioButton Remote - соединение с сервером по сети

В разделе Authentication type задается способ идентификации пользователя на сервере. Будет ли программа распознавать его по доменному имени и паролю - Windows или же по его персональным имени и паролю на сервере - SQL Server.

Если выбираете RadioButton SQL Server, то следует указать имя и пароль. Имя указывается в поле Login, пароль - в поле Password.

Если выбираете RadioButton Windows, то имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows.

Из раскрывающегося списка Host выбираете сервер (хост), к которому хотите подключиться. В этот список программа автоматически добавляет серверы, найденные в локальной сети. Если компоненты SQL-DMO components установлены на клиентском компьютере, используется их функция ListAvailableSQLServers. Если SQL-DMO components не установлены, используется функция NetServerEnum из netapi32.dll. Если данная библиотека не установлена, то при первом открытии программы этот список будет пуст, и имя сервера необходимо будет задать вручную. В этом случае в списке Server будут отображаться те серверы, базы данных которых уже зарегистрированы в программе.

Примечание: имя сервера не всегда может отображаться в списке, тогда вводите его вручную.

MS SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2005 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в Server Вы должны будете указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

Примечание: тип подключения Local выбирается только в случае подключения к локальному серверу, установленному, как неименованный экземпляр. В случае подключения к именованному экземпляру локального сервера, выберите тип подключения Remote и хост в формате localhost\ИМЯЭКЗЕМПЛЯРА, или 127.0.0.1\ИМЯЭКЗЕМПЛЯРА.

Если Вы используете версию DB Extract for SQL Server для EMS SQL Management Studio for SQL Server, то на первом шаге доступна кнопка Select registered database, при нажатии на которую открывается диалог выбора базы данных из зарегистрированных в EMS SQL Management Studio.

Следующий шаг


Выбор зарегистрированной базы данных

В этом диалоге выберите базу данных для извлечения. Этот диалог доступен только в версии DB Extract for SQL Server для EMS SQL Management Studio.

Selecting registered database

В этом списке отображаются все базы данных, зарегистрированные в EMS SQL Management Studio.

Выберите нужную базу и нажмите кнопку OK.

Регистрационная информация базы данных автоматически появится в соответствующих полях на первом шаге.


Шаг 2 - Выбор баз данных

На этом шаге Вам необходимо выбрать одну или несколько баз данных из которых будут извлекаться данные и метаданные.

hs2105 - Step2 - Selecting databases

В списке Available Databases Вы можете видеть все доступные на сервере базы данных.

С помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available, перетаскивания или двойного щелчка мыши, переместите базы данных из списка доступных - Available Databases - в список выбранных - Selected Databases.

Важно: Чтобы выбрать несколько баз данных одновременно, удерживайте клавиши Shift или Ctrl во время выделения объектов.

Следующий шаг


Шаг 3 - Указание типов объектов

На этом шаге Вы можете выбрать типы извлекаемых объектов.

hs2107 - Step3 - Specifying types of objects

Extract options

RadioButton Extract both structure and data - извлечь данные и метаданные.

RadioButton Extract metadata only - извлечь только метаданные.

RadioButton Extract data only - извлечь только данные.

Metadata options

RadioButton Extract all objects - извлечь все объекты.

RadioButton Extract selected objects - извлечь выбранные объекты.

Вы можете выбрать несколько типов объектов, которые будут извлечены.

Отметьте флажками нужные типы объектов.

Быстро выделить все типы объектов Вы можете, нажав на кнопку Select all. Unselect all позволит убрать все флажки. Вы можете обратить выделение, нажав кнопку Invert selection.

Эти операции доступны в контекстном меню, открывающемся при нажатии правой кнопкой мыши в разделе Metadata options.

Step 3 - Context menu

Data options

RadioButton Extract all data tables - извлечь все данные таблиц.

RadioButton Extract selected data tables - извлечь данные только выбранных таблиц.

Перейти на Шаг 4 если выбран Extract all objects

Перейти на Шаг 5 или Шаг 6 если выбран Extract selected objects


Шаг 4 - Выбор объектов для извлечения метаданных

На этом шаге выберите объекты базы данных, которые будут извлечены.

hs2109 - Step4 - Selecting objects for metadata extraction

На этом шаге отображается список доступных объектов исходной базы данных - Source database content. Объекты представлены в виде дерева. Управлять списком Вы можете с помощью контекстного меню.

Если хотите импортировать объект в назначенную базу данных, то установите флажок напротив его названия.

В поле Source object definition отображается дополнительная информация по выделенному объекту. Если источник не поддерживает схемы, то главным узлом древовидной структуры будет узел таблиц.

В дереве Available objects отображаются все доступные объекты базы данных. Типы объектов Вы выбрали на шаге Указание типов объектов.

Изначально объекты сгруппированы по принадлежности к базе данных и по типам объектов. Вы можете изменить группировку, переместив заголовок нужного столбца в верхнюю область формы. Перетащив выбранный заголовок обратно Вы отмените группировку.

Кроме того, вы можете использовать диалоговое окно Custom Filter, в котором можно установить условия для фильтрации объектов дерева.

hs2109 - Step4 - Custom Filter

Из списка Available objects выберите доступные объекты и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available, перетаскивания или двойного щелчка мыши, переместите их в список выбранных объектов - Selected objects.

Важно: Вы можете выбрать одновременно несколько объектов, выделяя имя нужного и удерживая при этом клавишу Shift или Ctrl.

Контекстное меню списков Available objects и Selected objects позволяет Вам упростить работу с большим количеством объектов.

Step 4-5 - Context Menu

С помощью этого меню Вы можете:

Expand All - развернуть всё,

Collapse All - свернуть всё,

Set Filter - установить фильтр.

Конструктор фильтров позволяет задать условия отбора объектов. Вы можете сохранить критерии фильтра в файле *.flt, а затем загрузить из этого файла, при необходимости.

Чтобы сохранить условия фильтра во внешний файл, с расширением *.flt, нажмите кнопку Save As. Нажав на кнопку Open, Вы можете открыть ранее сохраненный файл с условиями фильтра.

hs2109 - Step4 - Filter Builder

Перейти на следующий шаг если выбран Extract all data tables на Шаге 3.

Перейти на Шаг 6


Шаг 5 - Выбор таблиц для извлечения данных

На этом шаге выберите таблицы, данные которых должны быть извлечены.

В списке Available data tables отображаются таблицы, относящиеся к базам данных, которые были выбраны на шаге Выбор объектов для извлечения метаданных. Список имеет вид дерева, в котором таблицы сгруппированы по принадлежности к базе данных и схеме.

hs2111 - Step5 - Selecting tables for data extraction

Из списка Available data tables выберите доступные таблицы и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available, перетаскивания или двойного щелчка мыши, переместите их в список выбранных таблиц - Selected data tables.

Важно: Вы можете выбрать одновременно несколько объектов, выделяя имя нужного и удерживая при этом клавишу Shift или Ctrl.

Контекстное меню списков Available data tables и Selected data tables позволяет Вам упростить работу с большим количеством объектов.

Step 4-5 - Context Menu

С помощью этого меню Вы можете:

Expand All - развернуть всё,

Collapse All - свернуть всё,

Set Filter - установить фильтр.

С помощью диалоговое окно Custom Filter Вы можете устанавливать условия фильтрации таблиц.

hs2111 - Step5-6 - Custom Filter

Конструктор фильтров позволяет задать условия отбора объектов. Вы можете сохранить критерии фильтра в файле *.flt, а затем загрузить из этого файла, при необходимости.

Чтобы сохранить условия фильтра во внешний файл, с расширением *.flt, нажмите кнопку Save As. Нажав на кнопку Open, Вы можете открыть ранее сохраненный файл с условиями фильтра.

hs2111 - Step5-6 - Filter Builder

Следующий шаг


Шаг 6 - Задание параметров извлечения

На этом шаге задайте настройки генерируемого SQL скрипта для извлечения данных.

Metadata options

CheckBox Generate "CREATE DATABASE" statements

В генерируемый скрипт будет добавлен оператор CREATE DATABASE.

CheckBox Generate "USE DATABASE" statement

В генерируемый скрипт будет добавлен оператор USE DATABASE.

CheckBox Generate "DROP "statements

В генерируемый скрипт будет добавлен оператор DROP .

CheckBox With "IF" statements

В генерируемый скрипт, в оператор DROP, будет добавлено ключевое слово IF.

CheckBox Create empty procedures

Если этот флажок, то пустые процедуры будут включены в итоговый скрипт.

CheckBox Extract privileges

Если Вы хотите, чтобы были извлечены права на объекты, то установите этот флажок.

CheckBox Order by dependencies

Эта опция указывает должны ли объекты в скрипте быть отсортированы в соответствии с их зависимостями.

CheckBox Extract dependent objects

Извлекать зависимые объекты выбранного объекта.

CheckBox Extract dependent tables data

Извлекать данные зависимых таблиц.

CheckBox Use collations

Установив этот флажок, Вы подтверждаете использование кодировок в процессе извлечения данных.

hs2113 - Step6 - Setting up extraction options

В разделе Data options задайте параметры извлечения данных.

CheckBox Если установлен флажок Insert "COMMIT" after each block, то после указанного в счетчике Records in a block числа записей транзакция будет фиксироваться.

CheckBox Delete existing records before insert

В генерируемый скрипт будет добавлен оператор TRUNCATE TABLE перед оператором INSERT INTO, который позволит удалить существующие записи перед тем, как вставлять новые.

CheckBox Generate "PRINT <object name>" statement

В генерируемый скрипт будет добавлен оператор PRINT.

Data query options

В этой таблице Вы можете указать дополнительные параметры операторов SELECT, используемых для извлечения данных:

  • Database name - в этом столбце отображается список баз данных.
  • Limit data - установив ненулевое значение в этом столбце, Вы можете ограничить количество записей, извлекаемых из каждой таблицы.
  • Table name - имя извлекаемой таблицы базы данных (и имя схемы, которой она принадлежит).
  • Table data filter - в этом поле Вы можете задать условия WHERE для каждой таблицы.

Важно: Вы можете настроить параметры выбора как для одной, так и для всех таблиц, используя контекстное меню.

Step 6-7 - Context menu

  • Add 'WHERE' to Selection - добавить условие отбора для выделенной таблицы.
  • Add 'WHERE' to All - добавить условие отбора для всех таблиц.

Следующий шаг


Шаг 7 - Указание имен файлов и директорий

На этом шаге вы должны указать имя файла и директорию, где будет сохранен сгенерированный скрипт.

Directory options

Default directory

С помощью кнопки btnOpenFile укажите путь к директории, в которую будет помещен сгенерированный скрипт.

CheckBox Add to path

Установите этот флажок, чтобы добавить текущую дату, время, или дату и время (может быть выбрано в соответствующем раскрывающемся списке) к имени директории.

hs2115 - Step7 - Specifying file names and directories

File options

Эта группа опций позволит Вам указать будут ли исходные базы данных помещены в один SQL скрипт, или распределены по нескольким файлам меньшего размера. В каждом таком файле будет скрипт для одной базы. Эта опция доступна только в том случае, если извлекаются объекты из нескольких баз данных.

RadioButton Separate file for each database - каждую базу данных выгружать в отдельный файл. Эта опция доступна только в том случае, если извлекаются объекты из нескольких баз данных.

RadioButton Single file for all database - все базы данных выгружать в один файл.

File name

Укажите имя для итогового *.sql файла. С помощью кнопки btnSaveAs укажите путь к этому файлу.

File charset

Выберите кодировку итогового файла.

CheckBox Add to name

Установите этот флажок, чтобы добавить текущую дату, время, или дату и время (может быть выбрано в соответствующем раскрывающемся списке) к имени файла.

Compression options

В этом разделе укажите параметры сжатия итогового файла.

CheckBox Compress files

Установите этот флажок, если хотите поместить сгенерированный файл скрипта в ZIP архив.

CheckBox Single archive file

Установите этот флажок, чтобы указать должен ли итоговый файл скрипта быть помещен в один архив , или должен быть разделен на несколько. В каждом архиве будет скрипт для одной базы. Эта опция доступна только в том случае, если извлекаются объекты из нескольких баз данных.

Archive file name

С помощью диалогового окна, открывающегося при нажатии на кнопку btnSaveAs, выберите путь к файлу архива и укажите его имя.

CheckBox Add to name

Установите этот флажок, чтобы добавить текущую дату, время, или дату и время (может быть выбрано в соответствующем раскрывающемся списке) к имени файла архива.

Split to volumes

Вы можете разделить архив на тома, выбрав размер тома из этого раскрывающегося списка.

BLOB options

RadioButton Don't extract BLOB fields - поля типа BLOB не будут извлечены.

RadioButton Extract BLOB fields to strings (not recommended) - при выборе этого пункта поля типа BLOB будут извлечены в виде строк.

RadioButton Extract BLOB fields into file - извлекать поля этих типов в файл *.blo. С помощью кнопки btnSaveAs откройте диалоговое окно, в котором задайте имя файла и путь к нему.

Важно: Оператор SET BLOBFILE будет добавлен в итоговый скрипт, при выборе Extract BLOB fields into file. Этот оператор выполняется корректно только в продуктах компании EMS.

CheckBox Если установлен флажок Single blob file, то будет создан один файл, содержащий все данные типа BLOB.

File Name

Укажите имя файла, в который будут выгружаться данные типа BLOB *.blo. С помощью кнопки btnSaveAs укажите путь к этому файлу.

CheckBox Add to name

Установите этот флажок, чтобы добавить текущую дату, время, или дату и время (может быть выбрано в соответствующем раскрывающемся списке) к имени файла.

CheckBox Compression

Установите этот флажок, если хотите сжать файл, содержащий данные типа BLOB.

Compression Level

Степень сжатия файла выберите из этого раскрывающегося списка.

Normal,

Fastest,

Best.

File names

В этой таблице Вы можете просматривать суммарную информацию по всем заданным файлам *.sql и *.zip.

Database Name - имя базы данных, которая будет

SQL file name - имя файла SQL скрипта *.sql.

File charset - кодировка файла.

Archive Name - имя файла архива. (Столбец отображается, если итоговый файл архивируется).

Archive volume size - размер архива.

Blob file name - имя файла, в который выгружены данные типа BLOB. (Столбец отображается, если данные типа BLOB выгружаются в отдельный файл).

Следующий шаг


Шаг 8 - Параметры расписания

Используйте инструменты, расположенные на этой форме, для задания расписания автоматического извлечения баз данных.

Scheduled execution options

RadioButton Run now - запустить операцию извлечения базы данных.

RadioButton Run now and create scheduled task - создать расписание и запустить операцию.

RadioButton Create scheduled task only - только создать задание для расписания.

Recurrence rule

RadioButton Run once - запустить один раз.

RadioButton Add daily task - задать настройки для ежедневного запуска.

RadioButton Add weekly task - задать настройки для еженедельного запуска.

RadioButton Add monthly task - задать настройки для ежемесячного запуска.

hs2117 - Step8 - Scheduling options

Task options

В этом разделе укажите параметры выполнения задания.

Scheduled time

Время запуска задания.

Scheduled date

В этом поле укажите дату выполнения задания по извлечению базы данных. Это поле доступно для редактирования только если в разделе Recurrence Rule выбран пункт RadioButton Run once.

Важно: дата выполнения в этом поле не может отставать от текущей больше, чем на месяц вперед.

CheckBox Do not close console window after execution

Не закрывать окно приложения после выполнения операции.

Важно: Необходимо, чтобы был запущен сервис Task Scheduler service. Для запуска необходимо открыть Windows Control Panel | Administrative Tools | Services (или открыть Пуск | Выполнить... и в появившемся окне выполнить команду services.msc)

Weekly task / Monthly task

В этих двух разделах содержатся списки дней недели/месяца. Установив флажки напротив нужных дней, Вы указываете дату выполнения задания.

CheckBox Generate a separate task for each day

Отметьте эту опцию, если Вы хотите создать несколько задач для "Планировщик заданий" Windows. Каждая задача будет соответствовать указанному дню.

Execute as...

В этом разделе укажите:

Windows Domain - домен (если доменное имя пользователя используется),

User name - имя пользователя,

User password - пароль

Рекомендуется использовать текущего пользователя Windows.

Следующий шаг


Шаг 9 - Выполнение операции

О процессе выполнения операции сообщается на последнем шаге.

Script options

CheckBox Abort extraction on error

Прервать выполнение операции при возникновении ошибки.

CheckBox Show comments in script

Установите эту опцию, чтобы разрешить в процессе выполнения добавлять комментарии в итоговый SQL скрипт.

Если все необходимые параметры указаны верно, нажмите кнопку Extract, чтобы начать выполнение операции.

Если Вы хотите что-то изменить, то можете вернуться к любому из шагов мастера, используя кнопку Back.

О ходе выполнения сообщается в окне Extraction log.

hs2119 - Step9 - Start of extraction process

Не забудьте сохранить параметры извлечения, если Вы собираетесь повторить извлечение позже, используя те же или аналогичные настройки.

На протяжении всего процесса выполнения Вы можете использовать кнопку Send to background для перевода процесса в фоновый режим выполнения.

Нажатие на кнопку Cancel прервет выполнение операции, а нажатие на кнопку Minimize свернет окно мастера.

Смотрите также:

Файлы конфигурации

Настройки программы


Файлы конфигурации

DB Extract for SQL Server позволяет сохранять настройки извлечения баз данных во внешнем файле шаблона, имеющем расширение *.ext.

Вы можете загрузить предварительно сохраненный шаблон, если хотите внести изменения, или запустить консольное приложение для выполнения операции.

Сохранение файла конфигурации

Загрузка файла конфигурации

Смотрите также:

Использование мастера

Настройки программы


Сохранить файл конфигурации

Шаблоны сохраняются с помощью специального диалогового окна Save template options, которое открывается при выборе пункта Save template из раскрывающегося списка, появляющегося при нажатии кнопки Tools. Эта опция доступна на Шаге 8 и на всех последующих шагах.

hs2210 - Saving template

Параметры сохранения шаблона:

File name

Имя и путь к файлу шаблона укажите в этом поле, с помощью кнопки btnSaveAs.

Comment

При необходимости, снабдите файл комментарием.

hs2210 - Template options

Смотрите также:

Загрузить файл конфигурации


Загрузить файл конфигурации

Предварительно сохраненные шаблоны Вы можете открыть для выполнения.

Меню, позволяющее выбирать действия для работы с шаблонами, открывается при нажатии на раскрывающийся список кнопки Tools.

Шаблоны DB Extract загружаются при помощи диалогового окна, открывающегося при выборе пункта Load template.

hs2220 - Loading template

Вы можете открыть шаблон заново, выбрав нужный из списка Reopen template.

При необходимости, Вы можете вернуться на предыдущие шаги и изменить настройки операции.

Смотрите также:

Сохранить файл конфигурации


Настройки программы

Вы можете полностью настроить интерфейс программы с помощью инструмента Preferences.

Чтобы открыть окно Preferences необходимо на любом шаге мастера нажать кнопку Tools и из появившегося списка выбрать пункт Preferences.

hs2300 - Preferences

Основные элементы управления располагаются на следующих вкладках:

General options

На этой вкладке задайте основные опции программы.

Localization

Язык интерфейса программы укажите на этой вкладке.

Interface

На вкладках раздела Interface Вы можете указать стиль отображения таких элементов интерфейса, как кнопки, флажки и т.д.

Смотрите также:

Использование мастера

Файлы конфигурации


Задание основных параметров

CheckBox Show database list

Если этот флажок установлен, то все базы данных, доступные на сервере, отображаются в списке доступных баз данных - Available Databases, на Втором шаге. Если флажок не установлен, то Вам необходимо будет добавлять базы данных, используя кнопку btnAddDatabaseToDBList.

CheckBox Remember password

Помнить пароль (пароли) для доступа к базе данных.

CheckBox Confirm exit

Если при выходе из программы необходимо запрашивать подтверждение, то установите этот флажок.

CheckBox Save current options on exit

Сохранить настройки. Если установлен этот флажок, то все указанные настройки будут отображаться при следующем запуске программы.

CheckBox Save password and user name for Scheduled Task creation

Установите эту опцию, чтобы помнить логин Windows для выполнения назначенных заданий.

hs2310 - Setting general options

Смотрите также:

Локализация

Задание параметров интерфейса


Локализация

С помощью инструментов, расположенных на этой вкладке Вы можете задавать язык программы.

hs2320 - Setting program language

Вы можете выбрать один из предложенных языков, или создать свой.

В поле Default directory btnOpenFile указан путь к папке, в которой по умолчанию находятся все файлы локализации, имеющие расширение *.lng.

Из раскрывающегося списка Choose program language выберите язык программы.

CheckBox Если установлен флажок Auto scan languages on startup, то каждый раз при запуске DB Extract for SQL Server папка Default directory будет проверяться на наличие новых файлов *.lng, которые затем автоматически будут добавлены в список доступных языков программы.

В списке Available languages показан список доступных локализаций, которые можно установить как основной язык программы.

При нажатии на кнопку Add defaults проверяется наличие новых файлов *.lng в папке по умолчанию, которые автоматически добавляются в список доступных языков программы.

Нажав на кнопку Add, Вы можете добавить в список Available languages файл локализации, указав в появившемся окне имя локализации и путь к файлу.

hs2320 - Add language

Кнопка Edit позволяет редактировать выбранную локализацию.

hs2320 - Edit language

Нажав на кнопку Delete, Вы удалите выбранную локализацию из списка доступных.

Смотрите также:

Задание основных параметров

Задание параметров интерфейса


Задание параметров интерфейса

На вкладке Interface Вы можете выбрать схему оформления внешнего вида элементов управления программы.

Preferences - Interface

Схему выберите из раскрывающегося списка Schema name. Образцы элементов управления, расположенные ниже, примут вид в соответствии с выбранной схемой. Изменять внешний вид каждой группы элементов в отдельности можно на следующих вкладках:

  • Tree Lists - Деревья и списки
  • Edit controls - Элементы управления редактирования
  • Check boxes - Флажки
  • Buttons - Кнопки
  • Page controls - Вкладки
  • Group boxes - Группа кнопок

Вы можете создавать и сохранять собственные схемы настроек интерфейса.

Задайте необходимые настройки на вкладках, вернитесь на вкладку Interface и нажмите кнопку Save As.

Укажите имя создаваемой схемы в появившемся диалоговом окне и нажмите OK.

hs2330 - Input scheme name

Смотрите также:

Задание основных параметров

Локализация


Деревья и списки

На вкладке Trees and Lists настройте внешний вид списков.

Preferences - Interface - Trees and lists

Из раскрывающегося списка Look & Feel выберите один из стандартных стилей оформления списков.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Hide selection

Если флажок установлен, то выделенный объект не будет отличаться от остальных. Если не установлен, то выбранный объект будет выделен другим цветом.

CheckBox Hide focus rectangle

Если флажок установлен, то выделенный объект не обозначается другим цветом, но вокруг его названия отображается прямоугольник.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Элементы управления редактирования

Флажки

Кнопки

Группы кнопок


Элементы управления редактирования

На вкладке Edit controls задайте стиль элементов управления и редактирования.

Preferences - Interface - Edit controls

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

Из списка Button style - стиль кнопок.

3D - трехмерные,

Flat - плоские с тенью,

Simple - простые

Hotflat - плоские в рамке

Ultraflat - плоские.

Стиль кнопок, расположенных в пределах поля, можно задать с помощью раскрывающегося списка Button transparency.

None - непрозрачные,

Inactive - прозрачные, когда неактивные.

Always - прозрачные,

Hide inactive - показывать при редактировании,

Hide unselected - показывать при наведении курсора.

Hot track - подсветка элементов управления.

Shadow - тень.

Native style - естественный стиль.

Edges - границы:

CheckBox Left - слева;

CheckBox Right - справа;

CheckBox Top - сверху;

CheckBox Bottom - снизу.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Флажки

Кнопки

Группы кнопок


Флажки

На вкладке Check boxes задайте вид флажков и переключателей.

Preferences - Interface - Check boxes

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Кнопки

Группы кнопок


Кнопки

На этой вкладке настройте внешний вид кнопок.

Preferences - Interface - Buttons

Из списка Button kind выберите вид кнопок.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Флажки

Группы кнопок


Группы кнопок

Задайте стиль отображения групп кнопок на вкладке Group boxes.

Preferences - Interface - Group boxes

Из раскрывающегося списка Border style выберите стиль рамки.

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

Shadow - тень.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Флажки

Кнопки


Консольное приложение

Консольное приложение DB Extract for SQL Server предназначено для быстрого и удобного извлечения базы данных SQL Server, а также для использования в любых планировщиках задач.

hs3000 - Console application

  • Использование консольного приложения
  • Формат файла конфигурации

Смотрите также:

Работа с приложением


Использование консольного приложения

Все параметры извлечения базы данных Вы можете указать в файле конфигурации, имеющем расширение *.ext.

В Консольном приложении может DB Extract for SQL Server может быть использован шаблон.

Чтобы создать файл конфигурации (шаблон) следуйте инструкции:

  • запустите DB Extract for SQL Server Мастер извлечения баз данных;
  • задайте необходимые параметры на каждом шаге;
  • проверьте сравнение и синхронизацию на последнем шаге
  • сохраните шаблон.

Файл конфигурации можно запустить тремя способами:

  • использовать пункт Load Template из списка, открывающегося при нажатии на кнопку Tools.
  • дважды щелкнуть на созданном файле конфигурации (*.edc) мышью.
  • задать в консольном приложении команду запуска - <path to DB Extract for SQL Server console application>\MsExtractC.exe TemplateFile [-L] [-B]

Применение:

<path to DB Extract for SQL Server console application>\MsExtractC.exe TemplateFile [-L]

TemplateFile

Имя файла конфигурации *.ext и путь к нему.

[-L]

Выберите текущую локализацию.

[-B]

Используйте этот параметр, если хотите запустить процесс в фоновом режиме.

Пример:

"C:\Program Files\EMS\MS SQL Extract\MsExtractC.exe" "C:\Program Files\EMS\MS SQL Extract\DBExtract1.ext" -L

Важно: Следующие значения кода завершения возвращаются программой DB Extract for SQL Server операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка или ошибки;

2 - критическая ошибка. Эта задача не выполнена.

Смотрите также:

Использование мастера

Формат файла конфигурации


Формат файла конфигурации

Файл конфигурации (шаблон) используемый DB Extract for SQL Server состоит из нескольких разделов, каждый из которых соответствует конкретной группе настроек, указанных на разных шагах Мастера извлечения баз данных.

Параметры подключения

Общие опции

Параметры извлечения

Параметры файлов

Назначенные задания

Запросы

Базы данных

Смотрите также:

Использование консольного приложения


Параметры подключения

В разделе [#General#] отображаются имя и версия программного продукта.

В разделе [#Connection#] задаются параметры подключения. Эти же параметры Вы можете указать на Первом шаге.

Параметры:

Host - сервер,

Login and Password - имя пользователя и пароль.

Эти параметры являются обязательными.

Remote - удаленное подключение

0 = локальное соединение (сервер установлен на этом компьютере)

1 = соединение с сервером по сети

NTAuth

0 = серверная аутентификация

1 = имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows

Смотрите также:

Общие опции

Параметры извлечения

Параметры файлов

Назначенные задания

Запросы

Базы данных


Общие опции

[#Options#]

В этом разделе находятся параметры извлечения баз данных, указываемые на Шаге 3 - Указание типов объектов Мастера.

ExtractOptionsIndex

0 = Extract both structure and data - извлечь данные и метаданные.

1 = Extract metadata only - извлечь только метаданные.

2 = Extract data only - извлечь только данные.

ExtractAllMetaObjects

0 = Extract selected types of objects only - извлечь выбранные объекты.

1 = Extract all objects - извлечь все объекты.

ExtractMetadataFrom (доступно если ExtractAllMetaObjects = 0)

The Значение этой опции - список значений "0" и "1" для каждого типа объектов.

Tables, Views, Procedures, UDTs, Users, Roles, Defaults, UDFs, Rules, Schemas, Assemblies, XML schema collections, Synonyms, Database triggers, Partition functions, Partition schemes, Aggregates, Symmetric keys, Asymmetric keys, Certificates, Full-text catalogs, Message types, Contracts, Services, Routes, Remote service bindings, Logins, Backup devices, Jobs, Alerts, Operators, Linked servers, Shared schedules, Proxies, Credentials, Endpoints, Server triggers

ExtractAllData

0 = извлечь данные только выбранных таблиц.

1 = извлечь все данные таблиц

Следующие параметры Вы можете указать на Шаге 9 - Выполнение операции мастера.

AbortOnError

0 = Не прерывать выполнение операции при возникновении ошибки.

1 = Прервать выполнение операции при возникновении ошибки.

InsertComments

0 = не разрешать в процессе выполнения добавлять комментарии в итоговый SQL скрипт.

1 = разрешить в процессе выполнения добавлять комментарии в итоговый SQL скрипт.

Смотрите также:

Параметры подключения

Параметры извлечения

Параметры файлов

Назначенные задания

Запросы

Базы данных


Параметры извлечения

[#ExtractOptions#]

В этом разделе находятся параметры извлечения баз данных, указываемые на Шаге 6 - Задание параметров извлечения Мастера.

CreateDatabaseStmt

0 = В генерируемый скрипт не будет добавлен оператор CREATE DATABASE.

1 = В генерируемый скрипт будет добавлен оператор CREATE DATABASE.

DropTableStmt

0 = В генерируемый скрипт не будет добавлен оператор DROP

1 = В генерируемый скрипт будет добавлен оператор DROP.

RecordsInBlock

После указанного числа записей будет вставлен оператор COMMIT для фиксации транзакции.

InsertCommit

0 = В генерируемый скрипт не будет добавлен оператор COMMIT после каждого блока.

1 = В генерируемый скрипт будет добавлен оператор COMMIT после каждого блока.

DeleteAllRecords

0 = не удалять существующие записи перед тем, как вставлять новые.

1 = удалять существующие записи перед тем, как вставлять новые.

Privileges

0 = не извлекать права доступа к объектам.

1 = извлекать права доступа к объектам.

BlobExtractType

0 = поля типа BLOB не будут извлечены

1 = поля типа BLOB будут извлечены в виде строк.

2 = извлекать поля этих типов в файл *.blo.

BlobSingleFile

0 = поля BLOB будут извлечены в несколько файлов.

1 = поля BLOB будут извлечены в один файл.

BlobComressionLevel

Степень сжатия BLOB файла

0 = None

1 = Fastest

2 = Normal

3 = Best

AddDateTimeToBlob

0 = Не добавлять текущую дату и время к имени BLOB файла(ов).

1 = Добавлять текущую дату и время к имени BLOB файла(ов)

AddDateTimeTypeBlob

0 = Дата будет добавлена к имени BLOB файла(ов)

1 = Время будет добавлено к имени BLOB файла(ов)

2 = Дата и время будут добавлены к имени BLOB файла(ов)

AddUse

0 = В генерируемый скрипт не будет добавлен оператор USE DATABASE.

1 = В генерируемый скрипт будет добавлен оператор USE DATABASE.

PrintObjectName

0 = В генерируемый скрипт не будет добавлен оператор PRINT <object name>.

1 = В генерируемый скрипт будет добавлен оператор PRINT <object name>.

UseCollations

0 = не использовать кодировки в процессе извлечения данных.

1 = использовать кодировки в процессе извлечения данных.

Смотрите также:

Параметры подключения

Общие опции

Параметры файлов

Назначенные задания

Запросы

Базы данных


Параметры файлов

[#FileOptions#]

В этом разделе находятся параметры извлечения баз данных, указываемые на Шаге 7 - Указание имен файлов и директорий Мастера.

SingleFile

0 = Создать отдельный файл скрипта для каждой извлекаемой базы данных (смотрите раздел Базы данных).

1 = Все данные и метаданные извлекаются в один файл.

SingleFileName

Имя файла скрипта (если параметр SingleFile = 1)

AddDateTimeToFile

0 = Не добавлять текущую дату и время к имени файла(ов)

1 = Добавлять текущую дату и время к имени файла(ов)

AddDateTimeTypeFile

0 = Дата будет добавлена к имени файла

1 = Время будет добавлено к имени файла

2 = Дата и время будут добавлены к имени файла

CompressFiles

0 = Не сжимать итоговый файл.

1 = Сжимать итоговый файл.

SingleArchiveFile

0 = Создать отдельный файл архива для каждой извлекаемой базы данных (смотрите раздел Базы данных)

1 = Помещать все файлы итогового скрипта в один архив.

SingleArchiveFileName

Имя файла архива (если SingleArchiveFile = 1)

SingleArchiveVolumeSize

Вы можете разделить архив на тома, указав размер тома. По умолчанию размер указывается в байтах. Если хотите указать в килобайтах или мегабайтах, то перед значением необходимо поставить 'K' или 'M'.

AddDateTimeToArc

0 = Не добавлять текущую дату и время к имени файла архива(архивов)

1 = Добавлять текущую дату и время к имени файла архива(архивов)

AddDateTimeTypeArc

0 = Дата будет добавлена к имени файла архива.

1 = Время будет добавлено к имени файла архива.

2 = Дата и время будут добавлены к имени файла архива.

InitialDir

Путь к директории, в которую будет помещен сгенерированный скрипт.

AddFolderWithDate

0 = не добавлять к имени создаваемой директории (параметр InitialDir) дату или время.

1 = добавлять к имени создаваемой директории (параметр InitialDir) дату или время.

AddDateTimeTypeFolder

0 = Дата будет добавлена к имени директории.

1 = Время будет добавлено к имени директории.

2 = Дата и время будут добавлены к имени директории.

Смотрите также:

Параметры подключения

Общие опции

Параметры извлечения

Назначенные задания

Запросы

Базы данных


Назначенные задания

[#ScheduledTask#]

В этом разделе находятся параметры извлечения баз данных, указываемые на Шаге 8 - Параметры расписания Мастера.

Параметры для задания расписаний автоматического извлечения баз данных.

TaskType

0 = запустить выполнение операции один раз.

1 = задать настройки для ежедневного запуска.

2 = задать настройки для еженедельного запуска.

3 = задать настройки для ежемесячного запуска.

ScheduledPrefIndex

0 = запустить операцию извлечения базы данных.

1 = создать расписание и запустить операцию.

2 = только создать задание для расписания.

SchellTime

Время выполнения задания.

ScheduledDate

Дата выполнения задания (если TaskType = 0)

WeeklyList

Дни недели, в которые нужно выполнять задание по извлечению базы данных (если TaskType = 2).

Значение этого параметра может быть "0" или "1".

Каждое значение соответствует одному дню недели.

Пример:

WeeklyList=1,0,0,0,1,0,0

Задание будет выполняться в понедельник и в пятницу.

DaysList

Дни месяца, в которые нужно выполнять задание по извлечению базы данных (если TaskType = 3).

Значение этого параметра может быть "0" или "1".

Каждое значение соответствует одному дню месяца.

SeparateTask (если TaskType = 3)

0 = Создать одно задание для всех выбранных дней месяца.

1 = Создать отдельное задание для каждого дня месяца.

TaskDomain

Домен Windows (если доменное имя пользователя используется),

TaskUserName

Имя пользователя Windows.

TaskPassword

Пароль пользователя Windows.

NotCloseConsole

0 = закрывать окно консольного приложения после завершения операции.

1 = не закрывать окно консольного приложения после завершения операции.

[#Comment#]

В этом разделе хранятся комментарии к файлу шаблона.

Пример:

Line0 = Template1 для извлечения данных и метаданных

Смотрите также:

Параметры подключения

Общие опции

Параметры извлечения

Параметры файлов

Запросы

Базы данных


Запросы

В этих разделах находятся параметры извлечения баз данных, указываемые на Шаге 6 - Задание параметров извлечения Мастера.

[#Limits#]

Количество записей, извлекаемых из каждой таблицы.

Формат: <database name>.<schema name>.<table name> = <records limit>

[#WhereClauses#]

Условия WHERE для каждой таблицы.

Формат: <database name>.<schema name>.<table name> = <WHERE clause>

Смотрите также:

Параметры подключения

Общие опции

Параметры извлечения

Параметры файлов

Назначенные задания

Базы данных


Базы данных

Этот раздел шаблона DB Extract содержит список объектов базы данных, выбранных для извлечения и индивидуальные параметры извлечения.

OutputFileName

Имя итогового SQL скрипта *.sql. (если SingleFile = 0, смотрите раздел Параметры файлов)

ArchiveFileName

Имя итогового файла архива *.zip. (если SingleArchiveFile = 0, смотрите раздел Параметры файлов)

Перечень объектов, указанных для извлечения представлен в следующем формате:

<ObjectType>Count

В этом разделе задайте количество выбранных объектов выбранного типа, или укажите 'ALL', чтобы выбрать все объекты этого типа.

TablesXX

Каждый такой параметр хранит имя таблицы, указанной для извлечения метаданных. XX - порядковый номер таблицы в списке.

Пример:

Tables0 = TestDB.dbo.Account

Список объектов баз данных берется из значения параметра ExtractMetadataFrom. Смотрите раздел Общие опции и Шаг 3 - Указание типов объектов.

Список таблиц, из которых будут извлекаться данные, располагается ниже.

DataTablesCount

В этом разделе задайте количество выбранных таблиц, или укажите 'ALL', чтобы выбрать все таблицы.

DataTablesXX

Каждый такой параметр хранит имя таблицы, указанной для извлечения данных. XX - порядковый номер таблицы в списке.

Пример:

DataTables0 = TestDB.dbo.Address

Смотрите также:

Параметры подключения

Общие опции

Параметры извлечения

Параметры файлов

Назначенные задания

Запросы


Фильтр

В этом диалоговом окне можно задать 2 условия фильтрации и их отношение - должны ли выполняться оба условия сразу, или достаточно выполнения одного.

hs2109 - Step4 - Custom Filter

С помощью этого окна можно задавать интервалы.

Из раскрывающихся списков выберите условие отбора:

  • равно - equals,
  • не равно - does not equal,
  • больше - is greater than,
  • больше или равно - is greater than or equal to,
  • меньше - is less than,
  • меньше или равно - is less than or equal to,
  • пустые - is blank,
  • не пустые - is not blank,
  • между <значение> и <значение> - between and,
  • не между - not between,
  • в - in,
  • не в - not in.

В поле укажите последовательность символов.

Используйте символ "%" для указания любого набора символов и символ "_" для обозначения любого символа. При выполнении условия отбираются только те значения, которые отвечают указанному условию.

Второе условие не является обязательным.

Установив переключатель в положение AND укажите, что оба условия должны выполняться одновременно, в положение OR укажите, что должно выполняться только одно из них.


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться DB Extract for SQL Server, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

DB Extract for SQL Server подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

На первом шаге из раскрывающегося списка Database home выберите имя клиента и из раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.