Добро пожаловать в EMS Data Pump!

EMS Data Pump for SQL Server – это программа для перемещения баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных SQL Server. Удобный и простой в использовании мастер настройки позволяет задавать строки соединения c ADO, выбирать таблицы, поля и индексы для переноса, просматривать и редактировать сценарии SQL для создания целевых баз данных SQL Server, а также настраивать весь процесс импорта. Data Pump for SQL Server позволяет автоматизировать миграцию данных в SQL Server с помощью консольной утилиты. Теперь миграция баз данных в SQL Server становится настолько простой, насколько это возможно!

Посетите наш сайт: http://www.sqlmanager.net/

Ключевые особенности

  • Дружественный интерфейс мастера настройки
  • Перенос структуры баз данных и данных из любых SQL серверов или локальных баз данных, имеющих ADO провайдер
  • Возможность указания схемы для таблиц назначенной базы данных
  • Выбор таблиц полей и индексов исходной базы данных для переноса


Новости

Версия | Дата выпуска
Data Pump for SQL Server 3.1.2 | 4 марта 2020

Что нового в EMS Data Pump?

  • Добавлена поддержка Azure, SQL Server 2017, MySQL Server 8 и PostgreSQL 12.
  • Для удаления данных из таблиц теперь выполняется запрос TRUNCATE.
  • MySQL. Исправлена ошибка 'MySQL has gone away' при работе мастера.
  • PostgreSQL. Исправлены ошибки при обработке значений по умолчанию.
  • Исправлено отображение количества записей для больших таблиц.
  • В некоторых случаях при импорте данных с использованием оператора COPY выдавались ошибки. Исправлено.
  • В консольной версии исправлена ошибка загрузки шаблона с частичным выбором колонок в таблицах.
  • Другие изменения и улучшения.

Смотрите также:

История версий


Системные требования

  • Microsoft Windows NT4 c SP4 или более поздней версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows 2008 Server, Microsoft Windows Vista, Microsoft Windows 7, Microsoft® Windows 8, Microsoft® Windows 8.1, Microsoft® Windows 10
  • 512 MB RAM (рекомендуется 128 MB или более)
  • 20 Mб свободного пространства на жестком диске для установки программы
  • Microsoft Data Access Components (MDAC) или SQL Server Native Client
  • Возможность соединения с локальным или удаленным сервером SQL Server™
  • Поддерживаемые версии сервера MS SQL Server: с 7.0 по 2017


Установка

Установка программы

  • загрузите установочный файл программы со страницы загрузки,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • откройте файл MSDataPumpSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Часто задаваемые вопросы по установке ПО

Обновление программы

  • загрузите установочный файл со страницы загрузки сайта,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • закройте программу Data Pump for SQL Server, если она запущена,
  • запустите файл MSDataPumpSetup.exe и следуйте инструкциям мастера обновления.

Смотрите также:

Системные требования


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Digital River. Процедура совершения покупки через Share-it! защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернет и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией Digital River.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery). Сделав заказ, Вы сможете немедленно скачать регистрационные ключи или пароли и ссылки на архивы полных версий программ. Также Вы получите копию регистрационных ключей или паролей по электронной почте.

Если при оформлении не получили регистрационный ключ в течение двух часов, обратитесь в службу поддержки по этому адресу sales@sqlmanager.net.

Если Вы являетесь зарегистрированным пользователем, то при возникновении проблем или вопросов при использовании нашего программного обеспечения обращайтесь в службу поддержки.

Описание продукта | MyCommerce/Digital River
EMS Data Pump for SQL Server (Бизнес версия) + 1 год Сопровождения* | Зарегистрировать!
EMS Data Pump for SQL Server (Бизнес версия) + 2 года Сопровождения*
EMS Data Pump for SQL Server (Бизнес версия) + 3 года Сопровождения*
EMS Data Pump for SQL Server (Некоммерческая версия) + 1 год Сопровождения*
EMS Data Pump for SQL Server (Некоммерческая версия) + 2 года Сопровождения*
EMS Data Pump for SQL Server (Некоммерческая версия) + 3 года Сопровождения*
EMS Data Pump for SQL Server (Пробная версия) | Загрузить!

Программа EMS по Сопровождению ПО это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Подробнее об услуге сопровождения читайте на странице http://sqlmanager.net/ru/support/faq/maintenance

Смотрите также:

Регистрация


Регистрация

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией из Digital River
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно - проверить наличие регистрационного имени и пароль на стартовой странице. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Welcome to Data Pump - Register product

Смотрите также:

Приобретение


История версий

Data Pump for SQL Server
  • В начало
  • « Назад
  • Вперед »

Пердыдущие версии

Наименование продукта | Версия | Дата выпуска
Data Pump for SQL Server | Версия 3.1.1 | 10.03.2016
Data Pump for SQL Server | Версия 3.1 | 20.06.2011
Data Pump 2009 for SQL Server | Версия 3.0.0.1 | 24.02.2009
Data Pump 2006 for SQL Server | Версия 2.2.0.1 | 21.02.2007
Data Pump 2006 for SQL Server | Версия 2.1.0.1 | 26.06.2006

Полная история версий доступна на сайте http://www.sqlmanager.net/products/mssql/datapump/news

Версия 3.1.1

  • Обновленная программа инсталляции, содержащая множество исправлений.
  • Поддержка миллисекунд для типов Datetime и Timestamp.
  • Исправлена ошибка 'Out of memory' при попытке переноса большого объема данных.
  • Исправлена ошибка генерации скрипта для индексов с одинаковыми именами.
  • Исправление получения данных об ограничениях (constraints) для MS SQL Server при подключении через ODBC.
  • Исправлена ошибка 'Out of memory' при импорте из DBF/FoxPro через Advantage OLE DB Provider 11.
  • На шаге 5 мастера при переносе данных в некоторых случаях возникала ошибка 'Access Violation'. Исправлено.
  • При повторном подключении к MySQL через ODBC возникала AV. Исправлено.
  • Другие улучшения и исправления

Версия 3.1

  • Добавлена возможность переноса описаний объектов при условии поддержки провайдером.
  • Теперь возможен перенос данных представлений/запросов.
  • Добавлена возможность обновления дерева объектов исходной базы данных.
  • Теперь при импорте данных автоматически происходит отключение и пересоздание внешних ключей.
  • Добавлена поддержка последних версий серверов.
  • Прочие незначительные изменения и исправления.

Версия 3.0

  • Добавлена поддержка Unicode.
  • Добавлена поддержка схем исходной СУБД.
  • Добавлена опция для включения/отключения обновления объектов при соединении.
  • Добавлена опция, определяющая, выбраны ли по умолчанию все исходные таблицы на Шаге 3.
  • На Шаге 4 появилась возможность настроить заключение в кавычки идентификаторов объектов исходной базы.
  • Добавлена поддержка последних версий целевых СУБД.
  • Улучшена поддержка схем для БД назначения.
  • Добавлена возможность очищать таблицы перед импортом данных.
  • Добавлена возможность генерировать выражение DROP TABLE.
  • Перенос полей типа Time в ОС, использующие точку в качестве разделителя, приводил к ошибке. Исправлено.
  • Добавлена поддержка аутентификации Windows для Oracle.
  • Теперь можно менять размер окна мастера.
  • На последнем шаге добавлена опция перезапуска мастера.
  • Добавлена возможность выбрать, на каком шаге будет открыт мастер после загрузки шаблона.
  • Добавлена возможность начать импорт данных после загрузки шаблона.
  • Добавлено шифрование паролей в шаблонах и реестре.
  • Другие исправления и улучшения.

Версия 2.2

  • Внедрена возможность автоматически заключать в кавычки имена объектов в результирующем скрипте для импорта данных (при использовании "неопознанных" поставщиков OLE DB/ODBC).
  • Добавлена возможность указать схему, в которую по умолчанию производится импорт данных из таблиц.
  • Усовершенствована обработка полей DATETIME: в значениях типа DATETIME импортируются также миллисекунды.
  • Добавлены французская и немецкая локализации интерфейса.
  • Ряд незначительных исправлений и доработок интерфейса.

Версия 2.1

  • Реализованы два варианта формата шаблона: фиксированный, указывающий конкретный список объектов для переноса, и динамический, определяющий только исключенные объекты; объекты не входящие в этот список подлежат переносу. Файлы шаблонов в старом формате продолжают поддерживаться.
  • В графическую утилиту добавлена опция "Recreate database", позволяющая удалить существующую базу данных перед созданием новой. (Ранее опция существовала только в консольной версии)
  • Теперь консольная версия возвращает код ошибки (0 - успешное завершение, 1 - критическая ошибка, 2 - некритическая ошибка)

Смотрите также:

Новости


Часто задаваемые вопросы

  • Что такое EMS Data Pump?
  • Что мне нужно для начала работы с Data Pump for SQL Server?
  • Когда я пытаюсь соединиться с базой данных, я получаю следующее сообщение: Access denied for user:user@host.domain. Почему так происходит?
  • Я загрузил демонстрационную версию Data Pump for SQL Server, но у меня конвертируются не все записи из исходных файлов. В чем причина?
  • Я пытаюсь импортировать данные из MS Access. Когда я открываю таблицу, то вижу: indices(0), constraints(0) и не могу выбрать их. Как это исправить?
  • Я пытаюсь использовать Data Pump для конвертирования базы данных MS Access 2000 в SQL Server, но получаю ошибку нарушения доступа в модуле msjet40.dll.

В:

Что такое EMS Data Pump for SQL Server?

О:

EMS Data Pump for SQL Server - это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных SQL Server®. Удобный и простой в использовании мастер настройки позволяет задавать строки соединения c ADO, выбирать таблицы, поля и индексы для переноса, просматривать и редактировать сценарии SQL для создания требуемой базы данных SQL Server®, а также выбирать таблицы для импорта.

В:

Что мне нужно для начала работы с Data Pump for SQL Server?

О:

Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному серверу SQL Server. Во-вторых, Вам нужен компьютер, работающий под управлением ОС Windows 95/98/Me/NT4/2000/XP и удовлетворяющий следующим системным требованиям: Pentium 166, 32 Mb RAM.

В:

Когда я пытаюсь соединиться с базой данных, я получаю следующее сообщение: Access denied for user:user@host.domain. Почему так происходит?

О:

Эта ошибка генерируется сервером SQL Server из-за того, что у Вас нет полномочий для связи с сервером непосредственно с Вашего хоста. Пожалуйста, свяжитесь с Вашим администратором базы данных для разрешения этой проблемы.

В:

Я загрузил демонстрационную версию Data Pump for SQL Server, но у меня конвертируются не все записи из исходных файлов. В чем причина?

О:

Это ограничение демонстрационной версии, которая позволяет конвертировать только 10% записей. После регистрации продукт будет полностью функциональным.

В:

Я пытаюсь импортировать данные из MS Access. Когда я открываю таблицу, то вижу: indices(0), constraints(0) и не могу выбрать их. Как это исправить?

О:

Используйте Microsoft Jet OLE DB Provider для установки связи с Вашей базой данных MS Access. Проблема будет решена.

В:

Я пытаюсь использовать Data Pump для конвертирования базы данных MS Access 2000 в SQL Server, но получаю ошибку нарушения доступа в модуле msjet40.dll.

О:

Попробуйте переустановить Microsoft Data Access Components (MDAC) 2.8. Загрузить компоненты можно здесь: http://www.microsoft.com/downloads/search.aspx?display.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Мастер переноса баз данных

EMS Data Pump for SQL Server позволит осуществить перенос баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных SQL Server. Удобный и простой в использовании мастер настройки позволяет задавать строки соединения c ADO, выбирать таблицы, поля и индексы для переноса, просматривать и редактировать сценарии SQL для создания целевых баз данных SQL Server, а также настраивать весь процесс импорта.

Использование мастера

Использование файлов конфигурации (шаблонов)

Настройка программы

Перемещаться по шагам мастера можно с помощью кнопок Next> и <Back.

Смотрите также:

Консольное приложение


Работа с мастером переноса баз данных

Мастер позволит Вам быстро выполнить операцию. На каждом его шаге необходимо указывать определенные параметры миграции баз данных и импорта данных.

Начало работы

Шаг 1 - Установка параметров соединения

Шаг 2 - Выбор исходных схем

Шаг 3 - Выбор исходных объектов

Шаг 4 - Установка опций

Шаг 5 - Редактирование назначенных объектов

Шаг 6 - Просмотр/изменение скрипта

Шаг 7 - Выбор таблиц для импорта данных

Шаг 8 - Импорт данных

Смотрите также:

Использование консольного приложения

Использование файлов конфигурации (шаблонов)

Настройка программы


Начало работы

Так выглядит Data Pump for SQL Server при первом запуске.

На этой форме Вы можете просмотреть регистрационную информацию, или, нажав кнопку Enter Registration Code, ввести имя и регистрационный ключ в появившемся окне.

Если регистрационный ключ указан правильно, то появится сообщение о дате окончания периода сопровождения.

Если копия программы не зарегистрирована, то в нижней части формы отображается количество дней, оставшихся до окончания действия ознакомительной копии.

Wizard Application - Getting started

Нажмите кнопку Next для перехода к первому шагу мастера экспорта данных.

Смотрите также:

Регистрация


Шаг 1 - Установка параметров соединения

На этом шаге укажите параметры подключения к базам данных.

Важно: Необходимо обладать правами, позволяющими вносить данные в назначенную базу данных.

Важно: Чтобы установить соединение с источником данных, необходимо использовать дополнительное программное обеспечение, а именно - источники данных (OLE DB провайдеров и ODBC драйверов). Функциональность Data Pump может быть частично ограничена возможностями используемого источника данных.

В разделе Source Database Connection Parameters укажите параметры подключения к исходной базе данных. С помощью кнопки Build откройте окно Задания параметров передачи данных и укажите все необходимые настройки.

Step 1 - Setting connection properties

В разделе Connection type выберите тип соединения с сервером.

RadioButton Local - локальное соединение (сервер установлен на этом компьютере)

RadioButton Remote - соединение с сервером по сети

Действие, которое будет выполнено для назначенной базы данных, Вы берите в разделе Database actions.

RadioButton Create new database - создать новую базу, куда будут помещены данные.

RadioButton Connect to existing database - подключиться к уже существующей базе.

RadioButton Recreate database - пересоздать назначенную базу данных. (Важно: Все данные, хранившиеся в этой базе ранее, будут удалены.)

В разделе Authentication Type задается способ идентификации пользователя на сервере. Будет ли программа распознавать его по доменному имени и паролю - Windows или же по его персональным имени и паролю на сервере - SQL Server.

Если выбираете RadioButton Windows, то имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows. Если выбираете RadioButton Server, то следует указать имя и пароль. Имя указывается в поле User name, пароль - в поле Password.

Из раскрывающегося списка Server выбираете сервер (хост), к которому хотите подключиться. В этот список программа автоматически добавляет серверы, найденные в локальной сети. Если компоненты SQL-DMO components установлены на клиентском компьютере, используется их функция ListAvailableSQLServers. Если SQL-DMO components не установлены, используется функция NetServerEnum из netapi32.dll. Если данная библиотека не установлена, то при первом открытии программы этот список будет пуст, и имя сервера необходимо будет задать вручную. В этом случае в списке Server будут отображаться те серверы, базы данных которых уже зарегистрированы в программе.

Примечание: имя сервера не всегда может отображаться в списке, тогда вводите его вручную.

MS SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2005 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в Server Вы должны будете указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

Примечание: тип подключения Local выбирается только в случае подключения к локальному серверу, установленному, как неименованный экземпляр. В случае подключения к именованному экземпляру локального сервера, выберите тип подключения Remote и хост в формате localhost\ИМЯЭКЗЕМПЛЯРА, или 127.0.0.1\ИМЯЭКЗЕМПЛЯРА.

Базу данных выберите из раскрывающегося списка Database.

Если Вы используете версию Data Pump for SQL Server для EMS SQL Management Studio for SQL Server, то на первом шаге доступна кнопка Select registered database, при нажатии на которую открывается диалог выбора базы данных из зарегистрированных в EMS SQL Management Studio.

<Предыдущий шаг

Следующий шаг>


Задание параметров передачи данных

С помощью диалогового окна Data Link Properties Вы можете задать настройки подключения к исходной базе данных.

Это стандартное диалоговое окно операционной системы Windows. Дополнительную информацию о нем Вы можете посмотреть в справке операционной системы, открывающейся при нажатии кнопки Help.

На вкладках вы можете задать необходимые параметры подключения.

  • Провайдер
  • Подключение
  • Дополнительно
  • Все

Установка параметров соединения


Провайдер

Вкладка Provider используется для выбора подходящего поставщика OLE DB для тех данных, к которым осуществляется доступ. Например, для подключения к IBM® DB2, выберите IBM OLE DB Provider for DB2.

Для того чтобы подключиться к серверу с помощью ODBC драйвера, выберите Microsoft OLE DB Provider for ODBC Drivers.

Data link properties - Provider

В списке отображаются все обнаруженные на жестком диске поставщики OLE DB.

Нажмите кнопку Next, чтобы перейти на вкладку Connection.

Смотрите также:

Подключение

Дополнительно

Все


Подключение

Вкладка Connection используется для настройки параметров подключения к данным ODBC.

Вкладка Connection для каждого поставщика своя. На нее выносятся только те свойства соединения, которые необходимы для поставщика OLE DB, указанного на вкладке Провайдер.

Data link properties - Connection

Если Вы выбрали поставщика Microsoft OLE DB Provider for ODBC Drivers, то вкладка Connection будет выглядеть следующим образом.

Select or enter server name

Выберите из списка или введите имя источника данных ODBC (DSN), к которому необходимо получить доступ. Имеется возможность добавить другие источники с помощью администратора источников данных ODBC. Обновите список с помощью кнопки Refresh.

Enter information to log on to the server.

Укажите имя пользователя и пароль в полях User name и Password соответственно.

Blank password

Позволяет поставщику возвращать строку подключения с пустым паролем.

Allow saving passwords

Сохранить пароль.

Use Trusted Connection

Использовать надежное соединение.

Test Connection

Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.

Смотрите также:

Провайдер

Дополнительно

Все


Настройки подключения для поставщика Microsoft OLE DB для драйверов ODBC

Data Pump for SQL Server
  • В начало
  • « Назад
  • Вперед »

Поставщик Microsoft OLE DB для драйверов ODBC

Для того чтобы создать источник данных ODBC, выполните следующую последовательность действий:

  • Выберите пункт RadioButton Use connection string и нажмите кнопку Build. В открывшемся диалоге Select Data Source выбора источника данных задайте настройки источника.
  • В полях User name и Password укажите имя пользователя и пароль, которые необходимо использовать при подключении к серверу. Вы можете оставить эти поля пустыми, так как параметры подключения приведены в создаваемой строке подключения (Connection string).
  • При необходимости отметьте опции [image] Blank password (позволить поставщику возвращать строку подключения с пустым паролем) и [image] Allow saving password (сохранить пароль).

Microsoft OLE DB Provider for ODBC - Connection

Test Connection

Проверка соединения с указанным источником данных. Если соединение установить не удалось, убедитесь в правильности заданных настроек. Возможно, отсутствие соединения вызвано неточным соблюдением регистра символов или ошибками синтаксиса.


Выбор источника данных

В диалоге выбора источника данных перейдите на вкладку Источник данных компьютера (Machine Data Source), чтобы создать новый источник данных.

Microsoft OLE DB Provider for ODBC - Connection - Setting data source

Нажмите кнопку New, чтобы запустить мастер создания нового источника данных.

Также Вы можете выбрать ранее созданный источник данных из списка.


Выбор типа источника данных

На первом шаге мастера выберите тип создаваемого источника данных.

Microsoft OLE DB Provider for ODBC - Connection - Creating new data source - Selecting data source type

RadioButton User Data Source - пользовательский

Выбор источника данных пользователя создает источник данных, специфический для данного компьютера и доступный только данному пользователю.

RadioButton System Data Source - системный

Выбор системного источника данных создает источник данных, который может использоваться всеми пользователями на компьютере и виден всем пользователям компьютерных и системных сервисов

Нажмите кнопку Next, чтобы перейти к шагу выбора драйвера.


Выбор драйвера

На этом шаге мастера выберите драйвер, для которого задается источник.

В столбце Name выберите драйвер для создаваемого источника. Например, драйвер PostgreSQL ANSI, если Вы хотите подключиться к серверу PostgreSQL.

Microsoft OLE DB Provider for ODBC - Connection - Creating new data source - Selecting driver

В списке отображаются все драйвера, установленные на компьютере.

Нажмите кнопку Next, чтобы перейти на последний шаг мастера.


Создание источника данных

На этом шаге можно просмотреть значения заданных на предыдущих шагах опций.

Microsoft OLE DB Provider for ODBC - Connection - Creating new data source - Verifying information

Нажмите кнопку Finish, чтобы завершить выполнение мастера и перейти к диалогу задания дополнительных настроек выбранного драйвера.


Задание дополнительных настроек ODBC драйвера

После завершения всех шагов мастера создания источника данных появится диалог, в котором необходимо задать дополнительные настройки конфигурации выбранного драйвера.

Microsoft OLE DB Provider for ODBC - Connection - Setting specific ODBS provider options

Набор опций в диалоге зависит от того, какой ODBC драйвер Вы создаете.


Дополнительно

Вкладка Advanced используется для просмотра и настройки остальных параметров инициализации данных. Эта вкладка для каждого поставщика данных своя. На нее выносятся только свойства инициализации, которые характерны для выбранного поставщика.

Data link properties - Advanced

Impersonation level

Уровень представления, используемый сервером при исполнении роли клиентов. Данное свойство не распространяется на соединения RPC (Remote Procedure Call – вызовы удаленных процедур); а сами уровни представления аналогичны использующимся в RPC. Значения свойства напрямую соответствуют уровням олицетворения, которые могут быть указаны для проверенных соединений RPC, но могут применяться и к другим соединениям. Выберите один из следующих уровней.

  • Аноним—Анонимное подключение клиента к серверу. Процессу сервера недоступны идентификационные сведения клиента, поэтому представление клиента невозможно.
  • Делегирование—При работе от лица клиента, процесс может использовать защищенный контекст клиента. Кроме того, в этом случае от имени клиента процессом сервера могут осуществляться подключения к другим серверам.
  • Идентификация—Клиент может быть опознан сервером. Сервер может исполнять роль клиента при проверке таблицы управления доступом ACL (Access Control List), однако получить доступ к системным объектом как клиент он не может.
  • Олицетворение—При работе в качестве клиента, процесс сервера может использовать защищенный контекст клиента. Сведения могут быть получены только при установленном соединении, но не при каждом вызове.

Protection level

Уровень защиты данных, передаваемых между сервером и клиентом. Данное свойство не распространяется на соединения RPC (Remote Procedure Call – вызовы удаленных процедур); а сами уровни защиты аналогичны использующимся в RPC. Значения свойства напрямую соответствуют уровням защиты, которые могут быть указаны для проверенных соединений RPC, но могут применяться и к другим соединениям. Выберите один из следующих уровней.

  • Вызов—Проверка подлинности источника данных в начале каждого запроса от клиента к серверу.
  • Подключение—Проверка подлинности данных проводится только при установлении соединения с сервером.
  • Не проверяется—Подлинность отправляемых на сервер данных не проверяется.
  • Пакет—Проверка подлинности того, что все полученные данные исходят от клиента.
  • Целостность пакета—Проверка подлинности того, что все полученные данные исходят от клиента и не были изменены при передаче.
  • Приватность пакета—Проверка подлинности того, что все полученные данные исходят от клиента и не были изменены при передаче, а также защита конфиденциальности данных шифрованием.

Connect timeout

Время (в секундах), в течение которого поставщик OLE DB ожидает завершения инициализации. По истечении этого времени соединение установлено не будет и возникнет ошибка.

Access permissions

Выберите одно или несколько прав доступа.

  • Read—Только чтение.
  • ReadWrite—Чтение и запись.
  • Share Deny None—Никому не отказывать ни в чтении, ни в записи.
  • Share Deny Read—Запретить всем работу в режиме чтения.
  • Share Deny Write—Запретить всем работу в режиме записи.
  • Share Exclusive—Запретить всем работу в режиме чтения/записи.
  • Write—Только запись.

Смотрите также:

Провайдер

Подключение

Все


Все

Вкладка All предназначена для просмотра и настройки всех параметров инициализации OLE DB, которые поддерживает текущий поставщик. В зависимости от используемого поставщика OLE DB параметры могут изменяться.

Data link properties - All

Все свойства и их значения представлены в виде таблицы.

В поле Name отображается параметр, в поле Value - его значение.

Имеется возможность открыть диалоговое окно Изменение значения свойства, дважды щелкнув нужное свойство или нажав кнопку Edit Value. Для изменения свойства предназначено диалоговое окно Edit Property Value.

Нажмите кнопку OK, чтобы сохранить внесенные изменения и перейти на шаг установки параметров соединения.

Смотрите также:

Провайдер

Подключение

Дополнительно


Выбор зарегистрированной базы данных

В этом диалоге выберите базу данных, в которую Вы хотите перенести данные. Этот диалог доступен только в версии Data Pump for SQL Server для EMS SQL Management Studio.

Selecting registered database

В этом списке отображаются все базы данных, зарегистрированные в EMS SQL Management Studio.

Выберите нужную базу и нажмите кнопку OK.

Регистрационная информация базы данных автоматически появится в соответствующих полях на первом шаге.


Шаг 2 - Bыбор исходных схем

На этом шаге Вы можете выбрать схемы исходной базы данных, из которых будут извлечены объекты. Этот шаг доступен только если исходный сервер и провайдер (драйвер) поддерживают схемы.

Из списка Available schemas выберите доступные схемы и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available, перетаскивания или двойного щелчка мыши, переместите их в список выбранных схем - Selected schemas. Будут обработаны таблицы только из выбранных схем.

Step 2 - Selecting source schemas

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации.

<Предыдущий шаг

Следующий шаг>


Шаг 3 - Выбор исходных объектов

На этом шаге отображается список объектов исходной базы данных - Source database content. Объекты представлены в виде дерева. Управлять списком Вы можете с помощью контекстного меню.

Если хотите импортировать объект в назначенную базу данных, то установите флажок напротив его названия.

В поле Source object definition отображается дополнительная информация по выделенному объекту. Если источник не поддерживает схемы, то главным узлом древовидной структуры будет узел таблиц.

Step 3 - Selecting source objects

Важно: В назначенной базе данных все выбранные представления будут конвертированы в таблицы.

Контекстное меню

Контекстное меню открывается при нажатии на список объектов правой кнопкой мыши.

С его помощью Вы можете:

Step 3 - Source database content - Context menu

iconExpandAll Expand all - развернуть все узлы дерева

iconCollapseAll Collapse all - свернуть все узлы дерева

iconSelectAllIndexes Select all indexes - выбрать все индексы для переноса

iconUnselectAllIndexes Unselect all indexes - отменить выбор всех индексов

iconSelectAllKeys Select all keys - выбрать все ключи для переноса

iconUnselectAllKeys Unselect all keys - отменить выбор всех ключей

iconRefresh Refresh - обновить список объектов

<Предыдущий шаг

Следующий шаг>


Шаг 4 - Установка опций

На этом шаге Вы можете задать параметры переноса данных.

Step 4 - Setting options

Convert database structure options

В этом разделе Вы можете задать параметры преобразования структуры базы данных.

CheckBox Convert names to SQL92 standard

Установка этого флажка приводит все имена объектов базы данных в соответствие с правилами именования SQL92.

Object names format

В выпадающем списке можно указать должны ли имена объектов быть преобразованы к верхнему/нижнему регистру или остаться без изменений.

  • Upper Case - к верхнему регистру.
  • Lower Case - к нижнему.
  • As Is - оставить, как есть.

CheckBox Convert default values

Установите этот флажок, чтобы конвертировать значения по умолчанию исходной базы в значения по умолчанию назначенной базы.

Важно: Формат значений по умолчанию отличается для разных типов серверов, поэтому, если этот флаг установлен, Вам, возможно, придется исправлять значения по умолчанию на шаге 5 вручную, чтобы добиться корректного выполнения скрипта.

Schemas processing

В этом разделе укажите, действия, которые будут произведены со схемами.

RadioButton As is

Структура схем будет создана в соответствии со структурой исходной БД.

RadioButton Use existing schema for import

Если будет выбран этот вариант, таблицы будут помещены в существующую схему. Используйте раскрывающийся список для выбора схемы.

RadioButton Import tables to the new schema

Для импортируемых данных создается новая схема. Имя создаваемой схемы укажите в соответствующем поле.

Script options

В этом разделе Вы можете задать параметры генерации и выполнения SQL скрипта.

CheckBox Enable comments

В тело скрипта будут включены комментарии.

CheckBox Show "OK" for successfully executed statements

Если будет выбран этот вариант, отчеты об успешно выполненных операторах будут перечислены в информационной области скрипта на Шаге 6.

CheckBox Stop script execution on error

Остановить выполнение скрипта при возникновении ошибки.

CheckBox Always skip successfully executed statements

При последующем выполнении скрипта пропускать успешно выполненные операторы.

CheckBox Generate "DROP TABLE" statements

Добавить в скрипт операторы DROP для таблиц.

Import options

В том разделе Вы можете указать настройки импорта данных

CheckBox Clear tables before import data

Очистить таблицы, перед тем, как поместить в них данные. Шаг 8.

CheckBox Remove trailing spaces

Если этот вариант выбран, то пробелы в конце строк будут обрезаны.

CheckBox Quote source identifiers

Установив этот флажок, Вы позволяете заключать в кавычки идентификаторы исходных объектов.

Рекомендуется использовать кавычки, если имена объектов содержат пробелы, либо являются ключевыми словами языка.

Из раскрывающегося списка выберите тип кавычек.

  • Default - будут использоваться кавычки, принятые по умолчанию в источнике данных. Рекомендуется.
  • Одни из стандартных - "...", '...', `...`, [...], (...), {...}, <...>.
  • Custom - любой другой символ.

В окне, открывающемся при нажатии кнопки Global type mapping, открывается окно, позволяющее установить соответствия типов данных.

<Предыдущий шаг

Следующий шаг>


Установление соответствия типов

В этом окне Вы можете просматривать и изменять таблицу преобразования типов данных, используемых OLE DB провайдером к типам, существующим в назначенной базе данных.

Step 4 - Setting options - Global type mapping

Вы можете установить соответствие для каждого типа.

Список исходных типов данных отображается в столбце Source Type. Для каждого типа Вы можете выбрать соответствующий, в столбце Target Type. Редактор типа - Data type editor - открывается при нажатии на кнопку btnEllipsis.

С помощью редактора Data type editor Вы можете задать параметры конвертации исходного типа в указанный.

Для некоторых типов данных Вы можете задать масштаб, размер и точность представления данных.

Step 4 - Setting options - Global type mapping - Data type editor

Field Type - тип поля.

Precision - точность представления данных.

Scale - масштаб.

RadioButton Source precision - Как в исходной базе данных.

RadioButton User defined - определенное пользователем значение.

Установка опций


Шаг 5 - Редактирование назначенных объектов

На этом шаге мастера вы можете просматривать предварительную структуру назначенной базы данных.

Структура базы представлена в виде дерева. Вы можете просматривать зависимости объектов.

Step 5 - Editing target objects

Структура назначенной базы данных отображается в разделе Target database content.

Контекстное меню

Контекстное меню позволяет управлять списком объектов. Открывается при нажатии на список правой кнопкой мышки.

Step 5 - Target database content - Context menu

iconExpandAll Expand all - развернуть всё.

iconCollapseAll Collapse all - свернуть всё.

В разделе Source object definition отображается описание выбранного объекта исходной базы данных. В разделе Target object definition Вы можете просматривать и изменять настройки объекта, который будет создан в назначенной базе данных.

В этом разделе Вы можете изменять параметры следующих типов объектов:

tables - таблицы,

table fields - поля,

table indexes - индексы таблиц,

primary key / [image] unique key / [image] foreign key - первичные/уникальные/внешние ключи,

Чтобы применить внесенные изменения, нажмите кнопку Apply.

Важно: программа не может контролировать совместимость заданных свойств, а также свойств полученных из исходной базы данных, поэтому следует внимательно задавать параметры совместимости, чтобы сгенерированный скрипт был выполним.

<Предыдущий шаг

Следующий шаг>


Свойства назначенной таблицы

На пятом шаге, в разделе Target object definition Вы можете просматривать и редактировать параметры назначенной [image] таблицы.

Step 5 - Editing target objects - Target table properties

Из раскрывающегося списка Schema выберите схему, в которую будут помещена таблица.

В поле Name - укажите имя таблицы

Comment

При необходимости можно снабдить объект комментарием.

Шаг 5 - Редактирование назначенных объектов


Свойства назначенного поля

На пятом шаге, в разделе Target object definition Вы можете просматривать и редактировать параметры назначенного [image] поля таблицы

Step 5 - Editing target objects - Target field properties

Name

Имя поля.

Type

Используйте раскрывающийся список, поддерживаемых SQL Server типов данных, чтобы выбрать тот, который вы хотели бы применить к выбранному объекту.

Size

Размер поля (для полей типа string).

Scale

Масштаб поля (если это возможно для выбранного типа данных).

Default value

Значение по умолчанию для поля.

Comment

При необходимости можно снабдить объект комментарием.

CheckBox Not NULL

Определяет способность поля принимать значение NULL (независимо от того, является ли поле NULL/NOT NULL)

CheckBox Is Row Guid

Столбцу указано свойство ROWGUIDCOL. ROWGUIDCOL указывает на то, что столбец - GUID колонка.

CheckBox Identity

Редактируемый столбец является идентификационным.

Seed

Значение, используемое для первой строки, загружаемой в таблицу.

Increment

Значение, добавляемое к предыдущему идентификационному значению загружаемой строки.

CheckBox Not for replication

при выполнении операций вставки ограничение внешнего ключа не устанавливается, если установлен этот флажок.

Шаг 5 - Редактирование назначенных объектов


Свойства назначенного индекса

На пятом шаге, в разделе Target object definition Вы можете просматривать и редактировать параметры назначенного [image] индекса.

Step 5 - Editing target objects - Target index properties

Name - имя индекса

Columns (read only) - имя столбца, являющегося индексом.

CheckBox Unique - является ли индекс уникальным. Каждый раз при добавлении данных, происходит проверка на наличие дублирующихся значений.

CheckBox Clustered

Индекс является кластерным. Индекс, в котором физический порядок строк в соответствующей таблице определяется логическим порядком ключевых значений.

CheckBox Drop existing

Должны ли быть удалены существующие индексы, прежде чем создавать новые.

CheckBox Fill factor

Коэффициент заполнения индекса, используемый по умолчанию.

Указывает, как полный Microsoft SQL Server должен создавать каждую страницу при создании нового индекса на основании существующих данных. Коэффициент заполнения влияет на производительность, так как в процессе заполнения SQL Server тратит значительное время на разбиение страниц по мере их заполнения.

CheckBox Ignore duplicate keys

Игнорировать дублирующиеся ключи. Указывает реакцию на ошибку, вызванную дублированием значений ключа в многострочной транзакции INSERT в уникальном кластеризованном или уникальном некластеризованном индексе.

CheckBox Pad index

этот флажок устанавливает процентную долю свободного пространства в страницах промежуточного уровня во время создания индекса. Pad Index активен только тогда, когда задан коэффициент заполнения - Fill factor.

CheckBox Do not recompute statistics

Устаревшая статистика не подлежит автоматическому пересчету.

Шаг 5 - Редактирование назначенных объектов


Свойства назначенного ключа

На пятом шаге, в разделе Target object definition Вы можете просматривать и редактировать параметры назначенного [image] первичного/ [image] уникального/ [image] внешнего ключа.

Step 5 - Editing target objects - Target key properties

Name - Имя ключа

Type (read only)

Тип ключа: Primary key, Unique key, Foreign key

Columns (read only)

Столбцы, составляющие ключ

Foreign Table (read only)

Имя внешней таблицы (для Foreign key)

Foreign Columns (read only)

Столбец во внешней таблице.

ON DELETE rule

Действие, выполняемое при удалении: NO ACTION, CASCADE, SET NULL (для Foreign key)

ON UPDATE rule

Действие, выполняемое при обновлении: NO ACTION, CASCADE, SET NULL (для Foreign key)

Шаг 5 - Редактирование назначенных объектов


Шаг 6 - Просмотр/изменение скрипта

На этом шаге Вы можете просматривать, изменять и выполнять сгенерированный SQL скрипт.

Step 6 - Viewing-editing generated script

Область редактирования скрипта позволяет вам просматривать, редактировать и сохранять скрипт.

Для вашего удобства, в редакторе скрипта осуществляется подсветка синтаксиса.

Инструменты работы со скриптом расположены в контекстном меню области редактирования.

Нажмите кнопку Execute Script, чтобы выполнить созданный SQL скрипт.

В области, расположенной в нижней части формы, отображаются результаты выполнения скрипта.

При выборе строки в разделе результатов, подсвечивается соответствующий оператор в редакторе скрипта.

Вы также можете использовать контекстное меню.

<Предыдущий шаг

Следующий шаг>


Использование контекстного меню

Для редактора текста запроса существует специальное контекстное меню, которое отрывается по нажатию правой клавиши мыши в любой точке области редактирования на шестом шаге. Это меню позволяет быстро выполнять самые используемые команды.

Step 6 - Script area - Context menu

  • Markers - Открыть подменю, позволяющее работать с маркерами
  • Toggle Bookmarks - Установить закладку
  • Go To Line Number - Перейти к строке под номером...
  • Undo - Отменить действие
  • Redo - Вернуть отмененное действие
  • Cut - Вырезать выделенное
  • Copy - Копировать выделенное
  • Paste - Вставить
  • Select All - Выделить все
  • Find - Найти
  • Replace - Найти и заменить
  • Search Next - Возобновить поиск
  • Incremental Search - инкрементный поиск
  • Load - Загрузить из файла
  • Save - Сохранить в файл
  • Load script from fixed template - Загрузить скрипт из шаблона
  • Quick Code - открыть подменю Quick Code

Подменю пункта Quick Code:

  • Select Character - Выбрать символ
  • Toggle Comment - Преобразовать выделенный текст в комментарии
  • Selection Lower Case - Привести выделенный текст к нижнему регистру
  • Selection Upper Case - Привести выделенный текст к верхнему регистру
  • Selection Toggle Case - Изменить регистр выделенного текста
  • Indent - Увеличить отступ текста
  • Unindent - Уменьшить отступ текста

Вы можете использовать это контекстное меню для работы с областью информации, расположенной в нижней части шестого шага.

Step 6 - Script execution information - Context menu

  • Execute Statement - Выполнить текущий оператор SQL
  • Clear successfully executed statements - Удалить сообщения об успешно выполненных операторах
  • Select a statement in script editor - Выделить оператор в тексте скрипта
  • Copy error message - Копировать сообщение об ошибке

Шаг 6 - Просмотр/изменение скрипта


Шаг 7 - Выбор таблиц для импорта данных

На этом шаге мастера Вы можете выбрать таблицы, из которых будут импортированы данные.

Из списка Available tables выберите доступные таблицы и с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available, перетаскивания или двойного щелчка мыши, переместите их в список выбранных таблиц - Selected tables.

Если список пуст, то возможно Вы не выполняли скрипт на предыдущем шаге, либо при выполнении возникли ошибки.

Step 7 - Selecting tables for data import

Вы можете устанавливать SQL критерии для выбранных данных с помощью Редактора критериев, открывающегося при нажатии на кнопку btnEllipsis.

В списке доступных таблиц содержатся только те, которые уже были созданы не предыдущем шаге.

<Предыдущий шаг

Следующий шаг>


Редактор критериев

Редактор критериев позволит Вам изменить задать дополнительные критерии отбора для данных исходной таблицы.

В назначенные таблицы будут импортированы только те данные, которые соответствуют условиям, указанным в разделах SELECT, FROM, WHERE.

Step 7 - Selecting tables for data import - Criterion editor

Важно: Вы также можете проверить текст критерия, чтобы убедиться, что синтаксис является правильным, и, чтобы узнать, сколько записей будет извлечено запросом.

Синтаксис описания критерия зависит от исходного сервера.

Нажмите кнопку OK, чтобы применить критерий для выбранной таблицы, или Cancel, чтобы выйти из редактора и вернуться к Шагу 6.

Шаг 7 - Выбор таблиц для импорта данных


Шаг 8 - Импорт данных

На этом шаге мастера Вы можете выполнить операцию импорта данных.

Step 8 - Importing data

CheckBox Detailed error messages

Отображать детальные сообщения об ошибках.

Commit after ... records

Фиксировать транзакцию после каждого указанного числа записей.

CheckBox Detailed data import process

Отображать детальный отчет о выполнении операции.

Нажмите кнопку <Back, если Вы хотите вернуться и изменить настройки.

Нажмите кнопку Import, чтобы начать импорт данных.

Контекстное меню журнала импорта позволяет вам сохранить журнал во внешний файл.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • загрузить шаблон.
  • сохранить шаблон.

<Предыдущий шаг


Использование файлов конфигурации (шаблонов)

Data Pump for SQL Server позволяет сохранять настройки конвертации данных во внешнем файле шаблона, имеющем расширение *.dpc.

Вы можете загрузить предварительно сохраненный шаблон, если хотите внести изменения, или запустить консольное приложение для выполнения операции.

Сохранение шаблонов

Сохранение параметров шаблонов

Загрузка шаблонов

Смотрите также:

Использование мастера

Настройка программы

Формат файла конфигурации


Сохранение шаблонов

Шаблоны сохраняются с помощью специального диалогового окна Save template options, которое открывается при выборе пункта Save template из раскрывающегося списка, появляющегося при нажатии кнопки Tools.

Вы можете сохранить все заданные настройки операции в файл шаблона (*.dpc) на последнем шаге "Импорт данных".

Порядок сохранения шаблона:

  • нажмите кнопку Tools;
  • выберите пункт Save template из открывшегося меню;
  • измените шаблон, используя диалоговое окно Save template options.

Смотрите также:

Загрузка шаблонов


Сохранение параметров шаблонов

В окне Save template options Вы можете конфигурировать шаблон.

Using templates - Save template options

File name

Имя и путь к файлу шаблона укажите в этом поле, с помощью кнопки btnSaveAs.

Comment

При необходимости, снабдите файл комментарием.

Template Type

В этом разделе выберите тип создаваемого шаблона.

RadioButton Dynamic template

Хранит настройки и список объектов. Если появляются новые объекты в исходной базе данных, то они автоматически добавляются в список исходных объектов.

RadioButton Fixed template

В шаблоне этого типа список объектов фиксированный.

CheckBox Recreate database

Если этот флажок установлен, то консольное приложение будет удалять назначенную базу данных и создавать её заново, помещая в неё структуру и данные исходной базы.

Сохранение шаблонов


Загрузка шаблонов

Меню, позволяющее выбирать действия для работы с шаблонами, открывается при нажатии на раскрывающийся список кнопки Tools.

Сохраненные шаблоны Data Pump загружаются при помощи диалогового окна, открывающегося при выборе пункта Load template.

Вы можете открыть шаблон заново, выбрав нужный из списка Reopen template.

Когда выбран шаблон, Вы можете перейти на любой шаг и изменить настройки операции.

Смотрите также:

Сохранение шаблонов


Настройка программы

Вы можете полностью настроить интерфейс программы с помощью инструмента Preferences.

Чтобы открыть окно Preferences необходимо на любом шаге мастера нажать кнопку Tools и из появившегося списка выбрать пункт Preferences.

Основные элементы управления располагаются на следующих вкладках:

General

На этой вкладке задайте основные опции программы.

Localization

Язык интерфейса программы укажите на этой вкладке.

Interface

На вкладках раздела Interface Вы можете указать стиль отображения таких элементов интерфейса, как кнопки, флажки и т.д.

Смотрите также:

Использование мастера

Использование файлов конфигурации (шаблонов)


Задание основных параметров

На этой вкладке задайте основные опции программы.

Preferences - General

CheckBox Save current options on exit

Сохранить настройки. Если установлен этот флажок, то все заданные на шагах мастера настройки будут отображаться при следующем запуске программы.

CheckBox Remember password

Помнить пароль (пароли) для доступа к базе данных.

CheckBox Confirm exit

Если при выходе из программы необходимо запрашивать подтверждение, то установите этот флажок.

CheckBox Confirm columns unchecking

Если Вы на третьем шаге не выбрали объект, имеющий зависимые объекты, то необходимо будет подтвердить это действие в появившемся окне.

Если флажок установлен, то окно подтверждения будет появляться.

CheckBox Refresh source objects on connection

Если этот флажок установлен, то исходные объекты будут обновляться при установке соединения.

CheckBox Select all tables in the source database by default

Если флажок установлен, то на третьем шаге по умолчанию буду выбраны все исходные таблицы.

В группе After loading the template укажите действия, выполняемые после загрузки шаблона:

RadioButton Open the wizard at step

Если эта опция выбрана, то после загрузки шаблона мастер откроется на шаге, выбранном из раскрывающегося списка.

RadioButton Run data import automatically

Если эта опция выбрана, то после загрузки шаблона импорт данных будет начат автоматически.

Смотрите также:

Локализация

Задание параметров интерфейса


Локализация

С помощью инструментов, расположенных на этой вкладке Вы можете задавать язык программы.

Preferences - Localization

В списке Language показан список доступных локализаций, которые можно установить как основной язык программы.

В поле Language file btnExplorer указан путь к папке, в которой по умолчанию находятся все файлы локализации, имеющие расширение *.lng.

Смотрите также:

Задание основных параметров

Задание параметров интерфейса


Задание параметров интерфейса

На вкладке Interface Вы можете выбрать схему оформления внешнего вида элементов управления программы.

Preferences - Interface

Схему выберите из раскрывающегося списка Schema name. Образцы элементов управления, расположенные ниже, примут вид в соответствии с выбранной схемой. Изменять внешний вид каждой группы элементов в отдельности можно на следующих вкладках:

  • Tree Lists - Деревья и списки
  • Edit controls - Элементы управления редактирования
  • Check boxes - Флажки
  • Buttons - Кнопки
  • Page controls - Вкладки
  • Group boxes - Группа кнопок

Вы можете создавать и сохранять собственные схемы настроек интерфейса.

Задайте необходимые настройки на вкладках, вернитесь на вкладку Interface и нажмите кнопку Save As.

Укажите имя создаваемой схемы в появившемся диалоговом окне и нажмите OK.

Preferences - Interface - Input scheme name

Смотрите также:

Задание основных параметров

Локализация


Деревья и списки

На вкладке Trees and Lists настройте внешний вид списков.

Preferences - Interface - Trees and lists

Из раскрывающегося списка Look & Feel выберите один из стандартных стилей оформления списков.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Hide selection

Если флажок установлен, то выделенный объект не будет отличаться от остальных. Если не установлен, то выбранный объект будет выделен другим цветом.

CheckBox Hide focus rectangle

Если флажок установлен, то выделенный объект не обозначается другим цветом, но вокруг его названия отображается прямоугольник.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Элементы управления редактирования

Флажки

Кнопки

Вкладки

Группы кнопок


Элементы управления редактирования

На вкладке Edit controls задайте стиль элементов управления и редактирования.

Preferences - Interface - Edit controls

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

Из списка Button style - стиль кнопок.

3D - трехмерные,

Flat - плоские с тенью,

Simple - простые

Hotflat - плоские в рамке

Ultraflat - плоские.

Стиль кнопок, расположенных в пределах поля, можно задать с помощью раскрывающегося списка Button transparency.

None - непрозрачные,

Inactive - прозрачные, когда неактивные.

Always - прозрачные,

Hide inactive - показывать при редактировании,

Hide unselected - показывать при наведении курсора.

Hot track - подсветка элементов управления.

Shadow - тень.

Native style - естественный стиль.

Edges - границы:

CheckBox Left - слева;

CheckBox Right - справа;

CheckBox Top - сверху;

CheckBox Bottom - снизу.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Флажки

Кнопки

Вкладки

Группы кнопок


Флажки

На вкладке Check boxes задайте вид флажков и переключателей.

Preferences - Interface - Check boxes

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Кнопки

Вкладки

Группы кнопок


Кнопки

На этой вкладке настройте внешний вид кнопок.

Preferences - Interface - Buttons

Из списка Button kind выберите вид кнопок.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Флажки

Вкладки

Группы кнопок


Вкладки

В этом окне задайте стиль оформления вкладок.

Preferences - Interface - Page controls

Из списка Tab Style выберите нужный стиль вкладок.

Tabs - в виде вкладок,

Buttons - в виде кнопок

Flat - плоские.

CheckBox Hot track - подсветка элементов управления.

CheckBox Multiline pages - вкладки могут располагаться в несколько рядов.

CheckBox Shadow - тень.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Флажки

Кнопки

Группы кнопок


Группы кнопок

Задайте стиль отображения групп кнопок на вкладке Group boxes.

Preferences - Interface - Group boxes

Из раскрывающегося списка Border style выберите стиль рамки.

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

Shadow - тень.

CheckBox Native style

Если флажок установлен, то к элементам управления будет применен стиль, действующий в ОС по умолчанию.

Важно: опция Native style доступна только в Windows® XP.

Все вносимые изменения отображаются в нижней части формы.

Смотрите также:

Деревья и списки

Элементы управления редактирования

Флажки

Кнопки

Вкладки


Консольное приложение

Консольное приложение Data Pump for SQL Server предназначено для быстрого и удобного экспорта данных из внешних файлов в таблицы базы данных SQL Server, а также для использования в любых планировщиках задач.

Использование консольного приложения

Смотрите также:

Мастер переноса баз данных


Использование консольного приложения

Все параметры переноса данных Вы можете указать в файле конфигурации, имеющем расширение *.dpc.

Шаблон может быть использован в Консольном приложении Data Pump for SQL Server.

Чтобы создать файл конфигурации (шаблон) следуйте инструкции:

  • запустите Data Pump for SQL Server Мастер сравнения и синхронизации данных;
  • задайте необходимые параметры на каждом шаге;
  • проверьте сравнение и синхронизацию на последнем шаге
  • сохраните шаблон.

Файл конфигурации можно запустить тремя способами:

  • использовать пункт Load Template из списка, открывающегося при нажатии на кнопку Tools.
  • дважды щелкнуть на созданном файле конфигурации (*.edc) мышью.
  • задать в консольном приложении команду запуска - <path to Data Pump for SQL Server console application>\MsDataPumpC.exe TemplateFile [-L] [-B]

Применение:

<path to Data Pump for SQL Server console application>\MsDataPumpC.exe TemplateFile [-L]

TemplateFile

Имя файла конфигурации *.dpc и путь к нему.

[-L]

Выберите текущую локализацию.

[-B]

Используйте этот параметр, если хотите запустить процесс в фоновом режиме.

Пример:

"C:\Program Files\EMS\Data Pump for SQL Server\MsDataPumpC.exe" DataPump1.dpc -L

Важно: Когда Вы используете консольное приложение Data Pump, то генерируемый скрипт операторы импорта всегда выполняются.

Важно: Следующие значения кода завершения возвращаются программой Data Pump for SQL Server операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка или ошибки;

2 - критическая ошибка. Эта задача не выполнена.

Смотрите также:

Использование мастера


Окно поиска

Text to find

В это поле вводится искомое сочетание символов.

Из раскрывающегося списка Вы можете выбрать сочетание символов, которое искали до этого.

CheckBox Case sensitive

Учитывать разряд символов при поиске

CheckBox Whole words only

Искать слово целиком

CheckBox Regular expressions

Искать устойчивое выражение

Direction

Выберите направление поиска.

RadioButton Forward - вперед

RadioButton Backward - назад

Scope

Укажите диапазон поиска.

RadioButton Global

Искать внутри всей доступной рабочей области.

RadioButton Selected text

Искать только в предварительно выделенном тексте.

Origin

Укажите, с какого места следует начать поиск

RadioButton From cursor

От курсора

RadioButton Entire scope

С начала доступной области

CheckBox Mark search result with stack marker

Если флажок установлен, то результаты поиска будут выделены цветом.

Нажмите кнопку Show All, чтобы выделить в тексте все результаты поиска.


Окно поиска и замены

В этом окне Вы можете указывать текст в Редакторе, который необходимо найти и текст, которым нужно заменить найденный.

Text to find

В это поле вводится искомое сочетание символов.

Из раскрывающегося списка Вы можете выбрать сочетание символов, которое искали до этого.

Text to replace

В этом поле укажите то сочетание символов, на которое нужно заменить искомый текст.

Options

CheckBox Case sensitive

Учитывать разряд символов при поиске

CheckBox Whole words only

Искать слово целиком

CheckBox Regular expressions

Искать устойчивое выражение

CheckBox Replace with template

Для корректной работы данной опции необходимо, чтобы был установлен флажок Regular expressions. Включите опцию, если хотите, чтобы регулярные выражения распознавались в поле Text to replace. Выражение, указанное в этом поле, будет применено к каждой строке, удовлетворяющей условию в поле Text to replace.

Важно: Синтаксис регулярных выражений, доступных для использования в полях Text to find и Text to replace схож с синтаксисом регулярных выражений Perl. Исчерпывающую информацию можно найти по адресу: http://perldoc.perl.org/perlre.html#Regular-Expressions.

CheckBox Prompt on replace - включите опцию, если хотите чтобы при каждом нахождении указанной последовательности символов программа выводила запрос о замене. Если опция выключена, замена будет происходить автоматически.

Direction

Выберите направление поиска.

RadioButton Forward - вперед

RadioButton Backward - назад

Scope

Укажите диапазон поиска.

RadioButton Global

Искать внутри всей доступной рабочей области.

RadioButton Selected text

Искать только в предварительно выделенном тексте.

Origin

Укажите, с какого места следует начать поиск

RadioButton From cursor

От курсора

RadioButton Entire scope

С начала доступной области

CheckBox Mark search result with stack marker

Если флажок установлен, то результаты поиска будут выделены цветом.

Show All, чтобы выделить в тексте все результаты поиска.

Нажмите кнопку Replace All, чтобы автоматически заменить все искомые сочетания символов.


Формат файла конфигурации

Файл конфигурации (шаблон) используемый Data Pump for SQL Server состоит из нескольких разделов, каждый из которых соответствует конкретной группе настроек, указанных на разных шагах Мастера переноса баз данных.

[#General#]

В этом разделе хранятся общие сведения об утилите:

Параметр | Описание
Product | внутреннее название продукта
Version | версия

[Source]

В этом разделе хранятся параметры подключения к источнику данных. Эти параметры указываются на Первом шаге Мастера и являются обязательными для заполнения.

Параметр | Описание
ConnectionString | Строка подключения источника данных

[#Comment#]

Комментарии к файлу шаблона.

Параметр | Описание
Line<N> | текст комментария

N - идентификатор строки

Пример:

Line0=Data Pump for SQL Server

Line1=Template file #1

Line2=Pumping tables from MS Access to SQL Server

[Options]

В этом разделе хранятся параметры преобразования данных и варианты исполнения скрипта. Соответствующие параметры задаются на шагах 4 и 8 Мастер переноса баз данных.

Параметр

Описание

CommitAfter

Количество записей, после которых необходимо вставить оператор COMMIT

DisplayErrorMessages

0 = сообщения об ошибках не отображаются в журнале импорта.

1 = сообщения об ошибках отображаются в журнале импорта.

DetailErrorMessages

0 = простые сообщения об ошибках в журнале импорта

1 = детализированные сообщения об ошибках в журнале импорта

ShowTableProgress

0 = не детализированная информация о ходе импорта в журнале импорта

1 = детализированная информация о ходе импорта в журнале импорта

ConvertNames

0 = не конвертируются имена объектов

1 = имена преобразуются в соответствии с правилами именования SQL92

NamesFormat

nfAsIs = имена объектов остаются без изменений

nfLowerCase = имена объектов преобразуются к нижнему регистру

nfUpperCase = имена объектов преобразуются к верхнему регистру

ConvertDefaultValues

0 = значения по умолчанию источника данных не конвертируются

1 = значения по умолчанию источника данных преобразуются в значения по умолчанию назначенной базы данных.

EnableScriptComments

0 = комментарии отключены

1 = комментарии включены в тело скрипта

DropIfExistDbStatement

параметр не используется Data Pump for SQL Server

StopScriptOnError

0 = выполнение скрипта не остановился при возникновении ошибки

1 = выполнение скрипта остановился при возникновении ошибки

ShowExecutedStatements

0 = в разделе Script execution information area на Шаге 6не отображается информация о выполнении скрипта.

1 = в разделе Script execution information area на Шаге 6не отображается информация о успешном выполнении скрипта.

AlwaysSkipSuccExecuted

0 = при следующем выполнении скрипта на Шаге 6 сообщения об успешно выполненных операторах появятся.

1 = при следующем выполнении скрипта на Шаге 6 сообщения об успешно выполненных операторах не появятся.

ClearTablesBeforeImport

0 = не очищать таблицу назначенной базы данных SQL Server перед импортом данных на Шаге 8.

1 = очищать таблицу назначенной базы данных SQL Server перед импортом данных на Шаге 8.

TrimStringSpaces

0 = пробелы в конце строк не будут обрезаны.

1 = пробелы в конце строк будут обрезаны.

QuoteNamesInImportSelQuery

0 = не заключать в кавычки идентификаторы исходных объектов.

1 = заключать в кавычки идентификаторы исходных объектов.

QuoteTemplate

qtCustom = текущие символы кавычек (QuoteCharLeft, QuoteCharRight)

qtDefault = кавычки, принятые по умолчанию в источнике данных.

qtDoubleQuote = "..."

qtSingleQuote = '...'

qtApostrophe = `...`

qtSquareBracket = [...]

qtRoundBracket = (...)

qtBrace = {...}

qtAngleBracket = <...>

QuoteCharLeft

символ левой кавычки (if QuoteTemplate = qtCustom)

QuoteCharRight

символ правой кавычки (if QuoteTemplate = qtCustom)

SchemasMapping

Работа со схемами

SchemasMappingExist

Название схемы в источнике данных Data Pump for SQL Server

SchemasMappingNew

Название новой схемы Data Pump for SQL Server

GenerateDropTableStmt

0 = не добавлять в скрипт операторы DROP для таблиц.

1 = добавлять в скрипт операторы DROP для таблиц.

DefaultTableCollation

правило сравнения символьных данных.

DefaultTableType

способ хранения, который будет применен ко вставленным таблицам по умолчанию

[Target]

В этом разделе хранятся параметры подключения для целевой базы данных SQL Server.

Параметр | Описание
Host | Сервер (хост) назначенной базы данных, к которому хотите подключиться.
Login | имя пользователя (if NTAuth = 0)
Password | пароль пользователя(encrypted)
RemoteIndex | 0 = локальное соединение (сервер установлен на этом компьютере) 1 = соединение с сервером по сети
DataBase | Имя целевой базы данных
DatabaseActions | cdtCreate = создать новую базу, куда будут помещены данные. cdtSelectExisting = подключиться к уже существующей базе. cdtRecreate = пересоздать назначенную базу данных.
NTAuth | 0 = аутентификация SQL Server 1 = аутентификация Windows authentication

[{TBL}<table_name>]

В этом разделе укажите параметры создаваемой назначенной таблицы и параметры импорта данных. Эти параметры задаются на Шаге 5 и Шаге 7.

Важно: Этот раздел доступен только при редактировании динамических шаблонов.

Параметр | Описание
Name | Имя таблицы
NameSpace | схема SQL Server
Excluded | 1 = таблица исключена из импорта данных на Шаге 7
WhereClause | текст условия WHERE для вставки данных

[{FLD}<field_name>]

В этом разделе Вы можете изменять свойства полей. Эти параметры редактируются на Шаге 5.

Важно: Этот раздел доступен только при редактировании динамических шаблонов.

Параметр | Описание
Name | Имя поля
Type | тип данных в поле
Size | Размер поля
Scale | Масштаб поля (если это возможно для выбранного типа данных).
Precision | точность отображения данных
Default | Значение по умолчанию для поля.
NotNULL | способность поля принимать значение NULL 0 = nullable 1 = NOT NULL
AutoIncrement | 0 = не идентификационное поле 1 = идентификационное поле
NotForRepl | 0 = при выполнении операций вставки ограничение внешнего ключа устанавливается 1 = при выполнении операций вставки ограничение внешнего ключа не устанавливается
Seed | Значение, используемое для первой строки, загружаемой в таблицу.
Increment | Значение, добавляемое к предыдущему идентификационному значению загружаемой строки.
RowGuid | 0 = обычный столбец 1 = столбец - GUID колонка.

[{IND}<index_name>]

В этом разделе Вы можете просматривать и редактировать параметры назначенного индекса.

Важно: Этот раздел доступен только при редактировании динамических шаблонов.

Параметр | Описание
Name | Имя индекса
Unique | 0 = не уникальный индекс 1 = уникальный индекс
Clustered | 0 = не кластерный индекс 1 = кластерный индекс
PadIndex | 0 = PAD_INDEX выключен 1 = PAD_INDEX включен
FillFactor | Коэффициент заполнения индекса, используемый по умолчанию.
IgnoreDuplicate | Игнорировать дублирующиеся ключи. 0 = IGNORE_DUP_KEY выключен 1 = IGNORE_DUP_KEY включен
DropExisting | 0 = существующие ключи не удаляются 1 = существующие ключи удаляются
Statics | 0 = устаревшая статистика автоматически пересчитывается 1 = устаревшая статистика не пересчитывается автоматически

[{FK}<key_name>]

В этом разделе Вы можете просматривать и редактировать параметры ключей.

Важно: Этот раздел доступен только при редактировании динамических шаблонов.

Параметр | Описание
Name | Имя ключа
DeleteAction | Действие, выполняемое при удалении (для внешних ключей): 0 = NO ACTION 1 = CASCADE 2 = SET NULL 3 = SET DEFAULT
UpdateAction | Действие, выполняемое при обновлении (для внешних ключей): 0 = NO ACTION 1 = CASCADE 2 = SET NULL 3 = SET DEFAULT

[TypeMapping]

В этом разделе Вы можете указать соответствие типов данных, между данными, используемыми OLE DB провайдером и типами, существующими в назначенной базе данных.

Важно: Этот раздел доступен только при редактировании динамических шаблонов.

[ExcludedFromStructure]

В этом разделе Вы можете указать список объектов исходной базы данных, которые не будут перенесены в назначенную базу данных. Эти параметры задаются на Шаге 3.

Важно: Этот раздел доступен только при редактировании динамических шаблонов.

Параметр | Описание
{NSP}<schema_name> | исключенная схема (если доступно)
{TBL}<table_name> | исключенная таблица
{IND}<index_name> | исключенный индекс
{FK}<key_name> | исключенный ключ

[SelectedTables]

В этом разделе Вы можете указать список таблиц исходной базы данных, которые будут перенесены в назначенную базу данных. Эти параметры задаются на Шаге 3.

Важно: Этот раздел доступен только при редактировании фиксированных шаблонов.

Параметр | Описание
TableCount | количество переносимых таблиц
SrcTableNS<N> | Имя исходной схемы (если доступно)
SrcTableNM<N> | Имя исходной таблицы
TrgTableNS0<N> | Имя назначенной схемы
TrgTableNM<N> | Имя назначенной таблицы

N - идентификатор таблицы.

Пример:

[SelectedTables]

TableCount=2

SrcTableNS0=dbo

SrcTableNM0=EMPLOYEE

TrgTableNM0=EMPLOYEE

SrcTableNS1=dbo

SrcTableNM1=DEPARTMENT

TrgTableNM1=DEPARTMENT

[Table<N>]

В этом разделе Вы можете указать список полей исходной базы данных, которые будут перенесены в назначенную базу данных. Эти параметры задаются на Шаге 3.

Важно: Этот раздел доступен только при редактировании фиксированных шаблонов.

Параметр | Описание
SrcField<N> | Имя исходного поля
TrgField<N> | Имя назначенного поля
FieldCount | количество выбранных полей

N - идентификатор поля.

Пример:

[Table1]

SrcField0=DepartmentID

TrgField0=DEPARTMENTID

SrcField1=Name

TrgField1=NAME

SrcField2=GroupName

TrgField2=GROUPNAME

SrcField3=ModifiedDate

TrgField3=MODIFIEDDATE

FieldCount=4

[FixedInfo]

В этом разделе хранятся результаты скрипта, представленные на Шаге 6.

Важно: Этот раздел доступен только при редактировании фиксированных шаблонов.

Параметр | Описание
Line<N> | текст скрипта

N - идентификатор строки скрипта.


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться Data Pump for SQL Server, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

Data Pump for SQL Server подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

На первом шаге из раскрывающегося списка Database home выберите имя клиента и из раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.