Добро пожаловать в EMS Data Export!

Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта Ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF, ACCDB и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (конечные имена файлов, экспортируемые поля, форматы данных и многое другое) и консольной утилитой для быстрого экспорта данных из таблиц и запросов.

Ключевые особенности

  • Экспорт данных в 20 самых популярных форматов: MS Excel, MS Access, MS Word, RTF, HTML, PDF, XML, TXT, DBF, CSV, ODF, SYLK, DIF, LaTeX, SQL, ACCDB, буфер обмена и другие
  • Одновременный экспорт данных из нескольких таблиц, представлений или запросов
  • Выбор полей для экспорта и изменение их порядка
  • Настраиваемые параметры экспорта для каждой таблицы, а также множество настроек экспорта для каждого формата данных
  • Возможность сохранения всех параметров экспорта активной сессии в файл конфигурации
  • Консольная утилита для автоматизации экспорта данных с помощью файла конфигурации
  • Поддержка новейших версий DB2
  • Дружественный интерфейс мастера настройки

Смотрите также:

Страница продукта на сайте | https://www.sqlmanager.ru/products/db2/dataexport
Поддержка | https://www.sqlmanager.ru/support
Регистрация: | https://www.sqlmanager.ru/products/db2/dataexport/buy


Hовости

Версия | Дата выпуска
Data Export for DB2 4.0 | 25.04.2023

Что нового в Data Export?

  • Добавлена поддержка темной темы интерфейса.

Whats new - Dark schema

  • Добавлена поддержка юникодных имен объектов.
  • Добавлена поддержка протокола SFTP для загрузки файлов экспорта на удаленный сервер.
  • После экспорта оставались временные файлы в папке TEMP. Исправлено.
  • Исправлен экспорт изображений в формат DOCX.
  • Множество других исправлений и улучшений.

Смотрите также:

Предыдущие версии


Cистемные требования

  • Microsoft® Windows XP, Microsoft® Windows 2003 Server, Windows® 2008 Server, Microsoft Windows Server 2008 R2, Microsoft Windows Server 2012, Microsoft Windows Server 2012 R2, Microsoft Windows Server 2016, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8/8.1, Microsoft Windows 10, Microsoft Windows 11
  • 512 MB RAM
  • 50MB свободного пространства на жестком диске для установки программы
  • DB2 Run-Time/Administrative Client, версия 8.0 или выше


Установка

Установка программы Data Export for DB2

  • загрузите установочный файл программы со страницы загрузки,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • откройте файл DB2ExportSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Часто задаваемые вопросы по установке ПО

Обновление программы

  • загрузите установочный файл программы со страницы загрузки сайта,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • закройте программу Data Export for DB2, если она запущена,
  • запустите файл DB2ExportSetup.exe и следуйте инструкциям мастера обновления.


Приобретение

Для приобретения наших продуктов на территории Российской Федерации вы можете использовать форму он-лайн оплаты платежной картой либо запросить счёт для безналичной оплаты путем банковского перевода.

Выбор типа лицензии, количества лет Сопровождения и способа оплаты происходит на странице покупки продукта.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery).

После приобретения мы отправим вам регистрационный ключ электронной почтой. Регистрационная информация будет так же доступна зарегистрированным пользователям на нашем сайте.

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО.

Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

Подробнее об услуге сопровождения читайте на странице http://www.sqlmanager.ru/support/faq#maintenance.

Если у вас остались вопросы - вы можете найти ответы на них в разделе FAQ или обратиться в службу поддержки по адресу sales@sqlmanager.ru.


Регистрация

Чтобы зарегистрировать приобретенную копию Data Export for DB2, необходимо выполнить следующие действия:

  • Получите извещение, содержащее регистрационную информацию, от службы Digital River.
  • Введите Регистрационное имя и Регистрационный ключ в поля Registration Name и Registration Key соответственно.
  • На странице Начало работы проверьте, что регистрационные данные были введены верно.

Welcome to EMS Data Export - Register product

Смотрите также:

Приобретение


Предыдyщие версии

23.07.2021 Выпущена новая версия Data Export for DB2 3.7.4

19.07.2019 Выпущена новая версия Data Export for DB2 3.7.3

09.04.2016 Выпущена новая версия Data Export for DB2 3.7.2

28.04.2016 Выпущена новая версия Data Export for DB2 3.7.1

09.06.2014 Выпущена новая версия Data Export for DB2 3.7.0.1

28.01.2013 Выпущена новая версия Data Export for DB2 3.6.0.1

18.06.2012 Выпущена новая версия Data Export for DB2 3.5.0.1

14.12.2011 Выпущена новая версия Data Export for DB2 3.4.0.7

17.02.2010 Выпущена новая версия Data Export for DB2 3.3.0.1

25.02.2009 Выпущена новая версия Data Export 2007 for DB2

22.05.2008 Выпущена новая версия Data Export 2007 for DB2

21.08.2007 Выпущена новая версия Data Export 3.0

30.10.2006 Выпущен Data Export вер.2.3

04.05.2006 Выпущен Data Export 2005 версии 2.2

23.07.2021 Выпущена новая версия Data Export for DB2 3.7.4

  • Добавлена поддержка сервера PostgreSQL 13.
  • Добавлена поддержка сервера MySQL версии 8.
  • Исправлена ошибка подключения к SQL Server с использованием TLS 1.2.
  • При экспорте в формат SQL исправлено ошибочное подставление имени таблицы.
  • Исправлена ошибка вызова процедуры в скрипте.
  • Другие небольшие исправления.

19.07.2019 Выпущена новая версия Data Export for DB2 3.7.3

  • MS. Добавлена поддержка баз данных Azure.
  • Добавлена возможность отключения записи метки BOM в файл при экспорте в формат SQL.
  • MS. Исправлена ошибка подключения к SQL Server 2017 с использованием TLS.
  • При использовании шаблона не применялся порядок колонок. Исправлено.
  • Исправлено выравнивание столбцов по ширине при экспорте в формат DOC.
  • В шаблон не сохранялись некоторые параметры форматирования XLS. Исправлено.
  • В консольной версии не применялась ориентация листа для формата PDF. Исправлено.
  • В шаблоне не сохранялись переименованные названия колонок для CSV формата.
  • В некоторых случаях из шаблона некорректно загружались запросы. Исправлено.
  • При использовании опции "Apply to all exported objects" в скрипт SQL выгружались имена таблиц без указания схемы. Исправлено.
  • Множество других исправлений и улучшений.

09.08.2017 Выпущена новая версия Data Export for DB2 3.7.2

  • Теперь данные BLOB можно экспортировать в виде Base64 строки для форматов, не поддерживающих бинарные данные.
  • Добавление BOM в файлы экспорта текстового формата теперь опционально.
  • Исправлены ошибки при использовании Before export скриптов.
  • Сообщения об удаленных таблицах не добавлялись в лог при использовании шаблона.
  • Исправлена ошибка при экспорте представлений.
  • Исправлен экспорт дат в XLSX файлы при использовании форматов.
  • Исправлен экспорт в TXT файлы при использовании опции "User-defined column width".
  • Другие небольшие исправления.

28.04.2016 Выпущена новая версия Data Export for DB2 3.7.1

  • Поддержка последних версий OpenSSH.
  • Улучшена производительность и работа с памятью.
  • Шаблоны некорректно загружались в Studio. Исправлено.
  • Не выгружались данные из представлений в консольной версии. Исправлено.
  • Добавлена настройка формата timestamp для имен экспортируемых файлов.
  • Форматы полей не всегда загружались из шаблона. Исправлено.
  • Множество других улучшений и исправлений.

09.06.2014 Выпущена новая версия Data Export for DB2 3.7.0.1

  • DOCX. Реализована вставка в таблицу изображений из BLOB-полей.
  • XML. Реализован экспорт бинарных данных из BLOB-полей в форматах HEX и Base64.
  • Форматы числовых шаблонов, а также шаблонов даты и времени приведены в соответствие со стандартными форматами Windows.
  • Реализован пассивный режим подключения при загрузке файла на FTP-сервер.
  • XLS. При добавлении гиперссылки на другой *.xls файл, ссылка иногда оказывалась нерабочей. Исправлено
  • SQL. При вставке большого количества записей возникала ошибка "Out of memory". Исправлено.
  • MDB, ACCDB. Поля типа Integer выгружались как текст. Исправлено.
  • CSV. Не работала выгрузка в файл в кодировке UTF-8. Исправлено.
  • XML. При экспорте данных с пробелами, обычные пробелы заменялись неразрывными. Исправлено.
  • Прочие исправления и улучшения.

28.01.2013 Выпущена новая версия Data Export for DB2 3.6.0.1

  • Добавлена возможность выгрузки экспортированных файлов на FTP сервер.
  • Добавлена возможность дополнять имя экспортируемого файла датой/временем.
  • Добавлена возможность выполнять SQL скрипт до и после экспорта объекта.
  • Теперь шаблон программы создается одним файлом.
  • Теперь локализация доступна и в консольной версии.
  • Теперь бинарные данные можно экспортировать как HEX.
  • Экспорт в SQL. Добавлена возможность формирования одного оператора INSERT.
  • Экспорт в Excel (xls). Теперь можно разбивать экспортируемые данные по заданному количеству строк на листы в файле Excel.
  • Теперь можно сохранять изменения в шаблон без повторного вызова диалога сохранения.
  • При загрузке из шаблона портились SQL запросы. Исправлено.
  • Прочие изменения и исправления.

18.06.2012 Выпущена новая версия Data Export for DB2 3.5.0.1

  • Добавлен экспорт данных в формат MS Access 2007 (*.accdb. Необходимо наличие Microsoft Access Database Engine 2010 Redistributable).
  • Теперь файл Справки в программе запускается на выбранном языке локализации, при его наличии.
  • Добавлено контекстное меню для редактора SQL запроса: Копировать (Copy), Вставить (Paste), Выбрать все (Select All), Сохранить как запрос по умолчанию (Save as default query).
  • Добавлена возможность сохранения и копирования журнала процесса экспорта в буфер обмена.
  • Происходила утечка памяти при экспорте в формат Excel 2007. Исправлено.
  • При одновременном запуске двух и более экземпляров консольного экспорта с указанием для каждого индивидуального файла журнала, файл журнала создавался только для первого экземпляра. Исправлено.
  • При экспорте в MS Access более 2 ГБ данных появляется понятное пользователю сообщение об ошибке.
  • Журнал процесса экспорта не поддерживал вывод юникодных символов. Исправлено.
  • Прочие изменения и исправления.

14.12.2011 Выпущена новая версия Data Export for DB2 3.4.0.7

  • Консольная версия утилиты теперь отображает прогресс процесса экспорта данных.
  • Экспорт в формат SQL на OC Windows 7 приводил к ошибке Access Violation. Исправлено.
  • Для формата MS Access при экспорте в существующую таблицу возникала ошибка. Исправлено.
  • При экспорте в формат PDF неверно работало выравнивание по правому краю и по центру. Исправлено.
  • Теперь при экспорте в формат PDF строки с большим числом символов разбиваются и размещаются корректно, не перекрывая соседние ячейки.
  • Не сохранялась настройка выбранного для приложения языка. Исправлено.
  • В автоматически сгенерированных именах файлов недопустимые символы теперь заменяются знаком подчеркивания.
  • Прочие незначительные изменения и исправления.

17.02.2010 Выпущена новая версия Data Export for DB2 3.3.0.1

  • При экспорте из SQL запроса, добавлена возможность автоматически добавлять текст запроса в колонтитулы.
  • Визуальные изменения, сохранения размеров, теперь утилитой экспорта стало пользоваться еще удобнее.
  • Исправлена ошибка записи в верхний колонтитул количества строк в DBF файле.
  • Теперь при экспорте в DBF можно указывать size и decimal для полей типа float.
  • Исправлена ошибка, возникавшая при экспорте более 65536 записей в формат Excel 97-2003.
  • Другие улучшения и исправления.

22.05.2008 Выпущена новая версия Data Export 3.2

  • При экспорте в SQL Script данные полей типа BLOB (MEMO, BLOB, CLOB, etc.) форматируются в соответствии с синтаксисом выбранного destination server.
  • Добавлена возможность задавать ориентацию страницы (portrait, landscape) при экспорте в MS Word 2007.
  • Теперь отображение таблиц в DB2, имеющих одинаковые имена, но разный регистр букв, происходит правильно.
  • При экспорте с помощью шаблона, на пятом шаге не отображались таблицы. Исправлено.
  • Прочие улучшения и доработки.

22.05.2008 Выпущена новая версия Data Export 3.1

  • Добавлена возможность выбора кодировки при экспорте в TXT файл (ANSI, OEM, MAC, UTF8, UTF16, UTF32).
  • Теперь при экспорте в SQL скрипт, если совпадает тип утилиты и сервер, для которого Вы генерируете SQL файл - извлекается описание таблицы из базы для оператора CREATE TABLE.
  • Исправлена ошибка Error :Record 0 not accessible in Unidirectional mode. появлявшаяся у триал версии.
  • Путь до директории, в которой должен быть сохранен выходной файл теперь можно загружать из шаблона.
  • Добавлена возможность генерировать оператор SQL 'IDENTITY_INSERT' для экспорта в MSSQL script.
  • Теперь при экспорте данных из запроса отображается список полей.
  • Исправлена ошибка, касающаяся размеров DBF файлов. Теперь файлы создаются с правильным размером.
  • Прочие улучшения и доработки.

21.08.2007 Выпущена новая версия Data Export 3.0

Мы рады представить Вам новую версию EMS Data Export, мощное решение для быстрого экспорта Ваших данных из таблицы базы данных в 19 популярных форматов, включая MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и другие.

Что нового в Data Export версии 3.0

  • Добавлена возможность экспорта данных в файлов новых форматов:
  • MS Excel 2007
  • MS Word 2007
  • Open Document Format (Open Document Text и Open Document Spreadsheet)
  • Generic XML с поддержкой XSD схемы
  • Теперь вы можете использовать параметризованные запросы для экспорта данных. Значения параметров запросов в Мастере теперь запрашиваются в интерактивном режиме. В консольном режиме значения параметров можно задавать в параметрах командной строки или интерактивно.
  • Значительно улучшен исходный код, заметно возросла скорость работы утилиты.
  • При экспорте в формат SQL появилась возможность выбирать тип SQL сервера: SQL Server, Oracle, MySQL, DB2 и др.
  • Появилась возможность изменять размер окна утилиты.
  • Возникала ошибка при экспорте в формат MS Access таблиц с полями VARCHAR длиннее, чем 255 символов. Исправлено.
  • Прочие улучшения и доработки.

30.10.2006 Выпущен Data Export вер.2.3

Что нового в Data Export version 2.3

  • Добавлена поддержка экспорта из формата DBF, созданного с помощью VisualFoxPro.
  • Теперь утилита требует значительно меньше оперативной памяти при экспорте больших файлов.
  • Устранена ошибка, вызывавшая сдвиг данных из нижних ячеек в верхние во время экспорта из XLS файлов, в случае, когда содержимое верхних ячеек пусто.
  • Устранена ошибка, делавшая невозможным экспорт из файлов, содержащих в имени символ "." (точка).
  • При экспорте из файлов формата CSV некоторые данные из одних столбцов иногда дублировались в других столбцах. Исправлено.
  • Некорректное чтение полей типа MEMO с одинарным символом признака конца данных в секции (#26) из DBT файлов (формат DBF). Исправлено.
  • Исправлена ошибка формирования неверного выходного SQL скрипта при операциях экспорта Update, Update or Insert, Delete, Delete or Insert.
  • Другие улучшения и исправления.

04.05.2006 Выпущен Data Export 2005 версии 2.2.

Что нового в Data Export 2005 версии 2.2?

  • Добавлена опция "Interpret HTML Tags", позволяющая производить замену спецсимволов <, >, ", & на &lt; &gt; &quot; &amp; соответственно.
  • Добавлена возможность указания файла шаблона в командной строке для графической версии утилиты; обеспечена возможность сортировки списка баз данных.
  • Некоторые улучшения в графическом интерфейсе.
  • При экспорте в CSV формат устранено появление ненужных символов разделителей в конце строк заголовка.
  • При экспорте в буфер обмена устранено появление ненужных символов разделителей в конце строк записей.
  • Устранена ошибка, вызывающая некорректную загрузку содержимого запросов (queries) из файлов шаблонов.
  • Устранена ошибка, не позволявшая устанавливать высоту, ширину и поля листа при экспорте в PDF формат.
  • Устранена ошибка, не позволявшая сохранять ширину и выравнивание в файл шаблона при экспорте в PDF формат.
  • Устранено появление ошибки EOleSysError, как правило, возникающей при экспорте в MS Access во время создания нового файла базы данных (.mdb).


Часто задаваемые вопросы

Содержание

  • Что такое Data Export for DB2?
  • Что мне потребуется для начала работы с Data Export for DB2?
  • Как проще всего сконфигурировать файлы-шаблоны для консольного приложения Data Export for DB2?
  • В чем разница между функцией "Экспорт" в инструментарии SQL Manager for DB2 и утилите Data Export for DB2?
  • Я загрузил демонстрационную версию Data Export for DB2, но у меня экспортируются не все записи из исходных файлов. В чем причина?

В:

Что такое Data Export for DB2?

О:

Data Export for DB2 - это мощное приложение, предназначенное для быстрого экспорта Ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access (только для версии Windows®), MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (конечные имена файлов, экспортируемые поля, форматы данных и многое другое) и консольной утилитой для быстрого экспорта данных из таблиц и запросов.

В:

Что мне потребуется для начала работы с Data Export for DB2?

О:

Во-первых, Вам потребуется установленный на компьютере клиент DB2, а также доступ к любому локальному или удаленному серверу DB2 (https://www.ibm.com/software/data/db2/udb/).

Во-вторых, Вам нужен компьютер, работающий под управлением ОС Microsoft Windows NT4 c SP4 или более поздний версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows Vista и удовлетворяющий следующим системным требованиям: Pentium 300, 64 Mb RAM

В:

Как проще всего сконфигурировать файлы-шаблоны для консольного приложения Data Export for DB2?

О:

Сконфигурировать файлы-шаблоны для каждой таблицы проще всего визуально, используя Data Export for DB2 Wizard. В "третьем шаге" мастера настройте необходимые параметры и нажмите кнопку "Сохранить параметры экспорта/Save Export Options". Все настройки будут сохранены в файле-шаблоне, который может быть использован консольным приложением.

В:

В чем разница между функцией "Экспорт" в инструментарии SQL Manager for DB2 и утилите Data Export for DB2?

О:

Data Export for DB2 имеет некоторые дополнительные возможности, которые отсутствуют в SQL Manager for DB2. Например:

  • Одновременный экспорт данных из нескольких таблиц одновременно;
  • Экспорт данных из выбранных таблиц различных баз данных, расположенных на одном сервере;
  • Консольная утилита для экспорта данных с помощью файла конфигурации со всеми параметрами.

В:

Я загрузил демонстрационную версию Data Export for DB2, но у меня экспортируются не все записи из исходных файлов. В чем причина?

О:

Это ограничение демонстрационной версии, которая позволяет экспортировать только 20% записей. После регистрации продукт будет полностью функциональным.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for PostgreSQL EMS SQL Backup for PostgreSQL — это простой в использовании визуальный инструмент для создания резервных копий для нескольких серверов PostgreSQL из единой консоли. Вы можете создавать автоматизированные задачи резервного копирования на основе расписаний и хранить их в локальных или удаленных папках или облачных хранилищах.
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Мастер экспорта данных

Data Export for DB2 - позволяет экспортировать данные из таблиц, представлений, результатов запроса в файлы самых распространенных форматов.

Wizard application - Working with wizard application

Смотрите также:

Консольное приложение

Настройка программы


Работа с мастером экспорта данных

Data Export for DB2 позволяет экспортировать данные из таблиц, представлений, результатов запроса в файлы самых распространенных форматов.

Начало работы

Шаг 1 - Задание параметров соединения

Шаг 2 - Выбор таблиц

Шаг 3 - Создание запросов

Шаг 4 - Выбор формата выходного файла

Шаг 5 - Выбор полей для экспорта

Шаг 6 - Задание опций экспорта

Шаг 7 - Задание форматов данных

Шаг 8 - Задание общих опций

Шаг 9 - Задание дополнительных скриптов

Шаг 10 - Начало экспорта данных


Начало работы

Так выглядит Data Export for DB2 при первом запуске.

На этой форме Вы можете просмотреть регистрационную информацию и версию программы.

Enter Registration Code...

Нажмите кнопку для указания имени и регистрационного ключа в появившемся окне. Если регистрационный ключ указан правильно, то появится сообщение о дате окончания периода сопровождения.

Если копия программы не зарегистрирована, то в нижней части формы отображается количество дней, оставшихся до окончания действия ознакомительной копии.

Wizard application - Working with wizard application

Нажмите кнопку Next для перехода к первому шагу мастера экспорта данных.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации,
  • открыть файл конфигурации.

Следующий шаг

Смотрите также:

Приобретение и регистрация


Шаг 1 - Задание параметров соединения

На первом шаге необходимо задать параметры подключения к серверу DB2.

Задайте параметры авторизации пользователя на сервере. Имя указывается в поле Login, пароль - в поле Password.

Для доступа к DB2 серверу через HTTP протокол выберите HTTP туннелирование, установив переключатель RadioButton Connect through the HTTP tunnel.

Базу данных выберите из раскрывающегося списка Database alias. Список баз данных формируется на основании системного каталога DB2. Для работы с базой данных первоначально необходимо ее каталогизировать с помощью стандартных средств DB2 Client.

Дополнительную информацию о настройках подключения смотрите на странице Часто задаваемые вопросы.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации,
  • открыть файл конфигурации.

Следующий шаг


Шаг 2 - Bыбор таблиц

На этом шаге Вам необходимо из списка всех полей таблицы или представления выбрать те, которые Вы хотите экспортировать.

В верхней части окна отображается имя базы данных, которая содержит доступные для экспорта таблицы. Из раскрывающегося списка Select schema выберите схему, содержащую необходимые таблицы.

Из списка Available Tables выберите доступные для экспорта таблицы и с помощью кнопок, перетаскивания или двойного щелчка мыши, переместите их в список экспортируемых таблиц - Selected Tables. Если вы не выбрали ни одной таблицы, то на следующем шаге необходимо будет создать запрос.

Select destination Directory

Укажите путь к папке, в которой будет сохранен выходной файл. При нажатии на кнопку Select открывается диалоговое окно, позволяющее выбрать нужную директорию.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации.

Следующий шаг


Шаг 3 - Создание запросов

На этом шаге Вы можете создать запросы, результат которых следует экспортировать.

В верхней части окна отображается имя базы данных, которая содержит доступные для экспорта таблицы. Из раскрывающегося списка Select schema выберите схему, содержащую необходимые для создания запроса таблицы.

Создать запрос можно с помощью кнопки btnAddQuery . Чтобы удалить созданный запрос, нажмите кнопку btnRemoveQuery . Если хотите удалить сразу все запросы, воспользуйтесь кнопкой btnClearAll .

В окне Queries отображается список созданных запросов.

Текст каждого запроса можно задавать и просматривать в окне редактора запросов - Query Text.

Текст запроса в редактор можно загрузить из внешнего файла. Для этого необходимо нажать кнопку Load Query. После нажатия откроется диалоговое окно, позволяющее найти и выбрать файл с запросом.

Если хотите сохранить текст запроса в файл - нажмите кнопку Save Query. Удалить текст запроса из редактора можно, нажав кнопку Clear Query.

Если на предыдущем шаге Вы не выбрали ни одной таблицы, то на этом шаге кнопка Next станет активной только после создания запроса.

Для редактора запросов существует контекстное меню, которое отрывается по нажатию правой клавиши мыши в любой точке окна ввода запроса. Оно содержит как стандартные команды для работы с текстом: копировать (Copy), вставить (Paste), выделить все (Select All), так и команду для сохранения введенного запроса как запроса по умолчанию (Save as Default Query). Введенный Вами запрос будет автоматически скопирован в область редактирования шаблона запроса.

Если Вы хотите пропускать этот шаг при следующем выполнении экспорта данных, то установите флажок Don't show this step anymore. Если Вы установили этот флажок, то сделать шаг видимым сможете только на вкладке General окна настройки Preferences.

Если в качестве источника данных выбран запрос с параметрами, то на последнем шаге, при нажатии на кнопку Export, появится диалог Input Parameters, в котором Вы можете задать тип и значение параметров.

Step 9 - Imput Parameters dialog

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации.

Следующий шаг


Шаг 4 - Выбор формата выходного файла

На этом шаге необходимо выбрать формат файла, в который будут экспортированы данные.

Для каждой таблицы и запроса можно выбрать собственный формат выходного файла. Экспортируемые таблицы и запросы отображаются в списке Exported Objects.

Выберите таблицу из списка и задайте для нее формат выходного файла в разделе Export to, установив переключатель напротив нужного формата.

Вы можете применить формат данных сразу для всех таблиц и запросов, установив флажок CheckBox Apply to all exported objects.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации.

Следующий шаг


Шаг 5 - Выбор полей для экспорта

На пятом шаге Вы можете выбрать, какие колонки таблиц необходимо экспортировать.

Нужную таблицу или запрос выберите из списка Exported Objects.

Список колонок выбранной таблицы отображается в окне Exported columns. В столбце Column name показаны названия колонок, а в столбце Is Exported - экспортируется это поле или нет. По умолчанию все поля таблицы экспортируются, следовательно, каждая колонка отмечена. Ели хотите исключить колонку, то снимите соответствующую ей галочку.

С помощью пунктов контекстного меню или кнопок btnMoveUpField Move Up и btnMoveDownField Move Down Вы можете менять порядок колонок в выходном файле.

Если установлен флажок CheckBox Export all columns of all tables, то экспортированы будут все колонки всех таблиц и запросов.

С помощью кнопок Check all и Uncheck all Вы можете отметить как экспортируемые или неэкспортируемые сразу все колонки таблицы одновременно. Кнопка Invert All осуществляет замену всех значений в поле Is Exported на противоположные.

Если Вы хотите пропускать этот шаг при следующем выполнении экспорта данных, то установите флажок CheckBox Don't show this step anymore. Если Вы установили этот флажок, то сделать шаг видимым сможете только на вкладке Выбора шагов мастера.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации.

Следующий шаг


Шаг 6 - Задание опций экспорта

Набор опций на седьмом шаге определяется выбранным форматом выходного файла.

Для следующих форматов можно указывать различные свойства на этом шаге:

  • Excel
  • Access
  • Word / RTF
  • HTML
  • PDF
  • ASCII (for TXT and CSV formats)
  • SQL
  • XML
  • Excel/ODS
  • ODT

Если установлен флажок CheckBox Apply To All Exported Objects, то внесенные изменения будут применены ко всем экспортируемым объектам одновременно.

Allow captions - формат названий столбцов можно будет изменять, если установлен этот флажок.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации.

Следующий шаг


Задание колонтитулов

На этой вкладке можно задать текст, который будет отображаться в верхнем и нижнем колонтитулах выходного файла.

Если Вы выбрали формат файла, не поддерживающий колонтитулы, то этого шага не будет.

Если установлен флажок CheckBox Apply To All Exported Objects, то внесенные изменения будут применены ко всем экспортируемым объектам одновременно.

CheckBox Allow captions - формат названий столбцов можно будет изменять, если установлен этот флажок.

В поле Header text указываете текст верхнего колонтитула.

В поле Footer text - нижнего.

Этот текст будет повторяться на каждой странице выходного файла.

Step 7 - Header & Footer

Add Query Text

При экспорте из запроса, текст запроса можно добавить в верхний или нижний колонтитул. Используйте функцию Add Query Text для добавления текста текущего запроса. При использовании Add Query Template в колонтитул добавится текст запроса актуальный на момент нажатия кнопки Export на последнем шаге.

Важно: в поля колонтитулов можно вставлять макросы:

&N - количество страниц;

&P - номер текущей страницы.

Следующий шаг


Задание параметров заголовков колонок

На вкладке Caption & Width Вы можете задать названия и ширину столбцов в выходном файле.

CheckBox Allow captions

Включать имена поле в итоговый файл.

Step 7 - Caption and width

В столбце Column name отображаются названия экспортируемых полей.

В столбце Caption для каждого поля можно задать заголовок, который будет отображаться в выходном файле. Ширину поля в выходном файле укажите в столбце Width.

Для некоторых типов выходных файлов можно задавать и выравнивание текста заголовков.

В поле Align выберите горизонтальное выравнивание текста заголовка:

  • Left - по левому краю,
  • Center - по центру,
  • Right - по правому краю.

Следующий шаг


Особенности экспорта в Excel

Если данные будут экспортированы в файл формата Excel, то на этом шаге Вы можете указать следующие свойства:

  • колонтитулы - Header & Footer,
  • заголовки столбцов - Caption, width and align
  • формат данных - на вкладке Data format
  • расширения - на вкладке Extensions,
  • оформление - на вкладке Advanced.

Format-specific options - MS Excel - Data format - Fields

Следующий шаг


Оформление таблицы и данных

Вкладка Data format содержит инструменты, необходимые для форматирования ячеек выходного файла.

Вы можете задавать такие параметры как шрифт, выравнивание, границы и т.д. для всех типов ячеек (ячеек с данными, заголовков, ссылок и т.д.). Можно также создавать стили, которые могут быть применены ко всем типам ячеек.

Оформление Полей

Опции

Стили оформления

Format-specific options - MS Excel - Data format - Fields

Sample Cell

Все выбранные эффекты отображаются в этом поле.


Оформление столбцов

На вкладке Fields для каждого поля Вы можете указать совокупность параметров, определяющих его внешний вид.

Format-specific options - MS Excel - Data format - Fields

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Если нажата кнопка [image] [image] [image] [image] , значит граница будет отображаться. Для верхней, нижней, правой и левой границы отдельная кнопка.

Из раскрывающихся списков выберите тип границы (одинарная, двойная, пунктирная и т.д.). Нажав на кнопку [image] , Вы можете задать для границы цвет.

Кнопка [image] отвечает за цвет фона.

Из раскрывающегося списка Вы выберите узор.

Кнопка [image] позволяет выбрать цвет узора.

В группе Functions Вы можете задать для столбца одну итоговую функцию. Это значит что для данных в столбце будет найдено:

  • сумма - SUM,
  • или среднее арифметическое - AVG,
  • или минимальное значение - MIN,
  • или максимальное значение - MAX.
  • или количество записей - COUNT

Sample Cell

Все выбранные эффекты отображаются в этом поле.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного поля и для всех полей соответственно.


Опции

На вкладке Options есть возможность задать свойства вспомогательного текста:

  • верхний колонтитул - HEADER,
  • заголовок - CAPTION,
  • итоговые функции - AGGREGATE,
  • нижний колонтитул - FOOTER.

Format-specific options - MS Excel - Data format - Options

Все инструменты, отвечающие за шрифт, находятся на вкладке Font:

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Если нажата кнопка [image] [image] [image] [image] , значит граница будет отображаться. Для верхней, нижней, правой и левой границы отдельная кнопка.

Из раскрывающихся списков выберите тип границы (одинарная, двойная, пунктирная и т.д.). Нажав на кнопку [image] , Вы можете задать для границы цвет.

Кнопка [image] отвечает за цвет фона.

Из раскрывающегося списка Вы можете выбрать узор.

Кнопка [image] позволяет выбрать цвет узора

Sample Cell

Все выбранные эффекты отображаются в этом поле.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного поля и для всех полей соответственно.


Стили оформления

Вы можете создать собственный набор стилей, которые будут использоваться для оформления столбцов и строк.

Стили создаются на вкладке Styles.

С их помощью Вы можете оформить таблицу, задав различный цвет для столбцов или строк.

Чтобы создать стиль необходимо нажать на кнопку "+", чтобы удалить - на "-".

Менять порядок стилей можно с помощью кнопок btnMoveUp btnMoveDown .

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip style определяет, как будут применены созданные стили:

  • None - не применен,
  • Col - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Col или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Col, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Format-specific options - MS Excel - Data format - Styles

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выбираете один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Если нажата кнопка [image] [image] [image] [image] , значит граница будет отображаться. Для верхней, нижней, правой и левой границы отдельная кнопка.

Из раскрывающихся списков выберите тип границы (одинарная, двойная, пунктирная и т.д.). Нажав на кнопку [image] , Вы можете задать для границы цвет.

Кнопка [image] отвечает за цвет фона.

Из раскрывающегося списка Вы выберите узор.

Кнопка [image] позволяет выбрать цвет узора

Sample Cell

Все выбранные эффекты отображаются в этом поле.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного поля и для всех полей соответственно.


Расширения

Вкладка Extensions позволяет:

создавать ссылки в ячейках - объекты Hyperlinks,

создавать примечания для любой ячейки выходного файла - Notes,

задавать свойства диаграммы - Charts.

Все эти объекты представлены в виде иерархического списка.

Чтобы создать объект необходимо нажать на кнопку "+", чтобы удалить - на "-".


Ссылки

На этой вкладке Вы можете изменять параметры созданной гиперссылки.

Замечание: Если Вы создали гиперссылку, то её название, указанное в поле Title, заменит содержимое ячейки, для которой Вы её создали.

Format-specific options - MS Excel - Extensions - Hyperlinks

Свойства гиперссылки:

С помощью счетчиков Col и Row Вы задаете ту ячейку, в которой будет находиться гиперссылка. Col - номер столбца, Row - номер строки.

В разделе Style выберите тип ссылки - URL - адрес в интернете, Local file - файл на компьютере, на котором запущен Data Export for DB2, или в локальной сети.

В поле Title укажите имя гиперссылки.

В поле Target задайте путь к файлу или web странице.


Примечания

Примечание представляет собой какие-либо замечания, относящиеся к ячейке и хранящиеся независимо от содержимого этой ячейки. Ячейки с примечаниями помечаются треугольником в правом верхнем углу. При наведении указателя на ячейку, помеченную таким образом, отображается примечание.

Для создания примечаний к ячейкам выходного файла на вкладке Extensions существует вкладка Notes.

Format-specific options - MS Excel - Extensions - Notes

С помощью счетчиков Col и Row Вы можете задать ту ячейку, в которой будет находиться примечание. Col - номер столбца, Row - номер строки.

В поле Text пишете текст примечания.

Все инструменты, отвечающие за шрифт примечания, находятся на вкладке Font:

Format-specific options - MS Excel - Extensions - Notes - Font

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), подчеркивание (сплошное одинарное, не сплошное одинарное, сплошное двойное, не сплошное двойное), выравнивание текста по горизонтали и выравнивание текста по вертикали.

В разделе Orientation выбирается ориентация текста в окне примечания.

На вкладке Fill Вы можете задать вид фона окна примечания.

Format-specific options - MS Excel - Extensions - Notes - Fill

  • Solid - фон однородный,
  • Gradient - будет использован градиент фонового цвета,
  • Horizontal - горизонтальный,
  • Vertical - вертикальный,
  • Diagonal Up - диагональная_1,
  • Diagonal Down - диагональная_2,
  • From Corner - из угла,
  • From Center - от центра.

Кнопка [image] отвечает за цвет фона.

Кнопка [image] позволяет выбрать цвет узора.

Передвигая ползунок Transparency от отметки 0% до 100%, Вы можете задать степень прозрачности окна примечания. 100% - наибольшая степень прозрачности.


Диаграммы

Вы можете создать диаграмму в выходном файле Microsoft Excel.

Для этого на вкладке Extensions нужно создать объект Chart.

Format-specific options - MS Excel - Extensions - Charts

Основные свойства диаграммы можно задать на вкладке Base.

В поле Title указываете имя диаграммы.

Из раскрывающегося списка Style выберите тип диаграммы. Список состоит из стандартных типов диаграмм, таких как гистограмма, круговая, точечная и т.д.

В разделе Legend position укажите положение легенды:

RadioButton Bottom - под диаграммой,

RadioButton Corner - в углу,

RadioButton Top - над диаграммой,

RadioButton Right - справа от диаграммы,

RadioButton Left - слева от диаграммы.

Если установлен флажок CheckBox Show legend, то легенда будет отображаться.

Если установлен Флажок CheckBox Auto color, то на диаграмме каждая серия будет выделена своим цветом. Если не установлен, то все серии будут одного цвета.

На вкладке Position задается расположение диаграммы на листе.

Format-specific options - MS Excel - Extensions - Charts - Position

Автоматическое - Auto:

В разделе Placement указывается положение диаграммы относительно данных.

  • Bottom - под данными,
  • Right - справа от данных.

Ниже, с помощью счетчиков, указываются размер диаграммы и отступы сверху и слева в сантиметрах.

Left - расстояние до данных слева,

Top - расстояние до данных сверху,

Height - высота диаграммы,

Width - ширина диаграммы.

В разделе Custom можно указать абсолютное положение диаграммы с помощью координат X1, X2, Y1 и Y2.

На вкладке Category Labels Вы можете указывать, в каких строках и столбцах строить диаграмму.

Из раскрывающегося списка Column выберите столбец таблицы, который будет являться осью X в диаграмме.

Или с помощью счетчиков раздела Custom укажите диапазон ячеек.

Format-specific options - MS Excel - Extensions - Charts - Category Labels

Для того, чтобы построить диаграмму, необходимо создать объект Series. Без него невозможно построить диаграмму.

Этот объект указывает на те значения, которые будут располагаться в диаграмме по оси Y.

Для одной диаграммы может быть создано несколько серий.

Свойства серий задаются на специальной вкладке:

Format-specific options - MS Excel - Extensions - Series

Title - название серии,

Column - столбец таблицы, значения которого будут образовывать серию.

Или с помощью счетчиков раздела Custom указываете диапазон ячеек.

Нажав на кнопку [image] , Вы можете задать для серии цвет.


Оформление страницы

На вкладке Advanced Вы можете задать общие свойства страницы:

  • Page header - верхний колонтитул страницы,
  • Page footer - нижний колонтитул страницы,
  • Sheet title - название листа,
  • Split by rows - число строк, которое будет записано на каждый лист.

CheckBox Automatic column width

Автоматически вычислять ширину столбцов на основе размера данных.

Format-specific options - MS Excel - Advanced


Особенности экспорта в Access

Если данные будут экспортированы в файл формата Access (*.mdb) или MS Access (*.accdb), то на этом шаге Вы можете указать следующие свойства:

Step 7 - Format-specific options - Access 97

Password

Укажите пароль существующей таблицы, в которую Вы хотите поместить экспортируемые данные
Table Name

Укажите имя таблицы, в которую загрузить данные.

CheckBox Create table if it does not exist

При включенной опции таблица будет создана автоматически.

CheckBox Export Date/Time fields as nvarchar

Преобразовывать поля, имеющие тип данных дата или время в поля типа nvarchar.

Если установлен флажок Apply to all exported objects, то внесенные изменения будут применены ко всем экспортируемым объектам одновременно.

Следующий шаг


Особенности экспорта в Word/RTF

При экспорте данных в документ Microsoft Word можно указать следующие свойства выходного файла:

  • Задание колонтитулов - вкладка Header & Footer,
  • Задание параметров заголовков полей - вкладка Caption & Width & Align,
  • Базовые стили - вкладка Base Styles,
  • Стили оформления строк - вкладка Strip Styles,
  • Параметры страницы - вкладка Advanced.

Format-specific options - Word 97- Data styles

Sample

Все выбранные эффекты отображаются в этом поле.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного поля и для всех полей соответственно.

Следующий шаг


Базовые стили

На вкладке Base Styles Вы можете указать основные свойства выходного документа.

Из списка выберите объект, для которого необходимо задать свойства:

верхний колонтитул - HEADER,

заголовок - CAPTION,

нижний колонтитул - FOOTER,

ссылка - HYPERLINK.

Format-specific options - Word 97- Data styles

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Кнопка [image] отвечает за цвет фона. Если установлен флажок CheckBox Allow Background, то цвет фона будет отображаться в выходном файле.

Кнопка [image] позволяет выбрать цвет, которым будет выделен текст. Если установлен флажок CheckBox Allow Highlight, то в выходном файле текст будет выделен указанным цветом.

Sample

Все выбранные эффекты отображаются в этом поле.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного поля и для всех полей соответственно.


Стили оформления строк

На вкладке Styles Вы можете создать собственный набор стилей, которые будут использоваться для оформления столбцов и строк.

С их помощью Вы можете оформить таблицу, задав различный цвет для столбцов или строк.

Чтобы создать стиль необходимо нажать на кнопку "+", чтобы удалить - на "-".

Менять порядок стилей можно с помощью кнопок btnMoveUp btnMoveDown .

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip style определяет, как будут применены созданные стили:

  • None - не применен,
  • Col - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Col или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Col, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Format-specific options - MS Word and RTF - Strip Styles

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Кнопка [image] отвечает за цвет фона. Если установлен флажок CheckBox Allow Background, то цвет фона будет отображаться в выходном файле.

Кнопка [image] позволяет выбрать цвет, которым будет выделен текст. Если установлен флажок CheckBox Allow Highlight, то в выходном файле текст будет выделен указанным цветом.

Sample

Все выбранные эффекты отображаются в этом поле.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного поля и для всех полей соответственно.


Оформление страницы

На вкладке Advanced задайте параметры страницы выходного файла.

Format-specific options - MS Word and RTF - Advanced

В разделе Page orientation установите ориентацию страницы:

RadioButton Portrait - книжная,

RadioButton Landscape - альбомная.

CheckBox Automatic column width

Автоматически вычислять ширину столбцов на основе размера данных.


Особенности экспорта в HTML

Если Вы экспортируете данные в формате HTML, то для выходного файла Вы можете задать следующие характеристики:

  • задать колонтитулы на вкладке Header & Footer,
  • задать параметры заголовков полей - вкладка Caption & Align,
  • оформление таблицы в выходном файле можно выбрать из предлагаемых форматов на вкладке Preview,
  • основные свойства выходного файла можно указать на вкладке Basic,
  • свойства многостраничного документа можно задать на вкладке Multi-file,
  • шрифт и формат ячеек таблицы укажите на вкладке Advanced.

Step 7 - Format-specific options - HTML

Следующий шаг


Автоформат

На вкладке Preview Вы можете задать внешний вид таблицы данных.

Из раскрывающегося списка Template можно выбрать уже готовый шаблон оформления документа. В окне предпросмотра показано, как будет выглядеть итоговая таблица, если к ней применить выбранный шаблон оформления.

Format-specific options - HTML - Preview

Для того, чтобы изменить шаблон, достаточно нажать на любой элемент в окне предпросмотра. При нажатии на элемент появится стандартная палитра, из которой можно выбрать нужный цвет для этого элемента.

Можно изменять цвет текста, цвет фона и различных видов гиперссылок.

Внесенные изменения можно сохранить в виде шаблона с помощью кнопки Save template. В этом случае при следующем экспортировании Вы уже сможете воспользоваться готовым шаблоном, загрузив его с помощью кнопки Load template.


Базовые опции

Свойства выходного файла Вы можете задать на вкладке Basic.

Название выходного HTML файла указывается в поле Title. По умолчанию оно соответствует имени экспортируемого объекта.

В разделе Using CSS можно выбрать место хранения таблицы стилей:

RadioButton Internal - означает, что стили будут храниться в самом выходном HTML файле,

RadioButton External - для таблицы стилей будет создан отдельный файл формата *.css.

В поле CSS file name укажите имя CSS файла, а также выберите, куда его сохранить, с помощью кнопки btnEllipsis .

Если установлен флажок CheckBox Overwrite CSS file if it exist, то при создании нового CSS файла существующий будет заменен новым.

Format-specific options - HTML - Basic

Если установлен флажок CheckBox Interpret HTML tags, то HTML-теги будут интерпретированы как стили.


Многостраничный документ

Data Export for DB2 позволяет экспортировать таблицы, содержащие любое количество записей. Для того чтобы в выходном HTML файле было удобно просматривать таблицы с большим количеством записей, при экспорте Вы можете указать, что выходной файл будет многостраничным, а также указать количество строк на каждой странице.

Multi-file export

CheckBox Use multi-file export

Установив этот флажок, Вы указываете, что создаваемый HTML-документ будет многостраничным.

Maximum record(s) in a single file

Задайте количество записей, которое будет содержаться на каждой странице.

CheckBox Generate index

Если опция включена, то будет создана страница содержания, в которой будут ссылки на все страницы с данными.

Index link template

Укажите название страницы, которое будет отображаться в содержании рядом с номером страницы.

Format-specific options - HTML - Multi-file

Navigation

В этом разделе вы можете задать свойства навигационных элементов управления, то есть тех, которые обеспечивают переход между страницами документа. Навигация по многостраничному документу обеспечивается с помощью ссылок, которые выстроены в одну строку.

CheckBox On top

Разместить ссылку в верхней части страницы.

CheckBox On bottom

Разместить ссылку внизу страницы.

Далее в текстовых полях указывается текст ссылок:

  • Index link - текст ссылки на страницу содержания,
  • First link - текст ссылки на первую страницу с данными,
  • Prior link - текст ссылки на предыдущую страницу с данными,
  • Next link - текст ссылки на следующую страницу с данными,
  • Last link - текст ссылки на последнюю страницу с данными.


Оформление файла

Как будет выглядеть выходной файл, можно задать с помощью инструментов на вкладке Advanced.

Body options

Font name

Выберите шрифт, который будет использоваться по умолчанию на всех страницах выходного файла

Font size

Укажите размер шрифта для выходного файла.

Background

При помощи кнопки btnEllipsis выберите изображение в качестве фона.

Advanced attributes

Укажите дополнительные аттрибуты страницы.

Format-specific options - HTML - Advanced

Table options

Cell padding

Укажите размер между границами ячейки и содержимым.

Cell spacing

Укажите размер между ячейками таблицы.

Background

При помощи кнопки btnEllipsis выберите изображение в качестве фона таблицы.

Advanced attributes

Укажите дополнительные аттрибуты таблицы.


Особенности экспорта в PDF

Если данные будут экспортированы в файл формата PDF, то на этом Вы можете указать следующие свойства:

Step 7 - Format-specific options - PDF

Дополнительные свойства выходного файла задайте на вкладках Задание колонтитулов и Задание параметров заголовков полей

Из списка выберите объект, для которого необходимо задать вид шрифта:

Верхний колонтитул - Header font,

Заголовок - Caption font,

Данные - Data font.

Нижний колонтитул - Footer font.

Из раскрывающегося списка Font name выберите нужный шрифт. Кодировку выберите из списка Font Encoding.

В счетчике Font size укажите размер шрифта.

Кнопка btnFontColor отвечает за цвет шрифта.

В поле, расположенном ниже, Вы можете видеть все изменения производимые с объектом. Они отображаются на образце текста "SAMPLE".

Page options

  • из раскрывающегося списка Page size выберите размер страницы. По умолчанию стоит размер А4,
  • ширина страницы указывается в счетчике Width,
  • высота - в счетчике Height,
  • в раскрывающемся списке Units содержатся единицы измерения, в которых указан размер страницы,
  • из раскрывающегося списка Orientation выберите ориентацию страницы: (Portrait - книжная, Landscape - альбомная).

В разделе Margins можно задать размер полей страницы:

Left - левого,

Right - правого,

Top - верхнего,

Bottom - нижнего.

На вкладке Grid options задайте некоторые свойства таблицы:

Step 7 - Format-specific options - PDF - Grid options

Col spacing - количество пробелов для выравнивания столбца,

Row spacing - количество пробелов для выравнивания строки,

Line width - толщина линий таблицы.

Следующий шаг


Особенности экспорта в TXT/CSV

Если данные будут экспортированы в файл формата TXT или CSV, то на этом шаге Вы можете указать следующие свойства.

Для файлов формата TXT

Step 7 - Format-specific options - TXT

CheckBox Automatic column width

Автоматически вычислять ширину столбцов на основе размера данных.

Spacing

Укажите расстояние между ячейками.

Encoding

Выберите кодировку выходного файла:ANSI, OEM, MAC, UTF-8, UTF-16, UTF-32.

CheckBox Add byte order mark (BOM)

Добавлять метку порядка байтов BOM.

Для файлов формата CSV

Step 7 - Format-specific options - CSV

CheckBox Quote captions

Заключать в кавычки заголовки колонок.

CheckBox Quote strings

Заключать в кавычки строчные данные.

Comma

Выберите разделитель столбцов для CSV файла:

  • , (запятая)
  • ; (точка с запятой)
  • ' (апостроф)
  • TAB (символ табуляции)
  • SPACE (пробел)

Encoding

Выберите кодировку выходного файла:ANSI, OEM, MAC, UTF-8, UTF-16, UTF-32.

CheckBox Add byte order mark (BOM)

Добавлять метку порядка байтов BOM.

Следующий шаг


Особенности экспорта в SQL

Если данные будут экспортированы в файл формата SQL, то на этом шаге Вы можете указать следующие свойства:

Step 7 - Format-specific options - SQL

Destination server

Выберите сервер, для которого Вы генерируете SQL-файл.

RadioButton ANSI SQL-92

RadioButton DB2

RadioButton InterBase/Firebird

RadioButton MS SQL

RadioButton MySQL

RadioButton Oracle

RadioButton PostgreSQL

Table options

Table name

Задайте имя таблицы в выходном файле.

CheckBox Add 'Create Table' statement

Включите опцию, чтобы добавить в скрипт оператор CREATE TABLE и выберите SQL-диалект из выпадающего списка.

CheckBox Add 'IDENTITY_INSERT' statement (появляется при экспорте в MS SQL)

Эта опция позволяет вставлять явные значения в столбец идентификаторов таблицы.

Commit

CheckBox Commit after records

Фиксировать транзакцию после каждых n записей. Применяется для больших таблиц. Количество записей указывается в счетчике.

CheckBox Commit after script

Оператор фиксации транзакции будет помещен в конце скрипта.

Commit statement

Задайте оператор фиксации транзакции.

Other options

CheckBox Create multiple insert statement

Если отмечена эта опция, то в результирующем скрипте будет сгенерирован набор INSERT операторов для вставки данных.

Export null values as

Задайте текст для вывода значений NULL.

Statement term

Укажите разделитель операторов.

CheckBox Add byte order mark (BOM)

Добавлять метку порядка байтов BOM.

Следующий шаг


Особенности экспорта в XML

Если данные будут экспортированы в файл формата XML, то на шаге 6 Вы можете указать следующие свойства:

Encoding

Выберите из списка кодировку выходного файла.

CheckBox Standalone

Если опция включена, то будут использованы внешние декларации разметки, которые оказывают влияние на информацию, которую XML процессор передает приложению.

Step 7 - Format-specific options - XML

XML type

Выберите используемый тип XML: Datapacket 2.0 или Access.

CheckBox Export XSD schema

Если выбран тип Access, то можно экспортировать и XSD схему.

CheckBox Convert images to Bitmap

Если отмечена данная опция, то все изображения, хранящиеся в экспортируемой таблице, будут сконвертированы в *.png формат, что обеспечит совместимость с базой MS Access.

Следующий шаг


Особенности экспорта в DBF

При экспорте данных в формат DBF доступны следующие параметры:

На вкладке DBF Options Вы можете указать размер целой (Float Size) и дробной (Float Decimal) части значений типа float.Кодировку выберите из раскрывающегося списка Encoding.

Step 7 - Format-specific options - DBF

Следующий шаг


Особенности экспорта в Excel/ODS

Если Вы экспортируете данные в формате MS Excel или ODS, то для выходного файла Вы можете задать следующие характеристики:

  • задать колонтитулы на вкладке Header & Footer,
  • задать параметры заголовков полей - вкладка Caption,
  • задать основные параметры текста в выходном файле - Options,
  • задать стили оформления - Styles

Step 7 - Format-specific options - Excel ODS

Следующий шаг


Опции

На вкладке Options есть возможность задать свойства вспомогательного текста:

  • верхний колонтитул - HEADER,
  • заголовок - CAPTION,
  • данные - DATA,
  • нижний колонтитул - FOOTER.

Format-specific options - MS Excel 2007 and ODS - Options

Sheet Name

Укажите название листа.

Font

Выберите нужный шрифт.

Size

Укажите размер шрифта или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Wrap Text.

Если необходимо переносить текст по словам внутри ячейки, то нажмите кнопку.

Use Background

Использование фона для файла. Цвет фона можно выбрать с помощью кнопки [image] .

В окне, расположенном ниже, Вы можете видеть все изменения производимые с полем. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного объекта и для всех объектов соответственно.

На вкладке Border установите флажок Use Border, если хотите использовать границы в таблице.

Format-specific options - MS Excel 2007 and ODS - Options - Border

Кнопка Border Color [image] позволяет выбрать цвет границ. Из раскрывающегося списка Border Style выберите тип линии границы.


Стили оформления

Вы можете создать собственный набор стилей, которые будут использоваться для оформления столбцов и строк.

Format-specific options - MS Excel 2007 and ODS - Styles

Чтобы создать стиль необходимо нажать на кнопку "+", чтобы удалить - на "-".

Менять порядок стилей можно с помощью кнопок btnMoveUp btnMoveDown .

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Strip style

Определите как будут применены созданные стили:

  • None - не применен,
  • Column - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Column или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Column, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Все инструменты, отвечающие за шрифт, находятся на вкладке Font:

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Если необходимо переносить текст по словам внутри ячейки, то нажмите кнопку Wrap Text.

Если установлен флажок Use Background, то с помощью кнопки [image] можно задать цвет фона выходного файла.

В окне, расположенном ниже, Вы можете видеть все изменения производимые с полем. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного объекта и для всех объектов соответственно.

На вкладке Border установите флажок Use Border, если хотите использовать границы в таблице.

Format-specific options - MS Excel 2007 and ODS - Options - Border

Кнопка Border Color [image] позволяет выбрать цвет границ. Из раскрывающегося списка Border Style выберите тип линии границы.


Особенности экспорта в WORD/ODT

При экспорте данных в документ ODF Spreadsheets можно указать следующие свойства выходного файла:

  • Колонтитулы
  • Заголовки
  • Опции
  • Стили оформления строк
  • Оформление страницы

Step 7 - Format-specific options - Word ODT

Следующий шаг


Опции

На вкладке Options есть возможность задать свойства вспомогательного текста:

  • верхний колонтитул - HEADER,
  • заголовок - CAPTION,
  • данные - DATA,
  • нижний колонтитул - FOOTER.

Format-specific options - MS Word 2007 and ODT - Options

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Если необходимо переносить текст по словам внутри ячейки, то нажмите кнопку Wrap Text.

Если установлен флажок CheckBox Use Background, то с помощью кнопки [image] можно задать цвет фона выходного файла.

Если установлен флажок CheckBox Use Highlight, то из раскрывающегося списка вы сможете выбрать цвет выделения текста.

В окне, расположенном ниже, Вы можете видеть все изменения производимые с полем. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного объекта и для всех объектов соответственно.


Стили оформления

На вкладке Styles Вы можете создать собственный набор стилей, которые будут использоваться для оформления столбцов и строк.

С их помощью Вы можете оформить таблицу, задав различный цвет для столбцов или строк.

Чтобы создать стиль необходимо нажать на кнопку "+", чтобы удалить - на "-".

Менять порядок стилей можно с помощью кнопок btnMoveUp btnMoveDown.

При помощи следующих двух кнопок - Load Styles и Save styles - можно загрузить стили из файла и сохранить их в файл.

Переключатель Strip style определяет, как будут применены созданные стили:

  • None - не применен,
  • Column - к столбцам,
  • Row - к строкам.

Если создать один стиль и выбрать Column или Row в переключателе Strip style, то стиль будет применен ко всей таблице.

Если создать два стиля и выбрать Column, то к нечетным столбцам будет применен первый стиль, к четным, соответственно - второй.

Format-specific options - MS Word 2007 and ODT - Styles

Все инструменты, отвечающие за шрифт, находятся на вкладке Font:

Из раскрывающегося списка Font выберите нужный шрифт.

В списке Size укажите размер или выберите один из предложенных.

С помощью кнопок, расположенных ниже, Вы можете задать цвет шрифта, начертание (жирное, курсив или перечеркнутое), выравнивание текста по горизонтали и выравнивание текста по вертикали.

Если необходимо переносить текст по словам внутри ячейки, то нажмите кнопку Wrap Text.

Если установлен флажок CheckBox Use Background, то с помощью кнопки [image] можно задать цвет фона выходного файла.

Если установлен флажок CheckBox Use Highlight, то из раскрывающегося списка вы сможете выбрать цвет выделения текста.

В окне, расположенном ниже, Вы можете видеть все изменения производимые с полем. Они отображаются на образце текста.

Кнопки Reset Item и Reset All позволяют отменить изменения для одного объекта и для всех объектов соответственно.


Оформление страницы

На вкладке Advanced установите флажок CheckBox Use Border, если хотите использовать границы в таблице.

Format-specific options - MS Word 2007 and ODT - Border

Кнопка Border Color [image] позволяет выбрать цвет границ.

В поле Border Width введите желаемую ширину границы.


Шаг 7 - Задание форматов данных

На этом шаге Вы задаете, в каком формате будут отображаться данные.

Вы можете применить формат данных сразу для всех таблиц и запросов, установив флажок CheckBox Apply to all exported objects.

Data type formats

Форматы отображения Вы можете задать для следующих форматов данных:

  • Integer - Целое число,
  • Date - Дата,
  • DateTime - Дата и время,
  • Boolean True - Истина,
  • Null string - Строка NULL.
  • Float - Число с плавающей точкой,
  • Time - Время,
  • Currency - Денежный,
  • Boolean False - Ложь.

В разделе указываются символы, которые будут являться разделителями десятичных разрядов.

  • Decimal Separator - символ в десятичной дроби, отделяющий целое от дроби,
  • Date Separators - разделитель даты,
  • Thousand Separators - разделитель тысяч,
  • Time Separators - разделитель времени.

User-defined column formats

Для каждой экспортируемой колонки Вы можете задать формат отображения данных.

Column Name

Выберите колонки таблицы из раскрывающегося списка

Column Format

Выберите один из допустимых форматов для использования. Если нужного формата в списке нет, то Вы можете указать его вручную.

Add

Добавление необходимого формата в список.

Редактировать формат отображения данных отдельного поля Вы можете двумя способами:

  • повторно выберите колонку из раскрывающегося списка Column Name, задайте для него другие параметры и нажмите кнопку Add,
  • в списке измененных форматов выберите нужную колонку и нажмите кнопку Edit.

Delete

Удалить одну колонку из списка.

Clear

Полностью очистить список измененных форматов.

Если Вы хотите пропускать этот шаг при следующем выполнении экспорта данных, то установите флажок CheckBox Don't show this step anymore. Если Вы установили этот флажок, то сделать шаг видимым сможете только на вкладке Выбора шагов мастера.

Следующий шаг


Шаг 8 - Задание общих опций

На предпоследнем шаге у Вас есть возможность задать общие свойства экспорта данных.

Если установлен флажок CheckBox Apply to all exported objects, то внесенные изменения будут применены ко всем экспортируемым объектам одновременно.

File properties

Destination file

Задайте имя экспортируемого файла и путь к нему. При нажатии на кнопку Browse... открывается диалоговое окно, позволяющее выбрать один из существующих файлов указанного ранее формата.

CheckBox Open file after export

Если флажок установлен, то файл, в который были экспортированы данные, будет открыт после завершения экспорта.

CheckBox Print file after export

Выходной файл с экспортированными в него данными будет напечатан.

CheckBox Use file name template

Если к имени файла необходимо добавить текущие дату и время, Вы можете указать желаемый формат, соответствующий Форматам данных.

Constraints

Skip n records

Пропустить n записей. Если в счетчике стоит 0, то экспортированы будут все записи. Если же больше нуля, то первые n записей будут пропущены.

CheckBox Export empty data

Экспорт пустых записей.

CheckBox Encode binary data to Base64 -

Экспортируемые бинарные данные кодируются в формат Base64.

RadioButton Export all records

Экспортировать все записи

RadioButton Export only n records

Этот счетчик позволяет экспортировать только указанное количество записей.

Save Export Options... / Load Export Options...

Данные кнопки используются для сохранения и загрузки параметров экспорта в файл *.exp.

Upload options

Выберите протокол в поле Upload mode, чтобы загрузить экспортированные файлы на FTP сервер.

Укажите параметры подключения:

Host - имя машины (IP-адрес), которая является FTP сервером.

Port - порт FTP сервера.

Path - директория на FTP сервере, в которую необходимо загрузить экспортированные файлы.

User - имя пользователя на сервере.

Password - пароль пользователя.

Check connection

Проверяет возможность установления подключения с заданными параметрами.

Если Вы хотите пропускать этот шаг при следующем выполнении экспорта данных, то установите флажок CheckBox Don't show this step anymore. Если Вы установили этот флажок, то сделать шаг видимым сможете только на вкладке Выбора шагов мастера.

Следующий шаг


Шаг 9 - Задание дополнительных скриптов

Этот шаг позволяет задать вам скрипты, который будет выполнен для исходной и/или назначенной таблицы перед процессом экспорта и после него.

Если установлен флажок CheckBox Apply to all exported objects, то внесенные изменения будут применены ко всем экспортируемым объектам одновременно.

В верхней и нижней частях формы Before export script и After export script задайте скрипты, которые будут выполняться до и после экспорта соответственно.

Step 9 - Defining scripts

Save script - сохранить введенный скрипт во внешний *.sql файл.

Load script - загрузить сохраненный скрипт из файла.

Clear - очистить окно ввода.

Если Вы хотите пропускать этот шаг при следующем выполнении экспорта данных, то установите флажок CheckBox Don't show this step anymore. Если Вы установили этот флажок, то сделать шаг видимым сможете только на вкладке Выбора шагов мастера.

Следующий шаг


Шаг 10 - Начало экспорта данных

Этот шаг информирует Вас о том, что все параметры экспорта заданы, и Вы можете начать экспорт данных.

Нажмите на кнопку Export, чтобы начать экспорт данных.

При выполнении операции в окне Export Log отображается информация о ходе выполнения экспорта данных.

С помощью кнопки btnSave Save Вы можете сохранить протокол экспорта в *.log файл.

При нажатии на кнопку btnCopy Copy вся информация будет скопирована в буфер обмена.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации,
  • открыть файл конфигурации.


Использование файлов конфигурации (шаблонов)

В Data Export for DB2 предусмотрена возможность сохранения последовательности действий и параметров в специальных файлах, которые называются файлы конфигурации.

В мастере в левом нижнем углу расположена кнопка Tools. При нажатии на эту кнопку открывается список действий.

Using configuration files - Saving template

С помощью этого списка можно:

  • Save Template - сохранить шаблон,
  • Load Template - загрузить шаблон,
  • Reopen Configuration - открыть один из недавно открывавшихся файлов конфигурации экспорта.

Все параметры, указанные с помощью мастера, можно сохранить в файл формата *.cfg.

Using configuration files - Save Template options

File name

Укажите имя файла шаблона и путь к нему.

Comment

Введите комментарий для файла шаблона.

Сохранять шаблон можно на любом шаге мастера, но чтобы сохранились все настройки делать надо это на последнем шаге. Загружать шаблон можно только на вступительном и первом шаге.


Настройка программы

Data Export for DB2 позволяет полностью настроить интерфейс программы.

Чтобы открыть окно Preferences необходимо на любом шаге мастера нажать кнопку Tools и из появившегося списка выбрать пункт Preferences.

Preferences - General

Основные элементы управления располагаются на следующих вкладках:

Задание основных параметров

Выбор шагов мастера

Задание форматов данных по умолчанию

Создание шаблона запроса

Выбор языка программы

Нажав на кнопку Reset, Вы можете сбросить принятые настройки и вернуть их к настройкам, принятым по умолчанию.


Задание основных параметров

Основные опции программы Data Export for DB2 задайте на вкладке General.

General

Theme

Выберите цветовую схему интерфейса программы: Light (Светлая) или Dark (Темная). Для применения схемы требуется перезагрузка программы.

CheckBox Confirmation on exit

Включите опцию, чтобы запрашивать подтверждение при выходе из программы.

CheckBox Save password

Установив этот флажок, Вы можете сохранить пароли доступа к базам данных.

CheckBox Format SQL values-

Если установлен этот флажок, то значения SQL (такие как integer, float, currency, datetime и т.д.) будут иметь формат по умолчанию. Задать форматы данных по умолчанию можно на вкладке Default formats.

CheckBox Show views

Представления будут отображаться в списке таблиц на шаге 2.

CheckBox Show system tables

Если установлен этот флажок, то в список доступных таблиц на шаге 2 будут включены системные таблицы.

Preferences - General


Выбор шагов мастера

Skipped steps

CheckBox Skip steps

При включенной опции будут пропускаться шаги мастера, выбранные на вкладке.

Шаги, которые будут пропущены, отметьте флажками в разделе Skipped Steps:

  • Queries - Шаг 3 - Создание запросов
  • Exported columns - Шаг 5 - Выбор полей для экспорта
  • Formats - Шаг 6 - Задание форматов данных
  • Export Options - Шаг 8 - Задание общих опций
  • Scripts - Шаг 9 - Задание дополнительных скриптов

Preferences - Skipped steps

Важно: на каждом шаге из перечисленных выше присутствует опция CheckBox Don't show this step anymore, позволяющая отметить, что шаг следует пропускать в дальнейшем. Отменить действие данной опции возможно только с помощью текущего диалога.


Задание форматов данных по умолчанию

На этой вкладке задайте форматы данных, которые будут использоваться по умолчанию.

Preferences - Default formats

Изменять форматы данных при экспорте можно будет на шестом шаге Задание форматов данных.

  • Integer - Целое число,
  • Float - Число с плавающей точкой,
  • Currency - Денежный,
  • Date - Дата,
  • Time - Время,
  • DateTime - Дата и время,
  • Boolean True - Истина,
  • Boolean False - Ложь.
  • Null string - Строка NULL.


Создание шаблона запроса

На этой вкладке Вы можете создать шаблон запроса, который будет отображаться на четвертом шаге при создании нового запроса.

Preferences - Default query

Текст запроса введите в редактор SQL.


Выбор языка программы

На вкладке Languages выберите язык интерфейса программы Data Export for DB2.

Preferences - Languages

В списке Languages отображаются доступные языки. Из этого списка можно выбрать нужную локализацию.

В столбце Language показан язык локализации, в столбце File Name - название и путь к файлу локализации.

В список локализаций попадают все файлы формата *.lng, содержащиеся в папке, указанной в поле Language Directory. Чтобы сделать указанную в поле папку, директорией в которой содержатся локализации, нужно нажать кнопку btnEllipsis .


Консольное приложение

Консольное приложение Data Export for DB2 предназначено для быстрого и удобного экспорта данных из внешних файлов в таблицы базы данных DB2, а также для использования в любых планировщиках задач.

Работа с консольным приложением

Формат файла конфигурации

Как настроить экспорт по расписанию

Смотрите также:

Мастер экспорта данных


Работа с консольным приложением

Все параметры экспорта, заданные в Data Export for DB2 можно сохранить в файл конфигурации экспорта (*.cfg). Консольное приложение использует имя этого файла как параметр при выполнении экспорта.

Чтобы создать файл конфигурации (шаблон) следуйте инструкции:

  • запустите Data Export for DB2,
  • задайте необходимые параметры на каждом шаге мастера экспорта данных,
  • проверьте процесс экспорта на последнем шаге,
  • сохраните опции в файле конфигурации экспорта

Запустить файл конфигурации можно двумя способами:

  • дважды щелкнуть на созданном файле конфигурации (*.cfg) мышью.
  • задать в консольном приложении команду запуска - <путь к консольному приложению Data Export for DB2>\DB2ExportC.exe TemplateFile [-B]

TemplateFile

Имя файла конфигурации *.cfg и путь к нему.

[-B]

Используйте этот параметр, если хотите запустить процесс в фоновом режиме.

Пример:

Файл конфигурации называется Example.cfg.

"C:\Program Files\EMS\Data Export for DB2\DB2ExportC.exe" "C:\Program Files\EMS\Data Export for DB2\Example.cfg"

Важно: Следующие значения кода завершения возвращаются программой Data Export for DB2 операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка (или несколько);

2 - критическая ошибка. Задача не выполнена.

Смотрите также:

Как настроить экспорт по расписанию

Формат файла конфигурации


Как настроить экспорт по расписанию

Как настроить программу для запуска по расписанию с помощью стандартного планировщика задач Windows:

1. Задайте настройки экспорта в проекте и сохраните шаблон Tools --> Save template.

2. Запустите командную строку Windows (наберите CMD в диалоге Выполнить... в Windows).

3. Для запуска консольной версии программы используйте команду:

<путь к консольному приложению Data Export for DB2>\DB2ExportC.exe TemplateFile [-B]

Например:

"C:\Program Files\EMS\Data Export for DB2\DB2ExportC.exe" "C:\Program Files\EMS\Data Export for DB2\Example.cfg"

4. Запустите Планировщик задач в Windows.

5. Укажите команду для экспорта данных (см. Пункт 3).

6. Настройте расписание для запуска команды.

7. Сохраните задачу.

Смотрите также:

Работа с консольным приложением

Формат файла конфигурации


Задание форматов данных

Форматы данных определяют вид данных разных типов.

Форматы Float/Integer

0 | Цифра от 0 до 9
# | Символ разряда. Если на месте знака '#' в исходном значении стоит цифра, эта цифра будет скопирована в результирующую строку. В противном случае на месте этого знака не будет ничего.
. | символ, отделяющий десятичную часть
, | разделитель групп разрядов
E+ | экспоненциальное представление.

Форматы Date/Time format

С помощью следующих команд Вы указываете, какую часть даты и в каком виде нужно отображать.

c | Отображает дату, используя краткий формат даты.
d | День отображается в виде числа от 1 до 31 без нулевого старшего разряда.
dd | День отображается в виде числа от 01 до 31 с нулевым старшим разрядом.
ddd | День отображается в виде аббревиатуры (Sun-Sat).
dddd | Отображается полное название дня недели (Sunday-Saturday).
ddddd | Отображать краткий формат.
dddddd | Использовать полный формат даты.
M | Отображать месяц в виде числа без нулевого старшего разряда (1-12).
MM | Отображать месяц в виде числа с нулевым старшим разрядом (01-12)
MMM | Отображать месяц в виде аббревиатуры (Jan-Dec).
MMMM | Отображать полное название месяца (January-December).
yy | Отображать год в виде последних двух цифр (00-99).
yyyy | Отображать год в четырех цифр (0000-9999).
h | Отображать час в виде числа без нулевого старшего разряда (0-23).
hh | Отображать час в виде числа с нулевым старшим разрядом (00-23).
m | Отображать минуты в виде числа без нулевого старшего разряда (0-59).
mm | Отображать минуты в виде числа с нулевым старшим разрядом (00-59).
s | Отображать секунды в виде числа без нулевого старшего разряда (0-59).
ss | Отображать секунды в виде числа с нулевым старшим разрядом (00-59).
z | Отображать миллисекунды в виде числа без нулевого старшего разряда (0-999).
zzz | Отображать миллисекунды в виде числа с нулевым старшим разрядом (000-999).
t | Отображать время, используя Short Time Format.
tt | Отображать время, используя Long Time Format.
a/p | Использовать двенадцатичасовой формат даты с префиксом a/p.
am/pm | Использовать двенадцатичасовой формат даты с префиксом am/pm.
/ | Использовать этот разделитель даты (mm/dd/yy).
: | Использовать этот разделитель времени (hh:mm).
'xx'/"xx" | Символы, заключенные в одинарные или двойные кавычки не подлежат форматированию.


Поддерживаемые форматы файлов

MS Excel 97-2003

Наиболее популярный формат файлов для хранения электронных таблиц, разработанный Microsoft.

(*.xls)

MS Access 97-2003

Файл этого формата представляет собой базу данных Access, с возможностью использования ADO connection.

(*.mdb)

MS Word 97-2003

Наиболее популярный формат текстовых документов, разработанный Microsoft.

(*.doc)

RTF

Межплатформенный формат хранения размеченных текстовых документов, предложенный Microsoft. RTF-документы поддерживаются большинством современных текстовых редакторов.

(*.rtf)

HTML

(от англ. Hypertext Markup Language — «язык разметки гипертекста»)

Формат для отображения web страниц

(*.html, *.htm)

PDF

Межплатформенный формат электронных документов, предназначен для представления в электронном виде полиграфической продукции.

(*.pdf)

Text file

Текстовый файл

(*.txt)

CSV

(от англ. Comma Separated Values — значения, разделенные запятыми)

Текстовый формат, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом (delimiter), например, запятой (,), точкой с запятой(;), символом табуляции. Текстовые значения обрамляются символом двойные кавычки ("); если в значении встречаются кавычки — они представляются в файле в виде двух кавычек подряд.

(*.csv)

DIF

Стандарт для файлов обмена данными

(*.dif)

SYLK

Формат Символической Связи.

(*.slk)

LaTeX

Специфический формат файлов макрорасширений к TeX.

(*.tex)

XML

Расширяемый язык разметки. Предназначен для хранения структурированных данных

(*.xml).

DBF

Формат хранения данных, используемый в качестве одного из стандартных способов хранения и передачи информации системами управления базами данных, электронными таблицами и т.д.

(*.dbf)

MS Excel

Разработанный Microsoft формат файлов для хранения электронных таблиц. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.xlsx)

MS Word

Разработанный Microsoft формат файлов для хранения электронных документов. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.docx)

MS Access

Разработанный Microsoft формат файлов для хранения баз данных. Формат представляет собой zip-архив, содержащий текст в виде XML, необходимую графику и другие данные

(*.accdb)

ODF Spreadsheets

Открытый формат файлов документов для хранения и обмена редактируемыми офисными документами - электронными таблицами.

(*.ods)

ODF text

Открытый формат файлов документов для хранения и обмена редактируемыми текстовыми офисными документами

(*.odt)


Формат файла конфигурации

Файл конфигурации состоит из нескольких разделов

[#General#]

В этом разделе отображается название продукта и его версия.

[Connection]

В этом разделе содержится информация о подключении к серверу: Логин, Пароль (encrypted). Эти параметры являются обязательными.

Замечание: Параметр DBName, используемый в предыдущих версиях, больше не является обязательным. Вы можете задать базу данных для каждой таблицы и запроса в разделе [Databases].

[Tables]

В этом разделе представлен список экспортируемых таблиц. Список имеет следующий вид:

<table key>=<table name>

e.g.

table1=Country

table2=Employee

Этот раздел может быть пустым.

[Queries]

В этом разделе представлен список экспортируемых запросов и их идентификаторов. Список имеет следующий вид:

<query key>=<query identifier>

e.g.

query1=CountryQ

[SQL_<query key>]

Этот раздел содержит текст всех запросов. Строки должны быть представлены в следующем виде:

Item_0=<query line 1>

Item_1=<query line2>

etc.

Пример:

[Queries]

query0=Query_0

[SQL_query0]

Item_0=select name, capital

Item_1=from countries

Item_2=where continent = 'South America'

Замечание: Этот раздел может быть пустым, но если не будут заданы таблицы или запросы, то экспорт данных не будет произведен.

[Files]

В этом разделе содержится список файлов, в которые будет производиться экспорт данных. Для каждого файла указан формат.

<table key>=<filename>

<query key>=<filename>

etc.

Также, файлы могут быть представлены в списке следующим образом:

table1=table1.xls

или

query1=C:\Exported data\query1.docx

Замечание: Вы должны указать форматы выходных файлов. Если этого не сделать все данные будут экспортированы в файлы формата .xls.

[Databases]

в этом разделе Вы можете указать базу данных для каждой таблицы и запроса.

<table key>=<database name>

<query key>=<database name>

Если Вы не указали название базы данных в этом разделе, то в качестве базы данных для экспорта будет использоваться та база, название которой было задано в поле DBName, в разделе [Connection].

[Templates]

В этом разделе указывается файл шаблона для каждой экспортируемой таблицы или запроса. Файл шаблона (*.exp) создается приложением и содержит параметры экспорта: тип экспорта, выходной файл, поля для экспорта число экспортируемых записей, параметры экспорта для различных типов файлов и т.д.

Этот раздел имеет такой вид:

<table key>=<template filename>

<query key>=<template filename>

etc.

Для выходного файла Вы можете задать полный путь к нему.

table1=template1_xls.exp

или

query_clients=D:\Templates\template2_rtf.exp

Если вы не задали ни одного выходного файла в разделе [Files], то эти названия будут взяты из шаблона. Если вы не задали ни выходного файла, ни шаблона для таблиц и запросов, то имя и формат выходного файла будут по умолчанию представлять собой для таблиц - <table name>.xls, для запросов - <query key>.xls.

Вы можете добавлять ключи для таблиц и запросов в любой раздел. Ключ имеет вид <table key>=<template filename>. В ключе не должно быть пробелов и он должен быть абсолютно одинаков в каждом разделе, в котором его прописали.


Использование параметров запросов

Мастер экспорта данных и Консольное приложение Data Export for DB2 поддерживают наличие параметров в запросах.

Пример: Вы можете экспортировать данные из таблицы table1 и на третьем шаге Мастера экспорта данных Вы задаете запрос Query_0:

SELECT * FROM table1 WHERE field1 > :param0

Затем, Вам необходимо сохранить шаблон, который будет использован консольным приложением. Чтобы задать параметры, укажите необходимые значения параметров в командной строке консольного приложения (если вы запускаете консольное приложение из директории, в которой установлена программа и шаблон файла также расположен в этой директории):

Db2ExportC.exe TemplateFile -Query_0:param0=5

5 - значение параметра

Если Вы экспортируете данные из сложных запросов, то вам необходимо будет в командной строке прописать следующее:

Db2ExportC.exe TemplateFile -Query_0:param0=5 -Query_1:param1=10 -Query_2:param2=15

5, 10, 15 - значения параметров.

Смотрите также:

Работа с консольным приложением


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться Data Export for DB2, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

Data Export for DB2 подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

На первом шаге из раскрывающегося списка Database home выберите имя клиента и из раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.