Добро пожаловать в EMS Data Generator!

Data Generator for DB2 – это мощная программа для генерации тестовых данных для таблиц баз данных DB2 с возможностью сохранения и редактирования сценариев. С помощью этого приложения вы сможете моделировать среду рабочей базы данных, заполнять одновременно несколько таблиц тестовыми данными, задавать таблицы для генерации данных, устанавливать диапазоны значений, создавать текстовые поля по маске, задавать списки значений вручную или выбирать их из запросов SQL, настраивать различные параметры генерации тестовых данных для каждого типа поля и многое другое. Data Generator for DB2 предоставляет все необходимые инструменты для быстрой генерации тестовых данных в базах DB2 и дополнительно включает консольную утилиту для генерации тестовых данных с помощью шаблонов генерации.

Посетите наш сайт: https://www.sqlmanager.ru

Ключевые особенности

  • Поддержка Unicode
  • Простой и понятный интерфейс мастера настройки
  • Возможность сохранения и редактирования сгенерированных данных в сценарии SQL без выполнения запросов на сервере
  • Генерация данных в несколько таблиц из разных схем
  • Поддержка всех типов данных DB2, включая пользовательские типы
  • Для каждого поля доступны различные режимы генерации данных: из списка значений, случайные значения, из последовательности и другие
  • Возможность использовать результаты запроса SQL при генерации данных
  • Возможность использования значений другого поля для генерации данных
  • Доступен предварительный просмотр каждой таблицы
  • Автоматический контроль целостности ссылок для связанных таблиц
  • Большой набор параметров генерации для поля каждого типа
  • Добавление NULL значений в указанном проценте записей
  • Возможность очистки таблиц перед генерацией данных
  • Сохранение настройки параметров генерации
  • Консольное версия программы для генерации данных с использованием файла конфигурации.

Информация по продукту

Домашняя страница: | https://www.sqlmanager.ru/products/db2/datagenerator
Служба поддержки: | https://www.sqlmanager.ru/support
Регистрация: | https://www.sqlmanager.ru/products/db2/datagenerator/buy


Новости

Версия | Дата выпуска
Data Generator for DB2 4.0 | 21.11.2023

Что нового в Data Generator версии 4.0?

  • Добавлена поддержка темной темы.
    whats new dark scheme
  • Добавлена поддержка юникодных имен объектов.
  • Добавлен выбор кодировки для файла скрипта.
  • В комплект программы добавлены файлы с тестовыми данным.
  • Множество других исправлений и улучшений.

Смотрите также:

История версий


Системные требования

Системные требования Data Generator for DB2

  • Microsoft Windows XP, Microsoft Windows Server 2003, Microsoft Windows Server 2008, Microsoft Windows Server 2008 R2, Microsoft Windows Server 2012, Microsoft Windows Server 2012 R2, Microsoft Windows Server 2016, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8/8.1, Microsoft Windows 10, Microsoft Windows 11
  • 50 MB свободного пространства на жестком диске для установки программы
  • DB2 Run-Time/Administrative Client, версия 8.0 или выше
  • IBM DB2 Connect (в случае использования серверов на платформах: z/Series, iSeries, pSeries)


Установка

Установка программы

  • загрузите установочный файл программы со страницы загрузки,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • откройте файл DB2DataGenSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS

Обновление программы

  • загрузите установочный файл программы со страницы загрузки сайта,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • закройте программу Data Generator for DB2, если она запущена,
  • запустите файл DB2DataGenSetup.exe и следуйте инструкциям мастера обновления.

Смотрите также:

Системные требования


Приобретение

Для приобретения наших продуктов на территории Российской Федерации вы можете использовать форму он-лайн оплаты платежной картой либо запросить счёт для безналичной оплаты путем банковского перевода.

Выбор типа лицензии, количества лет Сопровождения и способа оплаты происходит на странице покупки продукта.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery).

После приобретения мы отправим вам регистрационный ключ электронной почтой. Регистрационная информация будет так же доступна зарегистрированным пользователям на нашем сайте.

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО.

Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

Подробнее об услуге сопровождения читайте на странице https://www.sqlmanager.ru/support/faq#maintenance.

Если у вас остались вопросы - вы можете найти ответы на них в разделе FAQ или обратиться в службу поддержки по адресу sales@sqlmanager.ru.


Регистрация

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно - проверить наличие регистрационного имени и пароль на стартовой странице. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Welcome to EMS Data Generator - Register product

Смотрите также:

Приобретение


История версий

Наименование продукта | Версия | Дата выпуска
Data Generator for DB2 | Версия 3.0.1.3 | 17.12.2012
Data Generator 2005 for DB2 | Версия 2.3.0.1 | 07.02.2007

Полная история версий продукта доступна по адресу: https://www.sqlmanager.ru/products/db2/datagenerator/news

Версия 3.0.1.3

  • Улучшен интерфейс мастера генерации данных
  • Добавлена опция 'Commit every'
  • Добавлена возможность загрузки списка значения из файлов TXT и CSV
  • Консольная версия программы теперь создает лог
  • Системные таблицы теперь не отображаются
  • Увеличена скорость генерации данных в поля string
  • Добавлена опция 'Clear tables before generation'
  • Добавлена опция хранения зашифрованных паролей
  • Увеличена скорость генерации данных
  • Улучшена генерация данных в таблицы с внешними ключами
  • Другие исправления и улучшения

К началу

Версия 2.3

  • Улучшен интерфейс мастера генерации данных
  • Добавлена опция 'Commit every'
  • Добавлена возможность загрузки списка значения из файлов TXT и CSV
  • Консольная версия программы теперь создает лог
  • Системные таблицы теперь не отображаются
  • Увеличена скорость генерации данных в поля string
  • Добавлена опция 'Clear tables before generation'
  • Добавлена опция хранения зашифрованных паролей
  • Увеличена скорость генерации данных
  • Улучшена генерация данных в таблицы с внешними ключами
  • Другие исправления и улучшения

К началу

Смотрите также:

Новости


Часто задаваемые вопросы

Пожалуйста, прочтите внимательно эту страницу, если у вас есть вопросы о EMS Data Generator for DB2.

Содержание

  • Что такое EMS Data Generator for DB2?
  • Что необходимо для начала работы с EMS Data Generator for DB2?
  • Как проще всего сконфигурировать файлы-шаблоны для консольного приложения Data Generator?
  • Как зарегистрировать Data Generator for DB2?
  • Есть ли какие-нибудь ограничения в пробной версии, по сравнению с полной версией?

В: Что такое Data Generator for DB2?

О: Data Generator for DB2 - это мощная программа для генерации тестовых данных для таблиц баз данных DB2 с возможностью сохранения и редактирования сценариев. С помощью этого приложения вы сможете заполнять одновременно несколько таблиц тестовыми данными, задавать таблицы для генерации данных, устанавливать диапазоны значений, создавать текстовые поля по маске и многое другое. Data Generator for DB2 предоставляет все необходимые инструменты для быстрой генерации тестовых данных в базах DB2 и дополнительно включает консольную утилиту для генерации тестовых данных с помощью шаблонов генерации.

В: Что необходимо для начала работы с Data Generator for DB2?

О: Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному DB2 серверу для работы с Data Generator. Вы можете загрузить DB2 сервер баз данных по ссылке https://www.ibm.com/products/db2. Кроме того, необходимо, чтобы Ваш компьютер удовлетворял Системным требованиям Data Generator for DB2.

В: Как проще всего сконфигурировать файлы-шаблоны для консольного приложения Data Generator?

О: Вы можете сформировать шаблон в графической версии программы. Выполните необходимые настройки на шаге 4 мастера генерации данных, нажмите кнопку Tools и выберите пункт меню Save Template. Все настроенные параметры сохранятся в файле конфигурации, который затем может быть использован при работе с консольным приложением.

В: Как зарегистрировать Data Generator for DB2?

О: Если Вы уже приобрели Data Generator for DB2, то для регистрации программы достаточно ввести регистрационную информацию. Более подробную информацию можно получить в разделах Приобретение и Регистрация.

В: Есть ли какие-нибудь ограничения в пробной версии, по сравнению с полной версией?

О: В пробной версии программы установлено ограничение (100) на максимальное количество единовременно генерируемых значений. В остальном функционале версии программы не отличаются. Таким образом Вы можете полностью протестировать возможности Data Generator for DB2 в течение 30-ти дневного периода.

Наверх

При возникновении новых вопросов, обратитесь в Службу поддержки.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for PostgreSQL EMS SQL Backup for PostgreSQL — это простой в использовании визуальный инструмент для создания резервных копий для нескольких серверов PostgreSQL из единой консоли. Вы можете создавать автоматизированные задачи резервного копирования на основе расписаний и хранить их в локальных или удаленных папках или облачных хранилищах.
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Мастер генерации данных

Data Generator for DB2 позволяет настроить параметры генерации данных с помощью мастера.

  • Работа с мастером генерации данных
  • Файлы конфигурации
  • Настройка программы

Wizard Application - Using wizard application

Смотрите также:

Консольное приложение


Работа с мастером генерации данных

Ознакомьтесь с инструкциями по каждому шагу мастера генерации тестовых данных.

Начало работы

Шаг 1 - Настройки подключения

Шаг 2 - Выбор схем и таблиц

Шаг 3 - Параметры генерации

Шаг 4 - Опции генерации

Шаг 5 - Запуск процесса генерации

Шаг 6 - Редактирование скрипта генерации

Смотрите также:

Консольное приложение


Начало работы

Так выглядит Data Generator for DB2 при первом запуске.

В данном окне доступна регистрационная информация. Если Ваша копия Data Generator for DB2 еще не зарегистрирована, нажмите кнопку Enter Registration Code... и введите регистрационную информацию.

Wizard Application - Getting started

Нажмите кнопку Next для перехода на Шаг 1.

Смотрите также:

Регистрация


Шаг 1 - Настройки подключения

На данном шаге Вам следует настроить подключение к серверу DB2.

Step 1 - Setting connection properties

Настройки подключения

Задайте свойства подключения:

  • укажите параметры авторизации: имя пользователя и пароль для доступа к целевой базе данных DB2;
  • введите имя базы данных, или выберите ее при помощи раскрывающегося меню Database alias.

Помните, что Вам необходимо иметь привилегии достаточные для записи в целевую базу данных сервера DB2.

По завершении настройки подключения нажмите кнопку Next для перехода на следующий шаг.


Шаг 2 - Выбор схем и таблиц

На этом шаге Вам необходимо выбрать таблицу для генерации тестовых данных.

Сначала задайте схему при помощи раскрывающегося списка Select Schema в верхней части окна.

В списке Available Tables доступны все таблицы указанной базы данных. Чтобы выбрать таблицу, Вам нужно переместить ее из списка Available Tables в список Selected Tables. В этом списке имена таблиц отображены в полном формате: <имя_схемы>.<имя_таблицы>. Отменить выбор таблицы Вы можете исключив ее из списка Selected Tables. Для перемещения таблиц между списками используйте кнопки Move all to Selected Move to Selected Move to Available Move all to Available или метод drag-and-drop.

Важно: Чтобы выбрать несколько таблиц, в процессе их выделения удерживайте кнопки Shift или Ctrl.

Step 2 - Selecting schemas and tables

Помните что порядок генерации данных в таблицы зависит от их порядка в списке Selected Tables. Это может быть крайне важным при генерации данных в связанные таблицы. Вы можете изменить порядок таблиц методом drag-and-drop.

После нажатия на кнопку Next, Data Generator for DB2 анализирует порядок генерации данных, с целью предотвратить нарушение целостности ссылочных данных, и советует изменить порядок их генерации.

Завершив работу на данном шаге, нажмите кнопку Next для перехода на следующий шаг.


Шаг 3 - Параметры генерации

На данном шаге Вы можете выбрать поля для генерации данных, а также задать различные параметры.

Выбранные таблицы отображены в дереве Generate Data for, расположенном в левой части окна. Поля таблиц и их типы указаны ниже, в таблице Column list.

Records count

Количество записей, которые следует сгенерировать для соответствующей таблицы.

CheckBox Clear

Установите флажок, если необходимо очистить таблицу перед генерацией данных.

Preview

Нажмите кнопку Preview для предварительного просмотра данных таблицы.

Step 3 - Specifying generation parameters

Выбрав в дереве Generate Data for таблицу, вы можете указать параметры генерации данных для каждого поля. Для этого воспользуйтесь разделом Generation Properties, расположенным в правой части окна. В управлении параметрами полей Вам помогут кнопки btnSelectAll - выбрать все, btnUnselectAll - исключить все, btnInvertSelection - инвертировать выбор.

CheckBox Set NULL value in ... % of cases

Включите опцию для определения количества значений NULL для соответствующего поля (в процентах).

Data generation mode

RadioButton Generate random data

Данный тип генерации данных позволяет заполнить таблицу случайными значениями.

RadioButton Generate incremental data

Если выбран этот тип, то будет сгенерирована последовательность данных с заданным начальным значением и инкрементом.

RadioButton Get data from list / SQL-query

С помощью данного типа Вы можете заполнить таблицу данными, полученными из списка или в результате выполнения запроса.

RadioButton Get data from column

Позволяет генерировать данные из указанного поля.

Параметры генерации данных различаются для разных типов данных. Подробнее смотрите в приведенных ниже разделах:

  • параметры для поля типа FLOAT
  • параметры для поля типа INTEGER
  • параметры для поля типа DATE
  • параметры для поля типа TIME
  • параметры для поля типа STRING
  • параметры для поля типа BLOB

Если поле - часть внешнего ключа, Вы можете выбрать одну из следующих опций:

RadioButton Generate data from the dependent column

Значения для такого поля будут получены из соответствующих полей внешних таблиц.

RadioButton Generate data from list / SQL-query

RadioButton Ratio 1:N

Для данного метода генерации необходимо задать параметр N. При генерации одного значения в основную таблицу, N значений будут сгенерированы во внешнюю таблицу.

Step 3 - Generation properties - Ratio

Выполнив настройку на данном шаге, нажмите кнопку Next для перехода на следующий шаг.


Параметры для поля типа INTEGER

В полях типа integer содержатся целочисленные данные. Значения для такого поля могут быть сгенерированы случайным образом, последовательно, а также могут быть получены из конкретного списка значений, или с помощью SQL запроса. В качестве источника данных можно использовать также значение существующего поля соответствующего типа.

Раздел Generation properties позволяет определить параметры генерации значений для поля типа integer.

Integer field parameters

Выберите тип генерации данных:

RadioButton Generate random data

Определите минимальное (Min value) и максимальное значение (Max value) с помощью соответствующих полей.

Integer field parameters - Mode - Random data

CheckBox Use formula

Данная опция позволяет корректировать данные посредством формулы; 'x' - в данном примере значение сгенерированное случайным образом. Можно использовать операторы сложения, вычитания, умножения, деления и возведения в степень (+,-,*,/,^).

RadioButton Generate incremental data

Укажите начальное значение (Initial value) и инкремент (Increment) для генерации возрастающей упорядоченной последовательности значений.

Integer field parameters - Mode - Incremental data

RadioButton Get Data from list / SQL query

Этот тип дает Вам возможность определить список значений для последующей генерации из него числовых данных. Вы также можете ввести значения вручную с помощью опции List of Values.

Чтобы добавить отдельное значение, используйте кнопку btnListAddValue Add Value.

Загрузить список значений из внешнего файла можно с помощью кнопки btnListLoadFromFile Load from file.

Для сохранения списка значений во внешнем файле воспользуйтесь кнопкой btnListSaveToFile Save to file.

Чтобы удалить выбранное значение, нажмите кнопку btnListDeleteValue Delete Value.

Очистить список можно с помощью кнопки btnListClear Clear.

CheckBox Random order

Включите опцию, если хотите, чтобы в процессе генерации значения из списка отбирались в случайном порядке. Если опция выключена, будет сохранен оригинальный порядок.

Чтобы для генерации данных использовать набор данных, полученный в результате SQL запроса, выберите опцию SQL Query.

Integer field parameters - Mode - List or query

RadioButton Get data from column

Данный тип генерации данных позволяет Вам указать поле, значения которого будут использованы для генерации данных. Используйте раскрывающиеся списки Table и Field для выбора подходящего поля.

Integer field parameters - Mode - Field


Параметры для поля типа FLOAT

В полях типа float содержатся данные в виде дробных чисел. Значения для поля данного типа могут быть сгенерированы случайным образом, последовательно, а также могут быть получены из конкретного списка значений, или с помощью SQL запроса. В качестве источника данных можно использовать также значение существующего поля соответствующего типа.

Раздел Generation properties позволяет определить параметры генерации значений для поля типа float.

Float field parameters

Выберите тип генерации данных:

RadioButton Generate random data

В данном разделе Вы можете указать количество цифр в числе (Precision) и в дробной части (Scale).

Float field parameters - Mode - Random data

RadioButton Generate incremental data

Укажите начальное значение (Initial Value) и инкремент (Increment) для генерации возрастающей упорядоченной последовательности значений.

Float field parameters - Mode - Incremental data

RadioButton Get data from List / SQL query

Данная секция позволяет вам определить список значений для последующей генерации из него числовых данных с плавающей запятой. Вы также можете ввести значения вручную с помощью опции List of Values.

Чтобы добавить отдельное значение, используйте кнопку btnListAddValue Add Value.

Загрузить список значений из внешнего файла можно с помощью кнопки btnListLoadFromFile Load from file.

Для сохранения списка значений во внешнем файле воспользуйтесь кнопкой btnListSaveToFile Save to file.

Чтобы удалить выбранное значение, нажмите кнопку btnListDeleteValue Delete Value.

Очистить список можно с помощью кнопки btnListClear Clear.

CheckBox Random order

Включите опцию, если хотите, чтобы в процессе генерации значения из списка отбирались в случайном порядке. Если опция выключена, будет сохранен оригинальный порядок.

Чтобы для генерации данных использовать набор данных, полученный в результате SQL запроса, выберите опцию SQL Query.

Float field parameters - Mode - List or query

RadioButton Get data from column

Данный тип генерации данных позволяет Вам указать поле, значения которого будут использованы для генерации данных. Используйте раскрывающиеся списки Table и Field для выбора подходящего поля.

Float field parameters - Mode - Field


Параметры для поля типа DATE

В полях типа date содержатся данные в виде даты/времени. Значения для поля данного типа могут быть сгенерированы случайным образом, последовательно, а также могут быть получены из конкретного списка значений, или с помощью SQL запроса. В качестве источника данных можно использовать также значение существующего поля соответствующего типа.

Раздел Generation properties позволяет определить параметры генерации значений для поля типа date.

Date field parameters

Выберите тип генерации данных:

RadioButton Generate random data

Определите диапазон, указав минимальное (Min date) и максимальное (Max date) значение.

Date field parameters - Mode - Random data

RadioButton Generate incremental data

Укажите начальное значение (Initial value) и инкремент (Increment) для генерации возрастающей упорядоченной последовательности значений.

Date field parameters - Mode - Incremental data

RadioButton Get data from List / SQL query

Данная секция позволяет вам определить список значений для последующей генерации из него временных данных. Вы также можете ввести значения вручную с помощью опции List of Values.

Чтобы добавить отдельное значение, используйте кнопку btnListAddValue Add Value.

Загрузить список значений из внешнего файла можно с помощью кнопки btnListLoadFromFile Load from file.

Для сохранения списка значений во внешнем файле воспользуйтесь кнопкой btnListSaveToFile Save to file.

Чтобы удалить выбранное значение, нажмите кнопку btnListDeleteValue Delete Value.

Очистить список можно с помощью кнопки btnListClear Clear.

CheckBox Random order

Включите опцию, если хотите, чтобы в процессе генерации значения из списка отбирались в случайном порядке. Если опция выключена, будет сохранен оригинальный порядок.

Чтобы для генерации данных использовать набор данных, полученный в результате SQL запроса, выберите опцию SQL Query.

Date field parameters - Mode - List or query

RadioButton Get data from column

Данный тип генерации данных позволяет Вам указать поле, значения которого будут использованы для генерации данных. Используйте раскрывающиеся списки Table и Field для выбора подходящего поля.

Date field parameters - Mode - Field


Параметры для поля типа TIME

В полях типа time содержатся данные в виде времени. Значения для поля данного типа могут быть сгенерированы случайным образом, последовательно, а также могут быть получены из конкретного списка значений, или с помощью SQL запроса. В качестве источника данных можно использовать также значение существующего поля соответствующего типа.

Раздел Generation properties позволяет определить параметры генерации значений для поля типа time.

Time field parameters

Выберите тип генерации данных:

RadioButton Generate random data

Определите диапазон, указав минимальное (Min date) и максимальное (Max date) значение.

Time field parameters - Mode - Random data

RadioButton Generate incremental data

Укажите начальное значение (Start) и инкремент (Increment) для генерации возрастающей упорядоченной последовательности значений.

Time field parameters - Mode - Incremental data

RadioButton Get data from List / SQL query

Данная секция позволяет вам определить список значений для последующей генерации из него временных данных. Вы также можете ввести значения вручную с помощью опции List of Values.

Чтобы добавить отдельное значение, используйте кнопку btnListAddValue Add Value.

Загрузить список значений из внешнего файла можно с помощью кнопки btnListLoadFromFile Load from file.

Для сохранения списка значений во внешнем файле воспользуйтесь кнопкой btnListSaveToFile Save to file.

Чтобы удалить выбранное значение, нажмите кнопку btnListDeleteValue Delete Value.

Очистить список можно с помощью кнопки btnListClear Clear.

CheckBox Random order

Включите опцию, если хотите, чтобы в процессе генерации значения из списка отбирались в случайном порядке. Если опция выключена, будет сохранен оригинальный порядок.

Чтобы для генерации данных использовать набор данных, полученный в результате SQL запроса, выберите опцию SQL Query.

Time field parameters - Mode - List or query

RadioButton Get data from column

Данный тип генерации данных позволяет Вам указать поле, значения которого будут использованы для генерации данных. Используйте раскрывающиеся списки Table и Field для выбора подходящего поля.

Time field parameters - Mode - Field


Параметры для поля типа STRING

В полях типа string содержатся текстовые данные. Сортировка и сравнение таких данных производится исходя из набора символов указанного для столбца. Значения для такого поля могут быть сгенерированы случайным образом (с использованием ограничений или шаблонов), последовательно, а также могут быть получены из конкретного списка значений, или с помощью SQL запроса. В качестве источника данных можно использовать также значение существующего поля соответствующего типа.

Раздел Generation properties позволяет определить параметры генерации значений для поля типа string.

String field parameters

Выберите тип генерации данных:

RadioButton Generate random data

Данные типа string могут быть сгенерированы случайным образом двумя способами: с использованием ограничений или шаблонов.

  • Использование ограничений (Constraints)

Задайте минимальную (Min length) и максимальную длину (Max length) генерируемых значений. Вы также можете указать диапазон символов, которые будут использованы для генерации данных: начальный (Start char) и конечный (End char) символ диапазона.

String field parameters - Mode - Random data

  • Использование шаблонов (Mask)

Выберите опцию Using mask для генерации значений с помощью шаблона. Используйте окно Masks для создания и редактирования различных шаблонов текстовых данных:

- символы 'A' и 'a' в процессе генерации данных заменяются на случайные буквы ('А'-'Z' и 'a'-'z');

- символ 'N' служит для обозначения случайной цифры;

- символы '{n}' обозначают количество последнего символа n раз;

- символ следующий за знаком '\' рассматривается, как обычный символ.

Все остальные символы в маске будут представлены без изменений.

String field parameters - Mode - Random data - Masks

RadioButton Generate incremental Data

Укажите начальное значение (Initial value) и инкремент (Increment) для генерации возрастающей упорядоченной последовательности значений. Вам также следует указать начальный символ и конечный символ диапазона, который будет использован при генерации последовательности. В поле Charset задайте кодировку.

String field parameters - Mode - Incremental data

RadioButton Get data from List / SQL query

Данная секция позволяет вам определить список значений для последующей генерации из него текстовых данных. Вы также можете ввести значения вручную с помощью опции List of Values.

Чтобы добавить отдельное значение, используйте кнопку btnListAddValue Add Value.

Загрузить список значений из внешнего файла можно с помощью кнопки btnListLoadFromFile Load from file.

Для сохранения списка значений во внешнем файле воспользуйтесь кнопкой btnListSaveToFile Save to file.

Чтобы удалить выбранное значение, нажмите кнопку btnListDeleteValue Delete Value.

Очистить список можно с помощью кнопки btnListClear Clear.

CheckBox Random order

Включите опцию, если хотите, чтобы в процессе генерации значения из списка отбирались в случайном порядке. Если опция выключена, будет сохранен оригинальный порядок.

Чтобы для генерации данных использовать набор данных, полученный в результате SQL запроса, выберите опцию SQL Query.

Использование опции Sample text позволяет генерировать данные из отрывка текста. Текст, который будет использован по умолчанию, можно задать в разделе Default constraints диалогового окна Preferences.

String field parameters - Mode - List or query

RadioButton Get data from column

Данный тип генерации данных позволяет Вам указать поле, значения которого будут использованы для генерации данных. Используйте раскрывающиеся списки Table и Field для выбора подходящего поля.

String field parameters - Mode - Field


Параметры для поля типа BLOB

Поле типа BLOB (binary large object) может хранить разнообразные данные. Значения для поля данного типа могут быть сгенерированы случайным образом, последовательно, а также могут быть получены из конкретного списка файлов, или с помощью SQL запроса. В качестве источника данных можно использовать также значение существующего поля соответствующего типа.

Раздел Generation properties позволяет определить параметры генерации значений для поля типа BLOB.

BLOB field parameters

Выберите тип генерации данных:

RadioButton Generate random data

Укажите минимальную (Min length) и максимальную (Max length) длину генерируемых значений.

BLOB field parameters - Mode - Random data

RadioButton Get data from files / SQL query

Данная секция позволяет вам определить список значений для последующей генерации данных из него. Вы также можете ввести значения вручную с помощью опции List of Values.

Чтобы добавить отдельный файл, используйте кнопку btnListAddValue Add Value.

Загрузить список путей к файлам из внешнего файла можно с помощью кнопки btnListLoadFromFile Load from file.

Для сохранения списка путей к файлам во внешний файлы воспользуйтесь кнопкой btnListSaveToFile Save to file.

Чтобы удалить выбранный файл, нажмите кнопку btnListDeleteValue Delete Value.

Очистить список можно с помощью кнопки btnListClear Clear.

CheckBox Random order

Включите опцию, если хотите, чтобы в процессе генерации значения из списка отбирались в случайном порядке. Если опция выключена, будет сохранен оригинальный порядок.

Чтобы для генерации данных использовать набор данных, полученный в результате SQL запроса, выберите опцию SQL Query.

BLOB field parameters - Mode - Files or query

RadioButton Get data from column

Данный тип генерации данных позволяет Вам указать поле, значения которого будут использованы для генерации данных. Используйте раскрывающиеся списки Table и Field для выбора подходящего поля.

BLOB field parameters - Mode - Field


Просмотр DDL таблиц

Выбрав схему в дереве Generate data for, Вы также можете выбрать принадлежащую ей таблицу. В правой части окна Вы увидите DDL выбранной таблицы.

Важно: Вы можете увидеть DDL таблицы в виде всплывающей подсказки при наведении курсора на имя таблицы в области Generate Data for.

Step 3 - Viewing table definition

Table Definition

Раскрывающийся список состоит из таблиц, которые были выбраны на Шаге 2. Выберите таблицу, чтобы увидеть ее DDL.

Чтобы скопировать DDL таблицы в буфер обмена, Вам следует щелкнуть правой клавишей мыши в разделе Table Definition, затем, в появившемся контекстном меню выбрать пункт Copy DDL to clipboard.


Предварительный просмотр данных

Окно Preview позволяет просмотреть данные выбранной таблицы.

Важно: Данные, которые отображены в данном окне, выбраны согласно заданным параметром, но, в действительности, не внесены в таблицу. То есть, в этом окне приведен пример генерации данных, согласно заданным условиям, но для вставки в таблицу будет сгенерирован другой набор данных.

Чтобы открыть предварительный просмотр, Вам нужно нажать на кнопку Preview на Шаге 3.

Отображенная в окне Preview таблица содержит все выбранные столбцы, а также данные, сгенерированные исходя из заданных на Шаге 3 параметров. При необходимости Вы можете изменить порядок столбцов, перемещая с помощью мыши их заголовки.

Щелкните мышкой по заголовку столбца для сортировки в значений в убывающем или возрастающем порядке.

Step 3 - Table Preview

Если требуется отфильтровать данные в таблице, воспользуйтесь одним из следующих способов:

  • нажмите на кнопку со стрелкой, расположенную справа от заголовка столбца. В раскрывшемся списке Вы можете выбрать любое из значений списка. После этого в таблице будут отображены только те записи, в которых значения данного столбца соответствуют выбранному;
  • нажмите на кнопку со стрелкой, расположенную справа от заголовка столбца. В раскрывшемся списке выберите пункт Custom. В появившемся диалоговом окне Custom Filter задайте необходимые условия фильтрации.

В раскрывающемся списке выберите логический оператор (like, is less than, is greater than и т.д.), который следует использовать для фильтрации. В поле напротив укажите значение, которое будет использоваться оператором.

Step 3 - Table Preview - Custom Filter

Если необходимо, Вы можете задать второе условие, и указать как оно соотносится с первым: оба условия должны быть выполнены (AND) или хотя бы одно условие должно быть выполнено (OR). Символ '_' заменяет любой одиночный символ, а символ '%' воспринимается как любая последовательность символов в строке условий.


Шаг 4 - Опции генерации

На данном шаге мастера Вы можете выполнить настройку следующих опций.

Step 4 - Setting generation options

Action

Выберите действие для следующего шага мастера:

RadioButton Execute statements

Выполнить скрипт генерации данных.

RadioButton Save data generation script to file

Сохранить скрипт генерации данных в файл, не выполняя его.

RadioButton Execute statements and save data generation script to file

Выполнить скрипт генерации данных и сохранить его в файл.

File name

Данное поле доступно, если выбрана одна из опций: Save data generation script to file или Execute statements and save data generation script to file. Укажите путь к файлу *.sql, в который Вы хотите сохранить скрипт, используя Проводник btnExplorer или вручную.

File encoding

Файл, содержащий скрипт, будет сохранён в выбранной в этом поле кодировке.

Line end

В файле будут установлены выбранные символы конца строки. Доступны символы для Windows (CR LF), Unix (LF) и MacOS (CR).


Шаг 5 - Запуск процесса генерации

Данный шаг извещает Вас о том, что все параметры генерации данных заданы, и Вы можете запустить процесс генерации.

Step 5 - Start of data generation

Если все настройки выполнены корректно, нажмите кнопку Generate для запуска процесса генерации. Если вы желаете что-то изменить, вернитесь на предыдущие шаги, используя кнопку Back.

Диалоговое окно Generating... отображает количество сгенерированных записей, время, затраченное на их генерацию, количество ошибок, если таковые присутствуют, а также визуально отображает процент сгенерированных данных. Если Вы хотите чтобы процесс генерации данных проходил в фоновом режиме, нажмите кнопку Send to background. Чтобы свернуть окно, нажмите кнопку Minimize. Отмена процесса - кнопка Cancel.

Step 5 - Generating data

Отчет о выполненных операциях, а также ошибках (при их наличии), отображается в окне Generation Log.

После завершении процесса, Вы можете использовать кнопки View SQL file in editor для редактирования скрипта генерации данных на шаге 6, и Save log to file для сохранения во внешний файл отчета о процессе генерации.

Не забудьте сохранить настройки генерации данных. Это может быть полезно, если позже Вам понадобится повторить процедуру генерации с этими же (подобными) настройками.


Шаг 6 - Редактирование скрипта генерации

Этот шаг мастера дает Вам возможность редактирования итогового скрипта генерации данных.

Возможность свертывать части кода, подсветка синтаксиса и другие возможности сделают редактирование скрипта более удобным.

Step 6 - Editing generation script

Контекстное меню редактора содержит большинство стандартных функций для работы с текстом (Вырезать - Cut, Копировать - Copy, Вставить - Paste, Выделить все - Select All) а также функции для работы со скриптом в целом (переместить курсор на выбранную строку - Go to Line Number, управлять маркерами - Markers, переключаться между закладками - toggle bookmarks) и т.д.

В редакторе также доступны диалоговые окна поиска (Find Text) и замены (Replace Text), повышающие эффективность работы с кодом SQL.

Полный перечень команд контекстного меню представлен ниже:

  • управление маркерами (подменю Markers): добавить маркер (пункт Drop marker или клавиша F2), удалить маркер (пункт Collect marker или клавиша ESC), изменить позицию маркера (пункт Swap marker; в этом случае последний добавленный маркер переместится на текущую позицию курсора, а курсор будет установлен на исходную позицию данного маркера);
  • подменю Toggle Bookmarks и Goto Bookmarks позволяют оставлять в тексте закладки, и переключаться между ними;
  • пункт Go to Line Number позволяет перейти на заданную строку;
  • операции редактирования можно выполнить с помощью пунктов меню: Undo, Redo, Cut, Copy, Paste, Select all;
  • операции поиска и замены доступны с помощью пунктов меню Find и Replace соответственно;
  • пункт Save... позволяет сохранить скрипт во внешний файл *.sql;
  • с помощью подменю Quick Code можно выполнить следующее: вставить символ, закомментировать часть кода, отменить комментирование, переключить регистр выделенного текста, добавить/убрать отступ для текущей строки.

Нажмите кнопку Back для возврата на предыдущие шаги (содержимое редактора при этом потеряно не будет).

Если нажать на кнопку Save, то скрипт будет сохранен во внешний файл.

Нажатие на кнопку Close приведет к закрытию приложения (перед этим Вам будет предложено сохранить изменения).


Использование файла конфигурации

Data Generator for DB2 позволяет сохранять настройки программы в файле *.gtm для повторной генерации данных с идентичными или схожими параметрами.

Вы можете загрузить сохраненные ранее настройки приложения, при необходимости внести в них изменения перед генерацией данных, или использовать файл настройки для быстрой генерации данных с помощью консольного приложения.

  • Сохранение файла конфигурации
  • Загрузка файла конфигурации

Смотрите также:

Работа с мастером генерации данных

Настройки программы


Сохранение файла конфигурации

Шаблон Data Generator может быть сохранен в диалоговом окне Save template options. Чтобы открыть этот диалог, нажмите кнопку Tools и выберите пункт Save Template в появившемся меню.

В открывшемся диалоговом окне следует заполнить следующие поля:

File name

Укажите имя файла шаблона и его местонахождение в окне Save As..., которое можно открыть, нажав на кнопку btnSaveAs.

Comment

Если необходимо, укажите комментарий к файлу конфигурации.

Using configuration files - Save Template options

Сохранение настроек программы доступно с шага Параметры генерации до последнего шага мастера Data Generator for DB2.

  • Загрузка файла конфигурации


Загрузка файла конфигурации

Шаблон Data Generator может быть загружен с помощью диалогового окна Open template. Чтобы открыть данное окно, нажмите кнопку Tools и выберите пункт Load template в появившемся меню.

Помните, что загрузить шаблон можно на шагах мастера, начиная с начального и до шага Параметры генерации, используя пункт Load Template меню Tools.

Вы можете открыть шаблон заново, выбрав нужный из списка Reopen template.

  • Сохранение файла конфигурации


Настройки программы

Вы можете тщательно настроить интерфейс Data Generator for DB2 с помощью опций, представленных в диалоговом окне Preferences. В этом разделе Вы найдете их описание.

Общие

Опции данной секции определяют поведение программы.

Ограничения

В этой секции задаются ограничения для значений полей, которые будут использоваться по умолчанию.

Локализация

Секция позволяет выбрать язык интерфейса Data Generator for DB2.

Смотрите также:

Работа с мастером генерации данных

Использование файла конфигурации


Общие настройки

В секции General расположены опции, с помощью которых Вы можете задать основные параметры программы.

Theme

Выберите цветовую схему программы: Light (Светлая) или Dark (Темная).

Number of records to generate

Определите количество значений для генерации, которое будет использовано по умолчанию.

Commit every ... records

Задайте количество записей в блоке скрипта генерации, после которого будет следовать оператор COMMIT.

Number of records to preview

Укажите количество записей для отображения в режиме предварительного просмотра по умолчанию.

Preferences - General

CheckBox Set NULL value in ... % of cases

Данная опция позволяет задать процент записей, которым будет присвоено значение NULL.

CheckBox Confirmation on exit

Включите опцию, если при закрытии программы необходим запрос о подтверждении.

CheckBox All fields selected by default

Если флажок установлен, то по умолчанию в процесс генерации данных будут включены все поля.

CheckBox BLOB fields selected by default

Отключите опцию, если по умолчанию следует исключать поля типа BLOB из процесса генерации данных.

CheckBox Clear tables before generation

Используйте опцию для очистки таблиц перед генерацией данных.

CheckBox Save passwords

Опция позволяет при закрытии приложения автоматически сохранять пароли, которые были использованы для подключения к базам данных. Если опция включена, то сохраняется последний пароль, использованный для подключения к базе.

Смотрите также:

Настройки ограничений

Выбор языка программы


Настройка ограничений

В этом разделе Вы можете определить ограничения по умолчанию для всех поддерживаемых типов данных

Числовые типы

Символьные типы

Дата/время типы

Значения по умолчанию используются в качестве изначально заданных значений для диапазона данных и могут быть изменены на Шаге 3.

Смотрите также:

Общие настройки

Выбор языка программы


Числовые типы

На этой вкладке вы можете определить ограничения по умолчанию для числовых типов.

Preferences - Defaults - Numeric

Integer types

Установите целевые минимальное и максимальное значения по умолчанию для целочисленных типов.

Floating-Point types

Установите значения точности и масштаба по умолчанию для типов с плавающей точкой.


Символы

На этой вкладке вы можете определить ограничения для символьных типов данных.

Min Length

Установите минимальную длину генерируемого значения.

Max Length

Установите максимальную длину генерируемого значения.

Start Char

Выберите начальный символ для диапазона символов, который будет использоваться для генерации.

End Char

Выберите конечный символ для диапазона символов, который будет использоваться для генерации.

CheckBox Include new line

Выберите этот параметр, чтобы разрешить перевод строк в сгенерированных строковых значениях.

CheckBox Windows new line

Выберите этот параметр, чтобы указать перенос строк в стиле Windows.

Preferences - Defaults - Character

Sample Text

Если Вам будет удобнее, вы можете ввести любую строку, которая будет использоваться в качестве примера текста. Вы можете выбрать генерацию образца текста при настройке параметров генерации для строковых типов данных.


Дата/Время типы

На этой вкладке Вы можете определить ограничения по умолчанию для типов данных даты и времени.

Preferences - Defaults - DateTime

Min Date

Выберите начальную дату для генерации значений.

Max Date

Выберите конечную даты для генерации значений.

Date format

Введите с клавиатуры или используйте выпадающий список, чтобы указать подходящий формат даты.

Min Time

Выберите начальное время диапазона для генерация значений времени.

Max Time

Выберите конечное время диапазона для генерация значений времени.

Time format

Введите с клавиатуры или используйте выпадающий список, чтобы указать подходящий формат времени.


Выбор языка программы

На вкладке Language Вы можете управлять файлами локализации Data Generator.

Вы можете добавить свой файл с расширением *.lng, в список доступных локализаций. Для этого скопируйте его в папку %program_directory%\Languages folder. Затем укажите местонахождение файла в поле Language directory и нажмите на кнопку Load files.

В центральной таблице отображены доступные языки. Для выбора языка следует выделить его в списке и нажать OK.

Preferences - Localization

Смотрите также:

Общие настройки

Настройки ограничений


Деревья и списки

В разделе Trees and Lists настройте внешний вид деревьев и списков.

Preferences - Interface - Trees and lists

Из раскрывающегося списка Look & Feel выберите один из стандартных стилей оформления списков.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Hide selection - скрыть выделение.

CheckBox Hide focus rectangle - прятать прямоугольник фокуса.

CheckBox Native style - естественный стиль.

Смотрите также:

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций

Шрифты


Элементы редактирования

В разделе Edit controls задайте стиль элементов редактирования.

Preferences - Interface - Edit controls

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

Из списка Button style - стиль кнопок.

3D - трехмерные,

Flat - плоские с тенью,

Simple - простые

Hotflat - плоские в рамке

Ultraflat - плоские.

Стиль кнопок, расположенных в пределах поля, можно задать с помощью раскрывающегося списка Button transparency.

None - непрозрачные,

Inactive - прозрачные, когда неактивные.

Always - прозрачные,

Hide inactive - показывать при редактировании,

Hide unselected - показывать при наведении курсора.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль.

Edges - границы:

CheckBox Left - слева;

CheckBox Right - справа;

CheckBox Top - сверху;

CheckBox Bottom - снизу.

Смотрите также:

Деревья и списки

Флажки

Кнопки

Элементы окна

Группы опций

Шрифты


Флажки

В разделе Check boxes задайте вид флажков и переключателей.

Preferences - Interface - Check boxes

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль.

Смотрите также:

Деревья и списки

Элементы редактирования

Кнопки

Элементы окна

Группы опций

Шрифты


Кнопки

В этом разделе настройте внешний вид кнопок.

Preferences - Interface - Buttons

Из списка Button kind выберите вид кнопок.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Native style - естественный стиль.

Смотрите также:

Деревья и списки

Элементы редактирования

Флажки

Элементы окна

Группы опций

Шрифты


Элементы окна

В этом разделе задайте стиль оформления вкладок.

Preferences - Interface - Page controls

Из списка Tab Style выберите нужный стиль вкладок.

Tabs - в виде вкладок,

Buttons - в виде кнопок

Flat - плоские.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль.

Смотрите также:

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Группы опций

Шрифты


Группы опций

Задайте стиль отображения групп опций в разделе Group boxes.

Preferences - Interface - Group boxes

Из раскрывающегося списка Border style выберите стиль рамки.

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль.

Смотрите также:

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Шрифты


Шрифты

Раздел Preferences содержит опции настройки используемых в приложении шрифтов.

Под опциями расположен образец текста, на котором Вы можете отслеживать изменения в настройках.

Preferences - Interface - Fonts

System font name

В раскрывающемся списке выберите шрифт, который следует использовать в программе.

Preferences - Interface - Fonts - System font name

System font size

Выберите подходящий размер шрифта из списка доступных значений или задайте его вручную.

Смотрите также:

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций


Консольное приложение

Консольное приложение Data Generator for DB2 предназначено для быстрой и удобной генерации данных в таблицы базы данных DB2, а также для использования в любых планировщиках задач.

  • Работа с консольным приложением
  • Формат файла конфигурации

Смотрите также:

Мастер генерации данных


Работа с консольным приложением

Все параметры генерации данных Вы можете указать в файле конфигурации, имеющем расширение *.gmt. Консольное приложение использует имя этого файла как параметр при выполнении экспорта.

Чтобы создать файл конфигурации (шаблон) следуйте инструкции:

  • запустите Data Generator for DB2 Мастер генерации данных;
  • задайте необходимые параметры на каждом шаге;
  • проверьте процесс генерации на последнем шаге;
  • сохраните шаблон.

Запустить файл конфигурации можно двумя способами:

  • дважды щелкнуть на созданном файле конфигурации (*.gmt) мышью.
  • задать в консольном приложении команду запуска - <путь к консольному приложению Data Generator for DB2>\Db2DataGenC.exe ИмяФайлаКонфигурации [-B] [-L]

[-L]

Укажите параметр для использования локализации, выбранной для Мастера генерации данных

[-B]

Используйте данный параметр для запуска консольного приложения Data Generator for DB2 в фоновом режиме.

Пример:

"C:\Program Files\EMS\Data Generator for DB2\Db2DataGenC.exe" "C:\EMS\Templates\DataGenerator\Example.gtm" -L

Важно: Следующие значения кода завершения возвращаются программой Data Generator for DB2 операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка (или несколько);

2 - критическая ошибка. Задача не выполнена.

Смотрите также:

Мастер генерации данных

Формат файла конфигурации


Тип генерации данных

Секция Data generation mode позволяет выбрать тип генерации данных: Generate random data - генерировать случайные значения, Generate incremental data - генерировать последовательность значений, Get data from list / SQL-query - получать значения из списка или с помощью SQL запроса, Get data from field - получать значения из поля.

Generate random data

Используйте этот тип, если следует генерировать случайные значения из указанного диапазона.

Generate incremental Data

Данный тип позволяет генерировать последовательность значений в соответствии с указанными начальным значением (Initial value) и приращением (Increment).

Get Data from List / SQL query

Выберите этот тип, если данные следует генерировать из определенного пользователем списка значений:

- список значений (list of values) используется для данных типа numeric, string, date/time, boolean.

- список файлов (list of files) используется для данных типа BLOB;

- результат SQL запроса;

- заданный образец текста (sample text) используется для данных типа string.

CheckBox Random order

Включите опцию если следует генерировать данные в случайном порядке. Если опция выключена, то будет сохранен порядок, использованный в списке (результате запроса).

Get data from column

Этот тип предполагает генерацию данных из указанного поля. Используйте раскрывающиеся списки Table и Field чтобы определить исходное поле, данные из которого будут использованы для генерации.


Формат файла конфигурации

Формат файла конфигурации Data Generator for DB2 разделен на несколько секций, каждая из которых соответствует шагу в мастере генерации данных.

[#General#]

Данная секция содержит общую информацию о программе:

Параметр | Описание
Product | внутреннее название продукта
Version | версия

[#Comment#]

Секция содержит комментарии к файлу конфигурации:

Параметр | Описание
Line<N> | комментарий N - номер строки в комментарии

Пример:

Line0=Data Generator for DB2

Line1=Template file

Line2=Data generation #1

[CONNECTION]

В данной секции можно задать параметры подключения к серверу DB2. Параметры являются обязательными и соответствуют настройкам, предлагаемым на Шаге 1 мастера генерации данных.

Параметр | Описание
DBAlias | алиас базы даннх DB2
Login | имя пользователя DB2 (если NTAuth = 0)
Password | пароль пользователя (зашифрован)
Major | первая цифра версии программы (для использования при шифровании); крайне не рекомендуется изменять значение параметра
Minor | вторая цифра версии программы (для использования при шифровании); крайне не рекомендуется изменять значение параметра)
PassPhrase | параметр не используется в Data Generator for DB2

[ADDITIONAL]

Секция содержат дополнительные настройки, указанные на Шаге 2 and Шаге 4 Мастера генерации данных.

Параметр | Описание
TablesCount | количество таблиц, выбранных для генерации данных
SqlExecute | соответствует опции Execute statements на Шаге 4: 1 = включена 0 = выключена
SqlSave | соответствует опции Save data generation script to file на шаге 4: 1 = включена 0 = выключена
SaveFile | путь к файлу скрипта (если SqlSave = 1)
BlobFile | параметр не используется в Data Generator for DB2
ExportBlobType | параметр не используется в Data Generator for DB2

[TABLE_XX]

Данный раздел повторяется для всех таблиц; соответствующие настройки расположены на Шаге 3 мастера генерации данных.

Параметр | Описание
Schema | имя схемы, которой принадлежит таблица
TableName | имя таблицы, в которую генерируются данные
RecordCount | количество записей, которые будут сгенерированы
ClearBeforeGeneration | 1 очистить таблицу перед генерацией 0 оставить таблицу в исходном виде

[TABLE_XX_FIELD_YY]

Секция создается для каждого поля каждой таблицы.

Параметр | Описание
DoGenerate | 0 не включать поле 1 включать поле
IncludeNulls | 1 значения NULL будут использованы в указанном проценте случаев 0 отключить опцию
NumNulls | процент значений NULL
GenMethod | определяет Тип генерации данных: 0 = incremental data generation 1 = random data generation 2 = Get data from list / SQL query option 3 = from another field
GenFromSQL | 0 = использовать список значений для генерации данных 1 = использовать запрос SQL
SQL | текст запроса SQL результат которого будет использован для генерации значений
UsingMask | 0 = не использовать маску для значений строковых полей 1 = генерировать значения строкового поля с использованием маски
Mask | маска для значений строкового поля
MinInt | минимальное значение для полей типа integer
MaxInt | максимальное значение для полей типа integer
UseFormula | 0 = без формулы 1 = использовать формулу для генерации значений
Formula | формула для генерации значений, например x*2+1
Digits | количество цифр целой части для полей типа float
Precision | количество знаков после запятой для полей типа float
MinDate | минимальное значение для полей типа datе
MaxDate | максимальное значение для полей типа datе
IncludeTime | определяет включать ли время в значения DATETIME полей
MinTime | минимальное значение для полей типа time
MaxTime | максимальное значение для полей типа time
MinLength | минимальная длина для строковых полей
MaxLength | максимальная длина для строковых полей
StartChar | код первого символа для генерации значений строковых полей
EndChar | код последнего символа для генерации значений строковых полей
Charset | кодировка поля
InitialValue | начальное элемент последовательности значений
IncrementStep | инкремент последовательности значений (для GenMethod = 0)
UseNewLine | 1 = использовать перевод строки 0 = не использовать перевод строки
WinNewLineStyle | использовать перенос строки используемый: 1 = Windows 0 = Unix
SampleText | образец текста для генерации строковых значений


Диалог поиска

С помощью окна Find Text можно найти сочетание символов при редактировании скрипта.

В поле Text to Find укажите искомую последовательность символов. Или выберите одну из предыдущих.

Options

CheckBox Case Sensitive

При поиске учитывать регистр.

CheckBox Whole words only

Учитывать слово целиком.

CheckBox Regular Expressions

Если отмечена эта опция, то введенный текст будет распознаваться как регулярное выражение.

Например, если Вы введете "empl*", то будет произведен поиск по метаданным всех строк, содержащих подстроку "empl". При вводе "^emp" результатом поиска будут объекты, в метаданных которых есть строки, начинающиеся на "emp", а при поиске

"^emp|emp$" - строки, содержащие "emp" в начале или конце строки.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в поле Text to find, соответствует синтаксису регулярных выражений языка Perl. Более подробная информация может быть найдена по ссылке: http://perldoc.perl.org/perlre.html#Regular-Expressions.

Direction

Укажите направление поиска:

RadioButton Forward - вниз,

RadioButton Backward - вверх.

Scope

RadioButton Global - искать во всем тексте.

RadioButton Selected text - искать только в выделенном тексте.

Origin

RadioButton From cursor - поиск начинается с того места где стоит курсор.

RadioButton Entire scope - поиск с начала текста.

CheckBox Mark search result with stack marker - помечать результаты поиска маркером.


Диалог замены

С помощью окна Replace Text можно найти сочетание символов при редактировании скрипта и заменить его на указанное.

В поле Text to find укажите искомую последовательность символов. Или выберите одну из предыдущих.

В поле Text to replace укажите последовательность символов, на которою желаете заменить найденные или выберите одну из предыдущих.

Options

CheckBox Case Sensitive

При поиске учитывать регистр.

CheckBox Whole words only

Учитывать слово целиком.

CheckBox Regular Expressions

Если отмечена эта опция, то введенный текст будет распознаваться как регулярное выражение.

Например, если Вы введете "empl*", то будет произведен поиск по метаданным всех строк, содержащих подстроку "empl". При вводе "^emp" результатом поиска будут объекты, в метаданных которых есть строки, начинающиеся на "emp", а при поиске

"^emp|emp$" - строки, содержащие "emp" в начале или конце строки.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в поле Text to find, соответствует синтаксису регулярных выражений языка Perl. Более подробная информация может быть найдена по ссылке: http://perldoc.perl.org/perlre.html#Regular-Expressions.

CheckBox Prompt on replace - включите опцию, если хотите чтобы при каждом нахождении указанной последовательности символов программа выводила запрос о замене. Если опция выключена, замена будет происходить автоматически.

Direction

Укажите направление поиска:

RadioButton Forward - вниз,

RadioButton Backward - вверх.

Scope

RadioButton Global - искать во всем тексте.

RadioButton Selected text - искать только в выделенном тексте.

Origin

RadioButton From cursor - поиск начинается с того места где стоит курсор.

RadioButton Entire scope - поиск с начала текста.

CheckBox Mark search result with stack marker - помечать результаты поиска маркером.

Кнопка Replace All позволяет заменить все совпадения. Если опция Prompt on replace включена, будет выдаваться запрос подтверждения замены текста.


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться Data Generator for DB2, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

Data Generator for DB2 подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

На первом шаге из раскрывающегося списка Database home выберите имя клиента и из раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.