EMS logo

Навигация по продуктам

SQL Studio for Oracle

Наш партнерский статус

Microsoft Certified Partner
Oracle Certified Partner
Embarcadero Technology Partner

EMS SQL Management Studio for Oracle

Он-лайн Документация

Часто задаваемые вопросы по SQL Studio


Пожалуйста внимательно прочтите эту страницу, если у Вас возникли вопросы по EMS SQL Management Studio for Oracle.

 

Содержание

 

Что такое STUDIO

 

Регистрация баз данных и подключение

 

Управление объектами

 

Запросы

 

Конструктор отчетов

 

Управление данными

 

Анализ данных

 

Резервное копирование/Восстановление

 

Управление шаблонами

 

Планировщик

 

Управление журналами

 

Локализация

 

 

Список ответов

 

 

Что такое STUDIO

 

Q: Что такое EMS SQL Management Studio?

A: EMS SQL Management Studio – это комплексное решение для администрирования и разработки баз данных. STUDIO представляет собой набор мощных инструментов для работы с базами данных, объединенных удобной, функциональной оболочкой. Разработчики по достоинству оценят возможность создания/редактирования/удаления любых объектов базы данных. Полезными для них будут инструменты сравнения БД, экспорта и импорта данных, генерации тестовых данных. Администраторам будут интересны инструменты для миграции БД, создания резервных копий и их последующего восстановления и, конечно, Планировщик, позволяющий автоматизировать большую часть работы администратора.

 

Q: STUDIO содержит очень много возможностей, но буду ли я их использовать? Нет ли более простого продукта?

A: Такой вопрос, в основном, задают новички в администрировании и разработке баз данных. Они не могут понять, для чего нужно столько различных инструментов!? Мы хотим сказать, что с каждым днем ваш опыт будет расти, перед вами будут стоять новые, более сложные задачи, и для их решения вам будет необходимо иметь все больше инструментов. STUDIO содержит в себе ВСЕ необходимые инструменты для администратора или разработчика баз данных. STUDIO уже готова к вашему профессиональному росту! Более того, изучив и поняв инструменты STUDIO, вы сможете находить более простые, удобные и надежные решения ваших задач! Конечно, мы понимаем, что нашим продуктом пользуются не только профессионалы, поэтому в STUDIO включены многочисленные мастера, делающие работу легкой и приятной даже для новичка. Интерфейс STUDIO спроектирован так, чтобы многочисленные инструменты не мешались пользователю, а вызывались исключительно тогда, когда это необходимо. Наш опыт показывает, что подавляющее большинство пользователей очень быстро привыкают к нашим мощным продуктам, и мы не имеем никаких обращений от пользователей с просьбами сделать даунгрейд на более простой продукт.

 

Q: Что мне необходимо для начала работы с STUDIO?

A: Для начала работы с STUDIO вам необходимо скачать установочный пакет здесь. На компьютере с MS Windows запустить программу-инсталлятор. По окончании работы инсталлятора программа готова к использованию в триальном режиме. Вы можете использовать программу в триальном режиме в течение 30 дней. За это период вам необходимо принять решение о приобретении STUDIO. Оплатить STUDIO можно здесь. После оплаты вы получите по электронной почте регистрационный ключ, после ввода которого (Главное меню/Справка/Зарегистрировать) ваша копия STUDIO станет зарегистрированной.

 

Q: Многие утилиты, входящие в STUDIO, вы продаете отдельно. В чем преимущество покупки их в составе STUDIO?

A: Действительно, для решения какой-либо одной несложной задачи можно приобрести один или несколько наших инструментов. Однако покупая эти инструменты в составе STUDIO, вы получаете дополнительные возможности. Прежде всего, это возможность запускать инструменты студии из планировщика задач. Т.е. вы можете задать последовательность использования нескольких инструментов, указать, с какими параметрами должны быть использованы инструменты, задать время и/или частоту выполнения задач. Планировщик выполнит все ваши задачи, сохранит журналы выполненных инструментов и вышлет вам уведомление об удачном/неудачном завершении задачи на ваш электронный адрес. С помощью Планировщика вы реально можете автоматизировать большинство сервисных задач по обслуживанию вашей БД. Вторая возможность - это хранение всех зарегистрированных БД в одном репозитории. Таким образом, однажды зарегистрировав источник данных, вы можете использовать его во всех инструментах STUDIO. Это экономит ваше время и снижает вероятность ошибки. Третий, очень немаловажный момент, - это цена. Приобретая инструменты в составе студии, вы платите за них существенно меньше, чем при покупке отдельными продуктами. Скидка достигает 40%!

 

Наверх

 

Регистрация баз данных и подключение

 

 

Q: Могу ли я работать с несколькими базами данных одновременно?

A: Да, STUDIO позволяет работать с неограниченным количеством БД одновременно. Это правило распространяется и на БД, работа с которыми ведется через SSH туннель. Единственное условие для этого - БД должна быть корректно зарегистрирована в репозитории баз данных.

 

Q: Я работаю под MS Windows, но мой удаленный сервер Oracle работает на LINUX. Могу ли я работать с этим        сервером, используя STUDIO?
A: Да, это возможно. Главное - это то, что сама STUDIO работает исключительно под управлением MS WINDOWS. Однако, под какой ОС работает сервер Oracle, не имеет никакого значения.

 

Q: Для чего нужен общий репозиторий зарегистрированных баз данных?
A: Единый репозиторий баз данных позволяет после однократной регистрации базы данных иметь возможность обращаться к ней из разных инструментов STUDIO. Для сравнения, покупая ранее наши наборы инструментов (бандлы), вы должны были в каждом инструменте вводить информацию о соединении с источником данных. Это приводило к дополнительным затратам времени и ошибкам. Теперь в STUDIO такой проблемы нет.

 

 

 

Q: Что такое SSH-туннель?

A: SSH (Secure Shell Host) протокол используется для повышения компьютерной безопасности при работе с Unix-системами в Internet. SSH использует несколько алгоритмов шифрования разной степени надежности. Распространенность SSH связана еще и с тем, что многие Linux-подобные ОС (например, FreeBSD) включают в стандартную комплектацию SSH сервер. Для получения дополнительной информации вы можете посетить http://openssh.org. Опция SHH туннель в SQL Management Studio for Oracle представляет собой средство организации безопасного доступа к Oracle серверам при работе по небезопасным каналам связи. Также вы можете использовать SSH туннель для доступа к удаленным Oracle серверам, если по каким-либо причинам порт 3050 закрыт для внешних подключений. Соединение через SSH туннель выглядит следующим образом. Сначала устанавливается соединение и производится процедура аутентификации между встроенным в SQL Manager SSH клиентом и удаленным SSH сервером, затем вся исходящая и входящая информация между программой и Oracle сервером передается через SSH сервер с использованием коммуникационного порта (обычно 22), а SSH сервер транслирует информацию уже непосредственно Oracle серверу. Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием SSH туннеля, вы должны задать следующие параметры при регистрации базы данных в SQL Manager for Oracle:

 На первом шаге:

 Хост - имя хоста, где расположен сервер Oracle с точки зрения сервера SSH. Если SSH и Oracle сервера установлены на одной машине, то он совпадает с хостом SSH, или он может быть 'localhost'.

 Порт - порт сервера Oracle, его значение по умолчанию 3050.

 Пользователь - имя пользователя сервера Oracle.

 Пароль - пароль пользователя Oracle.

 Имейте в виду, что имя хоста Oracle должно быть задано относительно сервера SSH. Например, если Oracle и SSH сервера установлены на одном компьютере, Вы должны указать localhost в качестве имени хоста вместо имени внешнего хоста или IP адреса.

 Далее выберите опцию Использовать туннелирование и SSH туннель.

 На втором шаге:

 SSH хост - хост, где активирован сервер SSH.

 SSH порт - порт, где активирован сервер SSH.

 SSH пользователь - пользователь Linux машины. (Это пользователь Linux. Это не пользователь сервера Oracle.)

 SSH пароль - пароль пользователя Linux.

 

Q: Моя рабочая станция подключена в сеть через файервол (роутер). Могу ли я использовать СТУДИЮ для управления удаленным Oracle сервером?

A: Если из-за политики безопасности, принятой у вас в корпоративной сети или хостинг провайдером, вы не можете соединиться с вашим Oracle сервером напрямую через TCP/IP (например этому мешает файервол), то для этой цели вы можете использовать опцию SSH туннель в SQL Manager.

 

Q: Я не могу настроить соединение с Oracle сервером через SSH. Какие значения я должен ввести в поля на закладке SSH в диалоговом окне Регистрации Базы Данных?

A: Чтобы правильно настроить соединение SSH, укажите следующие значения в соответствующих полях:

 На странице/закладке "SSH":

 Имя хоста SSH - хост, где запущен сервер SSH.

 SSH порт - порт, где запущен сервер SSH.

 Имя пользователя SSH - пользователь компьютера с Linux ОС. (Это пользователь Linux. Это не пользователь сервера Oracle.)

 SSH пароль - пароль пользователя Linux.

 На странице/закладке "Свойства соединения/Общие" (Connection properties/General):

 Хост - хост, где находится Oracle сервер с точки зрения сервера SSH. Если серверы SSH и Oracle находятся на одном компьютере, хост равен SSH Host, либо может быть локальным 'localhost'.

 Порт - порт Oracle сервера на удаленном хосте (Remote Host), по умолчанию равен 3050.

 Имя Пользователя - имя пользователя Oracle.

 Пароль - пароль пользователя Oracle.

 Имейте в виду, что в этом случае имя хоста Oracle должен быть указан по отношению к серверу SSH. Например, если и Oracle и SSH серверы находятся на одном компьютере, вы должны в качестве имени хоста указать localhost вместо внешнего имени хоста сервера или адреса IP.

Наверх

Управление объектами

 

Q: Какие объекты базы данных будут доступны мне при работе в STUDIO?

A: Вы можете работать с любыми объектами баз данных Oracle, такими, как таблицы, поля, индексы, представления, хранимые процедуры и функции, триггеры и т.д.

 

Q: У меня в таблице более миллиона записей, однако в сетке данных отображаются только 1000. В чем проблема?

A: Пожалуйста, выберите опцию "Выбирать все записи из таблицы" на закладке "Сетка" диалога "Настройки/Настройки окружения". При этом помните, что на выборку всех записей из таблицы может потребоваться значительное время.

 

Q: Как повысить скорость работы с большими таблицами?

A: В целях повышения скорости работы и удобства Сетка Данных позволяет производить гибкую настройку многих параметров отображения данных. Ниже приведены наиболее важные из них (пункт меню "Настройки/Настройки окружения"):

 1. На закладке Сетка:

  • Ограничения в редакторах. При включении опции "Выбирать все записи из таблицы" вы будете иметь возможность видеть все записи таблицы без дополнительных запросов к серверу, однако для больших таблиц или при низкоскоростном канале связи возможны значительные задержки при получении данных, также входящий трафик может быть большим. Режим рекомендуется при работе с базами данных, расположенными локально либо в частной сети. Режим "Выбирать только" ограничивает максимальное число записей, возвращаемых в результате запроса. Режим обусловлен тем, что человек не способен осмысленно просмотреть огромный объем информации за один раз. Для запроса и отображения следующей порции данных служит кнопка "Далее" в панели инструментов "Сетка Данных". Данный режим значительно ускоряет просмотр данных таблицы, предотвращает зависание и разрыв соединения при таймауте. Рекомендуется для работы с большими таблицами, при низкоскоростных каналах связи и когда объем трафика имеет значение. Данный режим включен по умолчанию. При данном режиме очень полезны опции "Использовать сортировку SQL" и "Использовать фильтр SQL".

 2. На странице "Сетка/Настройки данных":

  • Режим сетки по умолчанию. Данная опция определяет, будут ли все строки запроса загружаться в Сетку сразу ("Загружать все строки"), либо по мере необходимости ("Загружать видимые строки"), т.е. когда пользователь пролистывает данные в таблице. Первый режим увеличивает время открытия результата запроса, но уменьшает задержки при пролистывании. При втором режиме время открытия результата запроса минимально, но возникают задержки при навигации по сетке.
  • Использовать сортировку SQL при просмотре данных. При включенной опции при задании пользователем сортировки данных на сервер отправляется новый запрос, результат которого заново отображается в сетке. Очень полезна опция при включенном режиме - "Выбирать только", но она увеличивает трафик. При отключенной опции сортировка выполняется на клиенте без участия сервера, но только в уже загруженных данных. Т.е. если указано "Выбирать только 1000 записей", то отсортируются только эти записи.
  • Использовать фильтр SQL при просмотре данных. При включенной опции фильтрация данных будет производиться на сервере, куда отправляется новый запрос, результат которого заново отображается в сетке.
  •        Также очень полезна опция при включенном режиме - "Выбирать только", но она увеличивает трафик. При отключенной опции фильтрация выполняется на клиенте без участия сервера, но только в уже загруженных данных. Т.е. если указано "Выбирать только 1000 записей", то фильтр будет выбирать только из этих записей.

 

 3. Для максимальной производительности при работе с большими таблицами мы рекомендуем установить следующие значения для опций:

 - Выбирать только – Включено

 - Загружать все строки – Включено

 - Использовать сортировку SQL – Включено

 - Использовать фильтр SQL – Включено

 

Q: Какие действия я могу выполнять с объектами базы данных?

A: Вы можете создавать новые объекты, удалять и модифицировать существующие. Также можете копировать объекты между базами данных, расположенных как на одном, так и на разных серверах.

 

Q: При создании таблицы с именем `TestTable` она сохраняется как 'TESTTABLE'. Это неправильно!

A: Попробуйте отключить опцию "Convert created objects' names to upper case" в разделе Environment Options -> Object Editors.

 

Q: Как я могу настроить форматы данных в сетке?

A: Вы можете настроить любой из форматов отображения данных: integer, float, date, time и date/time в окне "Настройки окружения". Вы можете это сделать, используя Главное меню "Настройки/Настройки окружения/Сетка/ Цвета и Форматы".

 

Q: Я не могу изменить DDL. Почему?

A: Вкладки "DDL" в Редакторе таблиц и в Редакторе UDF доступны только для чтения. Они отображают SQL текст операций, производимых вами во вкладках "Поля", "Индексы" и прочих или через UDF. Чтобы изменить этот текст, вы можете скопировать его в буфер обмена и изменить его, используя Редактор SQL-скрипта.

Наверх

 

Запросы

 

Q: Я новичок в Oracle. Я плохо строю SQL-запросы. Есть ли в STUDIO визуальный конструктор запросов, как в MS ACCESS?

A: Да, STUDIO имеет мощный визуальный конструктор запросов, позволяющий даже новичку строить достаточно сложные запросы, а профессионалу тратить на это значительно меньше времени. Вам только необходимо указать, какие таблицы участвуют в запросе, как они связаны между собой и какие данные вы хотите получить. Визуальный конструктор сам составит текст запроса. Вам останется только выполнить его. Вы сразу же можете увидеть результат выполнения запроса и внести, в случае необходимости, изменения в запрос. Изменения можно делать как в визуальном редакторе, так и в текстовом. Причем изменения, сделанные в тексте запроса, будут отображены в визуальном редакторе, и наоборот.

 

Q: Могу ли я использовать визуальный конструктор запросов STUDIO для создания сложных запросов (включая составные и вложенные)?

A: Да, визуальный конструктор запросов позволяет строить и сложные запросы, включая составные (оператор UNION) и вложенные (SUBQUERIES).

 

Q: Могу ли я сохранить созданный запрос для будущего использования?

A: Да, конечно. Для того чтобы необходимый запрос можно было быстро найти и выполнить, STUDIO обладает следующими возможностями:

 1. ВСЕ выполненные запросы автоматически сохраняются в Истории. Вы можете просмотреть Историю и выполнить любой запрос еще раз, либо отредактировать его.

 2. Наиболее часто используемые запросы вы можете поместить в список фаворитных запросов.

 3. Вы можете сохранить любой запрос как SQL-скрипт в файл на диске и позднее загрузить его, либо выполнить с помощью консольного инструмента SQL скрипт.

 4. Вы можете сохранить ваш запрос вместе с диаграммой. В этом случае в будущем, после загрузки этого запроса в STUDIO вы увидите диаграмму запроса такой, какой вы ее создали.

 5. STUDIO позволяет сохранить диаграмму запроса как рисунок bitmap.

 

Q: Могу ли я выполнить запрос из командной строки?

A: Да. Для этого в состав STUDIO входит инструмент SQL скрипт, который в том числе может выполнить скрипт, сохраненный в файле. Эта возможность позволяет вам создавать запросы и отдавать их на выполнение Планировщику STUDIO. Планировщик выполнит ваш запрос строго в назначенное вами время и сообщит вам о результате выполнения.

 

Q: Могу ли я сохранить результат выполнения запроса в csv или xls файле?

A: Да, конечно. STUDIO имеет мощный инструмент для экспорта данных (в том числе и результатов запроса). Кроме указанных вами форматов STUDIO позволяет выполнить экспорт в файлы следующих типов: MS Access, MS Word, HTML, RTF, DBF, XML и другие. Для облегчения настройки операции экспорта STUDIO содержит дружественный Мастер Экспорта Данных.

Наверх

 

Конструктор отчетов

 

Q: Как я могу создать отчет?

A: Вы можете использовать для создания отчета Мастер Создания Отчетов ("Создать -> Отчет") или Конструктор отчетов ("Инструменты/Конструктор отчетов"). Чтобы создать простейший отчет на основе запроса, вам нужно выбрать "Master Data band" на втором шаге мастера, дважды щелкнуть на нем, либо щелкнуть на кнопке "Edit" и задать запрос для вашего отчета. После этого настроить необязательные опции на оставшихся шагах и нажать "Готово".

 

Q: Как создать отчет на основе запроса?

A: Используйте Мастер Создания Отчетов, чтобы создать отчет на основе запроса. Для этого вам нужно нажать в панели инструментов Создать -> Отчет, затем нужно выбрать Master Data band на втором шаге мастера, дважды щелкнуть на нем, либо щелкнуть на Edit кнопке и задать запрос для вашего отчета. После этого настроить необязательные опции на оставшихся шагах и нажать Готово.

 

Q: Могу ли я сохранить полученный отчет в HTML, EXCEL, WORD?

A: Откройте отчет для просмотра, дважды кликнув на нем мышкой в Проводнике баз данных, затем выберите "Save report as" в панели навигации или инструментов и выберите тип сохраняемого файла в поле "Save as type".

Наверх

 

Управление данными

 

Q: В чем отличие между функциями экспорта/импорта STUDIO и одноименными функциями SQL Manager for Oracle?

A: Инструменты для экспорта/импорта, входящие в состав STUDIO, обладают большими возможностями по сравнению с одноименными функциями SQL Manager for Oracle.
  • Экспорт/импорт данных из/в таблицы разных баз данных одного хоста.
  • Экспорт/импорт данных из/в таблицы разных баз данных разных хостов.
  • Наличие консольной утилиты, позволяющей, например, выполнять операции экспорта/импорта в автоматическом режиме с помощью Планировщика STUDIO.
  • Использование общего репозитория зарегистрированных баз данных.

 

Q: Мне необходимо импортировать данные из CSV-файла. Как я могу сделать это с помощью STUDIO?

A: Для этого необходимо воспользоваться Мастером импорта. Он поможет установить все необходимые параметры для операции импорта. Более того, вы можете сохранить эти настройки для импорта в качестве шаблона и использовать их в будущем. Кроме CSV-файла вы можете выполнить импорт из MS Excel, MS Access, DBF, XML, TXT и других форматов.

 

Q: Как изменить директорию, в которой будут сохранены экспортированные данные?

A: Чтобы изменить директорию, вам необходимо выполнить следующие шаги:

  • Выберите базу данных в Проводнике и щелкните на ней правой кнопкой мыши, затем в появившемся меню выберете "Информация о регистрации" (вы также можете найти этот пункт в главном меню "База данных"). Откроется окно со свойствами базы данных.
  • Нажмите на закладку "Каталоги".
  • В секции "Каталог по умолчанию для экспортируемых данных" вы можете выбрать директорию по умолчанию для экспортируемого файла.

 

Q: Для чего в состав STUDIO входят консольные версии утилит манипулирования данными?

A: Основное назначение консольных версий инструментов STUDIO - это выполнение некоторых сервисных операций с базой данных без непосредственного участия пользователя. Все консольные инструменты поддерживают конфигурационные файлы (шаблоны), созданные в их одноименных GUI-версиях. Файл шаблона содержит все необходимую информацию для работы консольной версии инструмента. Имея консольную версию инструмента и шаблон, вы можете создать в Планировщике STUDIO задачу с необходимым временем выполнения и/или периодичностью. Конечно, вы можете использовать консольные версии инструментов STUDIO и в собственных приложениях автоматизации.

 

Q: У меня есть база данных в MS Access. Мне необходимо мигрировать ее на удаленный сервер Oracle. Как это сделать с помощью STUDIO?

A: Вы можете использовать Data Pump for Oracle для этой цели. Для запуска Data Pump из STUDIO выберите закладку "Управление данными" и кликните на Data Pump for Oracle, или выберите Пуск->Программы->EMS->SQL Studio for Oracle->Data Pump for Oracle. Мы рекомендуем вам использовать провайдер Microsoft Jet 4.0 OLE DB для соединения с вашей базой данных MS Access.

 

Q: У меня есть источник данных ODBC. Могу ли я мигрировать из него в Oracle?

A: ODBC (Open DataBase Connectivity) — это открытый, стандартный интерфейс доступа к базам данных, разработанный фирмой Microsoft. Абсолютное большинство систем управления базами данных имеют собственный, либо разработанный сторонними производителями программного обеспечения ODBC драйвер.

 Для миграции из ODBC источника данных вам нужно использовать Data Pump for Oracle. Для запуска Data Pump из STUDIO выберите закладку Манипулирование данными и кликните на Data Pump for Oracle, или выберите Пуск->Программы->EMS->SQL Studio for Oracle->Data Pump for Oracle. В утилите вы должны использовать OLE DB провайдер для ODBC драйверов для соединения c вашим источником данных ODBC.

 

Q: Из каких баз данных я могу мигрировать в Oracle, используя STUDIO?

A: С помощью утилиты Data Pump for Oracle вы можете мигрировать из любых баз данных, к которым вы можете подсоединиться, используя OLE DB провайдер (например, SQL Server, Oracle, MS Access, DB2 и др.), а также ODBC драйвер (MySQL, PostgreSQL, Interbase, Firebird, dbase файлы и др.).

 

Q: Я только разрабатываю приложение. Структура базы данных уже создана. Как STUDIO может помочь в заполнении базы данных тестовыми данными?

A: STUDIO обладает мощным инструментом для генерации тестовых данных - Data Generator for Oracle. Используя имеющийся мастер, вы можете настраивать такие параметры генерации, как количество генерируемых строк, диапазон значений для каждого поля, доля строк со значением NULL и др. Data Generator реализует случайную, инкрементную, по заданному списку значений генерацию данных и другие алгоритмы. Естественно, что все это обилие настроек STUDIO может сохранить как шаблон для будущего использования.

 

Q: Моя база содержит много связей между таблицами и других ограничений. Будет ли STUDIO учитывать это при генерации тестовых данных?

A: Да, конечно. При генерации тестовых данных STUDIO учитывает все связи и ограничения, уже имеющиеся в базе данных.

 

Наверх

 

Анализ данных

 

Q: Мне необходимо найти различия в метаданных в двух базах данных и затем их синхронизировать. Как STUDIO может помочь это сделать?

A: Для этой цели STUDIO имеет инстумент Database Comparer (DB Comparer). Его интерфейс прост и понятен, но результаты работы просто впечатляют! Вам достаточно указать две базы данных, метаданные которых вы хотите сравнить, а также некоторые дополнительные параметры, такие как сравниваемые объекты БД, направление синхронизации и др. Результатом работы DB Comparer будет перечень найденных различий в метаданных этих двух БД и скрипт, с помощью которого вы можете синхронизировать одну базу с другой. Причем вы можете синхронизировать каждое отличие отдельно от всех остальных, применяя только необходимые изменения в нужном вам порядке.

 

Q: Мне необходимо найти различия в данных между существующей базой данных и ее вчерашней резервной копией. Каковы мои действия?

A: Для этой операции вам необходимо запустить мастер Data Comparer и в качестве исходной базы данных указать существующую рабочую базу, а в качестве целевой базы данных указать вчерашнюю резервную копию базы данных (ее необходимо предварительно восстановить на любом доступном Oracle сервере). Затем указать, данные в каких таблицах вы хотите сравнить. Далее следуйте по шагам мастера. Помните, что Data Comparer позволяет сравнивать данные в таблицах с неидентичными метаданными. После выполнения операции сравнения вы увидите список различий между вашими двумя базами данных и предложение выполнить синхронизацию данных либо от исходной базы данных к целевой, либо от целевой к исходной. Вы можете сохранить SQL-скрипт, выполняющий синхронизацию, в отдельный файл на диске и выполнить его позднее с помощью инструмента SQL скрипт (возможно, с использованием планировщика STUDIO).

 

Q: Могу ли я запустить синхронизацию метаданных или данных из командной строки?

A: Да, для этого существуют консольные версии наших утилит - DB Comparer for Oracle Console Application и Data Comparer for Oracle. Все консольные инструменты поддерживают конфигурационные файлы (шаблоны), созданные в их одноименных GUI-версиях. Файл шаблона содержит всю необходимую информацию для работы консольной версии инструмента. Имея консольную версию инструмента и шаблон, вы можете элементарно выполнять синхронизацию из командной строки, не задавая множества параметров вручную.

 

Q: Может ли STUDIO синхронизировать Oracle базу данных с базой данных других DBMS?

A: Данная возможность не поддерживается нашими утилитами, поскольку они допускают синхронизацию данных и метаданных только между серверами одного типа, т.е. Oracle c Oracle.

Наверх

 

Резервное копирование/Восстановление

 

Q: Какие возможности для создания резервной копии предоставляет STUDIO?

A: SQL Studio поддерживает несколько способов резервного копирования баз данных.
  • С помощью утилиты DB Extract for Oracle, либо Мастера извлечения базы данных в SQL Manager for Oracle. Оба этих инструмента создают резервные копии баз данных, либо заданных пользователем объектов в форме SQL-скрипта. Генерируемый скрипт может содержать управляющие SQL команды, команды создания объектов и команды вставки данных. Основными преимуществами данного метода является возможность сохранения структуры БД и данных как полностью, так и частично, а также возможность гибкой настройки. Из недостатков следует выделить значительные время и трафик, которые может потребовать резервное копирование больших баз данных. Для вызова DB Extract откройте закладку "Анализ данных" в STUDIO и выберите DB Extract for Oracle. Для вызова Мастера извлечения базы данных откройте SQL Manager for Oracle и выберите "Инструменты/Извлечение базы данных" в главном меню. Для восстановления БД из созданного таким образом скрипта вы можете просто выполнить этот скрипт на сервере Oracle. Для этой цели вы можете использовать SQL Manager for Oracle либо инструмент SQL-скрипт в SQL Manager for Oracle.
  • С помощью Data Export for Oracle либо Мастера экспортирования данных в SQL Manager for Oracle. Данный способ подходит для резервного копирования данных любого вида таблиц. Используйте его, если вы хотите сохранить только данные, без сохранения структуры. Мы рекомендуем использовать CSV формат для резервного копирования данных. Для вызова Data Export откройте закладку "Управление базами данных" в STUDIO и выберите Data Export for Oracle. Для вызова Мастера экспортирования данных из SQL Manager for Oracle откройте вашу таблицу на закладке "Данные" и выберите "Экспорт данных". Для восстановления данных из созданного таким образом файла вы можете использовать утилиту Data Import for Oracle или Мастера импортирования данных в SQL Manager for Oracle. Отличия между Data Import for Oracle и Мастером импортирования данных в SQL Manager for Oracle вы можете найти здесь.

 

Q: Можно ли резервную копию, сделанную на одном сервере, восстановить на другом сервере?

A: Существует несколько случаев:

 1) Резервную копию, созданную с помощью Мастера резервного копирования, можно восстановить на любом сервере, имеющем версию равную либо выше версии сервера, на котором была сделана резервная копия.

 2) Резервную копию, созданную с помощью утилиты DB Extract for Oracle, либо Мастера извлечения базы данных в SQL Manager for Oracle можно восстановить на любом сервере, имеющем версию равную либо выше версии сервера, на котором была сделана резервная копия.

 3) Данные, сохраненные с помощью утилиты Data Export for Oracle или Мастера сохранения данных в SQL Manager for Oracle, можно восстановить в таблицу на сервере Oracle любой версии.

 

Q: Чем отличается функции извлечения базы данных и создания резервной копии в STUDIO?

A:Мастер резервного копирования копирует все объекты выбранной базы данных, а также опционально содержимое таблиц выбранной базы в файл резервной копии по указанному пути, который может быть только локальной директорией на сервере. DB Extract for Oracle, либо Мастер извлечения баз данных в SQL Manager for Oracle создают резервные копии баз данных, либо заданных пользователем объектов в форме SQL-скрипта. Генерируемый скрипт может содержать управляющие SQL команды, команды создания объектов и команды вставки данных. Таким образом, Мастер резервного копирования использует возможности сервера Oracle для выполнения резервного копирования и отличается высокой скоростью, надежностью, но не может поместить файлы резервных копий в произвольную папку на клиенте. Этот метод подходит для полного резервного копирования баз данных. Основными преимуществами резервного копирования с помощью утилиты DB Extract for Oracle являются возможность сохранения структуры БД и данных как полностью, так и частично, а также возможность гибкой настройки. Из недостатков следует выделить значительные время и трафик, которые может потребовать резервное копирование больших баз данных.

Наверх

 

Управление шаблонами

 

Q: Что такое шаблоны, используемые, например, в функциях импорта/экспорта? Для чего они нужны?

A: Шаблоны в STUDIO предназначены для хранения параметров, необходимых для выполнения того или иного инструмента STUDIO. Благодаря шаблонам вы можете многократно выполнять одну и ту же операцию с помощью инструмента STUDIO без необходимости каждый раз вводить в мастере по 10-20 необходимых параметров. Хранимые в шаблоне параметры можно легко изменить или создать новый шаблон на основе существующего.

 

Q: Где хранятся шаблоны STUDIO?

A: Шаблон представляет из себя файл, в котором в определенном формате хранятся необходимые параметры. Файлы шаблонов могут располагаться в любом месте на диске компьютера, главное, что бы вы помнили, где они находятся :). Для облегчения задачи по хранению и поиску шаблонов STUDIO имеет менеджера шаблонов. Он позволяет вам зарегистрировать необходимые шаблоны в STUDIO и больше не задумываться о том, куда же вы сохранили нужный шаблон. Если вы создаете новый шаблон в студии, то менеджер шаблонов автоматически запомнит его месторасположение на диске. Все зарегистрированные шаблоны будут сгруппированы по инструментам, для которых они предназначены, и доступны вам в любой момент. Для запуска инструмента с выбранным шаблоном будет достаточно просто сделать двойной клик на шаблоне.

 

Q: Удаление шаблона из списка в STUDIO приводит к удалению шаблона с диска?

A: Менеджер шаблонов позволяет вам выполнить оба действия: просто удалить шаблон из списка зарегистрированных шаблонов либо, дополнительно, удалить и сам файл шаблона с диска компьютера.

 

Q: Как я могу создать новый шаблон для Импорта?

A: Для создания шаблона для инструмента Импорта вы можете запустить инструмент Импорта ("Запуск/Data Import" в главном меню). Затем, используя кнопку NEXT, заполнить все необходимые параметры для импорта. По достижении последнего шага мастера, используя кнопку "Настройки/Сохранить шаблон", указать, куда и с каким именем вы хотите сохранить только что созданный шаблон.

Наверх

 

Планировщик

 

Q: Мне необходимо выполнить ряд функций по обслуживанию базы данных (экспорт из одной базы данных, импорт этих данных в другую базу данных, резервное копирование обоих баз данных) во внерабочее время (ночью). STUDIO имеет решение для этого?

A: Да, конечно. Именно для таких ситуаций и предназначен Планировщик STUDIO. Планировщик может запускать на выполнение предварительно созданные вами Задачи. Вы можете настроить время запуска Задачи и периодичность ее запуска. Каждая Задача может состоять из неограниченного количества Шагов (элементарных действий). Задача должна состоять как минимум из одного шага. В вашем случае следует выполнить следующее:

 1. Создать новую Задачу

 2. Создать в этой Задаче 4 шага (Экспорт, Импорт, Резервное копирование, Резервное копирование). При создании этих шагов вам будет необходимо указать, в каких файлах шаблонов хранятся необходимые для работы инструментов параметры.

 3. Создать в Планировщике Запланированную Задачу, использующую только что созданную (п.1) Задачу.

 

Q: Как настроить задачу, чтобы при неудачном ее выполнении я получал e-mail на указанный адрес?

A: В окне редактирования Задачи есть закладка "Уведомления". Переключившись на нее, вы можете указать наиболее подходящий вам способ уведомления как об успехе выполнения Задачи, так и о неудачном ее завершении. В текущей версии STUDIO поддерживаются следующие виды уведомлений: NetSend, системный журнал приложений, электронная почта.

 

Q: Может ли ход выполнения задачи меняться в зависимости от результатов выполнения ее шагов?

A: Да. При создании/редактировании каждого Шага Задачи вы можете определять, какой шаг должен выполняться далее. Причем для каждого из трех обрабатываемых событий (успешное выполнение шага, выполнение шага с ошибкой, завершение шага по таймауту) можно указать свой вариант продолжения работы Задачи.

 

Q: Как я могу посмотреть информацию о выполненных задачах?

A: Вся информация о запуске Задач фиксируется в журнале. Вам будет доступна информация не только о выполнении Задачи, но и входящих в нее Шагов. Более того, вы сможете посмотреть журнал приложения, выполненного в конкретном шаге. Это очень удобно при анализе причин неудачного завершения Задачи/Шага. Мощные фильтры журнала позволят отобразить только интересующие вас записи.

 

Q: Что произойдет, если в процессе выполнения задачи вызванное приложение не может завершиться (критическая ошибка, задача не отвечает)? Выполнение задачи остановится?

A: Для разрешения таких конфликтов в каждом Шаге Задачи вы можете определить его таймаут. Если Шаг выполняется дольше, чем указано в его таймауте, то Шаг завершается с событием "По таймауту" и выполнение задачи продолжается в соответствии с заложенным вами алгоритмом.

 

Q: Что необходимо для работы Планировщика?

A: Для работы Планировщика необходимо, чтобы был запущен агент студии (иконка в панели задач). И конечно, компьютер должен оставаться включенным все время, в течение которого должны запускаться задачи.

 

Q: Что произойдет, если после включения компьютера планировщик обнаружит задачи, которые должны были быть выполнены в прошлом, но не были выполнены?

A: Эти задачи выполнены не будут.

Наверх

 

Управление журналами

 

Q: Для меня важна информация из журналов приложений, выполняемых планировщиком. STUDIO сохраняет эти журналы?

A: Да. STUDIO обладает удобным инструментом для работы с журналами. При создании любого Шага в Задаче вы можете указать месторасположение журнала выполняемой утилиты. При выборе инструментов, входящих в STUDIO, расположение журнала заполняется автоматически. Журналы выполненных шагов сохраняются во внутренней базе данных STUDIO и доступны вам через меню "Навигация/Журналы".

 

Q: Внешнее приложение, которое выполняется в одной из задач, не имеет журнала – только экранный вывод. Как мне сохранить выводимые на экран данные?

A: Если выполняемая утилита не имеет журнала, а выводит что-либо на экран (в текстовом режиме, а не в GUI), то STUDIO может сохранить этот экранный вывод в качестве журнала. Для этого при создании задачи поставьте галочку "Внести в журнал рабочий экран".

 

Q: Как долго хранятся журналы в STUDIO?

A: Журналы хранятся в STUDIO неограниченное время. Удалить ненужные журналы вы можете вручную с помощью STUDIO (закладка "Журналы").

Наверх

 

Локализация

 

Q: Какие локализации интерфейса доступы для STUDIO?

A: В настоящей версии оболочка STUDIO поддерживает следующие локализации: английскую, немецкую, русскую, французскую.

Наверх

 

 

Если у Вас все еще есть вопросы, обратитесь в Службу поддержки.