EMS logo

Навигация по продуктам

DB Comparer for MySQL

Наш партнерский статус

Microsoft Certified Partner
Oracle Certified Partner
Embarcadero Technology Partner

EMS DB Comparer for MySQL

Он-лайн Документация

Дизайнер отчетов


Дизайнер отчетов позволяет создавать и редактировать отчеты. Он запускается при создании нового отчета в окне Reports или при открытии существующего.

 

Для Вашего удобства на панели Reports находятся несколько макетов отчетов.

 

Данный инструмент, предоставленный FastReport (http://www.fast-report.com), имеет собственную справочную систему, которую можно вызвать, нажав F1 в окне дизайнера отчетов.

 

Как создать простой отчет с помощью дизайнера отчетов:

 

 

Добавление раздела

 

 

Чтобы добавить раздел в отчет:

  • перейдите на вкладку Page 1 дизайнера отчетов;
  • выберите требуемый компонент из списка btnFastReport_InsertBand Insert Band (панель инструментов в левой части окна);
  • перейдите на рабочую область дизайнера отчетов;
  • измените свойства объекта с помощью Properties Inspector, если необходимо.

 

Важно: Панель Properties Inspector может быть вызвана/скрыта нажатием клавиши F11.

 

 

Report Designer - Adding bands

 

 

Добавление данных

 

Чтобы добавить данные в отчет:

  • перейдите на вкладку Data дизайнера отчетов;
  • выберите элемент(ы) дерева btnFastReport_Data Data tree и переместите его (их) на рабочую область;

 

Report Designer - Adding report data

 

 

Просмотр отчета

 

Предварительный просмотр отчета можно осуществить с помощью пункта главного меню Project | Preview или кнопки btnPrintPreview Preview, расположенной на панели инструментов. Также можно воспользоваться сочетанием клавиш Ctrl+P. В этом режиме возможен просмотр отчета, редактирование и печать.

 

Если необходимо напечатать отчет, нажмите кнопку btnPrint Print, расположенную на панели инструментов.

 

Report Designer - Preview

 

 

Сохранение отчета

 

После того как необходимые изменения были внесены, отчет можно сохранить во внешний файл *.fr3, как на локальном компьютере, так и в сети.

 

Чтобы сохранить отчет, Выберите пункт главного меню Project | Save или воспользуйтесь кнопкой btnSave Save report, расположенной на панели инструментов. Также можно использовать сочетание клавиш Ctrl+S.